Getting Started

AgInfiniiVision IVI Driver Reference |
Getting Started | Keysight Technologies

Welcome to the AgInfiniiVision version 2.5.8.0 IVI driver. Keysight's IVI drivers simplify the creation and maintenance of instrument control applications in a variety of development environments. IVI drivers allow you to programmatically control your instrumentation while providing a greater degree of instrument interchangeability and code reuse. This driver supports compiling application programs for 32 or 64 bit platforms.

Programming with the AgInfiniiVision Driver

Basics of programming this driver including example code. How to: Reference the Driver, Create an Instance of the Driver, Initialize the Driver, and Access Items of Various Data Types

    Programming with the IVI-COM Driver - Using the IVI-COM driver in the following application development environments: Visual C#, Visual C++, Visual Basic.NET, Visual Basic 6, Keysight VEE Pro, LabVIEW, MATLAB

    Programming with the IVI-C Driver - Using the IVI-C driver in the following application development environments: Visual C++, LabWindow/CVI, LabVIEW

    Example Programs - You may build and run the example programs installed with the driver. They demonstrate basic driver usage in a variety of application development environments. Examples may be accessed from the Windows Start Menu shortcut under:
    All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision

AgInfiniiVision Driver Reference

    IVI-COM Driver Reference - Documentation for each IVI-COM method, property, and error code.

    IVI-C Driver Reference - Documentation for each IVI-C function, attribute, and error code.

IVI Overview

General, information on IVI features common to all IVI drivers as well as compliance and installation information.

    IVI Compliance Information - IVI-required compliance information for the AgInfiniiVision driver.

    IVI Backgrounder - An overview of IVI topics and concepts for driver developers including introductory information on the IVI Foundation standards and specifications.

Web Sites

  • Keysight Technologies Home Page
    • IVI Drivers & Components Downloads
    • Keysight I/O Libraries Suite
    • GPIB, USB, & Instrument Control Products
    • Keysight VEE Pro
    • Technical Support, Manuals, & Downloads
    • Contact Keysight Test & Measurement
  • IVI Foundation - Usage Guides, Specifications, Shared Components Downloads
  • MSDN Online
Copyright Keysight Technologies 2011-2019 1.15


IVI Compliance Information

AgInfiniiVision IVI Driver Reference Keysight Technologies
IVI Compliance Information

This page provides IVI-required compliance information for the AgInfiniiVision driver.

Driver Identification

This section provides IVI-required identity information for the AgInfiniiVision driver.

Identification Category | Description
Driver Revision | 2.5.8.0
Driver Vendor | Agilent Technologies
Driver Description | IVI driver for the Keysight 1000X, 2000X, 3000X, 4000X, 6000X, C7300, M924x and P924x Oscilloscope families.
Prefix/Component Identifier | AgInfiniiVision
Supported Models | DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, DSO-X 3014A, DSO-X 3024A, DSO-X 3032A, DSO-X 3034A, DSO-X 3052A, DSO-X 3054A, MSO-X 3012A, MSO-X 3014A, MSO-X 3024A, MSO-X 3032A, MSO-X 3034A, MSO-X 3052A, MSO-X 3054A, DSO-X 3012A, MSO-X 3102A, MSO-X 3104A, DSO-X 3102A, DSO-X 3104A, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, DSO-X 3052T, DSO-X 4022A, DSO-X 4032A, DSO-X 4052A, DSO-X 4024A, DSO-X 4034A, DSO-X 4054A, DSO-X 4154A, MSO-X 4022A, MSO-X 4032A, MSO-X 4052A, MSO-X 4054A, MSO-X 4024A, MSO-X 4034A, MSO-X 4104A, MSO-X 4154A, DSO-X 4104A, MSO-X 6002A, MSO-X 6004A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, EDU-X 1002A, EDU-X 1002G, DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, P9241A, P9242A, P9243A, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, C7302, C7302C, C7304, C7304C

Compliance Category

IVI drivers come in a variety of types and configurations. This section provides IVI-required compliance information on the various categories of IVI compliance for the AgInfiniiVision driver.

Compliance Category | Compliance Information
IVI Generation | IVI-2014
Category Name | IVI-COM/C IviScope Specific Instrument Driver
Class Specification Version | IviScope 4.1

Class Capability Groups

In addition to the IVI Inherent Capabilities required of all IVI instrument drivers, the AgInfiniiVision driver supports the IviScope instrument class.

The following table lists each of the capability Extension Groups for the IviScope instrument class and indicates whether the group is supported by the AgInfiniiVision driver.

Capability Name | Supported | Description
IviScopeAcLineTrigger | Yes | IviScope with the ability to trigger on zero crossings of a network supply voltage.
IviScopeAutoSetup | Yes | IviScope with the automatic configuration ability.
IviScopeAverageAcquisition | Yes | IviScope with the ability to create a waveform that is the average of multiple waveform acquisitions.
IviScopeBase | Yes | This group includes the capability to acquire waveforms using edge triggering.
IviScopeContinuousAcquisition | Yes | IviScope with the ability to continuously acquire data from the input and display it on the screen.
IviScopeGlitchTrigger | Yes | IviScope with the ability to trigger on glitches.
IviScopeInterpolation | Yes | IviScope with the ability to configure the oscilloscope to interpolate missing points in a waveform.
IviScopeMinMaxWaveform | Yes | IviScope with the ability to acquire a minimum and maximum waveforms that correspond to the same time range.
IviScopeProbeAutoSense | Yes | IviScope with the ability to automatically sense the probe attenuation of an attached probe.
IviScopeRuntTrigger | Yes | IviScope with the ability to trigger on runts.
IviScopeSampleMode | Yes | IviScope with the ability to return the actual sample mode.
IviScopeTriggerModifier | Yes | IviScope with the ability to modify the behavior of the triggering subsystem in the absence of a expected trigger.
IviScopeTVTrigger | Yes | IviScope with the ability to trigger on standard television signals.
IviScopeWaveformMeas | Yes | IviScope with the ability to calculate waveform measurements, such as rise time or frequency.
IviScopeWidthTrigger | Yes | IviScope with the ability to trigger on a variety of conditions regarding pulse widths.

Optional Features

This section provides IVI-required information regarding optional IVI driver features supported by the AgInfiniiVision driver.

Feature | Supported
Interchangeability checking | No
State caching | No
Coercion recording | Yes

Additional Compliance Information

Additional IVI compliance information for this driver may be found in the driver Readme and Introduction files available from the Windows Start Menu shortcut under: All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision

Copyright Keysight Technologies 2011-2019


AgInfiniiVision IVI-COM Driver

AgInfiniiVision IVI-COM Driver

The AgInfiniiVision driver includes a fully compliant IVI-COM driver. The topics in this section detail how to perform specific programming tasks using the IVI-COM interfaces available with the AgInfiniiVision driver.

In This Section

Initializing the IVI-COM Driver

Presents the steps required to properly initialize the IVI-COM driver.

Accessing Instrument-Specific Functionality

Explains how to access the specialized functionality of the AgInfiniiVision driver.

Using Simulation

Provides information on using the simulation capabilities of the driver.

Programming with the IVI-COM Driver in Various Development Environment

Demonstrates how the AgInfiniiVision driver can be used in a various application development environments (ADEs).

Reference

Presents reference documentation for each IVI-COM method and property.


Initializing the IVI-COM Driver

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Initializing the IVI-COM Driver

Initializing the IVI-COM driver proceeds in two steps. First, the IVI-COM driver must be instantiated and then the Initialize method is called. This topic explains these two steps along with the options available for each step.

Instantiating the IVI-COM Driver

There are two ways to instantiate the IVI-COM driver -- direct instantiation using the specific driver name, and using the COM Session Factory. If the client application is to be interchangeable, then the COM Session Factory must be used and the driver must support an IVI instrument class. This driver supports IviScope. This component exposes a CreateDriver function that accepts a logical name for the driver. Instantiating the driver by name keeps the client program from having any dependencies on a specific driver and enables the application to be interchangeable but limited to the functionality of the IVI class. For more information, see the topic: How IVI Drivers Provide Interchangeability

If interchangeability is not necessary for a particular client application or the driver does not support an IVI instrument class, then you may instantiate the IVI-COM driver directly. The exact syntax for creating an instance of a COM component varies from language to language. For instance, the CreateInstance function can be used in C++ while the new operator is used in C# and Visual Basic.NET. In any event, the client application will have a direct reference to the specific driver, so the program would not be interchangeable. For many applications, this is perfectly acceptable and exposes the full functionality of the driver.

The examples below in the section describing the Initialize function will present both techniques for instantiating an IVI-COM driver.

Calling the Initialize Function

The IVI-defined Initialize method offers a variety of options and parameters that control fundamental aspects of the driver's behavior. It is critical to understand what options are available and how they impact driver operation.

ResourceName

The ResourceName parameter can be a logical name present in the IVI Configuration Store or a physical resource descriptor. If the ResourceName is a logical name, then additional options stored in the IVI Configuration Store will be loaded and processed. This allows client code to reuse driver option settings and to keep the driver code as concise as possible, by removing settings that can be stored in the IVI Configuration Store. It is important to note that any parameters or options passed directly to the Initialize function via the OptionString parameter (discussed below) override any settings found in the IVI Configuration Store.

Interface Physical Resource Descriptor Syntax
GPIB GPIB[board]::primary address[::secondary address][::INSTR]
Example: GPIB0::18::INSTR
ASRL ASRL[board][::INSTR]
Example: ASRL1::INSTR
TCPIP TCPIP[board]::host address[::LAN device name]::INSTR
Example: TCPIP0::127.0.0.1::INSTR
TCPIP TCPIP[board]::host address::port::SOCKET
Example: TCPIP0::127.0.0.1::5025::SOCKET
USB USB[board]::manufacturer ID::model code::serial number[::USB interface number][::INSTR]
Example: USB0::2391::291::SN_001001::INSTR
PXI PXI[bus]::device[::function][::INSTR]
Example: PXI1::5::INSTR
PXI PXI0::CHASSISchassis::SLOTslot[::FUNCfunction][::INSTR]
PXI0::bus-device[.function][::INSTR]

IdQuery

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that is supported by the driver. If the model is not supported, Initialize will fail with the E_IVI_ID_QUERY_FAILED error code.

Reset

If this is enabled, the driver will perform a reset of the instrument. If the reset fails, Initialize will fail with the E_IVI_RESET_FAILED error code.

OptionString

The OptionString allows the user to pass optional settings to the driver. These settings override any settings that are specified in the IVI Configuration Store. If the IVI Configuration Store is not used (a resource descriptor is passed as the ResourceName instead of a logical name) then any setting that is not specified has a default value as specified by IVI.

Option Name | Description | Default
QueryInstrStatus | Specifies whether the IVI specific driver queries the instrument status at the end of each user operation. Querying the instrument status is very useful for debugging. After validating the program, the user can set this attribute to False to disable status checking and maximize performance. The user specifies this value for the entire IVI driver session. | false
Simulate | Specifies whether or not the IVI specific driver simulates instrument driver I/O operations. If simulation is enabled, the specific driver functions do not perform instrument I/O. For output parameters that represent instrument data, the specific driver functions return simulated values. | false
Cache | Specifies whether or not to cache the value of attributes. When caching is enabled, the IVI specific driver keeps track of the current instrument settings so that it can avoid sending redundant commands to the instrument. | true
InterchangeCheck | Specifies whether the IVI specific driver performs interchangeability checking. If the Interchange Check attribute is enabled, the specific driver maintains a record of each interchangeability warning that it encounters. The user calls the Get Next Interchange Warning function to extract and delete the oldest interchangeability warning from the list. | false
RangeCheck | Specifies whether the IVI specific driver validates attribute values and function parameters. If enabled, the specific driver validates the parameter values that users pass to driver functions. Validating attribute values and function parameters is useful for debugging. After validating the program, the user can set this attribute to False to disable range checking and maximize performance. | true
RecordCoercions | Specifies whether the IVI specific driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the Record Value Coercions attribute is enabled, the specific driver maintains a record of each coercion. The user calls the Get Next Coercion Record function to extract and delete the oldest coercion record from the list. | false
DriverSetup | Specifies additional settings supported by the driver, but not defined by IVI. | ""

DriverSetup

This is used to specify settings that are supported by the driver but not defined by IVI. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following 'DriverSetup=' is part of the assignment. The following settings are supported by the AgInfiniiVision driver.

Option Name | Description | Default
Model | Instrument model to use during simulation. Must be one of the supported model strings as returned by the IviDriver.Identity.SupportedInstrumentModels property. | (default_model)
Trace | If true, output trace log of all driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option. The log file may be viewed in your web browser. Beginning with Keysight IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details. | false
TraceName | If specified, sets the path and file name for the XML log file output when option Trace=true. It is not necessary to include the .xml extension with the name. Example: 'DriverSetup = Trace=true, TraceName=C:\Temp\TraceOut' If not specified, tracing generates a unique XML trace file name based on the date and time. A new file is created each time the driver is initialized with tracing enabled. | ""
TraceArray | If true, array parameter data is output to the trace log. | false
TraceArraySizeMax | Specifies the maximum number of elements to trace for array parameters. Requires option 'TraceArray=true'. | 10
TraceSizeMax | Specifies the maximum size of the trace log file in bytes. Once the file reaches this size, tracing will be turned off automatically by the driver. | 1000000
TraceSaveInterval | Specifies how often the driver should save trace data to the trace log file. The value is specified in minutes. | 1

Example 1 (no range checking, no state caching) -- Instantiate with the COM Session Factory

Note: This example only applies to drivers that support an IVI instrument class. This driver supports: IviScope

The following code initializes the driver with default options, except for range checking and state caching which are turned off. Use of the COM Session Factory allows interchangability with other drivers supporting the same IVI class but limits functionality to the class.

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace
#import "IviDriverTypeLib.dll" no_namespace
#import "IviSessionFactory.dll" no_namespace

void main()
{
  try
  {
    // Create an instance of the driver using the session factory.
    // This code is interchangeable since no reference to the specific driver exists.
    IIviSessionFactory spFactory(__uuidof(IviSessionFactory));
    IIviDriverPtr spDriver = spFactory->CreateDriver(_T("MyLogicalName"));

    // Initialize the driver with no range checking and no state caching.  This will
    // also check the instrument ID to make sure it is supported and reset the instrument.
    spDriver->Initialize(_T("MyLogicalName"), VARIANT_TRUE, VARIANT_TRUE, _T("RangeCheck=false, Cache=false"));

    // Use the driver class compliant functionality...

    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {

    wprintf(e.Description(), e.ErrorMessage(), MB_ICONERROR);
  }
}

C# Copy Code Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.SessionFactory.Interop;

public class App
{
  public static void Main(string[] args)
  {
    try
    {
      // Create an instance of the driver using the session factory
      // This code is interchangeable since no reference to the specific driver exists.
      IIviSessionFactory factory = new IviSessionFactoryClass();
      IIviDriver driver = (IIviDriver)factory.CreateDriver("MyLogicalName");

      // Initialize the driver with no range checking and no state caching.  This will
      // also check the instrument ID to make sure it is supported and reset the instrument.
      driver.Initialize("MyLogicalName", true, true, "RangeCheck=false, Cache=false");

      // Use the driver class compliant functionality...

      // Close the session
      driver.Close();
    }
    catch (Exception e)
    {
      Console.WriteLine(e.Message);
    }
  }
}

Example 2 (simulation) -- Direct Driver Instantiation

The following code initializes the driver in simulation mode and specifies the model to simulate using direct instantiation. This exposes the full functionality of the AgInfiniiVision driver.

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace
#import "IviDriverTypeLib.dll" no_namespace
#import "AgInfiniiVision.dll" no_namespace

void main()
{
  try
  {
    // Instantiate the driver class directly
    IIviDriverPtr spDriver(__uuidof(AgInfiniiVision)); // not interchangeable, using driver class name

    // Initialize the driver  in simulation mode.  Resource descriptor is ignored when Simulate=true.
    // This will also check the instrument ID to make sure it is supported and reset the instrument.
    spDriver->Initialize(_T("GPIB0::13::INSTR"), VARIANT_TRUE, VARIANT_TRUE, _T("Simulate=true, DriverSetup= Model=DSO-X 2002A"));

    // Use the driver ...

    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {
    wprintf(e.Description(), e.ErrorMessage(), MB_ICONERROR);
  }
}

C# Copy Code Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Agilent.AgInfiniiVision.Interop;

public class App
{
  [STAThread]
  public static void Main(string[] args)
  {
    try
    {
      // Instantiate the driver class directly
      IIviDriver driver = new AgInfiniiVisionClass(); // not interchangeable, using driver class name

      // Initialize the driver in simulation mode.  Resource name is ignored when Simulate=true.
      // This will also check the instrument ID to make sure it is supported and reset the instrument.
      driver.Initialize("GPIB0::13::INSTR", true, true, "Simulate=true, DriverSetup= Model=DSO-X 2002A");

      // Use the driver...

      // Close the session
      driver.Close();
    }
    catch (Exception e)
    {
      Console.WriteLine(e.Message);
    }
  }
}


Writing Interchangeable Code Using the IviScope Class Interfaces

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Writing Interchangeable Code Using the IviScope Class-Compliant Interfaces

IVI class-compliant capabilities refers to functionality defined for a particular IVI instrument class. IVI drivers may or may not include class-compliant capabilities. This driver supports the IviScope class. Users that wish to write interchangeable application programs must restrict themselves to accessing only the IVI-defined (Inherent and class-compliant) interfaces on this IVI-COM driver. For more information, see the topic: How IVI Drivers Provide Interchangeability

Example Code - Using IviScope Interfaces

The following example code accesses the class-compliant interfaces, and uses the COM Session Factory for interchangeability. Since this code uses only IVI-defined interfaces, there are no references to any instrument-specific driver details. This means the code is interchangeable.

C# Copy Code Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi..Interop;
using Ivi.SessionFactory.Interop;

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Create an instance of the session factory
        IIviSessionFactory factory = new IviSessionFactoryClass();

        // Ask the session factory to create an instance of
        // the appropriate driver based on a logical name
        IIviScope iviscope = (IIviScope)factory.CreateDriver("MyLogicalName");

        // Initialize the driver using the same logical name
        iviscope.Initialize("MyLogicalName", true, true, "");

        // Use the class-compliant capabilities...
        //iviscope.Range = 10.0; // Example only

        // Close the session
        iviscope.Close();
      }
      catch (Exception e)
      {
        // Handle errors appropriately
        Console.WriteLine(e.Message);
      }
    }
  }
}

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O functionality
#import "IviDriverTypeLib.dll" no_namespace  // IVI inherent functionality
#import "IviScopeTypeLib.dll" no_namespace  // IVI Class functionality
#import "IviSessionFactory.dll" no_namespace  // COM Session Factory functionality

void main()
{
  try
  {
    // Create an instance of the session factory
    IIviSessionFactory spFactory(__uuidof(IviSessionFactory));

    // Ask the session factory to create an instance of
    // the appropriate driver based on a logical name
    IIviScopePtr spIviScope = spFactory->CreateDriver(_T("MyLogicalName"));

    // Initialize the driver using the same logical name
    spIviScope->Initialize(_T("MyLogicalName"), VARIANT_TRUE, VARIANT_TRUE, _T(""));

    // Use the class-compliant capabilities...
    //spIviScope->Range = 10.0;  // Example only

    // Close the session
    spIviScope->Close();
  }
  catch (_com_error&)
  {
    // Handle errors appropriately
    wprintf(e.Description(), e.ErrorMessage(), MB_ICONERROR);
  }
}

Visual Basic Copy Code Copy Code
Imports System
Imports System.Runtime.InteropServices
Imports Ivi.Driver.Interop
Imports Ivi..Interop
Imports Ivi.SessionFactory.Interop

Module Module1

    Sub Main()

        Try
            ' Create an instance of the session factory
            Dim factory As New IviSessionFactoryClass()

            ' Ask the session factory to create an instance of
            ' the appropriate driver based on a logical name
            Dim iviscope As IIviScope = factory.CreateDriver("MyLogicalName")

            ' Initialize the driver using the same logical name
            iviscope.Initialize("MyLogicalName", False, False, "")

            ' Use the class-compliant capabilities...
            ' iviscope.Range = 10.0  'Example only

            ' Close the session
            iviscope.Close()

        Catch err As System.Exception
            ' Handle errors appropriately
            Console.WriteLine(err.Message())
        End Try

    End Sub

End Module

For more information, see the Advanced Topics, Interchangability section of the Getting Started Guide on the IVI Foundation website.


Accessing Repeated Capabilities

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Accessing Repeated Capabilities

This page provides information on the supported repeated capabilities and repeated capability names for the AgInfiniiVision driver.

Repeated Capabilities

The AgInfiniiVision driver supports the following repeated capabilities:

  • Channel
  • Measurement
  • DigitalChannel
  • SerialBus
  • MathFunction
  • WaveGen

The following table provides detailed information on each repeated capability supported by the AgInfiniiVision driver.

For a detailed explanation of repeated capabilities, including repeated capability styles, physical names, and dynamic repeated capabilities, see the topic Repeated Capabilities.

Repeated Capability | IVI-COM Style | Dynamic | Physical Names
Channel | Collection | Yes |
Measurement | Collection | Yes |
DigitalChannel | Collection | Yes |
SerialBus | Collection | Yes |
MathFunction | Collection | Yes |
WaveGen | Collection | Yes |


Accessing Instrument-Specific Functionality

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Accessing Instrument-Specific Functionality

As the name implies, the instrument-specific capabilities are those methods and properties that are unique to the instrument. In practice, the instrument-specific portion of the driver exposes the full functionality of the instrument -- including functionality that may also be available in the class-compliant capabilities. Users that do not care about interchangeability or that need to access functionality that is not defined by IVI will use the instrument-specific interfaces in application programs.

When to use the instrument specific interfaces

  • When the required functionality is not exposed in the class-compliant interfaces.
  • When interchangeability is not a requirement.
  • When performance is critical. Sometimes a driver may perform better using the instrument specific interfaces because they match the instrument functionality more closely than the class-compliant interfaces.

Example

The following client code uses the instrument specific interfaces.

C++ Copy Code Copy Code
#import "IviDriverTypeLib.dll" no_namespace
#import "AgInfiniiVision.dll" no_namespace
void main()
{
  try
  {
    // Instantiate the driver class directly
    IAgInfiniiVisionPtr spDriver(__uuidof(AgInfiniiVision));

    // Initialize the driver
    spDriver->Initialize(_T("GPIB0::13::INSTR"), VARIANT_TRUE, VARIANT_TRUE, _T(""));

    // Use instrument specific interfaces...
    spDriver->Output->Enabled = VARIANT_TRUE;
    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {
  }
}
C# Copy Code Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Agilent.AgInfiniiVision.Interop;
namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Instantiate the driver class directly
        IAgInfiniiVision driver = new AgInfiniiVisionClass();
        // Initialize the driver
        driver.Initialize("GPIB0::13::INSTR", true, true, "");

        // Use instrument specific interfaces...
        driver.Output.Enabled = true;
        // Close the session
        driver.Close();
      }
      catch (Exception e)
      {
        Console.WriteLine(e.Message);
      }
    }
  }
}


Using Simulation

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Using Simulation

An IVI driver can operate without the presence of an actual instrument by using simulation mode. When simulation is turned on, the driver performs no instrument communication, but attempts to generate results which allow client applications to reasonably execute. You can turn on simulation using either of the following two techniques:

  • Passing the "simulate=true" option string parameter to the Initialize method.
  • Setting the Simulate property to True.

The IVI-COM driver contains a Simulate property in the IIviDriverOperation interface. The IVI-C driver contains a corresponding Simulate attribute. Note that if you initialize an IVI-COM driver with simulation turned off you can later turn the simulation on. However, if you initialize an IVI-COM driver with simulation turned on, you will get an error (The simulation state cannot be changed) if you attempt to later turn it off. This is because you cannot initiate a live I/O session with an instrument after you have called the Initialize function.

Using The Option String

The fourth and last parameter to the Initialize method is the option string. See the help on Initialize for more details. To turn simulation on with the option string, include the following in the option string:

simulate=true

For example, the Initialize call in C# might look like this:

instr.Initialize("GPIB0::13::INSTR", true, true, "Simulate=True");

When the simulate option is set True, the value of the resource descriptor parameter (the first parameter above) is ignored. This is because no I/O connection will be made with the instrument, as is required by IVI-3.1: Driver Architecture Specification.

The Driver Session Simulate Property

A DriverSession in the IVI Configuration Store contains properties for the same items which can be set with the option string parameter. The name of a DriverSession, or the name of a LogicalName which points to a DriverSession, can be used as the first parameter to Initialize. If the Simulate property in the DriverSession is true, the driver is initialized in simulation mode.

Changing the Instrument Model

Many drivers support more than one instrument model. These models are listed in the SupportedInstrumentModels property in the IIviDriverIdentity interface. Drivers will typically select one of these as the default model by creating a special type of entry in the IVI Configuration Store known as a Configurable Initial Settings. You can modify the Model value in the Configurable Initial Settings for the DriverSession of interest, or you can simply specify the model to simulate at runtime during the call to Initialize.

To have the driver simulate a specific model of your choosing, simply add the desired model to the DriverSetup string using the following special syntax:

Simulate=true, DriverSetup=Model=DSO-X 2002A

The complete Initialize call becomes:

instr.Initialize("GPIB0::13::INSTR", True, True, "Simulate=True, DriverSetup= Model=DSO-X 2002A")

If you set the model to a value not supported by the driver, the driver reports an error.

Limitations of Simulation

Simulation is designed to allow the driver to be used without an instrument or any I/O software or hardware. However, simulation is not intended to fully emulate the instrument. There are some important differences you should be aware of:

  • Many instruments have status systems, and these are not live. For instance, you can set Enable and Transition registers but queries of Condition and Event registers will always return a fixed value, which is usually zero.
  • There often is no parameter range checking or coercion unless done in the driver. Most drivers depend on the instrument to perform range checking and coercion of parameter values. In simulation mode, this will not occur. For example setting a frequency parameter to 1E99 will be accepted without error in simulation where an instrument would return a "parameter out of range" error.
  • IIviDriverUtility::ErrorQuery() typically returns no error.
  • Measurement data is not live. Most data queries will return a fixed value or a small array of values.


Programming the IVI-COM Driver in Various Development Environments

Programming with the IVI-COM Driver in Various Development Environments

IVI-COM drivers are implemented using standard COM technology. Specifically, IVI-COM drivers support what are known as custom COM interfaces. To ensure compatibility with the broadest possible set of development environments, the IVI specifications restrict data types that can be used in an IVI-COM driver to a special set called oleautomation data types (also known simply as automation data types. Automation types were originally designed for Visual Basic but have since gained broad acceptance. Consequently, IVI-COM drivers can be used in a wide variety of development environments, namely, those that support custom oleautomation COM interfaces.

IVI-COM Drivers and .NET

Interop assemblies are used in .NET environments, such as C# and VB.NET, to access COM components. When installing an IVI-COM driver on a computer with the .NET Framework, the IVI specifications require an interop assembly be deployed and properly registered. The full path to the interop assembly for the AgInfiniiVision driver is:

<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgInfiniiVision.Interop.dll

The topics in this section provide detailed instructions on how to access and use IVI-COM drivers in a variety of popular development environments. Each topic includes a complete example of IVI-COM driver usage.

In This Section

Using C#

Provides instructions on using interop assemblies to access IVI-COM drivers.

Using Visual Basic.NET

Describes the process for importing interop assemblies into Visual Basic.NET and invoking methods and properties.

Using Visual C++

Explains how to import IVI-COM driver type libraries into C++ and use smart pointers to access methods and properties.

Using Visual Basic 6

Explains how to use IVI-COM drivers with pre-.NET Visual Basic.

Using Keysight VEE Pro

Presents information on using the driver with Keysight VEE Pro.

Using LabVIEW

Provides an introduction to LabVIEW's special support of IVI-COM.

Using MATLAB

Presents information on using the driver with MATLAB.

Using Simulation

Presents information on using the simulation capabilities of the driver.


Using Visual C#

Using Visual C#

This section describes how to use the AgInfiniiVision IVI-COM driver from Visual C#. The driver includes a .NET Interop assembly for using the driver in .NET environments such as C#.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver interop DLL and at least one of the IVI interop DLLs (specifically, Ivi.Driver.Interop.dll) must be created.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the Browse tab and select folder: <IviInstallDir>\Bin\Primary Interop Assemblies\
    Where <IviInstallDir> default location is: C:\Program Files\IVI Foundation\IVI\
  3. Select the following interop assemblies:
    • Ivi.Driver.Interop.dll
    • Agilent.AgInfiniiVision.Interop.dll
    • If needed for interchangability, IviScope.Interop.dll
  4. Click the OK button to add the assembly references.
  5. Each of the above interop assemblies should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the C# using statement allows the type name to be used directly.

C# Copy Code Copy Code
using Ivi.Driver.Interop;
using Agilent.AgInfiniiVision.Interop;

Creating an Instance of the Driver

The driver can be instantiated by simply using the new operator directly on the driver class.

C# Copy Code Copy Code
AgInfiniiVision driver = new AgInfiniiVision();

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close at the end of your program is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C# Copy Code Copy Code
driver.Initialize("GPIB0::13::INSTR", false, false, "");
driver.Close();

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see the topic: Initializing the Driver

C# Copy Code Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
bool idQuery = false;

// If true, the instrument is reset at initialization
bool reset = false;

// Setup IVI-defined initialization options
string standardInitOptions =
  "Cache=false, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=false, RecordCoercions=false, Simulate=false";

// Setup driver-specific initialization options
string driverSetupOptions =
  "DriverSetup= Model=DSO-X 2002A, Trace=false";

driver.Initialize("GPIB0::13::INSTR", idQuery, reset, standardInitOptions + "," + driverSetupOptions);

// Driver application code here...

driver.Close();

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Note: The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Simple Data Types

C# Copy Code Copy Code
// Set the value of a property
driver.Frequency.VoltageRange = 20.0;

// Get the value of a property
double voltageRange = driver.Frequency.VoltageRange;

// Set the value of a property (enum)
driver.Temperature.TransducerType = IviDmmTransducerTypeEnum.IviDmmTransducerTypeThermocouple;

// Read a value from a method (as a return value)
double measuredValue = driver.Measurement.Read(2000);

Strings

C# Copy Code Copy Code
// Get a string property
string description = driver.Identity.Description;

// Read a value from a method (as a return value)
string coercionRecord = driver.DriverOperation.GetNextCoercionRecord();

// Read a value from a method (as an out parameter)
string errMsg = null;
int errCode = 0;
driver.Utility.ErrorQuery(ref errCode, ref errMsg);

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

C# Copy Code Copy Code
// Read an array of values, this returns a typed array
double[] measuredValues = driver.Measurement.ReadMultiPoint(5000);

// Iterate through the array
for (int i = 0; i < measuredValues.Length; i++)
{
  double measuredValue = measuredValues[i];
}

This example demonstrates passing an input array to a driver method. Note the use of the C# ref keyword.

C# Copy Code Copy Code
// Here we know in advance the exact size of the array
double[] frequencies = new double[3];
frequencies[0] = 10.0E6;
frequencies[1] = 12.0E6;
frequencies[2] = 14.0E6;

// An array input parameter takes a reference to an array
driver.ConfigureFrequencies(ref frequencies);

// Here we do not know in advance the size of the array
// so we use a resizable array
ArrayList valueList = new ArrayList();
valueList.Add(10.0E6);
valueList.Add(12.0E6);
valueList.Add(14.0E6);

// Create a fixed size array from the resizable array
double[] valueArray = (double[])valueList.ToArray(typeof(double));

// An array input parameter takes a reference to an array
driver.ConfigureFrequencies(ref valueArray);

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities.

Note: This driver may not use any or all types of repeated capabilites. The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Trace1") of a Collection-style repeated capability. Note that C# requires a special syntax when using parameterized properties, such as the Item property. Specifically parameterized properties appear in C# as methods with "get_" prepended to the property name.

C# Copy Code Copy Code
IIviSpecAnTrace trace = specAn.Traces.get_Item("Trace1");

double[] measuredValues = trace.ReadY(25000);

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a Selector-style repeated capability:

C# Copy Code Copy Code
IIviSpecAnMarker marker = specAn.Marker;

marker.ActiveMarker = "Marker1";
marker.Position = 1.2E9;
marker.Enabled = true;

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a Parameter-style repeated capability:

C# Copy Code Copy Code
IIviFgenFM fm = fgen.FM;

fm.set_Enabled("Channel1", true);
bool enabled = fm.get_Enabled("Channel1");

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

C# Copy Code Copy Code
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Agilent.AgInfiniiVision.Interop;

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Create driver instance
        AgInfiniiVision driver = new AgInfiniiVision();

        // Edit resource and options as needed.  Resource is ignored if option Simulate=true
        string resourceDesc = "GPIB0::13::INSTR";

        string initOptions = "QueryInstrStatus=true, Simulate=true, DriverSetup= Trace=false";

        bool idquery = true;
        bool reset   = true;

        // Initialize the driver.
        driver.Initialize(resourceDesc, idquery, reset, initOptions);
        Console.WriteLine("Driver Initialized");

        // Print a few IIviDriverIdentity properties
        Console.WriteLine("Identifier:  {0}", driver.Identity.Identifier);
        Console.WriteLine("Revision:    {0}", driver.Identity.Revision);
        Console.WriteLine("Vendor:      {0}", driver.Identity.Vendor);
        Console.WriteLine("Description: {0}", driver.Identity.Description);
        Console.WriteLine("Model:       {0}", driver.Identity.InstrumentModel);
        Console.WriteLine("FirmwareRev: {0}", driver.Identity.InstrumentFirmwareRevision);
        Console.WriteLine("\nSimulate:    {0}\n", driver.DriverOperation.Simulate);

        // TODO: Exercise driver methods and properties

        // Check instrument for errors
        int errorNum = -1;
        string errorMsg = null;
        Console.WriteLine("");
        while (errorNum != 0)
        {
          driver.Utility.ErrorQuery(ref errorNum, ref errorMsg);
          Console.WriteLine("ErrorQuery: {0}, {1}", errorNum, errorMsg);
        }
      }
      catch (Exception ex)
      {
        Console.WriteLine(ex.Message);
      }
      finally
      {
        if (driver != null && driver.Initialized)
        {
          // Close the driver
          driver.Close();
          Console.WriteLine("Driver Closed");
        }
      }

      Console.WriteLine("Done - Press Enter to Exit");
      Console.ReadLine();
    }
  }
}

Writing Interchangeable Code using the IviScope Class

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability

When writing interchangeable code, driver initialization and configuration information is read from the IVI Configuration Store and COM Session Factory included with the IVI Shared Components already installed on your system. For additonal example code see the topic: Writing Interchangeable Code Using the IviScope Class-Compliant Interfaces

Referencing IviScope and the IviSessionFactory

Instead of referencing the AgInfiniiVision type library, reference the IviScope and IviSessionFactory type libraries.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the COM tab.
  3. Select the following type libraries:
    • IviDriver 1.0 Type Library
    • IviScope Type Library
    • IviSessionFactory 1.0 Type Library
  4. Click the Select button and then OK.
  5. Each of the above type libraries should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the C# using statement allows the type name to be used directly.

C# Copy Code Copy Code
using Ivi.Driver.Interop;
using Ivi..Interop;
using Ivi.SessionFactory.Interop;

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

C# Copy Code Copy Code
IIviSessionFactory factory = new IviSessionFactoryClass();
IIviScope iviscope = factory.CreateDriver("MyLogicalName");

Initializing the Driver Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

C# Copy Code Copy Code
iviscope.Initialize("MyLogicalName", false, false, "");
iviscope.Close();

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using Visual Basic.NET

Using Visual Basic.NET

This section describes how to use the AgInfiniiVision IVI-COM driver from Visual Basic.NET. The driver includes a .NET Interop assembly for using the driver in .NET environments such as VB.NET.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver interop DLL and at least one of the IVI interop DLLs (specifically, Ivi.Driver.Interop.dll) must be created.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the Browse tab and select folder: <IviInstallDir>\Bin\Primary Interop Assemblies\
    Where <IviInstallDir> default location is: C:\Program Files\IVI Foundation\IVI\
  3. Select the following interop assemblies:
    • Ivi.Driver.Interop.dll
    • Agilent.AgInfiniiVision.Interop.dll
    • If needed for interchangability, IviScope.Interop.dll
  4. Click the OK button to add the assembly references.
  5. Each of the above interop assemblies should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the VB Imports statement allows the type name to be used directly.

Visual Basic Copy Code Copy Code
Imports Ivi.Driver.Interop
Imports Agilent.AgInfiniiVision.Interop

Creating an Instance of the Driver

The driver can be initialized by simply using the new operator directly on the driver class.

Visual Basic Copy Code Copy Code
Dim driver As new AgInfiniiVision

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

Visual Basic Copy Code Copy Code
driver.Initialize("GPIB0::13::INSTR", False, False, "")
driver.Close()

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see the topic: Initializing the Driver

Visual Basic Copy Code Copy Code
' If True, this will query the instrument model and fail initialization
' if the model is not supported by the driver
Dim idQuery As Boolean = False

' If True, the instrument is reset at initialization
Dim reset As Boolean = False

' Setup IVI-defined initialization options
Dim standardInitOptions As String = _
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false"

' Setup driver-specific initialization options
Dim driverSetupOptions As String = _
  "DriverSetup= Model=DSO-X 2002A, Trace=false"

driver.Initialize("GPIB0::13::INSTR", idQuery, reset, standardInitOptions + "," + driverSetupOptions)
driver.Close()

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Note: The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Simple Data Types

Visual Basic Copy Code Copy Code
' Set the value of a property
driver.Frequency.VoltageRange = 20.0

' Get the value of a property
Dim voltageRange As Double = driver.Frequency.VoltageRange

' Set the value of a property (enum)
driver.Temperature.TransducerType = IviDmmTransducerTypeEnum.IviDmmTransducerTypeThermocouple

' Read a value from a method (as a return value)
Dim measuredValue As Double = driver.Measurement.Read(2000)

Strings

Visual Basic Copy Code Copy Code
' Get a string property
Dim description As String = driver.Identity.Description

' Read a value from a method (as a return value)
Dim coercionRecord As String = driver.DriverOperation.GetNextCoercionRecord()

' Read a value from a method (as an out parameter)
Dim errMsg As String = ""
Dim errCode As Integer = 0
driver.Utility.ErrorQuery(errCode, errMsg)

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

Visual Basic Copy Code Copy Code
' Read an array of values. This returns a typed array
Dim measuredValues() As Double = driver.Measurement.ReadMultiPoint(5000)

' Iterate through the array
Dim index As Integer
For index = 0 To (measuredValues.Length - 1)
  Dim measuredValue As Double = measuredValues(i)
Next

This example demonstrates passing an input array to a driver method.

Visual Basic Copy Code Copy Code
' Here we know in advance the exact size of the array
Dim frequencies(3) As Double
frequencies(0) = 10.0E6
frequencies(1) = 12.0E6
frequencies(2) = 14.0E6

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies(frequencies)

' Here we do not know in advance the size of the array
' so we use a resizable array
Dim valueList As New ArrayList
valueList.Add(10.0E6)
valueList.Add(12.0E6)
valueList.Add(14.0E6)

' Create a fixed size array from the resizable array
Dim valueArray() As Double
valueArray = valueList.ToArray(GetType(Double))

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies(valueArray)

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities.

Note: This driver may not use any or all types of repeated capabilites. The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Trace1") of a Collection-style repeated capability:

Visual Basic Copy Code Copy Code
Dim trace As IIviSpecAnTrace = specAn.Traces.Item("Trace1")

Dim measuredValues() As Double = spTrace.ReadY(25000)

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a Selector-style repeated capability:

Visual Basic Copy Code Copy Code
Dim marker As IIviSpecAnMarker = specAn.Marker

marker.ActiveMarker = "Marker1"
marker.Position = 1.2E9
marker.Enabled = true

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a Parameter-style repeated capability:

Visual Basic Copy Code Copy Code
Dim fm As IIviFgenFM = fgen.FM

fm.Enabled("Channel1") = true
Dim enabled As Boolean = fm.Enabled("Channel1")

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

Visual Basic Copy Code Copy Code
Imports Ivi.Driver.Interop
Imports Agilent.AgInfiniiVision.Interop

Module Module1

    Sub Main()

        ' Create an instance of the driver
        Dim driver As New AgInfiniiVision()

        Try
            ' Edit resource and options as needed.  Resource is ignored if option Simulate=true
            Dim resourceDesc As String = "GPIB0::13::INSTR"
            ' resourceDesc = "TCPIP0::<ip or hostname>::INSTR"

            ' Set initialization options
            Dim initOptions As String = "QueryInstrStatus=true, Simulate=true, DriverSetup= Model=DSO-X 2002A"
            Dim idquery As Boolean = True
            Dim reset   As Boolean = True

            ' Initialize the driver.
            driver.Initialize(resourceDesc, idquery, reset, initOptions)
            Console.WriteLine("Driver Initialized")

            ' Get driver Identity properties.
            Console.WriteLine("Identifier:  {0}", driver.Identity.Identifier)
            Console.WriteLine("Revision:    {0}", driver.Identity.Revision)
            Console.WriteLine("Vendor:      {0}", driver.Identity.Vendor)
            Console.WriteLine("Description: {0}", driver.Identity.Description)
            Console.WriteLine("Model:       {0}", driver.Identity.InstrumentModel)
            Console.WriteLine("FirmwareRev: {0}", driver.Identity.InstrumentFirmwareRevision)
            Console.WriteLine()
            Console.WriteLine("Simulate:    {0}", driver.DriverOperation.Simulate)
            Console.WriteLine()

            ' TODO: driver specific tasks...

            ' Check instrument for errors.
            Dim errorCode As Integer = -1
            Dim errorMsg As String = String.Empty
            Console.WriteLine()
            Do
                driver.Utility.ErrorQuery(errorCode, errorMsg)
                Console.WriteLine("ErrorQuery: {0}, {1}", errorCode, errorMsg)
            Loop While errorCode <> 0

        Catch err As System.Exception
            Console.WriteLine()
            Console.WriteLine("Exception Error:")
            Console.WriteLine("  " + err.Message())
        End Try

        ' Close driver if initialized.
        If (driver.Initialized) Then
            driver.Close()
            Console.WriteLine("Driver Closed")
        End If

        Console.WriteLine()
        Console.Write("Done - Press Enter to Exit ")
        Console.ReadLine()

    End Sub

End Module

Writing Interchangeable Code using the IviScope Class

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability

When writing interchangeable code, driver initialization and configuration information is read from the IVI Configuration Store and COM Session Factory included with the IVI Shared Components already installed on your system. For additonal example code see the topic: Writing Interchangeable Code Using the IviScope Class-Compliant Interfaces

Referencing IviScope and the IviSessionFactory

Instead of referencing the AgInfiniiVision type library, reference the IviScope and IviSessionFactory type libraries.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the COM tab.
  3. Select the following type libraries:
    • IviDriver 1.0 Type Library
    • IviScope Type Library
    • IviSessionFactory 1.0 Type Library
  4. Click the Select button and then OK.
  5. Each of the above type libraries should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the VB.NET Imports statement allows the type name to be used directly.

Visual Basic Copy Code Copy Code
Imports Ivi.Driver.Interop
Imports Ivi..Interop
Imports Ivi.SessionFactory.Interop

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

Visual Basic Copy Code Copy Code
Dim factory As New IviSessionFactoryClass()
Dim iviscope As IIviScope = factory.CreateDriver("MyLogicalName")

Initializing the Driver Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

Visual Basic Copy Code Copy Code
iviscope.Initialize("MyLogicalName", False, False, "")
iviscope.Close()

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using Visual C++

Using Visual C++

This section describes how to use the AgInfiniiVision IVI-COM driver from Visual C++. The techniques presented in this section work for Visual Studio 6 and later.

Smart Pointer Wrapper Classes

There are many ways to use COM objects, such as IVI-COM drivers, from Visual C++. The easiest way is to use the #import statement. This special compiler directive automatically generates smart pointer wrapper classes for every interface in your IVI-COM driver. These wrapper classes greatly simplify the use of IVI-COM drivers in C++.

Smart pointer wrapper classes have the following benefits:

  • They provide a simple syntax for instantiating the driver (e.g. calling CoCreateInstance).
  • They automatically call AddRef and Release when needed.
  • They automatically call QueryInterface when navigating to different interfaces on the driver.
  • Method parameters marked as [out, retval] appear as the method return value type instead of an HRESULT.
  • Properties can be accessed as a property instead of using get_ and put_ accessor functions.
  • Methods and properties throw exceptions rather than requiring explicit checks against an HRESULT return code.
  • String parameters (BSTRs) are transformed into the _bstr_t smart string class, which can be initialized with ANSI or Unicode strings.

The code in this section uses smart pointer wrappers. The #import statement supports a variety of optional parameters to exercise more precise control over the wrapper generation and format. See the MSDN documentation on #import for more details.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created. Note that the order of the #import statements shown below is important. Compilation will fail if the order is incorrect, as there are dependencies between the types defined in the various DLLs.

GlobMgr.dll is required by drivers using VISA-COM I/O. Generally, SCPI based instrument drivers use VISA-COM and non-SCPI based modular instrument drivers do not. If required, you may have to add the path to GlobMgr.dll (<Program Files>\IVIFoundation\Visa\VisaCom) to your Visual Studio, Tools, Options, Projects and Solutions, VC++ Directories path for executable files.

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O functionality
#import "IviDriverTypeLib.dll" no_namespace  // IVI inherent functionality
#import "AgInfiniiVision.dll" no_namespace  // Instrument specific functionality

Creating an Instance of the Driver

Unlike most environments that support COM, C++ does not automatically initialize COM, so this must be done explicitly. If you fail to perform this step, then any attempt to make any COM-based call (such as instantiating the driver) will fail.

C++ Copy Code Copy Code
// Initialize COM, do this at the start of the program
HRESULT hr = ::CoInitialize(NULL);

// Uninitialize COM, do this at the end of the program
::CoUninitialize();

To instantiate the driver directly, pass in the CLSID of the specific driver using the __uuidof C++ keyword, as shown below:

C++ Copy Code Copy Code
IAgInfiniiVisionPtr spDriver(__uuidof(AgInfiniiVision));

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close at the end of your program is required by the IVI specifications, else unpredictable driver behavior could result. Simply releasing the driver object (which the wrapper classes automatically do for you) is not sufficient. The reference count of the driver will never reach zero if Close is not called.

For more details on the Initialize method, see the topic: Initializing the Driver

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy Code Copy Code
spDriver->Initialize(_T("GPIB0::13::INSTR"), VARIANT_FALSE, VARIANT_FALSE, _T(""));
spDriver->Close();

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

C++ Copy Code Copy Code
// If VARIANT_TRUE, this will query the instrument model and fail initialization
// if the model is not supported by the driver
VARIANT_BOOL idQuery = VARIANT_FALSE;

// If VARIANT_TRUE, the instrument is reset at initialization
VARIANT_BOOL reset = VARIANT_FALSE;

// Setup IVI-defined initialization options
_bstr_t standardInitOptions =
  "Cache=false, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=false, RecordCoercions=false, Simulate=false";

// Setup driver-specific initialization options
_bstr_t driverSetupOptions =
  "DriverSetup= Model=DSO-X 2002A, Trace=false";

spDriver->Initialize(_T("GPIB0::13::INSTR"), idQuery, reset, standardInitOptions + _bstr_t(_T(",")) + driverSetupOptions);
spDriver->Close();

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Note: The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Simple Data Types

C++ Copy Code Copy Code
// Set the value of a property
spDriver->Frequency->VoltageRange = 20.0;

// Get the value of a property
double voltageRange = spDriver->Frequency->VoltageRange;

// Set the value of a property (enum)
spDriver->Temperature->TransducerType = IviDmmTransducerTypeThermocouple;

// Read a value from a method (as a return value)
double measuredValue = spDriver->Measurement->Read(2000);

Strings

It is important to correctly free the memory when reading or writing strings. Here the _bstr_t destructor takes care of freeing the memory when the object goes out of scope.

C++ Copy Code Copy Code
// Get a string property
_bstr_t description = spDriver->Identity->Description;

// Read a value from a method (as a return value)
_bstr_t coercionRecord = spDriver->DriverOperation->GetNextCoercionRecord();

// Read a value from a method (as an out parameter)
_bstr_t errMsg;
long errCode;
spDriver->Utility->ErrorQuery(&errCode, errMsg.GetAddress());

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval]. This uses the CComSafeArray class to manage the memory automatically.

C++ Copy Code Copy Code
#include <atlsafe.h> // for CComSafeArray

// Read an array of values, this returns a raw SAFEARRAY pointer
SAFEARRAY* psaMeasuredValues = spDriver->Measurement->ReadMultiPoint(5000);

// Use the CComSafeArray smart data type, transferring memory ownership to it
// Memory will be freed when the smart data type goes out of scope
CComSafeArray<double> csaMeasuredValues;
csaMeasuredValues.Attach(psaMeasuredValues);

// Iterate through the array
for (long i = 0; i < (long)csaMeasuredValues.GetCount(); i++)
{
  double measuredValue = csaMeasuredValues.GetAt(i);
}

It is important to know that the CComSafeArray constructor and assignment operator make a copy of the SAFEARRAY. For arrays containing many elements, this must be carefully taken into consideration. The Attach and Detach functions do not perform copies and can often be used when one might have unnecessarily used the constructor or assignment operator.

The code below demonstrates some common mistakes made when using SAFEARRAYs and the CComSafeArray class.

C++ Copy Code Copy Code
#include <atlsafe.h> // for CComSafeArray

// DO NOT DO THIS, this will LEAK!
CComSafeArray<double> csaMeasuredValues = spDCPwr->Measurement->ReadMultiPoint(5000);

// DO NOT DO THIS, this will LEAK!
CComSafeArray<double> csaMeasuredValues(spDCPwr->Measurement->ReadMultiPoint(5000));

The following code demonstrates how to pass an array to a driver method.

C++ Copy Code Copy Code
#include <atlsafe.h> // for CComSafeArray

CComSafeArray<double> csaFrequencies;
csaFrequencies.Add(10.0E6);
csaFrequencies.Add(12.0E6);
csaFrequencies.Add(14.0E6);

// An array input parameter takes a SAFEARRAY**
spDriver->ConfigureFrequencies(csaFrequencies.GetSafeArrayPtr());

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities.

Note: This driver may not use any or all types of repeated capabilites. The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Trace1") of a Collection-style repeated capability. Note that C++ requires a special syntax when using parameterized properties, such as the Item property. Specifically, square brackets must be used around the repeated capability Physical Name.

C++ Copy Code Copy Code
IIviSpecAnTracePtr spTrace = spSpecAn->Traces->Item[_T("Trace1")];

SAFEARRAY* psaMeasuredValues = spTrace->ReadY(25000);
CComSafeArray<double> csaMeasuredValues;
csaMeasuredValues.Attach(psaMeasuredValues);

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a Selector-style repeated capability:

C++ Copy Code Copy Code
IIviSpecAnMarkerPtr spMarker = spSpecAn->Marker;

spMarker->ActiveMarker = _T("Marker1");
spMarker->Position = 1.2E9;
spMarker->Enabled = VARIANT_TRUE;

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a Parameter-style repeated capability:

C++ Copy Code Copy Code
IIviFgenFMPtr spFM = spFgen->FM;

spFM->Enabled[_T("Channel1")] = VARIANT_TRUE;
VARIANT_BOOL enabled = spFM->Enabled[_T("Channel1")];

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O funtionality
#import "IviDriverTypeLib.dll" no_namespace  // IVI inherent functionality
#import "AgInfiniiVision.dll" no_namespace  // Instrument specfic functionality

void main()
{
  HRESULT hr = ::CoInitialize(NULL);

  try
  {
    // Create an instance of the driver.
    IAgInfiniiVisionPtr spDriver(__uuidof(AgInfiniiVision));

    // Edit resource and options as needed.  Resource is ignored if option Simulate=true
    CString strResourceDesc = "GPIB0::13::INSTR";

    CString strInitOptions = "QueryInstrStatus=true, Simulate=true, DriverSetup= Model=DSO-X 2002A, Trace=false";

    VARIANT_BOOL idQuery = VARIANT_TRUE;
    VARIANT_BOOL reset   = VARIANT_TRUE;

    // Initialize the driver.
    spDriver->Initialize(LPCTSTR(strResourceDesc), idQuery, reset, LPCTSTR(strInitOptions));
    printf("Driver Initialized\n");

    try
    {
      // Print a few IIviDriverIdentity properties
      wprintf(L"Identifier:  %s\n", spDriver->Identity->Identifier.GetBSTR());
      wprintf(L"Revision:    %s\n", spDriver->Identity->Revision.GetBSTR());
      wprintf(L"Vendor:      %s\n", spDriver->Identity->Vendor.GetBSTR());
      wprintf(L"Description: %s\n", spDriver->Identity->Description.GetBSTR());
      wprintf(L"Model:       %s\n", spDriver->Identity->InstrumentModel.GetBSTR());
      wprintf(L"FirmwareRev: %s\n", spDriver->Identity->InstrumentFirmwareRevision.GetBSTR());

      // TODO: Exercise driver methods and properties

    }
    catch (_com_error& ex)
    {
      if (ex.Error() == E_IVI_INSTRUMENT_STATUS)
      {
        // ErrorQuery should give us more information
        long errCode;
        _bstr_t errMsg;
        spDriver->Utility->ErrorQuery(&errCode, errMsg.GetAddress());

        // Print the error
        wprintf(L"Instrument Error: %s\n", errMsg.GetBSTR());
      }
      else
      {
        // Print the exception
        wprintf(L"Exception: %s\n", ex.Description.GetBSTR());
      }
    }
    spDriver->Close();
  }
  catch (_com_error& e)
  {
    // There was some problem creating the driver or initializing it
    // There is no need to call Close() and we cannot call ErrorQuery()
    // because the driver is not initialized.
    wprintf(L"Exception: %s\n", e.Description.GetBSTR());
  }

  // Note that by this point all COM objects have been released
  // because all the smart pointers go out of scope at the end of
  // the outermost try block.
  // This is important, no COM calls can be made after CoUninitialize.
  ::CoUninitialize();
}

Writing Interchangeable Code using the IviScope Class

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability

When writing interchangeable code, driver initialization and configuration information is read from the IVI Configuration Store and COM Session Factory included with the IVI Shared Components already installed on your system. For additonal example code see the topic: Writing Interchangeable Code Using the IviScope Class-Compliant Interfaces

Referencing IviScope and the IviSessionFactory

Instead of referencing the AgInfiniiVision.dll, reference the IviScopeTypeLib.dll and IviSessionFactory.dll.

C++ Copy Code Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O functionality
#import "IviDriverTypeLib.dll" no_namespace  // IVI inherent functionality
#import "IviScopeTypeLib.dll" no_namespace  // IVI Class functionality
#import "IviSessionFactory.dll" no_namespace  // COM Session Factory functionality

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory. To instantiate the COM Session Factory, you simply pass in the CLSID of the IVI-COM Session Factory to the constructor of the wrapper class. The easiest way to obtain the CLSID of any COM class is via the __uuidof C++ keyword, as shown below.

C++ Copy Code Copy Code
IIviSessionFactory spFactory(__uuidof(IviSessionFactory));
IIviScopePtr spIviScope = spFactory->CreateDriver(_T("MyLogicalName"));

spIviScope->Range = 300;

Initializing the Driver Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

C++ Copy Code Copy Code
spIviScope->Initialize(_T("MyLogicalName"), VARIANT_FALSE, VARIANT_FALSE, _T(""));
spIviScope->Close();

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using Visual Basic 6

Using Visual Basic 6

This section describes how to use the AgInfiniiVision IVI-COM driver from Visual Basic 6.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created.

  1. In the project menu, select References.
  2. Click the COM tab.
  3. Check the following type libraries:
    • IviDriver 1.0 Type Library
    • IVI AgInfiniiVision 2.5 Type Library
  4. Click OK.

Creating an Instance of the Driver

The driver can be initialized by simply using the new operator directly on the driver class.

Visual Basic Copy Code Copy Code
Dim driver As new AgInfiniiVision

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close at the end of your program is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

Visual Basic Copy Code Copy Code
driver.Initialize "GPIB0::13::INSTR", False, False, ""
driver.Close()

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see the topic: Initializing the Driver

Visual Basic Copy Code Copy Code
' If True, this will query the instrument model and fail initialization
' if the model is not supported by the driver
Dim idQuery As Boolean
idQuery = False

' If True, the instrument is reset at initialization
Dim reset As Boolean
reset = False

' Setup IVI-defined initialization options
Dim standardInitOptions As String
standardInitOptions = "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false"

' Setup driver-specific initialization options
Dim driverSetupOptions As String
driverSetupOptions = "DriverSetup= Model=DSO-X 2002A, Trace=false"

driver.Initialize "GPIB0::13::INSTR", idQuery, reset, standardInitOptions & "," & driverSetupOptions
driver.Close

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Note: The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Simple Data Types

Visual Basic Copy Code Copy Code
' Set the value of a property
driver.Outputs.Item("MyOutput").VoltageLevel = 3.5

' Get the value of a property
Dim voltageLevel as Double
voltageLevel = driver.Outputs.Item("MyOutput").VoltageLevel = 3.5

' Set the value of a property (enum)
driver.Outputs.Item("MyOutput").TriggerSource = IviDCPwrTriggerSourceExternal

' Read a value from a method (as a return value)
double measuredValue = driver.Outputs.Item("MyOutput").Measure(IviDCPwrMeasurementTypeVoltage)

Strings

Visual Basic Copy Code Copy Code
' Get a string property
Dim description As String
description = driver.Identity.Description

' Read a value from a method (as a return value)
Dim coercionRecord As String
coercionRecord = driver.DriverOperation.GetNextCoercionRecord()

' Read a value from a method (as an out parameter)
Dim errCode As Long
Dim errMsg As String
driver.Utility.ErrorQuery errCode, errMsg

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

Visual Basic Copy Code Copy Code
' Read an array of values. This returns a typed array
Dim measuredValues() As Double
measuredValues = driver.Measurement.ReadMultiPoint(5000)

' Iterate through the array
Dim index As Long
For index = LBound(measuredValues) To UBound(measuredValues)
  Dim measuredValue As Double
  measuredValue = measuredValues(i)
Next

This example demonstrates passing an input array to a driver method.

Visual Basic Copy Code Copy Code
' Here we know in advance the exact size of the array
Dim frequencies(3) As Double
frequencies(0) = 10.0E6
frequencies(1) = 12.0E6
frequencies(2) = 14.0E6

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies frequencies

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities.

Note: This driver may not use any or all types of repeated capabilites. The code below is for illustration only, may be from other drivers, and may not apply directly to this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Output1") of a Collection-style repeated capability:

Visual Basic Copy Code Copy Code
Dim output as IIviDCPwrOutput
Set output = driver.Outputs.Item("Output1")

output.VoltageLevel = 3.5

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a Selector-style repeated capability:

Visual Basic Copy Code Copy Code
Dim marker As IIviSpecAnMarker
Set marker = specAn.Marker

marker.ActiveMarker = "Marker1"
marker.Position = 1.2E9
marker.Enabled = true

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a Parameter-style repeated capability:

Visual Basic Copy Code Copy Code
Dim fm As IIviFgenFM
Set fm = fgen.FM

fm.Enabled("Channel1") = true
Dim enabled As Boolean
enabled = fm.Enabled("Channel1")

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

Visual Basic Copy Code Copy Code
Sub Example()

  Dim driver As new AgInfiniiVision

  ' IIviDriverIdentity properties - Initialize not required
  Dim identifier As String
  identifier = driver.Identity.identifier
  Output.Text = Output.Text & "Identifer: " & identifier & vbCr & vbLf

  Dim revision As String
  revision = driver.Identity.revision
  Output.Text = Output.Text & "Revision: " & revision & vbCr & vbLf

  Dim vendor As String
  vendor = driver.Identity.vendor
  Output.Text = Output.Text & "Vendor: " & vendor & vbCr & vbLf

   ' Setup Resource Descriptor
  Dim resourceDesc As String
  resourceDesc = "GPIB0::13::INSTR"

 ' Setup IVI-defined initialization options
  Dim standardInitOptions As String
  standardInitOptions = "Cache=false, InterchangeCheck=false, QueryInstrStatus=false, RangeCheck=false, RecordCoercions=false, Simulate=false"

  ' Setup driver-specific initialization options
  Dim driverSetupOptions As String
  driverSetupOptions = "DriverSetup= Model=DSO-X 2002A, Trace=false"

  driver.Initialize resourceDesc, False, False, standardInitOptions + "," + driverSetupOptions

  ' IIviDriverIdentity properties - Initialize required
  Dim instModel As String
  instModel = driver.Identity.InstrumentModel
  Output.Text = Output.Text & "InstrumentModel: " & instModel & vbCr & vbLf

  Dim instFirmwareRevision As String
  instFirmwareRevision = driver.Identity.InstrumentFirmwareRevision
  Output.Text = Output.Text & "InstrumentFirmwareRevision: " & instFirmwareRevision & vbCr & vbLf

  Dim instManufacturer As String
  instManufacturer = driver.Identity.InstrumentManufacturer
  Output.Text = Output.Text & "InstrumentManufacturer: " & instManufacturer & vbCr & vbLf

  ' TODO: Exercise driver methods and properties

  ' Check instrument for errors
  Dim errorNum As Long
  Dim errorMsg As String
  errorNum = -1
  While (errorNum <> 0)

    driver.Utility.ErrorQuery errorNum, errorMsg
    Output.Text = Output.Text & "ErrorQuery: " & errorNum & ", " & errorMsg & vbCr & vbLf

  Wend

  ' Close driver
  driver.Close

  End Sub

Writing Interchangeable Code using the IviScope Class

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability
When writing interchangeable code, driver initialization and configuration information is read from the IVI Configuration Store and COM Session Factory included with the IVI Shared Components already installed on your system.

Referencing IviScope and the IviSessionFactory

Instead of referencing the AgInfiniiVision type library, reference the IviScope and IviSessionFactory type libraries.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the COM tab.
  3. Check the following type libraries:
    • IviDriver 1.0 Type Library
    • IviScope Type Library
    • IviSessionFactory 1.0 Type Library
  4. Click OK.

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

Visual Basic Copy Code Copy Code
Dim factory As New IviSessionFactory()
Dim iviscope As IIviScope
set iviscope = factory.CreateDriver("MyLogicalName")

Initializing the Driver Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

Visual Basic Copy Code Copy Code
iviscope.Initialize("MyLogicalName", False, False, "")
iviscope.Close()

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using Keysight VEE Pro

Using Keysight VEE Pro

VEE Pro 9.0 or greater is required and includes features for easy use of IVI-COM drivers. VEE Pro provides access to the AgInfiniiVision driver COM object using .NET interop references. You may use Keysight VEE Pro's help for general information on using IVI-COM objects in Keysight VEE Pro. Look in the index for the following topics: IVI, IVI-COM, Instrument Manager, Component Drivers

A complete, working, VEE example program may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

Referencing the AgInfiniiVision IVI-COM Driver in VEE Pro

With VEE Pro 9.0 and above, it is recommended that you take advantage of the fully integrated and simplified "To/From IVI-COM" feature.

Open VEE Pro's Instrument Manager, if you have an instrument connected already, you can click the "Configure Drivers" button and VEE Pro will automatically search for the IVI-COM drivers installed on your machine. If an IVI-COM driver for your instrument is found, the "IVI-COM Driver" button will be enabled.

If you do not have an instrument connected, you can click on the "Properties" button and then the "Advanced" button, under the "IVI-COM" tab, select an IVI-COM driver or IVI-COM driver session in the drop-down list box. Click OK, and the "IVI-COM Driver" button will be enabled.

If you cannot find the driver in this list, it was not installed and registered properly. See Installation.

Creating an AgInfiniiVision IVI-COM Driver Instance in VEE Pro

Open Instrument Manager again and select your instrument, click the "IVI-COM Driver" button. This will place an "To/From IVI-COM" object onto your workspace. Double click on the highlighted line, this will open a dialog to let you select the operations that you want to perform on the driver.

CreateInstance

Before you do anything else, double-click the first bolded operation, and click the OK button. This will add an operation to create an instance of the IVI-COM driver.

It is recommended that you use a global Declare Variable object for your driver instance object. This is more robust and provides easy access to your driver object throughout your program.

Initializing the Driver

Before you can do anything very interesting with an IVI-COM driver you must call its Initialize method. Double-click the second bolded operation. This will let you modify any initialization parameters.

ResourceName
This string identifies a particular instrument in the system. Its contents may be a VISA style string such as GPIB0::13::INSTR.
IdQuery
This Boolean determines whether the driver interrogates the instrument about its identity and then verifies that the instrument is one suitable for the driver. The instrument model must be in the supported model list. If this parameter is False, the driver skips this verification.
Reset
This second Boolean determines whether the driver resets the instrument.
OptionString
The final parameter, a string, may set a number of driver properties. If the string is empty, the properties are set to default values or the values contained in the Configuration Store for this session.
Closing the Driver

You should always match your Initialize operation with the Close operation to release any resources. It is the third bolded operation in the "Select an Operation from" dialog.

Accessing Properties and Methods in VEE Pro

Now you can use the driver to program the instrument by accessing the driver's properties and methods. An IVI-COM driver is used the same way as other ActiveX objects are used in Keysight VEE Pro.

You can use a To/From IVI-COM object or you can use a formula box. For example, here is a To/From IVI-COM object. The first line creates an instance of the driver, the second line initializes the driver, the third line calls a method to clear the status, the fourth line sets a property to enable the display. The last line closes the driver.

The help file for the driver lists and explains all of the driver's methods and properties.

Descending the Interface Hierarchy in VEE Pro

An IVI-COM driver contains a hierarchy of interfaces. Many of the properties at the root are interface pointers.

So how does a VEE Pro program get to these members? From the To/From IVI-COM object, you see that this driver has a property called DriverOperation whose type is IIviDriverOperation. Now you can open up that tree node to discover all its methods and properties. Once you find the method or property that you want, double-click on it to do any editing and then the operation will be added to the To/From IVI-COM object.

These techniques for descending the interface hierarchy apply equally to the IVI inherent capabilities, class-compliant interfaces, and instrument-specific interfaces.

Keeping an Interface Pointer

If the program accesses many methods and properties in the same sub-interface or even uses the same method or property in a sub-interface many times, a more efficient programming technique is to create a reference to the interface. This efficiency becomes especially important if you are using DCOM to access the driver. If the program contains a formula box with:

A.DriverOperation.IoResourceDescriptor

Every time the code executes, Keysight VEE Pro queries the object for the DriverOperation property. While the time for this operation is very small when on the local machine, the time becomes measurable when done over a network.

To save this time, the program can hold a reference to the interface. A formula box would contain the line:

A.DriverOperation

The Result from this box is connected to formula boxes or .NET Operation Builders which use the DriverOperation interface. If this interface pointer is used many times, Keysight VEE Pro is saved from asking the driver for the same, static information that many times. That time saving becomes significant in a remote, DCOM environment.

Tip: to create a .NET Operation Builder for any .NET type, go to Device->.NET Operation Builder, click the Find toolbar button, and type in the type name or a part of the type name.

Handling COM Data Types in VEE Pro

Keysight VEE Pro can handle all COM automation data types. IVI-COM drivers are no exception and even purposely restrict the data types used by the driver to avoid any difficult programming tasks.

Boolean
The COM VARIANT_BOOL data type is used. Its value can be VARIANT_TRUE or VARIANT_FALSE.
Int32

The COM LONG data type is used for Int32 values.

Real64

The COM DOUBLE data type is used for Real64 values.

Text

The COM BSTR data type is used for text strings.

Array

The COM SAFEARRAY data type is for arrays.

Interface Pointer

An interface pointer's type is maintained by Keysight VEE Pro.

in, out parameters
Some parameters are declared to be both in and out. For these parameters, you must have an input and output for the parameter. The method call in the formula requires the keyword ByRef before these parameters. Two examples are ErrorQuery and SelfTest in IIviDriverUtility.

The formula box for doing an ErrorQuery would look like:

Further Information

To learn more about Using Keysight VEE Pro, visit:
http://www.keysight.com/find/vee.

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using LabVIEW

Using LabVIEW

National Instruments LabVIEW provides extensive support for COM components. Any COM component that restricts itself to automation data types (i.e. Visual Basic-compatible types) may be used directly from LabVIEW. Since all IVI-COM drivers use only automation data types, they can be used from LabVIEW in precisely the same manner as any other COM component.

There are two ways to access the AgInfiniiVision IVI-COM driver in LabVIEW: using the Class Browser and using the IVI Class Driver VIs. This section discusses both techniques.

Using the LabVIEW Class Driver VIs

LabVIEW provides IVI Class Driver VIs that can be used to write interchangeable IVI applications. If interchangeability is the overriding requirement or if only the IVI-defined functions are needed in an application, then using the LabVIEW IVI Class Driver VIs is the preferred way to access the AgInfiniiVision driver in LabVIEW. These VIs are located on the Functions palette under Instrument I/O -> IVI Class Drivers.

The COM Adapter

The IVI Class Driver VIs have the ability to load both IVI-COM and IVI-C drivers directly. If the driver includes an IVI-C wrapper, then the IVI Class Driver VIs will load the AgInfiniiVision driver as if it were a native IVI-C driver. No extra steps are required on the part of the developer.

If an IVI driver does not include an IVI-C wrapper, then the IVI Class Driver VIs can still be used to load the IVI-COM native driver directly. There are two requirements for the IVI Class Driver VIs to be used with a native IVI-COM driver:

  1. The NI IVI Compliance Package 3.2 (or later) must be installed.
  2. The IVI-COM adapter feature must be enabled when installing the NI IVI Compliance Package. Note: This feature is disabled by default, so you must explicitly enable it when installing.

The LabVIEW Class Browser

The most convenient way to access the instrument-specific features of an IVI-COM driver is to use the Class Browser. This feature is available in LabVIEW version 8.0 and later. The Class Browser presents an intuitive hierarchical view of all methods and properties in the driver -- class-compliant and instrument-specific. From this hierarchical view, the LabVIEW developer can simply drag-n-drop methods and properties onto the block diagram and LabVIEW automatically creates the appropriately configured Invoke Node (for methods) or Property Node (for properties).

Building a Simple IVI Application in LabVIEW

This section provides step-by-step instructions for building a simple LabVIEW application with the AgInfiniiVision IVI-COM driver.

Accessing the AgInfiniiVision Driver from the Class Browser

The first step in building a LabVIEW application using an IVI-COM driver is to access the Class Browser and direct it to load the AgInfiniiVision IVI-COM driver. From LabVIEW's perspective, the AgInfiniiVision driver is simply a COM (aka "ActiveX") component. As such, it can be loaded via the ActiveX feature of the Class Browser.

To load the AgInfiniiVision into the Class Browser

  1. From the View menu, choose Class Browser. The Class Browser window appears.
  2. From the Object Library combo box at the top, choose ActiveX and then Select Type Libraries... The system will likely pause for several seconds as LabVIEW scans your system for all installed COM components.
  3. From the Select Type Libraries dialog box that appears, check the checkbox labeled "IVI AgInfiniiVision 2.5 Type Library Version 2.5" and click OK.
  4. From the Class combo box, select AgInfiniiVisionLib.IAgInfiniiVision.
  5. The Properties and Methods window now displays the hierarchy of methods and properties available in the AgInfiniiVision driver. The items with small blue dots are interface reference properties and allow you to navigate to sub-interfaces on the driver. Double-click on one of these, such as the System interface and the Properties and Methods window is updated to display the methods and properties of the sub-interface. To navigate back to the root of the hierarchy, click on the System hyperlink in the Selected property or method textbox near the bottom.

Initializing the Driver

The two main LabVIEW primitives required to access IVI-COM driver methods and properties are the Invoke Node (for methods) and the Property Node (for properties). Conveniently, the Class Browser automatically creates and configures these nodes for you.

Before any Invoke Node or Property Node can execute on the IVI-COM driver, it must be instantiated. This is accomplished using the Automation Open VI from the ActiveX palette. The following procedure explains how to instantiate and initialize the driver.

To instantiate and initialize the AgInfiniiVision driver

  1. From the Class Browser, choose the Initialize node from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. The Automation Open VI is used to instantiate the IVI-COM driver before executing the Initialize function. Right-click on the Initialize Invoke Node just at the top left corner at the reference input, and select ActiveX Palette and then Automation Open. This creates the Automation Open VI. Make sure the Automation Refnum output of the Automation Open VI is wired to the reference input of the Initialize Invoke Node. Also, make sure the error clusters of the two VIs are wired together.
  3. The Automation Open VI requires an input control. Right-click on the Automation Refnum input of the Automation Open VI and choose Select ActiveX Class and then choose Browse.
  4. From the Type Library combo box at the top, choose "AgInfiniiVision Version 2.5". Expand the AgInfiniiVision node and choose IAgInfiniiVision (the first interface under the expanded node). Click OK.
  5. LabVIEW creates an Automation Refnum input control and wires it to the Automation Open VI. Make sure the error clusters of the two VIs are wired together.
  6. At this point, the VI will not compile since some of the required inputs of the Initialize Invoke Node have not be supplied. Right-click on the ResourceName input of the Initialize Invoke Node and choose Create and then Constant. LabVIEW places a constant string on the diagram and wires it to the ResourceName input. In the string constant created, enter the appropriate VISA resource descriptor for connecting to the instrument.
  7. Right-click on the IdQuery input of the Initialize Invoke Node, choose Create and then Constant. LabVIEW creates a constant boolean wired to the IdQuery input. Repeat this process with the Reset input.
  8. At this point, the application is executable. LabVIEW will instantiate the AgInfiniiVision IVI-COM driver and call the Initialize function. However, we must properly close the IVI-COM driver. We must also have the ability to read and write driver properties. These final tasks are covered in the next sections.

Reading and Writing Properties

Once the driver has been instantiated with the Automation Open VI and the Initialize function executes, any method or property on the AgInfiniiVision driver can be invoked. The previous sections explained how to call the Initialize method. Other driver methods are accessed in precisely the same fashion.

This section explains how to read and write driver properties.

To access properties on the AgInfiniiVision driver

  1. From the Class Browser, choose any property from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. LabVIEW creates a Property Node for that property on the diagram. Wire the reference out terminal of the Initialize Invoke Node to the reference input terminal of the Property Node. Also, wire the error clusters together.
  3. By default, the Property Node is configured to read a driver property, as indicated by the small arrow on the right side of the node's terminal. Right-click on the Property Node terminal and select Create and then choose Indicator. This places an output indicator on the diagram and wires it to the Property Node. This reads the value of the selected property from the driver and present it in the indicator.
  4. To use a Property Node to write a property value to the driver, simply right-click on the Property Node and choose Change to Write. This reconfigures the Property Node to be a "setter" node, as indicated by the re-positioning of the small arrow to the left side of the node terminal.
  5. A single Property Node can be used to read and write multiple properties. This is accomplished by resizing the Property Node vertically. Move the cursor over the node and resizing handles appear at the top and bottom of the node. Use the resizing handles to drag the border of the node down to display additional terminals.
  6. To configure a specific terminal to access a particular property, right-click on a terminal and choose Select Property.... This brings up an additional Class Browser window, from which you can select the desired property. You can configure individual terminals to read or write by right-clicking the specific terminal and choosing Change To Read or Change To Write as appropriate. Note that multi-terminal Property Nodes execute in order from top to bottom.

Closing the Driver

To complete a LabVIEW application using the AgInfiniiVision driver, it is important to properly close the driver. If the driver is not properly closed, unexpected behavior and resource leaks could result. Moreover, it is important to understand when to close the driver. If multiple VIs within an LabVIEW application need to access the driver, the instantiation and initialization of the driver is typically done in a dedicated VI as is the close operation described in this section. You generally do not open, access, and close an IVI-COM driver within a single LabVIEW VI. Nevertheless, the procedure described here applies to a single VI application and to applications that share a driver instance.

To close the AgInfiniiVision driver

  1. From the Class Browser, choose the Close node from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. Wire the reference out terminal of the last Invoke Node or Property Node in your VI to the reference input of the Close Invoke Node. Also, wire the error clusters together.
  3. Executing the Close method on the driver instructs the driver to release any resources it is holding. It does not, however, tell LabVIEW to dispose of the driver instance. This is accomplished with the Close Reference VI.
  4. Right-click on the reference out terminal of the Close Invoke Node and choose ActiveX Palette and then select Reference Close.
  5. Wire the reference out terminal of the Close Invoke Node to the reference input of the Close Reference VI.
  6. Your simple LabVIEW application using the AgInfiniiVision driver is now complete.


Using MATLAB

Using MATLAB

MATLAB provides rich support for building applications with IVI-COM drivers. Special preconfigured MATLAB classes allow you to access IVI-defined functionality. In addition, for accessing instrument-specific functionality, the AgInfiniiVision driver includes a MATLAB wrapper file that is automatically installed by the AgInfiniiVision driver installer at the following location:

    • For 32 bit platform : \Program Files\IVI Foundation\IVI\Components\MATLAB
    • For 64 bit platform : \Program Files (x86)\IVI Foundation\IVI\Components\MATLAB

Requirements for Using the AgInfiniiVision in MATLAB

The following components are required to be installed (at the time the AgInfiniiVision driver installer runs), in order to use the AgInfiniiVision driver in MATLAB:

  • MATLAB R2012b (32-bit Version only) for both 32 bit and 64 bit platforms
  • MATLAB Instrument Control Toolbox

Accessing Class-Compliant Functionality

Access to class-compliant functionality in an IVI driver is provided by the MATLAB Class objects. You use the appropriate MATLAB Class to create an instrument object. These classes are located in the instrument.ivicom package.

Note: If the class is listed as 'NoClass' below, this driver does not support an IVI instrument class and this section may be disregarded.

The following code demonstrates how to access the 'IviScope' class supported by the AgInfiniiVision driver.

driver = instrument.ivicom.IviScope(‘MyLogicalName’);

Note that in addition to using the logical name to identify the driver to use (as shown in the example above), you can also use the session name or the software module name. Please see the topic Configuring the Driver for information on these additional identifiers.

Accessing Instrument-Specific Functionality

In order to access the instrument-specific functionality of the AgInfiniiVision driver, the driver must be directly referenced. Note that directly referencing the AgInfiniiVision driver provides access to the class-compliant functionality as well. The class for the AgInfiniiVision driver is located in the instrument.driver package.

The following code demonstrates how to directly access the AgInfiniiVision driver.

driver = instrument.driver.AgInfiniiVision();

The DeviceSpecific property is used to gain access to the instrument-specific methods and properties, as shown below.

driver.DeviceSpecific.System.WaitForOperationComplete(2000);

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

MATLAB Copy Code Copy Code
    % Creates a driver object, reads a few Identity interface
    % properties, and checks the instrument error queue.
    %
    % Runs in simulation mode without an instrument.

disp(blanks(1)');
disp('  ML_Example1');
try

    % Create driver instance
    driver = instrument.driver.AgInfiniiVision();

    % Edit resource and options as needed.  Resource is ignored if option Simulate=true
    resourceDesc = 'GPIB0::13::INSTR';

    initOptions = 'QueryInstrStatus=true, Simulate=true, DriverSetup= Model=, Trace=false';
    idquery = true;
    reset   = true;

    driver.Initialize(resourceDesc, idquery, reset, initOptions);
    disp('Driver Initialized');

    % Print a few IIviDriver.Identity properties
    disp(['Identifier:      ', driver.Identity.Identifier]);
    disp(['Revision:        ', driver.Identity.Revision]);
    disp(['Vendor:          ', driver.Identity.Vendor]);
    disp(['Description:     ', driver.Identity.Description]);
    disp(['InstrumentModel: ', driver.Identity.InstrumentModel]);
    disp(['FirmwareRev:     ', driver.Identity.InstrumentFirmwareRevision]);
    disp(blanks(1));

    % TODO: Exercise 'DeviceSpecific' driver methods and properties
    % Example syntax: serNum = driver.DeviceSpecific.System.SerialNumber;

    % Check instrument for errors
    errorNum = -1;
    errorMsg = ('');
    disp(blanks(1)');
    while (errorNum ~= 0)
        [errorNum, errorMsg] = driver.Utility.ErrorQuery();
        disp(['ErrorQuery: ', num2str(errorNum), ', ', errorMsg]);
    end

catch exception
    disp(getReport(exception));
end

if driver.Initialized
    driver.Close();
    disp('Driver Closed');
end

disp('Done');
disp(blanks(1)');

Further Information

To learn more about using MATLAB with IVI instrument drivers, visit:
http://www.mathworks.com/ivi.


IVI-COM Reference

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IVI-COM Reference

The topics in this section document each method and property exposed from the IVI-COM driver. Both a hierarchical and flat view of the AgInfiniiVision driver functionality are available, as is a listing of instrument command strings and their associated driver methods and properties.

In This Section

Driver Hierarchy

Presents a hierarchical view of all driver methods and properties.

Driver Interfaces

Presents the driver functionality in a flat list of interfaces.

Instrument Command Reference

Provides a table associating instrument command strings with driver methods and properties.

Errors and Warnings

Presents all driver errors and warnings.


IVI-COM Hierarchy

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IVI-COM Hierarchy

This section presents the functionality of the AgInfiniiVision driver in hierarchical form. Each link below represents the root of a specific hierarchy exposed by the driver, such as the instrument-specific hierarchy, the inherent capabilities (IIviDriver) hierarchy, etc.

Hierarchies

Root Interface Name
IAgInfiniiVision8
IIviDriver
IIviScope
Top


IAgInfiniiVision8 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8 Interface
See Also

IAgInfiniiVision8 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision8
   Inherits IAgInfiniiVision7
C#
public interface IAgInfiniiVision8 : IAgInfiniiVision7
Visual C++
__interface IAgInfiniiVision8 : IAgInfiniiVision7

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | AnalogBus | Pointer to the IAgInfiniiVision8AnalogBus interface.
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | External2 | Pointer to the IAgInfiniiVisionExternal interface.
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | FRA | Pointer to the IAgInfiniiVision8FRA interface.
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision6.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision6.)
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision6.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Trigger4 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision7.)
Public property | Trigger5 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision6.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Acquisition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Acquisition Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionAcquisition interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition As IAgInfiniiVisionAcquisition
C#
public IAgInfiniiVisionAcquisition  Acquisition { get; }
Visual C++
HRESULT get_Acquisition(
    IAgInfiniiVisionAcquisition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureRecord Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.ConfigureRecord Method
IAgInfiniiVisionAcquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureRecord ( _
    ByVal  TimePerRecord As Double  _
    ByVal  NumberOfPointsMin As Integer  _
    ByVal  StartTime As Double  _
)
C#
public void  ConfigureRecord(
    double  TimePerRecord,
    int  NumberOfPointsMin,
    double  StartTime
)
Visual C++
HRESULT ConfigureRecord(
    double  TimePerRecord,
    long  NumberOfPointsMin,
    double  StartTime
);

Parameters

TimePerRecord

Specifies the time per record. This value sets the Horizontal Time Per Record property.

NumberOfPointsMin

Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.

StartTime

Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


Interpolation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.Interpolation Property
IAgInfiniiVisionAcquisition See Also

The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Interpolation As AgInfiniiVisionInterpolationEnum
C#
public AgInfiniiVisionInterpolationEnum  Interpolation { get; set; }
Visual C++
HRESULT get_Interpolation(
    AgInfiniiVisionInterpolationEnum*  val
);
HRESULT put_Interpolation(
    AgInfiniiVisionInterpolationEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberOfAverages Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.NumberOfAverages Property
IAgInfiniiVisionAcquisition See Also

The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfAverages As Integer
C#
public int  NumberOfAverages { get; set; }
Visual C++
HRESULT get_NumberOfAverages(
    long*  val
);
HRESULT put_NumberOfAverages(
    long  val
);

Remarks

The count of 1 was functionally equivalent to the HRESolution acquisition type, it is no longer supported, select the high-resolution acquisition mode by setting IAgInfiniiVisionAcquisition.Type to HRESolution.

Instrument Command

:ACQuire:COUNt {value}
:ACQuire:COUNt?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberOfPointsMin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.NumberOfPointsMin Property
IAgInfiniiVisionAcquisition See Also

The minimum number of points which can be in a waveform record for each channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfPointsMin As Integer
C#
public int  NumberOfPointsMin { get; set; }
Visual C++
HRESULT get_NumberOfPointsMin(
    long*  val
);
HRESULT put_NumberOfPointsMin(
    long  val
);

Remarks

It configures the record length that the oscilloscope uses for waveform acquisition. If number of minimum points exceeds the permissible value for sample mode then data out of range error is returned.

Instrument Command

:WAVeform:POINts {value}
:WAVeform:POINts?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


RecordLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.RecordLength Property
IAgInfiniiVisionAcquisition See Also

Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property."

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordLength As Integer
C#
public int  RecordLength { get; }
Visual C++
HRESULT get_RecordLength(
    long*  val
);

Instrument Command

:WAVeform:POINts?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


SampleMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.SampleMode Property
IAgInfiniiVisionAcquisition See Also

Read Only - Gets the current acquisition sample mode setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleMode As AgInfiniiVisionSampleModeEnum
C#
public AgInfiniiVisionSampleModeEnum  SampleMode { get; }
Visual C++
HRESULT get_SampleMode(
    AgInfiniiVisionSampleModeEnum*  val
);

Remarks

The time position parameter is usually referenced to the center of the screen, although it can be referenced to the 1st division from the left or right side of the screen. The acquisition start time in driver refers to the left side of the screen. For example if you have set up the instrument for a 1 ms acquisition that starts 5 ms (Acquisition start time) after the trigger, the time position sent to the scope must be offset by 5 (1 or 9) horizontal divisions. The time position reference is center, the range is 1 ms which means the left side is 0.5 x 1ms from the center. The driver will set the time position for 5.5 ms, which will make the left side of the screen = 5 ms.

Instrument Command

:ACQuire:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


SampleRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.SampleRate Property
IAgInfiniiVisionAcquisition See Also

Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleRate As Double
C#
public double  SampleRate { get; }
Visual C++
HRESULT get_SampleRate(
    double*  val
);

Instrument Command

:WAVeform:XINCrement?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


SegmentedMemory Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.SegmentedMemory Property
IAgInfiniiVisionAcquisition See Also

Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SegmentedMemory As IAgInfiniiVisionAcquisitionSegmentedMemory
C#
public IAgInfiniiVisionAcquisitionSegmentedMemory  SegmentedMemory { get; }
Visual C++
HRESULT get_SegmentedMemory(
    IAgInfiniiVisionAcquisitionSegmentedMemory**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


Analyze Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory..::.Analyze Method
IAgInfiniiVisionAcquisitionSegmentedMemory See Also

Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Analyze ( _
)
C#
public void  Analyze(
)
Visual C++
HRESULT Analyze(
);

Instrument Command

:ACQuire:SEGMented:ANALyze

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisitionSegmentedMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory..::.Count Property
IAgInfiniiVisionAcquisitionSegmentedMemory See Also

The number of memory segments to acquire.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Count As Integer
C#
public int  Count { get; set; }
Visual C++
HRESULT get_Count(
    long*  val
);
HRESULT put_Count(
    long  val
);

Instrument Command

:ACQuire:SEGMented:COUNt {value}
:ACQuire:SEGMented:COUNt?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisitionSegmentedMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


Index Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory..::.Index Property
IAgInfiniiVisionAcquisitionSegmentedMemory See Also

The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Index As Integer
C#
public int  Index { get; set; }
Visual C++
HRESULT get_Index(
    long*  val
);
HRESULT put_Index(
    long  val
);

Instrument Command

:ACQuire:SEGMented:INDex {value}
:ACQuire:SEGMented:INDex?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisitionSegmentedMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


SaveOption Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory..::.SaveOption Property
IAgInfiniiVisionAcquisitionSegmentedMemory See Also

The segments to be included when the waveform is saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SaveOption As AgInfiniiVisionMemorySegmentOptionEnum
C#
public AgInfiniiVisionMemorySegmentOptionEnum  SaveOption { get; set; }
Visual C++
HRESULT get_SaveOption(
    AgInfiniiVisionMemorySegmentOptionEnum*  val
);
HRESULT put_SaveOption(
    AgInfiniiVisionMemorySegmentOptionEnum  val
);

Instrument Command

:SAVE:WAVeform:SEGMented {ALL|CURR}
:SAVE:WAVeform:SEGMented?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisitionSegmentedMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeTag Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory..::.TimeTag Property
IAgInfiniiVisionAcquisitionSegmentedMemory See Also

Read Only - Returns the time tag of the currently selected segmented memory index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TimeTag As Double
C#
public double  TimeTag { get; }
Visual C++
HRESULT get_TimeTag(
    double*  val
);

Instrument Command

:WAVeform:SEGMented:TTAG?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisitionSegmentedMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


SingleAcquisition Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.SingleAcquisition Method
IAgInfiniiVisionAcquisition See Also

Acquires a single trigger of data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SingleAcquisition ( _
)
C#
public void  SingleAcquisition(
)
Visual C++
HRESULT SingleAcquisition(
);

Instrument Command

:SINGle

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


StartTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.StartTime Property
IAgInfiniiVisionAcquisition See Also

The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StartTime As Double
C#
public double  StartTime { get; set; }
Visual C++
HRESULT get_StartTime(
    double*  val
);
HRESULT put_StartTime(
    double  val
);

Remarks

The time position parameter is usually referenced to the center of the screen, although it can be referenced to the 1st division from the left or right side of the screen. The acquisition start time in driver refers to the left side of the screen. For example if you have set up the instrument for a 1 ms acquisition that starts 5 ms (Acquisition start time) after the trigger, the time position sent to the scope must be offset by 5 (1 or 9) horizontal divisions. The time position reference is center, the range is 1 ms which means the left side is 0.5 x 1ms from the center. The driver will set the time position for 5.5 ms, which will make the left side of the screen = 5 ms.

Instrument Command

:TIMebase:POSition {value}
:TIMebase:POSition?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


Stop Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.Stop Method
IAgInfiniiVisionAcquisition See Also

Stops the acquisition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Stop ( _
)
C#
public void  Stop(
)
Visual C++
HRESULT Stop(
);

Instrument Command

:STOP

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


TimePerRecord Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.TimePerRecord Property
IAgInfiniiVisionAcquisition See Also

The time in seconds that corresponds to the record length.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimePerRecord As Double
C#
public double  TimePerRecord { get; set; }
Visual C++
HRESULT get_TimePerRecord(
    double*  val
);
HRESULT put_TimePerRecord(
    double  val
);

Instrument Command

:TIMebase:RANGe {value}
:TIMebase:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition..::.Type Property
IAgInfiniiVisionAcquisition See Also

Type of acquisition data oscilloscope uses to fill the waveform record.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionAcquisitionTypeEnum
C#
public AgInfiniiVisionAcquisitionTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionAcquisitionTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionAcquisitionTypeEnum  val
);

Instrument Command

:ACQuire:TYPE {NORM|PEAK|HRES|AVER}
:ACQuire:TYPE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionAcquisition Interface
Agilent.AgInfiniiVision.Interop Namespace


Acquisition2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.Acquisition2 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionAcquisition interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition2 As IAgInfiniiVisionAcquisition2
C#
public IAgInfiniiVisionAcquisition2  Acquisition2 { get; }
Visual C++
HRESULT get_Acquisition2(
    IAgInfiniiVisionAcquisition2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


ReferenceSignal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition2..::.ReferenceSignal Property
IAgInfiniiVisionAcquisition2 See Also

Selects the 10 MHz Reference Signal Mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ReferenceSignal As AgInfiniiVisionAcquisitionReferenceSignalModeEnum
C#
public AgInfiniiVisionAcquisitionReferenceSignalModeEnum  ReferenceSignal { get; set; }
Visual C++
HRESULT get_ReferenceSignal(
    AgInfiniiVisionAcquisitionReferenceSignalModeEnum*  val
);
HRESULT put_ReferenceSignal(
    AgInfiniiVisionAcquisitionReferenceSignalModeEnum  val
);

Instrument Command

:ACQuire:RSIGnal {IN|OUT|OFF}
:ACQuire:RSIGnal?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionAcquisition2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Acquisition3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Acquisition3 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVisionAcquisition interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition3 As IAgInfiniiVisionAcquisition3
C#
public IAgInfiniiVisionAcquisition3  Acquisition3 { get; }
Visual C++
HRESULT get_Acquisition3(
    IAgInfiniiVisionAcquisition3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSampleMode Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition3..::.SetSampleMode Method
IAgInfiniiVisionAcquisition3 See Also

Sets the acquisition mode of the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSampleMode ( _
    ByVal  Mode As AgInfiniiVisionSampleModeEnum  _
)
C#
public void  SetSampleMode(
    AgInfiniiVisionSampleModeEnum  Mode
)
Visual C++
HRESULT SetSampleMode(
    AgInfiniiVisionSampleModeEnum  Mode
);

Parameters

Mode

The acquisition sampling mode.

Remarks

  • AgInfiniiVisionSampleModeRealTime: The Real time mode Specifies that the oscilloscope produce the waveform display from samples collected during one trigger event (that is, one acquisition). At fast sweep speeds, when not enough samples can be collected for a waveform, a sophisticated reconstruction filter is used to fill-in sample points and enhance the waveform display. In Real time mode, to accurately reproduce a sampled waveform, the sample rate should be at least 2.5 times the highest frequency component of the waveform. If not, it is possible for the reconstructed waveform to be distorted or aliased. Aliasing is most commonly seen as jitter on fast digital edges. Use Real time sampling to capture infrequent triggers, unstable triggers, or complex changing waveforms, such as eye diagrams.
  • AgInfiniiVisionSampleModeMaxRealTime: The Maximum update rate real time mode is the same as Realtime except that in order to provide maximum update rate (trigger rates), the sample rate drops from 20 GSa/s to 2 GSa/s at a faster time/div setting than normal. This mode is ideal for finding glitches and infrequent events in waveforms that do not require the full 20 GSa/s sample rate (and associated bandwidth). This mode is not allowed in single, roll, segmented, mask test, or zone trigger.
  • AgInfiniiVisionSampleModeEquivalentTime: The equivalent time sampling mode is Available in 6 GHz bandwidth models, this option gives you another way to fill-in sample points at fast sweep speeds - it is used only when sweep speeds are 20 ns/div or faster. In this case, instead of a reconstruction filter, a technique known as random repetitive sampling is used to build-up and draw one waveform using multiple triggers (acquisitions). At slower sweep speeds, there are enough sample points in a trigger (acquisition, in other words) to render a waveform on the display. Equivalent time sampling mode requires a repetitive waveform with a stable trigger.
  • AgInfiniiVisionSampleModeSegmented: The segmented mode sets the oscilloscope in segmented memory mode.

    • Instrument Command

    :ACQuire:MODE {RTIM|SEGM|ETIM|MRT}

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionAcquisition3 Interface
    Agilent.AgInfiniiVision.Interop Namespace


AnalogBus Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8..::.AnalogBus Property
IAgInfiniiVision8 See Also

Pointer to the IAgInfiniiVision8AnalogBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AnalogBus As IAgInfiniiVision8AnalogBus
C#
public IAgInfiniiVision8AnalogBus  AnalogBus { get; }
Visual C++
HRESULT get_AnalogBus(
    IAgInfiniiVision8AnalogBus**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision8 Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.Clear Method
IAgInfiniiVision8AnalogBus See Also

Excludes all of the analog channels from the selected bus definition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
)
C#
public void  Clear(
)
Visual C++
HRESULT Clear(
);

Instrument Command

:ABUS:CLEar

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.Enabled Property
IAgInfiniiVision8AnalogBus See Also

It enables or disables the view of the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:ABUS:DISPlay {ON|OFF}
:ABUS:DISPlay?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


GetBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.GetBit Method
IAgInfiniiVision8AnalogBus See Also

Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetBit ( _
    ByVal  Bit As Short  _
) As Boolean
C#
public bool  GetBit(
    short  Bit
)
Visual C++
HRESULT GetBit(
    short  Bit
    VARIANT_BOOL*  retval
);

Parameters

Bit

Digital bit to be included in bus definition

Return Value

0 or 1

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BIT{Bit}?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


GetBits Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.GetBits Method
IAgInfiniiVision8AnalogBus See Also

Returns the definition for the specified bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetBits ( _
) As String
C#
public string  GetBits(
)
Visual C++
HRESULT GetBits(
    BSTR*  retval
);

Return Value

Definition in String format.

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BITS?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.Label Property
IAgInfiniiVision8AnalogBus See Also

The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Remarks

  • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters.

    • Instrument Command

    :ABUS:LABel "{value}"
    :ABUS:LABel?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    IAgInfiniiVision8AnalogBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.SetBit Method
IAgInfiniiVision8AnalogBus See Also

Includes/Excludes the selected bit as part of the definition for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetBit ( _
    ByVal  Bits As Short  _
    ByVal  BitState As Boolean  _
)
C#
public void  SetBit(
    short  Bits,
    bool  BitState
)
Visual C++
HRESULT SetBit(
    short  Bits,
    VARIANT_BOOL  BitState
);

Parameters

Bits

DigitalBit(0-15) to be included/excluded in the bus

BitState

Flag indicating bit is enabled or disabled

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BIT{Bits} {1|0}

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SetBits Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus..::.SetBits Method
IAgInfiniiVision8AnalogBus See Also

Includes/Excludes the selected bits in the channel list in the definition of the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetBits ( _
    ByVal  ChannelList As String  _
    ByVal  BitState As Boolean  _
)
C#
public void  SetBits(
    string  ChannelList,
    bool  BitState
)
Visual C++
HRESULT SetBits(
    BSTR  ChannelList,
    VARIANT_BOOL  BitState
);

Parameters

ChannelList

Channel List containing bits to be included/excluded in the bus definition

BitState

Flag indicating bit is enabled or disabled

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BITS (@{ChannelList}),{1|0}

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVision8AnalogBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Calibration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Calibration Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionCalibration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Calibration As IAgInfiniiVisionCalibration
C#
public IAgInfiniiVisionCalibration  Calibration { get; }
Visual C++
HRESULT get_Calibration(
    IAgInfiniiVisionCalibration**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Calibrate Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Calibrate Method
IAgInfiniiVisionCalibration See Also

Starts the user calibration procedure. See the User's Guide for details.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Calibrate ( _
)
C#
public void  Calibrate(
)
Visual C++
HRESULT Calibrate(
);

Instrument Command

:CALibrate:STARt

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Date Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Date Property
IAgInfiniiVisionCalibration See Also

Read Only - Gets the date of the last calibration.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Date As String
C#
public string  Date { get; }
Visual C++
HRESULT get_Date(
    BSTR*  val
);

Instrument Command

:CALibrate:DATE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Enabled Property
IAgInfiniiVisionCalibration See Also

Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Enabled As AgInfiniiVisionCalibrationProtectionEnum
C#
public AgInfiniiVisionCalibrationProtectionEnum  Enabled { get; }
Visual C++
HRESULT get_Enabled(
    AgInfiniiVisionCalibrationProtectionEnum*  val
);

Instrument Command

:CALibrate:PROTected?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Label Property
IAgInfiniiVisionCalibration See Also

Calibration string(up to 32 characters not including the quotes).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Instrument Command

:CALibrate:LABel "{value}"
:CALibrate:LABel?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Result Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Result Method
IAgInfiniiVisionCalibration See Also

Read Only- Summary results of the last user calibration procedure.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Result ( _
    ByRef  StatusCode As Integer  _
    ByRef  StatusString As String  _
)
C#
public void  Result(
    ref int  StatusCode,
    ref string  StatusString
)
Visual C++
HRESULT Result(
    long*  StatusCode,
    BSTR*  StatusString
);

Parameters

StatusCode

An integer status code.

StatusString

ASCII status string.

Instrument Command

:CALibrate:STATus?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


SignalSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.SignalSource Property
IAgInfiniiVisionCalibration See Also

Signal on the rear panel trigger out BNC.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SignalSource As AgInfiniiVisionCalibrationSignalSourceEnum
C#
public AgInfiniiVisionCalibrationSignalSourceEnum  SignalSource { get; set; }
Visual C++
HRESULT get_SignalSource(
    AgInfiniiVisionCalibrationSignalSourceEnum*  val
);
HRESULT put_SignalSource(
    AgInfiniiVisionCalibrationSignalSourceEnum  val
);

Remarks

  • AgInfiniiVisionCalibrationSignalSourceWaveGen2 is only available on models with 2 WaveGen outputs.
  • AgInfiniiVisionCalibrationSignalSourceOff is only supported by 1000X, M924x and P924x.
  • AgInfiniiVisionCalibrationSignalSourceTrigSource is only supported by 3000T, 4000X, M924x and P924x.
  • AgInfiniiVisionCalibrationSignalSourceNFC is only supported by 3000T, 4000X, 6000X, M924x and P924x.

    • Instrument Command

    :CALibrate:OUTPut {TRIG|MASK|WAVE|WGEN2|OFF|TSOurce|NFC}
    :CALibrate:OUTPut?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionCalibration Interface
    Agilent.AgInfiniiVision.Interop Namespace


Temperature Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Temperature Property
IAgInfiniiVisionCalibration See Also

Read Only - Change in temperature since the last user calibration procedure.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Temperature As Double
C#
public double  Temperature { get; }
Visual C++
HRESULT get_Temperature(
    double*  val
);

Instrument Command

:CALibrate:TEMPerature?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Time Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration..::.Time Property
IAgInfiniiVisionCalibration See Also

Read Only - Time of the last calibration.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Time As String
C#
public string  Time { get; }
Visual C++
HRESULT get_Time(
    BSTR*  val
);

Instrument Command

:CALibrate:TIME?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCalibration Interface
Agilent.AgInfiniiVision.Interop Namespace


Channels Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Channels Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionChannels interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels As IAgInfiniiVisionChannels
C#
public IAgInfiniiVisionChannels  Channels { get; }
Visual C++
HRESULT get_Channels(
    IAgInfiniiVisionChannels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannels..::.Count Property
IAgInfiniiVisionChannels See Also

Read Only - Returns the number of Channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannels..::.Item Property
IAgInfiniiVisionChannels See Also

Pointer to the IAgInfiniiVisionChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVisionChannel
C#
public IAgInfiniiVisionChannel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVisionChannel**  val
);

Parameters

Name

The name of a Channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


ClearProtection Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ClearProtection Method
IAgInfiniiVisionChannel See Also

Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ClearProtection ( _
)
C#
public void  ClearProtection(
)
Visual C++
HRESULT ClearProtection(
);

Instrument Command

:CHANnel{Channel}:PROTection

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Configure Method
IAgInfiniiVisionChannel See Also

Configures the range, offset, coupling, probe attenuation, and channel enabled state of the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Range As Double  _
    ByVal  Offset As Double  _
    ByVal  Coupling As AgInfiniiVisionVerticalCouplingEnum  _
    ByVal  ProbeAttenuation As Double  _
    ByVal  Enabled As Boolean  _
)
C#
public void  Configure(
    double  Range,
    double  Offset,
    AgInfiniiVisionVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    bool  Enabled
)
Visual C++
HRESULT Configure(
    double  Range,
    double  Offset,
    AgInfiniiVisionVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    VARIANT_BOOL  Enabled
);

Parameters

Range

Specifies the vertical range. This value sets the Vertical Range property.

Offset

Specifies the vertical offset. This value sets the Vertical Offset property.

Coupling

Specifies how to couple the input signal.

ProbeAttenuation

Specifies the probe attenuation. This value sets the Probe Attenuation property.

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled property.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureCharacteristics Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ConfigureCharacteristics Method
IAgInfiniiVisionChannel See Also

Configures the input impedance and the maximum frequency of the input signal which control the electrical characteristics of the channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureCharacteristics ( _
    ByVal  InputImpedance As Double  _
    ByVal  InputFrequencyMax As Double  _
)
C#
public void  ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
)
Visual C++
HRESULT ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
);

Parameters

InputImpedance

The input impedance for the channel. The driver sets the Input Impedance to this value.

InputFrequencyMax

The maximum input frequency for the channel. The driver sets the Max Input Frequency to this value.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Coupling Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Coupling Property
IAgInfiniiVisionChannel See Also

Coupling of the input signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As AgInfiniiVisionVerticalCouplingEnum
C#
public AgInfiniiVisionVerticalCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    AgInfiniiVisionVerticalCouplingEnum*  val
);
HRESULT put_Coupling(
    AgInfiniiVisionVerticalCouplingEnum  val
);

Instrument Command

:CHANnel{Channel}:COUPling {AC|DC}
:CHANnel{Channel}:COUPling?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Enabled Property
IAgInfiniiVisionChannel See Also

If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:CHANnel{Channel}:DISPlay {ON|OFF}
:CHANnel{Channel}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


InputFrequencyMax Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.InputFrequencyMax Property
IAgInfiniiVisionChannel See Also

The maximum input frequency of the channel. It is the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InputFrequencyMax As Double
C#
public double  InputFrequencyMax { get; set; }
Visual C++
HRESULT get_InputFrequencyMax(
    double*  val
);
HRESULT put_InputFrequencyMax(
    double  val
);

Remarks

  • For 6000x series this property sets the bandwidth limit value and turns on bandwidth limiting.
  • You can request any limit; the oscilloscope will choose the one that is greater than or equal to the limit requested. The limits available depend on the bandwidth of oscilloscope, the channel's input impedance setting, and the channel's V/div setting, as shown below in the table:

    • Input Impedance | V/div | Oscilloscope Bandwidth | Limits Available
1M Ohm | >2 mV/div | (all) | 20 MHz
 | <=2 mV/div | (all) | 20 MHz or 200 MHz
50 Ohm | (all) | 1 GHz | 20 MHz or 200 MHz
 |  | 2.5 GHz | 20 MHz, 200 MHz, or 1.5 GHz
 |  | 4 GHz | 20 MHz, 200 MHz, 1.5 GHz, or 3 GHz
 |  | 6 GHz | 20 MHz, 200 MHz, 1.5 GHz, or 3 GHz

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


InputImpedance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.InputImpedance Property
IAgInfiniiVisionChannel See Also

The input impedance of the channel. The units are ohms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InputImpedance As Double
C#
public double  InputImpedance { get; set; }
Visual C++
HRESULT get_InputImpedance(
    double*  val
);
HRESULT put_InputImpedance(
    double  val
);

Remarks

The legal values are 1E6 ohm for 2000X, and 1E6 and 50 ohm for 3000X series.

Instrument Command

:CHANnel{Channel}:IMPedance {value}
:CHANnel{Channel}:IMPedance?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Invert Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Invert Property
IAgInfiniiVisionChannel See Also

Inverts the input signal for the specified channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Invert As Boolean
C#
public bool  Invert { get; set; }
Visual C++
HRESULT get_Invert(
    VARIANT_BOOL*  val
);
HRESULT put_Invert(
    VARIANT_BOOL  val
);

Instrument Command

:CHANnel{Channel}:INVert {ON|OFF}
:CHANnel{Channel}:INVert?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Label Property
IAgInfiniiVisionChannel See Also

The analog channel label.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Remarks

  • For 2000X Family

    • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters. Lower case characters are converted to upper case.

  • For 3000X, 4000X and 6000X families.

    • Label strings are 32 characters or less, and may contain any commonly used ASCII characters. Labels with more than 32 characters are truncated to 32 characters. Lower case characters are converted to upper case.

    Instrument Command

    :CHANnel{Channel}:LABel "{value}"
    :CHANnel{Channel}:LABel?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Offset Property
IAgInfiniiVisionChannel See Also

The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Instrument Command

:CHANnel{Channel}:OFFSet {value}
:CHANnel{Channel}:OFFSet?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeAttenuation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ProbeAttenuation Property
IAgInfiniiVisionChannel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ProbeAttenuation As Double
C#
public double  ProbeAttenuation { get; set; }
Visual C++
HRESULT get_ProbeAttenuation(
    double*  val
);
HRESULT put_ProbeAttenuation(
    double  val
);

Instrument Command

:CHANnel{Channel}:PROBe {value}
:CHANnel{Channel}:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ProbeID Property
IAgInfiniiVisionChannel See Also

Read Only - Type of probe attached to the specified oscilloscope channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeID As String
C#
public string  ProbeID { get; }
Visual C++
HRESULT get_ProbeID(
    BSTR*  val
);

Instrument Command

:CHANnel{Channel}:PROBe:ID?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeSense Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ProbeSense Property
IAgInfiniiVisionChannel See Also

Read Only - The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeSense As Double
C#
public double  ProbeSense { get; }
Visual C++
HRESULT get_ProbeSense(
    double*  val
);

Instrument Command

:CHANnel{Channel}:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeSkew Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.ProbeSkew Property
IAgInfiniiVisionChannel See Also

Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ProbeSkew As Double
C#
public double  ProbeSkew { get; set; }
Visual C++
HRESULT get_ProbeSkew(
    double*  val
);
HRESULT put_ProbeSkew(
    double  val
);

Instrument Command

:CHANnel{Channel}:PROBe:SKEW {value}
:CHANnel{Channel}:PROBe:SKEW?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Protection Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Protection Property
IAgInfiniiVisionChannel See Also

Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Protection As AgInfiniiVisionChannelProtectionEnum
C#
public AgInfiniiVisionChannelProtectionEnum  Protection { get; }
Visual C++
HRESULT get_Protection(
    AgInfiniiVisionChannelProtectionEnum*  val
);

Instrument Command

:CHANnel{Channel}:PROTection?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Range Property
IAgInfiniiVisionChannel See Also

The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

When using 1:1 probe attenuation, legal values for the range are from 16 mV to 40 V

Instrument Command

:CHANnel{Channel}:RANGe {value}
:CHANnel{Channel}:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Scale Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Scale Property
IAgInfiniiVisionChannel See Also

Vertical scale, or units per division, of the selected channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Scale As Double
C#
public double  Scale { get; set; }
Visual C++
HRESULT get_Scale(
    double*  val
);
HRESULT put_Scale(
    double  val
);

Remarks

When using 1:1 probe attenuation, legal values for the scale are from 2 mV to 5 V

Instrument Command

:CHANnel{Channel}:SCALe {value}
:CHANnel{Channel}:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Units Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel..::.Units Property
IAgInfiniiVisionChannel See Also

Measurement units for the connected probe.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Units As AgInfiniiVisionChannelUnitsEnum
C#
public AgInfiniiVisionChannelUnitsEnum  Units { get; set; }
Visual C++
HRESULT get_Units(
    AgInfiniiVisionChannelUnitsEnum*  val
);
HRESULT put_Units(
    AgInfiniiVisionChannelUnitsEnum  val
);

Instrument Command

:CHANnel{Channel}:UNITs {VOLT|AMP}
:CHANnel{Channel}:UNITs?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannels..::.Name Property
IAgInfiniiVisionChannels See Also

Read Only - Returns the Channel name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of Channels.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockRecovery Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.ClockRecovery Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVision4ClockRecovery interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ClockRecovery As IAgInfiniiVision4ClockRecovery
C#
public IAgInfiniiVision4ClockRecovery  ClockRecovery { get; }
Visual C++
HRESULT get_ClockRecovery(
    IAgInfiniiVision4ClockRecovery**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


DisplayEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4ClockRecovery..::.DisplayEnabled Property
IAgInfiniiVision4ClockRecovery See Also

Enable or disable the display of the recovered clock.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DisplayEnabled As Boolean
C#
public bool  DisplayEnabled { get; set; }
Visual C++
HRESULT get_DisplayEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DisplayEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Preset value is false.

    • Instrument Command

    :CLOCk {1|0}
    :CLOCk?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4ClockRecovery Interface
    Agilent.AgInfiniiVision.Interop Namespace


GetMethod Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4ClockRecovery..::.GetMethod Method
IAgInfiniiVision4ClockRecovery See Also

Returns the currently selected clock recovery method.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetMethod ( _
    ByRef  ClockMethod As AgInfiniiVisionClockRecoveryMethodEnum  _
    ByRef  DataRate As Double  _
    ByRef  LoopBandwidth As Double  _
    ByRef  DampingFactor As Double  _
    ByRef  Source As String  _
    ByRef  Slope As AgInfiniiVisionEdgeSlopeEnum  _
    ByRef  Multiplier As Integer  _
)
C#
public void  GetMethod(
    ref AgInfiniiVisionClockRecoveryMethodEnum  ClockMethod,
    ref double  DataRate,
    ref double  LoopBandwidth,
    ref double  DampingFactor,
    ref string  Source,
    ref AgInfiniiVisionEdgeSlopeEnum  Slope,
    ref int  Multiplier
)
Visual C++
HRESULT GetMethod(
    AgInfiniiVisionClockRecoveryMethodEnum*  ClockMethod,
    double*  DataRate,
    double*  LoopBandwidth,
    double*  DampingFactor,
    BSTR*  Source,
    AgInfiniiVisionEdgeSlopeEnum*  Slope,
    long*  Multiplier
);

Parameters

ClockMethod

Currently selected clock method.

DataRate

The data signal's expected bits/second rate. This value is not valid when clock method is AgInfiniiVisionClockMethodExplicit.

LoopBandwidth

The -3 dB bandwidth specification of PLL. This value is only valid when clock method is AgInfiniiVisionClockMethodFirstOrderPLL or AgInfiniiVisionClockMethodSecondOrderPLL.

DampingFactor

The PLL's observed jitter transfer function. This value is only valid when clock method is AgInfiniiVisionClockMethodSecondOrderPLL.

Source

Explicit clock source, CHANnel1 to number of analog channels. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Slope

Slope. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Multiplier

Explicit clock multiplier from 1 to 1000. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Instrument Command

:CLOCk:METHod?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4ClockRecovery Interface
Agilent.AgInfiniiVision.Interop Namespace


SetMethod Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4ClockRecovery..::.SetMethod Method
IAgInfiniiVision4ClockRecovery See Also

Sets the clock recovery method.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetMethod ( _
    ByVal  ClockMethod As AgInfiniiVisionClockRecoveryMethodEnum  _
    ByVal  DataRate As Double  _
    ByVal  LoopBandwidth As Double  _
    ByVal  DampingFactor As Double  _
    ByVal  Source As String  _
    ByVal  Slope As AgInfiniiVisionEdgeSlopeEnum  _
    ByVal  Multiplier As Integer  _
)
C#
public void  SetMethod(
    AgInfiniiVisionClockRecoveryMethodEnum  ClockMethod,
    double  DataRate,
    double  LoopBandwidth,
    double  DampingFactor,
    string  Source,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    int  Multiplier
)
Visual C++
HRESULT SetMethod(
    AgInfiniiVisionClockRecoveryMethodEnum  ClockMethod,
    double  DataRate,
    double  LoopBandwidth,
    double  DampingFactor,
    BSTR  Source,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    long  Multiplier
);

Parameters

ClockMethod

Currently selected clock method.

DataRate

The data signal's expected bits/second rate. This value is not valid when clock method is AgInfiniiVisionClockMethodExplicit.

LoopBandwidth

The -3 dB bandwidth specification of PLL. This value is only valid when clock method is AgInfiniiVisionClockMethodFirstOrderPLL or AgInfiniiVisionClockMethodSecondOrderPLL.

DampingFactor

The PLL's observed jitter transfer function. This value is only valid when clock method is AgInfiniiVisionClockMethodSecondOrderPLL.

Source

Explicit clock source, CHANnel1 to number of analog channels. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Slope

Slope. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Multiplier

Explicit clock multiplier from 1 to 1000. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Instrument Command

:CLOCk:METHod {FIXed|AUTO|SEMI|FOPL|SOPL|EXPlicit}, {DataRate}, {LoopBandwidth}, {DampingFactor}, {Source}, {RISing|FALLing|BOTH}, {Multiplier}

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4ClockRecovery Interface
Agilent.AgInfiniiVision.Interop Namespace


Close Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.Close Method
IIviDriver See Also

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Close ( _
)
C#
public void  Close(
)
Visual C++
HRESULT Close(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Counter Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Counter Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVision4Counter interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Counter As IAgInfiniiVision4Counter
C#
public IAgInfiniiVision4Counter  Counter { get; }
Visual C++
HRESULT get_Counter(
    IAgInfiniiVision4Counter**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Configure Method
IAgInfiniiVision4Counter See Also

This method sets the Counter mode, source and Number of digits of resolution.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Mode As AgInfiniiVisionCounterModeEnum  _
    ByVal  NumberOfDigits As Integer  _
    ByVal  Source As String  _
    ByVal  TotalizeSlope As AgInfiniiVisionCounterTotalizerPolarityEnum  _
)
C#
public void  Configure(
    AgInfiniiVisionCounterModeEnum  Mode,
    int  NumberOfDigits,
    string  Source,
    AgInfiniiVisionCounterTotalizerPolarityEnum  TotalizeSlope
)
Visual C++
HRESULT Configure(
    AgInfiniiVisionCounterModeEnum  Mode,
    long  NumberOfDigits,
    BSTR  Source,
    AgInfiniiVisionCounterTotalizerPolarityEnum  TotalizeSlope
);

Parameters

Mode

The counter mode.

NumberOfDigits

The number of digits of resolution used for the frequency or period counter. This parameter can be used when Mode parameter is set to AgInfiniiVisionCounterModeFrequency and AgInfiniiVisionCounterModePeriod.

Source

The waveform source that the counter measures. Input value can be from Channel1 to number of analog channels or TQEvent.

TotalizeSlope

Specifies whether positive or negative edges are counted. This parameter can be used when Mode parameter is set to AgInfiniiVisionCounterModeTotalize.

Remarks

For 4000X series IAgInfiniiVision4Counter.NumberOfDigits is a read only property. So IAgInfiniiVision4Counter.Configure will skip to set IAgInfiniiVision4Counter.NumberOfDigits.

Instrument Command

:COUNter:MODE {FREQuency|PERiod|TOTalize};:COUNter:NDIGits {NumberOfDigits};:COUNter:SOURce {Source};:COUNter:TOTalize:SLOPe {NEGative|POSitive}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision4Counter Interface
Agilent.AgInfiniiVision.Interop Namespace


Current Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Current Property
IAgInfiniiVision4Counter See Also

Read Only - the current counter value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Current As Double
C#
public double  Current { get; }
Visual C++
HRESULT get_Current(
    double*  val
);

Instrument Command

:COUNter:CURRent?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision4Counter Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Enabled Property
IAgInfiniiVision4Counter See Also

Enables or disables the counter feature.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • Preset value is false.

    • Instrument Command

    :COUNter:ENABle {1|0}
    :COUNter:ENABle?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4Counter Interface
    Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Mode Property
IAgInfiniiVision4Counter See Also

The counter mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionCounterModeEnum
C#
public AgInfiniiVisionCounterModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionCounterModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionCounterModeEnum  val
);

Remarks

  • Preset value is AfInfiniiVisionCounterFrequency.

    • Instrument Command

    :COUNter:MODE {FREQuency|PERiod|TOTalize}
    :COUNter:MODE?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4Counter Interface
    Agilent.AgInfiniiVision.Interop Namespace


NumberOfDigits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.NumberOfDigits Property
IAgInfiniiVision4Counter See Also

The number of digits of resolution used for the frequency or period counter.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfDigits As Integer
C#
public int  NumberOfDigits { get; set; }
Visual C++
HRESULT get_NumberOfDigits(
    long*  val
);
HRESULT put_NumberOfDigits(
    long  val
);

Remarks

  • For 3000T, M924x and P924x series Input range is 3 to 8 digits.
  • For 4000X series this property is read only.
  • For 6000X series Input range is 3 to 10 digits.
  • Preset value is 5.
  • Higher resolutions require longer gate times, which cause the measurement times to be longer as well.

    • Instrument Command

    :COUNter:NDIGits {value}
    :COUNter:NDIGits?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4Counter Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Source Property
IAgInfiniiVision4Counter See Also

The waveform source that the counter measures.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

  • Input value can be from Channel1 to number of analog channels or TQEvent.
  • Input value TQEvent is not available when Trigger type is edge.
  • Preset value is Channel1.

    • Instrument Command

    :COUNter:SOURce {value}
    :COUNter:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4Counter Interface
    Agilent.AgInfiniiVision.Interop Namespace


Totalizer Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter..::.Totalizer Property
IAgInfiniiVision4Counter See Also

Pointer to the IAgInfiniiVision4CounterTotalizer interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Totalizer As IAgInfiniiVision4CounterTotalizer
C#
public IAgInfiniiVision4CounterTotalizer  Totalizer { get; }
Visual C++
HRESULT get_Totalizer(
    IAgInfiniiVision4CounterTotalizer**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4Counter Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizer..::.Clear Method
IAgInfiniiVision4CounterTotalizer See Also

Zeros the edge event counter.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
)
C#
public void  Clear(
)
Visual C++
HRESULT Clear(
);

Instrument Command

:COUNter:TOTalize:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision4CounterTotalizer Interface
Agilent.AgInfiniiVision.Interop Namespace


Gating Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizer..::.Gating Property
IAgInfiniiVision4CounterTotalizer See Also

Pointer to the IAgInfiniiVision4CounterTotalizerGating interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Gating As IAgInfiniiVision4CounterTotalizerGating
C#
public IAgInfiniiVision4CounterTotalizerGating  Gating { get; }
Visual C++
HRESULT get_Gating(
    IAgInfiniiVision4CounterTotalizerGating**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4CounterTotalizer Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizerGating..::.Configure Method
IAgInfiniiVision4CounterTotalizerGating See Also

This method sets the totalize gated source and polarity.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Polarity As AgInfiniiVisionCounterTotalizerPolarityEnum  _
    ByVal  Source As String  _
)
C#
public void  Configure(
    AgInfiniiVisionCounterTotalizerPolarityEnum  Polarity,
    string  Source
)
Visual C++
HRESULT Configure(
    AgInfiniiVisionCounterTotalizerPolarityEnum  Polarity,
    BSTR  Source
);

Parameters

Polarity

The gating signal condition under which totalizer edges are counted.

Source

The analog channel that has the totalizer gating signal. Input value can be from Channel1 to number of analog channels.

Instrument Command

:COUNter:TOTalize:GATE:POLarity {NEGative|POSitive};:COUNter:TOTalize:GATE:SOURce {Source}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision4CounterTotalizerGating Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizerGating..::.Enabled Property
IAgInfiniiVision4CounterTotalizerGating See Also

Enables or disables totalizer gating.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • When totalizer gating is enabled, the totalizer only counts edges when a second gating signal polarity is true. The second gating signal can be one of the remaining analog channel inputs.
  • Preset value is false.

    • Instrument Command

    :COUNter:TOTalize:GATE:ENABle {1|0}
    :COUNter:TOTalize:GATE:ENABle?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4CounterTotalizerGating Interface
    Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizerGating..::.Polarity Property
IAgInfiniiVision4CounterTotalizerGating See Also

The gating signal condition under which totalizer edges are counted.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionCounterTotalizerPolarityEnum
C#
public AgInfiniiVisionCounterTotalizerPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionCounterTotalizerPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionCounterTotalizerPolarityEnum  val
);

Remarks

  • The gating signal is specified with the IAgInfiniiVision4CounterTotalizeGated.Source property.
  • Preset value is AgInfiniiVisionTotalizeEventPolarityPositive.

    • Instrument Command

    :COUNter:TOTalize:GATE:POLarity {NEGative|POSitive}
    :COUNter:TOTalize:GATE:POLarity?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4CounterTotalizerGating Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizerGating..::.Source Property
IAgInfiniiVision4CounterTotalizerGating See Also

The analog channel that has the totalizer gating signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

  • Input value can be from Channel1 to number of analog channels, other than the Channel selected as Countersource using IAgInfiniiVision4Counter.Source property.

    • Instrument Command

    :COUNter:TOTalize:GATE:SOURce {value}
    :COUNter:TOTalize:GATE:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4CounterTotalizerGating Interface
    Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizer..::.Slope Property
IAgInfiniiVision4CounterTotalizer See Also

Specifies whether positive or negative edges are counted.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionCounterTotalizerPolarityEnum
C#
public AgInfiniiVisionCounterTotalizerPolarityEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionCounterTotalizerPolarityEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionCounterTotalizerPolarityEnum  val
);

Remarks

  • Preset value is AgInfiniiVisionCounterTotalizeEventPolarityPositive.

    • Instrument Command

    :COUNter:TOTalize:SLOPe {NEGative|POSitive}
    :COUNter:TOTalize:SLOPe?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision4CounterTotalizer Interface
    Agilent.AgInfiniiVision.Interop Namespace


Cursors Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Cursors Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionCursors interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Cursors As IAgInfiniiVisionCursors
C#
public IAgInfiniiVisionCursors  Cursors { get; }
Visual C++
HRESULT get_Cursors(
    IAgInfiniiVisionCursors**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.Mode Property
IAgInfiniiVisionCursors See Also

The cursors mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionCursorsModeEnum
C#
public AgInfiniiVisionCursorsModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionCursorsModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionCursorsModeEnum  val
);

Instrument Command

:MARKer:MODE {OFF|MEAS|MAN|WAV|BIN|HEX}
:MARKer:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


X1Position Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.X1Position Property
IAgInfiniiVisionCursors See Also

Specifies the X1 cursor position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property X1Position As Double
C#
public double  X1Position { get; set; }
Visual C++
HRESULT get_X1Position(
    double*  val
);
HRESULT put_X1Position(
    double  val
);

Instrument Command

:MARKer:X1Position {value}
:MARKer:X1Position?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


X1Y1Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.X1Y1Source Property
IAgInfiniiVisionCursors See Also

The source for the cursors. The channel you specify must be enabled for cursors to be displayed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property X1Y1Source As String
C#
public string  X1Y1Source { get; set; }
Visual C++
HRESULT get_X1Y1Source(
    BSTR*  val
);
HRESULT put_X1Y1Source(
    BSTR  val
);

Remarks

Allowed values are:

"Channel<n>"

"FUNC" (for 1000X/2000X/3000X)

"Math<n>" (for 3000T/4000X/6000X/M924x/P924x)

"Histogram" (for 6000X)

  • If all channels are off or if mode is set to OFF, the query returns NONE.
  • The channel you specify must be enabled for cursors to be displayed, if the channel or function is not on, an error message is issued.

    • Instrument Command

    :MARKer:X1Y1source {value}
    :MARKer:X1Y1source?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionCursors Interface
    Agilent.AgInfiniiVision.Interop Namespace


X2Position Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.X2Position Property
IAgInfiniiVisionCursors See Also

Specifies the X2 cursor position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property X2Position As Double
C#
public double  X2Position { get; set; }
Visual C++
HRESULT get_X2Position(
    double*  val
);
HRESULT put_X2Position(
    double  val
);

Instrument Command

:MARKer:X2Position {value}
:MARKer:X2Position?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


X2Y2Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.X2Y2Source Property
IAgInfiniiVisionCursors See Also

The source for the cursors. The channel you specify must be enabled for cursors to be displayed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property X2Y2Source As String
C#
public string  X2Y2Source { get; set; }
Visual C++
HRESULT get_X2Y2Source(
    BSTR*  val
);
HRESULT put_X2Y2Source(
    BSTR  val
);

Remarks

  • Allowed values are Channel<n>, FUNC (for 1000X/2000X/3000X), Math<n> (for 4000X), WMEM<n> and Histogram.
  • If all channels are off or if mode is set to OFF, the query returns NONE.

    • Instrument Command

    :MARKer:X2Y2source {value}
    :MARKer:X2Y2source?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionCursors Interface
    Agilent.AgInfiniiVision.Interop Namespace


XDelta Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.XDelta Property
IAgInfiniiVisionCursors See Also

Read Only - The value difference between the current X1 and X2 cursor positions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property XDelta As Double
C#
public double  XDelta { get; }
Visual C++
HRESULT get_XDelta(
    double*  val
);

Instrument Command

:MARKer:XDELta?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


Y1Position Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.Y1Position Property
IAgInfiniiVisionCursors See Also

Specifies the Y1 cursor position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Y1Position As Double
C#
public double  Y1Position { get; set; }
Visual C++
HRESULT get_Y1Position(
    double*  val
);
HRESULT put_Y1Position(
    double  val
);

Instrument Command

:MARKer:Y1Position {value}
:MARKer:Y1Position?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


Y2Position Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.Y2Position Property
IAgInfiniiVisionCursors See Also

Specifies the Y2 cursor position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Y2Position As Double
C#
public double  Y2Position { get; set; }
Visual C++
HRESULT get_Y2Position(
    double*  val
);
HRESULT put_Y2Position(
    double  val
);

Instrument Command

:MARKer:Y2Position {value}
:MARKer:Y2Position?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


YDelta Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors..::.YDelta Property
IAgInfiniiVisionCursors See Also

Read Only - The value difference between the current Y1 and Y2 cursor positions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property YDelta As Double
C#
public double  YDelta { get; }
Visual C++
HRESULT get_YDelta(
    double*  val
);

Instrument Command

:MARKer:YDELta?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors Interface
Agilent.AgInfiniiVision.Interop Namespace


Cursors2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Cursors2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionCursors2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Cursors2 As IAgInfiniiVisionCursors2
C#
public IAgInfiniiVisionCursors2  Cursors2 { get; }
Visual C++
HRESULT get_Cursors2(
    IAgInfiniiVisionCursors2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


UseCursorPosition Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors2..::.UseCursorPosition Method
IAgInfiniiVisionCursors2 See Also

Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub UseCursorPosition ( _
    ByVal  CursorsType As AgInfiniiVisionCursorsUseCursorPositionEnum  _
)
C#
public void  UseCursorPosition(
    AgInfiniiVisionCursorsUseCursorPositionEnum  CursorsType
)
Visual C++
HRESULT UseCursorPosition(
    AgInfiniiVisionCursorsUseCursorPositionEnum  CursorsType
);

Parameters

CursorsType

Specifies the cursors (X or Y) to use.

Remarks

Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent. The cursors to use (X or Y) are selected using the CursorsType parameter.

The CursorsType parameter can be set to one of the following values:

  • AgInfiniiVisionCursorsUseCursorPositionX - Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent. Sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
  • AgInfiniiVisionCursorsUseCursorPositionY - Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors2 Interface
Agilent.AgInfiniiVision.Interop Namespace


XUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors2..::.XUnits Property
IAgInfiniiVisionCursors2 See Also

The X cursors units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property XUnits As AgInfiniiVisionCursorsXUnitsEnum
C#
public AgInfiniiVisionCursorsXUnitsEnum  XUnits { get; set; }
Visual C++
HRESULT get_XUnits(
    AgInfiniiVisionCursorsXUnitsEnum*  val
);
HRESULT put_XUnits(
    AgInfiniiVisionCursorsXUnitsEnum  val
);

Remarks

The XUnits property can be set to one of the following properties

  • AgInfiniiVisionCursorsXUnitsSeconds - for making time measurements.
  • AgInfiniiVisionCursorsXUnitsHz - for making frequency measurements.
  • AgInfiniiVisionCursorsXUnitsDegrees - for making phase measurements.
  • AgInfiniiVisionCursorsXUnitsPercent - for making ratio measurements.

Changing the XUnits property affects the input and output values of the X1Position, X2Position and XDelta properties.

Instrument Command

:MARKer:XUNits {SEC|HERT|DEGR|PERC}
:MARKer:XUNits?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors2 Interface
Agilent.AgInfiniiVision.Interop Namespace


YUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors2..::.YUnits Property
IAgInfiniiVisionCursors2 See Also

The Y cursors units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YUnits As AgInfiniiVisionCursorsYUnitsEnum
C#
public AgInfiniiVisionCursorsYUnitsEnum  YUnits { get; set; }
Visual C++
HRESULT get_YUnits(
    AgInfiniiVisionCursorsYUnitsEnum*  val
);
HRESULT put_YUnits(
    AgInfiniiVisionCursorsYUnitsEnum  val
);

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionCursorsYUnitsBase - for making measurements in the units associated with the cursors source
  • AgInfiniiVisionCursorsYUnitsPercent - for making ratio measurements

Changing the YUnits property affects the input and output values of the Y1Position, Y2Position and YDelta properties

Instrument Command

:MARKer:YUNits {BASE|PERC}
:MARKer:YUNits?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionCursors2 Interface
Agilent.AgInfiniiVision.Interop Namespace


DigitalChannels Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.DigitalChannels Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionDigitalChannels interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DigitalChannels As IAgInfiniiVisionDigitalChannels
C#
public IAgInfiniiVisionDigitalChannels  DigitalChannels { get; }
Visual C++
HRESULT get_DigitalChannels(
    IAgInfiniiVisionDigitalChannels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Bus Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.Bus Property
IAgInfiniiVisionDigitalChannels See Also

Pointer to the IAgInfiniiVisionDigitalChannelsBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Bus As IAgInfiniiVisionDigitalChannelsBus
C#
public IAgInfiniiVisionDigitalChannelsBus  Bus { get; }
Visual C++
HRESULT get_Bus(
    IAgInfiniiVisionDigitalChannelsBus**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.Clear Method
IAgInfiniiVisionDigitalChannelsBus See Also

Excludes all of the digital channels from the selected bus definition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
    ByVal  BusType As Short  _
)
C#
public void  Clear(
    short  BusType
)
Visual C++
HRESULT Clear(
    short  BusType
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Instrument Command

:BUS{BusType}:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Enable Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.Enable Method
IAgInfiniiVisionDigitalChannelsBus See Also

Display the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Enable ( _
    ByVal  BusType As Short  _
    ByVal  ViewState As Boolean  _
)
C#
public void  Enable(
    short  BusType,
    bool  ViewState
)
Visual C++
HRESULT Enable(
    short  BusType,
    VARIANT_BOOL  ViewState
);

Parameters

BusType

Type of Bus: Bus1|Bus2

ViewState

Current state of bus

Instrument Command

:BUS{BusType}:DISPlay {}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


GetChannelBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.GetChannelBit Method
IAgInfiniiVisionDigitalChannelsBus See Also

Returns the definition for the specified bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetChannelBit ( _
    ByVal  BusType As Short  _
) As String
C#
public string  GetChannelBit(
    short  BusType
)
Visual C++
HRESULT GetChannelBit(
    short  BusType
    BSTR*  retval
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Return Value

Definition in String format.

Instrument Command

:BUS{BusType}:BITS?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


GetLabel Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.GetLabel Method
IAgInfiniiVisionDigitalChannelsBus See Also

Returns the label of the specified bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetLabel ( _
    ByVal  BusType As Short  _
) As String
C#
public string  GetLabel(
    short  BusType
)
Visual C++
HRESULT GetLabel(
    short  BusType
    BSTR*  retval
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Return Value

Any series of 10 or less characters as a quoted ASCII string.

Instrument Command

:BUS{BusType}:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


GetMaskBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.GetMaskBit Method
IAgInfiniiVisionDigitalChannelsBus See Also

Returns the mask value for the specified bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetMaskBit ( _
    ByVal  BusType As Short  _
) As String
C#
public string  GetMaskBit(
    short  BusType
)
Visual C++
HRESULT GetMaskBit(
    short  BusType
    BSTR*  retval
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Return Value

The mask value in string format.

Instrument Command

:BUS{BusType}:MASK?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


IsDigitalBitEnabled Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.IsDigitalBitEnabled Method
IAgInfiniiVisionDigitalChannelsBus See Also

Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function IsDigitalBitEnabled ( _
    ByVal  BusType As Short  _
    ByVal  DigtalBits As Short  _
) As Boolean
C#
public bool  IsDigitalBitEnabled(
    short  BusType,
    short  DigtalBits
)
Visual C++
HRESULT IsDigitalBitEnabled(
    short  BusType,
    short  DigtalBits
    VARIANT_BOOL*  retval
);

Parameters

BusType

Type of Bus: Bus1|Bus2

DigtalBits

Digital bit to be included in bus definition

Return Value

0 or 1

Instrument Command

:BUS{BusType}:BIT{DigtalBits}?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


IsEnabled Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.IsEnabled Method
IAgInfiniiVisionDigitalChannelsBus See Also

Returns the flag indicating whether the specified bus is enabled or disabled.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function IsEnabled ( _
    ByVal  BusType As Short  _
) As Boolean
C#
public bool  IsEnabled(
    short  BusType
)
Visual C++
HRESULT IsEnabled(
    short  BusType
    VARIANT_BOOL*  retval
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Return Value

0 or 1

Instrument Command

:BUS{BusType}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SetChannelBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.SetChannelBit Method
IAgInfiniiVisionDigitalChannelsBus See Also

Includes/Excludes the selected bits in the channel list in the definition of the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetChannelBit ( _
    ByVal  BusType As Short  _
    ByVal  ChannelList As String  _
    ByVal  BitState As Boolean  _
)
C#
public void  SetChannelBit(
    short  BusType,
    string  ChannelList,
    bool  BitState
)
Visual C++
HRESULT SetChannelBit(
    short  BusType,
    BSTR  ChannelList,
    VARIANT_BOOL  BitState
);

Parameters

BusType

Type of Bus: Bus1|Bus2

ChannelList

Channel List containing bits to be included/excluded in the bus definition

BitState

Flag indicating bit is enabled or disabled

Instrument Command

:BUS{BusType}:BITS (@{ChannelList}),{}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SetDigitalBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.SetDigitalBit Method
IAgInfiniiVisionDigitalChannelsBus See Also

Includes/Excludes the selected bit as part of the definition for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetDigitalBit ( _
    ByVal  BusType As Short  _
    ByVal  DigitalBits As Short  _
    ByVal  BitState As Boolean  _
)
C#
public void  SetDigitalBit(
    short  BusType,
    short  DigitalBits,
    bool  BitState
)
Visual C++
HRESULT SetDigitalBit(
    short  BusType,
    short  DigitalBits,
    VARIANT_BOOL  BitState
);

Parameters

BusType

Type of Bus: Bus1|Bus2

DigitalBits

DigitalBit(0-15) to be included/excluded in the bus

BitState

Flag indicating bit is enabled or disabled

Instrument Command

:BUS{BusType}:BIT{DigitalBits} {}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SetLabel Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.SetLabel Method
IAgInfiniiVisionDigitalChannelsBus See Also

The bus label.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetLabel ( _
    ByVal  BusType As Short  _
    ByVal  Label As String  _
)
C#
public void  SetLabel(
    short  BusType,
    string  Label
)
Visual C++
HRESULT SetLabel(
    short  BusType,
    BSTR  Label
);

Parameters

BusType

Type of Bus: Bus1|Bus2

Label

Label to the specified bus

Remarks

Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters.

Instrument Command

:BUS{BusType}:LABel "{Label}"

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SetMaskBit Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus..::.SetMaskBit Method
IAgInfiniiVisionDigitalChannelsBus See Also

Bits to be included and excluded in the selected bus according to the mask.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetMaskBit ( _
    ByVal  BusType As Short  _
    ByVal  MaskBits As String  _
)
C#
public void  SetMaskBit(
    short  BusType,
    string  MaskBits
)
Visual C++
HRESULT SetMaskBit(
    short  BusType,
    BSTR  MaskBits
);

Parameters

BusType

Type of Bus: Bus1|Bus2

MaskBits

Mask containing bit information

Instrument Command

:BUS{BusType}:MASK {MaskBits},

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannelsBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.Count Property
IAgInfiniiVisionDigitalChannels See Also

Read Only - Returns the number of digitalchannels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.Item Property
IAgInfiniiVisionDigitalChannels See Also

Pointer to the IAgInfiniiVisionDigitalChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVisionDigitalChannel
C#
public IAgInfiniiVisionDigitalChannel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVisionDigitalChannel**  val
);

Parameters

Name

The name of a digitalchannel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the DigitalChannel repeated capability.

Remarks

It now supports the entire digital pod (instead of just individual digital channels) through the "DigitalPod<1-2>" repeated-capabilities."

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.Enabled Property
IAgInfiniiVisionDigitalChannel See Also

Enables/Disables the specified digital channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:DIGital{DigitalChannel}:DISPlay {ON|OFF}
:DIGital{DigitalChannel}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


FetchDigitalWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.FetchDigitalWaveform Method
IAgInfiniiVisionDigitalChannel See Also

Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchDigitalWaveform ( _
    ByRef  WaveformArray As Byte()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchDigitalWaveform(
    ref byte[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchDigitalWaveform(
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

WaveformArray

The waveform data that is the actual data acquired for each point in the specified Channel.

InitialX

the first data point((XREFerence = 0)

XIncrement

The time difference between consecutive data points in seconds.

Remarks

  • DigitalChannel<n> will return the waveform for the specified channel, while using DigitalPod<n> will return the waveform for the entire pod.
  • DigitalPod1 consists of DigitalChannel<0-7>
    • DigitalPod2 consists of DigitalChannel<8-15>.

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionDigitalChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.Label Property
IAgInfiniiVisionDigitalChannel See Also

Enables/Disables analog and digital channel labels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Instrument Command

:DIGital{DigitalChannel}:LABel "{value}"
:DIGital{DigitalChannel}:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Position Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.Position Property
IAgInfiniiVisionDigitalChannel See Also

The position of the specified channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Position As Integer
C#
public int  Position { get; set; }
Visual C++
HRESULT get_Position(
    long*  val
);
HRESULT put_Position(
    long  val
);

Remarks

If the returned value is "-1", this indicates there is no space to display the digital waveform

Instrument Command

:DIGital{DigitalChannel}:POSition {value}
:DIGital{DigitalChannel}:POSition?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


ReadDigitalWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.ReadDigitalWaveform Method
IAgInfiniiVisionDigitalChannel See Also

Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadDigitalWaveform ( _
    ByRef  WaveformArray As Byte()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
    ByVal  MaxTime As Integer  _
)
C#
public void  ReadDigitalWaveform(
    ref byte[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement,
    int  MaxTime
)
Visual C++
HRESULT ReadDigitalWaveform(
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement,
    long  MaxTime
);

Parameters

WaveformArray

The waveform data that is the actual data acquired for each point in the specified Channel.

InitialX

The x-origin value for the currently specified source. XORigin is the X-axis value of the data point specified by the :Waveform:XREFerence value. It is always the X-axis value of the first data point (XREFerence = 0).

XIncrement

Time difference between consecutive data points in seconds.

MaxTime

Timeout in milliseconds

Remarks

  • DigitalChannel<n> will return the waveform for the specified channel, while using DigitalPod<n> will return the waveform for the entire pod.
  • DigitalPod1 consists of DigitalChannel<0-7>
    • DigitalPod2 consists of DigitalChannel<8-15>.

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionDigitalChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


Size Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.Size Property
IAgInfiniiVisionDigitalChannel See Also

Size of digital channels on the display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Size As AgInfiniiVisionDigitalChannelSizeEnum
C#
public AgInfiniiVisionDigitalChannelSizeEnum  Size { get; set; }
Visual C++
HRESULT get_Size(
    AgInfiniiVisionDigitalChannelSizeEnum*  val
);
HRESULT put_Size(
    AgInfiniiVisionDigitalChannelSizeEnum  val
);

Instrument Command

:DIGital{DigitalChannel}:SIZE {SMAL|LARG|MED}
:DIGital{DigitalChannel}:SIZE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Threshold Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel..::.Threshold Property
IAgInfiniiVisionDigitalChannel See Also

Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Threshold As String
C#
public string  Threshold { get; set; }
Visual C++
HRESULT get_Threshold(
    BSTR*  val
);
HRESULT put_Threshold(
    BSTR  val
);

Remarks

Permissible values are CMOS | ECL | TTL | <user defined value>];user defined value can be from -8.00 to +8.00

Instrument Command

:DIGital{DigitalChannel}:THReshold {value}
:DIGital{DigitalChannel}:THReshold?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.Name Property
IAgInfiniiVisionDigitalChannels See Also

Read Only - Returns the digitalchannel name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of digitalchannels.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


ReadActivity Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.ReadActivity Method
IAgInfiniiVisionDigitalChannels See Also

Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadActivity ( _
    ByRef  Edge As Integer  _
    ByRef  Level As Integer  _
)
C#
public void  ReadActivity(
    ref int  Edge,
    ref int  Level
)
Visual C++
HRESULT ReadActivity(
    long*  Edge,
    long*  Level
);

Parameters

Edge

Indicates the presence of edges. A bit = 0 (zero) in the edges result indicates that no edges were detected on that channel since the last query. A bit = 1 (one) in the edges result indicates that edges have been detected on that channel.

Level

indicates logical highs or lows.

Instrument Command

:ACTivity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


ResetActivity Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels..::.ResetActivity Method
IAgInfiniiVisionDigitalChannels See Also

Clears the logic activity registers of the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ResetActivity ( _
)
C#
public void  ResetActivity(
)
Visual C++
HRESULT ResetActivity(
);

Instrument Command

:ACTivity

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDigitalChannels Interface
Agilent.AgInfiniiVision.Interop Namespace


Display Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Display Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionDisplay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Display As IAgInfiniiVisionDisplay
C#
public IAgInfiniiVisionDisplay  Display { get; }
Visual C++
HRESULT get_Display(
    IAgInfiniiVisionDisplay**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Erase Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.Erase Method
IAgInfiniiVisionDisplay See Also

Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Erase ( _
)
C#
public void  Erase(
)
Visual C++
HRESULT Erase(
);

Instrument Command

:DISPlay:CLEar

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay Interface
Agilent.AgInfiniiVision.Interop Namespace


GetScreenBitmap Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.GetScreenBitmap Method
IAgInfiniiVisionDisplay See Also

Reads screen image data

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetScreenBitmap ( _
    ByVal  ImageFormat As AgInfiniiVisionDisplayImageFormatEnum  _
    ByVal  Palette As AgInfiniiVisionDisplayPaletteEnum  _
) As Byte()
C#
public byte[]   GetScreenBitmap(
    AgInfiniiVisionDisplayImageFormatEnum  ImageFormat,
    AgInfiniiVisionDisplayPaletteEnum  Palette
)
Visual C++
HRESULT GetScreenBitmap(
    AgInfiniiVisionDisplayImageFormatEnum  ImageFormat,
    AgInfiniiVisionDisplayPaletteEnum  Palette
    SAFEARRAY**  retval
);

Parameters

ImageFormat

Image Data format

Palette

Image data palette

Return Value

Screen image data is returned in the IEEE-488.2 # binary block data format.

Instrument Command

:DISPlay:DATA? {BMP|BMP8|PNG}, {COL|GRAY};

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay Interface
Agilent.AgInfiniiVision.Interop Namespace


LabelEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.LabelEnabled Property
IAgInfiniiVisionDisplay See Also

Enable/Disables the analog and digital channel labels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LabelEnabled As Boolean
C#
public bool  LabelEnabled { get; set; }
Visual C++
HRESULT get_LabelEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_LabelEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:DISPlay:LABel {ON|OFF}
:DISPlay:LABel?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay Interface
Agilent.AgInfiniiVision.Interop Namespace


Persistence Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.Persistence Property
IAgInfiniiVisionDisplay See Also

Enables or disables infinite-persistence mode of the oscilloscope display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Persistence As AgInfiniiVisionDisplayPersistenceModeEnum
C#
public AgInfiniiVisionDisplayPersistenceModeEnum  Persistence { get; set; }
Visual C++
HRESULT get_Persistence(
    AgInfiniiVisionDisplayPersistenceModeEnum*  val
);
HRESULT put_Persistence(
    AgInfiniiVisionDisplayPersistenceModeEnum  val
);

Remarks

AgInfiniiVisionDisplayPersistenceModeAdaptive: All previous acquisitions that have taken place in hardware since the last controller PC screen capture are displayed. Applicable to M924x and P924x only.

Instrument Command

:DISPlay:PERSistence {MIN|INF|ADAP}
:DISPlay:PERSistence?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay Interface
Agilent.AgInfiniiVision.Interop Namespace


PersistenceTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.PersistenceTime Property
IAgInfiniiVisionDisplay See Also

Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PersistenceTime As Double
C#
public double  PersistenceTime { get; set; }
Visual C++
HRESULT get_PersistenceTime(
    double*  val
);
HRESULT put_PersistenceTime(
    double  val
);

Instrument Command

:DISPlay:PERSistence {value}
:DISPlay:PERSistence?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay Interface
Agilent.AgInfiniiVision.Interop Namespace


VectorEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay..::.VectorEnabled Property
IAgInfiniiVisionDisplay See Also

Enables or disables the lines drawn between acquired data points on the screen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VectorEnabled As Boolean
C#
public bool  VectorEnabled { get; set; }
Visual C++
HRESULT get_VectorEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_VectorEnabled(
    VARIANT_BOOL  val
);

Remarks

  • 1000X, 2000X, 3000X, 3000T, M924x and P924x: The vector setting cannot be adjusted by user (this property will always return true).
  • 4000X: The vector setting can only be adjusted on models with bandwidth greater or equal to 1GHz.
  • 6000X: The vector setting can only be adjusted on models with bandwidth greater or equal to 6GHz.

    • Instrument Command

    :DISPlay:VECTors {ON|OFF}
    :DISPlay:VECTors?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionDisplay Interface
    Agilent.AgInfiniiVision.Interop Namespace


Display2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Display2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionDisplay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Display2 As IAgInfiniiVisionDisplay2
C#
public IAgInfiniiVisionDisplay2  Display2 { get; }
Visual C++
HRESULT get_Display2(
    IAgInfiniiVisionDisplay2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


InvertColorEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay2..::.InvertColorEnabled Property
IAgInfiniiVisionDisplay2 See Also

Specifies whether the graticule colors are inverted or not.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InvertColorEnabled As Boolean
C#
public bool  InvertColorEnabled { get; set; }
Visual C++
HRESULT get_InvertColorEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_InvertColorEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:HARDcopy:INKSaver {ON|OFF}
:HARDcopy:INKSaver?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionDisplay2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Display3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.Display3 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionDisplay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Display3 As IAgInfiniiVisionDisplay3
C#
public IAgInfiniiVisionDisplay3  Display3 { get; }
Visual C++
HRESULT get_Display3(
    IAgInfiniiVisionDisplay3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Annotation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3..::.Annotation Property
IAgInfiniiVisionDisplay3 See Also

Pointer to the IAgInfiniiVisionDisplay3Annotation interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Annotation As IAgInfiniiVisionDisplay3Annotation
C#
public IAgInfiniiVisionDisplay3Annotation  Annotation { get; }
Visual C++
HRESULT get_Annotation(
    IAgInfiniiVisionDisplay3Annotation**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Background Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3Annotation..::.Background Property
IAgInfiniiVisionDisplay3Annotation See Also

Specifies the background of the annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Background As AgInfiniiVisionDisplayAnnotationBackgroundEnum
C#
public AgInfiniiVisionDisplayAnnotationBackgroundEnum  Background { get; set; }
Visual C++
HRESULT get_Background(
    AgInfiniiVisionDisplayAnnotationBackgroundEnum*  val
);
HRESULT put_Background(
    AgInfiniiVisionDisplayAnnotationBackgroundEnum  val
);

Instrument Command

:DISPlay:ANNotation:BACKground {OPAQ|INV|TRAN}
:DISPlay:ANNotation:BACKground?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay3Annotation Interface
Agilent.AgInfiniiVision.Interop Namespace


Color Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3Annotation..::.Color Property
IAgInfiniiVisionDisplay3Annotation See Also

Specifies the annotation color.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Color As AgInfiniiVisionDisplayAnnotationColorEnum
C#
public AgInfiniiVisionDisplayAnnotationColorEnum  Color { get; set; }
Visual C++
HRESULT get_Color(
    AgInfiniiVisionDisplayAnnotationColorEnum*  val
);
HRESULT put_Color(
    AgInfiniiVisionDisplayAnnotationColorEnum  val
);

Remarks

  • You can choose white, red, or colors that match analog channels, digital channels, math waveforms, reference waveforms, or markers.

    • Instrument Command

    :DISPlay:ANNotation:COLor {CH1|CH2|CH3|CH4|DIG|MATH|REF|MARK|WHIT|RED}
    :DISPlay:ANNotation:COLor?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionDisplay3Annotation Interface
    Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3Annotation..::.Enabled Property
IAgInfiniiVisionDisplay3Annotation See Also

Enables or disables the annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • When set to true, the annotation appears in the upper left corner of the oscilloscope's display.

    • Instrument Command

    :DISPlay:ANNotation {1|0}
    :DISPlay:ANNotation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionDisplay3Annotation Interface
    Agilent.AgInfiniiVision.Interop Namespace


Text Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3Annotation..::.Text Property
IAgInfiniiVisionDisplay3Annotation See Also

Specifies the annotation string.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Text As String
C#
public string  Text { get; set; }
Visual C++
HRESULT get_Text(
    BSTR*  val
);
HRESULT put_Text(
    BSTR  val
);

Remarks

  • The annotation string can contain up to 254 characters.
  • You can include a carriage return in the annotation string using the characters "\n". Note that this is not a new line character but the actual "\" (backslash) and "n" characters in the string. Carriage returns lessen the number of characters available for the annotation string.

    • Instrument Command

    :DISPlay:ANNotation:TEXT "{value}"
    :DISPlay:ANNotation:TEXT?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionDisplay3Annotation Interface
    Agilent.AgInfiniiVision.Interop Namespace


Sidebar Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3..::.Sidebar Property
IAgInfiniiVisionDisplay3 See Also

Write Only. Specifies the sidebar dialog to display on the screen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public WriteOnly Property Sidebar As AgInfiniiVisionDisplaySidebarEnum
C#
public AgInfiniiVisionDisplaySidebarEnum  Sidebar { set; }
Visual C++
HRESULT put_Sidebar(
    AgInfiniiVisionDisplaySidebarEnum  val
);

Instrument Command

:DISPlay:SIDebar {SUMM|CURS|MEAS|DVM|NAV|CONT|HIST|EVEN|COUN}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Display4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.Display4 Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVisionDisplay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Display4 As IAgInfiniiVisionDisplay4
C#
public IAgInfiniiVisionDisplay4  Display4 { get; }
Visual C++
HRESULT get_Display4(
    IAgInfiniiVisionDisplay4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


Annotation2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4..::.Annotation2 Property
IAgInfiniiVisionDisplay4 See Also

Pointer to the IAgInfiniiVisionDisplay3Annotation interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Annotation2 As IAgInfiniiVisionDisplay4Annotation2
C#
public IAgInfiniiVisionDisplay4Annotation2  Annotation2 { get; }
Visual C++
HRESULT get_Annotation2(
    IAgInfiniiVisionDisplay4Annotation2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDisplay4 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetBackground Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetBackground Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Gets the background of the annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetBackground ( _
    ByVal  Index As Integer  _
) As AgInfiniiVisionDisplayAnnotationBackgroundEnum
C#
public AgInfiniiVisionDisplayAnnotationBackgroundEnum  GetBackground(
    int  Index
)
Visual C++
HRESULT GetBackground(
    long  Index
    AgInfiniiVisionDisplayAnnotationBackgroundEnum*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

Mode

Instrument Command

:DISPlay:ANNotation{Index}:BACKground?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetColor Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetColor Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Gets the annotation color.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetColor ( _
    ByVal  Index As Integer  _
) As AgInfiniiVisionDisplayAnnotationColorEnum
C#
public AgInfiniiVisionDisplayAnnotationColorEnum  GetColor(
    int  Index
)
Visual C++
HRESULT GetColor(
    long  Index
    AgInfiniiVisionDisplayAnnotationColorEnum*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

Color

Instrument Command

:DISPlay:ANNotation{Index}:COLor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetEnabled Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetEnabled Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Get the state of annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetEnabled ( _
    ByVal  Index As Integer  _
) As Boolean
C#
public bool  GetEnabled(
    int  Index
)
Visual C++
HRESULT GetEnabled(
    long  Index
    VARIANT_BOOL*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

1 or 0

Instrument Command

:DISPlay:ANNotation{Index}?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetText Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetText Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Gets the annotation string.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetText ( _
    ByVal  Index As Integer  _
) As String
C#
public string  GetText(
    int  Index
)
Visual C++
HRESULT GetText(
    long  Index
    BSTR*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

Text

Instrument Command

:DISPlay:ANNotation{Index}:TEXT?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetX1Position Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetX1Position Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Gets the annotation's horizontal X1 position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetX1Position ( _
    ByVal  Index As Integer  _
) As Long
C#
public long  GetX1Position(
    int  Index
)
Visual C++
HRESULT GetX1Position(
    long  Index
    __int64*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

X1 Position

Remarks

0 to 800 - width of annotation.

Instrument Command

:DISPlay:ANNotation{Index}:X1Position?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetY1Position Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.GetY1Position Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Gets the annotation's vertical Y1 position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetY1Position ( _
    ByVal  Index As Integer  _
) As Long
C#
public long  GetY1Position(
    int  Index
)
Visual C++
HRESULT GetY1Position(
    long  Index
    __int64*  retval
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Return Value

Y1 Position

Remarks

0 to 480 - height of annotation for 3000T, M924x and P924x

0 to 600 - height of annotation for 4000X and 6000X

Instrument Command

:DISPlay:ANNotation{Index}:Y1Position?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetBackground Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetBackground Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Sets the background of the annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetBackground ( _
    ByVal  Index As Integer  _
    ByVal  Background As AgInfiniiVisionDisplayAnnotationBackgroundEnum  _
)
C#
public void  SetBackground(
    int  Index,
    AgInfiniiVisionDisplayAnnotationBackgroundEnum  Background
)
Visual C++
HRESULT SetBackground(
    long  Index,
    AgInfiniiVisionDisplayAnnotationBackgroundEnum  Background
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Background

Background.

Instrument Command

:DISPlay:ANNotation{Index}:BACKground {OPAQ|INV|TRAN}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetColor Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetColor Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Sets the annotation color.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetColor ( _
    ByVal  Index As Integer  _
    ByVal  Color As AgInfiniiVisionDisplayAnnotationColorEnum  _
)
C#
public void  SetColor(
    int  Index,
    AgInfiniiVisionDisplayAnnotationColorEnum  Color
)
Visual C++
HRESULT SetColor(
    long  Index,
    AgInfiniiVisionDisplayAnnotationColorEnum  Color
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Color

Color.

Instrument Command

:DISPlay:ANNotation{Index}:COLor {CH1|CH2|CH3|CH4|DIG|MATH|REF|MARK|WHIT|RED}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetEnabled Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetEnabled Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Enable or disable the annotation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetEnabled ( _
    ByVal  Index As Integer  _
    ByVal  Enabled As Boolean  _
)
C#
public void  SetEnabled(
    int  Index,
    bool  Enabled
)
Visual C++
HRESULT SetEnabled(
    long  Index,
    VARIANT_BOOL  Enabled
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Enabled

Annotation enable.

Instrument Command

:DISPlay:ANNotation{Index} {ON|OFF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetText Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetText Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Sets the annotation string.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetText ( _
    ByVal  Index As Integer  _
    ByVal  Text As String  _
)
C#
public void  SetText(
    int  Index,
    string  Text
)
Visual C++
HRESULT SetText(
    long  Index,
    BSTR  Text
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Text

Annotation text.

Instrument Command

:DISPlay:ANNotation{Index}:TEXT "{Text}"

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetX1Position Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetX1Position Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Sets the annotation's horizontal X1 position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetX1Position ( _
    ByVal  Index As Integer  _
    ByVal  Position As Double  _
)
C#
public void  SetX1Position(
    int  Index,
    double  Position
)
Visual C++
HRESULT SetX1Position(
    long  Index,
    double  Position
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Position

Width of annotation.

Remarks

0 to 800 - width of annotation.

Instrument Command

:DISPlay:ANNotation{Index}:X1Position {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetY1Position Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2..::.SetY1Position Method
IAgInfiniiVisionDisplay4Annotation2 See Also

Sets the annotation's vertical Y1 position.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetY1Position ( _
    ByVal  Index As Integer  _
    ByVal  Position As Double  _
)
C#
public void  SetY1Position(
    int  Index,
    double  Position
)
Visual C++
HRESULT SetY1Position(
    long  Index,
    double  Position
);

Parameters

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Position

Height of annotation.

Remarks

0 to 480 - height of annotation for 3000T, M924x and P924x.

0 to 600 - height of annotation for 4000X and 6000X.

Instrument Command

:DISPlay:ANNotation{Index}:Y1Position {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionDisplay4Annotation2 Interface
Agilent.AgInfiniiVision.Interop Namespace


DriverOperation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.DriverOperation Property
IIviDriver See Also

Pointer to the IIviDriverOperation interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property DriverOperation As IIviDriverOperation
C#
public IIviDriverOperation  DriverOperation { get; }
Visual C++
HRESULT get_DriverOperation(
    IIviDriverOperation**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Cache Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.Cache Property
IIviDriverOperation See Also

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property Cache As Boolean
C#
public bool  Cache { get; set; }
Visual C++
HRESULT get_Cache(
    VARIANT_BOOL*  val
);
HRESULT put_Cache(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


ClearInterchangeWarnings Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.ClearInterchangeWarnings Method
IIviDriverOperation See Also

Not Supported - Clears the list of interchangeability warnings that the IVI specific driver maintains.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ClearInterchangeWarnings ( _
)
C#
public void  ClearInterchangeWarnings(
)
Visual C++
HRESULT ClearInterchangeWarnings(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


DriverSetup Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.DriverSetup Property
IIviDriverOperation See Also

Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property DriverSetup As String
C#
public string  DriverSetup { get; }
Visual C++
HRESULT get_DriverSetup(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


GetNextCoercionRecord Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.GetNextCoercionRecord Method
IIviDriverOperation See Also

Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Function GetNextCoercionRecord ( _
) As String
C#
public string  GetNextCoercionRecord(
)
Visual C++
HRESULT GetNextCoercionRecord(
    BSTR*  retval
);

Return Value

The coercion record string shall contain the following information: (1) The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant. (2) If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.(3) If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.(4) The value that the user specified for the attribute.(5) The value to which the attribute was coerced.

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


GetNextInterchangeWarning Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.GetNextInterchangeWarning Method
IIviDriverOperation See Also

Not Supported - Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Function GetNextInterchangeWarning ( _
) As String
C#
public string  GetNextInterchangeWarning(
)
Visual C++
HRESULT GetNextInterchangeWarning(
    BSTR*  retval
);

Return Value

A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


InterchangeCheck Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.InterchangeCheck Property
IIviDriverOperation See Also

Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property InterchangeCheck As Boolean
C#
public bool  InterchangeCheck { get; set; }
Visual C++
HRESULT get_InterchangeCheck(
    VARIANT_BOOL*  val
);
HRESULT put_InterchangeCheck(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


InvalidateAllAttributes Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.InvalidateAllAttributes Method
IIviDriverOperation See Also

Invalidates all of the driver's cached values.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub InvalidateAllAttributes ( _
)
C#
public void  InvalidateAllAttributes(
)
Visual C++
HRESULT InvalidateAllAttributes(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


IoResourceDescriptor Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.IoResourceDescriptor Property
IIviDriverOperation See Also

Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property IoResourceDescriptor As String
C#
public string  IoResourceDescriptor { get; }
Visual C++
HRESULT get_IoResourceDescriptor(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


LogicalName Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.LogicalName Property
IIviDriverOperation See Also

Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property LogicalName As String
C#
public string  LogicalName { get; }
Visual C++
HRESULT get_LogicalName(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


QueryInstrumentStatus Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.QueryInstrumentStatus Property
IIviDriverOperation See Also

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property QueryInstrumentStatus As Boolean
C#
public bool  QueryInstrumentStatus { get; set; }
Visual C++
HRESULT get_QueryInstrumentStatus(
    VARIANT_BOOL*  val
);
HRESULT put_QueryInstrumentStatus(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


RangeCheck Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.RangeCheck Property
IIviDriverOperation See Also

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property RangeCheck As Boolean
C#
public bool  RangeCheck { get; set; }
Visual C++
HRESULT get_RangeCheck(
    VARIANT_BOOL*  val
);
HRESULT put_RangeCheck(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


RecordCoercions Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.RecordCoercions Property
IIviDriverOperation See Also

Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property RecordCoercions As Boolean
C#
public bool  RecordCoercions { get; set; }
Visual C++
HRESULT get_RecordCoercions(
    VARIANT_BOOL*  val
);
HRESULT put_RecordCoercions(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


ResetInterchangeCheck Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.ResetInterchangeCheck Method
IIviDriverOperation See Also

Not Supported - Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ResetInterchangeCheck ( _
)
C#
public void  ResetInterchangeCheck(
)
Visual C++
HRESULT ResetInterchangeCheck(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


Simulate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation..::.Simulate Property
IIviDriverOperation See Also

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property Simulate As Boolean
C#
public bool  Simulate { get; set; }
Visual C++
HRESULT get_Simulate(
    VARIANT_BOOL*  val
);
HRESULT put_Simulate(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


DVM Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.DVM Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionDVM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DVM As IAgInfiniiVisionDVM
C#
public IAgInfiniiVisionDVM  DVM { get; }
Visual C++
HRESULT get_DVM(
    IAgInfiniiVisionDVM**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoRangeEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.AutoRangeEnabled Property
IAgInfiniiVisionDVM See Also

Enables or disables the Digital Voltmeter's Auto Range capability.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AutoRangeEnabled As Boolean
C#
public bool  AutoRangeEnabled { get; set; }
Visual C++
HRESULT get_AutoRangeEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_AutoRangeEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:DVM:ARANge {ON|OFF}
:DVM:ARANge?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


Current Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.Current Property
IAgInfiniiVisionDVM See Also

Read Only - Returns the displayed 3-digit DVM value based on the current mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Current As Double
C#
public double  Current { get; }
Visual C++
HRESULT get_Current(
    double*  val
);

Instrument Command

:DVM:CURRent?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.Enabled Property
IAgInfiniiVisionDVM See Also

Enables or disables the Digital Voltmeter (DVM) analysis feature.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:DVM:ENABle {1|0}
:DVM:ENABle?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.Frequency Property
IAgInfiniiVisionDVM See Also

Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Frequency As Double
C#
public double  Frequency { get; }
Visual C++
HRESULT get_Frequency(
    double*  val
);

Remarks

For 3000T, 4000X and 6000X series, the Frequency capability is accessible from the Counter interface

Instrument Command

:DVM:FREQuency?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3014A, DSO-X 3024A, DSO-X 3032A, DSO-X 3034A, DSO-X 3052A, DSO-X 3054A, DSO-X 3102A, DSO-X 3104A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3014A, MSO-X 3024A, MSO-X 3032A, MSO-X 3034A, MSO-X 3052A, MSO-X 3054A, MSO-X 3102A, MSO-X 3104A

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.Mode Property
IAgInfiniiVisionDVM See Also

Specifies the digital voltmeter (DVM) mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionDVMModeEnum
C#
public AgInfiniiVisionDVMModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionDVMModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionDVMModeEnum  val
);

Instrument Command

:DVM:MODE {ACRM|DC|DCRM|FREQ}
:DVM:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM..::.Source Property
IAgInfiniiVisionDVM See Also

Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:DVM:SOURce {value}
:DVM:SOURce?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionDVM Interface
Agilent.AgInfiniiVision.Interop Namespace


External Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.External Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionExternal interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property External As IAgInfiniiVisionExternal
C#
public IAgInfiniiVisionExternal  External { get; }
Visual C++
HRESULT get_External(
    IAgInfiniiVisionExternal**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeAttenuation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal..::.ProbeAttenuation Property
IAgInfiniiVisionExternal See Also

Scaling factor by which the probe attached to the external trigger attenuates the input.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ProbeAttenuation As Double
C#
public double  ProbeAttenuation { get; set; }
Visual C++
HRESULT get_ProbeAttenuation(
    double*  val
);
HRESULT put_ProbeAttenuation(
    double  val
);

Remarks

The probe attenuation factor may be from 0.1 to 1000. For example, with a 10:1 probe, the value is 10.0.

Instrument Command

:EXTernal:PROBe {value}
:EXTernal:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionExternal Interface
Agilent.AgInfiniiVision.Interop Namespace


ProbeSense Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal..::.ProbeSense Property
IAgInfiniiVisionExternal See Also

Read Only - Probe attenuation value that the oscilloscope automatically senses.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeSense As Double
C#
public double  ProbeSense { get; }
Visual C++
HRESULT get_ProbeSense(
    double*  val
);

Instrument Command

:EXTernal:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionExternal Interface
Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal..::.Range Property
IAgInfiniiVisionExternal See Also

Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

When using 1:1 probe attenuation, the range can only be set to 8.0 V.

Instrument Command

:EXTernal:RANGe {value}
:EXTernal:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionExternal Interface
Agilent.AgInfiniiVision.Interop Namespace


Units Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal..::.Units Property
IAgInfiniiVisionExternal See Also

The measurement units for the probe connected to the external trigger input.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Units As AgInfiniiVisionExternalProbeUnitsEnum
C#
public AgInfiniiVisionExternalProbeUnitsEnum  Units { get; set; }
Visual C++
HRESULT get_Units(
    AgInfiniiVisionExternalProbeUnitsEnum*  val
);
HRESULT put_Units(
    AgInfiniiVisionExternalProbeUnitsEnum  val
);

Instrument Command

:EXTernal:UNITs {VOLT|AMP}
:EXTernal:UNITs?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionExternal Interface
Agilent.AgInfiniiVision.Interop Namespace


External2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8..::.External2 Property
IAgInfiniiVision8 See Also

Pointer to the IAgInfiniiVisionExternal interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property External2 As IAgInfiniiVisionExternal2
C#
public IAgInfiniiVisionExternal2  External2 { get; }
Visual C++
HRESULT get_External2(
    IAgInfiniiVisionExternal2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision8 Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal2..::.Enabled Property
IAgInfiniiVisionExternal2 See Also

Enables or disables the external trigger input display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:EXTernal:DISPlay {1|0}
:EXTernal:DISPlay?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVisionExternal2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal2..::.Label Property
IAgInfiniiVisionExternal2 See Also

The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Remarks

  • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters. Lower case characters are converted to upper case.

    • Instrument Command

    :EXTernal:LABel {value}
    :EXTernal:LABel?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    IAgInfiniiVisionExternal2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Threshold Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal2..::.Threshold Property
IAgInfiniiVisionExternal2 See Also

The external trigger input threshold (trigger) voltage level in volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Threshold As Double
C#
public double  Threshold { get; set; }
Visual C++
HRESULT get_Threshold(
    double*  val
);
HRESULT put_Threshold(
    double  val
);

Instrument Command

:EXTernal:LEVel {value}
:EXTernal:LEVel?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

IAgInfiniiVisionExternal2 Interface
Agilent.AgInfiniiVision.Interop Namespace


VerticalPosition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal2..::.VerticalPosition Property
IAgInfiniiVisionExternal2 See Also

The external trigger input waveform's vertical position on the oscilloscope display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalPosition As Double
C#
public double  VerticalPosition { get; set; }
Visual C++
HRESULT get_VerticalPosition(
    double*  val
);
HRESULT put_VerticalPosition(
    double  val
);

Remarks

  • When the external trigger input's waveform is displayed, a cyan digital waveform, based on the threshold voltage level, appears on the oscilloscope display. This waveform is one division tall, and the base of the waveform can be positioned from -3.5 divisions to 2.5 divisions.

    • Instrument Command

    :EXTernal:POSition {value}
    :EXTernal:POSition?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    IAgInfiniiVisionExternal2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


FFT Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.FFT Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVision5FFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FFT As IAgInfiniiVision5FFT
C#
public IAgInfiniiVision5FFT  FFT { get; }
Visual C++
HRESULT get_FFT(
    IAgInfiniiVision5FFT**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


AverageCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.AverageCount Property
IAgInfiniiVision5FFT See Also

Sets and gets the number of waveforms to be averaged together.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AverageCount As Long
C#
public long  AverageCount { get; set; }
Visual C++
HRESULT get_AverageCount(
    __int64*  val
);
HRESULT put_AverageCount(
    __int64  val
);

Instrument Command

:FFT:AVERage:COUNt {value}
:FFT:AVERage:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


CenterFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.CenterFrequency Property
IAgInfiniiVision5FFT See Also

Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Instrument Command

:FFT:CENTer {value}
:FFT:CENTer?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Clear Method
IAgInfiniiVision5FFT See Also

Clears the number of evaluated waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
)
C#
public void  Clear(
)
Visual C++
HRESULT Clear(
);

Instrument Command

:FFT:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


DisplayMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.DisplayMode Property
IAgInfiniiVision5FFT See Also

Sets and gets the FFT waveform display modes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DisplayMode As AgInfiniiVisionMathFFTDisplayModeEnum
C#
public AgInfiniiVisionMathFFTDisplayModeEnum  DisplayMode { get; set; }
Visual C++
HRESULT get_DisplayMode(
    AgInfiniiVisionMathFFTDisplayModeEnum*  val
);
HRESULT put_DisplayMode(
    AgInfiniiVisionMathFFTDisplayModeEnum  val
);

Instrument Command

:FFT:DMODe {NORM|AVER|MAXH|MINH}
:FFT:DMODe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Enabled Property
IAgInfiniiVision5FFT See Also

Enable or disable the display of the FFT function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • When ON is selected, the FFT function is calculated and displayed.
  • When OFF is selected, the FFT function is neither calculated nor displayed.

    • Instrument Command

    :FFT:DISPlay {ON|OFF}
    :FFT:DISPlay?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

    See Also

    Reference

    IAgInfiniiVision5FFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Offset Property
IAgInfiniiVision5FFT See Also

Sets and gets the FFT vertical value represented at center screen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Instrument Command

:FFT:OFFSet {value}
:FFT:OFFSet?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Range Property
IAgInfiniiVision5FFT See Also

Sets and gets the full-scale vertical axis for the FFT function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Instrument Command

:FFT:RANGe {value}
:FFT:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Source Property
IAgInfiniiVision5FFT See Also

Sets and gets the source for the FFT function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:FFT:SOURce1 {value}
:FFT:SOURce1?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


Span Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.Span Property
IAgInfiniiVision5FFT See Also

Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Span As Double
C#
public double  Span { get; set; }
Visual C++
HRESULT get_Span(
    double*  val
);
HRESULT put_Span(
    double  val
);

Instrument Command

:FFT:SPAN {value}
:FFT:SPAN?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


StartFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.StartFrequency Property
IAgInfiniiVision5FFT See Also

Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StartFrequency As Double
C#
public double  StartFrequency { get; set; }
Visual C++
HRESULT get_StartFrequency(
    double*  val
);
HRESULT put_StartFrequency(
    double  val
);

Instrument Command

:FFT:FREQuency:STARt {value}
:FFT:FREQuency:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


StopFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.StopFrequency Property
IAgInfiniiVision5FFT See Also

Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StopFrequency As Double
C#
public double  StopFrequency { get; set; }
Visual C++
HRESULT get_StopFrequency(
    double*  val
);
HRESULT put_StopFrequency(
    double  val
);

Instrument Command

:FFT:FREQuency:STOP {value}
:FFT:FREQuency:STOP?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


VerticalUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.VerticalUnits Property
IAgInfiniiVision5FFT See Also

Specifies the FFT vertical units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalUnits As AgInfiniiVisionMathFFTVerticalUnitsEnum
C#
public AgInfiniiVisionMathFFTVerticalUnitsEnum  VerticalUnits { get; set; }
Visual C++
HRESULT get_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum*  val
);
HRESULT put_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum  val
);

Instrument Command

:FFT:VTYPe {DEC|VRMS}
:FFT:VTYPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


WindowType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT..::.WindowType Property
IAgInfiniiVision5FFT See Also

Windowing transforms for the FFT.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WindowType As AgInfiniiVisionMathFFTWindowTypeEnum
C#
public AgInfiniiVisionMathFFTWindowTypeEnum  WindowType { get; set; }
Visual C++
HRESULT get_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum*  val
);
HRESULT put_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum  val
);

Instrument Command

:FFT:WINDow {RECT|HANN|FLAT|BHAR}
:FFT:WINDow?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

IAgInfiniiVision5FFT Interface
Agilent.AgInfiniiVision.Interop Namespace


FRA Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8..::.FRA Property
IAgInfiniiVision8 See Also

Pointer to the IAgInfiniiVision8FRA interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FRA As IAgInfiniiVision8FRA
C#
public IAgInfiniiVision8FRA  FRA { get; }
Visual C++
HRESULT get_FRA(
    IAgInfiniiVision8FRA**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision8 Interface
Agilent.AgInfiniiVision.Interop Namespace


Amplitude Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.Amplitude Property
IAgInfiniiVision8FRA See Also

The waveform generator amplitude in the frequency response analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Amplitude As Double
C#
public double  Amplitude { get; set; }
Visual C++
HRESULT get_Amplitude(
    double*  val
);
HRESULT put_Amplitude(
    double  val
);

Instrument Command

:FRANalysis:WGEN:VOLTage {value}
:FRANalysis:WGEN:VOLTage?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


AmplitudeProfileState Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.AmplitudeProfileState Property
IAgInfiniiVision8FRA See Also

Enables or disables the ability to specify amplitude ramping within different decades

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AmplitudeProfileState As Boolean
C#
public bool  AmplitudeProfileState { get; set; }
Visual C++
HRESULT get_AmplitudeProfileState(
    VARIANT_BOOL*  val
);
HRESULT put_AmplitudeProfileState(
    VARIANT_BOOL  val
);

Instrument Command

:FRANalysis:WGEN:VOLTage:PROFile {1|0}
:FRANalysis:WGEN:VOLTage:PROFile?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.Enabled Property
IAgInfiniiVision8FRA See Also

Enables or disables the Frequency Response Analysis (FRA) feature.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:FRANalysis:ENABle
:FRANalysis:ENABle?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


FetchData Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.FetchData Method
IAgInfiniiVision8FRA See Also

Fetch the frequency response analysis data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchData ( _
    ByRef  Frequency As Double()   _
    ByRef  Amplitude As Double()   _
    ByRef  Gain As Double()   _
    ByRef  Phase As Double()   _
)
C#
public void  FetchData(
    ref double[]   Frequency,
    ref double[]   Amplitude,
    ref double[]   Gain,
    ref double[]   Phase
)
Visual C++
HRESULT FetchData(
    SAFEARRAY**  Frequency,
    SAFEARRAY**  Amplitude,
    SAFEARRAY**  Gain,
    SAFEARRAY**  Phase
);

Parameters

Frequency

Frequency

Amplitude

Amplitude

Gain

Gain

Phase

Phase

Instrument Command

:FRANalysis:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


GetAmplitudeProfile Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.GetAmplitudeProfile Method
IAgInfiniiVision8FRA See Also

Returns waveform generator amplitude in the frequency response analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetAmplitudeProfile ( _
    ByVal  Range As AgInfiniiVisionFRAAmpRangeEnum  _
) As Double
C#
public double  GetAmplitudeProfile(
    AgInfiniiVisionFRAAmpRangeEnum  Range
)
Visual C++
HRESULT GetAmplitudeProfile(
    AgInfiniiVisionFRAAmpRangeEnum  Range
    double*  retval
);

Parameters

Range

Range

Return Value

Range

Instrument Command

:FRANalysis:WGEN:VOLTage? {F20HZ|F100HZ|F10KHZ|F100KHZ|F1MHZ|F10MHZ|F20MHZ|F1KHZ}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


InputSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.InputSource Property
IAgInfiniiVision8FRA See Also

The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InputSource As String
C#
public string  InputSource { get; set; }
Visual C++
HRESULT get_InputSource(
    BSTR*  val
);
HRESULT put_InputSource(
    BSTR  val
);

Instrument Command

:FRANalysis:SOURce:INPut {value}
:FRANalysis:SOURce:INPut?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


OutputLoadImpedance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.OutputLoadImpedance Property
IAgInfiniiVision8FRA See Also

The current expected output load impedance

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputLoadImpedance As AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum
C#
public AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  OutputLoadImpedance { get; set; }
Visual C++
HRESULT get_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum*  val
);
HRESULT put_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  val
);

Instrument Command

:FRANalysis:WGEN:LOAD {ONEM|FIFT}
:FRANalysis:WGEN:LOAD?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


OutputSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.OutputSource Property
IAgInfiniiVision8FRA See Also

The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputSource As String
C#
public string  OutputSource { get; set; }
Visual C++
HRESULT get_OutputSource(
    BSTR*  val
);
HRESULT put_OutputSource(
    BSTR  val
);

Instrument Command

:FRANalysis:SOURce:OUTPut {value}
:FRANalysis:SOURce:OUTPut?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


PointsPerDecade Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.PointsPerDecade Property
IAgInfiniiVision8FRA See Also

The number of points per decade in the frequency response analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PointsPerDecade As Integer
C#
public int  PointsPerDecade { get; set; }
Visual C++
HRESULT get_PointsPerDecade(
    long*  val
);
HRESULT put_PointsPerDecade(
    long  val
);

Instrument Command

:FRANalysis:PPDecade {value}
:FRANalysis:PPDecade?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


Run Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.Run Method
IAgInfiniiVision8FRA See Also

Initiates the Frequency Response Analysis.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Run ( _
)
C#
public void  Run(
)
Visual C++
HRESULT Run(
);

Remarks

  • This analysis controls the built-in waveform generator to sweep a sine wave across a range of frequencies while measuring the input to and output from a device under test (DUT). At each frequency, gain (A) and phase are measured and plotted on a Bode frequency response chart.
  • When the frequency response analysis completes, you can use the FetchData method to get list of data for each step in the sweep: Frequency (Hz), Amplitude (Vpp), Gain (dB), and Phase (�).
  • It takes some time for the frequency sweep analysis to complete. You can query bit 0 of the Standard Event Status Register to find out when the analysis is complete.
  • Ensure that System::TimeoutMilliseconds is set to the appropriate value before calling FRA::Run. A typical sweep may take up to 1 minute."

    • Instrument Command

    :FRANalysis:RUN

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision8FRA Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetAmplitudeProfile Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.SetAmplitudeProfile Method
IAgInfiniiVision8FRA See Also

Return the waveform generator's output sine wave amplitude.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetAmplitudeProfile ( _
    ByVal  Amplitude As Double  _
    ByVal  Range As AgInfiniiVisionFRAAmpRangeEnum  _
)
C#
public void  SetAmplitudeProfile(
    double  Amplitude,
    AgInfiniiVisionFRAAmpRangeEnum  Range
)
Visual C++
HRESULT SetAmplitudeProfile(
    double  Amplitude,
    AgInfiniiVisionFRAAmpRangeEnum  Range
);

Parameters

Amplitude

Amplitude

Range

Range

Remarks

  • When the amplitude profile setting is on, the range option specifies the frequency
  • whose initial ramp amplitude is returned

    • Instrument Command

    :FRANalysis:WGEN:VOLTage {Amplitude}, {F20HZ|F100HZ|F10KHZ|F100KHZ|F1MHZ|F10MHZ|F20MHZ|F1KHZ}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision8FRA Interface
    Agilent.AgInfiniiVision.Interop Namespace


StartFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.StartFrequency Property
IAgInfiniiVision8FRA See Also

The frequency sweep start value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StartFrequency As Double
C#
public double  StartFrequency { get; set; }
Visual C++
HRESULT get_StartFrequency(
    double*  val
);
HRESULT put_StartFrequency(
    double  val
);

Instrument Command

:FRANalysis:FREQuency:STARt {value}
:FRANalysis:FREQuency:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


StopFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.StopFrequency Property
IAgInfiniiVision8FRA See Also

The frequency sweep stop value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StopFrequency As Double
C#
public double  StopFrequency { get; set; }
Visual C++
HRESULT get_StopFrequency(
    double*  val
);
HRESULT put_StopFrequency(
    double  val
);

Instrument Command

:FRANalysis:FREQuency:STOP
:FRANalysis:FREQuency:STOP?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


SweepMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA..::.SweepMode Property
IAgInfiniiVision8FRA See Also

Select between the normal swept frequency response analysis or analysis at a single frequency

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SweepMode As AgInfiniiVisionFRAFreqModeEnum
C#
public AgInfiniiVisionFRAFreqModeEnum  SweepMode { get; set; }
Visual C++
HRESULT get_SweepMode(
    AgInfiniiVisionFRAFreqModeEnum*  val
);
HRESULT put_SweepMode(
    AgInfiniiVisionFRAFreqModeEnum  val
);

Instrument Command

:FRANalysis:FREQuency:MODE {SING|SWE}
:FRANalysis:FREQuency:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision8FRA Interface
Agilent.AgInfiniiVision.Interop Namespace


Histogram Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Histogram Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVision4Histogram interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Histogram As IAgInfiniiVision4Histogram
C#
public IAgInfiniiVision4Histogram  Histogram { get; }
Visual C++
HRESULT get_Histogram(
    IAgInfiniiVision4Histogram**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Axis Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Axis Property
IAgInfiniiVision4Histogram See Also

The orientation of the histogram.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Axis As AgInfiniiVisionHistogramAxisEnum
C#
public AgInfiniiVisionHistogramAxisEnum  Axis { get; set; }
Visual C++
HRESULT get_Axis(
    AgInfiniiVisionHistogramAxisEnum*  val
);
HRESULT put_Axis(
    AgInfiniiVisionHistogramAxisEnum  val
);

Remarks

  • When the value of IAgInfiniium4Histogram.Mode property is selected as AgInfiniiVisionHistogramModeWaveform, this property specifies the orientation of the histogram
  • When the value of IAgInfiniium4Histogram.Mode property is selected as AgInfiniiVisionHistogramModeMeasurement, histograms are always displayed horizontally at the bottom of the graticule.
  • Preset value is AgInfiniiVisionHistogramAxisHorizontal.

    • Instrument Command

    :HISTogram:AXIS {VERTical|HORizontal}
    :HISTogram:AXIS?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


DisplayEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.DisplayEnabled Property
IAgInfiniiVision4Histogram See Also

Enable or disable the histogram display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DisplayEnabled As Boolean
C#
public bool  DisplayEnabled { get; set; }
Visual C++
HRESULT get_DisplayEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DisplayEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Preset value is false.

    • Instrument Command

    :HISTogram:DISPlay {1|0}
    :HISTogram:DISPlay?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


GetResult Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.GetResult Method
IAgInfiniiVision4Histogram See Also

Returns the histogram result of the selected result type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetResult ( _
    ByVal  ResultType As AgInfiniiVisionHistogramResultTypeEnum  _
) As Double
C#
public double  GetResult(
    AgInfiniiVisionHistogramResultTypeEnum  ResultType
)
Visual C++
HRESULT GetResult(
    AgInfiniiVisionHistogramResultTypeEnum  ResultType
    double*  retval
);

Parameters

ResultType

Result type.

Return Value

The histogram result of the selected result type.

Remarks

  • Available when Mode property is set to AgInfiniiVisionHistogramModeMeasurement and DisplayEnabled property is set to true.

    • Instrument Command

    :MEASure:HISTogram:{BWIDth|HITS|M1S|M2S|M3S|MAXimum|MEAN|MEDian|MINimum|MODE|PEAK|PPEak|SDEViation}?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


Measurement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Measurement Property
IAgInfiniiVision4Histogram See Also

The measurement to analyze.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Measurement As AgInfiniiVisionMeasurementSlotEnum
C#
public AgInfiniiVisionMeasurementSlotEnum  Measurement { get; set; }
Visual C++
HRESULT get_Measurement(
    AgInfiniiVisionMeasurementSlotEnum*  val
);
HRESULT put_Measurement(
    AgInfiniiVisionMeasurementSlotEnum  val
);

Remarks

  • Available when Mode property is set to AgInfiniiVisionHistogramModeMeasurement.
  • You can select a measurement slot if a measurement is installed at that slot using AgInfiniiVisionMeasurementEnum

    • Instrument Command

    :HISTogram:MEASurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
    :HISTogram:MEASurement?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Mode Property
IAgInfiniiVision4Histogram See Also

The type of histogram or disables the histogram analysis feature.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionHistogramModeEnum
C#
public AgInfiniiVisionHistogramModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionHistogramModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionHistogramModeEnum  val
);

Remarks

  • Preset value is AgInfiniiVisionHistogramModeOff.

    • Instrument Command

    :HISTogram:MODE {OFF|WAVeform|MEASurement}
    :HISTogram:MODE?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Reset Method
IAgInfiniiVision4Histogram See Also

Zeros the histogram counters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Instrument Command

:HISTogram:RESet

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4Histogram Interface
Agilent.AgInfiniiVision.Interop Namespace


Size Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Size Property
IAgInfiniiVision4Histogram See Also

The number of divisions the histogram bar graph should use.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Size As Double
C#
public double  Size { get; set; }
Visual C++
HRESULT get_Size(
    double*  val
);
HRESULT put_Size(
    double  val
);

Remarks

  • For horizontal histograms, whole and half divisions from 1 to 4 can be selected as input.
  • For vertical histograms, whole and half divisions from 1 to 5 can be selected as input.

    • Instrument Command

    :HISTogram:SIZE {value}
    :HISTogram:SIZE?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Type Property
IAgInfiniiVision4Histogram See Also

The histogram type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionHistogramTypeEnum
C#
public AgInfiniiVisionHistogramTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionHistogramTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionHistogramTypeEnum  val
);

Remarks

  • Preset value is AgInfiniiVIsionHistogramTypeHorizontal.

    • Instrument Command

    :HISTogram:TYPE {VERTical|HORizontal|MEASurement}
    :HISTogram:TYPE?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Histogram Interface
    Agilent.AgInfiniiVision.Interop Namespace


Window Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram..::.Window Property
IAgInfiniiVision4Histogram See Also

Pointer to the IAgInfiniiVision4HistogramWindow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Window As IAgInfiniiVision4HistogramWindow
C#
public IAgInfiniiVision4HistogramWindow  Window { get; }
Visual C++
HRESULT get_Window(
    IAgInfiniiVision4HistogramWindow**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4Histogram Interface
Agilent.AgInfiniiVision.Interop Namespace


Limits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindow..::.Limits Property
IAgInfiniiVision4HistogramWindow See Also

Pointer to the IAgInfiniiVision4HistogramWindowLimits interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Limits As IAgInfiniiVision4HistogramWindowLimits
C#
public IAgInfiniiVision4HistogramWindowLimits  Limits { get; }
Visual C++
HRESULT get_Limits(
    IAgInfiniiVision4HistogramWindowLimits**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4HistogramWindow Interface
Agilent.AgInfiniiVision.Interop Namespace


Bottom Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindowLimits..::.Bottom Property
IAgInfiniiVision4HistogramWindowLimits See Also

The histogram limits window's bottom boundary.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Bottom As Double
C#
public double  Bottom { get; set; }
Visual C++
HRESULT get_Bottom(
    double*  val
);
HRESULT put_Bottom(
    double  val
);

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is -15.0.

    • Instrument Command

    :HISTogram:WINDow:BLIMit {value}
    :HISTogram:WINDow:BLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4HistogramWindowLimits Interface
    Agilent.AgInfiniiVision.Interop Namespace


Left Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindowLimits..::.Left Property
IAgInfiniiVision4HistogramWindowLimits See Also

The histogram limits window's left boundary.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Left As Double
C#
public double  Left { get; set; }
Visual C++
HRESULT get_Left(
    double*  val
);
HRESULT put_Left(
    double  val
);

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is -400.0E-06.

    • Instrument Command

    :HISTogram:WINDow:LLIMit {value}
    :HISTogram:WINDow:LLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4HistogramWindowLimits Interface
    Agilent.AgInfiniiVision.Interop Namespace


Right Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindowLimits..::.Right Property
IAgInfiniiVision4HistogramWindowLimits See Also

The histogram limits window's right boundary.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Right As Double
C#
public double  Right { get; set; }
Visual C++
HRESULT get_Right(
    double*  val
);
HRESULT put_Right(
    double  val
);

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is 400.0E-06.

    • Instrument Command

    :HISTogram:WINDow:RLIMit {value}
    :HISTogram:WINDow:RLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4HistogramWindowLimits Interface
    Agilent.AgInfiniiVision.Interop Namespace


Top Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindowLimits..::.Top Property
IAgInfiniiVision4HistogramWindowLimits See Also

The histogram limits window's top boundary.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Top As Double
C#
public double  Top { get; set; }
Visual C++
HRESULT get_Top(
    double*  val
);
HRESULT put_Top(
    double  val
);

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is 15.0.

    • Instrument Command

    :HISTogram:WINDow:TLIMit {value}
    :HISTogram:WINDow:TLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4HistogramWindowLimits Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindow..::.Source Property
IAgInfiniiVision4HistogramWindow See Also

The waveform that is used as the histogram source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

Input value could be one of the following

  • Channel1 to Number of analog channels.
  • Math1, Math2, Math3 or Math4.
  • WMEM1 to number of reference waveforms.

The preset value is Channel1.

Instrument Command

:HISTogram:WINDow:SOURce {value}
:HISTogram:WINDow:SOURce?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4HistogramWindow Interface
Agilent.AgInfiniiVision.Interop Namespace


Identity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.Identity Property
IIviDriver See Also

Pointer to the IIviDriverIdentity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Identity As IIviDriverIdentity
C#
public IIviDriverIdentity  Identity { get; }
Visual C++
HRESULT get_Identity(
    IIviDriverIdentity**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Description Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviComponentIdentity..::.Description Property
IIviComponentIdentity See Also

Read Only - A brief description of the implementing component. Description is limited to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Description As String
C#
public string  Description { get; }
Visual C++
HRESULT get_Description(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


GroupCapabilities Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.GroupCapabilities Property
IIviDriverIdentity See Also

Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property GroupCapabilities As String
C#
public string  GroupCapabilities { get; }
Visual C++
HRESULT get_GroupCapabilities(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Identifier Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.Identifier Property
IIviDriverIdentity See Also

Read Only - The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Identifier As String
C#
public string  Identifier { get; }
Visual C++
HRESULT get_Identifier(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentFirmwareRevision Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.InstrumentFirmwareRevision Property
IIviDriverIdentity See Also

Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentFirmwareRevision As String
C#
public string  InstrumentFirmwareRevision { get; }
Visual C++
HRESULT get_InstrumentFirmwareRevision(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentManufacturer Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.InstrumentManufacturer Property
IIviDriverIdentity See Also

Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentManufacturer As String
C#
public string  InstrumentManufacturer { get; }
Visual C++
HRESULT get_InstrumentManufacturer(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentModel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.InstrumentModel Property
IIviDriverIdentity See Also

Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentModel As String
C#
public string  InstrumentModel { get; }
Visual C++
HRESULT get_InstrumentModel(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Revision Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviComponentIdentity..::.Revision Property
IIviComponentIdentity See Also

Read Only - The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Revision As String
C#
public string  Revision { get; }
Visual C++
HRESULT get_Revision(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


SpecificationMajorVersion Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.SpecificationMajorVersion Property
IIviDriverIdentity See Also

Read Only - For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SpecificationMajorVersion As Integer
C#
public int  SpecificationMajorVersion { get; }
Visual C++
HRESULT get_SpecificationMajorVersion(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


SpecificationMinorVersion Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.SpecificationMinorVersion Property
IIviDriverIdentity See Also

Read Only - For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SpecificationMinorVersion As Integer
C#
public int  SpecificationMinorVersion { get; }
Visual C++
HRESULT get_SpecificationMinorVersion(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


SupportedInstrumentModels Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity..::.SupportedInstrumentModels Property
IIviDriverIdentity See Also

Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SupportedInstrumentModels As String
C#
public string  SupportedInstrumentModels { get; }
Visual C++
HRESULT get_SupportedInstrumentModels(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Vendor Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviComponentIdentity..::.Vendor Property
IIviComponentIdentity See Also

Read Only - The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Vendor As String
C#
public string  Vendor { get; }
Visual C++
HRESULT get_Vendor(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


Initialize Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.Initialize Method
IIviDriver See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Initialize ( _
    ByVal  ResourceName As String  _
    ByVal  IdQuery As Boolean  _
    ByVal  Reset As Boolean  _
    ByVal  OptionString As String  _
)
C#
public void  Initialize(
    string  ResourceName,
    bool  IdQuery,
    bool  Reset,
    string  OptionString
)
Visual C++
HRESULT Initialize(
    BSTR  ResourceName,
    VARIANT_BOOL  IdQuery,
    VARIANT_BOOL  Reset,
    BSTR  OptionString
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

OptionString

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

Remarks

For detailed parameter usage see: Initializing the IVI-COM Driver

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Initialized Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.Initialized Property
IIviDriver See Also

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Initialized As Boolean
C#
public bool  Initialized { get; }
Visual C++
HRESULT get_Initialized(
    VARIANT_BOOL*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Jitter Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Jitter Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVision4Jitter interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Jitter As IAgInfiniiVision4Jitter
C#
public IAgInfiniiVision4Jitter  Jitter { get; }
Visual C++
HRESULT get_Jitter(
    IAgInfiniiVision4Jitter**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


AnalysisEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter..::.AnalysisEnabled Property
IAgInfiniiVision4Jitter See Also

Enables or disables the jitter analysis feature.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AnalysisEnabled As Boolean
C#
public bool  AnalysisEnabled { get; set; }
Visual C++
HRESULT get_AnalysisEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_AnalysisEnabled(
    VARIANT_BOOL  val
);

Remarks

When jitter analysis is enabled, these oscilloscope settings are forced on:

  • Precision measurements with a 1M precision analysis record length, which gives better accuracy.
  • All edges in each acquisition are measured (instead of a single edge per acquisition, as is normally the case). For each acquisition, the measurement count increases by the number of edges in the acquisition. This applies to all measurements that look at edges, not just jitter analysis measurements.

When jitter analysis is disabled:
  • The "precision measurements" and 1M precision analysis record length settings are returned to the settings present when jitter analysis was enabled.
  • The oscilloscope returns to measuring a specific edge in each acquisition (generally around the horizontal time reference) and ignoring all other edges in the acquisition, as is normally the case. For each acquisition, the measurement count increases by one.

The preset value is false.

Instrument Command

:JITTer:STATe {1|0}
:JITTer:STATe?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4Jitter Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureHistogram Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter..::.ConfigureHistogram Method
IAgInfiniiVision4Jitter See Also

Auto-configures and turns on the jitter measurement histogram for the selected measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureHistogram ( _
)
C#
public void  ConfigureHistogram(
)
Visual C++
HRESULT ConfigureHistogram(
);

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:HISTogram:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4Jitter Interface
    Agilent.AgInfiniiVision.Interop Namespace


Measurement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter..::.Measurement Property
IAgInfiniiVision4Jitter See Also

The measurement to analyze.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Measurement As AgInfiniiVisionMeasurementSlotEnum
C#
public AgInfiniiVisionMeasurementSlotEnum  Measurement { get; set; }
Visual C++
HRESULT get_Measurement(
    AgInfiniiVisionMeasurementSlotEnum*  val
);
HRESULT put_Measurement(
    AgInfiniiVisionMeasurementSlotEnum  val
);

Remarks

The measurement slot you specify must have one of these measurements installed:

  • Data TIE (time interval error).
  • Time interval error measurements use clock recovery.
  • Clock TIE (time interval error).
  • Time interval error measurements use clock recovery.
  • N-Period.
  • N-Period to N-Period.
  • +Width to +Width.
  • -Width to -Width.
  • +Duty Cycle.

Instrument Command

:JITTer:MEASurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
:JITTer:MEASurement?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision4Jitter Interface
Agilent.AgInfiniiVision.Interop Namespace


Spectrum Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter..::.Spectrum Property
IAgInfiniiVision4Jitter See Also

Pointer to the IAgInfiniiVision4JitterSpectrum interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Spectrum As IAgInfiniiVision4JitterSpectrum
C#
public IAgInfiniiVision4JitterSpectrum  Spectrum { get; }
Visual C++
HRESULT get_Spectrum(
    IAgInfiniiVision4JitterSpectrum**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4Jitter Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrum..::.Configure Method
IAgInfiniiVision4JitterSpectrum See Also

Auto-configures and turns on the jitter spectrum for the selected measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
)
C#
public void  Configure(
)
Visual C++
HRESULT Configure(
);

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:SPECtrum:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrum Interface
    Agilent.AgInfiniiVision.Interop Namespace


Horizontal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrum..::.Horizontal Property
IAgInfiniiVision4JitterSpectrum See Also

Pointer to the IAgInfiniiVision4JitterSpectrumHorizontal interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Horizontal As IAgInfiniiVision4JitterSpectrumHorizontal
C#
public IAgInfiniiVision4JitterSpectrumHorizontal  Horizontal { get; }
Visual C++
HRESULT get_Horizontal(
    IAgInfiniiVision4JitterSpectrumHorizontal**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4JitterSpectrum Interface
Agilent.AgInfiniiVision.Interop Namespace


CenterFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumHorizontal..::.CenterFrequency Property
IAgInfiniiVision4JitterSpectrumHorizontal See Also

The center frequency for the jitter measurement spectrum.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Remarks

  • Preset value is 50.000E+03.

    • Instrument Command

    :JITTer:SPECtrum:HORizontal:POSition {value}
    :JITTer:SPECtrum:HORizontal:POSition?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrumHorizontal Interface
    Agilent.AgInfiniiVision.Interop Namespace


FrequencySpan Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumHorizontal..::.FrequencySpan Property
IAgInfiniiVision4JitterSpectrumHorizontal See Also

The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property FrequencySpan As Double
C#
public double  FrequencySpan { get; set; }
Visual C++
HRESULT get_FrequencySpan(
    double*  val
);
HRESULT put_FrequencySpan(
    double  val
);

Remarks

  • Preset value is 100E+03.

    • Instrument Command

    :JITTer:SPECtrum:HORizontal:RANGe {value}
    :JITTer:SPECtrum:HORizontal:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrumHorizontal Interface
    Agilent.AgInfiniiVision.Interop Namespace


Vertical Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrum..::.Vertical Property
IAgInfiniiVision4JitterSpectrum See Also

Pointer to the IAgInfiniiVision4JitterSpectrumVertical interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Vertical As IAgInfiniiVision4JitterSpectrumVertical
C#
public IAgInfiniiVision4JitterSpectrumVertical  Vertical { get; }
Visual C++
HRESULT get_Vertical(
    IAgInfiniiVision4JitterSpectrumVertical**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4JitterSpectrum Interface
Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumVertical..::.Offset Property
IAgInfiniiVision4JitterSpectrumVertical See Also

The vertical value represented at center screen for the jitter measurement spectrum.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

  • Preset value is 0.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:OFFSet {value}
    :JITTer:SPECtrum:VERTical:OFFSet?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrumVertical Interface
    Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumVertical..::.Range Property
IAgInfiniiVision4JitterSpectrumVertical See Also

The full-scale vertical range for the jitter measurement spectrum.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

  • Preset value is 8.00E+00.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:RANGe {value}
    :JITTer:SPECtrum:VERTical:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrumVertical Interface
    Agilent.AgInfiniiVision.Interop Namespace


Unit Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumVertical..::.Unit Property
IAgInfiniiVision4JitterSpectrumVertical See Also

The vertical units for the jitter spectrum.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Unit As AgInfiniiVisionJitterSpectrumVerticalUnitEnum
C#
public AgInfiniiVisionJitterSpectrumVerticalUnitEnum  Unit { get; set; }
Visual C++
HRESULT get_Unit(
    AgInfiniiVisionJitterSpectrumVerticalUnitEnum*  val
);
HRESULT put_Unit(
    AgInfiniiVisionJitterSpectrumVerticalUnitEnum  val
);

Remarks

  • Preset value is AgInfiniiVisionJitterSpectrumVerticalUnitDecibel.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:TYPE {DECibel|VRMS}
    :JITTer:SPECtrum:VERTical:TYPE?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrumVertical Interface
    Agilent.AgInfiniiVision.Interop Namespace


Window Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrum..::.Window Property
IAgInfiniiVision4JitterSpectrum See Also

Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Window As AgInfiniiVisionJitterSpectrumWindowEnum
C#
public AgInfiniiVisionJitterSpectrumWindowEnum  Window { get; set; }
Visual C++
HRESULT get_Window(
    AgInfiniiVisionJitterSpectrumWindowEnum*  val
);
HRESULT put_Window(
    AgInfiniiVisionJitterSpectrumWindowEnum  val
);

Remarks

  • The jitter spectrum operation assumes that the time record repeats. Unless an integral number of sampled waveform cycles exist in the record, a discontinuity is created between the end of one record and the beginning of the next. This discontinuity introduces additional frequency components about the peaks into the spectrum. This is referred to as leakage. To minimize leakage, windows that approach zero smoothly at the start and end of the record are employed as filters to the FFTs. Each window is useful for certain classes of input signals.
  • Preset value is AgInfiniiVisionJitterSpectrumWindowHanning.

    • Instrument Command

    :JITTer:SPECtrum:WINDow {RECTangular|HANNing|FLATtop|BHARris}
    :JITTer:SPECtrum:WINDow?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterSpectrum Interface
    Agilent.AgInfiniiVision.Interop Namespace


Trend Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter..::.Trend Property
IAgInfiniiVision4Jitter See Also

Pointer to the IAgInfiniiVision4JitterTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trend As IAgInfiniiVision4JitterTrend
C#
public IAgInfiniiVision4JitterTrend  Trend { get; }
Visual C++
HRESULT get_Trend(
    IAgInfiniiVision4JitterTrend**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4Jitter Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrend..::.Configure Method
IAgInfiniiVision4JitterTrend See Also

Auto-configures and turns on the jitter measurement trend for the selected measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
)
C#
public void  Configure(
)
Visual C++
HRESULT Configure(
);

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:TRENd:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterTrend Interface
    Agilent.AgInfiniiVision.Interop Namespace


ConfigureSmoothing Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrend..::.ConfigureSmoothing Method
IAgInfiniiVision4JitterTrend See Also

Auto-configures and turns on smoothing for the jitter measurement trend.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureSmoothing ( _
)
C#
public void  ConfigureSmoothing(
)
Visual C++
HRESULT ConfigureSmoothing(
);

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:TRENd:SMOoth:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterTrend Interface
    Agilent.AgInfiniiVision.Interop Namespace


SmoothingPoints Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrend..::.SmoothingPoints Property
IAgInfiniiVision4JitterTrend See Also

The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SmoothingPoints As Integer
C#
public int  SmoothingPoints { get; set; }
Visual C++
HRESULT get_SmoothingPoints(
    long*  val
);
HRESULT put_SmoothingPoints(
    long  val
);

Remarks

  • The input value can be an odd number of points, from 3 up to half of the measurement record or precision analysis record.
  • Preset value is 5.

    • Instrument Command

    :JITTer:TRENd:SMOoth:POINts {value}
    :JITTer:TRENd:SMOoth:POINts?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterTrend Interface
    Agilent.AgInfiniiVision.Interop Namespace


Vertical Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrend..::.Vertical Property
IAgInfiniiVision4JitterTrend See Also

Pointer to the IAgInfiniiVision4JitterTrendVertical interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Vertical As IAgInfiniiVision4JitterTrendVertical
C#
public IAgInfiniiVision4JitterTrendVertical  Vertical { get; }
Visual C++
HRESULT get_Vertical(
    IAgInfiniiVision4JitterTrendVertical**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4JitterTrend Interface
Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrendVertical..::.Offset Property
IAgInfiniiVision4JitterTrendVertical See Also

The vertical value represented at center screen for the jitter measurement trend.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

  • Preset value is 0.

    • Instrument Command

    :JITTer:TRENd:VERTical:OFFSet {value}
    :JITTer:TRENd:VERTical:OFFSet?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterTrendVertical Interface
    Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrendVertical..::.Range Property
IAgInfiniiVision4JitterTrendVertical See Also

The full-scale vertical range for the jitter measurement trend.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

  • Preset value is +8.00E+00.

    • Instrument Command

    :JITTer:TRENd:VERTical:RANGe {value}
    :JITTer:TRENd:VERTical:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVision4JitterTrendVertical Interface
    Agilent.AgInfiniiVision.Interop Namespace


MaskTest Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.MaskTest Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MaskTest As IAgInfiniiVisionMaskTest
C#
public IAgInfiniiVisionMaskTest  MaskTest { get; }
Visual C++
HRESULT get_MaskTest(
    IAgInfiniiVisionMaskTest**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


AllChannelEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.AllChannelEnabled Property
IAgInfiniiVisionMaskTest See Also

Enables all analog channels to be included in the mask test or only selected channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AllChannelEnabled As Boolean
C#
public bool  AllChannelEnabled { get; set; }
Visual C++
HRESULT get_AllChannelEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_AllChannelEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:ALL {ON|OFF}
:MTESt:ALL?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoMask Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.AutoMask Method
IAgInfiniiVisionMaskTest See Also

Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoMask ( _
)
C#
public void  AutoMask(
)
Visual C++
HRESULT AutoMask(
);

Remarks

The mask only encompasses the portion of the waveform visible on the display, so you must ensure that the waveform is acquired and displayed consistently to obtain repeatable results.

Instrument Command

:MTESt:AMASk:CREate

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoMaskUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.AutoMaskUnits Property
IAgInfiniiVisionMaskTest See Also

Measurement units for automask which interprets the tolerance parameters for automasking.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AutoMaskUnits As AgInfiniiVisionMaskTestUnitsEnum
C#
public AgInfiniiVisionMaskTestUnitsEnum  AutoMaskUnits { get; set; }
Visual C++
HRESULT get_AutoMaskUnits(
    AgInfiniiVisionMaskTestUnitsEnum*  val
);
HRESULT put_AutoMaskUnits(
    AgInfiniiVisionMaskTestUnitsEnum  val
);

Instrument Command

:MTESt:AMASk:UNITs {CURR|DIV}
:MTESt:AMASk:UNITs?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


BindControlEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.BindControlEnabled Property
IAgInfiniiVisionMaskTest See Also

Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BindControlEnabled As Boolean
C#
public bool  BindControlEnabled { get; set; }
Visual C++
HRESULT get_BindControlEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_BindControlEnabled(
    VARIANT_BOOL  val
);

Remarks

  • If the Bind 1 & 0 Levels control is enabled, the 1 Level and the 0 Level controls track each other. Adjusting either the 1 Level or the 0 Level control shifts the position of the mask up or down without changing its size.
  • If the Bind 1 & 0 Levels control is disabled, adjusting either the 1 Level or the 0 Level control changes the vertical height of the mask
  • If the Bind -1 & 0 Levels control is enabled, the -1 Level and the 0 Level controls track each other. Adjusting either the -1 Level or the 0 Level control shifts the position of the mask up or down without changing its size.
  • If the Bind -1 & 0 Levels control is disabled, adjusting either the -1 Level or the 0 Level control changes the vertical height of the mask.

    • Instrument Command

    :MTESt:SCALe:BIND {ON|OFF}
    :MTESt:SCALe:BIND?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMaskTest Interface
    Agilent.AgInfiniiVision.Interop Namespace


Configuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Configuration Property
IAgInfiniiVisionMaskTest See Also

Pointer to the IAgInfiniiVisionMaskTestConfiguration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Configuration As IAgInfiniiVisionMaskTestConfiguration
C#
public IAgInfiniiVisionMaskTestConfiguration  Configuration { get; }
Visual C++
HRESULT get_Configuration(
    IAgInfiniiVisionMaskTestConfiguration**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


MeasurementEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.MeasurementEnabled Property
IAgInfiniiVisionMaskTestConfiguration See Also

Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MeasurementEnabled As Boolean
C#
public bool  MeasurementEnabled { get; set; }
Visual C++
HRESULT get_MeasurementEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_MeasurementEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:RMODe:FACTion:MEASure {ON|OFF}
:MTESt:RMODe:FACTion:MEASure?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


SigmaLevel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.SigmaLevel Property
IAgInfiniiVisionMaskTestConfiguration See Also

Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SigmaLevel As Double
C#
public double  SigmaLevel { get; set; }
Visual C++
HRESULT get_SigmaLevel(
    double*  val
);
HRESULT put_SigmaLevel(
    double  val
);

Instrument Command

:MTESt:RMODe:SIGMa {value}
:MTESt:RMODe:SIGMa?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.Source Property
IAgInfiniiVisionMaskTestConfiguration See Also

The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:MTESt:SOURce {value}
:MTESt:SOURce?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TerminationCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.TerminationCondition Property
IAgInfiniiVisionMaskTestConfiguration See Also

The termination conditions for the mask test.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TerminationCondition As AgInfiniiVisionMaskTestTerminationConditionEnum
C#
public AgInfiniiVisionMaskTestTerminationConditionEnum  TerminationCondition { get; set; }
Visual C++
HRESULT get_TerminationCondition(
    AgInfiniiVisionMaskTestTerminationConditionEnum*  val
);
HRESULT put_TerminationCondition(
    AgInfiniiVisionMaskTestTerminationConditionEnum  val
);

Instrument Command

:MTESt:RMODe {FOR|SIGM|TIME|WAV}
:MTESt:RMODe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TerminationEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.TerminationEnabled Property
IAgInfiniiVisionMaskTestConfiguration See Also

Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TerminationEnabled As Boolean
C#
public bool  TerminationEnabled { get; set; }
Visual C++
HRESULT get_TerminationEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_TerminationEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:RMODe:FACTion:STOP {ON|OFF}
:MTESt:RMODe:FACTion:STOP?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Time Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.Time Property
IAgInfiniiVisionMaskTestConfiguration See Also

The number of seconds for a mask test to run. Permissible Range is 1 to 86400.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Time As Double
C#
public double  Time { get; set; }
Visual C++
HRESULT get_Time(
    double*  val
);
HRESULT put_Time(
    double  val
);

Instrument Command

:MTESt:RMODe:TIME {value}
:MTESt:RMODe:TIME?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Waveform Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration..::.Waveform Property
IAgInfiniiVisionMaskTestConfiguration See Also

The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Waveform As Long
C#
public long  Waveform { get; set; }
Visual C++
HRESULT get_Waveform(
    __int64*  val
);
HRESULT put_Waveform(
    __int64  val
);

Instrument Command

:MTESt:RMODe:WAVeforms {value}
:MTESt:RMODe:WAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Delete Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Delete Method
IAgInfiniiVisionMaskTest See Also

Deletes the currently loaded mask.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Delete ( _
)
C#
public void  Delete(
)
Visual C++
HRESULT Delete(
);

Instrument Command

:MTESt:DELete

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


ElapsedTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.ElapsedTime Property
IAgInfiniiVisionMaskTest See Also

Read Only - Elapsed time (in seconds) in the current mask test run.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ElapsedTime As Double
C#
public double  ElapsedTime { get; }
Visual C++
HRESULT get_ElapsedTime(
    double*  val
);

Instrument Command

:MTESt:COUNt:TIME?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Enabled Property
IAgInfiniiVisionMaskTest See Also

Enables/Disables the mask test features.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:ENABle {ON|OFF}
:MTESt:ENABle?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


FailedWaveformCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.FailedWaveformCount Property
IAgInfiniiVisionMaskTest See Also

Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FailedWaveformCount As Long
C#
public long  FailedWaveformCount { get; }
Visual C++
HRESULT get_FailedWaveformCount(
    __int64*  val
);

Instrument Command

:MTESt:COUNt:FWAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalTolerance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.HorizontalTolerance Property
IAgInfiniiVisionMaskTest See Also

Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalTolerance As Double
C#
public double  HorizontalTolerance { get; set; }
Visual C++
HRESULT get_HorizontalTolerance(
    double*  val
);
HRESULT put_HorizontalTolerance(
    double  val
);

Remarks

  • The horizontal tolerance value is interpreted based on the AutoMask units.
  • The unit set as Current specifies time in the horizontal direction, therefore tolerance will be in seconds.
  • The unit set as Divisions specifies division, therefore the tolerance will be in division.

    • Instrument Command

    :MTESt:AMASk:XDELta {value}
    :MTESt:AMASk:XDELta?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMaskTest Interface
    Agilent.AgInfiniiVision.Interop Namespace


LockEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.LockEnabled Property
IAgInfiniiVisionMaskTest See Also

Enables/Disables the mask lock.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LockEnabled As Boolean
C#
public bool  LockEnabled { get; set; }
Visual C++
HRESULT get_LockEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_LockEnabled(
    VARIANT_BOOL  val
);

Remarks

When Enabled it locks a mask to the source. As the vertical or horizontal scaling or position of the SOURce changes, the mask is redrawn accordingly.When Disabled the mask is static and does not move.

Instrument Command

:MTESt:LOCK {ON|OFF}
:MTESt:LOCK?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


Markers Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Markers Property
IAgInfiniiVisionMaskTest See Also

Pointer to the IAgInfiniiVisionMaskTestMarkers interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Markers As IAgInfiniiVisionMaskTestMarkers
C#
public IAgInfiniiVisionMaskTestMarkers  Markers { get; }
Visual C++
HRESULT get_Markers(
    IAgInfiniiVisionMaskTestMarkers**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


X1Coordinate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestMarkers..::.X1Coordinate Property
IAgInfiniiVisionMaskTestMarkers See Also

The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property X1Coordinate As Double
C#
public double  X1Coordinate { get; set; }
Visual C++
HRESULT get_X1Coordinate(
    double*  val
);
HRESULT put_X1Coordinate(
    double  val
);

Remarks

Once the X1 and XDELta coordinates are set, all X values of vertices in the mask regions are defined with respect to this value, according to the equation: X = (X * deltaX) + X1 Thus, if you set X1 to 100 ms, and XDELta to 100 ms, an X value of 0.100 is a vertex at 110 ms. The oscilloscope uses this equation to normalize vertices. This simplifies reprogramming to handle different data rates. For example, if you halve the period of the waveform of interest, you need only to adjust the XDELta value to set up the mask for the new waveform.

Instrument Command

:MTESt:SCALe:X1 {value}
:MTESt:SCALe:X1?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestMarkers Interface
Agilent.AgInfiniiVision.Interop Namespace


XDelta Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestMarkers..::.XDelta Property
IAgInfiniiVisionMaskTestMarkers See Also

The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property XDelta As Double
C#
public double  XDelta { get; set; }
Visual C++
HRESULT get_XDelta(
    double*  val
);
HRESULT put_XDelta(
    double  val
);

Remarks

Because all X vertices of the regions defined for mask testing are normalized with respect to X1 and deltaX, redefining deltaX also moves those vertices to stay in the same locations with respect to X1 and deltaX. Thus, in many applications, it is best if you define XDELta as a pulse width or bit period. Then, a change in data rate without corresponding changes in the waveform can easily be handled by changing deltaX. The X-coordinate of polygon vertices is normalized using this equation: X = (X * deltaX) + X1 The X delta value is a time value specifying the distance of the X2 marker with respect to the X1 marker. For example, if the period of the waveform you wish to test is 1 ms, setting deltaX to 1 ms ensures that the waveform's period is between the X1 and X2 markers.

Instrument Command

:MTESt:SCALe:XDELta {value}
:MTESt:SCALe:XDELta?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestMarkers Interface
Agilent.AgInfiniiVision.Interop Namespace


Y1Coordinate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestMarkers..::.Y1Coordinate Property
IAgInfiniiVisionMaskTestMarkers See Also

Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Y1Coordinate As Double
C#
public double  Y1Coordinate { get; set; }
Visual C++
HRESULT get_Y1Coordinate(
    double*  val
);
HRESULT put_Y1Coordinate(
    double  val
);

Remarks

All Y values of vertices in the coordinate system are defined with respect to the boundaries set by SCALe:Y1 and SCALe:Y2 according to the equation: Y = (Y * (Y2 - Y1)) + Y1 Thus, if you set Y1 to 100 mV, and Y2 to 1 V, a Y value of 0.100 in a vertex is at 190 mV.

Instrument Command

:MTESt:SCALe:Y1 {value}
:MTESt:SCALe:Y1?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestMarkers Interface
Agilent.AgInfiniiVision.Interop Namespace


Y2Coordinate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestMarkers..::.Y2Coordinate Property
IAgInfiniiVisionMaskTestMarkers See Also

Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Y2Coordinate As Double
C#
public double  Y2Coordinate { get; set; }
Visual C++
HRESULT get_Y2Coordinate(
    double*  val
);
HRESULT put_Y2Coordinate(
    double  val
);

Remarks

All Y values of vertices in the coordinate system are defined with respect to the boundaries set by SCALe:Y1 and SCALe:Y2 according to the equation: Y = (Y * (Y2 - Y1)) + Y1 Thus, if you set Y1 to 100 mV, and Y2 to 1 V, a Y value of 0.100 in a vertex is at 190 mV.

Instrument Command

:MTESt:SCALe:Y2 {value}
:MTESt:SCALe:Y2?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTestMarkers Interface
Agilent.AgInfiniiVision.Interop Namespace


PrintFailuresEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.PrintFailuresEnabled Property
IAgInfiniiVisionMaskTest See Also

Enables/Disables printing on mask failure.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PrintFailuresEnabled As Boolean
C#
public bool  PrintFailuresEnabled { get; set; }
Visual C++
HRESULT get_PrintFailuresEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_PrintFailuresEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:RMODe:FACTion:PRINt {ON|OFF}
:MTESt:RMODe:FACTion:PRINt?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Reset Method
IAgInfiniiVisionMaskTest See Also

Resets the mask statistics.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Instrument Command

:MTESt:COUNt:RESet

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


SaveFailuresEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.SaveFailuresEnabled Property
IAgInfiniiVisionMaskTest See Also

Enables/Disables saving on mask failure.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SaveFailuresEnabled As Boolean
C#
public bool  SaveFailuresEnabled { get; set; }
Visual C++
HRESULT get_SaveFailuresEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_SaveFailuresEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MTESt:RMODe:FACTion:SAVE {ON|OFF}
:MTESt:RMODe:FACTion:SAVE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


Title Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.Title Property
IAgInfiniiVisionMaskTest See Also

Read Only - Returns the mask title which is a string of up to 128 characters

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Title As String
C#
public string  Title { get; }
Visual C++
HRESULT get_Title(
    BSTR*  val
);

Instrument Command

:MTESt:TITLe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


VerticalTolerance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.VerticalTolerance Property
IAgInfiniiVisionMaskTest See Also

The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalTolerance As Double
C#
public double  VerticalTolerance { get; set; }
Visual C++
HRESULT get_VerticalTolerance(
    double*  val
);
HRESULT put_VerticalTolerance(
    double  val
);

Remarks

  • The vertical tolerance value is interpreted based on the AutoMask units.
  • The unit set as Current specifies voltage in the vertical direction, therefore tolerance will be in voltage.
  • The unit set as Divisions specifies division, therefore the tolerance will be in division.

    • Instrument Command

    :MTESt:AMASk:YDELta {value}
    :MTESt:AMASk:YDELta?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMaskTest Interface
    Agilent.AgInfiniiVision.Interop Namespace


WaveformCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest..::.WaveformCount Property
IAgInfiniiVisionMaskTest See Also

Read Only - The total number of waveforms acquired in the current mask test run.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WaveformCount As Integer
C#
public int  WaveformCount { get; }
Visual C++
HRESULT get_WaveformCount(
    long*  val
);

Instrument Command

:MTESt:COUNt:WAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMaskTest Interface
Agilent.AgInfiniiVision.Interop Namespace


Math Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Math Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionMath interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Math As IAgInfiniiVisionMath
C#
public IAgInfiniiVisionMath  Math { get; }
Visual C++
HRESULT get_Math(
    IAgInfiniiVisionMath**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Enabled Property
IAgInfiniiVisionMath See Also

Enables/Disables the math function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:DISPlay {ON|OFF}
    :FUNCtion:DISPlay?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


FFT Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.FFT Property
IAgInfiniiVisionMath See Also

Pointer to the IAgInfiniiVisionMathFFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FFT As IAgInfiniiVisionMathFFT
C#
public IAgInfiniiVisionMathFFT  FFT { get; }
Visual C++
HRESULT get_FFT(
    IAgInfiniiVisionMathFFT**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMath Interface
Agilent.AgInfiniiVision.Interop Namespace


CenterFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT..::.CenterFrequency Property
IAgInfiniiVisionMathFFT See Also

Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Remarks

  • The Unit of Frequency is Hz.
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:CENTer {value}
    :FUNCtion:CENTer?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


Span Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT..::.Span Property
IAgInfiniiVisionMathFFT See Also

Frequency span of the display when FFT is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Span As Double
C#
public double  Span { get; set; }
Visual C++
HRESULT get_Span(
    double*  val
);
HRESULT put_Span(
    double  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SPAN {value}
    :FUNCtion:SPAN?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


WindowType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT..::.WindowType Property
IAgInfiniiVisionMathFFT See Also

Windowing transforms for the FFT.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WindowType As AgInfiniiVisionMathFFTWindowTypeEnum
C#
public AgInfiniiVisionMathFFTWindowTypeEnum  WindowType { get; set; }
Visual C++
HRESULT get_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum*  val
);
HRESULT put_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:WINDow {RECT|HANN|FLAT|BHAR}
    :FUNCtion:WINDow?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


InternalOperation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.InternalOperation Property
IAgInfiniiVisionMath See Also

Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InternalOperation As AgInfiniiVisionMathIntOperationEnum
C#
public AgInfiniiVisionMathIntOperationEnum  InternalOperation { get; set; }
Visual C++
HRESULT get_InternalOperation(
    AgInfiniiVisionMathIntOperationEnum*  val
);
HRESULT put_InternalOperation(
    AgInfiniiVisionMathIntOperationEnum  val
);

Remarks

  • Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:OPERation {ADD|SUBT|MULT}
    :FUNCtion:GOFT:OPERation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


InternalSource1 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.InternalSource1 Property
IAgInfiniiVisionMath See Also

Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InternalSource1 As String
C#
public string  InternalSource1 { get; set; }
Visual C++
HRESULT get_InternalSource1(
    BSTR*  val
);
HRESULT put_InternalSource1(
    BSTR  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:SOURce1 {value}
    :FUNCtion:GOFT:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


InternalSource2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.InternalSource2 Property
IAgInfiniiVisionMath See Also

Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InternalSource2 As String
C#
public string  InternalSource2 { get; set; }
Visual C++
HRESULT get_InternalSource2(
    BSTR*  val
);
HRESULT put_InternalSource2(
    BSTR  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:SOURce2 {value}
    :FUNCtion:GOFT:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Offset Property
IAgInfiniiVisionMath See Also

Voltage or vertical value represented at center screen for the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:OFFSet {value}
    :FUNCtion:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Operation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Operation Property
IAgInfiniiVisionMath See Also

Waveform math operation

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Operation As AgInfiniiVisionMathOperationsEnum
C#
public AgInfiniiVisionMathOperationsEnum  Operation { get; set; }
Visual C++
HRESULT get_Operation(
    AgInfiniiVisionMathOperationsEnum*  val
);
HRESULT put_Operation(
    AgInfiniiVisionMathOperationsEnum  val
);

Remarks

  • The Bus Timing and Bus State Selections are only available if an MSO license is installed.
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:OPERation {ADD|SUBT|MULT|FFT|INT|DIFF|SQRT|MAGN|ABS|LN|LOG|EXP|TEN|LOWP|HIGH|DIV|LIN|TREN|BTIM|BST|SQU|AVER|MAXHold|MINHold|CLOCk|SMOoth|ENV|FFTP}
    :FUNCtion:OPERation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Range Property
IAgInfiniiVisionMath See Also

Range of Full-scale vertical axis for the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:RANGe {value}
    :FUNCtion:RANGe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source1 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Source1 Property
IAgInfiniiVisionMath See Also

First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source1 As String
C#
public string  Source1 { get; set; }
Visual C++
HRESULT get_Source1(
    BSTR*  val
);
HRESULT put_Source1(
    BSTR  val
);

Remarks

The Source1 property can be specified in one of the following string formats:

  • Channel<n>, where n: 1 to the number of analog channels available
  • GOFT
  • Bus<m>, where m: 1 or 2
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SOURce1 {value}
    :FUNCtion:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.Source2 Property
IAgInfiniiVisionMath See Also

Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source2 As String
C#
public string  Source2 { get; set; }
Visual C++
HRESULT get_Source2(
    BSTR*  val
);
HRESULT put_Source2(
    BSTR  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SOURce2 {value}
    :FUNCtion:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


VerticalScale Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath..::.VerticalScale Property
IAgInfiniiVisionMath See Also

Vertical scale, or units per division, of the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalScale As Double
C#
public double  VerticalScale { get; set; }
Visual C++
HRESULT get_VerticalScale(
    double*  val
);
HRESULT put_VerticalScale(
    double  val
);

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SCALe {value}
    :FUNCtion:SCALe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMath Interface
    Agilent.AgInfiniiVision.Interop Namespace


Math2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Math2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionMath2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Math2 As IAgInfiniiVisionMath2
C#
public IAgInfiniiVisionMath2  Math2 { get; }
Visual C++
HRESULT get_Math2(
    IAgInfiniiVisionMath2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Bus Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.Bus Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2Bus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Bus As IAgInfiniiVisionMath2Bus
C#
public IAgInfiniiVisionMath2Bus  Bus { get; }
Visual C++
HRESULT get_Bus(
    IAgInfiniiVisionMath2Bus**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus..::.ClockSource Property
IAgInfiniiVisionMath2Bus See Also

Specifies the clock signal source for the Chart Logic Bus State operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The ClockSource property can be specified in one of the following formats:

  • "DigitalChannel<d>", where d: 0 to the number of digital channels available minus 1.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:CLOCk {value}
:FUNCtion:BUS:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Bus Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus..::.Slope Property
IAgInfiniiVisionMath2Bus See Also

Specifies the clock signal edge for the Chart Logic Bus State operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionMathBusSlopeEnum
C#
public AgInfiniiVisionMathBusSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionMathBusSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionMathBusSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionMathBusSlopeNegative - specifies negative slope.
  • AgInfiniiVisionMathBusSlopePositive - specifies the positive slope.
  • AgInfiniiVisionMathBusSlopeEither - specifies either negative or positive slope.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:SLOPe {NEG|POS|EITH}
:FUNCtion:BUS:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Bus Interface
Agilent.AgInfiniiVision.Interop Namespace


YIncrement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus..::.YIncrement Property
IAgInfiniiVisionMath2Bus See Also

Specifies the value associated with each increment in Chart Logic Bus data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YIncrement As Double
C#
public double  YIncrement { get; set; }
Visual C++
HRESULT get_YIncrement(
    double*  val
);
HRESULT put_YIncrement(
    double  val
);

Remarks

The units for this property are selected using the YUnits property.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YINCrement {value}
:FUNCtion:BUS:YINCrement?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Bus Interface
Agilent.AgInfiniiVision.Interop Namespace


YOrigin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus..::.YOrigin Property
IAgInfiniiVisionMath2Bus See Also

Specifies the value associated with Chart Logic Bus data equal to zero.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YOrigin As Double
C#
public double  YOrigin { get; set; }
Visual C++
HRESULT get_YOrigin(
    double*  val
);
HRESULT put_YOrigin(
    double  val
);

Remarks

The units for this property are selected using the YUnits property.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YORigin {value}
:FUNCtion:BUS:YORigin?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Bus Interface
Agilent.AgInfiniiVision.Interop Namespace


YUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus..::.YUnits Property
IAgInfiniiVisionMath2Bus See Also

Specifies the vertical units for the Chart Logic Bus operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YUnits As AgInfiniiVisionMathBusYUnitsEnum
C#
public AgInfiniiVisionMathBusYUnitsEnum  YUnits { get; set; }
Visual C++
HRESULT get_YUnits(
    AgInfiniiVisionMathBusYUnitsEnum*  val
);
HRESULT put_YUnits(
    AgInfiniiVisionMathBusYUnitsEnum  val
);

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionMathBusYUnitsVolts - specifies the units as Volts
  • AgInfiniiVisionMathBusYUnitsAmps - specifies the units as Amperes
  • AgInfiniiVisionMathBusYUnitsNone - specifies the units as None

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YUNits {VOLT|AMP|NONE}
:FUNCtion:BUS:YUNits?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Bus Interface
Agilent.AgInfiniiVision.Interop Namespace


FFT2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.FFT2 Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2FFT2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FFT2 As IAgInfiniiVisionMathFFT2
C#
public IAgInfiniiVisionMathFFT2  FFT2 { get; }
Visual C++
HRESULT get_FFT2(
    IAgInfiniiVisionMathFFT2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


VerticalUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT2..::.VerticalUnits Property
IAgInfiniiVisionMathFFT2 See Also

Specifies the FFT vertical units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalUnits As AgInfiniiVisionMathFFTVerticalUnitsEnum
C#
public AgInfiniiVisionMathFFTVerticalUnitsEnum  VerticalUnits { get; set; }
Visual C++
HRESULT get_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum*  val
);
HRESULT put_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum  val
);

Remarks

The VerticalUnits property can be set to one of the following values:

  • AgInfiniiVisionMathFFTVerticalUnitsdB - specifies the FFT vertical units as Decibel
  • AgInfiniiVisionMathFFTVerticalUnitsVRMS - specifies the FFT vertical units as Vrms

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:VTYPe {DEC|VRMS}
:FUNCtion:VTYPe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFFT2 Interface
Agilent.AgInfiniiVision.Interop Namespace


FilterFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.FilterFrequency Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2FilterFrequency interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FilterFrequency As IAgInfiniiVisionMath2FilterFrequency
C#
public IAgInfiniiVisionMath2FilterFrequency  FilterFrequency { get; }
Visual C++
HRESULT get_FilterFrequency(
    IAgInfiniiVisionMath2FilterFrequency**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


HighPassBandwidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2FilterFrequency..::.HighPassBandwidth Property
IAgInfiniiVisionMath2FilterFrequency See Also

Specifies the high-pass filter's -3 dB cutoff frequency.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HighPassBandwidth As Double
C#
public double  HighPassBandwidth { get; set; }
Visual C++
HRESULT get_HighPassBandwidth(
    double*  val
);
HRESULT put_HighPassBandwidth(
    double  val
);

Remarks

This feature is only available if an ADVMATH license is installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:FREQuency:HIGHpass {value}
:FUNCtion:FREQuency:HIGHpass?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2FilterFrequency Interface
Agilent.AgInfiniiVision.Interop Namespace


LowPassBandwidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2FilterFrequency..::.LowPassBandwidth Property
IAgInfiniiVisionMath2FilterFrequency See Also

Specifies the low-pass filter's -3 dB cutoff frequency.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LowPassBandwidth As Double
C#
public double  LowPassBandwidth { get; set; }
Visual C++
HRESULT get_LowPassBandwidth(
    double*  val
);
HRESULT put_LowPassBandwidth(
    double  val
);

Remarks

This feature is only available if an ADVMATH license is installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:FREQuency:LOWPass {value}
:FUNCtion:FREQuency:LOWPass?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2FilterFrequency Interface
Agilent.AgInfiniiVision.Interop Namespace


Integrate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.Integrate Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2Integrate interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Integrate As IAgInfiniiVisionMath2Integrate
C#
public IAgInfiniiVisionMath2Integrate  Integrate { get; }
Visual C++
HRESULT get_Integrate(
    IAgInfiniiVisionMath2Integrate**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


InputOffset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Integrate..::.InputOffset Property
IAgInfiniiVisionMath2Integrate See Also

Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InputOffset As Double
C#
public double  InputOffset { get; set; }
Visual C++
HRESULT get_InputOffset(
    double*  val
);
HRESULT put_InputOffset(
    double  val
);

Remarks

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:INTegrate:IOFFset {value}
:FUNCtion:INTegrate:IOFFset?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMath2Integrate Interface
Agilent.AgInfiniiVision.Interop Namespace


Linear Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.Linear Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2Linear interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Linear As IAgInfiniiVisionMath2Linear
C#
public IAgInfiniiVisionMath2Linear  Linear { get; }
Visual C++
HRESULT get_Linear(
    IAgInfiniiVisionMath2Linear**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Gain Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Linear..::.Gain Property
IAgInfiniiVisionMath2Linear See Also

Specifies the Gain ("A" in Ax + B) for the Linear Math operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Gain As Double
C#
public double  Gain { get; set; }
Visual C++
HRESULT get_Gain(
    double*  val
);
HRESULT put_Gain(
    double  val
);

Remarks

This feature is only available if an ADVMATH license is installed.

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:LINear:GAIN {value}
    :FUNCtion:LINear:GAIN?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMath2Linear Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Linear..::.Offset Property
IAgInfiniiVisionMath2Linear See Also

Specifies the Offset ("B" in Ax + B) for the Linear Math operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

This feature is only available if an ADVMATH license is installed.

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:LINear:OFFSet {value}
    :FUNCtion:LINear:OFFSet?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMath2Linear Interface
    Agilent.AgInfiniiVision.Interop Namespace


MeasurementTrend Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2..::.MeasurementTrend Property
IAgInfiniiVisionMath2 See Also

Pointer to the IAgInfiniiVisionMath2MeasurementTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MeasurementTrend As IAgInfiniiVisionMath2MeasurementTrend
C#
public IAgInfiniiVisionMath2MeasurementTrend  MeasurementTrend { get; }
Visual C++
HRESULT get_MeasurementTrend(
    IAgInfiniiVisionMath2MeasurementTrend**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMath2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2MeasurementTrend..::.Type Property
IAgInfiniiVisionMath2MeasurementTrend See Also

Specifies the measurement whose trend is shown in the math waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionMathMeasurementTrendTypeEnum
C#
public AgInfiniiVisionMathMeasurementTrendTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionMathMeasurementTrendTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionMathMeasurementTrendTypeEnum  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:TRENd:MEASurement {FREQ|PER|DUTY|PWID|NWID|RIS|FALL|VRAT|VAV|ACRM}
    :FUNCtion:TRENd:MEASurement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMath2MeasurementTrend Interface
    Agilent.AgInfiniiVision.Interop Namespace


MathFunctions Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.MathFunctions Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionMathFunctions interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MathFunctions As IAgInfiniiVisionMathFunctions
C#
public IAgInfiniiVisionMathFunctions  MathFunctions { get; }
Visual C++
HRESULT get_MathFunctions(
    IAgInfiniiVisionMathFunctions**  val
);

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions..::.Count Property
IAgInfiniiVisionMathFunctions See Also

Returns the number of mathfunctions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Remarks

On 1000X, 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunctions Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions..::.Item Property
IAgInfiniiVisionMathFunctions See Also

Pointer to the IAgInfiniiVisionMathFunction interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVisionMathFunction
C#
public IAgInfiniiVisionMathFunction  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVisionMathFunction**  val
);

Parameters

Name

The name of a mathfunction. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the MathFunction repeated capability.

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunctions Interface
Agilent.AgInfiniiVision.Interop Namespace


Average Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Average Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionAverage interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Average As IAgInfiniiVisionMathFunctionAverage
C#
public IAgInfiniiVisionMathFunctionAverage  Average { get; }
Visual C++
HRESULT get_Average(
    IAgInfiniiVisionMathFunctionAverage**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionAverage..::.Count Property
IAgInfiniiVisionMathFunctionAverage See Also

Specify the number of waveforms to be averaged together.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Count As Integer
C#
public int  Count { get; set; }
Visual C++
HRESULT get_Count(
    long*  val
);
HRESULT put_Count(
    long  val
);

Remarks

  • The number of averages can be set from 2 to 65536 in increments of powers of 2.
  • NOTE: Not supported by 1000X/2000X/3000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:AVERage:COUNt {value}
    :FUNCtion{MathFunction}:AVERage:COUNt?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionAverage Interface
    Agilent.AgInfiniiVision.Interop Namespace


Bus Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Bus Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Bus As IAgInfiniiVisionMathFunctionBus
C#
public IAgInfiniiVisionMathFunctionBus  Bus { get; }
Visual C++
HRESULT get_Bus(
    IAgInfiniiVisionMathFunctionBus**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus..::.ClockSource Property
IAgInfiniiVisionMathFunctionBus See Also

Specifies the clock signal source for the Chart Logic Bus State operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The Source2 property can be specified in one of the following string formats:

  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "NONE" - read-only, used by single-source math operations.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:CLOCk {value}
    :FUNCtion{MathFunction}:BUS:CLOCk?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus..::.Slope Property
IAgInfiniiVisionMathFunctionBus See Also

Specifies the clock signal edge for the Chart Logic Bus State operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionMathBusSlopeEnum
C#
public AgInfiniiVisionMathBusSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionMathBusSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionMathBusSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionMathBusSlopeNegative - specifies negative slope.
  • AgInfiniiVisionMathBusSlopePositive - specifies the positive slope.
  • AgInfiniiVisionMathBusSlopeEither - specifies either negative or positive slope.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:SLOPe {NEG|POS|EITH}
    :FUNCtion{MathFunction}:BUS:SLOPe?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


YIncrement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus..::.YIncrement Property
IAgInfiniiVisionMathFunctionBus See Also

Specifies the value associated with each increment in Chart Logic Bus data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YIncrement As Double
C#
public double  YIncrement { get; set; }
Visual C++
HRESULT get_YIncrement(
    double*  val
);
HRESULT put_YIncrement(
    double  val
);

Remarks

  • The units for this property are selected using the YUnits property.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YINCrement {value}
    :FUNCtion{MathFunction}:BUS:YINCrement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


YOrigin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus..::.YOrigin Property
IAgInfiniiVisionMathFunctionBus See Also

Specifies the value associated with Chart Logic Bus data equal to zero.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YOrigin As Double
C#
public double  YOrigin { get; set; }
Visual C++
HRESULT get_YOrigin(
    double*  val
);
HRESULT put_YOrigin(
    double  val
);

Remarks

  • The units for this property are selected using the YUnits property.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YORigin {value}
    :FUNCtion{MathFunction}:BUS:YORigin?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


YUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus..::.YUnits Property
IAgInfiniiVisionMathFunctionBus See Also

Specifies the vertical units for the Chart Logic Bus operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property YUnits As AgInfiniiVisionMathBusYUnitsEnum
C#
public AgInfiniiVisionMathBusYUnitsEnum  YUnits { get; set; }
Visual C++
HRESULT get_YUnits(
    AgInfiniiVisionMathBusYUnitsEnum*  val
);
HRESULT put_YUnits(
    AgInfiniiVisionMathBusYUnitsEnum  val
);

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionMathBusYUnitsVolts - specifies the units as Volts
  • AgInfiniiVisionMathBusYUnitsAmps - specifies the units as Amperes
  • AgInfiniiVisionMathBusYUnitsNone - specifies the units as None
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YUNits {VOLT|AMP|NONE}
    :FUNCtion{MathFunction}:BUS:YUNits?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionBus Interface
    Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Enabled Property
IAgInfiniiVisionMathFunction See Also

Enables/Disables the math function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

NOTE: On 3000X and 2000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:DISPlay {ON|OFF}
:FUNCtion{MathFunction}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


FFT Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.FFT Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionFFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FFT As IAgInfiniiVisionMathFunctionFFT
C#
public IAgInfiniiVisionMathFunctionFFT  FFT { get; }
Visual C++
HRESULT get_FFT(
    IAgInfiniiVisionMathFunctionFFT**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


CenterFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT..::.CenterFrequency Property
IAgInfiniiVisionMathFunctionFFT See Also

Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Remarks

  • The Unit of Frequency is Hz.
  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:CENTer {value}
    :FUNCtion{MathFunction}:CENTer?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


Span Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT..::.Span Property
IAgInfiniiVisionMathFunctionFFT See Also

Frequency span of the display when FFT is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Span As Double
C#
public double  Span { get; set; }
Visual C++
HRESULT get_Span(
    double*  val
);
HRESULT put_Span(
    double  val
);

Remarks

  • NOTE: 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:SPAN {value}
    :FUNCtion{MathFunction}:SPAN?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


VerticalUnits Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT..::.VerticalUnits Property
IAgInfiniiVisionMathFunctionFFT See Also

Specifies the FFT vertical units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VerticalUnits As AgInfiniiVisionMathFFTVerticalUnitsEnum
C#
public AgInfiniiVisionMathFFTVerticalUnitsEnum  VerticalUnits { get; set; }
Visual C++
HRESULT get_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum*  val
);
HRESULT put_VerticalUnits(
    AgInfiniiVisionMathFFTVerticalUnitsEnum  val
);

Remarks

The VerticalUnits property can be set to one of the following values:

  • AgInfiniiVisionMathFFTVerticalUnitsdB - specifies the FFT vertical units as Decibel
  • AgInfiniiVisionMathFFTVerticalUnitsVRMS - specifies the FFT vertical units as Vrms
  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:VTYPe {DEC|VRMS}
    :FUNCtion{MathFunction}:VTYPe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


WindowType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT..::.WindowType Property
IAgInfiniiVisionMathFunctionFFT See Also

Windowing transforms or operations for the FFT.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WindowType As AgInfiniiVisionMathFFTWindowTypeEnum
C#
public AgInfiniiVisionMathFFTWindowTypeEnum  WindowType { get; set; }
Visual C++
HRESULT get_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum*  val
);
HRESULT put_WindowType(
    AgInfiniiVisionMathFFTWindowTypeEnum  val
);

Remarks

  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:WINDow {RECT|HANN|FLAT|BHAR}
    :FUNCtion{MathFunction}:WINDow?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT Interface
    Agilent.AgInfiniiVision.Interop Namespace


Filter Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Filter Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionFilter interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Filter As IAgInfiniiVisionMathFunctionFilter
C#
public IAgInfiniiVisionMathFunctionFilter  Filter { get; }
Visual C++
HRESULT get_Filter(
    IAgInfiniiVisionMathFunctionFilter**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


HighPassBandwidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFilter..::.HighPassBandwidth Property
IAgInfiniiVisionMathFunctionFilter See Also

Specifies the high-pass filter's -3 dB cutoff frequency.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HighPassBandwidth As Double
C#
public double  HighPassBandwidth { get; set; }
Visual C++
HRESULT get_HighPassBandwidth(
    double*  val
);
HRESULT put_HighPassBandwidth(
    double  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:FREQuency:HIGHpass {value}
    :FUNCtion{MathFunction}:FREQuency:HIGHpass?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFilter Interface
    Agilent.AgInfiniiVision.Interop Namespace


LowPassBandwidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFilter..::.LowPassBandwidth Property
IAgInfiniiVisionMathFunctionFilter See Also

Specifies the low-pass filter's -3 dB cutoff frequency.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LowPassBandwidth As Double
C#
public double  LowPassBandwidth { get; set; }
Visual C++
HRESULT get_LowPassBandwidth(
    double*  val
);
HRESULT put_LowPassBandwidth(
    double  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:FREQuency:LOWPass {value}
    :FUNCtion{MathFunction}:FREQuency:LOWPass?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFilter Interface
    Agilent.AgInfiniiVision.Interop Namespace


Integrate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Integrate Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionIntegrate interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Integrate As IAgInfiniiVisionMathFunctionIntegrate
C#
public IAgInfiniiVisionMathFunctionIntegrate  Integrate { get; }
Visual C++
HRESULT get_Integrate(
    IAgInfiniiVisionMathFunctionIntegrate**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


InputOffset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionIntegrate..::.InputOffset Property
IAgInfiniiVisionMathFunctionIntegrate See Also

Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InputOffset As Double
C#
public double  InputOffset { get; set; }
Visual C++
HRESULT get_InputOffset(
    double*  val
);
HRESULT put_InputOffset(
    double  val
);

Remarks

  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:INTegrate:IOFFset {value}
    :FUNCtion{MathFunction}:INTegrate:IOFFset?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionIntegrate Interface
    Agilent.AgInfiniiVision.Interop Namespace


Linear Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Linear Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionLinear interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Linear As IAgInfiniiVisionMathFunctionLinear
C#
public IAgInfiniiVisionMathFunctionLinear  Linear { get; }
Visual C++
HRESULT get_Linear(
    IAgInfiniiVisionMathFunctionLinear**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Gain Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionLinear..::.Gain Property
IAgInfiniiVisionMathFunctionLinear See Also

Specifies the Gain ("A" in Ax + B) for the Linear Math operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Gain As Double
C#
public double  Gain { get; set; }
Visual C++
HRESULT get_Gain(
    double*  val
);
HRESULT put_Gain(
    double  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:LINear:GAIN {value}
    :FUNCtion{MathFunction}:LINear:GAIN?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionLinear Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionLinear..::.Offset Property
IAgInfiniiVisionMathFunctionLinear See Also

Specifies the Offset ("B" in Ax + B) for the Linear Math operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:LINear:OFFSet {value}
    :FUNCtion{MathFunction}:LINear:OFFSet?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionLinear Interface
    Agilent.AgInfiniiVision.Interop Namespace


MeasurementTrend Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.MeasurementTrend Property
IAgInfiniiVisionMathFunction See Also

Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MeasurementTrend As IAgInfiniiVisionMathFunctionMeasurementTrend
C#
public IAgInfiniiVisionMathFunctionMeasurementTrend  MeasurementTrend { get; }
Visual C++
HRESULT get_MeasurementTrend(
    IAgInfiniiVisionMathFunctionMeasurementTrend**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionMeasurementTrend..::.Type Property
IAgInfiniiVisionMathFunctionMeasurementTrend See Also

Specifies the measurement whose trend is shown in the math waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionMathMeasurementTrendTypeEnum
C#
public AgInfiniiVisionMathMeasurementTrendTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionMathMeasurementTrendTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionMathMeasurementTrendTypeEnum  val
);

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • This property is not supported for 6000X series. use IAgInfiniiVision4MathFunctionMeasurementTrend2.Slot property.
  • For 3000T/4000X/6000X/M924x/P924x/P924x A models with firmware revision greater than 6.0, please use the IAgInfiniiVision4MathFunctionMeasurementTrend2.Slot property, as the "Type" property has been obsoleted.
  • On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:TRENd:MEASurement {FREQ|PER|DUTY|PWID|NWID|RIS|FALL|VRAT|VAV|ACRM}
    :FUNCtion{MathFunction}:TRENd:MEASurement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionMeasurementTrend Interface
    Agilent.AgInfiniiVision.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Offset Property
IAgInfiniiVisionMathFunction See Also

Voltage or vertical value represented at center screen for the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

Instrument Command

:FUNCtion{MathFunction}:OFFSet {value}
:FUNCtion{MathFunction}:OFFSet?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Operation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Operation Property
IAgInfiniiVisionMathFunction See Also

Waveform math operation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Operation As AgInfiniiVisionMathOperationsEnum
C#
public AgInfiniiVisionMathOperationsEnum  Operation { get; set; }
Visual C++
HRESULT get_Operation(
    AgInfiniiVisionMathOperationsEnum*  val
);
HRESULT put_Operation(
    AgInfiniiVisionMathOperationsEnum  val
);

Remarks

  • The Bus Timing and Bus State Selections are only available if an MSO license is installed.
  • NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE : Here "Math1" controls the g(t) and "Math2" controls the f(t).

    • Instrument Command

    :FUNCtion{MathFunction}:OPERation {ADD|SUBT|MULT|FFT|INT|DIFF|SQRT|MAGN|ABS|LN|LOG|EXP|TEN|LOWP|HIGH|DIV|LIN|TREN|BTIM|BST|SQU|AVER|MAXHold|MINHold|CLOCk|SMOoth|ENV|FFTP}
    :FUNCtion{MathFunction}:OPERation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunction Interface
    Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Range Property
IAgInfiniiVisionMathFunction See Also

Range of Full-scale vertical axis for the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:RANGe {value}
:FUNCtion{MathFunction}:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Scale Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Scale Property
IAgInfiniiVisionMathFunction See Also

Vertical scale, or units per division, of the selected function.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Scale As Double
C#
public double  Scale { get; set; }
Visual C++
HRESULT get_Scale(
    double*  val
);
HRESULT put_Scale(
    double  val
);

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:SCALe {value}
:FUNCtion{MathFunction}:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction Interface
Agilent.AgInfiniiVision.Interop Namespace


Source1 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Source1 Property
IAgInfiniiVisionMathFunction See Also

The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source1 As String
C#
public string  Source1 { get; set; }
Visual C++
HRESULT get_Source1(
    BSTR*  val
);
HRESULT put_Source1(
    BSTR  val
);

Remarks

  • Higher math functions can operate on lower math functions when using operators other than the simple arithmetic operations (+, - , *, /). For example, if "Math1" is a subtraction of Channel1 and Channel2, the "Math2" could be set up as a FFT operation on "Math1". These are called cascaded math functions.
  • To cascade math functions, select the lower math function as the source for the current math function.
  • When cascading math functions, to get the most accurate results, be sure to vertically scale lower math functions so that their waveforms take up the full screen without being clipped.
  • The Source1 property can be specified in one of the following string formats:
  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "Math<m>", where m is any lower math channel (for cascading).
  • "BUS<b>", where b: 1 or 2, for bus charting visualization functions.
  • NOTE: On 1000X, 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

    • Instrument Command

    :FUNCtion{MathFunction}:SOURce1 {value}
    :FUNCtion{MathFunction}:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunction Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction..::.Source2 Property
IAgInfiniiVisionMathFunction See Also

Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source2 As String
C#
public string  Source2 { get; set; }
Visual C++
HRESULT get_Source2(
    BSTR*  val
);
HRESULT put_Source2(
    BSTR  val
);

Remarks

The Source2 property can be specified in one of the following string formats:

  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "NONE" - read-only, used by single-source math operations.

    • Instrument Command

    :FUNCtion{MathFunction}:SOURce2 {value}
    :FUNCtion{MathFunction}:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMathFunction Interface
    Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions..::.Name Property
IAgInfiniiVisionMathFunctions See Also

Returns the mathfunction name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of mathfunctions.

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunctions Interface
Agilent.AgInfiniiVision.Interop Namespace


MathFunctions2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.MathFunctions2 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVisionMathFunctions interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MathFunctions2 As IAgInfiniiVisionMathFunctions2
C#
public IAgInfiniiVisionMathFunctions2  MathFunctions2 { get; }
Visual C++
HRESULT get_MathFunctions2(
    IAgInfiniiVisionMathFunctions2**  val
);

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions2..::.Item2 Property
IAgInfiniiVisionMathFunctions2 See Also

Pointer to the IAgInfiniiVisionMathFunction interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgInfiniiVisionMathFunction2
C#
public IAgInfiniiVisionMathFunction2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgInfiniiVisionMathFunction2**  val
);

Parameters

Name

The name of a mathfunction. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the MathFunction repeated capability.

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunctions2 Interface
Agilent.AgInfiniiVision.Interop Namespace


FFT2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2..::.FFT2 Property
IAgInfiniiVisionMathFunction2 See Also

Pointer to the IAgInfiniiVisionMathFunctionFFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FFT2 As IAgInfiniiVisionMathFunctionFFT2
C#
public IAgInfiniiVisionMathFunctionFFT2  FFT2 { get; }
Visual C++
HRESULT get_FFT2(
    IAgInfiniiVisionMathFunctionFFT2**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction2 Interface
Agilent.AgInfiniiVision.Interop Namespace


StartFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT2..::.StartFrequency Property
IAgInfiniiVisionMathFunctionFFT2 See Also

The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StartFrequency As Double
C#
public double  StartFrequency { get; set; }
Visual C++
HRESULT get_StartFrequency(
    double*  val
);
HRESULT put_StartFrequency(
    double  val
);

Remarks

  • Preset value is 0.

    • Instrument Command

    :FUNCtion{MathFunction}:FFT:FREQuency:STARt {value}
    :FUNCtion{MathFunction}:FFT:FREQuency:STARt?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


StopFrequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT2..::.StopFrequency Property
IAgInfiniiVisionMathFunctionFFT2 See Also

The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property StopFrequency As Double
C#
public double  StopFrequency { get; set; }
Visual C++
HRESULT get_StopFrequency(
    double*  val
);
HRESULT put_StopFrequency(
    double  val
);

Remarks

  • Preset value is 100.0000E+03.

    • Instrument Command

    :FUNCtion{MathFunction}:FFT:FREQuency:STOP {value}
    :FUNCtion{MathFunction}:FFT:FREQuency:STOP?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionFFT2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


MeasurementTrend2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2..::.MeasurementTrend2 Property
IAgInfiniiVisionMathFunction2 See Also

Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MeasurementTrend2 As IAgInfiniiVisionMathFunctionMeasurementTrend2
C#
public IAgInfiniiVisionMathFunctionMeasurementTrend2  MeasurementTrend2 { get; }
Visual C++
HRESULT get_MeasurementTrend2(
    IAgInfiniiVisionMathFunctionMeasurementTrend2**  val
);

Remarks

Note: On 4000-X Series, this operation affects the oscilloscope's Math 2 (M2) channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Slot Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionMeasurementTrend2..::.Slot Property
IAgInfiniiVisionMathFunctionMeasurementTrend2 See Also

The measurement whose trend is shown in the math waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slot As AgInfiniiVisionMeasurementSlotEnum
C#
public AgInfiniiVisionMeasurementSlotEnum  Slot { get; set; }
Visual C++
HRESULT get_Slot(
    AgInfiniiVisionMeasurementSlotEnum*  val
);
HRESULT put_Slot(
    AgInfiniiVisionMeasurementSlotEnum  val
);

Remarks

Note: This property is supported by 3000T/4000X/6000X/M924x/P924x with firmware revision >= 6.00. For older revisions, please use the IAgInfiniiVisionMathFunctionMeasurementTrend::Type property instead.

  • If no measurements are installed, this returns AgInfiniiVisionMeasurementSlotNone.
  • Preset value is AgInfiniiVisionMeasurementSlotNone.

    • Instrument Command

    :FUNCtion{MathFunction}:TRENd:NMEasurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
    :FUNCtion{MathFunction}:TRENd:NMEasurement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunctionMeasurementTrend2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Smoothing Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2..::.Smoothing Property
IAgInfiniiVisionMathFunction2 See Also

Pointer to the IAgInfiniiVisionMathFunction2Smoothing interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Smoothing As IAgInfiniiVisionMathFunction2Smoothing
C#
public IAgInfiniiVisionMathFunction2Smoothing  Smoothing { get; }
Visual C++
HRESULT get_Smoothing(
    IAgInfiniiVisionMathFunction2Smoothing**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMathFunction2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Points Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2Smoothing..::.Points Property
IAgInfiniiVisionMathFunction2Smoothing See Also

The number of smoothing points to use.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Points As Integer
C#
public int  Points { get; set; }
Visual C++
HRESULT get_Points(
    long*  val
);
HRESULT put_Points(
    long  val
);

Remarks

  • An odd number of points can be choosed as input from 3 up to half of the measurement record or precision analysis record.
  • Preset value is 5.

    • Instrument Command

    :FUNCtion{MathFunction}:SMOoth:POINts {value}
    :FUNCtion{MathFunction}:SMOoth:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMathFunction2Smoothing Interface
    Agilent.AgInfiniiVision.Interop Namespace


Measurements Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Measurements Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionMeasurements interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurements As IAgInfiniiVisionMeasurements
C#
public IAgInfiniiVisionMeasurements  Measurements { get; }
Visual C++
HRESULT get_Measurements(
    IAgInfiniiVisionMeasurements**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Abort Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Abort Method
IAgInfiniiVisionMeasurements See Also

Aborts an acquisition and returns the oscilloscope to the Idle state.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Abort ( _
)
C#
public void  Abort(
)
Visual C++
HRESULT Abort(
);

Instrument Command

:STOP

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.AutoSetup Method
IAgInfiniiVisionMeasurements See Also

Automatically configures all the oscilloscopes settings based on the input signals.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Instrument Command

:AUToscale

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Clear Method
IAgInfiniiVisionMeasurements See Also

Clears all selected measurements and markers from the screen

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
)
C#
public void  Clear(
)
Visual C++
HRESULT Clear(
);

Instrument Command

:MEASure:CLEar

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Configuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Configuration Property
IAgInfiniiVisionMeasurements See Also

Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Configuration As IAgInfiniiVisionMeasurementsConfiguration
C#
public IAgInfiniiVisionMeasurementsConfiguration  Configuration { get; }
Visual C++
HRESULT get_Configuration(
    IAgInfiniiVisionMeasurementsConfiguration**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureDelay Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.ConfigureDelay Method
IAgInfiniiVisionMeasurementsConfiguration See Also

Configures the edge specifications for the delay and phase measurements.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureDelay ( _
    ByVal  Source2 As String  _
    ByVal  DelaySlope1 As AgInfiniiVisionMeasurementSlopeEnum  _
    ByVal  DelaySlope2 As AgInfiniiVisionMeasurementSlopeEnum  _
    ByVal  DelayOccurrence1 As Integer  _
    ByVal  DelayOccurrence2 As Integer  _
)
C#
public void  ConfigureDelay(
    string  Source2,
    AgInfiniiVisionMeasurementSlopeEnum  DelaySlope1,
    AgInfiniiVisionMeasurementSlopeEnum  DelaySlope2,
    int  DelayOccurrence1,
    int  DelayOccurrence2
)
Visual C++
HRESULT ConfigureDelay(
    BSTR  Source2,
    AgInfiniiVisionMeasurementSlopeEnum  DelaySlope1,
    AgInfiniiVisionMeasurementSlopeEnum  DelaySlope2,
    long  DelayOccurrence1,
    long  DelayOccurrence2
);

Parameters

Source2

Second source for measurements such as Delay, Phase etc.

DelaySlope1

The polarity of the slope for the first waveform source of a generic delay measurement.

DelaySlope2

The polarity of the slope for the second waveform source of a generic delay measurement.

DelayOccurrence1

The occurrence count for the first waveform source of a generic delay measurement.

DelayOccurrence2

The occurrence count for the second waveform source of a generic delay measurement.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


DelayOccurrence1 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.DelayOccurrence1 Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The occurrence count for the first waveform source of a generic delay measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DelayOccurrence1 As Integer
C#
public int  DelayOccurrence1 { get; set; }
Visual C++
HRESULT get_DelayOccurrence1(
    long*  val
);
HRESULT put_DelayOccurrence1(
    long  val
);

Instrument Command

:MEASure:DEFine DEL
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


DelayOccurrence2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.DelayOccurrence2 Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The occurrence count for the second waveform source of a generic delay measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DelayOccurrence2 As Integer
C#
public int  DelayOccurrence2 { get; set; }
Visual C++
HRESULT get_DelayOccurrence2(
    long*  val
);
HRESULT put_DelayOccurrence2(
    long  val
);

Instrument Command

:MEASure:DEFine DEL
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


DelaySlope1 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.DelaySlope1 Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The polarity of the slope for the first waveform source of a generic delay measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DelaySlope1 As AgInfiniiVisionMeasurementSlopeEnum
C#
public AgInfiniiVisionMeasurementSlopeEnum  DelaySlope1 { get; set; }
Visual C++
HRESULT get_DelaySlope1(
    AgInfiniiVisionMeasurementSlopeEnum*  val
);
HRESULT put_DelaySlope1(
    AgInfiniiVisionMeasurementSlopeEnum  val
);

Instrument Command

:MEASure:DEFine DEL {POS|NEG}
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


DelaySlope2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.DelaySlope2 Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The polarity of the slope for the second waveform source of a generic delay measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DelaySlope2 As AgInfiniiVisionMeasurementSlopeEnum
C#
public AgInfiniiVisionMeasurementSlopeEnum  DelaySlope2 { get; set; }
Visual C++
HRESULT get_DelaySlope2(
    AgInfiniiVisionMeasurementSlopeEnum*  val
);
HRESULT put_DelaySlope2(
    AgInfiniiVisionMeasurementSlopeEnum  val
);

Instrument Command

:MEASure:DEFine DEL {POS|NEG}
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


MarkersEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.MarkersEnabled Property
IAgInfiniiVisionMeasurementsConfiguration See Also

Enables markers for tracking measurements on the display. This feature is always on.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MarkersEnabled As Boolean
C#
public bool  MarkersEnabled { get; set; }
Visual C++
HRESULT get_MarkersEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_MarkersEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MEASure:SHOW {ON|OFF}
:MEASure:SHOW?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Source2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.Source2 Property
IAgInfiniiVisionMeasurementsConfiguration See Also

Second source for measurements such as Delay, Phase etc.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source2 As String
C#
public string  Source2 { get; set; }
Visual C++
HRESULT get_Source2(
    BSTR*  val
);
HRESULT put_Source2(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeAtEdgeOccurrence Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.TimeAtEdgeOccurrence Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The occurrence count for the TimeAtEdge measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeAtEdgeOccurrence As Integer
C#
public int  TimeAtEdgeOccurrence { get; set; }
Visual C++
HRESULT get_TimeAtEdgeOccurrence(
    long*  val
);
HRESULT put_TimeAtEdgeOccurrence(
    long  val
);

Remarks

Need to Cache for use at actual measurement call

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeAtEdgeSlope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.TimeAtEdgeSlope Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The edge slope for a TimeAtEdge measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeAtEdgeSlope As AgInfiniiVisionMeasurementSlopeEnum
C#
public AgInfiniiVisionMeasurementSlopeEnum  TimeAtEdgeSlope { get; set; }
Visual C++
HRESULT get_TimeAtEdgeSlope(
    AgInfiniiVisionMeasurementSlopeEnum*  val
);
HRESULT put_TimeAtEdgeSlope(
    AgInfiniiVisionMeasurementSlopeEnum  val
);

Remarks

Need to Cache for use at actual measurement call

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeAtValueOccurrence Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.TimeAtValueOccurrence Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The occurrence count for the TimeAtValue measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeAtValueOccurrence As Integer
C#
public int  TimeAtValueOccurrence { get; set; }
Visual C++
HRESULT get_TimeAtValueOccurrence(
    long*  val
);
HRESULT put_TimeAtValueOccurrence(
    long  val
);

Remarks

Need to Cache for use at actual measurement call

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeAtValueSlope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.TimeAtValueSlope Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The edge slope for a TimeAtValue measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeAtValueSlope As AgInfiniiVisionMeasurementSlopeEnum
C#
public AgInfiniiVisionMeasurementSlopeEnum  TimeAtValueSlope { get; set; }
Visual C++
HRESULT get_TimeAtValueSlope(
    AgInfiniiVisionMeasurementSlopeEnum*  val
);
HRESULT put_TimeAtValueSlope(
    AgInfiniiVisionMeasurementSlopeEnum  val
);

Remarks

Need to Cache for use at actual measurement call.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeAtValueValue Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.TimeAtValueValue Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The voltage for the TimeAtValue measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeAtValueValue As Double
C#
public double  TimeAtValueValue { get; set; }
Visual C++
HRESULT get_TimeAtValueValue(
    double*  val
);
HRESULT put_TimeAtValueValue(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


ValueAtTimeTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.ValueAtTimeTime Property
IAgInfiniiVisionMeasurementsConfiguration See Also

The time (in seconds) used to make the ValueAtTime measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ValueAtTimeTime As Double
C#
public double  ValueAtTimeTime { get; set; }
Visual C++
HRESULT get_ValueAtTimeTime(
    double*  val
);
HRESULT put_ValueAtTimeTime(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Window Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration..::.Window Property
IAgInfiniiVisionMeasurementsConfiguration See Also

Measurement window when zoomed time base is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Window As AgInfiniiVisionMeasurementWindowTypeEnum
C#
public AgInfiniiVisionMeasurementWindowTypeEnum  Window { get; set; }
Visual C++
HRESULT get_Window(
    AgInfiniiVisionMeasurementWindowTypeEnum*  val
);
HRESULT put_Window(
    AgInfiniiVisionMeasurementWindowTypeEnum  val
);

Instrument Command

:MEASure:WINDow {MAIN|ZOOM|AUTO|GATE}
:MEASure:WINDow?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurementsConfiguration Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Count Property
IAgInfiniiVisionMeasurements See Also

Read Only - Returns the number of channels that measurements can use as a source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Initiate Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Initiate Method
IAgInfiniiVisionMeasurements See Also

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Initiate ( _
)
C#
public void  Initiate(
)
Visual C++
HRESULT Initiate(
);

Instrument Command

:DIGitize;*OPC?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


IsWaveformElementInvalid Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.IsWaveformElementInvalid Method
IAgInfiniiVisionMeasurements See Also

Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function IsWaveformElementInvalid ( _
    ByVal  Element As Double  _
) As Boolean
C#
public bool  IsWaveformElementInvalid(
    double  Element
)
Visual C++
HRESULT IsWaveformElementInvalid(
    double  Element
    VARIANT_BOOL*  retval
);

Parameters

Element

Pass one of the values from the waveform array returned by the read and fetch waveform methods.

Return Value

True if an element in the waveform array is invalid. False otherwise.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Item Property
IAgInfiniiVisionMeasurements See Also

Pointer to the IAgInfiniiVisionMeasurement interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVisionMeasurement
C#
public IAgInfiniiVisionMeasurement  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVisionMeasurement**  val
);

Parameters

Name

The name of a measurement. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Measurement repeated capability.

Remarks

It now allows fetching and reading from math and reference-waveform sources.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


FetchWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.FetchWaveform Method
IAgInfiniiVisionMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveform ( _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveform(
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveform(
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


FetchWaveformMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.FetchWaveformMeasurement Method
IAgInfiniiVisionMeasurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMeasurement ( _
    ByVal  MeasFunction As AgInfiniiVisionMeasurementEnum  _
    ByRef  Measurement As Double  _
)
C#
public void  FetchWaveformMeasurement(
    AgInfiniiVisionMeasurementEnum  MeasFunction,
    ref double  Measurement
)
Visual C++
HRESULT FetchWaveformMeasurement(
    AgInfiniiVisionMeasurementEnum  MeasFunction,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Instrument Command

    :MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT}?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


FetchWaveformMinMax Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.FetchWaveformMinMax Method
IAgInfiniiVisionMeasurement See Also

Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMinMax ( _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveformMinMax(
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveformMinMax(
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


ReadWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.ReadWaveform Method
IAgInfiniiVisionMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveform ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveform(
    int  MaxTimeMilliseconds,
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveform(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


ReadWaveformMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.ReadWaveformMeasurement Method
IAgInfiniiVisionMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMeasurement ( _
    ByVal  MeasFunction As AgInfiniiVisionMeasurementEnum  _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  Measurement As Double  _
)
C#
public void  ReadWaveformMeasurement(
    AgInfiniiVisionMeasurementEnum  MeasFunction,
    int  MaxTimeMilliseconds,
    ref double  Measurement
)
Visual C++
HRESULT ReadWaveformMeasurement(
    AgInfiniiVisionMeasurementEnum  MeasFunction,
    long  MaxTimeMilliseconds,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Instrument Command

    :MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT}?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


ReadWaveformMinMax Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement..::.ReadWaveformMinMax Method
IAgInfiniiVisionMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMinMax ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveformMinMax(
    int  MaxTimeMilliseconds,
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveformMinMax(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMeasurement Interface
    Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Name Property
IAgInfiniiVisionMeasurements See Also

Read Only - Returns the measurement name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of measurements.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Status Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements..::.Status Method
IAgInfiniiVisionMeasurements See Also

Returns whether an acquisition is in progress, complete, or if the status is unknown.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function Status ( _
) As AgInfiniiVisionAcquisitionStatusEnum
C#
public AgInfiniiVisionAcquisitionStatusEnum  Status(
)
Visual C++
HRESULT Status(
    AgInfiniiVisionAcquisitionStatusEnum*  retval
);

Return Value

The acquisition status.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements Interface
Agilent.AgInfiniiVision.Interop Namespace


Measurements2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Measurements2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionMeasurements2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurements2 As IAgInfiniiVisionMeasurements2
C#
public IAgInfiniiVisionMeasurements2  Measurements2 { get; }
Visual C++
HRESULT get_Measurements2(
    IAgInfiniiVisionMeasurements2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Statistics Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2..::.Statistics Property
IAgInfiniiVisionMeasurements2 See Also

Pointer to the IAgInfiniiVisionMeasurements2Statistics interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Statistics As IAgInfiniiVisionMeasurements2Statistics
C#
public IAgInfiniiVisionMeasurements2Statistics  Statistics { get; }
Visual C++
HRESULT get_Statistics(
    IAgInfiniiVisionMeasurements2Statistics**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.Count Property
IAgInfiniiVisionMeasurements2Statistics See Also

Specifies the maximum number of values used when calculating measurement statistics.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Count As String
C#
public string  Count { get; set; }
Visual C++
HRESULT get_Count(
    BSTR*  val
);
HRESULT put_Count(
    BSTR  val
);

Remarks

The Count property can be specified in one of the following string formats:

  • "Infinite"
  • "n", where n: an integer from 2 to 2000

Instrument Command

:MEASure:STATistics:MCOunt {value}
:MEASure:STATistics:MCOunt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


DisplayEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.DisplayEnabled Property
IAgInfiniiVisionMeasurements2Statistics See Also

Enables or disables the display of the measurement statistics.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DisplayEnabled As Boolean
C#
public bool  DisplayEnabled { get; set; }
Visual C++
HRESULT get_DisplayEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DisplayEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MEASure:STATistics:DISPlay {ON|OFF}
:MEASure:STATistics:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


Format Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.Format Property
IAgInfiniiVisionMeasurements2Statistics See Also

Specifies the type of information returned by the GetResults() method.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Format As AgInfiniiVisionMeasurementStatisticsFormatEnum
C#
public AgInfiniiVisionMeasurementStatisticsFormatEnum  Format { get; set; }
Visual C++
HRESULT get_Format(
    AgInfiniiVisionMeasurementStatisticsFormatEnum*  val
);
HRESULT put_Format(
    AgInfiniiVisionMeasurementStatisticsFormatEnum  val
);

Remarks

The Format property can be set to one of the following values:

  • AgInfiniiVisionMeasurementStatisticsFormatOn - All statistics are on
  • AgInfiniiVisionMeasurementStatisticsFormatCurrent - Only the Current statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMinimum - Only the Minimum statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMaximum - Only the Maximum statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMean - Only the Mean statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatStandardDeviation - Only the Standard Deviation statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatCount - Only the Count statistic is on

Instrument Command

:MEASure:STATistics {ON|CURR|MIN|MAX|MEAN|STDD|COUN}
:MEASure:STATistics?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


GetResults Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.GetResults Method
IAgInfiniiVisionMeasurements2Statistics See Also

Returns the results of the continuously displayed measurements.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetResults ( _
    ByRef  Results As String  _
)
C#
public void  GetResults(
    ref string  Results
)
Visual C++
HRESULT GetResults(
    BSTR*  Results
);

Parameters

Results

The results for the continuously displayed measurements.

Remarks

  • If more than one measurement is running continuously, the return values are duplicated for each continuous measurement from the first to last (left to right) result displayed. Each result returned is separated from the previous result by a comma. There is a maximum of four continuous measurements that can be continuously displayed at a time.
  • When no quick measurements are installed, this method returns nothing (empty string). When the count for any of the measurements is 0, the value of infinity (9.9E+37) is returned for the min, max, mean, and standard deviation.
  • Measurement label, current, min, max, mean, std dev, and count are only returned if the Configuration.ResultsStatistics property is set to ON.
  • The following shows the order of values received for a single measurement:
    • Measurement label current min max mean std dev count

    If Configuration.ResultsStatistics property is set to Current, Min, Max, Mean, Standard Deviation or Count, only that particular statistic value is returned for each measurement that is on.

    Instrument Command

    :MEASure:RESults?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMeasurements2Statistics Interface
    Agilent.AgInfiniiVision.Interop Namespace


Increment Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.Increment Method
IAgInfiniiVisionMeasurements2Statistics See Also

This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Increment ( _
)
C#
public void  Increment(
)
Visual C++
HRESULT Increment(
);

Remarks

  • This command lets you, for example, gather statistics over multiple pulses captured in a single acquisition. To do this, change the horizontal position and enter the command for each new pulse that is measured.
  • This method is only valid when the oscilloscope is stopped and quick measurements are on.
  • The method is valid in segmented acquisition mode even though the corresponding front panel softkey is not available.

    • Instrument Command

    :MEASure:STATistics:INCRement

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMeasurements2Statistics Interface
    Agilent.AgInfiniiVision.Interop Namespace


InstallMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.InstallMeasurement Method
IAgInfiniiVisionMeasurements2Statistics See Also

Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub InstallMeasurement ( _
    ByVal  Source As String  _
    ByVal  Measurement As AgInfiniiVisionMeasurementEnum  _
)
C#
public void  InstallMeasurement(
    string  Source,
    AgInfiniiVisionMeasurementEnum  Measurement
)
Visual C++
HRESULT InstallMeasurement(
    BSTR  Source,
    AgInfiniiVisionMeasurementEnum  Measurement
);

Parameters

Source

Specifies the source for the measurement.

Measurement

Specifies the type of the measurement to install.

Remarks

The Source parameter can be specified in one of the following formats:

  • DigitalChannel<d>, where d: 0 to the number of digital channels available minus 1.
    This format is valid only for the following measurement types: FrequencyCounter, DutyCycle, Frequency, Negative Pulse Width, Positive Pulse Width, Period.
  • Channel<n>, where n: 1 to the number of analog channels available.
  • FUNC
  • MATH
  • WMEM<r>, where n: 1 to 2.
  • VAL_EXTERNAL
    This format is valid only for the FrequencyCounter measurement.

The Measurement parameter can be set to one of the following values:
  • AgInfiniiVisionMeasurementRiseTime - starts a rise-time measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallTime - starts a fall-time measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFrequency - starts a frequency measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementPeriod - starts the period measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageRMS - starts an RMS value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltagePeakToPeak - starts a vertical peak-to-peak measurement.
  • AgInfiniiVisionMeasurementVoltageMax - starts a maximum vertical value measurement.
  • AgInfiniiVisionMeasurementVoltageMin - starts a minimum vertical value measurement.
  • AgInfiniiVisionMeasurementVoltageHigh - starts a waveform top value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageLow - starts a waveform base value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageAverage - starts an average value measurement.
  • AgInfiniiVisionMeasurementWidthNeg - starts the negative pulse width measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementWidthPos - starts the positive pulse width measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementDutyCycleNeg - starts a duty cycle measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementDutyCycePos - starts a duty cycle measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementAmplitude - starts a vertical amplitude measurement.
  • AgInfiniiVisionMeasurementVoltageCycleRMS - starts an RMS value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageCycleAverage - starts an average value measurement.
  • AgInfiniiVisionMeasurementOverShoot - starts an overshoot measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementPreShoot - starts a preshoot measurement.
  • AgInfiniiVisionMeasurementFrequencyCounter - starts a counter measurement. Only valid Sources are: DIG<d> or CHAN<n> or EXT
  • AgInfiniiVisionMeasurementTimeAtMax - starts an X-at-Max-Y measurement on the selected window.
  • AgInfiniiVisionMeasurementTimeAtMin - starts an X-at-Min-Y measurement on the selected window.
  • AgInfiniiVisionMeasurementDelay - places the instrument in continuous measurement mode and starts a delay measurement.
  • AgInfiniiVisionMeasurementPhase - places the instrument in continuous measurement mode and starts a phase measurement.
  • AgInfiniiVisionMeasurementArea - installs an area measurement on screen. Area measurements show the are between the waveform and the ground level. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementBurstWidth - installs a burst width measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallingEdgeCount - installs a falling edge count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallingPulseCount - installs a falling pulse count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementRisingEdgeCount - installs a rising edge count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementRisingPulseCount - installs a rising pulse count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementStandardDeviation - starts standard deviation measurement. This measurement is not available if the source selected is FFT.

Instrument Command

:MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT} {Source}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


RelativeStdDevEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.RelativeStdDevEnabled Property
IAgInfiniiVisionMeasurements2Statistics See Also

Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RelativeStdDevEnabled As Boolean
C#
public bool  RelativeStdDevEnabled { get; set; }
Visual C++
HRESULT get_RelativeStdDevEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_RelativeStdDevEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:MEASure:STATistics:RSDeviation {ON|OFF}
:MEASure:STATistics:RSDeviation?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics..::.Reset Method
IAgInfiniiVisionMeasurements2Statistics See Also

This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Instrument Command

:MEASure:STATistics:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionMeasurements2Statistics Interface
Agilent.AgInfiniiVision.Interop Namespace


Measurements3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Measurements3 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVisionMeasurements interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurements3 As IAgInfiniiVisionMeasurements3
C#
public IAgInfiniiVisionMeasurements3  Measurements3 { get; }
Visual C++
HRESULT get_Measurements3(
    IAgInfiniiVisionMeasurements3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements3..::.Item2 Property
IAgInfiniiVisionMeasurements3 See Also

Pointer to the IAgInfiniiVisionMeasurement interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgInfiniiVisionMeasurement2
C#
public IAgInfiniiVisionMeasurement2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgInfiniiVisionMeasurement2**  val
);

Parameters

Name

The name of a measurement. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Measurement repeated capability.

Remarks

It now allows fetching and reading from math and reference-waveform sources.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMeasurements3 Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureJitterMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement2..::.ConfigureJitterMeasurement Method
IAgInfiniiVisionMeasurement2 See Also

Configure and adds the selected Jitter measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureJitterMeasurement ( _
    ByVal  MeasFunction As AgInfiniiVisionMeasurementJitterEnum  _
    ByVal  Slope As AgInfiniiVisionEdgeSlopeEnum  _
    ByVal  NumberOfPeriods As Integer  _
    ByVal  Unit As AgInfiniiVisionJitterMeasurementUnitEnum  _
)
C#
public void  ConfigureJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    int  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit
)
Visual C++
HRESULT ConfigureJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    long  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit
);

Parameters

MeasFunction

The Jitter measurement.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEASure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth} , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionMeasurement2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


FetchJitterMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement2..::.FetchJitterMeasurement Method
IAgInfiniiVisionMeasurement2 See Also

Returns the measured value of the selected measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub FetchJitterMeasurement ( _
    ByVal  MeasFunction As AgInfiniiVisionMeasurementJitterEnum  _
    ByVal  Slope As AgInfiniiVisionEdgeSlopeEnum  _
    ByVal  NumberOfPeriods As Integer  _
    ByVal  Unit As AgInfiniiVisionJitterMeasurementUnitEnum  _
    ByRef  Result As Double  _
)
C#
public void  FetchJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    int  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit,
    ref double  Result
)
Visual C++
HRESULT FetchJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    long  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit,
    double*  Result
);

Parameters

MeasFunction

The Jitter measurement.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Result

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the ConfigureJitterMeasurement method.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEAure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth}? , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionMeasurement2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


ReadJitterMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement2..::.ReadJitterMeasurement Method
IAgInfiniiVisionMeasurement2 See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ReadJitterMeasurement ( _
    ByVal  MeasFunction As AgInfiniiVisionMeasurementJitterEnum  _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByVal  Slope As AgInfiniiVisionEdgeSlopeEnum  _
    ByVal  NumberOfPeriods As Integer  _
    ByVal  Unit As AgInfiniiVisionJitterMeasurementUnitEnum  _
    ByRef  Result As Double  _
)
C#
public void  ReadJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    int  MaxTimeMilliseconds,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    int  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit,
    ref double  Result
)
Visual C++
HRESULT ReadJitterMeasurement(
    AgInfiniiVisionMeasurementJitterEnum  MeasFunction,
    long  MaxTimeMilliseconds,
    AgInfiniiVisionEdgeSlopeEnum  Slope,
    long  NumberOfPeriods,
    AgInfiniiVisionJitterMeasurementUnitEnum  Unit,
    double*  Result
);

Parameters

MeasFunction

The Jitter measurement.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Result

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the ConfigureJitterMeasurement method.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEAure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth}? , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionMeasurement2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Memory Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Memory Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionMemory interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Memory As IAgInfiniiVisionMemory
C#
public IAgInfiniiVisionMemory  Memory { get; }
Visual C++
HRESULT get_Memory(
    IAgInfiniiVisionMemory**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


CurrentRecallDirectory Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.CurrentRecallDirectory Property
IAgInfiniiVisionMemory See Also

Present working directory for recall operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CurrentRecallDirectory As String
C#
public string  CurrentRecallDirectory { get; set; }
Visual C++
HRESULT get_CurrentRecallDirectory(
    BSTR*  val
);
HRESULT put_CurrentRecallDirectory(
    BSTR  val
);

Instrument Command

:RECall:PWD "{value}"
:RECall:PWD?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


CurrentRecallFile Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.CurrentRecallFile Property
IAgInfiniiVisionMemory See Also

File for recall operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CurrentRecallFile As String
C#
public string  CurrentRecallFile { get; set; }
Visual C++
HRESULT get_CurrentRecallFile(
    BSTR*  val
);
HRESULT put_CurrentRecallFile(
    BSTR  val
);

Remarks

It is the file's base name only, without path information or an extension

Instrument Command

:RECall:FILename {value}
:RECall:FILename?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


CurrentSaveDirectory Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.CurrentSaveDirectory Property
IAgInfiniiVisionMemory See Also

Present working directory for save operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CurrentSaveDirectory As String
C#
public string  CurrentSaveDirectory { get; set; }
Visual C++
HRESULT get_CurrentSaveDirectory(
    BSTR*  val
);
HRESULT put_CurrentSaveDirectory(
    BSTR  val
);

Instrument Command

:SAVE:PWD {value}
:SAVE:PWD?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


CurrentSaveFile Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.CurrentSaveFile Property
IAgInfiniiVisionMemory See Also

File for save operations.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CurrentSaveFile As String
C#
public string  CurrentSaveFile { get; set; }
Visual C++
HRESULT get_CurrentSaveFile(
    BSTR*  val
);
HRESULT put_CurrentSaveFile(
    BSTR  val
);

Remarks

It is the file's base name only, without path information or an extension

Instrument Command

:SAVE:FILename {value}
:SAVE:FILename?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


ImageFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.ImageFormat Property
IAgInfiniiVisionMemory See Also

Type of image format

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ImageFormat As AgInfiniiVisionMemoryImageFormatEnum
C#
public AgInfiniiVisionMemoryImageFormatEnum  ImageFormat { get; set; }
Visual C++
HRESULT get_ImageFormat(
    AgInfiniiVisionMemoryImageFormatEnum*  val
);
HRESULT put_ImageFormat(
    AgInfiniiVisionMemoryImageFormatEnum  val
);

Remarks

NONE is returned, when a waveform data file format is currently selected

Instrument Command

:SAVE:IMAGe:FORMat {BMP|BMP8bit|PNG}
:SAVE:IMAGe:FORMat?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


ImagePalette Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.ImagePalette Property
IAgInfiniiVisionMemory See Also

Image palette color.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ImagePalette As AgInfiniiVisionMemoryImagePaletteEnum
C#
public AgInfiniiVisionMemoryImagePaletteEnum  ImagePalette { get; set; }
Visual C++
HRESULT get_ImagePalette(
    AgInfiniiVisionMemoryImagePaletteEnum*  val
);
HRESULT put_ImagePalette(
    AgInfiniiVisionMemoryImagePaletteEnum  val
);

Instrument Command

:SAVE:IMAGe:PALette {COL|GRAY}
:SAVE:IMAGe:PALette?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


InvertColorEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.InvertColorEnabled Property
IAgInfiniiVisionMemory See Also

Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property InvertColorEnabled As Boolean
C#
public bool  InvertColorEnabled { get; set; }
Visual C++
HRESULT get_InvertColorEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_InvertColorEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SAVE:IMAGe:INKSaver {ON|OFF}
:SAVE:IMAGe:INKSaver?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


Recall Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.Recall Method
IAgInfiniiVisionMemory See Also

Recall option for Mask, Oscilloscope Setup and Reference memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Recall ( _
    ByVal  Options As AgInfiniiVisionMemoryRecallOptionsEnum  _
    ByVal  FileName As String  _
)
C#
public void  Recall(
    AgInfiniiVisionMemoryRecallOptionsEnum  Options,
    string  FileName
)
Visual C++
HRESULT Recall(
    AgInfiniiVisionMemoryRecallOptionsEnum  Options,
    BSTR  FileName
);

Parameters

Options

Recall Options

FileName

Specifies file to be recalled

Remarks

When recalling an LDF or DBC file, ensure that the destination has been set via Memory::SerialRecallDestination before calling Memory::Recall

Instrument Command

:RECall{:MASK|:SETup|:WMEMory1|:WMEMory2|:ARBitrary|:ARBitrary|:WMEMory3|:WMEMory4|:LDF|:DBC} {FileName}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


ReferenceWaveformSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.ReferenceWaveformSource Property
IAgInfiniiVisionMemory See Also

The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ReferenceWaveformSource As String
C#
public string  ReferenceWaveformSource { get; set; }
Visual C++
HRESULT get_ReferenceWaveformSource(
    BSTR*  val
);
HRESULT put_ReferenceWaveformSource(
    BSTR  val
);

Remarks

  • Only ADD or SUBtract math operations can be saved as reference waveforms
  • The ReferenceWaveformSource property can be specified in one of the following string formats:
  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "Math<m>", where m : 1 t o 4.
  • "WMEM<m>", where m : 1 t o 4.

    • Instrument Command

    :SAVE:WMEMory:SOURce {value}
    :SAVE:WMEMory:SOURce?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMemory Interface
    Agilent.AgInfiniiVision.Interop Namespace


Save Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.Save Method
IAgInfiniiVisionMemory See Also

Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Save ( _
    ByVal  Options As AgInfiniiVisionMemorySaveOptionsEnum  _
    ByVal  FileName As String  _
)
C#
public void  Save(
    AgInfiniiVisionMemorySaveOptionsEnum  Options,
    string  FileName
)
Visual C++
HRESULT Save(
    AgInfiniiVisionMemorySaveOptionsEnum  Options,
    BSTR  FileName
);

Parameters

Options

Save options

FileName

Specifies file to be saved

Remarks

  • AgInfiniiVisionMemorySaveOptionsArbCsv2 option is not available for 2000X and 3000X model series.

    • Instrument Command

    :SAVE{:IMAGe|:WAVeform|:WMEMory|:SETup|:MASK|:LIST|:ARBitrary|:ARBitrary|:MULTi|:RESults} {FileName}

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMemory Interface
    Agilent.AgInfiniiVision.Interop Namespace


SaveFactorsEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.SaveFactorsEnabled Property
IAgInfiniiVisionMemory See Also

Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SaveFactorsEnabled As Boolean
C#
public bool  SaveFactorsEnabled { get; set; }
Visual C++
HRESULT get_SaveFactorsEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_SaveFactorsEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SAVE:IMAGe:FACTors {}
:SAVE:IMAGe:FACTors?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


WaveformFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.WaveformFormat Property
IAgInfiniiVisionMemory See Also

Data format of waveform

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WaveformFormat As AgInfiniiVisionMemoryWaveformFormatEnum
C#
public AgInfiniiVisionMemoryWaveformFormatEnum  WaveformFormat { get; set; }
Visual C++
HRESULT get_WaveformFormat(
    AgInfiniiVisionMemoryWaveformFormatEnum*  val
);
HRESULT put_WaveformFormat(
    AgInfiniiVisionMemoryWaveformFormatEnum  val
);

Remarks

  • Input value AgInfiniiVisionMemoryWaveformFormatALB is not supported for 4000x and M9240X series models.

    • Instrument Command

    :SAVE:WAVeform:FORMat {ALB|ASC|CSV|BIN}
    :SAVE:WAVeform:FORMat?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionMemory Interface
    Agilent.AgInfiniiVision.Interop Namespace


WaveformLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory..::.WaveformLength Property
IAgInfiniiVisionMemory See Also

Waveform data length (number of points saved).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WaveformLength As Integer
C#
public int  WaveformLength { get; set; }
Visual C++
HRESULT get_WaveformLength(
    long*  val
);
HRESULT put_WaveformLength(
    long  val
);

Instrument Command

:SAVE:WAVeform:LENGth {value}
:SAVE:WAVeform:LENGth?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory Interface
Agilent.AgInfiniiVision.Interop Namespace


Memory2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Memory2 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVisionMemory interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Memory2 As IAgInfiniiVisionMemory2
C#
public IAgInfiniiVisionMemory2  Memory2 { get; }
Visual C++
HRESULT get_Memory2(
    IAgInfiniiVisionMemory2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


ResultFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2..::.ResultFormat Property
IAgInfiniiVisionMemory2 See Also

Pointer to the IAgInfiniiVisionMemory2ResultFormat interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ResultFormat As IAgInfiniiVisionMemory2ResultFormat
C#
public IAgInfiniiVisionMemory2ResultFormat  ResultFormat { get; }
Visual C++
HRESULT get_ResultFormat(
    IAgInfiniiVisionMemory2ResultFormat**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory2 Interface
Agilent.AgInfiniiVision.Interop Namespace


CursorEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.CursorEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the cursor values will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CursorEnabled As Boolean
C#
public bool  CursorEnabled { get; set; }
Visual C++
HRESULT get_CursorEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_CursorEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:CURSor {1|0}
    :SAVE:RESults:FORMat:CURSor?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


HistogramEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.HistogramEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the histogram statistics will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HistogramEnabled As Boolean
C#
public bool  HistogramEnabled { get; set; }
Visual C++
HRESULT get_HistogramEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_HistogramEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:HISTogram {1|0}
    :SAVE:RESults:FORMat:HISTogram?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


MaskEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.MaskEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the mask statistics will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MaskEnabled As Boolean
C#
public bool  MaskEnabled { get; set; }
Visual C++
HRESULT get_MaskEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_MaskEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:MASK {1|0}
    :SAVE:RESults:FORMat:MASK?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


MeasurementEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.MeasurementEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the measurement results will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MeasurementEnabled As Boolean
C#
public bool  MeasurementEnabled { get; set; }
Visual C++
HRESULT get_MeasurementEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_MeasurementEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:MEASurement {1|0}
    :SAVE:RESults:FORMat:MEASurement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


SearchEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.SearchEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the found search event times will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SearchEnabled As Boolean
C#
public bool  SearchEnabled { get; set; }
Visual C++
HRESULT get_SearchEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_SearchEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:SEARch {1|0}
    :SAVE:RESults:FORMat:SEARch?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


SegmentedEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat..::.SegmentedEnabled Property
IAgInfiniiVisionMemory2ResultFormat See Also

Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SegmentedEnabled As Boolean
C#
public bool  SegmentedEnabled { get; set; }
Visual C++
HRESULT get_SegmentedEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_SegmentedEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:SEGMented {1|0}
    :SAVE:RESults:FORMat:SEGMented?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionMemory2ResultFormat Interface
    Agilent.AgInfiniiVision.Interop Namespace


Memory3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision6..::.Memory3 Property
IAgInfiniiVision6 See Also

Pointer to the IAgInfiniiVisionMemory interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Memory3 As IAgInfiniiVisionMemory3
C#
public IAgInfiniiVisionMemory3  Memory3 { get; }
Visual C++
HRESULT get_Memory3(
    IAgInfiniiVisionMemory3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision6 Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialRecallDestination Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory3..::.SerialRecallDestination Property
IAgInfiniiVisionMemory3 See Also

This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SerialRecallDestination As AgInfiniiVisionSerialBusEnum
C#
public AgInfiniiVisionSerialBusEnum  SerialRecallDestination { get; set; }
Visual C++
HRESULT get_SerialRecallDestination(
    AgInfiniiVisionSerialBusEnum*  val
);
HRESULT put_SerialRecallDestination(
    AgInfiniiVisionSerialBusEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionMemory3 Interface
Agilent.AgInfiniiVision.Interop Namespace


ReferenceLevel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.ReferenceLevel Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionReferenceLevel interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceLevel As IAgInfiniiVisionReferenceLevel
C#
public IAgInfiniiVisionReferenceLevel  ReferenceLevel { get; }
Visual C++
HRESULT get_ReferenceLevel(
    IAgInfiniiVisionReferenceLevel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceLevel..::.Configure Method
IAgInfiniiVisionReferenceLevel See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Low As Double  _
    ByVal  Mid As Double  _
    ByVal  High As Double  _
)
C#
public void  Configure(
    double  Low,
    double  Mid,
    double  High
)
Visual C++
HRESULT Configure(
    double  Low,
    double  Mid,
    double  High
);

Parameters

Low

Measurement low reference. This value sets the Meas Low Ref property

Mid

Measurement mid reference. This value sets the Meas Mid Ref property.

High

Measurement high reference. This value sets the Meas High Ref property.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceLevel Interface
Agilent.AgInfiniiVision.Interop Namespace


High Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceLevel..::.High Property
IAgInfiniiVisionReferenceLevel See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property High As Double
C#
public double  High { get; set; }
Visual C++
HRESULT get_High(
    double*  val
);
HRESULT put_High(
    double  val
);

Instrument Command

:MEASure:DEFine
:MEASure:DEFine?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceLevel Interface
Agilent.AgInfiniiVision.Interop Namespace


Low Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceLevel..::.Low Property
IAgInfiniiVisionReferenceLevel See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Low As Double
C#
public double  Low { get; set; }
Visual C++
HRESULT get_Low(
    double*  val
);
HRESULT put_Low(
    double  val
);

Instrument Command

:MEASure:DEFine
:MEASure:DEFine?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceLevel Interface
Agilent.AgInfiniiVision.Interop Namespace


Mid Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceLevel..::.Mid Property
IAgInfiniiVisionReferenceLevel See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mid As Double
C#
public double  Mid { get; set; }
Visual C++
HRESULT get_Mid(
    double*  val
);
HRESULT put_Mid(
    double  val
);

Instrument Command

:MEASure:DEFine
:MEASure:DEFine?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceLevel Interface
Agilent.AgInfiniiVision.Interop Namespace


ReferenceWaveform Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.ReferenceWaveform Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionReferenceWaveform interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceWaveform As IAgInfiniiVisionReferenceWaveform
C#
public IAgInfiniiVisionReferenceWaveform  ReferenceWaveform { get; }
Visual C++
HRESULT get_ReferenceWaveform(
    IAgInfiniiVisionReferenceWaveform**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.Clear Method
IAgInfiniiVisionReferenceWaveform See Also

Clears the specified reference waveform location.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
    ByVal  WaveformLocation As Short  _
)
C#
public void  Clear(
    short  WaveformLocation
)
Visual C++
HRESULT Clear(
    short  WaveformLocation
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Instrument Command

:WMEMory{WaveformLocation}:CLEar

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Enable Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.Enable Method
IAgInfiniiVisionReferenceWaveform See Also

Enables/Disables the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Enable ( _
    ByVal  WaveformLocation As Short  _
    ByVal  DisplayState As Boolean  _
)
C#
public void  Enable(
    short  WaveformLocation,
    bool  DisplayState
)
Visual C++
HRESULT Enable(
    short  WaveformLocation,
    VARIANT_BOOL  DisplayState
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

DisplayState

On|Off Display State

Instrument Command

:WMEMory{WaveformLocation}:DISPlay {}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


GetLabel Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.GetLabel Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Label associated with a specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetLabel ( _
    ByVal  WaveformLocation As Short  _
) As String
C#
public string  GetLabel(
    short  WaveformLocation
)
Visual C++
HRESULT GetLabel(
    short  WaveformLocation
    BSTR*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

A quoted ASCII string.

Instrument Command

:WMEMory{WaveformLocation}:LABel?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


GetOffset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.GetOffset Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Current offset value for the selected reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetOffset ( _
    ByVal  WaveformLocation As Short  _
) As Double
C#
public double  GetOffset(
    short  WaveformLocation
)
Visual C++
HRESULT GetOffset(
    short  WaveformLocation
    double*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

Vertical offset value.

Instrument Command

:WMEMory{WaveformLocation}:YOFFset?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


GetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.GetRange Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Current full-scale range for the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetRange ( _
    ByVal  WaveformLocation As Short  _
) As Double
C#
public double  GetRange(
    short  WaveformLocation
)
Visual C++
HRESULT GetRange(
    short  WaveformLocation
    double*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

The vertical full-scale range value.

Instrument Command

:WMEMory{WaveformLocation}:YRANge?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSkewFactor Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.GetSkewFactor Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Current skew factor for the selected reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSkewFactor ( _
    ByVal  WaveformLocation As Short  _
) As Double
C#
public double  GetSkewFactor(
    short  WaveformLocation
)
Visual C++
HRESULT GetSkewFactor(
    short  WaveformLocation
    double*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

Time in seconds.

Instrument Command

:WMEMory{WaveformLocation}:SKEW?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


GetVerticalScale Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.GetVerticalScale Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Current vertical units per division for the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetVerticalScale ( _
    ByVal  WaveformLocation As Short  _
) As Double
C#
public double  GetVerticalScale(
    short  WaveformLocation
)
Visual C++
HRESULT GetVerticalScale(
    short  WaveformLocation
    double*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

Vertical units per division.

Instrument Command

:WMEMory{WaveformLocation}:YSCale?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


IsEnabled Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.IsEnabled Method
IAgInfiniiVisionReferenceWaveform See Also

Returns the Current display setting of the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function IsEnabled ( _
    ByVal  WaveformLocation As Short  _
) As Boolean
C#
public bool  IsEnabled(
    short  WaveformLocation
)
Visual C++
HRESULT IsEnabled(
    short  WaveformLocation
    VARIANT_BOOL*  retval
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Return Value

Possible values are: (1 or ON) or (0 or OFF).

Instrument Command

:WMEMory{WaveformLocation}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Save Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.Save Method
IAgInfiniiVisionReferenceWaveform See Also

Copies the analog channel or math function waveform to the specified reference waveform location.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Save ( _
    ByVal  WaveformLocation As Short  _
    ByVal  Source As String  _
)
C#
public void  Save(
    short  WaveformLocation,
    string  Source
)
Visual C++
HRESULT Save(
    short  WaveformLocation,
    BSTR  Source
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Source

Waveform Source

Instrument Command

:WMEMory{WaveformLocation}:SAVE {Source}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


SetLabel Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.SetLabel Method
IAgInfiniiVisionReferenceWaveform See Also

Label for the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetLabel ( _
    ByVal  WaveformLocation As Short  _
    ByVal  Label As String  _
)
C#
public void  SetLabel(
    short  WaveformLocation,
    string  Label
)
Visual C++
HRESULT SetLabel(
    short  WaveformLocation,
    BSTR  Label
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Label

Label can have maximum of 10 characters, ASCII characters are allowed. Lower case are automatically converted to upper case.

Instrument Command

:WMEMory{WaveformLocation}:LABel "{Label}"

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


SetOffset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.SetOffset Method
IAgInfiniiVisionReferenceWaveform See Also

Offset value that is represented at center screen for the selected reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetOffset ( _
    ByVal  WaveformLocation As Short  _
    ByVal  OffsetValue As Double  _
)
C#
public void  SetOffset(
    short  WaveformLocation,
    double  OffsetValue
)
Visual C++
HRESULT SetOffset(
    short  WaveformLocation,
    double  OffsetValue
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

OffsetValue

Offset Value

Instrument Command

:WMEMory{WaveformLocation}:YOFFset {OffsetValue}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


SetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.SetRange Method
IAgInfiniiVisionReferenceWaveform See Also

Full-scale range of vertical axis of the selected reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetRange ( _
    ByVal  WaveformLocation As Short  _
    ByVal  Range As Double  _
)
C#
public void  SetRange(
    short  WaveformLocation,
    double  Range
)
Visual C++
HRESULT SetRange(
    short  WaveformLocation,
    double  Range
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Range

Vertical axis range

Instrument Command

:WMEMory{WaveformLocation}:YRANge {Range}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSkewFactor Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.SetSkewFactor Method
IAgInfiniiVisionReferenceWaveform See Also

Skew factor for the specified reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSkewFactor ( _
    ByVal  WaveformLocation As Short  _
    ByVal  Skewfactor As Double  _
)
C#
public void  SetSkewFactor(
    short  WaveformLocation,
    double  Skewfactor
)
Visual C++
HRESULT SetSkewFactor(
    short  WaveformLocation,
    double  Skewfactor
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

Skewfactor

Skew Factor

Instrument Command

:WMEMory{WaveformLocation}:SKEW {Skewfactor}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


SetVerticalScale Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform..::.SetVerticalScale Method
IAgInfiniiVisionReferenceWaveform See Also

Vertical scale, or units per division, of the selected reference waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetVerticalScale ( _
    ByVal  WaveformLocation As Short  _
    ByVal  VerticalScale As Double  _
)
C#
public void  SetVerticalScale(
    short  WaveformLocation,
    double  VerticalScale
)
Visual C++
HRESULT SetVerticalScale(
    short  WaveformLocation,
    double  VerticalScale
);

Parameters

WaveformLocation

Reference waveform Location 1 or 2

VerticalScale

Vertical Scale or Units per Division

Instrument Command

:WMEMory{WaveformLocation}:YSCale {VerticalScale}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionReferenceWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Search Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Search Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Search As IAgInfiniiVision2Search
C#
public IAgInfiniiVision2Search  Search { get; }
Visual C++
HRESULT get_Search(
    IAgInfiniiVision2Search**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Count Property
IAgInfiniiVision2Search See Also

Read Only - Gets the number of search events found.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Instrument Command

:SEARch:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Edge Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Edge Property
IAgInfiniiVision2Search See Also

Pointer to the IAgInfiniiVision2Search2Edge interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IAgInfiniiVision2SearchEdge
C#
public IAgInfiniiVision2SearchEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IAgInfiniiVision2SearchEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchEdge..::.Configure Method
IAgInfiniiVision2SearchEdge See Also

Configures the Source and Slope properties for an Edge search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Slope As AgInfiniiVisionSearchEdgeSlopeEnum  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionSearchEdgeSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionSearchEdgeSlopeEnum  Slope
);

Parameters

Source

The channel on which to search for edges. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Slope

The slope of the edge for the search.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchEdge..::.Slope Property
IAgInfiniiVision2SearchEdge See Also

The slope of the edge for the search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionSearchEdgeSlopeEnum
C#
public AgInfiniiVisionSearchEdgeSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionSearchEdgeSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionSearchEdgeSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionSearchEdgeSlopeNegative - specifies the negative slope
  • AgInfiniiVisionSearchEdgeSlopePositive - specifies the positive slope
  • AgInfiniiVisionSearchEdgeSlopeEither - specifies either the negative or positive slope

Instrument Command

:SEARch:EDGE:SLOPe {NEG|POS|EITH}
:SEARch:EDGE:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchEdge..::.Source Property
IAgInfiniiVision2SearchEdge See Also

The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:SEARch:EDGE:SOURce {value}
:SEARch:EDGE:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


Glitch Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Glitch Property
IAgInfiniiVision2Search See Also

Pointer to the IAgInfiniiVision2Search2Glitch interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IAgInfiniiVision2SearchGlitch
C#
public IAgInfiniiVision2SearchGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IAgInfiniiVision2SearchGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.Condition Property
IAgInfiniiVision2SearchGlitch See Also

Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchGlitchConditionEnum
C#
public AgInfiniiVisionSearchGlitchConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchGlitchConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchGlitchConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchGlitchConditionGreaterThan - to search for a pulse width greater than a time value
  • AgInfiniiVisionSearchGlitchConditionLessThan - to search for a pulse width less than a time value
  • AgInfiniiVisionSearchGlitchConditionRange - to search for a pulse width within a range of time values

Instrument Command

:SEARch:GLITch:QUALifier {GRE|LESS|RANG}
:SEARch:GLITch:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.Configure Method
IAgInfiniiVision2SearchGlitch See Also

Configures the Source, Polarity and Condition properties for the Glitch search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Polarity As AgInfiniiVisionSearchGlitchPolarityEnum  _
    ByVal  Condition As AgInfiniiVisionSearchGlitchConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionSearchGlitchPolarityEnum  Polarity,
    AgInfiniiVisionSearchGlitchConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionSearchGlitchPolarityEnum  Polarity,
    AgInfiniiVisionSearchGlitchConditionEnum  Condition
);

Parameters

Source

The channel on which to search for glitches (pulse widths). The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Polarity

The polarity for the glitch (pulse width) source.

Condition

The mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


GetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.GetRange Method
IAgInfiniiVision2SearchGlitch See Also

Gets the pulse width duration time (in seconds) for the selected source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetRange ( _
    ByRef  LowerLimit As Double  _
    ByRef  UpperLimit As Double  _
)
C#
public void  GetRange(
    ref double  LowerLimit,
    ref double  UpperLimit
)
Visual C++
HRESULT GetRange(
    double*  LowerLimit,
    double*  UpperLimit
);

Parameters

LowerLimit

The lower limit for the pulse width duration time (in seconds) for the selected source

UpperLimit

The upper limit for the pulse width duration time (in seconds) for the selected source

Instrument Command

:SEARch:GLITch:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


MaxPulseWidthDuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.MaxPulseWidthDuration Property
IAgInfiniiVision2SearchGlitch See Also

The maximum pulse width duration time (in seconds) for the selected source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MaxPulseWidthDuration As Double
C#
public double  MaxPulseWidthDuration { get; set; }
Visual C++
HRESULT get_MaxPulseWidthDuration(
    double*  val
);
HRESULT put_MaxPulseWidthDuration(
    double  val
);

Instrument Command

:SEARch:GLITch:LESSthan {value}
:SEARch:GLITch:LESSthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


MinPulseWidthDuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.MinPulseWidthDuration Property
IAgInfiniiVision2SearchGlitch See Also

The minimum pulse width duration time (in seconds) for the selected source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MinPulseWidthDuration As Double
C#
public double  MinPulseWidthDuration { get; set; }
Visual C++
HRESULT get_MinPulseWidthDuration(
    double*  val
);
HRESULT put_MinPulseWidthDuration(
    double  val
);

Instrument Command

:SEARch:GLITch:GREaterthan {value}
:SEARch:GLITch:GREaterthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.Polarity Property
IAgInfiniiVision2SearchGlitch See Also

The polarity for the glitch (pulse width) source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionSearchGlitchPolarityEnum
C#
public AgInfiniiVisionSearchGlitchPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionSearchGlitchPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionSearchGlitchPolarityEnum  val
);

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSearchGlitchPolarityPositive - to specify positive polarity for the glitch search
  • AgInfiniiVisionSearchGlitchPolarityNegative - to specify negative polarity for the glitch search

Instrument Command

:SEARch:GLITch:POLarity {POS|NEG}
:SEARch:GLITch:POLarity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


SetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.SetRange Method
IAgInfiniiVision2SearchGlitch See Also

Sets the pulse width duration time (in seconds) for the selected source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetRange ( _
    ByVal  LowerLimit As Double  _
    ByVal  UpperLimit As Double  _
)
C#
public void  SetRange(
    double  LowerLimit,
    double  UpperLimit
)
Visual C++
HRESULT SetRange(
    double  LowerLimit,
    double  UpperLimit
);

Parameters

LowerLimit

The lower limit for the pulse width duration time (in seconds) for the selected source

UpperLimit

The upper limit for the pulse width duration time (in seconds) for the selected source

Remarks

The parameters can be entered in any order. The smaller value becomes LowerLimit and the larger value becomes UpperLimit.

Instrument Command

:SEARch:GLITch:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch..::.Source Property
IAgInfiniiVision2SearchGlitch See Also

The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

If all the channels are off, the current pulse width source is returned as "NONE".

Instrument Command

:SEARch:GLITch:SOURce {value}
:SEARch:GLITch:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Mode Property
IAgInfiniiVision2Search See Also

The oscilloscope search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchModeEnum
C#
public AgInfiniiVisionSearchModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchModeEdge - the Edge search mode
  • AgInfiniiVisionSearchModeGlitch - the Glitch search mode
  • AgInfiniiVisionSearchModeRunt - the Runt search mode
  • AgInfiniiVisionSearchModeTransition - the Transition search mode
  • AgInfiniiVisionSearchModeSerial1 - the Serial1 search mode
  • AgInfiniiVisionSearchModeSerial2 - the Serial2 search mode
  • AgInfiniiVisionSearchModeOff - disables the search mode

Instrument Command

:SEARch:MODE {EDGE|GLIT|RUNT|TRAN|SER1|SER2|OFF|PEAK}
:SEARch:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Runt Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Runt Property
IAgInfiniiVision2Search See Also

Pointer to the IAgInfiniiVision2Search2Runt interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IAgInfiniiVision2SearchRunt
C#
public IAgInfiniiVision2SearchRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IAgInfiniiVision2SearchRunt**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt..::.Condition Property
IAgInfiniiVision2SearchRunt See Also

Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchRuntConditionEnum
C#
public AgInfiniiVisionSearchRuntConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchRuntConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchRuntConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchRuntConditionGreaterThan - to search for a runt that is greater than a time value
  • AgInfiniiVisionSearchRuntConditionLessThan - to search for a runt that is less than a time value
  • AgInfiniiVisionSearchRuntConditionNone - to search for a runt for any time value

Instrument Command

:SEARch:RUNT:QUALifier {GRE|LESS|NONE}
:SEARch:RUNT:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt..::.Configure Method
IAgInfiniiVision2SearchRunt See Also

Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Polarity As AgInfiniiVisionSearchRuntPolarityEnum  _
    ByVal  Condition As AgInfiniiVisionSearchRuntConditionEnum  _
    ByVal  QualifierTime As Double  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionSearchRuntPolarityEnum  Polarity,
    AgInfiniiVisionSearchRuntConditionEnum  Condition,
    double  QualifierTime
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionSearchRuntPolarityEnum  Polarity,
    AgInfiniiVisionSearchRuntConditionEnum  Condition,
    double  QualifierTime
);

Parameters

Source

The channel on which to search for the runt pulse. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Polarity

Sets/Gets the polarity for the runt search.

Condition

Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.

QualifierTime

When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt..::.Polarity Property
IAgInfiniiVision2SearchRunt See Also

Sets/Gets the polarity for the runt search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionSearchRuntPolarityEnum
C#
public AgInfiniiVisionSearchRuntPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionSearchRuntPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionSearchRuntPolarityEnum  val
);

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSearchRuntPolarityPositive - to specify positive polarity for the runt search
  • AgInfiniiVisionSearchRuntPolarityNegative - to specify negative polarity for the runt search
  • AgInfiniiVisionSearchRuntPolarityEither - to specify either negative or positive polarity for the runt search

Instrument Command

:SEARch:RUNT:POLarity {POS|NEG|EITH}
:SEARch:RUNT:POLarity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


QualifierTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt..::.QualifierTime Property
IAgInfiniiVision2SearchRunt See Also

When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property QualifierTime As Double
C#
public double  QualifierTime { get; set; }
Visual C++
HRESULT get_QualifierTime(
    double*  val
);
HRESULT put_QualifierTime(
    double  val
);

Instrument Command

:SEARch:RUNT:TIME {value}
:SEARch:RUNT:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt..::.Source Property
IAgInfiniiVision2SearchRunt See Also

The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:SEARch:RUNT:SOURce {value}
:SEARch:RUNT:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Serial Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Serial Property
IAgInfiniiVision2Search See Also

Pointer to the IAgInfiniiVision2Search2Serial interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Serial As IAgInfiniiVision2SearchSerial
C#
public IAgInfiniiVision2SearchSerial  Serial { get; }
Visual C++
HRESULT get_Serial(
    IAgInfiniiVision2SearchSerial**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


ARINC429 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.ARINC429 Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ARINC429 As IAgInfiniiVision2SearchSerialARINC429
C#
public IAgInfiniiVision2SearchSerialARINC429  ARINC429 { get; }
Visual C++
HRESULT get_ARINC429(
    IAgInfiniiVision2SearchSerialARINC429**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Label Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429..::.Label Property
IAgInfiniiVision2SearchSerialARINC429 See Also

Specifies the ARINC 429 label value when labels are used in the selected search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Label As String
C#
public string  Label { get; set; }
Visual C++
HRESULT get_Label(
    BSTR*  val
);
HRESULT put_Label(
    BSTR  val
);

Remarks

The Label property is specified in of the following formats:

  • "n", where n: 8-bit integer in decimal format
  • "#Hnn", where n: { 0,..,9 | A,..,F }
  • "#Qnnn", where n: { 0,..,7 }
  • "0xnn", where n: { 0,..,9 | A,..,F }
  • The return value for this property is in decimal format.

    • Instrument Command

    :SEARch:SERial:A429:LABel {value}
    :SEARch:SERial:A429:LABel?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision2SearchSerialARINC429 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429..::.Mode Property
IAgInfiniiVision2SearchSerialARINC429 See Also

Specifies the type of ARINC 429 information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchSerialARINC429ModeEnum
C#
public AgInfiniiVisionSearchSerialARINC429ModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchSerialARINC429ModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchSerialARINC429ModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialARINC429ModeLabel - Specifies the Label search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeLabelBits - Specifies the Label + Bits search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeParityError - Specifies the Parity Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeWordError - Specifies the Word Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeGapError - Specifies the Gap Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeWordOrGapError - Specifies the Word or Gap Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeAllErrors - Specifies All Errors search mode.

Instrument Command

:SEARch:SERIAL:A429:MODE {LAB|LBIT|PERR|WERR|GERR|WGER|ALL}
:SEARch:SERIAL:A429:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429..::.PatternData Property
IAgInfiniiVision2SearchSerialARINC429 See Also

Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property is specified in the following format:

  • "nn...n", where n: {0 | 1}

The pattern string will be truncated on the left-hand-side if the length exceeds the pattern length of the particular ARINC format.

Pattern length for the different formats:
  • LDSDi
    • Label - 8 bits.
    • SDI - 2 bits.
    • Data - 19 bits.
    • SSM - 2 bits.
    • Label - 8 bits.
    • Data - 21 bits.
    • SSM - 2 bits.
    • Label - 8 bits.
    • Data - 23 bits.

Instrument Command

:SEARch:SERial:A429:PATTern:DATA "{value}"
:SEARch:SERial:A429:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternSDI Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429..::.PatternSDI Property
IAgInfiniiVision2SearchSerialARINC429 See Also

Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternSDI As String
C#
public string  PatternSDI { get; set; }
Visual C++
HRESULT get_PatternSDI(
    BSTR*  val
);
HRESULT put_PatternSDI(
    BSTR  val
);

Remarks

The specified SDI is only used if the IAgInfiniiVisionSerialBusARINC429.DisplayFormat property includes the SDI field. The PatternSDI property is specified in the following format:

  • "nn", where n: {0 | 1}

Instrument Command

:SEARch:SERial:A429:PATTern:SDI "{value}"
:SEARch:SERial:A429:PATTern:SDI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternSSM Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429..::.PatternSSM Property
IAgInfiniiVision2SearchSerialARINC429 See Also

Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternSSM As String
C#
public string  PatternSSM { get; set; }
Visual C++
HRESULT get_PatternSSM(
    BSTR*  val
);
HRESULT put_PatternSSM(
    BSTR  val
);

Remarks

The specified SSM is only used if the IAgInfiniiVisionSerialBusARINC429.DisplayFormat property includes the SSM field. The PatternSSM property is specified in the following format:

  • "nn", where n: {0 | 1}

Instrument Command

:SEARch:SERial:A429:PATTern:SSM "{value}"
:SEARch:SERial:A429:PATTern:SSM?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


CAN Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.CAN Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialCAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CAN As IAgInfiniiVision2SearchSerialCAN
C#
public IAgInfiniiVision2SearchSerialCAN  CAN { get; }
Visual C++
HRESULT get_CAN(
    IAgInfiniiVision2SearchSerialCAN**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN..::.Mode Property
IAgInfiniiVision2SearchSerialCAN See Also

Specifies the type of CAN information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchCANModeEnum
C#
public AgInfiniiVisionSearchCANModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchCANModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchCANModeEnum  val
);

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchCANTypeData - searches for CAN Data frames matching the specified ID, Data, and the DLC (Data length code)
  • AgInfiniiVisionSearchCANTypeIDData - searches for CAN frames matching the specified ID of a Data frame
  • AgInfiniiVisionSearchCANTypeIDEither - searches for the specified ID, regardless if it is a Remote frame or a Data frame
  • AgInfiniiVisionSearchCANTypeIDRemote - searches for CAN frames matching the specified ID of a Remote frame
  • AgInfiniiVisionSearchCANTypeAllErrors - searches for CAN active error frames and unknown bus conditions
  • AgInfiniiVisionSearchCANTypeOverload - searches for CAN overload frames
  • AgInfiniiVisionSearchCANTypeError - searches for CAN Error frame

Instrument Command

:SEARch:SERial:CAN:MODE {DATA|IDD|IDE|IDR|ALL|OVER|ERR|ACK|FORM|STUF|CRC|MSIG|MESSage}
:SEARch:SERial:CAN:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN..::.PatternData Property
IAgInfiniiVision2SearchSerialCAN See Also

Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The length of the data value is specified using the PatternDataLength property.

Instrument Command

:SEARch:SERial:CAN:PATTern:DATA "{value}"
:SEARch:SERial:CAN:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN..::.PatternDataLength Property
IAgInfiniiVision2SearchSerialCAN See Also

Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternDataLength As Integer
C#
public int  PatternDataLength { get; set; }
Visual C++
HRESULT get_PatternDataLength(
    long*  val
);
HRESULT put_PatternDataLength(
    long  val
);

Remarks

The data value is specified using the PatternData property.

Instrument Command

:SEARch:SERial:CAN:PATTern:DATA:LENGth {value}
:SEARch:SERial:CAN:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN..::.PatternID Property
IAgInfiniiVision2SearchSerialCAN See Also

Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternID As String
C#
public string  PatternID { get; set; }
Visual C++
HRESULT get_PatternID(
    BSTR*  val
);
HRESULT put_PatternID(
    BSTR  val
);

Remarks

The ID value can be a standard ID or an extended ID, depending on the value of the PatternIDType property.

Instrument Command

:SEARch:SERial:CAN:PATTern:ID "{value}"
:SEARch:SERial:CAN:PATTern:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternIDType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN..::.PatternIDType Property
IAgInfiniiVision2SearchSerialCAN See Also

Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternIDType As AgInfiniiVisionSearchCANPatternIDTypeEnum
C#
public AgInfiniiVisionSearchCANPatternIDTypeEnum  PatternIDType { get; set; }
Visual C++
HRESULT get_PatternIDType(
    AgInfiniiVisionSearchCANPatternIDTypeEnum*  val
);
HRESULT put_PatternIDType(
    AgInfiniiVisionSearchCANPatternIDTypeEnum  val
);

Remarks

The PatternIDType property can be set to one of the following values:

  • AgInfiniiVisionSearchCANPatternIDTypeStandard - specifies that a standard ID value is used for searching
  • AgInfiniiVisionSearchCANPatternIDTypeExtended - specifies that an extended ID value is used for searching
  • The ID value is specified using the PatternID property.

    • Instrument Command

    :SEARch:SERial:CAN:PATTern:ID:MODE {STAN|EXT}
    :SEARch:SERial:CAN:PATTern:ID:MODE?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVision2SearchSerialCAN Interface
    Agilent.AgInfiniiVision.Interop Namespace


FlexRay Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.FlexRay Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FlexRay As IAgInfiniiVision2SearchSerialFlexRay
C#
public IAgInfiniiVision2SearchSerialFlexRay  FlexRay { get; }
Visual C++
HRESULT get_FlexRay(
    IAgInfiniiVision2SearchSerialFlexRay**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


CycleNumber Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay..::.CycleNumber Property
IAgInfiniiVision2SearchSerialFlexRay See Also

Specifies the cycle value to find when searching for FlexRay frames.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CycleNumber As String
C#
public string  CycleNumber { get; set; }
Visual C++
HRESULT get_CycleNumber(
    BSTR*  val
);
HRESULT put_CycleNumber(
    BSTR  val
);

Remarks

The CycleNumber property can be specified in one of the following formats:

  • "ALL"
  • "n", where n: an integer from 0-63

Instrument Command

:SEARch:SERial:FLEXray:CYCLe {value}
:SEARch:SERial:FLEXray:CYCLe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


FrameID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay..::.FrameID Property
IAgInfiniiVision2SearchSerialFlexRay See Also

Specifies the frame ID value to find when searching for FlexRay frames.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property FrameID As String
C#
public string  FrameID { get; set; }
Visual C++
HRESULT get_FrameID(
    BSTR*  val
);
HRESULT put_FrameID(
    BSTR  val
);

Remarks

The FrameID property can be specified in one of the following formats:

  • "ALL"
  • "n", where n is an integer from 1-2047

Instrument Command

:SEARch:SERial:FLEXray:FRAMe {value}
:SEARch:SERial:FLEXray:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay..::.Mode Property
IAgInfiniiVision2SearchSerialFlexRay See Also

Specifies the type of FlexRay information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchSerialFlexRayModeEnum
C#
public AgInfiniiVisionSearchSerialFlexRayModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchSerialFlexRayModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchSerialFlexRayModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialFlexRayModeFrameID - Finds frames with the specified ID.
  • AgInfiniiVisionSearchSerialFlexRayModeCycleNumber - Finds frames with the specified cycle number and ID.
  • AgInfiniiVisionSearchSerialFlexRayModeData - Finds frames with the specified data, cycle number and frame ID.
  • AgInfiniiVisionSearchSerialFlexRayModeHeaderCRC - Finds cyclic redundancy check errors in headers.
  • AgInfiniiVisionSearchSerialFlexRayModeFrameCRC - Finds cyclic redundancy check errors in frames.
  • AgInfiniiVisionSearchSerialFlexRayModeAllErrors - Finds all errors.

Instrument Command

:SEARch:SERial:FLEXray:MODE {FRAM|CYCL|DATA|HERR|FERR|AERR}
:SEARch:SERial:FLEXray:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay..::.PatternData Property
IAgInfiniiVision2SearchSerialFlexRay See Also

Specifies the data value to find when searching for FlexRay frames.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in the following format:

  • "nn..n", where n: {0 | 1 | X}

Instrument Command

:SEARch:SERial:FLEXray:DATA "{value}"
:SEARch:SERial:FLEXray:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay..::.PatternDataLength Property
IAgInfiniiVision2SearchSerialFlexRay See Also

Specifies the length of data values when searching for FlexRay frames.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternDataLength As Integer
C#
public int  PatternDataLength { get; set; }
Visual C++
HRESULT get_PatternDataLength(
    long*  val
);
HRESULT put_PatternDataLength(
    long  val
);

Instrument Command

:SEARch:SERial:FLEXray:DATA:LENGth {value}
:SEARch:SERial:FLEXray:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


I2S Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.I2S Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialI2S interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property I2S As IAgInfiniiVision2SearchSerialI2S
C#
public IAgInfiniiVision2SearchSerialI2S  I2S { get; }
Visual C++
HRESULT get_I2S(
    IAgInfiniiVision2SearchSerialI2S**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


AudioChannel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S..::.AudioChannel Property
IAgInfiniiVision2SearchSerialI2S See Also

Specifies the channel on which to search for I2S events: right, left, or either channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AudioChannel As AgInfiniiVisionSearchI2SAudioChannelEnum
C#
public AgInfiniiVisionSearchI2SAudioChannelEnum  AudioChannel { get; set; }
Visual C++
HRESULT get_AudioChannel(
    AgInfiniiVisionSearchI2SAudioChannelEnum*  val
);
HRESULT put_AudioChannel(
    AgInfiniiVisionSearchI2SAudioChannelEnum  val
);

Remarks

The AudioChannel property can be set to one of the following values:

  • AgInfiniiVisionSearchI2SAudioChannelRight - for the right audio channel
  • AgInfiniiVisionSearchI2SAudioChannelLeft - for the left audio channel
  • AgInfiniiVisionSearchI2SAudioChannelEither - for either left or right audio channel

Instrument Command

:SEARch:SERial:I2S:AUDio {LEFT|RIGH|EITH}
:SEARch:SERial:I2S:AUDio?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


GetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S..::.GetRange Method
IAgInfiniiVision2SearchSerialI2S See Also

Gets the data value range when searching for I2S events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetRange ( _
    ByRef  LowerLimit As Integer  _
    ByRef  UpperLimit As Integer  _
)
C#
public void  GetRange(
    ref int  LowerLimit,
    ref int  UpperLimit
)
Visual C++
HRESULT GetRange(
    long*  LowerLimit,
    long*  UpperLimit
);

Parameters

LowerLimit

The lower limit for the data value range when searching for I2S events.

UpperLimit

The upper limit for the data value range when searching for I2S events.

Instrument Command

:SEARch:SERial:I2S:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S..::.Mode Property
IAgInfiniiVision2SearchSerialI2S See Also

Specifies the type of I2S information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchI2SModeEnum
C#
public AgInfiniiVisionSearchI2SModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchI2SModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchI2SModeEnum  val
);

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchI2STypeEqual - searches for the specified audio channel's data word when it equals the specified word
  • AgInfiniiVisionSearchI2STypeNotEqual - searches for any word other than the specified word
  • AgInfiniiVisionSearchI2STypeLessThan - searches for channel data words less than the specified value
  • AgInfiniiVisionSearchI2STypeGreaterThan - searches for channel data words greater than the specified value
  • AgInfiniiVisionSearchI2STypeInRange - searches for channel data words in the range
  • AgInfiniiVisionSearchI2STypeOutRange - searches for channel data words outside the range

Data word values are specified using the PatternData property.
Values ranges are specified using the SetRange() and GetRange() methods.

Instrument Command

:SEARch:SERial:I2S:MODE {EQU|NOT|LESS|GRE|INR|OUTR}
:SEARch:SERial:I2S:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S..::.PatternData Property
IAgInfiniiVision2SearchSerialI2S See Also

Specifies the data word value when searching for I2S events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The data word value is a string, which can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 | X}
  • "0xnn...n" where n: {0,..,9 | A,..,F | X}

Instrument Command

:SEARch:SERial:I2S:PATTern:DATA "{value}"
:SEARch:SERial:I2S:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


SetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S..::.SetRange Method
IAgInfiniiVision2SearchSerialI2S See Also

Sets the data value range when searching for I2S events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetRange ( _
    ByVal  LowerLimit As String  _
    ByVal  UpperLimit As String  _
)
C#
public void  SetRange(
    string  LowerLimit,
    string  UpperLimit
)
Visual C++
HRESULT SetRange(
    BSTR  LowerLimit,
    BSTR  UpperLimit
);

Parameters

LowerLimit

The lower limit for the data value range when searching for I2S events.

UpperLimit

The upper limit for the data value range when searching for I2S events.

Remarks

The LowerLimit and UpperLimit parameters of the data value range can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

This method is only used when Mode is set to AgInfiniiVisionSearchI2STypeInRange or AgInfiniiVisionSearchI2STypeOutRange.
You may enter the parameters in any order. The smaller value becomes LowerLimit and the larger value becomes UpperLimit.

Instrument Command

:SEARch:SERial:I2S:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


IIC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.IIC Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialIIC interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IIC As IAgInfiniiVision2SearchSerialIIC
C#
public IAgInfiniiVision2SearchSerialIIC  IIC { get; }
Visual C++
HRESULT get_IIC(
    IAgInfiniiVision2SearchSerialIIC**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Address Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC..::.Address Property
IAgInfiniiVision2SearchSerialIIC See Also

Specifies the address values when searching for IIC events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Address As String
C#
public string  Address { get; set; }
Visual C++
HRESULT get_Address(
    BSTR*  val
);
HRESULT put_Address(
    BSTR  val
);

Remarks

The Address property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

The returned value is always in an integer string format

Instrument Command

:SEARch:SERial:IIC:PATTern:ADDRess "{value}"
:SEARch:SERial:IIC:PATTern:ADDRess?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC..::.Condition Property
IAgInfiniiVision2SearchSerialIIC See Also

Specifies the data value qualifier used when searching for IIC EEPROM data read events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchIICConditionEnum
C#
public AgInfiniiVisionSearchIICConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchIICConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchIICConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchIICConditionEqual
  • AgInfiniiVisionSearchIICConditionNotEqual
  • AgInfiniiVisionSearchIICConditionLessThan
  • AgInfiniiVisionSearchIICConditionGreaterThan

Instrument Command

:SEARch:SERial:IIC:QUALifier {EQU|NOT|LESS|GRE}
:SEARch:SERial:IIC:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC..::.Mode Property
IAgInfiniiVision2SearchSerialIIC See Also

Selects the type of IIC information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchIICModeEnum
C#
public AgInfiniiVisionSearchIICModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchIICModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchIICModeEnum  val
);

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchIICTypeRead7 - searches for 7-bit address frames containing Start:Address7:Read:Ack:Data
  • AgInfiniiVisionSearchIICTypeWrite7 - searches for 7-bit address frames containing Start:Address7:Write:Ack:Data
  • AgInfiniiVisionSearchIICTypeMissingAcknowledge - searches for missing acknowledge events
  • AgInfiniiVisionSearchIICTypeNoAcknowledge - searches for address with no acknowledge events
  • AgInfiniiVisionSearchIICTypeR7Data2 - searches for 7-bit address frames containing Start:Address7:Read:Ack:Data:Ack:Data2
  • AgInfiniiVisionSearchIICTypeW7Data2 - searches for 7-bit address frames containing Start:Address7:Write:Ack:Data:Ack:Data2
  • AgInfiniiVisionSearchIICTypeRestart - searches for another start condition occurring before a stop condition
  • AgInfiniiVisionSearchIICTypeReadEprom - searches for EEPROM data reads

When searching for events containing addresses, address values are specified using the Address property.
When searching for events containing data, data values are specified using the PatternData and PatternData2 properties.

Instrument Command

:SEARch:SERial:IIC:MODE {READ7|WRIT7|NACK|ANAC|R7D2|W7D2|REST|READE|ADDR}
:SEARch:SERial:IIC:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC..::.PatternData Property
IAgInfiniiVision2SearchSerialIIC See Also

Specifies the data values when searching for IIC events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

When searching for IIC EEPROM data read events, you specify the data value qualifier using the Condition property.

Instrument Command

:SEARch:SERial:IIC:PATTern:DATA "{value}"
:SEARch:SERial:IIC:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC..::.PatternData2 Property
IAgInfiniiVision2SearchSerialIIC See Also

Specifies the second data value when searching for IIC events with two data values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData2 As String
C#
public string  PatternData2 { get; set; }
Visual C++
HRESULT get_PatternData2(
    BSTR*  val
);
HRESULT put_PatternData2(
    BSTR  val
);

Remarks

The PatternData2 property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

Instrument Command

:SEARch:SERial:IIC:PATTern:DATA2 "{value}"
:SEARch:SERial:IIC:PATTern:DATA2?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


LIN Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.LIN Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialLIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property LIN As IAgInfiniiVision2SearchSerialLIN
C#
public IAgInfiniiVision2SearchSerialLIN  LIN { get; }
Visual C++
HRESULT get_LIN(
    IAgInfiniiVision2SearchSerialLIN**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


ID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialLIN..::.ID Property
IAgInfiniiVision2SearchSerialLIN See Also

Specifies the frame ID value when searching for LIN events

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ID As String
C#
public string  ID { get; set; }
Visual C++
HRESULT get_ID(
    BSTR*  val
);
HRESULT put_ID(
    BSTR  val
);

Remarks

The ID property can be specified in one of the following string formats:

  • "n" where n: 7-bit integer in signed decimal
  • "#Hnn" where n: {0,..,9 | A,..,F}
  • "#Bnn" where n: {0 | 1 }
  • "0xnn" where n: {0,..,9 | A,..,F}

Valid range of values are: 0 to 63 or 0x00 to 0x3f

Instrument Command

:SEARch:SERial:LIN:ID {value}
:SEARch:SERial:LIN:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialLIN..::.Mode Property
IAgInfiniiVision2SearchSerialLIN See Also

Selects the type of LIN information to find in the Lister display

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchLINModeEnum
C#
public AgInfiniiVisionSearchLINModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchLINModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchLINModeEnum  val
);

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchLINModeID - searches for a frame ID
  • AgInfiniiVisionSearchLINModeData - searches for a frame ID and data
  • AgInfiniiVisionSearchLINModeError - searches for errors
  • AgInfiniiVisionSearchLINModeFrame - searches for symbolic frames
  • AgInfiniiVisionSearchLINModeFrameSig - searches for symbolic frames and signal values

Frame IDs are specified using the ID property.
Data values are specified using the PatternData property.

Instrument Command

:SEARch:SERial:LIN:MODE {ID|DATA|ERR|FRAM|FSIG}
:SEARch:SERial:LIN:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialLIN..::.PatternData Property
IAgInfiniiVision2SearchSerialLIN See Also

Specifies the data value when searching for LIN events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "0xnn...n" where n: {0,..,9 | A,..,F | X}

The length of the data value entered is specified using the PatternDataLength property.

Instrument Command

:SEARch:SERial:LIN:PATTern:DATA "{value}"
:SEARch:SERial:LIN:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialLIN..::.PatternDataLength Property
IAgInfiniiVision2SearchSerialLIN See Also

Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternDataLength As Integer
C#
public int  PatternDataLength { get; set; }
Visual C++
HRESULT get_PatternDataLength(
    long*  val
);
HRESULT put_PatternDataLength(
    long  val
);

Remarks

The data value is specified using the PatternData property

Instrument Command

:SEARch:SERial:LIN:PATTern:DATA:LENGth {value}
:SEARch:SERial:LIN:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


M1553 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.M1553 Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialM1553 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property M1553 As IAgInfiniiVision2SearchSerialM1553
C#
public IAgInfiniiVision2SearchSerialM1553  M1553 { get; }
Visual C++
HRESULT get_M1553(
    IAgInfiniiVision2SearchSerialM1553**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialM1553..::.Mode Property
IAgInfiniiVision2SearchSerialM1553 See Also

Specifies the type of MIL-STD-1553 information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchSerialM1553ModeEnum
C#
public AgInfiniiVisionSearchSerialM1553ModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchSerialM1553ModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchSerialM1553ModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialM1553ModeDataStart - Finds the start of a data word (at the end of a valid Data Sync pulse).
  • AgInfiniiVisionSearchSerialM1553ModeCommandStart - Finds the start of a Command/Status word (at the end of a valid C/S Sync pulse).
  • AgInfiniiVisionSearchSerialM1553ModeRTA - Finds the Command/Status Word whose RTA matches the specified value. The value is specified in hex.
  • AgInfiniiVisionSearchSerialM1553ModeRTA11 - Finds the RTA and the remaining 11 bits that match the specified criteria. The RTA can be specified as a hex value and the remaining bits are specified as 1 or 0.
  • AgInfiniiVisionSearchSerialM1553ModeParityError - Finds (odd) parity bits that are incorrect for the data in the word.
  • AgInfiniiVisionSearchSerialM1553ModeSyncError - Finds invalid sync pulses.
  • AgInfiniiVisionSearchSerialM1553ModeManchesterError - Finds Manchester encoding errors.

Instrument Command

:SEARch:SERial:M1553:MODE {DSTA|CSTA|RTA|RTA11|PERR|SERR|MERR}
:SEARch:SERial:M1553:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialM1553..::.PatternData Property
IAgInfiniiVision2SearchSerialM1553 See Also

Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in one of the following formats:

  • "nn...n", where n: {0 | 1 | X}

Instrument Command

:SEARch:SERial:M1553:PATTern:DATA "{value}"
:SEARch:SERial:M1553:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


RTA Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialM1553..::.RTA Property
IAgInfiniiVision2SearchSerialM1553 See Also

Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RTA As String
C#
public string  RTA { get; set; }
Visual C++
HRESULT get_RTA(
    BSTR*  val
);
HRESULT put_RTA(
    BSTR  val
);

Remarks

The RTA property can be specified in one of the following formats:

  • "n", where n is an integer from 0-31
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SEARch:SERial:M1553:RTA {value}
:SEARch:SERial:M1553:RTA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


SPI Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.SPI Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialSPI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SPI As IAgInfiniiVision2SearchSerialSPI
C#
public IAgInfiniiVision2SearchSerialSPI  SPI { get; }
Visual C++
HRESULT get_SPI(
    IAgInfiniiVision2SearchSerialSPI**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialSPI..::.Mode Property
IAgInfiniiVision2SearchSerialSPI See Also

Specifies whether the SPI search will be on the MOSI data or the MISO data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchSPIModeEnum
C#
public AgInfiniiVisionSearchSPIModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchSPIModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchSPIModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSPITypeMOSI - to specify that the search will be on MOSI data
  • AgInfiniiVisionSearchSPITypeMISO - to specify that the search will be on MISO data

Data values are specified using the PatternData property.

Instrument Command

:SEARch:SERial:SPI:MODE {MOSI|MISO}
:SEARch:SERial:SPI:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialSPI..::.PatternData Property
IAgInfiniiVision2SearchSerialSPI See Also

Specifies the data value when searching for SPI events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in the following string format:

  • "0xnnnnnn", where n: {0,..,9 | A,..,F | X}

The width of the data value is specified using the PatternWidth property.

Instrument Command

:SEARch:SERial:SPI:PATTern:DATA "{value}"
:SEARch:SERial:SPI:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialSPI..::.PatternWidth Property
IAgInfiniiVision2SearchSerialSPI See Also

Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternWidth As Integer
C#
public int  PatternWidth { get; set; }
Visual C++
HRESULT get_PatternWidth(
    long*  val
);
HRESULT put_PatternWidth(
    long  val
);

Remarks

The data value is specified using the PatternData property.

Instrument Command

:SEARch:SERial:SPI:PATTern:WIDTh {value}
:SEARch:SERial:SPI:PATTern:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SearchSerialSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


UART Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial..::.UART Property
IAgInfiniiVision2SearchSerial See Also

Pointer to the IAgInfiniiVision2SearchSerialUART interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property UART As IAgInfiniiVision2SearchSerialUART
C#
public IAgInfiniiVision2SearchSerialUART  UART { get; }
Visual C++
HRESULT get_UART(
    IAgInfiniiVision2SearchSerialUART**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SearchSerial Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialUART..::.Condition Property
IAgInfiniiVision2SearchSerialUART See Also

Specifies the data value qualifier when searching for UART/RS232 events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchUARTConditionEnum
C#
public AgInfiniiVisionSearchUARTConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchUARTConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchUARTConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchUARTConditionEqual - Equal
  • AgInfiniiVisionSearchUARTConditionNotEqual - Not Equal
  • AgInfiniiVisionSearchUARTConditionGreaterThan - Greater Than
  • AgInfiniiVisionSearchUARTConditionLessThan - Less Than

Instrument Command

:SEARch:SERial:UART:QUALifier {EQU|NOT|GRE|LESS}
:SEARch:SERial:UART:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialUART..::.Mode Property
IAgInfiniiVision2SearchSerialUART See Also

Selects the type of UART/RS232 information to find in the Lister display

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchUARTModeEnum
C#
public AgInfiniiVisionSearchUARTModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchUARTModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchUARTModeEnum  val
);

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchUARTTypeRData - searches for a receive data value when data words are from 5 to 8 bits long
  • AgInfiniiVisionSearchUARTTypeRD1 - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 1
  • AgInfiniiVisionSearchUARTTypeRD0 - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 0
  • AgInfiniiVisionSearchUARTTypeRDX - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X)
  • AgInfiniiVisionSearchUARTTypeTData - searches for a transmit data value when data words are from 5 to 8 bits long
  • AgInfiniiVisionSearchUARTTypeTD1 - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 1
  • AgInfiniiVisionSearchUARTTypeTD0 - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 0
  • AgInfiniiVisionSearchUARTTypeTDX - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X)
  • AgInfiniiVisionSearchUARTTypeParityError - searches for parity errors
  • AgInfiniiVisionSearchUARTTypeAnyError - searches for any error

Data values are specified using the PatternData property.
Data value qualifiers are specified using the Condition property.

Instrument Command

:SEARch:SERial:UART:MODE {RDAT|RD1|RD0|RDX|TDAT|TD1|TD0|TDX|PAR|AERR}
:SEARch:SERial:UART:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialUART Interface
Agilent.AgInfiniiVision.Interop Namespace


PatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialUART..::.PatternData Property
IAgInfiniiVision2SearchSerialUART See Also

Specifies a data value when searching for UART/RS232 events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PatternData As String
C#
public string  PatternData { get; set; }
Visual C++
HRESULT get_PatternData(
    BSTR*  val
);
HRESULT put_PatternData(
    BSTR  val
);

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F} from 0x00-0xff
  • "#Bnn...n", where n: {0 | 1}
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00-0xff
  • Any of the 128 valid 7-bit ASCII characters (or standard abbreviations)

The data value qualifier is specified using the Condition property.

Instrument Command

:SEARch:SERial:UART:DATA {value}
:SEARch:SERial:UART:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchSerialUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Transition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search..::.Transition Property
IAgInfiniiVision2Search See Also

Pointer to the IAgInfiniiVision2Search2Transition interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Transition As IAgInfiniiVision2SearchTransition
C#
public IAgInfiniiVision2SearchTransition  Transition { get; }
Visual C++
HRESULT get_Transition(
    IAgInfiniiVision2SearchTransition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2Search Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition..::.Condition Property
IAgInfiniiVision2SearchTransition See Also

Specifies whether to search for edge transitions greater than or less than a time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchTransitionConditionEnum
C#
public AgInfiniiVisionSearchTransitionConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchTransitionConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchTransitionConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchTransitionConditionGreaterThan - to search for transitions greater than a time
  • AgInfiniiVisionSearchTransitionConditionLessThan - to search for transitions less than a time

Instrument Command

:SEARch:TRANsition:QUALifier {GRE|LESS}
:SEARch:TRANsition:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchTransition Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition..::.Configure Method
IAgInfiniiVision2SearchTransition See Also

Configures the Source, Slope, Condition and QualifierTime properties for a transition search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Slope As AgInfiniiVisionSearchTransitionSlopeEnum  _
    ByVal  Condition As AgInfiniiVisionSearchTransitionConditionEnum  _
    ByVal  QualifierTime As Double  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionSearchTransitionSlopeEnum  Slope,
    AgInfiniiVisionSearchTransitionConditionEnum  Condition,
    double  QualifierTime
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionSearchTransitionSlopeEnum  Slope,
    AgInfiniiVisionSearchTransitionConditionEnum  Condition,
    double  QualifierTime
);

Parameters

Source

The channel on which to search for edge transitions. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Slope

Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.

Condition

Specifies whether to search for edge transitions greater than or less than a time.

QualifierTime

The time of the transition to search for. You can search for transitions greater than or less than this time.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchTransition Interface
Agilent.AgInfiniiVision.Interop Namespace


QualifierTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition..::.QualifierTime Property
IAgInfiniiVision2SearchTransition See Also

The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property QualifierTime As Double
C#
public double  QualifierTime { get; set; }
Visual C++
HRESULT get_QualifierTime(
    double*  val
);
HRESULT put_QualifierTime(
    double  val
);

Instrument Command

:SEARch:TRANsition:TIME {value}
:SEARch:TRANsition:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchTransition Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition..::.Slope Property
IAgInfiniiVision2SearchTransition See Also

Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionSearchTransitionSlopeEnum
C#
public AgInfiniiVisionSearchTransitionSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionSearchTransitionSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionSearchTransitionSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTransitionSlopeNegative - to specify negative slope
  • AgInfiniiVisionTransitionSlopePositive - to specify positive slope

Instrument Command

:SEARch:TRANsition:SLOPe {NEG|POS}
:SEARch:TRANsition:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchTransition Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition..::.Source Property
IAgInfiniiVision2SearchTransition See Also

The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:SEARch:TRANsition:SOURce {value}
:SEARch:TRANsition:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SearchTransition Interface
Agilent.AgInfiniiVision.Interop Namespace


Search2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.Search2 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Search2 As IAgInfiniiVisionSearch2
C#
public IAgInfiniiVisionSearch2  Search2 { get; }
Visual C++
HRESULT get_Search2(
    IAgInfiniiVisionSearch2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Serial2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch2..::.Serial2 Property
IAgInfiniiVisionSearch2 See Also

Pointer to the IAgInfiniiVision2Search2Serial interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Serial2 As IAgInfiniiVisionSearchSerial2
C#
public IAgInfiniiVisionSearchSerial2  Serial2 { get; }
Visual C++
HRESULT get_Serial2(
    IAgInfiniiVisionSearchSerial2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearch2 Interface
Agilent.AgInfiniiVision.Interop Namespace


USB Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2..::.USB Property
IAgInfiniiVisionSearchSerial2 See Also

Pointer to the IAgInfiniiVision2Search2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property USB As IAgInfiniiVisionSearchSerial2USB
C#
public IAgInfiniiVisionSearchSerial2USB  USB { get; }
Visual C++
HRESULT get_USB(
    IAgInfiniiVisionSearchSerial2USB**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Address Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.Address Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 7-bit Address portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Address As String
C#
public string  Address { get; set; }
Visual C++
HRESULT get_Address(
    BSTR*  val
);
HRESULT put_Address(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ADDRess {value}
:SEARch:SERial:USB:ADDRess?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.Condition Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the USB search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSearchUSBConditionEnum
C#
public AgInfiniiVisionSearchUSBConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSearchUSBConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSearchUSBConditionEnum  val
);

Remarks

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:MODE {TOK|DATA|HAND|SPEC|ALL|PID|CRC5|CRC16|GLIT|STUFF|SE1}
:SEARch:SERial:USB:MODE?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


CRC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.CRC Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the CRC portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CRC As String
C#
public string  CRC { get; set; }
Visual C++
HRESULT get_CRC(
    BSTR*  val
);
HRESULT put_CRC(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:CRC {value}
:SEARch:SERial:USB:CRC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.Data Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the Data portion of the trigger, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As String
C#
public string  Data { get; set; }
Visual C++
HRESULT get_Data(
    BSTR*  val
);
HRESULT put_Data(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xn..." where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:DATA {value}
:SEARch:SERial:USB:DATA?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


DataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.DataLength Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the data length in bytes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataLength As Short
C#
public short  DataLength { get; set; }
Visual C++
HRESULT get_DataLength(
    short*  val
);
HRESULT put_DataLength(
    short  val
);

Remarks

  • It range is from 1 to 20.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:DATA:LENGth {value}
    :SEARch:SERial:USB:DATA:LENGth?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


EndPoint Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.EndPoint Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 4-bit Endpoint portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property EndPoint As String
C#
public string  EndPoint { get; set; }
Visual C++
HRESULT get_EndPoint(
    BSTR*  val
);
HRESULT put_EndPoint(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ENDPoint {value}
:SEARch:SERial:USB:ENDPoint?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


ET Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.ET Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 2-bit ET portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ET As String
C#
public string  ET { get; set; }
Visual C++
HRESULT get_ET(
    BSTR*  val
);
HRESULT put_ET(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | 2 | 3 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ET {value}
:SEARch:SERial:USB:ET?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Frame Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.Frame Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 11-bit Frame portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frame As String
C#
public string  Frame { get; set; }
Visual C++
HRESULT get_Frame(
    BSTR*  val
);
HRESULT put_Frame(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xnnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:FRAMe {value}
:SEARch:SERial:USB:FRAMe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


HubAddress Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.HubAddress Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 7-bit Hub Address portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HubAddress As String
C#
public string  HubAddress { get; set; }
Visual C++
HRESULT get_HubAddress(
    BSTR*  val
);
HRESULT put_HubAddress(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:HADDress {value}
:SEARch:SERial:USB:HADDress?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


PIDData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.PIDData Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the USB data PID to find.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDData As AgInfiniiVisionPIDDataEnum
C#
public AgInfiniiVisionPIDDataEnum  PIDData { get; set; }
Visual C++
HRESULT get_PIDData(
    AgInfiniiVisionPIDDataEnum*  val
);
HRESULT put_PIDData(
    AgInfiniiVisionPIDDataEnum  val
);

Remarks

  • The DATA USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:DATA {DATA0|DATA1|DATA2|MDAT}
    :SEARch:SERial:USB:PID:DATA?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDHandshake Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.PIDHandshake Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the USB handshake PID to find.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDHandshake As AgInfiniiVisionPIDHandshakeEnum
C#
public AgInfiniiVisionPIDHandshakeEnum  PIDHandshake { get; set; }
Visual C++
HRESULT get_PIDHandshake(
    AgInfiniiVisionPIDHandshakeEnum*  val
);
HRESULT put_PIDHandshake(
    AgInfiniiVisionPIDHandshakeEnum  val
);

Remarks

  • The HANDshake USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:HANDshake {ACK|NAK|STALL|NYET}
    :SEARch:SERial:USB:PID:HANDshake?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDSpecial Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.PIDSpecial Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the USB special PID to find.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDSpecial As AgInfiniiVisionPIDSpecialEnum
C#
public AgInfiniiVisionPIDSpecialEnum  PIDSpecial { get; set; }
Visual C++
HRESULT get_PIDSpecial(
    AgInfiniiVisionPIDSpecialEnum*  val
);
HRESULT put_PIDSpecial(
    AgInfiniiVisionPIDSpecialEnum  val
);

Remarks

  • The SPECial USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:SPECial {PING|PRE|ERR|SPLIT}
    :SEARch:SERial:USB:PID:SPECial?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDToken Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.PIDToken Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the USB token PID to find.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDToken As AgInfiniiVisionPIDTokenEnum
C#
public AgInfiniiVisionPIDTokenEnum  PIDToken { get; set; }
Visual C++
HRESULT get_PIDToken(
    AgInfiniiVisionPIDTokenEnum*  val
);
HRESULT put_PIDToken(
    AgInfiniiVisionPIDTokenEnum  val
);

Remarks

  • The TOKen USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:TOKen {OUT|IN|SET|SOF}
    :SEARch:SERial:USB:PID:TOKen?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


Port Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.Port Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 7-bit Port portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Port As String
C#
public string  Port { get; set; }
Visual C++
HRESULT get_Port(
    BSTR*  val
);
HRESULT put_Port(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:PORT {value}
:SEARch:SERial:USB:PORT?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


SC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.SC Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 1-bit SC portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SC As String
C#
public string  SC { get; set; }
Visual C++
HRESULT get_SC(
    BSTR*  val
);
HRESULT put_SC(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:SC {value}
:SEARch:SERial:USB:SC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


SEU Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB..::.SEU Property
IAgInfiniiVisionSearchSerial2USB See Also

Specifies the 2-bit S and E or U portion of the search value, in hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SEU As String
C#
public string  SEU { get; set; }
Visual C++
HRESULT get_SEU(
    BSTR*  val
);
HRESULT put_SEU(
    BSTR  val
);

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | 2 | 3 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:SEU {value}
:SEARch:SERial:USB:SEU?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSearchSerial2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Search3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.Search3 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Search3 As IAgInfiniiVisionSearch3
C#
public IAgInfiniiVisionSearch3  Search3 { get; }
Visual C++
HRESULT get_Search3(
    IAgInfiniiVisionSearch3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Peak Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3..::.Peak Property
IAgInfiniiVisionSearch3 See Also

Pointer to the IAgInfiniiVisionSearch3Peak interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Peak As IAgInfiniiVisionSearch3Peak
C#
public IAgInfiniiVisionSearch3Peak  Peak { get; }
Visual C++
HRESULT get_Peak(
    IAgInfiniiVisionSearch3Peak**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearch3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Excursion Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3Peak..::.Excursion Property
IAgInfiniiVisionSearch3Peak See Also

The change in level that must occur (in other words, hysteresis) to be recognized as a peak.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Excursion As Double
C#
public double  Excursion { get; set; }
Visual C++
HRESULT get_Excursion(
    double*  val
);
HRESULT put_Excursion(
    double  val
);

Remarks

  • Preset value is 0.

    • Instrument Command

    :SEARch:PEAK:EXCursion {value}
    :SEARch:PEAK:EXCursion?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearch3Peak Interface
    Agilent.AgInfiniiVision.Interop Namespace


NumberOfPeaks Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3Peak..::.NumberOfPeaks Property
IAgInfiniiVisionSearch3Peak See Also

The maximum number of FFT peaks to find.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfPeaks As Integer
C#
public int  NumberOfPeaks { get; set; }
Visual C++
HRESULT get_NumberOfPeaks(
    long*  val
);
HRESULT put_NumberOfPeaks(
    long  val
);

Remarks

  • Input range is 1 to 10.
  • Preset value is 4.

    • Instrument Command

    :SEARch:PEAK:NPEaks {value}
    :SEARch:PEAK:NPEaks?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearch3Peak Interface
    Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3Peak..::.Source Property
IAgInfiniiVisionSearch3Peak See Also

The FFT math function waveform to search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

  • Input range is None or Function1 to Function4.

    • Instrument Command

    :SEARch:PEAK:SOURce {value}
    :SEARch:PEAK:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearch3Peak Interface
    Agilent.AgInfiniiVision.Interop Namespace


Threshold Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3Peak..::.Threshold Property
IAgInfiniiVisionSearch3Peak See Also

The threshold level necessary to be considered a peak.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Threshold As Double
C#
public double  Threshold { get; set; }
Visual C++
HRESULT get_Threshold(
    double*  val
);
HRESULT put_Threshold(
    double  val
);

Remarks

  • Preset value is 0.

    • Instrument Command

    :SEARch:PEAK:THReshold {value}
    :SEARch:PEAK:THReshold?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearch3Peak Interface
    Agilent.AgInfiniiVision.Interop Namespace


Search4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.Search4 Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Search4 As IAgInfiniiVisionSearch4
C#
public IAgInfiniiVisionSearch4  Search4 { get; }
Visual C++
HRESULT get_Search4(
    IAgInfiniiVisionSearch4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


Serial3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch4..::.Serial3 Property
IAgInfiniiVisionSearch4 See Also

Pointer to the IAgInfiniiVision2Search2Serial interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Serial3 As IAgInfiniiVisionSearchSerial3
C#
public IAgInfiniiVisionSearchSerial3  Serial3 { get; }
Visual C++
HRESULT get_Serial3(
    IAgInfiniiVisionSearchSerial3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearch4 Interface
Agilent.AgInfiniiVision.Interop Namespace


SENT Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3..::.SENT Property
IAgInfiniiVisionSearchSerial3 See Also

Pointer to the IAgInfiniiVisionSearchSerial3SENT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SENT As IAgInfiniiVisionSearchSerial3SENT
C#
public IAgInfiniiVisionSearchSerial3SENT  SENT { get; }
Visual C++
HRESULT get_SENT(
    IAgInfiniiVisionSearchSerial3SENT**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Fast Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENT..::.Fast Property
IAgInfiniiVisionSearchSerial3SENT See Also

Pointer to the IAgInfiniiVisionSearchSerial3SENTFast interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Fast As IAgInfiniiVisionSearchSerial3SENTFast
C#
public IAgInfiniiVisionSearchSerial3SENTFast  Fast { get; }
Visual C++
HRESULT get_Fast(
    IAgInfiniiVisionSearchSerial3SENTFast**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENTFast..::.Data Property
IAgInfiniiVisionSearchSerial3SENTFast See Also

Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As String
C#
public string  Data { get; set; }
Visual C++
HRESULT get_Data(
    BSTR*  val
);
HRESULT put_Data(
    BSTR  val
);

Remarks

The input format of string is

  • <Input String> :: = "nnnn..." where n :: = { 0 | 1 | X }

    • or

  • <Input String> :: = "0xn..." where n :: = { 0,..,9 | A,..,F | X |$}

    • Instrument Command

    :SEARch:SERial:SENT:FAST:DATA "{value}"
    :SEARch:SERial:SENT:FAST:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial3SENTFast Interface
    Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENT..::.Mode Property
IAgInfiniiVisionSearchSerial3SENT See Also

Sets and gets the search mode settings.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSearchSentEnum
C#
public AgInfiniiVisionSearchSentEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSearchSentEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSearchSentEnum  val
);

Remarks

  • AgInfiniiVisionSearchSentFCData - finds Fast Channel data nibbles that match the values entered using additional softkeys.
  • AgInfiniiVisionSearchSentSCMid - finds Slow Channel Message IDs that match the value entered using additional softkeys.
  • AgInfiniiVisionSearchSentSCData - finds Slow Channel Message IDs and Data that match the values entered using additional softkeys.
  • AgInfiniiVisionSearchSentCRCerror - finds any CRC error, Fast or Slow.
  • AgInfiniiVisionSearchSentPPERror - finds where a nibble is either too wide or too narrow (for example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, or checksum pulse periods are checked.

    • Instrument Command

    :SEARch:SERial:SENT:MODE {FCD|SCM|SCD|CRC|PPER}
    :SEARch:SERial:SENT:MODE?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial3SENT Interface
    Agilent.AgInfiniiVision.Interop Namespace


Slow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENT..::.Slow Property
IAgInfiniiVisionSearchSerial3SENT See Also

Pointer to the IAgInfiniiVisionSearchSerial3SENTSlow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Slow As IAgInfiniiVisionSearchSerial3SENTSlow
C#
public IAgInfiniiVisionSearchSerial3SENTSlow  Slow { get; }
Visual C++
HRESULT get_Slow(
    IAgInfiniiVisionSearchSerial3SENTSlow**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENTSlow..::.Data Property
IAgInfiniiVisionSearchSerial3SENTSlow See Also

Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As String
C#
public string  Data { get; set; }
Visual C++
HRESULT get_Data(
    BSTR*  val
);
HRESULT put_Data(
    BSTR  val
);

Remarks

The format of Data is look like

  • <Input String Data> :: =From -1 (don't care) to 65535, in NR1 format.

    • Instrument Command

    :SEARch:SERial:SENT:SLOW:DATA {value}
    :SEARch:SERial:SENT:SLOW:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial3SENTSlow Interface
    Agilent.AgInfiniiVision.Interop Namespace


ID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENTSlow..::.ID Property
IAgInfiniiVisionSearchSerial3SENTSlow See Also

Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ID As Integer
C#
public int  ID { get; set; }
Visual C++
HRESULT get_ID(
    long*  val
);
HRESULT put_ID(
    long  val
);

Remarks

  • <Input String Data> :: =From -1 (don't care) to 255, in NR1 format (depending on the message length).

    • Instrument Command

    :SEARch:SERial:SENT:SLOW:ID {value}
    :SEARch:SERial:SENT:SLOW:ID?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSearchSerial3SENTSlow Interface
    Agilent.AgInfiniiVision.Interop Namespace


Search5 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision6..::.Search5 Property
IAgInfiniiVision6 See Also

Pointer to the IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Search5 As IAgInfiniiVisionSearch5
C#
public IAgInfiniiVisionSearch5  Search5 { get; }
Visual C++
HRESULT get_Search5(
    IAgInfiniiVisionSearch5**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision6 Interface
Agilent.AgInfiniiVision.Interop Namespace


Serial4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5..::.Serial4 Property
IAgInfiniiVisionSearch5 See Also

Pointer to the IAgInfiniiVision2Search2Serial interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Serial4 As IAgInfiniiVisionSearchSerial4
C#
public IAgInfiniiVisionSearchSerial4  Serial4 { get; }
Visual C++
HRESULT get_Serial4(
    IAgInfiniiVisionSearchSerial4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearch5 Interface
Agilent.AgInfiniiVision.Interop Namespace


CAN2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial4..::.CAN2 Property
IAgInfiniiVisionSearchSerial4 See Also

Pointer to the IAgInfiniiVision2SearchSerialCAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CAN2 As IAgInfiniiVision2Search5Serial4CAN2
C#
public IAgInfiniiVision2Search5Serial4CAN2  CAN2 { get; }
Visual C++
HRESULT get_CAN2(
    IAgInfiniiVision2Search5Serial4CAN2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial4 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicMessage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search5Serial4CAN2..::.SymbolicMessage Property
IAgInfiniiVision2Search5Serial4CAN2 See Also

Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicMessage As String
C#
public string  SymbolicMessage { get; set; }
Visual C++
HRESULT get_SymbolicMessage(
    BSTR*  val
);
HRESULT put_SymbolicMessage(
    BSTR  val
);

Instrument Command

:SEARch:SERial:CAN:SYMBolic:MESSage {value}
:SEARch:SERial:CAN:SYMBolic:MESSage?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2Search5Serial4CAN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicSignal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search5Serial4CAN2..::.SymbolicSignal Property
IAgInfiniiVision2Search5Serial4CAN2 See Also

Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicSignal As String
C#
public string  SymbolicSignal { get; set; }
Visual C++
HRESULT get_SymbolicSignal(
    BSTR*  val
);
HRESULT put_SymbolicSignal(
    BSTR  val
);

Instrument Command

:SEARch:SERial:CAN:SYMBolic:SIGNal {value}
:SEARch:SERial:CAN:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2Search5Serial4CAN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicValue Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search5Serial4CAN2..::.SymbolicValue Property
IAgInfiniiVision2Search5Serial4CAN2 See Also

Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicValue As Double
C#
public double  SymbolicValue { get; set; }
Visual C++
HRESULT get_SymbolicValue(
    double*  val
);
HRESULT put_SymbolicValue(
    double  val
);

Instrument Command

:SEARch:SERial:CAN:SYMBolic:VALue {value}
:SEARch:SERial:CAN:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2Search5Serial4CAN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


LIN2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial4..::.LIN2 Property
IAgInfiniiVisionSearchSerial4 See Also

Pointer to the IAgInfiniiVision2SearchSerialLIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property LIN2 As IAgInfiniiVisionSearch5Serial4LIN2
C#
public IAgInfiniiVisionSearch5Serial4LIN2  LIN2 { get; }
Visual C++
HRESULT get_LIN2(
    IAgInfiniiVisionSearch5Serial4LIN2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSearchSerial4 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicFrame Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5Serial4LIN2..::.SymbolicFrame Property
IAgInfiniiVisionSearch5Serial4LIN2 See Also

Sets and Gets the specific message when LIN serial search mode is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicFrame As String
C#
public string  SymbolicFrame { get; set; }
Visual C++
HRESULT get_SymbolicFrame(
    BSTR*  val
);
HRESULT put_SymbolicFrame(
    BSTR  val
);

Instrument Command

:SEARch:SERial:LIN:SYMBolic:FRAMe {value}
:SEARch:SERial:LIN:SYMBolic:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSearch5Serial4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicSignal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5Serial4LIN2..::.SymbolicSignal Property
IAgInfiniiVisionSearch5Serial4LIN2 See Also

Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicSignal As String
C#
public string  SymbolicSignal { get; set; }
Visual C++
HRESULT get_SymbolicSignal(
    BSTR*  val
);
HRESULT put_SymbolicSignal(
    BSTR  val
);

Instrument Command

:SEARch:SERial:LIN:SYMBolic:SIGNal {value}
:SEARch:SERial:LIN:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSearch5Serial4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SymbolicValue Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5Serial4LIN2..::.SymbolicValue Property
IAgInfiniiVisionSearch5Serial4LIN2 See Also

Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SymbolicValue As Double
C#
public double  SymbolicValue { get; set; }
Visual C++
HRESULT get_SymbolicValue(
    double*  val
);
HRESULT put_SymbolicValue(
    double  val
);

Instrument Command

:SEARch:SERial:LIN:SYMBolic:VALue {value}
:SEARch:SERial:LIN:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSearch5Serial4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialBuses Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.SerialBuses Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVision2SerialBuses interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialBuses As IAgInfiniiVision2SerialBuses
C#
public IAgInfiniiVision2SerialBuses  SerialBuses { get; }
Visual C++
HRESULT get_SerialBuses(
    IAgInfiniiVision2SerialBuses**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBuses..::.Count Property
IAgInfiniiVision2SerialBuses See Also

Read Only - Returns the number of serial buses.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBuses Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBuses..::.Item Property
IAgInfiniiVision2SerialBuses See Also

Pointer to the IAgInfiniiVisionSerialBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVision2SerialBus
C#
public IAgInfiniiVision2SerialBus  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVision2SerialBus**  val
);

Parameters

Name

The name of a serial bus. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the SerialBus repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBuses Interface
Agilent.AgInfiniiVision.Interop Namespace


ARINC429 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.ARINC429 Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ARINC429 As IAgInfiniiVision2SerialBusARINC429
C#
public IAgInfiniiVision2SerialBusARINC429  ARINC429 { get; }
Visual C++
HRESULT get_ARINC429(
    IAgInfiniiVision2SerialBusARINC429**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.AutoSetup Method
IAgInfiniiVision2SerialBusARINC429 See Also

Automatically configures settings for the ARINC 429 serial bus mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Remarks

It sets the upper/lower trigger threshold to 3.0V and -3.0V repsectively, turn Noise Reject off, sets the probe attenuation to 10:0, sets the vertical scale to 4V/div, turn Serial Decode on, sets the base to Hex, sets the format to Label/SDI/Data/SSM, sets the trigger to the currently active serial bus and sets the trigger mode to Word Start.

Instrument Command

:SBUS{SerialBus}:A429:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


Base Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.Base Property
IAgInfiniiVision2SerialBusARINC429 See Also

Selects between hexadecimal and binary display of the decoded data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Base As AgInfiniiVisionSerialBusARINC429BaseEnum
C#
public AgInfiniiVisionSerialBusARINC429BaseEnum  Base { get; set; }
Visual C++
HRESULT get_Base(
    AgInfiniiVisionSerialBusARINC429BaseEnum*  val
);
HRESULT put_Base(
    AgInfiniiVisionSerialBusARINC429BaseEnum  val
);

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429BaseBinary - specifies binary base
  • AgInfiniiVisionSerialBusARINC429BaseHexadecimal - specifies hexadecimal base

The Base property has no effect on the SDI and SSM fields, which are always displayed in binary, nor the Label field, which is always displayed in octal.

Instrument Command

:SBUS{SerialBus}:A429:BASe {BIN|HEX}
:SBUS{SerialBus}:A429:BASe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


DisplayFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.DisplayFormat Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the word decode format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DisplayFormat As AgInfiniiVisionSerialBusARINC429DisplayFormatEnum
C#
public AgInfiniiVisionSerialBusARINC429DisplayFormatEnum  DisplayFormat { get; set; }
Visual C++
HRESULT get_DisplayFormat(
    AgInfiniiVisionSerialBusARINC429DisplayFormatEnum*  val
);
HRESULT put_DisplayFormat(
    AgInfiniiVisionSerialBusARINC429DisplayFormatEnum  val
);

Remarks

The DisplayFormat property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelSDIDataSSM - specifies the Label/SDI/Data/SSM format
  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelDataSSM - specifies the Label/Data/SSM format
  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelData - specifies the Label/Data format

Instrument Command

:SBUS{SerialBus}:A429:FORMat {LDSD|LDSS|LDAT}
:SBUS{SerialBus}:A429:FORMat?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


ErrorCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.ErrorCount Property
IAgInfiniiVision2SerialBusARINC429 See Also

Read Only - Returns the ARINC 429 error count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorCount As Integer
C#
public int  ErrorCount { get; }
Visual C++
HRESULT get_ErrorCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:A429:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetTriggerRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.GetTriggerRange Method
IAgInfiniiVision2SerialBusARINC429 See Also

Gets the range for the Label Range trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetTriggerRange ( _
    ByRef  LowerLimit As Integer  _
    ByRef  UpperLimit As Integer  _
)
C#
public void  GetTriggerRange(
    ref int  LowerLimit,
    ref int  UpperLimit
)
Visual C++
HRESULT GetTriggerRange(
    long*  LowerLimit,
    long*  UpperLimit
);

Parameters

LowerLimit

The lower limit for the Label Range trigger mode for the selected bus.

UpperLimit

The upper limit for the Label Range trigger mode for the selected bus.

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


ResetCounters Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.ResetCounters Method
IAgInfiniiVision2SerialBusARINC429 See Also

Resets the ARINC 429 counters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ResetCounters ( _
)
C#
public void  ResetCounters(
)
Visual C++
HRESULT ResetCounters(
);

Instrument Command

:SBUS{SerialBus}:A429:COUNt:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


SetTriggerRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.SetTriggerRange Method
IAgInfiniiVision2SerialBusARINC429 See Also

Sets the range for the Label Range trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetTriggerRange ( _
    ByVal  LowerLimit As String  _
    ByVal  UpperLimit As String  _
)
C#
public void  SetTriggerRange(
    string  LowerLimit,
    string  UpperLimit
)
Visual C++
HRESULT SetTriggerRange(
    BSTR  LowerLimit,
    BSTR  UpperLimit
);

Parameters

LowerLimit

The lower limit for the Label Range trigger mode for the selected bus.

UpperLimit

The upper limit for the Label Range trigger mode for the selected bus.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "#Qnn", where n: {0,..,7}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


SignalType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.SignalType Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SignalType As AgInfiniiVisionSerialBusARINC429SignalTypeEnum
C#
public AgInfiniiVisionSerialBusARINC429SignalTypeEnum  SignalType { get; set; }
Visual C++
HRESULT get_SignalType(
    AgInfiniiVisionSerialBusARINC429SignalTypeEnum*  val
);
HRESULT put_SignalType(
    AgInfiniiVisionSerialBusARINC429SignalTypeEnum  val
);

Remarks

The SignalType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429SignalTypeLineA - specifies the Line A (non-inverted) signal type.
  • AgInfiniiVisionSerialBusARINC429SignalTypeLineB - specifies the Line B (inverted) signal type.
  • AgInfiniiVisionSerialBusARINC429SignalTypeDifferential - specifies the Differential (A - B) signal type.

Instrument Command

:SBUS{SerialBus}:A429:SIGNal {A|B|DIFF}
:SBUS{SerialBus}:A429:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.Source Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies which signal is used as the source for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The Source property can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels.

Instrument Command

:SBUS{SerialBus}:A429:SOURce {value}
:SBUS{SerialBus}:A429:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


Speed Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.Speed Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the speed of the ARINC 429 interface for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Speed As AgInfiniiVisionSerialBusARINC429SpeedEnum
C#
public AgInfiniiVisionSerialBusARINC429SpeedEnum  Speed { get; set; }
Visual C++
HRESULT get_Speed(
    AgInfiniiVisionSerialBusARINC429SpeedEnum*  val
);
HRESULT put_Speed(
    AgInfiniiVisionSerialBusARINC429SpeedEnum  val
);

Remarks

The Speed property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429SpeedLow - specifies low speed (12.5kb/s)
  • AgInfiniiVisionSerialBusARINC429SpeedHigh - specifies high speed (100kb/s)

Instrument Command

:SBUS{SerialBus}:A429:SPEed {LOW|HIGH}
:SBUS{SerialBus}:A429:SPEed?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerLabel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerLabel Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the Label portion of the trigger for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerLabel As String
C#
public string  TriggerLabel { get; set; }
Visual C++
HRESULT get_TriggerLabel(
    BSTR*  val
);
HRESULT put_TriggerLabel(
    BSTR  val
);

Remarks

The TriggerLabel property can be specified in one of the following formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "#Qnn", where n: {0,..,7}
  • "0xnn", where n: {0,..,9 | A,..,F}
  • "0xXX" (don't care)

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:LABel {value}
:SBUS{SerialBus}:A429:TRIGger:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the Data portion of the trigger for the selected bus, in binary.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData property can be specified in the following format:

  • "nn..n", where n: {0 | 1 | X}

The length depends on the value of the DisplayFormat property:
  • If DisplayFormat is set to Label/SDI/Data/SSM, then the data length is 19 bits
  • If DisplayFormat is set to Label/Data/SSM, then the data length is 21 bits
  • If DisplayFormat is set to Label/Data, then the data length is 23 bits

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternSDI Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerPatternSDI Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternSDI As String
C#
public string  TriggerPatternSDI { get; set; }
Visual C++
HRESULT get_TriggerPatternSDI(
    BSTR*  val
);
HRESULT put_TriggerPatternSDI(
    BSTR  val
);

Remarks

The TriggerPatternSDI property can be specified in the following format:

  • "nn", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:SDI "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:SDI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternSSM Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerPatternSSM Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternSSM As String
C#
public string  TriggerPatternSSM { get; set; }
Visual C++
HRESULT get_TriggerPatternSSM(
    BSTR*  val
);
HRESULT put_TriggerPatternSSM(
    BSTR  val
);

Remarks

The TriggerPatternSSM property can be specified in the following format:

  • "nn", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:SSM "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:SSM?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerThresholdHigh Property
IAgInfiniiVision2SerialBusARINC429 See Also

The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerThresholdHigh As Double
C#
public double  TriggerThresholdHigh { get; set; }
Visual C++
HRESULT get_TriggerThresholdHigh(
    double*  val
);
HRESULT put_TriggerThresholdHigh(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerThresholdLow Property
IAgInfiniiVision2SerialBusARINC429 See Also

The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerThresholdLow As Double
C#
public double  TriggerThresholdLow { get; set; }
Visual C++
HRESULT get_TriggerThresholdLow(
    double*  val
);
HRESULT put_TriggerThresholdLow(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.TriggerType Property
IAgInfiniiVision2SerialBusARINC429 See Also

Specifies the ARINC 429 trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusARINC429TriggerTypeEnum
C#
public AgInfiniiVisionSerialBusARINC429TriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusARINC429TriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusARINC429TriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordStart - Word start mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordStop - Word stop mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabel - Label mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabelBits - Label + Bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabelRange - Label range mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeParityError - Parity error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordError - Word error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeGapError - Gap error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordOrGapError - Word or Gap error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllErrors - All errors mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllBits - All bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllZeroBits - All zero bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllOneBits - All one bits mode

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:TYPE {WSTA|WSTO|LAB|LBIT|LRAN|PERR|WERR|WGER|ALL|ABIT|AZB|AOB|GERR}
:SBUS{SerialBus}:A429:TRIGger:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


WordCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429..::.WordCount Property
IAgInfiniiVision2SerialBusARINC429 See Also

Read Only - Returns the ARINC 429 word count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WordCount As Integer
C#
public int  WordCount { get; }
Visual C++
HRESULT get_WordCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:A429:COUNt:WORD?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusARINC429 Interface
Agilent.AgInfiniiVision.Interop Namespace


CAN Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.CAN Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2CAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CAN As IAgInfiniiVision2SerialBusCAN
C#
public IAgInfiniiVision2SerialBusCAN  CAN { get; }
Visual C++
HRESULT get_CAN(
    IAgInfiniiVision2SerialBusCAN**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


BaudRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.BaudRate Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BaudRate As Integer
C#
public int  BaudRate { get; set; }
Visual C++
HRESULT get_BaudRate(
    long*  val
);
HRESULT put_BaudRate(
    long  val
);

Remarks

If the baud rate you select does not match the system baud rate, false triggers may occur.
Valid values are from 10000 to 1000000 in 100b/s increments.

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:BAUDrate {value}
:SBUS{SerialBus}:CAN:SIGNal:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


ErrorCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.ErrorCount Property
IAgInfiniiVision2SerialBusCAN See Also

Read Only - Gets the error frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorCount As Integer
C#
public int  ErrorCount { get; }
Visual C++
HRESULT get_ErrorCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


OverloadCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.OverloadCount Property
IAgInfiniiVision2SerialBusCAN See Also

Read Only - Gets the overload frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property OverloadCount As Integer
C#
public int  OverloadCount { get; }
Visual C++
HRESULT get_OverloadCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:OVERload?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


ResetCounters Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.ResetCounters Method
IAgInfiniiVision2SerialBusCAN See Also

Resets the frame counters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ResetCounters ( _
)
C#
public void  ResetCounters(
)
Visual C++
HRESULT ResetCounters(
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


SamplePoint Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.SamplePoint Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SamplePoint As Double
C#
public double  SamplePoint { get; set; }
Visual C++
HRESULT get_SamplePoint(
    double*  val
);
HRESULT put_SamplePoint(
    double  val
);

Remarks

Valid values are: 30.0 to 90.0 in NR3 format for 6000x For others valid values are: 60, 62.5, 68, 70, 75, 80, 87.5

Instrument Command

:SBUS{SerialBus}:CAN:SAMPlepoint {value}
:SBUS{SerialBus}:CAN:SAMPlepoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


SignalType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.SignalType Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SignalType As AgInfiniiVisionSerialBusCANSignalTypeEnum
C#
public AgInfiniiVisionSerialBusCANSignalTypeEnum  SignalType { get; set; }
Visual C++
HRESULT get_SignalType(
    AgInfiniiVisionSerialBusCANSignalTypeEnum*  val
);
HRESULT put_SignalType(
    AgInfiniiVisionSerialBusCANSignalTypeEnum  val
);

Remarks

The SignalType property can be set to one of the following values:

  • Dominant high signals:
    • AgInfiniiVisionSerialBusCANSignalTypeCANH - the actual CAN_H differential bus signal
    • AgInfiniiVisionSerialBusCANSignalTypeDIFH - the CAN differential (H-L) bus signal connected to an analog source channel using a differential probe
  • Dominant low signals:
    • AgInfiniiVisionSerialBusCANSignalTypeCANL - the actual CAN_L differential bus signal
    • AgInfiniiVisionSerialBusCANSignalTypeRX - the Receive signal from the CAN bus transceiver
    • AgInfiniiVisionSerialBusCANSignalTypeTX - the Transmit signal to the CAN bus transceiver
    • AgInfiniiVisionSerialBusCANSignalTypeDIFL - the CAN differential (L-H) bus signal connected to an analog source channel using a differential probe
    • AgInfiniiVisionSerialBusCANSignalTypeDifferential - the CAN differential bus signal connected to an analog source channel using a differential probe. This is the same as AgInfiniiVisionSerialBusCANSignalTypeDIFL

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:DEFinition {CANH|CANL|RX|TX|DIFF|DIFL|DIFH}
:SBUS{SerialBus}:CAN:SIGNal:DEFinition?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.Source Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the source for the CAN signal

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The Source property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:CAN:SOURce {value}
:SBUS{SerialBus}:CAN:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TotalCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TotalCount Property
IAgInfiniiVision2SerialBusCAN See Also

Read Only - Gets the total frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TotalCount As Integer
C#
public int  TotalCount { get; }
Visual C++
HRESULT get_TotalCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:TOTal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TriggerCondition Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the CAN trigger on condition

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerCondition As AgInfiniiVisionSerialBusCANTriggerConditionEnum
C#
public AgInfiniiVisionSerialBusCANTriggerConditionEnum  TriggerCondition { get; set; }
Visual C++
HRESULT get_TriggerCondition(
    AgInfiniiVisionSerialBusCANTriggerConditionEnum*  val
);
HRESULT put_TriggerCondition(
    AgInfiniiVisionSerialBusCANTriggerConditionEnum  val
);

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusCANTriggerConditionSOF - will trigger on the Start of Frame (SOF) bit of a Data frame, Remote Transfer Request (RTR) frame, or an Overload frame
  • AgInfiniiVisionSerialBusCANTriggerConditionData - will trigger on CAN Data frames matching the specified Id, Data, and the DLC (Data length code)
  • AgInfiniiVisionSerialBusCANTriggerConditionError - will trigger on CAN Error frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDData - will trigger on CAN frames matching the specified Id of a Data frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDEither - will trigger on the specified Id, regardless if it is a Remote frame or a Data frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDRemote - will trigger on CAN frames matching the specified Id of a Remote frame
  • AgInfiniiVisionSerialBusCANTriggerConditionAllErrors - will trigger on CAN active error frames and unknown bus conditions
  • AgInfiniiVisionSerialBusCANTriggerConditionOverload - will trigger on CAN overload frames
  • AgInfiniiVisionSerialBusCANTriggerConditionAckError - will trigger on a data or remote frame acknowledge bit that is recessive

The table below shows the remote programming parameter and the corresponding front-panel softkey selection:
Remote Parameter | Front-panel Trigger on: softkey selection (softkey text - softkey popup text)
SOF | SOF - Start of Frame
Data | ID & Data - Data Frame ID and Data
Error | Error - Error frame
IDData | ID & ~RTR - Data Frame ID (~RTR)
IDEither | ID - Remote or Data Frame ID
IDRemote | ID & RTR - Remote Frame ID (RTR)
AllErrors | All Errors - All Errors
Overload | Overload - Overload Frame
AckError | Ack Error - Acknowledge Error

CAN Id specification is set by the TriggerPatternID and TriggerPatternIDType properties.
CAN Data specification is set by the TriggerPatternData property.
CAN Data Length Code is set by the TriggerPatternDataLength property.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger {SOF|DATA|ERR|IDD|IDE|IDR|ALL|OVER|ACK|EOF|FDD|FORM|STUF|CRC|SPEC|BRSB|CRCD|EBA|EBP|MESS|MSIG|FDMS}
:SBUS{SerialBus}:CAN:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData property can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

If more bits are sent than specified by the TriggerPatternDataLength property, the most significant bits will be truncated. If the data length is changed after the string is programmed, the added or deleted bits will be added to or deleted from the least significant bits.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TriggerPatternDataLength Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternDataLength As Integer
C#
public int  TriggerPatternDataLength { get; set; }
Visual C++
HRESULT get_TriggerPatternDataLength(
    long*  val
);
HRESULT put_TriggerPatternDataLength(
    long  val
);

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:LENGth {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TriggerPatternID Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternID As String
C#
public string  TriggerPatternID { get; set; }
Visual C++
HRESULT get_TriggerPatternID(
    BSTR*  val
);
HRESULT put_TriggerPatternID(
    BSTR  val
);

Remarks

The TriggerPatternID property can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

If more bits are sent than allowed (11 bits in standard mode, 29 bits in extended mode) by the TriggerPatternIDType property, the most significant bits will be truncated. If the ID mode is changed after the string is programmed, the added or deleted bits will be added to or deleted from the most significant bits.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID "{value}"
:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternIDType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.TriggerPatternIDType Property
IAgInfiniiVision2SerialBusCAN See Also

Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternIDType As AgInfiniiVisionSerialBusCANPatternIDTypeEnum
C#
public AgInfiniiVisionSerialBusCANPatternIDTypeEnum  TriggerPatternIDType { get; set; }
Visual C++
HRESULT get_TriggerPatternIDType(
    AgInfiniiVisionSerialBusCANPatternIDTypeEnum*  val
);
HRESULT put_TriggerPatternIDType(
    AgInfiniiVisionSerialBusCANPatternIDTypeEnum  val
);

Remarks

The TriggerPatternIDType can be set to one of the following values:

  • AgInfiniiVisionSerialBusCANPatternIDTypeStandard - selects the standard 11-bit identifier
  • AgInfiniiVisionSerialBusCANPatternIDTypeExtended - selects the extended 29-bit identifier

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID:MODE {STAN|EXT}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


Utilization Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN..::.Utilization Property
IAgInfiniiVision2SerialBusCAN See Also

Read Only - Gets the percent utilization.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Utilization As Double
C#
public double  Utilization { get; }
Visual C++
HRESULT get_Utilization(
    double*  val
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:UTILization?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusCAN Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.Enabled Property
IAgInfiniiVision2SerialBus See Also

Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

This property is only valid when a serial decode option has been licensed.
Two I2S buses or two SPI buses cannot be decoded on both SerialBus1 and SerialBus2 at the same time.

Instrument Command

:SBUS{SerialBus}:DISPlay {ON|OFF}
:SBUS{SerialBus}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


FlexRay Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.FlexRay Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FlexRay As IAgInfiniiVision2SerialBusFlexRay
C#
public IAgInfiniiVision2SerialBusFlexRay  FlexRay { get; }
Visual C++
HRESULT get_FlexRay(
    IAgInfiniiVision2SerialBusFlexRay**  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.AutoSetup Method
IAgInfiniiVision2SerialBusFlexRay See Also

Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Remarks

Sets the selected source channel's impedance to 50 Ohms, sets the selected source channel's probe attenuation to 10:1, sets the trigger level (on the selected source channel) to -300 mV, turns on trigger Noise Reject, turns on Serial Decode and sets the trigger type to FlexRay.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


BaudRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.BaudRate Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BaudRate As Double
C#
public double  BaudRate { get; set; }
Visual C++
HRESULT get_BaudRate(
    double*  val
);
HRESULT put_BaudRate(
    double  val
);

Remarks

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:BAUDrate {value}
:SBUS{SerialBus}:FLEXray:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


Channel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.Channel Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the bus channel, A or B, of the FlexRay signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Channel As AgInfiniiVisionSerialBusFlexRayChannelEnum
C#
public AgInfiniiVisionSerialBusFlexRayChannelEnum  Channel { get; set; }
Visual C++
HRESULT get_Channel(
    AgInfiniiVisionSerialBusFlexRayChannelEnum*  val
);
HRESULT put_Channel(
    AgInfiniiVisionSerialBusFlexRayChannelEnum  val
);

Remarks

The channel property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayChannelA - specifies bus channel A
  • AgInfiniiVisionSerialBusFlexRayChannelB - specifies bus channel B

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:CHANnel {A|B}
:SBUS{SerialBus}:FLEXray:CHANnel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


ErrorCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.ErrorCount Property
IAgInfiniiVision2SerialBusFlexRay See Also

Read Only - Gets the FlexRay error frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorCount As Integer
C#
public int  ErrorCount { get; }
Visual C++
HRESULT get_ErrorCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


NullCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.NullCount Property
IAgInfiniiVision2SerialBusFlexRay See Also

Read Only - Gets the FlexRay null frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NullCount As Integer
C#
public int  NullCount { get; }
Visual C++
HRESULT get_NullCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:NULL?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


ResetCounters Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.ResetCounters Method
IAgInfiniiVision2SerialBusFlexRay See Also

Resets the FlexRay frame counters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ResetCounters ( _
)
C#
public void  ResetCounters(
)
Visual C++
HRESULT ResetCounters(
);

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:RESET

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.Source Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the input source for the FlexRay signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The Source can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels available.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:SOURce {value}
:SBUS{SerialBus}:FLEXray:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


SyncCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.SyncCount Property
IAgInfiniiVision2SerialBusFlexRay See Also

Read Only - Gets the FlexRay sync frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SyncCount As Integer
C#
public int  SyncCount { get; }
Visual C++
HRESULT get_SyncCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:SYNC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TotalCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TotalCount Property
IAgInfiniiVision2SerialBusFlexRay See Also

Read Only - Gets the FlexRay total frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TotalCount As Integer
C#
public int  TotalCount { get; }
Visual C++
HRESULT get_TotalCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:TOTal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerErrorType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerErrorType Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerErrorType As AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum
C#
public AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum  TriggerErrorType { get; set; }
Visual C++
HRESULT get_TriggerErrorType(
    AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum*  val
);
HRESULT put_TriggerErrorType(
    AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum  val
);

Remarks

The TriggerErrorType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeAll - triggers on ALL errors.
  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeHeaderCRC - triggers on only Header CRC errors.
  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeFrameCRC - triggers on only Frame CRC errors.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:ERRor:TYPE {ALL|HCRC|FCRC}
:SBUS{SerialBus}:FLEXray:TRIGger:ERRor:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerEventAutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerEventAutoSetup Method
IAgInfiniiVision2SerialBusFlexRay See Also

Presets oscilloscope parameters for the selected event type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub TriggerEventAutoSetup ( _
)
C#
public void  TriggerEventAutoSetup(
)
Visual C++
HRESULT TriggerEventAutoSetup(
);

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:AUToset

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerEventBSSID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerEventBSSID Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the ByteStart Sequence ID.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerEventBSSID As String
C#
public string  TriggerEventBSSID { get; set; }
Visual C++
HRESULT get_TriggerEventBSSID(
    BSTR*  val
);
HRESULT put_TriggerEventBSSID(
    BSTR  val
);

Remarks

The TriggerEventBSSID property can be specified in one of the following formats:

  • "All"
  • "n", where n: 1-2047

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:BSS:ID {value}
:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:BSS:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerEventType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerEventType Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerEventType As AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum
C#
public AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum  TriggerEventType { get; set; }
Visual C++
HRESULT get_TriggerEventType(
    AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum*  val
);
HRESULT put_TriggerEventType(
    AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum  val
);

Remarks

The TriggerEventType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeWakeUp - triggers on Wake-Up event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeTSS - triggers on Transmission Start Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeBSS - triggers on Byte Start Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeFES - triggers on Frame End Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeDTS - triggers on Dynamic Trailing Sequence event.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:TYPE {WAK|TSS|BSS|FES|DTS}
:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerFrameCCBase Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerFrameCCBase Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerFrameCCBase As Integer
C#
public int  TriggerFrameCCBase { get; set; }
Visual C++
HRESULT get_TriggerFrameCCBase(
    long*  val
);
HRESULT put_TriggerFrameCCBase(
    long  val
);

Remarks

The TriggerFrameCCBase property can be set to a value from 0 through the Cycle Count Repetition factor minus 1).

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCBase {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCBase?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerFrameCCRepetition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerFrameCCRepetition Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerFrameCCRepetition As String
C#
public string  TriggerFrameCCRepetition { get; set; }
Visual C++
HRESULT get_TriggerFrameCCRepetition(
    BSTR*  val
);
HRESULT put_TriggerFrameCCRepetition(
    BSTR  val
);

Remarks

The TriggerFrameCCRepetition property can be specified in one of the following formats:

  • "All"
  • "n", where n is an integer from 2 to 64

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCRepetition {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCRepetition?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerFrameID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerFrameID Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerFrameID As String
C#
public string  TriggerFrameID { get; set; }
Visual C++
HRESULT get_TriggerFrameID(
    BSTR*  val
);
HRESULT put_TriggerFrameID(
    BSTR  val
);

Remarks

The TriggerFrameID property can be specified in one of the following formats:

  • "All"
  • "n", where n is an integer from 1-2047

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:ID {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerFrameType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerFrameType Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerFrameType As AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum
C#
public AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum  TriggerFrameType { get; set; }
Visual C++
HRESULT get_TriggerFrameType(
    AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum*  val
);
HRESULT put_TriggerFrameType(
    AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum  val
);

Remarks

The TriggerFrameType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNormal - will trigger on only normal (NSTArtup and NNULl and NSYNc) frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeStartup - will trigger on only startup frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNull - will trigger on only null frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeSync - will trigger on only sync frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotStartup - will trigger on frames other than startup frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotNull - will trigger on frames other than null frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotSync - will trigger on frames other than sync frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeAll - will trigger on all FlexRay frame types.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:TYPE {NORM|STAR|NULL|SYNC|NSTA|NNUL|NSYN|ALL}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay..::.TriggerType Property
IAgInfiniiVision2SerialBusFlexRay See Also

Specifies the FlexRay trigger on condition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum
C#
public AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerTypeFrame - triggers on specified frames (without errors).
  • AgInfiniiVisionSerialBusFlexRayTriggerTypeError - triggers on selected active error frames and unknown bus conditions.
  • AgInfiniiVisionSerialBusFlexRayTriggerTypeEvent - triggers on specified FlexRay event/symbol.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger {FRAM|ERR|EVEN}
:SBUS{SerialBus}:FLEXray:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusFlexRay Interface
Agilent.AgInfiniiVision.Interop Namespace


I2S Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.I2S Property
IAgInfiniiVision2SerialBus See Also

Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property I2S As IAgInfiniiVision2SerialBusI2S
C#
public IAgInfiniiVision2SerialBusI2S  I2S { get; }
Visual C++
HRESULT get_I2S(
    IAgInfiniiVision2SerialBusI2S**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Base Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.Base Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the base to use for the I2S decode display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Base As AgInfiniiVisionSerialBusI2SBaseEnum
C#
public AgInfiniiVisionSerialBusI2SBaseEnum  Base { get; set; }
Visual C++
HRESULT get_Base(
    AgInfiniiVisionSerialBusI2SBaseEnum*  val
);
HRESULT put_Base(
    AgInfiniiVisionSerialBusI2SBaseEnum  val
);

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SBaseDecimal - specifies Decimal base
  • AgInfiniiVisionSerialBusI2SBaseHexadecimal - specifies Hexadecimal base

Instrument Command

:SBUS{SerialBus}:I2S:BASE {DEC|HEX}
:SBUS{SerialBus}:I2S:BASE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSlope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.ClockSlope Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies which edge of the I2S serial clock signal clocks in data

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSlope As AgInfiniiVisionSerialBusI2SClockSlopeEnum
C#
public AgInfiniiVisionSerialBusI2SClockSlopeEnum  ClockSlope { get; set; }
Visual C++
HRESULT get_ClockSlope(
    AgInfiniiVisionSerialBusI2SClockSlopeEnum*  val
);
HRESULT put_ClockSlope(
    AgInfiniiVisionSerialBusI2SClockSlopeEnum  val
);

Remarks

The ClockSlope property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SClockSlopeNegative - falling edge
  • AgInfiniiVisionSerialBusI2SClockSlopePositive - rising edge

Instrument Command

:SBUS{SerialBus}:I2S:CLOCk:SLOPe {NEG|POS}
:SBUS{SerialBus}:I2S:CLOCk:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.ClockSource Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:CLOCk {value}
:SBUS{SerialBus}:I2S:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


DataAlignment Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.DataAlignment Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataAlignment As AgInfiniiVisionSerialBusI2SDataAlignmentEnum
C#
public AgInfiniiVisionSerialBusI2SDataAlignmentEnum  DataAlignment { get; set; }
Visual C++
HRESULT get_DataAlignment(
    AgInfiniiVisionSerialBusI2SDataAlignmentEnum*  val
);
HRESULT put_DataAlignment(
    AgInfiniiVisionSerialBusI2SDataAlignmentEnum  val
);

Remarks

The DataAlignment property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SDataAlignmentStandard - Standard alignment
  • AgInfiniiVisionSerialBusI2SDataAlignmentLeftJustified - left justified
  • AgInfiniiVisionSerialBusI2SDataAlignmentRightJustified - right justified

The word select polarity is specified separately with the WordSelectPolarity property.

Instrument Command

:SBUS{SerialBus}:I2S:ALIGnment {I2S|LJ|RJ}
:SBUS{SerialBus}:I2S:ALIGnment?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


DataSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.DataSource Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataSource As String
C#
public string  DataSource { get; set; }
Visual C++
HRESULT get_DataSource(
    BSTR*  val
);
HRESULT put_DataSource(
    BSTR  val
);

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:DATA {value}
:SBUS{SerialBus}:I2S:SOURce:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


GetTriggerRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.GetTriggerRange Method
IAgInfiniiVision2SerialBusI2S See Also

Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetTriggerRange ( _
    ByRef  LowerLimit As Integer  _
    ByRef  UpperLimit As Integer  _
)
C#
public void  GetTriggerRange(
    ref int  LowerLimit,
    ref int  UpperLimit
)
Visual C++
HRESULT GetTriggerRange(
    long*  LowerLimit,
    long*  UpperLimit
);

Parameters

LowerLimit

The lower range boundary.

UpperLimit

The upper range boundary.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

Note that for AgInfiniiVisionSerialBusI2STriggerConditionIncreasing and AgInfiniiVisionSerialBusI2STriggerConditionDecreasing, the LowerLimit and UpperLimit values correspond to the "Armed" and "Trigger" softkeys.

The length of the LowerLimit and UpperLimit values is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the length is equal to the transmitter word size.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


ReceiverWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.ReceiverWidth Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ReceiverWidth As Integer
C#
public int  ReceiverWidth { get; set; }
Visual C++
HRESULT get_ReceiverWidth(
    long*  val
);
HRESULT put_ReceiverWidth(
    long  val
);

Remarks

Valid values are from 4 to 32.

Instrument Command

:SBUS{SerialBus}:I2S:RWIDth {value}
:SBUS{SerialBus}:I2S:RWIDth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


SetTriggerRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.SetTriggerRange Method
IAgInfiniiVision2SerialBusI2S See Also

Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetTriggerRange ( _
    ByVal  LowerLimit As String  _
    ByVal  UpperLimit As String  _
)
C#
public void  SetTriggerRange(
    string  LowerLimit,
    string  UpperLimit
)
Visual C++
HRESULT SetTriggerRange(
    BSTR  LowerLimit,
    BSTR  UpperLimit
);

Parameters

LowerLimit

The lower range boundary.

UpperLimit

The upper range boundary.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

Note that for AgInfiniiVisionSerialBusI2STriggerConditionIncreasing and AgInfiniiVisionSerialBusI2STriggerConditionDecreasing, the LowerLimit and UpperLimit values correspond to the "Armed" and "Trigger" softkeys.

The length of the LowerLimit and UpperLimit values is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the length is equal to the transmitter word size.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


TransmittedWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.TransmittedWidth Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TransmittedWidth As Integer
C#
public int  TransmittedWidth { get; set; }
Visual C++
HRESULT get_TransmittedWidth(
    long*  val
);
HRESULT put_TransmittedWidth(
    long  val
);

Remarks

Valid values are from 4 to 32.

Instrument Command

:SBUS{SerialBus}:I2S:TWIDth {value}
:SBUS{SerialBus}:I2S:TWIDth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerAudioChannel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.TriggerAudioChannel Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the audio channel to trigger on.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerAudioChannel As AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum
C#
public AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum  TriggerAudioChannel { get; set; }
Visual C++
HRESULT get_TriggerAudioChannel(
    AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum*  val
);
HRESULT put_TriggerAudioChannel(
    AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum  val
);

Remarks

The TriggerAudioChannel property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2STriggerAudioChannelLeft - Left channel
  • AgInfiniiVisionSerialBusI2STriggerAudioChannelRight - Right channel
  • AgInfiniiVisionSerialBusI2STriggerAudioChannelEither - Right or Left channel

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:AUDio {LEFT|RIGH|EITH}
:SBUS{SerialBus}:I2S:TRIGger:AUDio?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.TriggerCondition Property
IAgInfiniiVision2SerialBusI2S See Also

Specified the I2S trigger operator.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerCondition As AgInfiniiVisionSerialBusI2STriggerConditionEnum
C#
public AgInfiniiVisionSerialBusI2STriggerConditionEnum  TriggerCondition { get; set; }
Visual C++
HRESULT get_TriggerCondition(
    AgInfiniiVisionSerialBusI2STriggerConditionEnum*  val
);
HRESULT put_TriggerCondition(
    AgInfiniiVisionSerialBusI2STriggerConditionEnum  val
);

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniivisionSerialBusI2STriggerConditionEqual - triggers on the specified audio channel's data word when it equals the specified word
  • AgInfiniivisionSerialBusI2STriggerConditionNotEqual - triggers on any word other than the specified word
  • AgInfiniivisionSerialBusI2STriggerConditionLessThan - triggers when the channel's data word is less than the specified value
  • AgInfiniivisionSerialBusI2STriggerConditionGreaterThan - triggers when the channel's data word is greater than the specified value
  • AgInfiniivisionSerialBusI2STriggerConditionInRange - enter upper and lower values to specify the range in which to trigger
  • AgInfiniivisionSerialBusI2STriggerConditionOutRange - enter upper and lower values to specify range in which trigger will not occur
  • AgInfiniivisionSerialBusI2STriggerConditionIncreasing - triggers when the data value makes a certain increase over time and the specified value is met or exceeded. Use the SetTriggerRange() method to set "Trigger" and "Armed" values. The "Trigger" value is the value that must be met or exceeded to cause the trigger. The "Armed" value is the value the data must go below in order to re-arm the oscilloscope (ready it to trigger again)
  • AgInfiniivisionSerialBusI2STriggerConditionDecreasing - similar to the Increasing trigger condition except the trigger occurs on a certain decrease over time and the "Trigger" data value is less than the "Armed" data value

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger {EQU|NOT|LESS|GRE|INR|OUTR|INCR|DECR}
:SBUS{SerialBus}:I2S:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the I2S trigger data pattern searched for in each I2S message.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData can be specified in one of the following string formats:

  • "n", where n: 32-bit integer in signed decimal
  • "#Bnn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

Set a string bit to "0" or "1" to set the corresponding bit in the data pattern to low or high, respectively.
Set a string bit to "X" to ignore (mask off) that bit in the data pattern.
Use the "$" character to indicate that the value of the corresponding bit will not be changed (the existing bit value is used).

The TriggerPatternData property specifies the I2S trigger data pattern used by the Equal, NotEqual, GreaterThan, and LessThan trigger conditions. If the GreaterThan or LessThan trigger condition is selected, the bits specified to be masked off ("X") will be interpreted as 0's.

The length of the trigger data value is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the data length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the data length is equal to the transmitter word size.

If more bits are sent than the specified trigger data length, the most significant bits will be truncated. If the word size is changed after the string is programmed, the added or deleted bits will be added to or deleted from the least significant bits.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:I2S:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


WordSelectPolarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.WordSelectPolarity Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies the polarity of the word select (WS) signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WordSelectPolarity As AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum
C#
public AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum  WordSelectPolarity { get; set; }
Visual C++
HRESULT get_WordSelectPolarity(
    AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum*  val
);
HRESULT put_WordSelectPolarity(
    AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum  val
);

Remarks

The WordSelectPolarity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SWordSelectPolarityLeft - a word select (WS) state of low indicates left channel data is active on the I2S bus, and a WS state of high indicates right channel data is active on the bus
  • AgInfiniiVisionSerialBusI2SWordSelectPolarityRight - a word select (WS) state of low indicates right channel data is active on the I2S bus, and a WS state of high indicates left channel data is active on the bus

Instrument Command

:SBUS{SerialBus}:I2S:WSLow {LEFT|RIGH}
:SBUS{SerialBus}:I2S:WSLow?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


WordSelectSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S..::.WordSelectSource Property
IAgInfiniiVision2SerialBusI2S See Also

Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property WordSelectSource As String
C#
public string  WordSelectSource { get; set; }
Visual C++
HRESULT get_WordSelectSource(
    BSTR*  val
);
HRESULT put_WordSelectSource(
    BSTR  val
);

Remarks

The WordSelectSource property can be specified in one of the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:WSELect {value}
:SBUS{SerialBus}:I2S:SOURce:WSELect?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusI2S Interface
Agilent.AgInfiniiVision.Interop Namespace


IIC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.IIC Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2IIC interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IIC As IAgInfiniiVision2SerialBusIIC
C#
public IAgInfiniiVision2SerialBusIIC  IIC { get; }
Visual C++
HRESULT get_IIC(
    IAgInfiniiVision2SerialBusIIC**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


AddressWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.AddressWidth Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AddressWidth As AgInfiniiVisionSerialBusIICAddressWidthEnum
C#
public AgInfiniiVisionSerialBusIICAddressWidthEnum  AddressWidth { get; set; }
Visual C++
HRESULT get_AddressWidth(
    AgInfiniiVisionSerialBusIICAddressWidthEnum*  val
);
HRESULT put_AddressWidth(
    AgInfiniiVisionSerialBusIICAddressWidthEnum  val
);

Remarks

The AddressWidth property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICAddressWidthBit7 - Bit 7
  • AgInfiniiVisionSerialBusIICAddressWidthBit8 - Bit 8

Instrument Command

:SBUS{SerialBus}:IIC:ASIZe {BIT7|BIT8}
:SBUS{SerialBus}:IIC:ASIZe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.ClockSource Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the source for the IIC serial clock (SCL).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:IIC:SOURce:CLOCk {value}
:SBUS{SerialBus}:IIC:SOURce:CLOCk?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


DataSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.DataSource Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the source for IIC serial data (SDA).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataSource As String
C#
public string  DataSource { get; set; }
Visual C++
HRESULT get_DataSource(
    BSTR*  val
);
HRESULT put_DataSource(
    BSTR  val
);

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:IIC:SOURce:DATA {value}
:SBUS{SerialBus}:IIC:SOURce:DATA?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.TriggerCondition Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerCondition As AgInfiniiVisionSerialBusIICTriggerConditionEnum
C#
public AgInfiniiVisionSerialBusIICTriggerConditionEnum  TriggerCondition { get; set; }
Visual C++
HRESULT get_TriggerCondition(
    AgInfiniiVisionSerialBusIICTriggerConditionEnum*  val
);
HRESULT put_TriggerCondition(
    AgInfiniiVisionSerialBusIICTriggerConditionEnum  val
);

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICTriggerConditionEqual - Equal
  • AgInfiniiVisionSerialBusIICTriggerConditionNotEqual - Not Equal
  • AgInfiniiVisionSerialBusIICTriggerConditionGreaterThan - Greater Than
  • AgInfiniiVisionSerialBusIICTriggerConditionLessThan - Less Than

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:QUALifier {EQU|NOT|LESS|GRE}
:SBUS{SerialBus}:IIC:TRIGger:QUALifier?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternAddress Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.TriggerPatternAddress Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternAddress As String
C#
public string  TriggerPatternAddress { get; set; }
Visual C++
HRESULT get_TriggerPatternAddress(
    BSTR*  val
);
HRESULT put_TriggerPatternAddress(
    BSTR  val
);

Remarks

The TriggerPatternAddress can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:ADDRess {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:ADDRess?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATA {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATA?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.TriggerPatternData2 Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData2 As String
C#
public string  TriggerPatternData2 { get; set; }
Visual C++
HRESULT get_TriggerPatternData2(
    BSTR*  val
);
HRESULT put_TriggerPatternData2(
    BSTR  val
);

Remarks

The TriggerPatternData2 can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATa2 {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATa2?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC..::.TriggerType Property
IAgInfiniiVision2SerialBusIIC See Also

Specifies the IIC trigger type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusIICTriggerTypeEnum
C#
public AgInfiniiVisionSerialBusIICTriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusIICTriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusIICTriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICTriggerTypeStart - Start condition
  • AgInfiniiVisionSerialBusIICTriggerTypeStop - Stop condition
  • AgInfiniiVisionSerialBusIICTriggerTypeRead7 - 7-bit address frame containing (Start:Address7:Read:Ack:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeR7Data2 - 7-bit address frame containing (Start:Address7:Read:Ack:Data:Ack:Data2)
  • AgInfiniiVisionSerialBusIICTriggerTypeReadEprom - EEPROM data read
  • AgInfiniiVisionSerialBusIICTriggerTypeWrite7 - 7-bit address frame containing (Start:Address7:Write:Ack:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeW7Data2 - 7-bit address frame containing (Start:Address7:Write:Ack:Data:Ack:Data2)
  • AgInfiniiVisionSerialBusIICTriggerTypeWrite10 - 10-bit address frame containing (Start:Address byte1:Write:Ack:Address byte 2:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeMissingAcknowledge - Missing acknowledge
  • AgInfiniiVisionSerialBusIICTriggerTypeNoAcknowledge - Address with no acknowledge
  • AgInfiniiVisionSerialBusIICTriggerTypeRestart - Another start condition occurs before a stop condition

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:TYPE {STAR|STOP|READ7|R7D2|READE|WRIT7|W7D2|WRIT10|NACK|ANAC|REST|ADDR|DNAC}
:SBUS{SerialBus}:IIC:TRIGger:TYPE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusIIC Interface
Agilent.AgInfiniiVision.Interop Namespace


LIN Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.LIN Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2LIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property LIN As IAgInfiniiVision2SerialBusLIN
C#
public IAgInfiniiVision2SerialBusLIN  LIN { get; }
Visual C++
HRESULT get_LIN(
    IAgInfiniiVision2SerialBusLIN**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


BaudRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.BaudRate Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BaudRate As Integer
C#
public int  BaudRate { get; set; }
Visual C++
HRESULT get_BaudRate(
    long*  val
);
HRESULT put_BaudRate(
    long  val
);

Remarks

Valid values are from 2400 to 625000 in 100 b/s increments

Instrument Command

:SBUS{SerialBus}:LIN:SIGNal:BAUDrate {value}
:SBUS{SerialBus}:LIN:SIGNal:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


ParityEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.ParityEnabled Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ParityEnabled As Boolean
C#
public bool  ParityEnabled { get; set; }
Visual C++
HRESULT get_ParityEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_ParityEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SBUS{SerialBus}:LIN:PARity {ON|OFF}
:SBUS{SerialBus}:LIN:PARity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


SamplePoint Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.SamplePoint Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SamplePoint As Double
C#
public double  SamplePoint { get; set; }
Visual C++
HRESULT get_SamplePoint(
    double*  val
);
HRESULT put_SamplePoint(
    double  val
);

Remarks

Valid values are: 60, 62.5, 68, 70, 75, 80, 87.5

The sample point values are not limited by the baud rate.

Instrument Command

:SBUS{SerialBus}:LIN:SAMPlepoint {value}
:SBUS{SerialBus}:LIN:SAMPlepoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.Source Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the source for the CAN signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The Source property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:LIN:SOURce {value}
:SBUS{SerialBus}:LIN:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


Standard Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.Standard Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Standard As AgInfiniiVisionSerialBusLINStandardEnum
C#
public AgInfiniiVisionSerialBusLINStandardEnum  Standard { get; set; }
Visual C++
HRESULT get_Standard(
    AgInfiniiVisionSerialBusLINStandardEnum*  val
);
HRESULT put_Standard(
    AgInfiniiVisionSerialBusLINStandardEnum  val
);

Remarks

The Standard property can be set to one of the following values:

  • AgInfiniiVisionSerialBusLINStandardLIN13 - to specify the LIN1.3 standard for triggering and decoding
  • AgInfiniiVisionSerialBusLINStandardLIN20 - to specify the LIN2.0 standard for triggering and decoding

Instrument Command

:SBUS{SerialBus}:LIN:STANdard {LIN13|LIN20}
:SBUS{SerialBus}:LIN:STANdard?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


SyncBreakLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.SyncBreakLength Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SyncBreakLength As Integer
C#
public int  SyncBreakLength { get; set; }
Visual C++
HRESULT get_SyncBreakLength(
    long*  val
);
HRESULT put_SyncBreakLength(
    long  val
);

Remarks

Valid values are: 11, 12, 13

Instrument Command

:SBUS{SerialBus}:LIN:SYNCbreak {value}
:SBUS{SerialBus}:LIN:SYNCbreak?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.TriggerCondition Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the LIN trigger condition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerCondition As AgInfiniiVisionSerialBusLINTriggerConditionEnum
C#
public AgInfiniiVisionSerialBusLINTriggerConditionEnum  TriggerCondition { get; set; }
Visual C++
HRESULT get_TriggerCondition(
    AgInfiniiVisionSerialBusLINTriggerConditionEnum*  val
);
HRESULT put_TriggerCondition(
    AgInfiniiVisionSerialBusLINTriggerConditionEnum  val
);

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusLINTriggerConditionSyncBreak - Sync Break
  • AgInfiniiVisionSerialBusLINTriggerConditionID - Frame ID
  • AgInfiniiVisionSerialBusLINTriggerConditionData - Frame ID and Data

Use the TriggerID property to specify the frame ID.
Use the TriggerPatternDataLength and TriggerPatternData properties to specify the data string length and value.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger {SYNC|ID|DATA|PAR|CSUM|FRAM|FSIG}
:SBUS{SerialBus}:LIN:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.TriggerID Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerID As String
C#
public string  TriggerID { get; set; }
Visual C++
HRESULT get_TriggerID(
    BSTR*  val
);
HRESULT put_TriggerID(
    BSTR  val
);

Remarks

The TriggerID property can be specified in one of the following string formats:

  • "n", where n: 7-bit integer in decimal from 0-63
  • "#Bnn..n", where n: {0 | 1}
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 to 0x3f

Setting the ID to a value of "-1" results in "0xXX" which is equivalent to all IDs.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:ID {value}
:SBUS{SerialBus}:LIN:TRIGger:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusLIN See Also

Specifies the LIN trigger data pattern searched for in each LIN data field.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData property can be specified in one of the following string formats:

  • "n", where n: 32-bit integer in unsigned decimal
  • "#Bnn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

Set a string bit to "0" or "1" to set the corresponding bit in the data pattern to low or high, respectively.
Set a string bit to "X" to ignore (mask off) that bit in the data pattern.
Use the "$" character to indicate that the value of the corresponding bit will not be changed (the existing bit value is used).

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN..::.TriggerPatternDataLength Property
IAgInfiniiVision2SerialBusLIN See Also

the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternDataLength As Integer
C#
public int  TriggerPatternDataLength { get; set; }
Visual C++
HRESULT get_TriggerPatternDataLength(
    long*  val
);
HRESULT put_TriggerPatternDataLength(
    long  val
);

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA:LENGth {value}
:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusLIN Interface
Agilent.AgInfiniiVision.Interop Namespace


M1553 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.M1553 Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2M1553 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property M1553 As IAgInfiniiVision2SerialBusM1553
C#
public IAgInfiniiVision2SerialBusM1553  M1553 { get; }
Visual C++
HRESULT get_M1553(
    IAgInfiniiVision2SerialBusM1553**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.AutoSetup Method
IAgInfiniiVision2SerialBusM1553 See Also

This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Remarks

Its also sets the upper/lower probe attenuation to 10:1, turns on serial decode, turns off trigger noise reject and sets the trigger mode to MIL-STD 1553.

Instrument Command

:SBUS{SerialBus}:M1553:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


Base Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.Base Property
IAgInfiniiVision2SerialBusM1553 See Also

Specifies the base to use for the MIL-STD 1553 decode display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Base As AgInfiniiVisionSerialBusM1553BaseEnum
C#
public AgInfiniiVisionSerialBusM1553BaseEnum  Base { get; set; }
Visual C++
HRESULT get_Base(
    AgInfiniiVisionSerialBusM1553BaseEnum*  val
);
HRESULT put_Base(
    AgInfiniiVisionSerialBusM1553BaseEnum  val
);

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusM1553BaseBinary - specifies the binary base
  • AgInfiniiVisionSerialBusM1553BaseHexadecimal - specifies the hexadecimal base

Instrument Command

:SBUS{SerialBus}:M1553:BASe {BIN|HEX}
:SBUS{SerialBus}:M1553:BASe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.Source Property
IAgInfiniiVision2SerialBusM1553 See Also

Specifies which signal is used as the source for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The Source property can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels.

Instrument Command

:SBUS{SerialBus}:M1553:SOURce {value}
:SBUS{SerialBus}:M1553:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.TriggerPatternData Property
IAgInfiniiVision2SerialBusM1553 See Also

Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternData As String
C#
public string  TriggerPatternData { get; set; }
Visual C++
HRESULT get_TriggerPatternData(
    BSTR*  val
);
HRESULT put_TriggerPatternData(
    BSTR  val
);

Remarks

The TriggerPatternData property can be specified in the following format:

  • "nn...n", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:M1553:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerRTA Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.TriggerRTA Property
IAgInfiniiVision2SerialBusM1553 See Also

Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerRTA As String
C#
public string  TriggerRTA { get; set; }
Visual C++
HRESULT get_TriggerRTA(
    BSTR*  val
);
HRESULT put_TriggerRTA(
    BSTR  val
);

Remarks

The TriggerRTA property can be specified in one of the following formats:

  • "n", where n is an integer from 0-31
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:RTA {value}
:SBUS{SerialBus}:M1553:TRIGger:RTA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.TriggerThresholdHigh Property
IAgInfiniiVision2SerialBusM1553 See Also

The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerThresholdHigh As Double
C#
public double  TriggerThresholdHigh { get; set; }
Visual C++
HRESULT get_TriggerThresholdHigh(
    double*  val
);
HRESULT put_TriggerThresholdHigh(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.TriggerThresholdLow Property
IAgInfiniiVision2SerialBusM1553 See Also

The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerThresholdLow As Double
C#
public double  TriggerThresholdLow { get; set; }
Visual C++
HRESULT get_TriggerThresholdLow(
    double*  val
);
HRESULT put_TriggerThresholdLow(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553..::.TriggerType Property
IAgInfiniiVision2SerialBusM1553 See Also

Specifies the type of MIL-STD 1553 trigger to be used.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusM1553TriggerTypeEnum
C#
public AgInfiniiVisionSerialBusM1553TriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusM1553TriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusM1553TriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusM1553TriggerTypeDataStart - (Data Word Start) triggers on the start of a Data word (at the end of a valid Data Sync pulse).
  • AgInfiniiVisionSerialBusM1553TriggerTypeDataStop - (Data Word Stop) triggers on the end of a Data word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeCommandStart - (Command/Status Word Start) triggers on the start of Comamnd/Status word (at the end of a valid C/S Sync pulse).
  • AgInfiniiVisionSerialBusM1553TriggerTypeCommandStop - (Command/Status Word Stop) triggers on the end of a Command/Status word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeRTA - (Remote Terminal Address) triggers if the RTA of the Command/Status word matches the specified value. The value is specified in hex.
  • AgInfiniiVisionSerialBusM1553TriggerTypeRTA11 - (RTA + 11 Bits) triggers if the RTA and the remaining 11 bits match the specified criteria. The RTA can be specifed as a hex value, and the remaining 11 bits can be specifed as a 1, 0, or X (don't care).
  • AgInfiniiVisionSerialBusM1553TriggerTypeParityError - (Parity Error) triggers if the (odd) parity bit is incorrect for the data in the word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeManchesterError - (Manchester Error) triggers if a Manchester encoding error is detected.
  • AgInfiniiVisionSerialBusM1553TriggerTypeSyncError - (Sync Error) triggers if an invalid Sync pulse is found.

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:TYPE {DSTA|DSTO|CSTA|CSTO|RTA|RTA11|PERR|MERR|SERR}
:SBUS{SerialBus}:M1553:TRIGger:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusM1553 Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.Mode Property
IAgInfiniiVision2SerialBus See Also

Determines the decode mode for the serial bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSerialBusModeEnum
C#
public AgInfiniiVisionSerialBusModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSerialBusModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSerialBusModeEnum  val
);

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSerialBusModeCAN - CAN mode
  • AgInfiniiVisionSerialBusModeI2S - I2S mode
  • AgInfiniiVisionSerialBusModeIIC - IIC mode
  • AgInfiniiVisionSerialBusModeLIN - LIN mode
  • AgInfiniiVisionSerialBusModeSPI - SPI mode
  • AgInfiniiVisionSerialBusModeUART - UART mode
  • AgInfiniiVisionSerialBusModeARINC429 - ARINC 429 mode
  • AgInfiniiVisionSerialBusModeM1553 - MIL-STD 1553 mode
  • AgInfiniiVisionSerialBusModeFlexRay - FlexRay mode
  • AgInfiniiVisionSerialBusModeSENT - SENT mode

In addition to the above values, the current serial bus decode mode setting can also return the following value:
  • AgInfiniiVisionSerialBusModeNONE

This property is only valid when a serial decode option has been licensed.

Instrument Command

:SBUS{SerialBus}:MODE {CAN|I2S|IIC|LIN|SPI|UART|NONE|A429|M1553|FLEX|USB|SENT}
:SBUS{SerialBus}:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


SPI Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.SPI Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2SPI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SPI As IAgInfiniiVision2SerialBusSPI
C#
public IAgInfiniiVision2SerialBusSPI  SPI { get; }
Visual C++
HRESULT get_SPI(
    IAgInfiniiVision2SerialBusSPI**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


BitOrder Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.BitOrder Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BitOrder As AgInfiniiVisionSerialBusSPIBitOrderEnum
C#
public AgInfiniiVisionSerialBusSPIBitOrderEnum  BitOrder { get; set; }
Visual C++
HRESULT get_BitOrder(
    AgInfiniiVisionSerialBusSPIBitOrderEnum*  val
);
HRESULT put_BitOrder(
    AgInfiniiVisionSerialBusSPIBitOrderEnum  val
);

Remarks

The BitOrder property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPIBitOrderLSBF - Least Significant Bit First
  • AgInfiniiVisionSerialBusSPIBitOrderMSBF - Most Significant Bit First

Instrument Command

:SBUS{SerialBus}:SPI:BITorder {LSBF|MSBF}
:SBUS{SerialBus}:SPI:BITorder?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSlope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.ClockSlope Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSlope As AgInfiniiVisionSerialBusSPIClockSlopeEnum
C#
public AgInfiniiVisionSerialBusSPIClockSlopeEnum  ClockSlope { get; set; }
Visual C++
HRESULT get_ClockSlope(
    AgInfiniiVisionSerialBusSPIClockSlopeEnum*  val
);
HRESULT put_ClockSlope(
    AgInfiniiVisionSerialBusSPIClockSlopeEnum  val
);

Remarks

The ClockSource property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPIClockSlopeNegative - falling edge
  • AgInfiniiVisionSerialBusSPIClockSlopePositive - rising edge

Instrument Command

:SBUS{SerialBus}:SPI:CLOCk:SLOPe {NEG|POS}
:SBUS{SerialBus}:SPI:CLOCk:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.ClockSource Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the source for the SPI serial clock.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:CLOCk {value}
:SBUS{SerialBus}:SPI:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockTimeout Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.ClockTimeout Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockTimeout As Double
C#
public double  ClockTimeout { get; set; }
Visual C++
HRESULT get_ClockTimeout(
    double*  val
);
HRESULT put_ClockTimeout(
    double  val
);

Instrument Command

:SBUS{SerialBus}:SPI:CLOCk:TIMeout {value}
:SBUS{SerialBus}:SPI:CLOCk:TIMeout?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


FrameSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.FrameSource Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property FrameSource As String
C#
public string  FrameSource { get; set; }
Visual C++
HRESULT get_FrameSource(
    BSTR*  val
);
HRESULT put_FrameSource(
    BSTR  val
);

Remarks

The FrameSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:FRAMe {value}
:SBUS{SerialBus}:SPI:SOURce:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


Framing Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.Framing Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Framing As AgInfiniiVisionSerialBusSPIFramingEnum
C#
public AgInfiniiVisionSerialBusSPIFramingEnum  Framing { get; set; }
Visual C++
HRESULT get_Framing(
    AgInfiniiVisionSerialBusSPIFramingEnum*  val
);
HRESULT put_Framing(
    AgInfiniiVisionSerialBusSPIFramingEnum  val
);

Instrument Command

:SBUS{SerialBus}:SPI:FRAMing {CHIP|NCH|TIM}
:SBUS{SerialBus}:SPI:FRAMing?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


MISOSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.MISOSource Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the source for the SPI serial MISO data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MISOSource As String
C#
public string  MISOSource { get; set; }
Visual C++
HRESULT get_MISOSource(
    BSTR*  val
);
HRESULT put_MISOSource(
    BSTR  val
);

Remarks

The MISOSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:MISO {value}
:SBUS{SerialBus}:SPI:SOURce:MISO?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


MOSISource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.MOSISource Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the source for the SPI serial MOSI data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MOSISource As String
C#
public string  MOSISource { get; set; }
Visual C++
HRESULT get_MOSISource(
    BSTR*  val
);
HRESULT put_MOSISource(
    BSTR  val
);

Remarks

The MOSISource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:MOSI {value}
:SBUS{SerialBus}:SPI:SOURce:MOSI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternMISOData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.TriggerPatternMISOData Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternMISOData As String
C#
public string  TriggerPatternMISOData { get; set; }
Visual C++
HRESULT get_TriggerPatternMISOData(
    BSTR*  val
);
HRESULT put_TriggerPatternMISOData(
    BSTR  val
);

Remarks

The TriggerPatternMISOData can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

The TriggerPatternMISOWidth property should be set before the TriggerPatternMISOData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:DATA "{value}"
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternMISOWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.TriggerPatternMISOWidth Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternMISOWidth As Integer
C#
public int  TriggerPatternMISOWidth { get; set; }
Visual C++
HRESULT get_TriggerPatternMISOWidth(
    long*  val
);
HRESULT put_TriggerPatternMISOWidth(
    long  val
);

Remarks

Valid values are from 4 to 64.

The TriggerPatternMISOWidth property should be set before the TriggerPatternMISOData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:WIDTh {value}
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternMOSIData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.TriggerPatternMOSIData Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternMOSIData As String
C#
public string  TriggerPatternMOSIData { get; set; }
Visual C++
HRESULT get_TriggerPatternMOSIData(
    BSTR*  val
);
HRESULT put_TriggerPatternMOSIData(
    BSTR  val
);

Remarks

The TriggerPatternMOSIData can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

The TriggerPatternMOSIWidth property should be set before the TriggerPatternMOSIData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:DATA "{value}"
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternMOSIWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.TriggerPatternMOSIWidth Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternMOSIWidth As Integer
C#
public int  TriggerPatternMOSIWidth { get; set; }
Visual C++
HRESULT get_TriggerPatternMOSIWidth(
    long*  val
);
HRESULT put_TriggerPatternMOSIWidth(
    long  val
);

Remarks

Valid values are from 4 to 64.

The TriggerPatternMOSIWidth property should be set before the TriggerPatternMOSIData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:WIDTh {value}
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.TriggerType Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies whether the SPI trigger will be on the MOSI data or the MISO data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusSPITriggerTypeEnum
C#
public AgInfiniiVisionSerialBusSPITriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusSPITriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusSPITriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPITriggerTypeMOSI - MOSI
  • AgInfiniiVisionSerialBusSPITriggerTypeMISO - MISO

When triggering on MOSI data , the data value is specified by the TriggerPatternMOSIData and TriggerPatternMOSIWidth properties.

When triggering on MISO data , the data value is specified by the TriggerPatternMISOData and TriggerPatternMISOWidth properties.

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:TYPE {MOSI|MISO}
:SBUS{SerialBus}:SPI:TRIGger:TYPE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI..::.Width Property
IAgInfiniiVision2SerialBusSPI See Also

Specifies the number of bits in a word of data for SPI.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Width As Integer
C#
public int  Width { get; set; }
Visual C++
HRESULT get_Width(
    long*  val
);
HRESULT put_Width(
    long  val
);

Remarks

Valid values are fomr 4-16

Instrument Command

:SBUS{SerialBus}:SPI:WIDTh {value}
:SBUS{SerialBus}:SPI:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVision2SerialBusSPI Interface
Agilent.AgInfiniiVision.Interop Namespace


UART Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus..::.UART Property
IAgInfiniiVision2SerialBus See Also

Pointer to the IAgInfiniiVision2SerialBus2UART interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property UART As IAgInfiniiVision2SerialBusUART
C#
public IAgInfiniiVision2SerialBusUART  UART { get; }
Visual C++
HRESULT get_UART(
    IAgInfiniiVision2SerialBusUART**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBus Interface
Agilent.AgInfiniiVision.Interop Namespace


Base Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.Base Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the base to use for the UART decode and Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Base As AgInfiniiVisionSerialBusUARTBaseEnum
C#
public AgInfiniiVisionSerialBusUARTBaseEnum  Base { get; set; }
Visual C++
HRESULT get_Base(
    AgInfiniiVisionSerialBusUARTBaseEnum*  val
);
HRESULT put_Base(
    AgInfiniiVisionSerialBusUARTBaseEnum  val
);

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTBaseASCII - ASCII
  • AgInfiniiVisionSerialBusUARTBaseBinary - Binary
  • AgInfiniiVisionSerialBusUARTBaseHexadecimal - Hexadecimal

Instrument Command

:SBUS{SerialBus}:UART:BASE {ASC|BIN|HEX}
:SBUS{SerialBus}:UART:BASE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


BaudRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.BaudRate Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BaudRate As Integer
C#
public int  BaudRate { get; set; }
Visual C++
HRESULT get_BaudRate(
    long*  val
);
HRESULT put_BaudRate(
    long  val
);

Remarks

If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Valid values are from 1200 to 8000000 in 100b/s increments.

If the baud rate you select does not match the system baud rate, false triggers may occur.

Instrument Command

:SBUS{SerialBus}:UART:BAUDrate {value}
:SBUS{SerialBus}:UART:BAUDrate?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


BitOrder Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.BitOrder Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BitOrder As AgInfiniiVisionSerialBusUARTBitOrderEnum
C#
public AgInfiniiVisionSerialBusUARTBitOrderEnum  BitOrder { get; set; }
Visual C++
HRESULT get_BitOrder(
    AgInfiniiVisionSerialBusUARTBitOrderEnum*  val
);
HRESULT put_BitOrder(
    AgInfiniiVisionSerialBusUARTBitOrderEnum  val
);

Remarks

The BitOrder property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTBitOrderMSBFirst - MSB First
  • AgInfiniiVisionSerialBusUARTBitOrderLSBFirst - LSB First

AgInfiniiVisionSerialBusUARTBitOrderLSBFirst sets the least significant bit of each message "byte" as transmitted first. AgInfiniiVisionSerialBusUARTBitOrderMSBFirst sets the most significant bit as transmitted first.

Instrument Command

:SBUS{SerialBus}:UART:BITorder {LSBF|MSBF}
:SBUS{SerialBus}:UART:BITorder?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


ErrorCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.ErrorCount Property
IAgInfiniiVision2SerialBusUART See Also

Read Only - Gets the UART error frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ErrorCount As Integer
C#
public int  ErrorCount { get; }
Visual C++
HRESULT get_ErrorCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:UART:COUNt:ERRor?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Framing Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.Framing Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Framing As String
C#
public string  Framing { get; set; }
Visual C++
HRESULT get_Framing(
    BSTR*  val
);
HRESULT put_Framing(
    BSTR  val
);

Remarks

The Framing property can be specified in one of the following formats:

  • "OFF"
  • "n", where n: 8-bit integer in decimal from 0 - 255
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 - 0xff
  • "#Bnn..n", where n: {0 | 1}

Instrument Command

:SBUS{SerialBus}:UART:FRAMing {value}
:SBUS{SerialBus}:UART:FRAMing?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Parity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.Parity Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Parity As AgInfiniiVisionSerialBusUARTParityEnum
C#
public AgInfiniiVisionSerialBusUARTParityEnum  Parity { get; set; }
Visual C++
HRESULT get_Parity(
    AgInfiniiVisionSerialBusUARTParityEnum*  val
);
HRESULT put_Parity(
    AgInfiniiVisionSerialBusUARTParityEnum  val
);

Remarks

The Parity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTParityEven - Even parity
  • AgInfiniiVisionSerialBusUARTParityOdd - Odd parity
  • AgInfiniiVisionSerialBusUARTParityNone - No parity

Instrument Command

:SBUS{SerialBus}:UART:PARity {EVEN|ODD|NONE}
:SBUS{SerialBus}:UART:PARity?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.Polarity Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionSerialBusUARTPolarityEnum
C#
public AgInfiniiVisionSerialBusUARTPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionSerialBusUARTPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionSerialBusUARTPolarityEnum  val
);

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTPolarityHigh - High polarity
  • AgInfiniiVisionSerialBusUARTPolarityLow - Low polarity

Instrument Command

:SBUS{SerialBus}:UART:POLarity {HIGH|LOW}
:SBUS{SerialBus}:UART:POLarity?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


ResetCounters Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.ResetCounters Method
IAgInfiniiVision2SerialBusUART See Also

This method resets the UART frame counters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ResetCounters ( _
)
C#
public void  ResetCounters(
)
Visual C++
HRESULT ResetCounters(
);

Instrument Command

:SBUS{SerialBus}:UART:COUNt:RESet

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


RxFrameCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.RxFrameCount Property
IAgInfiniiVision2SerialBusUART See Also

Read Only - Gets the UART Rx frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property RxFrameCount As Integer
C#
public int  RxFrameCount { get; }
Visual C++
HRESULT get_RxFrameCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:UART:COUNt:RXFRames?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


RxSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.RxSource Property
IAgInfiniiVision2SerialBusUART See Also

Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RxSource As String
C#
public string  RxSource { get; set; }
Visual C++
HRESULT get_RxSource(
    BSTR*  val
);
HRESULT put_RxSource(
    BSTR  val
);

Remarks

The RxSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:UART:SOURce:RX {value}
:SBUS{SerialBus}:UART:SOURce:RX?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerBase Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerBase Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the front panel UART/RS232 trigger setup data selection.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerBase As AgInfiniiVisionSerialBusUARTTriggerBaseEnum
C#
public AgInfiniiVisionSerialBusUARTTriggerBaseEnum  TriggerBase { get; set; }
Visual C++
HRESULT get_TriggerBase(
    AgInfiniiVisionSerialBusUARTTriggerBaseEnum*  val
);
HRESULT put_TriggerBase(
    AgInfiniiVisionSerialBusUARTTriggerBaseEnum  val
);

Remarks

The TriggerBase property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerBaseASCII - front panel data selection is from ASCII values
  • AgInfiniiVisionSerialBusUARTTriggerBaseHexadecimal - front panel data selection is from hexadecimal values

The TriggerBase property does not affect the TriggerData property which can always setdata values using ASCII or hexadecimal values.

The TriggerBase property is independent of the Base property which affects decode and Lister only.

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:BASE {ASC|HEX}
:SBUS{SerialBus}:UART:TRIGger:BASE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerBurst Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerBurst Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerBurst As String
C#
public string  TriggerBurst { get; set; }
Visual C++
HRESULT get_TriggerBurst(
    BSTR*  val
);
HRESULT put_TriggerBurst(
    BSTR  val
);

Remarks

The TriggerBurst property can be specified in one of the following formats:

  • "Off"
  • "n", where n is integer from 1 to 4096

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:BURSt {value}
:SBUS{SerialBus}:UART:TRIGger:BURSt?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerCondition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerCondition Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerCondition As AgInfiniiVisionSerialBusUARTTriggerConditionEnum
C#
public AgInfiniiVisionSerialBusUARTTriggerConditionEnum  TriggerCondition { get; set; }
Visual C++
HRESULT get_TriggerCondition(
    AgInfiniiVisionSerialBusUARTTriggerConditionEnum*  val
);
HRESULT put_TriggerCondition(
    AgInfiniiVisionSerialBusUARTTriggerConditionEnum  val
);

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerConditionEqual - Equal
  • AgInfiniiVisionSerialBusUARTTriggerConditionNotEqual - Not Equal
  • AgInfiniiVisionSerialBusUARTTriggerConditionGreaterThan - Greater Than
  • AgInfiniiVisionSerialBusUARTTriggerConditionLessThan - Less Than

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:QUALifier {EQU|NOT|GRE|LESS}
:SBUS{SerialBus}:UART:TRIGger:QUALifier?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerData Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerData As String
C#
public string  TriggerData { get; set; }
Visual C++
HRESULT get_TriggerData(
    BSTR*  val
);
HRESULT put_TriggerData(
    BSTR  val
);

Remarks

The TriggerData property can be specified in one of the following string formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F} from 0x00 to 0xff
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 to 0xff
  • "#Bnn..n", where n: {0 | 1}
  • any of the 128 valid 7-bit ASCII characters (or standard abbreviations)

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:DATA {value}
:SBUS{SerialBus}:UART:TRIGger:DATA?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerIdleTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerIdleTime Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerIdleTime As Double
C#
public double  TriggerIdleTime { get; set; }
Visual C++
HRESULT get_TriggerIdleTime(
    double*  val
);
HRESULT put_TriggerIdleTime(
    double  val
);

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:IDLE {value}
:SBUS{SerialBus}:UART:TRIGger:IDLE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TriggerType Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the UART Trigger Type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerType As AgInfiniiVisionSerialBusUARTTriggerTypeEnum
C#
public AgInfiniiVisionSerialBusUARTTriggerTypeEnum  TriggerType { get; set; }
Visual C++
HRESULT get_TriggerType(
    AgInfiniiVisionSerialBusUARTTriggerTypeEnum*  val
);
HRESULT put_TriggerType(
    AgInfiniiVisionSerialBusUARTTriggerTypeEnum  val
);

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerTypeRStart - RStart
  • AgInfiniiVisionSerialBusUARTTriggerTypeRStop - RStop
  • AgInfiniiVisionSerialBusUARTTriggerTypeRData - RData
  • AgInfiniiVisionSerialBusUARTTriggerTypeRD1 - RD1
  • AgInfiniiVisionSerialBusUARTTriggerTypeRD0 - RD0
  • AgInfiniiVisionSerialBusUARTTriggerTypeRDX - RDX
  • AgInfiniiVisionSerialBusUARTTriggerTypeParityError - Parity Error
  • AgInfiniiVisionSerialBusUARTTriggerTypeTStart - TStart
  • AgInfiniiVisionSerialBusUARTTriggerTypeTStop - TStop
  • AgInfiniiVisionSerialBusUARTTriggerTypeTData - TData
  • AgInfiniiVisionSerialBusUARTTriggerTypeTD1 - TD1
  • AgInfiniiVisionSerialBusUARTTriggerTypeTD0 - TD0
  • AgInfiniiVisionSerialBusUARTTriggerTypeTDX - TDX

When one of the RD or TD types is selected, the TriggerData and TriggerCondition properties are used to specify the data value and comparison operator.

The RD1, RD0, RDX, TD1, TD0, and TDX types (for triggering on data and alert bit values) are only valid when a 9-bit width has been selected.

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:TYPE {RSTA|RSTO|RDAT|RD1|RD0|RDX|PAR|TSTA|TSTO|TDAT|TD1|TD0|TDX}
:SBUS{SerialBus}:UART:TRIGger:TYPE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TxFrameCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TxFrameCount Property
IAgInfiniiVision2SerialBusUART See Also

Read Only - Gets the UART Tx frame count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TxFrameCount As Integer
C#
public int  TxFrameCount { get; }
Visual C++
HRESULT get_TxFrameCount(
    long*  val
);

Instrument Command

:SBUS{SerialBus}:UART:COUNt:TXFRames?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


TxSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.TxSource Property
IAgInfiniiVision2SerialBusUART See Also

Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TxSource As String
C#
public string  TxSource { get; set; }
Visual C++
HRESULT get_TxSource(
    BSTR*  val
);
HRESULT put_TxSource(
    BSTR  val
);

Remarks

The TxSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:UART:SOURce:TX {value}
:SBUS{SerialBus}:UART:SOURce:TX?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART..::.Width Property
IAgInfiniiVision2SerialBusUART See Also

Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Width As Integer
C#
public int  Width { get; set; }
Visual C++
HRESULT get_Width(
    long*  val
);
HRESULT put_Width(
    long  val
);

Remarks

Valid values are from 5 to 9

Instrument Command

:SBUS{SerialBus}:UART:WIDTh {value}
:SBUS{SerialBus}:UART:WIDTh?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBusUART Interface
Agilent.AgInfiniiVision.Interop Namespace


Lister Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBuses..::.Lister Property
IAgInfiniiVision2SerialBuses See Also

Pointer to the IAgInfiniiVision2SerialBusesLister interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Lister As IAgInfiniiVision2SerialBusesLister
C#
public IAgInfiniiVision2SerialBusesLister  Lister { get; }
Visual C++
HRESULT get_Lister(
    IAgInfiniiVision2SerialBusesLister**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBuses Interface
Agilent.AgInfiniiVision.Interop Namespace


Display Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusesLister..::.Display Property
IAgInfiniiVision2SerialBusesLister See Also

The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Display As AgInfiniiVisionSerialBusListerDisplayEnum
C#
public AgInfiniiVisionSerialBusListerDisplayEnum  Display { get; set; }
Visual C++
HRESULT get_Display(
    AgInfiniiVisionSerialBusListerDisplayEnum*  val
);
HRESULT put_Display(
    AgInfiniiVisionSerialBusListerDisplayEnum  val
);

Remarks

The Display property can be set to one of the following values:

  • AgInfiniiVisionSerialBusListerDisplayOff - for turning the Lister off
  • AgInfiniiVisionSerialBusListerDisplaySerialBus1 - to display SerialBus1 in the Lister
  • AgInfiniiVisionSerialBusListerDisplaySerialBus2 - to display SerialBus2 in the Lister
  • AgInfiniiVisionSerialBusListerDisplayAll - to display information for all serial buses. The decode information for different buses is interleaved in time in this case

Serial bus decode must be on (using the IAgInfiniiVisionSerialBus.Enabled property) before it can be displayed in the Lister.

Instrument Command

:LISTer:DISPlay {OFF|SBUS1|SBUS2|ALL}
:LISTer:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusesLister Interface
Agilent.AgInfiniiVision.Interop Namespace


GetData Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusesLister..::.GetData Method
IAgInfiniiVision2SerialBusesLister See Also

Gets the lister data as a string.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetData ( _
    ByRef  Data As String  _
)
C#
public void  GetData(
    ref string  Data
)
Visual C++
HRESULT GetData(
    BSTR*  Data
);

Parameters

Data

The lister data in a string format.

Instrument Command

:LISTer:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusesLister Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeReference Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusesLister..::.TimeReference Property
IAgInfiniiVision2SerialBusesLister See Also

Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeReference As AgInfiniiVisionSerialBusListerTimeReferenceEnum
C#
public AgInfiniiVisionSerialBusListerTimeReferenceEnum  TimeReference { get; set; }
Visual C++
HRESULT get_TimeReference(
    AgInfiniiVisionSerialBusListerTimeReferenceEnum*  val
);
HRESULT put_TimeReference(
    AgInfiniiVisionSerialBusListerTimeReferenceEnum  val
);

Remarks

The TimeReference property can be set to one of the following values:

  • AgInfiniiVisionSerialBusListerTimeReferenceTrigger - to specify that the time value for a Lister row is relative to the trigger
  • AgInfiniiVisionSerialBusListerTimeReferencePrevious - to specify that the time value for a Lister row is relative to the previous Lister row

Instrument Command

:LISTer:REFerence {TRIG|PREV}
:LISTer:REFerence?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVision2SerialBusesLister Interface
Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBuses..::.Name Property
IAgInfiniiVision2SerialBuses See Also

Read Only - Returns the serial bus name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of serial buses.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2SerialBuses Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialBuses2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.SerialBuses2 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVision2SerialBuses interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialBuses2 As IAgInfiniiVisionSerialBuses2
C#
public IAgInfiniiVisionSerialBuses2  SerialBuses2 { get; }
Visual C++
HRESULT get_SerialBuses2(
    IAgInfiniiVisionSerialBuses2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses2..::.Item2 Property
IAgInfiniiVisionSerialBuses2 See Also

Pointer to the IAgInfiniiVisionSerialBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgInfiniiVisionSerialBus2
C#
public IAgInfiniiVisionSerialBus2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgInfiniiVisionSerialBus2**  val
);

Parameters

Name

The name of a serial bus. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the SerialBus repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBuses2 Interface
Agilent.AgInfiniiVision.Interop Namespace


USB Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2..::.USB Property
IAgInfiniiVisionSerialBus2 See Also

Pointer to the IAgInfiniiVisionSerialBus2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property USB As IAgInfiniiVisionSerialBus2USB
C#
public IAgInfiniiVisionSerialBus2USB  USB { get; }
Visual C++
HRESULT get_USB(
    IAgInfiniiVisionSerialBus2USB**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Address Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Address Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Address As String
C#
public string  Address { get; set; }
Visual C++
HRESULT get_Address(
    BSTR*  val
);
HRESULT put_Address(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ADDRess {value}
:SBUS{SerialBus}:USB:TRIGger:ADDRess?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Base Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Base Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Base As AgInfiniiVisionSerialBusUSBBaseEnum
C#
public AgInfiniiVisionSerialBusUSBBaseEnum  Base { get; set; }
Visual C++
HRESULT get_Base(
    AgInfiniiVisionSerialBusUSBBaseEnum*  val
);
HRESULT put_Base(
    AgInfiniiVisionSerialBusUSBBaseEnum  val
);

Remarks

  • All other fields are displayed in hex.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:BASE {ASC|BIN|DEC|HEX}
    :SBUS{SerialBus}:USB:BASE?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Condition Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies USB trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionSerialBusUSBConditionEnum
C#
public AgInfiniiVisionSerialBusUSBConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionSerialBusUSBConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionSerialBusUSBConditionEnum  val
);

Remarks

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.Condition property.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger {SOP|EOP|ENT|EXIT|RES|TOK|DATA|HAND|SPEC|ALL|PID|CRC5|CRC16|GLIT|STUFF|SE1}
:SBUS{SerialBus}:USB:TRIGger?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


CRC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.CRC Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the CRC portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CRC As String
C#
public string  CRC { get; set; }
Visual C++
HRESULT get_CRC(
    BSTR*  val
);
HRESULT put_CRC(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:CRC {value}
:SBUS{SerialBus}:USB:TRIGger:CRC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Data Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the Data portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As String
C#
public string  Data { get; set; }
Visual C++
HRESULT get_Data(
    BSTR*  val
);
HRESULT put_Data(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn..." where n = {0 | 1 | X}
    • "0xn..." where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:DATA {value}
:SBUS{SerialBus}:USB:TRIGger:DATA?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


DataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.DataLength Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the data length in bytes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataLength As Short
C#
public short  DataLength { get; set; }
Visual C++
HRESULT get_DataLength(
    short*  val
);
HRESULT put_DataLength(
    short  val
);

Remarks

  • It range is from 1 to 20.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:DATA:LENGth {value}
    :SBUS{SerialBus}:USB:TRIGger:DATA:LENGth?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


DifferentialSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.DifferentialSource Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies which signal is used as the differential source for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DifferentialSource As String
C#
public string  DifferentialSource { get; set; }
Visual C++
HRESULT get_DifferentialSource(
    BSTR*  val
);
HRESULT put_DifferentialSource(
    BSTR  val
);

Remarks

  • "Channel<n>", where <n> can be from 1 to the number of analog channels.

    • NOTE: Only supported for 4000X and 6000X series models.

    Instrument Command

    :SBUS{SerialBus}:USB:SOURce:DIFFerential {value}
    :SBUS{SerialBus}:USB:SOURce:DIFFerential?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


DMinusSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.DMinusSource Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies which signal is used as the USB D- source for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DMinusSource As String
C#
public string  DMinusSource { get; set; }
Visual C++
HRESULT get_DMinusSource(
    BSTR*  val
);
HRESULT put_DMinusSource(
    BSTR  val
);

Remarks

The DMinusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.DMinusSource property.

Instrument Command

:SBUS{SerialBus}:USB:SOURce:DMINus {value}
:SBUS{SerialBus}:USB:SOURce:DMINus?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


DPlusSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.DPlusSource Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies which signal is used as the USB D+ source for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DPlusSource As String
C#
public string  DPlusSource { get; set; }
Visual C++
HRESULT get_DPlusSource(
    BSTR*  val
);
HRESULT put_DPlusSource(
    BSTR  val
);

Remarks

The DPlusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.DPlusSource property.

Instrument Command

:SBUS{SerialBus}:USB:SOURce:DPLus {value}
:SBUS{SerialBus}:USB:SOURce:DPLus?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


EndPoint Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.EndPoint Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property EndPoint As String
C#
public string  EndPoint { get; set; }
Visual C++
HRESULT get_EndPoint(
    BSTR*  val
);
HRESULT put_EndPoint(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ENDPoint {value}
:SBUS{SerialBus}:USB:TRIGger:ENDPoint?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


ET Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.ET Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ET As String
C#
public string  ET { get; set; }
Visual C++
HRESULT get_ET(
    BSTR*  val
);
HRESULT put_ET(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ET {value}
:SBUS{SerialBus}:USB:TRIGger:ET?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Frame Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Frame Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frame As String
C#
public string  Frame { get; set; }
Visual C++
HRESULT get_Frame(
    BSTR*  val
);
HRESULT put_Frame(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnnnnnn" where n = {0 | 1 | X}
    • "0xnnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:FRAMe {value}
:SBUS{SerialBus}:USB:TRIGger:FRAMe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


HubAddress Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.HubAddress Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HubAddress As String
C#
public string  HubAddress { get; set; }
Visual C++
HRESULT get_HubAddress(
    BSTR*  val
);
HRESULT put_HubAddress(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:HADDress {value}
:SBUS{SerialBus}:USB:TRIGger:HADDress?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


PIDCheck Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.PIDCheck Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDCheck As String
C#
public string  PIDCheck { get; set; }
Visual C++
HRESULT get_PIDCheck(
    BSTR*  val
);
HRESULT put_PIDCheck(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:PCHeck {value}
:SBUS{SerialBus}:USB:TRIGger:PCHeck?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


PIDData Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.PIDData Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the USB data PID to trigger on for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDData As AgInfiniiVisionPIDDataEnum
C#
public AgInfiniiVisionPIDDataEnum  PIDData { get; set; }
Visual C++
HRESULT get_PIDData(
    AgInfiniiVisionPIDDataEnum*  val
);
HRESULT put_PIDData(
    AgInfiniiVisionPIDDataEnum  val
);

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The DATA USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:DATA {DATA0|DATA1|DATA2|MDAT}
    :SBUS{SerialBus}:USB:TRIGger:PID:DATA?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDHandshake Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.PIDHandshake Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the USB handshake PID to trigger on for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDHandshake As AgInfiniiVisionPIDHandshakeEnum
C#
public AgInfiniiVisionPIDHandshakeEnum  PIDHandshake { get; set; }
Visual C++
HRESULT get_PIDHandshake(
    AgInfiniiVisionPIDHandshakeEnum*  val
);
HRESULT put_PIDHandshake(
    AgInfiniiVisionPIDHandshakeEnum  val
);

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The HANDshake USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:HANDshake {ACK|NAK|STALL|NYET}
    :SBUS{SerialBus}:USB:TRIGger:PID:HANDshake?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDSpecial Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.PIDSpecial Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the USB special PID to trigger on for the selected bus

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDSpecial As AgInfiniiVisionPIDSpecialEnum
C#
public AgInfiniiVisionPIDSpecialEnum  PIDSpecial { get; set; }
Visual C++
HRESULT get_PIDSpecial(
    AgInfiniiVisionPIDSpecialEnum*  val
);
HRESULT put_PIDSpecial(
    AgInfiniiVisionPIDSpecialEnum  val
);

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The SPECial USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:SPECial {PING|PRE|ERR|SPLIT}
    :SBUS{SerialBus}:USB:TRIGger:PID:SPECial?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


PIDToken Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.PIDToken Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the USB token PID to trigger on for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PIDToken As AgInfiniiVisionPIDTokenEnum
C#
public AgInfiniiVisionPIDTokenEnum  PIDToken { get; set; }
Visual C++
HRESULT get_PIDToken(
    AgInfiniiVisionPIDTokenEnum*  val
);
HRESULT put_PIDToken(
    AgInfiniiVisionPIDTokenEnum  val
);

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The TOKen USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:TOKen {OUT|IN|SET|SOF}
    :SBUS{SerialBus}:USB:TRIGger:PID:TOKen?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionSerialBus2USB Interface
    Agilent.AgInfiniiVision.Interop Namespace


Port Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Port Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Port As String
C#
public string  Port { get; set; }
Visual C++
HRESULT get_Port(
    BSTR*  val
);
HRESULT put_Port(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:PORT {value}
:SBUS{SerialBus}:USB:TRIGger:PORT?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


SC Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.SC Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SC As String
C#
public string  SC { get; set; }
Visual C++
HRESULT get_SC(
    BSTR*  val
);
HRESULT put_SC(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "n" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:SC {value}
:SBUS{SerialBus}:USB:TRIGger:SC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


SEU Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.SEU Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SEU As String
C#
public string  SEU { get; set; }
Visual C++
HRESULT get_SEU(
    BSTR*  val
);
HRESULT put_SEU(
    BSTR  val
);

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:SEU {value}
:SBUS{SerialBus}:USB:TRIGger:SEU?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Speed Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB..::.Speed Property
IAgInfiniiVisionSerialBus2USB See Also

Specifies the speed of the USB interface for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Speed As AgInfiniiVisionSerialBusUSBSpeedEnum
C#
public AgInfiniiVisionSerialBusUSBSpeedEnum  Speed { get; set; }
Visual C++
HRESULT get_Speed(
    AgInfiniiVisionSerialBusUSBSpeedEnum*  val
);
HRESULT put_Speed(
    AgInfiniiVisionSerialBusUSBSpeedEnum  val
);

Remarks

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.Speed property.

Instrument Command

:SBUS{SerialBus}:USB:SPEed {LOW|FULL|HIGH}
:SBUS{SerialBus}:USB:SPEed?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSerialBus2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialBuses3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.SerialBuses3 Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVision2SerialBuses interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialBuses3 As IAgInfiniiVisionSerialBuses3
C#
public IAgInfiniiVisionSerialBuses3  SerialBuses3 { get; }
Visual C++
HRESULT get_SerialBuses3(
    IAgInfiniiVisionSerialBuses3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses3..::.Item3 Property
IAgInfiniiVisionSerialBuses3 See Also

Pointer to the IAgInfiniiVisionSerialBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item3( _
    ByVal  Name As String  _
) As IAgInfiniiVisionSerialBus3
C#
public IAgInfiniiVisionSerialBus3  get_Item3(
    string  Name
)
Visual C++
HRESULT get_Item3(
    BSTR  Name,
    IAgInfiniiVisionSerialBus3**  val
);

Parameters

Name

The name of a serial bus. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the SerialBus repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBuses3 Interface
Agilent.AgInfiniiVision.Interop Namespace


CAN2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3..::.CAN2 Property
IAgInfiniiVisionSerialBus3 See Also

Pointer to the IAgInfiniiVision2SerialBus2CAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CAN2 As IAgInfiniiVisionSerialBus3CAN2
C#
public IAgInfiniiVisionSerialBus3CAN2  CAN2 { get; }
Visual C++
HRESULT get_CAN2(
    IAgInfiniiVisionSerialBus3CAN2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3 Interface
Agilent.AgInfiniiVision.Interop Namespace


FD Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2..::.FD Property
IAgInfiniiVisionSerialBus3CAN2 See Also

Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FD As IAgInfiniiVisionSerialBus3CAN2FD
C#
public IAgInfiniiVisionSerialBus3CAN2FD  FD { get; }
Visual C++
HRESULT get_FD(
    IAgInfiniiVisionSerialBus3CAN2FD**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


BaudRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.BaudRate Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property BaudRate As Integer
C#
public int  BaudRate { get; set; }
Visual C++
HRESULT get_BaudRate(
    long*  val
);
HRESULT put_BaudRate(
    long  val
);

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:FDBaudrate {value}
:SBUS{SerialBus}:CAN:SIGNal:FDBaudrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


DataLengthCode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.DataLengthCode Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Sets and gets the DLC value to be used in the CAN FD data trigger mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataLengthCode As Integer
C#
public int  DataLengthCode { get; set; }
Visual C++
HRESULT get_DataLengthCode(
    long*  val
);
HRESULT put_DataLengthCode(
    long  val
);

Remarks

A specific valid FD value can be specified, or -1 can be specified to indicate "don't care".

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:DLC {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:DLC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


SamplePoint Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.SamplePoint Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SamplePoint As Double
C#
public double  SamplePoint { get; set; }
Visual C++
HRESULT get_SamplePoint(
    double*  val
);
HRESULT put_SamplePoint(
    double  val
);

Remarks

Valid values are: The even numbered percentages from 30% to 90%of time between the beginning of the bit time to the end of the bit time.

Instrument Command

:SBUS{SerialBus}:CAN:FDSPoint {value}
:SBUS{SerialBus}:CAN:FDSPoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


SpecErrorCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.SpecErrorCount Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SpecErrorCount As Double
C#
public double  SpecErrorCount { get; }
Visual C++
HRESULT get_SpecErrorCount(
    double*  val
);

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:SPEC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerIDFilterEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.TriggerIDFilterEnabled Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Enable and disable the triggers filtering by CAN IDs.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerIDFilterEnabled As Boolean
C#
public bool  TriggerIDFilterEnabled { get; set; }
Visual C++
HRESULT get_TriggerIDFilterEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_TriggerIDFilterEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:IDFilter {ON|OFF}
:SBUS{SerialBus}:CAN:TRIGger:IDFilter?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerPatternStartBytePosition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD..::.TriggerPatternStartBytePosition Property
IAgInfiniiVisionSerialBus3CAN2FD See Also

Sets and gets the starting byte position for CAN FD data triggers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerPatternStartBytePosition As Integer
C#
public int  TriggerPatternStartBytePosition { get; set; }
Visual C++
HRESULT get_TriggerPatternStartBytePosition(
    long*  val
);
HRESULT put_TriggerPatternStartBytePosition(
    long  val
);

Remarks

CAN FD frames can have up to 64 bytes of data. You can trigger on up to 8 bytes of data. The starting byte position setting lets you trigger on data anywhere within the frame.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:STARt {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3CAN2FD Interface
Agilent.AgInfiniiVision.Interop Namespace


SENT Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3..::.SENT Property
IAgInfiniiVisionSerialBus3 See Also

Pointer to the IAgInfiniiVisionSerialBus3SENT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SENT As IAgInfiniiVisionSerialBus3SENT
C#
public IAgInfiniiVisionSerialBus3SENT  SENT { get; }
Visual C++
HRESULT get_SENT(
    IAgInfiniiVisionSerialBus3SENT**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Clock Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.Clock Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the nominal clock period (tick), from 1us to 300us.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Clock As Double
C#
public double  Clock { get; set; }
Visual C++
HRESULT get_Clock(
    double*  val
);
HRESULT put_Clock(
    double  val
);

Instrument Command

:SBUS{SerialBus}:SENT:CLOCk {value}
:SBUS{SerialBus}:SENT:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


CRCFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.CRCFormat Property
IAgInfiniiVisionSerialBus3SENT See Also

Set and get the format of the CRC.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property CRCFormat As AgInfiniiVisionSerialBusSENTCRCEnum
C#
public AgInfiniiVisionSerialBusSENTCRCEnum  CRCFormat { get; set; }
Visual C++
HRESULT get_CRCFormat(
    AgInfiniiVisionSerialBusSENTCRCEnum*  val
);
HRESULT put_CRCFormat(
    AgInfiniiVisionSerialBusSENTCRCEnum  val
);

Remarks

Enhanced Serial Message CRCs are always calculated using the recommended format, but for the Fast Channel Messages, and for Short Serial Message CRCs, this setting is used.

Instrument Command

:SBUS{SerialBus}:SENT:CRC {LEG|REC}
:SBUS{SerialBus}:SENT:CRC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Format Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.Format Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the message decode/triggering format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Format As AgInfiniiVisionSerialBusSENTFormatEnum
C#
public AgInfiniiVisionSerialBusSENTFormatEnum  Format { get; set; }
Visual C++
HRESULT get_Format(
    AgInfiniiVisionSerialBusSENTFormatEnum*  val
);
HRESULT put_Format(
    AgInfiniiVisionSerialBusSENTFormatEnum  val
);

Remarks

  • AgInfiniiVisionSerialBusSENTFormatNibbles - displays the raw transmitted nibble values.
  • AgInfiniiVisionSerialBusSENTFormatFSIGnal - displays Fast Channel Message Signals.
  • AgInfiniiVisionSerialBusSENTFormatFSSerial - displays both Fast and Slow Messages (Short format) simultaneously.
  • AgInfiniiVisionSerialBusSENTFormatFESerial - displays both Fast and Slow Messages (Enhanced format) simultaneously.
  • AgInfiniiVisionSerialBusSENTFormatSSERial - displays Slow Channel Messages in Short format.
  • AgInfiniiVisionSerialBusSENTFormatESERial - displays Slow Channel Messages in Enhanced format.

This selection affects both decoding and triggering. The decode is affected both in how the system interprets the data, and what will be displayed. The trigger is affected in that the trigger hardware needs to be configured to trigger on serial messages correctly.

Instrument Command

:SBUS{SerialBus}:SENT:FORMat {NIBB|FSIG|FSS|FES|SSER|ESER}
:SBUS{SerialBus}:SENT:FORMat?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalDisplay Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalDisplay Method
IAgInfiniiVisionSerialBus3SENT See Also

This method specifies whether the given signal is on or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalDisplay ( _
    ByVal  Index As Integer  _
) As Boolean
C#
public bool  GetSignalDisplay(
    int  Index
)
Visual C++
HRESULT GetSignalDisplay(
    long  Index
    VARIANT_BOOL*  retval
);

Parameters

Index

From 1 to 6.

Return Value

SENT decode number base

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalLength Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalLength Method
IAgInfiniiVisionSerialBus3SENT See Also

Gets the bit length of the signal being defined.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalLength ( _
    ByVal  Index As Integer  _
) As Integer
C#
public int  GetSignalLength(
    int  Index
)
Visual C++
HRESULT GetSignalLength(
    long  Index
    long*  retval
);

Parameters

Index

From 1 to 6.

Return Value

Signal bit length 1 to 6

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalMultiplier Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalMultiplier Method
IAgInfiniiVisionSerialBus3SENT See Also

Gets the multiplier value for the Fast Channel Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalMultiplier ( _
    ByVal  Index As Integer  _
) As Double
C#
public double  GetSignalMultiplier(
    int  Index
)
Visual C++
HRESULT GetSignalMultiplier(
    long  Index
    double*  retval
);

Parameters

Index

From 1 to 6.

Return Value

Multiplier value 1 to 24

Remarks

The multiplier to be used in calculating a physical value displayed for a Fast Channel Signal.

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:MULTiplier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalNibbleOrder Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalNibbleOrder Method
IAgInfiniiVisionSerialBus3SENT See Also

Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalNibbleOrder ( _
    ByVal  Index As Integer  _
) As AgInfiniiVisionSerialBusSENTSignalOrderEnum
C#
public AgInfiniiVisionSerialBusSENTSignalOrderEnum  GetSignalNibbleOrder(
    int  Index
)
Visual C++
HRESULT GetSignalNibbleOrder(
    long  Index
    AgInfiniiVisionSerialBusSENTSignalOrderEnum*  retval
);

Parameters

Index

From 1 to 6.

Return Value

Nibble order 1 to 6.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:ORDer?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalOffset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalOffset Method
IAgInfiniiVisionSerialBus3SENT See Also

Gets the offset value for the Fast Channel Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalOffset ( _
    ByVal  Index As Integer  _
) As Double
C#
public double  GetSignalOffset(
    int  Index
)
Visual C++
HRESULT GetSignalOffset(
    long  Index
    double*  retval
);

Parameters

Index

From 1 to 6.

Return Value

Offset value 1 to 6.

Remarks

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:OFFSet?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


GetSignalStartPosition Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.GetSignalStartPosition Method
IAgInfiniiVisionSerialBus3SENT See Also

Gets the starting bit of the Fast Signal being defined.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetSignalStartPosition ( _
    ByVal  Index As Integer  _
) As Integer
C#
public int  GetSignalStartPosition(
    int  Index
)
Visual C++
HRESULT GetSignalStartPosition(
    long  Index
    long*  retval
);

Parameters

Index

From 1 to 6.

Return Value

Fast Signal starting bit 1 to 6

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


IdleState Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.IdleState Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the idle state of the SENT bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property IdleState As AgInfiniiVisionSerialBusSENTIdleStateEnum
C#
public AgInfiniiVisionSerialBusSENTIdleStateEnum  IdleState { get; set; }
Visual C++
HRESULT get_IdleState(
    AgInfiniiVisionSerialBusSENTIdleStateEnum*  val
);
HRESULT put_IdleState(
    AgInfiniiVisionSerialBusSENTIdleStateEnum  val
);

Instrument Command

:SBUS{SerialBus}:SENT:IDLE {LOW|HIGH}
:SBUS{SerialBus}:SENT:IDLE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberBase Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.NumberBase Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the number base used by the decoder.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberBase As AgInfiniiVisionSerialBusSENTNumberBaseEnum
C#
public AgInfiniiVisionSerialBusSENTNumberBaseEnum  NumberBase { get; set; }
Visual C++
HRESULT get_NumberBase(
    AgInfiniiVisionSerialBusSENTNumberBaseEnum*  val
);
HRESULT put_NumberBase(
    AgInfiniiVisionSerialBusSENTNumberBaseEnum  val
);

Remarks

The chosen base is used for the data nibbles in Raw decode format, the defined Signals in the other formats, and for the data field of the Serial Messages.

Instrument Command

:SBUS{SerialBus}:SENT:DISPlay {HEX|DEC|SYMB}
:SBUS{SerialBus}:SENT:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberOfNibble Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.NumberOfNibble Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the number of nibbles in a SENT message, from 1 to 6.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfNibble As Integer
C#
public int  NumberOfNibble { get; set; }
Visual C++
HRESULT get_NumberOfNibble(
    long*  val
);
HRESULT put_NumberOfNibble(
    long  val
);

Instrument Command

:SBUS{SerialBus}:SENT:LENGth {value}
:SBUS{SerialBus}:SENT:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


PausePulse Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.PausePulse Property
IAgInfiniiVisionSerialBus3SENT See Also

This command specifies whether the SENT messages are followed by a pause pulse.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PausePulse As Boolean
C#
public bool  PausePulse { get; set; }
Visual C++
HRESULT get_PausePulse(
    VARIANT_BOOL*  val
);
HRESULT put_PausePulse(
    VARIANT_BOOL  val
);

Instrument Command

:SBUS{SerialBus}:SENT:PPULse {ON|OFF}
:SBUS{SerialBus}:SENT:PPULse?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalDisplay Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalDisplay Method
IAgInfiniiVisionSerialBus3SENT See Also

Set the given signal is on or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalDisplay ( _
    ByVal  Index As Integer  _
    ByVal  StateEnabled As Boolean  _
)
C#
public void  SetSignalDisplay(
    int  Index,
    bool  StateEnabled
)
Visual C++
HRESULT SetSignalDisplay(
    long  Index,
    VARIANT_BOOL  StateEnabled
);

Parameters

Index

From 1 to 6.

StateEnabled

True or false

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:DISPlay {ON|OFF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalLength Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalLength Method
IAgInfiniiVisionSerialBus3SENT See Also

Sets the bit length of the signal being defined.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalLength ( _
    ByVal  Index As Integer  _
    ByVal  Length As Integer  _
)
C#
public void  SetSignalLength(
    int  Index,
    int  Length
)
Visual C++
HRESULT SetSignalLength(
    long  Index,
    long  Length
);

Parameters

Index

From 1 to 6.

Length

Length

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:LENGth {Length}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalMultiplier Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalMultiplier Method
IAgInfiniiVisionSerialBus3SENT See Also

Sets the multiplier value for the Fast Channel Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalMultiplier ( _
    ByVal  Index As Integer  _
    ByVal  Multiplier As Double  _
)
C#
public void  SetSignalMultiplier(
    int  Index,
    double  Multiplier
)
Visual C++
HRESULT SetSignalMultiplier(
    long  Index,
    double  Multiplier
);

Parameters

Index

From 1 to 6.

Multiplier

Multiplier.

Remarks

The multiplier to be used in calculating a physical value displayed for a Fast Channel Signal.

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:MULTiplier {Multiplier}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalNibbleOrder Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalNibbleOrder Method
IAgInfiniiVisionSerialBus3SENT See Also

Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalNibbleOrder ( _
    ByVal  Index As Integer  _
    ByVal  Order As AgInfiniiVisionSerialBusSENTSignalOrderEnum  _
)
C#
public void  SetSignalNibbleOrder(
    int  Index,
    AgInfiniiVisionSerialBusSENTSignalOrderEnum  Order
)
Visual C++
HRESULT SetSignalNibbleOrder(
    long  Index,
    AgInfiniiVisionSerialBusSENTSignalOrderEnum  Order
);

Parameters

Index

From 1 to 6.

Order

Order.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:ORDer {MSNF|LSNF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalOffset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalOffset Method
IAgInfiniiVisionSerialBus3SENT See Also

Sets the offset value for the Fast Channel Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalOffset ( _
    ByVal  Index As Integer  _
    ByVal  Offset As Double  _
)
C#
public void  SetSignalOffset(
    int  Index,
    double  Offset
)
Visual C++
HRESULT SetSignalOffset(
    long  Index,
    double  Offset
);

Parameters

Index

From 1 to 6.

Offset

Offset.

Remarks

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:OFFSet {Offset}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


SetSignalStartPosition Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.SetSignalStartPosition Method
IAgInfiniiVisionSerialBus3SENT See Also

Sets the starting bit of the Fast Signal being defined.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetSignalStartPosition ( _
    ByVal  Index As Integer  _
    ByVal  Position As Integer  _
)
C#
public void  SetSignalStartPosition(
    int  Index,
    int  Position
)
Visual C++
HRESULT SetSignalStartPosition(
    long  Index,
    long  Position
);

Parameters

Index

From 1 to 6.

Position

Position.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:STARt {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.Source Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the input channel for SENT decode and triggering.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Instrument Command

:SBUS{SerialBus}:SENT:SOURce {value}
:SBUS{SerialBus}:SENT:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Tolerance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.Tolerance Property
IAgInfiniiVisionSerialBus3SENT See Also

Sets and gets the tolerance for determing if the sync pulse is valid.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Tolerance As Double
C#
public double  Tolerance { get; set; }
Visual C++
HRESULT get_Tolerance(
    double*  val
);
HRESULT put_Tolerance(
    double  val
);

Remarks

Valid values range from 3% to 30%.

Instrument Command

:SBUS{SerialBus}:SENT:TOLerance {value}
:SBUS{SerialBus}:SENT:TOLerane?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT..::.Trigger Property
IAgInfiniiVisionSerialBus3SENT See Also

Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IAgInfiniiVisionSerialBus3SENTTrigger
C#
public IAgInfiniiVisionSerialBus3SENTTrigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IAgInfiniiVisionSerialBus3SENTTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3SENT Interface
Agilent.AgInfiniiVision.Interop Namespace


FastChannel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTrigger..::.FastChannel Property
IAgInfiniiVisionSerialBus3SENTTrigger See Also

Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FastChannel As IAgInfiniiVisionSerialBus3SENTTriggerFastChannel
C#
public IAgInfiniiVisionSerialBus3SENTTriggerFastChannel  FastChannel { get; }
Visual C++
HRESULT get_FastChannel(
    IAgInfiniiVisionSerialBus3SENTTriggerFastChannel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3SENTTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerFastChannel..::.Data Property
IAgInfiniiVisionSerialBus3SENTTriggerFastChannel See Also

Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As String
C#
public string  Data { get; set; }
Visual C++
HRESULT get_Data(
    BSTR*  val
);
HRESULT put_Data(
    BSTR  val
);

Remarks

The input format of string is

  • <Input String> :: = "nnnn..." where n :: = { 0 | 1 | X }

    • or

  • <Input String> :: = "0xn..." where n :: = { 0,..,9 | A,..,F | X |$}

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:FAST:DATA "{value}"
    :SBUS{SerialBus}:SENT:TRIGger:FAST:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus3SENTTriggerFastChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


SlowChannel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTrigger..::.SlowChannel Property
IAgInfiniiVisionSerialBus3SENTTrigger See Also

Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SlowChannel As IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel
C#
public IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel  SlowChannel { get; }
Visual C++
HRESULT get_SlowChannel(
    IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3SENTTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Data Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel..::.Data Property
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel See Also

Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Data As Integer
C#
public int  Data { get; set; }
Visual C++
HRESULT get_Data(
    long*  val
);
HRESULT put_Data(
    long  val
);

Remarks

The format of Data is look like

  • <Data> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthShort, from -1 (don't care) to 65535, in NR1 format.
  • <Data> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthLong, from -1 (don't care) to 4096, in NR1 format.

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:SLOW:DATA {value}
    :SBUS{SerialBus}:SENT:TRIGger:SLOW:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


ID Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel..::.ID Property
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel See Also

Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ID As Integer
C#
public int  ID { get; set; }
Visual C++
HRESULT get_ID(
    long*  val
);
HRESULT put_ID(
    long  val
);

Remarks

The format of ID is look like

  • <ID> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthShort, from -1 (don't care) to 15, in NR1 format.
  • <ID> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthLong, from -1 (don't care) to 255, in NR1 format.

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:SLOW:ID {value}
    :SBUS{SerialBus}:SENT:TRIGger:SLOW:ID?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel Interface
    Agilent.AgInfiniiVision.Interop Namespace


IDDataLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel..::.IDDataLength Property
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel See Also

Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property IDDataLength As AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum
C#
public AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum  IDDataLength { get; set; }
Visual C++
HRESULT get_IDDataLength(
    AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum*  val
);
HRESULT put_IDDataLength(
    AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum  val
);

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger:SLOW:ILENgth {SHOR|LONG}
:SBUS{SerialBus}:SENT:TRIGger:SLOW:ILENgth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialBuses4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision6..::.SerialBuses4 Property
IAgInfiniiVision6 See Also

Pointer to the IAgInfiniiVision2SerialBuses interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialBuses4 As IAgInfiniiVisionSerialBuses4
C#
public IAgInfiniiVisionSerialBuses4  SerialBuses4 { get; }
Visual C++
HRESULT get_SerialBuses4(
    IAgInfiniiVisionSerialBuses4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision6 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses4..::.Item4 Property
IAgInfiniiVisionSerialBuses4 See Also

Pointer to the IAgInfiniiVisionSerialBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item4( _
    ByVal  Name As String  _
) As IAgInfiniiVisionSerialBus4
C#
public IAgInfiniiVisionSerialBus4  get_Item4(
    string  Name
)
Visual C++
HRESULT get_Item4(
    BSTR  Name,
    IAgInfiniiVisionSerialBus4**  val
);

Parameters

Name

The name of a serial bus. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the SerialBus repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBuses4 Interface
Agilent.AgInfiniiVision.Interop Namespace


CAN3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4..::.CAN3 Property
IAgInfiniiVisionSerialBus4 See Also

Pointer to the IAgInfiniiVision2SerialBus2CAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CAN3 As IAgInfiniiVisionSerialBus4CAN3
C#
public IAgInfiniiVisionSerialBus4CAN3  CAN3 { get; }
Visual C++
HRESULT get_CAN3(
    IAgInfiniiVisionSerialBus4CAN3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Display Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3..::.Display Property
IAgInfiniiVisionSerialBus4CAN3 See Also

Sets and Gets the CAN decode display type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Display As AgInfiniiVisionSerialBusCANDisplayEnum
C#
public AgInfiniiVisionSerialBusCANDisplayEnum  Display { get; set; }
Visual C++
HRESULT get_Display(
    AgInfiniiVisionSerialBusCANDisplayEnum*  val
);
HRESULT put_Display(
    AgInfiniiVisionSerialBusCANDisplayEnum  val
);

Instrument Command

:SBUS{SerialBus}:CAN:DISPlay {HEX|SYMB}
:SBUS{SerialBus}:CAN:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, EDU-X 1002A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4CAN3 Interface
Agilent.AgInfiniiVision.Interop Namespace


FD2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3..::.FD2 Property
IAgInfiniiVisionSerialBus4CAN3 See Also

Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FD2 As IAgInfiniiVisionSerialBus4CAN3FD2
C#
public IAgInfiniiVisionSerialBus4CAN3FD2  FD2 { get; }
Visual C++
HRESULT get_FD2(
    IAgInfiniiVisionSerialBus4CAN3FD2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus4CAN3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Standard Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3FD2..::.Standard Property
IAgInfiniiVisionSerialBus4CAN3FD2 See Also

Sets and Gets the frame decode standard.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Standard As AgInfiniiVisionSerialBusCANFDStandardEnum
C#
public AgInfiniiVisionSerialBusCANFDStandardEnum  Standard { get; set; }
Visual C++
HRESULT get_Standard(
    AgInfiniiVisionSerialBusCANFDStandardEnum*  val
);
HRESULT put_Standard(
    AgInfiniiVisionSerialBusCANFDStandardEnum  val
);

Remarks

  • Supported by 3000T, 4000X, 6000X, M924x and P924x.

    • Instrument Command

    :SBUS{SerialBus}:CAN:FDSTandard {ISO|NISO}
    :SBUS{SerialBus}:CAN:FDSTandard?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus4CAN3FD2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicMessage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3..::.TriggerSymbolicMessage Property
IAgInfiniiVisionSerialBus4CAN3 See Also

Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicMessage As String
C#
public string  TriggerSymbolicMessage { get; set; }
Visual C++
HRESULT get_TriggerSymbolicMessage(
    BSTR*  val
);
HRESULT put_TriggerSymbolicMessage(
    BSTR  val
);

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:MESSage {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:MESSage?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus4CAN3 Interface
    Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicSignal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3..::.TriggerSymbolicSignal Property
IAgInfiniiVisionSerialBus4CAN3 See Also

Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicSignal As String
C#
public string  TriggerSymbolicSignal { get; set; }
Visual C++
HRESULT get_TriggerSymbolicSignal(
    BSTR*  val
);
HRESULT put_TriggerSymbolicSignal(
    BSTR  val
);

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:SIGNal {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:SIGNal?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus4CAN3 Interface
    Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicValue Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3..::.TriggerSymbolicValue Property
IAgInfiniiVisionSerialBus4CAN3 See Also

Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicValue As Double
C#
public double  TriggerSymbolicValue { get; set; }
Visual C++
HRESULT get_TriggerSymbolicValue(
    double*  val
);
HRESULT put_TriggerSymbolicValue(
    double  val
);

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:VALue {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:VALue?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSerialBus4CAN3 Interface
    Agilent.AgInfiniiVision.Interop Namespace


LIN2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4..::.LIN2 Property
IAgInfiniiVisionSerialBus4 See Also

Pointer to the IAgInfiniiVision2SerialBus2LIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property LIN2 As IAgInfiniiVisionSerialBus4LIN2
C#
public IAgInfiniiVisionSerialBus4LIN2  LIN2 { get; }
Visual C++
HRESULT get_LIN2(
    IAgInfiniiVisionSerialBus4LIN2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Display Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4LIN2..::.Display Property
IAgInfiniiVisionSerialBus4LIN2 See Also

Sets and Gets the LIN decode display type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Display As AgInfiniiVisionSerialBusLINDisplayEnum
C#
public AgInfiniiVisionSerialBusLINDisplayEnum  Display { get; set; }
Visual C++
HRESULT get_Display(
    AgInfiniiVisionSerialBusLINDisplayEnum*  val
);
HRESULT put_Display(
    AgInfiniiVisionSerialBusLINDisplayEnum  val
);

Instrument Command

:SBUS{SerialBus}:LIN:DISPlay {HEX|SYMB}
:SBUS{SerialBus}:LIN:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicFrame Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4LIN2..::.TriggerSymbolicFrame Property
IAgInfiniiVisionSerialBus4LIN2 See Also

Sets and Gets the specific message when the LIN trigger mode is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicFrame As String
C#
public string  TriggerSymbolicFrame { get; set; }
Visual C++
HRESULT get_TriggerSymbolicFrame(
    BSTR*  val
);
HRESULT put_TriggerSymbolicFrame(
    BSTR  val
);

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:FRAMe "{value}"
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicSignal Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4LIN2..::.TriggerSymbolicSignal Property
IAgInfiniiVisionSerialBus4LIN2 See Also

Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicSignal As String
C#
public string  TriggerSymbolicSignal { get; set; }
Visual C++
HRESULT get_TriggerSymbolicSignal(
    BSTR*  val
);
HRESULT put_TriggerSymbolicSignal(
    BSTR  val
);

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:SIGNal "{value}"
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerSymbolicValue Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4LIN2..::.TriggerSymbolicValue Property
IAgInfiniiVisionSerialBus4LIN2 See Also

Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerSymbolicValue As Double
C#
public double  TriggerSymbolicValue { get; set; }
Visual C++
HRESULT get_TriggerSymbolicValue(
    double*  val
);
HRESULT put_TriggerSymbolicValue(
    double  val
);

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:VALue {value}
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4LIN2 Interface
Agilent.AgInfiniiVision.Interop Namespace


SENT2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4..::.SENT2 Property
IAgInfiniiVisionSerialBus4 See Also

Pointer to the IAgInfiniiVisionSerialBus3SENT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SENT2 As IAgInfiniiVisionSerialBus3SENT2
C#
public IAgInfiniiVisionSerialBus3SENT2  SENT2 { get; }
Visual C++
HRESULT get_SENT2(
    IAgInfiniiVisionSerialBus3SENT2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT2..::.Trigger2 Property
IAgInfiniiVisionSerialBus3SENT2 See Also

Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger2 As IAgInfiniiVisionSerialBus4SENT2Trigger2
C#
public IAgInfiniiVisionSerialBus4SENT2Trigger2  Trigger2 { get; }
Visual C++
HRESULT get_Trigger2(
    IAgInfiniiVisionSerialBus4SENT2Trigger2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSerialBus3SENT2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4SENT2Trigger2..::.Mode Property
IAgInfiniiVisionSerialBus4SENT2Trigger2 See Also

Sets and Gets the SENT trigger mode setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionSerialBusSENTTriggerModeEnum
C#
public AgInfiniiVisionSerialBusSENTTriggerModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionSerialBusSENTTriggerModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionSerialBusSENTTriggerModeEnum  val
);

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger {SFCM|SSCM|FCD|SCM|SCD|TOL|FCC|SCC|CRC|PPER|SSP}
:SBUS{SerialBus}:SENT:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4SENT2Trigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Tolerance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4SENT2Trigger2..::.Tolerance Property
IAgInfiniiVisionSerialBus4SENT2Trigger2 See Also

Sets and Gets the tolerance variation percent setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Tolerance As Integer
C#
public int  Tolerance { get; set; }
Visual C++
HRESULT get_Tolerance(
    long*  val
);
HRESULT put_Tolerance(
    long  val
);

Remarks

Value ::= from 1-28, in NR1 format.

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger:TOLerance {value}
:SBUS{SerialBus}:SENT:TRIGger:TOLerance?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionSerialBus4SENT2Trigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Status Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Status Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionStatus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Status As IAgInfiniiVisionStatus
C#
public IAgInfiniiVisionStatus  Status { get; }
Visual C++
HRESULT get_Status(
    IAgInfiniiVisionStatus**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Clear Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus..::.Clear Method
IAgInfiniiVisionStatus See Also

Clears all event registers and error queue. The enable registers are unaffected.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Clear ( _
)
C#
public void  Clear(
)
Visual C++
HRESULT Clear(
);

Instrument Command

*CLS

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionStatus Interface
Agilent.AgInfiniiVision.Interop Namespace


ConfigureServiceRequest Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus..::.ConfigureServiceRequest Method
IAgInfiniiVisionStatus See Also

Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureServiceRequest ( _
    ByVal  Reason As AgInfiniiVisionStatusSRQReasonEnum  _
)
C#
public void  ConfigureServiceRequest(
    AgInfiniiVisionStatusSRQReasonEnum  Reason
)
Visual C++
HRESULT ConfigureServiceRequest(
    AgInfiniiVisionStatusSRQReasonEnum  Reason
);

Parameters

Reason

The defined values are powers of two, 1, 2, 4, etc. The client can OR several reasons together so multiple events can generate a service request.

Remarks

All other events are disabled from generating a service request. To detect a service request the client application must poll the status byte using the Status.SerialPoll method or Status.Register property and test the request service bit.

Instrument Command

*CLS;*SRE;*ESE;:OPEE;:OVL

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionStatus Interface
Agilent.AgInfiniiVision.Interop Namespace


Preset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus..::.Preset Method
IAgInfiniiVisionStatus See Also

Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Preset ( _
)
C#
public void  Preset(
)
Visual C++
HRESULT Preset(
);

Instrument Command

*RST

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionStatus Interface
Agilent.AgInfiniiVision.Interop Namespace


Register Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus..::.Register Property
IAgInfiniiVisionStatus See Also

The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Register( _
    ByVal  Register As AgInfiniiVisionStatusRegisterEnum  _
    ByVal  SubRegister As AgInfiniiVisionStatusSubRegisterEnum  _
) As Integer
C#
public int  get_Register(
    AgInfiniiVisionStatusRegisterEnum  Register,
    AgInfiniiVisionStatusSubRegisterEnum  SubRegister
)
public void  set_Register(
    AgInfiniiVisionStatusRegisterEnum  Register,
    AgInfiniiVisionStatusSubRegisterEnum  SubRegister,
    int  val
)
Visual C++
HRESULT get_Register(
    AgInfiniiVisionStatusRegisterEnum  Register,
    AgInfiniiVisionStatusSubRegisterEnum  SubRegister,
    long*  val
);
HRESULT put_Register(
    AgInfiniiVisionStatusRegisterEnum  Register,
    AgInfiniiVisionStatusSubRegisterEnum  SubRegister,
    long  val
);

Parameters

Register

The status register to access. See StatusRegisterEnums for available registers.

SubRegister

The status sub register to access. See StatusSubRegisterEnums for available sub registers.

Remarks

See SCPI Volume 1: Syntax and Style, Section 9. The Register parameter refers to the entire set of registers. The SubRegister parameter refers to a particular register in a Register. Some Registers do not have all the possible sub-registers.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionStatus Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialPoll Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus..::.SerialPoll Property
IAgInfiniiVisionStatus See Also

Read Only - Serial poll the instrument status byte.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialPoll As Integer
C#
public int  SerialPoll { get; }
Visual C++
HRESULT get_SerialPoll(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionStatus Interface
Agilent.AgInfiniiVision.Interop Namespace


System Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.System Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionSystem interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property System As IAgInfiniiVisionSystem
C#
public IAgInfiniiVisionSystem  System { get; }
Visual C++
HRESULT get_System(
    IAgInfiniiVisionSystem**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Date Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.Date Property
IAgInfiniiVisionSystem See Also

Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Date As String
C#
public string  Date { get; set; }
Visual C++
HRESULT get_Date(
    BSTR*  val
);
HRESULT put_Date(
    BSTR  val
);

Instrument Command

:SYSTem:DATE {value}
:SYSTem:DATE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


DirectIO Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.DirectIO Property
IAgInfiniiVisionSystem See Also

Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DirectIO As IFormattedIO488
C#
public IFormattedIO488  DirectIO { get; }
Visual C++
HRESULT get_DirectIO(
    IFormattedIO488**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


DisableLocalControls Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.DisableLocalControls Method
IAgInfiniiVisionSystem See Also

Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub DisableLocalControls ( _
)
C#
public void  DisableLocalControls(
)
Visual C++
HRESULT DisableLocalControls(
);

Remarks

The client program can ensure that an operator cannot change the state of an instrument through its front panel. This method is only supported by instruments using a GPIB connection.

Instrument Command

:SYSTem:LOCK 1

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


EnableLocalControls Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.EnableLocalControls Method
IAgInfiniiVisionSystem See Also

Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub EnableLocalControls ( _
)
C#
public void  EnableLocalControls(
)
Visual C++
HRESULT EnableLocalControls(
);

Remarks

This method is only supported by instruments using a GPIB connection.

Instrument Command

:SYSTem:LOCK 0

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


GetState Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.GetState Method
IAgInfiniiVisionSystem See Also

Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetState ( _
    ByRef  Data As Byte()   _
)
C#
public void  GetState(
    ref byte[]   Data
)
Visual C++
HRESULT GetState(
    SAFEARRAY**  Data
);

Parameters

Data

Binary data representation of the current instrument state.

Instrument Command

*LRN?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


Message Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.Message Property
IAgInfiniiVisionSystem See Also

Writes a message(excluding quotation marks) to a text box in the center of the display

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public WriteOnly Property Message As String
C#
public string  Message { set; }
Visual C++
HRESULT put_Message(
    BSTR  val
);

Instrument Command

:SYSTem:DSP "{value}"

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


ProtectionEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.ProtectionEnabled Property
IAgInfiniiVisionSystem See Also

Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ProtectionEnabled As Boolean
C#
public bool  ProtectionEnabled { get; set; }
Visual C++
HRESULT get_ProtectionEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_ProtectionEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SYSTem:PROTection:LOCK {ON|OFF}
:SYSTem:PROTection:LOCK?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


PutState Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.PutState Method
IAgInfiniiVisionSystem See Also

Writes binary instrument state as saved by GetState method.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub PutState ( _
    ByVal  Data As Byte()   _
)
C#
public void  PutState(
    byte[]   Data
)
Visual C++
HRESULT PutState(
    SAFEARRAY**  Data
);

Parameters

Data

Binary data representation of the instrument state as read from the instrument using the GetState method.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


RecallState Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.RecallState Method
IAgInfiniiVisionSystem See Also

Restore the instrument to a state previously stored in the instrument's internal memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub RecallState ( _
    ByVal  MemoryLocation As AgInfiniiVisionMemoryLocationEnum  _
)
C#
public void  RecallState(
    AgInfiniiVisionMemoryLocationEnum  MemoryLocation
)
Visual C++
HRESULT RecallState(
    AgInfiniiVisionMemoryLocationEnum  MemoryLocation
);

Parameters

MemoryLocation

An integer which identifies which one of many internal memory locations was used to store the instrument's state.

Instrument Command

*RCL {0|1|2|3|4|5|6|7|8|9}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


SaveState Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.SaveState Method
IAgInfiniiVisionSystem See Also

Save the instrument's state to the instrument's internal memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SaveState ( _
    ByVal  MemoryLocation As AgInfiniiVisionMemoryLocationEnum  _
)
C#
public void  SaveState(
    AgInfiniiVisionMemoryLocationEnum  MemoryLocation
)
Visual C++
HRESULT SaveState(
    AgInfiniiVisionMemoryLocationEnum  MemoryLocation
);

Parameters

MemoryLocation

An integer which identifies which one of many internal memory locations is to be used to store the instrument's state.

Instrument Command

*SAV {0|1|2|3|4|5|6|7|8|9}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


SerialNumber Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.SerialNumber Property
IAgInfiniiVisionSystem See Also

Read Only - Instrument serial number.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialNumber As String
C#
public string  SerialNumber { get; }
Visual C++
HRESULT get_SerialNumber(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


Time Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.Time Property
IAgInfiniiVisionSystem See Also

Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Time As String
C#
public string  Time { get; set; }
Visual C++
HRESULT get_Time(
    BSTR*  val
);
HRESULT put_Time(
    BSTR  val
);

Instrument Command

:SYSTem:TIME {value}
:SYSTem:TIME?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeoutMilliseconds Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.TimeoutMilliseconds Property
IAgInfiniiVisionSystem See Also

The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeoutMilliseconds As Integer
C#
public int  TimeoutMilliseconds { get; set; }
Visual C++
HRESULT get_TimeoutMilliseconds(
    long*  val
);
HRESULT put_TimeoutMilliseconds(
    long  val
);

Remarks

Driver methods and properties with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value. Some methods provide a MaxTimeMilliseconds parameter which gives the client direct control over the timeout value for that method. Sometimes, however, increasing the timeout value can work around an obscure driver defect.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


TraceEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.TraceEnabled Property
IAgInfiniiVisionSystem See Also

If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TraceEnabled As Boolean
C#
public bool  TraceEnabled { get; set; }
Visual C++
HRESULT get_TraceEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_TraceEnabled(
    VARIANT_BOOL  val
);

Remarks

A new file is generated each time the driver is initialized. You may specify the trace file name using 'TraceName=' the 'DriverSetup=' option string parameter to the Initialize() method. For example: 'DriverSetup= TraceName=TraceOutput'

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


WaitForOperationComplete Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem..::.WaitForOperationComplete Method
IAgInfiniiVisionSystem See Also

Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub WaitForOperationComplete ( _
    ByVal  MaxTimeMilliseconds As Integer  _
)
C#
public void  WaitForOperationComplete(
    int  MaxTimeMilliseconds
)
Visual C++
HRESULT WaitForOperationComplete(
    long  MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds

How long to wait, in milliseconds, for all the operations started in the instrument to complete.

Instrument Command

*OPC?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem Interface
Agilent.AgInfiniiVision.Interop Namespace


System2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.System2 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionSystem interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property System2 As IAgInfiniiVisionSystem2
C#
public IAgInfiniiVisionSystem2  System2 { get; }
Visual C++
HRESULT get_System2(
    IAgInfiniiVisionSystem2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


ClearIO Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.ClearIO Method
IAgInfiniiVisionSystem2 See Also

Performs an IEEE 488.1-style clear of the device.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ClearIO ( _
)
C#
public void  ClearIO(
)
Visual C++
HRESULT ClearIO(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


ReadBytes Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.ReadBytes Method
IAgInfiniiVisionSystem2 See Also

Reads a complete response from the instrument and returns it as an array of bytes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function ReadBytes ( _
) As Byte()
C#
public byte[]   ReadBytes(
)
Visual C++
HRESULT ReadBytes(
    SAFEARRAY**  retval
);

Return Value

An array of bytes returned from the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


ReadString Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.ReadString Method
IAgInfiniiVisionSystem2 See Also

Reads a complete response from the instrument and returns it as a string.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function ReadString ( _
) As String
C#
public string  ReadString(
)
Visual C++
HRESULT ReadString(
    BSTR*  retval
);

Return Value

A string returned from the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


TouchScreenEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.TouchScreenEnabled Property
IAgInfiniiVisionSystem2 See Also

Disables or enables the touchscreen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TouchScreenEnabled As Boolean
C#
public bool  TouchScreenEnabled { get; set; }
Visual C++
HRESULT get_TouchScreenEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_TouchScreenEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:SYSTem:TOUCh {ON|OFF}
:SYSTem:TOUCh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


WriteBytes Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.WriteBytes Method
IAgInfiniiVisionSystem2 See Also

Write an array of bytes to the device.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub WriteBytes ( _
    ByVal  Buffer As Byte()   _
)
C#
public void  WriteBytes(
    byte[]   Buffer
)
Visual C++
HRESULT WriteBytes(
    SAFEARRAY**  Buffer
);

Parameters

Buffer

The array of bytes to be written to the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


WriteString Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2..::.WriteString Method
IAgInfiniiVisionSystem2 See Also

Write a string to the device.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub WriteString ( _
    ByVal  Data As String  _
)
C#
public void  WriteString(
    string  Data
)
Visual C++
HRESULT WriteString(
    BSTR  Data
);

Parameters

Data

String to the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem2 Interface
Agilent.AgInfiniiVision.Interop Namespace


System3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4..::.System3 Property
IAgInfiniiVision4 See Also

Pointer to the IAgInfiniiVisionSystem interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property System3 As IAgInfiniiVisionSystem3
C#
public IAgInfiniiVisionSystem3  System3 { get; }
Visual C++
HRESULT get_System3(
    IAgInfiniiVisionSystem3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Precision Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem3..::.Precision Property
IAgInfiniiVisionSystem3 See Also

Pointer to the IAgInfiniiVisionSystem3Precision interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Precision As IAgInfiniiVisionSystem3Precision
C#
public IAgInfiniiVisionSystem3Precision  Precision { get; }
Visual C++
HRESULT get_Precision(
    IAgInfiniiVisionSystem3Precision**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem3Precision..::.Enabled Property
IAgInfiniiVisionSystem3Precision See Also

Enables or disables the oscilloscope's precision analysis setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • When set to false provides the maximum oscilloscope waveform update rate by performing measurements and math functions on the default 65535-point (maximum) measurement record.
  • When set to true then at the expense of oscilloscope waveform update rate, this setting allows measurements and math functions to be performed on a longer, precision analysis record.
  • Preset value is false.

    • Precision analysis is not available when:
    • Realtime sampling mode is off.
    • Averaging acquisition modes is selected.
    • XY or Roll time modes are selected.

    Instrument Command

    :SYSTem:PRECision {1|0}
    :SYSTem:PRECision?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSystem3Precision Interface
    Agilent.AgInfiniiVision.Interop Namespace


RecordLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem3Precision..::.RecordLength Property
IAgInfiniiVisionSystem3Precision See Also

The length of the precision analysis record (when precision measurements and math functions mode is enabled).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RecordLength As Integer
C#
public int  RecordLength { get; set; }
Visual C++
HRESULT get_RecordLength(
    long*  val
);
HRESULT put_RecordLength(
    long  val
);

Remarks

  • Input range is from 100k to 1M points.
  • Preset value is 200000 points.

    • Instrument Command

    :SYSTem:PRECision:LENGth {value}
    :SYSTem:PRECision:LENGth?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionSystem3Precision Interface
    Agilent.AgInfiniiVision.Interop Namespace


System4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.System4 Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVisionSystem interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property System4 As IAgInfiniiVisionSystem4
C#
public IAgInfiniiVisionSystem4  System4 { get; }
Visual C++
HRESULT get_System4(
    IAgInfiniiVisionSystem4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


IOTimeout Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem4..::.IOTimeout Property
IAgInfiniiVisionSystem4 See Also

The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property IOTimeout As Integer
C#
public int  IOTimeout { get; set; }
Visual C++
HRESULT get_IOTimeout(
    long*  val
);
HRESULT put_IOTimeout(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem4 Interface
Agilent.AgInfiniiVision.Interop Namespace


ReadBytes2 Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem4..::.ReadBytes2 Method
IAgInfiniiVisionSystem4 See Also

Reads a complete response from the instrument and returns it as an array of bytes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function ReadBytes2 ( _
) As Byte()
C#
public byte[]   ReadBytes2(
)
Visual C++
HRESULT ReadBytes2(
    SAFEARRAY**  retval
);

Return Value

An array allocated by the method to hold the bytes returned by the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem4 Interface
Agilent.AgInfiniiVision.Interop Namespace


WriteBytes2 Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem4..::.WriteBytes2 Method
IAgInfiniiVisionSystem4 See Also

Write an array of bytes to the device.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function WriteBytes2 ( _
    ByVal  Buffer As Byte()   _
) As Long
C#
public long  WriteBytes2(
    byte[]   Buffer
)
Visual C++
HRESULT WriteBytes2(
    SAFEARRAY**  Buffer
    __int64*  retval
);

Parameters

Buffer

The array of bytes to be written to the device.

Return Value

The number of bytes actually written.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem4 Interface
Agilent.AgInfiniiVision.Interop Namespace


WriteString2 Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem4..::.WriteString2 Method
IAgInfiniiVisionSystem4 See Also

Write a string to the device.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub WriteString2 ( _
    ByVal  Data As String  _
)
C#
public void  WriteString2(
    string  Data
)
Visual C++
HRESULT WriteString2(
    BSTR  Data
);

Parameters

Data

The string to be written to the device.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionSystem4 Interface
Agilent.AgInfiniiVision.Interop Namespace


Timebase Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Timebase Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionTimebase interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Timebase As IAgInfiniiVisionTimebase
C#
public IAgInfiniiVisionTimebase  Timebase { get; }
Visual C++
HRESULT get_Timebase(
    IAgInfiniiVisionTimebase**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalScale Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase..::.HorizontalScale Property
IAgInfiniiVisionTimebase See Also

Horizontal scale or seconds per division for the main window.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalScale As Double
C#
public double  HorizontalScale { get; set; }
Visual C++
HRESULT get_HorizontalScale(
    double*  val
);
HRESULT put_HorizontalScale(
    double  val
);

Instrument Command

:TIMebase:SCALe {value}
:TIMebase:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebase Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase..::.Mode Property
IAgInfiniiVisionTimebase See Also

Current time base mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionTimebaseModeEnum
C#
public AgInfiniiVisionTimebaseModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionTimebaseModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionTimebaseModeEnum  val
);

Instrument Command

:TIMebase:MODE {MAIN|WIND|XY|ROLL}
:TIMebase:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebase Interface
Agilent.AgInfiniiVision.Interop Namespace


TimeReference Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase..::.TimeReference Property
IAgInfiniiVisionTimebase See Also

Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeReference As AgInfiniiVisionTimebaseReferenceEnum
C#
public AgInfiniiVisionTimebaseReferenceEnum  TimeReference { get; set; }
Visual C++
HRESULT get_TimeReference(
    AgInfiniiVisionTimebaseReferenceEnum*  val
);
HRESULT put_TimeReference(
    AgInfiniiVisionTimebaseReferenceEnum  val
);

Remarks

This affects the trigger point on the display, and does affect IAgInfiniiVisionAcquisition.StartTime, as StartTime() always refers to the left-edge of the screen.

Instrument Command

:TIMebase:REFerence {LEFT|CENT|RIGH}
:TIMebase:REFerence?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebase Interface
Agilent.AgInfiniiVision.Interop Namespace


VernierEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase..::.VernierEnabled Property
IAgInfiniiVisionTimebase See Also

Time base control's vernier.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property VernierEnabled As Boolean
C#
public bool  VernierEnabled { get; set; }
Visual C++
HRESULT get_VernierEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_VernierEnabled(
    VARIANT_BOOL  val
);

Instrument Command

:TIMebase:VERNier {ON|OFF}
:TIMebase:VERNier?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebase Interface
Agilent.AgInfiniiVision.Interop Namespace


Window Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase..::.Window Property
IAgInfiniiVisionTimebase See Also

Pointer to the IAgInfiniiVisionTimebaseWindow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Window As IAgInfiniiVisionTimebaseWindow
C#
public IAgInfiniiVisionTimebaseWindow  Window { get; }
Visual C++
HRESULT get_Window(
    IAgInfiniiVisionTimebaseWindow**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebase Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalPosition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebaseWindow..::.HorizontalPosition Property
IAgInfiniiVisionTimebaseWindow See Also

Horizontal window position in the zoomed view of the main sweep.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalPosition As Double
C#
public double  HorizontalPosition { get; set; }
Visual C++
HRESULT get_HorizontalPosition(
    double*  val
);
HRESULT put_HorizontalPosition(
    double  val
);

Instrument Command

:TIMebase:WINDow:POSition {value}
:TIMebase:WINDow:POSition?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebaseWindow Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalScale Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebaseWindow..::.HorizontalScale Property
IAgInfiniiVisionTimebaseWindow See Also

Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalScale As Double
C#
public double  HorizontalScale { get; set; }
Visual C++
HRESULT get_HorizontalScale(
    double*  val
);
HRESULT put_HorizontalScale(
    double  val
);

Instrument Command

:TIMebase:WINDow:SCALe {value}
:TIMebase:WINDow:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebaseWindow Interface
Agilent.AgInfiniiVision.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebaseWindow..::.Range Property
IAgInfiniiVisionTimebaseWindow See Also

Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Instrument Command

:TIMebase:WINDow:RANGe {value}
:TIMebase:WINDow:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTimebaseWindow Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Trigger Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionTrigger interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IAgInfiniiVisionTrigger
C#
public IAgInfiniiVisionTrigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IAgInfiniiVisionTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


AcLine Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.AcLine Property
IAgInfiniiVisionTrigger See Also

Pointer to the IAgInfiniiVisionTriggerAcLine interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AcLine As IAgInfiniiVisionTriggerAcLine
C#
public IAgInfiniiVisionTriggerAcLine  AcLine { get; }
Visual C++
HRESULT get_AcLine(
    IAgInfiniiVisionTriggerAcLine**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerAcLine..::.Slope Property
IAgInfiniiVisionTriggerAcLine See Also

The slope of the zero crossing upon which the scope triggers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionACLineSlopeEnum
C#
public AgInfiniiVisionACLineSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionACLineSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionACLineSlopeEnum  val
);

Instrument Command

:TRIGger[:EDGE]:SLOPe {POS|NEG}
:TRIGger[:EDGE]:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionTriggerAcLine Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Configure Method
IAgInfiniiVisionTrigger See Also

Configures trigger Type and Holdoff. Holdoff units are seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Type As AgInfiniiVisionTriggerTypeEnum  _
    ByVal  Holdoff As Double  _
)
C#
public void  Configure(
    AgInfiniiVisionTriggerTypeEnum  Type,
    double  Holdoff
)
Visual C++
HRESULT Configure(
    AgInfiniiVisionTriggerTypeEnum  Type,
    double  Holdoff
);

Parameters

Type

Specifies the trigger type. This value sets the Trigger Type property.

Holdoff

Specifies the trigger hold-off. This value sets the Trigger Holdoff property.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Continuous Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Continuous Property
IAgInfiniiVisionTrigger See Also

If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Continuous As Boolean
C#
public bool  Continuous { get; set; }
Visual C++
HRESULT get_Continuous(
    VARIANT_BOOL*  val
);
HRESULT put_Continuous(
    VARIANT_BOOL  val
);

Instrument Command

:RUN |:STOP
:OPERation:CONDition?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Coupling Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Coupling Property
IAgInfiniiVisionTrigger See Also

How the oscilloscope couples the trigger source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As AgInfiniiVisionTriggerCouplingEnum
C#
public AgInfiniiVisionTriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    AgInfiniiVisionTriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    AgInfiniiVisionTriggerCouplingEnum  val
);

Instrument Command

:TRIGger[:EDGE]:COUPling {AC|DC|HFR|LFR|NREJ|TV}
:TRIGger[:EDGE]:COUPling?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Edge Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Edge Property
IAgInfiniiVisionTrigger See Also

Pointer to the class-compliant IIviScopeTriggerEdge interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IAgInfiniiVisionTriggerEdge
C#
public IAgInfiniiVisionTriggerEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IAgInfiniiVisionTriggerEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerEdge..::.Configure Method
IAgInfiniiVisionTriggerEdge See Also

Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Slope As AgInfiniiVisionTriggerSlopeEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    AgInfiniiVisionTriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    AgInfiniiVisionTriggerSlopeEnum  Slope
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Slope

Specifies the trigger slope. This value sets the Trigger Slope property.

Remarks

If trigger source is VAL_LINE or VAL_WGEN, then Level parameter is ignored. Also, if trigger source is VAL_LINE and slope is either AgInfiniiVisionTriggerSlopeAlternate or AgInfiniiVisionTriggerSlopeAlternate, then Slope parameter is ignored. Similarly if trigger source is VAL_WGEN and slope is any of AgInfiniiVisionTriggerSlopeNegative, AgInfiniiVisionTriggerSlopeAlternate, AgInfiniiVisionTriggerSlopeAlternate, then Slope parameter is ignored.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


RejectFilterType Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerEdge..::.RejectFilterType Property
IAgInfiniiVisionTriggerEdge See Also

Enable the type of reject filter.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RejectFilterType As AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum
C#
public AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum  RejectFilterType { get; set; }
Visual C++
HRESULT get_RejectFilterType(
    AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum*  val
);
HRESULT put_RejectFilterType(
    AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum  val
);

Instrument Command

:TRIGger[:EDGE]:REJect {HFR|LFR|OFF}
:TRIGger[:EDGE]:REJect?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerEdge..::.Slope Property
IAgInfiniiVisionTriggerEdge See Also

The slope, a rising or a falling edge, that triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionTriggerSlopeEnum
C#
public AgInfiniiVisionTriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionTriggerSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionTriggerSlopeEnum  val
);

Instrument Command

:TRIGger[:EDGE]:SLOPe {POS|NEG|EITH|ALT}
:TRIGger[:EDGE]:SLOPe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerEdge Interface
Agilent.AgInfiniiVision.Interop Namespace


Glitch Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Glitch Property
IAgInfiniiVisionTrigger See Also

Pointer to the class-compliant IIviScopeTriggerGlitch interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IAgInfiniiVisionTriggerGlitch
C#
public IAgInfiniiVisionTriggerGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IAgInfiniiVisionTriggerGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.Condition Property
IAgInfiniiVisionTriggerGlitch See Also

Glitch condition determines whether it glitches less than or greater than the specified duration.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionGlitchConditionEnum
C#
public AgInfiniiVisionGlitchConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionGlitchConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionGlitchConditionEnum  val
);

Instrument Command

:TRIGger:GLITch:QUALifier {LESS|GRE|RANG}
:TRIGger:GLITch:QUALifier?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.Configure Method
IAgInfiniiVisionTriggerGlitch See Also

Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Width As Double  _
    ByVal  Polarity As AgInfiniiVisionGlitchPolarityEnum  _
    ByVal  Condition As AgInfiniiVisionGlitchConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  Width,
    AgInfiniiVisionGlitchPolarityEnum  Polarity,
    AgInfiniiVisionGlitchConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  Width,
    AgInfiniiVisionGlitchPolarityEnum  Polarity,
    AgInfiniiVisionGlitchConditionEnum  Condition
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Width

Specifies the glitch triggering glitch width in seconds.

Polarity

Specifies the glitch polarity. This value sets the Glitch Polarity property.

Condition

Specifies the glitch condition. This value sets the Glitch Condition property.

Remarks

Note: Trigger.Type should be set to AgInfiniiVisionTriggerTypeGlitch before executing this method.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


GetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.GetRange Method
IAgInfiniiVisionTriggerGlitch See Also

READ ONLY- Gets the pulse width duration time for trigger source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetRange ( _
    ByRef  LowerLimit As Double  _
    ByRef  UpperLimit As Double  _
)
C#
public void  GetRange(
    ref double  LowerLimit,
    ref double  UpperLimit
)
Visual C++
HRESULT GetRange(
    double*  LowerLimit,
    double*  UpperLimit
);

Parameters

LowerLimit

LowerLimit

UpperLimit

UpperLimit

Instrument Command

:TRIGger:GLITch:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Level Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.Level Property
IAgInfiniiVisionTriggerGlitch See Also

Trigger level voltage for the active pulse width trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Instrument Command

:TRIGger:GLITch:LEVel {value}
:TRIGger:GLITch:LEVel?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.Polarity Property
IAgInfiniiVisionTriggerGlitch See Also

The polarity of the glitch that triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionGlitchPolarityEnum
C#
public AgInfiniiVisionGlitchPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionGlitchPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionGlitchPolarityEnum  val
);

Instrument Command

:TRIGger:GLITch:POLarity {POS|NEG}
:TRIGger:GLITch:POLarity?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


SetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.SetRange Method
IAgInfiniiVisionTriggerGlitch See Also

Pulse width duration for the selected source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetRange ( _
    ByVal  LowerLimit As Double  _
    ByVal  UpperLimit As Double  _
)
C#
public void  SetRange(
    double  LowerLimit,
    double  UpperLimit
)
Visual C++
HRESULT SetRange(
    double  LowerLimit,
    double  UpperLimit
);

Parameters

LowerLimit

LowerLimit. Permissible values are from 10 ns to 9.99 seconds

UpperLimit

UpperLimit. Permissible values are from 15 ns to 10 seconds

Remarks

You can enter the parameters in any order,the smaller value becomes the greater than time and the larger value becomes the less than time.

Instrument Command

:TRIGger:GLITch:RANGe {LowerLimit}, {UpperLimit}

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch..::.Width Property
IAgInfiniiVisionTriggerGlitch See Also

Pulse width duration for the selected source. The units are seconds. Set condition to either GreaterThan or LessThan, prior to setting Width.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Width As Double
C#
public double  Width { get; set; }
Visual C++
HRESULT get_Width(
    double*  val
);
HRESULT put_Width(
    double  val
);

Instrument Command

:TRIGger:GLITch:LESSthan {value}|:TRIGger:GLITch:GREaterthan {value}
:TRIGger:GLITch:LESSthan? |:TRIGger:GLITch:GREaterthan?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerGlitch Interface
Agilent.AgInfiniiVision.Interop Namespace


HFRejectFilterEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.HFRejectFilterEnabled Property
IAgInfiniiVisionTrigger See Also

The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HFRejectFilterEnabled As Boolean
C#
public bool  HFRejectFilterEnabled { get; set; }
Visual C++
HRESULT get_HFRejectFilterEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_HFRejectFilterEnabled(
    VARIANT_BOOL  val
);

Remarks

Use this filter to remove high-frequency noise, such as AM or FM broadcast stations, from the trigger path. This property is not valid in TV trigger mode

Instrument Command

:TRIGger:HFReject {ON|OFF}
:TRIGger:HFReject?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Holdoff Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Holdoff Property
IAgInfiniiVisionTrigger See Also

The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Holdoff As Double
C#
public double  Holdoff { get; set; }
Visual C++
HRESULT get_Holdoff(
    double*  val
);
HRESULT put_Holdoff(
    double  val
);

Instrument Command

:TRIGger:HOLDoff {value}
:TRIGger:HOLDoff?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Level Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Level Property
IAgInfiniiVisionTrigger See Also

Voltage threshold for the trigger subsystem. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Instrument Command

:TRIGger[:EDGE]:LEVel {value}
:TRIGger[:EDGE]:LEVel?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Modifier Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Modifier Property
IAgInfiniiVisionTrigger See Also

Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Modifier As AgInfiniiVisionTriggerModifierEnum
C#
public AgInfiniiVisionTriggerModifierEnum  Modifier { get; set; }
Visual C++
HRESULT get_Modifier(
    AgInfiniiVisionTriggerModifierEnum*  val
);
HRESULT put_Modifier(
    AgInfiniiVisionTriggerModifierEnum  val
);

Instrument Command

:TRIGger:SWEep {NORM|AUTO}
:TRIGger:SWEep?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


NoiseRejectFilterEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.NoiseRejectFilterEnabled Property
IAgInfiniiVisionTrigger See Also

Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NoiseRejectFilterEnabled As Boolean
C#
public bool  NoiseRejectFilterEnabled { get; set; }
Visual C++
HRESULT get_NoiseRejectFilterEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_NoiseRejectFilterEnabled(
    VARIANT_BOOL  val
);

Remarks

This property is not valid in TV trigger mode.

Instrument Command

:TRIGger:NREJect {ON|OFF}
:TRIGger:NREJect?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Pattern Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Pattern Property
IAgInfiniiVisionTrigger See Also

Pointer to the IAgInfiniiVisionTriggerPattern interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Pattern As IAgInfiniiVisionTriggerPattern
C#
public IAgInfiniiVisionTriggerPattern  Pattern { get; }
Visual C++
HRESULT get_Pattern(
    IAgInfiniiVisionTriggerPattern**  val
);

Remarks

AnalogMask and DigitalMask of 546xx agilent driver is removed since Analog Pattern and Digital Pattern covers the functionality of it.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


AnalogPattern Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.AnalogPattern Property
IAgInfiniiVisionTriggerPattern See Also

The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AnalogPattern As String
C#
public string  AnalogPattern { get; set; }
Visual C++
HRESULT get_AnalogPattern(
    BSTR*  val
);
HRESULT put_AnalogPattern(
    BSTR  val
);

Remarks

For Example if input string is "01010101XXXXXXX" and the model has 4 analog channels only "01010" will be accepted.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.Condition Property
IAgInfiniiVisionTriggerPattern See Also

The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionPatternMatchingModeEnum
C#
public AgInfiniiVisionPatternMatchingModeEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionPatternMatchingModeEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionPatternMatchingModeEnum  val
);

Remarks

Only ENTER condition is supported in 2000X Series

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.Configure Method
IAgInfiniiVisionTriggerPattern See Also

Configures the pattern trigger

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  AnalogPattern As String  _
    ByVal  DigitalPattern As String  _
    ByVal  Condition As AgInfiniiVisionPatternMatchingModeEnum  _
)
C#
public void  Configure(
    string  AnalogPattern,
    string  DigitalPattern,
    AgInfiniiVisionPatternMatchingModeEnum  Condition
)
Visual C++
HRESULT Configure(
    BSTR  AnalogPattern,
    BSTR  DigitalPattern,
    AgInfiniiVisionPatternMatchingModeEnum  Condition
);

Parameters

AnalogPattern

The analog channel pattern.

DigitalPattern

The digital channel pattern. This parameter will only be taken into account when MSO is licensed.

Condition

The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


DigitalPattern Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.DigitalPattern Property
IAgInfiniiVisionTriggerPattern See Also

The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DigitalPattern As String
C#
public string  DigitalPattern { get; set; }
Visual C++
HRESULT get_DigitalPattern(
    BSTR*  val
);
HRESULT put_DigitalPattern(
    BSTR  val
);

Remarks

For Example if input string is "01010101XXXXXXX" and the model has 8 digital channels only "01010101" will be accepted.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


GetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.GetRange Method
IAgInfiniiVisionTriggerPattern See Also

Returns the duration time for the defined pattern.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetRange ( _
    ByRef  LessThanTime As Double  _
    ByRef  GreaterThanTime As Double  _
)
C#
public void  GetRange(
    ref double  LessThanTime,
    ref double  GreaterThanTime
)
Visual C++
HRESULT GetRange(
    double*  LessThanTime,
    double*  GreaterThanTime
);

Parameters

LessThanTime

Less than time.

GreaterThanTime

Greater than time.

Instrument Command

:TRIGger:PATTern:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


MaxDuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.MaxDuration Property
IAgInfiniiVisionTriggerPattern See Also

Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MaxDuration As Double
C#
public double  MaxDuration { get; set; }
Visual C++
HRESULT get_MaxDuration(
    double*  val
);
HRESULT put_MaxDuration(
    double  val
);

Instrument Command

:TRIGger:PATTern:LESSthan {value}
:TRIGger:PATTern:LESSthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


MinDuration Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.MinDuration Property
IAgInfiniiVisionTriggerPattern See Also

Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MinDuration As Double
C#
public double  MinDuration { get; set; }
Visual C++
HRESULT get_MinDuration(
    double*  val
);
HRESULT put_MinDuration(
    double  val
);

Instrument Command

:TRIGger:PATTern:GREaterthan {value}
:TRIGger:PATTern:GREaterthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


SetRange Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern..::.SetRange Method
IAgInfiniiVisionTriggerPattern See Also

Duration for the defined pattern when the pattern condition is set to INRange or OUTRange

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetRange ( _
    ByVal  LessThanTime As Double  _
    ByVal  GreaterThanTime As Double  _
)
C#
public void  SetRange(
    double  LessThanTime,
    double  GreaterThanTime
)
Visual C++
HRESULT SetRange(
    double  LessThanTime,
    double  GreaterThanTime
);

Parameters

LessThanTime

Less than time. Permissible values are from 10ns to 9.99 seconds.

GreaterThanTime

Greater than time.. Permissible values are from 15ns to 10 seconds

Remarks

You can enter the parameters in any order,the smaller value becomes the greater than time, and the larger value becomes the less than time.

Instrument Command

:TRIGger:PATTern:RANGe {LessThanTime},{GreaterThanTime}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerPattern Interface
Agilent.AgInfiniiVision.Interop Namespace


Runt Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Runt Property
IAgInfiniiVisionTrigger See Also

Pointer to the class-compliant IIviScopeTriggerRunt interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IAgInfiniiVisionTriggerRunt
C#
public IAgInfiniiVisionTriggerRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IAgInfiniiVisionTriggerRunt**  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.Condition Property
IAgInfiniiVisionTriggerRunt See Also

Condition used for specifying runt pulse widths.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionTriggerRuntConditionEnum
C#
public AgInfiniiVisionTriggerRuntConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionTriggerRuntConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionTriggerRuntConditionEnum  val
);

Instrument Command

:TRIGger:RUNT:QUALifier {NONE|LESS|GRE}
:TRIGger:RUNT:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.Configure Method
IAgInfiniiVisionTriggerRunt See Also

Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As AgInfiniiVisionRuntPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    AgInfiniiVisionRuntPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    AgInfiniiVisionRuntPolarityEnum  Polarity
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

Polarity

Sets the runt polarity.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.Polarity Property
IAgInfiniiVisionTriggerRunt See Also

The polarity of the runt that triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionRuntPolarityEnum
C#
public AgInfiniiVisionRuntPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionRuntPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionRuntPolarityEnum  val
);

Instrument Command

:TRIGger:RUNT:POLarity {POS|NEG|EITH}
:TRIGger:RUNT:POLarity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


QualifierTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.QualifierTime Property
IAgInfiniiVisionTriggerRunt See Also

Time used for triggering on runt pulses whose width is greater than or less than the specified time value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property QualifierTime As Double
C#
public double  QualifierTime { get; set; }
Visual C++
HRESULT get_QualifierTime(
    double*  val
);
HRESULT put_QualifierTime(
    double  val
);

Instrument Command

:TRIGger:RUNT:TIME {value}
:TRIGger:RUNT:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.ThresholdHigh Property
IAgInfiniiVisionTriggerRunt See Also

The high threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt..::.ThresholdLow Property
IAgInfiniiVisionTriggerRunt See Also

The low threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerRunt Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Source Property
IAgInfiniiVisionTrigger See Also

Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

Sources are accepted only in this standard notation: Channel<n> | VAL_EXTERNAL | VAL_LINE | DigitalChannel<n>| VAL_WGEN | VAL_WGEN2 | VAL_WMOD, where n is number of supported analog or digital channel.

Instrument Command

:TRIGger[:EDGE]:SOURce {value}
:TRIGger[:EDGE]:SOURce?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


TV Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.TV Property
IAgInfiniiVisionTrigger See Also

Pointer to the IAgInfiniiVisionTriggerTV interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IAgInfiniiVisionTriggerTV
C#
public IAgInfiniiVisionTriggerTV  TV { get; }
Visual C++
HRESULT get_TV(
    IAgInfiniiVisionTriggerTV**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV..::.Configure Method
IAgInfiniiVisionTriggerTV See Also

Configures the TV Trigger parameters.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  SignalFormat As AgInfiniiVisionTVSignalFormatEnum  _
    ByVal  Event As AgInfiniiVisionTVTriggerEventEnum  _
    ByVal  Polarity As AgInfiniiVisionTVTriggerPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionTVSignalFormatEnum  SignalFormat,
    AgInfiniiVisionTVTriggerEventEnum  Event,
    AgInfiniiVisionTVTriggerPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionTVSignalFormatEnum  SignalFormat,
    AgInfiniiVisionTVTriggerEventEnum  Event,
    AgInfiniiVisionTVTriggerPolarityEnum  Polarity
);

Parameters

Source

The source the oscilloscope monitors for the trigger event.

SignalFormat

The format of TV signal on which the oscilloscope triggers.

Event

The event on which the oscilloscope triggers in TV Trigger mode.

Polarity

The polarity of the TV signal.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV Interface
Agilent.AgInfiniiVision.Interop Namespace


Event Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV..::.Event Property
IAgInfiniiVisionTriggerTV See Also

The TV trigger mode and field.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Event As AgInfiniiVisionTVTriggerEventEnum
C#
public AgInfiniiVisionTVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    AgInfiniiVisionTVTriggerEventEnum*  val
);
HRESULT put_Event(
    AgInfiniiVisionTVTriggerEventEnum  val
);

Remarks

The LVERtical parameter is only available when signal format is GENeric. The LALTernate parameter is not available when signal format GENeric.

Instrument Command

:TRIGger:TV:MODE {FIE1|FIE2|AFI|ALIN|LINE|LALT|LVER|VERT}
:TRIGger:TV:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV Interface
Agilent.AgInfiniiVision.Interop Namespace


LineNumber Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV..::.LineNumber Property
IAgInfiniiVisionTriggerTV See Also

The Line number which allows triggering on a specific line of video. The line number limit varies with the signal format and event.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Instrument Command

:TRIGger:TV:LINE {value}
:TRIGger:TV:LINE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV..::.Polarity Property
IAgInfiniiVisionTriggerTV See Also

The polarity of the TV that triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionTVTriggerPolarityEnum
C#
public AgInfiniiVisionTVTriggerPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionTVTriggerPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionTVTriggerPolarityEnum  val
);

Instrument Command

:TRIGger:TV:POLarity {POS|NEG}
:TRIGger:TV:POLarity?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV Interface
Agilent.AgInfiniiVision.Interop Namespace


SignalFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV..::.SignalFormat Property
IAgInfiniiVisionTriggerTV See Also

The format of TV signal on which the oscilloscope triggers. Currently, only NTSC, PAL, PAL-M and SECAM are supported.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As AgInfiniiVisionTVSignalFormatEnum
C#
public AgInfiniiVisionTVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    AgInfiniiVisionTVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    AgInfiniiVisionTVSignalFormatEnum  val
);

Instrument Command

:TRIGger:TV:STANdard {NTSC|PAL|SEC|PALM|GEN|P480L60HZ|I1080L50HZ|P720L60HZ|P1080L24HZ|P1080L25HZ|P1080L50HZ|P1080L60HZ|I1080L60HZ}
:TRIGger:TV:STANdard?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV Interface
Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Type Property
IAgInfiniiVisionTrigger See Also

The kind of event that triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionTriggerTypeEnum
C#
public AgInfiniiVisionTriggerTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionTriggerTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionTriggerTypeEnum  val
);

Remarks

If the timebase mode is ROLL or XY, the query returns "NONE".

AgInfiniiVisionTriggerTypeUSB: For 4000X and 6000X, use the IAgInfiniiVision2SerialBus2.USB interface in conjunction with AgInfiniiVisionTriggerTypeSerialBus1 or AgInfiniiVisionTriggerTypeSerialBus2 (depending on your selection) for complete USB triggering setup.

Note:1. AgInfiniiVisionTriggerTypeUSB: It is not supported by 1000X, 2000X and M924x models.

2. AgInfiniiVisionTriggerTypeWidth: It is not supported by 1000X, 2000X models.

3. AgInfiniiVisionTriggerTypeRunt: It is not supported by 1000X, 2000X models.

4. AgInfiniiVisionTriggerTypeDelay: It is not supported by 1000X, 2000X models.

Instrument Command

:TRIGger:MODE {EDGE|PATT|RUNT|GLIT|TV|ACL|PATT|DEL|EBUR|SHOL|TRAN|SBUS1|SBUS2|USB|NONE|OR}
:TRIGger:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger..::.Width Property
IAgInfiniiVisionTrigger See Also

Pointer to the IAgInfiniiVisionTriggerWidth interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Width As IAgInfiniiVisionTriggerWidth
C#
public IAgInfiniiVisionTriggerWidth  Width { get; }
Visual C++
HRESULT get_Width(
    IAgInfiniiVisionTriggerWidth**  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth..::.Condition Property
IAgInfiniiVisionTriggerWidth See Also

Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionWidthConditionEnum
C#
public AgInfiniiVisionWidthConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionWidthConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionWidthConditionEnum  val
);

Instrument Command

:TRIGger:PATTern:QUALifier {INR|OUTR}
:TRIGger:PATTern:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerWidth Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth..::.Configure Method
IAgInfiniiVisionTriggerWidth See Also

Configures the width trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As AgInfiniiVisionWidthPolarityEnum  _
    ByVal  Condition As AgInfiniiVisionWidthConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    AgInfiniiVisionWidthPolarityEnum  Polarity,
    AgInfiniiVisionWidthConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    AgInfiniiVisionWidthPolarityEnum  Polarity,
    AgInfiniiVisionWidthConditionEnum  Condition
);

Parameters

Source

The source the trigger monitors for a trigger event.

Level

The voltage threshold for the trigger sub-system.

ThresholdLow

The low width threshold time in seconds.

ThresholdHigh

The high width threshold time in seconds.

Polarity

The polarity of the pulse that triggers the oscilloscope.

Condition

Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerWidth Interface
Agilent.AgInfiniiVision.Interop Namespace


Polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth..::.Polarity Property
IAgInfiniiVisionTriggerWidth See Also

The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgInfiniiVisionWidthPolarityEnum
C#
public AgInfiniiVisionWidthPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgInfiniiVisionWidthPolarityEnum*  val
);
HRESULT put_Polarity(
    AgInfiniiVisionWidthPolarityEnum  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerWidth Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth..::.ThresholdHigh Property
IAgInfiniiVisionTriggerWidth See Also

The high width threshold time in seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerWidth Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth..::.ThresholdLow Property
IAgInfiniiVisionTriggerWidth See Also

The low width threshold time in seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerWidth Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.Trigger2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionTrigger2 interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger2 As IAgInfiniiVisionTrigger2
C#
public IAgInfiniiVisionTrigger2  Trigger2 { get; }
Visual C++
HRESULT get_Trigger2(
    IAgInfiniiVisionTrigger2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Delay Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.Delay Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTrigger2Delay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Delay As IAgInfiniiVisionTrigger2Delay
C#
public IAgInfiniiVisionTrigger2Delay  Delay { get; }
Visual C++
HRESULT get_Delay(
    IAgInfiniiVisionTrigger2Delay**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


ArmingSlope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.ArmingSlope Property
IAgInfiniiVisionTrigger2Delay See Also

Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ArmingSlope As AgInfiniiVisionTriggerDelaySlopeEnum
C#
public AgInfiniiVisionTriggerDelaySlopeEnum  ArmingSlope { get; set; }
Visual C++
HRESULT get_ArmingSlope(
    AgInfiniiVisionTriggerDelaySlopeEnum*  val
);
HRESULT put_ArmingSlope(
    AgInfiniiVisionTriggerDelaySlopeEnum  val
);

Remarks

The ArmingSlope property can be set to one of the following values:

  • AgInfiniiVisionTriggerDelaySlopeNegative - specifies falling (Negative) for the arming edge in the Edge Then Edge trigger
  • AgInfiniiVisionTriggerDelaySlopePositive - specifies rising (Positive) for the arming edge in the Edge Then Edge trigger

Instrument Command

:TRIGger:DELay:ARM:SLOPe {NEG|POS}
:TRIGger:DELay:ARM:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


ArmingSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.ArmingSource Property
IAgInfiniiVisionTrigger2Delay See Also

Selects the input used for the arming edge in the Edge Then Edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ArmingSource As String
C#
public string  ArmingSource { get; set; }
Visual C++
HRESULT get_ArmingSource(
    BSTR*  val
);
HRESULT put_ArmingSource(
    BSTR  val
);

Remarks

The ArmingSource property can be specified in one the following string formats:

  • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:DELay:ARM:SOURce {value}
:TRIGger:DELay:ARM:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.Configure Method
IAgInfiniiVisionTrigger2Delay See Also

Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  TriggerSource As String  _
    ByVal  TriggerSlope As AgInfiniiVisionTriggerDelaySlopeEnum  _
    ByVal  EdgeCount As Integer  _
    ByVal  ArmingSource As String  _
    ByVal  ArmingSlope As AgInfiniiVisionTriggerDelaySlopeEnum  _
    ByVal  DelayTime As Double  _
)
C#
public void  Configure(
    string  TriggerSource,
    AgInfiniiVisionTriggerDelaySlopeEnum  TriggerSlope,
    int  EdgeCount,
    string  ArmingSource,
    AgInfiniiVisionTriggerDelaySlopeEnum  ArmingSlope,
    double  DelayTime
)
Visual C++
HRESULT Configure(
    BSTR  TriggerSource,
    AgInfiniiVisionTriggerDelaySlopeEnum  TriggerSlope,
    long  EdgeCount,
    BSTR  ArmingSource,
    AgInfiniiVisionTriggerDelaySlopeEnum  ArmingSlope,
    double  DelayTime
);

Parameters

TriggerSource

Specifies the input used for the trigger edge in the Edge Then Edge trigger.

TriggerSlope

Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.

EdgeCount

Sets the Nth edge of the trigger source to trigger on

ArmingSource

Selects the input used for the arming edge in the Edge Then Edge trigger.

ArmingSlope

Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.

DelayTime

Sets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


EdgeCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.EdgeCount Property
IAgInfiniiVisionTrigger2Delay See Also

Sets/Gets the Nth edge of the trigger source to trigger on

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property EdgeCount As Integer
C#
public int  EdgeCount { get; set; }
Visual C++
HRESULT get_EdgeCount(
    long*  val
);
HRESULT put_EdgeCount(
    long  val
);

Instrument Command

:TRIGger:DELay:TRIGger:COUNt {value}
:TRIGger:DELay:TRIGger:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.Slope Property
IAgInfiniiVisionTrigger2Delay See Also

Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionTriggerDelaySlopeEnum
C#
public AgInfiniiVisionTriggerDelaySlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionTriggerDelaySlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionTriggerDelaySlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerDelaySlopeNegative - specifies falling (Negative) for the trigger edge in the Edge Then Edge trigger
  • AgInfiniiVisionTriggerDelaySlopePositive - specifies rising (Positive) for the trigger edge in the Edge Then Edge trigger

Instrument Command

:TRIGger:DELay:TRIGger:SLOPe {NEG|POS}
:TRIGger:DELay:TRIGger:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


Time Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay..::.Time Property
IAgInfiniiVisionTrigger2Delay See Also

Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Time As Double
C#
public double  Time { get; set; }
Visual C++
HRESULT get_Time(
    double*  val
);
HRESULT put_Time(
    double  val
);

Instrument Command

:TRIGger:DELay:TDELay:TIME {value}
:TRIGger:DELay:TDELay:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Delay Interface
Agilent.AgInfiniiVision.Interop Namespace


EdgeBurst Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.EdgeBurst Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property EdgeBurst As IAgInfiniiVisionTrigger2EdgeBurst
C#
public IAgInfiniiVisionTrigger2EdgeBurst  EdgeBurst { get; }
Visual C++
HRESULT get_EdgeBurst(
    IAgInfiniiVisionTrigger2EdgeBurst**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2EdgeBurst..::.Configure Method
IAgInfiniiVisionTrigger2EdgeBurst See Also

Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Slope As AgInfiniiVisionTriggerEdgeBurstSlopeEnum  _
    ByVal  IdleTime As Double  _
    ByVal  NthEdge As Integer  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionTriggerEdgeBurstSlopeEnum  Slope,
    double  IdleTime,
    int  NthEdge
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionTriggerEdgeBurstSlopeEnum  Slope,
    double  IdleTime,
    long  NthEdge
);

Parameters

Source

Specifies the input that produces the Nth edge burst trigger.

Slope

Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.

IdleTime

Sets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.

NthEdge

Sets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2EdgeBurst Interface
Agilent.AgInfiniiVision.Interop Namespace


IdleTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2EdgeBurst..::.IdleTime Property
IAgInfiniiVisionTrigger2EdgeBurst See Also

Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property IdleTime As Double
C#
public double  IdleTime { get; set; }
Visual C++
HRESULT get_IdleTime(
    double*  val
);
HRESULT put_IdleTime(
    double  val
);

Instrument Command

:TRIGger:EBURst:IDLE {value}
:TRIGger:EBURst:IDLE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2EdgeBurst Interface
Agilent.AgInfiniiVision.Interop Namespace


NthEdge Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2EdgeBurst..::.NthEdge Property
IAgInfiniiVisionTrigger2EdgeBurst See Also

Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property NthEdge As Integer
C#
public int  NthEdge { get; set; }
Visual C++
HRESULT get_NthEdge(
    long*  val
);
HRESULT put_NthEdge(
    long  val
);

Instrument Command

:TRIGger:EBURst:COUNt {value}
:TRIGger:EBURst:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2EdgeBurst Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2EdgeBurst..::.Slope Property
IAgInfiniiVisionTrigger2EdgeBurst See Also

Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionTriggerEdgeBurstSlopeEnum
C#
public AgInfiniiVisionTriggerEdgeBurstSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionTriggerEdgeBurstSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionTriggerEdgeBurstSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerEdgeBurstSlopeNegative - specifies that the falling edge (Negative) of the Nth edge in a burst will generate a trigger
  • AgInfiniiVisionTriggerEdgeBurstSlopePositive - specifies that the rising edge (Positive) of the Nth edge in a burst will generate a trigger

Instrument Command

:TRIGger:EBURst:SLOPe {NEG|POS}
:TRIGger:EBURst:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2EdgeBurst Interface
Agilent.AgInfiniiVision.Interop Namespace


ForceTrigger Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.ForceTrigger Method
IAgInfiniiVisionTrigger2 See Also

This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub ForceTrigger ( _
)
C#
public void  ForceTrigger(
)
Visual C++
HRESULT ForceTrigger(
);

Instrument Command

:TRIGger:FORCe

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


OR Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.OR Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTrigger2OR interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property OR As IAgInfiniiVisionTrigger2OR
C#
public IAgInfiniiVisionTrigger2OR  OR { get; }
Visual C++
HRESULT get_OR(
    IAgInfiniiVisionTrigger2OR**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


EdgePattern Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2OR..::.EdgePattern Property
IAgInfiniiVisionTrigger2OR See Also

Specifies the edges to include in the OR'ed edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property EdgePattern As String
C#
public string  EdgePattern { get; set; }
Visual C++
HRESULT get_EdgePattern(
    BSTR*  val
);
HRESULT put_EdgePattern(
    BSTR  val
);

Remarks

The EdgePattern property is specified in the following string format:

  • "nn..n", where n: {R | F | E | X}
R = rising edge,
F = faling edge,
E = either edge,
X = don't care.

In the string format shown above, each bit corresponds to a channel as described in the following table:
Oscilloscope Models | Value and Mask Bit Assignments
4 analog + 16 digital channels (mixed-signal) | Bits 0 through 15 - digital channels 0 through 15. Bits 16 through 19 - analog channels 4 through 1
2 analog + 16 digital channels (mixed-signal) | Bits 0 through 15 - digital channels 0 through 15. Bits 16 and 17 - analog channels 2 and 1
4 analog channels only | Bits 0 through 3 - analog channels 4 through 1
2 analog channels only | Bits 0 and 1 - analog channels 2 and 1

Instrument Command

:TRIGger:OR "{value}"
:TRIGger:OR?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2OR Interface
Agilent.AgInfiniiVision.Interop Namespace


SetupAndHold Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.SetupAndHold Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SetupAndHold As IAgInfiniiVisionTrigger2SetupAndHold
C#
public IAgInfiniiVisionTrigger2SetupAndHold  SetupAndHold { get; }
Visual C++
HRESULT get_SetupAndHold(
    IAgInfiniiVisionTrigger2SetupAndHold**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


ClockSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.ClockSource Property
IAgInfiniiVisionTrigger2SetupAndHold See Also

Selects the channel used to produce the trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ClockSource As String
C#
public string  ClockSource { get; set; }
Visual C++
HRESULT get_ClockSource(
    BSTR*  val
);
HRESULT put_ClockSource(
    BSTR  val
);

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:SHOLd:SOURce:CLOCk {value}
:TRIGger:SHOLd:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.Configure Method
IAgInfiniiVisionTrigger2SetupAndHold See Also

Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  ClockSource As String  _
    ByVal  Slope As AgInfiniiVisionTriggerSetupAndHoldSlopeEnum  _
    ByVal  DataSource As String  _
    ByVal  SetupTime As Double  _
    ByVal  HoldTime As Double  _
)
C#
public void  Configure(
    string  ClockSource,
    AgInfiniiVisionTriggerSetupAndHoldSlopeEnum  Slope,
    string  DataSource,
    double  SetupTime,
    double  HoldTime
)
Visual C++
HRESULT Configure(
    BSTR  ClockSource,
    AgInfiniiVisionTriggerSetupAndHoldSlopeEnum  Slope,
    BSTR  DataSource,
    double  SetupTime,
    double  HoldTime
);

Parameters

ClockSource

Selects the channel used to produce the trigger.

Slope

Selects the clock signal's active edge.

DataSource

Selects the channel used to produce the trigger.

SetupTime

Sets the setup time.

HoldTime

Sets the hold time.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


DataSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.DataSource Property
IAgInfiniiVisionTrigger2SetupAndHold See Also

Selects the channel used to produce the trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataSource As String
C#
public string  DataSource { get; set; }
Visual C++
HRESULT get_DataSource(
    BSTR*  val
);
HRESULT put_DataSource(
    BSTR  val
);

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:SHOLd:SOURce:DATA {value}
:TRIGger:SHOLd:SOURce:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


HoldTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.HoldTime Property
IAgInfiniiVisionTrigger2SetupAndHold See Also

Sets/Gets the hold time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HoldTime As Double
C#
public double  HoldTime { get; set; }
Visual C++
HRESULT get_HoldTime(
    double*  val
);
HRESULT put_HoldTime(
    double  val
);

Instrument Command

:TRIGger:SHOLd:TIME:HOLD {value}
:TRIGger:SHOLd:TIME:HOLD?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


SetupTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.SetupTime Property
IAgInfiniiVisionTrigger2SetupAndHold See Also

Sets/Gets the setup time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SetupTime As Double
C#
public double  SetupTime { get; set; }
Visual C++
HRESULT get_SetupTime(
    double*  val
);
HRESULT put_SetupTime(
    double  val
);

Instrument Command

:TRIGger:SHOLd:TIME:SETup {value}
:TRIGger:SHOLd:TIME:SETup?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold..::.Slope Property
IAgInfiniiVisionTrigger2SetupAndHold See Also

Selects the clock signal's active edge.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionTriggerSetupAndHoldSlopeEnum
C#
public AgInfiniiVisionTriggerSetupAndHoldSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionTriggerSetupAndHoldSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionTriggerSetupAndHoldSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerSHoldSlopeNegative - Negative slope
  • AgInfiniiVisionTriggerSHoldSlopePositive - Positive slope

Instrument Command

:TRIGger:SHOLd:SLOPe {NEG|POS}
:TRIGger:SHOLd:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2SetupAndHold Interface
Agilent.AgInfiniiVision.Interop Namespace


Transition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.Transition Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTrigger2Transition interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Transition As IAgInfiniiVisionTrigger2Transition
C#
public IAgInfiniiVisionTrigger2Transition  Transition { get; }
Visual C++
HRESULT get_Transition(
    IAgInfiniiVisionTrigger2Transition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.Condition Property
IAgInfiniiVisionTrigger2Transition See Also

Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionTriggerTransitionConditionEnum
C#
public AgInfiniiVisionTriggerTransitionConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionTriggerTransitionConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionTriggerTransitionConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionTriggerTransitionConditionGreaterThan - specifies that we are looking for rise/fall times greater than a certain time value.
  • AgInfiniiVisionTriggerTransitionConditionLessThan - specifies that we are looking for rise/fall times less than a certain time value.

Instrument Command

:TRIGger:TRANsition:QUALifier {GRE|LESS}
:TRIGger:TRANsition:QUALifier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.Configure Method
IAgInfiniiVisionTrigger2Transition See Also

Configures the source, slope, condition and qualifier time parameters for the Transition trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Slope As AgInfiniiVisionTriggerTransitionSlopeEnum  _
    ByVal  Condition As AgInfiniiVisionTriggerTransitionConditionEnum  _
    ByVal  QualifierTime As Double  _
)
C#
public void  Configure(
    string  Source,
    AgInfiniiVisionTriggerTransitionSlopeEnum  Slope,
    AgInfiniiVisionTriggerTransitionConditionEnum  Condition,
    double  QualifierTime
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    AgInfiniiVisionTriggerTransitionSlopeEnum  Slope,
    AgInfiniiVisionTriggerTransitionConditionEnum  Condition,
    double  QualifierTime
);

Parameters

Source

Specifies the channel used to produce the trigger.

Slope

Specifies a Positive rising edge or a Negative falling edge.

Condition

Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.

QualifierTime

Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


QualifierTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.QualifierTime Property
IAgInfiniiVisionTrigger2Transition See Also

Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property QualifierTime As Double
C#
public double  QualifierTime { get; set; }
Visual C++
HRESULT get_QualifierTime(
    double*  val
);
HRESULT put_QualifierTime(
    double  val
);

Instrument Command

:TRIGger:TRANsition:TIME {value}
:TRIGger:TRANsition:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.Slope Property
IAgInfiniiVisionTrigger2Transition See Also

Specifies a Positive rising edge or a Negative falling edge.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgInfiniiVisionTriggerTransitionSlopeEnum
C#
public AgInfiniiVisionTriggerTransitionSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgInfiniiVisionTriggerTransitionSlopeEnum*  val
);
HRESULT put_Slope(
    AgInfiniiVisionTriggerTransitionSlopeEnum  val
);

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerTransitionSlopeNegative - specifies a negative falling edge
  • AgInfiniiVisionTriggerTransitionSlopePositive - specifies a positive rising edge

Instrument Command

:TRIGger:TRANsition:SLOPe {NEG|POS}
:TRIGger:TRANsition:SLOPe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.ThresholdHigh Property
IAgInfiniiVisionTrigger2Transition See Also

The high threshold the oscilloscope uses for the transition trigger. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


ThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition..::.ThresholdLow Property
IAgInfiniiVisionTrigger2Transition See Also

The low threshold the oscilloscope uses for the transition trigger. The units are volts.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger2Transition Interface
Agilent.AgInfiniiVision.Interop Namespace


TV2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.TV2 Property
IAgInfiniiVisionTrigger2 See Also

Pointer to the IAgInfiniiVisionTriggerTV interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV2 As IAgInfiniiVisionTriggerTV2
C#
public IAgInfiniiVisionTriggerTV2  TV2 { get; }
Visual C++
HRESULT get_TV2(
    IAgInfiniiVisionTriggerTV2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


UDTV Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2..::.UDTV Property
IAgInfiniiVisionTriggerTV2 See Also

Pointer to the IAgInfiniiVisionTriggerTV2UDTV interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property UDTV As IAgInfiniiVisionTriggerTV2UDTV
C#
public IAgInfiniiVisionTriggerTV2UDTV  UDTV { get; }
Visual C++
HRESULT get_UDTV(
    IAgInfiniiVisionTriggerTV2UDTV**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTriggerTV2 Interface
Agilent.AgInfiniiVision.Interop Namespace


EdgeNumber Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2UDTV..::.EdgeNumber Property
IAgInfiniiVisionTriggerTV2UDTV See Also

Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property EdgeNumber As Integer
C#
public int  EdgeNumber { get; set; }
Visual C++
HRESULT get_EdgeNumber(
    long*  val
);
HRESULT put_EdgeNumber(
    long  val
);

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:ENUMber {value}
:TRIGger:TV:UDTV:ENUMber?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerTV2UDTV Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalSyncEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2UDTV..::.HorizontalSyncEnabled Property
IAgInfiniiVisionTriggerTV2UDTV See Also

Enables or disables the horizontal sync control in the Generic video trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalSyncEnabled As Boolean
C#
public bool  HorizontalSyncEnabled { get; set; }
Visual C++
HRESULT get_HorizontalSyncEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_HorizontalSyncEnabled(
    VARIANT_BOOL  val
);

Remarks

For interleaved video, setting the HorizontalSyncEnabled property to true and setting the HorizontalSyncTime property to the sync time of the probed video signal allows the ENUMber function to count only lines and not double count during equalization. Additionally, the Field Holdoff can be adjusted so that the oscilloscope triggers once per frame.
Similarly, for progressive video with a tri-level sync, setting the HorizontalSyncEnabled property to true and setting the HorizontalSyncTime property to the sync time of the probed video signal allows the EdgeNumber property to count only lines and not double count during vertical sync.
This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:HSYNc {ON|OFF}
:TRIGger:TV:UDTV:HSYNc?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerTV2UDTV Interface
Agilent.AgInfiniiVision.Interop Namespace


HorizontalSyncTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2UDTV..::.HorizontalSyncTime Property
IAgInfiniiVisionTriggerTV2UDTV See Also

When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HorizontalSyncTime As Double
C#
public double  HorizontalSyncTime { get; set; }
Visual C++
HRESULT get_HorizontalSyncTime(
    double*  val
);
HRESULT put_HorizontalSyncTime(
    double  val
);

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:HTIMe {value}
:TRIGger:TV:UDTV:HTIMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerTV2UDTV Interface
Agilent.AgInfiniiVision.Interop Namespace


MinTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2UDTV..::.MinTime Property
IAgInfiniiVisionTriggerTV2UDTV See Also

Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property MinTime As Double
C#
public double  MinTime { get; set; }
Visual C++
HRESULT get_MinTime(
    double*  val
);
HRESULT put_MinTime(
    double  val
);

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:PGTHan {value}
:TRIGger:TV:UDTV:PGTHan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTriggerTV2UDTV Interface
Agilent.AgInfiniiVision.Interop Namespace


USB Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2..::.USB Property
IAgInfiniiVisionTrigger2 See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property USB As IAgInfiniiVisionTrigger2USB
C#
public IAgInfiniiVisionTrigger2USB  USB { get; }
Visual C++
HRESULT get_USB(
    IAgInfiniiVisionTrigger2USB**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB..::.Condition Property
IAgInfiniiVisionTrigger2USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Condition As AgInfiniiVisionTriggerUSBConditionEnum
C#
public AgInfiniiVisionTriggerUSBConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    AgInfiniiVisionTriggerUSBConditionEnum*  val
);
HRESULT put_Condition(
    AgInfiniiVisionTriggerUSBConditionEnum  val
);

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionTriggerUSBConditionStartOfPacket - Start of packet
  • AgInfiniiVisionTriggerUSBConditionEndOfPacket - End of packet
  • AgInfiniiVisionTriggerUSBConditionEnterSuspend - Enter suspend state
  • AgInfiniiVisionTriggerUSBConditionExitSuspend - Exit suspend state
  • AgInfiniiVisionTriggerUSBConditionReset - Reset complete

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.Condition property.

Instrument Command

:TRIGger:USB:TRIGger {SOP|EOP|ENT|EXIT|RES}
:TRIGger:USB:TRIGger?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

IAgInfiniiVisionTrigger2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB..::.Configure Method
IAgInfiniiVisionTrigger2USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Condition As AgInfiniiVisionTriggerUSBConditionEnum  _
    ByVal  Speed As AgInfiniiVisionTriggerUSBSpeedEnum  _
    ByVal  DPlusSource As String  _
    ByVal  DMinusSource As String  _
)
C#
public void  Configure(
    AgInfiniiVisionTriggerUSBConditionEnum  Condition,
    AgInfiniiVisionTriggerUSBSpeedEnum  Speed,
    string  DPlusSource,
    string  DMinusSource
)
Visual C++
HRESULT Configure(
    AgInfiniiVisionTriggerUSBConditionEnum  Condition,
    AgInfiniiVisionTriggerUSBSpeedEnum  Speed,
    BSTR  DPlusSource,
    BSTR  DMinusSource
);

Parameters

Condition

Specifies where the USB trigger will occur.

Speed

Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).

DPlusSource

Specifies the source for the USB D+ signal.

DMinusSource

Specifies the source for the USB D- signal.

Remarks

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB interface.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

IAgInfiniiVisionTrigger2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


DMinusSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB..::.DMinusSource Property
IAgInfiniiVisionTrigger2USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DMinusSource As String
C#
public string  DMinusSource { get; set; }
Visual C++
HRESULT get_DMinusSource(
    BSTR*  val
);
HRESULT put_DMinusSource(
    BSTR  val
);

Remarks

The DMinusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.DMinusSource property.

Instrument Command

:TRIGger:USB:SOURce:DMINus {value}
:TRIGger:USB:SOURce:DMINus?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

IAgInfiniiVisionTrigger2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


DPlusSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB..::.DPlusSource Property
IAgInfiniiVisionTrigger2USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DPlusSource As String
C#
public string  DPlusSource { get; set; }
Visual C++
HRESULT get_DPlusSource(
    BSTR*  val
);
HRESULT put_DPlusSource(
    BSTR  val
);

Remarks

The DPlusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.DPlusSource property.

Instrument Command

:TRIGger:USB:SOURce:DPLus {value}
:TRIGger:USB:SOURce:DPLus?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

IAgInfiniiVisionTrigger2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Speed Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB..::.Speed Property
IAgInfiniiVisionTrigger2USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Speed As AgInfiniiVisionTriggerUSBSpeedEnum
C#
public AgInfiniiVisionTriggerUSBSpeedEnum  Speed { get; set; }
Visual C++
HRESULT get_Speed(
    AgInfiniiVisionTriggerUSBSpeedEnum*  val
);
HRESULT put_Speed(
    AgInfiniiVisionTriggerUSBSpeedEnum  val
);

Remarks

The Speed property can be set to one of the following values:

  • AgInfiniiVisionTriggerUSBSpeedLow - sets the expected USB signal speed to be Low Speed (1.5 Mb/s)
  • AgInfiniiVisionTriggerUSBSpeedFull - sets the expected USB signal speed to be Full Speed (12 Mb/s)

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.Speed property.

Instrument Command

:TRIGger:USB:SPEed {LOW|FULL}
:TRIGger:USB:SPEed?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

IAgInfiniiVisionTrigger2USB Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger3 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.Trigger3 Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionTrigger2 interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger3 As IAgInfiniiVisionTrigger3
C#
public IAgInfiniiVisionTrigger3  Trigger3 { get; }
Visual C++
HRESULT get_Trigger3(
    IAgInfiniiVisionTrigger3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3..::.AutoSetup Method
IAgInfiniiVisionTrigger3 See Also

It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Remarks

  • When High and Low (dual) trigger levels are used (as with Rise/Fall Time and Runt triggers, for example), this method has no effect.

    • Instrument Command

    :TRIGger:LEVel:ASETup

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionTrigger3 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Zone Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3..::.Zone Property
IAgInfiniiVisionTrigger3 See Also

Pointer to the IAgInfiniiVisionTrigger3Zone interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Zone As IAgInfiniiVisionTrigger3Zone
C#
public IAgInfiniiVisionTrigger3Zone  Zone { get; }
Visual C++
HRESULT get_Zone(
    IAgInfiniiVisionTrigger3Zone**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.Enabled Property
IAgInfiniiVisionTrigger3Zone See Also

Specifies the state for Zone 1 or Zone 2.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled( _
    ByVal  Zone As AgInfiniiVisionTriggerZoneEnum  _
) As Boolean
C#
public bool  get_Enabled(
    AgInfiniiVisionTriggerZoneEnum  Zone
)
public void  set_Enabled(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    bool  val
)
Visual C++
HRESULT get_Enabled(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    VARIANT_BOOL  val
);

Parameters

Zone

Specifies the Zone Number.

Remarks

Setting this property to true, sets the Enabled property to true.

Instrument Command

:TRIGger:ZONE{1|2}:STATe {ON|OFF}
:TRIGger:ZONE{1|2}:STATe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger3Zone Interface
Agilent.AgInfiniiVision.Interop Namespace


GetZonePlacement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.GetZonePlacement Method
IAgInfiniiVisionTrigger3Zone See Also

Queries the size and location of Zone 1 or Zone 2.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub GetZonePlacement ( _
    ByVal  Zone As AgInfiniiVisionTriggerZoneEnum  _
    ByRef  Width As Double  _
    ByRef  Height As Double  _
    ByRef  XCenter As Double  _
    ByRef  YCenter As Double  _
)
C#
public void  GetZonePlacement(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    ref double  Width,
    ref double  Height,
    ref double  XCenter,
    ref double  YCenter
)
Visual C++
HRESULT GetZonePlacement(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    double*  Width,
    double*  Height,
    double*  XCenter,
    double*  YCenter
);

Parameters

Zone

Specifies the Zone Number.

Width

Width of zone to be specified.

Height

Height of zone to be specified.

XCenter

X axis center of Zone to be specified.

YCenter

Y axis center of Zone to be specified.

Instrument Command

:TRIGger:ZONE{1|2}:PLACement?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger3Zone Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.Mode Property
IAgInfiniiVisionTrigger3Zone See Also

Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode( _
    ByVal  Zone As AgInfiniiVisionTriggerZoneEnum  _
) As AgInfiniiVisionTriggerZoneModeEnum
C#
public AgInfiniiVisionTriggerZoneModeEnum  get_Mode(
    AgInfiniiVisionTriggerZoneEnum  Zone
)
public void  set_Mode(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    AgInfiniiVisionTriggerZoneModeEnum  val
)
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    AgInfiniiVisionTriggerZoneModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    AgInfiniiVisionTriggerZoneModeEnum  val
);

Parameters

Zone

Specifies the Zone Number.

Instrument Command

:TRIGger:ZONE{1|2}:MODE {INT|NOT}
:TRIGger:ZONE{1|2}:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger3Zone Interface
Agilent.AgInfiniiVision.Interop Namespace


SetZonePlacement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.SetZonePlacement Method
IAgInfiniiVisionTrigger3Zone See Also

Sets the size and location of Zone 1 or Zone 2.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetZonePlacement ( _
    ByVal  Zone As AgInfiniiVisionTriggerZoneEnum  _
    ByVal  Width As Double  _
    ByVal  Height As Double  _
    ByVal  XCenter As Double  _
    ByVal  YCenter As Double  _
)
C#
public void  SetZonePlacement(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    double  Width,
    double  Height,
    double  XCenter,
    double  YCenter
)
Visual C++
HRESULT SetZonePlacement(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    double  Width,
    double  Height,
    double  XCenter,
    double  YCenter
);

Parameters

Zone

Specifies the Zone Number.

Width

Width of zone to be specified.

Height

Height of zone to be specified.

XCenter

X axis center of Zone to be specified.

YCenter

Y axis center of Zone to be specified.

Instrument Command

:TRIGger:ZONE{1|2}:PLACement {Width}, {Height}, {XCenter}, {YCenter}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger3Zone Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.Source Property
IAgInfiniiVisionTrigger3Zone See Also

Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

The StateEnabled property must also be true for a zone to be active.

Instrument Command

:TRIGger:ZONE:SOURce {value}
:TRIGger:ZONE:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionTrigger3Zone Interface
Agilent.AgInfiniiVision.Interop Namespace


Validity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone..::.Validity Property
IAgInfiniiVisionTrigger3Zone See Also

Read Only - Query returns the validity of Zone 1 or Zone 2.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Validity( _
    ByVal  Zone As AgInfiniiVisionTriggerZoneEnum  _
) As AgInfiniiVisionTriggerZoneValidityEnum
C#
public AgInfiniiVisionTriggerZoneValidityEnum  get_Validity(
    AgInfiniiVisionTriggerZoneEnum  Zone
)
Visual C++
HRESULT get_Validity(
    AgInfiniiVisionTriggerZoneEnum  Zone,
    AgInfiniiVisionTriggerZoneValidityEnum*  val
);

Parameters

Zone

Specifies the Zone Number.

Remarks

  • AgInfiniiVisionTriggerZoneValidityInvalid is returned (for Zone 2 only) when Zone 1 and Zone 2 overlap and have opposing qualifying conditions (modes). Zone 1 can never be invalid.
  • AgInfiniiVisionTriggerZoneValidityOffScreen is returned when the associated zone is off-screen, and thus not being used to qualify the trigger.
  • AgInfiniiVisionTriggerZoneValidityValid is returned when Zone is valid. A zone is valid when it is neither invalid nor off-screen.

    • Instrument Command

    :TRIGger:ZONE{1|2}:VALidity?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionTrigger3Zone Interface
    Agilent.AgInfiniiVision.Interop Namespace


Trigger4 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision7..::.Trigger4 Property
IAgInfiniiVision7 See Also

Pointer to the IAgInfiniiVisionTrigger2 interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger4 As IAgInfiniiVisionTrigger4
C#
public IAgInfiniiVisionTrigger4  Trigger4 { get; }
Visual C++
HRESULT get_Trigger4(
    IAgInfiniiVisionTrigger4**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision7 Interface
Agilent.AgInfiniiVision.Interop Namespace


PXI Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4..::.PXI Property
IAgInfiniiVisionTrigger4 See Also

Pointer to the IAgInfiniiVisionTrigger4PXI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property PXI As IAgInfiniiVisionTrigger4PXI
C#
public IAgInfiniiVisionTrigger4PXI  PXI { get; }
Visual C++
HRESULT get_PXI(
    IAgInfiniiVisionTrigger4PXI**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger4 Interface
Agilent.AgInfiniiVision.Interop Namespace


GetMasterArmLine Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.GetMasterArmLine Method
IAgInfiniiVisionTrigger4PXI See Also

Queries the PXI slave to master arm lines on or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function GetMasterArmLine ( _
    ByVal  Index As Integer  _
) As Boolean
C#
public bool  GetMasterArmLine(
    int  Index
)
Visual C++
HRESULT GetMasterArmLine(
    long  Index
    VARIANT_BOOL*  retval
);

Parameters

Index

Index.

Return Value

True or false

Instrument Command

:TRIGger:PXI:MALine{Index}:ENABle?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


Mode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.Mode Property
IAgInfiniiVisionTrigger4PXI See Also

Sets and gets the PXI trigger mode to bus master/slave or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgInfiniiVisionTriggerPXIModeEnum
C#
public AgInfiniiVisionTriggerPXIModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgInfiniiVisionTriggerPXIModeEnum*  val
);
HRESULT put_Mode(
    AgInfiniiVisionTriggerPXIModeEnum  val
);

Instrument Command

:TRIGger:PXI:MODE {OFF|MAST|SLAV}
:TRIGger:PXI:MODE?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


SetMasterArmLine Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.SetMasterArmLine Method
IAgInfiniiVisionTrigger4PXI See Also

Sets the PXI slave to master arm lines on or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetMasterArmLine ( _
    ByVal  Index As Integer  _
    ByVal  State As Boolean  _
)
C#
public void  SetMasterArmLine(
    int  Index,
    bool  State
)
Visual C++
HRESULT SetMasterArmLine(
    long  Index,
    VARIANT_BOOL  State
);

Parameters

Index

Index.

State

State.

Instrument Command

:TRIGger:PXI:MALine{Index}:ENABle {ON|OFF}

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


SlaveArmLine Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.SlaveArmLine Property
IAgInfiniiVisionTrigger4PXI See Also

Sets and gets the PXI slave to master arm line or off.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SlaveArmLine As AgInfiniiVisionPXITriggerEnum
C#
public AgInfiniiVisionPXITriggerEnum  SlaveArmLine { get; set; }
Visual C++
HRESULT get_SlaveArmLine(
    AgInfiniiVisionPXITriggerEnum*  val
);
HRESULT put_SlaveArmLine(
    AgInfiniiVisionPXITriggerEnum  val
);

Instrument Command

:TRIGger:PXI:SALine {PTR1|PTR2|PTR3|PTR4|PTR5|PTR6|PTR7|PTR0|OFF}
:TRIGger:PXI:SALine?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


Slot Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.Slot Property
IAgInfiniiVisionTrigger4PXI See Also

Sets and gets the PXI master slot number.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Slot As Integer
C#
public int  Slot { get; set; }
Visual C++
HRESULT get_Slot(
    long*  val
);
HRESULT put_Slot(
    long  val
);

Instrument Command

:TRIGger:PXI:MSLot {value}
:TRIGger:PXI:MSLot?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


TriggerLine Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI..::.TriggerLine Property
IAgInfiniiVisionTrigger4PXI See Also

Sets and gets the PXI master to slave trigger line.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TriggerLine As AgInfiniiVisionPXITriggerEnum
C#
public AgInfiniiVisionPXITriggerEnum  TriggerLine { get; set; }
Visual C++
HRESULT get_TriggerLine(
    AgInfiniiVisionPXITriggerEnum*  val
);
HRESULT put_TriggerLine(
    AgInfiniiVisionPXITriggerEnum  val
);

Remarks

Not supported enum AgInfiniiVisionTriggerPXITriggerLineOff.

Instrument Command

:TRIGger:PXI:TLINe {PTR1|PTR2|PTR3|PTR4|PTR5|PTR6|PTR7|PTR0|OFF}
:TRIGger:PXI:TLINe?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

IAgInfiniiVisionTrigger4PXI Interface
Agilent.AgInfiniiVision.Interop Namespace


Trigger5 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8..::.Trigger5 Property
IAgInfiniiVision8 See Also

Pointer to the IAgInfiniiVisionTrigger2 interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger5 As IAgInfiniiVisionTrigger5
C#
public IAgInfiniiVisionTrigger5  Trigger5 { get; }
Visual C++
HRESULT get_Trigger5(
    IAgInfiniiVisionTrigger5**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision8 Interface
Agilent.AgInfiniiVision.Interop Namespace


RandomHoldoff Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5..::.RandomHoldoff Property
IAgInfiniiVisionTrigger5 See Also

Pointer to the IAgInfiniiVisionTrigger5RandomHoldoff interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property RandomHoldoff As IAgInfiniiVisionTrigger5RandomHoldoff
C#
public IAgInfiniiVisionTrigger5RandomHoldoff  RandomHoldoff { get; }
Visual C++
HRESULT get_RandomHoldoff(
    IAgInfiniiVisionTrigger5RandomHoldoff**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionTrigger5 Interface
Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5RandomHoldoff..::.Enabled Property
IAgInfiniiVisionTrigger5RandomHoldoff See Also

Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • Random trigger holdoff is used to avoid a fixed trigger interval that could miss capturing effects during the holdoff time on a repetitive signal like a pulse train. The usage could also be thought as the reverse of the convention holdoff usage that is to randomize the trigger event and could generates an unstable trigger.

    • Instrument Command

    :TRIGger:HOLDoff:RANDom {1|0}
    :TRIGger:HOLDoff:RANDom?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionTrigger5RandomHoldoff Interface
    Agilent.AgInfiniiVision.Interop Namespace


TimeMax Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5RandomHoldoff..::.TimeMax Property
IAgInfiniiVisionTrigger5RandomHoldoff See Also

The maximum random holdoff time in seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeMax As Double
C#
public double  TimeMax { get; set; }
Visual C++
HRESULT get_TimeMax(
    double*  val
);
HRESULT put_TimeMax(
    double  val
);

Remarks

  • Default value is 10s.

    • Instrument Command

    :TRIGger:HOLDoff:MAXimum {value}
    :TRIGger:HOLDoff:MAXimum?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionTrigger5RandomHoldoff Interface
    Agilent.AgInfiniiVision.Interop Namespace


TimeMin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5RandomHoldoff..::.TimeMin Property
IAgInfiniiVisionTrigger5RandomHoldoff See Also

The minimum random holdoff time in seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property TimeMin As Double
C#
public double  TimeMin { get; set; }
Visual C++
HRESULT get_TimeMin(
    double*  val
);
HRESULT put_TimeMin(
    double  val
);

Remarks

  • Default value is 40ns.

    • Instrument Command

    :TRIGger:HOLDoff:MINimum {value}
    :TRIGger:HOLDoff:MINimum?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionTrigger5RandomHoldoff Interface
    Agilent.AgInfiniiVision.Interop Namespace


Utility Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver..::.Utility Property
IIviDriver See Also

Pointer to the IIviDriverUtility interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Utility As IIviDriverUtility
C#
public IIviDriverUtility  Utility { get; }
Visual C++
HRESULT get_Utility(
    IIviDriverUtility**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Disable Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.Disable Method
IIviDriverUtility See Also

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Disable ( _
)
C#
public void  Disable(
)
Visual C++
HRESULT Disable(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


ErrorQuery Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.ErrorQuery Method
IIviDriverUtility See Also

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ErrorQuery ( _
    ByRef  ErrorCode As Integer  _
    ByRef  ErrorMessage As String  _
)
C#
public void  ErrorQuery(
    ref int  ErrorCode,
    ref string  ErrorMessage
)
Visual C++
HRESULT ErrorQuery(
    long*  ErrorCode,
    BSTR*  ErrorMessage
);

Parameters

ErrorCode

Instrument error code

ErrorMessage

Instrument error message

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


LockObject Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.LockObject Method
IIviDriverUtility See Also

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub LockObject ( _
)
C#
public void  LockObject(
)
Visual C++
HRESULT LockObject(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.Reset Method
IIviDriverUtility See Also

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


ResetWithDefaults Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.ResetWithDefaults Method
IIviDriverUtility See Also

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ResetWithDefaults ( _
)
C#
public void  ResetWithDefaults(
)
Visual C++
HRESULT ResetWithDefaults(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


SelfTest Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.SelfTest Method
IIviDriverUtility See Also

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub SelfTest ( _
    ByRef  TestResult As Integer  _
    ByRef  TestMessage As String  _
)
C#
public void  SelfTest(
    ref int  TestResult,
    ref string  TestMessage
)
Visual C++
HRESULT SelfTest(
    long*  TestResult,
    BSTR*  TestMessage
);

Parameters

TestResult

The numeric result from the self test operation. 0 = no error (test passed)

TestMessage

The self test status message

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


UnlockObject Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility..::.UnlockObject Method
IIviDriverUtility See Also

Releases a previously obtained mutlithread lock.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub UnlockObject ( _
)
C#
public void  UnlockObject(
)
Visual C++
HRESULT UnlockObject(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


Waveform Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.Waveform Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionWaveform interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Waveform As IAgInfiniiVisionWaveform
C#
public IAgInfiniiVisionWaveform  Waveform { get; }
Visual C++
HRESULT get_Waveform(
    IAgInfiniiVisionWaveform**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


ByteOrder Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.ByteOrder Property
IAgInfiniiVisionWaveform See Also

Output sequence of the WORD data. It decides which significant byte to be transmitted first.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ByteOrder As AgInfiniiVisionWaveformByteOrderEnum
C#
public AgInfiniiVisionWaveformByteOrderEnum  ByteOrder { get; set; }
Visual C++
HRESULT get_ByteOrder(
    AgInfiniiVisionWaveformByteOrderEnum*  val
);
HRESULT put_ByteOrder(
    AgInfiniiVisionWaveformByteOrderEnum  val
);

Remarks

This property affects the transmitting sequence only when DataFormat is set to WORD.

Instrument Command

:WAVeform:BYTeorder {LSBF|MSBF}
:WAVeform:BYTeorder?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


DataFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.DataFormat Property
IAgInfiniiVisionWaveform See Also

Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DataFormat As AgInfiniiVisionWaveformDataFormatEnum
C#
public AgInfiniiVisionWaveformDataFormatEnum  DataFormat { get; set; }
Visual C++
HRESULT get_DataFormat(
    AgInfiniiVisionWaveformDataFormatEnum*  val
);
HRESULT put_DataFormat(
    AgInfiniiVisionWaveformDataFormatEnum  val
);

Instrument Command

:WAVeform:FORMat {WORD|BYTE|ASC}
:WAVeform:FORMat?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


PointCount Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.PointCount Property
IAgInfiniiVisionWaveform See Also

Number of waveform points to be transferred with the Waveform data

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PointCount As Integer
C#
public int  PointCount { get; set; }
Visual C++
HRESULT get_PointCount(
    long*  val
);
HRESULT put_PointCount(
    long  val
);

Instrument Command

:WAVeform:POINts {value}
:WAVeform:POINts?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


PointMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.PointMode Property
IAgInfiniiVisionWaveform See Also

Type of data record to be transferred

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PointMode As AgInfiniiVisionWaveformPointModeEnum
C#
public AgInfiniiVisionWaveformPointModeEnum  PointMode { get; set; }
Visual C++
HRESULT get_PointMode(
    AgInfiniiVisionWaveformPointModeEnum*  val
);
HRESULT put_PointMode(
    AgInfiniiVisionWaveformPointModeEnum  val
);

Instrument Command

:WAVeform:POINts:MODE {NORM|MAX|RAW}
:WAVeform:POINts:MODE?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Preamble Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.Preamble Method
IAgInfiniiVisionWaveform See Also

Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Function Preamble ( _
) As Double()
C#
public double[]   Preamble(
)
Visual C++
HRESULT Preamble(
    SAFEARRAY**  retval
);

Return Value

Preamble block.

Instrument Command

:WAVeform:PREamble?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.Source Property
IAgInfiniiVisionWaveform See Also

Source for the waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Remarks

    Permissible Values are:
  • "Channel<n>", where n = 1 to (# of analog channels)
  • "Math<n>", where n = 1 to (# of math functions)
  • "FUNC" (for 1000X, 2000X and 3000X only)
  • "POD<n>", where n = 1 or 2 (for MSO models only)
  • "BUS<n>", where n = 1 or 2 (for MSO models only)
  • "WMEM<n>", where n = 1 to (# of reference waveforms)
  • "SerialBus<n>", where n = 1 to 2

    • Instrument Command

    :WAVeform:SOURce {value}
    :WAVeform:SOURce?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveform Interface
    Agilent.AgInfiniiVision.Interop Namespace


UnsignedModeEnable Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.UnsignedModeEnable Property
IAgInfiniiVisionWaveform See Also

Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property UnsignedModeEnable As Boolean
C#
public bool  UnsignedModeEnable { get; set; }
Visual C++
HRESULT get_UnsignedModeEnable(
    VARIANT_BOOL*  val
);
HRESULT put_UnsignedModeEnable(
    VARIANT_BOOL  val
);

Instrument Command

:WAVeform:UNSigned {ON|OFF}
:WAVeform:UNSigned?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


View Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.View Property
IAgInfiniiVisionWaveform See Also

View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property View As String
C#
public string  View { get; set; }
Visual C++
HRESULT get_View(
    BSTR*  val
);
HRESULT put_View(
    BSTR  val
);

Instrument Command

:WAVeform:VIEW {value}
:WAVeform:VIEW?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


XIncrement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.XIncrement Property
IAgInfiniiVisionWaveform See Also

Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property XIncrement As Double
C#
public double  XIncrement { get; }
Visual C++
HRESULT get_XIncrement(
    double*  val
);

Instrument Command

:WAVeform:XINCrement?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


XOrigin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.XOrigin Property
IAgInfiniiVisionWaveform See Also

Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property XOrigin As Double
C#
public double  XOrigin { get; }
Visual C++
HRESULT get_XOrigin(
    double*  val
);

Instrument Command

:WAVeform:XORigin?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


XReference Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.XReference Property
IAgInfiniiVisionWaveform See Also

Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property XReference As Integer
C#
public int  XReference { get; }
Visual C++
HRESULT get_XReference(
    long*  val
);

Remarks

The x-reference point is the first point displayed and XREFerence is always 0.

Instrument Command

:WAVeform:XREFerence?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


YIncrement Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.YIncrement Property
IAgInfiniiVisionWaveform See Also

Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property YIncrement As Double
C#
public double  YIncrement { get; }
Visual C++
HRESULT get_YIncrement(
    double*  val
);

Instrument Command

:WAVeform:YINCrement?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


YOrigin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.YOrigin Property
IAgInfiniiVisionWaveform See Also

Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property YOrigin As Double
C#
public double  YOrigin { get; }
Visual C++
HRESULT get_YOrigin(
    double*  val
);

Instrument Command

:WAVeform:YORigin?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


YReference Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform..::.YReference Property
IAgInfiniiVisionWaveform See Also

Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property YReference As Integer
C#
public int  YReference { get; }
Visual C++
HRESULT get_YReference(
    long*  val
);

Instrument Command

:WAVeform:YREFerence?

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveform Interface
Agilent.AgInfiniiVision.Interop Namespace


Waveform2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5..::.Waveform2 Property
IAgInfiniiVision5 See Also

Pointer to the IAgInfiniiVisionWaveform interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Waveform2 As IAgInfiniiVisionWaveform2
C#
public IAgInfiniiVisionWaveform2  Waveform2 { get; }
Visual C++
HRESULT get_Waveform2(
    IAgInfiniiVisionWaveform2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision5 Interface
Agilent.AgInfiniiVision.Interop Namespace


SubSource Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform2..::.SubSource Property
IAgInfiniiVisionWaveform2 See Also

Selects the sub-source for those sources that have more than one possibility.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property SubSource As AgInfiniiVisionWaveformSubSourceEnum
C#
public AgInfiniiVisionWaveformSubSourceEnum  SubSource { get; set; }
Visual C++
HRESULT get_SubSource(
    AgInfiniiVisionWaveformSubSourceEnum*  val
);
HRESULT put_SubSource(
    AgInfiniiVisionWaveformSubSourceEnum  val
);

Remarks

  • If the IAgInfiniiVisionWaveform.Source is serial decode, more than one data set may be available, and this command lets you choose from the available data sets.
  • When using UART serial decode, this option lets you get "TX" data. (TX is an alias for SUB1.) The default, SUB0, specifies "RX" data. (RX is an alias for SUB0.)
  • When using SPI serial decode, this option lets you get "MISO" data. (MISO is an alias for SUB1.) The default, SUB0, specifies "MOSI" data. (MOSI is an alias for SUB0.)
  • When using SENT serial decode, this option lets you get "SLOW" data. (SLOW is an alias for SUB1.) The default, SUB0, specifies "FAST" data. (FAST is an alias for SUB0.)
  • If the IAgInfiniiVisionWaveform.Source is not SBUS, or the IAgInfiniiVision2SerialBus.Mode is not UART, SPI, or SENT, the only valid subsource is SUB0.

    • Instrument Command

    :WAVeform:SOURce:SUBSource {SUB0|SUB1|SLOW|FAST|RX|TX|MISO|MOSI}
    :WAVeform:SOURce:SUBSource?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveform2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


WaveformGenerator Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision..::.WaveformGenerator Property
IAgInfiniiVision See Also

Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WaveformGenerator As IAgInfiniiVisionWaveformGenerator
C#
public IAgInfiniiVisionWaveformGenerator  WaveformGenerator { get; }
Visual C++
HRESULT get_WaveformGenerator(
    IAgInfiniiVisionWaveformGenerator**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision Interface
Agilent.AgInfiniiVision.Interop Namespace


Amplitude Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.Amplitude Property
IAgInfiniiVisionWaveformGenerator See Also

Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Amplitude As Double
C#
public double  Amplitude { get; set; }
Visual C++
HRESULT get_Amplitude(
    double*  val
);
HRESULT put_Amplitude(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage {value}
    :WGEN:VOLTage?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


DutyCycle Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.DutyCycle Property
IAgInfiniiVisionWaveformGenerator See Also

Square wave duty cycle(20% to 80%) for Square waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DutyCycle As Double
C#
public double  DutyCycle { get; set; }
Visual C++
HRESULT get_DutyCycle(
    double*  val
);
HRESULT put_DutyCycle(
    double  val
);

Remarks

Duty cycle is the percentage of the period that the waveform is high.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:SQUare:DCYCle {value}
    :WGEN:FUNCtion:SQUare:DCYCle?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.Frequency Property
IAgInfiniiVisionWaveformGenerator See Also

Frequency for Sine, Square, Ramp, and Pulse waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frequency As Double
C#
public double  Frequency { get; set; }
Visual C++
HRESULT get_Frequency(
    double*  val
);
HRESULT put_Frequency(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FREQuency {value}
    :WGEN:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


Function Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.Function Property
IAgInfiniiVisionWaveformGenerator See Also

Type of waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Function As AgInfiniiVisionWaveformGeneratorFunctionEnum
C#
public AgInfiniiVisionWaveformGeneratorFunctionEnum  Function { get; set; }
Visual C++
HRESULT get_Function(
    AgInfiniiVisionWaveformGeneratorFunctionEnum*  val
);
HRESULT put_Function(
    AgInfiniiVisionWaveformGeneratorFunctionEnum  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion {SIN|SQU|RAMP|PULS|NOIS|DC|SINC|EXPR|EXPF|CARD|GAUS|ARB}
    :WGEN:FUNCtion?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


HighVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.HighVoltage Property
IAgInfiniiVisionWaveformGenerator See Also

High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HighVoltage As Double
C#
public double  HighVoltage { get; set; }
Visual C++
HRESULT get_HighVoltage(
    double*  val
);
HRESULT put_HighVoltage(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:HIGH {value}
    :WGEN:VOLTage:HIGH?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


LowVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.LowVoltage Property
IAgInfiniiVisionWaveformGenerator See Also

Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LowVoltage As Double
C#
public double  LowVoltage { get; set; }
Visual C++
HRESULT get_LowVoltage(
    double*  val
);
HRESULT put_LowVoltage(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:LOW {value}
    :WGEN:VOLTage:LOW?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


OffsetVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.OffsetVoltage Property
IAgInfiniiVisionWaveformGenerator See Also

Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OffsetVoltage As Double
C#
public double  OffsetVoltage { get; set; }
Visual C++
HRESULT get_OffsetVoltage(
    double*  val
);
HRESULT put_OffsetVoltage(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:OFFSet {value}
    :WGEN:VOLTage:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


OutputEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.OutputEnabled Property
IAgInfiniiVisionWaveformGenerator See Also

Enables/Disables waveform generator signal output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:OUTPut {}
    :WGEN:OUTPut?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


OutputLoadImpedance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.OutputLoadImpedance Property
IAgInfiniiVisionWaveformGenerator See Also

Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputLoadImpedance As AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum
C#
public AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  OutputLoadImpedance { get; set; }
Visual C++
HRESULT get_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum*  val
);
HRESULT put_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  val
);

Remarks

If the actual load impedance is different than the selected value, the displayed amplitude and offset levels will be incorrect.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:OUTPut:LOAD {ONEM|FIFT}
    :WGEN:OUTPut:LOAD?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


Period Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.Period Property
IAgInfiniiVisionWaveformGenerator See Also

Period in seconds for Sine, Square, Ramp, and Pulse waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Period As Double
C#
public double  Period { get; set; }
Visual C++
HRESULT get_Period(
    double*  val
);
HRESULT put_Period(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:PERiod {value}
    :WGEN:PERiod?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


PulseWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.PulseWidth Property
IAgInfiniiVisionWaveformGenerator See Also

Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PulseWidth As Double
C#
public double  PulseWidth { get; set; }
Visual C++
HRESULT get_PulseWidth(
    double*  val
);
HRESULT put_PulseWidth(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:PULSe:WIDTh {value}
    :WGEN:FUNCtion:PULSe:WIDTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


RampSymmetry Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.RampSymmetry Property
IAgInfiniiVisionWaveformGenerator See Also

Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RampSymmetry As Double
C#
public double  RampSymmetry { get; set; }
Visual C++
HRESULT get_RampSymmetry(
    double*  val
);
HRESULT put_RampSymmetry(
    double  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:RAMP:SYMMetry {value}
    :WGEN:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator..::.Reset Method
IAgInfiniiVisionWaveformGenerator See Also

Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:RST

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator Interface
    Agilent.AgInfiniiVision.Interop Namespace


WaveformGenerator2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2..::.WaveformGenerator2 Property
IAgInfiniiVision2 See Also

Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WaveformGenerator2 As IAgInfiniiVisionWaveformGenerator2
C#
public IAgInfiniiVisionWaveformGenerator2  WaveformGenerator2 { get; }
Visual C++
HRESULT get_WaveformGenerator2(
    IAgInfiniiVisionWaveformGenerator2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision2 Interface
Agilent.AgInfiniiVision.Interop Namespace


AdditionalNoise Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2..::.AdditionalNoise Property
IAgInfiniiVisionWaveformGenerator2 See Also

Specifies the amount of noise to add to the currently selected signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AdditionalNoise As Integer
C#
public int  AdditionalNoise { get; set; }
Visual C++
HRESULT get_AdditionalNoise(
    long*  val
);
HRESULT put_AdditionalNoise(
    long  val
);

Remarks

The sum of the amplitude between the original signal and injected noise is limited to the regular amplitude limit (for example, 5 Vpp in 1 MOhm), so the range for input value varies according to current amplitude.

Note that adding noise affects edge triggering on the waveform generator source as well as the waveform generator sync pulse output signal. This is because the trigger comparator is located after the noise source.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:MODulation:NOISe {value}
    :WGEN:MODulation:NOISe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2 Interface
    Agilent.AgInfiniiVision.Interop Namespace


Arbitrary Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2..::.Arbitrary Property
IAgInfiniiVisionWaveformGenerator2 See Also

Pointer to the IAgInfiniiVisionWaveformGenerator2Arbitrary interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Arbitrary As IAgInfiniiVisionWaveformGenerator2Arbitrary
C#
public IAgInfiniiVisionWaveformGenerator2Arbitrary  Arbitrary { get; }
Visual C++
HRESULT get_Arbitrary(
    IAgInfiniiVisionWaveformGenerator2Arbitrary**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveformGenerator2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Attribute Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.Attribute Property
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Pointer to the IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Attribute As IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute
C#
public IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute  Attribute { get; }
Visual C++
HRESULT get_Attribute(
    IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberOfPoints Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute..::.NumberOfPoints Property
IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute See Also

Read Only - Queries the number of points used by the current Arbitrary waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NumberOfPoints As Integer
C#
public int  NumberOfPoints { get; }
Visual C++
HRESULT get_NumberOfPoints(
    long*  val
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:ATTRibute:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute Interface
    Agilent.AgInfiniiVision.Interop Namespace


ByteOrder Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.ByteOrder Property
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Specifies the byte order for binary transfers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ByteOrder As AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum
C#
public AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum  ByteOrder { get; set; }
Visual C++
HRESULT get_ByteOrder(
    AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum*  val
);
HRESULT put_ByteOrder(
    AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum  val
);

Remarks

The ByteOrder property can be set to one of the following values:

  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderLSBFirst - specifies the LSB first byte order
  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderMSBFirst - specifies the MSB first byte order

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:BYTeorder {LSBF|MSBF}
    :WGEN:ARBitrary:BYTeorder?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Interpolation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.Interpolation Property
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Enables or disables the Interpolation control.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Interpolation As Boolean
C#
public bool  Interpolation { get; set; }
Visual C++
HRESULT get_Interpolation(
    VARIANT_BOOL*  val
);
HRESULT put_Interpolation(
    VARIANT_BOOL  val
);

Remarks

Interpolation specifies how lines are drawn between arbitrary waveform points:
When ON, lines are drawn between points in the arbitrary waveform. Voltage levels change linearly between one point and the next.
When OFF, all line segments in the arbitrary waveform are horizontal. The voltage level of one point remains until the next point.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:INTerpolate {ON|OFF}
    :WGEN:ARBitrary:INTerpolate?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.Reset Method
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Clears the Arbitrary waveform memory and loads it with the default waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:CLEar

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetData Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.SetData Method
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Downloads an arbitrary waveform in floating-point values format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetData ( _
    ByVal  Values As Double()   _
)
C#
public void  SetData(
    double[]   Values
)
Visual C++
HRESULT SetData(
    SAFEARRAY**  Values
);

Parameters

Values

Specifies the floating-point values between -1.0 and +1.0 for the arbitrary waveform.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetDataDAC Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.SetDataDAC Method
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Downloads an arbitrary waveform in integer (DAC) values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetDataDAC ( _
    ByVal  Values As Short()   _
)
C#
public void  SetDataDAC(
    short[]   Values
)
Visual C++
HRESULT SetDataDAC(
    SAFEARRAY**  Values
);

Parameters

Values

Specifies the decimal-integer values between -512 and +511 for the arbitrary waveform.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:DAC {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Store Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary..::.Store Method
IAgInfiniiVisionWaveformGenerator2Arbitrary See Also

Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Store ( _
    ByVal  Source As String  _
)
C#
public void  Store(
    string  Source
)
Visual C++
HRESULT Store(
    BSTR  Source
);

Parameters

Source

The source for the waveform.

Remarks

The Source parameter can be specified in one of the following formats:

  • Channel<n>, where n: from 1 to the number of analog channels.
  • WMEM<r>, where r: 1-2
  • Math<m>, where m: 1-4

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:STORe {Source}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


WaveGens Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3..::.WaveGens Property
IAgInfiniiVision3 See Also

Pointer to the IAgInfiniiVisionWaveGens interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WaveGens As IAgInfiniiVisionWaveGens
C#
public IAgInfiniiVisionWaveGens  WaveGens { get; }
Visual C++
HRESULT get_WaveGens(
    IAgInfiniiVisionWaveGens**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision3 Interface
Agilent.AgInfiniiVision.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens..::.Count Property
IAgInfiniiVisionWaveGens See Also

Returns the number of wavegens.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGens Interface
Agilent.AgInfiniiVision.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens..::.Item Property
IAgInfiniiVisionWaveGens See Also

Pointer to the IAgInfiniiVisionWaveGen interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgInfiniiVisionWaveGen
C#
public IAgInfiniiVisionWaveGen  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgInfiniiVisionWaveGen**  val
);

Parameters

Name

The name of a wavegen. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the WaveGen repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGens Interface
Agilent.AgInfiniiVision.Interop Namespace


AdditionalNoise Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.AdditionalNoise Property
IAgInfiniiVisionWaveGen See Also

Specifies the amount of noise to add to the currently selected signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AdditionalNoise As Integer
C#
public int  AdditionalNoise { get; set; }
Visual C++
HRESULT get_AdditionalNoise(
    long*  val
);
HRESULT put_AdditionalNoise(
    long  val
);

Remarks

The sum of the amplitude between the original signal and injected noise is limited to the regular amplitude limit (for example, 5 Vpp in 1 MOhm), so the range for input value varies according to current amplitude.

Note that adding noise affects edge triggering on the waveform generator source as well as the waveform generator sync pulse output signal. This is because the trigger comparator is located after the noise source.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:NOISe {value}
    :WGEN{WaveGen}:MODulation:NOISe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Amplitude Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Amplitude Property
IAgInfiniiVisionWaveGen See Also

Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Amplitude As Double
C#
public double  Amplitude { get; set; }
Visual C++
HRESULT get_Amplitude(
    double*  val
);
HRESULT put_Amplitude(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage {value}
    :WGEN{WaveGen}:VOLTage?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Arbitrary Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Arbitrary Property
IAgInfiniiVisionWaveGen See Also

Pointer to the IAgInfiniiVisionWaveGenArbitrary interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Arbitrary As IAgInfiniiVisionWaveGenArbitrary
C#
public IAgInfiniiVisionWaveGenArbitrary  Arbitrary { get; }
Visual C++
HRESULT get_Arbitrary(
    IAgInfiniiVisionWaveGenArbitrary**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGen Interface
Agilent.AgInfiniiVision.Interop Namespace


Attribute Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.Attribute Property
IAgInfiniiVisionWaveGenArbitrary See Also

Pointer to the IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Attribute As IAgInfiniiVisionWaveGenArbitraryAttribute
C#
public IAgInfiniiVisionWaveGenArbitraryAttribute  Attribute { get; }
Visual C++
HRESULT get_Attribute(
    IAgInfiniiVisionWaveGenArbitraryAttribute**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGenArbitrary Interface
Agilent.AgInfiniiVision.Interop Namespace


NumberOfPoints Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitraryAttribute..::.NumberOfPoints Property
IAgInfiniiVisionWaveGenArbitraryAttribute See Also

Read Only - Queries the number of points used by the current Arbitrary waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NumberOfPoints As Integer
C#
public int  NumberOfPoints { get; }
Visual C++
HRESULT get_NumberOfPoints(
    long*  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:ATTRibute:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitraryAttribute Interface
    Agilent.AgInfiniiVision.Interop Namespace


ByteOrder Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.ByteOrder Property
IAgInfiniiVisionWaveGenArbitrary See Also

Specifies the byte order for binary transfers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property ByteOrder As AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum
C#
public AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum  ByteOrder { get; set; }
Visual C++
HRESULT get_ByteOrder(
    AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum*  val
);
HRESULT put_ByteOrder(
    AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum  val
);

Remarks

The ByteOrder property can be set to one of the following values:

  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderLSBFirst - specifies the LSB first byte order
  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderMSBFirst - specifies the MSB first byte order
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:BYTeorder {LSBF|MSBF}
    :WGEN{WaveGen}:ARBitrary:BYTeorder?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Interpolation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.Interpolation Property
IAgInfiniiVisionWaveGenArbitrary See Also

Enables or disables the Interpolation control.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Interpolation As Boolean
C#
public bool  Interpolation { get; set; }
Visual C++
HRESULT get_Interpolation(
    VARIANT_BOOL*  val
);
HRESULT put_Interpolation(
    VARIANT_BOOL  val
);

Remarks

Interpolation specifies how lines are drawn between arbitrary waveform points:
When ON, lines are drawn between points in the arbitrary waveform. Voltage levels change linearly between one point and the next.
When OFF, all line segments in the arbitrary waveform are horizontal. The voltage level of one point remains until the next point.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:INTerpolate {ON|OFF}
    :WGEN{WaveGen}:ARBitrary:INTerpolate?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.Reset Method
IAgInfiniiVisionWaveGenArbitrary See Also

Clears the Arbitrary waveform memory and loads it with the default waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:CLEar

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetData Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.SetData Method
IAgInfiniiVisionWaveGenArbitrary See Also

Downloads an arbitrary waveform in floating-point values format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetData ( _
    ByVal  Values As Double()   _
)
C#
public void  SetData(
    double[]   Values
)
Visual C++
HRESULT SetData(
    SAFEARRAY**  Values
);

Parameters

Values

Specifies the floating-point values between -1.0 and +1.0 for the arbitrary waveform.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


SetDataDAC Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.SetDataDAC Method
IAgInfiniiVisionWaveGenArbitrary See Also

Downloads an arbitrary waveform in integer (DAC) values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub SetDataDAC ( _
    ByVal  Values As Short()   _
)
C#
public void  SetDataDAC(
    short[]   Values
)
Visual C++
HRESULT SetDataDAC(
    SAFEARRAY**  Values
);

Parameters

Values

Specifies the decimal-integer values between -512 and +511 for the arbitrary waveform.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only (i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:DAC {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGenArbitrary Interface
    Agilent.AgInfiniiVision.Interop Namespace


Store Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary..::.Store Method
IAgInfiniiVisionWaveGenArbitrary See Also

Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Store ( _
    ByVal  Source As String  _
)
C#
public void  Store(
    string  Source
)
Visual C++
HRESULT Store(
    BSTR  Source
);

Parameters

Source

The source for the waveform.

Remarks

The Source parameter can be specified in one of the following formats:

  • Channel<n>, where n: from 1 to the number of analog channels.
  • WMEM<r>, where r: 1-2
  • Math<m>, where m: 1-4
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only (i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

Instrument Command

:WGEN{WaveGen}:ARBitrary:STORe {Source}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionWaveGenArbitrary Interface
Agilent.AgInfiniiVision.Interop Namespace


DutyCycle Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.DutyCycle Property
IAgInfiniiVisionWaveGen See Also

Square wave duty cycle(20% to 80%) for Square waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property DutyCycle As Double
C#
public double  DutyCycle { get; set; }
Visual C++
HRESULT get_DutyCycle(
    double*  val
);
HRESULT put_DutyCycle(
    double  val
);

Remarks

  • Duty cycle is the percentage of the period that the waveform is high.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:SQUare:DCYCle {value}
    :WGEN{WaveGen}:FUNCtion:SQUare:DCYCle?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Frequency Property
IAgInfiniiVisionWaveGen See Also

Frequency for Sine, Square, Ramp, and Pulse waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frequency As Double
C#
public double  Frequency { get; set; }
Visual C++
HRESULT get_Frequency(
    double*  val
);
HRESULT put_Frequency(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FREQuency {value}
    :WGEN{WaveGen}:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Function Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Function Property
IAgInfiniiVisionWaveGen See Also

Type of waveform.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Function As AgInfiniiVisionWaveformGeneratorFunctionEnum
C#
public AgInfiniiVisionWaveformGeneratorFunctionEnum  Function { get; set; }
Visual C++
HRESULT get_Function(
    AgInfiniiVisionWaveformGeneratorFunctionEnum*  val
);
HRESULT put_Function(
    AgInfiniiVisionWaveformGeneratorFunctionEnum  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion {SIN|SQU|RAMP|PULS|NOIS|DC|SINC|EXPR|EXPF|CARD|GAUS|ARB}
    :WGEN{WaveGen}:FUNCtion?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


HighVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.HighVoltage Property
IAgInfiniiVisionWaveGen See Also

High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property HighVoltage As Double
C#
public double  HighVoltage { get; set; }
Visual C++
HRESULT get_HighVoltage(
    double*  val
);
HRESULT put_HighVoltage(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:HIGH {value}
    :WGEN{WaveGen}:VOLTage:HIGH?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


LowVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.LowVoltage Property
IAgInfiniiVisionWaveGen See Also

Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property LowVoltage As Double
C#
public double  LowVoltage { get; set; }
Visual C++
HRESULT get_LowVoltage(
    double*  val
);
HRESULT put_LowVoltage(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:LOW {value}
    :WGEN{WaveGen}:VOLTage:LOW?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Modulation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Modulation Property
IAgInfiniiVisionWaveGen See Also

Pointer to the IAgInfiniiVisionWaveGenModulation interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Modulation As IAgInfiniiVisionWaveGenModulation
C#
public IAgInfiniiVisionWaveGenModulation  Modulation { get; }
Visual C++
HRESULT get_Modulation(
    IAgInfiniiVisionWaveGenModulation**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGen Interface
Agilent.AgInfiniiVision.Interop Namespace


AM Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.AM Property
IAgInfiniiVisionWaveGenModulation See Also

Pointer to the IAgInfiniiVisionTrigger3ModulationAM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AM As IAgInfiniiVisionWaveGenModulationAM
C#
public IAgInfiniiVisionWaveGenModulationAM  AM { get; }
Visual C++
HRESULT get_AM(
    IAgInfiniiVisionWaveGenModulationAM**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGenModulation Interface
Agilent.AgInfiniiVision.Interop Namespace


Depth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationAM..::.Depth Property
IAgInfiniiVisionWaveGenModulationAM See Also

Specifies the amount of amplitude modulation.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Depth As Double
C#
public double  Depth { get; set; }
Visual C++
HRESULT get_Depth(
    double*  val
);
HRESULT put_Depth(
    double  val
);

Remarks

  • AM Depth refers to the portion of the amplitude range that will be used by the modulation. For example, a depth setting of 80% causes the output amplitude to vary from 10% to 90% (90% ? 10% = 80%) of the original amplitude as the modulating signal goes from its minimum to maximum amplitude.
  • Input ranges from 0 to 100.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:AM:DEPTh {value}
    :WGEN{WaveGen}:MODulation:AM:DEPTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationAM Interface
    Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationAM..::.Frequency Property
IAgInfiniiVisionWaveGenModulationAM See Also

Specifies the frequency of the modulating signal. Frequency in Hz .

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frequency As Double
C#
public double  Frequency { get; set; }
Visual C++
HRESULT get_Frequency(
    double*  val
);
HRESULT put_Frequency(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:AM:FREQuency {value}
    :WGEN{WaveGen}:MODulation:AM:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationAM Interface
    Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.Enabled Property
IAgInfiniiVisionWaveGenModulation See Also

Enables or disables modulated waveform generator output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • You can enable modulation for all waveform generator function types except pulse, DC, and noise.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:STATe {ON|OFF}
    :WGEN{WaveGen}:MODulation:STATe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulation Interface
    Agilent.AgInfiniiVision.Interop Namespace


FM Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.FM Property
IAgInfiniiVisionWaveGenModulation See Also

Pointer to the IAgInfiniiVisionTrigger3ModulationFM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FM As IAgInfiniiVisionWaveGenModulationFM
C#
public IAgInfiniiVisionWaveGenModulationFM  FM { get; }
Visual C++
HRESULT get_FM(
    IAgInfiniiVisionWaveGenModulationFM**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGenModulation Interface
Agilent.AgInfiniiVision.Interop Namespace


Deviation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFM..::.Deviation Property
IAgInfiniiVisionWaveGenModulationFM See Also

Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Deviation As Double
C#
public double  Deviation { get; set; }
Visual C++
HRESULT get_Deviation(
    double*  val
);
HRESULT put_Deviation(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FM:DEViation {value}
    :WGEN{WaveGen}:MODulation:FM:DEViation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationFM Interface
    Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFM..::.Frequency Property
IAgInfiniiVisionWaveGenModulationFM See Also

Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frequency As Double
C#
public double  Frequency { get; set; }
Visual C++
HRESULT get_Frequency(
    double*  val
);
HRESULT put_Frequency(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FM:FREQuency {value}
    :WGEN{WaveGen}:MODulation:FM:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationFM Interface
    Agilent.AgInfiniiVision.Interop Namespace


FSK Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.FSK Property
IAgInfiniiVisionWaveGenModulation See Also

Pointer to the IAgInfiniiVisionTrigger3ModulationFSK interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FSK As IAgInfiniiVisionWaveGenModulationFSK
C#
public IAgInfiniiVisionWaveGenModulationFSK  FSK { get; }
Visual C++
HRESULT get_FSK(
    IAgInfiniiVisionWaveGenModulationFSK**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGenModulation Interface
Agilent.AgInfiniiVision.Interop Namespace


Frequency Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFSK..::.Frequency Property
IAgInfiniiVisionWaveGenModulationFSK See Also

Specifies the "hop frequency". Hop frequency in Hz

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Frequency As Double
C#
public double  Frequency { get; set; }
Visual C++
HRESULT get_Frequency(
    double*  val
);
HRESULT put_Frequency(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FSKey:FREQuency {value}
    :WGEN{WaveGen}:MODulation:FSKey:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationFSK Interface
    Agilent.AgInfiniiVision.Interop Namespace


Rate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFSK..::.Rate Property
IAgInfiniiVisionWaveGenModulationFSK See Also

Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Rate As Double
C#
public double  Rate { get; set; }
Visual C++
HRESULT get_Rate(
    double*  val
);
HRESULT put_Rate(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FSKey:RATE {value}
    :WGEN{WaveGen}:MODulation:FSKey:RATE?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulationFSK Interface
    Agilent.AgInfiniiVision.Interop Namespace


Function Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.Function Property
IAgInfiniiVisionWaveGenModulation See Also

Specifies the shape of the modulating signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Function As AgInfiniiVisionModulationFunctionEnum
C#
public AgInfiniiVisionModulationFunctionEnum  Function { get; set; }
Visual C++
HRESULT get_Function(
    AgInfiniiVisionModulationFunctionEnum*  val
);
HRESULT put_Function(
    AgInfiniiVisionModulationFunctionEnum  val
);

Remarks

  • When the AgInfiniiVisionModulationFunctionRamp is selected, you can specify the amount of time per cycle that the ramp waveform is rising with the RampSymmetry property.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FUNCtion {SIN|SQU|RAMP}
    :WGEN{WaveGen}:MODulation:FUNCtion?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulation Interface
    Agilent.AgInfiniiVision.Interop Namespace


RampSymmetry Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.RampSymmetry Property
IAgInfiniiVisionWaveGenModulation See Also

Specifies the amount of time per cycle that the ramp waveform is rising.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RampSymmetry As Double
C#
public double  RampSymmetry { get; set; }
Visual C++
HRESULT get_RampSymmetry(
    double*  val
);
HRESULT put_RampSymmetry(
    double  val
);

Remarks

  • The ramp modulating waveform shape is specified with the Function property.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FUNCtion:RAMP:SYMMetry {value}
    :WGEN{WaveGen}:MODulation:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulation Interface
    Agilent.AgInfiniiVision.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation..::.Type Property
IAgInfiniiVisionWaveGenModulation See Also

Specifies the modulation type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgInfiniiVisionModulationTypeEnum
C#
public AgInfiniiVisionModulationTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgInfiniiVisionModulationTypeEnum*  val
);
HRESULT put_Type(
    AgInfiniiVisionModulationTypeEnum  val
);

Remarks

AgInfiniiVisionModulationTypeAM - the amplitude of the original carrier signal is modified according to the amplitude of the modulating signal.

  • Use the IAgInfiniiVisionWaveGenModulationAM.Frequency property to set the modulating signal frequency.
  • Use the IAgInfiniiVisionWaveGenModulationAM.Depth property to specify the amount of amplitude modulation.

    • AgInfiniiVisionModulationTypeFM - the frequency of the original carrier signal is modified according to the amplitude of the modulating signal.
  • Use the IAgInfiniiVisionWaveGenModulationFM.Frequency property to set the modulating signal frequency.
  • Use the IAgInfiniiVisionWaveGenModulationFM.Deviation property to specify the frequency deviation from the original carrier signal frequency.

    • AgInfiniiVisionModulationType - the output frequency "shifts" between the original carrier frequency and a "hop frequency" at the specified FSK rate.
    The FSK rate specifies a digital square wave modulating signal.
  • Use the IAgInfiniiVisionWaveGenModulationFSK.Frequency property to specify the "hop frequency".
  • Use the IAgInfiniiVisionWaveGenModulationFSK.Rate property to specify the rate at which the output frequency "shifts".

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:TYPE {AM|FM|FSK}
    :WGEN{WaveGen}:MODulation:TYPE?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGenModulation Interface
    Agilent.AgInfiniiVision.Interop Namespace


OffsetVoltage Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.OffsetVoltage Property
IAgInfiniiVisionWaveGen See Also

Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OffsetVoltage As Double
C#
public double  OffsetVoltage { get; set; }
Visual C++
HRESULT get_OffsetVoltage(
    double*  val
);
HRESULT put_OffsetVoltage(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:OFFSet {value}
    :WGEN{WaveGen}:VOLTage:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


OutputEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.OutputEnabled Property
IAgInfiniiVisionWaveGen See Also

Enables or Disables waveform generator signal output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut {ON|OFF}
    :WGEN{WaveGen}:OUTPut?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


OutputInverted Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.OutputInverted Property
IAgInfiniiVisionWaveGen See Also

Specifies whether the waveform generator output is inverted or not.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputInverted As Boolean
C#
public bool  OutputInverted { get; set; }
Visual C++
HRESULT get_OutputInverted(
    VARIANT_BOOL*  val
);
HRESULT put_OutputInverted(
    VARIANT_BOOL  val
);

Remarks

  • True => Inverted
    • False => Normal

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut:POLarity {INV|NORM}
    :WGEN{WaveGen}:OUTPut:POLarity?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


OutputLoadImpedance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.OutputLoadImpedance Property
IAgInfiniiVisionWaveGen See Also

Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputLoadImpedance As AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum
C#
public AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  OutputLoadImpedance { get; set; }
Visual C++
HRESULT get_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum*  val
);
HRESULT put_OutputLoadImpedance(
    AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum  val
);

Remarks

If the actual load impedance is different than the selected value, the displayed amplitude and offset levels will be incorrect.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut:LOAD {ONEM|FIFT}
    :WGEN{WaveGen}:OUTPut:LOAD?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Period Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Period Property
IAgInfiniiVisionWaveGen See Also

Period in seconds for Sine, Square, Ramp, and Pulse waveforms

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Period As Double
C#
public double  Period { get; set; }
Visual C++
HRESULT get_Period(
    double*  val
);
HRESULT put_Period(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:PERiod {value}
    :WGEN{WaveGen}:PERiod?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


PulseWidth Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.PulseWidth Property
IAgInfiniiVisionWaveGen See Also

Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property PulseWidth As Double
C#
public double  PulseWidth { get; set; }
Visual C++
HRESULT get_PulseWidth(
    double*  val
);
HRESULT put_PulseWidth(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:PULSe:WIDTh {value}
    :WGEN{WaveGen}:FUNCtion:PULSe:WIDTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


RampSymmetry Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.RampSymmetry Property
IAgInfiniiVisionWaveGen See Also

Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property RampSymmetry As Double
C#
public double  RampSymmetry { get; set; }
Visual C++
HRESULT get_RampSymmetry(
    double*  val
);
HRESULT put_RampSymmetry(
    double  val
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:RAMP:SYMMetry {value}
    :WGEN{WaveGen}:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Reset Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Reset Method
IAgInfiniiVisionWaveGen See Also

Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:RST

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    IAgInfiniiVisionWaveGen Interface
    Agilent.AgInfiniiVision.Interop Namespace


Tracking Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen..::.Tracking Property
IAgInfiniiVisionWaveGen See Also

Pointer to the IAgInfiniiVisionWaveGenTracking interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Tracking As IAgInfiniiVisionWaveGenTracking
C#
public IAgInfiniiVisionWaveGenTracking  Tracking { get; }
Visual C++
HRESULT get_Tracking(
    IAgInfiniiVisionWaveGenTracking**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGen Interface
Agilent.AgInfiniiVision.Interop Namespace


AmplitudeEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenTracking..::.AmplitudeEnabled Property
IAgInfiniiVisionWaveGenTracking See Also

If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property AmplitudeEnabled As Boolean
C#
public bool  AmplitudeEnabled { get; set; }
Visual C++
HRESULT get_AmplitudeEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_AmplitudeEnabled(
    VARIANT_BOOL  val
);

Remarks

  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:AMPLitude {ON|OFF}
    :WGEN{WaveGen}:TRACk:AMPLitude?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionWaveGenTracking Interface
    Agilent.AgInfiniiVision.Interop Namespace


CopySignal Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenTracking..::.CopySignal Method
IAgInfiniiVisionWaveGenTracking See Also

Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub CopySignal ( _
)
C#
public void  CopySignal(
)
Visual C++
HRESULT CopySignal(
);

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:CSIGnal

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionWaveGenTracking Interface
    Agilent.AgInfiniiVision.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenTracking..::.Enabled Property
IAgInfiniiVisionWaveGenTracking See Also

If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

  • Not all waveform shapes can be frequency tracked.
  • When Enabled or Frequency property is true, the other generator's waveform selections IAgInfiniiVisionWaveGen.Function must be in the same group as this generator's waveform.
  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk {ON|OFF}
    :WGEN{WaveGen}:TRACk?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionWaveGenTracking Interface
    Agilent.AgInfiniiVision.Interop Namespace


FrequencyEnabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenTracking..::.FrequencyEnabled Property
IAgInfiniiVisionWaveGenTracking See Also

If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property FrequencyEnabled As Boolean
C#
public bool  FrequencyEnabled { get; set; }
Visual C++
HRESULT get_FrequencyEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_FrequencyEnabled(
    VARIANT_BOOL  val
);

Remarks

  • Not all waveform shapes can be frequency tracked.
  • When Enabled property or Frequency property is true, the other generator's waveform selections IAgInfiniiVisionWaveGen.Function must be in the same group as this generator's waveform.
  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:FREQuency {ON|OFF}
    :WGEN{WaveGen}:TRACk:FREQuency?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    IAgInfiniiVisionWaveGenTracking Interface
    Agilent.AgInfiniiVision.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens..::.Name Property
IAgInfiniiVisionWaveGens See Also

Returns the wavegen name for a given index.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of wavegens.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGens Interface
Agilent.AgInfiniiVision.Interop Namespace


WaveGens2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision6..::.WaveGens2 Property
IAgInfiniiVision6 See Also

Pointer to the IAgInfiniiVisionWaveGens interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property WaveGens2 As IAgInfiniiVisionWaveGens2
C#
public IAgInfiniiVisionWaveGens2  WaveGens2 { get; }
Visual C++
HRESULT get_WaveGens2(
    IAgInfiniiVisionWaveGens2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVision6 Interface
Agilent.AgInfiniiVision.Interop Namespace


Item2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens2..::.Item2 Property
IAgInfiniiVisionWaveGens2 See Also

Pointer to the IAgInfiniiVisionWaveGen interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgInfiniiVisionWaveGen2
C#
public IAgInfiniiVisionWaveGen2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgInfiniiVisionWaveGen2**  val
);

Parameters

Name

The name of a wavegen. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the WaveGen repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGens2 Interface
Agilent.AgInfiniiVision.Interop Namespace


OutputMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2..::.OutputMode Property
IAgInfiniiVisionWaveGen2 See Also

Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property OutputMode As AgInfiniiVisionWaveformGeneratorOutputModeEnum
C#
public AgInfiniiVisionWaveformGeneratorOutputModeEnum  OutputMode { get; set; }
Visual C++
HRESULT get_OutputMode(
    AgInfiniiVisionWaveformGeneratorOutputModeEnum*  val
);
HRESULT put_OutputMode(
    AgInfiniiVisionWaveformGeneratorOutputModeEnum  val
);

Instrument Command

:WGEN{WaveGen}:OUTPut:MODE {NORM|SING}
:WGEN{WaveGen}:OUTPut:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionWaveGen2 Interface
Agilent.AgInfiniiVision.Interop Namespace


OutputSingle Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2..::.OutputSingle Method
IAgInfiniiVisionWaveGen2 See Also

Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Sub OutputSingle ( _
)
C#
public void  OutputSingle(
)
Visual C++
HRESULT OutputSingle(
);

Instrument Command

:WGEN{WaveGen}:OUTPut:SINGle

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IAgInfiniiVisionWaveGen2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Tracking2 Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2..::.Tracking2 Property
IAgInfiniiVisionWaveGen2 See Also

Pointer to the IAgInfiniiVisionWaveGenTracking interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Tracking2 As IAgInfiniiVisionWaveGen2Tracking2
C#
public IAgInfiniiVisionWaveGen2Tracking2  Tracking2 { get; }
Visual C++
HRESULT get_Tracking2(
    IAgInfiniiVisionWaveGen2Tracking2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgInfiniiVisionWaveGen2 Interface
Agilent.AgInfiniiVision.Interop Namespace


Phase Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2Tracking2..::.Phase Property
IAgInfiniiVisionWaveGen2Tracking2 See Also

Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Property Phase As Integer
C#
public int  Phase { get; set; }
Visual C++
HRESULT get_Phase(
    long*  val
);
HRESULT put_Phase(
    long  val
);

Instrument Command

:WGEN{WaveGen}:TRACk:PHASe {value}
:WGEN{WaveGen}:TRACk:PHASe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

IAgInfiniiVisionWaveGen2Tracking2 Interface
Agilent.AgInfiniiVision.Interop Namespace


IIviScope Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope Interface
See Also

IVI Scope class-compliant root interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScope
   Inherits IIviDriver
C#
public interface IIviScope : IIviDriver
Visual C++
__interface IIviScope : IIviDriver

Properties

 | Name | Description
Public property | Acquisition | Pointer to the class-compliant IIviScopeAcquisition interface
Public property | Channels | Pointer to the class-compliant IIviScopeChannels interface
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Measurements | Pointer to the class-compliant IIviScopeMeasurements interface
Public property | ReferenceLevel | Pointer to the class-compliant IIviScopeReferenceLevel interface
Public property | Trigger | Pointer to the class-compliant IIviScopeTrigger interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Acquisition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope..::.Acquisition Property
IIviScope See Also

Pointer to the class-compliant IIviScopeAcquisition interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition As IIviScopeAcquisition
C#
public IIviScopeAcquisition  Acquisition { get; }
Visual C++
HRESULT get_Acquisition(
    IIviScopeAcquisition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


ConfigureRecord Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.ConfigureRecord Method
IIviScopeAcquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureRecord ( _
    ByVal  TimePerRecord As Double  _
    ByVal  MinNumPts As Integer  _
    ByVal  AcquisitionStartTime As Double  _
)
C#
public void  ConfigureRecord(
    double  TimePerRecord,
    int  MinNumPts,
    double  AcquisitionStartTime
)
Visual C++
HRESULT ConfigureRecord(
    double  TimePerRecord,
    long  MinNumPts,
    double  AcquisitionStartTime
);

Parameters

TimePerRecord

Specifies the time per record. This value sets the Horizontal Time Per Record property.

MinNumPts

Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.

AcquisitionStartTime

Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Interpolation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.Interpolation Property
IIviScopeAcquisition See Also

The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Interpolation As IviScopeInterpolationEnum
C#
public IviScopeInterpolationEnum  Interpolation { get; set; }
Visual C++
HRESULT get_Interpolation(
    IviScopeInterpolationEnum*  val
);
HRESULT put_Interpolation(
    IviScopeInterpolationEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfAverages Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.NumberOfAverages Property
IIviScopeAcquisition See Also

The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfAverages As Integer
C#
public int  NumberOfAverages { get; set; }
Visual C++
HRESULT get_NumberOfAverages(
    long*  val
);
HRESULT put_NumberOfAverages(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfEnvelopes Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.NumberOfEnvelopes Property
IIviScopeAcquisition See Also

The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfEnvelopes As Integer
C#
public int  NumberOfEnvelopes { get; set; }
Visual C++
HRESULT get_NumberOfEnvelopes(
    long*  val
);
HRESULT put_NumberOfEnvelopes(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfPointsMin Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.NumberOfPointsMin Property
IIviScopeAcquisition See Also

The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfPointsMin As Integer
C#
public int  NumberOfPointsMin { get; set; }
Visual C++
HRESULT get_NumberOfPointsMin(
    long*  val
);
HRESULT put_NumberOfPointsMin(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


RecordLength Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.RecordLength Property
IIviScopeAcquisition See Also

The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordLength As Integer
C#
public int  RecordLength { get; }
Visual C++
HRESULT get_RecordLength(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


SampleMode Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.SampleMode Property
IIviScopeAcquisition See Also

The sample mode the oscilloscope is currently using.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleMode As IviScopeSampleModeEnum
C#
public IviScopeSampleModeEnum  SampleMode { get; }
Visual C++
HRESULT get_SampleMode(
    IviScopeSampleModeEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


SampleRate Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.SampleRate Property
IIviScopeAcquisition See Also

The effective digitizing rate using the current configuration. The units are samples per second.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleRate As Double
C#
public double  SampleRate { get; }
Visual C++
HRESULT get_SampleRate(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


StartTime Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.StartTime Property
IIviScopeAcquisition See Also

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property StartTime As Double
C#
public double  StartTime { get; set; }
Visual C++
HRESULT get_StartTime(
    double*  val
);
HRESULT put_StartTime(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


TimePerRecord Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.TimePerRecord Property
IIviScopeAcquisition See Also

The time in seconds that corresponds to the record length.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property TimePerRecord As Double
C#
public double  TimePerRecord { get; set; }
Visual C++
HRESULT get_TimePerRecord(
    double*  val
);
HRESULT put_TimePerRecord(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition..::.Type Property
IIviScopeAcquisition See Also

How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviScopeAcquisitionTypeEnum
C#
public IviScopeAcquisitionTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviScopeAcquisitionTypeEnum*  val
);
HRESULT put_Type(
    IviScopeAcquisitionTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Channels Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope..::.Channels Property
IIviScope See Also

Pointer to the class-compliant IIviScopeChannels interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels As IIviScopeChannels
C#
public IIviScopeChannels  Channels { get; }
Visual C++
HRESULT get_Channels(
    IIviScopeChannels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannels..::.Count Property
IIviScopeChannels See Also

The number of channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannels..::.Item Property
IIviScopeChannels See Also

An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviScopeChannel
C#
public IIviScopeChannel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviScopeChannel**  val
);

Parameters

Name

The name of a channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.Configure Method
IIviScopeChannel See Also

Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Range As Double  _
    ByVal  Offset As Double  _
    ByVal  Coupling As IviScopeVerticalCouplingEnum  _
    ByVal  ProbeAttenuation As Double  _
    ByVal  Enabled As Boolean  _
)
C#
public void  Configure(
    double  Range,
    double  Offset,
    IviScopeVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    bool  Enabled
)
Visual C++
HRESULT Configure(
    double  Range,
    double  Offset,
    IviScopeVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    VARIANT_BOOL  Enabled
);

Parameters

Range

Specifies the vertical range. This value sets the Vertical Range property.

Offset

Specifies the vertical offset. This value sets the Vertical Offset property.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

ProbeAttenuation

Specifies the probe attenuation. This value sets the Probe Attenuation property.

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ConfigureCharacteristics Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.ConfigureCharacteristics Method
IIviScopeChannel See Also

Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureCharacteristics ( _
    ByVal  InputImpedance As Double  _
    ByVal  InputFrequencyMax As Double  _
)
C#
public void  ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
)
Visual C++
HRESULT ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
);

Parameters

InputImpedance

The input impedance for the channel. The driver sets the Input Impedance to this value.

InputFrequencyMax

The maximum input frequency for the channel. The driver sets the Max Input Frequency to this value.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Coupling Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.Coupling Property
IIviScopeChannel See Also

How the oscilloscope couples the input signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviScopeVerticalCouplingEnum
C#
public IviScopeVerticalCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviScopeVerticalCouplingEnum*  val
);
HRESULT put_Coupling(
    IviScopeVerticalCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Enabled Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.Enabled Property
IIviScopeChannel See Also

If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


InputFrequencyMax Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.InputFrequencyMax Property
IIviScopeChannel See Also

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property InputFrequencyMax As Double
C#
public double  InputFrequencyMax { get; set; }
Visual C++
HRESULT get_InputFrequencyMax(
    double*  val
);
HRESULT put_InputFrequencyMax(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


InputImpedance Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.InputImpedance Property
IIviScopeChannel See Also

The input impedance of this channel. The units are ohms.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property InputImpedance As Double
C#
public double  InputImpedance { get; set; }
Visual C++
HRESULT get_InputImpedance(
    double*  val
);
HRESULT put_InputImpedance(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Offset Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.Offset Property
IIviScopeChannel See Also

The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ProbeAttenuation Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.ProbeAttenuation Property
IIviScopeChannel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ProbeAttenuation As Double
C#
public double  ProbeAttenuation { get; set; }
Visual C++
HRESULT get_ProbeAttenuation(
    double*  val
);
HRESULT put_ProbeAttenuation(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ProbeSense Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.ProbeSense Property
IIviScopeChannel See Also

The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeSense As Double
C#
public double  ProbeSense { get; }
Visual C++
HRESULT get_ProbeSense(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Range Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel..::.Range Property
IIviScopeChannel See Also

The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannels..::.Name Property
IIviScopeChannels See Also

The channel name for a given index.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of channels.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Measurements Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope..::.Measurements Property
IIviScope See Also

Pointer to the class-compliant IIviScopeMeasurements interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurements As IIviScopeMeasurements
C#
public IIviScopeMeasurements  Measurements { get; }
Visual C++
HRESULT get_Measurements(
    IIviScopeMeasurements**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Abort Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Abort Method
IIviScopeMeasurements See Also

Aborts an acquisition and returns the oscilloscope to the Idle state.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Abort ( _
)
C#
public void  Abort(
)
Visual C++
HRESULT Abort(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


AutoSetup Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.AutoSetup Method
IIviScopeMeasurements See Also

Automatically configures all the oscilloscopes settings based on the input signals.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Count Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Count Property
IIviScopeMeasurements See Also

Returns the number of channels that measurements can use as a source.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Initiate Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Initiate Method
IIviScopeMeasurements See Also

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Initiate ( _
)
C#
public void  Initiate(
)
Visual C++
HRESULT Initiate(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


IsWaveformElementInvalid Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.IsWaveformElementInvalid Method
IIviScopeMeasurements See Also

Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Function IsWaveformElementInvalid ( _
    ByVal  Element As Double  _
) As Boolean
C#
public bool  IsWaveformElementInvalid(
    double  Element
)
Visual C++
HRESULT IsWaveformElementInvalid(
    double  Element
    VARIANT_BOOL*  retval
);

Parameters

Element

Pass one of the values from the waveform array returned by the read and fetch waveform methods.

Return Value

True if an element in the waveform array is invalid. False otherwise.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Item Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Item Property
IIviScopeMeasurements See Also

An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviScopeMeasurement
C#
public IIviScopeMeasurement  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviScopeMeasurement**  val
);

Parameters

Name

The name of a channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


FetchWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.FetchWaveform Method
IIviScopeMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveform ( _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveform(
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveform(
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


FetchWaveformMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.FetchWaveformMeasurement Method
IIviScopeMeasurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMeasurement ( _
    ByVal  MeasFunction As IviScopeMeasurementEnum  _
    ByRef  Measurement As Double  _
)
C#
public void  FetchWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    ref double  Measurement
)
Visual C++
HRESULT FetchWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


FetchWaveformMinMax Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.FetchWaveformMinMax Method
IIviScopeMeasurement See Also

Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMinMax ( _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveformMinMax(
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveformMinMax(
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveform Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.ReadWaveform Method
IIviScopeMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveform ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveform(
    int  MaxTimeMilliseconds,
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveform(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveformMeasurement Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.ReadWaveformMeasurement Method
IIviScopeMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMeasurement ( _
    ByVal  MeasFunction As IviScopeMeasurementEnum  _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  Measurement As Double  _
)
C#
public void  ReadWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    int  MaxTimeMilliseconds,
    ref double  Measurement
)
Visual C++
HRESULT ReadWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    long  MaxTimeMilliseconds,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveformMinMax Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement..::.ReadWaveformMinMax Method
IIviScopeMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMinMax ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveformMinMax(
    int  MaxTimeMilliseconds,
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveformMinMax(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


Name Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Name Property
IIviScopeMeasurements See Also

The measurement name for given index.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of measurements.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Status Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements..::.Status Method
IIviScopeMeasurements See Also

Returns whether an acquisition is in progress, complete, or if the status is unknown.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Function Status ( _
) As IviScopeAcquisitionStatusEnum
C#
public IviScopeAcquisitionStatusEnum  Status(
)
Visual C++
HRESULT Status(
    IviScopeAcquisitionStatusEnum*  retval
);

Return Value

The acquisition status.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


ReferenceLevel Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope..::.ReferenceLevel Property
IIviScope See Also

Pointer to the class-compliant IIviScopeReferenceLevel interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceLevel As IIviScopeReferenceLevel
C#
public IIviScopeReferenceLevel  ReferenceLevel { get; }
Visual C++
HRESULT get_ReferenceLevel(
    IIviScopeReferenceLevel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeReferenceLevel..::.Configure Method
IIviScopeReferenceLevel See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Low As Double  _
    ByVal  Mid As Double  _
    ByVal  High As Double  _
)
C#
public void  Configure(
    double  Low,
    double  Mid,
    double  High
)
Visual C++
HRESULT Configure(
    double  Low,
    double  Mid,
    double  High
);

Parameters

Low

Measurement low reference. This value sets the Meas Low Ref property

Mid

Measurement mid reference. This value sets the Meas Mid Ref property.

High

Measurement high reference. This value sets the Meas High Ref property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


High Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeReferenceLevel..::.High Property
IIviScopeReferenceLevel See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property High As Double
C#
public double  High { get; set; }
Visual C++
HRESULT get_High(
    double*  val
);
HRESULT put_High(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Low Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeReferenceLevel..::.Low Property
IIviScopeReferenceLevel See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Low As Double
C#
public double  Low { get; set; }
Visual C++
HRESULT get_Low(
    double*  val
);
HRESULT put_Low(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Mid Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeReferenceLevel..::.Mid Property
IIviScopeReferenceLevel See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Mid As Double
C#
public double  Mid { get; set; }
Visual C++
HRESULT get_Mid(
    double*  val
);
HRESULT put_Mid(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Trigger Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScope..::.Trigger Property
IIviScope See Also

Pointer to the class-compliant IIviScopeTrigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IIviScopeTrigger
C#
public IIviScopeTrigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IIviScopeTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


AcLine Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.AcLine Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerAcLine interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AcLine As IIviScopeTriggerAcLine
C#
public IIviScopeTriggerAcLine  AcLine { get; }
Visual C++
HRESULT get_AcLine(
    IIviScopeTriggerAcLine**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerAcLine..::.Slope Property
IIviScopeTriggerAcLine See Also

The slope of the zero crossing upon which the scope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviScopeACLineSlopeEnum
C#
public IviScopeACLineSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviScopeACLineSlopeEnum*  val
);
HRESULT put_Slope(
    IviScopeACLineSlopeEnum  val
);

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIviScopeTriggerAcLine Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Configure Method
IIviScopeTrigger See Also

Configures trigger Type and Holdoff. Holdoff units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Type As IviScopeTriggerTypeEnum  _
    ByVal  Holdoff As Double  _
)
C#
public void  Configure(
    IviScopeTriggerTypeEnum  Type,
    double  Holdoff
)
Visual C++
HRESULT Configure(
    IviScopeTriggerTypeEnum  Type,
    double  Holdoff
);

Parameters

Type

Specifies the trigger type. This value sets the Trigger Type property.

Holdoff

Specifies the trigger hold-off. This value sets the Trigger Holdoff property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Continuous Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Continuous Property
IIviScopeTrigger See Also

If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Continuous As Boolean
C#
public bool  Continuous { get; set; }
Visual C++
HRESULT get_Continuous(
    VARIANT_BOOL*  val
);
HRESULT put_Continuous(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Coupling Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Coupling Property
IIviScopeTrigger See Also

How the oscilloscope couples the trigger source.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviScopeTriggerCouplingEnum
C#
public IviScopeTriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviScopeTriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    IviScopeTriggerCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Edge Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Edge Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerEdge interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IIviScopeTriggerEdge
C#
public IIviScopeTriggerEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IIviScopeTriggerEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerEdge..::.Configure Method
IIviScopeTriggerEdge See Also

Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Slope As IviScopeTriggerSlopeEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    IviScopeTriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    IviScopeTriggerSlopeEnum  Slope
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Slope

Specifies the trigger slope. This value sets the Trigger Slope property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerEdge Interface
Ivi.Scope.Interop Namespace


Slope Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerEdge..::.Slope Property
IIviScopeTriggerEdge See Also

The slope, a rising or a falling edge, that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviScopeTriggerSlopeEnum
C#
public IviScopeTriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviScopeTriggerSlopeEnum*  val
);
HRESULT put_Slope(
    IviScopeTriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerEdge Interface
Ivi.Scope.Interop Namespace


Glitch Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Glitch Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerGlitch interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IIviScopeTriggerGlitch
C#
public IIviScopeTriggerGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IIviScopeTriggerGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerGlitch..::.condition Property
IIviScopeTriggerGlitch See Also

The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property condition As IviScopeGlitchConditionEnum
C#
public IviScopeGlitchConditionEnum  condition { get; set; }
Visual C++
HRESULT get_condition(
    IviScopeGlitchConditionEnum*  val
);
HRESULT put_condition(
    IviScopeGlitchConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerGlitch..::.Configure Method
IIviScopeTriggerGlitch See Also

Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Width As Double  _
    ByVal  polarity As IviScopeGlitchPolarityEnum  _
    ByVal  condition As IviScopeGlitchConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  Width,
    IviScopeGlitchPolarityEnum  polarity,
    IviScopeGlitchConditionEnum  condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  Width,
    IviScopeGlitchPolarityEnum  polarity,
    IviScopeGlitchConditionEnum  condition
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Width

Specifies the glitch triggering glitch width in seconds. This value sets the Glitch Width property.

polarity

Specifies the glitch polarity. This value sets the Glitch Polarity property.

condition

Specifies the glitch condition. This value sets the Glitch Condition property.

Remarks

Note: Trigger.Type should be set to IviScopeTriggerGlitch before executing this method.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerGlitch..::.polarity Property
IIviScopeTriggerGlitch See Also

The polarity of the glitch that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeGlitchPolarityEnum
C#
public IviScopeGlitchPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeGlitchPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeGlitchPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerGlitch..::.Width Property
IIviScopeTriggerGlitch See Also

The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Width As Double
C#
public double  Width { get; set; }
Visual C++
HRESULT get_Width(
    double*  val
);
HRESULT put_Width(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Holdoff Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Holdoff Property
IIviScopeTrigger See Also

The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Holdoff As Double
C#
public double  Holdoff { get; set; }
Visual C++
HRESULT get_Holdoff(
    double*  val
);
HRESULT put_Holdoff(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Level Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Level Property
IIviScopeTrigger See Also

The voltage threshold for the trigger subsystem. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Modifier Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Modifier Property
IIviScopeTrigger See Also

The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Modifier As IviScopeTriggerModifierEnum
C#
public IviScopeTriggerModifierEnum  Modifier { get; set; }
Visual C++
HRESULT get_Modifier(
    IviScopeTriggerModifierEnum*  val
);
HRESULT put_Modifier(
    IviScopeTriggerModifierEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Runt Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Runt Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerRunt interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IIviScopeTriggerRunt
C#
public IIviScopeTriggerRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IIviScopeTriggerRunt**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerRunt..::.Configure Method
IIviScopeTriggerRunt See Also

Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  polarity As IviScopeRuntPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeRuntPolarityEnum  polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeRuntPolarityEnum  polarity
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

polarity

Sets the runt polarity.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerRunt..::.polarity Property
IIviScopeTriggerRunt See Also

The polarity of the runt that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeRuntPolarityEnum
C#
public IviScopeRuntPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeRuntPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeRuntPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


ThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerRunt..::.ThresholdHigh Property
IIviScopeTriggerRunt See Also

The high threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


ThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerRunt..::.ThresholdLow Property
IIviScopeTriggerRunt See Also

The low threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


Source Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Source Property
IIviScopeTrigger See Also

The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


TV Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.TV Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerTv interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IIviScopeTriggerTv
C#
public IIviScopeTriggerTv  TV { get; }
Visual C++
HRESULT get_TV(
    IIviScopeTriggerTv**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv..::.Configure Method
IIviScopeTriggerTv See Also

Configures the TV trigger source, signal format, event and polarity.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  SignalFormat As IviScopeTVSignalFormatEnum  _
    ByVal  Event As IviScopeTVTriggerEventEnum  _
    ByVal  polarity As IviScopeTVTriggerPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    IviScopeTVSignalFormatEnum  SignalFormat,
    IviScopeTVTriggerEventEnum  Event,
    IviScopeTVTriggerPolarityEnum  polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    IviScopeTVSignalFormatEnum  SignalFormat,
    IviScopeTVTriggerEventEnum  Event,
    IviScopeTVTriggerPolarityEnum  polarity
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

SignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format property.

Event

Specifies the TV trigger event. This value sets the TV Trigger Event property.

polarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


Event Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv..::.Event Property
IIviScopeTriggerTv See Also

The event on which the oscilloscope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Event As IviScopeTVTriggerEventEnum
C#
public IviScopeTVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    IviScopeTVTriggerEventEnum*  val
);
HRESULT put_Event(
    IviScopeTVTriggerEventEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


LineNumber Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv..::.LineNumber Property
IIviScopeTriggerTv See Also

The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv..::.polarity Property
IIviScopeTriggerTv See Also

The polarity of the TV signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeTVTriggerPolarityEnum
C#
public IviScopeTVTriggerPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeTVTriggerPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeTVTriggerPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


SignalFormat Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv..::.SignalFormat Property
IIviScopeTriggerTv See Also

The format of the TV signal on which the oscilloscope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As IviScopeTVSignalFormatEnum
C#
public IviScopeTVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    IviScopeTVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    IviScopeTVSignalFormatEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


Type Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Type Property
IIviScopeTrigger See Also

The kind of event that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviScopeTriggerTypeEnum
C#
public IviScopeTriggerTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviScopeTriggerTypeEnum*  val
);
HRESULT put_Type(
    IviScopeTriggerTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Width Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger..::.Width Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerWidth interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Width As IIviScopeTriggerWidth
C#
public IIviScopeTriggerWidth  Width { get; }
Visual C++
HRESULT get_Width(
    IIviScopeTriggerWidth**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


condition Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth..::.condition Property
IIviScopeTriggerWidth See Also

The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property condition As IviScopeWidthConditionEnum
C#
public IviScopeWidthConditionEnum  condition { get; set; }
Visual C++
HRESULT get_condition(
    IviScopeWidthConditionEnum*  val
);
HRESULT put_condition(
    IviScopeWidthConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth..::.Configure Method
IIviScopeTriggerWidth See Also

Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  polarity As IviScopeWidthPolarityEnum  _
    ByVal  condition As IviScopeWidthConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeWidthPolarityEnum  polarity,
    IviScopeWidthConditionEnum  condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeWidthPolarityEnum  polarity,
    IviScopeWidthConditionEnum  condition
);

Parameters

Source

Specifies the trigger source. The driver uses this value to set the Trigger Source attribute. See the attribute description for more information.

Level

Trigger Level. This value sets the Trigger Level property.

ThresholdLow

Sets the width triggering low threshold in seconds. This value sets the Width Low Threshold property.

ThresholdHigh

Sets the width triggering high threshold in seconds. This value sets the Width High Threshold property.

polarity

Sets the width polarity. This value sets the Width Polarity property.

condition

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth..::.polarity Property
IIviScopeTriggerWidth See Also

The polarity of the pulse that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeWidthPolarityEnum
C#
public IviScopeWidthPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeWidthPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeWidthPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


ThresholdHigh Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth..::.ThresholdHigh Property
IIviScopeTriggerWidth See Also

The high width threshold time. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


ThresholdLow Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth..::.ThresholdLow Property
IIviScopeTriggerWidth See Also

The low width threshold time. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


IIviDriver Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriver Interface
See Also

IVI Driver root interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriver
C#
public interface IIviDriver
Visual C++
__interface IIviDriver

Properties

 | Name | Description
Public property | DriverOperation | Pointer to the IIviDriverOperation interface
Public property | Identity | Pointer to the IIviDriverIdentity interface
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Public property | Utility | Pointer to the IIviDriverUtility interface
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IVI-COM Interfaces

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IVI-COM Interfaces

This section presents the functionality of the AgInfiniiVision driver presented in a flat list of interfaces, organized by namespace. Each link below represents a namespace containing the interface definitions for instrument-specific interfaces, inherent capabilities (IIviDriver), etc.

Namespaces

Namespace
Agilent.AgInfiniiVision.Interop
Ivi.Driver.Interop
Ivi.Scope.Interop
Top


Agilent.AgInfiniiVision.Interop Namespace

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Agilent.AgInfiniiVision.Interop Namespace

IVI AgInfiniiVision 2.5 Type Library

Classes

 | Class | Description
Public class | AgInfiniiVision |
Public class | AgInfiniiVisionChannel |
Public class | AgInfiniiVisionDigitalChannel |
Public class | AgInfiniiVisionMathFunction |
Public class | AgInfiniiVisionMeasurement |
Public class | AgInfiniiVisionSerialBus |
Public class | AgInfiniiVisionWaveGen |

Interfaces

 | Interface | Description
Public interface | IAgInfiniiVision | IAgInfiniiVision interface.
Public interface | IAgInfiniiVision2 | IAgInfiniiVision2 root interface.
Public interface | IAgInfiniiVision2Search | IAgInfiniiVision2Search interface.
Public interface | IAgInfiniiVision2Search5Serial4CAN2 | IAgInfiniiVision2Search5Serial4CAN2 interface.
Public interface | IAgInfiniiVision2SearchEdge | IAgInfiniiVision2SearchEdge interface.
Public interface | IAgInfiniiVision2SearchGlitch | IAgInfiniiVision2SearchGlitch interface.
Public interface | IAgInfiniiVision2SearchRunt | IAgInfiniiVision2SearchRunt interface.
Public interface | IAgInfiniiVision2SearchSerial | IAgInfiniiVision2SearchSerial interface.
Public interface | IAgInfiniiVision2SearchSerialARINC429 | IAgInfiniiVision2SearchSerialARINC429 interface.
Public interface | IAgInfiniiVision2SearchSerialCAN | IAgInfiniiVision2SearchSerialCAN interface.
Public interface | IAgInfiniiVision2SearchSerialFlexRay | IAgInfiniiVision2SearchSerialFlexRay interface.
Public interface | IAgInfiniiVision2SearchSerialI2S | IAgInfiniiVision2SearchSerialI2S interface.
Public interface | IAgInfiniiVision2SearchSerialIIC | IAgInfiniiVision2SearchSerialIIC interface.
Public interface | IAgInfiniiVision2SearchSerialLIN | IAgInfiniiVision2SearchSerialLIN interface.
Public interface | IAgInfiniiVision2SearchSerialM1553 | IAgInfiniiVision2SearchSerialM1553 interface.
Public interface | IAgInfiniiVision2SearchSerialSPI | IAgInfiniiVision2SearchSerialSPI interface.
Public interface | IAgInfiniiVision2SearchSerialUART | IAgInfiniiVision2SearchSerialUART interface.
Public interface | IAgInfiniiVision2SearchTransition | IAgInfiniiVision2SearchTransition interface.
Public interface | IAgInfiniiVision2SerialBus | IAgInfiniiVision2SerialBus interface.
Public interface | IAgInfiniiVision2SerialBusARINC429 | IAgInfiniiVision2SerialBusARINC429 interface.
Public interface | IAgInfiniiVision2SerialBusCAN | IAgInfiniiVision2SerialBusCAN interface.
Public interface | IAgInfiniiVision2SerialBuses | IAgInfiniiVision2SerialBuses interface.
Public interface | IAgInfiniiVision2SerialBusesLister | IAgInfiniiVision2SerialBusesLister interface.
Public interface | IAgInfiniiVision2SerialBusFlexRay | IAgInfiniiVision2SerialBusFlexRay interface.
Public interface | IAgInfiniiVision2SerialBusI2S | IAgInfiniiVision2SerialBusI2S interface.
Public interface | IAgInfiniiVision2SerialBusIIC | IAgInfiniiVision2SerialBusIIC interface.
Public interface | IAgInfiniiVision2SerialBusLIN | IAgInfiniiVision2SerialBusLIN interface.
Public interface | IAgInfiniiVision2SerialBusM1553 | IAgInfiniiVision2SerialBusM1553 interface.
Public interface | IAgInfiniiVision2SerialBusSPI | IAgInfiniiVision2SerialBusSPI interface.
Public interface | IAgInfiniiVision2SerialBusUART | IAgInfiniiVision2SerialBusUART interface.
Public interface | IAgInfiniiVision3 | IAgInfiniiVision3 interface.
Public interface | IAgInfiniiVision4 | IAgInfiniiVision4 interface.
Public interface | IAgInfiniiVision4ClockRecovery | IAgInfiniiVision4ClockRecovery interface.
Public interface | IAgInfiniiVision4Counter | IAgInfiniiVision4Counter interface.
Public interface | IAgInfiniiVision4CounterTotalizer | IAgInfiniiVision4CounterTotalizer interface.
Public interface | IAgInfiniiVision4CounterTotalizerGating | IAgInfiniiVision4CounterTotalizerGating interface.
Public interface | IAgInfiniiVision4Histogram | IAgInfiniiVision4Histogram interface.
Public interface | IAgInfiniiVision4HistogramWindow | IAgInfiniiVision4HistogramWindow interface.
Public interface | IAgInfiniiVision4HistogramWindowLimits | IAgInfiniiVision4HistogramWindowLimits interface.
Public interface | IAgInfiniiVision4Jitter | IAgInfiniiVision4Jitter interface.
Public interface | IAgInfiniiVision4JitterSpectrum | IAgInfiniiVision4JitterSpectrum interface.
Public interface | IAgInfiniiVision4JitterSpectrumHorizontal | IAgInfiniiVision4JitterSpectrumHorizontal interface.
Public interface | IAgInfiniiVision4JitterSpectrumVertical | IAgInfiniiVision4JitterSpectrumVertical interface.
Public interface | IAgInfiniiVision4JitterTrend | IAgInfiniiVision4JitterTrend interface.
Public interface | IAgInfiniiVision4JitterTrendVertical | IAgInfiniiVision4JitterTrendVertical interface.
Public interface | IAgInfiniiVision5 | IAgInfiniiVision5 interface.
Public interface | IAgInfiniiVision5FFT | IAgInfiniiVision5FFT interface.
Public interface | IAgInfiniiVision6 | IAgInfiniiVision6 interface.
Public interface | IAgInfiniiVision7 | IAgInfiniiVision7 interface.
Public interface | IAgInfiniiVision8 | IAgInfiniiVision8 interface.
Public interface | IAgInfiniiVision8AnalogBus | IAgInfiniiVision8AnalogBus interface.
Public interface | IAgInfiniiVision8FRA | IAgInfiniiVision8FRA interface.
Public interface | IAgInfiniiVisionAcquisition | IVI Scope class-compliant acquisition interface
Public interface | IAgInfiniiVisionAcquisition2 | IAgInfiniiVisionAcquisition2 interface.
Public interface | IAgInfiniiVisionAcquisition3 | IAgInfiniiVisionAcquisition3 interface.
Public interface | IAgInfiniiVisionAcquisitionSegmentedMemory | IAgInfiniiVisionSegmentedMemory interface.
Public interface | IAgInfiniiVisionCalibration | IAgInfiniiVisionCalibration interface.
Public interface | IAgInfiniiVisionChannel | IAgInfiniiVisionChannel Interface.
Public interface | IAgInfiniiVisionChannels | IAgInfiniiVisionChannels Interface.
Public interface | IAgInfiniiVisionCursors | IAgInfiniiVisionCursors interface.
Public interface | IAgInfiniiVisionCursors2 | IAgInfiniiVisionCursors2 interface.
Public interface | IAgInfiniiVisionDigitalChannel | IAgInfiniiVisionDigitalChannel interface.
Public interface | IAgInfiniiVisionDigitalChannels | IAgInfiniiVisionDigitalChannels interface.
Public interface | IAgInfiniiVisionDigitalChannelsBus | IAgInfiniiVisionDigitalChannelsBus interface.
Public interface | IAgInfiniiVisionDisplay | IAgInfiniiVisionDisplay interface.
Public interface | IAgInfiniiVisionDisplay2 | IAgInfiniiVisionDisplay2 interface.
Public interface | IAgInfiniiVisionDisplay3 | IAgInfiniiVisionDisplay3 interface.
Public interface | IAgInfiniiVisionDisplay3Annotation | IAgInfiniiVisionDisplay3Annotation interface.
Public interface | IAgInfiniiVisionDisplay4 | IAgInfiniiVisionDisplay4 interface.
Public interface | IAgInfiniiVisionDisplay4Annotation2 | IAgInfiniiVisionDisplay4Annotation2 interface.
Public interface | IAgInfiniiVisionDVM | IAgInfiniiVisionDVM interface.
Public interface | IAgInfiniiVisionExternal | IAgInfiniiVisionExternal interface.
Public interface | IAgInfiniiVisionExternal2 | IAgInfiniiVisionExternal2 interface.
Public interface | IAgInfiniiVisionMaskTest | IAgInfiniiVisionMaskTest interface.
Public interface | IAgInfiniiVisionMaskTestConfiguration | IAgInfiniiVisionMaskTestConfiguration interface.
Public interface | IAgInfiniiVisionMaskTestMarkers | IAgInfiniiVisionMaskTestMarkers interface.
Public interface | IAgInfiniiVisionMath | IAgInfiniiVisionMath interface.
Public interface | IAgInfiniiVisionMath2 | IAgInfiniiVisionMath2 interface.
Public interface | IAgInfiniiVisionMath2Bus | IAgInfiniiVisionMath2Bus interface.
Public interface | IAgInfiniiVisionMath2FilterFrequency | IAgInfiniiVisionMath2FilterFrequency interface.
Public interface | IAgInfiniiVisionMath2Integrate | IAgInfiniiVisionMath2Integrate interface.
Public interface | IAgInfiniiVisionMath2Linear | IAgInfiniiVisionMath2Linear interface.
Public interface | IAgInfiniiVisionMath2MeasurementTrend | IAgInfiniiVisionMath2MeasurementTrend interface.
Public interface | IAgInfiniiVisionMathFFT | IAgInfiniiVisionMathFFT interface.
Public interface | IAgInfiniiVisionMathFFT2 | IAgInfiniiVisionMathFFT2 interface.
Public interface | IAgInfiniiVisionMathFunction | IAgInfiniiVisionMathFunction interface.
Public interface | IAgInfiniiVisionMathFunction2 | IAgInfiniiVisionMathFunction2 interface.
Public interface | IAgInfiniiVisionMathFunction2Smoothing | IAgInfiniiVisionMathFunction2Smoothing interface.
Public interface | IAgInfiniiVisionMathFunctionAverage | IAgInfiniiVisionMathFunctionAverage interface.
Public interface | IAgInfiniiVisionMathFunctionBus | IAgInfiniiVisionMath2Bus interface.
Public interface | IAgInfiniiVisionMathFunctionFFT | IAgInfiniiVisionMathFFT2 interface.
Public interface | IAgInfiniiVisionMathFunctionFFT2 | IAgInfiniiVisionMathFunctionFFT2 interface.
Public interface | IAgInfiniiVisionMathFunctionFilter | IAgInfiniiVisionMath2FilterFrequency interface.
Public interface | IAgInfiniiVisionMathFunctionIntegrate | IAgInfiniiVisionMath2Integrate interface.
Public interface | IAgInfiniiVisionMathFunctionLinear | IAgInfiniiVisionMath2Linear interface.
Public interface | IAgInfiniiVisionMathFunctionMeasurementTrend | IAgInfiniiVisionMath2MeasurementTrend interface.
Public interface | IAgInfiniiVisionMathFunctionMeasurementTrend2 | IAgInfiniiVisionMathFunctionMeasurementTrend2 interface.
Public interface | IAgInfiniiVisionMathFunctions | IAgInfiniiVisionMathFunctions interface.
Public interface | IAgInfiniiVisionMathFunctions2 | IAgInfiniiVisionMathFunctions2 interface.
Public interface | IAgInfiniiVisionMeasurement | IAgInfiniiVisionMeasurement interface.
Public interface | IAgInfiniiVisionMeasurement2 | IAgInfiniiVisionMeasurement2 interface.
Public interface | IAgInfiniiVisionMeasurements | IAgInfiniiVisionMeasurements interface.
Public interface | IAgInfiniiVisionMeasurements2 | IAgInfiniiVisionMeasurements2 interface.
Public interface | IAgInfiniiVisionMeasurements2Statistics | IAgInfiniiVisionMeasurements2Statistics interface.
Public interface | IAgInfiniiVisionMeasurements3 | IAgInfiniiVisionMeasurements3 interface.
Public interface | IAgInfiniiVisionMeasurementsConfiguration | IAgInfiniiVisionMeasurementsConfiguration interface.
Public interface | IAgInfiniiVisionMemory | IAgInfiniiVisionMemory interface.
Public interface | IAgInfiniiVisionMemory2 | IAgInfiniiVisionMemory2 interface.
Public interface | IAgInfiniiVisionMemory2ResultFormat | IAgInfiniiVisionMemory2ResultFormat interface.
Public interface | IAgInfiniiVisionMemory3 | IAgInfiniiVisionMemory3 interface.
Public interface | IAgInfiniiVisionReferenceLevel | IVI Scope class-compliant reference level interface
Public interface | IAgInfiniiVisionReferenceWaveform | IAgInfiniiVisionReferenceWaveform interface.
Public interface | IAgInfiniiVisionSearch2 | IAgInfiniiVisionSearch2 interface.
Public interface | IAgInfiniiVisionSearch3 | IAgInfiniiVisionSearch3 interface.
Public interface | IAgInfiniiVisionSearch3Peak | IAgInfiniiVisionSearch3Peak interface.
Public interface | IAgInfiniiVisionSearch4 | IAgInfiniiVisionSearch4 interface.
Public interface | IAgInfiniiVisionSearch5 | IAgInfiniiVisionSearch5 interface.
Public interface | IAgInfiniiVisionSearch5Serial4LIN2 | IAgInfiniiVisionSearch5Serial4LIN2 interface.
Public interface | IAgInfiniiVisionSearchSerial2 | IAgInfiniiVisionSearchSerial2 interface.
Public interface | IAgInfiniiVisionSearchSerial2USB | IAgInfiniiVision2SerialBus2USB interface.
Public interface | IAgInfiniiVisionSearchSerial3 | IAgInfiniiVisionSearchSerial3 interface.
Public interface | IAgInfiniiVisionSearchSerial3SENT | IAgInfiniiVisionSearchSerial3SENT interface.
Public interface | IAgInfiniiVisionSearchSerial3SENTFast | IAgInfiniiVisionSearchSerial3SENTFast interface.
Public interface | IAgInfiniiVisionSearchSerial3SENTSlow | IAgInfiniiVisionSearchSerial3SENTSlow interface.
Public interface | IAgInfiniiVisionSearchSerial4 | IAgInfiniiVisionSearchSerial4 interface.
Public interface | IAgInfiniiVisionSerialBus2 | IAgInfiniiVisionSerialBus2 interface.
Public interface | IAgInfiniiVisionSerialBus2USB | IAgInfiniiVisionSerialBus2USB interface.
Public interface | IAgInfiniiVisionSerialBus3 | IAgInfiniiVisionSerialBus3 interface.
Public interface | IAgInfiniiVisionSerialBus3CAN2 | IAgInfiniiVisionSerialBus3CAN2 interface.
Public interface | IAgInfiniiVisionSerialBus3CAN2FD | IAgInfiniiVisionSerialBus3CAN2FD interface.
Public interface | IAgInfiniiVisionSerialBus3SENT | IAgInfiniiVisionSerialBus3SENT interface.
Public interface | IAgInfiniiVisionSerialBus3SENT2 | IAgInfiniiVisionSerialBus3SENT2 interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTrigger | IAgInfiniiVisionSerialBus3SENTTrigger interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.
Public interface | IAgInfiniiVisionSerialBus4 | IAgInfiniiVisionSerialBus4 interface.
Public interface | IAgInfiniiVisionSerialBus4CAN3 | IAgInfiniiVisionSerialBus4CAN3 interface.
Public interface | IAgInfiniiVisionSerialBus4CAN3FD2 | IAgInfiniiVisionSerialBus4CAN3FD2 interface.
Public interface | IAgInfiniiVisionSerialBus4LIN2 | IAgInfiniiVisionSerialBus4LIN2 interface.
Public interface | IAgInfiniiVisionSerialBus4SENT2Trigger2 | IAgInfiniiVisionSerialBus4SENT2Trigger2 interface.
Public interface | IAgInfiniiVisionSerialBuses2 | IAgInfiniiVisionSerialBuses2 interface.
Public interface | IAgInfiniiVisionSerialBuses3 | IAgInfiniiVisionSerialBuses3 interface.
Public interface | IAgInfiniiVisionSerialBuses4 | IAgInfiniiVisionSerialBuses4 interface.
Public interface | IAgInfiniiVisionStatus | IAgInfiniiVisionStatus interface.
Public interface | IAgInfiniiVisionSystem | IAgInfiniiVisionSystem interface.
Public interface | IAgInfiniiVisionSystem2 | IAgInfiniiVisionSystem2 interface.
Public interface | IAgInfiniiVisionSystem3 | IAgInfiniiVisionSystem3 interface.
Public interface | IAgInfiniiVisionSystem3Precision | IAgInfiniiVisionSystem3Precision interface.
Public interface | IAgInfiniiVisionSystem4 | IAgInfiniiVisionSystem4 interface.
Public interface | IAgInfiniiVisionTimebase | IAgInfiniiVisionTimebase interface.
Public interface | IAgInfiniiVisionTimebaseWindow | IAgInfiniiVisionTimebaseWindow interface.
Public interface | IAgInfiniiVisionTrigger | IVI Scope class-compliant trigger interface
Public interface | IAgInfiniiVisionTrigger2 | IAgInfiniiVisionTrigger2 interface.
Public interface | IAgInfiniiVisionTrigger2Delay | IAgInfiniiVisionTrigger2Delay interface.
Public interface | IAgInfiniiVisionTrigger2EdgeBurst | IAgInfiniiVisionTrigger2EdgeBurst interface.
Public interface | IAgInfiniiVisionTrigger2OR | IAgInfiniiVisionTrigger2OR interface.
Public interface | IAgInfiniiVisionTrigger2SetupAndHold | IAgInfiniiVisionTrigger2SetupAndHold interface.
Public interface | IAgInfiniiVisionTrigger2Transition | IAgInfiniiVisionTrigger2Transition interface.
Public interface | IAgInfiniiVisionTrigger2USB | IAgInfiniiVisionTrigger2USB interface.
Public interface | IAgInfiniiVisionTrigger3 | IAgInfiniiVisionTrigger3 interface.
Public interface | IAgInfiniiVisionTrigger3Zone | IAgInfiniiVisionTrigger3Zone interface.
Public interface | IAgInfiniiVisionTrigger4 | IAgInfiniiVisionTrigger4 interface.
Public interface | IAgInfiniiVisionTrigger4PXI | IAgInfiniiVisionTrigger4PXI interface.
Public interface | IAgInfiniiVisionTrigger5 | IAgInfiniiVisionTrigger5 interface.
Public interface | IAgInfiniiVisionTrigger5RandomHoldoff | IAgInfiniiVisionTrigger5RandomHoldoff interface.
Public interface | IAgInfiniiVisionTriggerAcLine | IAgInfiniiVisionTriggerAcLine interface.
Public interface | IAgInfiniiVisionTriggerEdge | IVI Scope class-compliant edge trigger interface
Public interface | IAgInfiniiVisionTriggerGlitch | IVI Scope class-compliant glitch trigger interface
Public interface | IAgInfiniiVisionTriggerPattern | IAgInfiniiVisionTriggerPattern interface.
Public interface | IAgInfiniiVisionTriggerRunt | IVI Scope class-compliant runt trigger interface
Public interface | IAgInfiniiVisionTriggerTV | IAgInfiniiVisionTriggerTV interface.
Public interface | IAgInfiniiVisionTriggerTV2 | IAgInfiniiVisionTriggerTV2 interface.
Public interface | IAgInfiniiVisionTriggerTV2UDTV | IAgInfiniiVisionTriggerTV2UDTV interface.
Public interface | IAgInfiniiVisionTriggerWidth | IAgInfiniiVisionTriggerWidth interface.
Public interface | IAgInfiniiVisionWaveform | IAgInfiniiVisionWaveform interface.
Public interface | IAgInfiniiVisionWaveform2 | IAgInfiniiVisionWaveform2 interface.
Public interface | IAgInfiniiVisionWaveformGenerator | IAgInfiniiVisionWaveformGenerator interface.
Public interface | IAgInfiniiVisionWaveformGenerator2 | IAgInfiniiVisionWaveformGenerator2 interface.
Public interface | IAgInfiniiVisionWaveformGenerator2Arbitrary | IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public interface | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public interface | IAgInfiniiVisionWaveGen | IAgInfiniiVisionWaveGen interface.
Public interface | IAgInfiniiVisionWaveGen2 | IAgInfiniiVisionWaveGen2 interface.
Public interface | IAgInfiniiVisionWaveGen2Tracking2 | IAgInfiniiVisionWaveGen2Tracking2 interface.
Public interface | IAgInfiniiVisionWaveGenArbitrary | IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public interface | IAgInfiniiVisionWaveGenArbitraryAttribute | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public interface | IAgInfiniiVisionWaveGenModulation | IAgInfiniiVisionTrigger3Modulation interface.
Public interface | IAgInfiniiVisionWaveGenModulationAM | IAgInfiniiVisionTrigger3ModulationAM interface.
Public interface | IAgInfiniiVisionWaveGenModulationFM | IAgInfiniiVisionTrigger3ModulationFM interface.
Public interface | IAgInfiniiVisionWaveGenModulationFSK | IAgInfiniiVisionTrigger3ModulationFSK interface.
Public interface | IAgInfiniiVisionWaveGens | IAgInfiniiVisionWaveGens interface.
Public interface | IAgInfiniiVisionWaveGens2 | IAgInfiniiVisionWaveGens2 interface.
Public interface | IAgInfiniiVisionWaveGenTracking | IAgInfiniiVisionWaveGenTracking interface.

Enumerations

 | Enumeration | Description
Public enumeration | AgInfiniiVisionACLineSlopeEnum | Values for the slope of the AC power line on which to trigger.
Public enumeration | AgInfiniiVisionAcquisitionReferenceSignalModeEnum | Different modes to selects the 10 MHz reference signal.
Public enumeration | AgInfiniiVisionAcquisitionStatusEnum | Values for the status parameter of the acquisition Status method
Public enumeration | AgInfiniiVisionAcquisitionTypeEnum | Values for Acquisition Type
Public enumeration | AgInfiniiVisionCalibrationProtectionEnum | Calibration Protection State
Public enumeration | AgInfiniiVisionCalibrationSignalSourceEnum | Signal on rear panel trigger out BNC
Public enumeration | AgInfiniiVisionChannelProtectionEnum | Values for channel protection
Public enumeration | AgInfiniiVisionChannelUnitsEnum | Measurement units for channel
Public enumeration | AgInfiniiVisionClockRecoveryMethodEnum | Clock Recovery methods.
Public enumeration | AgInfiniiVisionCounterModeEnum | Counter mode.
Public enumeration | AgInfiniiVisionCounterTotalizerPolarityEnum | The signal conditions.
Public enumeration | AgInfiniiVisionCursorsModeEnum | Mode for cursors
Public enumeration | AgInfiniiVisionCursorsUseCursorPositionEnum | Specifies whether to use the X cursors or Y cursors.
Public enumeration | AgInfiniiVisionCursorsXUnitsEnum | Values for the X cursors units.
Public enumeration | AgInfiniiVisionCursorsYUnitsEnum | Values for the Y Cursors units.
Public enumeration | AgInfiniiVisionDigitalChannelSizeEnum | Specifies the size of digital channels on the display
Public enumeration | AgInfiniiVisionDisplayAnnotationBackgroundEnum | Specifies the Annotation background type.
Public enumeration | AgInfiniiVisionDisplayAnnotationColorEnum | The annotation color.
Public enumeration | AgInfiniiVisionDisplayImageFormatEnum | Image format
Public enumeration | AgInfiniiVisionDisplayPaletteEnum | Image Palette
Public enumeration | AgInfiniiVisionDisplayPersistenceModeEnum | Persistence Mode
Public enumeration | AgInfiniiVisionDisplaySidebarEnum | Sidebar dialog to display on the screen.
Public enumeration | AgInfiniiVisionDVMModeEnum | Digital voltmenter (DVM) modes.
Public enumeration | AgInfiniiVisionEdgeSlopeEnum | Slope.
Public enumeration | AgInfiniiVisionErrorCodesEnum |
Public enumeration | AgInfiniiVisionExternalProbeUnitsEnum | Measurement units for external trigger probe input
Public enumeration | AgInfiniiVisionFRAAmpRangeEnum | Specifies the frequency whose initial ramp amplitude is to be adjusted or queried.
Public enumeration | AgInfiniiVisionFRAFreqModeEnum | The frequency mode setting of the Frequency Response Analysis (FRA).
Public enumeration | AgInfiniiVisionGlitchConditionEnum | Values for glitch trigger Condition
Public enumeration | AgInfiniiVisionGlitchPolarityEnum | Values for glitch trigger Polarity
Public enumeration | AgInfiniiVisionHistogramAxisEnum | Histogram axis type.
Public enumeration | AgInfiniiVisionHistogramModeEnum | Histogram mode.
Public enumeration | AgInfiniiVisionHistogramResultTypeEnum | Histogram Result Type.
Public enumeration | AgInfiniiVisionHistogramTypeEnum | Histogram Type.
Public enumeration | AgInfiniiVisionInterpolationEnum | Values for acquisition Interpolation
Public enumeration | AgInfiniiVisionJitterMeasurementUnitEnum | Jitter Measurement Unit.
Public enumeration | AgInfiniiVisionJitterSpectrumVerticalUnitEnum | Jitter Spectrum Vertical Units.
Public enumeration | AgInfiniiVisionJitterSpectrumWindowEnum | Jitter Spectrum Window Types.
Public enumeration | AgInfiniiVisionMaskTestTerminationConditionEnum | Termination conditions for the mask test
Public enumeration | AgInfiniiVisionMaskTestUnitsEnum | AutoMask Units
Public enumeration | AgInfiniiVisionMathBusSlopeEnum | Specifies the slope as Negative, Positive or Either when the IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsBusState.
Public enumeration | AgInfiniiVisionMathBusYUnitsEnum | Specifies the units for the IAgInfiniiVisionMathBusYIncrement and IAgInfiniiVisionMathBusYOrigin properties.
Public enumeration | AgInfiniiVisionMathFFTDisplayModeEnum | Display Mode.
Public enumeration | AgInfiniiVisionMathFFTVerticalUnitsEnum | Values for the FFT vertical units.
Public enumeration | AgInfiniiVisionMathFFTWindowTypeEnum | Type of Window transforms for FFT.
Public enumeration | AgInfiniiVisionMathIntOperationEnum | Operations for g(t) input function source
Public enumeration | AgInfiniiVisionMathMeasurementTrendTypeEnum | Specifies the measurement type when IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsMeasurementTrend.
Public enumeration | AgInfiniiVisionMathOperationsEnum | Values for Math operations
Public enumeration | AgInfiniiVisionMeasurementEnum | Values for the MeasFunction parameter of the measurement Read and Fetch methods
Public enumeration | AgInfiniiVisionMeasurementJitterEnum | Jitter Measurements type.
Public enumeration | AgInfiniiVisionMeasurementReferenceModeEnum | Values for Reference Mode
Public enumeration | AgInfiniiVisionMeasurementSlopeEnum | Values for Measurement Slope
Public enumeration | AgInfiniiVisionMeasurementSlotEnum | Measurement slots.
Public enumeration | AgInfiniiVisionMeasurementStatisticsFormatEnum | Values for the type of information returned by the ResultsStatistics() method
Public enumeration | AgInfiniiVisionMeasurementWindowTypeEnum | Measurement window type
Public enumeration | AgInfiniiVisionMemoryImageFormatEnum | Image format for saving an image
Public enumeration | AgInfiniiVisionMemoryImagePaletteEnum | Image palette color for saving an image
Public enumeration | AgInfiniiVisionMemoryLocationEnum | Values for memory location
Public enumeration | AgInfiniiVisionMemoryRecallOptionsEnum | Recall Options
Public enumeration | AgInfiniiVisionMemorySaveOptionsEnum | Save Options
Public enumeration | AgInfiniiVisionMemorySegmentOptionEnum | Segments to be included when the waveform is saved
Public enumeration | AgInfiniiVisionMemoryWaveformFormatEnum | Waveform data format type
Public enumeration | AgInfiniiVisionModulationFunctionEnum | Modulation function for Waveform Generator.
Public enumeration | AgInfiniiVisionModulationTypeEnum | Type of modulation for waveform generator.
Public enumeration | AgInfiniiVisionPatternMatchingModeEnum | Values for pattern matching values.
Public enumeration | AgInfiniiVisionPIDDataEnum | Packet Identifier.
Public enumeration | AgInfiniiVisionPIDHandshakeEnum | Packet Identifier (Handshake)
Public enumeration | AgInfiniiVisionPIDSpecialEnum | Packet Identifier (Special)
Public enumeration | AgInfiniiVisionPIDTokenEnum | Packet identifier.
Public enumeration | AgInfiniiVisionPXITriggerEnum | PXI Trigger Line.
Public enumeration | AgInfiniiVisionRuntPolarityEnum | IVI Scope class-compliant values for runt trigger Polarity
Public enumeration | AgInfiniiVisionSampleModeEnum | Acquisition mode of the oscilloscope
Public enumeration | AgInfiniiVisionSearchCANModeEnum | Specifies the type of CAN information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchCANPatternIDTypeEnum | Values that specify whether a standard ID value or an extended ID value is used when searching for a CAN event.
Public enumeration | AgInfiniiVisionSearchEdgeSlopeEnum | Values for the slope of the edge for the search.
Public enumeration | AgInfiniiVisionSearchGlitchConditionEnum | Values for the Glitch condition.
Public enumeration | AgInfiniiVisionSearchGlitchPolarityEnum | Values for Polarity for the Glitch search.
Public enumeration | AgInfiniiVisionSearchI2SAudioChannelEnum | To specify the audio channel: left, right or either channel.
Public enumeration | AgInfiniiVisionSearchI2SModeEnum | To specify the type of I2S information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchIICConditionEnum | Values for the data value qualifier used when searching for IIC EEPROM data read events.
Public enumeration | AgInfiniiVisionSearchIICModeEnum | Values for the type of IIC information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchLINModeEnum | Values for the type of LIN information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchModeEnum | Values for the search mode.
Public enumeration | AgInfiniiVisionSearchRuntConditionEnum | Values that specify how to search for a runt.
Public enumeration | AgInfiniiVisionSearchRuntPolarityEnum | Values for the polarity for the runt search.
Public enumeration | AgInfiniiVisionSearchSentEnum | Specifies the SENT search mode.
Public enumeration | AgInfiniiVisionSearchSerialARINC429ModeEnum | Specifies the ARINC 429 search mode.
Public enumeration | AgInfiniiVisionSearchSerialFlexRayModeEnum | Specifies the type of FlexRay information to find in the lister display.
Public enumeration | AgInfiniiVisionSearchSerialM1553ModeEnum | Specifies the MIL-STD 1553 search mode.
Public enumeration | AgInfiniiVisionSearchSPIModeEnum | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Public enumeration | AgInfiniiVisionSearchTransitionConditionEnum | Values that specify whether to search for edge transition greater than or less than a time.
Public enumeration | AgInfiniiVisionSearchTransitionSlopeEnum | Values that specify whether to search for rising edge transitions or falling edge transitions.
Public enumeration | AgInfiniiVisionSearchUARTConditionEnum | Specifies the data value qualifier when searching for UART/RS232 events.
Public enumeration | AgInfiniiVisionSearchUARTModeEnum | Values for the type of UART/RS232 information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchUSBConditionEnum | The USB search mode.
Public enumeration | AgInfiniiVisionSerialBusARINC429BaseEnum | Specifies the ARINC 429 base for the selected bus. The base setting will be used for both the Lister and the decode line displays, and controls how the Data field is displayed.
Public enumeration | AgInfiniiVisionSerialBusARINC429DisplayFormatEnum | Specifies the display format for both the decode line and the Lister.
Public enumeration | AgInfiniiVisionSerialBusARINC429SignalTypeEnum | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Public enumeration | AgInfiniiVisionSerialBusARINC429SpeedEnum | Specifies the speed of the ARINC 429 interface for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusARINC429TriggerTypeEnum | Specifies the ARINC 429 trigger mode for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusCANDisplayEnum | Values for Serial Bus CAN display
Public enumeration | AgInfiniiVisionSerialBusCANFDStandardEnum | The CAN standard to use when decoding or triggering on FD frames.
Public enumeration | AgInfiniiVisionSerialBusCANPatternIDTypeEnum | Values for the CAN identifier mode.
Public enumeration | AgInfiniiVisionSerialBusCANSignalTypeEnum | Values for the CAN signal type.
Public enumeration | AgInfiniiVisionSerialBusCANTriggerConditionEnum | Values for the CAN trigger on condition.
Public enumeration | AgInfiniiVisionSerialBusEnum | Values of recall destination for LDF or DBC files
Public enumeration | AgInfiniiVisionSerialBusFlexRayChannelEnum | Specifies whether the FlexRay Signal is for Bus A or B. It is important to specify the correct bus because this setting affects CRC error detection.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum | Specifies the FlexRay trigger on condition.
Public enumeration | AgInfiniiVisionSerialBusI2SBaseEnum | Specifies the base to use for the I2S decode display.
Public enumeration | AgInfiniiVisionSerialBusI2SClockSlopeEnum | Specifies which edge of the I2S serial clock signal clocks in data.
Public enumeration | AgInfiniiVisionSerialBusI2SDataAlignmentEnum | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode
Public enumeration | AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum | Specifies the audio channel to trigger on.
Public enumeration | AgInfiniiVisionSerialBusI2STriggerConditionEnum | Specifies the I2S trigger operator.
Public enumeration | AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum | Specifies the polarity of the word select (WS) signal.
Public enumeration | AgInfiniiVisionSerialBusIICAddressWidthEnum | Determines whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Public enumeration | AgInfiniiVisionSerialBusIICTriggerConditionEnum | Specifies the IIC data qualifier.
Public enumeration | AgInfiniiVisionSerialBusIICTriggerTypeEnum | Specifies the IIC trigger type
Public enumeration | AgInfiniiVisionSerialBusLINDisplayEnum | Specifies the LIN symbolic data loaded into the oscilloscope
Public enumeration | AgInfiniiVisionSerialBusLINStandardEnum | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Public enumeration | AgInfiniiVisionSerialBusLINTriggerConditionEnum | Specifies the LIN trigger condition to be.
Public enumeration | AgInfiniiVisionSerialBusListerDisplayEnum | Values for the lister display setting.
Public enumeration | AgInfiniiVisionSerialBusListerTimeReferenceEnum | Values for the lister time reference setting.
Public enumeration | AgInfiniiVisionSerialBusM1553BaseEnum | Specifies the base to use for the MIL-STD 1553 decode display.
Public enumeration | AgInfiniiVisionSerialBusM1553TriggerTypeEnum | Specifies the type of MIL-STD 1553 trigger to be used.
Public enumeration | AgInfiniiVisionSerialBusModeEnum | Specifies the decode mode for the serial bus.
Public enumeration | AgInfiniiVisionSerialBusSENTCRCEnum | CRC.
Public enumeration | AgInfiniiVisionSerialBusSENTFormatEnum | Message Formats.
Public enumeration | AgInfiniiVisionSerialBusSENTIdleStateEnum | Idle State.
Public enumeration | AgInfiniiVisionSerialBusSENTNumberBaseEnum | Number base.
Public enumeration | AgInfiniiVisionSerialBusSENTSignalOrderEnum | Nibble order.
Public enumeration | AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum | ID and data length format.
Public enumeration | AgInfiniiVisionSerialBusSENTTriggerModeEnum | The automative SENT serial decode trigger modes
Public enumeration | AgInfiniiVisionSerialBusSPIBitOrderEnum | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Public enumeration | AgInfiniiVisionSerialBusSPIClockSlopeEnum | specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Public enumeration | AgInfiniiVisionSerialBusSPIFramingEnum | Specifies the SPI trigger framing value.
Public enumeration | AgInfiniiVisionSerialBusSPITriggerTypeEnum | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Public enumeration | AgInfiniiVisionSerialBusUARTBaseEnum | Specifies the base to use for the UART decode and Lister display.
Public enumeration | AgInfiniiVisionSerialBusUARTBitOrderEnum | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTParityEnum | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTPolarityEnum | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerBaseEnum | Specifies the front panel UART/RS232 trigger setup data selection option
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerConditionEnum | Specifies the data qualifier for the trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerTypeEnum | Specifies the UART trigger type.
Public enumeration | AgInfiniiVisionSerialBusUSBBaseEnum | Base value to be used.
Public enumeration | AgInfiniiVisionSerialBusUSBConditionEnum | Specifies where the USB trigger mode for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusUSBSpeedEnum | Speed for USB interface for selected bus.
Public enumeration | AgInfiniiVisionStatusRegisterEnum | Enumeration for the Register parameter of the Register property in the Status interface.
Public enumeration | AgInfiniiVisionStatusSRQReasonEnum | Enumeration for the Reason parameter of the ConfigureServiceRequest method in the Status interface.
Public enumeration | AgInfiniiVisionStatusSubRegisterEnum | Enumeration for the SubRegister parameter of the Register property in the Status interface.
Public enumeration | AgInfiniiVisionTimebaseModeEnum | Time base Mode
Public enumeration | AgInfiniiVisionTimebaseReferenceEnum | Point on the display where the trigger point is referenced.
Public enumeration | AgInfiniiVisionTriggerCouplingEnum | Values for trigger Coupling
Public enumeration | AgInfiniiVisionTriggerDelaySlopeEnum | Specifies the rising or falling edge for the Edge Then Edge trigger.
Public enumeration | AgInfiniiVisionTriggerEdgeBurstSlopeEnum | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger
Public enumeration | AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum | Type of reject filter
Public enumeration | AgInfiniiVisionTriggerModifierEnum | Trigger modifier to determine the way oscilloscope behaves in the absence of signal
Public enumeration | AgInfiniiVisionTriggerPXIModeEnum | PXI Trigger Mode.
Public enumeration | AgInfiniiVisionTriggerRuntConditionEnum | Trigger Runt conditions for specifying runt pulse widths.
Public enumeration | AgInfiniiVisionTriggerSetupAndHoldSlopeEnum | Specifies the polarity for the TV trigger.
Public enumeration | AgInfiniiVisionTriggerSlopeEnum | Values for edge trigger Slope
Public enumeration | AgInfiniiVisionTriggerTransitionConditionEnum | Specifies whether you are looking for rise/fall times greater than or less than a certain time value.
Public enumeration | AgInfiniiVisionTriggerTransitionSlopeEnum | Specifies a Positive rising edge or a Negative falling edge.
Public enumeration | AgInfiniiVisionTriggerTypeEnum | Values for trigger Type
Public enumeration | AgInfiniiVisionTriggerUSBConditionEnum | Specifies where the USB trigger will occur.
Public enumeration | AgInfiniiVisionTriggerUSBSpeedEnum | Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Public enumeration | AgInfiniiVisionTriggerZoneEnum | Specifies the Zone Number.
Public enumeration | AgInfiniiVisionTriggerZoneModeEnum | Trigger zone qualifying conditions
Public enumeration | AgInfiniiVisionTriggerZoneValidityEnum | Specifies the trigger zone validity.
Public enumeration | AgInfiniiVisionTVSignalFormatEnum | Values for TV trigger SignalFormat
Public enumeration | AgInfiniiVisionTVTriggerEventEnum | Values for TV trigger Event
Public enumeration | AgInfiniiVisionTVTriggerPolarityEnum | Values for TV trigger Polarity
Public enumeration | AgInfiniiVisionVerticalCouplingEnum | Values for channel Coupling
Public enumeration | AgInfiniiVisionWaveformByteOrderEnum | Output sequence of the WORD data
Public enumeration | AgInfiniiVisionWaveformDataFormatEnum | Data format for data transmission mode for waveform
Public enumeration | AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum | Specifies the byte order for binary transfers.
Public enumeration | AgInfiniiVisionWaveformGeneratorFunctionEnum | Type of waveform
Public enumeration | AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum | Expected output load impedance
Public enumeration | AgInfiniiVisionWaveformGeneratorOutputModeEnum | Specifies whether the defined waveform is output continuously or as a single cycle.
Public enumeration | AgInfiniiVisionWaveformPointModeEnum | Type of data record to be transferred
Public enumeration | AgInfiniiVisionWaveformSubSourceEnum | Sub source.
Public enumeration | AgInfiniiVisionWidthConditionEnum | Values for width trigger Condition
Public enumeration | AgInfiniiVisionWidthPolarityEnum | Values for width trigger Polarity


Classes

 | Class | Description
Public class | AgInfiniiVision |
Public class | AgInfiniiVisionChannel |
Public class | AgInfiniiVisionDigitalChannel |
Public class | AgInfiniiVisionMathFunction |
Public class | AgInfiniiVisionMeasurement |
Public class | AgInfiniiVisionSerialBus |
Public class | AgInfiniiVisionWaveGen |


AgInfiniiVision Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVision Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVision
C#
public class AgInfiniiVision
Visual C++
class AgInfiniiVision

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionChannel Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionChannel Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionChannel
C#
public class AgInfiniiVisionChannel
Visual C++
class AgInfiniiVisionChannel

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDigitalChannel Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDigitalChannel Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionDigitalChannel
C#
public class AgInfiniiVisionDigitalChannel
Visual C++
class AgInfiniiVisionDigitalChannel

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathFunction Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathFunction Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionMathFunction
C#
public class AgInfiniiVisionMathFunction
Visual C++
class AgInfiniiVisionMathFunction

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurement Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurement Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionMeasurement
C#
public class AgInfiniiVisionMeasurement
Visual C++
class AgInfiniiVisionMeasurement

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBus Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBus Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionSerialBus
C#
public class AgInfiniiVisionSerialBus
Visual C++
class AgInfiniiVisionSerialBus

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveGen Class

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveGen Class
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Class AgInfiniiVisionWaveGen
C#
public class AgInfiniiVisionWaveGen
Visual C++
class AgInfiniiVisionWaveGen

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Interfaces

 | Interface | Description
Public interface | IAgInfiniiVision | IAgInfiniiVision interface.
Public interface | IAgInfiniiVision2 | IAgInfiniiVision2 root interface.
Public interface | IAgInfiniiVision2Search | IAgInfiniiVision2Search interface.
Public interface | IAgInfiniiVision2Search5Serial4CAN2 | IAgInfiniiVision2Search5Serial4CAN2 interface.
Public interface | IAgInfiniiVision2SearchEdge | IAgInfiniiVision2SearchEdge interface.
Public interface | IAgInfiniiVision2SearchGlitch | IAgInfiniiVision2SearchGlitch interface.
Public interface | IAgInfiniiVision2SearchRunt | IAgInfiniiVision2SearchRunt interface.
Public interface | IAgInfiniiVision2SearchSerial | IAgInfiniiVision2SearchSerial interface.
Public interface | IAgInfiniiVision2SearchSerialARINC429 | IAgInfiniiVision2SearchSerialARINC429 interface.
Public interface | IAgInfiniiVision2SearchSerialCAN | IAgInfiniiVision2SearchSerialCAN interface.
Public interface | IAgInfiniiVision2SearchSerialFlexRay | IAgInfiniiVision2SearchSerialFlexRay interface.
Public interface | IAgInfiniiVision2SearchSerialI2S | IAgInfiniiVision2SearchSerialI2S interface.
Public interface | IAgInfiniiVision2SearchSerialIIC | IAgInfiniiVision2SearchSerialIIC interface.
Public interface | IAgInfiniiVision2SearchSerialLIN | IAgInfiniiVision2SearchSerialLIN interface.
Public interface | IAgInfiniiVision2SearchSerialM1553 | IAgInfiniiVision2SearchSerialM1553 interface.
Public interface | IAgInfiniiVision2SearchSerialSPI | IAgInfiniiVision2SearchSerialSPI interface.
Public interface | IAgInfiniiVision2SearchSerialUART | IAgInfiniiVision2SearchSerialUART interface.
Public interface | IAgInfiniiVision2SearchTransition | IAgInfiniiVision2SearchTransition interface.
Public interface | IAgInfiniiVision2SerialBus | IAgInfiniiVision2SerialBus interface.
Public interface | IAgInfiniiVision2SerialBusARINC429 | IAgInfiniiVision2SerialBusARINC429 interface.
Public interface | IAgInfiniiVision2SerialBusCAN | IAgInfiniiVision2SerialBusCAN interface.
Public interface | IAgInfiniiVision2SerialBuses | IAgInfiniiVision2SerialBuses interface.
Public interface | IAgInfiniiVision2SerialBusesLister | IAgInfiniiVision2SerialBusesLister interface.
Public interface | IAgInfiniiVision2SerialBusFlexRay | IAgInfiniiVision2SerialBusFlexRay interface.
Public interface | IAgInfiniiVision2SerialBusI2S | IAgInfiniiVision2SerialBusI2S interface.
Public interface | IAgInfiniiVision2SerialBusIIC | IAgInfiniiVision2SerialBusIIC interface.
Public interface | IAgInfiniiVision2SerialBusLIN | IAgInfiniiVision2SerialBusLIN interface.
Public interface | IAgInfiniiVision2SerialBusM1553 | IAgInfiniiVision2SerialBusM1553 interface.
Public interface | IAgInfiniiVision2SerialBusSPI | IAgInfiniiVision2SerialBusSPI interface.
Public interface | IAgInfiniiVision2SerialBusUART | IAgInfiniiVision2SerialBusUART interface.
Public interface | IAgInfiniiVision3 | IAgInfiniiVision3 interface.
Public interface | IAgInfiniiVision4 | IAgInfiniiVision4 interface.
Public interface | IAgInfiniiVision4ClockRecovery | IAgInfiniiVision4ClockRecovery interface.
Public interface | IAgInfiniiVision4Counter | IAgInfiniiVision4Counter interface.
Public interface | IAgInfiniiVision4CounterTotalizer | IAgInfiniiVision4CounterTotalizer interface.
Public interface | IAgInfiniiVision4CounterTotalizerGating | IAgInfiniiVision4CounterTotalizerGating interface.
Public interface | IAgInfiniiVision4Histogram | IAgInfiniiVision4Histogram interface.
Public interface | IAgInfiniiVision4HistogramWindow | IAgInfiniiVision4HistogramWindow interface.
Public interface | IAgInfiniiVision4HistogramWindowLimits | IAgInfiniiVision4HistogramWindowLimits interface.
Public interface | IAgInfiniiVision4Jitter | IAgInfiniiVision4Jitter interface.
Public interface | IAgInfiniiVision4JitterSpectrum | IAgInfiniiVision4JitterSpectrum interface.
Public interface | IAgInfiniiVision4JitterSpectrumHorizontal | IAgInfiniiVision4JitterSpectrumHorizontal interface.
Public interface | IAgInfiniiVision4JitterSpectrumVertical | IAgInfiniiVision4JitterSpectrumVertical interface.
Public interface | IAgInfiniiVision4JitterTrend | IAgInfiniiVision4JitterTrend interface.
Public interface | IAgInfiniiVision4JitterTrendVertical | IAgInfiniiVision4JitterTrendVertical interface.
Public interface | IAgInfiniiVision5 | IAgInfiniiVision5 interface.
Public interface | IAgInfiniiVision5FFT | IAgInfiniiVision5FFT interface.
Public interface | IAgInfiniiVision6 | IAgInfiniiVision6 interface.
Public interface | IAgInfiniiVision7 | IAgInfiniiVision7 interface.
Public interface | IAgInfiniiVision8 | IAgInfiniiVision8 interface.
Public interface | IAgInfiniiVision8AnalogBus | IAgInfiniiVision8AnalogBus interface.
Public interface | IAgInfiniiVision8FRA | IAgInfiniiVision8FRA interface.
Public interface | IAgInfiniiVisionAcquisition | IVI Scope class-compliant acquisition interface
Public interface | IAgInfiniiVisionAcquisition2 | IAgInfiniiVisionAcquisition2 interface.
Public interface | IAgInfiniiVisionAcquisition3 | IAgInfiniiVisionAcquisition3 interface.
Public interface | IAgInfiniiVisionAcquisitionSegmentedMemory | IAgInfiniiVisionSegmentedMemory interface.
Public interface | IAgInfiniiVisionCalibration | IAgInfiniiVisionCalibration interface.
Public interface | IAgInfiniiVisionChannel | IAgInfiniiVisionChannel Interface.
Public interface | IAgInfiniiVisionChannels | IAgInfiniiVisionChannels Interface.
Public interface | IAgInfiniiVisionCursors | IAgInfiniiVisionCursors interface.
Public interface | IAgInfiniiVisionCursors2 | IAgInfiniiVisionCursors2 interface.
Public interface | IAgInfiniiVisionDigitalChannel | IAgInfiniiVisionDigitalChannel interface.
Public interface | IAgInfiniiVisionDigitalChannels | IAgInfiniiVisionDigitalChannels interface.
Public interface | IAgInfiniiVisionDigitalChannelsBus | IAgInfiniiVisionDigitalChannelsBus interface.
Public interface | IAgInfiniiVisionDisplay | IAgInfiniiVisionDisplay interface.
Public interface | IAgInfiniiVisionDisplay2 | IAgInfiniiVisionDisplay2 interface.
Public interface | IAgInfiniiVisionDisplay3 | IAgInfiniiVisionDisplay3 interface.
Public interface | IAgInfiniiVisionDisplay3Annotation | IAgInfiniiVisionDisplay3Annotation interface.
Public interface | IAgInfiniiVisionDisplay4 | IAgInfiniiVisionDisplay4 interface.
Public interface | IAgInfiniiVisionDisplay4Annotation2 | IAgInfiniiVisionDisplay4Annotation2 interface.
Public interface | IAgInfiniiVisionDVM | IAgInfiniiVisionDVM interface.
Public interface | IAgInfiniiVisionExternal | IAgInfiniiVisionExternal interface.
Public interface | IAgInfiniiVisionExternal2 | IAgInfiniiVisionExternal2 interface.
Public interface | IAgInfiniiVisionMaskTest | IAgInfiniiVisionMaskTest interface.
Public interface | IAgInfiniiVisionMaskTestConfiguration | IAgInfiniiVisionMaskTestConfiguration interface.
Public interface | IAgInfiniiVisionMaskTestMarkers | IAgInfiniiVisionMaskTestMarkers interface.
Public interface | IAgInfiniiVisionMath | IAgInfiniiVisionMath interface.
Public interface | IAgInfiniiVisionMath2 | IAgInfiniiVisionMath2 interface.
Public interface | IAgInfiniiVisionMath2Bus | IAgInfiniiVisionMath2Bus interface.
Public interface | IAgInfiniiVisionMath2FilterFrequency | IAgInfiniiVisionMath2FilterFrequency interface.
Public interface | IAgInfiniiVisionMath2Integrate | IAgInfiniiVisionMath2Integrate interface.
Public interface | IAgInfiniiVisionMath2Linear | IAgInfiniiVisionMath2Linear interface.
Public interface | IAgInfiniiVisionMath2MeasurementTrend | IAgInfiniiVisionMath2MeasurementTrend interface.
Public interface | IAgInfiniiVisionMathFFT | IAgInfiniiVisionMathFFT interface.
Public interface | IAgInfiniiVisionMathFFT2 | IAgInfiniiVisionMathFFT2 interface.
Public interface | IAgInfiniiVisionMathFunction | IAgInfiniiVisionMathFunction interface.
Public interface | IAgInfiniiVisionMathFunction2 | IAgInfiniiVisionMathFunction2 interface.
Public interface | IAgInfiniiVisionMathFunction2Smoothing | IAgInfiniiVisionMathFunction2Smoothing interface.
Public interface | IAgInfiniiVisionMathFunctionAverage | IAgInfiniiVisionMathFunctionAverage interface.
Public interface | IAgInfiniiVisionMathFunctionBus | IAgInfiniiVisionMath2Bus interface.
Public interface | IAgInfiniiVisionMathFunctionFFT | IAgInfiniiVisionMathFFT2 interface.
Public interface | IAgInfiniiVisionMathFunctionFFT2 | IAgInfiniiVisionMathFunctionFFT2 interface.
Public interface | IAgInfiniiVisionMathFunctionFilter | IAgInfiniiVisionMath2FilterFrequency interface.
Public interface | IAgInfiniiVisionMathFunctionIntegrate | IAgInfiniiVisionMath2Integrate interface.
Public interface | IAgInfiniiVisionMathFunctionLinear | IAgInfiniiVisionMath2Linear interface.
Public interface | IAgInfiniiVisionMathFunctionMeasurementTrend | IAgInfiniiVisionMath2MeasurementTrend interface.
Public interface | IAgInfiniiVisionMathFunctionMeasurementTrend2 | IAgInfiniiVisionMathFunctionMeasurementTrend2 interface.
Public interface | IAgInfiniiVisionMathFunctions | IAgInfiniiVisionMathFunctions interface.
Public interface | IAgInfiniiVisionMathFunctions2 | IAgInfiniiVisionMathFunctions2 interface.
Public interface | IAgInfiniiVisionMeasurement | IAgInfiniiVisionMeasurement interface.
Public interface | IAgInfiniiVisionMeasurement2 | IAgInfiniiVisionMeasurement2 interface.
Public interface | IAgInfiniiVisionMeasurements | IAgInfiniiVisionMeasurements interface.
Public interface | IAgInfiniiVisionMeasurements2 | IAgInfiniiVisionMeasurements2 interface.
Public interface | IAgInfiniiVisionMeasurements2Statistics | IAgInfiniiVisionMeasurements2Statistics interface.
Public interface | IAgInfiniiVisionMeasurements3 | IAgInfiniiVisionMeasurements3 interface.
Public interface | IAgInfiniiVisionMeasurementsConfiguration | IAgInfiniiVisionMeasurementsConfiguration interface.
Public interface | IAgInfiniiVisionMemory | IAgInfiniiVisionMemory interface.
Public interface | IAgInfiniiVisionMemory2 | IAgInfiniiVisionMemory2 interface.
Public interface | IAgInfiniiVisionMemory2ResultFormat | IAgInfiniiVisionMemory2ResultFormat interface.
Public interface | IAgInfiniiVisionMemory3 | IAgInfiniiVisionMemory3 interface.
Public interface | IAgInfiniiVisionReferenceLevel | IVI Scope class-compliant reference level interface
Public interface | IAgInfiniiVisionReferenceWaveform | IAgInfiniiVisionReferenceWaveform interface.
Public interface | IAgInfiniiVisionSearch2 | IAgInfiniiVisionSearch2 interface.
Public interface | IAgInfiniiVisionSearch3 | IAgInfiniiVisionSearch3 interface.
Public interface | IAgInfiniiVisionSearch3Peak | IAgInfiniiVisionSearch3Peak interface.
Public interface | IAgInfiniiVisionSearch4 | IAgInfiniiVisionSearch4 interface.
Public interface | IAgInfiniiVisionSearch5 | IAgInfiniiVisionSearch5 interface.
Public interface | IAgInfiniiVisionSearch5Serial4LIN2 | IAgInfiniiVisionSearch5Serial4LIN2 interface.
Public interface | IAgInfiniiVisionSearchSerial2 | IAgInfiniiVisionSearchSerial2 interface.
Public interface | IAgInfiniiVisionSearchSerial2USB | IAgInfiniiVision2SerialBus2USB interface.
Public interface | IAgInfiniiVisionSearchSerial3 | IAgInfiniiVisionSearchSerial3 interface.
Public interface | IAgInfiniiVisionSearchSerial3SENT | IAgInfiniiVisionSearchSerial3SENT interface.
Public interface | IAgInfiniiVisionSearchSerial3SENTFast | IAgInfiniiVisionSearchSerial3SENTFast interface.
Public interface | IAgInfiniiVisionSearchSerial3SENTSlow | IAgInfiniiVisionSearchSerial3SENTSlow interface.
Public interface | IAgInfiniiVisionSearchSerial4 | IAgInfiniiVisionSearchSerial4 interface.
Public interface | IAgInfiniiVisionSerialBus2 | IAgInfiniiVisionSerialBus2 interface.
Public interface | IAgInfiniiVisionSerialBus2USB | IAgInfiniiVisionSerialBus2USB interface.
Public interface | IAgInfiniiVisionSerialBus3 | IAgInfiniiVisionSerialBus3 interface.
Public interface | IAgInfiniiVisionSerialBus3CAN2 | IAgInfiniiVisionSerialBus3CAN2 interface.
Public interface | IAgInfiniiVisionSerialBus3CAN2FD | IAgInfiniiVisionSerialBus3CAN2FD interface.
Public interface | IAgInfiniiVisionSerialBus3SENT | IAgInfiniiVisionSerialBus3SENT interface.
Public interface | IAgInfiniiVisionSerialBus3SENT2 | IAgInfiniiVisionSerialBus3SENT2 interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTrigger | IAgInfiniiVisionSerialBus3SENTTrigger interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.
Public interface | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.
Public interface | IAgInfiniiVisionSerialBus4 | IAgInfiniiVisionSerialBus4 interface.
Public interface | IAgInfiniiVisionSerialBus4CAN3 | IAgInfiniiVisionSerialBus4CAN3 interface.
Public interface | IAgInfiniiVisionSerialBus4CAN3FD2 | IAgInfiniiVisionSerialBus4CAN3FD2 interface.
Public interface | IAgInfiniiVisionSerialBus4LIN2 | IAgInfiniiVisionSerialBus4LIN2 interface.
Public interface | IAgInfiniiVisionSerialBus4SENT2Trigger2 | IAgInfiniiVisionSerialBus4SENT2Trigger2 interface.
Public interface | IAgInfiniiVisionSerialBuses2 | IAgInfiniiVisionSerialBuses2 interface.
Public interface | IAgInfiniiVisionSerialBuses3 | IAgInfiniiVisionSerialBuses3 interface.
Public interface | IAgInfiniiVisionSerialBuses4 | IAgInfiniiVisionSerialBuses4 interface.
Public interface | IAgInfiniiVisionStatus | IAgInfiniiVisionStatus interface.
Public interface | IAgInfiniiVisionSystem | IAgInfiniiVisionSystem interface.
Public interface | IAgInfiniiVisionSystem2 | IAgInfiniiVisionSystem2 interface.
Public interface | IAgInfiniiVisionSystem3 | IAgInfiniiVisionSystem3 interface.
Public interface | IAgInfiniiVisionSystem3Precision | IAgInfiniiVisionSystem3Precision interface.
Public interface | IAgInfiniiVisionSystem4 | IAgInfiniiVisionSystem4 interface.
Public interface | IAgInfiniiVisionTimebase | IAgInfiniiVisionTimebase interface.
Public interface | IAgInfiniiVisionTimebaseWindow | IAgInfiniiVisionTimebaseWindow interface.
Public interface | IAgInfiniiVisionTrigger | IVI Scope class-compliant trigger interface
Public interface | IAgInfiniiVisionTrigger2 | IAgInfiniiVisionTrigger2 interface.
Public interface | IAgInfiniiVisionTrigger2Delay | IAgInfiniiVisionTrigger2Delay interface.
Public interface | IAgInfiniiVisionTrigger2EdgeBurst | IAgInfiniiVisionTrigger2EdgeBurst interface.
Public interface | IAgInfiniiVisionTrigger2OR | IAgInfiniiVisionTrigger2OR interface.
Public interface | IAgInfiniiVisionTrigger2SetupAndHold | IAgInfiniiVisionTrigger2SetupAndHold interface.
Public interface | IAgInfiniiVisionTrigger2Transition | IAgInfiniiVisionTrigger2Transition interface.
Public interface | IAgInfiniiVisionTrigger2USB | IAgInfiniiVisionTrigger2USB interface.
Public interface | IAgInfiniiVisionTrigger3 | IAgInfiniiVisionTrigger3 interface.
Public interface | IAgInfiniiVisionTrigger3Zone | IAgInfiniiVisionTrigger3Zone interface.
Public interface | IAgInfiniiVisionTrigger4 | IAgInfiniiVisionTrigger4 interface.
Public interface | IAgInfiniiVisionTrigger4PXI | IAgInfiniiVisionTrigger4PXI interface.
Public interface | IAgInfiniiVisionTrigger5 | IAgInfiniiVisionTrigger5 interface.
Public interface | IAgInfiniiVisionTrigger5RandomHoldoff | IAgInfiniiVisionTrigger5RandomHoldoff interface.
Public interface | IAgInfiniiVisionTriggerAcLine | IAgInfiniiVisionTriggerAcLine interface.
Public interface | IAgInfiniiVisionTriggerEdge | IVI Scope class-compliant edge trigger interface
Public interface | IAgInfiniiVisionTriggerGlitch | IVI Scope class-compliant glitch trigger interface
Public interface | IAgInfiniiVisionTriggerPattern | IAgInfiniiVisionTriggerPattern interface.
Public interface | IAgInfiniiVisionTriggerRunt | IVI Scope class-compliant runt trigger interface
Public interface | IAgInfiniiVisionTriggerTV | IAgInfiniiVisionTriggerTV interface.
Public interface | IAgInfiniiVisionTriggerTV2 | IAgInfiniiVisionTriggerTV2 interface.
Public interface | IAgInfiniiVisionTriggerTV2UDTV | IAgInfiniiVisionTriggerTV2UDTV interface.
Public interface | IAgInfiniiVisionTriggerWidth | IAgInfiniiVisionTriggerWidth interface.
Public interface | IAgInfiniiVisionWaveform | IAgInfiniiVisionWaveform interface.
Public interface | IAgInfiniiVisionWaveform2 | IAgInfiniiVisionWaveform2 interface.
Public interface | IAgInfiniiVisionWaveformGenerator | IAgInfiniiVisionWaveformGenerator interface.
Public interface | IAgInfiniiVisionWaveformGenerator2 | IAgInfiniiVisionWaveformGenerator2 interface.
Public interface | IAgInfiniiVisionWaveformGenerator2Arbitrary | IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public interface | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public interface | IAgInfiniiVisionWaveGen | IAgInfiniiVisionWaveGen interface.
Public interface | IAgInfiniiVisionWaveGen2 | IAgInfiniiVisionWaveGen2 interface.
Public interface | IAgInfiniiVisionWaveGen2Tracking2 | IAgInfiniiVisionWaveGen2Tracking2 interface.
Public interface | IAgInfiniiVisionWaveGenArbitrary | IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public interface | IAgInfiniiVisionWaveGenArbitraryAttribute | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public interface | IAgInfiniiVisionWaveGenModulation | IAgInfiniiVisionTrigger3Modulation interface.
Public interface | IAgInfiniiVisionWaveGenModulationAM | IAgInfiniiVisionTrigger3ModulationAM interface.
Public interface | IAgInfiniiVisionWaveGenModulationFM | IAgInfiniiVisionTrigger3ModulationFM interface.
Public interface | IAgInfiniiVisionWaveGenModulationFSK | IAgInfiniiVisionTrigger3ModulationFSK interface.
Public interface | IAgInfiniiVisionWaveGens | IAgInfiniiVisionWaveGens interface.
Public interface | IAgInfiniiVisionWaveGens2 | IAgInfiniiVisionWaveGens2 interface.
Public interface | IAgInfiniiVisionWaveGenTracking | IAgInfiniiVisionWaveGenTracking interface.


IAgInfiniiVision Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision Interface
See Also

IAgInfiniiVision interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision
   Inherits IIviDriver
C#
public interface IAgInfiniiVision : IIviDriver
Visual C++
__interface IAgInfiniiVision : IIviDriver

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface.
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface.
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface.
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface.
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface.
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license.
Public property | Math | Pointer to the IAgInfiniiVisionMath interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface.
Public property | System | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface.
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface.
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license.
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface.
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface.
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface.
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface.
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface.
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license.
Public property | Math | Pointer to the IAgInfiniiVisionMath interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface.
Public property | System | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface.
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface.
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license.
Top


IAgInfiniiVision2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2 Interface
See Also

IAgInfiniiVision2 root interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2
   Inherits IAgInfiniiVision
C#
public interface IAgInfiniiVision2 : IAgInfiniiVision
Visual C++
__interface IAgInfiniiVision2 : IAgInfiniiVision

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface.
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license.
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface.
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license.
Top


IAgInfiniiVision2Search Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search Interface
See Also

IAgInfiniiVision2Search interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2Search
C#
public interface IAgInfiniiVision2Search
Visual C++
__interface IAgInfiniiVision2Search

Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found.
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface.
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface.
Public property | Mode | The oscilloscope search mode.
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface.
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found.
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface.
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface.
Public property | Mode | The oscilloscope search mode.
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface.
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface.
Top


IAgInfiniiVision2Search5Serial4CAN2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2Search5Serial4CAN2 Interface
See Also

IAgInfiniiVision2Search5Serial4CAN2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2Search5Serial4CAN2
   Inherits IAgInfiniiVision2SearchSerialCAN
C#
public interface IAgInfiniiVision2Search5Serial4CAN2 : IAgInfiniiVision2SearchSerialCAN
Visual C++
__interface IAgInfiniiVision2Search5Serial4CAN2 : IAgInfiniiVision2SearchSerialCAN

Properties

 | Name | Description
Public property | Mode | Specifies the type of CAN information to find in the Lister display. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternData | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternDataLength | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternIDType | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | SymbolicMessage | Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.
Public property | SymbolicSignal | Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Public property | SymbolicValue | Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Mode | Specifies the type of CAN information to find in the Lister display. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternData | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternDataLength | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | PatternIDType | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event. (Inherited from IAgInfiniiVision2SearchSerialCAN.)
Public property | SymbolicMessage | Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.
Public property | SymbolicSignal | Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Public property | SymbolicValue | Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Top


IAgInfiniiVision2SearchEdge Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchEdge Interface
See Also

IAgInfiniiVision2SearchEdge interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchEdge
C#
public interface IAgInfiniiVision2SearchEdge
Visual C++
__interface IAgInfiniiVision2SearchEdge

Properties

 | Name | Description
Public property | Slope | The slope of the edge for the search.
Public property | Source | The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

Methods

 | Name | Description
Public method | Configure | Configures the Source and Slope properties for an Edge search.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the Source and Slope properties for an Edge search.
Top


Properties

 | Name | Description
Public property | Slope | The slope of the edge for the search.
Public property | Source | The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top


IAgInfiniiVision2SearchGlitch Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchGlitch Interface
See Also

IAgInfiniiVision2SearchGlitch interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchGlitch
C#
public interface IAgInfiniiVision2SearchGlitch
Visual C++
__interface IAgInfiniiVision2SearchGlitch

Properties

 | Name | Description
Public property | Condition | Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.
Public property | MaxPulseWidthDuration | The maximum pulse width duration time (in seconds) for the selected source.
Public property | MinPulseWidthDuration | The minimum pulse width duration time (in seconds) for the selected source.
Public property | Polarity | The polarity for the glitch (pulse width) source.
Public property | Source | The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

Methods

 | Name | Description
Public method | Configure | Configures the Source, Polarity and Condition properties for the Glitch search.
Public method | GetRange | Gets the pulse width duration time (in seconds) for the selected source.
Public method | SetRange | Sets the pulse width duration time (in seconds) for the selected source.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the Source, Polarity and Condition properties for the Glitch search.
Public method | GetRange | Gets the pulse width duration time (in seconds) for the selected source.
Public method | SetRange | Sets the pulse width duration time (in seconds) for the selected source.
Top


Properties

 | Name | Description
Public property | Condition | Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.
Public property | MaxPulseWidthDuration | The maximum pulse width duration time (in seconds) for the selected source.
Public property | MinPulseWidthDuration | The minimum pulse width duration time (in seconds) for the selected source.
Public property | Polarity | The polarity for the glitch (pulse width) source.
Public property | Source | The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top


IAgInfiniiVision2SearchRunt Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchRunt Interface
See Also

IAgInfiniiVision2SearchRunt interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchRunt
C#
public interface IAgInfiniiVision2SearchRunt
Visual C++
__interface IAgInfiniiVision2SearchRunt

Properties

 | Name | Description
Public property | Condition | Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.
Public property | Polarity | Sets/Gets the polarity for the runt search.
Public property | QualifierTime | When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).
Public property | Source | The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

Methods

 | Name | Description
Public method | Configure | Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.
Top


Properties

 | Name | Description
Public property | Condition | Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.
Public property | Polarity | Sets/Gets the polarity for the runt search.
Public property | QualifierTime | When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).
Public property | Source | The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top


IAgInfiniiVision2SearchSerial Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerial Interface
See Also

IAgInfiniiVision2SearchSerial interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerial
C#
public interface IAgInfiniiVision2SearchSerial
Visual C++
__interface IAgInfiniiVision2SearchSerial

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface.
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface.
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface.
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface.
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface.
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface.
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface.
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface.
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface.
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface.
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface.
Top


IAgInfiniiVision2SearchSerialARINC429 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialARINC429 Interface
See Also

IAgInfiniiVision2SearchSerialARINC429 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialARINC429
C#
public interface IAgInfiniiVision2SearchSerialARINC429
Visual C++
__interface IAgInfiniiVision2SearchSerialARINC429

Properties

 | Name | Description
Public property | Label | Specifies the ARINC 429 label value when labels are used in the selected search mode.
Public property | Mode | Specifies the type of ARINC 429 information to find in the Lister display.
Public property | PatternData | Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.
Public property | PatternSDI | Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.
Public property | PatternSSM | Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Label | Specifies the ARINC 429 label value when labels are used in the selected search mode.
Public property | Mode | Specifies the type of ARINC 429 information to find in the Lister display.
Public property | PatternData | Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.
Public property | PatternSDI | Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.
Public property | PatternSSM | Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.
Top


IAgInfiniiVision2SearchSerialCAN Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialCAN Interface
See Also

IAgInfiniiVision2SearchSerialCAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialCAN
C#
public interface IAgInfiniiVision2SearchSerialCAN
Visual C++
__interface IAgInfiniiVision2SearchSerialCAN

Properties

 | Name | Description
Public property | Mode | Specifies the type of CAN information to find in the Lister display.
Public property | PatternData | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Public property | PatternDataLength | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.
Public property | PatternID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Public property | PatternIDType | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Mode | Specifies the type of CAN information to find in the Lister display.
Public property | PatternData | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Public property | PatternDataLength | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.
Public property | PatternID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Public property | PatternIDType | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.
Top


IAgInfiniiVision2SearchSerialFlexRay Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialFlexRay Interface
See Also

IAgInfiniiVision2SearchSerialFlexRay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialFlexRay
C#
public interface IAgInfiniiVision2SearchSerialFlexRay
Visual C++
__interface IAgInfiniiVision2SearchSerialFlexRay

Properties

 | Name | Description
Public property | CycleNumber | Specifies the cycle value to find when searching for FlexRay frames.
Public property | FrameID | Specifies the frame ID value to find when searching for FlexRay frames.
Public property | Mode | Specifies the type of FlexRay information to find in the Lister display.
Public property | PatternData | Specifies the data value to find when searching for FlexRay frames.
Public property | PatternDataLength | Specifies the length of data values when searching for FlexRay frames.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CycleNumber | Specifies the cycle value to find when searching for FlexRay frames.
Public property | FrameID | Specifies the frame ID value to find when searching for FlexRay frames.
Public property | Mode | Specifies the type of FlexRay information to find in the Lister display.
Public property | PatternData | Specifies the data value to find when searching for FlexRay frames.
Public property | PatternDataLength | Specifies the length of data values when searching for FlexRay frames.
Top


IAgInfiniiVision2SearchSerialI2S Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialI2S Interface
See Also

IAgInfiniiVision2SearchSerialI2S interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialI2S
C#
public interface IAgInfiniiVision2SearchSerialI2S
Visual C++
__interface IAgInfiniiVision2SearchSerialI2S

Properties

 | Name | Description
Public property | AudioChannel | Specifies the channel on which to search for I2S events: right, left, or either channel.
Public property | Mode | Specifies the type of I2S information to find in the Lister display.
Public property | PatternData | Specifies the data word value when searching for I2S events.
Top

Methods

 | Name | Description
Public method | GetRange | Gets the data value range when searching for I2S events.
Public method | SetRange | Sets the data value range when searching for I2S events.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetRange | Gets the data value range when searching for I2S events.
Public method | SetRange | Sets the data value range when searching for I2S events.
Top


Properties

 | Name | Description
Public property | AudioChannel | Specifies the channel on which to search for I2S events: right, left, or either channel.
Public property | Mode | Specifies the type of I2S information to find in the Lister display.
Public property | PatternData | Specifies the data word value when searching for I2S events.
Top


IAgInfiniiVision2SearchSerialIIC Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialIIC Interface
See Also

IAgInfiniiVision2SearchSerialIIC interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialIIC
C#
public interface IAgInfiniiVision2SearchSerialIIC
Visual C++
__interface IAgInfiniiVision2SearchSerialIIC

Properties

 | Name | Description
Public property | Address | Specifies the address values when searching for IIC events.
Public property | Condition | Specifies the data value qualifier used when searching for IIC EEPROM data read events.
Public property | Mode | Selects the type of IIC information to find in the Lister display.
Public property | PatternData | Specifies the data values when searching for IIC events.
Public property | PatternData2 | Specifies the second data value when searching for IIC events with two data values.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Address | Specifies the address values when searching for IIC events.
Public property | Condition | Specifies the data value qualifier used when searching for IIC EEPROM data read events.
Public property | Mode | Selects the type of IIC information to find in the Lister display.
Public property | PatternData | Specifies the data values when searching for IIC events.
Public property | PatternData2 | Specifies the second data value when searching for IIC events with two data values.
Top


IAgInfiniiVision2SearchSerialLIN Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialLIN Interface
See Also

IAgInfiniiVision2SearchSerialLIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialLIN
C#
public interface IAgInfiniiVision2SearchSerialLIN
Visual C++
__interface IAgInfiniiVision2SearchSerialLIN

Properties

 | Name | Description
Public property | ID | Specifies the frame ID value when searching for LIN events
Public property | Mode | Selects the type of LIN information to find in the Lister display
Public property | PatternData | Specifies the data value when searching for LIN events.
Public property | PatternDataLength | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ID | Specifies the frame ID value when searching for LIN events
Public property | Mode | Selects the type of LIN information to find in the Lister display
Public property | PatternData | Specifies the data value when searching for LIN events.
Public property | PatternDataLength | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.
Top


IAgInfiniiVision2SearchSerialM1553 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialM1553 Interface
See Also

IAgInfiniiVision2SearchSerialM1553 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialM1553
C#
public interface IAgInfiniiVision2SearchSerialM1553
Visual C++
__interface IAgInfiniiVision2SearchSerialM1553

Properties

 | Name | Description
Public property | Mode | Specifies the type of MIL-STD-1553 information to find in the Lister display.
Public property | PatternData | Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.
Public property | RTA | Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Mode | Specifies the type of MIL-STD-1553 information to find in the Lister display.
Public property | PatternData | Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.
Public property | RTA | Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.
Top


IAgInfiniiVision2SearchSerialSPI Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialSPI Interface
See Also

IAgInfiniiVision2SearchSerialSPI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialSPI
C#
public interface IAgInfiniiVision2SearchSerialSPI
Visual C++
__interface IAgInfiniiVision2SearchSerialSPI

Properties

 | Name | Description
Public property | Mode | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Public property | PatternData | Specifies the data value when searching for SPI events.
Public property | PatternWidth | Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Mode | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Public property | PatternData | Specifies the data value when searching for SPI events.
Public property | PatternWidth | Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.
Top


IAgInfiniiVision2SearchSerialUART Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchSerialUART Interface
See Also

IAgInfiniiVision2SearchSerialUART interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchSerialUART
C#
public interface IAgInfiniiVision2SearchSerialUART
Visual C++
__interface IAgInfiniiVision2SearchSerialUART

Properties

 | Name | Description
Public property | Condition | Specifies the data value qualifier when searching for UART/RS232 events.
Public property | Mode | Selects the type of UART/RS232 information to find in the Lister display
Public property | PatternData | Specifies a data value when searching for UART/RS232 events.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Condition | Specifies the data value qualifier when searching for UART/RS232 events.
Public property | Mode | Selects the type of UART/RS232 information to find in the Lister display
Public property | PatternData | Specifies a data value when searching for UART/RS232 events.
Top


IAgInfiniiVision2SearchTransition Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SearchTransition Interface
See Also

IAgInfiniiVision2SearchTransition interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SearchTransition
C#
public interface IAgInfiniiVision2SearchTransition
Visual C++
__interface IAgInfiniiVision2SearchTransition

Properties

 | Name | Description
Public property | Condition | Specifies whether to search for edge transitions greater than or less than a time.
Public property | QualifierTime | The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.
Public property | Slope | Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.
Public property | Source | The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

Methods

 | Name | Description
Public method | Configure | Configures the Source, Slope, Condition and QualifierTime properties for a transition search.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the Source, Slope, Condition and QualifierTime properties for a transition search.
Top


Properties

 | Name | Description
Public property | Condition | Specifies whether to search for edge transitions greater than or less than a time.
Public property | QualifierTime | The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.
Public property | Slope | Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.
Public property | Source | The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top


IAgInfiniiVision2SerialBus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBus Interface
See Also

IAgInfiniiVision2SerialBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBus
C#
public interface IAgInfiniiVision2SerialBus
Visual C++
__interface IAgInfiniiVision2SerialBus

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface.
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface.
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface.
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface.
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface.
Public property | Mode | Determines the decode mode for the serial bus.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface.
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface.
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface.
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface.
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface.
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface.
Public property | Mode | Determines the decode mode for the serial bus.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface.
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface.
Top


IAgInfiniiVision2SerialBusARINC429 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusARINC429 Interface
See Also

IAgInfiniiVision2SerialBusARINC429 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusARINC429
C#
public interface IAgInfiniiVision2SerialBusARINC429
Visual C++
__interface IAgInfiniiVision2SerialBusARINC429

Properties

 | Name | Description
Public property | Base | Selects between hexadecimal and binary display of the decoded data.
Public property | DisplayFormat | Specifies the word decode format.
Public property | ErrorCount | Read Only - Returns the ARINC 429 error count.
Public property | SignalType | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Public property | Source | Specifies which signal is used as the source for the selected bus.
Public property | Speed | Specifies the speed of the ARINC 429 interface for the selected bus.
Public property | TriggerLabel | Specifies the Label portion of the trigger for the selected bus.
Public property | TriggerPatternData | Specifies the Data portion of the trigger for the selected bus, in binary.
Public property | TriggerPatternSDI | Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Public property | TriggerPatternSSM | Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Public property | TriggerThresholdHigh | The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Public property | TriggerThresholdLow | The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Public property | TriggerType | Specifies the ARINC 429 trigger mode for the selected bus.
Public property | WordCount | Read Only - Returns the ARINC 429 word count.
Top

Methods

 | Name | Description
Public method | AutoSetup | Automatically configures settings for the ARINC 429 serial bus mode.
Public method | GetTriggerRange | Gets the range for the Label Range trigger mode for the selected bus.
Public method | ResetCounters | Resets the ARINC 429 counters.
Public method | SetTriggerRange | Sets the range for the Label Range trigger mode for the selected bus.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | AutoSetup | Automatically configures settings for the ARINC 429 serial bus mode.
Public method | GetTriggerRange | Gets the range for the Label Range trigger mode for the selected bus.
Public method | ResetCounters | Resets the ARINC 429 counters.
Public method | SetTriggerRange | Sets the range for the Label Range trigger mode for the selected bus.
Top


Properties

 | Name | Description
Public property | Base | Selects between hexadecimal and binary display of the decoded data.
Public property | DisplayFormat | Specifies the word decode format.
Public property | ErrorCount | Read Only - Returns the ARINC 429 error count.
Public property | SignalType | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Public property | Source | Specifies which signal is used as the source for the selected bus.
Public property | Speed | Specifies the speed of the ARINC 429 interface for the selected bus.
Public property | TriggerLabel | Specifies the Label portion of the trigger for the selected bus.
Public property | TriggerPatternData | Specifies the Data portion of the trigger for the selected bus, in binary.
Public property | TriggerPatternSDI | Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Public property | TriggerPatternSSM | Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Public property | TriggerThresholdHigh | The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Public property | TriggerThresholdLow | The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Public property | TriggerType | Specifies the ARINC 429 trigger mode for the selected bus.
Public property | WordCount | Read Only - Returns the ARINC 429 word count.
Top


IAgInfiniiVision2SerialBusCAN Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusCAN Interface
See Also

IAgInfiniiVision2SerialBusCAN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusCAN
C#
public interface IAgInfiniiVision2SerialBusCAN
Visual C++
__interface IAgInfiniiVision2SerialBusCAN

Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Public property | ErrorCount | Read Only - Gets the error frame count.
Public property | OverloadCount | Read Only - Gets the overload frame count.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).
Public property | Source | Specifies the source for the CAN signal
Public property | TotalCount | Read Only - Gets the total frame count.
Public property | TriggerCondition | Specifies the CAN trigger on condition
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.
Public property | Utilization | Read Only - Gets the percent utilization.
Top

Methods

 | Name | Description
Public method | ResetCounters | Resets the frame counters.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ResetCounters | Resets the frame counters.
Top


Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Public property | ErrorCount | Read Only - Gets the error frame count.
Public property | OverloadCount | Read Only - Gets the overload frame count.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).
Public property | Source | Specifies the source for the CAN signal
Public property | TotalCount | Read Only - Gets the total frame count.
Public property | TriggerCondition | Specifies the CAN trigger on condition
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.
Public property | Utilization | Read Only - Gets the percent utilization.
Top


IAgInfiniiVision2SerialBuses Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBuses Interface
See Also

IAgInfiniiVision2SerialBuses interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBuses
C#
public interface IAgInfiniiVision2SerialBuses
Visual C++
__interface IAgInfiniiVision2SerialBuses

Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses.
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface.
Public property | Name | Read Only - Returns the serial bus name for a given index.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses.
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface.
Public property | Name | Read Only - Returns the serial bus name for a given index.
Top


IAgInfiniiVision2SerialBusesLister Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusesLister Interface
See Also

IAgInfiniiVision2SerialBusesLister interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusesLister
C#
public interface IAgInfiniiVision2SerialBusesLister
Visual C++
__interface IAgInfiniiVision2SerialBusesLister

Properties

 | Name | Description
Public property | Display | The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.
Public property | TimeReference | Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.
Top

Methods

 | Name | Description
Public method | GetData | Gets the lister data as a string.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetData | Gets the lister data as a string.
Top


Properties

 | Name | Description
Public property | Display | The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.
Public property | TimeReference | Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.
Top


IAgInfiniiVision2SerialBusFlexRay Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusFlexRay Interface
See Also

IAgInfiniiVision2SerialBusFlexRay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusFlexRay
C#
public interface IAgInfiniiVision2SerialBusFlexRay
Visual C++
__interface IAgInfiniiVision2SerialBusFlexRay

Properties

 | Name | Description
Public property | BaudRate | Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.
Public property | Channel | Specifies the bus channel, A or B, of the FlexRay signal.
Public property | ErrorCount | Read Only - Gets the FlexRay error frame count.
Public property | NullCount | Read Only - Gets the FlexRay null frame count.
Public property | Source | Specifies the input source for the FlexRay signal.
Public property | SyncCount | Read Only - Gets the FlexRay sync frame count.
Public property | TotalCount | Read Only - Gets the FlexRay total frame count.
Public property | TriggerErrorType | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Public property | TriggerEventBSSID | Specifies the ByteStart Sequence ID.
Public property | TriggerEventType | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Public property | TriggerFrameCCBase | Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameCCRepetition | Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameID | Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameType | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerType | Specifies the FlexRay trigger on condition.
Top

Methods

 | Name | Description
Public method | AutoSetup | Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.
Public method | ResetCounters | Resets the FlexRay frame counters.
Public method | TriggerEventAutoSetup | Presets oscilloscope parameters for the selected event type.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | AutoSetup | Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.
Public method | ResetCounters | Resets the FlexRay frame counters.
Public method | TriggerEventAutoSetup | Presets oscilloscope parameters for the selected event type.
Top


Properties

 | Name | Description
Public property | BaudRate | Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.
Public property | Channel | Specifies the bus channel, A or B, of the FlexRay signal.
Public property | ErrorCount | Read Only - Gets the FlexRay error frame count.
Public property | NullCount | Read Only - Gets the FlexRay null frame count.
Public property | Source | Specifies the input source for the FlexRay signal.
Public property | SyncCount | Read Only - Gets the FlexRay sync frame count.
Public property | TotalCount | Read Only - Gets the FlexRay total frame count.
Public property | TriggerErrorType | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Public property | TriggerEventBSSID | Specifies the ByteStart Sequence ID.
Public property | TriggerEventType | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Public property | TriggerFrameCCBase | Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameCCRepetition | Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameID | Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerFrameType | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Public property | TriggerType | Specifies the FlexRay trigger on condition.
Top


IAgInfiniiVision2SerialBusI2S Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusI2S Interface
See Also

IAgInfiniiVision2SerialBusI2S interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusI2S
C#
public interface IAgInfiniiVision2SerialBusI2S
Visual C++
__interface IAgInfiniiVision2SerialBusI2S

Properties

 | Name | Description
Public property | Base | Specifies the base to use for the I2S decode display.
Public property | ClockSlope | Specifies which edge of the I2S serial clock signal clocks in data
Public property | ClockSource | Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.
Public property | DataAlignment | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.
Public property | DataSource | Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.
Public property | ReceiverWidth | Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits
Public property | TransmittedWidth | Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.
Public property | TriggerAudioChannel | Specifies the audio channel to trigger on.
Public property | TriggerCondition | Specified the I2S trigger operator.
Public property | TriggerPatternData | Specifies the I2S trigger data pattern searched for in each I2S message.
Public property | WordSelectPolarity | Specifies the polarity of the word select (WS) signal.
Public property | WordSelectSource | Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.
Top

Methods

 | Name | Description
Public method | GetTriggerRange | Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Public method | SetTriggerRange | Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetTriggerRange | Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Public method | SetTriggerRange | Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Top


Properties

 | Name | Description
Public property | Base | Specifies the base to use for the I2S decode display.
Public property | ClockSlope | Specifies which edge of the I2S serial clock signal clocks in data
Public property | ClockSource | Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.
Public property | DataAlignment | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.
Public property | DataSource | Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.
Public property | ReceiverWidth | Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits
Public property | TransmittedWidth | Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.
Public property | TriggerAudioChannel | Specifies the audio channel to trigger on.
Public property | TriggerCondition | Specified the I2S trigger operator.
Public property | TriggerPatternData | Specifies the I2S trigger data pattern searched for in each I2S message.
Public property | WordSelectPolarity | Specifies the polarity of the word select (WS) signal.
Public property | WordSelectSource | Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.
Top


IAgInfiniiVision2SerialBusIIC Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusIIC Interface
See Also

IAgInfiniiVision2SerialBusIIC interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusIIC
C#
public interface IAgInfiniiVision2SerialBusIIC
Visual C++
__interface IAgInfiniiVision2SerialBusIIC

Properties

 | Name | Description
Public property | AddressWidth | Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Public property | ClockSource | Specifies the source for the IIC serial clock (SCL).
Public property | DataSource | Specifies the source for IIC serial data (SDA).
Public property | TriggerCondition | Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom
Public property | TriggerPatternAddress | Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.
Public property | TriggerPatternData | Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Public property | TriggerPatternData2 | Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Public property | TriggerType | Specifies the IIC trigger type.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AddressWidth | Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Public property | ClockSource | Specifies the source for the IIC serial clock (SCL).
Public property | DataSource | Specifies the source for IIC serial data (SDA).
Public property | TriggerCondition | Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom
Public property | TriggerPatternAddress | Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.
Public property | TriggerPatternData | Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Public property | TriggerPatternData2 | Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Public property | TriggerType | Specifies the IIC trigger type.
Top


IAgInfiniiVision2SerialBusLIN Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusLIN Interface
See Also

IAgInfiniiVision2SerialBusLIN interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusLIN
C#
public interface IAgInfiniiVision2SerialBusLIN
Visual C++
__interface IAgInfiniiVision2SerialBusLIN

Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s
Public property | ParityEnabled | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Public property | Source | Specifies the source for the CAN signal.
Public property | Standard | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Public property | SyncBreakLength | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.
Public property | TriggerCondition | Specifies the LIN trigger condition.
Public property | TriggerID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.
Public property | TriggerPatternData | Specifies the LIN trigger data pattern searched for in each LIN data field.
Public property | TriggerPatternDataLength | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s
Public property | ParityEnabled | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Public property | Source | Specifies the source for the CAN signal.
Public property | Standard | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Public property | SyncBreakLength | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.
Public property | TriggerCondition | Specifies the LIN trigger condition.
Public property | TriggerID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.
Public property | TriggerPatternData | Specifies the LIN trigger data pattern searched for in each LIN data field.
Public property | TriggerPatternDataLength | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Top


IAgInfiniiVision2SerialBusM1553 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusM1553 Interface
See Also

IAgInfiniiVision2SerialBusM1553 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusM1553
C#
public interface IAgInfiniiVision2SerialBusM1553
Visual C++
__interface IAgInfiniiVision2SerialBusM1553

Properties

 | Name | Description
Public property | Base | Specifies the base to use for the MIL-STD 1553 decode display.
Public property | Source | Specifies which signal is used as the source for the selected bus.
Public property | TriggerPatternData | Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.
Public property | TriggerRTA | Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.
Public property | TriggerThresholdHigh | The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Public property | TriggerThresholdLow | The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Public property | TriggerType | Specifies the type of MIL-STD 1553 trigger to be used.
Top

Methods

 | Name | Description
Public method | AutoSetup | This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | AutoSetup | This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.
Top


Properties

 | Name | Description
Public property | Base | Specifies the base to use for the MIL-STD 1553 decode display.
Public property | Source | Specifies which signal is used as the source for the selected bus.
Public property | TriggerPatternData | Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.
Public property | TriggerRTA | Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.
Public property | TriggerThresholdHigh | The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Public property | TriggerThresholdLow | The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Public property | TriggerType | Specifies the type of MIL-STD 1553 trigger to be used.
Top


IAgInfiniiVision2SerialBusSPI Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusSPI Interface
See Also

IAgInfiniiVision2SerialBusSPI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusSPI
C#
public interface IAgInfiniiVision2SerialBusSPI
Visual C++
__interface IAgInfiniiVision2SerialBusSPI

Properties

 | Name | Description
Public property | BitOrder | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Public property | ClockSlope | Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Public property | ClockSource | Specifies the source for the SPI serial clock.
Public property | ClockTimeout | Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.
Public property | FrameSource | Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.
Public property | Framing | Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.
Public property | MISOSource | Specifies the source for the SPI serial MISO data.
Public property | MOSISource | Specifies the source for the SPI serial MOSI data.
Public property | TriggerPatternMISOData | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Public property | TriggerPatternMISOWidth | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Public property | TriggerPatternMOSIData | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Public property | TriggerPatternMOSIWidth | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Public property | TriggerType | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Public property | Width | Specifies the number of bits in a word of data for SPI.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BitOrder | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Public property | ClockSlope | Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Public property | ClockSource | Specifies the source for the SPI serial clock.
Public property | ClockTimeout | Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.
Public property | FrameSource | Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.
Public property | Framing | Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.
Public property | MISOSource | Specifies the source for the SPI serial MISO data.
Public property | MOSISource | Specifies the source for the SPI serial MOSI data.
Public property | TriggerPatternMISOData | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Public property | TriggerPatternMISOWidth | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Public property | TriggerPatternMOSIData | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Public property | TriggerPatternMOSIWidth | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Public property | TriggerType | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Public property | Width | Specifies the number of bits in a word of data for SPI.
Top


IAgInfiniiVision2SerialBusUART Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision2SerialBusUART Interface
See Also

IAgInfiniiVision2SerialBusUART interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision2SerialBusUART
C#
public interface IAgInfiniiVision2SerialBusUART
Visual C++
__interface IAgInfiniiVision2SerialBusUART

Properties

 | Name | Description
Public property | Base | Specifies the base to use for the UART decode and Lister display.
Public property | BaudRate | Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.
Public property | BitOrder | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Public property | ErrorCount | Read Only - Gets the UART error frame count.
Public property | Framing | Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.
Public property | Parity | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Public property | Polarity | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Public property | RxFrameCount | Read Only - Gets the UART Rx frame count.
Public property | RxSource | Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.
Public property | TriggerBase | Specifies the front panel UART/RS232 trigger setup data selection.
Public property | TriggerBurst | Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.
Public property | TriggerCondition | Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.
Public property | TriggerData | Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.
Public property | TriggerIdleTime | Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.
Public property | TriggerType | Specifies the UART Trigger Type
Public property | TxFrameCount | Read Only - Gets the UART Tx frame count.
Public property | TxSource | Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.
Public property | Width | Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.
Top

Methods

 | Name | Description
Public method | ResetCounters | This method resets the UART frame counters.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ResetCounters | This method resets the UART frame counters.
Top


Properties

 | Name | Description
Public property | Base | Specifies the base to use for the UART decode and Lister display.
Public property | BaudRate | Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.
Public property | BitOrder | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Public property | ErrorCount | Read Only - Gets the UART error frame count.
Public property | Framing | Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.
Public property | Parity | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Public property | Polarity | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Public property | RxFrameCount | Read Only - Gets the UART Rx frame count.
Public property | RxSource | Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.
Public property | TriggerBase | Specifies the front panel UART/RS232 trigger setup data selection.
Public property | TriggerBurst | Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.
Public property | TriggerCondition | Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.
Public property | TriggerData | Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.
Public property | TriggerIdleTime | Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.
Public property | TriggerType | Specifies the UART Trigger Type
Public property | TxFrameCount | Read Only - Gets the UART Tx frame count.
Public property | TxSource | Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.
Public property | Width | Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.
Top


IAgInfiniiVision3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision3 Interface
See Also

IAgInfiniiVision3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision3
   Inherits IAgInfiniiVision2
C#
public interface IAgInfiniiVision3 : IAgInfiniiVision2
Visual C++
__interface IAgInfiniiVision3 : IAgInfiniiVision2

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface.
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface.
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface.
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface.
Top


IAgInfiniiVision4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4 Interface
See Also

IAgInfiniiVision4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4
   Inherits IAgInfiniiVision3
C#
public interface IAgInfiniiVision4 : IAgInfiniiVision3
Visual C++
__interface IAgInfiniiVision4 : IAgInfiniiVision3

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface.
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface.
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface.
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface.
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface.
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface.
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface.
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface.
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface.
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface.
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Top


IAgInfiniiVision4ClockRecovery Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4ClockRecovery Interface
See Also

IAgInfiniiVision4ClockRecovery interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4ClockRecovery
C#
public interface IAgInfiniiVision4ClockRecovery
Visual C++
__interface IAgInfiniiVision4ClockRecovery

Properties

 | Name | Description
Public property | DisplayEnabled | Enable or disable the display of the recovered clock.
Top

Methods

 | Name | Description
Public method | GetMethod | Returns the currently selected clock recovery method.
Public method | SetMethod | Sets the clock recovery method.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetMethod | Returns the currently selected clock recovery method.
Public method | SetMethod | Sets the clock recovery method.
Top


Properties

 | Name | Description
Public property | DisplayEnabled | Enable or disable the display of the recovered clock.
Top


IAgInfiniiVision4Counter Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Counter Interface
See Also

IAgInfiniiVision4Counter interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4Counter
C#
public interface IAgInfiniiVision4Counter
Visual C++
__interface IAgInfiniiVision4Counter

Properties

 | Name | Description
Public property | Current | Read Only - the current counter value.
Public property | Enabled | Enables or disables the counter feature.
Public property | Mode | The counter mode.
Public property | NumberOfDigits | The number of digits of resolution used for the frequency or period counter.
Public property | Source | The waveform source that the counter measures.
Public property | Totalizer | Pointer to the IAgInfiniiVision4CounterTotalizer interface.
Top

Methods

 | Name | Description
Public method | Configure | This method sets the Counter mode, source and Number of digits of resolution.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | This method sets the Counter mode, source and Number of digits of resolution.
Top


Properties

 | Name | Description
Public property | Current | Read Only - the current counter value.
Public property | Enabled | Enables or disables the counter feature.
Public property | Mode | The counter mode.
Public property | NumberOfDigits | The number of digits of resolution used for the frequency or period counter.
Public property | Source | The waveform source that the counter measures.
Public property | Totalizer | Pointer to the IAgInfiniiVision4CounterTotalizer interface.
Top


IAgInfiniiVision4CounterTotalizer Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizer Interface
See Also

IAgInfiniiVision4CounterTotalizer interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4CounterTotalizer
C#
public interface IAgInfiniiVision4CounterTotalizer
Visual C++
__interface IAgInfiniiVision4CounterTotalizer

Properties

 | Name | Description
Public property | Gating | Pointer to the IAgInfiniiVision4CounterTotalizerGating interface.
Public property | Slope | Specifies whether positive or negative edges are counted.
Top

Methods

 | Name | Description
Public method | Clear | Zeros the edge event counter.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Zeros the edge event counter.
Top


Properties

 | Name | Description
Public property | Gating | Pointer to the IAgInfiniiVision4CounterTotalizerGating interface.
Public property | Slope | Specifies whether positive or negative edges are counted.
Top


IAgInfiniiVision4CounterTotalizerGating Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4CounterTotalizerGating Interface
See Also

IAgInfiniiVision4CounterTotalizerGating interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4CounterTotalizerGating
C#
public interface IAgInfiniiVision4CounterTotalizerGating
Visual C++
__interface IAgInfiniiVision4CounterTotalizerGating

Properties

 | Name | Description
Public property | Enabled | Enables or disables totalizer gating.
Public property | Polarity | The gating signal condition under which totalizer edges are counted.
Public property | Source | The analog channel that has the totalizer gating signal.
Top

Methods

 | Name | Description
Public method | Configure | This method sets the totalize gated source and polarity.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | This method sets the totalize gated source and polarity.
Top


Properties

 | Name | Description
Public property | Enabled | Enables or disables totalizer gating.
Public property | Polarity | The gating signal condition under which totalizer edges are counted.
Public property | Source | The analog channel that has the totalizer gating signal.
Top


IAgInfiniiVision4Histogram Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Histogram Interface
See Also

IAgInfiniiVision4Histogram interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4Histogram
C#
public interface IAgInfiniiVision4Histogram
Visual C++
__interface IAgInfiniiVision4Histogram

Properties

 | Name | Description
Public property | Axis | The orientation of the histogram.
Public property | DisplayEnabled | Enable or disable the histogram display.
Public property | Measurement | The measurement to analyze.
Public property | Mode | The type of histogram or disables the histogram analysis feature.
Public property | Size | The number of divisions the histogram bar graph should use.
Public property | Type | The histogram type.
Public property | Window | Pointer to the IAgInfiniiVision4HistogramWindow interface.
Top

Methods

 | Name | Description
Public method | GetResult | Returns the histogram result of the selected result type.
Public method | Reset | Zeros the histogram counters.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetResult | Returns the histogram result of the selected result type.
Public method | Reset | Zeros the histogram counters.
Top


Properties

 | Name | Description
Public property | Axis | The orientation of the histogram.
Public property | DisplayEnabled | Enable or disable the histogram display.
Public property | Measurement | The measurement to analyze.
Public property | Mode | The type of histogram or disables the histogram analysis feature.
Public property | Size | The number of divisions the histogram bar graph should use.
Public property | Type | The histogram type.
Public property | Window | Pointer to the IAgInfiniiVision4HistogramWindow interface.
Top


IAgInfiniiVision4HistogramWindow Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindow Interface
See Also

IAgInfiniiVision4HistogramWindow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4HistogramWindow
C#
public interface IAgInfiniiVision4HistogramWindow
Visual C++
__interface IAgInfiniiVision4HistogramWindow

Properties

 | Name | Description
Public property | Limits | Pointer to the IAgInfiniiVision4HistogramWindowLimits interface.
Public property | Source | The waveform that is used as the histogram source.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Limits | Pointer to the IAgInfiniiVision4HistogramWindowLimits interface.
Public property | Source | The waveform that is used as the histogram source.
Top


IAgInfiniiVision4HistogramWindowLimits Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4HistogramWindowLimits Interface
See Also

IAgInfiniiVision4HistogramWindowLimits interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4HistogramWindowLimits
C#
public interface IAgInfiniiVision4HistogramWindowLimits
Visual C++
__interface IAgInfiniiVision4HistogramWindowLimits

Properties

 | Name | Description
Public property | Bottom | The histogram limits window's bottom boundary.
Public property | Left | The histogram limits window's left boundary.
Public property | Right | The histogram limits window's right boundary.
Public property | Top | The histogram limits window's top boundary.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Bottom | The histogram limits window's bottom boundary.
Public property | Left | The histogram limits window's left boundary.
Public property | Right | The histogram limits window's right boundary.
Public property | Top | The histogram limits window's top boundary.
Top


IAgInfiniiVision4Jitter Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4Jitter Interface
See Also

IAgInfiniiVision4Jitter interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4Jitter
C#
public interface IAgInfiniiVision4Jitter
Visual C++
__interface IAgInfiniiVision4Jitter

Properties

 | Name | Description
Public property | AnalysisEnabled | Enables or disables the jitter analysis feature.
Public property | Measurement | The measurement to analyze.
Public property | Spectrum | Pointer to the IAgInfiniiVision4JitterSpectrum interface.
Public property | Trend | Pointer to the IAgInfiniiVision4JitterTrend interface.
Top

Methods

 | Name | Description
Public method | ConfigureHistogram | Auto-configures and turns on the jitter measurement histogram for the selected measurement.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureHistogram | Auto-configures and turns on the jitter measurement histogram for the selected measurement.
Top


Properties

 | Name | Description
Public property | AnalysisEnabled | Enables or disables the jitter analysis feature.
Public property | Measurement | The measurement to analyze.
Public property | Spectrum | Pointer to the IAgInfiniiVision4JitterSpectrum interface.
Public property | Trend | Pointer to the IAgInfiniiVision4JitterTrend interface.
Top


IAgInfiniiVision4JitterSpectrum Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrum Interface
See Also

IAgInfiniiVision4JitterSpectrum interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4JitterSpectrum
C#
public interface IAgInfiniiVision4JitterSpectrum
Visual C++
__interface IAgInfiniiVision4JitterSpectrum

Properties

 | Name | Description
Public property | Horizontal | Pointer to the IAgInfiniiVision4JitterSpectrumHorizontal interface.
Public property | Vertical | Pointer to the IAgInfiniiVision4JitterSpectrumVertical interface.
Public property | Window | Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).
Top

Methods

 | Name | Description
Public method | Configure | Auto-configures and turns on the jitter spectrum for the selected measurement.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Auto-configures and turns on the jitter spectrum for the selected measurement.
Top


Properties

 | Name | Description
Public property | Horizontal | Pointer to the IAgInfiniiVision4JitterSpectrumHorizontal interface.
Public property | Vertical | Pointer to the IAgInfiniiVision4JitterSpectrumVertical interface.
Public property | Window | Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).
Top


IAgInfiniiVision4JitterSpectrumHorizontal Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumHorizontal Interface
See Also

IAgInfiniiVision4JitterSpectrumHorizontal interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4JitterSpectrumHorizontal
C#
public interface IAgInfiniiVision4JitterSpectrumHorizontal
Visual C++
__interface IAgInfiniiVision4JitterSpectrumHorizontal

Properties

 | Name | Description
Public property | CenterFrequency | The center frequency for the jitter measurement spectrum.
Public property | FrequencySpan | The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CenterFrequency | The center frequency for the jitter measurement spectrum.
Public property | FrequencySpan | The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.
Top


IAgInfiniiVision4JitterSpectrumVertical Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterSpectrumVertical Interface
See Also

IAgInfiniiVision4JitterSpectrumVertical interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4JitterSpectrumVertical
C#
public interface IAgInfiniiVision4JitterSpectrumVertical
Visual C++
__interface IAgInfiniiVision4JitterSpectrumVertical

Properties

 | Name | Description
Public property | Offset | The vertical value represented at center screen for the jitter measurement spectrum.
Public property | Range | The full-scale vertical range for the jitter measurement spectrum.
Public property | Unit | The vertical units for the jitter spectrum.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Offset | The vertical value represented at center screen for the jitter measurement spectrum.
Public property | Range | The full-scale vertical range for the jitter measurement spectrum.
Public property | Unit | The vertical units for the jitter spectrum.
Top


IAgInfiniiVision4JitterTrend Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrend Interface
See Also

IAgInfiniiVision4JitterTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4JitterTrend
C#
public interface IAgInfiniiVision4JitterTrend
Visual C++
__interface IAgInfiniiVision4JitterTrend

Properties

 | Name | Description
Public property | SmoothingPoints | The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.
Public property | Vertical | Pointer to the IAgInfiniiVision4JitterTrendVertical interface.
Top

Methods

 | Name | Description
Public method | Configure | Auto-configures and turns on the jitter measurement trend for the selected measurement.
Public method | ConfigureSmoothing | Auto-configures and turns on smoothing for the jitter measurement trend.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Auto-configures and turns on the jitter measurement trend for the selected measurement.
Public method | ConfigureSmoothing | Auto-configures and turns on smoothing for the jitter measurement trend.
Top


Properties

 | Name | Description
Public property | SmoothingPoints | The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.
Public property | Vertical | Pointer to the IAgInfiniiVision4JitterTrendVertical interface.
Top


IAgInfiniiVision4JitterTrendVertical Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision4JitterTrendVertical Interface
See Also

IAgInfiniiVision4JitterTrendVertical interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision4JitterTrendVertical
C#
public interface IAgInfiniiVision4JitterTrendVertical
Visual C++
__interface IAgInfiniiVision4JitterTrendVertical

Properties

 | Name | Description
Public property | Offset | The vertical value represented at center screen for the jitter measurement trend.
Public property | Range | The full-scale vertical range for the jitter measurement trend.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Offset | The vertical value represented at center screen for the jitter measurement trend.
Public property | Range | The full-scale vertical range for the jitter measurement trend.
Top


IAgInfiniiVision5 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5 Interface
See Also

IAgInfiniiVision5 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision5
   Inherits IAgInfiniiVision4
C#
public interface IAgInfiniiVision5 : IAgInfiniiVision4
Visual C++
__interface IAgInfiniiVision5 : IAgInfiniiVision4

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface.
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface.
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface.
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface.
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface.
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Top


IAgInfiniiVision5FFT Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision5FFT Interface
See Also

IAgInfiniiVision5FFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision5FFT
C#
public interface IAgInfiniiVision5FFT
Visual C++
__interface IAgInfiniiVision5FFT

Properties

 | Name | Description
Public property | AverageCount | Sets and gets the number of waveforms to be averaged together.
Public property | CenterFrequency | Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.
Public property | DisplayMode | Sets and gets the FFT waveform display modes.
Public property | Enabled | Enable or disable the display of the FFT function.
Public property | Offset | Sets and gets the FFT vertical value represented at center screen.
Public property | Range | Sets and gets the full-scale vertical axis for the FFT function.
Public property | Source | Sets and gets the source for the FFT function.
Public property | Span | Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.
Public property | StartFrequency | Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | StopFrequency | Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms for the FFT.
Top

Methods

 | Name | Description
Public method | Clear | Clears the number of evaluated waveforms.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Clears the number of evaluated waveforms.
Top


Properties

 | Name | Description
Public property | AverageCount | Sets and gets the number of waveforms to be averaged together.
Public property | CenterFrequency | Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.
Public property | DisplayMode | Sets and gets the FFT waveform display modes.
Public property | Enabled | Enable or disable the display of the FFT function.
Public property | Offset | Sets and gets the FFT vertical value represented at center screen.
Public property | Range | Sets and gets the full-scale vertical axis for the FFT function.
Public property | Source | Sets and gets the source for the FFT function.
Public property | Span | Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.
Public property | StartFrequency | Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | StopFrequency | Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms for the FFT.
Top


IAgInfiniiVision6 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision6 Interface
See Also

IAgInfiniiVision6 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision6
   Inherits IAgInfiniiVision5
C#
public interface IAgInfiniiVision6 : IAgInfiniiVision5
Visual C++
__interface IAgInfiniiVision6 : IAgInfiniiVision5

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface.
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface.
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface.
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface.
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface.
Top


IAgInfiniiVision7 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision7 Interface
See Also

IAgInfiniiVision7 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision7
   Inherits IAgInfiniiVision6
C#
public interface IAgInfiniiVision7 : IAgInfiniiVision6
Visual C++
__interface IAgInfiniiVision7 : IAgInfiniiVision6

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision6.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision6.)
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision6.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Trigger4 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision6.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision6.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision6.)
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision6.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Trigger4 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision6.)
Top


Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision.)
Public property | Acquisition2 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision3.)
Public property | Acquisition3 | Pointer to the IAgInfiniiVisionAcquisition interface (Inherited from IAgInfiniiVision4.)
Public property | AnalogBus | Pointer to the IAgInfiniiVision8AnalogBus interface.
Public property | Calibration | Pointer to the IAgInfiniiVisionCalibration interface. (Inherited from IAgInfiniiVision.)
Public property | Channels | Pointer to the IAgInfiniiVisionChannels interface. (Inherited from IAgInfiniiVision.)
Public property | ClockRecovery | Pointer to the IAgInfiniiVision4ClockRecovery interface. (Inherited from IAgInfiniiVision4.)
Public property | Counter | Pointer to the IAgInfiniiVision4Counter interface. (Inherited from IAgInfiniiVision4.)
Public property | Cursors | Pointer to the IAgInfiniiVisionCursors interface. (Inherited from IAgInfiniiVision.)
Public property | Cursors2 | Pointer to the IAgInfiniiVisionCursors2 interface. (Inherited from IAgInfiniiVision2.)
Public property | DigitalChannels | Pointer to the IAgInfiniiVisionDigitalChannels interface. (Inherited from IAgInfiniiVision.)
Public property | Display | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision.)
Public property | Display2 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision2.)
Public property | Display3 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision3.)
Public property | Display4 | Pointer to the IAgInfiniiVisionDisplay interface. (Inherited from IAgInfiniiVision5.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | DVM | Pointer to the IAgInfiniiVisionDVM interface. (Inherited from IAgInfiniiVision3.)
Public property | External | Pointer to the IAgInfiniiVisionExternal interface. (Inherited from IAgInfiniiVision.)
Public property | External2 | Pointer to the IAgInfiniiVisionExternal interface.
Public property | FFT | Pointer to the IAgInfiniiVision5FFT interface. (Inherited from IAgInfiniiVision5.)
Public property | FRA | Pointer to the IAgInfiniiVision8FRA interface.
Public property | Histogram | Pointer to the IAgInfiniiVision4Histogram interface. (Inherited from IAgInfiniiVision4.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Jitter | Pointer to the IAgInfiniiVision4Jitter interface. (Inherited from IAgInfiniiVision4.)
Public property | MaskTest | Pointer to the IAgInfiniiVisionMaskTest interface. Requires Limit Mask Test (Option MASK) license. (Inherited from IAgInfiniiVision.)
Public property | Math | Pointer to the IAgInfiniiVisionMath interface. (Inherited from IAgInfiniiVision.)
Public property | Math2 | Pointer to the IAgInfiniiVisionMath2 interface. (Inherited from IAgInfiniiVision2.)
Public property | MathFunctions | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision3.)
Public property | MathFunctions2 | Pointer to the IAgInfiniiVisionMathFunctions interface. (Inherited from IAgInfiniiVision4.)
Public property | Measurements | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision.)
Public property | Measurements2 | Pointer to the IAgInfiniiVisionMeasurements2 interface. (Inherited from IAgInfiniiVision2.)
Public property | Measurements3 | Pointer to the IAgInfiniiVisionMeasurements interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision.)
Public property | Memory2 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision4.)
Public property | Memory3 | Pointer to the IAgInfiniiVisionMemory interface. (Inherited from IAgInfiniiVision6.)
Public property | ReferenceLevel | Pointer to the IAgInfiniiVisionReferenceLevel interface (Inherited from IAgInfiniiVision.)
Public property | ReferenceWaveform | Pointer to the IAgInfiniiVisionReferenceWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Search | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision2.)
Public property | Search2 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision3.)
Public property | Search3 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision4.)
Public property | Search4 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision5.)
Public property | Search5 | Pointer to the IAgInfiniiVision2Search interface. (Inherited from IAgInfiniiVision6.)
Public property | SerialBuses | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision2.)
Public property | SerialBuses2 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision3.)
Public property | SerialBuses3 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision5.)
Public property | SerialBuses4 | Pointer to the IAgInfiniiVision2SerialBuses interface. (Inherited from IAgInfiniiVision6.)
Public property | Status | Pointer to the IAgInfiniiVisionStatus interface. (Inherited from IAgInfiniiVision.)
Public property | System | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision.)
Public property | System2 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision3.)
Public property | System3 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision4.)
Public property | System4 | Pointer to the IAgInfiniiVisionSystem interface. (Inherited from IAgInfiniiVision5.)
Public property | Timebase | Pointer to the IAgInfiniiVisionTimebase interface. (Inherited from IAgInfiniiVision.)
Public property | Trigger | Pointer to the IAgInfiniiVisionTrigger interface (Inherited from IAgInfiniiVision.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision2.)
Public property | Trigger3 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision3.)
Public property | Trigger4 | Pointer to the IAgInfiniiVisionTrigger2 interface (Inherited from IAgInfiniiVision7.)
Public property | Trigger5 | Pointer to the IAgInfiniiVisionTrigger2 interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Public property | Waveform | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision.)
Public property | Waveform2 | Pointer to the IAgInfiniiVisionWaveform interface. (Inherited from IAgInfiniiVision5.)
Public property | WaveformGenerator | Pointer to the IAgInfiniiVisionWaveformGenerator interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision.)
Public property | WaveformGenerator2 | Pointer to the IAgInfiniiVisionWaveformGenerator2 interface. Requires Waveform Generator (Option WAVEGEN) license. (Inherited from IAgInfiniiVision2.)
Public property | WaveGens | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision3.)
Public property | WaveGens2 | Pointer to the IAgInfiniiVisionWaveGens interface. (Inherited from IAgInfiniiVision6.)
Top


IAgInfiniiVision8AnalogBus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8AnalogBus Interface
See Also

IAgInfiniiVision8AnalogBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision8AnalogBus
C#
public interface IAgInfiniiVision8AnalogBus
Visual C++
__interface IAgInfiniiVision8AnalogBus

Properties

 | Name | Description
Public property | Enabled | It enables or disables the view of the selected bus.
Public property | Label | The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.
Top

Methods

 | Name | Description
Public method | Clear | Excludes all of the analog channels from the selected bus definition.
Public method | GetBit | Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.
Public method | GetBits | Returns the definition for the specified bus.
Public method | SetBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Public method | SetBits | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Excludes all of the analog channels from the selected bus definition.
Public method | GetBit | Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.
Public method | GetBits | Returns the definition for the specified bus.
Public method | SetBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Public method | SetBits | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Top


Properties

 | Name | Description
Public property | Enabled | It enables or disables the view of the selected bus.
Public property | Label | The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.
Top


IAgInfiniiVision8FRA Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVision8FRA Interface
See Also

IAgInfiniiVision8FRA interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVision8FRA
C#
public interface IAgInfiniiVision8FRA
Visual C++
__interface IAgInfiniiVision8FRA

Properties

 | Name | Description
Public property | Amplitude | The waveform generator amplitude in the frequency response analysis.
Public property | AmplitudeProfileState | Enables or disables the ability to specify amplitude ramping within different decades
Public property | Enabled | Enables or disables the Frequency Response Analysis (FRA) feature.
Public property | InputSource | The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.
Public property | OutputLoadImpedance | The current expected output load impedance
Public property | OutputSource | The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.
Public property | PointsPerDecade | The number of points per decade in the frequency response analysis.
Public property | StartFrequency | The frequency sweep start value.
Public property | StopFrequency | The frequency sweep stop value.
Public property | SweepMode | Select between the normal swept frequency response analysis or analysis at a single frequency
Top

Methods

 | Name | Description
Public method | FetchData | Fetch the frequency response analysis data.
Public method | GetAmplitudeProfile | Returns waveform generator amplitude in the frequency response analysis.
Public method | Run | Initiates the Frequency Response Analysis.
Public method | SetAmplitudeProfile | Return the waveform generator's output sine wave amplitude.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | FetchData | Fetch the frequency response analysis data.
Public method | GetAmplitudeProfile | Returns waveform generator amplitude in the frequency response analysis.
Public method | Run | Initiates the Frequency Response Analysis.
Public method | SetAmplitudeProfile | Return the waveform generator's output sine wave amplitude.
Top


Properties

 | Name | Description
Public property | Amplitude | The waveform generator amplitude in the frequency response analysis.
Public property | AmplitudeProfileState | Enables or disables the ability to specify amplitude ramping within different decades
Public property | Enabled | Enables or disables the Frequency Response Analysis (FRA) feature.
Public property | InputSource | The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.
Public property | OutputLoadImpedance | The current expected output load impedance
Public property | OutputSource | The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.
Public property | PointsPerDecade | The number of points per decade in the frequency response analysis.
Public property | StartFrequency | The frequency sweep start value.
Public property | StopFrequency | The frequency sweep stop value.
Public property | SweepMode | Select between the normal swept frequency response analysis or analysis at a single frequency
Top


IAgInfiniiVisionAcquisition Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition Interface
See Also

IVI Scope class-compliant acquisition interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionAcquisition
C#
public interface IAgInfiniiVisionAcquisition
Visual C++
__interface IAgInfiniiVisionAcquisition

Properties

 | Name | Description
Public property | Interpolation | The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record.
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel.
Public property | RecordLength | Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property."
Public property | SampleMode | Read Only - Gets the current acquisition sample mode setting.
Public property | SampleRate | Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable.
Public property | SegmentedMemory | Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | Type of acquisition data oscilloscope uses to fill the waveform record.
Top

Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Public method | SingleAcquisition | Acquires a single trigger of data.
Public method | Stop | Stops the acquisition.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Public method | SingleAcquisition | Acquires a single trigger of data.
Public method | Stop | Stops the acquisition.
Top


Properties

 | Name | Description
Public property | Interpolation | The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record.
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel.
Public property | RecordLength | Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property."
Public property | SampleMode | Read Only - Gets the current acquisition sample mode setting.
Public property | SampleRate | Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable.
Public property | SegmentedMemory | Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | Type of acquisition data oscilloscope uses to fill the waveform record.
Top


IAgInfiniiVisionAcquisition2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition2 Interface
See Also

IAgInfiniiVisionAcquisition2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionAcquisition2
   Inherits IAgInfiniiVisionAcquisition
C#
public interface IAgInfiniiVisionAcquisition2 : IAgInfiniiVisionAcquisition
Visual C++
__interface IAgInfiniiVisionAcquisition2 : IAgInfiniiVisionAcquisition

Properties

 | Name | Description
Public property | Interpolation | The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | RecordLength | Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property." (Inherited from IAgInfiniiVisionAcquisition.)
Public property | ReferenceSignal | Selects the 10 MHz Reference Signal Mode.
Public property | SampleMode | Read Only - Gets the current acquisition sample mode setting. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SampleRate | Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SegmentedMemory | Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required (Inherited from IAgInfiniiVisionAcquisition.)
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | TimePerRecord | The time in seconds that corresponds to the record length. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | Type | Type of acquisition data oscilloscope uses to fill the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Top

Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | SingleAcquisition | Acquires a single trigger of data. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | Stop | Stops the acquisition. (Inherited from IAgInfiniiVisionAcquisition.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Interpolation | The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | RecordLength | Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property." (Inherited from IAgInfiniiVisionAcquisition.)
Public property | ReferenceSignal | Selects the 10 MHz Reference Signal Mode.
Public property | SampleMode | Read Only - Gets the current acquisition sample mode setting. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SampleRate | Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SegmentedMemory | Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required (Inherited from IAgInfiniiVisionAcquisition.)
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | TimePerRecord | The time in seconds that corresponds to the record length. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | Type | Type of acquisition data oscilloscope uses to fill the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Top


IAgInfiniiVisionAcquisition3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisition3 Interface
See Also

IAgInfiniiVisionAcquisition3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionAcquisition3
   Inherits IAgInfiniiVisionAcquisition2
C#
public interface IAgInfiniiVisionAcquisition3 : IAgInfiniiVisionAcquisition2
Visual C++
__interface IAgInfiniiVisionAcquisition3 : IAgInfiniiVisionAcquisition2

Properties

 | Name | Description
Public property | Interpolation | The Oscilloscope uses the interpolation method when it cannot resolve a voltage for every point in the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | RecordLength | Read Only - The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the NumberOfPointsMin property." (Inherited from IAgInfiniiVisionAcquisition.)
Public property | ReferenceSignal | Selects the 10 MHz Reference Signal Mode. (Inherited from IAgInfiniiVisionAcquisition2.)
Public property | SampleMode | Read Only - Gets the current acquisition sample mode setting. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SampleRate | Read Only - Gets the current oscilloscope acquisition sample rate in samples/sec. The sample rate is not directly controllable. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | SegmentedMemory | Pointer to the IAgInfiniiVisionSegmentedMemory interface. Segmented memory option (Option SGM)license is required (Inherited from IAgInfiniiVisionAcquisition.)
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. The units are seconds. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | TimePerRecord | The time in seconds that corresponds to the record length. (Inherited from IAgInfiniiVisionAcquisition.)
Public property | Type | Type of acquisition data oscilloscope uses to fill the waveform record. (Inherited from IAgInfiniiVisionAcquisition.)
Top

Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | SetSampleMode | Sets the acquisition mode of the oscilloscope.
Public method | SingleAcquisition | Acquires a single trigger of data. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | Stop | Stops the acquisition. (Inherited from IAgInfiniiVisionAcquisition.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | SetSampleMode | Sets the acquisition mode of the oscilloscope.
Public method | SingleAcquisition | Acquires a single trigger of data. (Inherited from IAgInfiniiVisionAcquisition.)
Public method | Stop | Stops the acquisition. (Inherited from IAgInfiniiVisionAcquisition.)
Top


IAgInfiniiVisionAcquisitionSegmentedMemory Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionAcquisitionSegmentedMemory Interface
See Also

IAgInfiniiVisionSegmentedMemory interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionAcquisitionSegmentedMemory
C#
public interface IAgInfiniiVisionAcquisitionSegmentedMemory
Visual C++
__interface IAgInfiniiVisionAcquisitionSegmentedMemory

Properties

 | Name | Description
Public property | Count | The number of memory segments to acquire.
Public property | Index | The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).
Public property | SaveOption | The segments to be included when the waveform is saved.
Public property | TimeTag | Read Only - Returns the time tag of the currently selected segmented memory index.
Top

Methods

 | Name | Description
Public method | Analyze | Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Analyze | Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.
Top


Properties

 | Name | Description
Public property | Count | The number of memory segments to acquire.
Public property | Index | The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).
Public property | SaveOption | The segments to be included when the waveform is saved.
Public property | TimeTag | Read Only - Returns the time tag of the currently selected segmented memory index.
Top


IAgInfiniiVisionCalibration Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCalibration Interface
See Also

IAgInfiniiVisionCalibration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionCalibration
C#
public interface IAgInfiniiVisionCalibration
Visual C++
__interface IAgInfiniiVisionCalibration

Properties

 | Name | Description
Public property | Date | Read Only - Gets the date of the last calibration.
Public property | Enabled | Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.
Public property | Label | Calibration string(up to 32 characters not including the quotes).
Public property | SignalSource | Signal on the rear panel trigger out BNC.
Public property | Temperature | Read Only - Change in temperature since the last user calibration procedure.
Public property | Time | Read Only - Time of the last calibration.
Top

Methods

 | Name | Description
Public method | Calibrate | Starts the user calibration procedure. See the User's Guide for details.
Public method | Result | Read Only- Summary results of the last user calibration procedure.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Calibrate | Starts the user calibration procedure. See the User's Guide for details.
Public method | Result | Read Only- Summary results of the last user calibration procedure.
Top


Properties

 | Name | Description
Public property | Date | Read Only - Gets the date of the last calibration.
Public property | Enabled | Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.
Public property | Label | Calibration string(up to 32 characters not including the quotes).
Public property | SignalSource | Signal on the rear panel trigger out BNC.
Public property | Temperature | Read Only - Change in temperature since the last user calibration procedure.
Public property | Time | Read Only - Time of the last calibration.
Top


IAgInfiniiVisionChannel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannel Interface
See Also

IAgInfiniiVisionChannel Interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionChannel
C#
public interface IAgInfiniiVisionChannel
Visual C++
__interface IAgInfiniiVisionChannel

Properties

 | Name | Description
Public property | Coupling | Coupling of the input signal.
Public property | Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Public property | InputFrequencyMax | The maximum input frequency of the channel. It is the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Public property | InputImpedance | The input impedance of the channel. The units are ohms.
Public property | Invert | Inverts the input signal for the specified channel.
Public property | Label | The analog channel label.
Public property | Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Public property | ProbeSense | Read Only - The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | ProbeSkew | Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.
Public property | Protection | Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).
Public property | Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Public property | Scale | Vertical scale, or units per division, of the selected channel.
Public property | Units | Measurement units for the connected probe.
Top

Methods

 | Name | Description
Public method | ClearProtection | Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.
Public method | Configure | Configures the range, offset, coupling, probe attenuation, and channel enabled state of the oscilloscope.
Public method | ConfigureCharacteristics | Configures the input impedance and the maximum frequency of the input signal which control the electrical characteristics of the channel.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ClearProtection | Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.
Public method | Configure | Configures the range, offset, coupling, probe attenuation, and channel enabled state of the oscilloscope.
Public method | ConfigureCharacteristics | Configures the input impedance and the maximum frequency of the input signal which control the electrical characteristics of the channel.
Top


Properties

 | Name | Description
Public property | Coupling | Coupling of the input signal.
Public property | Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Public property | InputFrequencyMax | The maximum input frequency of the channel. It is the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Public property | InputImpedance | The input impedance of the channel. The units are ohms.
Public property | Invert | Inverts the input signal for the specified channel.
Public property | Label | The analog channel label.
Public property | Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Public property | ProbeSense | Read Only - The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | ProbeSkew | Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.
Public property | Protection | Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).
Public property | Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Public property | Scale | Vertical scale, or units per division, of the selected channel.
Public property | Units | Measurement units for the connected probe.
Top


IAgInfiniiVisionChannels Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionChannels Interface
See Also

IAgInfiniiVisionChannels Interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionChannels
C#
public interface IAgInfiniiVisionChannels
Visual C++
__interface IAgInfiniiVisionChannels

Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of Channels.
Public property | Item | Pointer to the IAgInfiniiVisionChannel interface.
Public property | Name | Read Only - Returns the Channel name for a given index.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of Channels.
Public property | Item | Pointer to the IAgInfiniiVisionChannel interface.
Public property | Name | Read Only - Returns the Channel name for a given index.
Top


IAgInfiniiVisionCursors Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors Interface
See Also

IAgInfiniiVisionCursors interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionCursors
C#
public interface IAgInfiniiVisionCursors
Visual C++
__interface IAgInfiniiVisionCursors

Properties

 | Name | Description
Public property | Mode | The cursors mode.
Public property | X1Position | Specifies the X1 cursor position.
Public property | X1Y1Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Public property | X2Position | Specifies the X2 cursor position.
Public property | X2Y2Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Public property | XDelta | Read Only - The value difference between the current X1 and X2 cursor positions.
Public property | Y1Position | Specifies the Y1 cursor position.
Public property | Y2Position | Specifies the Y2 cursor position.
Public property | YDelta | Read Only - The value difference between the current Y1 and Y2 cursor positions.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Mode | The cursors mode.
Public property | X1Position | Specifies the X1 cursor position.
Public property | X1Y1Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Public property | X2Position | Specifies the X2 cursor position.
Public property | X2Y2Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Public property | XDelta | Read Only - The value difference between the current X1 and X2 cursor positions.
Public property | Y1Position | Specifies the Y1 cursor position.
Public property | Y2Position | Specifies the Y2 cursor position.
Public property | YDelta | Read Only - The value difference between the current Y1 and Y2 cursor positions.
Top


IAgInfiniiVisionCursors2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionCursors2 Interface
See Also

IAgInfiniiVisionCursors2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionCursors2
   Inherits IAgInfiniiVisionCursors
C#
public interface IAgInfiniiVisionCursors2 : IAgInfiniiVisionCursors
Visual C++
__interface IAgInfiniiVisionCursors2 : IAgInfiniiVisionCursors

Properties

 | Name | Description
Public property | Mode | The cursors mode. (Inherited from IAgInfiniiVisionCursors.)
Public property | X1Position | Specifies the X1 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | X1Y1Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed. (Inherited from IAgInfiniiVisionCursors.)
Public property | X2Position | Specifies the X2 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | X2Y2Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed. (Inherited from IAgInfiniiVisionCursors.)
Public property | XDelta | Read Only - The value difference between the current X1 and X2 cursor positions. (Inherited from IAgInfiniiVisionCursors.)
Public property | XUnits | The X cursors units.
Public property | Y1Position | Specifies the Y1 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | Y2Position | Specifies the Y2 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | YDelta | Read Only - The value difference between the current Y1 and Y2 cursor positions. (Inherited from IAgInfiniiVisionCursors.)
Public property | YUnits | The Y cursors units.
Top

Methods

 | Name | Description
Public method | UseCursorPosition | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | UseCursorPosition | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
Top


Properties

 | Name | Description
Public property | Mode | The cursors mode. (Inherited from IAgInfiniiVisionCursors.)
Public property | X1Position | Specifies the X1 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | X1Y1Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed. (Inherited from IAgInfiniiVisionCursors.)
Public property | X2Position | Specifies the X2 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | X2Y2Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed. (Inherited from IAgInfiniiVisionCursors.)
Public property | XDelta | Read Only - The value difference between the current X1 and X2 cursor positions. (Inherited from IAgInfiniiVisionCursors.)
Public property | XUnits | The X cursors units.
Public property | Y1Position | Specifies the Y1 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | Y2Position | Specifies the Y2 cursor position. (Inherited from IAgInfiniiVisionCursors.)
Public property | YDelta | Read Only - The value difference between the current Y1 and Y2 cursor positions. (Inherited from IAgInfiniiVisionCursors.)
Public property | YUnits | The Y cursors units.
Top


IAgInfiniiVisionDigitalChannel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannel Interface
See Also

IAgInfiniiVisionDigitalChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDigitalChannel
C#
public interface IAgInfiniiVisionDigitalChannel
Visual C++
__interface IAgInfiniiVisionDigitalChannel

Properties

 | Name | Description
Public property | Enabled | Enables/Disables the specified digital channel.
Public property | Label | Enables/Disables analog and digital channel labels.
Public property | Position | The position of the specified channel.
Public property | Size | Size of digital channels on the display.
Public property | Threshold | Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).
Top

Methods

 | Name | Description
Public method | FetchDigitalWaveform | Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.
Public method | ReadDigitalWaveform | Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | FetchDigitalWaveform | Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.
Public method | ReadDigitalWaveform | Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.
Top


Properties

 | Name | Description
Public property | Enabled | Enables/Disables the specified digital channel.
Public property | Label | Enables/Disables analog and digital channel labels.
Public property | Position | The position of the specified channel.
Public property | Size | Size of digital channels on the display.
Public property | Threshold | Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).
Top


IAgInfiniiVisionDigitalChannels Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannels Interface
See Also

IAgInfiniiVisionDigitalChannels interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDigitalChannels
C#
public interface IAgInfiniiVisionDigitalChannels
Visual C++
__interface IAgInfiniiVisionDigitalChannels

Properties

 | Name | Description
Public property | Bus | Pointer to the IAgInfiniiVisionDigitalChannelsBus interface.
Public property | Count | Read Only - Returns the number of digitalchannels.
Public property | Item | Pointer to the IAgInfiniiVisionDigitalChannel interface.
Public property | Name | Read Only - Returns the digitalchannel name for a given index.
Top

Methods

 | Name | Description
Public method | ReadActivity | Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.
Public method | ResetActivity | Clears the logic activity registers of the oscilloscope.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ReadActivity | Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.
Public method | ResetActivity | Clears the logic activity registers of the oscilloscope.
Top


Properties

 | Name | Description
Public property | Bus | Pointer to the IAgInfiniiVisionDigitalChannelsBus interface.
Public property | Count | Read Only - Returns the number of digitalchannels.
Public property | Item | Pointer to the IAgInfiniiVisionDigitalChannel interface.
Public property | Name | Read Only - Returns the digitalchannel name for a given index.
Top


IAgInfiniiVisionDigitalChannelsBus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDigitalChannelsBus Interface
See Also

IAgInfiniiVisionDigitalChannelsBus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDigitalChannelsBus
C#
public interface IAgInfiniiVisionDigitalChannelsBus
Visual C++
__interface IAgInfiniiVisionDigitalChannelsBus

Methods

 | Name | Description
Public method | Clear | Excludes all of the digital channels from the selected bus definition.
Public method | Enable | Display the selected bus.
Public method | GetChannelBit | Returns the definition for the specified bus.
Public method | GetLabel | Returns the label of the specified bus.
Public method | GetMaskBit | Returns the mask value for the specified bus.
Public method | IsDigitalBitEnabled | Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.
Public method | IsEnabled | Returns the flag indicating whether the specified bus is enabled or disabled.
Public method | SetChannelBit | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Public method | SetDigitalBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Public method | SetLabel | The bus label.
Public method | SetMaskBit | Bits to be included and excluded in the selected bus according to the mask.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Excludes all of the digital channels from the selected bus definition.
Public method | Enable | Display the selected bus.
Public method | GetChannelBit | Returns the definition for the specified bus.
Public method | GetLabel | Returns the label of the specified bus.
Public method | GetMaskBit | Returns the mask value for the specified bus.
Public method | IsDigitalBitEnabled | Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.
Public method | IsEnabled | Returns the flag indicating whether the specified bus is enabled or disabled.
Public method | SetChannelBit | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Public method | SetDigitalBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Public method | SetLabel | The bus label.
Public method | SetMaskBit | Bits to be included and excluded in the selected bus according to the mask.
Top


IAgInfiniiVisionDisplay Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay Interface
See Also

IAgInfiniiVisionDisplay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay
C#
public interface IAgInfiniiVisionDisplay
Visual C++
__interface IAgInfiniiVisionDisplay

Properties

 | Name | Description
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels.
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display.
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen.
Top

Methods

 | Name | Description
Public method | Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.
Public method | GetScreenBitmap | Reads screen image data
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.
Public method | GetScreenBitmap | Reads screen image data
Top


Properties

 | Name | Description
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels.
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display.
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen.
Top


IAgInfiniiVisionDisplay2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay2 Interface
See Also

IAgInfiniiVisionDisplay2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay2
   Inherits IAgInfiniiVisionDisplay
C#
public interface IAgInfiniiVisionDisplay2 : IAgInfiniiVisionDisplay
Visual C++
__interface IAgInfiniiVisionDisplay2 : IAgInfiniiVisionDisplay

Properties

 | Name | Description
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not.
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top

Methods

 | Name | Description
Public method | Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased. (Inherited from IAgInfiniiVisionDisplay.)
Public method | GetScreenBitmap | Reads screen image data (Inherited from IAgInfiniiVisionDisplay.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not.
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top


IAgInfiniiVisionDisplay3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3 Interface
See Also

IAgInfiniiVisionDisplay3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay3
   Inherits IAgInfiniiVisionDisplay2
C#
public interface IAgInfiniiVisionDisplay3 : IAgInfiniiVisionDisplay2
Visual C++
__interface IAgInfiniiVisionDisplay3 : IAgInfiniiVisionDisplay2

Properties

 | Name | Description
Public property | Annotation | Pointer to the IAgInfiniiVisionDisplay3Annotation interface.
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not. (Inherited from IAgInfiniiVisionDisplay2.)
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Sidebar | Write Only. Specifies the sidebar dialog to display on the screen.
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top

Methods

 | Name | Description
Public method | Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased. (Inherited from IAgInfiniiVisionDisplay.)
Public method | GetScreenBitmap | Reads screen image data (Inherited from IAgInfiniiVisionDisplay.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Annotation | Pointer to the IAgInfiniiVisionDisplay3Annotation interface.
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not. (Inherited from IAgInfiniiVisionDisplay2.)
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Sidebar | Write Only. Specifies the sidebar dialog to display on the screen.
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top


IAgInfiniiVisionDisplay3Annotation Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay3Annotation Interface
See Also

IAgInfiniiVisionDisplay3Annotation interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay3Annotation
C#
public interface IAgInfiniiVisionDisplay3Annotation
Visual C++
__interface IAgInfiniiVisionDisplay3Annotation

Properties

 | Name | Description
Public property | Background | Specifies the background of the annotation.
Public property | Color | Specifies the annotation color.
Public property | Enabled | Enables or disables the annotation.
Public property | Text | Specifies the annotation string.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Background | Specifies the background of the annotation.
Public property | Color | Specifies the annotation color.
Public property | Enabled | Enables or disables the annotation.
Public property | Text | Specifies the annotation string.
Top


IAgInfiniiVisionDisplay4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4 Interface
See Also

IAgInfiniiVisionDisplay4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay4
   Inherits IAgInfiniiVisionDisplay3
C#
public interface IAgInfiniiVisionDisplay4 : IAgInfiniiVisionDisplay3
Visual C++
__interface IAgInfiniiVisionDisplay4 : IAgInfiniiVisionDisplay3

Properties

 | Name | Description
Public property | Annotation | Pointer to the IAgInfiniiVisionDisplay3Annotation interface. (Inherited from IAgInfiniiVisionDisplay3.)
Public property | Annotation2 | Pointer to the IAgInfiniiVisionDisplay3Annotation interface.
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not. (Inherited from IAgInfiniiVisionDisplay2.)
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Sidebar | Write Only. Specifies the sidebar dialog to display on the screen. (Inherited from IAgInfiniiVisionDisplay3.)
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top

Methods

 | Name | Description
Public method | Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased. (Inherited from IAgInfiniiVisionDisplay.)
Public method | GetScreenBitmap | Reads screen image data (Inherited from IAgInfiniiVisionDisplay.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Annotation | Pointer to the IAgInfiniiVisionDisplay3Annotation interface. (Inherited from IAgInfiniiVisionDisplay3.)
Public property | Annotation2 | Pointer to the IAgInfiniiVisionDisplay3Annotation interface.
Public property | InvertColorEnabled | Specifies whether the graticule colors are inverted or not. (Inherited from IAgInfiniiVisionDisplay2.)
Public property | LabelEnabled | Enable/Disables the analog and digital channel labels. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display. (Inherited from IAgInfiniiVisionDisplay.)
Public property | PersistenceTime | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0. (Inherited from IAgInfiniiVisionDisplay.)
Public property | Sidebar | Write Only. Specifies the sidebar dialog to display on the screen. (Inherited from IAgInfiniiVisionDisplay3.)
Public property | VectorEnabled | Enables or disables the lines drawn between acquired data points on the screen. (Inherited from IAgInfiniiVisionDisplay.)
Top


IAgInfiniiVisionDisplay4Annotation2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDisplay4Annotation2 Interface
See Also

IAgInfiniiVisionDisplay4Annotation2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDisplay4Annotation2
   Inherits IAgInfiniiVisionDisplay3Annotation
C#
public interface IAgInfiniiVisionDisplay4Annotation2 : IAgInfiniiVisionDisplay3Annotation
Visual C++
__interface IAgInfiniiVisionDisplay4Annotation2 : IAgInfiniiVisionDisplay3Annotation

Properties

 | Name | Description
Public property | Background | Specifies the background of the annotation. (Inherited from IAgInfiniiVisionDisplay3Annotation.)
Public property | Color | Specifies the annotation color. (Inherited from IAgInfiniiVisionDisplay3Annotation.)
Public property | Enabled | Enables or disables the annotation. (Inherited from IAgInfiniiVisionDisplay3Annotation.)
Public property | Text | Specifies the annotation string. (Inherited from IAgInfiniiVisionDisplay3Annotation.)
Top

Methods

 | Name | Description
Public method | GetBackground | Gets the background of the annotation.
Public method | GetColor | Gets the annotation color.
Public method | GetEnabled | Get the state of annotation.
Public method | GetText | Gets the annotation string.
Public method | GetX1Position | Gets the annotation's horizontal X1 position.
Public method | GetY1Position | Gets the annotation's vertical Y1 position.
Public method | SetBackground | Sets the background of the annotation.
Public method | SetColor | Sets the annotation color.
Public method | SetEnabled | Enable or disable the annotation.
Public method | SetText | Sets the annotation string.
Public method | SetX1Position | Sets the annotation's horizontal X1 position.
Public method | SetY1Position | Sets the annotation's vertical Y1 position.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetBackground | Gets the background of the annotation.
Public method | GetColor | Gets the annotation color.
Public method | GetEnabled | Get the state of annotation.
Public method | GetText | Gets the annotation string.
Public method | GetX1Position | Gets the annotation's horizontal X1 position.
Public method | GetY1Position | Gets the annotation's vertical Y1 position.
Public method | SetBackground | Sets the background of the annotation.
Public method | SetColor | Sets the annotation color.
Public method | SetEnabled | Enable or disable the annotation.
Public method | SetText | Sets the annotation string.
Public method | SetX1Position | Sets the annotation's horizontal X1 position.
Public method | SetY1Position | Sets the annotation's vertical Y1 position.
Top


IAgInfiniiVisionDVM Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionDVM Interface
See Also

IAgInfiniiVisionDVM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionDVM
C#
public interface IAgInfiniiVisionDVM
Visual C++
__interface IAgInfiniiVisionDVM

Properties

 | Name | Description
Public property | AutoRangeEnabled | Enables or disables the Digital Voltmeter's Auto Range capability.
Public property | Current | Read Only - Returns the displayed 3-digit DVM value based on the current mode.
Public property | Enabled | Enables or disables the Digital Voltmeter (DVM) analysis feature.
Public property | Frequency | Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.
Public property | Mode | Specifies the digital voltmeter (DVM) mode.
Public property | Source | Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AutoRangeEnabled | Enables or disables the Digital Voltmeter's Auto Range capability.
Public property | Current | Read Only - Returns the displayed 3-digit DVM value based on the current mode.
Public property | Enabled | Enables or disables the Digital Voltmeter (DVM) analysis feature.
Public property | Frequency | Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.
Public property | Mode | Specifies the digital voltmeter (DVM) mode.
Public property | Source | Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.
Top


IAgInfiniiVisionExternal Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal Interface
See Also

IAgInfiniiVisionExternal interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionExternal
C#
public interface IAgInfiniiVisionExternal
Visual C++
__interface IAgInfiniiVisionExternal

Properties

 | Name | Description
Public property | ProbeAttenuation | Scaling factor by which the probe attached to the external trigger attenuates the input.
Public property | ProbeSense | Read Only - Probe attenuation value that the oscilloscope automatically senses.
Public property | Range | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.
Public property | Units | The measurement units for the probe connected to the external trigger input.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ProbeAttenuation | Scaling factor by which the probe attached to the external trigger attenuates the input.
Public property | ProbeSense | Read Only - Probe attenuation value that the oscilloscope automatically senses.
Public property | Range | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.
Public property | Units | The measurement units for the probe connected to the external trigger input.
Top


IAgInfiniiVisionExternal2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionExternal2 Interface
See Also

IAgInfiniiVisionExternal2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionExternal2
   Inherits IAgInfiniiVisionExternal
C#
public interface IAgInfiniiVisionExternal2 : IAgInfiniiVisionExternal
Visual C++
__interface IAgInfiniiVisionExternal2 : IAgInfiniiVisionExternal

Properties

 | Name | Description
Public property | Enabled | Enables or disables the external trigger input display.
Public property | Label | The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).
Public property | ProbeAttenuation | Scaling factor by which the probe attached to the external trigger attenuates the input. (Inherited from IAgInfiniiVisionExternal.)
Public property | ProbeSense | Read Only - Probe attenuation value that the oscilloscope automatically senses. (Inherited from IAgInfiniiVisionExternal.)
Public property | Range | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor. (Inherited from IAgInfiniiVisionExternal.)
Public property | Threshold | The external trigger input threshold (trigger) voltage level in volts.
Public property | Units | The measurement units for the probe connected to the external trigger input. (Inherited from IAgInfiniiVisionExternal.)
Public property | VerticalPosition | The external trigger input waveform's vertical position on the oscilloscope display.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Enabled | Enables or disables the external trigger input display.
Public property | Label | The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).
Public property | ProbeAttenuation | Scaling factor by which the probe attached to the external trigger attenuates the input. (Inherited from IAgInfiniiVisionExternal.)
Public property | ProbeSense | Read Only - Probe attenuation value that the oscilloscope automatically senses. (Inherited from IAgInfiniiVisionExternal.)
Public property | Range | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor. (Inherited from IAgInfiniiVisionExternal.)
Public property | Threshold | The external trigger input threshold (trigger) voltage level in volts.
Public property | Units | The measurement units for the probe connected to the external trigger input. (Inherited from IAgInfiniiVisionExternal.)
Public property | VerticalPosition | The external trigger input waveform's vertical position on the oscilloscope display.
Top


IAgInfiniiVisionMaskTest Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTest Interface
See Also

IAgInfiniiVisionMaskTest interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMaskTest
C#
public interface IAgInfiniiVisionMaskTest
Visual C++
__interface IAgInfiniiVisionMaskTest

Properties

 | Name | Description
Public property | AllChannelEnabled | Enables all analog channels to be included in the mask test or only selected channels.
Public property | AutoMaskUnits | Measurement units for automask which interprets the tolerance parameters for automasking.
Public property | BindControlEnabled | Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.
Public property | Configuration | Pointer to the IAgInfiniiVisionMaskTestConfiguration interface.
Public property | ElapsedTime | Read Only - Elapsed time (in seconds) in the current mask test run.
Public property | Enabled | Enables/Disables the mask test features.
Public property | FailedWaveformCount | Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.
Public property | HorizontalTolerance | Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.
Public property | LockEnabled | Enables/Disables the mask lock.
Public property | Markers | Pointer to the IAgInfiniiVisionMaskTestMarkers interface.
Public property | PrintFailuresEnabled | Enables/Disables printing on mask failure.
Public property | SaveFailuresEnabled | Enables/Disables saving on mask failure.
Public property | Title | Read Only - Returns the mask title which is a string of up to 128 characters
Public property | VerticalTolerance | The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.
Public property | WaveformCount | Read Only - The total number of waveforms acquired in the current mask test run.
Top

Methods

 | Name | Description
Public method | AutoMask | Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.
Public method | Delete | Deletes the currently loaded mask.
Public method | Reset | Resets the mask statistics.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | AutoMask | Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.
Public method | Delete | Deletes the currently loaded mask.
Public method | Reset | Resets the mask statistics.
Top


Properties

 | Name | Description
Public property | AllChannelEnabled | Enables all analog channels to be included in the mask test or only selected channels.
Public property | AutoMaskUnits | Measurement units for automask which interprets the tolerance parameters for automasking.
Public property | BindControlEnabled | Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.
Public property | Configuration | Pointer to the IAgInfiniiVisionMaskTestConfiguration interface.
Public property | ElapsedTime | Read Only - Elapsed time (in seconds) in the current mask test run.
Public property | Enabled | Enables/Disables the mask test features.
Public property | FailedWaveformCount | Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.
Public property | HorizontalTolerance | Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.
Public property | LockEnabled | Enables/Disables the mask lock.
Public property | Markers | Pointer to the IAgInfiniiVisionMaskTestMarkers interface.
Public property | PrintFailuresEnabled | Enables/Disables printing on mask failure.
Public property | SaveFailuresEnabled | Enables/Disables saving on mask failure.
Public property | Title | Read Only - Returns the mask title which is a string of up to 128 characters
Public property | VerticalTolerance | The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.
Public property | WaveformCount | Read Only - The total number of waveforms acquired in the current mask test run.
Top


IAgInfiniiVisionMaskTestConfiguration Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestConfiguration Interface
See Also

IAgInfiniiVisionMaskTestConfiguration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMaskTestConfiguration
C#
public interface IAgInfiniiVisionMaskTestConfiguration
Visual C++
__interface IAgInfiniiVisionMaskTestConfiguration

Properties

 | Name | Description
Public property | MeasurementEnabled | Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings
Public property | SigmaLevel | Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.
Public property | Source | The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.
Public property | TerminationCondition | The termination conditions for the mask test.
Public property | TerminationEnabled | Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.
Public property | Time | The number of seconds for a mask test to run. Permissible Range is 1 to 86400.
Public property | Waveform | The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | MeasurementEnabled | Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings
Public property | SigmaLevel | Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.
Public property | Source | The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.
Public property | TerminationCondition | The termination conditions for the mask test.
Public property | TerminationEnabled | Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.
Public property | Time | The number of seconds for a mask test to run. Permissible Range is 1 to 86400.
Public property | Waveform | The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.
Top


IAgInfiniiVisionMaskTestMarkers Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMaskTestMarkers Interface
See Also

IAgInfiniiVisionMaskTestMarkers interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMaskTestMarkers
C#
public interface IAgInfiniiVisionMaskTestMarkers
Visual C++
__interface IAgInfiniiVisionMaskTestMarkers

Properties

 | Name | Description
Public property | X1Coordinate | The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.
Public property | XDelta | The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.
Public property | Y1Coordinate | Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.
Public property | Y2Coordinate | Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | X1Coordinate | The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.
Public property | XDelta | The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.
Public property | Y1Coordinate | Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.
Public property | Y2Coordinate | Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.
Top


IAgInfiniiVisionMath Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath Interface
See Also

IAgInfiniiVisionMath interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath
C#
public interface IAgInfiniiVisionMath
Visual C++
__interface IAgInfiniiVisionMath

Properties

 | Name | Description
Public property | Enabled | Enables/Disables the math function.
Public property | FFT | Pointer to the IAgInfiniiVisionMathFFT interface.
Public property | InternalOperation | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.
Public property | InternalSource1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Public property | InternalSource2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function.
Public property | Operation | Waveform math operation
Public property | Range | Range of Full-scale vertical axis for the selected function.
Public property | Source1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.
Public property | Source2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>
Public property | VerticalScale | Vertical scale, or units per division, of the selected function.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Enabled | Enables/Disables the math function.
Public property | FFT | Pointer to the IAgInfiniiVisionMathFFT interface.
Public property | InternalOperation | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.
Public property | InternalSource1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Public property | InternalSource2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function.
Public property | Operation | Waveform math operation
Public property | Range | Range of Full-scale vertical axis for the selected function.
Public property | Source1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.
Public property | Source2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>
Public property | VerticalScale | Vertical scale, or units per division, of the selected function.
Top


IAgInfiniiVisionMath2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2 Interface
See Also

IAgInfiniiVisionMath2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2
   Inherits IAgInfiniiVisionMath
C#
public interface IAgInfiniiVisionMath2 : IAgInfiniiVisionMath
Visual C++
__interface IAgInfiniiVisionMath2 : IAgInfiniiVisionMath

Properties

 | Name | Description
Public property | Bus | Pointer to the IAgInfiniiVisionMath2Bus interface.
Public property | Enabled | Enables/Disables the math function. (Inherited from IAgInfiniiVisionMath.)
Public property | FFT | Pointer to the IAgInfiniiVisionMathFFT interface. (Inherited from IAgInfiniiVisionMath.)
Public property | FFT2 | Pointer to the IAgInfiniiVisionMath2FFT2 interface.
Public property | FilterFrequency | Pointer to the IAgInfiniiVisionMath2FilterFrequency interface.
Public property | Integrate | Pointer to the IAgInfiniiVisionMath2Integrate interface.
Public property | InternalOperation | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | InternalSource1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | InternalSource2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | Linear | Pointer to the IAgInfiniiVisionMath2Linear interface.
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMath2MeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function. (Inherited from IAgInfiniiVisionMath.)
Public property | Operation | Waveform math operation (Inherited from IAgInfiniiVisionMath.)
Public property | Range | Range of Full-scale vertical axis for the selected function. (Inherited from IAgInfiniiVisionMath.)
Public property | Source1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2. (Inherited from IAgInfiniiVisionMath.)
Public property | Source2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n> (Inherited from IAgInfiniiVisionMath.)
Public property | VerticalScale | Vertical scale, or units per division, of the selected function. (Inherited from IAgInfiniiVisionMath.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Bus | Pointer to the IAgInfiniiVisionMath2Bus interface.
Public property | Enabled | Enables/Disables the math function. (Inherited from IAgInfiniiVisionMath.)
Public property | FFT | Pointer to the IAgInfiniiVisionMathFFT interface. (Inherited from IAgInfiniiVisionMath.)
Public property | FFT2 | Pointer to the IAgInfiniiVisionMath2FFT2 interface.
Public property | FilterFrequency | Pointer to the IAgInfiniiVisionMath2FilterFrequency interface.
Public property | Integrate | Pointer to the IAgInfiniiVisionMath2Integrate interface.
Public property | InternalOperation | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | InternalSource1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | InternalSource2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions. (Inherited from IAgInfiniiVisionMath.)
Public property | Linear | Pointer to the IAgInfiniiVisionMath2Linear interface.
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMath2MeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function. (Inherited from IAgInfiniiVisionMath.)
Public property | Operation | Waveform math operation (Inherited from IAgInfiniiVisionMath.)
Public property | Range | Range of Full-scale vertical axis for the selected function. (Inherited from IAgInfiniiVisionMath.)
Public property | Source1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2. (Inherited from IAgInfiniiVisionMath.)
Public property | Source2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n> (Inherited from IAgInfiniiVisionMath.)
Public property | VerticalScale | Vertical scale, or units per division, of the selected function. (Inherited from IAgInfiniiVisionMath.)
Top


IAgInfiniiVisionMath2Bus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Bus Interface
See Also

IAgInfiniiVisionMath2Bus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2Bus
C#
public interface IAgInfiniiVisionMath2Bus
Visual C++
__interface IAgInfiniiVisionMath2Bus

Properties

 | Name | Description
Public property | ClockSource | Specifies the clock signal source for the Chart Logic Bus State operation.
Public property | Slope | Specifies the clock signal edge for the Chart Logic Bus State operation.
Public property | YIncrement | Specifies the value associated with each increment in Chart Logic Bus data.
Public property | YOrigin | Specifies the value associated with Chart Logic Bus data equal to zero.
Public property | YUnits | Specifies the vertical units for the Chart Logic Bus operations.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ClockSource | Specifies the clock signal source for the Chart Logic Bus State operation.
Public property | Slope | Specifies the clock signal edge for the Chart Logic Bus State operation.
Public property | YIncrement | Specifies the value associated with each increment in Chart Logic Bus data.
Public property | YOrigin | Specifies the value associated with Chart Logic Bus data equal to zero.
Public property | YUnits | Specifies the vertical units for the Chart Logic Bus operations.
Top


IAgInfiniiVisionMath2FilterFrequency Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2FilterFrequency Interface
See Also

IAgInfiniiVisionMath2FilterFrequency interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2FilterFrequency
C#
public interface IAgInfiniiVisionMath2FilterFrequency
Visual C++
__interface IAgInfiniiVisionMath2FilterFrequency

Properties

 | Name | Description
Public property | HighPassBandwidth | Specifies the high-pass filter's -3 dB cutoff frequency.
Public property | LowPassBandwidth | Specifies the low-pass filter's -3 dB cutoff frequency.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | HighPassBandwidth | Specifies the high-pass filter's -3 dB cutoff frequency.
Public property | LowPassBandwidth | Specifies the low-pass filter's -3 dB cutoff frequency.
Top


IAgInfiniiVisionMath2Integrate Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Integrate Interface
See Also

IAgInfiniiVisionMath2Integrate interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2Integrate
C#
public interface IAgInfiniiVisionMath2Integrate
Visual C++
__interface IAgInfiniiVisionMath2Integrate

Properties

 | Name | Description
Public property | InputOffset | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | InputOffset | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Top


IAgInfiniiVisionMath2Linear Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2Linear Interface
See Also

IAgInfiniiVisionMath2Linear interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2Linear
C#
public interface IAgInfiniiVisionMath2Linear
Visual C++
__interface IAgInfiniiVisionMath2Linear

Properties

 | Name | Description
Public property | Gain | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Public property | Offset | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Gain | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Public property | Offset | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Top


IAgInfiniiVisionMath2MeasurementTrend Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMath2MeasurementTrend Interface
See Also

IAgInfiniiVisionMath2MeasurementTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMath2MeasurementTrend
C#
public interface IAgInfiniiVisionMath2MeasurementTrend
Visual C++
__interface IAgInfiniiVisionMath2MeasurementTrend

Properties

 | Name | Description
Public property | Type | Specifies the measurement whose trend is shown in the math waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Type | Specifies the measurement whose trend is shown in the math waveform.
Top


IAgInfiniiVisionMathFFT Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT Interface
See Also

IAgInfiniiVisionMathFFT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFFT
C#
public interface IAgInfiniiVisionMathFFT
Visual C++
__interface IAgInfiniiVisionMathFFT

Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Public property | Span | Frequency span of the display when FFT is selected.
Public property | WindowType | Windowing transforms for the FFT.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Public property | Span | Frequency span of the display when FFT is selected.
Public property | WindowType | Windowing transforms for the FFT.
Top


IAgInfiniiVisionMathFFT2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFFT2 Interface
See Also

IAgInfiniiVisionMathFFT2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFFT2
   Inherits IAgInfiniiVisionMathFFT
C#
public interface IAgInfiniiVisionMathFFT2 : IAgInfiniiVisionMathFFT
Visual C++
__interface IAgInfiniiVisionMathFFT2 : IAgInfiniiVisionMathFFT

Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz. (Inherited from IAgInfiniiVisionMathFFT.)
Public property | Span | Frequency span of the display when FFT is selected. (Inherited from IAgInfiniiVisionMathFFT.)
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms for the FFT. (Inherited from IAgInfiniiVisionMathFFT.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz. (Inherited from IAgInfiniiVisionMathFFT.)
Public property | Span | Frequency span of the display when FFT is selected. (Inherited from IAgInfiniiVisionMathFFT.)
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms for the FFT. (Inherited from IAgInfiniiVisionMathFFT.)
Top


IAgInfiniiVisionMathFunction Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction Interface
See Also

IAgInfiniiVisionMathFunction interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunction
C#
public interface IAgInfiniiVisionMathFunction
Visual C++
__interface IAgInfiniiVisionMathFunction

Properties

 | Name | Description
Public property | Average | Pointer to the IAgInfiniiVisionMathFunctionAverage interface.
Public property | Bus | Pointer to the IAgInfiniiVisionMathFunctionBus interface.
Public property | Enabled | Enables/Disables the math function.
Public property | FFT | Pointer to the IAgInfiniiVisionMathFunctionFFT interface.
Public property | Filter | Pointer to the IAgInfiniiVisionMathFunctionFilter interface.
Public property | Integrate | Pointer to the IAgInfiniiVisionMathFunctionIntegrate interface.
Public property | Linear | Pointer to the IAgInfiniiVisionMathFunctionLinear interface.
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function.
Public property | Operation | Waveform math operation.
Public property | Range | Range of Full-scale vertical axis for the selected function.
Public property | Scale | Vertical scale, or units per division, of the selected function.
Public property | Source1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.
Public property | Source2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Average | Pointer to the IAgInfiniiVisionMathFunctionAverage interface.
Public property | Bus | Pointer to the IAgInfiniiVisionMathFunctionBus interface.
Public property | Enabled | Enables/Disables the math function.
Public property | FFT | Pointer to the IAgInfiniiVisionMathFunctionFFT interface.
Public property | Filter | Pointer to the IAgInfiniiVisionMathFunctionFilter interface.
Public property | Integrate | Pointer to the IAgInfiniiVisionMathFunctionIntegrate interface.
Public property | Linear | Pointer to the IAgInfiniiVisionMathFunctionLinear interface.
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function.
Public property | Operation | Waveform math operation.
Public property | Range | Range of Full-scale vertical axis for the selected function.
Public property | Scale | Vertical scale, or units per division, of the selected function.
Public property | Source1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.
Public property | Source2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).
Top


IAgInfiniiVisionMathFunction2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2 Interface
See Also

IAgInfiniiVisionMathFunction2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunction2
   Inherits IAgInfiniiVisionMathFunction
C#
public interface IAgInfiniiVisionMathFunction2 : IAgInfiniiVisionMathFunction
Visual C++
__interface IAgInfiniiVisionMathFunction2 : IAgInfiniiVisionMathFunction

Properties

 | Name | Description
Public property | Average | Pointer to the IAgInfiniiVisionMathFunctionAverage interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Bus | Pointer to the IAgInfiniiVisionMathFunctionBus interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Enabled | Enables/Disables the math function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | FFT | Pointer to the IAgInfiniiVisionMathFunctionFFT interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | FFT2 | Pointer to the IAgInfiniiVisionMathFunctionFFT interface.
Public property | Filter | Pointer to the IAgInfiniiVisionMathFunctionFilter interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Integrate | Pointer to the IAgInfiniiVisionMathFunctionIntegrate interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Linear | Pointer to the IAgInfiniiVisionMathFunctionLinear interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | MeasurementTrend2 | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Operation | Waveform math operation. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Range | Range of Full-scale vertical axis for the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Scale | Vertical scale, or units per division, of the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Smoothing | Pointer to the IAgInfiniiVisionMathFunction2Smoothing interface.
Public property | Source1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Source2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources). (Inherited from IAgInfiniiVisionMathFunction.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Average | Pointer to the IAgInfiniiVisionMathFunctionAverage interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Bus | Pointer to the IAgInfiniiVisionMathFunctionBus interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Enabled | Enables/Disables the math function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | FFT | Pointer to the IAgInfiniiVisionMathFunctionFFT interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | FFT2 | Pointer to the IAgInfiniiVisionMathFunctionFFT interface.
Public property | Filter | Pointer to the IAgInfiniiVisionMathFunctionFilter interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Integrate | Pointer to the IAgInfiniiVisionMathFunctionIntegrate interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Linear | Pointer to the IAgInfiniiVisionMathFunctionLinear interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | MeasurementTrend | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | MeasurementTrend2 | Pointer to the IAgInfiniiVisionMathFunctionMeasurementTrend interface.
Public property | Offset | Voltage or vertical value represented at center screen for the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Operation | Waveform math operation. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Range | Range of Full-scale vertical axis for the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Scale | Vertical scale, or units per division, of the selected function. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Smoothing | Pointer to the IAgInfiniiVisionMathFunction2Smoothing interface.
Public property | Source1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions. (Inherited from IAgInfiniiVisionMathFunction.)
Public property | Source2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources). (Inherited from IAgInfiniiVisionMathFunction.)
Top


IAgInfiniiVisionMathFunction2Smoothing Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunction2Smoothing Interface
See Also

IAgInfiniiVisionMathFunction2Smoothing interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunction2Smoothing
C#
public interface IAgInfiniiVisionMathFunction2Smoothing
Visual C++
__interface IAgInfiniiVisionMathFunction2Smoothing

Properties

 | Name | Description
Public property | Points | The number of smoothing points to use.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Points | The number of smoothing points to use.
Top


IAgInfiniiVisionMathFunctionAverage Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionAverage Interface
See Also

IAgInfiniiVisionMathFunctionAverage interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionAverage
C#
public interface IAgInfiniiVisionMathFunctionAverage
Visual C++
__interface IAgInfiniiVisionMathFunctionAverage

Properties

 | Name | Description
Public property | Count | Specify the number of waveforms to be averaged together.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Specify the number of waveforms to be averaged together.
Top


IAgInfiniiVisionMathFunctionBus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionBus Interface
See Also

IAgInfiniiVisionMath2Bus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionBus
C#
public interface IAgInfiniiVisionMathFunctionBus
Visual C++
__interface IAgInfiniiVisionMathFunctionBus

Properties

 | Name | Description
Public property | ClockSource | Specifies the clock signal source for the Chart Logic Bus State operation.
Public property | Slope | Specifies the clock signal edge for the Chart Logic Bus State operation.
Public property | YIncrement | Specifies the value associated with each increment in Chart Logic Bus data.
Public property | YOrigin | Specifies the value associated with Chart Logic Bus data equal to zero.
Public property | YUnits | Specifies the vertical units for the Chart Logic Bus operations.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionMathFunctionFFT Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT Interface
See Also

IAgInfiniiVisionMathFFT2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionFFT
C#
public interface IAgInfiniiVisionMathFunctionFFT
Visual C++
__interface IAgInfiniiVisionMathFunctionFFT

Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Public property | Span | Frequency span of the display when FFT is selected.
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms or operations for the FFT.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Public property | Span | Frequency span of the display when FFT is selected.
Public property | VerticalUnits | Specifies the FFT vertical units.
Public property | WindowType | Windowing transforms or operations for the FFT.
Top


IAgInfiniiVisionMathFunctionFFT2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFFT2 Interface
See Also

IAgInfiniiVisionMathFunctionFFT2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionFFT2
   Inherits IAgInfiniiVisionMathFunctionFFT
C#
public interface IAgInfiniiVisionMathFunctionFFT2 : IAgInfiniiVisionMathFunctionFFT
Visual C++
__interface IAgInfiniiVisionMathFunctionFFT2 : IAgInfiniiVisionMathFunctionFFT

Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | Span | Frequency span of the display when FFT is selected. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | StartFrequency | The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | StopFrequency | The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | VerticalUnits | Specifies the FFT vertical units. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | WindowType | Windowing transforms or operations for the FFT. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CenterFrequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | Span | Frequency span of the display when FFT is selected. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | StartFrequency | The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | StopFrequency | The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Public property | VerticalUnits | Specifies the FFT vertical units. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Public property | WindowType | Windowing transforms or operations for the FFT. (Inherited from IAgInfiniiVisionMathFunctionFFT.)
Top


IAgInfiniiVisionMathFunctionFilter Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionFilter Interface
See Also

IAgInfiniiVisionMath2FilterFrequency interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionFilter
C#
public interface IAgInfiniiVisionMathFunctionFilter
Visual C++
__interface IAgInfiniiVisionMathFunctionFilter

Properties

 | Name | Description
Public property | HighPassBandwidth | Specifies the high-pass filter's -3 dB cutoff frequency.
Public property | LowPassBandwidth | Specifies the low-pass filter's -3 dB cutoff frequency.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionMathFunctionIntegrate Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionIntegrate Interface
See Also

IAgInfiniiVisionMath2Integrate interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionIntegrate
C#
public interface IAgInfiniiVisionMathFunctionIntegrate
Visual C++
__interface IAgInfiniiVisionMathFunctionIntegrate

Properties

 | Name | Description
Public property | InputOffset | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionMathFunctionLinear Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionLinear Interface
See Also

IAgInfiniiVisionMath2Linear interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionLinear
C#
public interface IAgInfiniiVisionMathFunctionLinear
Visual C++
__interface IAgInfiniiVisionMathFunctionLinear

Properties

 | Name | Description
Public property | Gain | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Public property | Offset | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionMathFunctionMeasurementTrend Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionMeasurementTrend Interface
See Also

IAgInfiniiVisionMath2MeasurementTrend interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionMeasurementTrend
C#
public interface IAgInfiniiVisionMathFunctionMeasurementTrend
Visual C++
__interface IAgInfiniiVisionMathFunctionMeasurementTrend

Properties

 | Name | Description
Public property | Type | Specifies the measurement whose trend is shown in the math waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionMathFunctionMeasurementTrend2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctionMeasurementTrend2 Interface
See Also

IAgInfiniiVisionMathFunctionMeasurementTrend2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctionMeasurementTrend2
   Inherits IAgInfiniiVisionMathFunctionMeasurementTrend
C#
public interface IAgInfiniiVisionMathFunctionMeasurementTrend2 : IAgInfiniiVisionMathFunctionMeasurementTrend
Visual C++
__interface IAgInfiniiVisionMathFunctionMeasurementTrend2 : IAgInfiniiVisionMathFunctionMeasurementTrend

Properties

 | Name | Description
Public property | Slot | The measurement whose trend is shown in the math waveform.
Public property | Type | Specifies the measurement whose trend is shown in the math waveform. (Inherited from IAgInfiniiVisionMathFunctionMeasurementTrend.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Slot | The measurement whose trend is shown in the math waveform.
Public property | Type | Specifies the measurement whose trend is shown in the math waveform. (Inherited from IAgInfiniiVisionMathFunctionMeasurementTrend.)
Top


IAgInfiniiVisionMathFunctions Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions Interface
See Also

IAgInfiniiVisionMathFunctions interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctions
C#
public interface IAgInfiniiVisionMathFunctions
Visual C++
__interface IAgInfiniiVisionMathFunctions

Properties

 | Name | Description
Public property | Count | Returns the number of mathfunctions.
Public property | Item | Pointer to the IAgInfiniiVisionMathFunction interface.
Public property | Name | Returns the mathfunction name for a given index.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Returns the number of mathfunctions.
Public property | Item | Pointer to the IAgInfiniiVisionMathFunction interface.
Public property | Name | Returns the mathfunction name for a given index.
Top


IAgInfiniiVisionMathFunctions2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMathFunctions2 Interface
See Also

IAgInfiniiVisionMathFunctions2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMathFunctions2
   Inherits IAgInfiniiVisionMathFunctions
C#
public interface IAgInfiniiVisionMathFunctions2 : IAgInfiniiVisionMathFunctions
Visual C++
__interface IAgInfiniiVisionMathFunctions2 : IAgInfiniiVisionMathFunctions

Properties

 | Name | Description
Public property | Count | Returns the number of mathfunctions. (Inherited from IAgInfiniiVisionMathFunctions.)
Public property | Item | Pointer to the IAgInfiniiVisionMathFunction interface. (Inherited from IAgInfiniiVisionMathFunctions.)
Public property | Item2 | Pointer to the IAgInfiniiVisionMathFunction interface.
Public property | Name | Returns the mathfunction name for a given index. (Inherited from IAgInfiniiVisionMathFunctions.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Returns the number of mathfunctions. (Inherited from IAgInfiniiVisionMathFunctions.)
Public property | Item | Pointer to the IAgInfiniiVisionMathFunction interface. (Inherited from IAgInfiniiVisionMathFunctions.)
Public property | Item2 | Pointer to the IAgInfiniiVisionMathFunction interface.
Public property | Name | Returns the mathfunction name for a given index. (Inherited from IAgInfiniiVisionMathFunctions.)
Top


IAgInfiniiVisionMeasurement Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement Interface
See Also

IAgInfiniiVisionMeasurement interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurement
C#
public interface IAgInfiniiVisionMeasurement
Visual C++
__interface IAgInfiniiVisionMeasurement

Methods

 | Name | Description
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Public method | FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Public method | ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Public method | FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Public method | ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Top


IAgInfiniiVisionMeasurement2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurement2 Interface
See Also

IAgInfiniiVisionMeasurement2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurement2
   Inherits IAgInfiniiVisionMeasurement
C#
public interface IAgInfiniiVisionMeasurement2 : IAgInfiniiVisionMeasurement
Visual C++
__interface IAgInfiniiVisionMeasurement2 : IAgInfiniiVisionMeasurement

Methods

 | Name | Description
Public method | ConfigureJitterMeasurement | Configure and adds the selected Jitter measurement.
Public method | FetchJitterMeasurement | Returns the measured value of the selected measurement.
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadJitterMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureJitterMeasurement | Configure and adds the selected Jitter measurement.
Public method | FetchJitterMeasurement | Returns the measured value of the selected measurement.
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadJitterMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Public method | ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels. (Inherited from IAgInfiniiVisionMeasurement.)
Top


IAgInfiniiVisionMeasurements Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements Interface
See Also

IAgInfiniiVisionMeasurements interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurements
C#
public interface IAgInfiniiVisionMeasurements
Visual C++
__interface IAgInfiniiVisionMeasurements

Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface.
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source.
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface.
Public property | Name | Read Only - Returns the measurement name for a given index.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Public method | Clear | Clears all selected measurements and markers from the screen
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Public method | Clear | Clears all selected measurements and markers from the screen
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Top


Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface.
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source.
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface.
Public property | Name | Read Only - Returns the measurement name for a given index.
Top


IAgInfiniiVisionMeasurements2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2 Interface
See Also

IAgInfiniiVisionMeasurements2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurements2
   Inherits IAgInfiniiVisionMeasurements
C#
public interface IAgInfiniiVisionMeasurements2 : IAgInfiniiVisionMeasurements
Visual C++
__interface IAgInfiniiVisionMeasurements2 : IAgInfiniiVisionMeasurements

Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Name | Read Only - Returns the measurement name for a given index. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Statistics | Pointer to the IAgInfiniiVisionMeasurements2Statistics interface.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Clear | Clears all selected measurements and markers from the screen (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown. (Inherited from IAgInfiniiVisionMeasurements.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Name | Read Only - Returns the measurement name for a given index. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Statistics | Pointer to the IAgInfiniiVisionMeasurements2Statistics interface.
Top


IAgInfiniiVisionMeasurements2Statistics Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements2Statistics Interface
See Also

IAgInfiniiVisionMeasurements2Statistics interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurements2Statistics
C#
public interface IAgInfiniiVisionMeasurements2Statistics
Visual C++
__interface IAgInfiniiVisionMeasurements2Statistics

Properties

 | Name | Description
Public property | Count | Specifies the maximum number of values used when calculating measurement statistics.
Public property | DisplayEnabled | Enables or disables the display of the measurement statistics.
Public property | Format | Specifies the type of information returned by the GetResults() method.
Public property | RelativeStdDevEnabled | Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.
Top

Methods

 | Name | Description
Public method | GetResults | Returns the results of the continuously displayed measurements.
Public method | Increment | This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.
Public method | InstallMeasurement | Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.
Public method | Reset | This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetResults | Returns the results of the continuously displayed measurements.
Public method | Increment | This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.
Public method | InstallMeasurement | Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.
Public method | Reset | This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.
Top


Properties

 | Name | Description
Public property | Count | Specifies the maximum number of values used when calculating measurement statistics.
Public property | DisplayEnabled | Enables or disables the display of the measurement statistics.
Public property | Format | Specifies the type of information returned by the GetResults() method.
Public property | RelativeStdDevEnabled | Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.
Top


IAgInfiniiVisionMeasurements3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurements3 Interface
See Also

IAgInfiniiVisionMeasurements3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurements3
   Inherits IAgInfiniiVisionMeasurements2
C#
public interface IAgInfiniiVisionMeasurements3 : IAgInfiniiVisionMeasurements2
Visual C++
__interface IAgInfiniiVisionMeasurements3 : IAgInfiniiVisionMeasurements2

Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item2 | Pointer to the IAgInfiniiVisionMeasurement interface.
Public property | Name | Read Only - Returns the measurement name for a given index. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Statistics | Pointer to the IAgInfiniiVisionMeasurements2Statistics interface. (Inherited from IAgInfiniiVisionMeasurements2.)
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Clear | Clears all selected measurements and markers from the screen (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage. (Inherited from IAgInfiniiVisionMeasurements.)
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown. (Inherited from IAgInfiniiVisionMeasurements.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Configuration | Pointer to the IAgInfiniiVisionMeasurementsConfiguration interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Count | Read Only - Returns the number of channels that measurements can use as a source. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item | Pointer to the IAgInfiniiVisionMeasurement interface. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Item2 | Pointer to the IAgInfiniiVisionMeasurement interface.
Public property | Name | Read Only - Returns the measurement name for a given index. (Inherited from IAgInfiniiVisionMeasurements.)
Public property | Statistics | Pointer to the IAgInfiniiVisionMeasurements2Statistics interface. (Inherited from IAgInfiniiVisionMeasurements2.)
Top


IAgInfiniiVisionMeasurementsConfiguration Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMeasurementsConfiguration Interface
See Also

IAgInfiniiVisionMeasurementsConfiguration interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMeasurementsConfiguration
C#
public interface IAgInfiniiVisionMeasurementsConfiguration
Visual C++
__interface IAgInfiniiVisionMeasurementsConfiguration

Properties

 | Name | Description
Public property | DelayOccurrence1 | The occurrence count for the first waveform source of a generic delay measurement.
Public property | DelayOccurrence2 | The occurrence count for the second waveform source of a generic delay measurement.
Public property | DelaySlope1 | The polarity of the slope for the first waveform source of a generic delay measurement.
Public property | DelaySlope2 | The polarity of the slope for the second waveform source of a generic delay measurement.
Public property | MarkersEnabled | Enables markers for tracking measurements on the display. This feature is always on.
Public property | Source2 | Second source for measurements such as Delay, Phase etc.
Public property | TimeAtEdgeOccurrence | The occurrence count for the TimeAtEdge measurement.
Public property | TimeAtEdgeSlope | The edge slope for a TimeAtEdge measurement.
Public property | TimeAtValueOccurrence | The occurrence count for the TimeAtValue measurement.
Public property | TimeAtValueSlope | The edge slope for a TimeAtValue measurement.
Public property | TimeAtValueValue | The voltage for the TimeAtValue measurement.
Public property | ValueAtTimeTime | The time (in seconds) used to make the ValueAtTime measurement.
Public property | Window | Measurement window when zoomed time base is selected.
Top

Methods

 | Name | Description
Public method | ConfigureDelay | Configures the edge specifications for the delay and phase measurements.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureDelay | Configures the edge specifications for the delay and phase measurements.
Top


Properties

 | Name | Description
Public property | DelayOccurrence1 | The occurrence count for the first waveform source of a generic delay measurement.
Public property | DelayOccurrence2 | The occurrence count for the second waveform source of a generic delay measurement.
Public property | DelaySlope1 | The polarity of the slope for the first waveform source of a generic delay measurement.
Public property | DelaySlope2 | The polarity of the slope for the second waveform source of a generic delay measurement.
Public property | MarkersEnabled | Enables markers for tracking measurements on the display. This feature is always on.
Public property | Source2 | Second source for measurements such as Delay, Phase etc.
Public property | TimeAtEdgeOccurrence | The occurrence count for the TimeAtEdge measurement.
Public property | TimeAtEdgeSlope | The edge slope for a TimeAtEdge measurement.
Public property | TimeAtValueOccurrence | The occurrence count for the TimeAtValue measurement.
Public property | TimeAtValueSlope | The edge slope for a TimeAtValue measurement.
Public property | TimeAtValueValue | The voltage for the TimeAtValue measurement.
Public property | ValueAtTimeTime | The time (in seconds) used to make the ValueAtTime measurement.
Public property | Window | Measurement window when zoomed time base is selected.
Top


IAgInfiniiVisionMemory Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory Interface
See Also

IAgInfiniiVisionMemory interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMemory
C#
public interface IAgInfiniiVisionMemory
Visual C++
__interface IAgInfiniiVisionMemory

Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations.
Public property | CurrentRecallFile | File for recall operations.
Public property | CurrentSaveDirectory | Present working directory for save operations.
Public property | CurrentSaveFile | File for save operations.
Public property | ImageFormat | Type of image format
Public property | ImagePalette | Image palette color.
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.
Public property | WaveformFormat | Data format of waveform
Public property | WaveformLength | Waveform data length (number of points saved).
Top

Methods

 | Name | Description
Public method | Recall | Recall option for Mask, Oscilloscope Setup and Reference memory.
Public method | Save | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Recall | Recall option for Mask, Oscilloscope Setup and Reference memory.
Public method | Save | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.
Top


Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations.
Public property | CurrentRecallFile | File for recall operations.
Public property | CurrentSaveDirectory | Present working directory for save operations.
Public property | CurrentSaveFile | File for save operations.
Public property | ImageFormat | Type of image format
Public property | ImagePalette | Image palette color.
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.
Public property | WaveformFormat | Data format of waveform
Public property | WaveformLength | Waveform data length (number of points saved).
Top


IAgInfiniiVisionMemory2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2 Interface
See Also

IAgInfiniiVisionMemory2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMemory2
   Inherits IAgInfiniiVisionMemory
C#
public interface IAgInfiniiVisionMemory2 : IAgInfiniiVisionMemory
Visual C++
__interface IAgInfiniiVisionMemory2 : IAgInfiniiVisionMemory

Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentRecallFile | File for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveDirectory | Present working directory for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveFile | File for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | ImageFormat | Type of image format (Inherited from IAgInfiniiVisionMemory.)
Public property | ImagePalette | Image palette color. (Inherited from IAgInfiniiVisionMemory.)
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not. (Inherited from IAgInfiniiVisionMemory.)
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n> (Inherited from IAgInfiniiVisionMemory.)
Public property | ResultFormat | Pointer to the IAgInfiniiVisionMemory2ResultFormat interface.
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image. (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformFormat | Data format of waveform (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformLength | Waveform data length (number of points saved). (Inherited from IAgInfiniiVisionMemory.)
Top

Methods

 | Name | Description
Public method | Recall | Recall option for Mask, Oscilloscope Setup and Reference memory. (Inherited from IAgInfiniiVisionMemory.)
Public method | Save | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory. (Inherited from IAgInfiniiVisionMemory.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentRecallFile | File for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveDirectory | Present working directory for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveFile | File for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | ImageFormat | Type of image format (Inherited from IAgInfiniiVisionMemory.)
Public property | ImagePalette | Image palette color. (Inherited from IAgInfiniiVisionMemory.)
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not. (Inherited from IAgInfiniiVisionMemory.)
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n> (Inherited from IAgInfiniiVisionMemory.)
Public property | ResultFormat | Pointer to the IAgInfiniiVisionMemory2ResultFormat interface.
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image. (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformFormat | Data format of waveform (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformLength | Waveform data length (number of points saved). (Inherited from IAgInfiniiVisionMemory.)
Top


IAgInfiniiVisionMemory2ResultFormat Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory2ResultFormat Interface
See Also

IAgInfiniiVisionMemory2ResultFormat interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMemory2ResultFormat
C#
public interface IAgInfiniiVisionMemory2ResultFormat
Visual C++
__interface IAgInfiniiVisionMemory2ResultFormat

Properties

 | Name | Description
Public property | CursorEnabled | Enables or disables whether the cursor values will be included when analysis results are saved.
Public property | HistogramEnabled | Enables or disables whether the histogram statistics will be included when analysis results are saved.
Public property | MaskEnabled | Enables or disables whether the mask statistics will be included when analysis results are saved.
Public property | MeasurementEnabled | Enables or disables whether the measurement results will be included when analysis results are saved.
Public property | SearchEnabled | Enables or disables whether the found search event times will be included when analysis results are saved.
Public property | SegmentedEnabled | Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CursorEnabled | Enables or disables whether the cursor values will be included when analysis results are saved.
Public property | HistogramEnabled | Enables or disables whether the histogram statistics will be included when analysis results are saved.
Public property | MaskEnabled | Enables or disables whether the mask statistics will be included when analysis results are saved.
Public property | MeasurementEnabled | Enables or disables whether the measurement results will be included when analysis results are saved.
Public property | SearchEnabled | Enables or disables whether the found search event times will be included when analysis results are saved.
Public property | SegmentedEnabled | Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.
Top


IAgInfiniiVisionMemory3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionMemory3 Interface
See Also

IAgInfiniiVisionMemory3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionMemory3
   Inherits IAgInfiniiVisionMemory2
C#
public interface IAgInfiniiVisionMemory3 : IAgInfiniiVisionMemory2
Visual C++
__interface IAgInfiniiVisionMemory3 : IAgInfiniiVisionMemory2

Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentRecallFile | File for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveDirectory | Present working directory for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveFile | File for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | ImageFormat | Type of image format (Inherited from IAgInfiniiVisionMemory.)
Public property | ImagePalette | Image palette color. (Inherited from IAgInfiniiVisionMemory.)
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not. (Inherited from IAgInfiniiVisionMemory.)
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n> (Inherited from IAgInfiniiVisionMemory.)
Public property | ResultFormat | Pointer to the IAgInfiniiVisionMemory2ResultFormat interface. (Inherited from IAgInfiniiVisionMemory2.)
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image. (Inherited from IAgInfiniiVisionMemory.)
Public property | SerialRecallDestination | This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).
Public property | WaveformFormat | Data format of waveform (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformLength | Waveform data length (number of points saved). (Inherited from IAgInfiniiVisionMemory.)
Top

Methods

 | Name | Description
Public method | Recall | Recall option for Mask, Oscilloscope Setup and Reference memory. (Inherited from IAgInfiniiVisionMemory.)
Public method | Save | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory. (Inherited from IAgInfiniiVisionMemory.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | CurrentRecallDirectory | Present working directory for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentRecallFile | File for recall operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveDirectory | Present working directory for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | CurrentSaveFile | File for save operations. (Inherited from IAgInfiniiVisionMemory.)
Public property | ImageFormat | Type of image format (Inherited from IAgInfiniiVisionMemory.)
Public property | ImagePalette | Image palette color. (Inherited from IAgInfiniiVisionMemory.)
Public property | InvertColorEnabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not. (Inherited from IAgInfiniiVisionMemory.)
Public property | ReferenceWaveformSource | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n> (Inherited from IAgInfiniiVisionMemory.)
Public property | ResultFormat | Pointer to the IAgInfiniiVisionMemory2ResultFormat interface. (Inherited from IAgInfiniiVisionMemory2.)
Public property | SaveFactorsEnabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image. (Inherited from IAgInfiniiVisionMemory.)
Public property | SerialRecallDestination | This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).
Public property | WaveformFormat | Data format of waveform (Inherited from IAgInfiniiVisionMemory.)
Public property | WaveformLength | Waveform data length (number of points saved). (Inherited from IAgInfiniiVisionMemory.)
Top


IAgInfiniiVisionReferenceLevel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceLevel Interface
See Also

IVI Scope class-compliant reference level interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionReferenceLevel
C#
public interface IAgInfiniiVisionReferenceLevel
Visual C++
__interface IAgInfiniiVisionReferenceLevel

Properties

 | Name | Description
Public property | High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

Methods

 | Name | Description
Public method | Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top


Properties

 | Name | Description
Public property | High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top


IAgInfiniiVisionReferenceWaveform Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionReferenceWaveform Interface
See Also

IAgInfiniiVisionReferenceWaveform interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionReferenceWaveform
C#
public interface IAgInfiniiVisionReferenceWaveform
Visual C++
__interface IAgInfiniiVisionReferenceWaveform

Methods

 | Name | Description
Public method | Clear | Clears the specified reference waveform location.
Public method | Enable | Enables/Disables the specified reference waveform.
Public method | GetLabel | Returns the Label associated with a specified reference waveform.
Public method | GetOffset | Returns the Current offset value for the selected reference waveform.
Public method | GetRange | Returns the Current full-scale range for the specified reference waveform.
Public method | GetSkewFactor | Returns the Current skew factor for the selected reference waveform.
Public method | GetVerticalScale | Returns the Current vertical units per division for the specified reference waveform.
Public method | IsEnabled | Returns the Current display setting of the specified reference waveform.
Public method | Save | Copies the analog channel or math function waveform to the specified reference waveform location.
Public method | SetLabel | Label for the specified reference waveform.
Public method | SetOffset | Offset value that is represented at center screen for the selected reference waveform.
Public method | SetRange | Full-scale range of vertical axis of the selected reference waveform.
Public method | SetSkewFactor | Skew factor for the specified reference waveform.
Public method | SetVerticalScale | Vertical scale, or units per division, of the selected reference waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Clears the specified reference waveform location.
Public method | Enable | Enables/Disables the specified reference waveform.
Public method | GetLabel | Returns the Label associated with a specified reference waveform.
Public method | GetOffset | Returns the Current offset value for the selected reference waveform.
Public method | GetRange | Returns the Current full-scale range for the specified reference waveform.
Public method | GetSkewFactor | Returns the Current skew factor for the selected reference waveform.
Public method | GetVerticalScale | Returns the Current vertical units per division for the specified reference waveform.
Public method | IsEnabled | Returns the Current display setting of the specified reference waveform.
Public method | Save | Copies the analog channel or math function waveform to the specified reference waveform location.
Public method | SetLabel | Label for the specified reference waveform.
Public method | SetOffset | Offset value that is represented at center screen for the selected reference waveform.
Public method | SetRange | Full-scale range of vertical axis of the selected reference waveform.
Public method | SetSkewFactor | Skew factor for the specified reference waveform.
Public method | SetVerticalScale | Vertical scale, or units per division, of the selected reference waveform.
Top


IAgInfiniiVisionSearch2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch2 Interface
See Also

IAgInfiniiVisionSearch2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch2
   Inherits IAgInfiniiVision2Search
C#
public interface IAgInfiniiVisionSearch2 : IAgInfiniiVision2Search
Visual C++
__interface IAgInfiniiVisionSearch2 : IAgInfiniiVision2Search

Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top


IAgInfiniiVisionSearch3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3 Interface
See Also

IAgInfiniiVisionSearch3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch3
   Inherits IAgInfiniiVisionSearch2
C#
public interface IAgInfiniiVisionSearch3 : IAgInfiniiVisionSearch2
Visual C++
__interface IAgInfiniiVisionSearch3 : IAgInfiniiVisionSearch2

Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface.
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface.
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top


IAgInfiniiVisionSearch3Peak Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch3Peak Interface
See Also

IAgInfiniiVisionSearch3Peak interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch3Peak
C#
public interface IAgInfiniiVisionSearch3Peak
Visual C++
__interface IAgInfiniiVisionSearch3Peak

Properties

 | Name | Description
Public property | Excursion | The change in level that must occur (in other words, hysteresis) to be recognized as a peak.
Public property | NumberOfPeaks | The maximum number of FFT peaks to find.
Public property | Source | The FFT math function waveform to search.
Public property | Threshold | The threshold level necessary to be considered a peak.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Excursion | The change in level that must occur (in other words, hysteresis) to be recognized as a peak.
Public property | NumberOfPeaks | The maximum number of FFT peaks to find.
Public property | Source | The FFT math function waveform to search.
Public property | Threshold | The threshold level necessary to be considered a peak.
Top


IAgInfiniiVisionSearch4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch4 Interface
See Also

IAgInfiniiVisionSearch4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch4
   Inherits IAgInfiniiVisionSearch3
C#
public interface IAgInfiniiVisionSearch4 : IAgInfiniiVisionSearch3
Visual C++
__interface IAgInfiniiVisionSearch4 : IAgInfiniiVisionSearch3

Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface. (Inherited from IAgInfiniiVisionSearch3.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Serial3 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface. (Inherited from IAgInfiniiVisionSearch3.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Serial3 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top


IAgInfiniiVisionSearch5 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5 Interface
See Also

IAgInfiniiVisionSearch5 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch5
   Inherits IAgInfiniiVisionSearch4
C#
public interface IAgInfiniiVisionSearch5 : IAgInfiniiVisionSearch4
Visual C++
__interface IAgInfiniiVisionSearch5 : IAgInfiniiVisionSearch4

Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface. (Inherited from IAgInfiniiVisionSearch3.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Serial3 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch4.)
Public property | Serial4 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Gets the number of search events found. (Inherited from IAgInfiniiVision2Search.)
Public property | Edge | Pointer to the IAgInfiniiVision2Search2Edge interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Glitch | Pointer to the IAgInfiniiVision2Search2Glitch interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Mode | The oscilloscope search mode. (Inherited from IAgInfiniiVision2Search.)
Public property | Peak | Pointer to the IAgInfiniiVisionSearch3Peak interface. (Inherited from IAgInfiniiVisionSearch3.)
Public property | Runt | Pointer to the IAgInfiniiVision2Search2Runt interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVision2Search.)
Public property | Serial2 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch2.)
Public property | Serial3 | Pointer to the IAgInfiniiVision2Search2Serial interface. (Inherited from IAgInfiniiVisionSearch4.)
Public property | Serial4 | Pointer to the IAgInfiniiVision2Search2Serial interface.
Public property | Transition | Pointer to the IAgInfiniiVision2Search2Transition interface. (Inherited from IAgInfiniiVision2Search.)
Top


IAgInfiniiVisionSearch5Serial4LIN2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearch5Serial4LIN2 Interface
See Also

IAgInfiniiVisionSearch5Serial4LIN2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearch5Serial4LIN2
   Inherits IAgInfiniiVision2SearchSerialLIN
C#
public interface IAgInfiniiVisionSearch5Serial4LIN2 : IAgInfiniiVision2SearchSerialLIN
Visual C++
__interface IAgInfiniiVisionSearch5Serial4LIN2 : IAgInfiniiVision2SearchSerialLIN

Properties

 | Name | Description
Public property | ID | Specifies the frame ID value when searching for LIN events (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | Mode | Selects the type of LIN information to find in the Lister display (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | PatternData | Specifies the data value when searching for LIN events. (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | PatternDataLength | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8. (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | SymbolicFrame | Sets and Gets the specific message when LIN serial search mode is set to Frame.
Public property | SymbolicSignal | Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.
Public property | SymbolicValue | Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ID | Specifies the frame ID value when searching for LIN events (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | Mode | Selects the type of LIN information to find in the Lister display (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | PatternData | Specifies the data value when searching for LIN events. (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | PatternDataLength | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8. (Inherited from IAgInfiniiVision2SearchSerialLIN.)
Public property | SymbolicFrame | Sets and Gets the specific message when LIN serial search mode is set to Frame.
Public property | SymbolicSignal | Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.
Public property | SymbolicValue | Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.
Top


IAgInfiniiVisionSearchSerial2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2 Interface
See Also

IAgInfiniiVisionSearchSerial2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial2
   Inherits IAgInfiniiVision2SearchSerial
C#
public interface IAgInfiniiVisionSearchSerial2 : IAgInfiniiVision2SearchSerial
Visual C++
__interface IAgInfiniiVisionSearchSerial2 : IAgInfiniiVision2SearchSerial

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface.
Top


IAgInfiniiVisionSearchSerial2USB Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial2USB Interface
See Also

IAgInfiniiVision2SerialBus2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial2USB
C#
public interface IAgInfiniiVisionSearchSerial2USB
Visual C++
__interface IAgInfiniiVisionSearchSerial2USB

Properties

 | Name | Description
Public property | Address | Specifies the 7-bit Address portion of the search value, in hex.
Public property | Condition | Specifies the USB search mode.
Public property | CRC | Specifies the CRC portion of the search value, in hex.
Public property | Data | Specifies the Data portion of the trigger, in hex.
Public property | DataLength | Specifies the data length in bytes.
Public property | EndPoint | Specifies the 4-bit Endpoint portion of the search value, in hex.
Public property | ET | Specifies the 2-bit ET portion of the search value, in hex.
Public property | Frame | Specifies the 11-bit Frame portion of the search value, in hex.
Public property | HubAddress | Specifies the 7-bit Hub Address portion of the search value, in hex.
Public property | PIDData | Specifies the USB data PID to find.
Public property | PIDHandshake | Specifies the USB handshake PID to find.
Public property | PIDSpecial | Specifies the USB special PID to find.
Public property | PIDToken | Specifies the USB token PID to find.
Public property | Port | Specifies the 7-bit Port portion of the search value, in hex.
Public property | SC | Specifies the 1-bit SC portion of the search value, in hex.
Public property | SEU | Specifies the 2-bit S and E or U portion of the search value, in hex.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Address | Specifies the 7-bit Address portion of the search value, in hex.
Public property | Condition | Specifies the USB search mode.
Public property | CRC | Specifies the CRC portion of the search value, in hex.
Public property | Data | Specifies the Data portion of the trigger, in hex.
Public property | DataLength | Specifies the data length in bytes.
Public property | EndPoint | Specifies the 4-bit Endpoint portion of the search value, in hex.
Public property | ET | Specifies the 2-bit ET portion of the search value, in hex.
Public property | Frame | Specifies the 11-bit Frame portion of the search value, in hex.
Public property | HubAddress | Specifies the 7-bit Hub Address portion of the search value, in hex.
Public property | PIDData | Specifies the USB data PID to find.
Public property | PIDHandshake | Specifies the USB handshake PID to find.
Public property | PIDSpecial | Specifies the USB special PID to find.
Public property | PIDToken | Specifies the USB token PID to find.
Public property | Port | Specifies the 7-bit Port portion of the search value, in hex.
Public property | SC | Specifies the 1-bit SC portion of the search value, in hex.
Public property | SEU | Specifies the 2-bit S and E or U portion of the search value, in hex.
Top


IAgInfiniiVisionSearchSerial3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3 Interface
See Also

IAgInfiniiVisionSearchSerial3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial3
   Inherits IAgInfiniiVisionSearchSerial2
C#
public interface IAgInfiniiVisionSearchSerial3 : IAgInfiniiVisionSearchSerial2
Visual C++
__interface IAgInfiniiVisionSearchSerial3 : IAgInfiniiVisionSearchSerial2

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SENT | Pointer to the IAgInfiniiVisionSearchSerial3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface. (Inherited from IAgInfiniiVisionSearchSerial2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SENT | Pointer to the IAgInfiniiVisionSearchSerial3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface. (Inherited from IAgInfiniiVisionSearchSerial2.)
Top


IAgInfiniiVisionSearchSerial3SENT Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENT Interface
See Also

IAgInfiniiVisionSearchSerial3SENT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial3SENT
C#
public interface IAgInfiniiVisionSearchSerial3SENT
Visual C++
__interface IAgInfiniiVisionSearchSerial3SENT

Properties

 | Name | Description
Public property | Fast | Pointer to the IAgInfiniiVisionSearchSerial3SENTFast interface.
Public property | Mode | Sets and gets the search mode settings.
Public property | Slow | Pointer to the IAgInfiniiVisionSearchSerial3SENTSlow interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Fast | Pointer to the IAgInfiniiVisionSearchSerial3SENTFast interface.
Public property | Mode | Sets and gets the search mode settings.
Public property | Slow | Pointer to the IAgInfiniiVisionSearchSerial3SENTSlow interface.
Top


IAgInfiniiVisionSearchSerial3SENTFast Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENTFast Interface
See Also

IAgInfiniiVisionSearchSerial3SENTFast interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial3SENTFast
C#
public interface IAgInfiniiVisionSearchSerial3SENTFast
Visual C++
__interface IAgInfiniiVisionSearchSerial3SENTFast

Properties

 | Name | Description
Public property | Data | Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Data | Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.
Top


IAgInfiniiVisionSearchSerial3SENTSlow Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial3SENTSlow Interface
See Also

IAgInfiniiVisionSearchSerial3SENTSlow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial3SENTSlow
C#
public interface IAgInfiniiVisionSearchSerial3SENTSlow
Visual C++
__interface IAgInfiniiVisionSearchSerial3SENTSlow

Properties

 | Name | Description
Public property | Data | Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.
Public property | ID | Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Data | Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.
Public property | ID | Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.
Top


IAgInfiniiVisionSearchSerial4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSearchSerial4 Interface
See Also

IAgInfiniiVisionSearchSerial4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSearchSerial4
   Inherits IAgInfiniiVisionSearchSerial3
C#
public interface IAgInfiniiVisionSearchSerial4 : IAgInfiniiVisionSearchSerial3
Visual C++
__interface IAgInfiniiVisionSearchSerial4 : IAgInfiniiVisionSearchSerial3

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SearchSerialCAN interface.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN2 | Pointer to the IAgInfiniiVision2SearchSerialLIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SENT | Pointer to the IAgInfiniiVisionSearchSerial3SENT interface. (Inherited from IAgInfiniiVisionSearchSerial3.)
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface. (Inherited from IAgInfiniiVisionSearchSerial2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SearchSerialARINC429 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN | Pointer to the IAgInfiniiVision2SearchSerialCAN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SearchSerialCAN interface.
Public property | FlexRay | Pointer to the IAgInfiniiVision2SearchSerialFlexRay interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | I2S | Pointer to the IAgInfiniiVision2SearchSerialI2S interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | IIC | Pointer to the IAgInfiniiVision2SearchSerialIIC interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN | Pointer to the IAgInfiniiVision2SearchSerialLIN interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | LIN2 | Pointer to the IAgInfiniiVision2SearchSerialLIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SearchSerialM1553 interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | SENT | Pointer to the IAgInfiniiVisionSearchSerial3SENT interface. (Inherited from IAgInfiniiVisionSearchSerial3.)
Public property | SPI | Pointer to the IAgInfiniiVision2SearchSerialSPI interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | UART | Pointer to the IAgInfiniiVision2SearchSerialUART interface. (Inherited from IAgInfiniiVision2SearchSerial.)
Public property | USB | Pointer to the IAgInfiniiVision2Search2USB interface. (Inherited from IAgInfiniiVisionSearchSerial2.)
Top


IAgInfiniiVisionSerialBus2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2 Interface
See Also

IAgInfiniiVisionSerialBus2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus2
   Inherits IAgInfiniiVision2SerialBus
C#
public interface IAgInfiniiVisionSerialBus2 : IAgInfiniiVision2SerialBus
Visual C++
__interface IAgInfiniiVisionSerialBus2 : IAgInfiniiVision2SerialBus

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface.
Top


IAgInfiniiVisionSerialBus2USB Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus2USB Interface
See Also

IAgInfiniiVisionSerialBus2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus2USB
C#
public interface IAgInfiniiVisionSerialBus2USB
Visual C++
__interface IAgInfiniiVisionSerialBus2USB

Properties

 | Name | Description
Public property | Address | Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.
Public property | Base | Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.
Public property | Condition | Specifies USB trigger mode for the selected bus.
Public property | CRC | Specifies the CRC portion of the trigger for the selected bus, in binary or hex.
Public property | Data | Specifies the Data portion of the trigger for the selected bus, in binary or hex.
Public property | DataLength | Specifies the data length in bytes.
Public property | DifferentialSource | Specifies which signal is used as the differential source for the selected bus.
Public property | DMinusSource | Specifies which signal is used as the USB D- source for the selected bus.
Public property | DPlusSource | Specifies which signal is used as the USB D+ source for the selected bus.
Public property | EndPoint | Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.
Public property | ET | Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.
Public property | Frame | Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.
Public property | HubAddress | Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.
Public property | PIDCheck | Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.
Public property | PIDData | Specifies the USB data PID to trigger on for the selected bus.
Public property | PIDHandshake | Specifies the USB handshake PID to trigger on for the selected bus.
Public property | PIDSpecial | Specifies the USB special PID to trigger on for the selected bus
Public property | PIDToken | Specifies the USB token PID to trigger on for the selected bus.
Public property | Port | Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.
Public property | SC | Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.
Public property | SEU | Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.
Public property | Speed | Specifies the speed of the USB interface for the selected bus.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Address | Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.
Public property | Base | Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.
Public property | Condition | Specifies USB trigger mode for the selected bus.
Public property | CRC | Specifies the CRC portion of the trigger for the selected bus, in binary or hex.
Public property | Data | Specifies the Data portion of the trigger for the selected bus, in binary or hex.
Public property | DataLength | Specifies the data length in bytes.
Public property | DifferentialSource | Specifies which signal is used as the differential source for the selected bus.
Public property | DMinusSource | Specifies which signal is used as the USB D- source for the selected bus.
Public property | DPlusSource | Specifies which signal is used as the USB D+ source for the selected bus.
Public property | EndPoint | Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.
Public property | ET | Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.
Public property | Frame | Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.
Public property | HubAddress | Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.
Public property | PIDCheck | Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.
Public property | PIDData | Specifies the USB data PID to trigger on for the selected bus.
Public property | PIDHandshake | Specifies the USB handshake PID to trigger on for the selected bus.
Public property | PIDSpecial | Specifies the USB special PID to trigger on for the selected bus
Public property | PIDToken | Specifies the USB token PID to trigger on for the selected bus.
Public property | Port | Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.
Public property | SC | Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.
Public property | SEU | Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.
Public property | Speed | Specifies the speed of the USB interface for the selected bus.
Top


IAgInfiniiVisionSerialBus3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3 Interface
See Also

IAgInfiniiVisionSerialBus3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3
   Inherits IAgInfiniiVisionSerialBus2
C#
public interface IAgInfiniiVisionSerialBus3 : IAgInfiniiVisionSerialBus2
Visual C++
__interface IAgInfiniiVisionSerialBus3 : IAgInfiniiVisionSerialBus2

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SENT | Pointer to the IAgInfiniiVisionSerialBus3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface. (Inherited from IAgInfiniiVisionSerialBus2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SENT | Pointer to the IAgInfiniiVisionSerialBus3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface. (Inherited from IAgInfiniiVisionSerialBus2.)
Top


IAgInfiniiVisionSerialBus3CAN2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2 Interface
See Also

IAgInfiniiVisionSerialBus3CAN2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3CAN2
   Inherits IAgInfiniiVision2SerialBusCAN
C#
public interface IAgInfiniiVisionSerialBus3CAN2 : IAgInfiniiVision2SerialBusCAN
Visual C++
__interface IAgInfiniiVisionSerialBus3CAN2 : IAgInfiniiVision2SerialBusCAN

Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | ErrorCount | Read Only - Gets the error frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | FD | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.
Public property | OverloadCount | Read Only - Gets the overload frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame). (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Source | Specifies the source for the CAN signal (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TotalCount | Read Only - Gets the total frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerCondition | Specifies the CAN trigger on condition (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Utilization | Read Only - Gets the percent utilization. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top

Methods

 | Name | Description
Public method | ResetCounters | Resets the frame counters. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | ErrorCount | Read Only - Gets the error frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | FD | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.
Public property | OverloadCount | Read Only - Gets the overload frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame). (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Source | Specifies the source for the CAN signal (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TotalCount | Read Only - Gets the total frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerCondition | Specifies the CAN trigger on condition (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Utilization | Read Only - Gets the percent utilization. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top


IAgInfiniiVisionSerialBus3CAN2FD Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3CAN2FD Interface
See Also

IAgInfiniiVisionSerialBus3CAN2FD interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3CAN2FD
C#
public interface IAgInfiniiVisionSerialBus3CAN2FD
Visual C++
__interface IAgInfiniiVisionSerialBus3CAN2FD

Properties

 | Name | Description
Public property | BaudRate | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Public property | DataLengthCode | Sets and gets the DLC value to be used in the CAN FD data trigger mode.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Public property | SpecErrorCount | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.
Public property | TriggerIDFilterEnabled | Enable and disable the triggers filtering by CAN IDs.
Public property | TriggerPatternStartBytePosition | Sets and gets the starting byte position for CAN FD data triggers.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Public property | DataLengthCode | Sets and gets the DLC value to be used in the CAN FD data trigger mode.
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Public property | SpecErrorCount | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.
Public property | TriggerIDFilterEnabled | Enable and disable the triggers filtering by CAN IDs.
Public property | TriggerPatternStartBytePosition | Sets and gets the starting byte position for CAN FD data triggers.
Top


IAgInfiniiVisionSerialBus3SENT Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT Interface
See Also

IAgInfiniiVisionSerialBus3SENT interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3SENT
C#
public interface IAgInfiniiVisionSerialBus3SENT
Visual C++
__interface IAgInfiniiVisionSerialBus3SENT

Properties

 | Name | Description
Public property | Clock | Sets and gets the nominal clock period (tick), from 1us to 300us.
Public property | CRCFormat | Set and get the format of the CRC.
Public property | Format | Sets and gets the message decode/triggering format.
Public property | IdleState | Sets and gets the idle state of the SENT bus.
Public property | NumberBase | Sets and gets the number base used by the decoder.
Public property | NumberOfNibble | Sets and gets the number of nibbles in a SENT message, from 1 to 6.
Public property | PausePulse | This command specifies whether the SENT messages are followed by a pause pulse.
Public property | Source | Sets and gets the input channel for SENT decode and triggering.
Public property | Tolerance | Sets and gets the tolerance for determing if the sync pulse is valid.
Public property | Trigger | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.
Top

Methods

 | Name | Description
Public method | GetSignalDisplay | This method specifies whether the given signal is on or off.
Public method | GetSignalLength | Gets the bit length of the signal being defined.
Public method | GetSignalMultiplier | Gets the multiplier value for the Fast Channel Signal.
Public method | GetSignalNibbleOrder | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Public method | GetSignalOffset | Gets the offset value for the Fast Channel Signal.
Public method | GetSignalStartPosition | Gets the starting bit of the Fast Signal being defined.
Public method | SetSignalDisplay | Set the given signal is on or off.
Public method | SetSignalLength | Sets the bit length of the signal being defined.
Public method | SetSignalMultiplier | Sets the multiplier value for the Fast Channel Signal.
Public method | SetSignalNibbleOrder | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Public method | SetSignalOffset | Sets the offset value for the Fast Channel Signal.
Public method | SetSignalStartPosition | Sets the starting bit of the Fast Signal being defined.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetSignalDisplay | This method specifies whether the given signal is on or off.
Public method | GetSignalLength | Gets the bit length of the signal being defined.
Public method | GetSignalMultiplier | Gets the multiplier value for the Fast Channel Signal.
Public method | GetSignalNibbleOrder | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Public method | GetSignalOffset | Gets the offset value for the Fast Channel Signal.
Public method | GetSignalStartPosition | Gets the starting bit of the Fast Signal being defined.
Public method | SetSignalDisplay | Set the given signal is on or off.
Public method | SetSignalLength | Sets the bit length of the signal being defined.
Public method | SetSignalMultiplier | Sets the multiplier value for the Fast Channel Signal.
Public method | SetSignalNibbleOrder | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Public method | SetSignalOffset | Sets the offset value for the Fast Channel Signal.
Public method | SetSignalStartPosition | Sets the starting bit of the Fast Signal being defined.
Top


Properties

 | Name | Description
Public property | Clock | Sets and gets the nominal clock period (tick), from 1us to 300us.
Public property | CRCFormat | Set and get the format of the CRC.
Public property | Format | Sets and gets the message decode/triggering format.
Public property | IdleState | Sets and gets the idle state of the SENT bus.
Public property | NumberBase | Sets and gets the number base used by the decoder.
Public property | NumberOfNibble | Sets and gets the number of nibbles in a SENT message, from 1 to 6.
Public property | PausePulse | This command specifies whether the SENT messages are followed by a pause pulse.
Public property | Source | Sets and gets the input channel for SENT decode and triggering.
Public property | Tolerance | Sets and gets the tolerance for determing if the sync pulse is valid.
Public property | Trigger | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.
Top


IAgInfiniiVisionSerialBus3SENT2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENT2 Interface
See Also

IAgInfiniiVisionSerialBus3SENT2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3SENT2
   Inherits IAgInfiniiVisionSerialBus3SENT
C#
public interface IAgInfiniiVisionSerialBus3SENT2 : IAgInfiniiVisionSerialBus3SENT
Visual C++
__interface IAgInfiniiVisionSerialBus3SENT2 : IAgInfiniiVisionSerialBus3SENT

Properties

 | Name | Description
Public property | Clock | Sets and gets the nominal clock period (tick), from 1us to 300us. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | CRCFormat | Set and get the format of the CRC. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Format | Sets and gets the message decode/triggering format. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | IdleState | Sets and gets the idle state of the SENT bus. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | NumberBase | Sets and gets the number base used by the decoder. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | NumberOfNibble | Sets and gets the number of nibbles in a SENT message, from 1 to 6. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | PausePulse | This command specifies whether the SENT messages are followed by a pause pulse. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Source | Sets and gets the input channel for SENT decode and triggering. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Tolerance | Sets and gets the tolerance for determing if the sync pulse is valid. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Trigger | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.
Top

Methods

 | Name | Description
Public method | GetSignalDisplay | This method specifies whether the given signal is on or off. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | GetSignalLength | Gets the bit length of the signal being defined. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | GetSignalMultiplier | Gets the multiplier value for the Fast Channel Signal. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | GetSignalNibbleOrder | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | GetSignalOffset | Gets the offset value for the Fast Channel Signal. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | GetSignalStartPosition | Gets the starting bit of the Fast Signal being defined. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalDisplay | Set the given signal is on or off. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalLength | Sets the bit length of the signal being defined. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalMultiplier | Sets the multiplier value for the Fast Channel Signal. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalNibbleOrder | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalOffset | Sets the offset value for the Fast Channel Signal. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public method | SetSignalStartPosition | Sets the starting bit of the Fast Signal being defined. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Clock | Sets and gets the nominal clock period (tick), from 1us to 300us. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | CRCFormat | Set and get the format of the CRC. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Format | Sets and gets the message decode/triggering format. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | IdleState | Sets and gets the idle state of the SENT bus. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | NumberBase | Sets and gets the number base used by the decoder. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | NumberOfNibble | Sets and gets the number of nibbles in a SENT message, from 1 to 6. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | PausePulse | This command specifies whether the SENT messages are followed by a pause pulse. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Source | Sets and gets the input channel for SENT decode and triggering. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Tolerance | Sets and gets the tolerance for determing if the sync pulse is valid. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Trigger | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface. (Inherited from IAgInfiniiVisionSerialBus3SENT.)
Public property | Trigger2 | Pointer to the IAgInfiniiVisionSerialBus3SENTTrigger interface.
Top


IAgInfiniiVisionSerialBus3SENTTrigger Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTrigger Interface
See Also

IAgInfiniiVisionSerialBus3SENTTrigger interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3SENTTrigger
C#
public interface IAgInfiniiVisionSerialBus3SENTTrigger
Visual C++
__interface IAgInfiniiVisionSerialBus3SENTTrigger

Properties

 | Name | Description
Public property | FastChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.
Public property | SlowChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | FastChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.
Public property | SlowChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.
Top


IAgInfiniiVisionSerialBus3SENTTriggerFastChannel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerFastChannel Interface
See Also

IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3SENTTriggerFastChannel
C#
public interface IAgInfiniiVisionSerialBus3SENTTriggerFastChannel
Visual C++
__interface IAgInfiniiVisionSerialBus3SENTTriggerFastChannel

Properties

 | Name | Description
Public property | Data | Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Data | Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.
Top


IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel Interface
See Also

IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel
C#
public interface IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel
Visual C++
__interface IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel

Properties

 | Name | Description
Public property | Data | Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.
Public property | ID | Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.
Public property | IDDataLength | Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Data | Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.
Public property | ID | Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.
Public property | IDDataLength | Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.
Top


IAgInfiniiVisionSerialBus4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4 Interface
See Also

IAgInfiniiVisionSerialBus4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus4
   Inherits IAgInfiniiVisionSerialBus3
C#
public interface IAgInfiniiVisionSerialBus4 : IAgInfiniiVisionSerialBus3
Visual C++
__interface IAgInfiniiVisionSerialBus4 : IAgInfiniiVisionSerialBus3

Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVisionSerialBus3.)
Public property | CAN3 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN2 | Pointer to the IAgInfiniiVision2SerialBus2LIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SENT | Pointer to the IAgInfiniiVisionSerialBus3SENT interface. (Inherited from IAgInfiniiVisionSerialBus3.)
Public property | SENT2 | Pointer to the IAgInfiniiVisionSerialBus3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface. (Inherited from IAgInfiniiVisionSerialBus2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ARINC429 | Pointer to the IAgInfiniiVision2SerialBus2ARINC429 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | CAN2 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface. (Inherited from IAgInfiniiVisionSerialBus3.)
Public property | CAN3 | Pointer to the IAgInfiniiVision2SerialBus2CAN interface.
Public property | Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | FlexRay | Pointer to the IAgInfiniiVision2SerialBus2FlexRay interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | I2S | Pointer to the I2SAgI2SnfiniiVisionSerial2BusI2S interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | IIC | Pointer to the IAgInfiniiVision2SerialBus2IIC interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN | Pointer to the IAgInfiniiVision2SerialBus2LIN interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | LIN2 | Pointer to the IAgInfiniiVision2SerialBus2LIN interface.
Public property | M1553 | Pointer to the IAgInfiniiVision2SerialBus2M1553 interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | Mode | Determines the decode mode for the serial bus. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | SENT | Pointer to the IAgInfiniiVisionSerialBus3SENT interface. (Inherited from IAgInfiniiVisionSerialBus3.)
Public property | SENT2 | Pointer to the IAgInfiniiVisionSerialBus3SENT interface.
Public property | SPI | Pointer to the IAgInfiniiVision2SerialBus2SPI interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | UART | Pointer to the IAgInfiniiVision2SerialBus2UART interface. (Inherited from IAgInfiniiVision2SerialBus.)
Public property | USB | Pointer to the IAgInfiniiVisionSerialBus2USB interface. (Inherited from IAgInfiniiVisionSerialBus2.)
Top


IAgInfiniiVisionSerialBus4CAN3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3 Interface
See Also

IAgInfiniiVisionSerialBus4CAN3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus4CAN3
   Inherits IAgInfiniiVisionSerialBus3CAN2
C#
public interface IAgInfiniiVisionSerialBus4CAN3 : IAgInfiniiVisionSerialBus3CAN2
Visual C++
__interface IAgInfiniiVisionSerialBus4CAN3 : IAgInfiniiVisionSerialBus3CAN2

Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Display | Sets and Gets the CAN decode display type.
Public property | ErrorCount | Read Only - Gets the error frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | FD | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface. (Inherited from IAgInfiniiVisionSerialBus3CAN2.)
Public property | FD2 | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.
Public property | OverloadCount | Read Only - Gets the overload frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame). (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Source | Specifies the source for the CAN signal (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TotalCount | Read Only - Gets the total frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerCondition | Specifies the CAN trigger on condition (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerSymbolicMessage | Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.
Public property | TriggerSymbolicSignal | Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Public property | TriggerSymbolicValue | Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Public property | Utilization | Read Only - Gets the percent utilization. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top

Methods

 | Name | Description
Public method | ResetCounters | Resets the frame counters. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Display | Sets and Gets the CAN decode display type.
Public property | ErrorCount | Read Only - Gets the error frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | FD | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface. (Inherited from IAgInfiniiVisionSerialBus3CAN2.)
Public property | FD2 | Pointer to the IAgInfiniiVisionSerialBus3CAN2FD interface.
Public property | OverloadCount | Read Only - Gets the overload frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | SignalType | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame). (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | Source | Specifies the source for the CAN signal (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TotalCount | Read Only - Gets the total frame count. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerCondition | Specifies the CAN trigger on condition (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternData | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternDataLength | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerPatternIDType | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Public property | TriggerSymbolicMessage | Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.
Public property | TriggerSymbolicSignal | Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Public property | TriggerSymbolicValue | Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Public property | Utilization | Read Only - Gets the percent utilization. (Inherited from IAgInfiniiVision2SerialBusCAN.)
Top


IAgInfiniiVisionSerialBus4CAN3FD2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4CAN3FD2 Interface
See Also

IAgInfiniiVisionSerialBus4CAN3FD2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus4CAN3FD2
   Inherits IAgInfiniiVisionSerialBus3CAN2FD
C#
public interface IAgInfiniiVisionSerialBus4CAN3FD2 : IAgInfiniiVisionSerialBus3CAN2FD
Visual C++
__interface IAgInfiniiVisionSerialBus4CAN3FD2 : IAgInfiniiVisionSerialBus3CAN2FD

Properties

 | Name | Description
Public property | BaudRate | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | DataLengthCode | Sets and gets the DLC value to be used in the CAN FD data trigger mode. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | SpecErrorCount | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | Standard | Sets and Gets the frame decode standard.
Public property | TriggerIDFilterEnabled | Enable and disable the triggers filtering by CAN IDs. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | TriggerPatternStartBytePosition | Sets and gets the starting byte position for CAN FD data triggers. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | DataLengthCode | Sets and gets the DLC value to be used in the CAN FD data trigger mode. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | SpecErrorCount | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | Standard | Sets and Gets the frame decode standard.
Public property | TriggerIDFilterEnabled | Enable and disable the triggers filtering by CAN IDs. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Public property | TriggerPatternStartBytePosition | Sets and gets the starting byte position for CAN FD data triggers. (Inherited from IAgInfiniiVisionSerialBus3CAN2FD.)
Top


IAgInfiniiVisionSerialBus4LIN2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4LIN2 Interface
See Also

IAgInfiniiVisionSerialBus4LIN2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus4LIN2
   Inherits IAgInfiniiVision2SerialBusLIN
C#
public interface IAgInfiniiVisionSerialBus4LIN2 : IAgInfiniiVision2SerialBusLIN
Visual C++
__interface IAgInfiniiVisionSerialBus4LIN2 : IAgInfiniiVision2SerialBusLIN

Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Display | Sets and Gets the LIN decode display type.
Public property | ParityEnabled | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Source | Specifies the source for the CAN signal. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Standard | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | SyncBreakLength | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerCondition | Specifies the LIN trigger condition. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerPatternData | Specifies the LIN trigger data pattern searched for in each LIN data field. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerPatternDataLength | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerSymbolicFrame | Sets and Gets the specific message when the LIN trigger mode is set to Frame.
Public property | TriggerSymbolicSignal | Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.
Public property | TriggerSymbolicValue | Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | BaudRate | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Display | Sets and Gets the LIN decode display type.
Public property | ParityEnabled | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | SamplePoint | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Source | Specifies the source for the CAN signal. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | Standard | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | SyncBreakLength | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerCondition | Specifies the LIN trigger condition. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerPatternData | Specifies the LIN trigger data pattern searched for in each LIN data field. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerPatternDataLength | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property. (Inherited from IAgInfiniiVision2SerialBusLIN.)
Public property | TriggerSymbolicFrame | Sets and Gets the specific message when the LIN trigger mode is set to Frame.
Public property | TriggerSymbolicSignal | Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.
Public property | TriggerSymbolicValue | Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.
Top


IAgInfiniiVisionSerialBus4SENT2Trigger2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBus4SENT2Trigger2 Interface
See Also

IAgInfiniiVisionSerialBus4SENT2Trigger2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBus4SENT2Trigger2
   Inherits IAgInfiniiVisionSerialBus3SENTTrigger
C#
public interface IAgInfiniiVisionSerialBus4SENT2Trigger2 : IAgInfiniiVisionSerialBus3SENTTrigger
Visual C++
__interface IAgInfiniiVisionSerialBus4SENT2Trigger2 : IAgInfiniiVisionSerialBus3SENTTrigger

Properties

 | Name | Description
Public property | FastChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface. (Inherited from IAgInfiniiVisionSerialBus3SENTTrigger.)
Public property | Mode | Sets and Gets the SENT trigger mode setting.
Public property | SlowChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface. (Inherited from IAgInfiniiVisionSerialBus3SENTTrigger.)
Public property | Tolerance | Sets and Gets the tolerance variation percent setting.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | FastChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerFastChannel interface. (Inherited from IAgInfiniiVisionSerialBus3SENTTrigger.)
Public property | Mode | Sets and Gets the SENT trigger mode setting.
Public property | SlowChannel | Pointer to the IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel interface. (Inherited from IAgInfiniiVisionSerialBus3SENTTrigger.)
Public property | Tolerance | Sets and Gets the tolerance variation percent setting.
Top


IAgInfiniiVisionSerialBuses2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses2 Interface
See Also

IAgInfiniiVisionSerialBuses2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBuses2
   Inherits IAgInfiniiVision2SerialBuses
C#
public interface IAgInfiniiVisionSerialBuses2 : IAgInfiniiVision2SerialBuses
Visual C++
__interface IAgInfiniiVisionSerialBuses2 : IAgInfiniiVision2SerialBuses

Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top


IAgInfiniiVisionSerialBuses3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses3 Interface
See Also

IAgInfiniiVisionSerialBuses3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBuses3
   Inherits IAgInfiniiVisionSerialBuses2
C#
public interface IAgInfiniiVisionSerialBuses3 : IAgInfiniiVisionSerialBuses2
Visual C++
__interface IAgInfiniiVisionSerialBuses3 : IAgInfiniiVisionSerialBuses2

Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses2.)
Public property | Item3 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses2.)
Public property | Item3 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top


IAgInfiniiVisionSerialBuses4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSerialBuses4 Interface
See Also

IAgInfiniiVisionSerialBuses4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSerialBuses4
   Inherits IAgInfiniiVisionSerialBuses3
C#
public interface IAgInfiniiVisionSerialBuses4 : IAgInfiniiVisionSerialBuses3
Visual C++
__interface IAgInfiniiVisionSerialBuses4 : IAgInfiniiVisionSerialBuses3

Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses2.)
Public property | Item3 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses3.)
Public property | Item4 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Read Only - Returns the number of serial buses. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Item2 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses2.)
Public property | Item3 | Pointer to the IAgInfiniiVisionSerialBus interface. (Inherited from IAgInfiniiVisionSerialBuses3.)
Public property | Item4 | Pointer to the IAgInfiniiVisionSerialBus interface.
Public property | Lister | Pointer to the IAgInfiniiVision2SerialBusesLister interface. (Inherited from IAgInfiniiVision2SerialBuses.)
Public property | Name | Read Only - Returns the serial bus name for a given index. (Inherited from IAgInfiniiVision2SerialBuses.)
Top


IAgInfiniiVisionStatus Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionStatus Interface
See Also

IAgInfiniiVisionStatus interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionStatus
C#
public interface IAgInfiniiVisionStatus
Visual C++
__interface IAgInfiniiVisionStatus

Properties

 | Name | Description
Public property | Register | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Public property | SerialPoll | Read Only - Serial poll the instrument status byte.
Top

Methods

 | Name | Description
Public method | Clear | Clears all event registers and error queue. The enable registers are unaffected.
Public method | ConfigureServiceRequest | Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.
Public method | Preset | Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Clear | Clears all event registers and error queue. The enable registers are unaffected.
Public method | ConfigureServiceRequest | Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.
Public method | Preset | Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.
Top


Properties

 | Name | Description
Public property | Register | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Public property | SerialPoll | Read Only - Serial poll the instrument status byte.
Top


IAgInfiniiVisionSystem Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem Interface
See Also

IAgInfiniiVisionSystem interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSystem
C#
public interface IAgInfiniiVisionSystem
Visual C++
__interface IAgInfiniiVisionSystem

Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface.
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status
Public property | SerialNumber | Read Only - Instrument serial number.
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.
Top

Methods

 | Name | Description
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.
Public method | PutState | Writes binary instrument state as saved by GetState method.
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory.
Public method | SaveState | Save the instrument's state to the instrument's internal memory.
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.
Public method | PutState | Writes binary instrument state as saved by GetState method.
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory.
Public method | SaveState | Save the instrument's state to the instrument's internal memory.
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.
Top


Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface.
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status
Public property | SerialNumber | Read Only - Instrument serial number.
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.
Top


IAgInfiniiVisionSystem2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem2 Interface
See Also

IAgInfiniiVisionSystem2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSystem2
   Inherits IAgInfiniiVisionSystem
C#
public interface IAgInfiniiVisionSystem2 : IAgInfiniiVisionSystem
Visual C++
__interface IAgInfiniiVisionSystem2 : IAgInfiniiVisionSystem

Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen.
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top

Methods

 | Name | Description
Public method | ClearIO | Performs an IEEE 488.1-style clear of the device.
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded. (Inherited from IAgInfiniiVisionSystem.)
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time. (Inherited from IAgInfiniiVisionSystem.)
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter. (Inherited from IAgInfiniiVisionSystem.)
Public method | PutState | Writes binary instrument state as saved by GetState method. (Inherited from IAgInfiniiVisionSystem.)
Public method | ReadBytes | Reads a complete response from the instrument and returns it as an array of bytes.
Public method | ReadString | Reads a complete response from the instrument and returns it as a string.
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | SaveState | Save the instrument's state to the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired. (Inherited from IAgInfiniiVisionSystem.)
Public method | WriteBytes | Write an array of bytes to the device.
Public method | WriteString | Write a string to the device.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ClearIO | Performs an IEEE 488.1-style clear of the device.
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded. (Inherited from IAgInfiniiVisionSystem.)
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time. (Inherited from IAgInfiniiVisionSystem.)
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter. (Inherited from IAgInfiniiVisionSystem.)
Public method | PutState | Writes binary instrument state as saved by GetState method. (Inherited from IAgInfiniiVisionSystem.)
Public method | ReadBytes | Reads a complete response from the instrument and returns it as an array of bytes.
Public method | ReadString | Reads a complete response from the instrument and returns it as a string.
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | SaveState | Save the instrument's state to the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired. (Inherited from IAgInfiniiVisionSystem.)
Public method | WriteBytes | Write an array of bytes to the device.
Public method | WriteString | Write a string to the device.
Top


Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen.
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top


IAgInfiniiVisionSystem3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem3 Interface
See Also

IAgInfiniiVisionSystem3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSystem3
   Inherits IAgInfiniiVisionSystem2
C#
public interface IAgInfiniiVisionSystem3 : IAgInfiniiVisionSystem2
Visual C++
__interface IAgInfiniiVisionSystem3 : IAgInfiniiVisionSystem2

Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | Precision | Pointer to the IAgInfiniiVisionSystem3Precision interface.
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen. (Inherited from IAgInfiniiVisionSystem2.)
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top

Methods

 | Name | Description
Public method | ClearIO | Performs an IEEE 488.1-style clear of the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded. (Inherited from IAgInfiniiVisionSystem.)
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time. (Inherited from IAgInfiniiVisionSystem.)
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter. (Inherited from IAgInfiniiVisionSystem.)
Public method | PutState | Writes binary instrument state as saved by GetState method. (Inherited from IAgInfiniiVisionSystem.)
Public method | ReadBytes | Reads a complete response from the instrument and returns it as an array of bytes. (Inherited from IAgInfiniiVisionSystem2.)
Public method | ReadString | Reads a complete response from the instrument and returns it as a string. (Inherited from IAgInfiniiVisionSystem2.)
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | SaveState | Save the instrument's state to the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired. (Inherited from IAgInfiniiVisionSystem.)
Public method | WriteBytes | Write an array of bytes to the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | WriteString | Write a string to the device. (Inherited from IAgInfiniiVisionSystem2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | Precision | Pointer to the IAgInfiniiVisionSystem3Precision interface.
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen. (Inherited from IAgInfiniiVisionSystem2.)
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top


IAgInfiniiVisionSystem3Precision Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem3Precision Interface
See Also

IAgInfiniiVisionSystem3Precision interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSystem3Precision
C#
public interface IAgInfiniiVisionSystem3Precision
Visual C++
__interface IAgInfiniiVisionSystem3Precision

Properties

 | Name | Description
Public property | Enabled | Enables or disables the oscilloscope's precision analysis setting.
Public property | RecordLength | The length of the precision analysis record (when precision measurements and math functions mode is enabled).
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Enabled | Enables or disables the oscilloscope's precision analysis setting.
Public property | RecordLength | The length of the precision analysis record (when precision measurements and math functions mode is enabled).
Top


IAgInfiniiVisionSystem4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionSystem4 Interface
See Also

IAgInfiniiVisionSystem4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionSystem4
   Inherits IAgInfiniiVisionSystem3
C#
public interface IAgInfiniiVisionSystem4 : IAgInfiniiVisionSystem3
Visual C++
__interface IAgInfiniiVisionSystem4 : IAgInfiniiVisionSystem3

Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | IOTimeout | The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | Precision | Pointer to the IAgInfiniiVisionSystem3Precision interface. (Inherited from IAgInfiniiVisionSystem3.)
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen. (Inherited from IAgInfiniiVisionSystem2.)
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top

Methods

 | Name | Description
Public method | ClearIO | Performs an IEEE 488.1-style clear of the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded. (Inherited from IAgInfiniiVisionSystem.)
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time. (Inherited from IAgInfiniiVisionSystem.)
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter. (Inherited from IAgInfiniiVisionSystem.)
Public method | PutState | Writes binary instrument state as saved by GetState method. (Inherited from IAgInfiniiVisionSystem.)
Public method | ReadBytes | Reads a complete response from the instrument and returns it as an array of bytes. (Inherited from IAgInfiniiVisionSystem2.)
Public method | ReadBytes2 | Reads a complete response from the instrument and returns it as an array of bytes.
Public method | ReadString | Reads a complete response from the instrument and returns it as a string. (Inherited from IAgInfiniiVisionSystem2.)
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | SaveState | Save the instrument's state to the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired. (Inherited from IAgInfiniiVisionSystem.)
Public method | WriteBytes | Write an array of bytes to the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | WriteBytes2 | Write an array of bytes to the device.
Public method | WriteString | Write a string to the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | WriteString2 | Write a string to the device.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | ClearIO | Performs an IEEE 488.1-style clear of the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | DisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded. (Inherited from IAgInfiniiVisionSystem.)
Public method | EnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time. (Inherited from IAgInfiniiVisionSystem.)
Public method | GetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter. (Inherited from IAgInfiniiVisionSystem.)
Public method | PutState | Writes binary instrument state as saved by GetState method. (Inherited from IAgInfiniiVisionSystem.)
Public method | ReadBytes | Reads a complete response from the instrument and returns it as an array of bytes. (Inherited from IAgInfiniiVisionSystem2.)
Public method | ReadBytes2 | Reads a complete response from the instrument and returns it as an array of bytes.
Public method | ReadString | Reads a complete response from the instrument and returns it as a string. (Inherited from IAgInfiniiVisionSystem2.)
Public method | RecallState | Restore the instrument to a state previously stored in the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | SaveState | Save the instrument's state to the instrument's internal memory. (Inherited from IAgInfiniiVisionSystem.)
Public method | WaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired. (Inherited from IAgInfiniiVisionSystem.)
Public method | WriteBytes | Write an array of bytes to the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | WriteBytes2 | Write an array of bytes to the device.
Public method | WriteString | Write a string to the device. (Inherited from IAgInfiniiVisionSystem2.)
Public method | WriteString2 | Write a string to the device.
Top


Properties

 | Name | Description
Public property | Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month. (Inherited from IAgInfiniiVisionSystem.)
Public property | DirectIO | Read Only - References a pointer to the IFormattedIO488 interface associated with the I/O object used by the driver. The client can use this interface to communicate directly to the instrument using all the capabilities of the I/O interface. (Inherited from IAgInfiniiVisionSystem.)
Public property | IOTimeout | The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.
Public property | Message | Writes a message(excluding quotation marks) to a text box in the center of the display (Inherited from IAgInfiniiVisionSystem.)
Public property | Precision | Pointer to the IAgInfiniiVisionSystem3Precision interface. (Inherited from IAgInfiniiVisionSystem3.)
Public property | ProtectionEnabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status (Inherited from IAgInfiniiVisionSystem.)
Public property | SerialNumber | Read Only - Instrument serial number. (Inherited from IAgInfiniiVisionSystem.)
Public property | Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999. (Inherited from IAgInfiniiVisionSystem.)
Public property | TimeoutMilliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property. (Inherited from IAgInfiniiVisionSystem.)
Public property | TouchScreenEnabled | Disables or enables the touchscreen. (Inherited from IAgInfiniiVisionSystem2.)
Public property | TraceEnabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. (Inherited from IAgInfiniiVisionSystem.)
Top


IAgInfiniiVisionTimebase Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebase Interface
See Also

IAgInfiniiVisionTimebase interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTimebase
C#
public interface IAgInfiniiVisionTimebase
Visual C++
__interface IAgInfiniiVisionTimebase

Properties

 | Name | Description
Public property | HorizontalScale | Horizontal scale or seconds per division for the main window.
Public property | Mode | Current time base mode.
Public property | TimeReference | Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen
Public property | VernierEnabled | Time base control's vernier.
Public property | Window | Pointer to the IAgInfiniiVisionTimebaseWindow interface.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | HorizontalScale | Horizontal scale or seconds per division for the main window.
Public property | Mode | Current time base mode.
Public property | TimeReference | Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen
Public property | VernierEnabled | Time base control's vernier.
Public property | Window | Pointer to the IAgInfiniiVisionTimebaseWindow interface.
Top


IAgInfiniiVisionTimebaseWindow Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTimebaseWindow Interface
See Also

IAgInfiniiVisionTimebaseWindow interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTimebaseWindow
C#
public interface IAgInfiniiVisionTimebaseWindow
Visual C++
__interface IAgInfiniiVisionTimebaseWindow

Properties

 | Name | Description
Public property | HorizontalPosition | Horizontal window position in the zoomed view of the main sweep.
Public property | HorizontalScale | Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window
Public property | Range | Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | HorizontalPosition | Horizontal window position in the zoomed view of the main sweep.
Public property | HorizontalScale | Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window
Public property | Range | Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.
Top


IAgInfiniiVisionTrigger Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger Interface
See Also

IVI Scope class-compliant trigger interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger
C#
public interface IAgInfiniiVisionTrigger
Visual C++
__interface IAgInfiniiVisionTrigger

Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface.
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Public property | Coupling | How the oscilloscope couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds.
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts.
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source.
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface.
Public property | Type | The kind of event that triggers the oscilloscope.
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface.
Top

Methods

 | Name | Description
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds.
Top


Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface.
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Public property | Coupling | How the oscilloscope couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds.
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts.
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source.
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface.
Public property | Type | The kind of event that triggers the oscilloscope.
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface.
Top


IAgInfiniiVisionTrigger2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2 Interface
See Also

IAgInfiniiVisionTrigger2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2
   Inherits IAgInfiniiVisionTrigger
C#
public interface IAgInfiniiVisionTrigger2 : IAgInfiniiVisionTrigger
Visual C++
__interface IAgInfiniiVisionTrigger2 : IAgInfiniiVisionTrigger

Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface.
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface.
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface.
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface.
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface.
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface.
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Top

Methods

 | Name | Description
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.
Top


Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface.
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface.
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface.
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface.
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface.
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface.
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Top


IAgInfiniiVisionTrigger2Delay Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Delay Interface
See Also

IAgInfiniiVisionTrigger2Delay interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2Delay
C#
public interface IAgInfiniiVisionTrigger2Delay
Visual C++
__interface IAgInfiniiVisionTrigger2Delay

Properties

 | Name | Description
Public property | ArmingSlope | Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.
Public property | ArmingSource | Selects the input used for the arming edge in the Edge Then Edge trigger.
Public property | EdgeCount | Sets/Gets the Nth edge of the trigger source to trigger on
Public property | Slope | Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.
Public property | Time | Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.
Top

Methods

 | Name | Description
Public method | Configure | Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.
Top


Properties

 | Name | Description
Public property | ArmingSlope | Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.
Public property | ArmingSource | Selects the input used for the arming edge in the Edge Then Edge trigger.
Public property | EdgeCount | Sets/Gets the Nth edge of the trigger source to trigger on
Public property | Slope | Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.
Public property | Time | Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.
Top


IAgInfiniiVisionTrigger2EdgeBurst Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2EdgeBurst Interface
See Also

IAgInfiniiVisionTrigger2EdgeBurst interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2EdgeBurst
C#
public interface IAgInfiniiVisionTrigger2EdgeBurst
Visual C++
__interface IAgInfiniiVisionTrigger2EdgeBurst

Properties

 | Name | Description
Public property | IdleTime | Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.
Public property | NthEdge | Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.
Public property | Slope | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.
Top

Methods

 | Name | Description
Public method | Configure | Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.
Top


Properties

 | Name | Description
Public property | IdleTime | Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.
Public property | NthEdge | Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.
Public property | Slope | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.
Top


IAgInfiniiVisionTrigger2OR Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2OR Interface
See Also

IAgInfiniiVisionTrigger2OR interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2OR
C#
public interface IAgInfiniiVisionTrigger2OR
Visual C++
__interface IAgInfiniiVisionTrigger2OR

Properties

 | Name | Description
Public property | EdgePattern | Specifies the edges to include in the OR'ed edge trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | EdgePattern | Specifies the edges to include in the OR'ed edge trigger.
Top


IAgInfiniiVisionTrigger2SetupAndHold Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2SetupAndHold Interface
See Also

IAgInfiniiVisionTrigger2SetupAndHold interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2SetupAndHold
C#
public interface IAgInfiniiVisionTrigger2SetupAndHold
Visual C++
__interface IAgInfiniiVisionTrigger2SetupAndHold

Properties

 | Name | Description
Public property | ClockSource | Selects the channel used to produce the trigger.
Public property | DataSource | Selects the channel used to produce the trigger.
Public property | HoldTime | Sets/Gets the hold time.
Public property | SetupTime | Sets/Gets the setup time.
Public property | Slope | Selects the clock signal's active edge.
Top

Methods

 | Name | Description
Public method | Configure | Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.
Top


Properties

 | Name | Description
Public property | ClockSource | Selects the channel used to produce the trigger.
Public property | DataSource | Selects the channel used to produce the trigger.
Public property | HoldTime | Sets/Gets the hold time.
Public property | SetupTime | Sets/Gets the setup time.
Public property | Slope | Selects the clock signal's active edge.
Top


IAgInfiniiVisionTrigger2Transition Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2Transition Interface
See Also

IAgInfiniiVisionTrigger2Transition interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2Transition
C#
public interface IAgInfiniiVisionTrigger2Transition
Visual C++
__interface IAgInfiniiVisionTrigger2Transition

Properties

 | Name | Description
Public property | Condition | Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.
Public property | QualifierTime | Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.
Public property | Slope | Specifies a Positive rising edge or a Negative falling edge.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for the transition trigger. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for the transition trigger. The units are volts.
Top

Methods

 | Name | Description
Public method | Configure | Configures the source, slope, condition and qualifier time parameters for the Transition trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the source, slope, condition and qualifier time parameters for the Transition trigger.
Top


Properties

 | Name | Description
Public property | Condition | Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.
Public property | QualifierTime | Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.
Public property | Slope | Specifies a Positive rising edge or a Negative falling edge.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for the transition trigger. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for the transition trigger. The units are volts.
Top


IAgInfiniiVisionTrigger2USB Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger2USB Interface
See Also

IAgInfiniiVisionTrigger2USB interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger2USB
C#
public interface IAgInfiniiVisionTrigger2USB
Visual C++
__interface IAgInfiniiVisionTrigger2USB

Properties

 | Name | Description
Public property | Condition | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.
Public property | DMinusSource | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.
Public property | DPlusSource | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.
Public property | Speed | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Top

Methods

 | Name | Description
Public method | Configure | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.
Top


Properties

 | Name | Description
Public property | Condition | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.
Public property | DMinusSource | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.
Public property | DPlusSource | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.
Public property | Speed | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Top


IAgInfiniiVisionTrigger3 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3 Interface
See Also

IAgInfiniiVisionTrigger3 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger3
   Inherits IAgInfiniiVisionTrigger2
C#
public interface IAgInfiniiVisionTrigger3 : IAgInfiniiVisionTrigger2
Visual C++
__interface IAgInfiniiVisionTrigger3 : IAgInfiniiVisionTrigger2

Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface.
Top

Methods

 | Name | Description
Public method | AutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key. (Inherited from IAgInfiniiVisionTrigger2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | AutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key. (Inherited from IAgInfiniiVisionTrigger2.)
Top


Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface.
Top


IAgInfiniiVisionTrigger3Zone Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger3Zone Interface
See Also

IAgInfiniiVisionTrigger3Zone interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger3Zone
C#
public interface IAgInfiniiVisionTrigger3Zone
Visual C++
__interface IAgInfiniiVisionTrigger3Zone

Properties

 | Name | Description
Public property | Enabled | Specifies the state for Zone 1 or Zone 2.
Public property | Mode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Public property | Source | Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>
Public property | Validity | Read Only - Query returns the validity of Zone 1 or Zone 2.
Top

Methods

 | Name | Description
Public method | GetZonePlacement | Queries the size and location of Zone 1 or Zone 2.
Public method | SetZonePlacement | Sets the size and location of Zone 1 or Zone 2.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetZonePlacement | Queries the size and location of Zone 1 or Zone 2.
Public method | SetZonePlacement | Sets the size and location of Zone 1 or Zone 2.
Top


Properties

 | Name | Description
Public property | Enabled | Specifies the state for Zone 1 or Zone 2.
Public property | Mode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Public property | Source | Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>
Public property | Validity | Read Only - Query returns the validity of Zone 1 or Zone 2.
Top


IAgInfiniiVisionTrigger4 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4 Interface
See Also

IAgInfiniiVisionTrigger4 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger4
   Inherits IAgInfiniiVisionTrigger3
C#
public interface IAgInfiniiVisionTrigger4 : IAgInfiniiVisionTrigger3
Visual C++
__interface IAgInfiniiVisionTrigger4 : IAgInfiniiVisionTrigger3

Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | PXI | Pointer to the IAgInfiniiVisionTrigger4PXI interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface. (Inherited from IAgInfiniiVisionTrigger3.)
Top

Methods

 | Name | Description
Public method | AutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values. (Inherited from IAgInfiniiVisionTrigger3.)
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key. (Inherited from IAgInfiniiVisionTrigger2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | PXI | Pointer to the IAgInfiniiVisionTrigger4PXI interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface. (Inherited from IAgInfiniiVisionTrigger3.)
Top


IAgInfiniiVisionTrigger4PXI Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger4PXI Interface
See Also

IAgInfiniiVisionTrigger4PXI interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger4PXI
C#
public interface IAgInfiniiVisionTrigger4PXI
Visual C++
__interface IAgInfiniiVisionTrigger4PXI

Properties

 | Name | Description
Public property | Mode | Sets and gets the PXI trigger mode to bus master/slave or off.
Public property | SlaveArmLine | Sets and gets the PXI slave to master arm line or off.
Public property | Slot | Sets and gets the PXI master slot number.
Public property | TriggerLine | Sets and gets the PXI master to slave trigger line.
Top

Methods

 | Name | Description
Public method | GetMasterArmLine | Queries the PXI slave to master arm lines on or off.
Public method | SetMasterArmLine | Sets the PXI slave to master arm lines on or off.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | GetMasterArmLine | Queries the PXI slave to master arm lines on or off.
Public method | SetMasterArmLine | Sets the PXI slave to master arm lines on or off.
Top


Properties

 | Name | Description
Public property | Mode | Sets and gets the PXI trigger mode to bus master/slave or off.
Public property | SlaveArmLine | Sets and gets the PXI slave to master arm line or off.
Public property | Slot | Sets and gets the PXI master slot number.
Public property | TriggerLine | Sets and gets the PXI master to slave trigger line.
Top


IAgInfiniiVisionTrigger5 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5 Interface
See Also

IAgInfiniiVisionTrigger5 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger5
   Inherits IAgInfiniiVisionTrigger4
C#
public interface IAgInfiniiVisionTrigger5 : IAgInfiniiVisionTrigger4
Visual C++
__interface IAgInfiniiVisionTrigger5 : IAgInfiniiVisionTrigger4

Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | PXI | Pointer to the IAgInfiniiVisionTrigger4PXI interface. (Inherited from IAgInfiniiVisionTrigger4.)
Public property | RandomHoldoff | Pointer to the IAgInfiniiVisionTrigger5RandomHoldoff interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface. (Inherited from IAgInfiniiVisionTrigger3.)
Top

Methods

 | Name | Description
Public method | AutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values. (Inherited from IAgInfiniiVisionTrigger3.)
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public method | ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key. (Inherited from IAgInfiniiVisionTrigger2.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AcLine | Pointer to the IAgInfiniiVisionTriggerAcLine interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Coupling | How the oscilloscope couples the trigger source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Delay | Pointer to the IAgInfiniiVisionTrigger2Delay interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | EdgeBurst | Pointer to the IAgInfiniiVisionTrigger2EdgeBurst interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | HFRejectFilterEnabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Holdoff | The length of time to wait after detecting a trigger before enabling the trigger subsystem again. The units are seconds. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Level | Voltage threshold for the trigger subsystem. The units are volts. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Modifier | Trigger sweep mode. The trigger modifier determines the oscilloscope's behavior in the absence of a trigger. (Inherited from IAgInfiniiVisionTrigger.)
Public property | NoiseRejectFilterEnabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | OR | Pointer to the IAgInfiniiVisionTrigger2OR interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Pattern | Pointer to the IAgInfiniiVisionTriggerPattern interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | PXI | Pointer to the IAgInfiniiVisionTrigger4PXI interface. (Inherited from IAgInfiniiVisionTrigger4.)
Public property | RandomHoldoff | Pointer to the IAgInfiniiVisionTrigger5RandomHoldoff interface.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface (Inherited from IAgInfiniiVisionTrigger.)
Public property | SetupAndHold | Pointer to the IAgInfiniiVisionTrigger2SetupAndHold interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Source | Input Source for trigger operations. Source is dependent on Trigger Type. Set Trigger Type before setting source. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Transition | Pointer to the IAgInfiniiVisionTrigger2Transition interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | TV | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | TV2 | Pointer to the IAgInfiniiVisionTriggerTV interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Type | The kind of event that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTrigger.)
Public property | USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Pointer to the IAgInfiniiVisionTrigger2USB interface. (Inherited from IAgInfiniiVisionTrigger2.)
Public property | Width | Pointer to the IAgInfiniiVisionTriggerWidth interface. (Inherited from IAgInfiniiVisionTrigger.)
Public property | Zone | Pointer to the IAgInfiniiVisionTrigger3Zone interface. (Inherited from IAgInfiniiVisionTrigger3.)
Top


IAgInfiniiVisionTrigger5RandomHoldoff Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTrigger5RandomHoldoff Interface
See Also

IAgInfiniiVisionTrigger5RandomHoldoff interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTrigger5RandomHoldoff
C#
public interface IAgInfiniiVisionTrigger5RandomHoldoff
Visual C++
__interface IAgInfiniiVisionTrigger5RandomHoldoff

Properties

 | Name | Description
Public property | Enabled | Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.
Public property | TimeMax | The maximum random holdoff time in seconds.
Public property | TimeMin | The minimum random holdoff time in seconds.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Enabled | Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.
Public property | TimeMax | The maximum random holdoff time in seconds.
Public property | TimeMin | The minimum random holdoff time in seconds.
Top


IAgInfiniiVisionTriggerAcLine Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerAcLine Interface
See Also

IAgInfiniiVisionTriggerAcLine interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerAcLine
C#
public interface IAgInfiniiVisionTriggerAcLine
Visual C++
__interface IAgInfiniiVisionTriggerAcLine

Properties

 | Name | Description
Public property | Slope | The slope of the zero crossing upon which the scope triggers.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Slope | The slope of the zero crossing upon which the scope triggers.
Top


IAgInfiniiVisionTriggerEdge Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerEdge Interface
See Also

IVI Scope class-compliant edge trigger interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerEdge
C#
public interface IAgInfiniiVisionTriggerEdge
Visual C++
__interface IAgInfiniiVisionTriggerEdge

Properties

 | Name | Description
Public property | RejectFilterType | Enable the type of reject filter.
Public property | Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top

Methods

 | Name | Description
Public method | Configure | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Top


Properties

 | Name | Description
Public property | RejectFilterType | Enable the type of reject filter.
Public property | Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top


IAgInfiniiVisionTriggerGlitch Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerGlitch Interface
See Also

IVI Scope class-compliant glitch trigger interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerGlitch
C#
public interface IAgInfiniiVisionTriggerGlitch
Visual C++
__interface IAgInfiniiVisionTriggerGlitch

Properties

 | Name | Description
Public property | Condition | Glitch condition determines whether it glitches less than or greater than the specified duration.
Public property | Level | Trigger level voltage for the active pulse width trigger.
Public property | Polarity | The polarity of the glitch that triggers the oscilloscope.
Public property | Width | Pulse width duration for the selected source. The units are seconds. Set condition to either GreaterThan or LessThan, prior to setting Width.
Top

Methods

 | Name | Description
Public method | Configure | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Public method | GetRange | READ ONLY- Gets the pulse width duration time for trigger source.
Public method | SetRange | Pulse width duration for the selected source.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Public method | GetRange | READ ONLY- Gets the pulse width duration time for trigger source.
Public method | SetRange | Pulse width duration for the selected source.
Top


Properties

 | Name | Description
Public property | Condition | Glitch condition determines whether it glitches less than or greater than the specified duration.
Public property | Level | Trigger level voltage for the active pulse width trigger.
Public property | Polarity | The polarity of the glitch that triggers the oscilloscope.
Public property | Width | Pulse width duration for the selected source. The units are seconds. Set condition to either GreaterThan or LessThan, prior to setting Width.
Top


IAgInfiniiVisionTriggerPattern Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerPattern Interface
See Also

IAgInfiniiVisionTriggerPattern interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerPattern
C#
public interface IAgInfiniiVisionTriggerPattern
Visual C++
__interface IAgInfiniiVisionTriggerPattern

Properties

 | Name | Description
Public property | AnalogPattern | The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Public property | Condition | The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.
Public property | DigitalPattern | The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Public property | MaxDuration | Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.
Public property | MinDuration | Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.
Top

Methods

 | Name | Description
Public method | Configure | Configures the pattern trigger
Public method | GetRange | Returns the duration time for the defined pattern.
Public method | SetRange | Duration for the defined pattern when the pattern condition is set to INRange or OUTRange
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the pattern trigger
Public method | GetRange | Returns the duration time for the defined pattern.
Public method | SetRange | Duration for the defined pattern when the pattern condition is set to INRange or OUTRange
Top


Properties

 | Name | Description
Public property | AnalogPattern | The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Public property | Condition | The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.
Public property | DigitalPattern | The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Public property | MaxDuration | Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.
Public property | MinDuration | Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.
Top


IAgInfiniiVisionTriggerRunt Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerRunt Interface
See Also

IVI Scope class-compliant runt trigger interface

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerRunt
C#
public interface IAgInfiniiVisionTriggerRunt
Visual C++
__interface IAgInfiniiVisionTriggerRunt

Properties

 | Name | Description
Public property | Condition | Condition used for specifying runt pulse widths.
Public property | Polarity | The polarity of the runt that triggers the oscilloscope.
Public property | QualifierTime | Time used for triggering on runt pulses whose width is greater than or less than the specified time value.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Top

Methods

 | Name | Description
Public method | Configure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Top


Properties

 | Name | Description
Public property | Condition | Condition used for specifying runt pulse widths.
Public property | Polarity | The polarity of the runt that triggers the oscilloscope.
Public property | QualifierTime | Time used for triggering on runt pulses whose width is greater than or less than the specified time value.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Top


IAgInfiniiVisionTriggerTV Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV Interface
See Also

IAgInfiniiVisionTriggerTV interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerTV
C#
public interface IAgInfiniiVisionTriggerTV
Visual C++
__interface IAgInfiniiVisionTriggerTV

Properties

 | Name | Description
Public property | Event | The TV trigger mode and field.
Public property | LineNumber | The Line number which allows triggering on a specific line of video. The line number limit varies with the signal format and event.
Public property | Polarity | The polarity of the TV that triggers the oscilloscope.
Public property | SignalFormat | The format of TV signal on which the oscilloscope triggers. Currently, only NTSC, PAL, PAL-M and SECAM are supported.
Top

Methods

 | Name | Description
Public method | Configure | Configures the TV Trigger parameters.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the TV Trigger parameters.
Top


Properties

 | Name | Description
Public property | Event | The TV trigger mode and field.
Public property | LineNumber | The Line number which allows triggering on a specific line of video. The line number limit varies with the signal format and event.
Public property | Polarity | The polarity of the TV that triggers the oscilloscope.
Public property | SignalFormat | The format of TV signal on which the oscilloscope triggers. Currently, only NTSC, PAL, PAL-M and SECAM are supported.
Top


IAgInfiniiVisionTriggerTV2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2 Interface
See Also

IAgInfiniiVisionTriggerTV2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerTV2
   Inherits IAgInfiniiVisionTriggerTV
C#
public interface IAgInfiniiVisionTriggerTV2 : IAgInfiniiVisionTriggerTV
Visual C++
__interface IAgInfiniiVisionTriggerTV2 : IAgInfiniiVisionTriggerTV

Properties

 | Name | Description
Public property | Event | The TV trigger mode and field. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | LineNumber | The Line number which allows triggering on a specific line of video. The line number limit varies with the signal format and event. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | Polarity | The polarity of the TV that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | SignalFormat | The format of TV signal on which the oscilloscope triggers. Currently, only NTSC, PAL, PAL-M and SECAM are supported. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | UDTV | Pointer to the IAgInfiniiVisionTriggerTV2UDTV interface.
Top

Methods

 | Name | Description
Public method | Configure | Configures the TV Trigger parameters. (Inherited from IAgInfiniiVisionTriggerTV.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Event | The TV trigger mode and field. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | LineNumber | The Line number which allows triggering on a specific line of video. The line number limit varies with the signal format and event. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | Polarity | The polarity of the TV that triggers the oscilloscope. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | SignalFormat | The format of TV signal on which the oscilloscope triggers. Currently, only NTSC, PAL, PAL-M and SECAM are supported. (Inherited from IAgInfiniiVisionTriggerTV.)
Public property | UDTV | Pointer to the IAgInfiniiVisionTriggerTV2UDTV interface.
Top


IAgInfiniiVisionTriggerTV2UDTV Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerTV2UDTV Interface
See Also

IAgInfiniiVisionTriggerTV2UDTV interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerTV2UDTV
C#
public interface IAgInfiniiVisionTriggerTV2UDTV
Visual C++
__interface IAgInfiniiVisionTriggerTV2UDTV

Properties

 | Name | Description
Public property | EdgeNumber | Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.
Public property | HorizontalSyncEnabled | Enables or disables the horizontal sync control in the Generic video trigger.
Public property | HorizontalSyncTime | When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.
Public property | MinTime | Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | EdgeNumber | Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.
Public property | HorizontalSyncEnabled | Enables or disables the horizontal sync control in the Generic video trigger.
Public property | HorizontalSyncTime | When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.
Public property | MinTime | Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.
Top


IAgInfiniiVisionTriggerWidth Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionTriggerWidth Interface
See Also

IAgInfiniiVisionTriggerWidth interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionTriggerWidth
C#
public interface IAgInfiniiVisionTriggerWidth
Visual C++
__interface IAgInfiniiVisionTriggerWidth

Properties

 | Name | Description
Public property | Condition | Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.
Public property | Polarity | The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.
Public property | ThresholdHigh | The high width threshold time in seconds.
Public property | ThresholdLow | The low width threshold time in seconds.
Top

Methods

 | Name | Description
Public method | Configure | Configures the width trigger.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the width trigger.
Top


Properties

 | Name | Description
Public property | Condition | Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.
Public property | Polarity | The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.
Public property | ThresholdHigh | The high width threshold time in seconds.
Public property | ThresholdLow | The low width threshold time in seconds.
Top


IAgInfiniiVisionWaveform Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform Interface
See Also

IAgInfiniiVisionWaveform interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveform
C#
public interface IAgInfiniiVisionWaveform
Visual C++
__interface IAgInfiniiVisionWaveform

Properties

 | Name | Description
Public property | ByteOrder | Output sequence of the WORD data. It decides which significant byte to be transmitted first.
Public property | DataFormat | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.
Public property | PointCount | Number of waveform points to be transferred with the Waveform data
Public property | PointMode | Type of data record to be transferred
Public property | Source | Source for the waveform.
Public property | UnsignedModeEnable | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.
Public property | View | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.
Public property | XIncrement | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.
Public property | XOrigin | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.
Public property | XReference | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value
Public property | YIncrement | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".
Public property | YOrigin | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.
Public property | YReference | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii
Top

Methods

 | Name | Description
Public method | Preamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Preamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel
Top


Properties

 | Name | Description
Public property | ByteOrder | Output sequence of the WORD data. It decides which significant byte to be transmitted first.
Public property | DataFormat | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.
Public property | PointCount | Number of waveform points to be transferred with the Waveform data
Public property | PointMode | Type of data record to be transferred
Public property | Source | Source for the waveform.
Public property | UnsignedModeEnable | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.
Public property | View | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.
Public property | XIncrement | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.
Public property | XOrigin | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.
Public property | XReference | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value
Public property | YIncrement | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".
Public property | YOrigin | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.
Public property | YReference | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii
Top


IAgInfiniiVisionWaveform2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveform2 Interface
See Also

IAgInfiniiVisionWaveform2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveform2
   Inherits IAgInfiniiVisionWaveform
C#
public interface IAgInfiniiVisionWaveform2 : IAgInfiniiVisionWaveform
Visual C++
__interface IAgInfiniiVisionWaveform2 : IAgInfiniiVisionWaveform

Properties

 | Name | Description
Public property | ByteOrder | Output sequence of the WORD data. It decides which significant byte to be transmitted first. (Inherited from IAgInfiniiVisionWaveform.)
Public property | DataFormat | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope. (Inherited from IAgInfiniiVisionWaveform.)
Public property | PointCount | Number of waveform points to be transferred with the Waveform data (Inherited from IAgInfiniiVisionWaveform.)
Public property | PointMode | Type of data record to be transferred (Inherited from IAgInfiniiVisionWaveform.)
Public property | Source | Source for the waveform. (Inherited from IAgInfiniiVisionWaveform.)
Public property | SubSource | Selects the sub-source for those sources that have more than one possibility.
Public property | UnsignedModeEnable | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed. (Inherited from IAgInfiniiVisionWaveform.)
Public property | View | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XIncrement | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XOrigin | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XReference | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value (Inherited from IAgInfiniiVisionWaveform.)
Public property | YIncrement | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1". (Inherited from IAgInfiniiVisionWaveform.)
Public property | YOrigin | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference. (Inherited from IAgInfiniiVisionWaveform.)
Public property | YReference | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii (Inherited from IAgInfiniiVisionWaveform.)
Top

Methods

 | Name | Description
Public method | Preamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel (Inherited from IAgInfiniiVisionWaveform.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | ByteOrder | Output sequence of the WORD data. It decides which significant byte to be transmitted first. (Inherited from IAgInfiniiVisionWaveform.)
Public property | DataFormat | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope. (Inherited from IAgInfiniiVisionWaveform.)
Public property | PointCount | Number of waveform points to be transferred with the Waveform data (Inherited from IAgInfiniiVisionWaveform.)
Public property | PointMode | Type of data record to be transferred (Inherited from IAgInfiniiVisionWaveform.)
Public property | Source | Source for the waveform. (Inherited from IAgInfiniiVisionWaveform.)
Public property | SubSource | Selects the sub-source for those sources that have more than one possibility.
Public property | UnsignedModeEnable | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed. (Inherited from IAgInfiniiVisionWaveform.)
Public property | View | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XIncrement | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XOrigin | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference. (Inherited from IAgInfiniiVisionWaveform.)
Public property | XReference | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value (Inherited from IAgInfiniiVisionWaveform.)
Public property | YIncrement | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1". (Inherited from IAgInfiniiVisionWaveform.)
Public property | YOrigin | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference. (Inherited from IAgInfiniiVisionWaveform.)
Public property | YReference | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii (Inherited from IAgInfiniiVisionWaveform.)
Top


IAgInfiniiVisionWaveformGenerator Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator Interface
See Also

IAgInfiniiVisionWaveformGenerator interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveformGenerator
C#
public interface IAgInfiniiVisionWaveformGenerator
Visual C++
__interface IAgInfiniiVisionWaveformGenerator

Properties

 | Name | Description
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Public property | Function | Type of waveform.
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Public property | OutputEnabled | Enables/Disables waveform generator signal output.
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Top

Methods

 | Name | Description
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Top


Properties

 | Name | Description
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Public property | Function | Type of waveform.
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Public property | OutputEnabled | Enables/Disables waveform generator signal output.
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Top


IAgInfiniiVisionWaveformGenerator2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2 Interface
See Also

IAgInfiniiVisionWaveformGenerator2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveformGenerator2
   Inherits IAgInfiniiVisionWaveformGenerator
C#
public interface IAgInfiniiVisionWaveformGenerator2 : IAgInfiniiVisionWaveformGenerator
Visual C++
__interface IAgInfiniiVisionWaveformGenerator2 : IAgInfiniiVisionWaveformGenerator

Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal.
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Function | Type of waveform. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OutputEnabled | Enables/Disables waveform generator signal output. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Top

Methods

 | Name | Description
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal.
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveformGenerator2Arbitrary interface.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Function | Type of waveform. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OutputEnabled | Enables/Disables waveform generator signal output. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising. (Inherited from IAgInfiniiVisionWaveformGenerator.)
Top


IAgInfiniiVisionWaveformGenerator2Arbitrary Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2Arbitrary Interface
See Also

IAgInfiniiVisionWaveformGenerator2Arbitrary interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveformGenerator2Arbitrary
C#
public interface IAgInfiniiVisionWaveformGenerator2Arbitrary
Visual C++
__interface IAgInfiniiVisionWaveformGenerator2Arbitrary

Properties

 | Name | Description
Public property | Attribute | Pointer to the IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public property | ByteOrder | Specifies the byte order for binary transfers.
Public property | Interpolation | Enables or disables the Interpolation control.
Top

Methods

 | Name | Description
Public method | Reset | Clears the Arbitrary waveform memory and loads it with the default waveform.
Public method | SetData | Downloads an arbitrary waveform in floating-point values format.
Public method | SetDataDAC | Downloads an arbitrary waveform in integer (DAC) values.
Public method | Store | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | Reset | Clears the Arbitrary waveform memory and loads it with the default waveform.
Public method | SetData | Downloads an arbitrary waveform in floating-point values format.
Public method | SetDataDAC | Downloads an arbitrary waveform in integer (DAC) values.
Public method | Store | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top


Properties

 | Name | Description
Public property | Attribute | Pointer to the IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public property | ByteOrder | Specifies the byte order for binary transfers.
Public property | Interpolation | Enables or disables the Interpolation control.
Top


IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute Interface
See Also

IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute
C#
public interface IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute
Visual C++
__interface IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute

Properties

 | Name | Description
Public property | NumberOfPoints | Read Only - Queries the number of points used by the current Arbitrary waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | NumberOfPoints | Read Only - Queries the number of points used by the current Arbitrary waveform.
Top


IAgInfiniiVisionWaveGen Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen Interface
See Also

IAgInfiniiVisionWaveGen interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGen
C#
public interface IAgInfiniiVisionWaveGen
Visual C++
__interface IAgInfiniiVisionWaveGen

Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal.
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveGenArbitrary interface.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Public property | Function | Type of waveform.
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | Modulation | Pointer to the IAgInfiniiVisionWaveGenModulation interface.
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Public property | OutputEnabled | Enables or Disables waveform generator signal output.
Public property | OutputInverted | Specifies whether the waveform generator output is inverted or not.
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Public property | Tracking | Pointer to the IAgInfiniiVisionWaveGenTracking interface.
Top

Methods

 | Name | Description
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal.
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveGenArbitrary interface.
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Public property | Function | Type of waveform.
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Public property | Modulation | Pointer to the IAgInfiniiVisionWaveGenModulation interface.
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Public property | OutputEnabled | Enables or Disables waveform generator signal output.
Public property | OutputInverted | Specifies whether the waveform generator output is inverted or not.
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Public property | Tracking | Pointer to the IAgInfiniiVisionWaveGenTracking interface.
Top


IAgInfiniiVisionWaveGen2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2 Interface
See Also

IAgInfiniiVisionWaveGen2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGen2
   Inherits IAgInfiniiVisionWaveGen
C#
public interface IAgInfiniiVisionWaveGen2 : IAgInfiniiVisionWaveGen
Visual C++
__interface IAgInfiniiVisionWaveGen2 : IAgInfiniiVisionWaveGen

Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveGenArbitrary interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Function | Type of waveform. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Modulation | Pointer to the IAgInfiniiVisionWaveGenModulation interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputEnabled | Enables or Disables waveform generator signal output. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputInverted | Specifies whether the waveform generator output is inverted or not. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputMode | Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Tracking | Pointer to the IAgInfiniiVisionWaveGenTracking interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Tracking2 | Pointer to the IAgInfiniiVisionWaveGenTracking interface.
Top

Methods

 | Name | Description
Public method | OutputSingle | Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset. (Inherited from IAgInfiniiVisionWaveGen.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | OutputSingle | Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.
Public method | Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset. (Inherited from IAgInfiniiVisionWaveGen.)
Top


Properties

 | Name | Description
Public property | AdditionalNoise | Specifies the amount of noise to add to the currently selected signal. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Arbitrary | Pointer to the IAgInfiniiVisionWaveGenArbitrary interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | DutyCycle | Square wave duty cycle(20% to 80%) for Square waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Function | Type of waveform. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | HighVoltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | LowVoltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Modulation | Pointer to the IAgInfiniiVisionWaveGenModulation interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OffsetVoltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputEnabled | Enables or Disables waveform generator signal output. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputInverted | Specifies whether the waveform generator output is inverted or not. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputLoadImpedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | OutputMode | Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.
Public property | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms (Inherited from IAgInfiniiVisionWaveGen.)
Public property | PulseWidth | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | RampSymmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Tracking | Pointer to the IAgInfiniiVisionWaveGenTracking interface. (Inherited from IAgInfiniiVisionWaveGen.)
Public property | Tracking2 | Pointer to the IAgInfiniiVisionWaveGenTracking interface.
Top


IAgInfiniiVisionWaveGen2Tracking2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGen2Tracking2 Interface
See Also

IAgInfiniiVisionWaveGen2Tracking2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGen2Tracking2
   Inherits IAgInfiniiVisionWaveGenTracking
C#
public interface IAgInfiniiVisionWaveGen2Tracking2 : IAgInfiniiVisionWaveGenTracking
Visual C++
__interface IAgInfiniiVisionWaveGen2Tracking2 : IAgInfiniiVisionWaveGenTracking

Properties

 | Name | Description
Public property | AmplitudeEnabled | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | Enabled | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | FrequencyEnabled | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | Phase | Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.
Top

Methods

 | Name | Description
Public method | CopySignal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted). (Inherited from IAgInfiniiVisionWaveGenTracking.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AmplitudeEnabled | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | Enabled | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | FrequencyEnabled | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output. (Inherited from IAgInfiniiVisionWaveGenTracking.)
Public property | Phase | Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.
Top


IAgInfiniiVisionWaveGenArbitrary Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitrary Interface
See Also

IAgInfiniiVisionWaveformGenerator2Arbitrary interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenArbitrary
C#
public interface IAgInfiniiVisionWaveGenArbitrary
Visual C++
__interface IAgInfiniiVisionWaveGenArbitrary

Properties

 | Name | Description
Public property | Attribute | Pointer to the IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.
Public property | ByteOrder | Specifies the byte order for binary transfers.
Public property | Interpolation | Enables or disables the Interpolation control.
Top

Methods

 | Name | Description
Public method | Reset | Clears the Arbitrary waveform memory and loads it with the default waveform.
Public method | SetData | Downloads an arbitrary waveform in floating-point values format.
Public method | SetDataDAC | Downloads an arbitrary waveform in integer (DAC) values.
Public method | Store | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionWaveGenArbitraryAttribute Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenArbitraryAttribute Interface
See Also

IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenArbitraryAttribute
C#
public interface IAgInfiniiVisionWaveGenArbitraryAttribute
Visual C++
__interface IAgInfiniiVisionWaveGenArbitraryAttribute

Properties

 | Name | Description
Public property | NumberOfPoints | Read Only - Queries the number of points used by the current Arbitrary waveform.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


IAgInfiniiVisionWaveGenModulation Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulation Interface
See Also

IAgInfiniiVisionTrigger3Modulation interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenModulation
C#
public interface IAgInfiniiVisionWaveGenModulation
Visual C++
__interface IAgInfiniiVisionWaveGenModulation

Properties

 | Name | Description
Public property | AM | Pointer to the IAgInfiniiVisionTrigger3ModulationAM interface.
Public property | Enabled | Enables or disables modulated waveform generator output.
Public property | FM | Pointer to the IAgInfiniiVisionTrigger3ModulationFM interface.
Public property | FSK | Pointer to the IAgInfiniiVisionTrigger3ModulationFSK interface.
Public property | Function | Specifies the shape of the modulating signal.
Public property | RampSymmetry | Specifies the amount of time per cycle that the ramp waveform is rising.
Public property | Type | Specifies the modulation type.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | AM | Pointer to the IAgInfiniiVisionTrigger3ModulationAM interface.
Public property | Enabled | Enables or disables modulated waveform generator output.
Public property | FM | Pointer to the IAgInfiniiVisionTrigger3ModulationFM interface.
Public property | FSK | Pointer to the IAgInfiniiVisionTrigger3ModulationFSK interface.
Public property | Function | Specifies the shape of the modulating signal.
Public property | RampSymmetry | Specifies the amount of time per cycle that the ramp waveform is rising.
Public property | Type | Specifies the modulation type.
Top


IAgInfiniiVisionWaveGenModulationAM Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationAM Interface
See Also

IAgInfiniiVisionTrigger3ModulationAM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenModulationAM
C#
public interface IAgInfiniiVisionWaveGenModulationAM
Visual C++
__interface IAgInfiniiVisionWaveGenModulationAM

Properties

 | Name | Description
Public property | Depth | Specifies the amount of amplitude modulation.
Public property | Frequency | Specifies the frequency of the modulating signal. Frequency in Hz .
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Depth | Specifies the amount of amplitude modulation.
Public property | Frequency | Specifies the frequency of the modulating signal. Frequency in Hz .
Top


IAgInfiniiVisionWaveGenModulationFM Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFM Interface
See Also

IAgInfiniiVisionTrigger3ModulationFM interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenModulationFM
C#
public interface IAgInfiniiVisionWaveGenModulationFM
Visual C++
__interface IAgInfiniiVisionWaveGenModulationFM

Properties

 | Name | Description
Public property | Deviation | Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.
Public property | Frequency | Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Deviation | Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.
Public property | Frequency | Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.
Top


IAgInfiniiVisionWaveGenModulationFSK Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenModulationFSK Interface
See Also

IAgInfiniiVisionTrigger3ModulationFSK interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenModulationFSK
C#
public interface IAgInfiniiVisionWaveGenModulationFSK
Visual C++
__interface IAgInfiniiVisionWaveGenModulationFSK

Properties

 | Name | Description
Public property | Frequency | Specifies the "hop frequency". Hop frequency in Hz
Public property | Rate | Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Frequency | Specifies the "hop frequency". Hop frequency in Hz
Public property | Rate | Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.
Top


IAgInfiniiVisionWaveGens Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens Interface
See Also

IAgInfiniiVisionWaveGens interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGens
C#
public interface IAgInfiniiVisionWaveGens
Visual C++
__interface IAgInfiniiVisionWaveGens

Properties

 | Name | Description
Public property | Count | Returns the number of wavegens.
Public property | Item | Pointer to the IAgInfiniiVisionWaveGen interface.
Public property | Name | Returns the wavegen name for a given index.
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Returns the number of wavegens.
Public property | Item | Pointer to the IAgInfiniiVisionWaveGen interface.
Public property | Name | Returns the wavegen name for a given index.
Top


IAgInfiniiVisionWaveGens2 Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGens2 Interface
See Also

IAgInfiniiVisionWaveGens2 interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGens2
   Inherits IAgInfiniiVisionWaveGens
C#
public interface IAgInfiniiVisionWaveGens2 : IAgInfiniiVisionWaveGens
Visual C++
__interface IAgInfiniiVisionWaveGens2 : IAgInfiniiVisionWaveGens

Properties

 | Name | Description
Public property | Count | Returns the number of wavegens. (Inherited from IAgInfiniiVisionWaveGens.)
Public property | Item | Pointer to the IAgInfiniiVisionWaveGen interface. (Inherited from IAgInfiniiVisionWaveGens.)
Public property | Item2 | Pointer to the IAgInfiniiVisionWaveGen interface.
Public property | Name | Returns the wavegen name for a given index. (Inherited from IAgInfiniiVisionWaveGens.)
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Properties

 | Name | Description
Public property | Count | Returns the number of wavegens. (Inherited from IAgInfiniiVisionWaveGens.)
Public property | Item | Pointer to the IAgInfiniiVisionWaveGen interface. (Inherited from IAgInfiniiVisionWaveGens.)
Public property | Item2 | Pointer to the IAgInfiniiVisionWaveGen interface.
Public property | Name | Returns the wavegen name for a given index. (Inherited from IAgInfiniiVisionWaveGens.)
Top


IAgInfiniiVisionWaveGenTracking Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IAgInfiniiVisionWaveGenTracking Interface
See Also

IAgInfiniiVisionWaveGenTracking interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Interface IAgInfiniiVisionWaveGenTracking
C#
public interface IAgInfiniiVisionWaveGenTracking
Visual C++
__interface IAgInfiniiVisionWaveGenTracking

Properties

 | Name | Description
Public property | AmplitudeEnabled | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Public property | Enabled | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Public property | FrequencyEnabled | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Top

Methods

 | Name | Description
Public method | CopySignal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).
Top

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Methods

 | Name | Description
Public method | CopySignal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).
Top


Properties

 | Name | Description
Public property | AmplitudeEnabled | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Public property | Enabled | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Public property | FrequencyEnabled | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Top


Enums

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Agilent.AgInfiniiVision.Interop Enums

Enumerations

 | Enumeration | Description
Public enumeration | AgInfiniiVisionACLineSlopeEnum | Values for the slope of the AC power line on which to trigger.
Public enumeration | AgInfiniiVisionAcquisitionReferenceSignalModeEnum | Different modes to selects the 10 MHz reference signal.
Public enumeration | AgInfiniiVisionAcquisitionStatusEnum | Values for the status parameter of the acquisition Status method
Public enumeration | AgInfiniiVisionAcquisitionTypeEnum | Values for Acquisition Type
Public enumeration | AgInfiniiVisionCalibrationProtectionEnum | Calibration Protection State
Public enumeration | AgInfiniiVisionCalibrationSignalSourceEnum | Signal on rear panel trigger out BNC
Public enumeration | AgInfiniiVisionChannelProtectionEnum | Values for channel protection
Public enumeration | AgInfiniiVisionChannelUnitsEnum | Measurement units for channel
Public enumeration | AgInfiniiVisionClockRecoveryMethodEnum | Clock Recovery methods.
Public enumeration | AgInfiniiVisionCounterModeEnum | Counter mode.
Public enumeration | AgInfiniiVisionCounterTotalizerPolarityEnum | The signal conditions.
Public enumeration | AgInfiniiVisionCursorsModeEnum | Mode for cursors
Public enumeration | AgInfiniiVisionCursorsUseCursorPositionEnum | Specifies whether to use the X cursors or Y cursors.
Public enumeration | AgInfiniiVisionCursorsXUnitsEnum | Values for the X cursors units.
Public enumeration | AgInfiniiVisionCursorsYUnitsEnum | Values for the Y Cursors units.
Public enumeration | AgInfiniiVisionDigitalChannelSizeEnum | Specifies the size of digital channels on the display
Public enumeration | AgInfiniiVisionDisplayAnnotationBackgroundEnum | Specifies the Annotation background type.
Public enumeration | AgInfiniiVisionDisplayAnnotationColorEnum | The annotation color.
Public enumeration | AgInfiniiVisionDisplayImageFormatEnum | Image format
Public enumeration | AgInfiniiVisionDisplayPaletteEnum | Image Palette
Public enumeration | AgInfiniiVisionDisplayPersistenceModeEnum | Persistence Mode
Public enumeration | AgInfiniiVisionDisplaySidebarEnum | Sidebar dialog to display on the screen.
Public enumeration | AgInfiniiVisionDVMModeEnum | Digital voltmenter (DVM) modes.
Public enumeration | AgInfiniiVisionEdgeSlopeEnum | Slope.
Public enumeration | AgInfiniiVisionErrorCodesEnum |
Public enumeration | AgInfiniiVisionExternalProbeUnitsEnum | Measurement units for external trigger probe input
Public enumeration | AgInfiniiVisionFRAAmpRangeEnum | Specifies the frequency whose initial ramp amplitude is to be adjusted or queried.
Public enumeration | AgInfiniiVisionFRAFreqModeEnum | The frequency mode setting of the Frequency Response Analysis (FRA).
Public enumeration | AgInfiniiVisionGlitchConditionEnum | Values for glitch trigger Condition
Public enumeration | AgInfiniiVisionGlitchPolarityEnum | Values for glitch trigger Polarity
Public enumeration | AgInfiniiVisionHistogramAxisEnum | Histogram axis type.
Public enumeration | AgInfiniiVisionHistogramModeEnum | Histogram mode.
Public enumeration | AgInfiniiVisionHistogramResultTypeEnum | Histogram Result Type.
Public enumeration | AgInfiniiVisionHistogramTypeEnum | Histogram Type.
Public enumeration | AgInfiniiVisionInterpolationEnum | Values for acquisition Interpolation
Public enumeration | AgInfiniiVisionJitterMeasurementUnitEnum | Jitter Measurement Unit.
Public enumeration | AgInfiniiVisionJitterSpectrumVerticalUnitEnum | Jitter Spectrum Vertical Units.
Public enumeration | AgInfiniiVisionJitterSpectrumWindowEnum | Jitter Spectrum Window Types.
Public enumeration | AgInfiniiVisionMaskTestTerminationConditionEnum | Termination conditions for the mask test
Public enumeration | AgInfiniiVisionMaskTestUnitsEnum | AutoMask Units
Public enumeration | AgInfiniiVisionMathBusSlopeEnum | Specifies the slope as Negative, Positive or Either when the IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsBusState.
Public enumeration | AgInfiniiVisionMathBusYUnitsEnum | Specifies the units for the IAgInfiniiVisionMathBusYIncrement and IAgInfiniiVisionMathBusYOrigin properties.
Public enumeration | AgInfiniiVisionMathFFTDisplayModeEnum | Display Mode.
Public enumeration | AgInfiniiVisionMathFFTVerticalUnitsEnum | Values for the FFT vertical units.
Public enumeration | AgInfiniiVisionMathFFTWindowTypeEnum | Type of Window transforms for FFT.
Public enumeration | AgInfiniiVisionMathIntOperationEnum | Operations for g(t) input function source
Public enumeration | AgInfiniiVisionMathMeasurementTrendTypeEnum | Specifies the measurement type when IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsMeasurementTrend.
Public enumeration | AgInfiniiVisionMathOperationsEnum | Values for Math operations
Public enumeration | AgInfiniiVisionMeasurementEnum | Values for the MeasFunction parameter of the measurement Read and Fetch methods
Public enumeration | AgInfiniiVisionMeasurementJitterEnum | Jitter Measurements type.
Public enumeration | AgInfiniiVisionMeasurementReferenceModeEnum | Values for Reference Mode
Public enumeration | AgInfiniiVisionMeasurementSlopeEnum | Values for Measurement Slope
Public enumeration | AgInfiniiVisionMeasurementSlotEnum | Measurement slots.
Public enumeration | AgInfiniiVisionMeasurementStatisticsFormatEnum | Values for the type of information returned by the ResultsStatistics() method
Public enumeration | AgInfiniiVisionMeasurementWindowTypeEnum | Measurement window type
Public enumeration | AgInfiniiVisionMemoryImageFormatEnum | Image format for saving an image
Public enumeration | AgInfiniiVisionMemoryImagePaletteEnum | Image palette color for saving an image
Public enumeration | AgInfiniiVisionMemoryLocationEnum | Values for memory location
Public enumeration | AgInfiniiVisionMemoryRecallOptionsEnum | Recall Options
Public enumeration | AgInfiniiVisionMemorySaveOptionsEnum | Save Options
Public enumeration | AgInfiniiVisionMemorySegmentOptionEnum | Segments to be included when the waveform is saved
Public enumeration | AgInfiniiVisionMemoryWaveformFormatEnum | Waveform data format type
Public enumeration | AgInfiniiVisionModulationFunctionEnum | Modulation function for Waveform Generator.
Public enumeration | AgInfiniiVisionModulationTypeEnum | Type of modulation for waveform generator.
Public enumeration | AgInfiniiVisionPatternMatchingModeEnum | Values for pattern matching values.
Public enumeration | AgInfiniiVisionPIDDataEnum | Packet Identifier.
Public enumeration | AgInfiniiVisionPIDHandshakeEnum | Packet Identifier (Handshake)
Public enumeration | AgInfiniiVisionPIDSpecialEnum | Packet Identifier (Special)
Public enumeration | AgInfiniiVisionPIDTokenEnum | Packet identifier.
Public enumeration | AgInfiniiVisionPXITriggerEnum | PXI Trigger Line.
Public enumeration | AgInfiniiVisionRuntPolarityEnum | IVI Scope class-compliant values for runt trigger Polarity
Public enumeration | AgInfiniiVisionSampleModeEnum | Acquisition mode of the oscilloscope
Public enumeration | AgInfiniiVisionSearchCANModeEnum | Specifies the type of CAN information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchCANPatternIDTypeEnum | Values that specify whether a standard ID value or an extended ID value is used when searching for a CAN event.
Public enumeration | AgInfiniiVisionSearchEdgeSlopeEnum | Values for the slope of the edge for the search.
Public enumeration | AgInfiniiVisionSearchGlitchConditionEnum | Values for the Glitch condition.
Public enumeration | AgInfiniiVisionSearchGlitchPolarityEnum | Values for Polarity for the Glitch search.
Public enumeration | AgInfiniiVisionSearchI2SAudioChannelEnum | To specify the audio channel: left, right or either channel.
Public enumeration | AgInfiniiVisionSearchI2SModeEnum | To specify the type of I2S information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchIICConditionEnum | Values for the data value qualifier used when searching for IIC EEPROM data read events.
Public enumeration | AgInfiniiVisionSearchIICModeEnum | Values for the type of IIC information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchLINModeEnum | Values for the type of LIN information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchModeEnum | Values for the search mode.
Public enumeration | AgInfiniiVisionSearchRuntConditionEnum | Values that specify how to search for a runt.
Public enumeration | AgInfiniiVisionSearchRuntPolarityEnum | Values for the polarity for the runt search.
Public enumeration | AgInfiniiVisionSearchSentEnum | Specifies the SENT search mode.
Public enumeration | AgInfiniiVisionSearchSerialARINC429ModeEnum | Specifies the ARINC 429 search mode.
Public enumeration | AgInfiniiVisionSearchSerialFlexRayModeEnum | Specifies the type of FlexRay information to find in the lister display.
Public enumeration | AgInfiniiVisionSearchSerialM1553ModeEnum | Specifies the MIL-STD 1553 search mode.
Public enumeration | AgInfiniiVisionSearchSPIModeEnum | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Public enumeration | AgInfiniiVisionSearchTransitionConditionEnum | Values that specify whether to search for edge transition greater than or less than a time.
Public enumeration | AgInfiniiVisionSearchTransitionSlopeEnum | Values that specify whether to search for rising edge transitions or falling edge transitions.
Public enumeration | AgInfiniiVisionSearchUARTConditionEnum | Specifies the data value qualifier when searching for UART/RS232 events.
Public enumeration | AgInfiniiVisionSearchUARTModeEnum | Values for the type of UART/RS232 information to find in the Lister display.
Public enumeration | AgInfiniiVisionSearchUSBConditionEnum | The USB search mode.
Public enumeration | AgInfiniiVisionSerialBusARINC429BaseEnum | Specifies the ARINC 429 base for the selected bus. The base setting will be used for both the Lister and the decode line displays, and controls how the Data field is displayed.
Public enumeration | AgInfiniiVisionSerialBusARINC429DisplayFormatEnum | Specifies the display format for both the decode line and the Lister.
Public enumeration | AgInfiniiVisionSerialBusARINC429SignalTypeEnum | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Public enumeration | AgInfiniiVisionSerialBusARINC429SpeedEnum | Specifies the speed of the ARINC 429 interface for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusARINC429TriggerTypeEnum | Specifies the ARINC 429 trigger mode for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusCANDisplayEnum | Values for Serial Bus CAN display
Public enumeration | AgInfiniiVisionSerialBusCANFDStandardEnum | The CAN standard to use when decoding or triggering on FD frames.
Public enumeration | AgInfiniiVisionSerialBusCANPatternIDTypeEnum | Values for the CAN identifier mode.
Public enumeration | AgInfiniiVisionSerialBusCANSignalTypeEnum | Values for the CAN signal type.
Public enumeration | AgInfiniiVisionSerialBusCANTriggerConditionEnum | Values for the CAN trigger on condition.
Public enumeration | AgInfiniiVisionSerialBusEnum | Values of recall destination for LDF or DBC files
Public enumeration | AgInfiniiVisionSerialBusFlexRayChannelEnum | Specifies whether the FlexRay Signal is for Bus A or B. It is important to specify the correct bus because this setting affects CRC error detection.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Public enumeration | AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum | Specifies the FlexRay trigger on condition.
Public enumeration | AgInfiniiVisionSerialBusI2SBaseEnum | Specifies the base to use for the I2S decode display.
Public enumeration | AgInfiniiVisionSerialBusI2SClockSlopeEnum | Specifies which edge of the I2S serial clock signal clocks in data.
Public enumeration | AgInfiniiVisionSerialBusI2SDataAlignmentEnum | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode
Public enumeration | AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum | Specifies the audio channel to trigger on.
Public enumeration | AgInfiniiVisionSerialBusI2STriggerConditionEnum | Specifies the I2S trigger operator.
Public enumeration | AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum | Specifies the polarity of the word select (WS) signal.
Public enumeration | AgInfiniiVisionSerialBusIICAddressWidthEnum | Determines whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Public enumeration | AgInfiniiVisionSerialBusIICTriggerConditionEnum | Specifies the IIC data qualifier.
Public enumeration | AgInfiniiVisionSerialBusIICTriggerTypeEnum | Specifies the IIC trigger type
Public enumeration | AgInfiniiVisionSerialBusLINDisplayEnum | Specifies the LIN symbolic data loaded into the oscilloscope
Public enumeration | AgInfiniiVisionSerialBusLINStandardEnum | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Public enumeration | AgInfiniiVisionSerialBusLINTriggerConditionEnum | Specifies the LIN trigger condition to be.
Public enumeration | AgInfiniiVisionSerialBusListerDisplayEnum | Values for the lister display setting.
Public enumeration | AgInfiniiVisionSerialBusListerTimeReferenceEnum | Values for the lister time reference setting.
Public enumeration | AgInfiniiVisionSerialBusM1553BaseEnum | Specifies the base to use for the MIL-STD 1553 decode display.
Public enumeration | AgInfiniiVisionSerialBusM1553TriggerTypeEnum | Specifies the type of MIL-STD 1553 trigger to be used.
Public enumeration | AgInfiniiVisionSerialBusModeEnum | Specifies the decode mode for the serial bus.
Public enumeration | AgInfiniiVisionSerialBusSENTCRCEnum | CRC.
Public enumeration | AgInfiniiVisionSerialBusSENTFormatEnum | Message Formats.
Public enumeration | AgInfiniiVisionSerialBusSENTIdleStateEnum | Idle State.
Public enumeration | AgInfiniiVisionSerialBusSENTNumberBaseEnum | Number base.
Public enumeration | AgInfiniiVisionSerialBusSENTSignalOrderEnum | Nibble order.
Public enumeration | AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum | ID and data length format.
Public enumeration | AgInfiniiVisionSerialBusSENTTriggerModeEnum | The automative SENT serial decode trigger modes
Public enumeration | AgInfiniiVisionSerialBusSPIBitOrderEnum | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Public enumeration | AgInfiniiVisionSerialBusSPIClockSlopeEnum | specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Public enumeration | AgInfiniiVisionSerialBusSPIFramingEnum | Specifies the SPI trigger framing value.
Public enumeration | AgInfiniiVisionSerialBusSPITriggerTypeEnum | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Public enumeration | AgInfiniiVisionSerialBusUARTBaseEnum | Specifies the base to use for the UART decode and Lister display.
Public enumeration | AgInfiniiVisionSerialBusUARTBitOrderEnum | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTParityEnum | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTPolarityEnum | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerBaseEnum | Specifies the front panel UART/RS232 trigger setup data selection option
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerConditionEnum | Specifies the data qualifier for the trigger when in UART mode.
Public enumeration | AgInfiniiVisionSerialBusUARTTriggerTypeEnum | Specifies the UART trigger type.
Public enumeration | AgInfiniiVisionSerialBusUSBBaseEnum | Base value to be used.
Public enumeration | AgInfiniiVisionSerialBusUSBConditionEnum | Specifies where the USB trigger mode for the selected bus.
Public enumeration | AgInfiniiVisionSerialBusUSBSpeedEnum | Speed for USB interface for selected bus.
Public enumeration | AgInfiniiVisionStatusRegisterEnum | Enumeration for the Register parameter of the Register property in the Status interface.
Public enumeration | AgInfiniiVisionStatusSRQReasonEnum | Enumeration for the Reason parameter of the ConfigureServiceRequest method in the Status interface.
Public enumeration | AgInfiniiVisionStatusSubRegisterEnum | Enumeration for the SubRegister parameter of the Register property in the Status interface.
Public enumeration | AgInfiniiVisionTimebaseModeEnum | Time base Mode
Public enumeration | AgInfiniiVisionTimebaseReferenceEnum | Point on the display where the trigger point is referenced.
Public enumeration | AgInfiniiVisionTriggerCouplingEnum | Values for trigger Coupling
Public enumeration | AgInfiniiVisionTriggerDelaySlopeEnum | Specifies the rising or falling edge for the Edge Then Edge trigger.
Public enumeration | AgInfiniiVisionTriggerEdgeBurstSlopeEnum | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger
Public enumeration | AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum | Type of reject filter
Public enumeration | AgInfiniiVisionTriggerModifierEnum | Trigger modifier to determine the way oscilloscope behaves in the absence of signal
Public enumeration | AgInfiniiVisionTriggerPXIModeEnum | PXI Trigger Mode.
Public enumeration | AgInfiniiVisionTriggerRuntConditionEnum | Trigger Runt conditions for specifying runt pulse widths.
Public enumeration | AgInfiniiVisionTriggerSetupAndHoldSlopeEnum | Specifies the polarity for the TV trigger.
Public enumeration | AgInfiniiVisionTriggerSlopeEnum | Values for edge trigger Slope
Public enumeration | AgInfiniiVisionTriggerTransitionConditionEnum | Specifies whether you are looking for rise/fall times greater than or less than a certain time value.
Public enumeration | AgInfiniiVisionTriggerTransitionSlopeEnum | Specifies a Positive rising edge or a Negative falling edge.
Public enumeration | AgInfiniiVisionTriggerTypeEnum | Values for trigger Type
Public enumeration | AgInfiniiVisionTriggerUSBConditionEnum | Specifies where the USB trigger will occur.
Public enumeration | AgInfiniiVisionTriggerUSBSpeedEnum | Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Public enumeration | AgInfiniiVisionTriggerZoneEnum | Specifies the Zone Number.
Public enumeration | AgInfiniiVisionTriggerZoneModeEnum | Trigger zone qualifying conditions
Public enumeration | AgInfiniiVisionTriggerZoneValidityEnum | Specifies the trigger zone validity.
Public enumeration | AgInfiniiVisionTVSignalFormatEnum | Values for TV trigger SignalFormat
Public enumeration | AgInfiniiVisionTVTriggerEventEnum | Values for TV trigger Event
Public enumeration | AgInfiniiVisionTVTriggerPolarityEnum | Values for TV trigger Polarity
Public enumeration | AgInfiniiVisionVerticalCouplingEnum | Values for channel Coupling
Public enumeration | AgInfiniiVisionWaveformByteOrderEnum | Output sequence of the WORD data
Public enumeration | AgInfiniiVisionWaveformDataFormatEnum | Data format for data transmission mode for waveform
Public enumeration | AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum | Specifies the byte order for binary transfers.
Public enumeration | AgInfiniiVisionWaveformGeneratorFunctionEnum | Type of waveform
Public enumeration | AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum | Expected output load impedance
Public enumeration | AgInfiniiVisionWaveformGeneratorOutputModeEnum | Specifies whether the defined waveform is output continuously or as a single cycle.
Public enumeration | AgInfiniiVisionWaveformPointModeEnum | Type of data record to be transferred
Public enumeration | AgInfiniiVisionWaveformSubSourceEnum | Sub source.
Public enumeration | AgInfiniiVisionWidthConditionEnum | Values for width trigger Condition
Public enumeration | AgInfiniiVisionWidthPolarityEnum | Values for width trigger Polarity


AgInfiniiVisionACLineSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionACLineSlopeEnum Enumeration
See Also

Values for the slope of the AC power line on which to trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionACLineSlopeEnum
C#
public enum AgInfiniiVisionACLineSlopeEnum
Visual C++
public enum class AgInfiniiVisionACLineSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionACLineSlopePositive | 0x00000000 | Trigger on the positive AC line slope.
AgInfiniiVisionACLineSlopeNegative | 0x00000001 | Trigger on the negative AC line slope.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionAcquisitionReferenceSignalModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionAcquisitionReferenceSignalModeEnum Enumeration
See Also

Different modes to selects the 10 MHz reference signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionAcquisitionReferenceSignalModeEnum
C#
public enum AgInfiniiVisionAcquisitionReferenceSignalModeEnum
Visual C++
public enum class AgInfiniiVisionAcquisitionReferenceSignalModeEnum

Members

Member name | Value | Description
AgInfiniiVisionAcquisitionReferenceSignalModeIn | 0x00000000 | This mode is used to supply a sample clock to the oscilloscope.
AgInfiniiVisionAcquisitionReferenceSignalModeOut | 0x00000001 | This mode is used to synchronize the timebase of two or more instruments.
AgInfiniiVisionAcquisitionReferenceSignalModeOff | 0x00000002 | This mode disables the oscilloscope's 10 MHz REF BNC connector.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionAcquisitionStatusEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionAcquisitionStatusEnum Enumeration
See Also

Values for the status parameter of the acquisition Status method

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionAcquisitionStatusEnum
C#
public enum AgInfiniiVisionAcquisitionStatusEnum
Visual C++
public enum class AgInfiniiVisionAcquisitionStatusEnum

Members

Member name | Value | Description
AgInfiniiVisionAcqInProgress | 0x00000000 | The oscilloscope is still acquiring data.
AgInfiniiVisionAcqComplete | 0x00000001 | The oscilloscope has completed the acquisition.
AgInfiniiVisionAcqStatusUnknown | 0x00000002 | The oscilloscope cannot determine the status of the acquisition.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionAcquisitionTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionAcquisitionTypeEnum Enumeration
See Also

Values for Acquisition Type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionAcquisitionTypeEnum
C#
public enum AgInfiniiVisionAcquisitionTypeEnum
Visual C++
public enum class AgInfiniiVisionAcquisitionTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionAcquisitionTypeNormal | 0x00000000 | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
AgInfiniiVisionAcquisitionTypePeakDetect | 0x00000001 | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record.
AgInfiniiVisionAcquisitionTypeHiRes | 0x00000002 | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record.
AgInfiniiVisionAcquisitionTypeAverage | 0x00000004 | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record. The end-user specifies the number of waveforms to acquire with the Number of Averages property.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCalibrationProtectionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCalibrationProtectionEnum Enumeration
See Also

Calibration Protection State

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCalibrationProtectionEnum
C#
public enum AgInfiniiVisionCalibrationProtectionEnum
Visual C++
public enum class AgInfiniiVisionCalibrationProtectionEnum

Members

Member name | Value | Description
AgInfiniiVisionCalibrationProtectionEnabled | 0x00000000 | Calibration is enabled
AgInfiniiVisionCalibrationProtectionDisabled | 0x00000001 | Calibration is disabled

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCalibrationSignalSourceEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCalibrationSignalSourceEnum Enumeration
See Also

Signal on rear panel trigger out BNC

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCalibrationSignalSourceEnum
C#
public enum AgInfiniiVisionCalibrationSignalSourceEnum
Visual C++
public enum class AgInfiniiVisionCalibrationSignalSourceEnum

Members

Member name | Value | Description
AgInfiniiVisionCalibrationSignalSourceTriggers | 0x00000000 | Pulse signal when a trigger event occurs.
AgInfiniiVisionCalibrationSignalSourceMask | 0x00000001 | Signal from mask test indicating a failure.
AgInfiniiVisionCalibrationSignalSourceWaveGen | 0x00000002 | Waveform generator sync output signal. This signal can be set by IAgInfiniiVisionWaveformGenerator.Function
AgInfiniiVisionCalibrationSignalSourceWaveGen2 | 0x00000003 | Sync output signal from Second waveform generator. This signal can be set by IAgInfiniiVisionWaveformGenerator.Function
AgInfiniiVisionCalibrationSignalSourceOff | 0x00000004 | 1000X: Either turns off the [Gen Out] BNC, or outputs the WaveGen signals if the WaveGen is turned on. M924x: Turns off the [Aux Out] output. Other models: Not applicable.
AgInfiniiVisionCalibrationSignalSourceTrigSource | 0x00000005 | The raw trigger signal from the oscilloscope's trigger circuit is output to Trig Out. It produces a rising edge whenever the input source would cause a trigger, even though that might occur multiple times within the time of a single acquisition.
AgInfiniiVisionCalibrationSignalSourceNFC | 0x00000006 | This option is available in the Near Field Communication(NFC) trigger mode when the ATRigger(Arm & Trigger) trigger event is selected. The ATRigger trigger event lets you arm the oscilloscope on one event and then trigger on a second event or after a specified timeout period if the second event does not occur.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionChannelProtectionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionChannelProtectionEnum Enumeration
See Also

Values for channel protection

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionChannelProtectionEnum
C#
public enum AgInfiniiVisionChannelProtectionEnum
Visual C++
public enum class AgInfiniiVisionChannelProtectionEnum

Members

Member name | Value | Description
AgInfiniiVisionChannelProtectionOK | 0x00000000 | If no overload has occurred, OK is returned.
AgInfiniiVisionChannelProtectionTripped | 0x00000001 | If a channel input has experienced an overload, TRIP is returned

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionChannelUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionChannelUnitsEnum Enumeration
See Also

Measurement units for channel

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionChannelUnitsEnum
C#
public enum AgInfiniiVisionChannelUnitsEnum
Visual C++
public enum class AgInfiniiVisionChannelUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionChannelUnitsVolt | 0x00000000 | VOLT for a voltage probe
AgInfiniiVisionChannelUnitsAmpere | 0x00000001 | AMPere for a current probe

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionClockRecoveryMethodEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionClockRecoveryMethodEnum Enumeration
See Also

Clock Recovery methods.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionClockRecoveryMethodEnum
C#
public enum AgInfiniiVisionClockRecoveryMethodEnum
Visual C++
public enum class AgInfiniiVisionClockRecoveryMethodEnum

Members

Member name | Value | Description
AgInfiniiVisionClockRecoveryMethodFixed | 0x00000000 | This clock recovery method is used to recovered the clock using the expected nominal data rate entered. It should be the reciprocal of the signal's unit interval.
AgInfiniiVisionClockRecoveryMethodFixedAuto | 0x00000001 | This clock recovery method is used to recovered the clock using the signal edge database only. The narrowest pulse is presumed to be an isolated one or zero.
AgInfiniiVisionClockRecoveryMethodFixedSemiAuto | 0x00000002 | This clock recovery method is used to recovered the clock using the expected nominal data rate as a "seed" and the signal edge database.
AgInfiniiVisionClockRecoveryMethodFirstOrderPLL | 0x00000003 | With First Order PLL, the clock is recovered using the DSP-modeled response of an ideal first-order hardware PLL.
AgInfiniiVisionClockRecoveryMethodSecondOrderPLL | 0x00000004 | With Second Order PLL, the clock is recovered using the DSP-modeled response of an ideal Type II, second-order hardware PLL.
AgInfiniiVisionClockRecoveryMethodExplicit | 0x00000005 | The clock is recovered from a second signal in your device under test, with a multiplier from 1 to 1000 applied.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCounterModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCounterModeEnum Enumeration
See Also

Counter mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCounterModeEnum
C#
public enum AgInfiniiVisionCounterModeEnum
Visual C++
public enum class AgInfiniiVisionCounterModeEnum

Members

Member name | Value | Description
AgInfiniiVisionCounterModeFrequency | 0x00000000 | The cycles per second (Hz) of the signal.
AgInfiniiVisionCounterModePeriod | 0x00000001 | The time periods of the signal's cycles.
AgInfiniiVisionCounterModeTotalize | 0x00000002 | The count of edge events on the signal.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCounterTotalizerPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCounterTotalizerPolarityEnum Enumeration
See Also

The signal conditions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCounterTotalizerPolarityEnum
C#
public enum AgInfiniiVisionCounterTotalizerPolarityEnum
Visual C++
public enum class AgInfiniiVisionCounterTotalizerPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionCounterTotalizerPolarityNegative | 0x00000000 | Negative or falling edge,
AgInfiniiVisionCounterTotalizerPolarityPositive | 0x00000001 | Positive or rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCursorsModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCursorsModeEnum Enumeration
See Also

Mode for cursors

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCursorsModeEnum
C#
public enum AgInfiniiVisionCursorsModeEnum
Visual C++
public enum class AgInfiniiVisionCursorsModeEnum

Members

Member name | Value | Description
AgInfiniiVisionCursorsModeOff | 0x00000000 | Removes the cursor information from the display
AgInfiniiVisionCursorsModeMeasurement | 0x00000001 | Cursors track the most recent measurement.
AgInfiniiVisionCursorsModeManual | 0x00000002 | Enables manual placement of the X and Y cursors.
AgInfiniiVisionCursorsModeWaveform | 0x00000003 | The Y1 cursor tracks the voltage value at the X1 cursor of the waveform specified by the X1Y1source, and the Y2 cursor does the same for the X2 cursor and its X2Y2source.
AgInfiniiVisionCursorsModeBinary | 0x00000004 | The logic levels of displayed waveforms at the current X1 and X2 cursor positions in binary.
AgInfiniiVisionCursorsModeHexadecimal | 0x00000005 | The logic levels of displayed waveforms at the current X1 and X2 cursor positions in Hexadecimal.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCursorsUseCursorPositionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCursorsUseCursorPositionEnum Enumeration
See Also

Specifies whether to use the X cursors or Y cursors.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCursorsUseCursorPositionEnum
C#
public enum AgInfiniiVisionCursorsUseCursorPositionEnum
Visual C++
public enum class AgInfiniiVisionCursorsUseCursorPositionEnum

Members

Member name | Value | Description
AgInfiniiVisionCursorsUseCursorPositionX | 0x00000000 | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent. Sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
AgInfiniiVisionCursorsUseCursorPositionY | 0x00000001 | Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCursorsXUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCursorsXUnitsEnum Enumeration
See Also

Values for the X cursors units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCursorsXUnitsEnum
C#
public enum AgInfiniiVisionCursorsXUnitsEnum
Visual C++
public enum class AgInfiniiVisionCursorsXUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionCursorsXUnitsSeconds | 0x00000000 | For making time measurements.
AgInfiniiVisionCursorsXUnitsHz | 0x00000001 | For making frequency measurements.
AgInfiniiVisionCursorsXUnitsDegrees | 0x00000002 | For making phase measurements.
AgInfiniiVisionCursorsXUnitsPercent | 0x00000003 | For making Ratio measurements.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionCursorsYUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionCursorsYUnitsEnum Enumeration
See Also

Values for the Y Cursors units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionCursorsYUnitsEnum
C#
public enum AgInfiniiVisionCursorsYUnitsEnum
Visual C++
public enum class AgInfiniiVisionCursorsYUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionCursorsYUnitsBase | 0x00000000 | For making measurements in the units associated with the cursors source.
AgInfiniiVisionCursorsYUnitsPercent | 0x00000001 | For making Ratio measurements.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDigitalChannelSizeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDigitalChannelSizeEnum Enumeration
See Also

Specifies the size of digital channels on the display

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDigitalChannelSizeEnum
C#
public enum AgInfiniiVisionDigitalChannelSizeEnum
Visual C++
public enum class AgInfiniiVisionDigitalChannelSizeEnum

Members

Member name | Value | Description
AgInfiniiVisionDigitalChannelSizeSmall | 0x00000000 | Small Size
AgInfiniiVisionDigitalChannelSizeLarge | 0x00000001 | Large size
AgInfiniiVisionDigitalChannelSizeMedium | 0x00000002 | Medium Size

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplayAnnotationBackgroundEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplayAnnotationBackgroundEnum Enumeration
See Also

Specifies the Annotation background type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplayAnnotationBackgroundEnum
C#
public enum AgInfiniiVisionDisplayAnnotationBackgroundEnum
Visual C++
public enum class AgInfiniiVisionDisplayAnnotationBackgroundEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplayAnnotationBackgroundOpaque | 0x00000000 | The annotation has a solid background.
AgInfiniiVisionDisplayAnnotationBackgroundInverted | 0x00000001 | The annotation's foreground and background colors are switched.
AgInfiniiVisionDisplayAnnotationBackgroundTransparent | 0x00000002 | The annotation has a transparent background.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplayAnnotationColorEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplayAnnotationColorEnum Enumeration
See Also

The annotation color.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplayAnnotationColorEnum
C#
public enum AgInfiniiVisionDisplayAnnotationColorEnum
Visual C++
public enum class AgInfiniiVisionDisplayAnnotationColorEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplayAnnotationColorChannel1 | 0x00000000 | Color that match analog channel 1's color.
AgInfiniiVisionDisplayAnnotationColorChannel2 | 0x00000001 | Color that match analog channel 2's color.
AgInfiniiVisionDisplayAnnotationColorChannel3 | 0x00000002 | Color that match analog channel 3's color.
AgInfiniiVisionDisplayAnnotationColorChannel4 | 0x00000003 | Color that match analog channel 4's color.
AgInfiniiVisionDisplayAnnotationColorDigitalChannel | 0x00000004 | Color that match Digital channel's color.
AgInfiniiVisionDisplayAnnotationColorMathWaveform | 0x00000005 | Color that match math waveform's color.
AgInfiniiVisionDisplayAnnotationColorReferenceWaveform | 0x00000006 | Color that match reference waveform's color.
AgInfiniiVisionDisplayAnnotationColorMarkers | 0x00000007 | Color that match marker.
AgInfiniiVisionDisplayAnnotationColorWhite | 0x00000008 | White color.
AgInfiniiVisionDisplayAnnotationColorRed | 0x00000009 | Red color.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplayImageFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplayImageFormatEnum Enumeration
See Also

Image format

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplayImageFormatEnum
C#
public enum AgInfiniiVisionDisplayImageFormatEnum
Visual C++
public enum class AgInfiniiVisionDisplayImageFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplayImageFormatBMP | 0x00000000 | 24-bit BMP
AgInfiniiVisionDisplayImageFormatBMP8Bit | 0x00000001 | 8-bit BMP8bit
AgInfiniiVisionDisplayImageFormatPNG | 0x00000002 | 24-bit PNG

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplayPaletteEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplayPaletteEnum Enumeration
See Also

Image Palette

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplayPaletteEnum
C#
public enum AgInfiniiVisionDisplayPaletteEnum
Visual C++
public enum class AgInfiniiVisionDisplayPaletteEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplayPaletteColor | 0x00000000 | Color
AgInfiniiVisionDisplayPaletteGrayscale | 0x00000001 | Grayscale

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplayPersistenceModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplayPersistenceModeEnum Enumeration
See Also

Persistence Mode

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplayPersistenceModeEnum
C#
public enum AgInfiniiVisionDisplayPersistenceModeEnum
Visual C++
public enum class AgInfiniiVisionDisplayPersistenceModeEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplayPersistenceModeMinimum | 0x00000000 | Zero persistence
AgInfiniiVisionDisplayPersistenceModeInfinite | 0x00000001 | Infinite persistence
AgInfiniiVisionDisplayPersistenceModeAdaptive | 0x00000002 | All previous acquisitions that have taken place in hardware since the last controller PC screen capture are displayed.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDisplaySidebarEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDisplaySidebarEnum Enumeration
See Also

Sidebar dialog to display on the screen.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDisplaySidebarEnum
C#
public enum AgInfiniiVisionDisplaySidebarEnum
Visual C++
public enum class AgInfiniiVisionDisplaySidebarEnum

Members

Member name | Value | Description
AgInfiniiVisionDisplaySidebarSummary | 0x00000000 | Display Summary on screen's sidebar.
AgInfiniiVisionDisplaySidebarCursors | 0x00000001 | Display Cursors information on screen's sidebar.
AgInfiniiVisionDisplaySidebarMeasurements | 0x00000002 | Display measurements on screen's sidebar.
AgInfiniiVisionDisplaySidebarDVM | 0x00000003 | Display DVM information on screen's sidebar.
AgInfiniiVisionDisplaySidebarNavigate | 0x00000004 | Display navigation information on screen's sidebar.
AgInfiniiVisionDisplaySidebarControls | 0x00000005 | Display controls on screen's sidebar.
AgInfiniiVisionDisplaySidebarHistogram | 0x00000006 | Display Histogram's information on screen's sidebar.
AgInfiniiVisionDisplaySidebarEvents | 0x00000007 | Display Events on screen's sidebar.
AgInfiniiVisionDisplaySidebarCounter | 0x00000008 | Display counter on screen's sidebar.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionDVMModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionDVMModeEnum Enumeration
See Also

Digital voltmenter (DVM) modes.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionDVMModeEnum
C#
public enum AgInfiniiVisionDVMModeEnum
Visual C++
public enum class AgInfiniiVisionDVMModeEnum

Members

Member name | Value | Description
AgInfiniiVisionDVMModeACRMS | 0x00000000 | Displays the root-mean-square value of the acquired data, with the DC component removed.
AgInfiniiVisionDVMModeDC | 0x00000001 | Displays the DC value of the acquired data.
AgInfiniiVisionDVMModeDCRMS | 0x00000002 | Displays the root-mean-square value of the acquired data.
AgInfiniiVisionDVMModeFrequency | 0x00000003 | Not Supported by 3000T/4000X/6000X series models. Displays the frequency counter measurement.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionEdgeSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionEdgeSlopeEnum Enumeration
See Also

Slope.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionEdgeSlopeEnum
C#
public enum AgInfiniiVisionEdgeSlopeEnum
Visual C++
public enum class AgInfiniiVisionEdgeSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionEdgeSlopeRising | 0x00000000 | Rising slope.
AgInfiniiVisionEdgeSlopeFalling | 0x00000001 | Falling Slope.
AgInfiniiVisionEdgeSlopeBoth | 0x00000002 | Both Rising and Falling slope.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionErrorCodesEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionErrorCodesEnum Enumeration
See Also

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionErrorCodesEnum
C#
public enum AgInfiniiVisionErrorCodesEnum
Visual C++
public enum class AgInfiniiVisionErrorCodesEnum

Members

Member name | Value | Description
E_AGINFINIIVISION_IO_GENERAL | 0x80044214 | I/O error.
E_AGINFINIIVISION_IO_TIMEOUT | 0x80044215 | I/O timeout error.
E_AGINFINIIVISION_MODEL_NOT_SUPPORTED | 0x80044216 | Instrument model does not support this feature.
E_AGINFINIIVISION_PERSONALITY_NOT_ACTIVE | 0x80044211 | Personality is not active.
E_AGINFINIIVISION_PERSONALITY_NOT_LICENSED | 0x80044213 | Personality is not licensed.
E_AGINFINIIVISION_PERSONALITY_NOT_INSTALLED | 0x80044212 | Personality is not installed.
E_AGINFINIIVISION_INVALID_MEASUREMENT_SOURCE | 0x8004420E |
E_AGINFINIIVISION_SETTINGS_CONFLICT | 0x80044217 | Setting Conflict
E_AGINFINIIVISION_OPTION_NOT_PRESENT | 0x80044218 |
E_AGINFINIIVISION_INVALID_PARAMETER | 0x800440DC |
E_AGINFINIIVISION_BAD_PATTERN | 0x8004421C |
E_AGINFINIIVISION_HARDWARE_MISSING | 0x800440F1 |
E_AGINFINIIVISION_NO_DATA_FOR_OPERATION | 0x8004421E | No Data for operation.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionExternalProbeUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionExternalProbeUnitsEnum Enumeration
See Also

Measurement units for external trigger probe input

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionExternalProbeUnitsEnum
C#
public enum AgInfiniiVisionExternalProbeUnitsEnum
Visual C++
public enum class AgInfiniiVisionExternalProbeUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionExternalProbeUnitsVolts | 0x00000000 | VOLT for a voltage probe
AgInfiniiVisionExternalProbeUnitsAmperes | 0x00000001 | AMPere for a current probe

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionFRAAmpRangeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionFRAAmpRangeEnum Enumeration
See Also

Specifies the frequency whose initial ramp amplitude is to be adjusted or queried.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionFRAAmpRangeEnum
C#
public enum AgInfiniiVisionFRAAmpRangeEnum
Visual C++
public enum class AgInfiniiVisionFRAAmpRangeEnum

Members

Member name | Value | Description
AgInfiniiVisionFRAAmpRange20HZ | 0x00000000 | Amplitude at 20Hz
AgInfiniiVisionFRAAmpRange100HZ | 0x00000001 | Amplitude at 100Hz
AgInfiniiVisionFRAAmpRange10KHZ | 0x00000003 | Amplitude at 10KHz
AgInfiniiVisionFRAAmpRange100KHZ | 0x00000004 | Amplitude at 100KHz
AgInfiniiVisionFRAAmpRange1MHZ | 0x00000005 | Amplitude at 1MHz
AgInfiniiVisionFRAAmpRange10MHZ | 0x00000006 | Amplitude at 10MHz
AgInfiniiVisionFRAAmpRange20MHZ | 0x00000007 | Amplitude at 20MHz
AgInfiniiVisionFRAAmpRange1KHZ | 0x00000002 | Amplitude at 1KHz

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionFRAFreqModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionFRAFreqModeEnum Enumeration
See Also

The frequency mode setting of the Frequency Response Analysis (FRA).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionFRAFreqModeEnum
C#
public enum AgInfiniiVisionFRAFreqModeEnum
Visual C++
public enum class AgInfiniiVisionFRAFreqModeEnum

Members

Member name | Value | Description
AgInfiniiVisionFRAFreqModeSingle | 0x00000000 | AgInfiniiVisionFRAFreqModeSingle - Runs the FRA at a single frequency. Useful for debugging purposes.
AgInfiniiVisionFRAFreqModeSweep | 0x00000001 | AgInfiniiVisionFRAFreqModeSweep - Runs the FRA in a normal frequency sweep (range) mode

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionGlitchConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionGlitchConditionEnum Enumeration
See Also

Values for glitch trigger Condition

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionGlitchConditionEnum
C#
public enum AgInfiniiVisionGlitchConditionEnum
Visual C++
public enum class AgInfiniiVisionGlitchConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionGlitchConditionLessThan | 0x00000001 | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
AgInfiniiVisionGlitchConditionGreaterThan | 0x00000002 | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.
AgInfiniiVisionGlitchConditionRange | 0x00000000 | The oscilloscope triggers within a range of time values

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionGlitchPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionGlitchPolarityEnum Enumeration
See Also

Values for glitch trigger Polarity

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionGlitchPolarityEnum
C#
public enum AgInfiniiVisionGlitchPolarityEnum
Visual C++
public enum class AgInfiniiVisionGlitchPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionGlitchPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive glitch.
AgInfiniiVisionGlitchPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative glitch.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionHistogramAxisEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionHistogramAxisEnum Enumeration
See Also

Histogram axis type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionHistogramAxisEnum
C#
public enum AgInfiniiVisionHistogramAxisEnum
Visual C++
public enum class AgInfiniiVisionHistogramAxisEnum

Members

Member name | Value | Description
AgInfiniiVisionHistogramAxisVertical | 0x00000000 | The limits window is divided into rows, and the number of hits in each row is displayed in a histogram bar graph at the left of the graticule.
AgInfiniiVisionHistogramAxisHorizontal | 0x00000001 | The limits window is divided into columns, and the number of hits in each column is displayed in a histogram bar graph at the bottom of the graticule.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionHistogramModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionHistogramModeEnum Enumeration
See Also

Histogram mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionHistogramModeEnum
C#
public enum AgInfiniiVisionHistogramModeEnum
Visual C++
public enum class AgInfiniiVisionHistogramModeEnum

Members

Member name | Value | Description
AgInfiniiVisionHistogramModeOff | 0x00000000 | Disables the histogram analysis feature.
AgInfiniiVisionHistogramModeWaveform | 0x00000001 | shows the number of times a waveform crosses into (or hits) a row or column of a user-defined window. For vertical histograms, the window is divided into rows.
AgInfiniiVisionHistogramModeMeasurement | 0x00000002 | Shows the distribution of a measurement's results just like ordinary measurement statistics.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionHistogramResultTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionHistogramResultTypeEnum Enumeration
See Also

Histogram Result Type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionHistogramResultTypeEnum
C#
public enum AgInfiniiVisionHistogramResultTypeEnum
Visual C++
public enum class AgInfiniiVisionHistogramResultTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionHistogramResultTypeBandwidth | 0x00000000 | The width of each bin (bucket) in the histogram.
AgInfiniiVisionHistogramResultTypeHits | 0x00000001 | The sum of all hits in all bins (buckets) in the histogram.
AgInfiniiVisionHistogramResultTypeM1S | 0x00000002 | The percentage of histogram hits that lie within +-1 Std Dev of the mean.
AgInfiniiVisionHistogramResultTypeM2S | 0x00000003 | The percentage of histogram hits that lie within +-2 Std Dev of the mean.
AgInfiniiVisionHistogramResultTypeM3S | 0x00000004 | The percentage of histogram hits that lie within +-3 Std Dev of the mean.
AgInfiniiVisionHistogramResultTypeMaximum | 0x00000005 | The value corresponding to the maximum bin that has any hits.
AgInfiniiVisionHistogramResultTypeMean | 0x00000006 | The mean value of the histogram.
AgInfiniiVisionHistogramResultTypeMedian | 0x00000007 | The median value of the histogram.
AgInfiniiVisionHistogramResultTypeMinimum | 0x00000008 | The value corresponding to the minimum bin that has any hits.
AgInfiniiVisionHistogramResultTypeMode | 0x00000009 | The mode value of the histogram.
AgInfiniiVisionHistogramResultTypePeak | 0x0000000A | The maximum number of hits in any single bin.
AgInfiniiVisionHistogramResultTypePeakToPeak | 0x0000000B | The delta between the Max and Min values.
AgInfiniiVisionHistogramResultTypeStandardDeviation | 0x0000000C | The standard deviation of the histogram values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionHistogramTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionHistogramTypeEnum Enumeration
See Also

Histogram Type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionHistogramTypeEnum
C#
public enum AgInfiniiVisionHistogramTypeEnum
Visual C++
public enum class AgInfiniiVisionHistogramTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionHistogramTypeVertical | 0x00000000 | The limits window is divided into rows, and the number of hits in each row is displayed in a histogram bar graph at the left of the graticule.
AgInfiniiVisionHistogramTypeHorizontal | 0x00000001 | The limits window is divided into columns, and the number of hits in each column is displayed in a histogram bar graph at the bottom of the graticule.
AgInfiniiVisionHistogramTypeMeasurement | 0x00000002 | Shows the distribution of a measurement's results just like ordinary measurement statistics.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionInterpolationEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionInterpolationEnum Enumeration
See Also

Values for acquisition Interpolation

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionInterpolationEnum
C#
public enum AgInfiniiVisionInterpolationEnum
Visual C++
public enum class AgInfiniiVisionInterpolationEnum

Members

Member name | Value | Description
AgInfiniiVisionInterpolationSineX | 0x00000002 | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionJitterMeasurementUnitEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionJitterMeasurementUnitEnum Enumeration
See Also

Jitter Measurement Unit.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionJitterMeasurementUnitEnum
C#
public enum AgInfiniiVisionJitterMeasurementUnitEnum
Visual C++
public enum class AgInfiniiVisionJitterMeasurementUnitEnum

Members

Member name | Value | Description
AgInfiniiVisionJitterMeasurementUnitSeconds | 0x00000000 | Seconds.
AgInfiniiVisionJitterMeasurementUnitInterval | 0x00000001 | Unit Interval.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionJitterSpectrumVerticalUnitEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionJitterSpectrumVerticalUnitEnum Enumeration
See Also

Jitter Spectrum Vertical Units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionJitterSpectrumVerticalUnitEnum
C#
public enum AgInfiniiVisionJitterSpectrumVerticalUnitEnum
Visual C++
public enum class AgInfiniiVisionJitterSpectrumVerticalUnitEnum

Members

Member name | Value | Description
AgInfiniiVisionJitterSpectrumVerticalUnitDecibel | 0x00000000 | Vertical unit Decibel.
AgInfiniiVisionJitterSpectrumVerticalUnitVRMS | 0x00000001 | Vertical unit VRMS.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionJitterSpectrumWindowEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionJitterSpectrumWindowEnum Enumeration
See Also

Jitter Spectrum Window Types.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionJitterSpectrumWindowEnum
C#
public enum AgInfiniiVisionJitterSpectrumWindowEnum
Visual C++
public enum class AgInfiniiVisionJitterSpectrumWindowEnum

Members

Member name | Value | Description
AgInfiniiVisionJitterSpectrumWindowRectangular | 0x00000000 | Useful for transient signals, and signals where there are an integral number of cycles in the time record.
AgInfiniiVisionJitterSpectrumWindowHanning | 0x00000001 | Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window.
AgInfiniiVisionJitterSpectrumWindowFlattop | 0x00000002 | Best for making accurate amplitude measurements of frequency peaks.
AgInfiniiVisionJitterSpectrumWindowBlackmanHarris | 0x00000003 | Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMaskTestTerminationConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMaskTestTerminationConditionEnum Enumeration
See Also

Termination conditions for the mask test

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMaskTestTerminationConditionEnum
C#
public enum AgInfiniiVisionMaskTestTerminationConditionEnum
Visual C++
public enum class AgInfiniiVisionMaskTestTerminationConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionMaskTestTerminationConditionForever | 0x00000000 | FOREVER: Mask test runs until it is turned off
AgInfiniiVisionMaskTestTerminationConditionSigma | 0x00000001 | SIGMA: Mask test runs until the Sigma level is reached
AgInfiniiVisionMaskTestTerminationConditionTime | 0x00000002 | TIME: Mask test runs for a fixed amount of time
AgInfiniiVisionMaskTestTerminationConditionWaveforms | 0x00000003 | WAVEFORM: The mask test runs until a fixed number of waveforms are acquire

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMaskTestUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMaskTestUnitsEnum Enumeration
See Also

AutoMask Units

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMaskTestUnitsEnum
C#
public enum AgInfiniiVisionMaskTestUnitsEnum
Visual C++
public enum class AgInfiniiVisionMaskTestUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionMaskTestUnitsCurrent | 0x00000000 | Current interprets Horizontal tolerance as Time and Vertical tolerance as Voltage
AgInfiniiVisionMaskTestUnitsDivisions | 0x00000001 | Division interprets tolerance parameters as Division

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathBusSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathBusSlopeEnum Enumeration
See Also

Specifies the slope as Negative, Positive or Either when the IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsBusState.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathBusSlopeEnum
C#
public enum AgInfiniiVisionMathBusSlopeEnum
Visual C++
public enum class AgInfiniiVisionMathBusSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionMathBusSlopeNegative | 0x00000000 | Specifies negative slope.
AgInfiniiVisionMathBusSlopePositive | 0x00000001 | Specifies the positive slope.
AgInfiniiVisionMathBusSlopeEither | 0x00000002 | Specifies either negative or positive slope.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathBusYUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathBusYUnitsEnum Enumeration
See Also

Specifies the units for the IAgInfiniiVisionMathBusYIncrement and IAgInfiniiVisionMathBusYOrigin properties.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathBusYUnitsEnum
C#
public enum AgInfiniiVisionMathBusYUnitsEnum
Visual C++
public enum class AgInfiniiVisionMathBusYUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionMathBusYUnitsVolts | 0x00000000 | Specifies the units as Volts.
AgInfiniiVisionMathBusYUnitsAmps | 0x00000001 | Specifies the units as Amperes.
AgInfiniiVisionMathBusYUnitsNone | 0x00000002 | Specifies the units as None.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathFFTDisplayModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathFFTDisplayModeEnum Enumeration
See Also

Display Mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathFFTDisplayModeEnum
C#
public enum AgInfiniiVisionMathFFTDisplayModeEnum
Visual C++
public enum class AgInfiniiVisionMathFFTDisplayModeEnum

Members

Member name | Value | Description
AgInfiniiVisionMathFFTDisplayModeNormal | 0x00000000 | Normal.
AgInfiniiVisionMathFFTDisplayModeAverage | 0x00000001 | Average.
AgInfiniiVisionMathFFTDisplayModeMaxHold | 0x00000002 | Maximum hold.
AgInfiniiVisionMathFFTDisplayModeMinHold | 0x00000003 | Minimum hold.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathFFTVerticalUnitsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathFFTVerticalUnitsEnum Enumeration
See Also

Values for the FFT vertical units.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathFFTVerticalUnitsEnum
C#
public enum AgInfiniiVisionMathFFTVerticalUnitsEnum
Visual C++
public enum class AgInfiniiVisionMathFFTVerticalUnitsEnum

Members

Member name | Value | Description
AgInfiniiVisionMathFFTVerticalUnitsdB | 0x00000000 | Specifies FFT vertical units as Decibels.
AgInfiniiVisionMathFFTVerticalUnitsVRMS | 0x00000001 | Specifies the FFT vertical units as VRMS.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathFFTWindowTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathFFTWindowTypeEnum Enumeration
See Also

Type of Window transforms for FFT.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathFFTWindowTypeEnum
C#
public enum AgInfiniiVisionMathFFTWindowTypeEnum
Visual C++
public enum class AgInfiniiVisionMathFFTWindowTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionMathFFTWindowTypeRectangular | 0x00000000 | RECTangular: Useful for transient signals, and signals where there are an integral number of cycles in the time record
AgInfiniiVisionMathFFTWindowTypeHanning | 0x00000001 | HANNing: Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window
AgInfiniiVisionMathFFTWindowTypeFlatTop | 0x00000002 | FLATtop: Best for making accurate amplitude measurements of frequency peaks.
AgInfiniiVisionMathFFTWindowTypeBHarris | 0x00000003 | BHARris (Blackman-Harris): Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathIntOperationEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathIntOperationEnum Enumeration
See Also

Operations for g(t) input function source

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathIntOperationEnum
C#
public enum AgInfiniiVisionMathIntOperationEnum
Visual C++
public enum class AgInfiniiVisionMathIntOperationEnum

Members

Member name | Value | Description
AgInfiniiVisionMathIntOperationAdd | 0x00000000 | ADD = Source1 + source2.
AgInfiniiVisionMathIntOperationSubtract | 0x00000001 | SUBTract = Source1 - source2.
AgInfiniiVisionMathIntOperationMultiply | 0x00000002 | MULTiply = Source1 * source2.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathMeasurementTrendTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathMeasurementTrendTypeEnum Enumeration
See Also

Specifies the measurement type when IAgInfiniiVisionMathOperation property is set to AgInfiniiVisionMathOperationsMeasurementTrend.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathMeasurementTrendTypeEnum
C#
public enum AgInfiniiVisionMathMeasurementTrendTypeEnum
Visual C++
public enum class AgInfiniiVisionMathMeasurementTrendTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionMathMeasurementTrendTypeFrequency | 0x00000000 | Specifies the measurement type as Frequency.
AgInfiniiVisionMathMeasurementTrendTypePeriod | 0x00000001 | Specifies the measurement type as Period.
AgInfiniiVisionMathMeasurementTrendTypeDutyCycle | 0x00000002 | Specifies the measurement type as Duty Cycle.
AgInfiniiVisionMathMeasurementTrendTypePositiveWidth | 0x00000003 | Specifies the measurement type as Positive Width.
AgInfiniiVisionMathMeasurementTrendTypeNegativeWidth | 0x00000004 | Specifies the measurement type as Negative Width.
AgInfiniiVisionMathMeasurementTrendTypeRiseTime | 0x00000005 | Specifies the measurement type as Rise Time.
AgInfiniiVisionMathMeasurementTrendTypeFallTime | 0x00000006 | Specifies the measurement type as Fall Time.
AgInfiniiVisionMathMeasurementTrendTypeVRatio | 0x00000007 | Specifies the measurement type as Voltage Ratio.
AgInfiniiVisionMathMeasurementTrendTypeVAverage | 0x00000008 | Specifies the measurement type as Voltage Average
AgInfiniiVisionMathMeasurementTrendTypeACRms | 0x00000009 | Specifies the measurement type as AC RMS.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMathOperationsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMathOperationsEnum Enumeration
See Also

Values for Math operations

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMathOperationsEnum
C#
public enum AgInfiniiVisionMathOperationsEnum
Visual C++
public enum class AgInfiniiVisionMathOperationsEnum

Members

Member name | Value | Description
AgInfiniiVisionMathOperationsAdd | 0x00000000 | ADD = Source1 + source2.
AgInfiniiVisionMathOperationsSubtract | 0x00000001 | SUBTract = Source1 - source2.
AgInfiniiVisionMathOperationsMultiply | 0x00000002 | MULTiply = Source1 * source2.
AgInfiniiVisionMathOperationsFFT | 0x00000003 | Using the Fast Fourier Transform (FFT), this operation displays the magnitudes of the frequency content that makes up the source waveform.
AgInfiniiVisionMathOperationsIntegrate | 0x00000004 | Integration on the selected waveform source.
AgInfiniiVisionMathOperationsDifferentiation | 0x00000005 | Differentiation on the selected waveform source.
AgInfiniiVisionMathOperationsSquareRoot | 0x00000006 | Square Root of the selected waveform source.
AgInfiniiVisionMathOperationsMagnify | 0x00000007 | Magnify.
AgInfiniiVisionMathOperationsAbsolute | 0x00000008 | Absolute.
AgInfiniiVisionMathOperationsNaturalLogarithm | 0x00000009 | Natural Logarithm on the selected waveform source.
AgInfiniiVisionMathOperationsCommonLogarithm | 0x0000000A | Common Logarithm on the selected waveform source.
AgInfiniiVisionMathOperationsExponential | 0x0000000B | Exponential on the selected waveform source.
AgInfiniiVisionMathOperationsBaseTenExponential | 0x0000000C | Base Ten Exponential on the selected waveform source.
AgInfiniiVisionMathOperationsLowPassFilter | 0x0000000D | Low Pass Filter
AgInfiniiVisionMathOperationsHighPassFilter | 0x0000000E | High Pass Filter.
AgInfiniiVisionMathOperationsDivide | 0x0000000F | Divide operation.
AgInfiniiVisionMathOperationsLinear | 0x00000010 | Linear operation on the selected waveform source.
AgInfiniiVisionMathOperationsMeasurmentTrend | 0x00000011 | Measurement Trend.
AgInfiniiVisionMathOperationsBusTiming | 0x00000012 | Bus Timing
AgInfiniiVisionMathOperationsBusState | 0x00000013 | Bus State
AgInfiniiVisionMathOperationsSquare | 0x00000014 | Square operation on the selected waveform source.
AgInfiniiVisionMathOperationsAverage | 0x00000015 | Average operation on the selected waveform source.
AgInfiniiVisionMathOperationsMaxHold | 0x00000016 | Operates on a single analog channel source or on a lower math function. The Max Hold (or Max Envelope) operator records the maximum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AgInfiniiVisionMathOperationsMinHold | 0x00000017 | Operates on a single analog channel source or on a lower math function. The Min Hold (or Min Envelope) operator records the minimum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AgInfiniiVisionMathOperationsClockRecovery | 0x00000018 | You can display recovered clocks from different sources using multiple math function waveforms; however, the same clock recovery method applies to all recovered clocks.
AgInfiniiVisionMathOperationsSmoothing | 0x00000019 | The smoothing operator limits the bandwidth of the source waveform. The smoothing operator can be used, for example, to smooth measurement trend waveforms.
AgInfiniiVisionMathOperationsEnvelope | 0x0000001A | The resulting math waveform is the amplitude envelope for an amplitude modulated (AM) input signal.
AgInfiniiVisionMathOperationsFFTPhase | 0x0000001B | Using the Fast Fourier Transform (FFT), this operation shows the phase relationships of the frequency content that makes up the source waveform

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementEnum Enumeration
See Also

Values for the MeasFunction parameter of the measurement Read and Fetch methods

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementEnum
C#
public enum AgInfiniiVisionMeasurementEnum
Visual C++
public enum class AgInfiniiVisionMeasurementEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementRiseTime | 0x00000000 | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AgInfiniiVisionMeasurementFallTime | 0x00000001 | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AgInfiniiVisionMeasurementFrequency | 0x00000002 | The frequency of one complete cycle in the waveform. The units are Hertz.
AgInfiniiVisionMeasurementPeriod | 0x00000003 | The length of time of one complete cycle in the waveform. The units are seconds.
AgInfiniiVisionMeasurementVoltageRMS | 0x00000004 | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AgInfiniiVisionMeasurementVoltagePeakToPeak | 0x00000005 | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AgInfiniiVisionMeasurementVoltageMax | 0x00000006 | The maximum amplitude found in the entire waveform. The units are Volts.
AgInfiniiVisionMeasurementVoltageMin | 0x00000007 | The minimum amplitude found in the entire waveform. The units are Volts.
AgInfiniiVisionMeasurementVoltageHigh | 0x00000008 | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AgInfiniiVisionMeasurementVoltageLow | 0x00000009 | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AgInfiniiVisionMeasurementVoltageAverage | 0x0000000A | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AgInfiniiVisionMeasurementWidthNeg | 0x0000000B | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AgInfiniiVisionMeasurementWidthPos | 0x0000000C | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AgInfiniiVisionMeasurementDutyCycleNeg | 0x0000000D | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AgInfiniiVisionMeasurementDutyCyclePos | 0x0000000E | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AgInfiniiVisionMeasurementAmplitude | 0x0000000F | The Voltage High less the Voltage Low in Volts over the entire waveform.
AgInfiniiVisionMeasurementVoltageCycleRMS | 0x00000010 | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AgInfiniiVisionMeasurementVoltageCycleAverage | 0x00000011 | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AgInfiniiVisionMeasurementOverShoot | 0x00000012 | The relative waveform distortion that follows an edge transition.
AgInfiniiVisionMeasurementPreshoot | 0x00000013 | The relative waveform distortion that precedes an edge transition.
AgInfiniiVisionMeasurementFrequencyCounter | 0x00000014 | The High precision frequency measurement made with an internal frequency counter.
AgInfiniiVisionMeasurementTimeAtMax | 0x00000015 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AgInfiniiVisionMeasurementTimeAtMin | 0x00000016 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AgInfiniiVisionMeasurementDelay | 0x00000017 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AgInfiniiVisionMeasurementPhase | 0x00000018 | This measures the relative phase of one waveform with respect to the period on another waveform.
AgInfiniiVisionMeasurementValueAtTime | 0x00000019 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AgInfiniiVisionMeasurementTimeAtValue | 0x0000001A | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AgInfiniiVisionMeasurementTimeOfEdge | 0x0000001B | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AgInfiniiVisionMeasurementArea | 0x0000001C | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AgInfiniiVisionMeasurementBurstWidth | 0x0000001D | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AgInfiniiVisionMeasurementFallingEdgeCount | 0x0000001E | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AgInfiniiVisionMeasurementFallingPulseCount | 0x0000001F | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AgInfiniiVisionMeasurementRisingEdgeCount | 0x00000020 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AgInfiniiVisionMeasurementRisingPulseCount | 0x00000021 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AgInfiniiVisionMeasurementStandardDeviation | 0x00000022 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
AgInfiniiVisionMeasurementBitRate | 0x00000023 | Bit rate measurement.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementJitterEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementJitterEnum Enumeration
See Also

Jitter Measurements type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementJitterEnum
C#
public enum AgInfiniiVisionMeasurementJitterEnum
Visual C++
public enum class AgInfiniiVisionMeasurementJitterEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementJitterTIEClock | 0x00000000 | The Clock TIE (Time Interval Error) jitter measurement.
AgInfiniiVisionMeasurementJitterTIEData | 0x00000001 | The Data TIE (Time Interval Error) jitter measurement.
AgInfiniiVisionMeasurementJitterNCJitter | 0x00000002 | The N-Cycle Period-Period jitter measurement.
AgInfiniiVisionMeasurementJitterNPeriod | 0x00000003 | The N-Period jitter measurement.
AgInfiniiVisionMeasurementJitterCTCNWidth | 0x00000004 | The -Width to -Width (cycle-to-cycle negative width) jitter measurement.
AgInfiniiVisionMeasurementJitterCTCPWidth | 0x00000005 | The +Width to +Width (cycle-to-cycle positive width) jitter measurement.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementReferenceModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementReferenceModeEnum Enumeration
See Also

Values for Reference Mode

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementReferenceModeEnum
C#
public enum AgInfiniiVisionMeasurementReferenceModeEnum
Visual C++
public enum class AgInfiniiVisionMeasurementReferenceModeEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementReferenceModePercent | 0x00000000 | Percentage reference mode
AgInfiniiVisionMeasurementReferenceModeAbsolute | 0x00000001 | Absolute reference mode

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementSlopeEnum Enumeration
See Also

Values for Measurement Slope

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementSlopeEnum
C#
public enum AgInfiniiVisionMeasurementSlopeEnum
Visual C++
public enum class AgInfiniiVisionMeasurementSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementSlopePositive | 0x00000000 | A positive (rising) edge
AgInfiniiVisionMeasurementSlopeNegative | 0x00000001 | A negative (falling) edge

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementSlotEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementSlotEnum Enumeration
See Also

Measurement slots.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementSlotEnum
C#
public enum AgInfiniiVisionMeasurementSlotEnum
Visual C++
public enum class AgInfiniiVisionMeasurementSlotEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementSlotNone | 0x00000000 | None.
AgInfiniiVisionMeasurementSlot1 | 0x00000001 | Measurement 1.
AgInfiniiVisionMeasurementSlot2 | 0x00000002 | Measurement 2.
AgInfiniiVisionMeasurementSlot3 | 0x00000003 | Measurement 3.
AgInfiniiVisionMeasurementSlot4 | 0x00000004 | Measurement 4.
AgInfiniiVisionMeasurementSlot5 | 0x00000005 | Measurement 5.
AgInfiniiVisionMeasurementSlot6 | 0x00000006 | Measurement 6.
AgInfiniiVisionMeasurementSlot7 | 0x00000007 | Measurement 7.
AgInfiniiVisionMeasurementSlot8 | 0x00000008 | Measurement 8.
AgInfiniiVisionMeasurementSlot9 | 0x00000009 | Measurement 9.
AgInfiniiVisionMeasurementSlot10 | 0x0000000A | Measurement 10.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementStatisticsFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementStatisticsFormatEnum Enumeration
See Also

Values for the type of information returned by the ResultsStatistics() method

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementStatisticsFormatEnum
C#
public enum AgInfiniiVisionMeasurementStatisticsFormatEnum
Visual C++
public enum class AgInfiniiVisionMeasurementStatisticsFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementStatisticsFormatAll | 0x00000000 | All statistics are returned.
AgInfiniiVisionMeasurementStatisticsFormatCurrent | 0x00000001 | Current Statistic is returned.
AgInfiniiVisionMeasurementStatisticsFormatMinimum | 0x00000002 | Minimum statistic is returned.
AgInfiniiVisionMeasurementStatisticsFormatMaximum | 0x00000003 | Maximum statistic is returned.
AgInfiniiVisionMeasurementStatisticsFormatMean | 0x00000004 | Mean statistic is returned.
AgInfiniiVisionMeasurementStatisticsFormatStandardDeviation | 0x00000005 | Standard Deviation statistic is returned.
AgInfiniiVisionMeasurementStatisticsFormatCount | 0x00000006 | Count statistic is returned.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMeasurementWindowTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMeasurementWindowTypeEnum Enumeration
See Also

Measurement window type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMeasurementWindowTypeEnum
C#
public enum AgInfiniiVisionMeasurementWindowTypeEnum
Visual C++
public enum class AgInfiniiVisionMeasurementWindowTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionMeasurementWindowTypeMain | 0x00000000 | Upper measurement window
AgInfiniiVisionMeasurementWindowTypeZoom | 0x00000001 | Lower measurement window
AgInfiniiVisionMeasurementWindowTypeAuto | 0x00000002 | Attempts to select the lower Zoom window,if it cannot be made there, the upper Main window is used.
AgInfiniiVisionMeasurementWindowTypeGate | 0x00000003 | Measurement window is between the X1 and X2 cursors.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemoryImageFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemoryImageFormatEnum Enumeration
See Also

Image format for saving an image

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemoryImageFormatEnum
C#
public enum AgInfiniiVisionMemoryImageFormatEnum
Visual C++
public enum class AgInfiniiVisionMemoryImageFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionMemoryImageFormatBMP | 0x00000000 | BMP
AgInfiniiVisionMemoryImageFormatBMP8bit | 0x00000002 | BMP8bit
AgInfiniiVisionMemoryImageFormatPNG | 0x00000003 | PNG

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemoryImagePaletteEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemoryImagePaletteEnum Enumeration
See Also

Image palette color for saving an image

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemoryImagePaletteEnum
C#
public enum AgInfiniiVisionMemoryImagePaletteEnum
Visual C++
public enum class AgInfiniiVisionMemoryImagePaletteEnum

Members

Member name | Value | Description
AgInfiniiVisionMemoryImagePaletteColor | 0x00000000 | Color
AgInfiniiVisionMemoryImagePaletteGrayscale | 0x00000001 | GrayScale

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemoryLocationEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemoryLocationEnum Enumeration
See Also

Values for memory location

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemoryLocationEnum
C#
public enum AgInfiniiVisionMemoryLocationEnum
Visual C++
public enum class AgInfiniiVisionMemoryLocationEnum

Members

Member name | Value | Description
AgInfiniiVisionMemoryLocation0 | 0x00000002 | Memory Location 0
AgInfiniiVisionMemoryLocation1 | 0x00000000 | Memory Location 1
AgInfiniiVisionMemoryLocation2 | 0x00000001 | Memory Location 2
AgInfiniiVisionMemoryLocation3 | 0x00000003 | Memory Location 3
AgInfiniiVisionMemoryLocation4 | 0x00000004 | Memory Location 4
AgInfiniiVisionMemoryLocation5 | 0x00000005 | Memory Location 5
AgInfiniiVisionMemoryLocation6 | 0x00000006 | Memory Location 6
AgInfiniiVisionMemoryLocation7 | 0x00000007 | Memory Location 7
AgInfiniiVisionMemoryLocation8 | 0x00000008 | Memory Location 8
AgInfiniiVisionMemoryLocation9 | 0x00000009 | Memory Location 9

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemoryRecallOptionsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemoryRecallOptionsEnum Enumeration
See Also

Recall Options

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemoryRecallOptionsEnum
C#
public enum AgInfiniiVisionMemoryRecallOptionsEnum
Visual C++
public enum class AgInfiniiVisionMemoryRecallOptionsEnum

Members

Member name | Value | Description
AgInfiniiVisionMemoryRecallOptionsMask | 0x00000001 | Recalls a mask.
AgInfiniiVisionMemoryRecallOptionsSetup | 0x00000002 | Recalls an oscilloscope setup
AgInfiniiVisionMemoryRecallOptionsReferenceWaveform1 | 0x00000003 | Recalls reference waveform 1
AgInfiniiVisionMemoryRecallOptionsReferenceWaveform2 | 0x00000004 | Recalls reference waveform 2
AgInfiniiVisionMemoryRecallOptionsArbCsv | 0x00000000 | Recalls the saved arbitrary waveform 1.
AgInfiniiVisionMemoryRecallOptionsArbCsv2 | 0x00000005 | Recalls the saved arbitrary waveform 2.
AgInfiniiVisionMemoryRecallOptionsReferenceWaveform3 | 0x00000006 | Recalls reference waveform 3
AgInfiniiVisionMemoryRecallOptionsReferenceWaveform4 | 0x00000007 | Recalls reference waveform 4
AgInfiniiVisionMemoryRecallOptionsLDF | 0x00000008 | Loads a LIN description file (LDF) symbolic data file into the oscilloscope.
AgInfiniiVisionMemoryRecallOptionsDBC | 0x00000009 | Load a CAN DBC (communication database) symbolic data file into the oscilloscope.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemorySaveOptionsEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemorySaveOptionsEnum Enumeration
See Also

Save Options

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemorySaveOptionsEnum
C#
public enum AgInfiniiVisionMemorySaveOptionsEnum
Visual C++
public enum class AgInfiniiVisionMemorySaveOptionsEnum

Members

Member name | Value | Description
AgInfiniiVisionMemorySaveOptionsImage | 0x00000000 | Saves an Image
AgInfiniiVisionMemorySaveOptionsWaveform | 0x00000001 | Saves waveform data
AgInfiniiVisionMemorySaveOptionsReferenceWaveform | 0x00000002 | Saves oscilloscope waveform data to a reference waveform file.
AgInfiniiVisionMemorySaveOptionsSetup | 0x00000003 | Saves an oscilloscope setup
AgInfiniiVisionMemorySaveOptionsMask | 0x00000004 | Saves a mask
AgInfiniiVisionMemorySaveOptionsLister | 0x00000005 | ONLY SUPPORTED ON THE 3000X SERIES- Saves the Lister display data
AgInfiniiVisionMemorySaveOptionsArbCsv | 0x00000006 | Saves the currently-loaded Arbitrary waveform 1 to the file location specified (internal or external).
AgInfiniiVisionMemorySaveOptionsArbCsv2 | 0x00000007 | Saves the currently-loaded Arbitrary waveform 2 to the file location specified (internal or external).
AgInfiniiVisionMemorySaveOptionsMultiWaveformData | 0x00000008 | Save multiple oscilloscope waveform to a h5 waveform file.
AgInfiniiVisionMemorySaveOptionsAnalysisResults | 0x00000009 | Saves analysis results to a comma-separated values (*.csv) file on a USB storage device.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemorySegmentOptionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemorySegmentOptionEnum Enumeration
See Also

Segments to be included when the waveform is saved

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemorySegmentOptionEnum
C#
public enum AgInfiniiVisionMemorySegmentOptionEnum
Visual C++
public enum class AgInfiniiVisionMemorySegmentOptionEnum

Members

Member name | Value | Description
AgInfiniiVisionMemorySegmentOptionAll | 0x00000000 | All acquired segments are saved
AgInfiniiVisionMemorySegmentOptionCurrent | 0x00000001 | Currently selected segment is saved

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionMemoryWaveformFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionMemoryWaveformFormatEnum Enumeration
See Also

Waveform data format type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionMemoryWaveformFormatEnum
C#
public enum AgInfiniiVisionMemoryWaveformFormatEnum
Visual C++
public enum class AgInfiniiVisionMemoryWaveformFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionMemoryWaveformFormatALB | 0x00000000 | Agilent module binary format file
AgInfiniiVisionMemoryWaveformFormatASCIIxy | 0x00000001 | Comma-separated value files for each analog channel that is turned on
AgInfiniiVisionMemoryWaveformFormatCSV | 0x00000002 | Single comma-separated value file that contains information for all analog channels that are turned on
AgInfiniiVisionMemoryWaveformFormatBinary | 0x00000003 | Binary data format file

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionModulationFunctionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionModulationFunctionEnum Enumeration
See Also

Modulation function for Waveform Generator.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionModulationFunctionEnum
C#
public enum AgInfiniiVisionModulationFunctionEnum
Visual C++
public enum class AgInfiniiVisionModulationFunctionEnum

Members

Member name | Value | Description
AgInfiniiVisionModulationFunctionSinusoidal | 0x00000000 | Sinusoidal function for waveform generator.
AgInfiniiVisionModulationFunctionSquare | 0x00000001 | Square function for waveform generator.
AgInfiniiVisionModulationFunctionRamp | 0x00000002 | Ramp function for waveform generator.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionModulationTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionModulationTypeEnum Enumeration
See Also

Type of modulation for waveform generator.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionModulationTypeEnum
C#
public enum AgInfiniiVisionModulationTypeEnum
Visual C++
public enum class AgInfiniiVisionModulationTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionModulationTypeAM | 0x00000000 | AM modulation.
AgInfiniiVisionModulationTypeFM | 0x00000001 | FM modulation.
AgInfiniiVisionModulationTypeFSK | 0x00000002 | FSK modulation.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPatternMatchingModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPatternMatchingModeEnum Enumeration
See Also

Values for pattern matching values.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPatternMatchingModeEnum
C#
public enum AgInfiniiVisionPatternMatchingModeEnum
Visual C++
public enum class AgInfiniiVisionPatternMatchingModeEnum

Members

Member name | Value | Description
AgInfiniiVisionPatternMatchingModeEnter | 0x00000000 | Pattern is entered.
AgInfiniiVisionPatternMatchingModeGreaterThan | 0x00000001 | Pattern present for less than a time value.
AgInfiniiVisionPatternMatchingModeLessThan | 0x00000002 | Pattern present for greater than a time value.
AgInfiniiVisionPatternMatchingModeInRange | 0x00000003 | Pattern present for a time within a range of values. Trigger occurs when the pattern exits not when the GREaterthan time value is exceeded.
AgInfiniiVisionPatternMatchingModeOutRange | 0x00000004 | Pattern present for a time outside of range of values.
AgInfiniiVisionPatternMatchingModeTimeout | 0x00000005 | Pattern present for greater than a time value. Trigger occurs when the GREaterthan time value is exceeded not when the pattern exits.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPIDDataEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPIDDataEnum Enumeration
See Also

Packet Identifier.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPIDDataEnum
C#
public enum AgInfiniiVisionPIDDataEnum
Visual C++
public enum class AgInfiniiVisionPIDDataEnum

Members

Member name | Value | Description
AgInfiniiVisionPIDDataData0 | 0x00000000 | DATA0
AgInfiniiVisionPIDDataData1 | 0x00000001 | DATA1
AgInfiniiVisionPIDDataData2 | 0x00000002 | DATA2
AgInfiniiVisionPIDDataMData | 0x00000003 | MDATA

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPIDHandshakeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPIDHandshakeEnum Enumeration
See Also

Packet Identifier (Handshake)

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPIDHandshakeEnum
C#
public enum AgInfiniiVisionPIDHandshakeEnum
Visual C++
public enum class AgInfiniiVisionPIDHandshakeEnum

Members

Member name | Value | Description
AgInfiniiVisionPIDHandshakeACK | 0x00000000 | ACK Handshake.
AgInfiniiVisionPIDHandshakeNAK | 0x00000001 | NAK Handshake
AgInfiniiVisionPIDHandshakeSTALL | 0x00000002 | STALL Handshake.
AgInfiniiVisionPIDHandshakeNYET | 0x00000003 | NYET (No Response Yet)

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPIDSpecialEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPIDSpecialEnum Enumeration
See Also

Packet Identifier (Special)

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPIDSpecialEnum
C#
public enum AgInfiniiVisionPIDSpecialEnum
Visual C++
public enum class AgInfiniiVisionPIDSpecialEnum

Members

Member name | Value | Description
AgInfiniiVisionPIDSpecialPing | 0x00000000 | Ping.
AgInfiniiVisionPIDSpecialPreamble | 0x00000001 | Preamble.
AgInfiniiVisionPIDSpecialERR | 0x00000002 | ERR.
AgInfiniiVisionPIDSpecialSplit | 0x00000003 | Split.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPIDTokenEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPIDTokenEnum Enumeration
See Also

Packet identifier.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPIDTokenEnum
C#
public enum AgInfiniiVisionPIDTokenEnum
Visual C++
public enum class AgInfiniiVisionPIDTokenEnum

Members

Member name | Value | Description
AgInfiniiVisionPIDTokenOut | 0x00000000 | OUT Token.
AgInfiniiVisionPIDTokenIn | 0x00000001 | IN Token.
AgInfiniiVisionPIDTokenSetup | 0x00000002 | SETUP Token.
AgInfiniiVisionPIDTokenSof | 0x00000003 | SOF Token.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionPXITriggerEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionPXITriggerEnum Enumeration
See Also

PXI Trigger Line.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionPXITriggerEnum
C#
public enum AgInfiniiVisionPXITriggerEnum
Visual C++
public enum class AgInfiniiVisionPXITriggerEnum

Members

Member name | Value | Description
AgInfiniiVisionPXITriggerLine1 | 0x00000001 | PXI Trigger Line 1.
AgInfiniiVisionPXITriggerLine2 | 0x00000002 | PXI Trigger Line 2.
AgInfiniiVisionPXITriggerLine3 | 0x00000003 | PXI Trigger Line 3.
AgInfiniiVisionPXITriggerLine4 | 0x00000004 | PXI Trigger Line 4.
AgInfiniiVisionPXITriggerLine5 | 0x00000005 | PXI Trigger Line 5.
AgInfiniiVisionPXITriggerLine6 | 0x00000006 | PXI Trigger Line 6.
AgInfiniiVisionPXITriggerLine7 | 0x00000007 | PXI Trigger Line 7.
AgInfiniiVisionPXITriggerLine0 | 0x00000000 | PXI Trigger Line 0.
AgInfiniiVisionPXITriggerLineOff | 0x00000008 | PXI Trigger Line OFF.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionRuntPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionRuntPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for runt trigger Polarity

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionRuntPolarityEnum
C#
public enum AgInfiniiVisionRuntPolarityEnum
Visual C++
public enum class AgInfiniiVisionRuntPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionRuntPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
AgInfiniiVisionRuntPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
AgInfiniiVisionRuntPolarityEither | 0x00000003 | The oscilloscope triggers on either a positive or negative runt.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSampleModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSampleModeEnum Enumeration
See Also

Acquisition mode of the oscilloscope

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSampleModeEnum
C#
public enum AgInfiniiVisionSampleModeEnum
Visual C++
public enum class AgInfiniiVisionSampleModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSampleModeRealTime | 0x00000000 | Indicates that the oscilloscope is using real-time sampling.
AgInfiniiVisionSampleModeSegmented | 0x00000001 | Indicates that the oscilloscope is using segmented memory mode.
AgInfiniiVisionSampleModeEquivalentTime | 0x00000002 | Indicates that the oscilloscope is using Equivalent time mode.
AgInfiniiVisionSampleModeMaxRealTime | 0x00000003 | Supported on 6000x series only- Indicates that the oscilloscope is using maximum update rate real-time sampling.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchCANModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchCANModeEnum Enumeration
See Also

Specifies the type of CAN information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchCANModeEnum
C#
public enum AgInfiniiVisionSearchCANModeEnum
Visual C++
public enum class AgInfiniiVisionSearchCANModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchCANModeData | 0x00000000 | Search for CAN Data frames matching the specified ID, Data, and the DLC (Data length code).
AgInfiniiVisionSearchCANModeIDData | 0x00000001 | Search for CAN frames matching the specified ID of a Data frame.
AgInfiniiVisionSearchCANModeIDEither | 0x00000002 | Search for the specified ID, regardless if it is a Remote frame or a Data frame.
AgInfiniiVisionSearchCANModeIDRemote | 0x00000003 | Search for CAN frames matching the specified ID of a Remote frame.
AgInfiniiVisionSearchCANModeAllErrors | 0x00000004 | Search for CAN active error frames and unknown bus conditions.
AgInfiniiVisionSearchCANModeOverload | 0x00000005 | Search for CAN overload frames.
AgInfiniiVisionSearchCANModeError | 0x00000006 | Search for CAN Error frame.
AgInfiniiVisionSearchCANModeAckError | 0x00000007 | The acknowledge bit if the polarity is incorrect.
AgInfiniiVisionSearchCANModeFormError | 0x00000008 | The reserved bit errors.
AgInfiniiVisionSearchCANModeStuffError | 0x00000009 | Find 6 consecutive 1s or 6 consecutive 0s, while in a non-error or non overload frame.
AgInfiniiVisionSearchCANModeCRCError | 0x0000000A | Finds when the calculated CRC does not match the transmitted CRC.
AgInfiniiVisionSearchCANModeMsgSig | 0x0000000B | Finds a symbolic message and a signal value.
AgInfiniiVisionSearchCANModeMsg | 0x0000000C | Finds a symbolic message.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchCANPatternIDTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchCANPatternIDTypeEnum Enumeration
See Also

Values that specify whether a standard ID value or an extended ID value is used when searching for a CAN event.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchCANPatternIDTypeEnum
C#
public enum AgInfiniiVisionSearchCANPatternIDTypeEnum
Visual C++
public enum class AgInfiniiVisionSearchCANPatternIDTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchCANPatternIDTypeStandard | 0x00000000 | Uses a standard ID value when searching for a CAN event.
AgInfiniiVisionSearchCANPatternIDTypeExtended | 0x00000001 | Uses an extended ID value when searching for a CAN event.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchEdgeSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchEdgeSlopeEnum Enumeration
See Also

Values for the slope of the edge for the search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchEdgeSlopeEnum
C#
public enum AgInfiniiVisionSearchEdgeSlopeEnum
Visual C++
public enum class AgInfiniiVisionSearchEdgeSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchEdgeSlopeNegative | 0x00000000 | Negative slope of the edge.
AgInfiniiVisionSearchEdgeSlopePositive | 0x00000001 | Positive slope of the edge.
AgInfiniiVisionSearchEdgeSlopeEither | 0x00000002 | Either negative or positive slope of the edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchGlitchConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchGlitchConditionEnum Enumeration
See Also

Values for the Glitch condition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchGlitchConditionEnum
C#
public enum AgInfiniiVisionSearchGlitchConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchGlitchConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchGlitchConditionGreaterThan | 0x00000000 | To Search for a pulse width greater than a time value.
AgInfiniiVisionSearchGlitchConditionLessThan | 0x00000001 | To Search for a pulse width less than a time value.
AgInfiniiVisionSearchGlitchConditionRange | 0x00000002 | To Search for a pulse width within a range of time values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchGlitchPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchGlitchPolarityEnum Enumeration
See Also

Values for Polarity for the Glitch search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchGlitchPolarityEnum
C#
public enum AgInfiniiVisionSearchGlitchPolarityEnum
Visual C++
public enum class AgInfiniiVisionSearchGlitchPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchGlitchPolarityPositive | 0x00000000 | Positive polarity.
AgInfiniiVisionSearchGlitchPolarityNegative | 0x00000001 | Negative polarity.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchI2SAudioChannelEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchI2SAudioChannelEnum Enumeration
See Also

To specify the audio channel: left, right or either channel.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchI2SAudioChannelEnum
C#
public enum AgInfiniiVisionSearchI2SAudioChannelEnum
Visual C++
public enum class AgInfiniiVisionSearchI2SAudioChannelEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchI2SAudioChannelLeft | 0x00000000 | The left audio channel.
AgInfiniiVisionSearchI2SAudioChannelRight | 0x00000001 | The right audio channel.
AgInfiniiVisionSearchI2SAudioChannelEither | 0x00000002 | Either left or right audio channel.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchI2SModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchI2SModeEnum Enumeration
See Also

To specify the type of I2S information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchI2SModeEnum
C#
public enum AgInfiniiVisionSearchI2SModeEnum
Visual C++
public enum class AgInfiniiVisionSearchI2SModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchI2SModeEqual | 0x00000000 | Search for the specified audio channel's data word when it equals the specified word.
AgInfiniiVisionSearchI2SModeNotEqual | 0x00000001 | Searches for any word other than the specified word.
AgInfiniiVisionSearchI2SModeLessThan | 0x00000002 | Search for channel data words less than the specified value.
AgInfiniiVisionSearchI2SModeGreaterThan | 0x00000003 | Search for channel data words greater than the specified value.
AgInfiniiVisionSearchI2SModeInRange | 0x00000004 | Search for channel data words in the range.
AgInfiniiVisionSearchI2SModeOutRange | 0x00000005 | Searches for channel data words outside the range.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchIICConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchIICConditionEnum Enumeration
See Also

Values for the data value qualifier used when searching for IIC EEPROM data read events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchIICConditionEnum
C#
public enum AgInfiniiVisionSearchIICConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchIICConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchIICConditionEqual | 0x00000000 | To search for a value equal to the specified value.
AgInfiniiVisionSearchIICConditionNotEqual | 0x00000001 | To search for a value not equal to the specified value.
AgInfiniiVisionSearchIICConditionLessThan | 0x00000002 | To search for a value less than the specified value.
AgInfiniiVisionSearchIICConditionGreaterThan | 0x00000003 | To search for a value greater than the specified value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchIICModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchIICModeEnum Enumeration
See Also

Values for the type of IIC information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchIICModeEnum
C#
public enum AgInfiniiVisionSearchIICModeEnum
Visual C++
public enum class AgInfiniiVisionSearchIICModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchIICModeRead7 | 0x00000000 | Searches for 7-bit address frames containing Start:Address7:Read:Ack:Data.
AgInfiniiVisionSearchIICModeWrite7 | 0x00000001 | Searches for 7-bit address frames containing Start:Address7:Write:Ack:Data
AgInfiniiVisionSearchIICModeMissingAcknowledge | 0x00000002 | Searches for missing acknowledge events
AgInfiniiVisionSearchIICModeNoAcknowledge | 0x00000003 | Searches for address with no acknowledge events
AgInfiniiVisionSearchIICModeR7Data2 | 0x00000004 | Searches for 7-bit address frames containing Start:Address7:Read:Ack:Data:Ack:Data2
AgInfiniiVisionSearchIICModeW7Data2 | 0x00000005 | Searches for 7-bit address frames containing Start:Address7:Write:Ack:Data:Ack:Data2
AgInfiniiVisionSearchIICModeRestart | 0x00000006 | Searches for another start condition occurring before a stop condition.
AgInfiniiVisionSearchIICModeReadEprom | 0x00000007 | Searches for EEPROM data reads
AgInfiniiVisionSearchIICModeAddress | 0x00000008 | Searches for a packet with the specified address.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchLINModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchLINModeEnum Enumeration
See Also

Values for the type of LIN information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchLINModeEnum
C#
public enum AgInfiniiVisionSearchLINModeEnum
Visual C++
public enum class AgInfiniiVisionSearchLINModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchLINModeID | 0x00000000 | Searches for a frame ID.
AgInfiniiVisionSearchLINModeData | 0x00000001 | Searches for a frame ID and data.
AgInfiniiVisionSearchLINModeError | 0x00000002 | Searches for errors.
AgInfiniiVisionSearchLINModeFrame | 0x00000003 | Searches for symbolic frames.
AgInfiniiVisionSearchLINModeFrameSig | 0x00000004 | Searches for symbolic frames and a signal values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchModeEnum Enumeration
See Also

Values for the search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchModeEnum
C#
public enum AgInfiniiVisionSearchModeEnum
Visual C++
public enum class AgInfiniiVisionSearchModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchModeEdge | 0x00000000 | Edge mode.
AgInfiniiVisionSearchModeGlitch | 0x00000001 | Glitch mode.
AgInfiniiVisionSearchModeRunt | 0x00000002 | Runt mode.
AgInfiniiVisionSearchModeTransition | 0x00000003 | Transition mode.
AgInfiniiVisionSearchModeSerial1 | 0x00000004 | Serial1 mode.
AgInfiniiVisionSearchModeSerial2 | 0x00000005 | Serial2 mode.
AgInfiniiVisionSearchModeOff | 0x00000006 | Search is disabled.
AgInfiniiVisionSearchModePeak | 0x00000007 | Peak mode.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchRuntConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchRuntConditionEnum Enumeration
See Also

Values that specify how to search for a runt.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchRuntConditionEnum
C#
public enum AgInfiniiVisionSearchRuntConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchRuntConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchRuntConditionGreaterThan | 0x00000000 | To search for a runt greater than a time value.
AgInfiniiVisionSearchRuntConditionLessThan | 0x00000001 | To search for a runt less than a time value.
AgInfiniiVisionSearchRuntConditionNone | 0x00000002 | To search for a runt for any time value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchRuntPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchRuntPolarityEnum Enumeration
See Also

Values for the polarity for the runt search.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchRuntPolarityEnum
C#
public enum AgInfiniiVisionSearchRuntPolarityEnum
Visual C++
public enum class AgInfiniiVisionSearchRuntPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchRuntPolarityPositive | 0x00000000 | Positive polarity.
AgInfiniiVisionSearchRuntPolarityNegative | 0x00000001 | Negative polarity.
AgInfiniiVisionSearchRuntPolarityEither | 0x00000002 | Either positive or negative polarity.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchSentEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchSentEnum Enumeration
See Also

Specifies the SENT search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchSentEnum
C#
public enum AgInfiniiVisionSearchSentEnum
Visual C++
public enum class AgInfiniiVisionSearchSentEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchSentFCData | 0x00000000 | FCData - finds Fast Channel data nibbles that match the values entered using additional softkeys.
AgInfiniiVisionSearchSentSCMsgid | 0x00000001 | SCMid - finds Slow Channel Message IDs that match the value entered using additional softkeys.
AgInfiniiVisionSearchSentSCData | 0x00000002 | SCData - finds Slow Channel Message IDs and Data that match the values entered using additional softkeys.
AgInfiniiVisionSearchSentCRCError | 0x00000003 | CRCerror - finds any CRC error, Fast or Slow.
AgInfiniiVisionSearchSentPPError | 0x00000004 | PPERror - finds where a nibble is either too wide or too narrow.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchSerialARINC429ModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchSerialARINC429ModeEnum Enumeration
See Also

Specifies the ARINC 429 search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchSerialARINC429ModeEnum
C#
public enum AgInfiniiVisionSearchSerialARINC429ModeEnum
Visual C++
public enum class AgInfiniiVisionSearchSerialARINC429ModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchSerialARINC429ModeLabel | 0x00000000 | Specifies the Label search mode.
AgInfiniiVisionSearchSerialARINC429ModeLabelBits | 0x00000001 | Specifies the Label + Bits search mode.
AgInfiniiVisionSearchSerialARINC429ModeParityError | 0x00000002 | Specifies the Parity Error search mode.
AgInfiniiVisionSearchSerialARINC429ModeWordError | 0x00000003 | Specifies the Word Error search mode.
AgInfiniiVisionSearchSerialARINC429ModeGapError | 0x00000004 | Specifies the Gap Error search mode.
AgInfiniiVisionSearchSerialARINC429ModeWordOrGapError | 0x00000005 | Specifies the Word or Gap Error search mode.
AgInfiniiVisionSearchSerialARINC429ModeAllErrors | 0x00000006 | Specifies All Errors search mode.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchSerialFlexRayModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchSerialFlexRayModeEnum Enumeration
See Also

Specifies the type of FlexRay information to find in the lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchSerialFlexRayModeEnum
C#
public enum AgInfiniiVisionSearchSerialFlexRayModeEnum
Visual C++
public enum class AgInfiniiVisionSearchSerialFlexRayModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchSerialFlexRayModeFrameID | 0x00000000 | Finds frames with the specified ID.
AgInfiniiVisionSearchSerialFlexRayModeCycleNumber | 0x00000001 | Finds frames with the specified cycle number and ID.
AgInfiniiVisionSearchSerialFlexRayModeData | 0x00000002 | Finds frames with the specified data, cycle number and frame ID.
AgInfiniiVisionSearchSerialFlexRayModeHeaderCRC | 0x00000003 | Finds cyclic redundancy check errors in headers.
AgInfiniiVisionSearchSerialFlexRayModeFrameCRC | 0x00000004 | Finds cyclic redundancy check errors in frames.
AgInfiniiVisionSearchSerialFlexRayModeAllErrors | 0x00000005 | Finds all errors.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchSerialM1553ModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchSerialM1553ModeEnum Enumeration
See Also

Specifies the MIL-STD 1553 search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchSerialM1553ModeEnum
C#
public enum AgInfiniiVisionSearchSerialM1553ModeEnum
Visual C++
public enum class AgInfiniiVisionSearchSerialM1553ModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchSerialM1553ModeDataStart | 0x00000000 | Finds the start of a data word (at the end of a valid Data Sync pulse).
AgInfiniiVisionSearchSerialM1553ModeCommandStart | 0x00000001 | Finds the start of a Command/Status word (at the end of a valid C/S Sync pulse).
AgInfiniiVisionSearchSerialM1553ModeRTA | 0x00000002 | Finds the Command/Status Word whose RTA matches the specified value. The value is specified in hex.
AgInfiniiVisionSearchSerialM1553ModeRTA11 | 0x00000003 | Finds the RTA and the remaining 11 bits that match the specified criteria. The RTA can be specified as a hex value and the remaining bits are specified as 1 or 0.
AgInfiniiVisionSearchSerialM1553ModeParityError | 0x00000004 | Finds (odd) parity bits that are incorrect for the data in the word.
AgInfiniiVisionSearchSerialM1553ModeSyncError | 0x00000005 | Finds invalid sync pulses.
AgInfiniiVisionSearchSerialM1553ModeManchesterError | 0x00000006 | Finds Manchester encoding errors.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchSPIModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchSPIModeEnum Enumeration
See Also

Specifies whether the SPI search will be on the MOSI data or the MISO data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchSPIModeEnum
C#
public enum AgInfiniiVisionSearchSPIModeEnum
Visual C++
public enum class AgInfiniiVisionSearchSPIModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchSPIModeMOSI | 0x00000000 | Searches on MOSI data.
AgInfiniiVisionSearchSPIModeMISO | 0x00000001 | Searches on MISO data.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchTransitionConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchTransitionConditionEnum Enumeration
See Also

Values that specify whether to search for edge transition greater than or less than a time.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchTransitionConditionEnum
C#
public enum AgInfiniiVisionSearchTransitionConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchTransitionConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchTransitionConditionGreaterThan | 0x00000000 | Search for edge transitions greater than a time.
AgInfiniiVisionSearchTransitionConditionLessThan | 0x00000001 | Search for edge transitions less than a time.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchTransitionSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchTransitionSlopeEnum Enumeration
See Also

Values that specify whether to search for rising edge transitions or falling edge transitions.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchTransitionSlopeEnum
C#
public enum AgInfiniiVisionSearchTransitionSlopeEnum
Visual C++
public enum class AgInfiniiVisionSearchTransitionSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchTransitionSlopeNegative | 0x00000000 | Search for falling edge transitions (Negative slope).
AgInfiniiVisionSearchTransitionSlopePositive | 0x00000001 | Search for rising edge transitions (Positive slope).

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchUARTConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchUARTConditionEnum Enumeration
See Also

Specifies the data value qualifier when searching for UART/RS232 events.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchUARTConditionEnum
C#
public enum AgInfiniiVisionSearchUARTConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchUARTConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchUARTConditionEqual | 0x00000000 | Searches for a value equal to the specified value.
AgInfiniiVisionSearchUARTConditionNotEqual | 0x00000001 | Searches for a value not equal to the specified value.
AgInfiniiVisionSearchUARTConditionGreaterThan | 0x00000002 | Searches for a value greater than the specified value.
AgInfiniiVisionSearchUARTConditionLessThan | 0x00000003 | Searches for a value less than the specified value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchUARTModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchUARTModeEnum Enumeration
See Also

Values for the type of UART/RS232 information to find in the Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchUARTModeEnum
C#
public enum AgInfiniiVisionSearchUARTModeEnum
Visual C++
public enum class AgInfiniiVisionSearchUARTModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchUARTModeRData | 0x00000000 | Searches for a receive data value when data words are from 5 to 8 bits long.
AgInfiniiVisionSearchUARTModeRD1 | 0x00000001 | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 1
AgInfiniiVisionSearchUARTModeRD0 | 0x00000002 | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 0
AgInfiniiVisionSearchUARTModeRDX | 0x00000003 | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X).
AgInfiniiVisionSearchUARTModeTData | 0x00000004 | Searches for a transmit data value when data words are from 5 to 8 bits long.
AgInfiniiVisionSearchUARTModeTD1 | 0x00000005 | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 1.
AgInfiniiVisionSearchUARTModeTD0 | 0x00000006 | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 0.
AgInfiniiVisionSearchUARTModeTDX | 0x00000007 | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X).
AgInfiniiVisionSearchUARTModeParityError | 0x00000008 | Searches for parity errors.
AgInfiniiVisionSearchUARTModeAnyError | 0x00000009 | Searches for any error.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSearchUSBConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSearchUSBConditionEnum Enumeration
See Also

The USB search mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSearchUSBConditionEnum
C#
public enum AgInfiniiVisionSearchUSBConditionEnum
Visual C++
public enum class AgInfiniiVisionSearchUSBConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSearchUSBConditionToken | 0x00000000 | Token.
AgInfiniiVisionSearchUSBConditionData | 0x00000001 | Data state.
AgInfiniiVisionSearchUSBConditionHandshake | 0x00000002 | Handshake.
AgInfiniiVisionSearchUSBConditionSpecial | 0x00000003 | Special.
AgInfiniiVisionSearchUSBConditionAllErrors | 0x00000004 | All errors.
AgInfiniiVisionSearchUSBConditionPIDError | 0x00000005 | PID error.
AgInfiniiVisionSearchUSBConditionCRC5Error | 0x00000006 | CRC5 error.
AgInfiniiVisionSearchUSBConditionCRC16Error | 0x00000007 | CRC16 error.
AgInfiniiVisionSearchUSBConditionGlitchError | 0x00000008 | Glitch error.
AgInfiniiVisionSearchUSBConditionStuffError | 0x00000009 | Stuff error.
AgInfiniiVisionSearchUSBConditionSE1Error | 0x0000000A | SE1 error.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusARINC429BaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusARINC429BaseEnum Enumeration
See Also

Specifies the ARINC 429 base for the selected bus. The base setting will be used for both the Lister and the decode line displays, and controls how the Data field is displayed.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusARINC429BaseEnum
C#
public enum AgInfiniiVisionSerialBusARINC429BaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusARINC429BaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusARINC429BaseBinary | 0x00000000 | Specifies the base to be binary.
AgInfiniiVisionSerialBusARINC429BaseHexadecimal | 0x00000001 | Specifies the base to be hexadecimal.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusARINC429DisplayFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusARINC429DisplayFormatEnum Enumeration
See Also

Specifies the display format for both the decode line and the Lister.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusARINC429DisplayFormatEnum
C#
public enum AgInfiniiVisionSerialBusARINC429DisplayFormatEnum
Visual C++
public enum class AgInfiniiVisionSerialBusARINC429DisplayFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusARINC429DisplayFormatLabelSDIDataSSM | 0x00000000 | Specifies the Label/SDI/Data/SSM format.
AgInfiniiVisionSerialBusARINC429DisplayFormatLabelDataSSM | 0x00000001 | Specifies the Label/Data/SSM format.
AgInfiniiVisionSerialBusARINC429DisplayFormatLabelData | 0x00000002 | Specifies the Label/SDI format.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusARINC429SignalTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusARINC429SignalTypeEnum Enumeration
See Also

Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusARINC429SignalTypeEnum
C#
public enum AgInfiniiVisionSerialBusARINC429SignalTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusARINC429SignalTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusARINC429SignalTypeLineA | 0x00000000 | Specifies the Line A (non-inverted) signal type.
AgInfiniiVisionSerialBusARINC429SignalTypeLineB | 0x00000001 | Specifies the Line B (inverted) signal type.
AgInfiniiVisionSerialBusARINC429SignalTypeDifferential | 0x00000002 | Specifies the Differential (A - B) signal type.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusARINC429SpeedEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusARINC429SpeedEnum Enumeration
See Also

Specifies the speed of the ARINC 429 interface for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusARINC429SpeedEnum
C#
public enum AgInfiniiVisionSerialBusARINC429SpeedEnum
Visual C++
public enum class AgInfiniiVisionSerialBusARINC429SpeedEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusARINC429SpeedLow | 0x00000000 | Specifies low speed (12.5kb/s).
AgInfiniiVisionSerialBusARINC429SpeedHigh | 0x00000001 | Specifies high speed (100kb/s).

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusARINC429TriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusARINC429TriggerTypeEnum Enumeration
See Also

Specifies the ARINC 429 trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusARINC429TriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusARINC429TriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusARINC429TriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusARINC429TriggerTypeWordStart | 0x00000000 | Word Start trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeWordStop | 0x00000001 | Word Stop trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeLabel | 0x00000002 | Label trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeLabelBits | 0x00000003 | Label + Bits trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeLabelRange | 0x00000004 | Label Range trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeParityError | 0x00000005 | Parity Error trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeWordError | 0x00000006 | Word Error trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeWordOrGapError | 0x00000007 | Word or Gap Error trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeAllErrors | 0x00000008 | All Errors trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeAllBits | 0x00000009 | All bits trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeAllZeroBits | 0x0000000A | All zero bits trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeAllOneBits | 0x0000000B | All one bits trigger mode.
AgInfiniiVisionSerialBusARINC429TriggerTypeGapError | 0x0000000C | Gap error trigger mode.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusCANDisplayEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusCANDisplayEnum Enumeration
See Also

Values for Serial Bus CAN display

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusCANDisplayEnum
C#
public enum AgInfiniiVisionSerialBusCANDisplayEnum
Visual C++
public enum class AgInfiniiVisionSerialBusCANDisplayEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusCANDisplayHexadecimal | 0x00000000 | Hexadecimal values are displayed
AgInfiniiVisionSerialBusCANDisplaySymbolic | 0x00000001 | Symbolic values are displayed

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusCANFDStandardEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusCANFDStandardEnum Enumeration
See Also

The CAN standard to use when decoding or triggering on FD frames.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusCANFDStandardEnum
C#
public enum AgInfiniiVisionSerialBusCANFDStandardEnum
Visual C++
public enum class AgInfiniiVisionSerialBusCANFDStandardEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusCANFDStandardISO | 0x00000000 | ISO Standard that will be used when decoding or triggering on FD frames
AgInfiniiVisionSerialBusCANFDStandardNISO | 0x00000001 | Non-ISO Standard will be used when decoding or triggering on FD frames

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusCANPatternIDTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusCANPatternIDTypeEnum Enumeration
See Also

Values for the CAN identifier mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusCANPatternIDTypeEnum
C#
public enum AgInfiniiVisionSerialBusCANPatternIDTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusCANPatternIDTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusCANPatternIDTypeStandard | 0x00000000 | Selects the standard 11-bit identifier.
AgInfiniiVisionSerialBusCANPatternIDTypeExtended | 0x00000001 | Selects the extended 29-bit identifier.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusCANSignalTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusCANSignalTypeEnum Enumeration
See Also

Values for the CAN signal type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusCANSignalTypeEnum
C#
public enum AgInfiniiVisionSerialBusCANSignalTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusCANSignalTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusCANSignalTypeCANH | 0x00000000 | The actual CAN_H differential bus signal.
AgInfiniiVisionSerialBusCANSignalTypeCANL | 0x00000001 | The actual CAN_L differential bus signal.
AgInfiniiVisionSerialBusCANSignalTypeRX | 0x00000002 | The Receive signal from the CAN bus transceiver
AgInfiniiVisionSerialBusCANSignalTypeTX | 0x00000003 | The Transmit signal to the CAN bus transceiver.
AgInfiniiVisionSerialBusCANSignalTypeDifferential | 0x00000004 | The CAN differential bus signal connected to an analog source channel using a differential probe. This is the same as DIFL.
AgInfiniiVisionSerialBusCANSignalTypeDIFL | 0x00000005 | The CAN differential (L-H) bus signal connected to an analog source channel using a differential probe.
AgInfiniiVisionSerialBusCANSignalTypeDIFH | 0x00000006 | The CAN differential (H-L) bus signal connected to an analog source channel using a differential probe.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusCANTriggerConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusCANTriggerConditionEnum Enumeration
See Also

Values for the CAN trigger on condition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusCANTriggerConditionEnum
C#
public enum AgInfiniiVisionSerialBusCANTriggerConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusCANTriggerConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusCANTriggerConditionSOF | 0x00000000 | Will trigger on the Start of Frame (SOF) bit of a Data frame, Remote Transfer Request (RTR) frame, or an Overload frame.
AgInfiniiVisionSerialBusCANTriggerConditionData | 0x00000001 | Will trigger on CAN Data frames matching the specified Id, Data, and the DLC (Data length code).
AgInfiniiVisionSerialBusCANTriggerConditionError | 0x00000002 | Will trigger on CAN Error frame.
AgInfiniiVisionSerialBusCANTriggerConditionIDData | 0x00000003 | Will trigger on CAN frames matching the specified Id of a Data frame.
AgInfiniiVisionSerialBusCANTriggerConditionIDEither | 0x00000004 | Will trigger on the specified Id, regardless if it is a Remote frame or a Data frame.
AgInfiniiVisionSerialBusCANTriggerConditionIDRemote | 0x00000005 | Will trigger on CAN frames matching the specified Id of a Remote frame.
AgInfiniiVisionSerialBusCANTriggerConditionAllErrors | 0x00000006 | Will trigger on CAN active error frames and unknown bus conditions.
AgInfiniiVisionSerialBusCANTriggerConditionOverload | 0x00000007 | Will trigger on CAN overload frames.
AgInfiniiVisionSerialBusCANTriggerConditionAckError | 0x00000008 | Will trigger on a data or remote frame acknowledge bit that is recessive.
AgInfiniiVisionSerialBusCANTriggerConditionEOF | 0x00000009 | Triggers at the end of any frame.
AgInfiniiVisionSerialBusCANTriggerConditionFDData | 0x0000000A | Triggers on CAN FD frames at the end of the last data byte defined in the trigger. You can trigger on up to 8 bytes of data anywhere within the CAN FD data, which can be up to 64 bytes long.
AgInfiniiVisionSerialBusCANTriggerConditionFormError | 0x0000000B | Triggers on reserved bit errors.
AgInfiniiVisionSerialBusCANTriggerConditionStuffError | 0x0000000C | Triggers on 6 consecutive 1s or 6 consecutive 0s, while in a non-error or non overload frame.
AgInfiniiVisionSerialBusCANTriggerConditionCRCError | 0x0000000D | Triggers when the calculated CRC does not match the transmitted CRC.
AgInfiniiVisionSerialBusCANTriggerConditionSpecError | 0x0000000E | Triggers on Ack, Form, Stuff, or CRC errors.
AgInfiniiVisionSerialBusCANTriggerConditionBRSBit | 0x0000000F | Triggers on the BRS bit of CAN FD frames.
AgInfiniiVisionSerialBusCANTriggerConditionCRCDbit | 0x00000010 | Triggers on the CRC delimiter bit in CAN FD frames.
AgInfiniiVisionSerialBusCANTriggerConditionEBActive | 0x00000011 | Triggers on the ESI bit if set active.
AgInfiniiVisionSerialBusCANTriggerConditionEBPassive | 0x00000012 | Triggers on the ESI bit if set passive.
AgInfiniiVisionSerialBusCANTriggerConditionMsg | 0x00000013 | Triggers on a symbolic message.
AgInfiniiVisionSerialBusCANTriggerConditionMsgSig | 0x00000014 | Triggers on a symbolic message and a signal value.
AgInfiniiVisionSerialBusCANTriggerConditionFDMsgSig | 0x00000015 | Triggers on a symbolic message and a signal value, limited to the first 8 bytes of FD data.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusEnum Enumeration
See Also

Values of recall destination for LDF or DBC files

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusEnum
C#
public enum AgInfiniiVisionSerialBusEnum
Visual C++
public enum class AgInfiniiVisionSerialBusEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBus1 | 0x00000000 | Selects Serial Bus 1 as the recall destination for LDF or DBC files.
AgInfiniiVisionSerialBus2 | 0x00000001 | Selects Serial Bus 2 as the recall destination for LDF or DBC files.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusFlexRayChannelEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusFlexRayChannelEnum Enumeration
See Also

Specifies whether the FlexRay Signal is for Bus A or B. It is important to specify the correct bus because this setting affects CRC error detection.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusFlexRayChannelEnum
C#
public enum AgInfiniiVisionSerialBusFlexRayChannelEnum
Visual C++
public enum class AgInfiniiVisionSerialBusFlexRayChannelEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusFlexRayChannelA | 0x00000000 | Specifies that the FlexRay Signal is for Bus A.
AgInfiniiVisionSerialBusFlexRayChannelB | 0x00000001 | Specifies that the FlexRay Signal is for Bus B.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum Enumeration
See Also

Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum
C#
public enum AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeAll | 0x00000000 | Triggers on ALL errors.
AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeHeaderCRC | 0x00000001 | Triggers on only Header CRC errors.
AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeFrameCRC | 0x00000002 | Triggers on only Frame CRC errors.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum Enumeration
See Also

Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum
C#
public enum AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusFlexRayTriggerEventTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeWakeUp | 0x00000000 | Triggers on Wake-Up event.
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeTSS | 0x00000001 | Triggers on Transmission Start Sequence event.
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeBSS | 0x00000002 | Triggers on Byte Start Sequence event.
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeFES | 0x00000003 | Triggers on Frame End Sequence event. This is equivalent to DTS.
AgInfiniiVisionSerialBusFlexRayTriggerEventTypeDTS | 0x00000004 | Triggers on Dynamic Trailing Sequence event. This is equivalent to FES.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum Enumeration
See Also

Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum
C#
public enum AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNormal | 0x00000000 | Trigger on only normal frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeStartup | 0x00000001 | Trigger on only startup frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNull | 0x00000002 | Trigger on only null frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeSync | 0x00000003 | Trigger on only sync frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotStartup | 0x00000004 | Trigger on frames other than startup frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotNull | 0x00000005 | Trigger on frames other than null frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotSync | 0x00000006 | Trigger on frames other than sync frames.
AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeAll | 0x00000007 | Trigger on all FlexRay frame types.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum Enumeration
See Also

Specifies the FlexRay trigger on condition.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusFlexRayTriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusFlexRayTriggerTypeFrame | 0x00000000 | Triggers on specified frames (without errors).
AgInfiniiVisionSerialBusFlexRayTriggerTypeError | 0x00000001 | Triggers on selected active error frames and unknown bus conditions.
AgInfiniiVisionSerialBusFlexRayTriggerTypeEvent | 0x00000002 | Triggers on specified FlexRay event/symbol.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2SBaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2SBaseEnum Enumeration
See Also

Specifies the base to use for the I2S decode display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2SBaseEnum
C#
public enum AgInfiniiVisionSerialBusI2SBaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2SBaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2SBaseDecimal | 0x00000000 | Specifies the decimal base.
AgInfiniiVisionSerialBusI2SBaseHexadecimal | 0x00000001 | Specifies the hexadecimal base.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2SClockSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2SClockSlopeEnum Enumeration
See Also

Specifies which edge of the I2S serial clock signal clocks in data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2SClockSlopeEnum
C#
public enum AgInfiniiVisionSerialBusI2SClockSlopeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2SClockSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2SClockSlopeNegative | 0x00000000 | Falling edge.
AgInfiniiVisionSerialBusI2SClockSlopePositive | 0x00000001 | Rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2SDataAlignmentEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2SDataAlignmentEnum Enumeration
See Also

Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2SDataAlignmentEnum
C#
public enum AgInfiniiVisionSerialBusI2SDataAlignmentEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2SDataAlignmentEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2SDataAlignmentStandard | 0x00000000 | Standard alignment.
AgInfiniiVisionSerialBusI2SDataAlignmentLeftJustified | 0x00000001 | Left Justified.
AgInfiniiVisionSerialBusI2SDataAlignmentRightJustified | 0x00000002 | Right Justified.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum Enumeration
See Also

Specifies the audio channel to trigger on.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum
C#
public enum AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2STriggerAudioChannelEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2STriggerAudioChannelLeft | 0x00000000 | Left audio channel.
AgInfiniiVisionSerialBusI2STriggerAudioChannelRight | 0x00000001 | Right audio channel.
AgInfiniiVisionSerialBusI2STriggerAudioChannelEither | 0x00000002 | Either left or right audio channel.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2STriggerConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2STriggerConditionEnum Enumeration
See Also

Specifies the I2S trigger operator.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2STriggerConditionEnum
C#
public enum AgInfiniiVisionSerialBusI2STriggerConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2STriggerConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2STriggerConditionEqual | 0x00000000 | Triggers on the specified audio channel's data word when it equals the specified word.
AgInfiniiVisionSerialBusI2STriggerConditionNotEqual | 0x00000001 | Triggers on any word other than the specified word.
AgInfiniiVisionSerialBusI2STriggerConditionLessThan | 0x00000002 | Triggers when the channel's data word is less than the specified value.
AgInfiniiVisionSerialBusI2STriggerConditionGreaterThan | 0x00000003 | Triggers when the channel's data word is greater than the specified value.
AgInfiniiVisionSerialBusI2STriggerConditionInRange | 0x00000004 | Enter upper and lower values to specify the range in which to trigger.
AgInfiniiVisionSerialBusI2STriggerConditionOutRange | 0x00000005 | Enter upper and lower values to specify range in which trigger will not occur.
AgInfiniiVisionSerialBusI2STriggerConditionIncreasing | 0x00000006 | Triggers when the data value makes a certain increase over time and the specified value is met or exceeded
AgInfiniiVisionSerialBusI2STriggerConditionDecreasing | 0x00000007 | Similar to Increasing except the trigger occurs on a certain decrease over time and the "Trigger" data value is less than the "Armed" data value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum Enumeration
See Also

Specifies the polarity of the word select (WS) signal.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum
C#
public enum AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum
Visual C++
public enum class AgInfiniiVisionSerialBusI2SWordSelectPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusI2SWordSelectPolarityLeft | 0x00000000 | A word select (WS) state of low indicates left channel data is active on the I2S bus, and a WS state of high indicates right channel data is active on the bus.
AgInfiniiVisionSerialBusI2SWordSelectPolarityRight | 0x00000001 | A word select (WS) state of low indicates right channel data is active on the I2S bus, and a WS state of high indicates left channel data is active on the bus.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusIICAddressWidthEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusIICAddressWidthEnum Enumeration
See Also

Determines whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusIICAddressWidthEnum
C#
public enum AgInfiniiVisionSerialBusIICAddressWidthEnum
Visual C++
public enum class AgInfiniiVisionSerialBusIICAddressWidthEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusIICAddressWidthBit7 | 0x00000000 | Bit 7
AgInfiniiVisionSerialBusIICAddressWidthBit8 | 0x00000001 | Bit 8

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusIICTriggerConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusIICTriggerConditionEnum Enumeration
See Also

Specifies the IIC data qualifier.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusIICTriggerConditionEnum
C#
public enum AgInfiniiVisionSerialBusIICTriggerConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusIICTriggerConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusIICTriggerConditionEqual | 0x00000000 | Equal to the specified value.
AgInfiniiVisionSerialBusIICTriggerConditionNotEqual | 0x00000001 | Not equal to the specified value.
AgInfiniiVisionSerialBusIICTriggerConditionLessThan | 0x00000002 | Less than the specified value.
AgInfiniiVisionSerialBusIICTriggerConditionGreaterThan | 0x00000003 | Greater than the specified value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusIICTriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusIICTriggerTypeEnum Enumeration
See Also

Specifies the IIC trigger type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusIICTriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusIICTriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusIICTriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusIICTriggerTypeStart | 0x00000000 | Start condition.
AgInfiniiVisionSerialBusIICTriggerTypeStop | 0x00000001 | Stop condition.
AgInfiniiVisionSerialBusIICTriggerTypeRead7 | 0x00000002 | 7-bit address frame containing (Start:Address7:Read:Ack:Data).
AgInfiniiVisionSerialBusIICTriggerTypeR7Data2 | 0x00000003 | 7-bit address frame containing (Start:Address7:Read:Ack:Data:Ack:Data2).
AgInfiniiVisionSerialBusIICTriggerTypeReadEprom | 0x00000004 | EEPROM data read.
AgInfiniiVisionSerialBusIICTriggerTypeWrite7 | 0x00000005 | 7-bit address frame containing (Start:Address7:Write:Ack:Data).
AgInfiniiVisionSerialBusIICTriggerTypeW7Data2 | 0x00000006 | 7-bit address frame containing (Start:Address7:Write:Ack:Data:Ack:Data2).
AgInfiniiVisionSerialBusIICTriggerTypeWrite10 | 0x00000007 | 10-bit address frame containing (Start:Address byte1:Write:Ack:Address byte 2:Data).
AgInfiniiVisionSerialBusIICTriggerTypeMissingAcknowledge | 0x00000008 | Missing acknowledge.
AgInfiniiVisionSerialBusIICTriggerTypeNoAcknowledge | 0x00000009 | Address with no acknowledge.
AgInfiniiVisionSerialBusIICTriggerTypeRestart | 0x0000000A | Another start condition occurs before a stop condition.
AgInfiniiVisionSerialBusIICTriggerTypeAddress | 0x0000000B | Triggers on the selected address. The R/W bit is ignored
AgInfiniiVisionSerialBusIICTriggerTypeDataNoAck | 0x0000000C | Write data with no acknowledge

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusLINDisplayEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusLINDisplayEnum Enumeration
See Also

Specifies the LIN symbolic data loaded into the oscilloscope

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusLINDisplayEnum
C#
public enum AgInfiniiVisionSerialBusLINDisplayEnum
Visual C++
public enum class AgInfiniiVisionSerialBusLINDisplayEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusLINDisplayHexadecimal | 0x00000000 | Hexadecimal values.
AgInfiniiVisionSerialBusLINDisplaySymbolic | 0x00000001 | Symbolic values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusLINStandardEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusLINStandardEnum Enumeration
See Also

Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusLINStandardEnum
C#
public enum AgInfiniiVisionSerialBusLINStandardEnum
Visual C++
public enum class AgInfiniiVisionSerialBusLINStandardEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusLINStandardLIN13 | 0x00000000 | Specifies the LIN 1.3 standard.
AgInfiniiVisionSerialBusLINStandardLIN20 | 0x00000001 | Specifies the LIN 2.0 standard.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusLINTriggerConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusLINTriggerConditionEnum Enumeration
See Also

Specifies the LIN trigger condition to be.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusLINTriggerConditionEnum
C#
public enum AgInfiniiVisionSerialBusLINTriggerConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusLINTriggerConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusLINTriggerConditionSyncBreak | 0x00000000 | Sync Break.
AgInfiniiVisionSerialBusLINTriggerConditionID | 0x00000001 | Frame ID.
AgInfiniiVisionSerialBusLINTriggerConditionData | 0x00000002 | Frame ID and Data
AgInfiniiVisionSerialBusLINTriggerConditionParityErr | 0x00000003 | Parity Errors
AgInfiniiVisionSerialBusLINTriggerConditionChecksumErr | 0x00000004 | Checksum Errors
AgInfiniiVisionSerialBusLINTriggerConditionFrame | 0x00000005 | Triggers on a symbolic frame
AgInfiniiVisionSerialBusLINTriggerConditionFrameSig | 0x00000006 | Triggers on a symbolic frame and a signal value

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusListerDisplayEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusListerDisplayEnum Enumeration
See Also

Values for the lister display setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusListerDisplayEnum
C#
public enum AgInfiniiVisionSerialBusListerDisplayEnum
Visual C++
public enum class AgInfiniiVisionSerialBusListerDisplayEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusListerDisplayOff | 0x00000000 | The lister is off.
AgInfiniiVisionSerialBusListerDisplaySerialBus1 | 0x00000001 | Display Serial Bus 1 in the lister.
AgInfiniiVisionSerialBusListerDisplaySerialBus2 | 0x00000002 | Not Supported on 2000X series. Display Serial Bus 2 in the lister.
AgInfiniiVisionSerialBusListerDisplayAll | 0x00000003 | Not Supported on 2000X series. Display all serial buses in the lister. The decode information for different buses is interleaved in time.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusListerTimeReferenceEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusListerTimeReferenceEnum Enumeration
See Also

Values for the lister time reference setting.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusListerTimeReferenceEnum
C#
public enum AgInfiniiVisionSerialBusListerTimeReferenceEnum
Visual C++
public enum class AgInfiniiVisionSerialBusListerTimeReferenceEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusListerTimeReferenceTrigger | 0x00000000 | The time value for a Lister row is relative to the trigger.
AgInfiniiVisionSerialBusListerTimeReferencePrevious | 0x00000001 | The time value for a Lister row is relative to the previous Lister row.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusM1553BaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusM1553BaseEnum Enumeration
See Also

Specifies the base to use for the MIL-STD 1553 decode display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusM1553BaseEnum
C#
public enum AgInfiniiVisionSerialBusM1553BaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusM1553BaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusM1553BaseBinary | 0x00000000 | Specifies binary base for the MIL-STD 1553 decode display.
AgInfiniiVisionSerialBusM1553BaseHexadecimal | 0x00000001 | Specifies hexadecimal base for the MIL-STD 1553 decode display.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusM1553TriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusM1553TriggerTypeEnum Enumeration
See Also

Specifies the type of MIL-STD 1553 trigger to be used.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusM1553TriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusM1553TriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusM1553TriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusM1553TriggerTypeDataStart | 0x00000000 | (Data Word Start) triggers on the start of a Data word (at the end of a valid Data Sync pulse).
AgInfiniiVisionSerialBusM1553TriggerTypeDataStop | 0x00000001 | (Data Word Stop) triggers on the end of a Data word.
AgInfiniiVisionSerialBusM1553TriggerTypeCommandStart | 0x00000002 | (Command/Status Word Start) triggers on the start of Comamnd/Status word (at the end of a valid C/S Sync pulse).
AgInfiniiVisionSerialBusM1553TriggerTypeCommandStop | 0x00000003 | (Command/Status Word Stop) triggers on the end of a Command/Status word.
AgInfiniiVisionSerialBusM1553TriggerTypeRTA | 0x00000004 | (Remote Terminal Address) triggers if the RTA of the Command/Status word matches the specified value. The value is specified in hex.
AgInfiniiVisionSerialBusM1553TriggerTypeRTA11 | 0x00000005 | (RTA + 11 Bits) triggers if the RTA and the remaining 11 bits match the specified criteria. The RTA can be specifed as a hex value, and the remaining 11 bits can be specifed as a 1, 0, or X (don't care).
AgInfiniiVisionSerialBusM1553TriggerTypeParityError | 0x00000006 | (Parity Error) triggers if the (odd) parity bit is incorrect for the data in the word.
AgInfiniiVisionSerialBusM1553TriggerTypeManchesterError | 0x00000007 | (Manchester Error) triggers if a Manchester encoding error is detected.
AgInfiniiVisionSerialBusM1553TriggerTypeSyncError | 0x00000008 | (Sync Error) triggers if an invalid Sync pulse is found.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusModeEnum Enumeration
See Also

Specifies the decode mode for the serial bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusModeEnum
C#
public enum AgInfiniiVisionSerialBusModeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusModeCAN | 0x00000000 | CAN mode.
AgInfiniiVisionSerialBusModeI2S | 0x00000001 | I2S mode.
AgInfiniiVisionSerialBusModeIIC | 0x00000002 | IIC mode.
AgInfiniiVisionSerialBusModeLIN | 0x00000003 | LIN mode.
AgInfiniiVisionSerialBusModeSPI | 0x00000004 | SPI mode.
AgInfiniiVisionSerialBusModeUART | 0x00000005 | UART mode.
AgInfiniiVisionSerialBusModeNone | 0x00000006 | None.
AgInfiniiVisionSerialBusModeARINC429 | 0x00000007 | ARINC 429 Mode.
AgInfiniiVisionSerialBusModeM1553 | 0x00000008 | MIL-STD 1553 Mode.
AgInfiniiVisionSerialBusModeFlexRay | 0x00000009 | FlexRay mode.
AgInfiniiVisionSerialBusModeUSB | 0x0000000A | USB Mode.
AgInfiniiVisionSerialBusModeSENT | 0x0000000B | SENT Mode.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTCRCEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTCRCEnum Enumeration
See Also

CRC.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTCRCEnum
C#
public enum AgInfiniiVisionSerialBusSENTCRCEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTCRCEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTCRCLegacy | 0x00000000 | Legacy.
AgInfiniiVisionSerialBusSENTCRCRecomended | 0x00000001 | Recomended.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTFormatEnum Enumeration
See Also

Message Formats.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTFormatEnum
C#
public enum AgInfiniiVisionSerialBusSENTFormatEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTFormatNibbles | 0x00000000 | Shows the fast channel message in raw hex.
AgInfiniiVisionSerialBusSENTFormatFSIGnal | 0x00000001 | Shows the defined Signals of the Fast Channel in Hex or Decimal based on the BASE command.
AgInfiniiVisionSerialBusSENTFormatFSSerial | 0x00000002 | Shows the Fast Signals and Short Serial Messages.
AgInfiniiVisionSerialBusSENTFormatFESerial | 0x00000003 | Shows the Fast Signals and Enhanced Serial Messages.
AgInfiniiVisionSerialBusSENTFormatSSERial | 0x00000004 | Shows only Short Serial Messages.
AgInfiniiVisionSerialBusSENTFormatESERial | 0x00000005 | Shows only Enhanced Serial Messages.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTIdleStateEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTIdleStateEnum Enumeration
See Also

Idle State.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTIdleStateEnum
C#
public enum AgInfiniiVisionSerialBusSENTIdleStateEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTIdleStateEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTIdleStateLow | 0x00000000 | Low.
AgInfiniiVisionSerialBusSENTIdleStateHigh | 0x00000001 | High.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTNumberBaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTNumberBaseEnum Enumeration
See Also

Number base.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTNumberBaseEnum
C#
public enum AgInfiniiVisionSerialBusSENTNumberBaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTNumberBaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTNumberBaseHex | 0x00000000 | Hex number.
AgInfiniiVisionSerialBusSENTNumberBaseDecimal | 0x00000001 | Decimal number.
AgInfiniiVisionSerialBusSENTNumberBaseSymbolic | 0x00000002 | Symbolic.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTSignalOrderEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTSignalOrderEnum Enumeration
See Also

Nibble order.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTSignalOrderEnum
C#
public enum AgInfiniiVisionSerialBusSENTSignalOrderEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTSignalOrderEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTSignalOrderMSNF | 0x00000000 | Most Significant Nibble first.
AgInfiniiVisionSerialBusSENTSignalOrderLSNF | 0x00000001 | Least Significant Nibble first.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum Enumeration
See Also

ID and data length format.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum
C#
public enum AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTTriggerIDLengthEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTTriggerIDLengthShort | 0x00000000 | "SHORt" the 16-bit data, 4-bit ID format.
AgInfiniiVisionSerialBusSENTTriggerIDLengthLong | 0x00000001 | "LONG" for the 12-bit data, 8-bit ID format.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSENTTriggerModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSENTTriggerModeEnum Enumeration
See Also

The automative SENT serial decode trigger modes

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSENTTriggerModeEnum
C#
public enum AgInfiniiVisionSerialBusSENTTriggerModeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSENTTriggerModeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSENTTriggerModeFastChanMsg | 0x00000000 | SFCMessage — triggers on the start of any Fast Channel Message (after 56 Synchronization/Calibration ticks).
AgInfiniiVisionSerialBusSENTTriggerModeSlowChanMsg | 0x00000001 | SSCMessage — trigger on the start of any Slow Channel Message.
AgInfiniiVisionSerialBusSENTTriggerModeFastChanScData | 0x00000002 | FCData — triggers on a Fast Channel Message when the Status & Communication nibble and the data nibbles match the values entered using additional softkeys.
AgInfiniiVisionSerialBusSENTTriggerModeSlowChanMsgId | 0x00000003 | SCMid — triggers when a Slow Channel Message ID matches the value entered using additional softkeys.
AgInfiniiVisionSerialBusSENTTriggerModeSlowChanMsgIdData | 0x00000004 | SCData — triggers when a Slow Channel Message ID and Data field both match the values entered using additional softkeys.
AgInfiniiVisionSerialBusSENTTriggerModeToleranceErr | 0x00000005 | TOLerror — triggers when the sync pulse width varies from the nominal value by greater than the entered percentage.
AgInfiniiVisionSerialBusSENTTriggerModeFastChanCrcErr | 0x00000006 | FCCerror — triggers on any Fast Channel Message CRC error.
AgInfiniiVisionSerialBusSENTTriggerModeSlowChanCrcErr | 0x00000007 | SCCerror — triggers on any Slow Channel Message CRC error.
AgInfiniiVisionSerialBusSENTTriggerModeAllCrcErr | 0x00000008 | CRCerror — triggers on any CRC error, Fast or Slow.
AgInfiniiVisionSerialBusSENTTriggerModePulsePeriodErr | 0x00000009 | PPERror — triggers if a nibble is either too wide or too narrow (for example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, or checksum pulse periods are checked.
AgInfiniiVisionSerialBusSENTTriggerModeSyncPulseErr | 0x0000000A | SSPerror — triggers on a sync pulse whose width varies from the previous sync pulse's width by greater than 1/64 (1.5625%, as defined in the SENT specification).

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSPIBitOrderEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSPIBitOrderEnum Enumeration
See Also

Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSPIBitOrderEnum
C#
public enum AgInfiniiVisionSerialBusSPIBitOrderEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSPIBitOrderEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSPIBitOrderLSBFirst | 0x00000000 | LSB first.
AgInfiniiVisionSerialBusSPIBitOrderMSBFirst | 0x00000001 | MSB first.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSPIClockSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSPIClockSlopeEnum Enumeration
See Also

specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSPIClockSlopeEnum
C#
public enum AgInfiniiVisionSerialBusSPIClockSlopeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSPIClockSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSPIClockSlopeNegative | 0x00000000 | Falling edge.
AgInfiniiVisionSerialBusSPIClockSlopePositive | 0x00000001 | Rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSPIFramingEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSPIFramingEnum Enumeration
See Also

Specifies the SPI trigger framing value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSPIFramingEnum
C#
public enum AgInfiniiVisionSerialBusSPIFramingEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSPIFramingEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSPIFramingChipSelect | 0x00000000 | Chip Select.
AgInfiniiVisionSerialBusSPIFramingNChipSelect | 0x00000001 | Not Chip select
AgInfiniiVisionSerialBusSPIFramingTimeout | 0x00000002 | Timeout.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusSPITriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusSPITriggerTypeEnum Enumeration
See Also

Specifies whether the SPI trigger will be on the MOSI data or the MISO data.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusSPITriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusSPITriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusSPITriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusSPITriggerTypeMOSI | 0x00000000 | SPI trigger will be on the MOSI data.
AgInfiniiVisionSerialBusSPITriggerTypeMISO | 0x00000001 | SPI trigger will be on the MISO data.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTBaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTBaseEnum Enumeration
See Also

Specifies the base to use for the UART decode and Lister display.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTBaseEnum
C#
public enum AgInfiniiVisionSerialBusUARTBaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTBaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTBaseASCII | 0x00000000 | ASCII base
AgInfiniiVisionSerialBusUARTBaseBinary | 0x00000001 | Binary base.
AgInfiniiVisionSerialBusUARTBaseHexadecimal | 0x00000002 | Hexadecimal base.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTBitOrderEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTBitOrderEnum Enumeration
See Also

Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTBitOrderEnum
C#
public enum AgInfiniiVisionSerialBusUARTBitOrderEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTBitOrderEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTBitOrderLSBFirst | 0x00000000 | LSB first.
AgInfiniiVisionSerialBusUARTBitOrderMSBFirst | 0x00000001 | MSB first.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTParityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTParityEnum Enumeration
See Also

Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTParityEnum
C#
public enum AgInfiniiVisionSerialBusUARTParityEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTParityEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTParityEven | 0x00000000 | Even parity.
AgInfiniiVisionSerialBusUARTParityOdd | 0x00000001 | Odd parity.
AgInfiniiVisionSerialBusUARTParityNone | 0x00000002 | No parity.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTPolarityEnum Enumeration
See Also

Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTPolarityEnum
C#
public enum AgInfiniiVisionSerialBusUARTPolarityEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTPolarityHigh | 0x00000000 | High polarity.
AgInfiniiVisionSerialBusUARTPolarityLow | 0x00000001 | Low polarity.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTTriggerBaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTTriggerBaseEnum Enumeration
See Also

Specifies the front panel UART/RS232 trigger setup data selection option

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTTriggerBaseEnum
C#
public enum AgInfiniiVisionSerialBusUARTTriggerBaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTTriggerBaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTTriggerBaseASCII | 0x00000000 | Front panel data selection is from ASCII values.
AgInfiniiVisionSerialBusUARTTriggerBaseHexadecimal | 0x00000001 | Front panel data selection is from hexadecimal values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTTriggerConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTTriggerConditionEnum Enumeration
See Also

Specifies the data qualifier for the trigger when in UART mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTTriggerConditionEnum
C#
public enum AgInfiniiVisionSerialBusUARTTriggerConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTTriggerConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTTriggerConditionEqual | 0x00000000 | Equal to the specified value.
AgInfiniiVisionSerialBusUARTTriggerConditionNotEqual | 0x00000001 | Not equal to the specified value.
AgInfiniiVisionSerialBusUARTTriggerConditionGreaterThan | 0x00000002 | Greater than the specified value.
AgInfiniiVisionSerialBusUARTTriggerConditionLessThan | 0x00000003 | Less than the specified value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUARTTriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUARTTriggerTypeEnum Enumeration
See Also

Specifies the UART trigger type.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUARTTriggerTypeEnum
C#
public enum AgInfiniiVisionSerialBusUARTTriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUARTTriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUARTTriggerTypeRStart | 0x00000000 | RStart trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeRStop | 0x00000001 | RStop trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeRData | 0x00000002 | RData trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeRD1 | 0x00000003 | RD1 trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeRD0 | 0x00000004 | RD0 trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeRDX | 0x00000005 | RDX trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeParityError | 0x00000006 | Parity Error trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTStart | 0x00000007 | TStart trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTStop | 0x00000008 | TStop trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTData | 0x00000009 | TData trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTD1 | 0x0000000A | TD1 trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTD0 | 0x0000000B | TD0 trigger type.
AgInfiniiVisionSerialBusUARTTriggerTypeTDX | 0x0000000C | TDX trigger type.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUSBBaseEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUSBBaseEnum Enumeration
See Also

Base value to be used.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUSBBaseEnum
C#
public enum AgInfiniiVisionSerialBusUSBBaseEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUSBBaseEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUSBBaseASCII | 0x00000000 | ASCII values.
AgInfiniiVisionSerialBusUSBBaseBinary | 0x00000001 | Binary values.
AgInfiniiVisionSerialBusUSBBaseDecimal | 0x00000002 | Decimal values.
AgInfiniiVisionSerialBusUSBBaseHexadecimal | 0x00000003 | Hexadecimal values.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUSBConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUSBConditionEnum Enumeration
See Also

Specifies where the USB trigger mode for the selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUSBConditionEnum
C#
public enum AgInfiniiVisionSerialBusUSBConditionEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUSBConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUSBConditionStartOfPacket | 0x00000000 | Start of packet.
AgInfiniiVisionSerialBusUSBConditionEndOfPacket | 0x00000001 | End of packet.
AgInfiniiVisionSerialBusUSBConditionEnterSuspend | 0x00000002 | Enter suspend state.
AgInfiniiVisionSerialBusUSBConditionExitSuspend | 0x00000003 | Exit suspend state.
AgInfiniiVisionSerialBusUSBConditionReset | 0x00000004 | Reset complete.
AgInfiniiVisionSerialBusUSBConditionToken | 0x00000005 | Token.
AgInfiniiVisionSerialBusUSBConditionData | 0x00000006 | Data state.
AgInfiniiVisionSerialBusUSBConditionHandshake | 0x00000007 | Handshake.
AgInfiniiVisionSerialBusUSBConditionSpecial | 0x00000008 | Special
AgInfiniiVisionSerialBusUSBConditionAllErrors | 0x00000009 | All errors.
AgInfiniiVisionSerialBusUSBConditionPacketIDError | 0x0000000A | Packet ID error
AgInfiniiVisionSerialBusUSBConditionCRC5Error | 0x0000000B | CRC5 error.
AgInfiniiVisionSerialBusUSBConditionCRC16Error | 0x0000000C | CRC6 error.
AgInfiniiVisionSerialBusUSBConditionGlitchError | 0x0000000D | Glitch error.
AgInfiniiVisionSerialBusUSBConditionStuffError | 0x0000000E | Stuff error.
AgInfiniiVisionSerialBusUSBConditionSE1Error | 0x0000000F | SE1 error.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionSerialBusUSBSpeedEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionSerialBusUSBSpeedEnum Enumeration
See Also

Speed for USB interface for selected bus.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionSerialBusUSBSpeedEnum
C#
public enum AgInfiniiVisionSerialBusUSBSpeedEnum
Visual C++
public enum class AgInfiniiVisionSerialBusUSBSpeedEnum

Members

Member name | Value | Description
AgInfiniiVisionSerialBusUSBSpeedLow | 0x00000000 | Low speed for USB interface.
AgInfiniiVisionSerialBusUSBSpeedFull | 0x00000001 | Full speed for USB interface.
AgInfiniiVisionSerialBusUSBSpeedHigh | 0x00000002 | High speed for USB interface.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionStatusRegisterEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionStatusRegisterEnum Enumeration
See Also

Enumeration for the Register parameter of the Register property in the Status interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionStatusRegisterEnum
C#
public enum AgInfiniiVisionStatusRegisterEnum
Visual C++
public enum class AgInfiniiVisionStatusRegisterEnum

Members

Member name | Value | Description
AgInfiniiVisionStatusRegisterStatusByte | 0x00000000 | Status Byte register. Conditions defined by IEEE 488.2.
AgInfiniiVisionStatusRegisterStandardEvent | 0x00000001 | Standard Event Status register. Conditions defined by IEEE 488.2.
AgInfiniiVisionStatusRegisterOperation | 0x00000002 | Operation register. Conditions which are part of the instrument's normal operation.
AgInfiniiVisionStatusRegisterOverloadEvent | 0x00000003 | Questionable register. Conditions which give an indication of the quality of various aspects of the signal.
AgInfiniiVisionStatusRegisterMaskTestEvent | 0x00000004 | Mask Test Event Register.
AgInfiniiVisionStatusRegisterArmEvent | 0x00000005 | Arm Event Register
AgInfiniiVisionStatusRegisterTriggerEvent | 0x00000006 | Trigger Event Register.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionStatusSRQReasonEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionStatusSRQReasonEnum Enumeration
See Also

Enumeration for the Reason parameter of the ConfigureServiceRequest method in the Status interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionStatusSRQReasonEnum
C#
public enum AgInfiniiVisionStatusSRQReasonEnum
Visual C++
public enum class AgInfiniiVisionStatusSRQReasonEnum

Members

Member name | Value | Description
AgInfiniiVisionStatusSRQReasonStbMAV | 0x00000001 | Message Available. Bit 4 in the status byte.
AgInfiniiVisionStatusSRQReasonStbUsr | 0x00000002 | An enabled user event condition has occurred. Bit 1 of Status Byte Register.
AgInfiniiVisionStatusSRQReasonStbMsg | 0x00000004 | An advisory has been displayed on the oscilloscope. Bit 2 of Status Byte Register.
AgInfiniiVisionStatusSRQReasonStbTRIG | 0x00000008 | A trigger has occurred. Bit 0 of Status Byte Register.
AgInfiniiVisionStatusSRQReasonEsrOPC | 0x00000010 | Operation Complete. Bit 0 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrQueryError | 0x00000020 | Query Error. Bit 2 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrDeviceError | 0x00000040 | Device Dependent Error. Bit 3 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrExecutionError | 0x00000080 | Execution Error. Bit 4 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrCommandError | 0x00000100 | Command Error. Bit 5 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrUserRequest | 0x00000200 | User Request. Bit 6 of the standard event status register.
AgInfiniiVisionStatusSRQReasonEsrRequestControl | 0x00000400 | The device is requesting control. Bit 1 of Standard Event Status Register.
AgInfiniiVisionStatusSRQReasonEsrPowerOn | 0x00000800 | An OFF to ON transition has occurred. Bit 7 of Standard Event Status Register.
AgInfiniiVisionStatusSRQReasonOperRun | 0x00001000 | The oscilloscope has gone from a stop state to a single or running state. Bit 3 of Operation Status Event register.
AgInfiniiVisionStatusSRQReasonOperAerWaitTRIG | 0x00002000 | The trigger is armed. Bit 5 of Operation Status Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel1Fault | 0x00004000 | Fault has occurred on Channel 1 input. Bit 6 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel2Fault | 0x00008000 | Fault has occurred on Channel 2 input. Bit 7 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel3Fault | 0x00010000 | Fault has occurred on Channel 3 input. Bit 8 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel4Fault | 0x00020000 | Fault has occurred on Channel 4 input. Bit 9 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrExternalTriggerFault | 0x00040000 | Bit 10 of overload event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel1Overload | 0x00080000 | Overload has occurred on Channel 1 input. Bit 0 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel2Overload | 0x00100000 | Overload has occurred on Channel 2 input. Bit 1 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel3Overload | 0x00200000 | Overload has occurred on Channel 3 input. Bit 2 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrChannel4Overload | 0x00400000 | Overload has occurred on Channel 4 input. Bit 3 of Overload Event register.
AgInfiniiVisionStatusSRQReasonOvlrExternalTriggerOverload | 0x00800000 | Bit 4 of overload event register
AgInfiniiVisionStatusSRQReasonMterComplete | 0x01000000 | The mask test is complete. Bit 0 of Mask Test Event register.
AgInfiniiVisionStatusSRQReasonMterFail | 0x02000000 | The mask test failed. Bit 1 of Mask Test Event register.
AgInfiniiVisionStatusSRQReasonMterStarted | 0x04000000 | Mask testing started. Bit 8 of Mask Test Event register.
AgInfiniiVisionStatusSRQReasonMterAutoMask | 0x08000000 | Auto mask creation completed. Bit 10 of Mask Test Event register.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionStatusSubRegisterEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionStatusSubRegisterEnum Enumeration
See Also

Enumeration for the SubRegister parameter of the Register property in the Status interface.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionStatusSubRegisterEnum
C#
public enum AgInfiniiVisionStatusSubRegisterEnum
Visual C++
public enum class AgInfiniiVisionStatusSubRegisterEnum

Members

Member name | Value | Description
AgInfiniiVisionStatusSubRegisterCondition | 0x00000000 | Conditions Register. Read only and not available with the Standard Event Status register. Condition bits represent the current instrument state. Reading a condition register does not change the value of the bits.
AgInfiniiVisionStatusSubRegisterEvent | 0x00000003 | Event Register. Read only and not available with the Status Byte register. Event bits capture changes in condition bits. Reading an event register clears it.
AgInfiniiVisionStatusSubRegisterEnable | 0x00000004 | Enable Register. Can be read or written and is available for all registers. Enable bits select whether an event bit causes a register summary bit, a kind of condition bit, to become true.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTimebaseModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTimebaseModeEnum Enumeration
See Also

Time base Mode

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTimebaseModeEnum
C#
public enum AgInfiniiVisionTimebaseModeEnum
Visual C++
public enum class AgInfiniiVisionTimebaseModeEnum

Members

Member name | Value | Description
AgInfiniiVisionTimebaseModeMain | 0x00000000 | The normal time base mode (Default)
AgInfiniiVisionTimebaseModeWindow | 0x00000001 | Zoomed or delayed time base mode
AgInfiniiVisionTimebaseModeXY | 0x00000002 | In the XY mode, HorizontalScale() and TimeReference() is not available. Measurements are disabled as well.
AgInfiniiVisionTimebaseModeRoll | 0x00000003 | In the ROLL mode, data moves continuously across the display from left to right. The oscilloscope runs continuously and is untriggered. The Timebase reference selection changes to right

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTimebaseReferenceEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTimebaseReferenceEnum Enumeration
See Also

Point on the display where the trigger point is referenced.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTimebaseReferenceEnum
C#
public enum AgInfiniiVisionTimebaseReferenceEnum
Visual C++
public enum class AgInfiniiVisionTimebaseReferenceEnum

Members

Member name | Value | Description
AgInfiniiVisionTimebaseReferenceLeft | 0x00000000 | Left side of the screen
AgInfiniiVisionTimebaseReferenceCenter | 0x00000001 | Center of the screen
AgInfiniiVisionTimebaseReferenceRight | 0x00000002 | Right side of the screen

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerCouplingEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerCouplingEnum Enumeration
See Also

Values for trigger Coupling

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerCouplingEnum
C#
public enum AgInfiniiVisionTriggerCouplingEnum
Visual C++
public enum class AgInfiniiVisionTriggerCouplingEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerCouplingAC | 0x00000000 | The oscilloscope AC couples the trigger signal.
AgInfiniiVisionTriggerCouplingDC | 0x00000001 | The oscilloscope DC couples the trigger signal.
AgInfiniiVisionTriggerCouplingHFReject | 0x00000002 | The oscilloscope filters out the high frequencies from the trigger signal.
AgInfiniiVisionTriggerCouplingLFReject | 0x00000003 | The oscilloscope filters out the low frequencies from the trigger signal.
AgInfiniiVisionTriggerCouplingNoiseReject | 0x00000004 | The oscilloscope requires more hysteresis from the trigger signal.
AgInfiniiVisionTriggerCouplingTV | 0x00000005 | The oscilloscope is in TV trigger mode.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerDelaySlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerDelaySlopeEnum Enumeration
See Also

Specifies the rising or falling edge for the Edge Then Edge trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerDelaySlopeEnum
C#
public enum AgInfiniiVisionTriggerDelaySlopeEnum
Visual C++
public enum class AgInfiniiVisionTriggerDelaySlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerDelaySlopeNegative | 0x00000000 | Falling edge.
AgInfiniiVisionTriggerDelaySlopePositive | 0x00000001 | Rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerEdgeBurstSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerEdgeBurstSlopeEnum Enumeration
See Also

Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerEdgeBurstSlopeEnum
C#
public enum AgInfiniiVisionTriggerEdgeBurstSlopeEnum
Visual C++
public enum class AgInfiniiVisionTriggerEdgeBurstSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerEdgeBurstSlopeNegative | 0x00000000 | Falling Edge.
AgInfiniiVisionTriggerEdgeBurstSlopePositive | 0x00000001 | Rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum Enumeration
See Also

Type of reject filter

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum
C#
public enum AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum
Visual C++
public enum class AgInfiniiVisionTriggerEdgeRejectFilterTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerEdgeRejectFilterTypeHighFrequency | 0x00000000 | High frequency reject filter: adds a 50 kHz low-pass filter in the trigger path
AgInfiniiVisionTriggerEdgeRejectFilterTypeLowFrequency | 0x00000001 | Low frequency reject filter: adds a 50 kHz high-pass filter in series with the trigger waveform
AgInfiniiVisionTriggerEdgeRejectFilterTypeOff | 0x00000002 | Disable any reject filter

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerModifierEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerModifierEnum Enumeration
See Also

Trigger modifier to determine the way oscilloscope behaves in the absence of signal

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerModifierEnum
C#
public enum AgInfiniiVisionTriggerModifierEnum
Visual C++
public enum class AgInfiniiVisionTriggerModifierEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerModifierNone | 0x00000001 | The oscilloscope waits until the trigger the end-user specifies occurs.
AgInfiniiVisionTriggerModifierAuto | 0x00000002 | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerPXIModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerPXIModeEnum Enumeration
See Also

PXI Trigger Mode.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerPXIModeEnum
C#
public enum AgInfiniiVisionTriggerPXIModeEnum
Visual C++
public enum class AgInfiniiVisionTriggerPXIModeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerPXIModeOFF | 0x00000000 | OFF.
AgInfiniiVisionTriggerPXIModeMaster | 0x00000001 | Master.
AgInfiniiVisionTriggerPXIModeSlave | 0x00000002 | Slave.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerRuntConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerRuntConditionEnum Enumeration
See Also

Trigger Runt conditions for specifying runt pulse widths.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerRuntConditionEnum
C#
public enum AgInfiniiVisionTriggerRuntConditionEnum
Visual C++
public enum class AgInfiniiVisionTriggerRuntConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerRuntConditionNone | 0x00000000 | Triggers on runt pulses of any width
AgInfiniiVisionTriggerRuntConditionLessThan | 0x00000001 | Triggers on runt pulses whose width is less than the qualifier time.
AgInfiniiVisionTriggerRuntConditionGreaterThan | 0x00000002 | Triggers on runt pulses whose width is greater than the qualifier time.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerSetupAndHoldSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerSetupAndHoldSlopeEnum Enumeration
See Also

Specifies the polarity for the TV trigger.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerSetupAndHoldSlopeEnum
C#
public enum AgInfiniiVisionTriggerSetupAndHoldSlopeEnum
Visual C++
public enum class AgInfiniiVisionTriggerSetupAndHoldSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerSetupAndHoldSlopeNegative | 0x00000000 | Negative polarity.
AgInfiniiVisionTriggerSetupAndHoldSlopePositive | 0x00000001 | Positive polarity.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerSlopeEnum Enumeration
See Also

Values for edge trigger Slope

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerSlopeEnum
C#
public enum AgInfiniiVisionTriggerSlopeEnum
Visual C++
public enum class AgInfiniiVisionTriggerSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerSlopePositive | 0x00000001 | A positive (rising) edge passing through the trigger level triggers the oscilloscope.
AgInfiniiVisionTriggerSlopeNegative | 0x00000000 | A negative (falling) edge passing through the trigger level triggers the oscilloscope.
AgInfiniiVisionTriggerSlopeEither | 0x00000002 | Either of a negative (falling) or positive (rising) edge passing through the trigger level triggers the oscilloscope.
AgInfiniiVisionTriggerSlopeAlternate | 0x00000003 | Alternate edge passing through the trigger level triggers the oscilloscope.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerTransitionConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerTransitionConditionEnum Enumeration
See Also

Specifies whether you are looking for rise/fall times greater than or less than a certain time value.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerTransitionConditionEnum
C#
public enum AgInfiniiVisionTriggerTransitionConditionEnum
Visual C++
public enum class AgInfiniiVisionTriggerTransitionConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerTransitionConditionGreaterThan | 0x00000000 | Look for rise/fall times greater than a certain time value.
AgInfiniiVisionTriggerTransitionConditionLessThan | 0x00000001 | Look for rise/fall times less than a certain time value.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerTransitionSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerTransitionSlopeEnum Enumeration
See Also

Specifies a Positive rising edge or a Negative falling edge.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerTransitionSlopeEnum
C#
public enum AgInfiniiVisionTriggerTransitionSlopeEnum
Visual C++
public enum class AgInfiniiVisionTriggerTransitionSlopeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerTransitionSlopeNegative | 0x00000000 | Falling edge.
AgInfiniiVisionTriggerTransitionSlopePositive | 0x00000001 | Rising edge.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerTypeEnum Enumeration
See Also

Values for trigger Type

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerTypeEnum
C#
public enum AgInfiniiVisionTriggerTypeEnum
Visual C++
public enum class AgInfiniiVisionTriggerTypeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerTypeEdge | 0x00000001 | Trigger on Edge
AgInfiniiVisionTriggerTypeWidth | 0x00000002 | Trigger on Width
AgInfiniiVisionTriggerTypeRunt | 0x00000003 | Trigger on Runt
AgInfiniiVisionTriggerTypeGlitch | 0x00000004 | Trigger on Glitch
AgInfiniiVisionTriggerTypeTV | 0x00000005 | Trigger on TV
AgInfiniiVisionTriggerTypeACLine | 0x00000007 | Trigger on ACLine
AgInfiniiVisionTriggerTypePattern | 0x00000008 | Trigger on Pattern
AgInfiniiVisionTriggerTypeDelay | 0x00000000 | Edge Then Edge Trigger.
AgInfiniiVisionTriggerTypeEBurst | 0x00000006 | EBurst trigger.
AgInfiniiVisionTriggerTypeSHold | 0x00000009 | Setup and Hold trigger.
AgInfiniiVisionTriggerTypeTransition | 0x0000000A | Trigger on Transition.
AgInfiniiVisionTriggerTypeSerialBus1 | 0x0000000B | Trigger on SerialBus1
AgInfiniiVisionTriggerTypeSerialBus2 | 0x0000000C | Trigger on SerialBus2
AgInfiniiVisionTriggerTypeUSB | 0x0000000D | Trigger on USB
AgInfiniiVisionTriggerTypeNone | 0x0000000E | Read Only - No Trigger type selected.
AgInfiniiVisionTriggerTypeOR | 0x0000000F | OR-logic Trigger.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerUSBConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerUSBConditionEnum Enumeration
See Also

Specifies where the USB trigger will occur.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerUSBConditionEnum
C#
public enum AgInfiniiVisionTriggerUSBConditionEnum
Visual C++
public enum class AgInfiniiVisionTriggerUSBConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerUSBConditionStartOfPacket | 0x00000000 | Start of packet.
AgInfiniiVisionTriggerUSBConditionEndOfPacket | 0x00000001 | End of packet.
AgInfiniiVisionTriggerUSBConditionEnterSuspend | 0x00000002 | Enter suspend state.
AgInfiniiVisionTriggerUSBConditionExitSuspend | 0x00000003 | Exit suspend state.
AgInfiniiVisionTriggerUSBConditionReset | 0x00000004 | Reset complete.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerUSBSpeedEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerUSBSpeedEnum Enumeration
See Also

Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerUSBSpeedEnum
C#
public enum AgInfiniiVisionTriggerUSBSpeedEnum
Visual C++
public enum class AgInfiniiVisionTriggerUSBSpeedEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerUSBSpeedLow | 0x00000000 | Low Speed (1.5 Mb/s)
AgInfiniiVisionTriggerUSBSpeedFull | 0x00000001 | Full Speed (12 Mb/s)

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerZoneEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerZoneEnum Enumeration
See Also

Specifies the Zone Number.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerZoneEnum
C#
public enum AgInfiniiVisionTriggerZoneEnum
Visual C++
public enum class AgInfiniiVisionTriggerZoneEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerZone1 | 0x00000000 | Specifies the Zone 1.
AgInfiniiVisionTriggerZone2 | 0x00000001 | Specifies the Zone 2.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerZoneModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerZoneModeEnum Enumeration
See Also

Trigger zone qualifying conditions

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerZoneModeEnum
C#
public enum AgInfiniiVisionTriggerZoneModeEnum
Visual C++
public enum class AgInfiniiVisionTriggerZoneModeEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerZoneModeIntersect | 0x00000000 | "Must Intersect" qualifying condition.
AgInfiniiVisionTriggerZoneModeNotIntersect | 0x00000001 | "Must Not Intersect" qualifying condition.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTriggerZoneValidityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTriggerZoneValidityEnum Enumeration
See Also

Specifies the trigger zone validity.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTriggerZoneValidityEnum
C#
public enum AgInfiniiVisionTriggerZoneValidityEnum
Visual C++
public enum class AgInfiniiVisionTriggerZoneValidityEnum

Members

Member name | Value | Description
AgInfiniiVisionTriggerZoneValidityValid | 0x00000000 | Trigger valid on the selected zone.
AgInfiniiVisionTriggerZoneValidityInvalid | 0x00000001 | When Zone 1 and Zone 2 overlap and have opposing qualifying conditions (modes).
AgInfiniiVisionTriggerZoneValidityOffScreen | 0x00000002 | When the associated zone is off-screen.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTVSignalFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTVSignalFormatEnum Enumeration
See Also

Values for TV trigger SignalFormat

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTVSignalFormatEnum
C#
public enum AgInfiniiVisionTVSignalFormatEnum
Visual C++
public enum class AgInfiniiVisionTVSignalFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionTVSignalFormatNTSC | 0x00000001 | Configures the oscilloscope to trigger on the NTSC signal format.
AgInfiniiVisionTVSignalFormatPAL | 0x00000002 | Configures the oscilloscope to trigger on the PAL signal format
AgInfiniiVisionTVSignalFormatSECAM | 0x00000003 | Configures the oscilloscope to trigger on the SECAM signal format
AgInfiniiVisionTVSignalFormatPALM | 0x00000004 | Configures the oscilloscope to trigger on the PALM signal format
AgInfiniiVisionTVSignalFormatGeneric | 0x00000005 | Configures the oscilloscope to trigger on the Generic signal format
AgInfiniiVisionTVSignalFormatP480 | 0x00000006 | Configures the oscilloscope to trigger on the P480 signal format
AgInfiniiVisionTVSignalFormatI1080 | 0x00000009 | Configures the oscilloscope to trigger on the I1080 signal format
AgInfiniiVisionTVSignalFormatP720 | 0x00000007 | Configures the oscilloscope to trigger on the P720 signal format
AgInfiniiVisionTVSignalFormatP1080 | 0x00000008 | Configures the oscilloscope to trigger on the P1080 signal format
AgInfiniiVisionTVSignalFormatP1080L25HZ | 0x0000000A | Configures the oscilloscope to trigger on the P1080L25Hz signal format
AgInfiniiVisionTVSignalFormatP1080L50HZ | 0x0000000B | Configures the oscilloscope to trigger on the P1080L50Hz signal format
AgInfiniiVisionTVSignalFormatP1080L60HZ | 0x0000000C | Configures the oscilloscope to trigger on the P1080L60Hz signal format
AgInfiniiVisionTVSignalFormatI1080L60HZ | 0x0000000D | Configures the oscilloscope to trigger on the I1080L60Hz signal format

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTVTriggerEventEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTVTriggerEventEnum Enumeration
See Also

Values for TV trigger Event

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTVTriggerEventEnum
C#
public enum AgInfiniiVisionTVTriggerEventEnum
Visual C++
public enum class AgInfiniiVisionTVTriggerEventEnum

Members

Member name | Value | Description
AgInfiniiVisionTVTriggerEventField1 | 0x00000001 | Sets the oscilloscope to trigger on field 1 of the video signal.
AgInfiniiVisionTVTriggerEventField2 | 0x00000002 | Sets the oscilloscope to trigger on field 2 of the video signal.
AgInfiniiVisionTVTriggerEventAnyField | 0x00000003 | Sets the oscilloscope to trigger on any field.
AgInfiniiVisionTVTriggerEventAnyLine | 0x00000004 | Sets the oscilloscope to trigger on any line.
AgInfiniiVisionTVTriggerEventLineNumber | 0x00000005 | Sets the oscilloscope to trigger on specified Line Number.
AgInfiniiVisionTVTriggerEventLineNumberAlternate | 0x00000006 | NOT SUPPORTED
AgInfiniiVisionTVTriggerEventLineNumberVertical | 0x00000007 | NOT SUPPORTED
AgInfiniiVisionTVTriggerEventVertical | 0x00000008 | NOT SUPPORTED

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionTVTriggerPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionTVTriggerPolarityEnum Enumeration
See Also

Values for TV trigger Polarity

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionTVTriggerPolarityEnum
C#
public enum AgInfiniiVisionTVTriggerPolarityEnum
Visual C++
public enum class AgInfiniiVisionTVTriggerPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionTVTriggerPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on a positive video sync pulse.
AgInfiniiVisionTVTriggerPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on a negative video sync pulse.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionVerticalCouplingEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionVerticalCouplingEnum Enumeration
See Also

Values for channel Coupling

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionVerticalCouplingEnum
C#
public enum AgInfiniiVisionVerticalCouplingEnum
Visual C++
public enum class AgInfiniiVisionVerticalCouplingEnum

Members

Member name | Value | Description
AgInfiniiVisionVerticalCouplingAC | 0x00000000 | The oscilloscope AC couples the input signal.
AgInfiniiVisionVerticalCouplingDC | 0x00000001 | The oscilloscope DC couples the input signal.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformByteOrderEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformByteOrderEnum Enumeration
See Also

Output sequence of the WORD data

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformByteOrderEnum
C#
public enum AgInfiniiVisionWaveformByteOrderEnum
Visual C++
public enum class AgInfiniiVisionWaveformByteOrderEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformByteOrderLSBFirst | 0x00000000 | LSBFirst sets the least significant byte to be transmitted first
AgInfiniiVisionWaveformByteOrderMSBFirst | 0x00000001 | MSBFirst sets the most significant byte to be transmitted first

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformDataFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformDataFormatEnum Enumeration
See Also

Data format for data transmission mode for waveform

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformDataFormatEnum
C#
public enum AgInfiniiVisionWaveformDataFormatEnum
Visual C++
public enum class AgInfiniiVisionWaveformDataFormatEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformDataFormatWord | 0x00000000 | WORD: Formatted data transfers 16-bit data as two bytes
AgInfiniiVisionWaveformDataFormatByte | 0x00000001 | BYTE: Formatted data is transferred as 8-bit bytes.
AgInfiniiVisionWaveformDataFormatAscii | 0x00000002 | ASCii: Formatted data converts the internal integer data values to real Y-axis values. Values are transferred as ASCii digits in floating point notation, separated by commas

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum Enumeration
See Also

Specifies the byte order for binary transfers.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum
C#
public enum AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum
Visual C++
public enum class AgInfiniiVisionWaveformGeneratorArbitraryByteOrderEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformGeneratorArbitraryByteOrderLSBFirst | 0x00000000 | Specifies the LSB first byte order for binary transfers.
AgInfiniiVisionWaveformGeneratorArbitraryByteOrderMSBFirst | 0x00000001 | Specifies the MSB first byte order for binary transfers.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformGeneratorFunctionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformGeneratorFunctionEnum Enumeration
See Also

Type of waveform

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformGeneratorFunctionEnum
C#
public enum AgInfiniiVisionWaveformGeneratorFunctionEnum
Visual C++
public enum class AgInfiniiVisionWaveformGeneratorFunctionEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformGeneratorFunctionSinusoid | 0x00000000 | Sine signal
AgInfiniiVisionWaveformGeneratorFunctionSquare | 0x00000001 | Square Wave signal
AgInfiniiVisionWaveformGeneratorFunctionRamp | 0x00000002 | Ramp Signal
AgInfiniiVisionWaveformGeneratorFunctionPulse | 0x00000003 | Pulse Signal
AgInfiniiVisionWaveformGeneratorFunctionNoise | 0x00000004 | Noise Signal
AgInfiniiVisionWaveformGeneratorFunctionDC | 0x00000005 | DC Level
AgInfiniiVisionWaveformGeneratorFunctionSineCardinal | 0x00000006 | -- NOT SUPPORTED IN 2000 X-SERIES -- Sine Cardinal
AgInfiniiVisionWaveformGeneratorFunctionExponentialRise | 0x00000007 | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Rise
AgInfiniiVisionWaveformGeneratorFunctionExponentialFall | 0x00000008 | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Fall
AgInfiniiVisionWaveformGeneratorFunctionCardiac | 0x00000009 | -- NOT SUPPORTED IN 2000 X-SERIES -- Cardiac
AgInfiniiVisionWaveformGeneratorFunctionGaussianPulse | 0x0000000A | -- NOT SUPPORTED IN 2000 X-SERIES -- Gaussian Pulse
AgInfiniiVisionWaveformGeneratorFunctionArbitrary | 0x0000000B | -- NOT SUPPORTED IN 2000 X-SERIES -- Arbitrary Waveform

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum Enumeration
See Also

Expected output load impedance

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum
C#
public enum AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum
Visual C++
public enum class AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceOneMeg | 0x00000000 | One Mega Ohm
AgInfiniiVisionWaveformGeneratorOutputLoadImpedanceFifty | 0x00000001 | Fifty Ohm

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformGeneratorOutputModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformGeneratorOutputModeEnum Enumeration
See Also

Specifies whether the defined waveform is output continuously or as a single cycle.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformGeneratorOutputModeEnum
C#
public enum AgInfiniiVisionWaveformGeneratorOutputModeEnum
Visual C++
public enum class AgInfiniiVisionWaveformGeneratorOutputModeEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformGeneratorOutputModeNormal | 0x00000000 | Defined waveform is output continuously.
AgInfiniiVisionWaveformGeneratorOutputModeSingle | 0x00000001 | One cycle of the defined waveform is output.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformPointModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformPointModeEnum Enumeration
See Also

Type of data record to be transferred

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformPointModeEnum
C#
public enum AgInfiniiVisionWaveformPointModeEnum
Visual C++
public enum class AgInfiniiVisionWaveformPointModeEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformPointModeNormal | 0x00000000 | Normal: The measurement record is transferred. It is a 62,500-point (maximum) representation of the raw acquisition record
AgInfiniiVisionWaveformPointModeMaximum | 0x00000001 | Maximum: Whichever record contains the maximum amount of points is used.
AgInfiniiVisionWaveformPointModeRaw | 0x00000002 | Raw: Raw acquisition record is transferred. The maximum number of points available in this record is determined by number of points available to be transferred.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWaveformSubSourceEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWaveformSubSourceEnum Enumeration
See Also

Sub source.

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWaveformSubSourceEnum
C#
public enum AgInfiniiVisionWaveformSubSourceEnum
Visual C++
public enum class AgInfiniiVisionWaveformSubSourceEnum

Members

Member name | Value | Description
AgInfiniiVisionWaveformSubSourceSUB0 | 0x00000000 | SUB0.
AgInfiniiVisionWaveformSubSourceSUB1 | 0x00000001 | SUB1.
AgInfiniiVisionWaveformSubSourceSlow | 0x00000002 | SLOW alias of SUB1 for SENT protocol.
AgInfiniiVisionWaveformSubSourceFast | 0x00000003 | FAST alias of SUB0 for SENT protocol.
AgInfiniiVisionWaveformSubSourceRx | 0x00000004 | RX alias of SUB0 for UART protocol.
AgInfiniiVisionWaveformSubSourceTx | 0x00000005 | TX alias of SUB1 for UART protocol.
AgInfiniiVisionWaveformSubSourceMISO | 0x00000006 | MISO alias of SUB1 for SPI protocol.
AgInfiniiVisionWaveformSubSourceMOSI | 0x00000007 | MOSI alias of SUB0 for SPI protocol.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWidthConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWidthConditionEnum Enumeration
See Also

Values for width trigger Condition

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWidthConditionEnum
C#
public enum AgInfiniiVisionWidthConditionEnum
Visual C++
public enum class AgInfiniiVisionWidthConditionEnum

Members

Member name | Value | Description
AgInfiniiVisionWidthConditionWithin | 0x00000001 | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold.
AgInfiniiVisionWidthConditionOutside | 0x00000002 | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


AgInfiniiVisionWidthPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
AgInfiniiVisionWidthPolarityEnum Enumeration
See Also

Values for width trigger Polarity

Namespace: Agilent.AgInfiniiVision.Interop
Assembly: Agilent.AgInfiniiVision.Interop (in Agilent.AgInfiniiVision.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgInfiniiVisionWidthPolarityEnum
C#
public enum AgInfiniiVisionWidthPolarityEnum
Visual C++
public enum class AgInfiniiVisionWidthPolarityEnum

Members

Member name | Value | Description
AgInfiniiVisionWidthPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
AgInfiniiVisionWidthPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.

See Also

Reference

Agilent.AgInfiniiVision.Interop Namespace


Ivi.Scope.Interop Namespace

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Scope.Interop Namespace

Interfaces

 | Interface | Description
Public interface | IIviScope | IVI Scope class-compliant root interface
Public interface | IIviScopeAcquisition | IVI Scope class-compliant acquisition interface
Public interface | IIviScopeChannel | IVI Scope class-compliant channel interface
Public interface | IIviScopeChannels | IVI Scope class-compliant channel collection interface
Public interface | IIviScopeMeasurement | IVI Scope class-compliant measurement interface
Public interface | IIviScopeMeasurements | IVI Scope class-compliant measurement collection interface
Public interface | IIviScopeReferenceLevel | IVI Scope class-compliant reference level interface
Public interface | IIviScopeTrigger | IVI Scope class-compliant trigger interface
Public interface | IIviScopeTriggerAcLine | IVI Scope class-compliant AC line trigger interface
Public interface | IIviScopeTriggerEdge | IVI Scope class-compliant edge trigger interface
Public interface | IIviScopeTriggerGlitch | IVI Scope class-compliant glitch trigger interface
Public interface | IIviScopeTriggerRunt | IVI Scope class-compliant runt trigger interface
Public interface | IIviScopeTriggerTv | IVI Scope class-compliant TV trigger interface
Public interface | IIviScopeTriggerWidth | IVI Scope class-compliant width trigger interface

Enumerations

 | Enumeration | Description
Public enumeration | IviScopeACLineSlopeEnum | IVI Scope class-compliant values for AC line trigger Slope
Public enumeration | IviScopeAcquisitionStatusEnum | IVI Scope class-compliant values for the status parameter of the acquisition Status method
Public enumeration | IviScopeAcquisitionTypeEnum | IVI Scope class-compliant values for Acquisition Type
Public enumeration | IviScopeErrorCodesEnum | IVI Scope class defined HRESULTS
Public enumeration | IviScopeGlitchConditionEnum | IVI Scope class-compliant values for glitch trigger Condition
Public enumeration | IviScopeGlitchPolarityEnum | IVI Scope class-compliant values for glitch trigger Polarity
Public enumeration | IviScopeInterpolationEnum | IVI Scope class-compliant values for acquisition Interpolation
Public enumeration | IviScopeMeasurementEnum | IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods
Public enumeration | IviScopeRuntPolarityEnum | IVI Scope class-compliant values for runt trigger Polarity
Public enumeration | IviScopeSampleModeEnum | IVI Scope class-compliant values for acquisition SampleMode
Public enumeration | IviScopeTimeOutEnum | IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.
Public enumeration | IviScopeTriggerCouplingEnum | IVI Scope class-compliant values for trigger Coupling
Public enumeration | IviScopeTriggerModifierEnum | IVI Scope class-compliant values for trigger Modifier
Public enumeration | IviScopeTriggerSlopeEnum | IVI Scope class-compliant values for edge trigger Slope
Public enumeration | IviScopeTriggerTypeEnum | IVI Scope class-compliant values for trigger Type
Public enumeration | IviScopeTVSignalFormatEnum | IVI Scope class-compliant values for TV trigger SignalFormat
Public enumeration | IviScopeTVTriggerEventEnum | IVI Scope class-compliant values for TV trigger Event
Public enumeration | IviScopeTVTriggerPolarityEnum | IVI Scope class-compliant values for TV trigger Polarity
Public enumeration | IviScopeVerticalCouplingEnum | IVI Scope class-compliant values for channel Coupling
Public enumeration | IviScopeWidthConditionEnum | IVI Scope class-compliant values for width trigger Condition
Public enumeration | IviScopeWidthPolarityEnum | IVI Scope class-compliant values for width trigger Polarity


Interfaces

 | Interface | Description
Public interface | IIviScope | IVI Scope class-compliant root interface
Public interface | IIviScopeAcquisition | IVI Scope class-compliant acquisition interface
Public interface | IIviScopeChannel | IVI Scope class-compliant channel interface
Public interface | IIviScopeChannels | IVI Scope class-compliant channel collection interface
Public interface | IIviScopeMeasurement | IVI Scope class-compliant measurement interface
Public interface | IIviScopeMeasurements | IVI Scope class-compliant measurement collection interface
Public interface | IIviScopeReferenceLevel | IVI Scope class-compliant reference level interface
Public interface | IIviScopeTrigger | IVI Scope class-compliant trigger interface
Public interface | IIviScopeTriggerAcLine | IVI Scope class-compliant AC line trigger interface
Public interface | IIviScopeTriggerEdge | IVI Scope class-compliant edge trigger interface
Public interface | IIviScopeTriggerGlitch | IVI Scope class-compliant glitch trigger interface
Public interface | IIviScopeTriggerRunt | IVI Scope class-compliant runt trigger interface
Public interface | IIviScopeTriggerTv | IVI Scope class-compliant TV trigger interface
Public interface | IIviScopeTriggerWidth | IVI Scope class-compliant width trigger interface


Properties

 | Name | Description
Public property | Acquisition | Pointer to the class-compliant IIviScopeAcquisition interface
Public property | Channels | Pointer to the class-compliant IIviScopeChannels interface
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Measurements | Pointer to the class-compliant IIviScopeMeasurements interface
Public property | ReferenceLevel | Pointer to the class-compliant IIviScopeReferenceLevel interface
Public property | Trigger | Pointer to the class-compliant IIviScopeTrigger interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top


IIviScopeAcquisition Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeAcquisition Interface
See Also

IVI Scope class-compliant acquisition interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeAcquisition
C#
public interface IIviScopeAcquisition
Visual C++
__interface IIviScopeAcquisition

Properties

 | Name | Description
Public property | Interpolation | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Public property | NumberOfEnvelopes | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Public property | RecordLength | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.
Public property | SampleMode | The sample mode the oscilloscope is currently using.
Public property | SampleRate | The effective digitizing rate using the current configuration. The units are samples per second.
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
Top

Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Top


Properties

 | Name | Description
Public property | Interpolation | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Public property | NumberOfAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Public property | NumberOfEnvelopes | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Public property | RecordLength | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.
Public property | SampleMode | The sample mode the oscilloscope is currently using.
Public property | SampleRate | The effective digitizing rate using the current configuration. The units are samples per second.
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
Top


IIviScopeChannel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannel Interface
See Also

IVI Scope class-compliant channel interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeChannel
C#
public interface IIviScopeChannel
Visual C++
__interface IIviScopeChannel

Properties

 | Name | Description
Public property | Coupling | How the oscilloscope couples the input signal.
Public property | Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Public property | InputImpedance | The input impedance of this channel. The units are ohms.
Public property | Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top

Methods

 | Name | Description
Public method | Configure | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Public method | ConfigureCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Public method | ConfigureCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Top


Properties

 | Name | Description
Public property | Coupling | How the oscilloscope couples the input signal.
Public property | Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Public property | InputImpedance | The input impedance of this channel. The units are ohms.
Public property | Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top


IIviScopeChannels Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeChannels Interface
See Also

IVI Scope class-compliant channel collection interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeChannels
C#
public interface IIviScopeChannels
Visual C++
__interface IIviScopeChannels

Properties

 | Name | Description
Public property | Count | The number of channels.
Public property | Item | An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.
Public property | Name | The channel name for a given index.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Properties

 | Name | Description
Public property | Count | The number of channels.
Public property | Item | An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.
Public property | Name | The channel name for a given index.
Top


IIviScopeMeasurement Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurement Interface
See Also

IVI Scope class-compliant measurement interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeMeasurement
C#
public interface IIviScopeMeasurement
Visual C++
__interface IIviScopeMeasurement

Methods

 | Name | Description
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Public method | FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Public method | ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeMeasurements Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeMeasurements Interface
See Also

IVI Scope class-compliant measurement collection interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeMeasurements
C#
public interface IIviScopeMeasurements
Visual C++
__interface IIviScopeMeasurements

Properties

 | Name | Description
Public property | Count | Returns the number of channels that measurements can use as a source.
Public property | Item | An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.
Public property | Name | The measurement name for given index.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Public method | AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Public method | IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Top


Properties

 | Name | Description
Public property | Count | Returns the number of channels that measurements can use as a source.
Public property | Item | An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.
Public property | Name | The measurement name for given index.
Top


IIviScopeReferenceLevel Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeReferenceLevel Interface
See Also

IVI Scope class-compliant reference level interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeReferenceLevel
C#
public interface IIviScopeReferenceLevel
Visual C++
__interface IIviScopeReferenceLevel

Properties

 | Name | Description
Public property | High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

Methods

 | Name | Description
Public method | Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTrigger Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTrigger Interface
See Also

IVI Scope class-compliant trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTrigger
C#
public interface IIviScopeTrigger
Visual C++
__interface IIviScopeTrigger

Properties

 | Name | Description
Public property | AcLine | Pointer to the class-compliant IIviScopeTriggerAcLine interface
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Public property | Coupling | How the oscilloscope couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Public property | Holdoff | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Public property | Level | The voltage threshold for the trigger subsystem. The units are volts.
Public property | Modifier | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
Public property | Source | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Public property | TV | Pointer to the class-compliant IIviScopeTriggerTv interface
Public property | Type | The kind of event that triggers the oscilloscope.
Public property | Width | Pointer to the class-compliant IIviScopeTriggerWidth interface
Top

Methods

 | Name | Description
Public method | Configure | Configures trigger Type and Holdoff. Holdoff units are seconds.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Properties

 | Name | Description
Public property | AcLine | Pointer to the class-compliant IIviScopeTriggerAcLine interface
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Public property | Coupling | How the oscilloscope couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Public property | Holdoff | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Public property | Level | The voltage threshold for the trigger subsystem. The units are volts.
Public property | Modifier | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
Public property | Source | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Public property | TV | Pointer to the class-compliant IIviScopeTriggerTv interface
Public property | Type | The kind of event that triggers the oscilloscope.
Public property | Width | Pointer to the class-compliant IIviScopeTriggerWidth interface
Top


IIviScopeTriggerAcLine Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerAcLine Interface
See Also

IVI Scope class-compliant AC line trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerAcLine
C#
public interface IIviScopeTriggerAcLine
Visual C++
__interface IIviScopeTriggerAcLine

Properties

 | Name | Description
Public property | Slope | The slope of the zero crossing upon which the scope triggers.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerEdge Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerEdge Interface
See Also

IVI Scope class-compliant edge trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerEdge
C#
public interface IIviScopeTriggerEdge
Visual C++
__interface IIviScopeTriggerEdge

Properties

 | Name | Description
Public property | Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top

Methods

 | Name | Description
Public method | Configure | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Properties

 | Name | Description
Public property | Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top


IIviScopeTriggerGlitch Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerGlitch Interface
See Also

IVI Scope class-compliant glitch trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerGlitch
C#
public interface IIviScopeTriggerGlitch
Visual C++
__interface IIviScopeTriggerGlitch

Properties

 | Name | Description
Public property | condition | The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.
Public property | polarity | The polarity of the glitch that triggers the oscilloscope.
Public property | Width | The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.
Top

Methods

 | Name | Description
Public method | Configure | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Top


Properties

 | Name | Description
Public property | condition | The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.
Public property | polarity | The polarity of the glitch that triggers the oscilloscope.
Public property | Width | The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.
Top


IIviScopeTriggerRunt Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerRunt Interface
See Also

IVI Scope class-compliant runt trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerRunt
C#
public interface IIviScopeTriggerRunt
Visual C++
__interface IIviScopeTriggerRunt

Properties

 | Name | Description
Public property | polarity | The polarity of the runt that triggers the oscilloscope.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Top

Methods

 | Name | Description
Public method | Configure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Properties

 | Name | Description
Public property | polarity | The polarity of the runt that triggers the oscilloscope.
Public property | ThresholdHigh | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Public property | ThresholdLow | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Top


IIviScopeTriggerTv Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerTv Interface
See Also

IVI Scope class-compliant TV trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerTv
C#
public interface IIviScopeTriggerTv
Visual C++
__interface IIviScopeTriggerTv

Properties

 | Name | Description
Public property | Event | The event on which the oscilloscope triggers.
Public property | LineNumber | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Public property | polarity | The polarity of the TV signal.
Public property | SignalFormat | The format of the TV signal on which the oscilloscope triggers.
Top

Methods

 | Name | Description
Public method | Configure | Configures the TV trigger source, signal format, event and polarity.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the TV trigger source, signal format, event and polarity.
Top


Properties

 | Name | Description
Public property | Event | The event on which the oscilloscope triggers.
Public property | LineNumber | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Public property | polarity | The polarity of the TV signal.
Public property | SignalFormat | The format of the TV signal on which the oscilloscope triggers.
Top


IIviScopeTriggerWidth Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviScopeTriggerWidth Interface
See Also

IVI Scope class-compliant width trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerWidth
C#
public interface IIviScopeTriggerWidth
Visual C++
__interface IIviScopeTriggerWidth

Properties

 | Name | Description
Public property | condition | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Public property | polarity | The polarity of the pulse that triggers the oscilloscope.
Public property | ThresholdHigh | The high width threshold time. The units are seconds.
Public property | ThresholdLow | The low width threshold time. The units are seconds.
Top

Methods

 | Name | Description
Public method | Configure | Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Methods

 | Name | Description
Public method | Configure | Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top


Properties

 | Name | Description
Public property | condition | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Public property | polarity | The polarity of the pulse that triggers the oscilloscope.
Public property | ThresholdHigh | The high width threshold time. The units are seconds.
Public property | ThresholdLow | The low width threshold time. The units are seconds.
Top


Enums

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Scope.Interop Enums

Enumerations

 | Enumeration | Description
Public enumeration | IviScopeACLineSlopeEnum | IVI Scope class-compliant values for AC line trigger Slope
Public enumeration | IviScopeAcquisitionStatusEnum | IVI Scope class-compliant values for the status parameter of the acquisition Status method
Public enumeration | IviScopeAcquisitionTypeEnum | IVI Scope class-compliant values for Acquisition Type
Public enumeration | IviScopeErrorCodesEnum | IVI Scope class defined HRESULTS
Public enumeration | IviScopeGlitchConditionEnum | IVI Scope class-compliant values for glitch trigger Condition
Public enumeration | IviScopeGlitchPolarityEnum | IVI Scope class-compliant values for glitch trigger Polarity
Public enumeration | IviScopeInterpolationEnum | IVI Scope class-compliant values for acquisition Interpolation
Public enumeration | IviScopeMeasurementEnum | IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods
Public enumeration | IviScopeRuntPolarityEnum | IVI Scope class-compliant values for runt trigger Polarity
Public enumeration | IviScopeSampleModeEnum | IVI Scope class-compliant values for acquisition SampleMode
Public enumeration | IviScopeTimeOutEnum | IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.
Public enumeration | IviScopeTriggerCouplingEnum | IVI Scope class-compliant values for trigger Coupling
Public enumeration | IviScopeTriggerModifierEnum | IVI Scope class-compliant values for trigger Modifier
Public enumeration | IviScopeTriggerSlopeEnum | IVI Scope class-compliant values for edge trigger Slope
Public enumeration | IviScopeTriggerTypeEnum | IVI Scope class-compliant values for trigger Type
Public enumeration | IviScopeTVSignalFormatEnum | IVI Scope class-compliant values for TV trigger SignalFormat
Public enumeration | IviScopeTVTriggerEventEnum | IVI Scope class-compliant values for TV trigger Event
Public enumeration | IviScopeTVTriggerPolarityEnum | IVI Scope class-compliant values for TV trigger Polarity
Public enumeration | IviScopeVerticalCouplingEnum | IVI Scope class-compliant values for channel Coupling
Public enumeration | IviScopeWidthConditionEnum | IVI Scope class-compliant values for width trigger Condition
Public enumeration | IviScopeWidthPolarityEnum | IVI Scope class-compliant values for width trigger Polarity


IviScopeACLineSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeACLineSlopeEnum Enumeration
See Also

IVI Scope class-compliant values for AC line trigger Slope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeACLineSlopeEnum
C#
public enum IviScopeACLineSlopeEnum
Visual C++
public enum class IviScopeACLineSlopeEnum

Members

Member name | Value | Description
IviScopeACLinePositive | 0x00000001 | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
IviScopeACLineNegative | 0x00000002 | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
IviScopeACLineEither | 0x00000003 | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeAcquisitionStatusEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeAcquisitionStatusEnum Enumeration
See Also

IVI Scope class-compliant values for the status parameter of the acquisition Status method

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeAcquisitionStatusEnum
C#
public enum IviScopeAcquisitionStatusEnum
Visual C++
public enum class IviScopeAcquisitionStatusEnum

Members

Member name | Value | Description
IviScopeAcqComplete | 0x00000001 | The oscilloscope has completed the acquisition.
IviScopeAcqInProgress | 0x00000000 | The oscilloscope is still acquiring data.
IviScopeAcqStatusUnknown | 0xFFFFFFFF | The oscilloscope cannot determine the status of the acquisition.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeAcquisitionTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeAcquisitionTypeEnum Enumeration
See Also

IVI Scope class-compliant values for Acquisition Type

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeAcquisitionTypeEnum
C#
public enum IviScopeAcquisitionTypeEnum
Visual C++
public enum class IviScopeAcquisitionTypeEnum

Members

Member name | Value | Description
IviScopeAcquisitionTypeNormal | 0x00000000 | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
IviScopeAcquisitionTypePeakDetect | 0x00000001 | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeHiRes | 0x00000002 | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeEnvelope | 0x00000003 | Sets the oscilloscope to the envelope acquisition mode. The oscilloscope acquires multiple waveforms and keeps the minimum and maximum voltages it acquires for each point in the waveform record.
IviScopeAcquisitionTypeAverage | 0x00000004 | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeErrorCodesEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeErrorCodesEnum Enumeration
See Also

IVI Scope class defined HRESULTS

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeErrorCodesEnum
C#
public enum IviScopeErrorCodesEnum
Visual C++
public enum class IviScopeErrorCodesEnum

Members

Member name | Value | Description
E_IVISCOPE_CHANNEL_NOT_ENABLED | 0x80042001 |
E_IVISCOPE_UNABLE_TO_PERFORM_MEASUREMENT | 0x80042002 |
E_IVISCOPE_MAX_TIME_EXCEEDED | 0x80042003 |
E_IVISCOPE_INVALID_ACQ_TYPE | 0x80042004 |
S_IVISCOPE_INVALID_WFM_ELEMENT | 0x00042001 |

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeGlitchConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeGlitchConditionEnum Enumeration
See Also

IVI Scope class-compliant values for glitch trigger Condition

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeGlitchConditionEnum
C#
public enum IviScopeGlitchConditionEnum
Visual C++
public enum class IviScopeGlitchConditionEnum

Members

Member name | Value | Description
IviScopeGlitchConditionLessThan | 0x00000001 | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
IviScopeGlitchConditionGreaterThan | 0x00000002 | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeGlitchPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeGlitchPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for glitch trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeGlitchPolarityEnum
C#
public enum IviScopeGlitchPolarityEnum
Visual C++
public enum class IviScopeGlitchPolarityEnum

Members

Member name | Value | Description
IviScopeGlitchPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive glitch.
IviScopeGlitchPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative glitch.
IviScopeGlitchPolarityEither | 0x00000003 | The oscilloscope triggers on either a positive or negative glitch.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeInterpolationEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeInterpolationEnum Enumeration
See Also

IVI Scope class-compliant values for acquisition Interpolation

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeInterpolationEnum
C#
public enum IviScopeInterpolationEnum
Visual C++
public enum class IviScopeInterpolationEnum

Members

Member name | Value | Description
IviScopeInterpolationNone | 0x00000001 | The oscilloscope does not interpolate points in the waveform. Instead, the driver sets every element in the waveform record for which the oscilloscope cannot receive a value to an IEEE-defined NaN (Not-a-Number) value.
IviScopeInterpolationSineX | 0x00000002 | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.
IviScopeInterpolationLinear | 0x00000003 | The oscilloscope uses a linear approximation to interpolate a value when it cannot resolve a voltage in the waveform record.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeMeasurementEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeMeasurementEnum Enumeration
See Also

IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeMeasurementEnum
C#
public enum IviScopeMeasurementEnum
Visual C++
public enum class IviScopeMeasurementEnum

Members

Member name | Value | Description
IviScopeMeasurementRiseTime | 0x00000000 | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
IviScopeMeasurementFallTime | 0x00000001 | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
IviScopeMeasurementFrequency | 0x00000002 | The frequency of one complete cycle in the waveform. The units are Hertz.
IviScopeMeasurementPeriod | 0x00000003 | The length of time of one complete cycle in the waveform. The units are seconds.
IviScopeMeasurementVoltageRMS | 0x00000004 | The true Root Mean Square voltage of the entire waveform. The units are Volts.
IviScopeMeasurementVoltagePeakToPeak | 0x00000005 | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
IviScopeMeasurementVoltageMax | 0x00000006 | The maximum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageMin | 0x00000007 | The minimum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageHigh | 0x00000008 | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
IviScopeMeasurementVoltageLow | 0x00000009 | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
IviScopeMeasurementVoltageAverage | 0x0000000A | The arithmetic average in volts measured over the entire waveform. The units are Volts.
IviScopeMeasurementWidthNeg | 0x0000000B | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
IviScopeMeasurementWidthPos | 0x0000000C | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
IviScopeMeasurementDutyCycleNeg | 0x0000000D | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
IviScopeMeasurementDutyCyclePos | 0x0000000E | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
IviScopeMeasurementAmplitude | 0x0000000F | The Voltage High less the Voltage Low in Volts over the entire waveform.
IviScopeMeasurementVoltageCycleRMS | 0x00000010 | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementVoltageCycleAverage | 0x00000011 | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementOverShoot | 0x00000012 | The relative waveform distortion that follows an edge transition.
IviScopeMeasurementPreshoot | 0x00000013 | The relative waveform distortion that precedes an edge transition.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeRuntPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeRuntPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for runt trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeRuntPolarityEnum
C#
public enum IviScopeRuntPolarityEnum
Visual C++
public enum class IviScopeRuntPolarityEnum

Members

Member name | Value | Description
IviScopeRuntPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
IviScopeRuntPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
IviScopeRuntPolarityEither | 0x00000003 | The oscilloscope triggers on either a positive or negative runt.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeSampleModeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeSampleModeEnum Enumeration
See Also

IVI Scope class-compliant values for acquisition SampleMode

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeSampleModeEnum
C#
public enum IviScopeSampleModeEnum
Visual C++
public enum class IviScopeSampleModeEnum

Members

Member name | Value | Description
IviScopeSampleModeRealTime | 0x00000000 | Indicates that the oscilloscope is using real-time sampling.
IviScopeSampleModeEquivalentTime | 0x00000001 | Indicates that the oscilloscope is using equivalent time sampling.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTimeOutEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTimeOutEnum Enumeration
See Also

IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTimeOutEnum
C#
public enum IviScopeTimeOutEnum
Visual C++
public enum class IviScopeTimeOutEnum

Members

Member name | Value | Description
IviScopeTimeOutInfinite | 0xFFFFFFFF | The method waits indefinitely for the measurement to complete.
IviScopeTimeOutImmediate | 0x00000000 | The method returns immediately. If no valid measurement value exists, the method returns an error.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerCouplingEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTriggerCouplingEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Coupling

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerCouplingEnum
C#
public enum IviScopeTriggerCouplingEnum
Visual C++
public enum class IviScopeTriggerCouplingEnum

Members

Member name | Value | Description
IviScopeTriggerCouplingAC | 0x00000000 | The oscilloscope AC couples the trigger signal.
IviScopeTriggerCouplingDC | 0x00000001 | The oscilloscope DC couples the trigger signal.
IviScopeTriggerCouplingHFReject | 0x00000003 | The oscilloscope filters out the high frequencies from the trigger signal.
IviScopeTriggerCouplingLFReject | 0x00000004 | The oscilloscope filters out the low frequencies from the trigger signal.
IviScopeTriggerCouplingNoiseReject | 0x00000005 | The oscilloscope filters out the noise from the trigger signal.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerModifierEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTriggerModifierEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Modifier

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerModifierEnum
C#
public enum IviScopeTriggerModifierEnum
Visual C++
public enum class IviScopeTriggerModifierEnum

Members

Member name | Value | Description
IviScopeTriggerModifierNone | 0x00000001 | The oscilloscope waits until the trigger the end-user specifies occurs.
IviScopeTriggerModifierAuto | 0x00000002 | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.
IviScopeTriggerModifierAutoLevel | 0x00000003 | The oscilloscope adjusts the trigger level if the trigger the end-user specifies does not occur.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerSlopeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTriggerSlopeEnum Enumeration
See Also

IVI Scope class-compliant values for edge trigger Slope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerSlopeEnum
C#
public enum IviScopeTriggerSlopeEnum
Visual C++
public enum class IviScopeTriggerSlopeEnum

Members

Member name | Value | Description
IviScopeTriggerSlopePositive | 0x00000001 | A positive (rising) edge passing through the trigger level triggers the oscilloscope.
IviScopeTriggerSlopeNegative | 0x00000000 | A negative (falling) edge passing through the trigger level triggers the oscilloscope.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerTypeEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTriggerTypeEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Type

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerTypeEnum
C#
public enum IviScopeTriggerTypeEnum
Visual C++
public enum class IviScopeTriggerTypeEnum

Members

Member name | Value | Description
IviScopeTriggerEdge | 0x00000001 | Configures the oscilloscope for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source property passes the voltage threshold specified with the Trigger Level property &amp; Trigger Slope property.
IviScopeTriggerWidth | 0x00000002 | Configures the oscilloscope for width triggering. Use the IviScopeWidthTrigger extension properties and methods to configure the trigger.
IviScopeTriggerRunt | 0x00000003 | Configures the oscilloscope for runt triggering. Use the IviScopeRuntTrigger extension properties and methods to configure the trigger.
IviScopeTriggerGlitch | 0x00000004 | Configures the oscilloscope for glitch triggering. Use the IviScopeGlitchTrigger extension properties and methods to configure the trigger.
IviScopeTriggerTV | 0x00000005 | Configures the oscilloscope for triggering on TV signals. Use the IviScopeTVTrigger extension properties and methods to configure the trigger.
IviScopeTriggerImmediate | 0x00000006 | NOT SUPPORTED
IviScopeTriggerACLine | 0x00000007 | Configures the oscilloscope for AC Line triggering. Use the IviScopeACLineTrigger extension properties and methods to configure the trigger.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVSignalFormatEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTVSignalFormatEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger SignalFormat

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVSignalFormatEnum
C#
public enum IviScopeTVSignalFormatEnum
Visual C++
public enum class IviScopeTVSignalFormatEnum

Members

Member name | Value | Description
IviScopeTVSignalFormatNTSC | 0x00000001 | Configures the oscilloscope to trigger on the NTSC signal format.
IviScopeTVSignalFormatPAL | 0x00000002 | Configures the oscilloscope to trigger on the PAL signal format
IviScopeTVSignalFormatSECAM | 0x00000003 | Configures the oscilloscope to trigger on the SECAM signal format

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVTriggerEventEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTVTriggerEventEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger Event

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVTriggerEventEnum
C#
public enum IviScopeTVTriggerEventEnum
Visual C++
public enum class IviScopeTVTriggerEventEnum

Members

Member name | Value | Description
IviScopeTVTriggerEventField1 | 0x00000001 | Sets the oscilloscope to trigger on field 1 of the video signal.
IviScopeTVTriggerEventField2 | 0x00000002 | Sets the oscilloscope to trigger on field 2 of the video signal.
IviScopeTVTriggerEventAnyField | 0x00000003 | Sets the oscilloscope to trigger on any field.
IviScopeTVTriggerEventAnyLine | 0x00000004 | Sets the oscilloscope to trigger on any line.
IviScopeTVTriggerEventLineNumber | 0x00000005 | Sets the oscilloscope to trigger on a specific line number you specify with the TV Trigger Line Number property.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVTriggerPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeTVTriggerPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVTriggerPolarityEnum
C#
public enum IviScopeTVTriggerPolarityEnum
Visual C++
public enum class IviScopeTVTriggerPolarityEnum

Members

Member name | Value | Description
IviScopeTVTriggerPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on a positive video sync pulse.
IviScopeTVTriggerPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on a negative video sync pulse.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeVerticalCouplingEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeVerticalCouplingEnum Enumeration
See Also

IVI Scope class-compliant values for channel Coupling

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeVerticalCouplingEnum
C#
public enum IviScopeVerticalCouplingEnum
Visual C++
public enum class IviScopeVerticalCouplingEnum

Members

Member name | Value | Description
IviScopeVerticalCouplingAC | 0x00000000 | The oscilloscope AC couples the input signal.
IviScopeVerticalCouplingDC | 0x00000001 | The oscilloscope DC couples the input signal.
IviScopeVerticalCouplingGnd | 0x00000002 | NOT SUPPORTED

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeWidthConditionEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeWidthConditionEnum Enumeration
See Also

IVI Scope class-compliant values for width trigger Condition

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeWidthConditionEnum
C#
public enum IviScopeWidthConditionEnum
Visual C++
public enum class IviScopeWidthConditionEnum

Members

Member name | Value | Description
IviScopeWidthConditionWithin | 0x00000001 | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold.
IviScopeWidthConditionOutside | 0x00000002 | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeWidthPolarityEnum Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviScopeWidthPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for width trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeWidthPolarityEnum
C#
public enum IviScopeWidthPolarityEnum
Visual C++
public enum class IviScopeWidthPolarityEnum

Members

Member name | Value | Description
IviScopeWidthPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityEither | 0x00000003 | Configures the oscilloscope to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition property.

See Also

Reference

Ivi.Scope.Interop Namespace


Ivi.Driver.Interop Namespace

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Driver.Interop Namespace

Interfaces

 | Interface | Description
Public interface | IIviClassWrapper | IVI Driver class wrapper interface
Public interface | IIviComponentIdentity | IVI Driver component identity interface
Public interface | IIviDriver | IVI Driver root interface
Public interface | IIviDriverIdentity | IVI Driver identity interface
Public interface | IIviDriverOperation | IVI Driver operation interface
Public interface | IIviDriverUtility | IVI Driver utility interface

Enumerations

 | Enumeration | Description
Public enumeration | IviDriver_ErrorCodes | IVI Driver (inherent features) defined HRESULTS


Interfaces

 | Interface | Description
Public interface | IIviClassWrapper | IVI Driver class wrapper interface
Public interface | IIviComponentIdentity | IVI Driver component identity interface
Public interface | IIviDriver | IVI Driver root interface
Public interface | IIviDriverIdentity | IVI Driver identity interface
Public interface | IIviDriverOperation | IVI Driver operation interface
Public interface | IIviDriverUtility | IVI Driver utility interface


IIviClassWrapper Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviClassWrapper Interface
See Also

IVI Driver class wrapper interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviClassWrapper
C#
public interface IIviClassWrapper
Visual C++
__interface IIviClassWrapper

Properties

 | Name | Description
Public property | NativeCHandle | The C session handle that the COM wrapper is currently using to communicate with an IVI-C specific driver.
Top

Methods

 | Name | Description
Public method | AttachToExistingCSession | Binds a COM wrapper object to an existing IVI-C specific driver session.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


Methods

 | Name | Description
Public method | AttachToExistingCSession | Binds a COM wrapper object to an existing IVI-C specific driver session.
Top


AttachToExistingCSession Method

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviClassWrapper..::.AttachToExistingCSession Method
IIviClassWrapper See Also

Binds a COM wrapper object to an existing IVI-C specific driver session.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub AttachToExistingCSession ( _
    ByVal  Vi As Integer  _
)
C#
public void  AttachToExistingCSession(
    int  Vi
)
Visual C++
HRESULT AttachToExistingCSession(
    long  Vi
);

Parameters

Vi

Requirements

Supported Models

All supported

See Also

Reference

IIviClassWrapper Interface
Ivi.Driver.Interop Namespace


Properties

 | Name | Description
Public property | NativeCHandle | The C session handle that the COM wrapper is currently using to communicate with an IVI-C specific driver.
Top


NativeCHandle Property

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviClassWrapper..::.NativeCHandle Property
IIviClassWrapper See Also

The C session handle that the COM wrapper is currently using to communicate with an IVI-C specific driver.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property NativeCHandle As Integer
C#
public int  NativeCHandle { get; }
Visual C++
HRESULT get_NativeCHandle(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviClassWrapper Interface
Ivi.Driver.Interop Namespace


IIviComponentIdentity Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviComponentIdentity Interface
See Also

IVI Driver component identity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviComponentIdentity
C#
public interface IIviComponentIdentity
Visual C++
__interface IIviComponentIdentity

Properties

 | Name | Description
Public property | Description | Read Only - A brief description of the implementing component. Description is limited to 256 bytes.
Public property | Revision | Read Only - The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Public property | Vendor | Read Only - The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


Properties

 | Name | Description
Public property | Description | Read Only - A brief description of the implementing component. Description is limited to 256 bytes.
Public property | Revision | Read Only - The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Public property | Vendor | Read Only - The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
Top


Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Top


Properties

 | Name | Description
Public property | DriverOperation | Pointer to the IIviDriverOperation interface
Public property | Identity | Pointer to the IIviDriverIdentity interface
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Public property | Utility | Pointer to the IIviDriverUtility interface
Top


IIviDriverIdentity Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverIdentity Interface
See Also

IVI Driver identity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverIdentity
   Inherits IIviComponentIdentity
C#
public interface IIviDriverIdentity : IIviComponentIdentity
Visual C++
__interface IIviDriverIdentity : IIviComponentIdentity

Properties

 | Name | Description
Public property | Description | Read Only - A brief description of the implementing component. Description is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | GroupCapabilities | Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Public property | Identifier | Read Only - The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
Public property | InstrumentFirmwareRevision | Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Public property | InstrumentManufacturer | Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.
Public property | InstrumentModel | Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Public property | Revision | Read Only - The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | SpecificationMajorVersion | Read Only - For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SpecificationMinorVersion | Read Only - For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SupportedInstrumentModels | Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Public property | Vendor | Read Only - The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Top

See Also

Reference

Ivi.Driver.Interop Namespace


Properties

 | Name | Description
Public property | Description | Read Only - A brief description of the implementing component. Description is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | GroupCapabilities | Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Public property | Identifier | Read Only - The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
Public property | InstrumentFirmwareRevision | Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Public property | InstrumentManufacturer | Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.
Public property | InstrumentModel | Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Public property | Revision | Read Only - The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | SpecificationMajorVersion | Read Only - For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SpecificationMinorVersion | Read Only - For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SupportedInstrumentModels | Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Public property | Vendor | Read Only - The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Top


IIviDriverOperation Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverOperation Interface
See Also

IVI Driver operation interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverOperation
C#
public interface IIviDriverOperation
Visual C++
__interface IIviDriverOperation

Properties

 | Name | Description
Public property | Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Public property | DriverSetup | Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Public property | InterchangeCheck | Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Public property | IoResourceDescriptor | Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Public property | LogicalName | Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.
Public property | QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Public property | RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Public property | RecordCoercions | Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Public property | Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Top

Methods

 | Name | Description
Public method | ClearInterchangeWarnings | Not Supported - Clears the list of interchangeability warnings that the IVI specific driver maintains.
Public method | GetNextCoercionRecord | Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Public method | GetNextInterchangeWarning | Not Supported - Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Public method | InvalidateAllAttributes | Invalidates all of the driver's cached values.
Public method | ResetInterchangeCheck | Not Supported - Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


Methods

 | Name | Description
Public method | ClearInterchangeWarnings | Not Supported - Clears the list of interchangeability warnings that the IVI specific driver maintains.
Public method | GetNextCoercionRecord | Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Public method | GetNextInterchangeWarning | Not Supported - Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Public method | InvalidateAllAttributes | Invalidates all of the driver's cached values.
Public method | ResetInterchangeCheck | Not Supported - Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Top


Properties

 | Name | Description
Public property | Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Public property | DriverSetup | Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Public property | InterchangeCheck | Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Public property | IoResourceDescriptor | Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Public property | LogicalName | Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.
Public property | QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Public property | RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Public property | RecordCoercions | Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Public property | Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Top


IIviDriverUtility Interface

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IIviDriverUtility Interface
See Also

IVI Driver utility interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverUtility
C#
public interface IIviDriverUtility
Visual C++
__interface IIviDriverUtility

Methods

 | Name | Description
Public method | Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Public method | ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Public method | LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Public method | Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Public method | ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Public method | SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Public method | UnlockObject | Releases a previously obtained mutlithread lock.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


Methods

 | Name | Description
Public method | Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Public method | ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Public method | LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Public method | Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Public method | ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Public method | SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Public method | UnlockObject | Releases a previously obtained mutlithread lock.
Top


Enums

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Driver.Interop Enums

Enumerations

 | Enumeration | Description
Public enumeration | IviDriver_ErrorCodes | IVI Driver (inherent features) defined HRESULTS


IviDriver_ErrorCodes Enumeration

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
IviDriver_ErrorCodes Enumeration
See Also

IVI Driver (inherent features) defined HRESULTS

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Enumeration IviDriver_ErrorCodes
C#
public enum IviDriver_ErrorCodes
Visual C++
public enum class IviDriver_ErrorCodes

Members

Member name | Value | Description
S_IVI_SUCCESS | 0x00000000 | Success.
E_IVI_CANNOT_RECOVER | 0x80047000 | Unrecoverable failure.
E_IVI_INSTRUMENT_STATUS | 0x80047001 | Instrument error detected.
E_IVI_CANNOT_OPEN_FILE | 0x80047002 | File could not be opened.
E_IVI_READING_FILE | 0x80047003 | File could not be read.
E_IVI_WRITING_FILE | 0x80047004 | File could not be written.
E_IVI_INVALID_PATHNAME | 0x8004700B | The path name is invalid.
E_IVI_INVALID_VALUE | 0x80047010 | Invalid value for parameter or property.
E_IVI_METHOD_NOT_SUPPORTED | 0x80047011 | Method not supported.
E_IVI_PROPERTY_NOT_SUPPORTED | 0x80047012 | Property not supported.
E_IVI_VALUE_NOT_SUPPORTED | 0x80047013 | The enumeration value for the parameter is not supported.
E_IVI_NOT_INITIALIZED | 0x8004701D | A connection to the instrument has not been initialized.
E_IVI_UNKNOWN_CHANNEL_NAME | 0x80047020 | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | 0x80047023 | Too many files opened.
E_IVI_CHANNEL_NAME_REQUIRED | 0x80047044 | Channel or repeated capability name required.
E_IVI_MISSING_OPTION_NAME | 0x80047049 | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | 0x8004704A | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | 0x8004704B | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | 0x8004704C | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | 0x80047056 | The necessary memory could not be allocated.
E_IVI_OPERATION_PENDING | 0x80047057 | Operation in progress.
E_IVI_NULL_POINTER | 0x80047058 | Null pointer passed for parameter or property.
E_IVI_UNEXPECTED_RESPONSE | 0x80047059 | Unexpected response from the instrument.
E_IVI_FILE_NOT_FOUND | 0x8004705B | File not found.
E_IVI_INVALID_FILE_FORMAT | 0x8004705C | The file format is invalid.
E_IVI_STATUS_NOT_AVAILABLE | 0x8004705D | The instrument status is not available.
E_IVI_ID_QUERY_FAILED | 0x8004705E | Instrument ID query failed.
E_IVI_RESET_FAILED | 0x8004705F | Instrument reset failed.
E_IVI_RESOURCE_UNKNOWN | 0x80047060 | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | 0x80047061 | The driver is already initialized.
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | 0x80047062 | The simulation state cannot be changed.
E_IVI_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0x80047063 | The number of levels in the selector is not valid for the repeated capability.
E_IVI_INVALID_RANGE_IN_SELECTOR | 0x80047064 | The range is not valid for the repeated capability.
E_IVI_UNKNOWN_NAME_IN_SELECTOR | 0x80047065 | Unknown name in selector.
E_IVI_BADLY_FORMED_SELECTOR | 0x80047066 | The repeated capability selector is badly-formed.
E_IVI_UNKNOWN_PHYSICAL_IDENTIFIER | 0x80047067 | Unknown physical repeated capability selector.
S_IVI_NSUP_ID_QUERY | 0x00047065 | Identification query not supported.
S_IVI_NSUP_RESET | 0x00047066 | Reset operation not supported.
S_IVI_NSUP_SELF_TEST | 0x00047067 | Self test operation not supported.
S_IVI_NSUP_ERROR_QUERY | 0x00047068 | Error query operation not supported.
S_IVI_NSUP_REV_QUERY | 0x00047069 | Revision query not supported.

See Also

Reference

Ivi.Driver.Interop Namespace


Instrument Command Reference

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Instrument Command Reference

This is the reference for all the instrument commands issued by the driver.

Instrument Commands

Instrument Command | Reference
*CLS | IAgInfiniiVisionStatus.Clear
*CLS;*SRE;*ESE;:OPEE;:OVL | IAgInfiniiVisionStatus.ConfigureServiceRequest
*LRN? | IAgInfiniiVisionSystem.GetState
*OPC? | IAgInfiniiVisionSystem.WaitForOperationComplete
*RCL {MemoryLocation} | IAgInfiniiVisionSystem.RecallState
*RST | IAgInfiniiVisionStatus.Preset
*SAV {MemoryLocation} | IAgInfiniiVisionSystem.SaveState
:ABUS:BIT{Bit}? | IAgInfiniiVision8AnalogBus.GetBit
:ABUS:BIT{Bits} {BitState} | IAgInfiniiVision8AnalogBus.SetBit
:ABUS:BITS (@{ChannelList}),{BitState} | IAgInfiniiVision8AnalogBus.SetBits
:ABUS:BITS? | IAgInfiniiVision8AnalogBus.GetBits
:ABUS:CLEar | IAgInfiniiVision8AnalogBus.Clear
:ABUS:DISPlay {value} | IAgInfiniiVision8AnalogBus.Enabled
:ABUS:DISPlay? | IAgInfiniiVision8AnalogBus.Enabled
:ABUS:LABel "{value}" | IAgInfiniiVision8AnalogBus.Label
:ABUS:LABel? | IAgInfiniiVision8AnalogBus.Label
:ACQuire:COUNt {value} | IAgInfiniiVisionAcquisition.NumberOfAverages
:ACQuire:COUNt? | IAgInfiniiVisionAcquisition.NumberOfAverages
:ACQuire:MODE {Mode} | IAgInfiniiVisionAcquisition3.SetSampleMode
:ACQuire:MODE? | IAgInfiniiVisionAcquisition.SampleMode
:ACQuire:RSIGnal {value} | IAgInfiniiVisionAcquisition2.ReferenceSignal
:ACQuire:RSIGnal? | IAgInfiniiVisionAcquisition2.ReferenceSignal
:ACQuire:SEGMented:ANALyze | IAgInfiniiVisionAcquisitionSegmentedMemory.Analyze
:ACQuire:SEGMented:COUNt {value} | IAgInfiniiVisionAcquisitionSegmentedMemory.Count
:ACQuire:SEGMented:COUNt? | IAgInfiniiVisionAcquisitionSegmentedMemory.Count
:ACQuire:SEGMented:INDex {value} | IAgInfiniiVisionAcquisitionSegmentedMemory.Index
:ACQuire:SEGMented:INDex? | IAgInfiniiVisionAcquisitionSegmentedMemory.Index
:ACQuire:TYPE {value} | IAgInfiniiVisionAcquisition.Type
:ACQuire:TYPE? | IAgInfiniiVisionAcquisition.Type
:ACTivity | IAgInfiniiVisionDigitalChannels.ResetActivity
:ACTivity? | IAgInfiniiVisionDigitalChannels.ReadActivity
:AUToscale | IAgInfiniiVisionMeasurements.AutoSetup
:BUS{BusType}:BIT{DigitalBits} {BitState} | IAgInfiniiVisionDigitalChannelsBus.SetDigitalBit
:BUS{BusType}:BIT{DigtalBits}? | IAgInfiniiVisionDigitalChannelsBus.IsDigitalBitEnabled
:BUS{BusType}:BITS (@{ChannelList}),{BitState} | IAgInfiniiVisionDigitalChannelsBus.SetChannelBit
:BUS{BusType}:BITS? | IAgInfiniiVisionDigitalChannelsBus.GetChannelBit
:BUS{BusType}:CLEar | IAgInfiniiVisionDigitalChannelsBus.Clear
:BUS{BusType}:DISPlay {ViewState} | IAgInfiniiVisionDigitalChannelsBus.Enable
:BUS{BusType}:DISPlay? | IAgInfiniiVisionDigitalChannelsBus.IsEnabled
:BUS{BusType}:LABel "{Label}" | IAgInfiniiVisionDigitalChannelsBus.SetLabel
:BUS{BusType}:LABel? | IAgInfiniiVisionDigitalChannelsBus.GetLabel
:BUS{BusType}:MASK {MaskBits}, | IAgInfiniiVisionDigitalChannelsBus.SetMaskBit
:BUS{BusType}:MASK? | IAgInfiniiVisionDigitalChannelsBus.GetMaskBit
:CALibrate:DATE? | IAgInfiniiVisionCalibration.Date
:CALibrate:LABel "{value}" | IAgInfiniiVisionCalibration.Label
:CALibrate:LABel? | IAgInfiniiVisionCalibration.Label
:CALibrate:OUTPut {value} | IAgInfiniiVisionCalibration.SignalSource
:CALibrate:OUTPut? | IAgInfiniiVisionCalibration.SignalSource
:CALibrate:PROTected? | IAgInfiniiVisionCalibration.Enabled
:CALibrate:STARt | IAgInfiniiVisionCalibration.Calibrate
:CALibrate:STATus? | IAgInfiniiVisionCalibration.Result
:CALibrate:TEMPerature? | IAgInfiniiVisionCalibration.Temperature
:CALibrate:TIME? | IAgInfiniiVisionCalibration.Time
:CHANnel{rcindex+1}:COUPling {value} | IAgInfiniiVisionChannel.Coupling
:CHANnel{rcindex+1}:COUPling? | IAgInfiniiVisionChannel.Coupling
:CHANnel{rcindex+1}:DISPlay {value} | IAgInfiniiVisionChannel.Enabled
:CHANnel{rcindex+1}:DISPlay? | IAgInfiniiVisionChannel.Enabled
:CHANnel{rcindex+1}:IMPedance {value} | IAgInfiniiVisionChannel.InputImpedance
:CHANnel{rcindex+1}:IMPedance? | IAgInfiniiVisionChannel.InputImpedance
:CHANnel{rcindex+1}:INVert {value} | IAgInfiniiVisionChannel.Invert
:CHANnel{rcindex+1}:INVert? | IAgInfiniiVisionChannel.Invert
:CHANnel{rcindex+1}:LABel "{value}" | IAgInfiniiVisionChannel.Label
:CHANnel{rcindex+1}:LABel? | IAgInfiniiVisionChannel.Label
:CHANnel{rcindex+1}:OFFSet {value} | IAgInfiniiVisionChannel.Offset
:CHANnel{rcindex+1}:OFFSet? | IAgInfiniiVisionChannel.Offset
:CHANnel{rcindex+1}:PROBe {value} | IAgInfiniiVisionChannel.ProbeAttenuation
:CHANnel{rcindex+1}:PROBe:ID? | IAgInfiniiVisionChannel.ProbeID
:CHANnel{rcindex+1}:PROBe:SKEW {value} | IAgInfiniiVisionChannel.ProbeSkew
:CHANnel{rcindex+1}:PROBe:SKEW? | IAgInfiniiVisionChannel.ProbeSkew
:CHANnel{rcindex+1}:PROBe? | IAgInfiniiVisionChannel.ProbeSense IAgInfiniiVisionChannel.ProbeAttenuation
:CHANnel{rcindex+1}:PROTection | IAgInfiniiVisionChannel.ClearProtection
:CHANnel{rcindex+1}:PROTection? | IAgInfiniiVisionChannel.Protection
:CHANnel{rcindex+1}:RANGe {value} | IAgInfiniiVisionChannel.Range
:CHANnel{rcindex+1}:RANGe? | IAgInfiniiVisionChannel.Range
:CHANnel{rcindex+1}:SCALe {value} | IAgInfiniiVisionChannel.Scale
:CHANnel{rcindex+1}:SCALe? | IAgInfiniiVisionChannel.Scale
:CHANnel{rcindex+1}:UNITs {value} | IAgInfiniiVisionChannel.Units
:CHANnel{rcindex+1}:UNITs? | IAgInfiniiVisionChannel.Units
:CLOCk {value} | IAgInfiniiVision4ClockRecovery.DisplayEnabled
:CLOCk:METHod {ClockMethod}, {DataRate}, {LoopBandwidth}, {DampingFactor}, {Source}, {Slope}, {Multiplier} | IAgInfiniiVision4ClockRecovery.SetMethod
:CLOCk:METHod? | IAgInfiniiVision4ClockRecovery.GetMethod
:CLOCk? | IAgInfiniiVision4ClockRecovery.DisplayEnabled
:COUNter:CURRent? | IAgInfiniiVision4Counter.Current
:COUNter:ENABle {value} | IAgInfiniiVision4Counter.Enabled
:COUNter:ENABle? | IAgInfiniiVision4Counter.Enabled
:COUNter:MODE {Mode};:COUNter:NDIGits {NumberOfDigits};:COUNter:SOURce {Source};:COUNter:TOTalize:SLOPe {TotalizeSlope} | IAgInfiniiVision4Counter.Configure
:COUNter:MODE {value} | IAgInfiniiVision4Counter.Mode
:COUNter:MODE? | IAgInfiniiVision4Counter.Mode
:COUNter:NDIGits {value} | IAgInfiniiVision4Counter.NumberOfDigits
:COUNter:NDIGits? | IAgInfiniiVision4Counter.NumberOfDigits
:COUNter:SOURce {value} | IAgInfiniiVision4Counter.Source
:COUNter:SOURce? | IAgInfiniiVision4Counter.Source
:COUNter:TOTalize:CLEar | IAgInfiniiVision4CounterTotalizer.Clear
:COUNter:TOTalize:GATE:ENABle {value} | IAgInfiniiVision4CounterTotalizerGating.Enabled
:COUNter:TOTalize:GATE:ENABle? | IAgInfiniiVision4CounterTotalizerGating.Enabled
:COUNter:TOTalize:GATE:POLarity {Polarity};:COUNter:TOTalize:GATE:SOURce {Source} | IAgInfiniiVision4CounterTotalizerGating.Configure
:COUNter:TOTalize:GATE:POLarity {value} | IAgInfiniiVision4CounterTotalizerGating.Polarity
:COUNter:TOTalize:GATE:POLarity? | IAgInfiniiVision4CounterTotalizerGating.Polarity
:COUNter:TOTalize:GATE:SOURce {value} | IAgInfiniiVision4CounterTotalizerGating.Source
:COUNter:TOTalize:GATE:SOURce? | IAgInfiniiVision4CounterTotalizerGating.Source
:COUNter:TOTalize:SLOPe {value} | IAgInfiniiVision4CounterTotalizer.Slope
:COUNter:TOTalize:SLOPe? | IAgInfiniiVision4CounterTotalizer.Slope
:DIGital{rcindex}:DISPlay {value} | IAgInfiniiVisionDigitalChannel.Enabled
:DIGital{rcindex}:DISPlay? | IAgInfiniiVisionDigitalChannel.Enabled
:DIGital{rcindex}:LABel "{value}" | IAgInfiniiVisionDigitalChannel.Label
:DIGital{rcindex}:LABel? | IAgInfiniiVisionDigitalChannel.Label
:DIGital{rcindex}:POSition {value} | IAgInfiniiVisionDigitalChannel.Position
:DIGital{rcindex}:POSition? | IAgInfiniiVisionDigitalChannel.Position
:DIGital{rcindex}:SIZE {value} | IAgInfiniiVisionDigitalChannel.Size
:DIGital{rcindex}:SIZE? | IAgInfiniiVisionDigitalChannel.Size
:DIGital{rcindex}:THReshold {value} | IAgInfiniiVisionDigitalChannel.Threshold
:DIGital{rcindex}:THReshold? | IAgInfiniiVisionDigitalChannel.Threshold
:DIGitize;*OPC? | IAgInfiniiVisionMeasurements.Initiate
:DISPlay:ANNotation {value} | IAgInfiniiVisionDisplay3Annotation.Enabled
:DISPlay:ANNotation:BACKground {value} | IAgInfiniiVisionDisplay3Annotation.Background
:DISPlay:ANNotation:BACKground? | IAgInfiniiVisionDisplay3Annotation.Background
:DISPlay:ANNotation:COLor {value} | IAgInfiniiVisionDisplay3Annotation.Color
:DISPlay:ANNotation:COLor? | IAgInfiniiVisionDisplay3Annotation.Color
:DISPlay:ANNotation:TEXT "{value}" | IAgInfiniiVisionDisplay3Annotation.Text
:DISPlay:ANNotation:TEXT? | IAgInfiniiVisionDisplay3Annotation.Text
:DISPlay:ANNotation? | IAgInfiniiVisionDisplay3Annotation.Enabled
:DISPlay:ANNotation{Index} {Enabled} | IAgInfiniiVisionDisplay4Annotation2.SetEnabled
:DISPlay:ANNotation{Index}:BACKground {Background} | IAgInfiniiVisionDisplay4Annotation2.SetBackground
:DISPlay:ANNotation{Index}:BACKground? | IAgInfiniiVisionDisplay4Annotation2.GetBackground
:DISPlay:ANNotation{Index}:COLor {Color} | IAgInfiniiVisionDisplay4Annotation2.SetColor
:DISPlay:ANNotation{Index}:COLor? | IAgInfiniiVisionDisplay4Annotation2.GetColor
:DISPlay:ANNotation{Index}:TEXT "{Text}" | IAgInfiniiVisionDisplay4Annotation2.SetText
:DISPlay:ANNotation{Index}:TEXT? | IAgInfiniiVisionDisplay4Annotation2.GetText
:DISPlay:ANNotation{Index}:X1Position {Position} | IAgInfiniiVisionDisplay4Annotation2.SetX1Position
:DISPlay:ANNotation{Index}:X1Position? | IAgInfiniiVisionDisplay4Annotation2.GetX1Position
:DISPlay:ANNotation{Index}:Y1Position {Position} | IAgInfiniiVisionDisplay4Annotation2.SetY1Position
:DISPlay:ANNotation{Index}:Y1Position? | IAgInfiniiVisionDisplay4Annotation2.GetY1Position
:DISPlay:ANNotation{Index}? | IAgInfiniiVisionDisplay4Annotation2.GetEnabled
:DISPlay:CLEar | IAgInfiniiVisionDisplay.Erase
:DISPlay:DATA? {ImageFormat}, {Palette}; | IAgInfiniiVisionDisplay.GetScreenBitmap
:DISPlay:LABel {value} | IAgInfiniiVisionDisplay.LabelEnabled
:DISPlay:LABel? | IAgInfiniiVisionDisplay.LabelEnabled
:DISPlay:PERSistence {value} | IAgInfiniiVisionDisplay.PersistenceTime
:DISPlay:PERSistence {value} | IAgInfiniiVisionDisplay.Persistence
:DISPlay:PERSistence? | IAgInfiniiVisionDisplay.Persistence IAgInfiniiVisionDisplay.PersistenceTime
:DISPlay:SIDebar {value} | IAgInfiniiVisionDisplay3.Sidebar
:DISPlay:VECTors {value} | IAgInfiniiVisionDisplay.VectorEnabled
:DISPlay:VECTors? | IAgInfiniiVisionDisplay.VectorEnabled
:DVM:ARANge {value} | IAgInfiniiVisionDVM.AutoRangeEnabled
:DVM:ARANge? | IAgInfiniiVisionDVM.AutoRangeEnabled
:DVM:CURRent? | IAgInfiniiVisionDVM.Current
:DVM:ENABle {value} | IAgInfiniiVisionDVM.Enabled
:DVM:ENABle? | IAgInfiniiVisionDVM.Enabled
:DVM:FREQuency? | IAgInfiniiVisionDVM.Frequency
:DVM:MODE {value} | IAgInfiniiVisionDVM.Mode
:DVM:MODE? | IAgInfiniiVisionDVM.Mode
:DVM:SOURce {value} | IAgInfiniiVisionDVM.Source
:DVM:SOURce? | IAgInfiniiVisionDVM.Source
:EXTernal:DISPlay {value} | IAgInfiniiVisionExternal2.Enabled
:EXTernal:DISPlay? | IAgInfiniiVisionExternal2.Enabled
:EXTernal:LABel {value:%Qs} | IAgInfiniiVisionExternal2.Label
:EXTernal:LABel? | IAgInfiniiVisionExternal2.Label
:EXTernal:LEVel {value} | IAgInfiniiVisionExternal2.Threshold
:EXTernal:LEVel? | IAgInfiniiVisionExternal2.Threshold
:EXTernal:POSition {value} | IAgInfiniiVisionExternal2.VerticalPosition
:EXTernal:POSition? | IAgInfiniiVisionExternal2.VerticalPosition
:EXTernal:PROBe {value} | IAgInfiniiVisionExternal.ProbeAttenuation
:EXTernal:PROBe? | IAgInfiniiVisionExternal.ProbeAttenuation IAgInfiniiVisionExternal.ProbeSense
:EXTernal:RANGe {value} | IAgInfiniiVisionExternal.Range
:EXTernal:RANGe? | IAgInfiniiVisionExternal.Range
:EXTernal:UNITs {value} | IAgInfiniiVisionExternal.Units
:EXTernal:UNITs? | IAgInfiniiVisionExternal.Units
:FFT:AVERage:COUNt {value} | IAgInfiniiVision5FFT.AverageCount
:FFT:AVERage:COUNt? | IAgInfiniiVision5FFT.AverageCount
:FFT:CENTer {value} | IAgInfiniiVision5FFT.CenterFrequency
:FFT:CENTer? | IAgInfiniiVision5FFT.CenterFrequency
:FFT:CLEar | IAgInfiniiVision5FFT.Clear
:FFT:DISPlay {value} | IAgInfiniiVision5FFT.Enabled
:FFT:DISPlay? | IAgInfiniiVision5FFT.Enabled
:FFT:DMODe {value} | IAgInfiniiVision5FFT.DisplayMode
:FFT:DMODe? | IAgInfiniiVision5FFT.DisplayMode
:FFT:FREQuency:STARt {value} | IAgInfiniiVision5FFT.StartFrequency
:FFT:FREQuency:STARt? | IAgInfiniiVision5FFT.StartFrequency
:FFT:FREQuency:STOP {value} | IAgInfiniiVision5FFT.StopFrequency
:FFT:FREQuency:STOP? | IAgInfiniiVision5FFT.StopFrequency
:FFT:OFFSet {value} | IAgInfiniiVision5FFT.Offset
:FFT:OFFSet? | IAgInfiniiVision5FFT.Offset
:FFT:RANGe {value} | IAgInfiniiVision5FFT.Range
:FFT:RANGe? | IAgInfiniiVision5FFT.Range
:FFT:SOURce1 {value} | IAgInfiniiVision5FFT.Source
:FFT:SOURce1? | IAgInfiniiVision5FFT.Source
:FFT:SPAN {value} | IAgInfiniiVision5FFT.Span
:FFT:SPAN? | IAgInfiniiVision5FFT.Span
:FFT:VTYPe {value} | IAgInfiniiVision5FFT.VerticalUnits
:FFT:VTYPe? | IAgInfiniiVision5FFT.VerticalUnits
:FFT:WINDow {value} | IAgInfiniiVision5FFT.WindowType
:FFT:WINDow? | IAgInfiniiVision5FFT.WindowType
:FRANalysis:DATA? | IAgInfiniiVision8FRA.FetchData
:FRANalysis:ENABle | IAgInfiniiVision8FRA.Enabled
:FRANalysis:ENABle? | IAgInfiniiVision8FRA.Enabled
:FRANalysis:FREQuency:MODE {value} | IAgInfiniiVision8FRA.SweepMode
:FRANalysis:FREQuency:MODE? | IAgInfiniiVision8FRA.SweepMode
:FRANalysis:FREQuency:STARt {value} | IAgInfiniiVision8FRA.StartFrequency
:FRANalysis:FREQuency:STARt? | IAgInfiniiVision8FRA.StartFrequency
:FRANalysis:FREQuency:STOP | IAgInfiniiVision8FRA.StopFrequency
:FRANalysis:FREQuency:STOP? | IAgInfiniiVision8FRA.StopFrequency
:FRANalysis:PPDecade {value} | IAgInfiniiVision8FRA.PointsPerDecade
:FRANalysis:PPDecade? | IAgInfiniiVision8FRA.PointsPerDecade
:FRANalysis:RUN | IAgInfiniiVision8FRA.Run
:FRANalysis:SOURce:INPut {value} | IAgInfiniiVision8FRA.InputSource
:FRANalysis:SOURce:INPut? | IAgInfiniiVision8FRA.InputSource
:FRANalysis:SOURce:OUTPut {value} | IAgInfiniiVision8FRA.OutputSource
:FRANalysis:SOURce:OUTPut? | IAgInfiniiVision8FRA.OutputSource
:FRANalysis:WGEN:LOAD {value} | IAgInfiniiVision8FRA.OutputLoadImpedance
:FRANalysis:WGEN:LOAD? | IAgInfiniiVision8FRA.OutputLoadImpedance
:FRANalysis:WGEN:VOLTage {Amplitude}, {Range} | IAgInfiniiVision8FRA.SetAmplitudeProfile
:FRANalysis:WGEN:VOLTage {value} | IAgInfiniiVision8FRA.Amplitude
:FRANalysis:WGEN:VOLTage:PROFile {value} | IAgInfiniiVision8FRA.AmplitudeProfileState
:FRANalysis:WGEN:VOLTage:PROFile? | IAgInfiniiVision8FRA.AmplitudeProfileState
:FRANalysis:WGEN:VOLTage? | IAgInfiniiVision8FRA.Amplitude
:FRANalysis:WGEN:VOLTage? {Range} | IAgInfiniiVision8FRA.GetAmplitudeProfile
:FUNCtion:BUS:CLOCk {value} | IAgInfiniiVisionMath2Bus.ClockSource
:FUNCtion:BUS:CLOCk? | IAgInfiniiVisionMath2Bus.ClockSource
:FUNCtion:BUS:SLOPe {value} | IAgInfiniiVisionMath2Bus.Slope
:FUNCtion:BUS:SLOPe? | IAgInfiniiVisionMath2Bus.Slope
:FUNCtion:BUS:YINCrement {value} | IAgInfiniiVisionMath2Bus.YIncrement
:FUNCtion:BUS:YINCrement? | IAgInfiniiVisionMath2Bus.YIncrement
:FUNCtion:BUS:YORigin {value} | IAgInfiniiVisionMath2Bus.YOrigin
:FUNCtion:BUS:YORigin? | IAgInfiniiVisionMath2Bus.YOrigin
:FUNCtion:BUS:YUNits {value} | IAgInfiniiVisionMath2Bus.YUnits
:FUNCtion:BUS:YUNits? | IAgInfiniiVisionMath2Bus.YUnits
:FUNCtion:CENTer {value} | IAgInfiniiVisionMathFFT.CenterFrequency
:FUNCtion:CENTer? | IAgInfiniiVisionMathFFT.CenterFrequency
:FUNCtion:DISPlay {value} | IAgInfiniiVisionMath.Enabled
:FUNCtion:DISPlay? | IAgInfiniiVisionMath.Enabled
:FUNCtion:FREQuency:HIGHpass {value} | IAgInfiniiVisionMath2FilterFrequency.HighPassBandwidth
:FUNCtion:FREQuency:HIGHpass? | IAgInfiniiVisionMath2FilterFrequency.HighPassBandwidth
:FUNCtion:FREQuency:LOWPass {value} | IAgInfiniiVisionMath2FilterFrequency.LowPassBandwidth
:FUNCtion:FREQuency:LOWPass? | IAgInfiniiVisionMath2FilterFrequency.LowPassBandwidth
:FUNCtion:GOFT:OPERation {value} | IAgInfiniiVisionMath.InternalOperation
:FUNCtion:GOFT:OPERation? | IAgInfiniiVisionMath.InternalOperation
:FUNCtion:GOFT:SOURce1 {value} | IAgInfiniiVisionMath.InternalSource1
:FUNCtion:GOFT:SOURce1? | IAgInfiniiVisionMath.InternalSource1
:FUNCtion:GOFT:SOURce2 {value} | IAgInfiniiVisionMath.InternalSource2
:FUNCtion:GOFT:SOURce2? | IAgInfiniiVisionMath.InternalSource2
:FUNCtion:INTegrate:IOFFset {value} | IAgInfiniiVisionMath2Integrate.InputOffset
:FUNCtion:INTegrate:IOFFset? | IAgInfiniiVisionMath2Integrate.InputOffset
:FUNCtion:LINear:GAIN {value} | IAgInfiniiVisionMath2Linear.Gain
:FUNCtion:LINear:GAIN? | IAgInfiniiVisionMath2Linear.Gain
:FUNCtion:LINear:OFFSet {value} | IAgInfiniiVisionMath2Linear.Offset
:FUNCtion:LINear:OFFSet? | IAgInfiniiVisionMath2Linear.Offset
:FUNCtion:OFFSet {value} | IAgInfiniiVisionMath.Offset
:FUNCtion:OFFSet? | IAgInfiniiVisionMath.Offset
:FUNCtion:OPERation {value} | IAgInfiniiVisionMath.Operation
:FUNCtion:OPERation? | IAgInfiniiVisionMath.Operation
:FUNCtion:RANGe {value} | IAgInfiniiVisionMath.Range
:FUNCtion:RANGe? | IAgInfiniiVisionMath.Range
:FUNCtion:SCALe {value} | IAgInfiniiVisionMath.VerticalScale
:FUNCtion:SCALe? | IAgInfiniiVisionMath.VerticalScale
:FUNCtion:SOURce1 {value} | IAgInfiniiVisionMath.Source1
:FUNCtion:SOURce1? | IAgInfiniiVisionMath.Source1
:FUNCtion:SOURce2 {value} | IAgInfiniiVisionMath.Source2
:FUNCtion:SOURce2? | IAgInfiniiVisionMath.Source2
:FUNCtion:SPAN {value} | IAgInfiniiVisionMathFFT.Span
:FUNCtion:SPAN? | IAgInfiniiVisionMathFFT.Span
:FUNCtion:TRENd:MEASurement {value} | IAgInfiniiVisionMath2MeasurementTrend.Type
:FUNCtion:TRENd:MEASurement? | IAgInfiniiVisionMath2MeasurementTrend.Type
:FUNCtion:VTYPe {value} | IAgInfiniiVisionMathFFT2.VerticalUnits
:FUNCtion:VTYPe? | IAgInfiniiVisionMathFFT2.VerticalUnits
:FUNCtion:WINDow {value} | IAgInfiniiVisionMathFFT.WindowType
:FUNCtion:WINDow? | IAgInfiniiVisionMathFFT.WindowType
:FUNCtion{rcindex+1}:AVERage:COUNt {value} | IAgInfiniiVisionMathFunctionAverage.Count
:FUNCtion{rcindex+1}:AVERage:COUNt? | IAgInfiniiVisionMathFunctionAverage.Count
:FUNCtion{rcindex+1}:BUS:CLOCk {value} | IAgInfiniiVisionMathFunctionBus.ClockSource
:FUNCtion{rcindex+1}:BUS:CLOCk? | IAgInfiniiVisionMathFunctionBus.ClockSource
:FUNCtion{rcindex+1}:BUS:SLOPe {value} | IAgInfiniiVisionMathFunctionBus.Slope
:FUNCtion{rcindex+1}:BUS:SLOPe? | IAgInfiniiVisionMathFunctionBus.Slope
:FUNCtion{rcindex+1}:BUS:YINCrement {value} | IAgInfiniiVisionMathFunctionBus.YIncrement
:FUNCtion{rcindex+1}:BUS:YINCrement? | IAgInfiniiVisionMathFunctionBus.YIncrement
:FUNCtion{rcindex+1}:BUS:YORigin {value} | IAgInfiniiVisionMathFunctionBus.YOrigin
:FUNCtion{rcindex+1}:BUS:YORigin? | IAgInfiniiVisionMathFunctionBus.YOrigin
:FUNCtion{rcindex+1}:BUS:YUNits {value} | IAgInfiniiVisionMathFunctionBus.YUnits
:FUNCtion{rcindex+1}:BUS:YUNits? | IAgInfiniiVisionMathFunctionBus.YUnits
:FUNCtion{rcindex+1}:CENTer {value} | IAgInfiniiVisionMathFunctionFFT.CenterFrequency
:FUNCtion{rcindex+1}:CENTer? | IAgInfiniiVisionMathFunctionFFT.CenterFrequency
:FUNCtion{rcindex+1}:DISPlay {value} | IAgInfiniiVisionMathFunction.Enabled
:FUNCtion{rcindex+1}:DISPlay? | IAgInfiniiVisionMathFunction.Enabled
:FUNCtion{rcindex+1}:FFT:FREQuency:STARt {value} | IAgInfiniiVisionMathFunctionFFT2.StartFrequency
:FUNCtion{rcindex+1}:FFT:FREQuency:STARt? | IAgInfiniiVisionMathFunctionFFT2.StartFrequency
:FUNCtion{rcindex+1}:FFT:FREQuency:STOP {value} | IAgInfiniiVisionMathFunctionFFT2.StopFrequency
:FUNCtion{rcindex+1}:FFT:FREQuency:STOP? | IAgInfiniiVisionMathFunctionFFT2.StopFrequency
:FUNCtion{rcindex+1}:FREQuency:HIGHpass {value} | IAgInfiniiVisionMathFunctionFilter.HighPassBandwidth
:FUNCtion{rcindex+1}:FREQuency:HIGHpass? | IAgInfiniiVisionMathFunctionFilter.HighPassBandwidth
:FUNCtion{rcindex+1}:FREQuency:LOWPass {value} | IAgInfiniiVisionMathFunctionFilter.LowPassBandwidth
:FUNCtion{rcindex+1}:FREQuency:LOWPass? | IAgInfiniiVisionMathFunctionFilter.LowPassBandwidth
:FUNCtion{rcindex+1}:INTegrate:IOFFset {value} | IAgInfiniiVisionMathFunctionIntegrate.InputOffset
:FUNCtion{rcindex+1}:INTegrate:IOFFset? | IAgInfiniiVisionMathFunctionIntegrate.InputOffset
:FUNCtion{rcindex+1}:LINear:GAIN {value} | IAgInfiniiVisionMathFunctionLinear.Gain
:FUNCtion{rcindex+1}:LINear:GAIN? | IAgInfiniiVisionMathFunctionLinear.Gain
:FUNCtion{rcindex+1}:LINear:OFFSet {value} | IAgInfiniiVisionMathFunctionLinear.Offset
:FUNCtion{rcindex+1}:LINear:OFFSet? | IAgInfiniiVisionMathFunctionLinear.Offset
:FUNCtion{rcindex+1}:OFFSet {value} | IAgInfiniiVisionMathFunction.Offset
:FUNCtion{rcindex+1}:OFFSet? | IAgInfiniiVisionMathFunction.Offset
:FUNCtion{rcindex+1}:OPERation {value} | IAgInfiniiVisionMathFunction.Operation
:FUNCtion{rcindex+1}:OPERation? | IAgInfiniiVisionMathFunction.Operation
:FUNCtion{rcindex+1}:RANGe {value} | IAgInfiniiVisionMathFunction.Range
:FUNCtion{rcindex+1}:RANGe? | IAgInfiniiVisionMathFunction.Range
:FUNCtion{rcindex+1}:SCALe {value} | IAgInfiniiVisionMathFunction.Scale
:FUNCtion{rcindex+1}:SCALe? | IAgInfiniiVisionMathFunction.Scale
:FUNCtion{rcindex+1}:SMOoth:POINts {value} | IAgInfiniiVisionMathFunction2Smoothing.Points
:FUNCtion{rcindex+1}:SMOoth:POINts? | IAgInfiniiVisionMathFunction2Smoothing.Points
:FUNCtion{rcindex+1}:SOURce1 {value} | IAgInfiniiVisionMathFunction.Source1
:FUNCtion{rcindex+1}:SOURce1? | IAgInfiniiVisionMathFunction.Source1
:FUNCtion{rcindex+1}:SOURce2 {value} | IAgInfiniiVisionMathFunction.Source2
:FUNCtion{rcindex+1}:SOURce2? | IAgInfiniiVisionMathFunction.Source2
:FUNCtion{rcindex+1}:SPAN {value} | IAgInfiniiVisionMathFunctionFFT.Span
:FUNCtion{rcindex+1}:SPAN? | IAgInfiniiVisionMathFunctionFFT.Span
:FUNCtion{rcindex+1}:TRENd:MEASurement {value} | IAgInfiniiVisionMathFunctionMeasurementTrend.Type
:FUNCtion{rcindex+1}:TRENd:MEASurement? | IAgInfiniiVisionMathFunctionMeasurementTrend.Type
:FUNCtion{rcindex+1}:TRENd:NMEasurement {value} | IAgInfiniiVisionMathFunctionMeasurementTrend2.Slot
:FUNCtion{rcindex+1}:TRENd:NMEasurement? | IAgInfiniiVisionMathFunctionMeasurementTrend2.Slot
:FUNCtion{rcindex+1}:VTYPe {value} | IAgInfiniiVisionMathFunctionFFT.VerticalUnits
:FUNCtion{rcindex+1}:VTYPe? | IAgInfiniiVisionMathFunctionFFT.VerticalUnits
:FUNCtion{rcindex+1}:WINDow {value} | IAgInfiniiVisionMathFunctionFFT.WindowType
:FUNCtion{rcindex+1}:WINDow? | IAgInfiniiVisionMathFunctionFFT.WindowType
:HARDcopy:INKSaver {value} | IAgInfiniiVisionDisplay2.InvertColorEnabled
:HARDcopy:INKSaver? | IAgInfiniiVisionDisplay2.InvertColorEnabled
:HISTogram:AXIS {value} | IAgInfiniiVision4Histogram.Axis
:HISTogram:AXIS? | IAgInfiniiVision4Histogram.Axis
:HISTogram:DISPlay {value} | IAgInfiniiVision4Histogram.DisplayEnabled
:HISTogram:DISPlay? | IAgInfiniiVision4Histogram.DisplayEnabled
:HISTogram:MEASurement {value} | IAgInfiniiVision4Histogram.Measurement
:HISTogram:MEASurement? | IAgInfiniiVision4Histogram.Measurement
:HISTogram:MODE {value} | IAgInfiniiVision4Histogram.Mode
:HISTogram:MODE? | IAgInfiniiVision4Histogram.Mode
:HISTogram:RESet | IAgInfiniiVision4Histogram.Reset
:HISTogram:SIZE {value} | IAgInfiniiVision4Histogram.Size
:HISTogram:SIZE? | IAgInfiniiVision4Histogram.Size
:HISTogram:TYPE {value} | IAgInfiniiVision4Histogram.Type
:HISTogram:TYPE? | IAgInfiniiVision4Histogram.Type
:HISTogram:WINDow:BLIMit {value} | IAgInfiniiVision4HistogramWindowLimits.Bottom
:HISTogram:WINDow:BLIMit? | IAgInfiniiVision4HistogramWindowLimits.Bottom
:HISTogram:WINDow:LLIMit {value} | IAgInfiniiVision4HistogramWindowLimits.Left
:HISTogram:WINDow:LLIMit? | IAgInfiniiVision4HistogramWindowLimits.Left
:HISTogram:WINDow:RLIMit {value} | IAgInfiniiVision4HistogramWindowLimits.Right
:HISTogram:WINDow:RLIMit? | IAgInfiniiVision4HistogramWindowLimits.Right
:HISTogram:WINDow:SOURce {value} | IAgInfiniiVision4HistogramWindow.Source
:HISTogram:WINDow:SOURce? | IAgInfiniiVision4HistogramWindow.Source
:HISTogram:WINDow:TLIMit {value} | IAgInfiniiVision4HistogramWindowLimits.Top
:HISTogram:WINDow:TLIMit? | IAgInfiniiVision4HistogramWindowLimits.Top
:JITTer:HISTogram:APPLy | IAgInfiniiVision4Jitter.ConfigureHistogram
:JITTer:MEASurement {value} | IAgInfiniiVision4Jitter.Measurement
:JITTer:MEASurement? | IAgInfiniiVision4Jitter.Measurement
:JITTer:SPECtrum:APPLy | IAgInfiniiVision4JitterSpectrum.Configure
:JITTer:SPECtrum:HORizontal:POSition {value} | IAgInfiniiVision4JitterSpectrumHorizontal.CenterFrequency
:JITTer:SPECtrum:HORizontal:POSition? | IAgInfiniiVision4JitterSpectrumHorizontal.CenterFrequency
:JITTer:SPECtrum:HORizontal:RANGe {value} | IAgInfiniiVision4JitterSpectrumHorizontal.FrequencySpan
:JITTer:SPECtrum:HORizontal:RANGe? | IAgInfiniiVision4JitterSpectrumHorizontal.FrequencySpan
:JITTer:SPECtrum:VERTical:OFFSet {value} | IAgInfiniiVision4JitterSpectrumVertical.Offset
:JITTer:SPECtrum:VERTical:OFFSet? | IAgInfiniiVision4JitterSpectrumVertical.Offset
:JITTer:SPECtrum:VERTical:RANGe {value} | IAgInfiniiVision4JitterSpectrumVertical.Range
:JITTer:SPECtrum:VERTical:RANGe? | IAgInfiniiVision4JitterSpectrumVertical.Range
:JITTer:SPECtrum:VERTical:TYPE {value} | IAgInfiniiVision4JitterSpectrumVertical.Unit
:JITTer:SPECtrum:VERTical:TYPE? | IAgInfiniiVision4JitterSpectrumVertical.Unit
:JITTer:SPECtrum:WINDow {value} | IAgInfiniiVision4JitterSpectrum.Window
:JITTer:SPECtrum:WINDow? | IAgInfiniiVision4JitterSpectrum.Window
:JITTer:STATe {value} | IAgInfiniiVision4Jitter.AnalysisEnabled
:JITTer:STATe? | IAgInfiniiVision4Jitter.AnalysisEnabled
:JITTer:TRENd:APPLy | IAgInfiniiVision4JitterTrend.Configure
:JITTer:TRENd:SMOoth:APPLy | IAgInfiniiVision4JitterTrend.ConfigureSmoothing
:JITTer:TRENd:SMOoth:POINts {value} | IAgInfiniiVision4JitterTrend.SmoothingPoints
:JITTer:TRENd:SMOoth:POINts? | IAgInfiniiVision4JitterTrend.SmoothingPoints
:JITTer:TRENd:VERTical:OFFSet {value} | IAgInfiniiVision4JitterTrendVertical.Offset
:JITTer:TRENd:VERTical:OFFSet? | IAgInfiniiVision4JitterTrendVertical.Offset
:JITTer:TRENd:VERTical:RANGe {value} | IAgInfiniiVision4JitterTrendVertical.Range
:JITTer:TRENd:VERTical:RANGe? | IAgInfiniiVision4JitterTrendVertical.Range
:LISTer:DATA? | IAgInfiniiVision2SerialBusesLister.GetData
:LISTer:DISPlay {value} | IAgInfiniiVision2SerialBusesLister.Display
:LISTer:DISPlay? | IAgInfiniiVision2SerialBusesLister.Display
:LISTer:REFerence {value} | IAgInfiniiVision2SerialBusesLister.TimeReference
:LISTer:REFerence? | IAgInfiniiVision2SerialBusesLister.TimeReference
:MARKer:MODE {value} | IAgInfiniiVisionCursors.Mode
:MARKer:MODE? | IAgInfiniiVisionCursors.Mode
:MARKer:X1Position {value} | IAgInfiniiVisionCursors.X1Position
:MARKer:X1Position? | IAgInfiniiVisionCursors.X1Position
:MARKer:X1Y1source {value} | IAgInfiniiVisionCursors.X1Y1Source
:MARKer:X1Y1source? | IAgInfiniiVisionCursors.X1Y1Source
:MARKer:X2Position {value} | IAgInfiniiVisionCursors.X2Position
:MARKer:X2Position? | IAgInfiniiVisionCursors.X2Position
:MARKer:X2Y2source {value} | IAgInfiniiVisionCursors.X2Y2Source
:MARKer:X2Y2source? | IAgInfiniiVisionCursors.X2Y2Source
:MARKer:XDELta? | IAgInfiniiVisionCursors.XDelta
:MARKer:XUNits {value} | IAgInfiniiVisionCursors2.XUnits
:MARKer:XUNits? | IAgInfiniiVisionCursors2.XUnits
:MARKer:Y1Position {value} | IAgInfiniiVisionCursors.Y1Position
:MARKer:Y1Position? | IAgInfiniiVisionCursors.Y1Position
:MARKer:Y2Position {value} | IAgInfiniiVisionCursors.Y2Position
:MARKer:Y2Position? | IAgInfiniiVisionCursors.Y2Position
:MARKer:YDELta? | IAgInfiniiVisionCursors.YDelta
:MARKer:YUNits {value} | IAgInfiniiVisionCursors2.YUnits
:MARKer:YUNits? | IAgInfiniiVisionCursors2.YUnits
:MEASure:{MeasFunction} , {Slope}, {NumberOfPeriods}, {Unit} | IAgInfiniiVisionMeasurement2.ConfigureJitterMeasurement
:MEASure:{MeasFunction}? | IAgInfiniiVisionMeasurement.FetchWaveformMeasurement IAgInfiniiVisionMeasurement.ReadWaveformMeasurement
:MEASure:{Measurement} {Source} | IAgInfiniiVisionMeasurements2Statistics.InstallMeasurement
:MEASure:CLEar | IAgInfiniiVisionMeasurements.Clear
:MEASure:DEFine | IAgInfiniiVisionReferenceLevel.High IAgInfiniiVisionReferenceLevel.Low IAgInfiniiVisionReferenceLevel.Mid
:MEASure:DEFine DEL | IAgInfiniiVisionMeasurementsConfiguration.DelayOccurrence1 IAgInfiniiVisionMeasurementsConfiguration.DelayOccurrence2
:MEASure:DEFine DEL {value} | IAgInfiniiVisionMeasurementsConfiguration.DelaySlope1 IAgInfiniiVisionMeasurementsConfiguration.DelaySlope2
:MEASure:DEFine? | IAgInfiniiVisionReferenceLevel.High IAgInfiniiVisionReferenceLevel.Low IAgInfiniiVisionReferenceLevel.Mid
:MEASure:DEFine? DEL | IAgInfiniiVisionMeasurementsConfiguration.DelayOccurrence1 IAgInfiniiVisionMeasurementsConfiguration.DelayOccurrence2 IAgInfiniiVisionMeasurementsConfiguration.DelaySlope1 IAgInfiniiVisionMeasurementsConfiguration.DelaySlope2
:MEASure:HISTogram:{ResultType}? | IAgInfiniiVision4Histogram.GetResult
:MEASure:RESults? | IAgInfiniiVisionMeasurements2Statistics.GetResults
:MEASure:SHOW {value} | IAgInfiniiVisionMeasurementsConfiguration.MarkersEnabled
:MEASure:SHOW? | IAgInfiniiVisionMeasurementsConfiguration.MarkersEnabled
:MEASure:STATistics {value} | IAgInfiniiVisionMeasurements2Statistics.Format
:MEASure:STATistics:DISPlay {value} | IAgInfiniiVisionMeasurements2Statistics.DisplayEnabled
:MEASure:STATistics:DISPlay? | IAgInfiniiVisionMeasurements2Statistics.DisplayEnabled
:MEASure:STATistics:INCRement | IAgInfiniiVisionMeasurements2Statistics.Increment
:MEASure:STATistics:MCOunt {value} | IAgInfiniiVisionMeasurements2Statistics.Count
:MEASure:STATistics:MCOunt? | IAgInfiniiVisionMeasurements2Statistics.Count
:MEASure:STATistics:RESet | IAgInfiniiVisionMeasurements2Statistics.Reset
:MEASure:STATistics:RSDeviation {value} | IAgInfiniiVisionMeasurements2Statistics.RelativeStdDevEnabled
:MEASure:STATistics:RSDeviation? | IAgInfiniiVisionMeasurements2Statistics.RelativeStdDevEnabled
:MEASure:STATistics? | IAgInfiniiVisionMeasurements2Statistics.Format
:MEASure:WINDow {value} | IAgInfiniiVisionMeasurementsConfiguration.Window
:MEASure:WINDow? | IAgInfiniiVisionMeasurementsConfiguration.Window
:MEAure:{MeasFunction}? , {Slope}, {NumberOfPeriods}, {Unit} | IAgInfiniiVisionMeasurement2.FetchJitterMeasurement IAgInfiniiVisionMeasurement2.ReadJitterMeasurement
:MTESt:ALL {value} | IAgInfiniiVisionMaskTest.AllChannelEnabled
:MTESt:ALL? | IAgInfiniiVisionMaskTest.AllChannelEnabled
:MTESt:AMASk:CREate | IAgInfiniiVisionMaskTest.AutoMask
:MTESt:AMASk:UNITs {value} | IAgInfiniiVisionMaskTest.AutoMaskUnits
:MTESt:AMASk:UNITs? | IAgInfiniiVisionMaskTest.AutoMaskUnits
:MTESt:AMASk:XDELta {value} | IAgInfiniiVisionMaskTest.HorizontalTolerance
:MTESt:AMASk:XDELta? | IAgInfiniiVisionMaskTest.HorizontalTolerance
:MTESt:AMASk:YDELta {value} | IAgInfiniiVisionMaskTest.VerticalTolerance
:MTESt:AMASk:YDELta? | IAgInfiniiVisionMaskTest.VerticalTolerance
:MTESt:COUNt:FWAVeforms? | IAgInfiniiVisionMaskTest.FailedWaveformCount
:MTESt:COUNt:RESet | IAgInfiniiVisionMaskTest.Reset
:MTESt:COUNt:TIME? | IAgInfiniiVisionMaskTest.ElapsedTime
:MTESt:COUNt:WAVeforms? | IAgInfiniiVisionMaskTest.WaveformCount
:MTESt:DELete | IAgInfiniiVisionMaskTest.Delete
:MTESt:ENABle {value} | IAgInfiniiVisionMaskTest.Enabled
:MTESt:ENABle? | IAgInfiniiVisionMaskTest.Enabled
:MTESt:LOCK {value} | IAgInfiniiVisionMaskTest.LockEnabled
:MTESt:LOCK? | IAgInfiniiVisionMaskTest.LockEnabled
:MTESt:RMODe {value} | IAgInfiniiVisionMaskTestConfiguration.TerminationCondition
:MTESt:RMODe:FACTion:MEASure {value} | IAgInfiniiVisionMaskTestConfiguration.MeasurementEnabled
:MTESt:RMODe:FACTion:MEASure? | IAgInfiniiVisionMaskTestConfiguration.MeasurementEnabled
:MTESt:RMODe:FACTion:PRINt {value} | IAgInfiniiVisionMaskTest.PrintFailuresEnabled
:MTESt:RMODe:FACTion:PRINt? | IAgInfiniiVisionMaskTest.PrintFailuresEnabled
:MTESt:RMODe:FACTion:SAVE {value} | IAgInfiniiVisionMaskTest.SaveFailuresEnabled
:MTESt:RMODe:FACTion:SAVE? | IAgInfiniiVisionMaskTest.SaveFailuresEnabled
:MTESt:RMODe:FACTion:STOP {value} | IAgInfiniiVisionMaskTestConfiguration.TerminationEnabled
:MTESt:RMODe:FACTion:STOP? | IAgInfiniiVisionMaskTestConfiguration.TerminationEnabled
:MTESt:RMODe:SIGMa {value} | IAgInfiniiVisionMaskTestConfiguration.SigmaLevel
:MTESt:RMODe:SIGMa? | IAgInfiniiVisionMaskTestConfiguration.SigmaLevel
:MTESt:RMODe:TIME {value} | IAgInfiniiVisionMaskTestConfiguration.Time
:MTESt:RMODe:TIME? | IAgInfiniiVisionMaskTestConfiguration.Time
:MTESt:RMODe:WAVeforms {value} | IAgInfiniiVisionMaskTestConfiguration.Waveform
:MTESt:RMODe:WAVeforms? | IAgInfiniiVisionMaskTestConfiguration.Waveform
:MTESt:RMODe? | IAgInfiniiVisionMaskTestConfiguration.TerminationCondition
:MTESt:SCALe:BIND {value} | IAgInfiniiVisionMaskTest.BindControlEnabled
:MTESt:SCALe:BIND? | IAgInfiniiVisionMaskTest.BindControlEnabled
:MTESt:SCALe:X1 {value} | IAgInfiniiVisionMaskTestMarkers.X1Coordinate
:MTESt:SCALe:X1? | IAgInfiniiVisionMaskTestMarkers.X1Coordinate
:MTESt:SCALe:XDELta {value} | IAgInfiniiVisionMaskTestMarkers.XDelta
:MTESt:SCALe:XDELta? | IAgInfiniiVisionMaskTestMarkers.XDelta
:MTESt:SCALe:Y1 {value} | IAgInfiniiVisionMaskTestMarkers.Y1Coordinate
:MTESt:SCALe:Y1? | IAgInfiniiVisionMaskTestMarkers.Y1Coordinate
:MTESt:SCALe:Y2 {value} | IAgInfiniiVisionMaskTestMarkers.Y2Coordinate
:MTESt:SCALe:Y2? | IAgInfiniiVisionMaskTestMarkers.Y2Coordinate
:MTESt:SOURce {value} | IAgInfiniiVisionMaskTestConfiguration.Source
:MTESt:SOURce? | IAgInfiniiVisionMaskTestConfiguration.Source
:MTESt:TITLe? | IAgInfiniiVisionMaskTest.Title
:OPERation:CONDition? | IAgInfiniiVisionTrigger.Continuous
:RECall:FILename {value:%Qs} | IAgInfiniiVisionMemory.CurrentRecallFile
:RECall:FILename? | IAgInfiniiVisionMemory.CurrentRecallFile
:RECall:PWD "{value}" | IAgInfiniiVisionMemory.CurrentRecallDirectory
:RECall:PWD? | IAgInfiniiVisionMemory.CurrentRecallDirectory
:RECall{Options} {FileName:%Qs} | IAgInfiniiVisionMemory.Recall
:RUN |:STOP | IAgInfiniiVisionTrigger.Continuous
:SAVE:FILename {value:%Qs} | IAgInfiniiVisionMemory.CurrentSaveFile
:SAVE:FILename? | IAgInfiniiVisionMemory.CurrentSaveFile
:SAVE:IMAGe:FACTors {value} | IAgInfiniiVisionMemory.SaveFactorsEnabled
:SAVE:IMAGe:FACTors? | IAgInfiniiVisionMemory.SaveFactorsEnabled
:SAVE:IMAGe:FORMat {value} | IAgInfiniiVisionMemory.ImageFormat
:SAVE:IMAGe:FORMat? | IAgInfiniiVisionMemory.ImageFormat
:SAVE:IMAGe:INKSaver {value} | IAgInfiniiVisionMemory.InvertColorEnabled
:SAVE:IMAGe:INKSaver? | IAgInfiniiVisionMemory.InvertColorEnabled
:SAVE:IMAGe:PALette {value} | IAgInfiniiVisionMemory.ImagePalette
:SAVE:IMAGe:PALette? | IAgInfiniiVisionMemory.ImagePalette
:SAVE:PWD {value:%Qs} | IAgInfiniiVisionMemory.CurrentSaveDirectory
:SAVE:PWD? | IAgInfiniiVisionMemory.CurrentSaveDirectory
:SAVE:RESults:FORMat:CURSor {value} | IAgInfiniiVisionMemory2ResultFormat.CursorEnabled
:SAVE:RESults:FORMat:CURSor? | IAgInfiniiVisionMemory2ResultFormat.CursorEnabled
:SAVE:RESults:FORMat:HISTogram {value} | IAgInfiniiVisionMemory2ResultFormat.HistogramEnabled
:SAVE:RESults:FORMat:HISTogram? | IAgInfiniiVisionMemory2ResultFormat.HistogramEnabled
:SAVE:RESults:FORMat:MASK {value} | IAgInfiniiVisionMemory2ResultFormat.MaskEnabled
:SAVE:RESults:FORMat:MASK? | IAgInfiniiVisionMemory2ResultFormat.MaskEnabled
:SAVE:RESults:FORMat:MEASurement {value} | IAgInfiniiVisionMemory2ResultFormat.MeasurementEnabled
:SAVE:RESults:FORMat:MEASurement? | IAgInfiniiVisionMemory2ResultFormat.MeasurementEnabled
:SAVE:RESults:FORMat:SEARch {value} | IAgInfiniiVisionMemory2ResultFormat.SearchEnabled
:SAVE:RESults:FORMat:SEARch? | IAgInfiniiVisionMemory2ResultFormat.SearchEnabled
:SAVE:RESults:FORMat:SEGMented {value} | IAgInfiniiVisionMemory2ResultFormat.SegmentedEnabled
:SAVE:RESults:FORMat:SEGMented? | IAgInfiniiVisionMemory2ResultFormat.SegmentedEnabled
:SAVE:WAVeform:FORMat {value} | IAgInfiniiVisionMemory.WaveformFormat
:SAVE:WAVeform:FORMat? | IAgInfiniiVisionMemory.WaveformFormat
:SAVE:WAVeform:LENGth {value} | IAgInfiniiVisionMemory.WaveformLength
:SAVE:WAVeform:LENGth? | IAgInfiniiVisionMemory.WaveformLength
:SAVE:WAVeform:SEGMented {value} | IAgInfiniiVisionAcquisitionSegmentedMemory.SaveOption
:SAVE:WAVeform:SEGMented? | IAgInfiniiVisionAcquisitionSegmentedMemory.SaveOption
:SAVE:WMEMory:SOURce {value} | IAgInfiniiVisionMemory.ReferenceWaveformSource
:SAVE:WMEMory:SOURce? | IAgInfiniiVisionMemory.ReferenceWaveformSource
:SAVE{Options} {FileName:%Qs} | IAgInfiniiVisionMemory.Save
:SBUS{rcindex+1}:A429:AUTosetup | IAgInfiniiVision2SerialBusARINC429.AutoSetup
:SBUS{rcindex+1}:A429:BASe {value} | IAgInfiniiVision2SerialBusARINC429.Base
:SBUS{rcindex+1}:A429:BASe? | IAgInfiniiVision2SerialBusARINC429.Base
:SBUS{rcindex+1}:A429:COUNt:ERRor? | IAgInfiniiVision2SerialBusARINC429.ErrorCount
:SBUS{rcindex+1}:A429:COUNt:RESet | IAgInfiniiVision2SerialBusARINC429.ResetCounters
:SBUS{rcindex+1}:A429:COUNt:WORD? | IAgInfiniiVision2SerialBusARINC429.WordCount
:SBUS{rcindex+1}:A429:FORMat {value} | IAgInfiniiVision2SerialBusARINC429.DisplayFormat
:SBUS{rcindex+1}:A429:FORMat? | IAgInfiniiVision2SerialBusARINC429.DisplayFormat
:SBUS{rcindex+1}:A429:SIGNal {value} | IAgInfiniiVision2SerialBusARINC429.SignalType
:SBUS{rcindex+1}:A429:SIGNal? | IAgInfiniiVision2SerialBusARINC429.SignalType
:SBUS{rcindex+1}:A429:SOURce {value} | IAgInfiniiVision2SerialBusARINC429.Source
:SBUS{rcindex+1}:A429:SOURce? | IAgInfiniiVision2SerialBusARINC429.Source
:SBUS{rcindex+1}:A429:SPEed {value} | IAgInfiniiVision2SerialBusARINC429.Speed
:SBUS{rcindex+1}:A429:SPEed? | IAgInfiniiVision2SerialBusARINC429.Speed
:SBUS{rcindex+1}:A429:TRIGger:LABel {value} | IAgInfiniiVision2SerialBusARINC429.TriggerLabel
:SBUS{rcindex+1}:A429:TRIGger:LABel? | IAgInfiniiVision2SerialBusARINC429.TriggerLabel
:SBUS{rcindex+1}:A429:TRIGger:PATTern:DATA "{value}" | IAgInfiniiVision2SerialBusARINC429.TriggerPatternData
:SBUS{rcindex+1}:A429:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusARINC429.TriggerPatternData
:SBUS{rcindex+1}:A429:TRIGger:PATTern:SDI "{value}" | IAgInfiniiVision2SerialBusARINC429.TriggerPatternSDI
:SBUS{rcindex+1}:A429:TRIGger:PATTern:SDI? | IAgInfiniiVision2SerialBusARINC429.TriggerPatternSDI
:SBUS{rcindex+1}:A429:TRIGger:PATTern:SSM "{value}" | IAgInfiniiVision2SerialBusARINC429.TriggerPatternSSM
:SBUS{rcindex+1}:A429:TRIGger:PATTern:SSM? | IAgInfiniiVision2SerialBusARINC429.TriggerPatternSSM
:SBUS{rcindex+1}:A429:TRIGger:RANGe {LowerLimit},{UpperLimit} | IAgInfiniiVision2SerialBusARINC429.SetTriggerRange
:SBUS{rcindex+1}:A429:TRIGger:RANGe? | IAgInfiniiVision2SerialBusARINC429.GetTriggerRange
:SBUS{rcindex+1}:A429:TRIGger:TYPE {value} | IAgInfiniiVision2SerialBusARINC429.TriggerType
:SBUS{rcindex+1}:A429:TRIGger:TYPE? | IAgInfiniiVision2SerialBusARINC429.TriggerType
:SBUS{rcindex+1}:CAN:COUNt:ERRor? | IAgInfiniiVision2SerialBusCAN.ErrorCount
:SBUS{rcindex+1}:CAN:COUNt:OVERload? | IAgInfiniiVision2SerialBusCAN.OverloadCount
:SBUS{rcindex+1}:CAN:COUNt:RESet | IAgInfiniiVision2SerialBusCAN.ResetCounters
:SBUS{rcindex+1}:CAN:COUNt:SPEC? | IAgInfiniiVisionSerialBus3CAN2FD.SpecErrorCount
:SBUS{rcindex+1}:CAN:COUNt:TOTal? | IAgInfiniiVision2SerialBusCAN.TotalCount
:SBUS{rcindex+1}:CAN:COUNt:UTILization? | IAgInfiniiVision2SerialBusCAN.Utilization
:SBUS{rcindex+1}:CAN:DISPlay {value} | IAgInfiniiVisionSerialBus4CAN3.Display
:SBUS{rcindex+1}:CAN:DISPlay? | IAgInfiniiVisionSerialBus4CAN3.Display
:SBUS{rcindex+1}:CAN:FDSPoint {value} | IAgInfiniiVisionSerialBus3CAN2FD.SamplePoint
:SBUS{rcindex+1}:CAN:FDSPoint? | IAgInfiniiVisionSerialBus3CAN2FD.SamplePoint
:SBUS{rcindex+1}:CAN:FDSTandard {value} | IAgInfiniiVisionSerialBus4CAN3FD2.Standard
:SBUS{rcindex+1}:CAN:FDSTandard? | IAgInfiniiVisionSerialBus4CAN3FD2.Standard
:SBUS{rcindex+1}:CAN:SAMPlepoint {value} | IAgInfiniiVision2SerialBusCAN.SamplePoint
:SBUS{rcindex+1}:CAN:SAMPlepoint? | IAgInfiniiVision2SerialBusCAN.SamplePoint
:SBUS{rcindex+1}:CAN:SIGNal:BAUDrate {value} | IAgInfiniiVision2SerialBusCAN.BaudRate
:SBUS{rcindex+1}:CAN:SIGNal:BAUDrate? | IAgInfiniiVision2SerialBusCAN.BaudRate
:SBUS{rcindex+1}:CAN:SIGNal:DEFinition {value} | IAgInfiniiVision2SerialBusCAN.SignalType
:SBUS{rcindex+1}:CAN:SIGNal:DEFinition? | IAgInfiniiVision2SerialBusCAN.SignalType
:SBUS{rcindex+1}:CAN:SIGNal:FDBaudrate {value} | IAgInfiniiVisionSerialBus3CAN2FD.BaudRate
:SBUS{rcindex+1}:CAN:SIGNal:FDBaudrate? | IAgInfiniiVisionSerialBus3CAN2FD.BaudRate
:SBUS{rcindex+1}:CAN:SOURce {value} | IAgInfiniiVision2SerialBusCAN.Source
:SBUS{rcindex+1}:CAN:SOURce? | IAgInfiniiVision2SerialBusCAN.Source
:SBUS{rcindex+1}:CAN:TRIGger {value} | IAgInfiniiVision2SerialBusCAN.TriggerCondition
:SBUS{rcindex+1}:CAN:TRIGger:IDFilter {value} | IAgInfiniiVisionSerialBus3CAN2FD.TriggerIDFilterEnabled
:SBUS{rcindex+1}:CAN:TRIGger:IDFilter? | IAgInfiniiVisionSerialBus3CAN2FD.TriggerIDFilterEnabled
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA "{value}" | IAgInfiniiVision2SerialBusCAN.TriggerPatternData
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:DLC {value} | IAgInfiniiVisionSerialBus3CAN2FD.DataLengthCode
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:DLC? | IAgInfiniiVisionSerialBus3CAN2FD.DataLengthCode
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:LENGth {value} | IAgInfiniiVision2SerialBusCAN.TriggerPatternDataLength
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:LENGth? | IAgInfiniiVision2SerialBusCAN.TriggerPatternDataLength
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:STARt {value} | IAgInfiniiVisionSerialBus3CAN2FD.TriggerPatternStartBytePosition
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA:STARt? | IAgInfiniiVisionSerialBus3CAN2FD.TriggerPatternStartBytePosition
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusCAN.TriggerPatternData
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:ID "{value}" | IAgInfiniiVision2SerialBusCAN.TriggerPatternID
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:ID:MODE {value} | IAgInfiniiVision2SerialBusCAN.TriggerPatternIDType
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:ID:MODE? | IAgInfiniiVision2SerialBusCAN.TriggerPatternIDType
:SBUS{rcindex+1}:CAN:TRIGger:PATTern:ID? | IAgInfiniiVision2SerialBusCAN.TriggerPatternID
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:MESSage {value} | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicMessage
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:MESSage? | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicMessage
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:SIGNal {value} | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicSignal
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:SIGNal? | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicSignal
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:VALue {value} | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicValue
:SBUS{rcindex+1}:CAN:TRIGger:SYMBolic:VALue? | IAgInfiniiVisionSerialBus4CAN3.TriggerSymbolicValue
:SBUS{rcindex+1}:CAN:TRIGger? | IAgInfiniiVision2SerialBusCAN.TriggerCondition
:SBUS{rcindex+1}:DISPlay {value} | IAgInfiniiVision2SerialBus.Enabled
:SBUS{rcindex+1}:DISPlay? | IAgInfiniiVision2SerialBus.Enabled
:SBUS{rcindex+1}:FLEXray:AUTosetup | IAgInfiniiVision2SerialBusFlexRay.AutoSetup
:SBUS{rcindex+1}:FLEXray:BAUDrate {value} | IAgInfiniiVision2SerialBusFlexRay.BaudRate
:SBUS{rcindex+1}:FLEXray:BAUDrate? | IAgInfiniiVision2SerialBusFlexRay.BaudRate
:SBUS{rcindex+1}:FLEXray:CHANnel {value} | IAgInfiniiVision2SerialBusFlexRay.Channel
:SBUS{rcindex+1}:FLEXray:CHANnel? | IAgInfiniiVision2SerialBusFlexRay.Channel
:SBUS{rcindex+1}:FLEXray:COUNt:ERRor? | IAgInfiniiVision2SerialBusFlexRay.ErrorCount
:SBUS{rcindex+1}:FLEXray:COUNt:NULL? | IAgInfiniiVision2SerialBusFlexRay.NullCount
:SBUS{rcindex+1}:FLEXray:COUNt:RESET | IAgInfiniiVision2SerialBusFlexRay.ResetCounters
:SBUS{rcindex+1}:FLEXray:COUNt:SYNC? | IAgInfiniiVision2SerialBusFlexRay.SyncCount
:SBUS{rcindex+1}:FLEXray:COUNt:TOTal? | IAgInfiniiVision2SerialBusFlexRay.TotalCount
:SBUS{rcindex+1}:FLEXray:SOURce {value} | IAgInfiniiVision2SerialBusFlexRay.Source
:SBUS{rcindex+1}:FLEXray:SOURce? | IAgInfiniiVision2SerialBusFlexRay.Source
:SBUS{rcindex+1}:FLEXray:TRIGger {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerType
:SBUS{rcindex+1}:FLEXray:TRIGger:ERRor:TYPE {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerErrorType
:SBUS{rcindex+1}:FLEXray:TRIGger:ERRor:TYPE? | IAgInfiniiVision2SerialBusFlexRay.TriggerErrorType
:SBUS{rcindex+1}:FLEXray:TRIGger:EVENt:AUToset | IAgInfiniiVision2SerialBusFlexRay.TriggerEventAutoSetup
:SBUS{rcindex+1}:FLEXray:TRIGger:EVENt:BSS:ID {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerEventBSSID
:SBUS{rcindex+1}:FLEXray:TRIGger:EVENt:BSS:ID? | IAgInfiniiVision2SerialBusFlexRay.TriggerEventBSSID
:SBUS{rcindex+1}:FLEXray:TRIGger:EVENt:TYPE {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerEventType
:SBUS{rcindex+1}:FLEXray:TRIGger:EVENt:TYPE? | IAgInfiniiVision2SerialBusFlexRay.TriggerEventType
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:CCBase {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameCCBase
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:CCBase? | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameCCBase
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:CCRepetition {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameCCRepetition
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:CCRepetition? | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameCCRepetition
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:ID {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameID
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:ID? | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameID
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:TYPE {value} | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameType
:SBUS{rcindex+1}:FLEXray:TRIGger:FRAMe:TYPE? | IAgInfiniiVision2SerialBusFlexRay.TriggerFrameType
:SBUS{rcindex+1}:FLEXray:TRIGger? | IAgInfiniiVision2SerialBusFlexRay.TriggerType
:SBUS{rcindex+1}:I2S:ALIGnment {value} | IAgInfiniiVision2SerialBusI2S.DataAlignment
:SBUS{rcindex+1}:I2S:ALIGnment? | IAgInfiniiVision2SerialBusI2S.DataAlignment
:SBUS{rcindex+1}:I2S:BASE {value} | IAgInfiniiVision2SerialBusI2S.Base
:SBUS{rcindex+1}:I2S:BASE? | IAgInfiniiVision2SerialBusI2S.Base
:SBUS{rcindex+1}:I2S:CLOCk:SLOPe {value} | IAgInfiniiVision2SerialBusI2S.ClockSlope
:SBUS{rcindex+1}:I2S:CLOCk:SLOPe? | IAgInfiniiVision2SerialBusI2S.ClockSlope
:SBUS{rcindex+1}:I2S:RWIDth {value} | IAgInfiniiVision2SerialBusI2S.ReceiverWidth
:SBUS{rcindex+1}:I2S:RWIDth? | IAgInfiniiVision2SerialBusI2S.ReceiverWidth
:SBUS{rcindex+1}:I2S:SOURce:CLOCk {value} | IAgInfiniiVision2SerialBusI2S.ClockSource
:SBUS{rcindex+1}:I2S:SOURce:CLOCk? | IAgInfiniiVision2SerialBusI2S.ClockSource
:SBUS{rcindex+1}:I2S:SOURce:DATA {value} | IAgInfiniiVision2SerialBusI2S.DataSource
:SBUS{rcindex+1}:I2S:SOURce:DATA? | IAgInfiniiVision2SerialBusI2S.DataSource
:SBUS{rcindex+1}:I2S:SOURce:WSELect {value} | IAgInfiniiVision2SerialBusI2S.WordSelectSource
:SBUS{rcindex+1}:I2S:SOURce:WSELect? | IAgInfiniiVision2SerialBusI2S.WordSelectSource
:SBUS{rcindex+1}:I2S:TRIGger {value} | IAgInfiniiVision2SerialBusI2S.TriggerCondition
:SBUS{rcindex+1}:I2S:TRIGger:AUDio {value} | IAgInfiniiVision2SerialBusI2S.TriggerAudioChannel
:SBUS{rcindex+1}:I2S:TRIGger:AUDio? | IAgInfiniiVision2SerialBusI2S.TriggerAudioChannel
:SBUS{rcindex+1}:I2S:TRIGger:PATTern:DATA "{value}" | IAgInfiniiVision2SerialBusI2S.TriggerPatternData
:SBUS{rcindex+1}:I2S:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusI2S.TriggerPatternData
:SBUS{rcindex+1}:I2S:TRIGger:RANGe {LowerLimit},{UpperLimit} | IAgInfiniiVision2SerialBusI2S.SetTriggerRange
:SBUS{rcindex+1}:I2S:TRIGger:RANGe? | IAgInfiniiVision2SerialBusI2S.GetTriggerRange
:SBUS{rcindex+1}:I2S:TRIGger? | IAgInfiniiVision2SerialBusI2S.TriggerCondition
:SBUS{rcindex+1}:I2S:TWIDth {value} | IAgInfiniiVision2SerialBusI2S.TransmittedWidth
:SBUS{rcindex+1}:I2S:TWIDth? | IAgInfiniiVision2SerialBusI2S.TransmittedWidth
:SBUS{rcindex+1}:I2S:WSLow {value} | IAgInfiniiVision2SerialBusI2S.WordSelectPolarity
:SBUS{rcindex+1}:I2S:WSLow? | IAgInfiniiVision2SerialBusI2S.WordSelectPolarity
:SBUS{rcindex+1}:IIC:ASIZe {value} | IAgInfiniiVision2SerialBusIIC.AddressWidth
:SBUS{rcindex+1}:IIC:ASIZe? | IAgInfiniiVision2SerialBusIIC.AddressWidth
:SBUS{rcindex+1}:IIC:SOURce:CLOCk {value} | IAgInfiniiVision2SerialBusIIC.ClockSource
:SBUS{rcindex+1}:IIC:SOURce:CLOCk? | IAgInfiniiVision2SerialBusIIC.ClockSource
:SBUS{rcindex+1}:IIC:SOURce:DATA {value} | IAgInfiniiVision2SerialBusIIC.DataSource
:SBUS{rcindex+1}:IIC:SOURce:DATA? | IAgInfiniiVision2SerialBusIIC.DataSource
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:ADDRess {value} | IAgInfiniiVision2SerialBusIIC.TriggerPatternAddress
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:ADDRess? | IAgInfiniiVision2SerialBusIIC.TriggerPatternAddress
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:DATA {value} | IAgInfiniiVision2SerialBusIIC.TriggerPatternData
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusIIC.TriggerPatternData
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:DATa2 {value} | IAgInfiniiVision2SerialBusIIC.TriggerPatternData2
:SBUS{rcindex+1}:IIC:TRIGger:PATTern:DATa2? | IAgInfiniiVision2SerialBusIIC.TriggerPatternData2
:SBUS{rcindex+1}:IIC:TRIGger:QUALifier {value} | IAgInfiniiVision2SerialBusIIC.TriggerCondition
:SBUS{rcindex+1}:IIC:TRIGger:QUALifier? | IAgInfiniiVision2SerialBusIIC.TriggerCondition
:SBUS{rcindex+1}:IIC:TRIGger:TYPE {value} | IAgInfiniiVision2SerialBusIIC.TriggerType
:SBUS{rcindex+1}:IIC:TRIGger:TYPE? | IAgInfiniiVision2SerialBusIIC.TriggerType
:SBUS{rcindex+1}:LIN:DISPlay {value} | IAgInfiniiVisionSerialBus4LIN2.Display
:SBUS{rcindex+1}:LIN:DISPlay? | IAgInfiniiVisionSerialBus4LIN2.Display
:SBUS{rcindex+1}:LIN:PARity {value} | IAgInfiniiVision2SerialBusLIN.ParityEnabled
:SBUS{rcindex+1}:LIN:PARity? | IAgInfiniiVision2SerialBusLIN.ParityEnabled
:SBUS{rcindex+1}:LIN:SAMPlepoint {value} | IAgInfiniiVision2SerialBusLIN.SamplePoint
:SBUS{rcindex+1}:LIN:SAMPlepoint? | IAgInfiniiVision2SerialBusLIN.SamplePoint
:SBUS{rcindex+1}:LIN:SIGNal:BAUDrate {value} | IAgInfiniiVision2SerialBusLIN.BaudRate
:SBUS{rcindex+1}:LIN:SIGNal:BAUDrate? | IAgInfiniiVision2SerialBusLIN.BaudRate
:SBUS{rcindex+1}:LIN:SOURce {value} | IAgInfiniiVision2SerialBusLIN.Source
:SBUS{rcindex+1}:LIN:SOURce? | IAgInfiniiVision2SerialBusLIN.Source
:SBUS{rcindex+1}:LIN:STANdard {value} | IAgInfiniiVision2SerialBusLIN.Standard
:SBUS{rcindex+1}:LIN:STANdard? | IAgInfiniiVision2SerialBusLIN.Standard
:SBUS{rcindex+1}:LIN:SYNCbreak {value} | IAgInfiniiVision2SerialBusLIN.SyncBreakLength
:SBUS{rcindex+1}:LIN:SYNCbreak? | IAgInfiniiVision2SerialBusLIN.SyncBreakLength
:SBUS{rcindex+1}:LIN:TRIGger {value} | IAgInfiniiVision2SerialBusLIN.TriggerCondition
:SBUS{rcindex+1}:LIN:TRIGger:ID {value} | IAgInfiniiVision2SerialBusLIN.TriggerID
:SBUS{rcindex+1}:LIN:TRIGger:ID? | IAgInfiniiVision2SerialBusLIN.TriggerID
:SBUS{rcindex+1}:LIN:TRIGger:PATTern:DATA "{value}" | IAgInfiniiVision2SerialBusLIN.TriggerPatternData
:SBUS{rcindex+1}:LIN:TRIGger:PATTern:DATA:LENGth {value} | IAgInfiniiVision2SerialBusLIN.TriggerPatternDataLength
:SBUS{rcindex+1}:LIN:TRIGger:PATTern:DATA:LENGth? | IAgInfiniiVision2SerialBusLIN.TriggerPatternDataLength
:SBUS{rcindex+1}:LIN:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusLIN.TriggerPatternData
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:FRAMe "{value}" | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicFrame
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:FRAMe? | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicFrame
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:SIGNal "{value}" | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicSignal
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:SIGNal? | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicSignal
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:VALue {value} | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicValue
:SBUS{rcindex+1}:LIN:TRIGger:SYMBolic:VALue? | IAgInfiniiVisionSerialBus4LIN2.TriggerSymbolicValue
:SBUS{rcindex+1}:LIN:TRIGger? | IAgInfiniiVision2SerialBusLIN.TriggerCondition
:SBUS{rcindex+1}:M1553:AUTosetup | IAgInfiniiVision2SerialBusM1553.AutoSetup
:SBUS{rcindex+1}:M1553:BASe {value} | IAgInfiniiVision2SerialBusM1553.Base
:SBUS{rcindex+1}:M1553:BASe? | IAgInfiniiVision2SerialBusM1553.Base
:SBUS{rcindex+1}:M1553:SOURce {value} | IAgInfiniiVision2SerialBusM1553.Source
:SBUS{rcindex+1}:M1553:SOURce? | IAgInfiniiVision2SerialBusM1553.Source
:SBUS{rcindex+1}:M1553:TRIGger:PATTern:DATA "{value}" | IAgInfiniiVision2SerialBusM1553.TriggerPatternData
:SBUS{rcindex+1}:M1553:TRIGger:PATTern:DATA? | IAgInfiniiVision2SerialBusM1553.TriggerPatternData
:SBUS{rcindex+1}:M1553:TRIGger:RTA {value} | IAgInfiniiVision2SerialBusM1553.TriggerRTA
:SBUS{rcindex+1}:M1553:TRIGger:RTA? | IAgInfiniiVision2SerialBusM1553.TriggerRTA
:SBUS{rcindex+1}:M1553:TRIGger:TYPE {value} | IAgInfiniiVision2SerialBusM1553.TriggerType
:SBUS{rcindex+1}:M1553:TRIGger:TYPE? | IAgInfiniiVision2SerialBusM1553.TriggerType
:SBUS{rcindex+1}:MODE {value} | IAgInfiniiVision2SerialBus.Mode
:SBUS{rcindex+1}:MODE? | IAgInfiniiVision2SerialBus.Mode
:SBUS{rcindex+1}:SENT:CLOCk {value} | IAgInfiniiVisionSerialBus3SENT.Clock
:SBUS{rcindex+1}:SENT:CLOCk? | IAgInfiniiVisionSerialBus3SENT.Clock
:SBUS{rcindex+1}:SENT:CRC {value} | IAgInfiniiVisionSerialBus3SENT.CRCFormat
:SBUS{rcindex+1}:SENT:CRC? | IAgInfiniiVisionSerialBus3SENT.CRCFormat
:SBUS{rcindex+1}:SENT:DISPlay {value} | IAgInfiniiVisionSerialBus3SENT.NumberBase
:SBUS{rcindex+1}:SENT:DISPlay? | IAgInfiniiVisionSerialBus3SENT.NumberBase
:SBUS{rcindex+1}:SENT:FORMat {value} | IAgInfiniiVisionSerialBus3SENT.Format
:SBUS{rcindex+1}:SENT:FORMat? | IAgInfiniiVisionSerialBus3SENT.Format
:SBUS{rcindex+1}:SENT:IDLE {value} | IAgInfiniiVisionSerialBus3SENT.IdleState
:SBUS{rcindex+1}:SENT:IDLE? | IAgInfiniiVisionSerialBus3SENT.IdleState
:SBUS{rcindex+1}:SENT:LENGth {value} | IAgInfiniiVisionSerialBus3SENT.NumberOfNibble
:SBUS{rcindex+1}:SENT:LENGth? | IAgInfiniiVisionSerialBus3SENT.NumberOfNibble
:SBUS{rcindex+1}:SENT:PPULse {value} | IAgInfiniiVisionSerialBus3SENT.PausePulse
:SBUS{rcindex+1}:SENT:PPULse? | IAgInfiniiVisionSerialBus3SENT.PausePulse
:SBUS{rcindex+1}:SENT:SIGNal{Index}:DISPlay {StateEnabled} | IAgInfiniiVisionSerialBus3SENT.SetSignalDisplay
:SBUS{rcindex+1}:SENT:SIGNal{Index}:DISPlay? | IAgInfiniiVisionSerialBus3SENT.GetSignalDisplay
:SBUS{rcindex+1}:SENT:SIGNal{Index}:LENGth {Length} | IAgInfiniiVisionSerialBus3SENT.SetSignalLength
:SBUS{rcindex+1}:SENT:SIGNal{Index}:LENGth? | IAgInfiniiVisionSerialBus3SENT.GetSignalLength
:SBUS{rcindex+1}:SENT:SIGNal{Index}:MULTiplier {Multiplier} | IAgInfiniiVisionSerialBus3SENT.SetSignalMultiplier
:SBUS{rcindex+1}:SENT:SIGNal{Index}:MULTiplier? | IAgInfiniiVisionSerialBus3SENT.GetSignalMultiplier
:SBUS{rcindex+1}:SENT:SIGNal{Index}:OFFSet {Offset} | IAgInfiniiVisionSerialBus3SENT.SetSignalOffset
:SBUS{rcindex+1}:SENT:SIGNal{Index}:OFFSet? | IAgInfiniiVisionSerialBus3SENT.GetSignalOffset
:SBUS{rcindex+1}:SENT:SIGNal{Index}:ORDer {Order} | IAgInfiniiVisionSerialBus3SENT.SetSignalNibbleOrder
:SBUS{rcindex+1}:SENT:SIGNal{Index}:ORDer? | IAgInfiniiVisionSerialBus3SENT.GetSignalNibbleOrder
:SBUS{rcindex+1}:SENT:SIGNal{Index}:STARt {Position} | IAgInfiniiVisionSerialBus3SENT.SetSignalStartPosition
:SBUS{rcindex+1}:SENT:SIGNal{Index}:STARt? | IAgInfiniiVisionSerialBus3SENT.GetSignalStartPosition
:SBUS{rcindex+1}:SENT:SOURce {value} | IAgInfiniiVisionSerialBus3SENT.Source
:SBUS{rcindex+1}:SENT:SOURce? | IAgInfiniiVisionSerialBus3SENT.Source
:SBUS{rcindex+1}:SENT:TOLerance {value} | IAgInfiniiVisionSerialBus3SENT.Tolerance
:SBUS{rcindex+1}:SENT:TOLerane? | IAgInfiniiVisionSerialBus3SENT.Tolerance
:SBUS{rcindex+1}:SENT:TRIGger {value} | IAgInfiniiVisionSerialBus4SENT2Trigger2.Mode
:SBUS{rcindex+1}:SENT:TRIGger:FAST:DATA "{value}" | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel.Data
:SBUS{rcindex+1}:SENT:TRIGger:FAST:DATA? | IAgInfiniiVisionSerialBus3SENTTriggerFastChannel.Data
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:DATA {value} | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.Data
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:DATA? | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.Data
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:ID {value} | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.ID
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:ID? | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.ID
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:ILENgth {value} | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength
:SBUS{rcindex+1}:SENT:TRIGger:SLOW:ILENgth? | IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength
:SBUS{rcindex+1}:SENT:TRIGger:TOLerance {value} | IAgInfiniiVisionSerialBus4SENT2Trigger2.Tolerance
:SBUS{rcindex+1}:SENT:TRIGger:TOLerance? | IAgInfiniiVisionSerialBus4SENT2Trigger2.Tolerance
:SBUS{rcindex+1}:SENT:TRIGger? | IAgInfiniiVisionSerialBus4SENT2Trigger2.Mode
:SBUS{rcindex+1}:SPI:BITorder {value} | IAgInfiniiVision2SerialBusSPI.BitOrder
:SBUS{rcindex+1}:SPI:BITorder? | IAgInfiniiVision2SerialBusSPI.BitOrder
:SBUS{rcindex+1}:SPI:CLOCk:SLOPe {value} | IAgInfiniiVision2SerialBusSPI.ClockSlope
:SBUS{rcindex+1}:SPI:CLOCk:SLOPe? | IAgInfiniiVision2SerialBusSPI.ClockSlope
:SBUS{rcindex+1}:SPI:CLOCk:TIMeout {value} | IAgInfiniiVision2SerialBusSPI.ClockTimeout
:SBUS{rcindex+1}:SPI:CLOCk:TIMeout? | IAgInfiniiVision2SerialBusSPI.ClockTimeout
:SBUS{rcindex+1}:SPI:FRAMing {value} | IAgInfiniiVision2SerialBusSPI.Framing
:SBUS{rcindex+1}:SPI:FRAMing? | IAgInfiniiVision2SerialBusSPI.Framing
:SBUS{rcindex+1}:SPI:SOURce:CLOCk {value} | IAgInfiniiVision2SerialBusSPI.ClockSource
:SBUS{rcindex+1}:SPI:SOURce:CLOCk? | IAgInfiniiVision2SerialBusSPI.ClockSource
:SBUS{rcindex+1}:SPI:SOURce:FRAMe {value} | IAgInfiniiVision2SerialBusSPI.FrameSource
:SBUS{rcindex+1}:SPI:SOURce:FRAMe? | IAgInfiniiVision2SerialBusSPI.FrameSource
:SBUS{rcindex+1}:SPI:SOURce:MISO {value} | IAgInfiniiVision2SerialBusSPI.MISOSource
:SBUS{rcindex+1}:SPI:SOURce:MISO? | IAgInfiniiVision2SerialBusSPI.MISOSource
:SBUS{rcindex+1}:SPI:SOURce:MOSI {value} | IAgInfiniiVision2SerialBusSPI.MOSISource
:SBUS{rcindex+1}:SPI:SOURce:MOSI? | IAgInfiniiVision2SerialBusSPI.MOSISource
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MISO:DATA "{value}" | IAgInfiniiVision2SerialBusSPI.TriggerPatternMISOData
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MISO:DATA? | IAgInfiniiVision2SerialBusSPI.TriggerPatternMISOData
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MISO:WIDTh {value} | IAgInfiniiVision2SerialBusSPI.TriggerPatternMISOWidth
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MISO:WIDTh? | IAgInfiniiVision2SerialBusSPI.TriggerPatternMISOWidth
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MOSI:DATA "{value}" | IAgInfiniiVision2SerialBusSPI.TriggerPatternMOSIData
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MOSI:DATA? | IAgInfiniiVision2SerialBusSPI.TriggerPatternMOSIData
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MOSI:WIDTh {value} | IAgInfiniiVision2SerialBusSPI.TriggerPatternMOSIWidth
:SBUS{rcindex+1}:SPI:TRIGger:PATTern:MOSI:WIDTh? | IAgInfiniiVision2SerialBusSPI.TriggerPatternMOSIWidth
:SBUS{rcindex+1}:SPI:TRIGger:TYPE {value} | IAgInfiniiVision2SerialBusSPI.TriggerType
:SBUS{rcindex+1}:SPI:TRIGger:TYPE? | IAgInfiniiVision2SerialBusSPI.TriggerType
:SBUS{rcindex+1}:SPI:WIDTh {value} | IAgInfiniiVision2SerialBusSPI.Width
:SBUS{rcindex+1}:SPI:WIDTh? | IAgInfiniiVision2SerialBusSPI.Width
:SBUS{rcindex+1}:UART:BASE {value} | IAgInfiniiVision2SerialBusUART.Base
:SBUS{rcindex+1}:UART:BASE? | IAgInfiniiVision2SerialBusUART.Base
:SBUS{rcindex+1}:UART:BAUDrate {value} | IAgInfiniiVision2SerialBusUART.BaudRate
:SBUS{rcindex+1}:UART:BAUDrate? | IAgInfiniiVision2SerialBusUART.BaudRate
:SBUS{rcindex+1}:UART:BITorder {value} | IAgInfiniiVision2SerialBusUART.BitOrder
:SBUS{rcindex+1}:UART:BITorder? | IAgInfiniiVision2SerialBusUART.BitOrder
:SBUS{rcindex+1}:UART:COUNt:ERRor? | IAgInfiniiVision2SerialBusUART.ErrorCount
:SBUS{rcindex+1}:UART:COUNt:RESet | IAgInfiniiVision2SerialBusUART.ResetCounters
:SBUS{rcindex+1}:UART:COUNt:RXFRames? | IAgInfiniiVision2SerialBusUART.RxFrameCount
:SBUS{rcindex+1}:UART:COUNt:TXFRames? | IAgInfiniiVision2SerialBusUART.TxFrameCount
:SBUS{rcindex+1}:UART:FRAMing {value} | IAgInfiniiVision2SerialBusUART.Framing
:SBUS{rcindex+1}:UART:FRAMing? | IAgInfiniiVision2SerialBusUART.Framing
:SBUS{rcindex+1}:UART:PARity {value} | IAgInfiniiVision2SerialBusUART.Parity
:SBUS{rcindex+1}:UART:PARity? | IAgInfiniiVision2SerialBusUART.Parity
:SBUS{rcindex+1}:UART:POLarity {value} | IAgInfiniiVision2SerialBusUART.Polarity
:SBUS{rcindex+1}:UART:POLarity? | IAgInfiniiVision2SerialBusUART.Polarity
:SBUS{rcindex+1}:UART:SOURce:RX {value} | IAgInfiniiVision2SerialBusUART.RxSource
:SBUS{rcindex+1}:UART:SOURce:RX? | IAgInfiniiVision2SerialBusUART.RxSource
:SBUS{rcindex+1}:UART:SOURce:TX {value} | IAgInfiniiVision2SerialBusUART.TxSource
:SBUS{rcindex+1}:UART:SOURce:TX? | IAgInfiniiVision2SerialBusUART.TxSource
:SBUS{rcindex+1}:UART:TRIGger:BASE {value} | IAgInfiniiVision2SerialBusUART.TriggerBase
:SBUS{rcindex+1}:UART:TRIGger:BASE? | IAgInfiniiVision2SerialBusUART.TriggerBase
:SBUS{rcindex+1}:UART:TRIGger:BURSt {value} | IAgInfiniiVision2SerialBusUART.TriggerBurst
:SBUS{rcindex+1}:UART:TRIGger:BURSt? | IAgInfiniiVision2SerialBusUART.TriggerBurst
:SBUS{rcindex+1}:UART:TRIGger:DATA {value} | IAgInfiniiVision2SerialBusUART.TriggerData
:SBUS{rcindex+1}:UART:TRIGger:DATA? | IAgInfiniiVision2SerialBusUART.TriggerData
:SBUS{rcindex+1}:UART:TRIGger:IDLE {value} | IAgInfiniiVision2SerialBusUART.TriggerIdleTime
:SBUS{rcindex+1}:UART:TRIGger:IDLE? | IAgInfiniiVision2SerialBusUART.TriggerIdleTime
:SBUS{rcindex+1}:UART:TRIGger:QUALifier {value} | IAgInfiniiVision2SerialBusUART.TriggerCondition
:SBUS{rcindex+1}:UART:TRIGger:QUALifier? | IAgInfiniiVision2SerialBusUART.TriggerCondition
:SBUS{rcindex+1}:UART:TRIGger:TYPE {value} | IAgInfiniiVision2SerialBusUART.TriggerType
:SBUS{rcindex+1}:UART:TRIGger:TYPE? | IAgInfiniiVision2SerialBusUART.TriggerType
:SBUS{rcindex+1}:UART:WIDTh {value} | IAgInfiniiVision2SerialBusUART.Width
:SBUS{rcindex+1}:UART:WIDTh? | IAgInfiniiVision2SerialBusUART.Width
:SBUS{rcindex+1}:USB:BASE {value} | IAgInfiniiVisionSerialBus2USB.Base
:SBUS{rcindex+1}:USB:BASE? | IAgInfiniiVisionSerialBus2USB.Base
:SBUS{rcindex+1}:USB:SOURce:DIFFerential {value} | IAgInfiniiVisionSerialBus2USB.DifferentialSource
:SBUS{rcindex+1}:USB:SOURce:DIFFerential? | IAgInfiniiVisionSerialBus2USB.DifferentialSource
:SBUS{rcindex+1}:USB:SOURce:DMINus {value:%qs} | IAgInfiniiVisionSerialBus2USB.DMinusSource
:SBUS{rcindex+1}:USB:SOURce:DMINus? | IAgInfiniiVisionSerialBus2USB.DMinusSource
:SBUS{rcindex+1}:USB:SOURce:DPLus {value:%qs} | IAgInfiniiVisionSerialBus2USB.DPlusSource
:SBUS{rcindex+1}:USB:SOURce:DPLus? | IAgInfiniiVisionSerialBus2USB.DPlusSource
:SBUS{rcindex+1}:USB:SPEed {value} | IAgInfiniiVisionSerialBus2USB.Speed
:SBUS{rcindex+1}:USB:SPEed? | IAgInfiniiVisionSerialBus2USB.Speed
:SBUS{rcindex+1}:USB:TRIGger {value} | IAgInfiniiVisionSerialBus2USB.Condition
:SBUS{rcindex+1}:USB:TRIGger:ADDRess {value:%qs} | IAgInfiniiVisionSerialBus2USB.Address
:SBUS{rcindex+1}:USB:TRIGger:ADDRess? | IAgInfiniiVisionSerialBus2USB.Address
:SBUS{rcindex+1}:USB:TRIGger:CRC {value:%qs} | IAgInfiniiVisionSerialBus2USB.CRC
:SBUS{rcindex+1}:USB:TRIGger:CRC? | IAgInfiniiVisionSerialBus2USB.CRC
:SBUS{rcindex+1}:USB:TRIGger:DATA {value:%qs} | IAgInfiniiVisionSerialBus2USB.Data
:SBUS{rcindex+1}:USB:TRIGger:DATA:LENGth {value} | IAgInfiniiVisionSerialBus2USB.DataLength
:SBUS{rcindex+1}:USB:TRIGger:DATA:LENGth? | IAgInfiniiVisionSerialBus2USB.DataLength
:SBUS{rcindex+1}:USB:TRIGger:DATA? | IAgInfiniiVisionSerialBus2USB.Data
:SBUS{rcindex+1}:USB:TRIGger:ENDPoint {value:%qs} | IAgInfiniiVisionSerialBus2USB.EndPoint
:SBUS{rcindex+1}:USB:TRIGger:ENDPoint? | IAgInfiniiVisionSerialBus2USB.EndPoint
:SBUS{rcindex+1}:USB:TRIGger:ET {value:%qs} | IAgInfiniiVisionSerialBus2USB.ET
:SBUS{rcindex+1}:USB:TRIGger:ET? | IAgInfiniiVisionSerialBus2USB.ET
:SBUS{rcindex+1}:USB:TRIGger:FRAMe {value:%qs} | IAgInfiniiVisionSerialBus2USB.Frame
:SBUS{rcindex+1}:USB:TRIGger:FRAMe? | IAgInfiniiVisionSerialBus2USB.Frame
:SBUS{rcindex+1}:USB:TRIGger:HADDress {value:%qs} | IAgInfiniiVisionSerialBus2USB.HubAddress
:SBUS{rcindex+1}:USB:TRIGger:HADDress? | IAgInfiniiVisionSerialBus2USB.HubAddress
:SBUS{rcindex+1}:USB:TRIGger:PCHeck {value:%qs} | IAgInfiniiVisionSerialBus2USB.PIDCheck
:SBUS{rcindex+1}:USB:TRIGger:PCHeck? | IAgInfiniiVisionSerialBus2USB.PIDCheck
:SBUS{rcindex+1}:USB:TRIGger:PID:DATA {value} | IAgInfiniiVisionSerialBus2USB.PIDData
:SBUS{rcindex+1}:USB:TRIGger:PID:DATA? | IAgInfiniiVisionSerialBus2USB.PIDData
:SBUS{rcindex+1}:USB:TRIGger:PID:HANDshake {value} | IAgInfiniiVisionSerialBus2USB.PIDHandshake
:SBUS{rcindex+1}:USB:TRIGger:PID:HANDshake? | IAgInfiniiVisionSerialBus2USB.PIDHandshake
:SBUS{rcindex+1}:USB:TRIGger:PID:SPECial {value} | IAgInfiniiVisionSerialBus2USB.PIDSpecial
:SBUS{rcindex+1}:USB:TRIGger:PID:SPECial? | IAgInfiniiVisionSerialBus2USB.PIDSpecial
:SBUS{rcindex+1}:USB:TRIGger:PID:TOKen {value} | IAgInfiniiVisionSerialBus2USB.PIDToken
:SBUS{rcindex+1}:USB:TRIGger:PID:TOKen? | IAgInfiniiVisionSerialBus2USB.PIDToken
:SBUS{rcindex+1}:USB:TRIGger:PORT {value:%qs} | IAgInfiniiVisionSerialBus2USB.Port
:SBUS{rcindex+1}:USB:TRIGger:PORT? | IAgInfiniiVisionSerialBus2USB.Port
:SBUS{rcindex+1}:USB:TRIGger:SC {value:%qs} | IAgInfiniiVisionSerialBus2USB.SC
:SBUS{rcindex+1}:USB:TRIGger:SC? | IAgInfiniiVisionSerialBus2USB.SC
:SBUS{rcindex+1}:USB:TRIGger:SEU {value:%qs} | IAgInfiniiVisionSerialBus2USB.SEU
:SBUS{rcindex+1}:USB:TRIGger:SEU? | IAgInfiniiVisionSerialBus2USB.SEU
:SBUS{rcindex+1}:USB:TRIGger? | IAgInfiniiVisionSerialBus2USB.Condition
:SEARch:COUNt? | IAgInfiniiVision2Search.Count
:SEARch:EDGE:SLOPe {value} | IAgInfiniiVision2SearchEdge.Slope
:SEARch:EDGE:SLOPe? | IAgInfiniiVision2SearchEdge.Slope
:SEARch:EDGE:SOURce {value} | IAgInfiniiVision2SearchEdge.Source
:SEARch:EDGE:SOURce? | IAgInfiniiVision2SearchEdge.Source
:SEARch:GLITch:GREaterthan {value} | IAgInfiniiVision2SearchGlitch.MinPulseWidthDuration
:SEARch:GLITch:GREaterthan? | IAgInfiniiVision2SearchGlitch.MinPulseWidthDuration
:SEARch:GLITch:LESSthan {value} | IAgInfiniiVision2SearchGlitch.MaxPulseWidthDuration
:SEARch:GLITch:LESSthan? | IAgInfiniiVision2SearchGlitch.MaxPulseWidthDuration
:SEARch:GLITch:POLarity {value} | IAgInfiniiVision2SearchGlitch.Polarity
:SEARch:GLITch:POLarity? | IAgInfiniiVision2SearchGlitch.Polarity
:SEARch:GLITch:QUALifier {value} | IAgInfiniiVision2SearchGlitch.Condition
:SEARch:GLITch:QUALifier? | IAgInfiniiVision2SearchGlitch.Condition
:SEARch:GLITch:RANGe {LowerLimit},{UpperLimit} | IAgInfiniiVision2SearchGlitch.SetRange
:SEARch:GLITch:RANGe? | IAgInfiniiVision2SearchGlitch.GetRange
:SEARch:GLITch:SOURce {value} | IAgInfiniiVision2SearchGlitch.Source
:SEARch:GLITch:SOURce? | IAgInfiniiVision2SearchGlitch.Source
:SEARch:MODE {value} | IAgInfiniiVision2Search.Mode
:SEARch:MODE? | IAgInfiniiVision2Search.Mode
:SEARch:PEAK:EXCursion {value} | IAgInfiniiVisionSearch3Peak.Excursion
:SEARch:PEAK:EXCursion? | IAgInfiniiVisionSearch3Peak.Excursion
:SEARch:PEAK:NPEaks {value} | IAgInfiniiVisionSearch3Peak.NumberOfPeaks
:SEARch:PEAK:NPEaks? | IAgInfiniiVisionSearch3Peak.NumberOfPeaks
:SEARch:PEAK:SOURce {value} | IAgInfiniiVisionSearch3Peak.Source
:SEARch:PEAK:SOURce? | IAgInfiniiVisionSearch3Peak.Source
:SEARch:PEAK:THReshold {value} | IAgInfiniiVisionSearch3Peak.Threshold
:SEARch:PEAK:THReshold? | IAgInfiniiVisionSearch3Peak.Threshold
:SEARch:RUNT:POLarity {value} | IAgInfiniiVision2SearchRunt.Polarity
:SEARch:RUNT:POLarity? | IAgInfiniiVision2SearchRunt.Polarity
:SEARch:RUNT:QUALifier {value} | IAgInfiniiVision2SearchRunt.Condition
:SEARch:RUNT:QUALifier? | IAgInfiniiVision2SearchRunt.Condition
:SEARch:RUNT:SOURce {value} | IAgInfiniiVision2SearchRunt.Source
:SEARch:RUNT:SOURce? | IAgInfiniiVision2SearchRunt.Source
:SEARch:RUNT:TIME {value} | IAgInfiniiVision2SearchRunt.QualifierTime
:SEARch:RUNT:TIME? | IAgInfiniiVision2SearchRunt.QualifierTime
:SEARch:SERial:A429:LABel {value} | IAgInfiniiVision2SearchSerialARINC429.Label
:SEARch:SERial:A429:LABel? | IAgInfiniiVision2SearchSerialARINC429.Label
:SEARch:SERIAL:A429:MODE {value} | IAgInfiniiVision2SearchSerialARINC429.Mode
:SEARch:SERIAL:A429:MODE? | IAgInfiniiVision2SearchSerialARINC429.Mode
:SEARch:SERial:A429:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialARINC429.PatternData
:SEARch:SERial:A429:PATTern:DATA? | IAgInfiniiVision2SearchSerialARINC429.PatternData
:SEARch:SERial:A429:PATTern:SDI "{value}" | IAgInfiniiVision2SearchSerialARINC429.PatternSDI
:SEARch:SERial:A429:PATTern:SDI? | IAgInfiniiVision2SearchSerialARINC429.PatternSDI
:SEARch:SERial:A429:PATTern:SSM "{value}" | IAgInfiniiVision2SearchSerialARINC429.PatternSSM
:SEARch:SERial:A429:PATTern:SSM? | IAgInfiniiVision2SearchSerialARINC429.PatternSSM
:SEARch:SERial:CAN:MODE {value} | IAgInfiniiVision2SearchSerialCAN.Mode
:SEARch:SERial:CAN:MODE? | IAgInfiniiVision2SearchSerialCAN.Mode
:SEARch:SERial:CAN:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialCAN.PatternData
:SEARch:SERial:CAN:PATTern:DATA:LENGth {value} | IAgInfiniiVision2SearchSerialCAN.PatternDataLength
:SEARch:SERial:CAN:PATTern:DATA:LENGth? | IAgInfiniiVision2SearchSerialCAN.PatternDataLength
:SEARch:SERial:CAN:PATTern:DATA? | IAgInfiniiVision2SearchSerialCAN.PatternData
:SEARch:SERial:CAN:PATTern:ID "{value}" | IAgInfiniiVision2SearchSerialCAN.PatternID
:SEARch:SERial:CAN:PATTern:ID:MODE {value} | IAgInfiniiVision2SearchSerialCAN.PatternIDType
:SEARch:SERial:CAN:PATTern:ID:MODE? | IAgInfiniiVision2SearchSerialCAN.PatternIDType
:SEARch:SERial:CAN:PATTern:ID? | IAgInfiniiVision2SearchSerialCAN.PatternID
:SEARch:SERial:CAN:SYMBolic:MESSage {value} | IAgInfiniiVision2Search5Serial4CAN2.SymbolicMessage
:SEARch:SERial:CAN:SYMBolic:MESSage? | IAgInfiniiVision2Search5Serial4CAN2.SymbolicMessage
:SEARch:SERial:CAN:SYMBolic:SIGNal {value} | IAgInfiniiVision2Search5Serial4CAN2.SymbolicSignal
:SEARch:SERial:CAN:SYMBolic:SIGNal? | IAgInfiniiVision2Search5Serial4CAN2.SymbolicSignal
:SEARch:SERial:CAN:SYMBolic:VALue {value} | IAgInfiniiVision2Search5Serial4CAN2.SymbolicValue
:SEARch:SERial:CAN:SYMBolic:VALue? | IAgInfiniiVision2Search5Serial4CAN2.SymbolicValue
:SEARch:SERial:FLEXray:CYCLe {value} | IAgInfiniiVision2SearchSerialFlexRay.CycleNumber
:SEARch:SERial:FLEXray:CYCLe? | IAgInfiniiVision2SearchSerialFlexRay.CycleNumber
:SEARch:SERial:FLEXray:DATA "{value}" | IAgInfiniiVision2SearchSerialFlexRay.PatternData
:SEARch:SERial:FLEXray:DATA:LENGth {value} | IAgInfiniiVision2SearchSerialFlexRay.PatternDataLength
:SEARch:SERial:FLEXray:DATA:LENGth? | IAgInfiniiVision2SearchSerialFlexRay.PatternDataLength
:SEARch:SERial:FLEXray:DATA? | IAgInfiniiVision2SearchSerialFlexRay.PatternData
:SEARch:SERial:FLEXray:FRAMe {value} | IAgInfiniiVision2SearchSerialFlexRay.FrameID
:SEARch:SERial:FLEXray:FRAMe? | IAgInfiniiVision2SearchSerialFlexRay.FrameID
:SEARch:SERial:FLEXray:MODE {value} | IAgInfiniiVision2SearchSerialFlexRay.Mode
:SEARch:SERial:FLEXray:MODE? | IAgInfiniiVision2SearchSerialFlexRay.Mode
:SEARch:SERial:I2S:AUDio {value} | IAgInfiniiVision2SearchSerialI2S.AudioChannel
:SEARch:SERial:I2S:AUDio? | IAgInfiniiVision2SearchSerialI2S.AudioChannel
:SEARch:SERial:I2S:MODE {value} | IAgInfiniiVision2SearchSerialI2S.Mode
:SEARch:SERial:I2S:MODE? | IAgInfiniiVision2SearchSerialI2S.Mode
:SEARch:SERial:I2S:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialI2S.PatternData
:SEARch:SERial:I2S:PATTern:DATA? | IAgInfiniiVision2SearchSerialI2S.PatternData
:SEARch:SERial:I2S:RANGe {LowerLimit},{UpperLimit} | IAgInfiniiVision2SearchSerialI2S.SetRange
:SEARch:SERial:I2S:RANGe? | IAgInfiniiVision2SearchSerialI2S.GetRange
:SEARch:SERial:IIC:MODE {value} | IAgInfiniiVision2SearchSerialIIC.Mode
:SEARch:SERial:IIC:MODE? | IAgInfiniiVision2SearchSerialIIC.Mode
:SEARch:SERial:IIC:PATTern:ADDRess "{value}" | IAgInfiniiVision2SearchSerialIIC.Address
:SEARch:SERial:IIC:PATTern:ADDRess? | IAgInfiniiVision2SearchSerialIIC.Address
:SEARch:SERial:IIC:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialIIC.PatternData
:SEARch:SERial:IIC:PATTern:DATA? | IAgInfiniiVision2SearchSerialIIC.PatternData
:SEARch:SERial:IIC:PATTern:DATA2 "{value}" | IAgInfiniiVision2SearchSerialIIC.PatternData2
:SEARch:SERial:IIC:PATTern:DATA2? | IAgInfiniiVision2SearchSerialIIC.PatternData2
:SEARch:SERial:IIC:QUALifier {value} | IAgInfiniiVision2SearchSerialIIC.Condition
:SEARch:SERial:IIC:QUALifier? | IAgInfiniiVision2SearchSerialIIC.Condition
:SEARch:SERial:LIN:ID {value} | IAgInfiniiVision2SearchSerialLIN.ID
:SEARch:SERial:LIN:ID? | IAgInfiniiVision2SearchSerialLIN.ID
:SEARch:SERial:LIN:MODE {value} | IAgInfiniiVision2SearchSerialLIN.Mode
:SEARch:SERial:LIN:MODE? | IAgInfiniiVision2SearchSerialLIN.Mode
:SEARch:SERial:LIN:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialLIN.PatternData
:SEARch:SERial:LIN:PATTern:DATA:LENGth {value} | IAgInfiniiVision2SearchSerialLIN.PatternDataLength
:SEARch:SERial:LIN:PATTern:DATA:LENGth? | IAgInfiniiVision2SearchSerialLIN.PatternDataLength
:SEARch:SERial:LIN:PATTern:DATA? | IAgInfiniiVision2SearchSerialLIN.PatternData
:SEARch:SERial:LIN:SYMBolic:FRAMe {value} | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicFrame
:SEARch:SERial:LIN:SYMBolic:FRAMe? | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicFrame
:SEARch:SERial:LIN:SYMBolic:SIGNal {value} | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicSignal
:SEARch:SERial:LIN:SYMBolic:SIGNal? | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicSignal
:SEARch:SERial:LIN:SYMBolic:VALue {value} | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicValue
:SEARch:SERial:LIN:SYMBolic:VALue? | IAgInfiniiVisionSearch5Serial4LIN2.SymbolicValue
:SEARch:SERial:M1553:MODE {value} | IAgInfiniiVision2SearchSerialM1553.Mode
:SEARch:SERial:M1553:MODE? | IAgInfiniiVision2SearchSerialM1553.Mode
:SEARch:SERial:M1553:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialM1553.PatternData
:SEARch:SERial:M1553:PATTern:DATA? | IAgInfiniiVision2SearchSerialM1553.PatternData
:SEARch:SERial:M1553:RTA {value} | IAgInfiniiVision2SearchSerialM1553.RTA
:SEARch:SERial:M1553:RTA? | IAgInfiniiVision2SearchSerialM1553.RTA
:SEARch:SERial:SENT:FAST:DATA "{value}" | IAgInfiniiVisionSearchSerial3SENTFast.Data
:SEARch:SERial:SENT:FAST:DATA? | IAgInfiniiVisionSearchSerial3SENTFast.Data
:SEARch:SERial:SENT:MODE {value} | IAgInfiniiVisionSearchSerial3SENT.Mode
:SEARch:SERial:SENT:MODE? | IAgInfiniiVisionSearchSerial3SENT.Mode
:SEARch:SERial:SENT:SLOW:DATA {value} | IAgInfiniiVisionSearchSerial3SENTSlow.Data
:SEARch:SERial:SENT:SLOW:DATA? | IAgInfiniiVisionSearchSerial3SENTSlow.Data
:SEARch:SERial:SENT:SLOW:ID {value} | IAgInfiniiVisionSearchSerial3SENTSlow.ID
:SEARch:SERial:SENT:SLOW:ID? | IAgInfiniiVisionSearchSerial3SENTSlow.ID
:SEARch:SERial:SPI:MODE {value} | IAgInfiniiVision2SearchSerialSPI.Mode
:SEARch:SERial:SPI:MODE? | IAgInfiniiVision2SearchSerialSPI.Mode
:SEARch:SERial:SPI:PATTern:DATA "{value}" | IAgInfiniiVision2SearchSerialSPI.PatternData
:SEARch:SERial:SPI:PATTern:DATA? | IAgInfiniiVision2SearchSerialSPI.PatternData
:SEARch:SERial:SPI:PATTern:WIDTh {value} | IAgInfiniiVision2SearchSerialSPI.PatternWidth
:SEARch:SERial:SPI:PATTern:WIDTh? | IAgInfiniiVision2SearchSerialSPI.PatternWidth
:SEARch:SERial:UART:DATA {value} | IAgInfiniiVision2SearchSerialUART.PatternData
:SEARch:SERial:UART:DATA? | IAgInfiniiVision2SearchSerialUART.PatternData
:SEARch:SERial:UART:MODE {value} | IAgInfiniiVision2SearchSerialUART.Mode
:SEARch:SERial:UART:MODE? | IAgInfiniiVision2SearchSerialUART.Mode
:SEARch:SERial:UART:QUALifier {value} | IAgInfiniiVision2SearchSerialUART.Condition
:SEARch:SERial:UART:QUALifier? | IAgInfiniiVision2SearchSerialUART.Condition
:SEARch:SERial:USB:ADDRess {value:%qs} | IAgInfiniiVisionSearchSerial2USB.Address
:SEARch:SERial:USB:ADDRess? | IAgInfiniiVisionSearchSerial2USB.Address
:SEARch:SERial:USB:CRC {value:%qs} | IAgInfiniiVisionSearchSerial2USB.CRC
:SEARch:SERial:USB:CRC? | IAgInfiniiVisionSearchSerial2USB.CRC
:SEARch:SERial:USB:DATA {value:%qs} | IAgInfiniiVisionSearchSerial2USB.Data
:SEARch:SERial:USB:DATA:LENGth {value} | IAgInfiniiVisionSearchSerial2USB.DataLength
:SEARch:SERial:USB:DATA:LENGth? | IAgInfiniiVisionSearchSerial2USB.DataLength
:SEARch:SERial:USB:DATA? | IAgInfiniiVisionSearchSerial2USB.Data
:SEARch:SERial:USB:ENDPoint {value:%qs} | IAgInfiniiVisionSearchSerial2USB.EndPoint
:SEARch:SERial:USB:ENDPoint? | IAgInfiniiVisionSearchSerial2USB.EndPoint
:SEARch:SERial:USB:ET {value:%qs} | IAgInfiniiVisionSearchSerial2USB.ET
:SEARch:SERial:USB:ET? | IAgInfiniiVisionSearchSerial2USB.ET
:SEARch:SERial:USB:FRAMe {value:%qs} | IAgInfiniiVisionSearchSerial2USB.Frame
:SEARch:SERial:USB:FRAMe? | IAgInfiniiVisionSearchSerial2USB.Frame
:SEARch:SERial:USB:HADDress {value:%qs} | IAgInfiniiVisionSearchSerial2USB.HubAddress
:SEARch:SERial:USB:HADDress? | IAgInfiniiVisionSearchSerial2USB.HubAddress
:SEARch:SERial:USB:MODE {value} | IAgInfiniiVisionSearchSerial2USB.Condition
:SEARch:SERial:USB:MODE? | IAgInfiniiVisionSearchSerial2USB.Condition
:SEARch:SERial:USB:PID:DATA {value} | IAgInfiniiVisionSearchSerial2USB.PIDData
:SEARch:SERial:USB:PID:DATA? | IAgInfiniiVisionSearchSerial2USB.PIDData
:SEARch:SERial:USB:PID:HANDshake {value} | IAgInfiniiVisionSearchSerial2USB.PIDHandshake
:SEARch:SERial:USB:PID:HANDshake? | IAgInfiniiVisionSearchSerial2USB.PIDHandshake
:SEARch:SERial:USB:PID:SPECial {value} | IAgInfiniiVisionSearchSerial2USB.PIDSpecial
:SEARch:SERial:USB:PID:SPECial? | IAgInfiniiVisionSearchSerial2USB.PIDSpecial
:SEARch:SERial:USB:PID:TOKen {value} | IAgInfiniiVisionSearchSerial2USB.PIDToken
:SEARch:SERial:USB:PID:TOKen? | IAgInfiniiVisionSearchSerial2USB.PIDToken
:SEARch:SERial:USB:PORT {value:%qs} | IAgInfiniiVisionSearchSerial2USB.Port
:SEARch:SERial:USB:PORT? | IAgInfiniiVisionSearchSerial2USB.Port
:SEARch:SERial:USB:SC {value:%qs} | IAgInfiniiVisionSearchSerial2USB.SC
:SEARch:SERial:USB:SC? | IAgInfiniiVisionSearchSerial2USB.SC
:SEARch:SERial:USB:SEU {value:%qs} | IAgInfiniiVisionSearchSerial2USB.SEU
:SEARch:SERial:USB:SEU? | IAgInfiniiVisionSearchSerial2USB.SEU
:SEARch:TRANsition:QUALifier {value} | IAgInfiniiVision2SearchTransition.Condition
:SEARch:TRANsition:QUALifier? | IAgInfiniiVision2SearchTransition.Condition
:SEARch:TRANsition:SLOPe {value} | IAgInfiniiVision2SearchTransition.Slope
:SEARch:TRANsition:SLOPe? | IAgInfiniiVision2SearchTransition.Slope
:SEARch:TRANsition:SOURce {value} | IAgInfiniiVision2SearchTransition.Source
:SEARch:TRANsition:SOURce? | IAgInfiniiVision2SearchTransition.Source
:SEARch:TRANsition:TIME {value} | IAgInfiniiVision2SearchTransition.QualifierTime
:SEARch:TRANsition:TIME? | IAgInfiniiVision2SearchTransition.QualifierTime
:SINGle | IAgInfiniiVisionAcquisition.SingleAcquisition
:STOP | IAgInfiniiVisionAcquisition.Stop IAgInfiniiVisionMeasurements.Abort
:SYSTem:DATE {value} | IAgInfiniiVisionSystem.Date
:SYSTem:DATE? | IAgInfiniiVisionSystem.Date
:SYSTem:DSP "{value}" | IAgInfiniiVisionSystem.Message
:SYSTem:LOCK 0 | IAgInfiniiVisionSystem.EnableLocalControls
:SYSTem:LOCK 1 | IAgInfiniiVisionSystem.DisableLocalControls
:SYSTem:PRECision {value} | IAgInfiniiVisionSystem3Precision.Enabled
:SYSTem:PRECision:LENGth {value} | IAgInfiniiVisionSystem3Precision.RecordLength
:SYSTem:PRECision:LENGth? | IAgInfiniiVisionSystem3Precision.RecordLength
:SYSTem:PRECision? | IAgInfiniiVisionSystem3Precision.Enabled
:SYSTem:PROTection:LOCK {value} | IAgInfiniiVisionSystem.ProtectionEnabled
:SYSTem:PROTection:LOCK? | IAgInfiniiVisionSystem.ProtectionEnabled
:SYSTem:TIME {value} | IAgInfiniiVisionSystem.Time
:SYSTem:TIME? | IAgInfiniiVisionSystem.Time
:SYSTem:TOUCh {value} | IAgInfiniiVisionSystem2.TouchScreenEnabled
:SYSTem:TOUCh? | IAgInfiniiVisionSystem2.TouchScreenEnabled
:TIMebase:MODE {value} | IAgInfiniiVisionTimebase.Mode
:TIMebase:MODE? | IAgInfiniiVisionTimebase.Mode
:TIMebase:POSition {value} | IAgInfiniiVisionAcquisition.StartTime
:TIMebase:POSition? | IAgInfiniiVisionAcquisition.StartTime
:TIMebase:RANGe {value} | IAgInfiniiVisionAcquisition.TimePerRecord
:TIMebase:RANGe? | IAgInfiniiVisionAcquisition.TimePerRecord
:TIMebase:REFerence {value} | IAgInfiniiVisionTimebase.TimeReference
:TIMebase:REFerence? | IAgInfiniiVisionTimebase.TimeReference
:TIMebase:SCALe {value} | IAgInfiniiVisionTimebase.HorizontalScale
:TIMebase:SCALe? | IAgInfiniiVisionTimebase.HorizontalScale
:TIMebase:VERNier {value} | IAgInfiniiVisionTimebase.VernierEnabled
:TIMebase:VERNier? | IAgInfiniiVisionTimebase.VernierEnabled
:TIMebase:WINDow:POSition {value} | IAgInfiniiVisionTimebaseWindow.HorizontalPosition
:TIMebase:WINDow:POSition? | IAgInfiniiVisionTimebaseWindow.HorizontalPosition
:TIMebase:WINDow:RANGe {value} | IAgInfiniiVisionTimebaseWindow.Range
:TIMebase:WINDow:RANGe? | IAgInfiniiVisionTimebaseWindow.Range
:TIMebase:WINDow:SCALe {value} | IAgInfiniiVisionTimebaseWindow.HorizontalScale
:TIMebase:WINDow:SCALe? | IAgInfiniiVisionTimebaseWindow.HorizontalScale
:TRIGger:DELay:ARM:SLOPe {value} | IAgInfiniiVisionTrigger2Delay.ArmingSlope
:TRIGger:DELay:ARM:SLOPe? | IAgInfiniiVisionTrigger2Delay.ArmingSlope
:TRIGger:DELay:ARM:SOURce {value} | IAgInfiniiVisionTrigger2Delay.ArmingSource
:TRIGger:DELay:ARM:SOURce? | IAgInfiniiVisionTrigger2Delay.ArmingSource
:TRIGger:DELay:TDELay:TIME {value} | IAgInfiniiVisionTrigger2Delay.Time
:TRIGger:DELay:TDELay:TIME? | IAgInfiniiVisionTrigger2Delay.Time
:TRIGger:DELay:TRIGger:COUNt {value} | IAgInfiniiVisionTrigger2Delay.EdgeCount
:TRIGger:DELay:TRIGger:COUNt? | IAgInfiniiVisionTrigger2Delay.EdgeCount
:TRIGger:DELay:TRIGger:SLOPe {value} | IAgInfiniiVisionTrigger2Delay.Slope
:TRIGger:DELay:TRIGger:SLOPe? | IAgInfiniiVisionTrigger2Delay.Slope
:TRIGger:EBURst:COUNt {value} | IAgInfiniiVisionTrigger2EdgeBurst.NthEdge
:TRIGger:EBURst:COUNt? | IAgInfiniiVisionTrigger2EdgeBurst.NthEdge
:TRIGger:EBURst:IDLE {value} | IAgInfiniiVisionTrigger2EdgeBurst.IdleTime
:TRIGger:EBURst:IDLE? | IAgInfiniiVisionTrigger2EdgeBurst.IdleTime
:TRIGger:EBURst:SLOPe {value} | IAgInfiniiVisionTrigger2EdgeBurst.Slope
:TRIGger:EBURst:SLOPe? | IAgInfiniiVisionTrigger2EdgeBurst.Slope
:TRIGger:FORCe | IAgInfiniiVisionTrigger2.ForceTrigger
:TRIGger:GLITch:LESSthan {value}|:TRIGger:GLITch:GREaterthan {value} | IAgInfiniiVisionTriggerGlitch.Width
:TRIGger:GLITch:LESSthan? |:TRIGger:GLITch:GREaterthan? | IAgInfiniiVisionTriggerGlitch.Width
:TRIGger:GLITch:LEVel {value} | IAgInfiniiVisionTriggerGlitch.Level
:TRIGger:GLITch:LEVel? | IAgInfiniiVisionTriggerGlitch.Level
:TRIGger:GLITch:POLarity {value} | IAgInfiniiVisionTriggerGlitch.Polarity
:TRIGger:GLITch:POLarity? | IAgInfiniiVisionTriggerGlitch.Polarity
:TRIGger:GLITch:QUALifier {value} | IAgInfiniiVisionTriggerGlitch.Condition
:TRIGger:GLITch:QUALifier? | IAgInfiniiVisionTriggerGlitch.Condition
:TRIGger:GLITch:RANGe {LowerLimit}, {UpperLimit} | IAgInfiniiVisionTriggerGlitch.SetRange
:TRIGger:GLITch:RANGe? | IAgInfiniiVisionTriggerGlitch.GetRange
:TRIGger:HFReject {value} | IAgInfiniiVisionTrigger.HFRejectFilterEnabled
:TRIGger:HFReject? | IAgInfiniiVisionTrigger.HFRejectFilterEnabled
:TRIGger:HOLDoff {value} | IAgInfiniiVisionTrigger.Holdoff
:TRIGger:HOLDoff:MAXimum {value} | IAgInfiniiVisionTrigger5RandomHoldoff.TimeMax
:TRIGger:HOLDoff:MAXimum? | IAgInfiniiVisionTrigger5RandomHoldoff.TimeMax
:TRIGger:HOLDoff:MINimum {value} | IAgInfiniiVisionTrigger5RandomHoldoff.TimeMin
:TRIGger:HOLDoff:MINimum? | IAgInfiniiVisionTrigger5RandomHoldoff.TimeMin
:TRIGger:HOLDoff:RANDom {value} | IAgInfiniiVisionTrigger5RandomHoldoff.Enabled
:TRIGger:HOLDoff:RANDom? | IAgInfiniiVisionTrigger5RandomHoldoff.Enabled
:TRIGger:HOLDoff? | IAgInfiniiVisionTrigger.Holdoff
:TRIGger:LEVel:ASETup | IAgInfiniiVisionTrigger3.AutoSetup
:TRIGger:MODE {value} | IAgInfiniiVisionTrigger.Type
:TRIGger:MODE? | IAgInfiniiVisionTrigger.Type
:TRIGger:NREJect {value} | IAgInfiniiVisionTrigger.NoiseRejectFilterEnabled
:TRIGger:NREJect? | IAgInfiniiVisionTrigger.NoiseRejectFilterEnabled
:TRIGger:OR "{value}" | IAgInfiniiVisionTrigger2OR.EdgePattern
:TRIGger:OR? | IAgInfiniiVisionTrigger2OR.EdgePattern
:TRIGger:PATTern:GREaterthan {value} | IAgInfiniiVisionTriggerPattern.MinDuration
:TRIGger:PATTern:GREaterthan? | IAgInfiniiVisionTriggerPattern.MinDuration
:TRIGger:PATTern:LESSthan {value} | IAgInfiniiVisionTriggerPattern.MaxDuration
:TRIGger:PATTern:LESSthan? | IAgInfiniiVisionTriggerPattern.MaxDuration
:TRIGger:PATTern:QUALifier {value} | IAgInfiniiVisionTriggerWidth.Condition
:TRIGger:PATTern:QUALifier? | IAgInfiniiVisionTriggerWidth.Condition
:TRIGger:PATTern:RANGe {LessThanTime},{GreaterThanTime} | IAgInfiniiVisionTriggerPattern.SetRange
:TRIGger:PATTern:RANGe? | IAgInfiniiVisionTriggerPattern.GetRange
:TRIGger:PXI:MALine{Index}:ENABle {State} | IAgInfiniiVisionTrigger4PXI.SetMasterArmLine
:TRIGger:PXI:MALine{Index}:ENABle? | IAgInfiniiVisionTrigger4PXI.GetMasterArmLine
:TRIGger:PXI:MODE {value} | IAgInfiniiVisionTrigger4PXI.Mode
:TRIGger:PXI:MODE? | IAgInfiniiVisionTrigger4PXI.Mode
:TRIGger:PXI:MSLot {value} | IAgInfiniiVisionTrigger4PXI.Slot
:TRIGger:PXI:MSLot? | IAgInfiniiVisionTrigger4PXI.Slot
:TRIGger:PXI:SALine {value} | IAgInfiniiVisionTrigger4PXI.SlaveArmLine
:TRIGger:PXI:SALine? | IAgInfiniiVisionTrigger4PXI.SlaveArmLine
:TRIGger:PXI:TLINe {value} | IAgInfiniiVisionTrigger4PXI.TriggerLine
:TRIGger:PXI:TLINe? | IAgInfiniiVisionTrigger4PXI.TriggerLine
:TRIGger:RUNT:POLarity {value} | IAgInfiniiVisionTriggerRunt.Polarity
:TRIGger:RUNT:POLarity? | IAgInfiniiVisionTriggerRunt.Polarity
:TRIGger:RUNT:QUALifier {value} | IAgInfiniiVisionTriggerRunt.Condition
:TRIGger:RUNT:QUALifier? | IAgInfiniiVisionTriggerRunt.Condition
:TRIGger:RUNT:TIME {value} | IAgInfiniiVisionTriggerRunt.QualifierTime
:TRIGger:RUNT:TIME? | IAgInfiniiVisionTriggerRunt.QualifierTime
:TRIGger:SHOLd:SLOPe {value} | IAgInfiniiVisionTrigger2SetupAndHold.Slope
:TRIGger:SHOLd:SLOPe? | IAgInfiniiVisionTrigger2SetupAndHold.Slope
:TRIGger:SHOLd:SOURce:CLOCk {value} | IAgInfiniiVisionTrigger2SetupAndHold.ClockSource
:TRIGger:SHOLd:SOURce:CLOCk? | IAgInfiniiVisionTrigger2SetupAndHold.ClockSource
:TRIGger:SHOLd:SOURce:DATA {value} | IAgInfiniiVisionTrigger2SetupAndHold.DataSource
:TRIGger:SHOLd:SOURce:DATA? | IAgInfiniiVisionTrigger2SetupAndHold.DataSource
:TRIGger:SHOLd:TIME:HOLD {value} | IAgInfiniiVisionTrigger2SetupAndHold.HoldTime
:TRIGger:SHOLd:TIME:HOLD? | IAgInfiniiVisionTrigger2SetupAndHold.HoldTime
:TRIGger:SHOLd:TIME:SETup {value} | IAgInfiniiVisionTrigger2SetupAndHold.SetupTime
:TRIGger:SHOLd:TIME:SETup? | IAgInfiniiVisionTrigger2SetupAndHold.SetupTime
:TRIGger:SWEep {value} | IAgInfiniiVisionTrigger.Modifier
:TRIGger:SWEep? | IAgInfiniiVisionTrigger.Modifier
:TRIGger:TRANsition:QUALifier {value} | IAgInfiniiVisionTrigger2Transition.Condition
:TRIGger:TRANsition:QUALifier? | IAgInfiniiVisionTrigger2Transition.Condition
:TRIGger:TRANsition:SLOPe {value} | IAgInfiniiVisionTrigger2Transition.Slope
:TRIGger:TRANsition:SLOPe? | IAgInfiniiVisionTrigger2Transition.Slope
:TRIGger:TRANsition:TIME {value} | IAgInfiniiVisionTrigger2Transition.QualifierTime
:TRIGger:TRANsition:TIME? | IAgInfiniiVisionTrigger2Transition.QualifierTime
:TRIGger:TV:LINE {value} | IAgInfiniiVisionTriggerTV.LineNumber
:TRIGger:TV:LINE? | IAgInfiniiVisionTriggerTV.LineNumber
:TRIGger:TV:MODE {value} | IAgInfiniiVisionTriggerTV.Event
:TRIGger:TV:MODE? | IAgInfiniiVisionTriggerTV.Event
:TRIGger:TV:POLarity {value} | IAgInfiniiVisionTriggerTV.Polarity
:TRIGger:TV:POLarity? | IAgInfiniiVisionTriggerTV.Polarity
:TRIGger:TV:STANdard {value} | IAgInfiniiVisionTriggerTV.SignalFormat
:TRIGger:TV:STANdard? | IAgInfiniiVisionTriggerTV.SignalFormat
:TRIGger:TV:UDTV:ENUMber {value} | IAgInfiniiVisionTriggerTV2UDTV.EdgeNumber
:TRIGger:TV:UDTV:ENUMber? | IAgInfiniiVisionTriggerTV2UDTV.EdgeNumber
:TRIGger:TV:UDTV:HSYNc {value} | IAgInfiniiVisionTriggerTV2UDTV.HorizontalSyncEnabled
:TRIGger:TV:UDTV:HSYNc? | IAgInfiniiVisionTriggerTV2UDTV.HorizontalSyncEnabled
:TRIGger:TV:UDTV:HTIMe {value} | IAgInfiniiVisionTriggerTV2UDTV.HorizontalSyncTime
:TRIGger:TV:UDTV:HTIMe? | IAgInfiniiVisionTriggerTV2UDTV.HorizontalSyncTime
:TRIGger:TV:UDTV:PGTHan {value} | IAgInfiniiVisionTriggerTV2UDTV.MinTime
:TRIGger:TV:UDTV:PGTHan? | IAgInfiniiVisionTriggerTV2UDTV.MinTime
:TRIGger:USB:SOURce:DMINus {value} | IAgInfiniiVisionTrigger2USB.DMinusSource
:TRIGger:USB:SOURce:DMINus? | IAgInfiniiVisionTrigger2USB.DMinusSource
:TRIGger:USB:SOURce:DPLus {value} | IAgInfiniiVisionTrigger2USB.DPlusSource
:TRIGger:USB:SOURce:DPLus? | IAgInfiniiVisionTrigger2USB.DPlusSource
:TRIGger:USB:SPEed {value} | IAgInfiniiVisionTrigger2USB.Speed
:TRIGger:USB:SPEed? | IAgInfiniiVisionTrigger2USB.Speed
:TRIGger:USB:TRIGger {value} | IAgInfiniiVisionTrigger2USB.Condition
:TRIGger:USB:TRIGger? | IAgInfiniiVisionTrigger2USB.Condition
:TRIGger:ZONE:SOURce {value} | IAgInfiniiVisionTrigger3Zone.Source
:TRIGger:ZONE:SOURce? | IAgInfiniiVisionTrigger3Zone.Source
:TRIGger:ZONE{Zone}:MODE {value} | IAgInfiniiVisionTrigger3Zone.Mode
:TRIGger:ZONE{Zone}:MODE? | IAgInfiniiVisionTrigger3Zone.Mode
:TRIGger:ZONE{Zone}:PLACement {Width}, {Height}, {XCenter}, {YCenter} | IAgInfiniiVisionTrigger3Zone.SetZonePlacement
:TRIGger:ZONE{Zone}:PLACement? | IAgInfiniiVisionTrigger3Zone.GetZonePlacement
:TRIGger:ZONE{Zone}:STATe {value} | IAgInfiniiVisionTrigger3Zone.Enabled
:TRIGger:ZONE{Zone}:STATe? | IAgInfiniiVisionTrigger3Zone.Enabled
:TRIGger:ZONE{Zone}:VALidity? | IAgInfiniiVisionTrigger3Zone.Validity
:TRIGger[:EDGE]:COUPling {value} | IAgInfiniiVisionTrigger.Coupling
:TRIGger[:EDGE]:COUPling? | IAgInfiniiVisionTrigger.Coupling
:TRIGger[:EDGE]:LEVel {value} | IAgInfiniiVisionTrigger.Level
:TRIGger[:EDGE]:LEVel? | IAgInfiniiVisionTrigger.Level
:TRIGger[:EDGE]:REJect {value} | IAgInfiniiVisionTriggerEdge.RejectFilterType
:TRIGger[:EDGE]:REJect? | IAgInfiniiVisionTriggerEdge.RejectFilterType
:TRIGger[:EDGE]:SLOPe {value} | IAgInfiniiVisionTriggerEdge.Slope IAgInfiniiVisionTriggerAcLine.Slope
:TRIGger[:EDGE]:SLOPe? | IAgInfiniiVisionTriggerEdge.Slope IAgInfiniiVisionTriggerAcLine.Slope
:TRIGger[:EDGE]:SOURce {value} | IAgInfiniiVisionTrigger.Source
:TRIGger[:EDGE]:SOURce? | IAgInfiniiVisionTrigger.Source
:WAVeform:BYTeorder {value} | IAgInfiniiVisionWaveform.ByteOrder
:WAVeform:BYTeorder? | IAgInfiniiVisionWaveform.ByteOrder
:WAVeform:FORMat {value} | IAgInfiniiVisionWaveform.DataFormat
:WAVeform:FORMat? | IAgInfiniiVisionWaveform.DataFormat
:WAVeform:POINts {value} | IAgInfiniiVisionAcquisition.NumberOfPointsMin IAgInfiniiVisionWaveform.PointCount
:WAVeform:POINts:MODE {value} | IAgInfiniiVisionWaveform.PointMode
:WAVeform:POINts:MODE? | IAgInfiniiVisionWaveform.PointMode
:WAVeform:POINts? | IAgInfiniiVisionAcquisition.RecordLength IAgInfiniiVisionAcquisition.NumberOfPointsMin IAgInfiniiVisionWaveform.PointCount
:WAVeform:PREamble? | IAgInfiniiVisionWaveform.Preamble
:WAVeform:SEGMented:TTAG? | IAgInfiniiVisionAcquisitionSegmentedMemory.TimeTag
:WAVeform:SOURce {value} | IAgInfiniiVisionWaveform.Source
:WAVeform:SOURce:SUBSource {value} | IAgInfiniiVisionWaveform2.SubSource
:WAVeform:SOURce:SUBSource? | IAgInfiniiVisionWaveform2.SubSource
:WAVeform:SOURce? | IAgInfiniiVisionWaveform.Source
:WAVeform:UNSigned {value} | IAgInfiniiVisionWaveform.UnsignedModeEnable
:WAVeform:UNSigned? | IAgInfiniiVisionWaveform.UnsignedModeEnable
:WAVeform:VIEW {value} | IAgInfiniiVisionWaveform.View
:WAVeform:VIEW? | IAgInfiniiVisionWaveform.View
:WAVeform:XINCrement? | IAgInfiniiVisionAcquisition.SampleRate IAgInfiniiVisionWaveform.XIncrement
:WAVeform:XORigin? | IAgInfiniiVisionWaveform.XOrigin
:WAVeform:XREFerence? | IAgInfiniiVisionWaveform.XReference
:WAVeform:YINCrement? | IAgInfiniiVisionWaveform.YIncrement
:WAVeform:YORigin? | IAgInfiniiVisionWaveform.YOrigin
:WAVeform:YREFerence? | IAgInfiniiVisionWaveform.YReference
:WGEN:ARBitrary:BYTeorder {value} | IAgInfiniiVisionWaveformGenerator2Arbitrary.ByteOrder
:WGEN:ARBitrary:BYTeorder? | IAgInfiniiVisionWaveformGenerator2Arbitrary.ByteOrder
:WGEN:ARBitrary:DATA {Values} | IAgInfiniiVisionWaveformGenerator2Arbitrary.SetData
:WGEN:ARBitrary:DATA:ATTRibute:POINts? | IAgInfiniiVisionWaveformGenerator2ArbitraryAttribute.NumberOfPoints
:WGEN:ARBitrary:DATA:CLEar | IAgInfiniiVisionWaveformGenerator2Arbitrary.Reset
:WGEN:ARBitrary:DATA:DAC {Values} | IAgInfiniiVisionWaveformGenerator2Arbitrary.SetDataDAC
:WGEN:ARBitrary:INTerpolate {value} | IAgInfiniiVisionWaveformGenerator2Arbitrary.Interpolation
:WGEN:ARBitrary:INTerpolate? | IAgInfiniiVisionWaveformGenerator2Arbitrary.Interpolation
:WGEN:ARBitrary:STORe {Source} | IAgInfiniiVisionWaveformGenerator2Arbitrary.Store
:WGEN:FREQuency {value} | IAgInfiniiVisionWaveformGenerator.Frequency
:WGEN:FREQuency? | IAgInfiniiVisionWaveformGenerator.Frequency
:WGEN:FUNCtion {value} | IAgInfiniiVisionWaveformGenerator.Function
:WGEN:FUNCtion:PULSe:WIDTh {value} | IAgInfiniiVisionWaveformGenerator.PulseWidth
:WGEN:FUNCtion:PULSe:WIDTh? | IAgInfiniiVisionWaveformGenerator.PulseWidth
:WGEN:FUNCtion:RAMP:SYMMetry {value} | IAgInfiniiVisionWaveformGenerator.RampSymmetry
:WGEN:FUNCtion:RAMP:SYMMetry? | IAgInfiniiVisionWaveformGenerator.RampSymmetry
:WGEN:FUNCtion:SQUare:DCYCle {value} | IAgInfiniiVisionWaveformGenerator.DutyCycle
:WGEN:FUNCtion:SQUare:DCYCle? | IAgInfiniiVisionWaveformGenerator.DutyCycle
:WGEN:FUNCtion? | IAgInfiniiVisionWaveformGenerator.Function
:WGEN:MODulation:NOISe {value} | IAgInfiniiVisionWaveformGenerator2.AdditionalNoise
:WGEN:MODulation:NOISe? | IAgInfiniiVisionWaveformGenerator2.AdditionalNoise
:WGEN:OUTPut {value} | IAgInfiniiVisionWaveformGenerator.OutputEnabled
:WGEN:OUTPut:LOAD {value} | IAgInfiniiVisionWaveformGenerator.OutputLoadImpedance
:WGEN:OUTPut:LOAD? | IAgInfiniiVisionWaveformGenerator.OutputLoadImpedance
:WGEN:OUTPut? | IAgInfiniiVisionWaveformGenerator.OutputEnabled
:WGEN:PERiod {value} | IAgInfiniiVisionWaveformGenerator.Period
:WGEN:PERiod? | IAgInfiniiVisionWaveformGenerator.Period
:WGEN:RST | IAgInfiniiVisionWaveformGenerator.Reset
:WGEN:VOLTage {value} | IAgInfiniiVisionWaveformGenerator.Amplitude
:WGEN:VOLTage:HIGH {value} | IAgInfiniiVisionWaveformGenerator.HighVoltage
:WGEN:VOLTage:HIGH? | IAgInfiniiVisionWaveformGenerator.HighVoltage
:WGEN:VOLTage:LOW {value} | IAgInfiniiVisionWaveformGenerator.LowVoltage
:WGEN:VOLTage:LOW? | IAgInfiniiVisionWaveformGenerator.LowVoltage
:WGEN:VOLTage:OFFSet {value} | IAgInfiniiVisionWaveformGenerator.OffsetVoltage
:WGEN:VOLTage:OFFSet? | IAgInfiniiVisionWaveformGenerator.OffsetVoltage
:WGEN:VOLTage? | IAgInfiniiVisionWaveformGenerator.Amplitude
:WGEN{rcindex+1}:ARBitrary:BYTeorder {value} | IAgInfiniiVisionWaveGenArbitrary.ByteOrder
:WGEN{rcindex+1}:ARBitrary:BYTeorder? | IAgInfiniiVisionWaveGenArbitrary.ByteOrder
:WGEN{rcindex+1}:ARBitrary:DATA {Values} | IAgInfiniiVisionWaveGenArbitrary.SetData
:WGEN{rcindex+1}:ARBitrary:DATA:ATTRibute:POINts? | IAgInfiniiVisionWaveGenArbitraryAttribute.NumberOfPoints
:WGEN{rcindex+1}:ARBitrary:DATA:CLEar | IAgInfiniiVisionWaveGenArbitrary.Reset
:WGEN{rcindex+1}:ARBitrary:DATA:DAC {Values} | IAgInfiniiVisionWaveGenArbitrary.SetDataDAC
:WGEN{rcindex+1}:ARBitrary:INTerpolate {value} | IAgInfiniiVisionWaveGenArbitrary.Interpolation
:WGEN{rcindex+1}:ARBitrary:INTerpolate? | IAgInfiniiVisionWaveGenArbitrary.Interpolation
:WGEN{rcindex+1}:ARBitrary:STORe {Source} | IAgInfiniiVisionWaveGenArbitrary.Store
:WGEN{rcindex+1}:FREQuency {value} | IAgInfiniiVisionWaveGen.Frequency
:WGEN{rcindex+1}:FREQuency? | IAgInfiniiVisionWaveGen.Frequency
:WGEN{rcindex+1}:FUNCtion {value} | IAgInfiniiVisionWaveGen.Function
:WGEN{rcindex+1}:FUNCtion:PULSe:WIDTh {value} | IAgInfiniiVisionWaveGen.PulseWidth
:WGEN{rcindex+1}:FUNCtion:PULSe:WIDTh? | IAgInfiniiVisionWaveGen.PulseWidth
:WGEN{rcindex+1}:FUNCtion:RAMP:SYMMetry {value} | IAgInfiniiVisionWaveGen.RampSymmetry
:WGEN{rcindex+1}:FUNCtion:RAMP:SYMMetry? | IAgInfiniiVisionWaveGen.RampSymmetry
:WGEN{rcindex+1}:FUNCtion:SQUare:DCYCle {value} | IAgInfiniiVisionWaveGen.DutyCycle
:WGEN{rcindex+1}:FUNCtion:SQUare:DCYCle? | IAgInfiniiVisionWaveGen.DutyCycle
:WGEN{rcindex+1}:FUNCtion? | IAgInfiniiVisionWaveGen.Function
:WGEN{rcindex+1}:MODulation:AM:DEPTh {value} | IAgInfiniiVisionWaveGenModulationAM.Depth
:WGEN{rcindex+1}:MODulation:AM:DEPTh? | IAgInfiniiVisionWaveGenModulationAM.Depth
:WGEN{rcindex+1}:MODulation:AM:FREQuency {value} | IAgInfiniiVisionWaveGenModulationAM.Frequency
:WGEN{rcindex+1}:MODulation:AM:FREQuency? | IAgInfiniiVisionWaveGenModulationAM.Frequency
:WGEN{rcindex+1}:MODulation:FM:DEViation {value} | IAgInfiniiVisionWaveGenModulationFM.Deviation
:WGEN{rcindex+1}:MODulation:FM:DEViation? | IAgInfiniiVisionWaveGenModulationFM.Deviation
:WGEN{rcindex+1}:MODulation:FM:FREQuency {value} | IAgInfiniiVisionWaveGenModulationFM.Frequency
:WGEN{rcindex+1}:MODulation:FM:FREQuency? | IAgInfiniiVisionWaveGenModulationFM.Frequency
:WGEN{rcindex+1}:MODulation:FSKey:FREQuency {value} | IAgInfiniiVisionWaveGenModulationFSK.Frequency
:WGEN{rcindex+1}:MODulation:FSKey:FREQuency? | IAgInfiniiVisionWaveGenModulationFSK.Frequency
:WGEN{rcindex+1}:MODulation:FSKey:RATE {value} | IAgInfiniiVisionWaveGenModulationFSK.Rate
:WGEN{rcindex+1}:MODulation:FSKey:RATE? | IAgInfiniiVisionWaveGenModulationFSK.Rate
:WGEN{rcindex+1}:MODulation:FUNCtion {value} | IAgInfiniiVisionWaveGenModulation.Function
:WGEN{rcindex+1}:MODulation:FUNCtion:RAMP:SYMMetry {value} | IAgInfiniiVisionWaveGenModulation.RampSymmetry
:WGEN{rcindex+1}:MODulation:FUNCtion:RAMP:SYMMetry? | IAgInfiniiVisionWaveGenModulation.RampSymmetry
:WGEN{rcindex+1}:MODulation:FUNCtion? | IAgInfiniiVisionWaveGenModulation.Function
:WGEN{rcindex+1}:MODulation:NOISe {value} | IAgInfiniiVisionWaveGen.AdditionalNoise
:WGEN{rcindex+1}:MODulation:NOISe? | IAgInfiniiVisionWaveGen.AdditionalNoise
:WGEN{rcindex+1}:MODulation:STATe {value} | IAgInfiniiVisionWaveGenModulation.Enabled
:WGEN{rcindex+1}:MODulation:STATe? | IAgInfiniiVisionWaveGenModulation.Enabled
:WGEN{rcindex+1}:MODulation:TYPE {value} | IAgInfiniiVisionWaveGenModulation.Type
:WGEN{rcindex+1}:MODulation:TYPE? | IAgInfiniiVisionWaveGenModulation.Type
:WGEN{rcindex+1}:OUTPut {value} | IAgInfiniiVisionWaveGen.OutputEnabled
:WGEN{rcindex+1}:OUTPut:LOAD {value} | IAgInfiniiVisionWaveGen.OutputLoadImpedance
:WGEN{rcindex+1}:OUTPut:LOAD? | IAgInfiniiVisionWaveGen.OutputLoadImpedance
:WGEN{rcindex+1}:OUTPut:MODE {value} | IAgInfiniiVisionWaveGen2.OutputMode
:WGEN{rcindex+1}:OUTPut:MODE? | IAgInfiniiVisionWaveGen2.OutputMode
:WGEN{rcindex+1}:OUTPut:POLarity {value} | IAgInfiniiVisionWaveGen.OutputInverted
:WGEN{rcindex+1}:OUTPut:POLarity? | IAgInfiniiVisionWaveGen.OutputInverted
:WGEN{rcindex+1}:OUTPut:SINGle | IAgInfiniiVisionWaveGen2.OutputSingle
:WGEN{rcindex+1}:OUTPut? | IAgInfiniiVisionWaveGen.OutputEnabled
:WGEN{rcindex+1}:PERiod {value} | IAgInfiniiVisionWaveGen.Period
:WGEN{rcindex+1}:PERiod? | IAgInfiniiVisionWaveGen.Period
:WGEN{rcindex+1}:RST | IAgInfiniiVisionWaveGen.Reset
:WGEN{rcindex+1}:TRACk {value} | IAgInfiniiVisionWaveGenTracking.Enabled
:WGEN{rcindex+1}:TRACk:AMPLitude {value} | IAgInfiniiVisionWaveGenTracking.AmplitudeEnabled
:WGEN{rcindex+1}:TRACk:AMPLitude? | IAgInfiniiVisionWaveGenTracking.AmplitudeEnabled
:WGEN{rcindex+1}:TRACk:CSIGnal | IAgInfiniiVisionWaveGenTracking.CopySignal
:WGEN{rcindex+1}:TRACk:FREQuency {value} | IAgInfiniiVisionWaveGenTracking.FrequencyEnabled
:WGEN{rcindex+1}:TRACk:FREQuency? | IAgInfiniiVisionWaveGenTracking.FrequencyEnabled
:WGEN{rcindex+1}:TRACk:PHASe {value} | IAgInfiniiVisionWaveGen2Tracking2.Phase
:WGEN{rcindex+1}:TRACk:PHASe? | IAgInfiniiVisionWaveGen2Tracking2.Phase
:WGEN{rcindex+1}:TRACk? | IAgInfiniiVisionWaveGenTracking.Enabled
:WGEN{rcindex+1}:VOLTage {value} | IAgInfiniiVisionWaveGen.Amplitude
:WGEN{rcindex+1}:VOLTage:HIGH {value} | IAgInfiniiVisionWaveGen.HighVoltage
:WGEN{rcindex+1}:VOLTage:HIGH? | IAgInfiniiVisionWaveGen.HighVoltage
:WGEN{rcindex+1}:VOLTage:LOW {value} | IAgInfiniiVisionWaveGen.LowVoltage
:WGEN{rcindex+1}:VOLTage:LOW? | IAgInfiniiVisionWaveGen.LowVoltage
:WGEN{rcindex+1}:VOLTage:OFFSet {value} | IAgInfiniiVisionWaveGen.OffsetVoltage
:WGEN{rcindex+1}:VOLTage:OFFSet? | IAgInfiniiVisionWaveGen.OffsetVoltage
:WGEN{rcindex+1}:VOLTage? | IAgInfiniiVisionWaveGen.Amplitude
:WMEMory{WaveformLocation}:CLEar | IAgInfiniiVisionReferenceWaveform.Clear
:WMEMory{WaveformLocation}:DISPlay {DisplayState} | IAgInfiniiVisionReferenceWaveform.Enable
:WMEMory{WaveformLocation}:DISPlay? | IAgInfiniiVisionReferenceWaveform.IsEnabled
:WMEMory{WaveformLocation}:LABel "{Label}" | IAgInfiniiVisionReferenceWaveform.SetLabel
:WMEMory{WaveformLocation}:LABel? | IAgInfiniiVisionReferenceWaveform.GetLabel
:WMEMory{WaveformLocation}:SAVE {Source} | IAgInfiniiVisionReferenceWaveform.Save
:WMEMory{WaveformLocation}:SKEW {Skewfactor} | IAgInfiniiVisionReferenceWaveform.SetSkewFactor
:WMEMory{WaveformLocation}:SKEW? | IAgInfiniiVisionReferenceWaveform.GetSkewFactor
:WMEMory{WaveformLocation}:YOFFset {OffsetValue} | IAgInfiniiVisionReferenceWaveform.SetOffset
:WMEMory{WaveformLocation}:YOFFset? | IAgInfiniiVisionReferenceWaveform.GetOffset
:WMEMory{WaveformLocation}:YRANge {Range} | IAgInfiniiVisionReferenceWaveform.SetRange
:WMEMory{WaveformLocation}:YRANge? | IAgInfiniiVisionReferenceWaveform.GetRange
:WMEMory{WaveformLocation}:YSCale {VerticalScale} | IAgInfiniiVisionReferenceWaveform.SetVerticalScale
:WMEMory{WaveformLocation}:YSCale? | IAgInfiniiVisionReferenceWaveform.GetVerticalScale
Top


Errors and Warnings

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Errors and Warnings

Errors

Name | Value (Hex) | Value (Decimal) | Description
E_IVI_CANNOT_RECOVER | 0x80047000 | -2147192832 | Failure cannot recover.
E_IVI_INSTRUMENT_STATUS | 0x80047001 | -2147192831 | Instrument error detected. Use ErrorQuery() to determine error(s).
E_IVI_CANNOT_OPEN_FILE | 0x80047002 | -2147192830 | Cannot open file.
E_IVI_READING_FILE | 0x80047003 | -2147192829 | Error reading file.
E_IVI_WRITING_FILE | 0x80047004 | -2147192828 | Error writing file.
E_IVI_INVALID_PATHNAME | 0x8004700B | -2147192821 | The path name is invalid.
E_IVI_INVALID_VALUE | 0x80047010 | -2147192816 | Invalid value (%1) for method %2, parameter %3.
E_IVI_METHOD_NOT_SUPPORTED | 0x80047011 | -2147192815 | Does not support this class-compliant feature: method %1.
E_IVI_PROPERTY_NOT_SUPPORTED | 0x80047012 | -2147192814 | Does not support this class-compliant feature: property %1.
E_IVI_VALUE_NOT_SUPPORTED | 0x80047013 | -2147192813 | Does not support this class-compliant feature: (enumeration) value %1 passed as the value for parameter %2 in method %3.
E_IVI_NOT_INITIALIZED | 0x8004701D | -2147192803 | A connection to the instrument has not been established.
E_IVI_UNKNOWN_CHANNEL_NAME | 0x80047020 | -2147192800 | Unknown channel name.
E_IVI_TOO_MANY_OPEN_FILES | 0x80047023 | -2147192797 | Too many files are opened.
E_IVI_CHANNEL_NAME_REQUIRED | 0x80047044 | -2147192764 | A channel name is required.
E_IVI_MISSING_OPTION_NAME | 0x80047049 | -2147192759 | The option string is missing an option name.
E_IVI_MISSING_OPTION_VALUE | 0x8004704A | -2147192758 | The option string is missing an option value.
E_IVI_BAD_OPTION_NAME | 0x8004704B | -2147192757 | The %1 name in the option string is unknown.
E_IVI_BAD_OPTION_VALUE | 0x8004704C | -2147192756 | The %1 value in the option string is unknown.
E_IVI_OUT_OF_MEMORY | 0x80047056 | -2147192746 | Could not allocate necessary memory.
E_IVI_OPERATION_PENDING | 0x80047057 | -2147192745 | Operation in progress.
E_IVI_NULL_POINTER | 0x80047058 | -2147192744 | Null pointer passed for method %1, parameter %2.
E_IVI_UNEXPECTED_RESPONSE | 0x80047059 | -2147192743 | Unexpected response from the instrument.
E_IVI_FILE_NOT_FOUND | 0x8004705B | -2147192741 | File not found.
E_IVI_INVALID_FILE_FORMAT | 0x8004705C | -2147192740 | Invalid file format.
E_IVI_STATUS_NOT_AVAILABLE | 0x8004705D | -2147192739 | The instrument status is not available.
E_IVI_ID_QUERY_FAILED | 0x8004705E | -2147192738 | Instrument ID query failed.
E_IVI_RESET_FAILED | 0x8004705F | -2147192737 | Instrument reset failed.
E_IVI_RESOURCE_UNKNOWN | 0x80047060 | -2147192736 | Unknown resource.
E_IVI_ALREADY_INITIALIZED | 0x80047061 | -2147192735 | The driver is already initialized.
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | 0x80047062 | -2147192734 | The simulation state cannot be changed.
E_IVI_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0x80047063 | -2147192733 | The number of levels in the selector is not valid for the %1 repeated capability.
E_IVI_INVALID_RANGE_IN_SELECTOR | 0x80047064 | -2147192732 | The range %1 is not valid for the repeated capability %2.
E_IVI_UNKNOWN_NAME_IN_SELECTOR | 0x80047065 | -2147192731 | Unknown name in selector.
E_IVI_BADLY_FORMED_SELECTOR | 0x80047066 | -2147192730 | The repeated capability selector is badly-formed.
E_IVI_UNKNOWN_PHYSICAL_IDENTIFIER | 0x80047067 | -2147192729 | Unknown physical repeated capability selector.
E_IVISCOPE_CHANNEL_NOT_ENABLED | 0x80042001 | -2147213311 | Specified channel is not enabled.
E_IVISCOPE_UNABLE_TO_PERFORM_MEASUREMENT | 0x80042002 | -2147213310 | Unable to perform desired measurement operation.
E_IVISCOPE_MAX_TIME_EXCEEDED | 0x80042003 | -2147213309 | Maximum time exceeded before the operation completed.
E_IVISCOPE_INVALID_ACQ_TYPE | 0x80042004 | -2147213308 | Invalid acquisition type.
E_AGINFINIIVISION_INVALID_PARAMETER | 0x800440DC | -2147204900 | Invalid parameter Value.
E_AGINFINIIVISION_HARDWARE_MISSING | 0x800440F1 | -2147204879 | Feature is unavailable or unlicensed.
E_AGINFINIIVISION_INVALID_MEASUREMENT_SOURCE | 0x8004420E | -2147204594 | Invalid Measurement Source
E_AGINFINIIVISION_PERSONALITY_NOT_ACTIVE | 0x80044211 | -2147204591 | Personality is not active.
E_AGINFINIIVISION_PERSONALITY_NOT_INSTALLED | 0x80044212 | -2147204590 | Personality is not installed.
E_AGINFINIIVISION_PERSONALITY_NOT_LICENSED | 0x80044213 | -2147204589 | Personality is not licensed.
E_AGINFINIIVISION_IO_GENERAL | 0x80044214 | -2147204588 | I/O error: %1.
E_AGINFINIIVISION_IO_TIMEOUT | 0x80044215 | -2147204587 | I/O timeout error: %1.
E_AGINFINIIVISION_MODEL_NOT_SUPPORTED | 0x80044216 | -2147204586 | Instrument model does not support this feature: %1.
E_AGINFINIIVISION_SETTINGS_CONFLICT | 0x80044217 | -2147204585 | Settings Conflict
E_AGINFINIIVISION_OPTION_NOT_PRESENT | 0x80044218 | -2147204584 | Option not present
E_AGINFINIIVISION_BAD_PATTERN | 0x8004421C | -2147204580 | Bad Pattern
E_AGINFINIIVISION_NO_DATA_FOR_OPERATION | 0x8004421E | -2147204578 | No Data for operation.
Top

Warnings

Name | Value (Hex) | Value (Decimal) | Description
S_IVI_SUCCESS | 0x0 | 0 | Success.
S_IVI_NSUP_ID_QUERY | 0x47065 | 290917 | ID Query is not supported by this instrument.
S_IVI_NSUP_RESET | 0x47066 | 290918 | Reset is not supported by this instrument.
S_IVI_NSUP_SELF_TEST | 0x47067 | 290919 | Self test is not supported by this instrument.
S_IVI_NSUP_ERROR_QUERY | 0x47068 | 290920 | Error query is not supported by this instrument.
S_IVI_NSUP_REV_QUERY | 0x47069 | 290921 | Firmware revision query is not supported by this instrument.
S_IVISCOPE_INVALID_WFM_ELEMENT | 0x42001 | 270337 | One of the elements in the waveform array is invalid.
Top


AgInfiniiVision IVI-C Driver

AgInfiniiVision IVI-C Driver

The AgInfiniiVision driver includes a fully compliant IVI-C driver. The topics in this section detail how to perform specific programming tasks using the IVI-C functionality available with the AgInfiniiVision driver.

In This Section

Initializing the IVI-C Driver

Presents the steps required to properly initialize the IVI-C driver.

Accessing Instrument-Specific Functionality

Explains how to access the specialized functionality of the AgInfiniiVision driver.

Using Simulation

Provides information on using the simulation capabilities of the driver.

Programming with the IVI-C Driver in Various Development Environment

Demonstrates how the AgInfiniiVision driver can be used in a various application development environments (ADEs).

Reference

Presents reference documentation for each IVI-C function and attribute.


Initializing the IVI-C Driver

Initializing the IVI-C Driver

There are two basic ways to initialize the IVI-C driver -- invoking the Initialize function directly on the specific driver and using an IVI-C class driver. If the client application is to be interchangeable, then the appropriate class driver must be used. Class drivers require that the first parameter passed to the Initialize function be a logical name for the driver. Instantiating the driver by name keeps the client program from having any dependencies on a specific driver and enables the application to be interchangeable.

If interchangeability is not necessary for a particular client application, it is often simpler to initialize the IVI-C driver directly. This avoids the need for obtaining an IVI-C class driver from a 3rd-party vendor (since the IVI Foundation does not develop or distribute IVI-C class drivers). When using the specific driver directly, the client application will necessarily have references to the specific driver (through the use of the "AgInfiniiVision" in function call names and by directly references AgInfiniiVision.h and AgInfiniiVision.lib); For many applications, this is perfectly acceptable.

The examples below in the section describing the Initialize function will present both techniques for initializing an IVI-C driver.

Calling the Initialize Function

The IVI-defined Initialize and Initialize With Options functions offer a variety of options and parameters that control fundamental aspects of the driver's behavior. It is critical to understand what options are available and how they impact driver operation.

ResourceName

The resource name parameter can be a logical name present in the IVI Configuration Store or a physical resource descriptor. If the ResourceName is a logical name, then additional options stored in the IVI Configuration Store will be loaded and processed. This allows client code to reuse driver option settings and to keep the driver code as concise as possible, by removing settings that can be stored in the IVI Configuration Store. It is important to note that any parameters or options passed directly to the Initialize function via the OptionString parameter (discussed below) override any settings found in the IVI Configuration Store.

IdQuery

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that is supported by the driver. If the model is not supported, Initialize will fail with the IVI_ERROR_ID_QUERY_FAILED error code.

Reset

If this is enabled, the driver will perform a reset of the instrument. If the reset fails, Initialize will fail with the IVI_ERROR_RESET_FAILED error code.

OptionString

The OptionString allows the user to pass optional settings to the driver. These settings override any settings that are specified in the IVI Configuration Store. If the IVI Configuration Store is not used (a resource descriptor is passed as the ResourceName instead of a logical name) then any setting that is not specified has a default value as specified by IVI.

Option Name | Description | Default
QueryInstrStatus | Specifies whether the IVI specific driver queries the instrument status at the end of each user operation. Querying the instrument status is very useful for debugging. After validating the program, the user can set this attribute to False to disable status checking and maximize performance. The user specifies this value for the entire IVI driver session. | false
Simulate | Specifies whether or not the IVI specific driver simulates instrument driver I/O operations. If simulation is enabled, the specific driver functions do not perform instrument I/O. For output parameters that represent instrument data, the specific driver functions return simulated values. | false
Cache | Specifies whether or not to cache the value of attributes. When caching is enabled, the IVI specific driver keeps track of the current instrument settings so that it can avoid sending redundant commands to the instrument. | true
InterchangeCheck | Specifies whether the IVI specific driver performs interchangeability checking. If the Interchange Check attribute is enabled, the specific driver maintains a record of each interchangeability warning that it encounters. The user calls the Get Next Interchange Warning function to extract and delete the oldest interchangeability warning from the list. | false
RangeCheck | Specifies whether the IVI specific driver validates attribute values and function parameters. If enabled, the specific driver validates the parameter values that users pass to driver functions. Validating attribute values and function parameters is useful for debugging. After validating the program, the user can set this attribute to False to disable range checking and maximize performance. | true
RecordCoercions | Specifies whether the IVI specific driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the Record Value Coercions attribute is enabled, the specific driver maintains a record of each coercion. The user calls the Get Next Coercion Record function to extract and delete the oldest coercion record from the list. | false
DriverSetup | Specifies additional settings supported by the driver, but not defined by IVI. | ""

DriverSetup

This is used to specify settings that are supported by the driver but not defined by IVI. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following 'DriverSetup=' is part of the assignment. The following settings are supported by the AgInfiniiVision driver.

Option Name | Description | Values
Model | Instrument model to use during simulation. | Any model supported by the driver
Trace | Output trace log of all driver calls to an XML file in the same directory as the application executable accessing the driver. | true, false
TraceName

If specified, an XML trace file of the specified name is created each time the driver is initialized with tracing enabled. It is not necessary to include the .xml extension with the name.

If not specified, tracing generates a unique XML trace file name based on the date and time. A new file is created each time the driver is initialized with tracing enabled.

String name
TraceArray | Specifies if array parameters should be traced. | true, false
TraceSizeMax | Specifies the maximum size of the trace log file in bytes. Once the file reaches this size, tracing will be turned off automatically by the driver. The default value is 1000000. | Numeric value in bytes
TraceArraySizeMax | Specifies the maximum number of elements to trace for array parameters. The default value is 10. | Numeric value in elements
TraceSaveInterval | Specifies how often the driver should save trace data to the trace log file. The value is specified in minutes. The default value is 1. | Numeric value in minutes

Example 1 -- Initializing with an IVI-C Class Driver

The following code initializes the driver with default options.

C++ Copy Code Copy Code
#include "IviScope.h" // Class Driver header file

void main()
{
  ViStatus status;
  ViSession session;

  // Initialize the driver using the IviScope session factory.
  // This code is interchangeable since no reference to the specific driver exists.
  // IdQuery and Reset options are enabled.
  status = IviScope_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  // ... call IviScope class driver functions

  status = IviScope_close(session);
}

Example 2 (simulation) -- Direct Driver Access

The following code initializes the driver in simulation mode and specifies the model to simulate.

C++ Copy Code Copy Code
#include "AgInfiniiVision.h" // Specific driver header file

void main()
{
  ViStatus status;
  ViSession session;

  // Initialize the driver in simulation mode.  Resource name is ignored when Simulate=true.
  // IdQuery and Reset options are enabled.
  status = AgInfiniiVision_InitWithOptions("GPIB0::13::INTR", VI_TRUE, VI_TRUE, "Simulate=true, DriverSetup= Model=DSO-X 2002A", &session);

  // ... call AgInfiniiVision driver functions

  status = AgInfiniiVision_close(session);
}


Writing Interchangeable Code Using an IviScope Class Driver

Writing Interchangeable Code Using an IviScope Class Driver

A class driver is an implementation of the IVI-defined C API for a particular instrument class. The class driver delegates to the appropriate specific driver based upon the logical name passed to the init or InitWithOptions functions. All functions in the class driver begin with the class name ("IviScope" in this case). Since an instrument-independent logical name is used to identify the specific driver and since the function calls have no instrument-specific references, code written using the IVI-C class driver is interchangeable. For more information, see the topic: How IVI Drivers Provide Interchangeability

IVI-C Class Driver Availability

An important consideration when programming with IVI-C drivers is that the IVI Foundation does not implement distribute class drivers. Member companies of the IVI Foundation provide class drivers as products. In order to program interchangeably with IVI-C drivers, you must obtain the appropriate IVI-C Class Driver from a 3rd party vendor.

IVI-C Class Driver Usage

Because a class driver delegates to a specific driver, it is necessary to initialize the class driver using a Logical Name setup in the IVI Configuration Store. This tells the class driver which specific driver is to be used. The class driver loads the appropriate specific driver and delegates all function calls to it.

IviScope Class Driver Programming Example

This example uses the an IviScope class driver to communicate with an instrument in an interchangeable manner. Note that the specific driver is not referenced at all in the client program. Also note that the IviScope.h file is not installed by the driver. It is available with the class driver from 3rd party.

C++ Copy Code Copy Code
#include "IviScope.h" // IviScope class driver header file
// Link to: <Program Files>\IVI Foundation\IVI\Lib\msc\IviDmm.lib

void main()
{
  ViStatus status;
  ViSession session;

  // Initialize the driver using a logical name
  status = IviScope_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  // Call IviScope class-compliant functions.
  // Example only.  See class driver help for actual function and attribute syntax.
  //status = IviScope_ConfigureTrigger(session, IVISCOPE_VAL_INTERNAL, 0.1);
  //status = IviScope_SetAttributeViInt32(session, VI_NULL, IVISCOPE_ATTR_TRIGGER_SLOPE, IVISCOPE_VAL_POSITIVE);

  // Close the session
  status = IviScope_close(session);
}

For more information, see the Advanced Topics, Interchangability section of the Getting Started Guide on the IVI Foundation website.


Accessing Repeated Capabilities

Accessing Repeated Capabilities

This page provides information on the supported repeated capabilities and repeated capability names for the AgInfiniiVision driver.

Repeated Capabilities

The AgInfiniiVision driver supports the following repeated capabilities:

  • Channel
  • Measurement
  • DigitalChannel
  • SerialBus
  • MathFunction
  • WaveGen

The following table provides detailed information on each repeated capability supported by the AgInfiniiVision driver.

For a detailed explanation of repeated capabilities, including repeated capability styles, physical names, and dynamic repeated capabilities, see the topic Repeated Capabilities.

Repeated Capability | IVI-C Style | Dynamic | Physical Names
Channel | Parameter | Yes |
Measurement | Parameter | Yes |
DigitalChannel | Parameter | Yes |
SerialBus | Parameter | Yes |
MathFunction | Parameter | Yes |
WaveGen | Parameter | Yes |


Accessing Instrument-Specific Functionality

Accessing Instrument-Specific Functionality

As the name implies, the instrument-specific capabilities are those methods and properties that are unique to the instrument. In practice, the instrument-specific portion of the driver exposes the full functionality of the instrument -- including functionality that may also be available in the class-compliant capabilities. Users that do not care about interchangeability or that need to access functionality that is not defined by IVI will use the instrument-specific interfaces in application programs.

When to use the instrument specific interfaces

  • When the required functionality is not exposed in the class-compliant interfaces.
  • When interchangeability is not a requirement.
  • When performance is critical. Sometimes a driver may perform better using the instrument specific interfaces because they match the instrument functionality more closely than the class-compliant interfaces.

Example

The following example demonstrates accessing instrument-specific function on the driver. Note that instrument-specific function calls are always prefixed with the instrument-specific prefix ("AgInfiniiVision"). In contrast, calls to IVI-defined class-compliant functions are prefixed with the IVI class name.

C++ Copy Code Copy Code
#include "AgInfiniiVision.h"
void main()
{
  ViStatus status;
  ViSession session;
  ViReal64 reading;

  status = AgInfiniiVision_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);
  status = AgInfiniiVision_ReadEx(session, 2000, 3, &reading);
  status = AgInfiniiVision_close(session);
}

Using both the class driver and specific driver

When programming against the class driver, it is possible to get access to the specific driver session that is used internally by the class driver. This allows the client program to talk directly to the specific driver.

Example

The following client code uses the class driver and the specific driver.

C++ Copy Code Copy Code
#include "AgInfiniiVision.h"
#include "IviDmm.h"
void main()
{
  ViStatus status;
  ViSession classSession;
  ViSession specificSession;
  ViReal64 reading;

  status = IviDmm_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &classSession);
  status = IviDmm_Read(classSession, 2000, &reading);

  // Get access to the specific driver session
  status = IviDmm_GetSpecificDriverCHandle(classSession, &specificSession);
  // Call the specific driver
  // ReadEx takes an additional parameter
  // This is available only from the specific driver
  status = AgInfiniiVision_ReadEx(specificSession, 2000, 3, &reading);

  status = IviDmm_close(classSession);
}


Using Simulation

Using Simulation

An IVI driver can operate without the presence of an actual instrument by using simulation mode. When simulation is turned on, the driver performs no instrument communication, but attempts to generate results which allow client applications to reasonably execute. You can turn on simulation using either of the following two techniques:

  • Passing the "simulate=VI_TRUE" option string parameter to the InitWithOptions function.
  • Setting the SIMULATE attribute to VI_TRUE.

The IVI-C driver contains a SIMULATE attribute. Note that you can turn simulation on, if you initialize a driver with it off. However, if you initialize an IVI-COM driver with simulation turned on, you will get an error (The simulation state cannot be changed) if you attempt to later turn it off. This is because you cannot initiate a live I/O session with an instrument after you have called the InitWithOptions function.

Using The Option String

The fourth and last parameter to the InitWithOptions function is the option string. See the help on InitWithOptions for more details. To turn simulation on with the option string, include the following in the option string:

simulate=VI_TRUE

For example, the InitWithOptions call might look like this:

AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "Simulate=VI_TRUE", &session);

When the simulate option is set VI_TRUE, the value of the resource descriptor parameter (the first parameter above) is ignored. This is because no I/O connection will be made with the instrument, as is required by IVI-3.1: Driver Architecture Specification.

The Driver Session Simulate Attribute

A DriverSession in the IVI Configuration Store contains properties for the same items which can be set with the option string parameter. The name of a DriverSession, or the name of a LogicalName which points to a DriverSession, can be used as the first parameter to InitWithOptions. If the SIMULATE attribute in the DriverSession is true, the driver is initialized in simulation mode.

Changing the Instrument Model

Many drivers support more than one instrument model. Drivers will typically select one of these as the default model by creating a special type of entry in the IVI Configuration Store known as a Configurable Initial Settings. You can modify the Model value in the Configurable Initial Settings for the DriverSession of interest, or you can simply specify the model to simulate at runtime during the call to Initialize.

To have the driver simulate a specific model of your choosing, simply add the desired model to the DriverSetup string using the following special syntax:

Simulate=VI_TRUE, DriverSetup=Model=DSO-X 2002A

The complete InitWithOptions call becomes:

AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "Simulate=VI_TRUE, DriverSetup= Model=DSO-X 2002A", &session);

If you set the model to a value not supported by the driver, the driver reports an error.

Limitations of Simulation

Simulation is designed to allow the driver to be used without an instrument or any I/O software or hardware. However, simulation is not intended to fully emulate the instrument. There are some important differences you should be aware of:

  • Many instruments have status systems, and these are not live. For instance, you can set Enable and Transition registers but queries of Condition and Event registers will always return a fixed value, which is usually zero.
  • There often is no parameter range checking or coercion unless done in the driver. Most drivers depend on the instrument to perform range checking and coercion of parameter values. In simulation mode, this will not occur. For example setting a frequency parameter to 1E99 will be accepted without error in simulation where an instrument would return a "parameter out of range" error.
  • AgInfiniiVision_error_query typically returns no error.
  • Measurement data is not live. Most data queries will return a fixed value or a small array of values.


Programming the IVI-C Driver in Various Development Environments

Programming with the IVI-C Driver in Various Development Environments

IVI-C drivers are implemented using standard Windows DLL technology. Consequently, IVI-C drivers can be used in a wide variety of development environments.

The topics in this section provide detailed instructions on how to access and use IVI-C drivers in a variety of popular development environments. Each topic includes a complete example of IVI-C driver usage.

In This Section

Using LabWindows/CVI

Explains how to use the IVI-C driver in National Instruments LabWindows/CVI.

Using LabVIEW

Provides instructions on how to use the IVI-C driver in National Instruments LabVIEW.

Using Visual C++

Describes the process for including an IVI-C driver in a Visual C++ project.

Using .NET

Explains how to use the driver in .NET languages, such as VB.NET and C#.

Using MATLAB

Presents information on using the driver with MATLAB.

Using Simulation

Presents information on using the simulation capabilities of the driver.


Using LabWindows/CVI

Using LabWindows/CVI

This section describes how to use the AgInfiniiVision IVI-C driver from LabWindows/CVI.

Adding the Instrument Driver to the Project

In order to access any of the driver functions, the proper header file (.h) must be included in the project and the proper import library (.lib) must be referenced. LabWindows can automatically reference these files given the location of the function panel file (.fp). The sections below explain the steps required to add the instrument driver to a LabWindows project based on the .fp file.

All IVI-C driver programs must do the following:

  • #include "AgInfiniiVision.h"
  • Link to AgInfiniiVision.lib
  • Prefix function calls with "AgInfiniiVision_"

To use the AgInfiniiVision specific driver, perform the following steps in LabWindows.

  1. From the Edit menu, choose Add Files to Project... and select Instrument (.fp).
  2. Browse to the location of the AgInfiniiVision.fp file. The .fp file is installed in the "Drivers\AgInfiniiVision" folder of your IVI installation folder. Typically this will be something like the following:
    "C:\Program Files\IVI Foundation\IVI\Drivers\AgInfiniiVision"
  3. LabWindows adds the driver to your project and loads it automatically.

Initializing the Driver

Calling AgInfiniiVision_InitWithOptions will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling AgInfiniiVision_close at the end of your program is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if close is not called.

For more details on initializing the driver, see the topic: Initializing the Driver

Initializing Using a Resource Descriptor

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy Code Copy Code
ViSession session;
ViStatus status;
status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
status = AgInfiniiVision_close(session);

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on initializing the driver, see the topic:Initializing the Driver

C++ Copy Code Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
ViBoolean idQuery = VI_FALSE;

// If true, the instrument is reset at initialization
ViBoolean reset = VI_FALSE;

// Setup IVI-defined initialization options
ViConstString standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", idQuery, reset, standardInitOptions, &session);
status = AgInfiniiVision_close(vi);

Accessing Attributes

Accessing attributes in an IVI-C driver is accomplished via a set of IVI-defined accessor functions. There are two accessor functions for each attribute type -- one accessor for reading attribute values and another accessor for writing attribute values.

The standard attribute accessors for reading attribute values are:

  • GetAttributeViInt32
  • GetAttributeViInt64
  • GetAttributeViReal64
  • GetAttributeViBoolean
  • GetAttributeViString

Correspondingly, the standard attribute accessors for writing attribute values are:

  • SetAttributeViInt32
  • SetAttributeViInt64
  • SetAttributeViReal64
  • SetAttributeViBoolean
  • SetAttributeViString

Each attribute accessor takes an attribute ID that uniquely identifies the attribute to access. These attribute IDs are #define'd constants listed in the AgInfiniiVision.h header file and documented in the "Attributes by Name" section of the help file.. The following example demonstrates basic usage of attribute accessors to read and write IVI-C driver attribute values.

The following code is for illustration only and may not apply directly to this driver.

C++ Copy Code Copy Code
ViStatus status;

// Set the value of an attribute
status = AgInfiniiVision_SetAttributeViReal64(vi, VI_NULL, AGINFINIIVISION_ATTR_FREQ_VOLTAGE_RANGE, 20.0);

// Get the value of a property
ViReal64 voltageRange;
status = AgInfiniiVision_GetAttributeViReal64(vi, VI_NULL, AGINFINIIVISION_ATTR_FREQ_VOLTAGE_RANGE, &voltageRange);

// Set the value of a property (enum)
// Note use of the #define'd constant for the attribute value
status = AgInfiniiVision_SetAttributeViInt32(vi, VI_NULL, AGINFINIIVISION_ATTR_TEMP_TRANSDUCER_TYPE, AGINFINIIVISION_VAL_THERMOCOUPLE);

Complete Example

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

C++ Copy Code Copy Code
#include "AgInfiniiVision.h"

int main (int argc, char *argv[])
{
  ViSession session;
  ViStatus status;
  ViChar str[128];
  ViInt32 ErrorCode;
  ViChar ErrorMessage[256];

  // Initialize the driver
  status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
  if(status)
  {
    // Initialization failed
    AgInfiniiVision_GetError(session, &ErrorCode, 255, ErrorMessage);
    printf("** InitWithOptions() Error: %d, %s\n", ErrorCode, ErrorMessage);
    printf("\nDone - Press Enter to Exit");
    getchar();
    return;
  }
  printf("Driver Initialized \n");

  // Read and output a few attributes
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX, 127, str);
  printf("DRIVER_PREFIX:      %s\n", str);
  status = AgInfiniiVisionl_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION, 127, str);
  printf("DRIVER_REVISION:    %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR, 127, str);
  printf("DRIVER_VENDOR:      %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION, 127, str);
  printf("DRIVER_DESCRIPTION: %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_INSTRUMENT_MODEL, 127, str);
  printf("INSTRUMENT_MODEL:   %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION, 127, str);
  printf("FIRMWARE_REVISION:  %s\n", str);

  // TODO: Exercise driver functions and attributes

  // Check instrument for errors
  ErrorCode = 1;
  printf("\n");
  while(ErrorCode)
  {
    status = AgInfiniiVision_error_query( session, &ErrorCode, ErrorMessage);
    printf("error_query: %d, %s\n", ErrorCode, ErrorMessage);
  }

  // Close the session
  status = AgInfiniiVision_close(session);
  if(status)
  {
    AgInfiniiVision_GetError(session, &ErrorCode, 255, ErrorMessage);
    printf("** Close() Error: %d, %s\n", ErrorCode, ErrorMessage);
  }
  else
    printf("Driver Closed \n");
}

Writing Interchangeable Code using an IviScope Class Driver

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability

Note: In order to write an interchangeable application, an IVI-C, IviScope class driver must be used in conjunction with this driver. You must install a 3rd-party IVI-C Class Driver to do so.

Adding the Instrument Driver to the Project

To modify the example code in this topic for use with an IviScope class driver, make the following substitutions:

  • Include IviScope.h instead of AgInfiniiVision.h.
  • Link to IviScope.lib instead of AgInfiniiVision.lib.
  • Prefix IVI Class function calls with "IviScope_" instead of "AgInfiniiVision_".
  • Prefix IVI Class attribute names with "IVISCOPE_" instead of "AGINFINIIVISION_".
  • For more information, please refer to Writing Interchangeable Code Using an IviScope Class Driver section.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

LabWindows/CVI Copy Code Copy Code
ViSession session;
ViStatus status;
status = IviScope_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);
status = IviScope_close(session);

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using LabVIEW

Using LabVIEW

LabVIEW provides rich support for accessing both IVI-COM and IVI-C drivers. The best mechanism to use depends upon a few factors, such as whether interchangeability is required and/or if access to instrument-specific functionality is desired. This topic explains the options available.

Using the LabVIEW Class Driver VIs

LabVIEW provides IVI Class Driver VIs that can be used to write interchangeable IVI applications. If interchangeability is the overriding requirement or if only the IVI-defined functions are needed in an application, then using the LabVIEW IVI Class Driver VIs is the preferred way to access the AgInfiniiVision driver in LabVIEW. These VIs are located on the Functions palette under Instrument I/O -> IVI Class Drivers. You can use these VIs to load and access the underlying AgInfiniiVision IVI-C driver.

Please see the National Instruments documentation for more details on using the IVI Class Driver VIs.

Using the LabVIEW Instrument Driver Import Wizard

National Instruments provides the LabVIEW Instrument Driver Import Wizard as a means to convert an IVI-C driver into a series of classic LabVIEW VIs arranged in standard LabVIEW menu palettes. This utility is not installed with the LabVIEW product, but it is freely available as a separate download from the National Instruments website. Unlike the IVI Class Driver VIs which only provide access to IVI-defined functions, the VIs produced by this utility provide access to the driver's instrument-specific functions. If interchangeability is not a requirement, then the LabVIEW Instrument Driver Import Wizard is a viable option.

Using the LabVIEW Class Browser

Although the import wizard produces convenient wrapper VIs for accessing the AgInfiniiVision driver, it has some important shortcomings that should be considered when designing a LabVIEW application with IVI drivers. First, the import wizard only generates wrapper VIs for accessing IVI driver functions -- no VIs are generated for any driver attributes. Since IVI drivers typically contain more attributes than functions, this means that most of the IVI driver functionality will not be accessible via the VIs produced by the import wizard. To access the attributes of the AgInfiniiVision driver, the LabVIEW Property Node must be used.

Another disadvantage of using the import wizard is that it generates VIs that unnecessarily call into the AgInfiniiVision driver through the IVI-C interface instead of the native IVI-COM interface. LabVIEW provides a very convenient tool called the Class Browser for accessing the IVI-COM driver directly. This avoids the overhead of going through the IVI-C wrapper layer, and, unlike the import wizard VIs, it can be used to access functions and attributes. Also unlike the import wizard which is a separate download utility, the Class Browser is a standard feature of LabVIEW.

For these reasons, it is generally preferable to use the Class Browser feature in lieu of the import wizard when accessing instrument-specific functionality. For details on using the Class Browser to access the AgInfiniiVision driver, please see the IVI-COM topic Using LabVIEW.


Using Visual C++

Using Visual C++

This section describes how to use the AgInfiniiVision IVI-C driver from Visual C++.

Referencing the Driver

In order to access any of the driver functions, the proper header file (.h) must be included in the project and the proper import library (.lib) must be referenced. This section demonstrates usage of the driver using instrument-specific references.

All IVI-C driver programs must do the following:

  • #include "AgInfiniiVision.h"
  • Link to AgInfiniiVision.lib
  • Prefix function calls with "AgInfiniiVision_"

To use the AgInfiniiVision specific driver, perform the following steps in Visual Studio.

  1. In solution explorer, right-click on the project and choose Properties.
  2. In the property pages dialog, expand the Linker node and select Input.
  3. In the Additional Dependencies field, enter "AgInfiniiVision.lib".
  4. Click OK.
  5. In the main application source file (.cpp), add the following line to the top of the file:

    #include "AgInfiniiVision.h"

Visual Studio must know the path to your driver's library (.lib) and header (.h) files. You can enter the following paths using the Tools, Options, Projects and Solutions, VC++ Directories dialog.

For Include Files (Win32 & x64) add: C:\Program Files (x86)\IVI Foundation\IVI\Include
For Library Files (Win32) add: C:\Program Files (x86)\IVI Foundation\IVI\Lib_\msc
For Library Files (x64) add: C:\Program Files (x86)\IVI Foundation\IVI\Lib_x64\msc
Note: For 32 bit operating systems paths start with: C:\Program Files\

Alternately, these paths may be entered in the Project Properties dialog, Configuration Properties, C++ and Linker panes.

Initializing the Driver

Calling AgInfiniiVision_InitWithOptions will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling AgInfiniiVision_close at the end of your program is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if close is not called.

For more details on initializing the driver, see the topic: Initializing the Driver

The driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy Code Copy Code
ViSession session;
ViStatus status;
status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
status = AgInfiniiVision_close(session);

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on initializing the driver, see the topic: Initializing the Driver

C++ Copy Code Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
ViBoolean idQuery = VI_FALSE;

// If true, the instrument is reset at initialization
ViBoolean reset = VI_FALSE;

// Setup IVI-defined initialization options
ViConstString standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", idQuery, reset, standardInitOptions, &session);
status = AgInfiniiVision_close(vi);

Accessing Attributes

Accessing attributes in an IVI-C driver is accomplished via a set of IVI-defined accessor functions. There are two accessor functions for each attribute type -- one accessor for reading (Get) attribute values and another accessor for writing (Set) attribute values.

The standard attribute accessors for reading attribute values are:

  • GetAttributeViInt32
  • GetAttributeViInt64
  • GetAttributeViReal64
  • GetAttributeViBoolean
  • GetAttributeViString

Correspondingly, the standard attribute accessors for writing attribute values are:

  • SetAttributeViInt32
  • SetAttributeViInt64
  • SetAttributeViReal64
  • SetAttributeViBoolean
  • SetAttributeViString

Each attribute accessor takes an attribute ID that uniquely identifies the attribute to access. These attribute IDs are #define'd constants listed in the AgInfiniiVision.h header file and documented in the "Attributes by Name" section of the help file.. The following example demonstrates basic usage of attribute accessors to read and write IVI-C driver attribute values.

The following code is for illustration only and may not apply directly to this driver.

C++ Copy Code Copy Code
ViStatus status;

// Set the value of an attribute
status = AgInfiniiVision_SetAttributeViReal64(vi, VI_NULL, AGINFINIIVISION_ATTR_VOLTAGE_RANGE, 20.0);

// Get the value of a property
ViReal64 voltageRange;
status = AgInfiniiVision_GetAttributeViReal64(vi, VI_NULL, AGINFINIIVISION_ATTR_VOLTAGE_RANGE, &voltageRange);

// Set the value of a property (enum)
// Note use of the #define'd constant for the attribute value
status = AgInfiniiVision_SetAttributeViInt32(vi, VI_NULL, AGINFINIIVISION_ATTR_TEMP_TRANSDUCER_TYPE, AGINFINIIVISION_VAL_THERMOCOUPLE);

Complete Example

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Keysight Instrument Drivers, IVI-COM-C Drivers, AgInfiniiVision, Examples

C++ Copy Code Copy Code
#include "AgInfiniiVision.h"

void main()
{
  ViSession session;
  ViStatus status;
  ViChar str[128];
  ViInt32 ErrorCode;
  ViChar ErrorMessage[256];

  // Initialize the driver
  status = AgInfiniiVision_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
  if(status)
  {
    // Initialization failed
    AgInfiniiVision_GetError(session, &ErrorCode, 255, ErrorMessage);
    printf("** InitWithOptions() Error: %d, %s\n", ErrorCode, ErrorMessage);
    printf("\nDone - Press Enter to Exit");
    getchar();
    return;
  }
  printf("Driver Initialized \n");

  // Read and output a few attributes
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX, 127, str);
  printf("DRIVER_PREFIX:      %s\n", str);
  status = AgInfiniiVisionl_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION, 127, str);
  printf("DRIVER_REVISION:    %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR, 127, str);
  printf("DRIVER_VENDOR:      %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION, 127, str);
  printf("DRIVER_DESCRIPTION: %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_INSTRUMENT_MODEL, 127, str);
  printf("INSTRUMENT_MODEL:   %s\n", str);
  status = AgInfiniiVision_GetAttributeViString(session, "", AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION, 127, str);
  printf("FIRMWARE_REVISION:  %s\n", str);

  // TODO: Exercise driver functions and attributes

  // Check instrument for errors
  ErrorCode = 1;
  printf("\n");
  while(ErrorCode)
  {
    status = AgInfiniiVision_error_query( session, &ErrorCode, ErrorMessage);
    printf("error_query: %d, %s\n", ErrorCode, ErrorMessage);
  }

  // Close the session
  status = AgInfiniiVision_close(session);
  if(status)
  {
    AgInfiniiVision_GetError(session, &ErrorCode, 255, ErrorMessage);
    printf("** Close() Error: %d, %s\n", ErrorCode, ErrorMessage);
  }
  else
    printf("Driver Closed \n");
}

Writing Interchangeable Code using an IviScope Class Driver

The following sections describe the differences from the above instructions when IVI Interchangeability is desired. Only the functionality of the IviScope class will be available. For an overview of IVI interchangeability see the topic: How IVI Drivers Provide Interchangeability

Note: In order to write an interchangeable application, an IVI-C, IviScope class driver must be used in conjunction with this driver. You must install a 3rd-party IVI-C Class Driver to do so.

Referencing the Driver

To modify the example code in this topic for use with an IviScope class driver, make the following substitutions:

  • Include IviScope.h instead of AgInfiniiVision.h.
  • Link to IviScope.lib instead of AgInfiniiVision.lib.
  • Prefix IVI Class function calls with "IviScope_" instead of "AgInfiniiVision_".
  • Prefix IVI Class attribute names with "IVISCOPE_" instead of "AGINFINIIVISION_".
  • For more information, please refer to Writing Interchangeable Code Using an IviScope Class Driver section.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party IVI Configuration Store Editor utility.

LabWindows/CVI Copy Code Copy Code
ViSession session;
ViStatus status;
status = IviScope_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);
status = IviScope_close(session);

For additional programming information see the Getting Started Guide on the IVI Foundation website.


Using .NET

Using .NET

There is no standard mechanism for accessing an IVI-C driver in .NET languages. Though the Microsoft .NET framework provides the [DllImport] attribute as a means to access any DLL function, its use is not standardized within IVI and it is very tedious and error prone in practice.

However, since the AgInfiniiVision driver is built upon an IVI-COM core driver, the best way to access the driver from .NET languages is via the .NET interop assembly provided with the driver. The interop assemblies directly accesses the IVI-COM driver (bypassing the IVI-C wrapper layer) and provide a way to author interchangeable .NET applications as well as instrument-specific applications that utility specialized driver features.

For details on using the AgInfiniiVision driver in .NET applications, see the IVI-COM topic Using C#.


Using MATLAB

Using MATLAB

Although MATLAB provides support for accessing conventional Windows DLLs, such as IVI-C drivers, the AgInfiniiVision driver includes a MATLAB wrapper that provides the most convenient way to access the AgInfiniiVision driver. This wrapper directly accesses the underlying IVI-COM core driver, so the overhead of going through the AgInfiniiVision driver's IVI-C wrapper layer is avoided.

For details on using the AgInfiniiVision driver in MATLAB, please see the IVI-COM topic Using MATLAB.


IVI-C Reference

IVI-C Reference

The topics in this section document each function and attribute exposed from the IVI-C driver. Functions and attributes are presented in a hierarchical function tree as well as in a flat list by name.

In This Section

Hierarchy

Presents a hierarchical view of all driver functions and attributes.

Functions and Attributes

Displays the IVI-C functions and attributes together in a flat list.

Functions By Name

Lists all IVI-C functions sorted alphabetically by name.

Attributes By Name

Lists all IVI-C attributes sorted alphabetically by name.

Errors and Warnings

Presents all driver errors and warnings ordered by error code.


AgInfiniiVision

AgInfiniiVision
See Also

Tree Node: \AgInfiniiVision

Branches

Name
Acquisition
Attribute Accessors
Channel
Configuration
Inherent IVI Attributes
Instrument Specific
Trigger
Utility
Waveform Acquisition
Waveform Measurement
Top

Functions

 | Name | Description
Function | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | Initialize With Options | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Top

See Also

Reference

AgInfiniiVision


Acquisition

Acquisition
See Also

Tree Node: \AgInfiniiVision\Acquisition

Attributes

 | Name | Description
Attribute | Acquisition Start Time | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | Acquisition Type | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
Attribute | Horizontal Minimum Number of Points | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Attribute | Horizontal Record Length | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.
Attribute | Horizontal Sample Rate | The effective digitizing rate using the current configuration. The units are samples per second.
Attribute | Horizontal Time Per Record | The time in seconds that corresponds to the record length.
Attribute | Initiate Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Attribute | Interpolation | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Attribute | Number of Averages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Attribute | Number of Envelopes | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Attribute | Sample Mode | The sample mode the oscilloscope is currently using.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ACQUISITION_START_TIME Attribute

AGINFINIIVISION_ATTR_ACQUISITION_START_TIME Attribute
Acquisition See Also

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Acquisition Start Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ACQUISITION_START_TIME 1250109

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ACQUISITION_START_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_ACQUISITION_TYPE Attribute

AGINFINIIVISION_ATTR_ACQUISITION_TYPE Attribute
Acquisition See Also

How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Acquisition Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ACQUISITION_TYPE 1250101

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ACQUISITION_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_NORMAL | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
AGINFINIIVISION_VAL_PEAK_DETECT | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record. The oscilloscope uses only real-time sampling.
AGINFINIIVISION_VAL_HI_RES | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record. The oscilloscope uses only real-time sampling.
AGINFINIIVISION_VAL_ENVELOPE | Sets the oscilloscope to the envelope acquisition mode. The oscilloscope acquires multiple waveforms and keeps the minimum and maximum voltages it acquires for each point in the waveform record.
AGINFINIIVISION_VAL_AVERAGE | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record.
Top

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS Attribute

AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS Attribute
Acquisition See Also

The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Horizontal Minimum Number of Points
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS 1250009

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH Attribute

AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH Attribute
Acquisition See Also

The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Horizontal Record Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH 1250008

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE Attribute

AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE Attribute
Acquisition See Also

The effective digitizing rate using the current configuration. The units are samples per second.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Horizontal Sample Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE 1250010

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD Attribute

AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD Attribute
Acquisition See Also

The time in seconds that corresponds to the record length.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Horizontal Time Per Record
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD 1250007

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS Attribute

AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS Attribute
Acquisition See Also

If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Initiate Continuous
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS 1250107

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_INTERPOLATION Attribute

AGINFINIIVISION_ATTR_INTERPOLATION Attribute
Acquisition See Also

The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Interpolation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INTERPOLATION 1250019

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INTERPOLATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_NO_INTERPOLATION | The oscilloscope does not interpolate points in the waveform. Instead, the driver sets every element in the waveform record for which the oscilloscope cannot receive a value to an IEEE-defined NaN (Not-a-Number) value.
AGINFINIIVISION_VAL_SINE_X | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.
AGINFINIIVISION_VAL_LINEAR | The oscilloscope uses a linear approximation to interpolate a value when it cannot resolve a voltage in the waveform record.
Top

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_NUM_AVERAGES Attribute

AGINFINIIVISION_ATTR_NUM_AVERAGES Attribute
Acquisition See Also

The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Number of Averages
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_NUM_AVERAGES 1250104

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_NUM_AVERAGES.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_NUM_ENVELOPES Attribute

AGINFINIIVISION_ATTR_NUM_ENVELOPES Attribute
Acquisition See Also

The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope

Attribute Tree Node: \AgInfiniiVision\Acquisition\Number of Envelopes
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_NUM_ENVELOPES 1250105

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_NUM_ENVELOPES.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_SAMPLE_MODE Attribute

AGINFINIIVISION_ATTR_SAMPLE_MODE Attribute
Acquisition See Also

The sample mode the oscilloscope is currently using.

Attribute Tree Node: \AgInfiniiVision\Acquisition\Sample Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SAMPLE_MODE 1250106

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SAMPLE_MODE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_REAL_TIME | Indicates that the oscilloscope is using real-time sampling.
AGINFINIIVISION_VAL_EQUIVALENT_TIME | Indicates that the oscilloscope is using equivalent time sampling.
Top

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


Attribute Accessors

Attribute Accessors
See Also

Tree Node: \AgInfiniiVision\Attribute Accessors

Functions

 | Name | Description
Function | GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetAttributeViBoolean Function

AgInfiniiVision_GetAttributeViBoolean Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViBoolean
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_GetAttributeViInt32 Function

AgInfiniiVision_GetAttributeViInt32 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViInt32
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_GetAttributeViInt64 Function

AgInfiniiVision_GetAttributeViInt64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViInt64
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_GetAttributeViReal64 Function

AgInfiniiVision_GetAttributeViReal64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViReal64
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_GetAttributeViSession Function

AgInfiniiVision_GetAttributeViSession Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViSession
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViSession(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViSession* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_GetAttributeViString Function

AgInfiniiVision_GetAttributeViString Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\GetAttributeViString
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViBoolean Function

AgInfiniiVision_SetAttributeViBoolean Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViBoolean
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViInt32 Function

AgInfiniiVision_SetAttributeViInt32 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViInt32
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViInt64 Function

AgInfiniiVision_SetAttributeViInt64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViInt64
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViReal64 Function

AgInfiniiVision_SetAttributeViReal64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViReal64
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViSession Function

AgInfiniiVision_SetAttributeViSession Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViSession
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViSession(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViSession AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


AgInfiniiVision_SetAttributeViString Function

AgInfiniiVision_SetAttributeViString Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgInfiniiVision\Attribute Accessors\SetAttributeViString
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgInfiniiVision


Channel

Channel
See Also

Tree Node: \AgInfiniiVision\Channel

Attributes

 | Name | Description
Attribute | Channel Count | The number of channels.
Attribute | Channel Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Attribute | Input Impedance | The input impedance of this channel. The units are ohms.
Attribute | Maximum Input Frequency | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Attribute | Probe Attenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Attribute | Probe Sense Value | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Attribute | Vertical Coupling | How the oscilloscope couples the input signal.
Attribute | Vertical Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | Vertical Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_COUNT Attribute

AGINFINIIVISION_ATTR_CHANNEL_COUNT Attribute
Channel See Also

The number of channels.

Attribute Tree Node: \AgInfiniiVision\Channel\Channel Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_COUNT 1050203

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_ENABLED Attribute

AGINFINIIVISION_ATTR_CHANNEL_ENABLED Attribute
Channel See Also

If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.

Attribute Tree Node: \AgInfiniiVision\Channel\Channel Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_ENABLED 1250005

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_INPUT_IMPEDANCE Attribute

AGINFINIIVISION_ATTR_INPUT_IMPEDANCE Attribute
Channel See Also

The input impedance of this channel. The units are ohms.

Attribute Tree Node: \AgInfiniiVision\Channel\Input Impedance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INPUT_IMPEDANCE 1250103

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INPUT_IMPEDANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY Attribute

AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY Attribute
Channel See Also

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.

Attribute Tree Node: \AgInfiniiVision\Channel\Maximum Input Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY 1250006

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_PROBE_ATTENUATION Attribute

AGINFINIIVISION_ATTR_PROBE_ATTENUATION Attribute
Channel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Attribute Tree Node: \AgInfiniiVision\Channel\Probe Attenuation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_PROBE_ATTENUATION 1250004

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_PROBE_ATTENUATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE Attribute

AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE Attribute
Channel See Also

The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

Attribute Tree Node: \AgInfiniiVision\Channel\Probe Sense Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE 1250108

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_VERTICAL_COUPLING Attribute

AGINFINIIVISION_ATTR_VERTICAL_COUPLING Attribute
Channel See Also

How the oscilloscope couples the input signal.

Attribute Tree Node: \AgInfiniiVision\Channel\Vertical Coupling
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_VERTICAL_COUPLING 1250003

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_VERTICAL_COUPLING.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_VERTICAL_OFFSET Attribute

AGINFINIIVISION_ATTR_VERTICAL_OFFSET Attribute
Channel See Also

The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Attribute Tree Node: \AgInfiniiVision\Channel\Vertical Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_VERTICAL_OFFSET 1250002

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_VERTICAL_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_VERTICAL_RANGE Attribute

AGINFINIIVISION_ATTR_VERTICAL_RANGE Attribute
Channel See Also

The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Attribute Tree Node: \AgInfiniiVision\Channel\Vertical Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_VERTICAL_RANGE 1250001

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AgInfiniiVision_close Function

AgInfiniiVision_close Function
AgInfiniiVision See Also

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Function Tree Node: \AgInfiniiVision\Close
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_close(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

AgInfiniiVision
AgInfiniiVision


Configuration

Configuration
See Also

Tree Node: \AgInfiniiVision\Configuration

Branches

Name
Acquisition
Channel
Configuration Information
Measurement
Trigger
Top

See Also

Reference

AgInfiniiVision


Acquisition

Acquisition
See Also

Tree Node: \AgInfiniiVision\Configuration\Acquisition

Functions

 | Name | Description
Function | Configure Acquisition Record | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Function | Configure Acquisition Type | This function configures how the oscilloscope acquires data and fills the waveform record.
Function | Configure Initiate Continuous | This function configures the oscilloscope to perform a continuous acquisition.
Function | Configure Interpolation | This function configures the interpolation method the oscilloscope uses when it cannot sample a voltage for a point in the waveform record.
Function | Configure Number of Averages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Function | Configure Number of Envelopes | This function configures the number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureAcquisitionRecord Function

AgInfiniiVision_ConfigureAcquisitionRecord Function
Acquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Acquisition Record
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureAcquisitionRecord(
    ViSession Vi,
    ViReal64 TimePerRecord,
    ViInt32 MinNumPts,
    ViReal64 AcquisitionStartTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

TimePerRecord

Specifies the time per record. This value sets the Horizontal Time Per Record property.

MinNumPts

Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.

AcquisitionStartTime

Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_ConfigureAcquisitionType Function

AgInfiniiVision_ConfigureAcquisitionType Function
Acquisition See Also

This function configures how the oscilloscope acquires data and fills the waveform record.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Acquisition Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureAcquisitionType(
    ViSession Vi,
    ViInt32 AcquisitionType
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

AcquisitionType

Specifies the manner in which the oscilloscope acquires data and fills the waveform record. The driver sets the Acquisition Type attribute to this value. See the attribute description for more information.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter AcquisitionType

Name | Description
AGINFINIIVISION_VAL_NORMAL | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
AGINFINIIVISION_VAL_PEAK_DETECT | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record. The oscilloscope uses only real-time sampling.
AGINFINIIVISION_VAL_HI_RES | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record. The oscilloscope uses only real-time sampling.
AGINFINIIVISION_VAL_ENVELOPE | Sets the oscilloscope to the envelope acquisition mode. The oscilloscope acquires multiple waveforms and keeps the minimum and maximum voltages it acquires for each point in the waveform record.
AGINFINIIVISION_VAL_AVERAGE | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record.
Top

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_ConfigureInitiateContinuous Function

AgInfiniiVision_ConfigureInitiateContinuous Function
Acquisition See Also

This function configures the oscilloscope to perform a continuous acquisition.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Initiate Continuous
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureInitiateContinuous(
    ViSession Vi,
    ViBoolean ContinuousAcquisition
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

ContinuousAcquisition

Specifies if the oscilloscope is enabled for continuous acquisition. The driver uses this value to set the Initiate Continuous attribute. See the attribute description for more information

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_ConfigureInterpolation Function

AgInfiniiVision_ConfigureInterpolation Function
Acquisition See Also

This function configures the interpolation method the oscilloscope uses when it cannot sample a voltage for a point in the waveform record.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Interpolation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureInterpolation(
    ViSession Vi,
    ViInt32 Interpolation
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Interpolation

Specifies interpolation method the oscilloscope uses when it cannot sample a voltage for a point in the waveform record. The driver sets the Interpolation attribute to this value. See the Interpolation attribute for a complete description and defined values.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Interpolation

Name | Description
AGINFINIIVISION_VAL_NO_INTERPOLATION | The oscilloscope does not interpolate points in the waveform. Instead, the driver sets every element in the waveform record for which the oscilloscope cannot receive a value to an IEEE-defined NaN (Not-a-Number) value.
AGINFINIIVISION_VAL_SINE_X | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.
AGINFINIIVISION_VAL_LINEAR | The oscilloscope uses a linear approximation to interpolate a value when it cannot resolve a voltage in the waveform record.
Top

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_ConfigureNumAverages Function

AgInfiniiVision_ConfigureNumAverages Function
Acquisition See Also

The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Number of Averages
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureNumAverages(
    ViSession Vi,
    ViInt32 NumberOfAverages
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

NumberOfAverages

Specifies the number of waveforms the oscilloscope acquires and averages. The driver sets the Number of Averages attribute to this value.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_ConfigureNumEnvelopes Function

AgInfiniiVision_ConfigureNumEnvelopes Function
Acquisition See Also

This function configures the number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms.

Function Tree Node: \AgInfiniiVision\Configuration\Acquisition\Configure Number of Envelopes
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureNumEnvelopes(
    ViSession Vi,
    ViInt32 NumEnvelopes
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

NumEnvelopes

Specifies the number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms. The driver sets the Number of Envelopes attribute to this value. See the Number of Envelopes attribute for a complete description.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


Channel

Channel
See Also

Tree Node: \AgInfiniiVision\Configuration\Channel

Functions

 | Name | Description
Function | Configure Channel | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Function | Configure Channel Characteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Function | Get Channel Name | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the ChannelIndex parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the ChannelName parameter and returns an error.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureChannel Function

AgInfiniiVision_ConfigureChannel Function
Channel See Also

Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

Function Tree Node: \AgInfiniiVision\Configuration\Channel\Configure Channel
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureChannel(
    ViSession Vi,
    ViConstString Channel,
    ViReal64 Range,
    ViReal64 Offset,
    ViInt32 Coupling,
    ViReal64 ProbeAttenuation,
    ViBoolean Enabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

Range

Specifies the vertical range. This value sets the Vertical Range property.

Offset

Specifies the vertical offset. This value sets the Vertical Offset property.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

ProbeAttenuation

Specifies the probe attenuation. This value sets the Probe Attenuation property.

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Coupling

Name | Description
AGINFINIIVISION_VAL_AC | The oscilloscope AC couples the input signal.
AGINFINIIVISION_VAL_DC | The oscilloscope DC couples the input signal.
AGINFINIIVISION_VAL_GND | NOT SUPPORTED
Top

See Also

Reference

Channel
AgInfiniiVision


AgInfiniiVision_ConfigureChanCharacteristics Function

AgInfiniiVision_ConfigureChanCharacteristics Function
Channel See Also

Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.

Function Tree Node: \AgInfiniiVision\Configuration\Channel\Configure Channel Characteristics
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureChanCharacteristics(
    ViSession Vi,
    ViConstString Channel,
    ViReal64 InputImpedance,
    ViReal64 MaxInputFrequency
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

InputImpedance

The input impedance for the channel. The driver sets the Input Impedance to this value.

MaxInputFrequency

The maximum input frequency for the channel. The driver sets the Max Input Frequency to this value.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AgInfiniiVision_GetChannelName Function

AgInfiniiVision_GetChannelName Function
Channel See Also

This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the ChannelIndex parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the ChannelName parameter and returns an error.

Function Tree Node: \AgInfiniiVision\Configuration\Channel\Get Channel Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetChannelName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

The number of bytes in the ViChar array that the user specifies for the Name parameter.

Name

A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the channel name. The caller may pass VI_NULL for this parameter if the NameBufferSize parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


Configuration Information

Configuration Information
See Also

Tree Node: \AgInfiniiVision\Configuration\Configuration Information

Functions

 | Name | Description
Function | Actual Record Length | This function returns the actual number of points the oscilloscope acquires per channel. After configuring the oscilloscope for an acquisition, call this function to determine the size of the waveforms that the oscilloscope acquires. The value is equal to or greater than the minimum number of points specified in the Configure Acquisition Record function. For IVI-C drivers, allocate a ViReal64 array of this size or greater to pass as the WaveformArray parameter of the IviScope_ReadWaveform and IviScope_FetchWaveform functions. The oscilloscope may use different size records depending on the acquisition type. Specify the acquisition type with the Configure Acquisition Type function.
Function | Actual Sample Mode | This function returns the sample mode the oscilloscope is currently using.
Function | Auto Probe Sense Value | The function returns the probe attenuation value the oscilloscope senses. The capability is enabled by setting the probeAttenuation parameter of the Configure Channel function to Probe Sense On. If the automatic probe sense capability is disabled, this function returns the manual probe attenuation setting.
Function | Auto Setup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | Sample Rate | This function returns the effective sample rate of the acquired waveform using the current configuration in samples per second.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ActualRecordLength Function

AgInfiniiVision_ActualRecordLength Function
Configuration Information See Also

This function returns the actual number of points the oscilloscope acquires per channel. After configuring the oscilloscope for an acquisition, call this function to determine the size of the waveforms that the oscilloscope acquires. The value is equal to or greater than the minimum number of points specified in the Configure Acquisition Record function. For IVI-C drivers, allocate a ViReal64 array of this size or greater to pass as the WaveformArray parameter of the IviScope_ReadWaveform and IviScope_FetchWaveform functions. The oscilloscope may use different size records depending on the acquisition type. Specify the acquisition type with the Configure Acquisition Type function.

Function Tree Node: \AgInfiniiVision\Configuration\Configuration Information\Actual Record Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ActualRecordLength(
    ViSession Vi,
    ViInt32* ActualRecordLength
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

ActualRecordLength

Returns the actual number of points the oscilloscope acquires for each channel. The driver returns the value held in the Horizontal Record Length attribute. See the Horizontal Record Length attribute for a complete description.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Configuration Information
AgInfiniiVision


AgInfiniiVision_SampleMode Function

AgInfiniiVision_SampleMode Function
Configuration Information See Also

This function returns the sample mode the oscilloscope is currently using.

Function Tree Node: \AgInfiniiVision\Configuration\Configuration Information\Actual Sample Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SampleMode(
    ViSession Vi,
    ViInt32* SampleMode
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

SampleMode

Returns the sample mode the oscilloscope is currently using. The driver returns the value of the Sample Mode attribute. See the Sample Mode attribute for a complete description and defined values.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter SampleMode

Name | Description
AGINFINIIVISION_VAL_REAL_TIME | Indicates that the oscilloscope is using real-time sampling.
AGINFINIIVISION_VAL_EQUIVALENT_TIME | Indicates that the oscilloscope is using equivalent time sampling.
Top

See Also

Reference

Configuration Information
AgInfiniiVision


AgInfiniiVision_AutoProbeSenseValue Function

AgInfiniiVision_AutoProbeSenseValue Function
Configuration Information See Also

The function returns the probe attenuation value the oscilloscope senses. The capability is enabled by setting the probeAttenuation parameter of the Configure Channel function to Probe Sense On. If the automatic probe sense capability is disabled, this function returns the manual probe attenuation setting.

Function Tree Node: \AgInfiniiVision\Configuration\Configuration Information\Auto Probe Sense Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AutoProbeSenseValue(
    ViSession Vi,
    ViConstString ChannelName,
    ViReal64* AutoProbeSenseValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The channel on which to query the probe attenuation value.For valid values, see the Channel repeated capability.

AutoProbeSenseValue

Returns the probe attenuation value the oscilloscope senses. The driver returns the value of the Probe Sense Value attribute. See the Probe Sense Value attribute for a complete description.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Configuration Information
AgInfiniiVision


AgInfiniiVision_AutoSetup Function

AgInfiniiVision_AutoSetup Function
Configuration Information See Also

Automatically configures all the oscilloscopes settings based on the input signals.

Function Tree Node: \AgInfiniiVision\Configuration\Configuration Information\Auto Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AutoSetup(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Configuration Information
AgInfiniiVision


AgInfiniiVision_SampleRate Function

AgInfiniiVision_SampleRate Function
Configuration Information See Also

This function returns the effective sample rate of the acquired waveform using the current configuration in samples per second.

Function Tree Node: \AgInfiniiVision\Configuration\Configuration Information\Sample Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SampleRate(
    ViSession Vi,
    ViReal64* SampleRate
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

SampleRate

Returns the effective sample rate of the acquired waveform the oscilloscope acquires for each channel. The driver returns the value held in the Horizontal Sample Rate attribute. See the Horizontal Sample Rate attribute for a complete description.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Configuration Information
AgInfiniiVision


Measurement

Measurement
See Also

Tree Node: \AgInfiniiVision\Configuration\Measurement

Functions

 | Name | Description
Function | Configure Reference Levels | Configures the reference levels for waveform measurements, low, mid, and high.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureRefLevels Function

AgInfiniiVision_ConfigureRefLevels Function
Measurement See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Function Tree Node: \AgInfiniiVision\Configuration\Measurement\Configure Reference Levels
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureRefLevels(
    ViSession Vi,
    ViReal64 Low,
    ViReal64 Mid,
    ViReal64 High
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Low

Measurement low reference. This value sets the Meas Low Ref property

Mid

Measurement mid reference. This value sets the Meas Mid Ref property.

High

Measurement high reference. This value sets the Meas High Ref property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


Trigger

Trigger
See Also

Tree Node: \AgInfiniiVision\Configuration\Trigger

Functions

 | Name | Description
Function | Configure AC Line Trigger Slope | This function configures the slope of the AC Line trigger. This function affects instrument behavior only if the trigger type is AC Line Trigger. Call the Configure Trigger function to set the trigger type before calling this function.
Function | Configure Edge Trigger Source | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Function | Configure Glitch Trigger Source | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Function | Configure Runt Trigger Source | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Function | Configure Trigger | Configures trigger Type and Holdoff. Holdoff units are seconds.
Function | Configure Trigger Coupling | This function sets the trigger coupling attribute.
Function | Configure Trigger Modifier | This function configures the oscilloscope's trigger modifier.
Function | Configure TV Trigger Line Number | This function configures the TV line upon which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal. This function affects instrument behavior only if the trigger type is set to the TV Trigger value and the TV trigger event is set to the TV Event Line Number value. Call the Configure TV Trigger Source function to set the TV trigger event before calling this function.
Function | Configure TV Trigger Source | Configures the TV trigger source, signal format, event and polarity.
Function | Configure Width Trigger Source | Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureAcLineTriggerSlope Function

AgInfiniiVision_ConfigureAcLineTriggerSlope Function
Trigger See Also

This function configures the slope of the AC Line trigger. This function affects instrument behavior only if the trigger type is AC Line Trigger. Call the Configure Trigger function to set the trigger type before calling this function.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure AC Line Trigger Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureAcLineTriggerSlope(
    ViSession Vi,
    ViInt32 ACLineSlope
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

ACLineSlope

Specifies whether an oscilloscope triggers on a zero crossing with a positive, negative, or either slope of the network supply voltage. The driver uses this value to set the AC Line Trigger Slope attribute. See the attribute description for more information.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter ACLineSlope

Name | Description
AGINFINIIVISION_VAL_AC_LINE_POSITIVE | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_NEGATIVE | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_EITHER | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureEdgeTriggerSource Function

AgInfiniiVision_ConfigureEdgeTriggerSource Function
Trigger See Also

Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Edge Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureEdgeTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViReal64 Level,
    ViInt32 Slope
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Slope

Specifies the trigger slope. This value sets the Trigger Slope property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the oscilloscope.
AGINFINIIVISION_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the oscilloscope.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureGlitchTriggerSource Function

AgInfiniiVision_ConfigureGlitchTriggerSource Function
Trigger See Also

Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Glitch Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureGlitchTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViReal64 Level,
    ViReal64 GlitchWidth,
    ViInt32 GlitchPolarity,
    ViInt32 GlitchCondition
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

GlitchWidth

Specifies the glitch triggering glitch width in seconds. This value sets the Glitch Width property.

GlitchPolarity

Specifies the glitch polarity. This value sets the Glitch Polarity property.

GlitchCondition

Specifies the glitch condition. This value sets the Glitch Condition property.

Return Value

Success or failure code.

Remarks

Note: Trigger.Type should be set to IviScopeTriggerGlitch before executing this method.

Requirements

Supported Models

All supported

Defined Values For Parameter GlitchPolarity

Name | Description
AGINFINIIVISION_VAL_GLITCH_POSITIVE | The oscilloscope triggers on a positive glitch.
AGINFINIIVISION_VAL_GLITCH_NEGATIVE | The oscilloscope triggers on a negative glitch.
AGINFINIIVISION_VAL_GLITCH_EITHER | The oscilloscope triggers on either a positive or negative glitch.
Top

Defined Values For Parameter GlitchCondition

Name | Description
AGINFINIIVISION_VAL_GLITCH_LESS_THAN | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
AGINFINIIVISION_VAL_GLITCH_GREATER_THAN | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.
AGINFINIIVISION_VAL_GLITCH_CONDITION_RANGE | The oscilloscope triggers within a range of time values
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureRuntTriggerSource Function

AgInfiniiVision_ConfigureRuntTriggerSource Function
Trigger See Also

Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Runt Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureRuntTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViReal64 RuntThresholdLow,
    ViReal64 RuntThresholdHigh,
    ViInt32 RuntPolarity
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source property.

RuntThresholdLow

Sets the runt triggering low threshold in volts.

RuntThresholdHigh

Sets the runt triggering high threshold in volts.

RuntPolarity

Sets the runt polarity.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter RuntPolarity

Name | Description
AGINFINIIVISION_VAL_RUNT_POSITIVE | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
AGINFINIIVISION_VAL_RUNT_NEGATIVE | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
AGINFINIIVISION_VAL_RUNT_EITHER | The oscilloscope triggers on either a positive or negative runt.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureTrigger Function

AgInfiniiVision_ConfigureTrigger Function
Trigger See Also

Configures trigger Type and Holdoff. Holdoff units are seconds.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Trigger
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTrigger(
    ViSession Vi,
    ViInt32 TriggerType,
    ViReal64 Holdoff
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

TriggerType

Specifies the trigger type. This value sets the Trigger Type property.

Holdoff

Specifies the trigger hold-off. This value sets the Trigger Holdoff property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter TriggerType

Name | Description
AGINFINIIVISION_VAL_EDGE_TRIGGER | Configures the oscilloscope for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source property passes the voltage threshold specified with the Trigger Level property &amp; Trigger Slope property.
AGINFINIIVISION_VAL_WIDTH_TRIGGER | Configures the oscilloscope for width triggering. Use the IviScopeWidthTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_RUNT_TRIGGER | Configures the oscilloscope for runt triggering. Use the IviScopeRuntTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_GLITCH_TRIGGER | Configures the oscilloscope for glitch triggering. Use the IviScopeGlitchTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_TV_TRIGGER | Configures the oscilloscope for triggering on TV signals. Use the IviScopeTVTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_IMMEDIATE_TRIGGER | NOT SUPPORTED
AGINFINIIVISION_VAL_AC_LINE_TRIGGER | Configures the oscilloscope for AC Line triggering. Use the IviScopeACLineTrigger extension properties and methods to configure the trigger.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureTriggerCoupling Function

AgInfiniiVision_ConfigureTriggerCoupling Function
Trigger See Also

This function sets the trigger coupling attribute.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Trigger Coupling
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerCoupling(
    ViSession Vi,
    ViInt32 Coupling
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Coupling

Specifies the trigger coupling. The driver uses this value to set the Trigger Coupling attribute. See the attribute description for more information.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Coupling

Name | Description
AGINFINIIVISION_VAL_AC | The oscilloscope AC couples the trigger signal.
AGINFINIIVISION_VAL_DC | The oscilloscope DC couples the trigger signal.
AGINFINIIVISION_VAL_HF_REJECT | The oscilloscope filters out the high frequencies from the trigger signal.
AGINFINIIVISION_VAL_LF_REJECT | The oscilloscope filters out the low frequencies from the trigger signal.
AGINFINIIVISION_VAL_NOISE_REJECT | The oscilloscope filters out the noise from the trigger signal.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureTriggerModifier Function

AgInfiniiVision_ConfigureTriggerModifier Function
Trigger See Also

This function configures the oscilloscope's trigger modifier.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Trigger Modifier
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerModifier(
    ViSession Vi,
    ViInt32 TriggerModifier
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

TriggerModifier

Specifies the method the oscilloscope uses in the absence of trigger conditions. The driver sets the Trigger Modifier attribute to this value. See the attribute description for more information and defined values.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter TriggerModifier

Name | Description
AGINFINIIVISION_VAL_NO_TRIGGER_MOD | The oscilloscope waits until the trigger the end-user specifies occurs.
AGINFINIIVISION_VAL_AUTO | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.
AGINFINIIVISION_VAL_AUTO_LEVEL | The oscilloscope adjusts the trigger level if the trigger the end-user specifies does not occur.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureTVTriggerLineNumber Function

AgInfiniiVision_ConfigureTVTriggerLineNumber Function
Trigger See Also

This function configures the TV line upon which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal. This function affects instrument behavior only if the trigger type is set to the TV Trigger value and the TV trigger event is set to the TV Event Line Number value. Call the Configure TV Trigger Source function to set the TV trigger event before calling this function.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure TV Trigger Line Number
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTVTriggerLineNumber(
    ViSession Vi,
    ViInt32 TVLineNumber
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

TVLineNumber

Specifies the TV trigger line number. The driver sets the TV Trigger Line Number attribute to this value. See the TV Trigger Line Number attribute description for details.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureTVTriggerSource Function

AgInfiniiVision_ConfigureTVTriggerSource Function
Trigger See Also

Configures the TV trigger source, signal format, event and polarity.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure TV Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTVTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViInt32 TVSignalFormat,
    ViInt32 TVEvent,
    ViInt32 TVPolarity
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source property.

TVSignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format property.

TVEvent

Specifies the TV trigger event. This value sets the TV Trigger Event property.

TVPolarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter TVSignalFormat

Name | Description
AGINFINIIVISION_VAL_NTSC | Configures the oscilloscope to trigger on the NTSC signal format.
AGINFINIIVISION_VAL_PAL | Configures the oscilloscope to trigger on the PAL signal format
AGINFINIIVISION_VAL_SECAM | Configures the oscilloscope to trigger on the SECAM signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATPALM2 | Configures the oscilloscope to trigger on the PALM signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMAT_GENERIC2 | Configures the oscilloscope to trigger on the Generic signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP4802 | Configures the oscilloscope to trigger on the P480 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATI10802 | Configures the oscilloscope to trigger on the I1080 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP7202 | Configures the oscilloscope to trigger on the P720 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP10802 | Configures the oscilloscope to trigger on the P1080 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L25HZ2 | Configures the oscilloscope to trigger on the P1080L25Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L60HZ2 | Configures the oscilloscope to trigger on the P1080L60Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L50HZ2 | Configures the oscilloscope to trigger on the P1080L50Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATI1080L60HZ2 | Configures the oscilloscope to trigger on the I1080L60Hz signal format
Top

Defined Values For Parameter TVEvent

Name | Description
AGINFINIIVISION_VAL_TV_EVENT_FIELD1 | Sets the oscilloscope to trigger on field 1 of the video signal.
AGINFINIIVISION_VAL_TV_EVENT_FIELD2 | Sets the oscilloscope to trigger on field 2 of the video signal.
AGINFINIIVISION_VAL_TV_EVENT_ANY_FIELD | Sets the oscilloscope to trigger on any field.
AGINFINIIVISION_VAL_TV_EVENT_ANY_LINE | Sets the oscilloscope to trigger on any line.
AGINFINIIVISION_VAL_TV_EVENT_LINE_NUMBER | Sets the oscilloscope to trigger on a specific line number you specify with the TV Trigger Line Number property.
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_LINE_NUMBER_ALTERNATE2 | NOT SUPPORTED
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_LINE_NUMBER_VERTICAL2 | NOT SUPPORTED
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_VERTICAL2 | NOT SUPPORTED
Top

Defined Values For Parameter TVPolarity

Name | Description
AGINFINIIVISION_VAL_TV_POSITIVE | Configures the oscilloscope to trigger on a positive video sync pulse.
AGINFINIIVISION_VAL_TV_NEGATIVE | Configures the oscilloscope to trigger on a negative video sync pulse.
Top

See Also

Reference

Trigger
AgInfiniiVision


AgInfiniiVision_ConfigureWidthTriggerSource Function

AgInfiniiVision_ConfigureWidthTriggerSource Function
Trigger See Also

Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Function Tree Node: \AgInfiniiVision\Configuration\Trigger\Configure Width Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureWidthTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViReal64 Level,
    ViReal64 WidthLowThreshold,
    ViReal64 WidthHighThreshold,
    ViInt32 WidthPolarity,
    ViInt32 WidthCondition
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. The driver uses this value to set the Trigger Source attribute. See the attribute description for more information.

Level

Trigger Level. This value sets the Trigger Level property.

WidthLowThreshold

Sets the width triggering low threshold in seconds. This value sets the Width Low Threshold property.

WidthHighThreshold

Sets the width triggering high threshold in seconds. This value sets the Width High Threshold property.

WidthPolarity

Sets the width polarity. This value sets the Width Polarity property.

WidthCondition

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition property.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter WidthPolarity

Name | Description
AGINFINIIVISION_VAL_WIDTH_POSITIVE | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_NEGATIVE | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_EITHER | Configures the oscilloscope to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
Top

Defined Values For Parameter WidthCondition

Name | Description
AGINFINIIVISION_VAL_WIDTH_WITHIN | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold.
AGINFINIIVISION_VAL_WIDTH_OUTSIDE | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold.
Top

See Also

Reference

Trigger
AgInfiniiVision


Inherent IVI Attributes

Inherent IVI Attributes
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes

Branches

Name
Advanced Session Information
Driver Capabilities
Driver Identification
Instrument Identification
User Options
Top

See Also

Reference

AgInfiniiVision


Advanced Session Information

Advanced Session Information
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Advanced Session Information

Attributes

 | Name | Description
Attribute | Driver Setup | Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | I/O Resource Descriptor | Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | Logical Name | Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_DRIVER_SETUP Attribute

AGINFINIIVISION_ATTR_DRIVER_SETUP Attribute
Advanced Session Information See Also

Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Advanced Session Information\Driver Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DRIVER_SETUP 1050007

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DRIVER_SETUP.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgInfiniiVision


AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR Attribute

AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR Attribute
Advanced Session Information See Also

Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Advanced Session Information\I/O Resource Descriptor
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR 1050304

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgInfiniiVision


AGINFINIIVISION_ATTR_LOGICAL_NAME Attribute

AGINFINIIVISION_ATTR_LOGICAL_NAME Attribute
Advanced Session Information See Also

Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Advanced Session Information\Logical Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_LOGICAL_NAME 1050305

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_LOGICAL_NAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgInfiniiVision


Driver Capabilities

Driver Capabilities
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Capabilities

Attributes

 | Name | Description
Attribute | Class Group Capabilities | Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | Supported Instrument Models | Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_GROUP_CAPABILITIES Attribute

AGINFINIIVISION_ATTR_GROUP_CAPABILITIES Attribute
Driver Capabilities See Also

Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Capabilities\Class Group Capabilities
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_GROUP_CAPABILITIES 1050401

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_GROUP_CAPABILITIES.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Driver Capabilities
AgInfiniiVision


AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS Attribute

AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS Attribute
Driver Capabilities See Also

Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Capabilities\Supported Instrument Models
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS 1050327

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Driver Capabilities
AgInfiniiVision


Driver Identification

Driver Identification
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification

Attributes

 | Name | Description
Attribute | Specific Driver Class Spec Major Version | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | Specific Driver Class Spec Minor Version | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | Specific Driver Description | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | Specific Driver Prefix | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | Specific Driver Revision | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | Specific Driver Vendor | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION Attribute
Driver Identification See Also

Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Class Spec Major Version
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION 1050515

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

Driver Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION Attribute
Driver Identification See Also

Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Class Spec Minor Version
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION 1050516

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

Driver Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION Attribute
Driver Identification See Also

Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Description
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION 1050514

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX Attribute
Driver Identification See Also

Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Prefix
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX 1050302

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION Attribute
Driver Identification See Also

Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Revision
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION 1050551

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR Attribute

AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR Attribute
Driver Identification See Also

Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Driver Identification\Specific Driver Vendor
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR 1050513

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgInfiniiVision


Instrument Identification

Instrument Identification
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Instrument Identification

Attributes

 | Name | Description
Attribute | Instrument Firmware Revision | Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | Instrument Manufacturer | Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.
Attribute | Instrument Model | Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION Attribute

AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION Attribute
Instrument Identification See Also

Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Instrument Identification\Instrument Firmware Revision
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION 1050510

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER Attribute

AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER Attribute
Instrument Identification See Also

Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Instrument Identification\Instrument Manufacturer
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER 1050511

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgInfiniiVision


AGINFINIIVISION_ATTR_INSTRUMENT_MODEL Attribute

AGINFINIIVISION_ATTR_INSTRUMENT_MODEL Attribute
Instrument Identification See Also

Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\Instrument Identification\Instrument Model
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INSTRUMENT_MODEL 1050512

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INSTRUMENT_MODEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgInfiniiVision


User Options

User Options
See Also

Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options

Attributes

 | Name | Description
Attribute | Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | Interchange Check | Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | Query Instrument Status | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | Range Check | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | Record Value Coercions | Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_CACHE Attribute

AGINFINIIVISION_ATTR_CACHE Attribute
User Options See Also

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Cache
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CACHE 1050004

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CACHE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AGINFINIIVISION_ATTR_INTERCHANGE_CHECK Attribute

AGINFINIIVISION_ATTR_INTERCHANGE_CHECK Attribute
User Options See Also

Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Interchange Check
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INTERCHANGE_CHECK 1050021

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INTERCHANGE_CHECK.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS Attribute

AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS Attribute
User Options See Also

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Query Instrument Status
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS 1050003

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AGINFINIIVISION_ATTR_RANGE_CHECK Attribute

AGINFINIIVISION_ATTR_RANGE_CHECK Attribute
User Options See Also

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Range Check
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_RANGE_CHECK 1050002

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_RANGE_CHECK.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AGINFINIIVISION_ATTR_RECORD_COERCIONS Attribute

AGINFINIIVISION_ATTR_RECORD_COERCIONS Attribute
User Options See Also

Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Record Value Coercions
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_RECORD_COERCIONS 1050006

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_RECORD_COERCIONS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AGINFINIIVISION_ATTR_SIMULATE Attribute

AGINFINIIVISION_ATTR_SIMULATE Attribute
User Options See Also

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Attribute Tree Node: \AgInfiniiVision\Inherent IVI Attributes\User Options\Simulate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SIMULATE 1050005

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SIMULATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgInfiniiVision


AgInfiniiVision_init Function

AgInfiniiVision_init Function
AgInfiniiVision See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Function Tree Node: \AgInfiniiVision\Initialize
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_init(
    ViRsrc ResourceName,
    ViBoolean IdQuery,
    ViBoolean Reset,
    ViSession* Vi
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

Vi

Unique identifier for an IVI session.

Return Value

Success or failure code.

Remarks

For detailed parameter usage see: Initializing the IVI-C Driver

See Also

Reference

AgInfiniiVision
AgInfiniiVision


AgInfiniiVision_InitWithOptions Function

AgInfiniiVision_InitWithOptions Function
AgInfiniiVision See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Function Tree Node: \AgInfiniiVision\Initialize With Options
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_InitWithOptions(
    ViRsrc ResourceName,
    ViBoolean IdQuery,
    ViBoolean Reset,
    ViConstString OptionsString,
    ViSession* Vi
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

OptionsString

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

Vi

Unique identifier for an IVI session.

Return Value

Success or failure code.

Remarks

For detailed parameter usage see: Initializing the IVI-C Driver

Requirements

Supported Models

All supported

See Also

Reference

AgInfiniiVision
AgInfiniiVision


Instrument Specific

Instrument Specific
See Also

Tree Node: \AgInfiniiVision\Instrument Specific

Branches

Name
Acquisition
AnalogBus
Calibration
Channel
ClockRecovery
Counter
Cursors
DigitalChannel
Display
DVM
External
FFT
FRA
Histogram
Jitter
MaskTest
Math
MathFunction
Measurement
Memory
ReferenceWaveform
Search
SegmentedMemory
SerialBus
Status
System
Timebase
Trigger
Waveform
WaveformGenerator
WaveGen
Top

See Also

Reference

AgInfiniiVision


Acquisition

Acquisition
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Acquisition

Functions

 | Name | Description
Function | Acquisition Set Sample Mode | Sets the acquisition mode of the oscilloscope.
Function | Acquisition Single Acquisition | Acquires a single trigger of data.
Function | Acquisition Stop | Stops the acquisition.
Top

Attributes

 | Name | Description
Attribute | Reference Signal | Selects the 10 MHz Reference Signal Mode.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_AcquisitionSetSampleMode Function

AgInfiniiVision_AcquisitionSetSampleMode Function
Acquisition See Also

Sets the acquisition mode of the oscilloscope.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Acquisition\Acquisition Set Sample Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AcquisitionSetSampleMode(
    ViSession Vi,
    ViInt32 Mode
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Mode

The acquisition sampling mode.

Return Value

Success or failure code.

Remarks

  • AgInfiniiVisionSampleModeRealTime: The Real time mode Specifies that the oscilloscope produce the waveform display from samples collected during one trigger event (that is, one acquisition). At fast sweep speeds, when not enough samples can be collected for a waveform, a sophisticated reconstruction filter is used to fill-in sample points and enhance the waveform display. In Real time mode, to accurately reproduce a sampled waveform, the sample rate should be at least 2.5 times the highest frequency component of the waveform. If not, it is possible for the reconstructed waveform to be distorted or aliased. Aliasing is most commonly seen as jitter on fast digital edges. Use Real time sampling to capture infrequent triggers, unstable triggers, or complex changing waveforms, such as eye diagrams.
  • AgInfiniiVisionSampleModeMaxRealTime: The Maximum update rate real time mode is the same as Realtime except that in order to provide maximum update rate (trigger rates), the sample rate drops from 20 GSa/s to 2 GSa/s at a faster time/div setting than normal. This mode is ideal for finding glitches and infrequent events in waveforms that do not require the full 20 GSa/s sample rate (and associated bandwidth). This mode is not allowed in single, roll, segmented, mask test, or zone trigger.
  • AgInfiniiVisionSampleModeEquivalentTime: The equivalent time sampling mode is Available in 6 GHz bandwidth models, this option gives you another way to fill-in sample points at fast sweep speeds - it is used only when sweep speeds are 20 ns/div or faster. In this case, instead of a reconstruction filter, a technique known as random repetitive sampling is used to build-up and draw one waveform using multiple triggers (acquisitions). At slower sweep speeds, there are enough sample points in a trigger (acquisition, in other words) to render a waveform on the display. Equivalent time sampling mode requires a repetitive waveform with a stable trigger.
  • AgInfiniiVisionSampleModeSegmented: The segmented mode sets the oscilloscope in segmented memory mode.

    • Instrument Command

    :ACQuire:MODE {RTIM|SEGM|ETIM|MRT}

    Requirements

    Supported Models

    All supported

    Defined Values For Parameter Mode

    Name | Description
AGINFINIIVISION_VAL_SAMPLE_MODE_REAL_TIME | Indicates that the oscilloscope is using real-time sampling.
AGINFINIIVISION_VAL_SAMPLE_MODE_SEGMENTED | Indicates that the oscilloscope is using segmented memory mode.
AGINFINIIVISION_VAL_SAMPLE_MODE_EQUIVALENT_TIME | Indicates that the oscilloscope is using Equivalent time mode.
AGINFINIIVISION_VAL_SAMPLE_MODE_MAX_REAL_TIME | Supported on 6000x series only- Indicates that the oscilloscope is using maximum update rate real-time sampling.
    Top

    See Also

    Reference

    Acquisition
    AgInfiniiVision


AgInfiniiVision_AcquisitionSingleAcquisition Function

AgInfiniiVision_AcquisitionSingleAcquisition Function
Acquisition See Also

Acquires a single trigger of data.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Acquisition\Acquisition Single Acquisition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AcquisitionSingleAcquisition(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:SINGle

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AgInfiniiVision_AcquisitionStop Function

AgInfiniiVision_AcquisitionStop Function
Acquisition See Also

Stops the acquisition.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Acquisition\Acquisition Stop
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AcquisitionStop(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:STOP

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgInfiniiVision


AGINFINIIVISION_ATTR_REFERENCE_SIGNAL Attribute

AGINFINIIVISION_ATTR_REFERENCE_SIGNAL Attribute
Acquisition See Also

Selects the 10 MHz Reference Signal Mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Acquisition\Reference Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_REFERENCE_SIGNAL 1150433

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_REFERENCE_SIGNAL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:ACQuire:RSIGnal {IN|OUT|OFF}
:ACQuire:RSIGnal?

Defined Values

Name | Description
AGINFINIIVISION_VAL_ACQUISITION_REFERENCE_SIGNAL_MODE_IN | This mode is used to supply a sample clock to the oscilloscope.
AGINFINIIVISION_VAL_ACQUISITION_REFERENCE_SIGNAL_MODE_OUT | This mode is used to synchronize the timebase of two or more instruments.
AGINFINIIVISION_VAL_ACQUISITION_REFERENCE_SIGNAL_MODE_OFF | This mode disables the oscilloscope's 10 MHz REF BNC connector.
Top

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Acquisition
AgInfiniiVision


AnalogBus

AnalogBus
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus

Functions

 | Name | Description
Function | Clear | Excludes all of the analog channels from the selected bus definition.
Function | Get Bit | Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.
Function | Get Bits | Returns the definition for the specified bus.
Function | Set Bit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | Set Bits | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Top

Attributes

 | Name | Description
Attribute | Enabled | It enables or disables the view of the selected bus.
Attribute | Label | The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_AnalogBusClear Function

AgInfiniiVision_AnalogBusClear Function
AnalogBus See Also

Excludes all of the analog channels from the selected bus definition.

Function Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AnalogBusClear(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:ABUS:CLEar

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED Attribute

AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED Attribute
AnalogBus See Also

It enables or disables the view of the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED 1150694

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:ABUS:DISPlay {ON|OFF}
:ABUS:DISPlay?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


AgInfiniiVision_AnalogBusGetBit Function

AgInfiniiVision_AnalogBusGetBit Function
AnalogBus See Also

Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.

Function Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Get Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AnalogBusGetBit(
    ViSession Vi,
    ViInt16 Bit,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Bit

Digital bit to be included in bus definition

Val

0 or 1

Return Value

Success or failure code.

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BIT{Bit}?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


AgInfiniiVision_AnalogBusGetBits Function

AgInfiniiVision_AnalogBusGetBits Function
AnalogBus See Also

Returns the definition for the specified bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Get Bits
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AnalogBusGetBits(
    ViSession Vi,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValBufferSize

Buffer size

Val

Definition in String format.

Return Value

Success or failure code.

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BITS?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL Attribute

AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL Attribute
AnalogBus See Also

The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL 1150675

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters.

    • Instrument Command

    :ABUS:LABel "{value}"
    :ABUS:LABel?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    AnalogBus
    AgInfiniiVision


AgInfiniiVision_AnalogBusSetBit Function

AgInfiniiVision_AnalogBusSetBit Function
AnalogBus See Also

Includes/Excludes the selected bit as part of the definition for the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Set Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AnalogBusSetBit(
    ViSession Vi,
    ViInt16 Bits,
    ViBoolean BitState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Bits

DigitalBit(0-15) to be included/excluded in the bus

BitState

Flag indicating bit is enabled or disabled

Return Value

Success or failure code.

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BIT{Bits} {1|0}

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


AgInfiniiVision_AnalogBusSetBits Function

AgInfiniiVision_AnalogBusSetBits Function
AnalogBus See Also

Includes/Excludes the selected bits in the channel list in the definition of the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\AnalogBus\Set Bits
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AnalogBusSetBits(
    ViSession Vi,
    ViConstString ChannelList,
    ViBoolean BitState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelList

Channel List containing bits to be included/excluded in the bus definition

BitState

Flag indicating bit is enabled or disabled

Return Value

Success or failure code.

Remarks

Bit | Channel
0 | channel 1
1 | channel 2
2 | EXT Trig Input

Instrument Command

:ABUS:BITS (@{ChannelList}),{1|0}

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

AnalogBus
AgInfiniiVision


Calibration

Calibration
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Calibration

Functions

 | Name | Description
Function | Calibration Calibrate | Starts the user calibration procedure. See the User's Guide for details.
Function | Calibration Result | Read Only- Summary results of the last user calibration procedure.
Top

Attributes

 | Name | Description
Attribute | CalibrationLabel | Calibration string(up to 32 characters not including the quotes).
Attribute | Date | Read Only - Gets the date of the last calibration.
Attribute | Enabled | Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.
Attribute | Signal Source | Signal on the rear panel trigger out BNC.
Attribute | Temperature | Read Only - Change in temperature since the last user calibration procedure.
Attribute | Time | Read Only - Time of the last calibration.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_CalibrationCalibrate Function

AgInfiniiVision_CalibrationCalibrate Function
Calibration See Also

Starts the user calibration procedure. See the User's Guide for details.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Calibration Calibrate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_CalibrationCalibrate(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:CALibrate:STARt

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AgInfiniiVision_CalibrationResult Function

AgInfiniiVision_CalibrationResult Function
Calibration See Also

Read Only- Summary results of the last user calibration procedure.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Calibration Result
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_CalibrationResult(
    ViSession Vi,
    ViInt32 SummaryResultBufferSize,
    ViInt32 StatusStringBufferSize2,
    ViChar[] StatusString,
    ViInt32* StatusCode
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SummaryResultBufferSize

Number of elements in SummaryResult.

StatusStringBufferSize2

Number of elements in SummaryResult.

StatusString

ASCII status string.

StatusCode

An integer status code.

Return Value

Success or failure code.

Instrument Command

:CALibrate:STATus?

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL Attribute

AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL Attribute
Calibration See Also

Calibration string(up to 32 characters not including the quotes).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\CalibrationLabel
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL 1150005

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:CALibrate:LABel "{value}"
:CALibrate:LABel?

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_DATE Attribute

AGINFINIIVISION_ATTR_CALIBRATION_DATE Attribute
Calibration See Also

Read Only - Gets the date of the last calibration.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Date
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_DATE 1150004

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_DATE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Instrument Command

:CALibrate:DATE?

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_ENABLED Attribute

AGINFINIIVISION_ATTR_CALIBRATION_ENABLED Attribute
Calibration See Also

Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_ENABLED 1150164

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_ENABLED.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:CALibrate:PROTected?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CALIBRATION_PROTECTION_ENABLED | Calibration is enabled
AGINFINIIVISION_VAL_CALIBRATION_PROTECTION_DISABLED | Calibration is disabled
Top

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE Attribute

AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE Attribute
Calibration See Also

Signal on the rear panel trigger out BNC.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Signal Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE 1150006

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • AgInfiniiVisionCalibrationSignalSourceWaveGen2 is only available on models with 2 WaveGen outputs.
  • AgInfiniiVisionCalibrationSignalSourceOff is only supported by 1000X, M924x and P924x.
  • AgInfiniiVisionCalibrationSignalSourceTrigSource is only supported by 3000T, 4000X, M924x and P924x.
  • AgInfiniiVisionCalibrationSignalSourceNFC is only supported by 3000T, 4000X, 6000X, M924x and P924x.

    • Instrument Command

    :CALibrate:OUTPut {TRIG|MASK|WAVE|WGEN2|OFF|TSOurce|NFC}
    :CALibrate:OUTPut?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_TRIGGERS2 | Pulse signal when a trigger event occurs.
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_MASK2 | Signal from mask test indicating a failure.
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_WAVE_GEN_NEW2 | Waveform generator sync output signal. This signal can be set by IAgInfiniiVisionWaveformGenerator.Function
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_WAVE_GEN2 | Sync output signal from Second waveform generator. This signal can be set by IAgInfiniiVisionWaveformGenerator.Function
AGINFINIIVISION_VAL_CHANNEL_PROTECTIONOK2 | "NOT USED",If no overload has occurred, OK is returned.
AGINFINIIVISION_VAL_CHANNEL_PROTECTION_TRIPPED2 | "NOT USED", If a channel input has experienced an overload, TRIP is returned
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_OFF | 1000X: Either turns off the [Gen Out] BNC, or outputs the WaveGen signals if the WaveGen is turned on. M924x: Turns off the [Aux Out] output. Other models: Not applicable.
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_TRIG_SOURCE | The raw trigger signal from the oscilloscope's trigger circuit is output to Trig Out. It produces a rising edge whenever the input source would cause a trigger, even though that might occur multiple times within the time of a single acquisition.
AGINFINIIVISION_VAL_CALIBRATION_SIGNAL_SOURCE_NFC | This option is available in the Near Field Communication(NFC) trigger mode when the ATRigger(Arm & Trigger) trigger event is selected. The ATRigger trigger event lets you arm the oscilloscope on one event and then trigger on a second event or after a specified timeout period if the second event does not occur.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Calibration
    AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE Attribute

AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE Attribute
Calibration See Also

Read Only - Change in temperature since the last user calibration procedure.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Temperature
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE 1150002

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:CALibrate:TEMPerature?

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


AGINFINIIVISION_ATTR_CALIBRATION_TIME Attribute

AGINFINIIVISION_ATTR_CALIBRATION_TIME Attribute
Calibration See Also

Read Only - Time of the last calibration.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Calibration\Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CALIBRATION_TIME 1150003

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CALIBRATION_TIME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Instrument Command

:CALibrate:TIME?

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgInfiniiVision


Channel

Channel
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Channel

Functions

 | Name | Description
Function | Channel Clear Protection | Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.
Function | Get ProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Top

Attributes

 | Name | Description
Attribute | Invert | Inverts the input signal for the specified channel.
Attribute | Label | The analog channel label.
Attribute | Probe Skew | Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.
Attribute | ProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Attribute | Protection | Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).
Attribute | Scale | Vertical scale, or units per division, of the selected channel.
Attribute | Units | Measurement units for the connected probe.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ChannelClearProtection Function

AgInfiniiVision_ChannelClearProtection Function
Channel See Also

Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Channel Clear Protection
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ChannelClearProtection(
    ViSession Vi,
    ViConstString Channel
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single channel.For valid values, see the Channel repeated capability.

Return Value

Success or failure code.

Instrument Command

:CHANnel{Channel}:PROTection

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AgInfiniiVision_GetProbeID Function

AgInfiniiVision_GetProbeID Function
Channel See Also

Read Only - Type of probe attached to the specified oscilloscope channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Get ProbeID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetProbeID(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 ProbeIDBufferSize,
    ViChar[] ProbeID
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

ProbeIDBufferSize

Number of elements in ProbeID.

ProbeID

Read Only - Type of probe attached to the specified oscilloscope channel.

Return Value

Success or failure code.

Instrument Command

:CHANnel{Channel}:PROBe:ID?

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_INVERT Attribute

AGINFINIIVISION_ATTR_CHANNEL_INVERT Attribute
Channel See Also

Inverts the input signal for the specified channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Invert
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_INVERT 1150026

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_INVERT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:CHANnel{Channel}:INVert {ON|OFF}
:CHANnel{Channel}:INVert?

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_LABEL Attribute

AGINFINIIVISION_ATTR_CHANNEL_LABEL Attribute
Channel See Also

The analog channel label.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_LABEL 1150027

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • For 2000X Family

    • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters. Lower case characters are converted to upper case.

  • For 3000X, 4000X and 6000X families.

    • Label strings are 32 characters or less, and may contain any commonly used ASCII characters. Labels with more than 32 characters are truncated to 32 characters. Lower case characters are converted to upper case.

    Instrument Command

    :CHANnel{Channel}:LABel "{value}"
    :CHANnel{Channel}:LABel?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Channel
    AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW Attribute

AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW Attribute
Channel See Also

Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Probe Skew
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW 1150030

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:CHANnel{Channel}:PROBe:SKEW {value}
:CHANnel{Channel}:PROBe:SKEW?

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_PROBEID Attribute

AGINFINIIVISION_ATTR_CHANNEL_PROBEID Attribute
Channel See Also

Read Only - Type of probe attached to the specified oscilloscope channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\ProbeID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_PROBEID 1150029

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_PROBEID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Instrument Command

:CHANnel{Channel}:PROBe:ID?

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_PROTECTION Attribute

AGINFINIIVISION_ATTR_CHANNEL_PROTECTION Attribute
Channel See Also

Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Protection
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_PROTECTION 1150202

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_PROTECTION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:CHANnel{Channel}:PROTection?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CHANNEL_PROTECTIONOK | If no overload has occurred, OK is returned.
AGINFINIIVISION_VAL_CHANNEL_PROTECTION_TRIPPED | If a channel input has experienced an overload, TRIP is returned
Top

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_SCALE Attribute

AGINFINIIVISION_ATTR_CHANNEL_SCALE Attribute
Channel See Also

Vertical scale, or units per division, of the selected channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_SCALE 1150032

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_SCALE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

When using 1:1 probe attenuation, legal values for the scale are from 2 mV to 5 V

Instrument Command

:CHANnel{Channel}:SCALe {value}
:CHANnel{Channel}:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


AGINFINIIVISION_ATTR_CHANNEL_UNITS Attribute

AGINFINIIVISION_ATTR_CHANNEL_UNITS Attribute
Channel See Also

Measurement units for the connected probe.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Channel\Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CHANNEL_UNITS 1150033

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CHANNEL_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:CHANnel{Channel}:UNITs {VOLT|AMP}
:CHANnel{Channel}:UNITs?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CHANNEL_UNITS_VOLT | VOLT for a voltage probe
AGINFINIIVISION_VAL_CHANNEL_UNITS_AMPERE | AMPere for a current probe
Top

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgInfiniiVision


ClockRecovery

ClockRecovery
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\ClockRecovery

Functions

 | Name | Description
Function | Get Method | Returns the currently selected clock recovery method.
Function | Set Method | Sets the clock recovery method.
Top

Attributes

 | Name | Description
Attribute | Display Enabled | Enable or disable the display of the recovered clock.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED Attribute

AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED Attribute
ClockRecovery See Also

Enable or disable the display of the recovered clock.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\ClockRecovery\Display Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED 1150598

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is false.

    • Instrument Command

    :CLOCk {1|0}
    :CLOCk?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    ClockRecovery
    AgInfiniiVision


AgInfiniiVision_ClockRecoveryGetMethod Function

AgInfiniiVision_ClockRecoveryGetMethod Function
ClockRecovery See Also

Returns the currently selected clock recovery method.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ClockRecovery\Get Method
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ClockRecoveryGetMethod(
    ViSession Vi,
    ViInt32* ClockMethod,
    ViReal64* DataRate,
    ViReal64* LoopBandwidth,
    ViReal64* DampingFactor,
    ViInt32 SourceBufferSize,
    ViChar[] Source,
    ViInt32* Slope,
    ViInt32* Multiplier
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ClockMethod

Currently selected clock method.

DataRate

The data signal's expected bits/second rate. This value is not valid when clock method is AgInfiniiVisionClockMethodExplicit.

LoopBandwidth

The -3 dB bandwidth specification of PLL. This value is only valid when clock method is AgInfiniiVisionClockMethodFirstOrderPLL or AgInfiniiVisionClockMethodSecondOrderPLL.

DampingFactor

The PLL's observed jitter transfer function. This value is only valid when clock method is AgInfiniiVisionClockMethodSecondOrderPLL.

SourceBufferSize

Number of elements in Source.

Source

Explicit clock source, CHANnel1 to number of analog channels. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Slope

Slope. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Multiplier

Explicit clock multiplier from 1 to 1000. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Return Value

Success or failure code.

Instrument Command

:CLOCk:METHod?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

Defined Values For Parameter ClockMethod

Name | Description
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED | This clock recovery method is used to recovered the clock using the expected nominal data rate entered. It should be the reciprocal of the signal's unit interval.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED_AUTO | This clock recovery method is used to recovered the clock using the signal edge database only. The narrowest pulse is presumed to be an isolated one or zero.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED_SEMI_AUTO | This clock recovery method is used to recovered the clock using the expected nominal data rate as a "seed" and the signal edge database.
AGINFINIIVISION_VAL_CLOCK_METHOD_FIRST_ORDER_PLL | With First Order PLL, the clock is recovered using the DSP-modeled response of an ideal first-order hardware PLL.
AGINFINIIVISION_VAL_CLOCK_METHOD_SECOND_ORDER_PLL | With Second Order PLL, the clock is recovered using the DSP-modeled response of an ideal Type II, second-order hardware PLL.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_EXPLICIT | The clock is recovered from a second signal in your device under test, with a multiplier from 1 to 1000 applied.
Top

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_EDGE_SLOPE_RISING | Rising slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_FALLING | Falling Slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_BOTH | Both Rising and Falling slope.
Top

See Also

Reference

ClockRecovery
AgInfiniiVision


AgInfiniiVision_ClockRecoverySetMethod Function

AgInfiniiVision_ClockRecoverySetMethod Function
ClockRecovery See Also

Sets the clock recovery method.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ClockRecovery\Set Method
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ClockRecoverySetMethod(
    ViSession Vi,
    ViInt32 ClockMethod,
    ViReal64 DataRate,
    ViReal64 LoopBandwidth,
    ViReal64 DampingFactor,
    ViConstString Source,
    ViInt32 Slope,
    ViInt32 Multiplier
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ClockMethod

Currently selected clock method.

DataRate

The data signal's expected bits/second rate. This value is not valid when clock method is AgInfiniiVisionClockMethodExplicit.

LoopBandwidth

The -3 dB bandwidth specification of PLL. This value is only valid when clock method is AgInfiniiVisionClockMethodFirstOrderPLL or AgInfiniiVisionClockMethodSecondOrderPLL.

DampingFactor

The PLL's observed jitter transfer function. This value is only valid when clock method is AgInfiniiVisionClockMethodSecondOrderPLL.

Source

Explicit clock source, CHANnel1 to number of analog channels. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Slope

Slope. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Multiplier

Explicit clock multiplier from 1 to 1000. This value is only valid when clock method is AgInfiniiVisionClockMethodExplicit.

Return Value

Success or failure code.

Instrument Command

:CLOCk:METHod {FIXed|AUTO|SEMI|FOPL|SOPL|EXPlicit}, {DataRate}, {LoopBandwidth}, {DampingFactor}, {Source}, {RISing|FALLing|BOTH}, {Multiplier}

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

Defined Values For Parameter ClockMethod

Name | Description
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED | This clock recovery method is used to recovered the clock using the expected nominal data rate entered. It should be the reciprocal of the signal's unit interval.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED_AUTO | This clock recovery method is used to recovered the clock using the signal edge database only. The narrowest pulse is presumed to be an isolated one or zero.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_FIXED_SEMI_AUTO | This clock recovery method is used to recovered the clock using the expected nominal data rate as a "seed" and the signal edge database.
AGINFINIIVISION_VAL_CLOCK_METHOD_FIRST_ORDER_PLL | With First Order PLL, the clock is recovered using the DSP-modeled response of an ideal first-order hardware PLL.
AGINFINIIVISION_VAL_CLOCK_METHOD_SECOND_ORDER_PLL | With Second Order PLL, the clock is recovered using the DSP-modeled response of an ideal Type II, second-order hardware PLL.
AGINFINIIVISION_VAL_CLOCK_RECOVERY_METHOD_EXPLICIT | The clock is recovered from a second signal in your device under test, with a multiplier from 1 to 1000 applied.
Top

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_EDGE_SLOPE_RISING | Rising slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_FALLING | Falling Slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_BOTH | Both Rising and Falling slope.
Top

See Also

Reference

ClockRecovery
AgInfiniiVision


Counter

Counter
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Counter

Branches

Name
Totalize
Top

Functions

 | Name | Description
Function | Configure | This method sets the Counter mode, source and Number of digits of resolution.
Top

Attributes

 | Name | Description
Attribute | Current | Read Only - the current counter value.
Attribute | Enabled | Enables or disables the counter feature.
Attribute | Mode | The counter mode.
Attribute | Number Of Digits | The number of digits of resolution used for the frequency or period counter.
Attribute | Source | The waveform source that the counter measures.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_CounterConfigure Function

AgInfiniiVision_CounterConfigure Function
Counter See Also

This method sets the Counter mode, source and Number of digits of resolution.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Configure
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_CounterConfigure(
    ViSession Vi,
    ViInt32 Mode,
    ViInt32 NumberOfDigits,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 TotalizeSlope
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Mode

The counter mode.

NumberOfDigits

The number of digits of resolution used for the frequency or period counter. This parameter can be used when Mode parameter is set to AgInfiniiVisionCounterModeFrequency and AgInfiniiVisionCounterModePeriod.

SourceBufferSize

Number of elements in Source.

Source

The waveform source that the counter measures. Input value can be from Channel1 to number of analog channels or TQEvent.

TotalizeSlope

Specifies whether positive or negative edges are counted. This parameter can be used when Mode parameter is set to AgInfiniiVisionCounterModeTotalize.

Return Value

Success or failure code.

Remarks

For 4000X series IAgInfiniiVision4Counter.NumberOfDigits is a read only property. So IAgInfiniiVision4Counter.Configure will skip to set IAgInfiniiVision4Counter.NumberOfDigits.

Instrument Command

:COUNter:MODE {FREQuency|PERiod|TOTalize};:COUNter:NDIGits {NumberOfDigits};:COUNter:SOURce {Source};:COUNter:TOTalize:SLOPe {NEGative|POSitive}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Mode

Name | Description
AGINFINIIVISION_VAL_COUNTER_MODE_FREQUENCY | The cycles per second (Hz) of the signal.
AGINFINIIVISION_VAL_COUNTER_MODE_PERIOD | The time periods of the signal's cycles.
AGINFINIIVISION_VAL_COUNTER_MODE_TOTALIZE | The count of edge events on the signal.
Top

Defined Values For Parameter TotalizeSlope

Name | Description
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_NEGATIVE | Negative or falling edge,
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_POSITIVE | Positive or rising edge.
Top

See Also

Reference

Counter
AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_CURRENT Attribute

AGINFINIIVISION_ATTR_COUNTER_CURRENT Attribute
Counter See Also

Read Only - the current counter value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Current
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_CURRENT 1150561

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_CURRENT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:COUNter:CURRent?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Counter
AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_ENABLED Attribute

AGINFINIIVISION_ATTR_COUNTER_ENABLED Attribute
Counter See Also

Enables or disables the counter feature.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_ENABLED 1150559

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is false.

    • Instrument Command

    :COUNter:ENABle {1|0}
    :COUNter:ENABle?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Counter
    AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_MODE Attribute

AGINFINIIVISION_ATTR_COUNTER_MODE Attribute
Counter See Also

The counter mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_MODE 1150558

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is AfInfiniiVisionCounterFrequency.

    • Instrument Command

    :COUNter:MODE {FREQuency|PERiod|TOTalize}
    :COUNter:MODE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_COUNTER_MODE_FREQUENCY | The cycles per second (Hz) of the signal.
AGINFINIIVISION_VAL_COUNTER_MODE_PERIOD | The time periods of the signal's cycles.
AGINFINIIVISION_VAL_COUNTER_MODE_TOTALIZE | The count of edge events on the signal.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Counter
    AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS Attribute

AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS Attribute
Counter See Also

The number of digits of resolution used for the frequency or period counter.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Number Of Digits
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS 1150562

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • For 3000T, M924x and P924x series Input range is 3 to 8 digits.
  • For 4000X series this property is read only.
  • For 6000X series Input range is 3 to 10 digits.
  • Preset value is 5.
  • Higher resolutions require longer gate times, which cause the measurement times to be longer as well.

    • Instrument Command

    :COUNter:NDIGits {value}
    :COUNter:NDIGits?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Counter
    AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_SOURCE Attribute

AGINFINIIVISION_ATTR_COUNTER_SOURCE Attribute
Counter See Also

The waveform source that the counter measures.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_SOURCE 1150560

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input value can be from Channel1 to number of analog channels or TQEvent.
  • Input value TQEvent is not available when Trigger type is edge.
  • Preset value is Channel1.

    • Instrument Command

    :COUNter:SOURce {value}
    :COUNter:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Counter
    AgInfiniiVision


Totalize

Totalize
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize

Branches

Name
Gated
Top

Functions

 | Name | Description
Function | Clear | Zeros the edge event counter.
Top

Attributes

 | Name | Description
Attribute | Event Slope | Specifies whether positive or negative edges are counted.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_CounterTotalizeClear Function

AgInfiniiVision_CounterTotalizeClear Function
Totalize See Also

Zeros the edge event counter.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_CounterTotalizeClear(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:COUNter:TOTalize:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Totalize
AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE Attribute

AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE Attribute
Totalize See Also

Specifies whether positive or negative edges are counted.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Event Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE 1150563

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is AgInfiniiVisionCounterTotalizeEventPolarityPositive.

    • Instrument Command

    :COUNter:TOTalize:SLOPe {NEGative|POSitive}
    :COUNter:TOTalize:SLOPe?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_NEGATIVE | Negative or falling edge,
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_POSITIVE | Positive or rising edge.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Totalize
    AgInfiniiVision


Gated

Gated
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Gated

Functions

 | Name | Description
Function | Configure | This method sets the totalize gated source and polarity.
Top

Attributes

 | Name | Description
Attribute | Enabled | Enables or disables totalizer gating.
Attribute | Polarity | The gating signal condition under which totalizer edges are counted.
Attribute | Source | The analog channel that has the totalizer gating signal.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_CounterTotalizeGatedConfigure Function

AgInfiniiVision_CounterTotalizeGatedConfigure Function
Gated See Also

This method sets the totalize gated source and polarity.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Gated\Configure
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_CounterTotalizeGatedConfigure(
    ViSession Vi,
    ViInt32 Polarity,
    ViInt32 SourceBufferSize,
    ViConstString Source
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Polarity

The gating signal condition under which totalizer edges are counted.

SourceBufferSize

Number of elements in Source.

Source

The analog channel that has the totalizer gating signal. Input value can be from Channel1 to number of analog channels.

Return Value

Success or failure code.

Instrument Command

:COUNter:TOTalize:GATE:POLarity {NEGative|POSitive};:COUNter:TOTalize:GATE:SOURce {Source}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Polarity

Name | Description
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_NEGATIVE | Negative or falling edge,
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_POSITIVE | Positive or rising edge.
Top

See Also

Reference

Gated
AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED Attribute

AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED Attribute
Gated See Also

Enables or disables totalizer gating.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Gated\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED 1150564

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When totalizer gating is enabled, the totalizer only counts edges when a second gating signal polarity is true. The second gating signal can be one of the remaining analog channel inputs.
  • Preset value is false.

    • Instrument Command

    :COUNter:TOTalize:GATE:ENABle {1|0}
    :COUNter:TOTalize:GATE:ENABle?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Gated
    AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY Attribute

AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY Attribute
Gated See Also

The gating signal condition under which totalizer edges are counted.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Gated\Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY 1150566

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The gating signal is specified with the IAgInfiniiVision4CounterTotalizeGated.Source property.
  • Preset value is AgInfiniiVisionTotalizeEventPolarityPositive.

    • Instrument Command

    :COUNter:TOTalize:GATE:POLarity {NEGative|POSitive}
    :COUNter:TOTalize:GATE:POLarity?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_NEGATIVE | Negative or falling edge,
AGINFINIIVISION_VAL_COUNTER_TOTALIZER_POLARITY_POSITIVE | Positive or rising edge.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Gated
    AgInfiniiVision


AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE Attribute

AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE Attribute
Gated See Also

The analog channel that has the totalizer gating signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Counter\Totalize\Gated\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE 1150565

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input value can be from Channel1 to number of analog channels, other than the Channel selected as Countersource using IAgInfiniiVision4Counter.Source property.

    • Instrument Command

    :COUNter:TOTalize:GATE:SOURce {value}
    :COUNter:TOTalize:GATE:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Gated
    AgInfiniiVision


Cursors

Cursors
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Cursors

Functions

 | Name | Description
Function | Use Cursor Position | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
Top

Attributes

 | Name | Description
Attribute | Cursors X Units | The X cursors units.
Attribute | Cursors Y Units | The Y cursors units.
Attribute | Mode | The cursors mode.
Attribute | X Delta | Read Only - The value difference between the current X1 and X2 cursor positions.
Attribute | X1 Position | Specifies the X1 cursor position.
Attribute | X1Y1 Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | X2 Position | Specifies the X2 cursor position.
Attribute | X2Y2 Source | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | Y Delta | Read Only - The value difference between the current Y1 and Y2 cursor positions.
Attribute | Y1 Position | Specifies the Y1 cursor position.
Attribute | Y2 Position | Specifies the Y2 cursor position.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X_UNITS Attribute

AGINFINIIVISION_ATTR_CURSORS_X_UNITS Attribute
Cursors See Also

The X cursors units.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Cursors X Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X_UNITS 1150268

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The XUnits property can be set to one of the following properties

  • AgInfiniiVisionCursorsXUnitsSeconds - for making time measurements.
  • AgInfiniiVisionCursorsXUnitsHz - for making frequency measurements.
  • AgInfiniiVisionCursorsXUnitsDegrees - for making phase measurements.
  • AgInfiniiVisionCursorsXUnitsPercent - for making ratio measurements.

Changing the XUnits property affects the input and output values of the X1Position, X2Position and XDelta properties.

Instrument Command

:MARKer:XUNits {SEC|HERT|DEGR|PERC}
:MARKer:XUNits?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CURSORSX_UNITS_SECONDS | For making time measurements.
AGINFINIIVISION_VAL_CURSORSX_UNITS_HZ | For making frequency measurements.
AGINFINIIVISION_VAL_CURSORSX_UNITS_DEGREES | For making phase measurements.
AGINFINIIVISION_VAL_CURSORSX_UNITS_PERCENT | For making Ratio measurements.
Top

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_Y_UNITS Attribute

AGINFINIIVISION_ATTR_CURSORS_Y_UNITS Attribute
Cursors See Also

The Y cursors units.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Cursors Y Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_Y_UNITS 1150269

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_Y_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionCursorsYUnitsBase - for making measurements in the units associated with the cursors source
  • AgInfiniiVisionCursorsYUnitsPercent - for making ratio measurements

Changing the YUnits property affects the input and output values of the Y1Position, Y2Position and YDelta properties

Instrument Command

:MARKer:YUNits {BASE|PERC}
:MARKer:YUNits?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CURSORSY_UNITS_BASE | For making measurements in the units associated with the cursors source.
AGINFINIIVISION_VAL_CURSORSY_UNITS_PERCENT | For making Ratio measurements.
Top

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_MODE Attribute

AGINFINIIVISION_ATTR_CURSORS_MODE Attribute
Cursors See Also

The cursors mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_MODE 1150007

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MARKer:MODE {OFF|MEAS|MAN|WAV|BIN|HEX}
:MARKer:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_CURSORS_MODE_OFF2 | Removes the cursor information from the display
AGINFINIIVISION_VAL_CURSORS_MODE_MEASUREMENT2 | Cursors track the most recent measurement.
AGINFINIIVISION_VAL_CURSORS_MODE_MANUAL2 | Enables manual placement of the X and Y cursors.
AGINFINIIVISION_VAL_CURSORS_MODE_WAVEFORM2 | The Y1 cursor tracks the voltage value at the X1 cursor of the waveform specified by the X1Y1source, and the Y2 cursor does the same for the X2 cursor and its X2Y2source.
AGINFINIIVISION_VAL_CURSORS_MODE_BINARY | The logic levels of displayed waveforms at the current X1 and X2 cursor positions in binary.
AGINFINIIVISION_VAL_CURSORS_MODE_HEXADECIMAL | The logic levels of displayed waveforms at the current X1 and X2 cursor positions in Hexadecimal.
Top

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AgInfiniiVision_UseCursorPosition Function

AgInfiniiVision_UseCursorPosition Function
Cursors See Also

Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Use Cursor Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_UseCursorPosition(
    ViSession Vi,
    ViInt32 CursorsType
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CursorsType

Specifies the cursors (X or Y) to use.

Return Value

Success or failure code.

Remarks

Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent. The cursors to use (X or Y) are selected using the CursorsType parameter.

The CursorsType parameter can be set to one of the following values:

  • AgInfiniiVisionCursorsUseCursorPositionX - Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent. Sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
  • AgInfiniiVisionCursorsUseCursorPositionY - Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent.

Requirements

Supported Models

All supported

Defined Values For Parameter CursorsType

Name | Description
AGINFINIIVISION_VAL_CURSORS_USE_CURSOR_POSITIONX | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent. Sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
AGINFINIIVISION_VAL_CURSORS_USE_CURSOR_POSITIONY | Sets Y1Position to 0 and Y2Position to 100 if the YUnits property is set to Percent.
Top

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X_DELTA Attribute

AGINFINIIVISION_ATTR_CURSORS_X_DELTA Attribute
Cursors See Also

Read Only - The value difference between the current X1 and X2 cursor positions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\X Delta
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X_DELTA 1150010

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X_DELTA.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MARKer:XDELta?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X1_POSITION Attribute

AGINFINIIVISION_ATTR_CURSORS_X1_POSITION Attribute
Cursors See Also

Specifies the X1 cursor position.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\X1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X1_POSITION 1150153

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X1_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MARKer:X1Position {value}
:MARKer:X1Position?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE Attribute

AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE Attribute
Cursors See Also

The source for the cursors. The channel you specify must be enabled for cursors to be displayed.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\X1Y1 Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE 1150008

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Allowed values are:

"Channel<n>"

"FUNC" (for 1000X/2000X/3000X)

"Math<n>" (for 3000T/4000X/6000X/M924x/P924x)

"Histogram" (for 6000X)

  • If all channels are off or if mode is set to OFF, the query returns NONE.
  • The channel you specify must be enabled for cursors to be displayed, if the channel or function is not on, an error message is issued.

    • Instrument Command

    :MARKer:X1Y1source {value}
    :MARKer:X1Y1source?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Cursors
    AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X2_POSITION Attribute

AGINFINIIVISION_ATTR_CURSORS_X2_POSITION Attribute
Cursors See Also

Specifies the X2 cursor position.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\X2 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X2_POSITION 1150154

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X2_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MARKer:X2Position {value}
:MARKer:X2Position?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE Attribute

AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE Attribute
Cursors See Also

The source for the cursors. The channel you specify must be enabled for cursors to be displayed.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\X2Y2 Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE 1150009

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Allowed values are Channel<n>, FUNC (for 1000X/2000X/3000X), Math<n> (for 4000X), WMEM<n> and Histogram.
  • If all channels are off or if mode is set to OFF, the query returns NONE.

    • Instrument Command

    :MARKer:X2Y2source {value}
    :MARKer:X2Y2source?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Cursors
    AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_Y_DELTA Attribute

AGINFINIIVISION_ATTR_CURSORS_Y_DELTA Attribute
Cursors See Also

Read Only - The value difference between the current Y1 and Y2 cursor positions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Y Delta
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_Y_DELTA 1150011

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_Y_DELTA.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MARKer:YDELta?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION Attribute

AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION Attribute
Cursors See Also

Specifies the Y1 cursor position.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Y1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION 1150155

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MARKer:Y1Position {value}
:MARKer:Y1Position?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION Attribute

AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION Attribute
Cursors See Also

Specifies the Y2 cursor position.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Cursors\Y2 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION 1150156

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MARKer:Y2Position {value}
:MARKer:Y2Position?

Requirements

Supported Models

All supported

See Also

Reference

Cursors
AgInfiniiVision


DigitalChannel

DigitalChannel
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel

Branches

Name
Bus
Top

Functions

 | Name | Description
Function | Digital Channel Fetch Digital Waveform | Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.
Function | Digital Channel Read Activity | Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.
Function | Digital Channel Read Digital Waveform | Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.
Function | Digital Channel Reset Activity | Clears the logic activity registers of the oscilloscope.
Function | Get Digital Channel Name | Returns the digitalchannel name that corresponds to the one-based index that the user specifies.
Top

Attributes

 | Name | Description
Attribute | DigitalChannel Count | Attribute that contains the number of DigitalChannels available on the instrument. This is the maximum index that may be used with the GetDigitalChannelName() function.
Attribute | Enabled | Enables/Disables the specified digital channel.
Attribute | Label | Enables/Disables analog and digital channel labels.
Attribute | Position | The position of the specified channel.
Attribute | Size | Size of digital channels on the display.
Attribute | Threshold | Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).
Top

See Also

Reference

AgInfiniiVision


Bus

Bus
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus

Functions

 | Name | Description
Function | Digital Channel Bus Clear | Excludes all of the digital channels from the selected bus definition.
Function | Digital Channel Bus Enable | Display the selected bus.
Function | Digital Channel Bus Get Channel Bit | Returns the definition for the specified bus.
Function | Digital Channel Bus Get Label | Returns the label of the specified bus.
Function | Digital Channel Bus Get Mask Bit | Returns the mask value for the specified bus.
Function | Digital Channel Bus Is Digital Bit Enabled | Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.
Function | Digital Channel Bus Is Enabled | Returns the flag indicating whether the specified bus is enabled or disabled.
Function | Digital Channel Bus Set Channel Bit | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Function | Digital Channel Bus Set Digital Bit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | Digital Channel Bus Set Label | The bus label.
Function | Digital Channel Bus Set Mask Bit | Bits to be included and excluded in the selected bus according to the mask.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_DigitalChannelBusClear Function

AgInfiniiVision_DigitalChannelBusClear Function
Bus See Also

Excludes all of the digital channels from the selected bus definition.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusClear(
    ViSession Vi,
    ViInt16 BusType
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusEnable Function

AgInfiniiVision_DigitalChannelBusEnable Function
Bus See Also

Display the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Enable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusEnable(
    ViSession Vi,
    ViInt16 BusType,
    ViBoolean ViewState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

ViewState

Current state of bus

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:DISPlay {}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusGetChannelBit Function

AgInfiniiVision_DigitalChannelBusGetChannelBit Function
Bus See Also

Returns the definition for the specified bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Get Channel Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusGetChannelBit(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 ChannelBitBufferSize,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

ChannelBitBufferSize

Number of elements in ChannelBit.

ValBufferSize

Buffer size.

Val

Definition in String format.

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:BITS?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusGetLabel Function

AgInfiniiVision_DigitalChannelBusGetLabel Function
Bus See Also

Returns the label of the specified bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Get Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusGetLabel(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 LabelBufferSize,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

LabelBufferSize

Number of elements in Label.

ValBufferSize

Buffer Size.

Val

Any series of 10 or less characters as a quoted ASCII string.

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusGetMaskBit Function

AgInfiniiVision_DigitalChannelBusGetMaskBit Function
Bus See Also

Returns the mask value for the specified bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Get Mask Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusGetMaskBit(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

ValBufferSize

Number of elements in Val.

Val

The mask value in string format.

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:MASK?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusIsDigitalBitEnabled Function

AgInfiniiVision_DigitalChannelBusIsDigitalBitEnabled Function
Bus See Also

Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Is Digital Bit Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusIsDigitalBitEnabled(
    ViSession Vi,
    ViInt16 BusType,
    ViInt16 DigtalBits,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

DigtalBits

Digital bit to be included in bus definition

Val

0 or 1

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:BIT{DigtalBits}?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusIsEnabled Function

AgInfiniiVision_DigitalChannelBusIsEnabled Function
Bus See Also

Returns the flag indicating whether the specified bus is enabled or disabled.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Is Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusIsEnabled(
    ViSession Vi,
    ViInt16 BusType,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

Val

0 or 1

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusSetChannelBit Function

AgInfiniiVision_DigitalChannelBusSetChannelBit Function
Bus See Also

Includes/Excludes the selected bits in the channel list in the definition of the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Set Channel Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusSetChannelBit(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 ChannelListBufferSize,
    ViConstString ChannelList,
    ViBoolean BitState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

ChannelListBufferSize

Number of elements in ChannelList.

ChannelList

Channel List containing bits to be included/excluded in the bus definition

BitState

Flag indicating bit is enabled or disabled

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:BITS (@{ChannelList}),{}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusSetDigitalBit Function

AgInfiniiVision_DigitalChannelBusSetDigitalBit Function
Bus See Also

Includes/Excludes the selected bit as part of the definition for the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Set Digital Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusSetDigitalBit(
    ViSession Vi,
    ViInt16 BusType,
    ViInt16 DigitalBits,
    ViBoolean BitState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

DigitalBits

DigitalBit(0-15) to be included/excluded in the bus

BitState

Flag indicating bit is enabled or disabled

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:BIT{DigitalBits} {}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusSetLabel Function

AgInfiniiVision_DigitalChannelBusSetLabel Function
Bus See Also

The bus label.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Set Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusSetLabel(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 LabelBufferSize,
    ViConstString Label
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

LabelBufferSize

Number of elements in Label.

Label

Label to the specified bus

Return Value

Success or failure code.

Remarks

Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters.

Instrument Command

:BUS{BusType}:LABel "{Label}"

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelBusSetMaskBit Function

AgInfiniiVision_DigitalChannelBusSetMaskBit Function
Bus See Also

Bits to be included and excluded in the selected bus according to the mask.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Bus\Digital Channel Bus Set Mask Bit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelBusSetMaskBit(
    ViSession Vi,
    ViInt16 BusType,
    ViInt32 MaskBitsBufferSize,
    ViConstString MaskBits
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BusType

Type of Bus: Bus1|Bus2

MaskBitsBufferSize

Number of elements in Mask.

MaskBits

Mask containing bit information

Return Value

Success or failure code.

Instrument Command

:BUS{BusType}:MASK {MaskBits},

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Bus
AgInfiniiVision


AgInfiniiVision_DigitalChannelFetchDigitalWaveform Function

AgInfiniiVision_DigitalChannelFetchDigitalWaveform Function
DigitalChannel See Also

Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Digital Channel Fetch Digital Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelFetchDigitalWaveform(
    ViSession Vi,
    ViConstString DigitalChannel,
    ViInt32 WaveformArrayBufferSize,
    ViByte[] WaveformArray,
    ViInt32* WaveformArrayActualSize,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DigitalChannel

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single digitalchannel.For valid values, see the DigitalChannel repeated capability.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

The waveform data that is the actual data acquired for each point in the specified Channel.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

InitialX

the first data point((XREFerence = 0)

XIncrement

The time difference between consecutive data points in seconds.

Return Value

Success or failure code.

Remarks

  • DigitalChannel<n> will return the waveform for the specified channel, while using DigitalPod<n> will return the waveform for the entire pod.
  • DigitalPod1 consists of DigitalChannel<0-7>
    • DigitalPod2 consists of DigitalChannel<8-15>.

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    DigitalChannel
    AgInfiniiVision


AgInfiniiVision_DigitalChannelReadActivity Function

AgInfiniiVision_DigitalChannelReadActivity Function
DigitalChannel See Also

Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Digital Channel Read Activity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelReadActivity(
    ViSession Vi,
    ViInt32* Edge,
    ViInt32* Level
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Edge

Indicates the presence of edges. A bit = 0 (zero) in the edges result indicates that no edges were detected on that channel since the last query. A bit = 1 (one) in the edges result indicates that edges have been detected on that channel.

Level

indicates logical highs or lows.

Return Value

Success or failure code.

Instrument Command

:ACTivity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AgInfiniiVision_DigitalChannelReadDigitalWaveform Function

AgInfiniiVision_DigitalChannelReadDigitalWaveform Function
DigitalChannel See Also

Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Digital Channel Read Digital Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelReadDigitalWaveform(
    ViSession Vi,
    ViConstString DigitalChannel,
    ViInt32 WaveformArrayBufferSize,
    ViByte[] WaveformArray,
    ViInt32* WaveformArrayActualSize,
    ViReal64* InitialX,
    ViReal64* XIncrement,
    ViInt32 MaxTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DigitalChannel

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single digitalchannel.For valid values, see the DigitalChannel repeated capability.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

The waveform data that is the actual data acquired for each point in the specified Channel.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

InitialX

The x-origin value for the currently specified source. XORigin is the X-axis value of the data point specified by the :Waveform:XREFerence value. It is always the X-axis value of the first data point (XREFerence = 0).

XIncrement

Time difference between consecutive data points in seconds.

MaxTime

Timeout in milliseconds

Return Value

Success or failure code.

Remarks

  • DigitalChannel<n> will return the waveform for the specified channel, while using DigitalPod<n> will return the waveform for the entire pod.
  • DigitalPod1 consists of DigitalChannel<0-7>
    • DigitalPod2 consists of DigitalChannel<8-15>.

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    DigitalChannel
    AgInfiniiVision


AgInfiniiVision_DigitalChannelResetActivity Function

AgInfiniiVision_DigitalChannelResetActivity Function
DigitalChannel See Also

Clears the logic activity registers of the oscilloscope.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Digital Channel Reset Activity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DigitalChannelResetActivity(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:ACTivity

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT Attribute
DigitalChannel See Also

Attribute that contains the number of DigitalChannels available on the instrument. This is the maximum index that may be used with the GetDigitalChannelName() function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\DigitalChannel Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT 1150038

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED Attribute
DigitalChannel See Also

Enables/Disables the specified digital channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED 1150039

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DigitalChannel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DIGital{DigitalChannel}:DISPlay {ON|OFF}
:DIGital{DigitalChannel}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AgInfiniiVision_GetDigitalChannelName Function

AgInfiniiVision_GetDigitalChannelName Function
DigitalChannel See Also

Returns the digitalchannel name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Get Digital Channel Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetDigitalChannelName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL Attribute
DigitalChannel See Also

Enables/Disables analog and digital channel labels.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL 1150040

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DigitalChannel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DIGital{DigitalChannel}:LABel "{value}"
:DIGital{DigitalChannel}:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION Attribute
DigitalChannel See Also

The position of the specified channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION 1150041

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DigitalChannel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If the returned value is "-1", this indicates there is no space to display the digital waveform

Instrument Command

:DIGital{DigitalChannel}:POSition {value}
:DIGital{DigitalChannel}:POSition?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE Attribute
DigitalChannel See Also

Size of digital channels on the display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Size
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE 1150042

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DigitalChannel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DIGital{DigitalChannel}:SIZE {SMAL|LARG|MED}
:DIGital{DigitalChannel}:SIZE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_DIGITAL_CHANNEL_SIZE_SMALL | Small Size
AGINFINIIVISION_VAL_DIGITAL_CHANNEL_SIZE_LARGE | Large size
AGINFINIIVISION_VAL_DIGITAL_CHANNEL_SIZE_MEDIUM | Medium Size
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD Attribute

AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD Attribute
DigitalChannel See Also

Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DigitalChannel\Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD 1150043

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DigitalChannel repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Permissible values are CMOS | ECL | TTL | <user defined value>];user defined value can be from -8.00 to +8.00

Instrument Command

:DIGital{DigitalChannel}:THReshold {value}
:DIGital{DigitalChannel}:THReshold?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

DigitalChannel
AgInfiniiVision


Display

Display
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Display

Branches

Name
Annotation
Top

Functions

 | Name | Description
Function | Display Erase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.
Function | Display Get Screen Bitmap | Reads screen image data
Top

Attributes

 | Name | Description
Attribute | Invert Color Enabled | Specifies whether the graticule colors are inverted or not.
Attribute | Label Enabled | Enable/Disables the analog and digital channel labels.
Attribute | Persistence | Enables or disables infinite-persistence mode of the oscilloscope display.
Attribute | Persistence Time | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.
Attribute | Sidebar | Write Only. Specifies the sidebar dialog to display on the screen.
Attribute | Vector Enabled | Enables or disables the lines drawn between acquired data points on the screen.
Top

See Also

Reference

AgInfiniiVision


Annotation

Annotation
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation

Functions

 | Name | Description
Function | Get Background | Gets the background of the annotation.
Function | Get Color | Gets the annotation color.
Function | Get Enabled | Get the state of annotation.
Function | Get Text | Gets the annotation string.
Function | GetX1 Position | Gets the annotation's horizontal X1 position.
Function | GetY1 Position | Gets the annotation's vertical Y1 position.
Function | Set Background | Sets the background of the annotation.
Function | Set Color | Sets the annotation color.
Function | Set Enabled | Enable or disable the annotation.
Function | Set Text | Sets the annotation string.
Function | SetX1 Position | Sets the annotation's horizontal X1 position.
Function | SetY1 Position | Sets the annotation's vertical Y1 position.
Top

Attributes

 | Name | Description
Attribute | Background | Specifies the background of the annotation.
Attribute | Color | Specifies the annotation color.
Attribute | Enabled | Enables or disables the annotation.
Attribute | Text | Specifies the annotation string.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND Attribute

AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND Attribute
Annotation See Also

Specifies the background of the annotation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Background
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND 1150436

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DISPlay:ANNotation:BACKground {OPAQ|INV|TRAN}
:DISPlay:ANNotation:BACKground?

Defined Values

Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_OPAQUE | The annotation has a solid background.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_INVERTED | The annotation's foreground and background colors are switched.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_TRANSPARENT | The annotation has a transparent background.
Top

Requirements

Supported Models

All supported

See Also

Reference

Annotation
AgInfiniiVision


AGINFINIIVISION_ATTR_ANNOTATION_COLOR Attribute

AGINFINIIVISION_ATTR_ANNOTATION_COLOR Attribute
Annotation See Also

Specifies the annotation color.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Color
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANNOTATION_COLOR 1150437

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANNOTATION_COLOR.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • You can choose white, red, or colors that match analog channels, digital channels, math waveforms, reference waveforms, or markers.

    • Instrument Command

    :DISPlay:ANNotation:COLor {CH1|CH2|CH3|CH4|DIG|MATH|REF|MARK|WHIT|RED}
    :DISPlay:ANNotation:COLor?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL1 | Color that match analog channel 1's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL2 | Color that match analog channel 2's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL3 | Color that match analog channel 3's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL4 | Color that match analog channel 4's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_DIGITAL_CHANNEL | Color that match Digital channel's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MATH_WAVEFORM | Color that match math waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_REFERENCE_WAVEFORM | Color that match reference waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MARKERS | Color that match marker.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_WHITE | White color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_RED | Red color.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Annotation
    AgInfiniiVision


AGINFINIIVISION_ATTR_ANNOTATION_ENABLED Attribute

AGINFINIIVISION_ATTR_ANNOTATION_ENABLED Attribute
Annotation See Also

Enables or disables the annotation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANNOTATION_ENABLED 1150435

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANNOTATION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When set to true, the annotation appears in the upper left corner of the oscilloscope's display.

    • Instrument Command

    :DISPlay:ANNotation {1|0}
    :DISPlay:ANNotation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Annotation
    AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetBackground Function

AgInfiniiVision_DisplayAnnotationGetBackground Function
Annotation See Also

Gets the background of the annotation.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Get Background
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetBackground(
    ViSession Vi,
    ViInt32 Index,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Val

Mode

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:BACKground?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Val

Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_OPAQUE | The annotation has a solid background.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_INVERTED | The annotation's foreground and background colors are switched.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_TRANSPARENT | The annotation has a transparent background.
Top

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetColor Function

AgInfiniiVision_DisplayAnnotationGetColor Function
Annotation See Also

Gets the annotation color.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Get Color
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetColor(
    ViSession Vi,
    ViInt32 Index,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Val

Color

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:COLor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Val

Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL1 | Color that match analog channel 1's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL2 | Color that match analog channel 2's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL3 | Color that match analog channel 3's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL4 | Color that match analog channel 4's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_DIGITAL_CHANNEL | Color that match Digital channel's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MATH_WAVEFORM | Color that match math waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_REFERENCE_WAVEFORM | Color that match reference waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MARKERS | Color that match marker.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_WHITE | White color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_RED | Red color.
Top

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetEnabled Function

AgInfiniiVision_DisplayAnnotationGetEnabled Function
Annotation See Also

Get the state of annotation.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Get Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetEnabled(
    ViSession Vi,
    ViInt32 Index,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Val

1 or 0

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetText Function

AgInfiniiVision_DisplayAnnotationGetText Function
Annotation See Also

Gets the annotation string.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Get Text
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetText(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

ValBufferSize

Buffer size

Val

Text

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:TEXT?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetX1Position Function

AgInfiniiVision_DisplayAnnotationGetX1Position Function
Annotation See Also

Gets the annotation's horizontal X1 position.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\GetX1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetX1Position(
    ViSession Vi,
    ViInt32 Index,
    ViInt64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Val

X1 Position

Return Value

Success or failure code.

Remarks

0 to 800 - width of annotation.

Instrument Command

:DISPlay:ANNotation{Index}:X1Position?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationGetY1Position Function

AgInfiniiVision_DisplayAnnotationGetY1Position Function
Annotation See Also

Gets the annotation's vertical Y1 position.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\GetY1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationGetY1Position(
    ViSession Vi,
    ViInt32 Index,
    ViInt64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Val

Y1 Position

Return Value

Success or failure code.

Remarks

0 to 480 - height of annotation for 3000T, M924x and P924x

0 to 600 - height of annotation for 4000X and 6000X

Instrument Command

:DISPlay:ANNotation{Index}:Y1Position?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetBackground Function

AgInfiniiVision_DisplayAnnotationSetBackground Function
Annotation See Also

Sets the background of the annotation.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Set Background
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetBackground(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 Background
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Background

Background.

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:BACKground {OPAQ|INV|TRAN}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Background

Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_OPAQUE | The annotation has a solid background.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_INVERTED | The annotation's foreground and background colors are switched.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_BACKGROUND_TRANSPARENT | The annotation has a transparent background.
Top

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetColor Function

AgInfiniiVision_DisplayAnnotationSetColor Function
Annotation See Also

Sets the annotation color.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Set Color
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetColor(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 Color
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Color

Color.

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:COLor {CH1|CH2|CH3|CH4|DIG|MATH|REF|MARK|WHIT|RED}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Color

Name | Description
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL1 | Color that match analog channel 1's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL2 | Color that match analog channel 2's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL3 | Color that match analog channel 3's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_CHANNEL4 | Color that match analog channel 4's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_DIGITAL_CHANNEL | Color that match Digital channel's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MATH_WAVEFORM | Color that match math waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_REFERENCE_WAVEFORM | Color that match reference waveform's color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_MARKERS | Color that match marker.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_WHITE | White color.
AGINFINIIVISION_VAL_DISPLAY_ANNOTATION_COLOR_RED | Red color.
Top

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetEnabled Function

AgInfiniiVision_DisplayAnnotationSetEnabled Function
Annotation See Also

Enable or disable the annotation.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Set Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetEnabled(
    ViSession Vi,
    ViInt32 Index,
    ViBoolean Enabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Enabled

Annotation enable.

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index} {ON|OFF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetText Function

AgInfiniiVision_DisplayAnnotationSetText Function
Annotation See Also

Sets the annotation string.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Set Text
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetText(
    ViSession Vi,
    ViInt32 Index,
    ViConstString Text
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Text

Annotation text.

Return Value

Success or failure code.

Instrument Command

:DISPlay:ANNotation{Index}:TEXT "{Text}"

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetX1Position Function

AgInfiniiVision_DisplayAnnotationSetX1Position Function
Annotation See Also

Sets the annotation's horizontal X1 position.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\SetX1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetX1Position(
    ViSession Vi,
    ViInt32 Index,
    ViReal64 Position
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Position

Width of annotation.

Return Value

Success or failure code.

Remarks

0 to 800 - width of annotation.

Instrument Command

:DISPlay:ANNotation{Index}:X1Position {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AgInfiniiVision_DisplayAnnotationSetY1Position Function

AgInfiniiVision_DisplayAnnotationSetY1Position Function
Annotation See Also

Sets the annotation's vertical Y1 position.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\SetY1 Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayAnnotationSetY1Position(
    ViSession Vi,
    ViInt32 Index,
    ViReal64 Position
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

1 to 10 (the annotation ID), Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.Not Supported Models: 1000X, 2000X and 3000X series.

Position

Height of annotation.

Return Value

Success or failure code.

Remarks

0 to 480 - height of annotation for 3000T, M924x and P924x.

0 to 600 - height of annotation for 4000X and 6000X.

Instrument Command

:DISPlay:ANNotation{Index}:Y1Position {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Annotation
AgInfiniiVision


AGINFINIIVISION_ATTR_ANNOTATION_TEXT Attribute

AGINFINIIVISION_ATTR_ANNOTATION_TEXT Attribute
Annotation See Also

Specifies the annotation string.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Annotation\Text
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ANNOTATION_TEXT 1150438

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ANNOTATION_TEXT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The annotation string can contain up to 254 characters.
  • You can include a carriage return in the annotation string using the characters "\n". Note that this is not a new line character but the actual "\" (backslash) and "n" characters in the string. Carriage returns lessen the number of characters available for the annotation string.

    • Instrument Command

    :DISPlay:ANNotation:TEXT "{value}"
    :DISPlay:ANNotation:TEXT?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Annotation
    AgInfiniiVision


AgInfiniiVision_DisplayErase Function

AgInfiniiVision_DisplayErase Function
Display See Also

Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Display Erase
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayErase(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:DISPlay:CLEar

Requirements

Supported Models

All supported

See Also

Reference

Display
AgInfiniiVision


AgInfiniiVision_DisplayGetScreenBitmap Function

AgInfiniiVision_DisplayGetScreenBitmap Function
Display See Also

Reads screen image data

Function Tree Node: \AgInfiniiVision\Instrument Specific\Display\Display Get Screen Bitmap
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_DisplayGetScreenBitmap(
    ViSession Vi,
    ViInt32 ImageFormat,
    ViInt32 Palette,
    ViInt32 ValBufferSize,
    ViByte[] Val,
    ViInt32* ValActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ImageFormat

Image Data format

Palette

Image data palette

ValBufferSize

Number of elements in Val.

Val

Screen image data is returned in the IEEE-488.2 # binary block data format.

ValActualSize

Actual number of elements in Val.

Return Value

Success or failure code.

Instrument Command

:DISPlay:DATA? {BMP|BMP8|PNG}, {COL|GRAY};

Requirements

Supported Models

All supported

Defined Values For Parameter ImageFormat

Name | Description
AGINFINIIVISION_VAL_DISPLAY_IMAGE_FORMATBMP2 | 24-bit BMP
AGINFINIIVISION_VAL_DISPLAY_IMAGE_FORMATBMP8_BIT2 | 8-bit BMP8bit
AGINFINIIVISION_VAL_DISPLAY_IMAGE_FORMATPNG2 | 24-bit PNG
Top

Defined Values For Parameter Palette

Name | Description
AGINFINIIVISION_VAL_DISPLAY_PALETTE_COLOR2 | Color
AGINFINIIVISION_VAL_DISPLAY_PALETTE_GRAYSCALE2 | Grayscale
Top

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED Attribute

AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED Attribute
Display See Also

Specifies whether the graticule colors are inverted or not.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Invert Color Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED 1150431

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:HARDcopy:INKSaver {ON|OFF}
:HARDcopy:INKSaver?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED Attribute

AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED Attribute
Display See Also

Enable/Disables the analog and digital channel labels.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Label Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED 1150016

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DISPlay:LABel {ON|OFF}
:DISPlay:LABel?

Requirements

Supported Models

All supported

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE Attribute

AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE Attribute
Display See Also

Enables or disables infinite-persistence mode of the oscilloscope display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Persistence
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE 1150017

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

AgInfiniiVisionDisplayPersistenceModeAdaptive: All previous acquisitions that have taken place in hardware since the last controller PC screen capture are displayed. Applicable to M924x and P924x only.

Instrument Command

:DISPlay:PERSistence {MIN|INF|ADAP}
:DISPlay:PERSistence?

Defined Values

Name | Description
AGINFINIIVISION_VAL_DISPLAY_PERSISTENCE_MODE_MINIMUM2 | Zero persistence
AGINFINIIVISION_VAL_DISPLAY_PERSISTENCE_MODE_INFINITE2 | Infinite persistence
AGINFINIIVISION_VAL_DISPLAY_PERSISTENCE_MODE_ADAPTIVE | All previous acquisitions that have taken place in hardware since the last controller PC screen capture are displayed.
Top

Requirements

Supported Models

All supported

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME Attribute

AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME Attribute
Display See Also

Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Persistence Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME 1150157

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DISPlay:PERSistence {value}
:DISPlay:PERSistence?

Requirements

Supported Models

All supported

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR Attribute

AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR Attribute
Display See Also

Write Only. Specifies the sidebar dialog to display on the screen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Sidebar
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR 1150434

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR.

AttributeValue

The value to which to set the attribute.

Instrument Command

:DISPlay:SIDebar {SUMM|CURS|MEAS|DVM|NAV|CONT|HIST|EVEN|COUN}

Defined Values

Name | Description
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_SUMMARY | Display Summary on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_CURSORS | Display Cursors information on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_MEASUREMENTS | Display measurements on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBARDVM | Display DVM information on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_NAVIGATE | Display navigation information on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_CONTROLS | Display controls on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_HISTOGRAM | Display Histogram's information on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_EVENTS | Display Events on screen's sidebar.
AGINFINIIVISION_VAL_DISPLAY_SIDEBAR_COUNTER | Display counter on screen's sidebar.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Display
AgInfiniiVision


AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED Attribute

AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED Attribute
Display See Also

Enables or disables the lines drawn between acquired data points on the screen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Display\Vector Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED 1150165

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • 1000X, 2000X, 3000X, 3000T, M924x and P924x: The vector setting cannot be adjusted by user (this property will always return true).
  • 4000X: The vector setting can only be adjusted on models with bandwidth greater or equal to 1GHz.
  • 6000X: The vector setting can only be adjusted on models with bandwidth greater or equal to 6GHz.

    • Instrument Command

    :DISPlay:VECTors {ON|OFF}
    :DISPlay:VECTors?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Display
    AgInfiniiVision


DVM

DVM
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\DVM

Attributes

 | Name | Description
Attribute | Auto Range Enabled | Enables or disables the Digital Voltmeter's Auto Range capability.
Attribute | Current | Read Only - Returns the displayed 3-digit DVM value based on the current mode.
Attribute | Enabled | Enables or disables the Digital Voltmeter (DVM) analysis feature.
Attribute | Frequency | Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.
Attribute | Mode | Specifies the digital voltmeter (DVM) mode.
Attribute | Source | Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED Attribute

AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED Attribute
DVM See Also

Enables or disables the Digital Voltmeter's Auto Range capability.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Auto Range Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED 1150439

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DVM:ARANge {ON|OFF}
:DVM:ARANge?

Requirements

Supported Models

All supported

See Also

Reference

DVM
AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_CURRENT Attribute

AGINFINIIVISION_ATTR_DVM_CURRENT Attribute
DVM See Also

Read Only - Returns the displayed 3-digit DVM value based on the current mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Current
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_CURRENT 1150440

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_CURRENT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:DVM:CURRent?

Requirements

Supported Models

All supported

See Also

Reference

DVM
AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_ENABLED Attribute

AGINFINIIVISION_ATTR_DVM_ENABLED Attribute
DVM See Also

Enables or disables the Digital Voltmeter (DVM) analysis feature.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_ENABLED 1150441

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DVM:ENABle {1|0}
:DVM:ENABle?

Requirements

Supported Models

All supported

See Also

Reference

DVM
AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_FREQUENCY Attribute

AGINFINIIVISION_ATTR_DVM_FREQUENCY Attribute
DVM See Also

Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_FREQUENCY 1150442

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_FREQUENCY.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Remarks

For 3000T, 4000X and 6000X series, the Frequency capability is accessible from the Counter interface

Instrument Command

:DVM:FREQuency?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3014A, DSO-X 3024A, DSO-X 3032A, DSO-X 3034A, DSO-X 3052A, DSO-X 3054A, DSO-X 3102A, DSO-X 3104A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3014A, MSO-X 3024A, MSO-X 3032A, MSO-X 3034A, MSO-X 3052A, MSO-X 3054A, MSO-X 3102A, MSO-X 3104A

See Also

Reference

DVM
AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_MODE Attribute

AGINFINIIVISION_ATTR_DVM_MODE Attribute
DVM See Also

Specifies the digital voltmeter (DVM) mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_MODE 1150443

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DVM:MODE {ACRM|DC|DCRM|FREQ}
:DVM:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_DVM_MODE_ACRMS | Displays the root-mean-square value of the acquired data, with the DC component removed.
AGINFINIIVISION_VAL_DVM_MODE_DC | Displays the DC value of the acquired data.
AGINFINIIVISION_VAL_DVM_MODE_DCRMS | Displays the root-mean-square value of the acquired data.
AGINFINIIVISION_VAL_DVM_MODE_FREQUENCY | Not Supported by 3000T/4000X/6000X series models. Displays the frequency counter measurement.
Top

Requirements

Supported Models

All supported

See Also

Reference

DVM
AgInfiniiVision


AGINFINIIVISION_ATTR_DVM_SOURCE Attribute

AGINFINIIVISION_ATTR_DVM_SOURCE Attribute
DVM See Also

Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\DVM\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DVM_SOURCE 1150444

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DVM_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:DVM:SOURce {value}
:DVM:SOURce?

Requirements

Supported Models

All supported

See Also

Reference

DVM
AgInfiniiVision


External

External
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\External

Attributes

 | Name | Description
Attribute | Enabled | Enables or disables the external trigger input display.
Attribute | Label | The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).
Attribute | Probe Attenuation | Scaling factor by which the probe attached to the external trigger attenuates the input.
Attribute | Probe Sense | Read Only - Probe attenuation value that the oscilloscope automatically senses.
Attribute | Range | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.
Attribute | Threshold | The external trigger input threshold (trigger) voltage level in volts.
Attribute | Units | The measurement units for the probe connected to the external trigger input.
Attribute | Vertical Position | The external trigger input waveform's vertical position on the oscilloscope display.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_ENABLED Attribute

AGINFINIIVISION_ATTR_EXTERNAL_ENABLED Attribute
External See Also

Enables or disables the external trigger input display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_ENABLED 1150678

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:EXTernal:DISPlay {1|0}
:EXTernal:DISPlay?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_LABEL Attribute

AGINFINIIVISION_ATTR_EXTERNAL_LABEL Attribute
External See Also

The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_LABEL 1150679

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Label strings are 10 characters or less, and may contain any commonly used ASCII characters. Labels with more than 10 characters are truncated to 10 characters. Lower case characters are converted to upper case.

    • Instrument Command

    :EXTernal:LABel {value}
    :EXTernal:LABel?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    External
    AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION Attribute

AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION Attribute
External See Also

Scaling factor by which the probe attached to the external trigger attenuates the input.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Probe Attenuation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION 1150012

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The probe attenuation factor may be from 0.1 to 1000. For example, with a 10:1 probe, the value is 10.0.

Instrument Command

:EXTernal:PROBe {value}
:EXTernal:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE Attribute

AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE Attribute
External See Also

Read Only - Probe attenuation value that the oscilloscope automatically senses.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Probe Sense
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE 1150013

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:EXTernal:PROBe?

Requirements

Supported Models

All supported

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_RANGE Attribute

AGINFINIIVISION_ATTR_EXTERNAL_RANGE Attribute
External See Also

Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_RANGE 1150015

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

When using 1:1 probe attenuation, the range can only be set to 8.0 V.

Instrument Command

:EXTernal:RANGe {value}
:EXTernal:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD Attribute

AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD Attribute
External See Also

The external trigger input threshold (trigger) voltage level in volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD 1150680

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:EXTernal:LEVel {value}
:EXTernal:LEVel?

Requirements

Supported Models

DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_UNITS Attribute

AGINFINIIVISION_ATTR_EXTERNAL_UNITS Attribute
External See Also

The measurement units for the probe connected to the external trigger input.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_UNITS 1150014

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:EXTernal:UNITs {VOLT|AMP}
:EXTernal:UNITs?

Defined Values

Name | Description
AGINFINIIVISION_VAL_EXTERNAL_PROBE_UNITS_VOLTS2 | VOLT for a voltage probe
AGINFINIIVISION_VAL_EXTERNAL_PROBE_UNITS_AMPERES2 | AMPere for a current probe
Top

Requirements

Supported Models

All supported

See Also

Reference

External
AgInfiniiVision


AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION Attribute

AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION Attribute
External See Also

The external trigger input waveform's vertical position on the oscilloscope display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\External\Vertical Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION 1150681

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When the external trigger input's waveform is displayed, a cyan digital waveform, based on the threshold voltage level, appears on the oscilloscope display. This waveform is one division tall, and the base of the waveform can be positioned from -3.5 divisions to 2.5 divisions.

    • Instrument Command

    :EXTernal:POSition {value}
    :EXTernal:POSition?

    Requirements

    Supported Models

    DSO-X 1102A, DSO-X 1102G, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G

    See Also

    Reference

    External
    AgInfiniiVision


FFT

FFT
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\FFT

Functions

 | Name | Description
Function | Clear | Clears the number of evaluated waveforms.
Top

Attributes

 | Name | Description
Attribute | Average Count | Sets and gets the number of waveforms to be averaged together.
Attribute | Center Frequency | Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.
Attribute | Display Mode | Sets and gets the FFT waveform display modes.
Attribute | Enabled | Enable or disable the display of the FFT function.
Attribute | Offset | Sets and gets the FFT vertical value represented at center screen.
Attribute | Range | Sets and gets the full-scale vertical axis for the FFT function.
Attribute | Source | Sets and gets the source for the FFT function.
Attribute | Span | Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.
Attribute | Start Frequency | Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | Stop Frequency | Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | Vertical Units | Specifies the FFT vertical units.
Attribute | Window Type | Windowing transforms for the FFT.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT Attribute

AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT Attribute
FFT See Also

Sets and gets the number of waveforms to be averaged together.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Average Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT 1150644

ViStatus AgInfiniiVision_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:FFT:AVERage:COUNt {value}
:FFT:AVERage:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY Attribute
FFT See Also

Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Center Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY 1150636

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:CENTer {value}
:FFT:CENTer?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AgInfiniiVision_FFTClear Function

AgInfiniiVision_FFTClear Function
FFT See Also

Clears the number of evaluated waveforms.

Function Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FFTClear(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:FFT:CLEar

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE Attribute

AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE Attribute
FFT See Also

Sets and gets the FFT waveform display modes.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Display Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE 1150637

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:DMODe {NORM|AVER|MAXH|MINH}
:FFT:DMODe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATHFFT_DISPLAY_MODE_NORMAL | Normal.
AGINFINIIVISION_VAL_MATHFFT_DISPLAY_MODE_AVERAGE | Average.
AGINFINIIVISION_VAL_MATHFFT_DISPLAY_MODE_MAX_HOLD | Maximum hold.
AGINFINIIVISION_VAL_MATHFFT_DISPLAY_MODE_MIN_HOLD | Minimum hold.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_ENABLED Attribute

AGINFINIIVISION_ATTR_ENABLED Attribute
FFT See Also

Enable or disable the display of the FFT function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ENABLED 1150645

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When ON is selected, the FFT function is calculated and displayed.
  • When OFF is selected, the FFT function is neither calculated nor displayed.

    • Instrument Command

    :FFT:DISPlay {ON|OFF}
    :FFT:DISPlay?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_OFFSET Attribute

AGINFINIIVISION_ATTR_FFT_OFFSET Attribute
FFT See Also

Sets and gets the FFT vertical value represented at center screen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_OFFSET 1150641

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:OFFSet {value}
:FFT:OFFSet?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_RANGE Attribute

AGINFINIIVISION_ATTR_FFT_RANGE Attribute
FFT See Also

Sets and gets the full-scale vertical axis for the FFT function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_RANGE 1150642

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:RANGe {value}
:FFT:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_SOURCE Attribute

AGINFINIIVISION_ATTR_FFT_SOURCE Attribute
FFT See Also

Sets and gets the source for the FFT function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_SOURCE 1150640

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:SOURce1 {value}
:FFT:SOURce1?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_SPAN Attribute

AGINFINIIVISION_ATTR_FFT_SPAN Attribute
FFT See Also

Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Span
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_SPAN 1150635

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_SPAN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:SPAN {value}
:FFT:SPAN?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_START_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FFT_START_FREQUENCY Attribute
FFT See Also

Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Start Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_START_FREQUENCY 1150633

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_START_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:FREQuency:STARt {value}
:FFT:FREQuency:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY Attribute
FFT See Also

Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Stop Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY 1150634

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:FREQuency:STOP {value}
:FFT:FREQuency:STOP?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT Attribute

AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT Attribute
FFT See Also

Specifies the FFT vertical units.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Vertical Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT 1150638

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:VTYPe {DEC|VRMS}
:FFT:VTYPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSDB | Specifies FFT vertical units as Decibels.
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSVRMS | Specifies the FFT vertical units as VRMS.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE Attribute

AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE Attribute
FFT See Also

Windowing transforms for the FFT.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FFT\Window Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE 1150639

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FFT:WINDow {RECT|HANN|FLAT|BHAR}
:FFT:WINDow?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_RECTANGULAR | RECTangular: Useful for transient signals, and signals where there are an integral number of cycles in the time record
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_HANNING | HANNing: Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_FLAT_TOP | FLATtop: Best for making accurate amplitude measurements of frequency peaks.
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPEB_HARRIS | BHARris (Blackman-Harris): Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T

See Also

Reference

FFT
AgInfiniiVision


FRA

FRA
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\FRA

Functions

 | Name | Description
Function | FetchData | Fetch the frequency response analysis data.
Function | Get Amplitude Profile | Returns waveform generator amplitude in the frequency response analysis.
Function | Run | Initiates the Frequency Response Analysis.
Function | Set Amplitude Profile | Return the waveform generator's output sine wave amplitude.
Top

Attributes

 | Name | Description
Attribute | Amplitude | The waveform generator amplitude in the frequency response analysis.
Attribute | Amplitude Profile State | Enables or disables the ability to specify amplitude ramping within different decades
Attribute | Enabled | Enables or disables the Frequency Response Analysis (FRA) feature.
Attribute | Input Source | The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.
Attribute | Output Load Impedance | The current expected output load impedance
Attribute | Output Source | The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.
Attribute | Points Per Decade | The number of points per decade in the frequency response analysis.
Attribute | Start Frequency | The frequency sweep start value.
Attribute | Stop Frequency | The frequency sweep stop value.
Attribute | Sweep Mode | Select between the normal swept frequency response analysis or analysis at a single frequency
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_AMPLITUDE Attribute

AGINFINIIVISION_ATTR_FRA_AMPLITUDE Attribute
FRA See Also

The waveform generator amplitude in the frequency response analysis.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Amplitude
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_AMPLITUDE 1150697

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_AMPLITUDE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:WGEN:VOLTage {value}
:FRANalysis:WGEN:VOLTage?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE Attribute

AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE Attribute
FRA See Also

Enables or disables the ability to specify amplitude ramping within different decades

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Amplitude Profile State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE 1150695

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:WGEN:VOLTage:PROFile {1|0}
:FRANalysis:WGEN:VOLTage:PROFile?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_ENABLED Attribute

AGINFINIIVISION_ATTR_FRA_ENABLED Attribute
FRA See Also

Enables or disables the Frequency Response Analysis (FRA) feature.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_ENABLED 1150686

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:ENABle
:FRANalysis:ENABle?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AgInfiniiVision_FRAFetchData Function

AgInfiniiVision_FRAFetchData Function
FRA See Also

Fetch the frequency response analysis data.

Function Tree Node: \AgInfiniiVision\Instrument Specific\FRA\FetchData
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FRAFetchData(
    ViSession Vi,
    ViInt32 FrequencyBufferSize,
    ViReal64[] Frequency,
    ViInt32* FrequencyActualSize,
    ViInt32 AmplitudeBufferSize,
    ViReal64[] Amplitude,
    ViInt32* AmplitudeActualSize,
    ViInt32 GainBufferSize,
    ViReal64[] Gain,
    ViInt32* GainActualSize,
    ViInt32 PhaseBufferSize,
    ViReal64[] Phase,
    ViInt32* PhaseActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

FrequencyBufferSize

Number of elements in Frequency.

Frequency

Frequency

FrequencyActualSize

Actual number of elements in Frequency.

AmplitudeBufferSize

Number of elements in Amplitude.

Amplitude

Amplitude

AmplitudeActualSize

Actual number of elements in Amplitude.

GainBufferSize

Number of elements in Gain.

Gain

Gain

GainActualSize

Actual number of elements in Gain.

PhaseBufferSize

Number of elements in Phase.

Phase

Phase

PhaseActualSize

Actual number of elements in Phase.

Return Value

Success or failure code.

Instrument Command

:FRANalysis:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AgInfiniiVision_FRAGetAmplitudeProfile Function

AgInfiniiVision_FRAGetAmplitudeProfile Function
FRA See Also

Returns waveform generator amplitude in the frequency response analysis.

Function Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Get Amplitude Profile
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FRAGetAmplitudeProfile(
    ViSession Vi,
    ViInt32 Range,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Range

Range

Val

Range

Return Value

Success or failure code.

Instrument Command

:FRANalysis:WGEN:VOLTage? {F20HZ|F100HZ|F10KHZ|F100KHZ|F1MHZ|F10MHZ|F20MHZ|F1KHZ}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Range

Name | Description
AGINFINIIVISION_VAL_FRA_AMP_RANGE_20HZ | Amplitude at 20Hz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_100HZ | Amplitude at 100Hz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_10KHZ | Amplitude at 10KHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_100KHZ | Amplitude at 100KHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_1MHZ | Amplitude at 1MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_10MHZ | Amplitude at 10MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_20MHZ | Amplitude at 20MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_1KHZ | Amplitude at 1KHz
Top

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE Attribute

AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE Attribute
FRA See Also

The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Input Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE 1150689

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:SOURce:INPut {value}
:FRANalysis:SOURce:INPut?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE Attribute

AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE Attribute
FRA See Also

The current expected output load impedance

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Output Load Impedance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE 1150698

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:WGEN:LOAD {ONEM|FIFT}
:FRANalysis:WGEN:LOAD?

Defined Values

Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_ONE_MEG | One Mega Ohm
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_FIFTY | Fifty Ohm
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE Attribute

AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE Attribute
FRA See Also

The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Output Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE 1150690

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:SOURce:OUTPut {value}
:FRANalysis:SOURce:OUTPut?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE Attribute

AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE Attribute
FRA See Also

The number of points per decade in the frequency response analysis.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Points Per Decade
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE 1150692

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:PPDecade {value}
:FRANalysis:PPDecade?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AgInfiniiVision_FRARun Function

AgInfiniiVision_FRARun Function
FRA See Also

Initiates the Frequency Response Analysis.

Function Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Run
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FRARun(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • This analysis controls the built-in waveform generator to sweep a sine wave across a range of frequencies while measuring the input to and output from a device under test (DUT). At each frequency, gain (A) and phase are measured and plotted on a Bode frequency response chart.
  • When the frequency response analysis completes, you can use the FetchData method to get list of data for each step in the sweep: Frequency (Hz), Amplitude (Vpp), Gain (dB), and Phase (�).
  • It takes some time for the frequency sweep analysis to complete. You can query bit 0 of the Standard Event Status Register to find out when the analysis is complete.
  • Ensure that System::TimeoutMilliseconds is set to the appropriate value before calling FRA::Run. A typical sweep may take up to 1 minute."

    • Instrument Command

    :FRANalysis:RUN

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FRA
    AgInfiniiVision


AgInfiniiVision_FRASetAmplitudeProfile Function

AgInfiniiVision_FRASetAmplitudeProfile Function
FRA See Also

Return the waveform generator's output sine wave amplitude.

Function Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Set Amplitude Profile
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FRASetAmplitudeProfile(
    ViSession Vi,
    ViReal64 Amplitude,
    ViInt32 Range
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Amplitude

Amplitude

Range

Range

Return Value

Success or failure code.

Remarks

  • When the amplitude profile setting is on, the range option specifies the frequency
  • whose initial ramp amplitude is returned

    • Instrument Command

    :FRANalysis:WGEN:VOLTage {Amplitude}, {F20HZ|F100HZ|F10KHZ|F100KHZ|F1MHZ|F10MHZ|F20MHZ|F1KHZ}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    Defined Values For Parameter Range

    Name | Description
AGINFINIIVISION_VAL_FRA_AMP_RANGE_20HZ | Amplitude at 20Hz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_100HZ | Amplitude at 100Hz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_10KHZ | Amplitude at 10KHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_100KHZ | Amplitude at 100KHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_1MHZ | Amplitude at 1MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_10MHZ | Amplitude at 10MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_20MHZ | Amplitude at 20MHz
AGINFINIIVISION_VAL_FRA_AMP_RANGE_1KHZ | Amplitude at 1KHz
    Top

    See Also

    Reference

    FRA
    AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_START_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FRA_START_FREQUENCY Attribute
FRA See Also

The frequency sweep start value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Start Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_START_FREQUENCY 1150687

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_START_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:FREQuency:STARt {value}
:FRANalysis:FREQuency:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY Attribute
FRA See Also

The frequency sweep stop value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Stop Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY 1150688

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:FREQuency:STOP
:FRANalysis:FREQuency:STOP?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


AGINFINIIVISION_ATTR_FRA_SWEEP_MODE Attribute

AGINFINIIVISION_ATTR_FRA_SWEEP_MODE Attribute
FRA See Also

Select between the normal swept frequency response analysis or analysis at a single frequency

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\FRA\Sweep Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FRA_SWEEP_MODE 1150693

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FRA_SWEEP_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:FRANalysis:FREQuency:MODE {SING|SWE}
:FRANalysis:FREQuency:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_FRA_FREQ_MODE_SINGLE | AgInfiniiVisionFRAFreqModeSingle - Runs the FRA at a single frequency. Useful for debugging purposes.
AGINFINIIVISION_VAL_FRA_FREQ_MODE_SWEEP | AgInfiniiVisionFRAFreqModeSweep - Runs the FRA in a normal frequency sweep (range) mode
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204G, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FRA
AgInfiniiVision


Histogram

Histogram
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Histogram

Branches

Name
Window
Top

Functions

 | Name | Description
Function | Get Result | Returns the histogram result of the selected result type.
Function | Reset | Zeros the histogram counters.
Top

Attributes

 | Name | Description
Attribute | Axis | The orientation of the histogram.
Attribute | Display Enabled | Enable or disable the histogram display.
Attribute | Measurement | The measurement to analyze.
Attribute | Mode | The type of histogram or disables the histogram analysis feature.
Attribute | Size | The number of divisions the histogram bar graph should use.
Attribute | Type | The histogram type.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_AXIS Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_AXIS Attribute
Histogram See Also

The orientation of the histogram.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Axis
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_AXIS 1150567

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_AXIS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When the value of IAgInfiniium4Histogram.Mode property is selected as AgInfiniiVisionHistogramModeWaveform, this property specifies the orientation of the histogram
  • When the value of IAgInfiniium4Histogram.Mode property is selected as AgInfiniiVisionHistogramModeMeasurement, histograms are always displayed horizontally at the bottom of the graticule.
  • Preset value is AgInfiniiVisionHistogramAxisHorizontal.

    • Instrument Command

    :HISTogram:AXIS {VERTical|HORizontal}
    :HISTogram:AXIS?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_HISTOGRAM_AXIS_VERTICAL | The limits window is divided into rows, and the number of hits in each row is displayed in a histogram bar graph at the left of the graticule.
AGINFINIIVISION_VAL_HISTOGRAM_AXIS_HORIZONTAL | The limits window is divided into columns, and the number of hits in each column is displayed in a histogram bar graph at the bottom of the graticule.
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED Attribute
Histogram See Also

Enable or disable the histogram display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Display Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED 1150572

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is false.

    • Instrument Command

    :HISTogram:DISPlay {1|0}
    :HISTogram:DISPlay?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


AgInfiniiVision_HistogramGetResult Function

AgInfiniiVision_HistogramGetResult Function
Histogram See Also

Returns the histogram result of the selected result type.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Get Result
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_HistogramGetResult(
    ViSession Vi,
    ViInt32 ResultType,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ResultType

Result type.

Val

The histogram result of the selected result type.

Return Value

Success or failure code.

Remarks

  • Available when Mode property is set to AgInfiniiVisionHistogramModeMeasurement and DisplayEnabled property is set to true.

    • Instrument Command

    :MEASure:HISTogram:{BWIDth|HITS|M1S|M2S|M3S|MAXimum|MEAN|MEDian|MINimum|MODE|PEAK|PPEak|SDEViation}?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    Defined Values For Parameter ResultType

    Name | Description
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_BANDWIDTH | The width of each bin (bucket) in the histogram.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_HITS | The sum of all hits in all bins (buckets) in the histogram.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_M1S | The percentage of histogram hits that lie within +-1 Std Dev of the mean.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_M2S | The percentage of histogram hits that lie within +-2 Std Dev of the mean.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_M3S | The percentage of histogram hits that lie within +-3 Std Dev of the mean.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_MAXIMUM | The value corresponding to the maximum bin that has any hits.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_MEAN | The mean value of the histogram.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_MEDIAN | The median value of the histogram.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_MINIMUM | The value corresponding to the minimum bin that has any hits.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_MODE | The mode value of the histogram.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_PEAK | The maximum number of hits in any single bin.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_PEAK_TO_PEAK | The delta between the Max and Min values.
AGINFINIIVISION_VAL_HISTOGRAM_RESULT_TYPE_STANDARD_DEVIATION | The standard deviation of the histogram values.
    Top

    See Also

    Reference

    Histogram
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT Attribute
Histogram See Also

The measurement to analyze.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT 1150570

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Available when Mode property is set to AgInfiniiVisionHistogramModeMeasurement.
  • You can select a measurement slot if a measurement is installed at that slot using AgInfiniiVisionMeasurementEnum

    • Instrument Command

    :HISTogram:MEASurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
    :HISTogram:MEASurement?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_NONE | None.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_1 | Measurement 1.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_2 | Measurement 2.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_3 | Measurement 3.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_4 | Measurement 4.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_5 | Measurement 5.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_6 | Measurement 6.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_7 | Measurement 7.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_8 | Measurement 8.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_9 | Measurement 9.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_10 | Measurement 10.
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_MODE Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_MODE Attribute
Histogram See Also

The type of histogram or disables the histogram analysis feature.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_MODE 1150568

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is AgInfiniiVisionHistogramModeOff.

    • Instrument Command

    :HISTogram:MODE {OFF|WAVeform|MEASurement}
    :HISTogram:MODE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_HISTOGRAM_MODE_OFF | Disables the histogram analysis feature.
AGINFINIIVISION_VAL_HISTOGRAM_MODE_WAVEFORM | shows the number of times a waveform crosses into (or hits) a row or column of a user-defined window. For vertical histograms, the window is divided into rows.
AGINFINIIVISION_VAL_HISTOGRAM_MODE_MEASUREMENT | Shows the distribution of a measurement's results just like ordinary measurement statistics.
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


AgInfiniiVision_HistogramReset Function

AgInfiniiVision_HistogramReset Function
Histogram See Also

Zeros the histogram counters.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Reset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_HistogramReset(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:HISTogram:RESet

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Histogram
AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_SIZE Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_SIZE Attribute
Histogram See Also

The number of divisions the histogram bar graph should use.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Size
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_SIZE 1150569

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_SIZE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • For horizontal histograms, whole and half divisions from 1 to 4 can be selected as input.
  • For vertical histograms, whole and half divisions from 1 to 5 can be selected as input.

    • Instrument Command

    :HISTogram:SIZE {value}
    :HISTogram:SIZE?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_TYPE Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_TYPE Attribute
Histogram See Also

The histogram type.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_TYPE 1150571

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is AgInfiniiVIsionHistogramTypeHorizontal.

    • Instrument Command

    :HISTogram:TYPE {VERTical|HORizontal|MEASurement}
    :HISTogram:TYPE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_HISTOGRAM_TYPE_VERTICAL | The limits window is divided into rows, and the number of hits in each row is displayed in a histogram bar graph at the left of the graticule.
AGINFINIIVISION_VAL_HISTOGRAM_TYPE_HORIZONTAL | The limits window is divided into columns, and the number of hits in each column is displayed in a histogram bar graph at the bottom of the graticule.
AGINFINIIVISION_VAL_HISTOGRAM_TYPE_MEASUREMENT | Shows the distribution of a measurement's results just like ordinary measurement statistics.
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Histogram
    AgInfiniiVision


Window

Window
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window

Branches

Name
Limits
Top

Attributes

 | Name | Description
Attribute | Source | The waveform that is used as the histogram source.
Top

See Also

Reference

AgInfiniiVision


Limits

Limits
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Limits

Attributes

 | Name | Description
Attribute | Bottom | The histogram limits window's bottom boundary.
Attribute | Left | The histogram limits window's left boundary.
Attribute | Right | The histogram limits window's right boundary.
Attribute | Top | The histogram limits window's top boundary.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM Attribute
Limits See Also

The histogram limits window's bottom boundary.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Limits\Bottom
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM 1150575

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is -15.0.

    • Instrument Command

    :HISTogram:WINDow:BLIMit {value}
    :HISTogram:WINDow:BLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Limits
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT Attribute
Limits See Also

The histogram limits window's left boundary.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Limits\Left
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT 1150577

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is -400.0E-06.

    • Instrument Command

    :HISTogram:WINDow:LLIMit {value}
    :HISTogram:WINDow:LLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Limits
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT Attribute
Limits See Also

The histogram limits window's right boundary.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Limits\Right
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT 1150576

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is 400.0E-06.

    • Instrument Command

    :HISTogram:WINDow:RLIMit {value}
    :HISTogram:WINDow:RLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Limits
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP Attribute
Limits See Also

The histogram limits window's top boundary.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Limits\Top
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP 1150574

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units are the same as the input waveform's vertical units.
  • Preset value is 15.0.

    • Instrument Command

    :HISTogram:WINDow:TLIMit {value}
    :HISTogram:WINDow:TLIMit?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Limits
    AgInfiniiVision


AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE Attribute

AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE Attribute
Window See Also

The waveform that is used as the histogram source.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Histogram\Window\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE 1150573

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Input value could be one of the following

  • Channel1 to Number of analog channels.
  • Math1, Math2, Math3 or Math4.
  • WMEM1 to number of reference waveforms.

The preset value is Channel1.

Instrument Command

:HISTogram:WINDow:SOURce {value}
:HISTogram:WINDow:SOURce?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Window
AgInfiniiVision


Jitter

Jitter
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter

Branches

Name
Spectrum
Trend
Top

Functions

 | Name | Description
Function | Configure Histogram | Auto-configures and turns on the jitter measurement histogram for the selected measurement.
Top

Attributes

 | Name | Description
Attribute | Analysis Enabled | Enables or disables the jitter analysis feature.
Attribute | Measurement | The measurement to analyze.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED Attribute

AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED Attribute
Jitter See Also

Enables or disables the jitter analysis feature.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Analysis Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED 1150578

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

When jitter analysis is enabled, these oscilloscope settings are forced on:

  • Precision measurements with a 1M precision analysis record length, which gives better accuracy.
  • All edges in each acquisition are measured (instead of a single edge per acquisition, as is normally the case). For each acquisition, the measurement count increases by the number of edges in the acquisition. This applies to all measurements that look at edges, not just jitter analysis measurements.

When jitter analysis is disabled:
  • The "precision measurements" and 1M precision analysis record length settings are returned to the settings present when jitter analysis was enabled.
  • The oscilloscope returns to measuring a specific edge in each acquisition (generally around the horizontal time reference) and ignoring all other edges in the acquisition, as is normally the case. For each acquisition, the measurement count increases by one.

The preset value is false.

Instrument Command

:JITTer:STATe {1|0}
:JITTer:STATe?

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Jitter
AgInfiniiVision


AgInfiniiVision_JitterConfigureHistogram Function

AgInfiniiVision_JitterConfigureHistogram Function
Jitter See Also

Auto-configures and turns on the jitter measurement histogram for the selected measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Configure Histogram
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_JitterConfigureHistogram(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:HISTogram:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Jitter
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_MEASUREMENT Attribute

AGINFINIIVISION_ATTR_JITTER_MEASUREMENT Attribute
Jitter See Also

The measurement to analyze.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_MEASUREMENT 1150579

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_MEASUREMENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The measurement slot you specify must have one of these measurements installed:

  • Data TIE (time interval error).
  • Time interval error measurements use clock recovery.
  • Clock TIE (time interval error).
  • Time interval error measurements use clock recovery.
  • N-Period.
  • N-Period to N-Period.
  • +Width to +Width.
  • -Width to -Width.
  • +Duty Cycle.

Instrument Command

:JITTer:MEASurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
:JITTer:MEASurement?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_NONE | None.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_1 | Measurement 1.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_2 | Measurement 2.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_3 | Measurement 3.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_4 | Measurement 4.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_5 | Measurement 5.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_6 | Measurement 6.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_7 | Measurement 7.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_8 | Measurement 8.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_9 | Measurement 9.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_10 | Measurement 10.
Top

Requirements

Supported Models

DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Jitter
AgInfiniiVision


Spectrum

Spectrum
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum

Branches

Name
Horizontal
Vertical
Top

Functions

 | Name | Description
Function | Enable | Auto-configures and turns on the jitter spectrum for the selected measurement.
Top

Attributes

 | Name | Description
Attribute | Window | Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_JitterSpectrumConfigure Function

AgInfiniiVision_JitterSpectrumConfigure Function
Spectrum See Also

Auto-configures and turns on the jitter spectrum for the selected measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Enable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_JitterSpectrumConfigure(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:SPECtrum:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Spectrum
    AgInfiniiVision


Horizontal

Horizontal
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Horizontal

Attributes

 | Name | Description
Attribute | Center Frequency | The center frequency for the jitter measurement spectrum.
Attribute | Frequency Span | The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY Attribute
Horizontal See Also

The center frequency for the jitter measurement spectrum.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Horizontal\Center Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY 1150587

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 50.000E+03.

    • Instrument Command

    :JITTer:SPECtrum:HORizontal:POSition {value}
    :JITTer:SPECtrum:HORizontal:POSition?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Horizontal
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN Attribute
Horizontal See Also

The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Horizontal\Frequency Span
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN 1150590

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 100E+03.

    • Instrument Command

    :JITTer:SPECtrum:HORizontal:RANGe {value}
    :JITTer:SPECtrum:HORizontal:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Horizontal
    AgInfiniiVision


Vertical

Vertical
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Vertical

Attributes

 | Name | Description
Attribute | Offset | The vertical value represented at center screen for the jitter measurement spectrum.
Attribute | Range | The full-scale vertical range for the jitter measurement spectrum.
Attribute | Unit | The vertical units for the jitter spectrum.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET Attribute
Vertical See Also

The vertical value represented at center screen for the jitter measurement spectrum.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Vertical\Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET 1150584

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 0.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:OFFSet {value}
    :JITTer:SPECtrum:VERTical:OFFSet?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Vertical
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE Attribute
Vertical See Also

The full-scale vertical range for the jitter measurement spectrum.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Vertical\Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE 1150585

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 8.00E+00.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:RANGe {value}
    :JITTer:SPECtrum:VERTical:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Vertical
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT Attribute
Vertical See Also

The vertical units for the jitter spectrum.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Vertical\Unit
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT 1150586

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is AgInfiniiVisionJitterSpectrumVerticalUnitDecibel.

    • Instrument Command

    :JITTer:SPECtrum:VERTical:TYPE {DECibel|VRMS}
    :JITTer:SPECtrum:VERTical:TYPE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_JITTER_SPECTRUM_VERTICAL_UNIT_DECIBEL | Vertical unit Decibel.
AGINFINIIVISION_VAL_JITTER_SPECTRUM_VERTICAL_UNITVRMS | Vertical unit VRMS.
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Vertical
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW Attribute

AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW Attribute
Spectrum See Also

Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Spectrum\Window
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW 1150583

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The jitter spectrum operation assumes that the time record repeats. Unless an integral number of sampled waveform cycles exist in the record, a discontinuity is created between the end of one record and the beginning of the next. This discontinuity introduces additional frequency components about the peaks into the spectrum. This is referred to as leakage. To minimize leakage, windows that approach zero smoothly at the start and end of the record are employed as filters to the FFTs. Each window is useful for certain classes of input signals.
  • Preset value is AgInfiniiVisionJitterSpectrumWindowHanning.

    • Instrument Command

    :JITTer:SPECtrum:WINDow {RECTangular|HANNing|FLATtop|BHARris}
    :JITTer:SPECtrum:WINDow?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_JITTER_SPECTRUM_WINDOW_RECTANGULAR | Useful for transient signals, and signals where there are an integral number of cycles in the time record.
AGINFINIIVISION_VAL_JITTER_SPECTRUM_WINDOW_HANNING | Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window.
AGINFINIIVISION_VAL_JITTER_SPECTRUM_WINDOW_FLATTOP | Best for making accurate amplitude measurements of frequency peaks.
AGINFINIIVISION_VAL_JITTER_SPECTRUM_WINDOW_BLACKMAN_HARRIS | Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).
    Top

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Spectrum
    AgInfiniiVision


Trend

Trend
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend

Branches

Name
Vertical
Top

Functions

 | Name | Description
Function | Enable | Auto-configures and turns on the jitter measurement trend for the selected measurement.
Function | Enable Smoothing | Auto-configures and turns on smoothing for the jitter measurement trend.
Top

Attributes

 | Name | Description
Attribute | Smoothing Points | The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_JitterTrendConfigure Function

AgInfiniiVision_JitterTrendConfigure Function
Trend See Also

Auto-configures and turns on the jitter measurement trend for the selected measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Enable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_JitterTrendConfigure(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:TRENd:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Trend
    AgInfiniiVision


AgInfiniiVision_JitterTrendConfigureSmoothing Function

AgInfiniiVision_JitterTrendConfigureSmoothing Function
Trend See Also

Auto-configures and turns on smoothing for the jitter measurement trend.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Enable Smoothing
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_JitterTrendConfigureSmoothing(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the IAgInfiniiVision4Measurement.ConfigureJitterMeasurement method.

    • Instrument Command

    :JITTer:TRENd:SMOoth:APPLy

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Trend
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS Attribute

AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS Attribute
Trend See Also

The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Smoothing Points
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS 1150580

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The input value can be an odd number of points, from 3 up to half of the measurement record or precision analysis record.
  • Preset value is 5.

    • Instrument Command

    :JITTer:TRENd:SMOoth:POINts {value}
    :JITTer:TRENd:SMOoth:POINts?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Trend
    AgInfiniiVision


Vertical

Vertical
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Vertical

Attributes

 | Name | Description
Attribute | Offset | The vertical value represented at center screen for the jitter measurement trend.
Attribute | Range | The full-scale vertical range for the jitter measurement trend.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET Attribute

AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET Attribute
Vertical See Also

The vertical value represented at center screen for the jitter measurement trend.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Vertical\Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET 1150581

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 0.

    • Instrument Command

    :JITTer:TRENd:VERTical:OFFSet {value}
    :JITTer:TRENd:VERTical:OFFSet?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Vertical
    AgInfiniiVision


AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE Attribute

AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE Attribute
Vertical See Also

The full-scale vertical range for the jitter measurement trend.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Jitter\Trend\Vertical\Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE 1150582

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is +8.00E+00.

    • Instrument Command

    :JITTer:TRENd:VERTical:RANGe {value}
    :JITTer:TRENd:VERTical:RANGe?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Vertical
    AgInfiniiVision


MaskTest

MaskTest
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest

Branches

Name
Configuration
Markers
MaskFailures
Top

Functions

 | Name | Description
Function | Mask Test Delete | Deletes the currently loaded mask.
Function | Mask Test Reset | Resets the mask statistics.
Function | Mast Test Auto Mask | Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.
Top

Attributes

 | Name | Description
Attribute | All Channel Enabled | Enables all analog channels to be included in the mask test or only selected channels.
Attribute | Bind Control Enabled | Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.
Attribute | Elapsed Time | Read Only - Elapsed time (in seconds) in the current mask test run.
Attribute | Enabled | Enables/Disables the mask test features.
Attribute | Horizontal Tolerance | Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.
Attribute | Lock Enabled | Enables/Disables the mask lock.
Attribute | Source | The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.
Attribute | Title | Read Only - Returns the mask title which is a string of up to 128 characters
Attribute | Units | Measurement units for automask which interprets the tolerance parameters for automasking.
Attribute | Vertical Tolerance | The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.
Attribute | Waveform Count | Read Only - The total number of waveforms acquired in the current mask test run.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED Attribute
MaskTest See Also

Enables all analog channels to be included in the mask test or only selected channels.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\All Channel Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED 1150047

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:ALL {ON|OFF}
:MTESt:ALL?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED Attribute
MaskTest See Also

Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Bind Control Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED 1150065

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • If the Bind 1 & 0 Levels control is enabled, the 1 Level and the 0 Level controls track each other. Adjusting either the 1 Level or the 0 Level control shifts the position of the mask up or down without changing its size.
  • If the Bind 1 & 0 Levels control is disabled, adjusting either the 1 Level or the 0 Level control changes the vertical height of the mask
  • If the Bind -1 & 0 Levels control is enabled, the -1 Level and the 0 Level controls track each other. Adjusting either the -1 Level or the 0 Level control shifts the position of the mask up or down without changing its size.
  • If the Bind -1 & 0 Levels control is disabled, adjusting either the -1 Level or the 0 Level control changes the vertical height of the mask.

    • Instrument Command

    :MTESt:SCALe:BIND {ON|OFF}
    :MTESt:SCALe:BIND?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MaskTest
    AgInfiniiVision


Configuration

Configuration
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration

Attributes

 | Name | Description
Attribute | Sigma Level | Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.
Attribute | Termination Condition | The termination conditions for the mask test.
Attribute | Termination Enabled | Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.
Attribute | Time | The number of seconds for a mask test to run. Permissible Range is 1 to 86400.
Attribute | Waveform | The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL Attribute

AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL Attribute
Configuration See Also

Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration\Sigma Level
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL 1150082

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:SIGMa {value}
:MTESt:RMODe:SIGMa?

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION Attribute

AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION Attribute
Configuration See Also

The termination conditions for the mask test.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration\Termination Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION 1150080

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe {FOR|SIGM|TIME|WAV}
:MTESt:RMODe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MASK_TEST_TERMINATION_CONDITION_FOREVER | FOREVER: Mask test runs until it is turned off
AGINFINIIVISION_VAL_MASK_TEST_TERMINATION_CONDITION_SIGMA | SIGMA: Mask test runs until the Sigma level is reached
AGINFINIIVISION_VAL_MASK_TEST_TERMINATION_CONDITION_TIME | TIME: Mask test runs for a fixed amount of time
AGINFINIIVISION_VAL_MASK_TEST_TERMINATION_CONDITION_WAVEFORMS | WAVEFORM: The mask test runs until a fixed number of waveforms are acquire
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED Attribute
Configuration See Also

Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration\Termination Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED 1150081

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:FACTion:STOP {ON|OFF}
:MTESt:RMODe:FACTion:STOP?

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME Attribute

AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME Attribute
Configuration See Also

The number of seconds for a mask test to run. Permissible Range is 1 to 86400.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration\Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME 1150083

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:TIME {value}
:MTESt:RMODe:TIME?

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM Attribute

AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM Attribute
Configuration See Also

The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Configuration\Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM 1150084

ViStatus AgInfiniiVision_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MTESt:RMODe:WAVeforms {value}
:MTESt:RMODe:WAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME Attribute

AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME Attribute
MaskTest See Also

Read Only - Elapsed time (in seconds) in the current mask test run.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Elapsed Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME 1150068

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MTESt:COUNt:TIME?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_ENABLED Attribute
MaskTest See Also

Enables/Disables the mask test features.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_ENABLED 1150067

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:ENABle {ON|OFF}
:MTESt:ENABle?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE Attribute

AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE Attribute
MaskTest See Also

Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Horizontal Tolerance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE 1150069

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The horizontal tolerance value is interpreted based on the AutoMask units.
  • The unit set as Current specifies time in the horizontal direction, therefore tolerance will be in seconds.
  • The unit set as Divisions specifies division, therefore the tolerance will be in division.

    • Instrument Command

    :MTESt:AMASk:XDELta {value}
    :MTESt:AMASk:XDELta?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MaskTest
    AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED Attribute
MaskTest See Also

Enables/Disables the mask lock.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Lock Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED 1150066

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

When Enabled it locks a mask to the source. As the vertical or horizontal scaling or position of the SOURce changes, the mask is redrawn accordingly.When Disabled the mask is static and does not move.

Instrument Command

:MTESt:LOCK {ON|OFF}
:MTESt:LOCK?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


Markers

Markers
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Markers

Attributes

 | Name | Description
Attribute | X Delta | The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.
Attribute | X1 Coordinate | The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.
Attribute | Y1 Coordinate | Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.
Attribute | Y2 Coordinate | Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA Attribute

AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA Attribute
Markers See Also

The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Markers\X Delta
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA 1150073

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Because all X vertices of the regions defined for mask testing are normalized with respect to X1 and deltaX, redefining deltaX also moves those vertices to stay in the same locations with respect to X1 and deltaX. Thus, in many applications, it is best if you define XDELta as a pulse width or bit period. Then, a change in data rate without corresponding changes in the waveform can easily be handled by changing deltaX. The X-coordinate of polygon vertices is normalized using this equation: X = (X * deltaX) + X1 The X delta value is a time value specifying the distance of the X2 marker with respect to the X1 marker. For example, if the period of the waveform you wish to test is 1 ms, setting deltaX to 1 ms ensures that the waveform's period is between the X1 and X2 markers.

Instrument Command

:MTESt:SCALe:XDELta {value}
:MTESt:SCALe:XDELta?

Requirements

Supported Models

All supported

See Also

Reference

Markers
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE Attribute

AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE Attribute
Markers See Also

The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Markers\X1 Coordinate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE 1150072

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Once the X1 and XDELta coordinates are set, all X values of vertices in the mask regions are defined with respect to this value, according to the equation: X = (X * deltaX) + X1 Thus, if you set X1 to 100 ms, and XDELta to 100 ms, an X value of 0.100 is a vertex at 110 ms. The oscilloscope uses this equation to normalize vertices. This simplifies reprogramming to handle different data rates. For example, if you halve the period of the waveform of interest, you need only to adjust the XDELta value to set up the mask for the new waveform.

Instrument Command

:MTESt:SCALe:X1 {value}
:MTESt:SCALe:X1?

Requirements

Supported Models

All supported

See Also

Reference

Markers
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE Attribute

AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE Attribute
Markers See Also

Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Markers\Y1 Coordinate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE 1150074

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

All Y values of vertices in the coordinate system are defined with respect to the boundaries set by SCALe:Y1 and SCALe:Y2 according to the equation: Y = (Y * (Y2 - Y1)) + Y1 Thus, if you set Y1 to 100 mV, and Y2 to 1 V, a Y value of 0.100 in a vertex is at 190 mV.

Instrument Command

:MTESt:SCALe:Y1 {value}
:MTESt:SCALe:Y1?

Requirements

Supported Models

All supported

See Also

Reference

Markers
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE Attribute

AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE Attribute
Markers See Also

Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Markers\Y2 Coordinate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE 1150075

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

All Y values of vertices in the coordinate system are defined with respect to the boundaries set by SCALe:Y1 and SCALe:Y2 according to the equation: Y = (Y * (Y2 - Y1)) + Y1 Thus, if you set Y1 to 100 mV, and Y2 to 1 V, a Y value of 0.100 in a vertex is at 190 mV.

Instrument Command

:MTESt:SCALe:Y2 {value}
:MTESt:SCALe:Y2?

Requirements

Supported Models

All supported

See Also

Reference

Markers
AgInfiniiVision


AgInfiniiVision_MaskTestDelete Function

AgInfiniiVision_MaskTestDelete Function
MaskTest See Also

Deletes the currently loaded mask.

Function Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Mask Test Delete
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MaskTestDelete(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:MTESt:DELete

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AgInfiniiVision_MaskTestReset Function

AgInfiniiVision_MaskTestReset Function
MaskTest See Also

Resets the mask statistics.

Function Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Mask Test Reset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MaskTestReset(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:MTESt:COUNt:RESet

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


MaskFailures

MaskFailures
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\MaskFailures

Attributes

 | Name | Description
Attribute | Failed Waveform Count | Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.
Attribute | Measurement Enabled | Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings
Attribute | Print Failures Enabled | Enables/Disables printing on mask failure.
Attribute | Save Failures Enabled | Enables/Disables saving on mask failure.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT Attribute

AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT Attribute
MaskFailures See Also

Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\MaskFailures\Failed Waveform Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT 1150076

ViStatus AgInfiniiVision_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MTESt:COUNt:FWAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

MaskFailures
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED Attribute
MaskFailures See Also

Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\MaskFailures\Measurement Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED 1150079

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:FACTion:MEASure {ON|OFF}
:MTESt:RMODe:FACTion:MEASure?

Requirements

Supported Models

All supported

See Also

Reference

MaskFailures
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED Attribute
MaskFailures See Also

Enables/Disables printing on mask failure.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\MaskFailures\Print Failures Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED 1150077

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:FACTion:PRINt {ON|OFF}
:MTESt:RMODe:FACTion:PRINt?

Requirements

Supported Models

All supported

See Also

Reference

MaskFailures
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED Attribute

AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED Attribute
MaskFailures See Also

Enables/Disables saving on mask failure.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\MaskFailures\Save Failures Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED 1150078

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:RMODe:FACTion:SAVE {ON|OFF}
:MTESt:RMODe:FACTion:SAVE?

Requirements

Supported Models

All supported

See Also

Reference

MaskFailures
AgInfiniiVision


AgInfiniiVision_MastTestAutoMask Function

AgInfiniiVision_MastTestAutoMask Function
MaskTest See Also

Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.

Function Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Mast Test Auto Mask
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MastTestAutoMask(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

The mask only encompasses the portion of the waveform visible on the display, so you must ensure that the waveform is acquired and displayed consistently to obtain repeatable results.

Instrument Command

:MTESt:AMASk:CREate

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_SOURCE Attribute

AGINFINIIVISION_ATTR_MASKTEST_SOURCE Attribute
MaskTest See Also

The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_SOURCE 1150064

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:SOURce {value}
:MTESt:SOURce?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_TITLE Attribute

AGINFINIIVISION_ATTR_MASKTEST_TITLE Attribute
MaskTest See Also

Read Only - Returns the mask title which is a string of up to 128 characters

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Title
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_TITLE 1150063

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_TITLE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Instrument Command

:MTESt:TITLe?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_UNITS Attribute

AGINFINIIVISION_ATTR_MASKTEST_UNITS Attribute
MaskTest See Also

Measurement units for automask which interprets the tolerance parameters for automasking.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_UNITS 1150048

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MTESt:AMASk:UNITs {CURR|DIV}
:MTESt:AMASk:UNITs?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MASK_TEST_UNITS_CURRENT | Current interprets Horizontal tolerance as Time and Vertical tolerance as Voltage
AGINFINIIVISION_VAL_MASK_TEST_UNITS_DIVISIONS | Division interprets tolerance parameters as Division
Top

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE Attribute

AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE Attribute
MaskTest See Also

The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Vertical Tolerance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE 1150070

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The vertical tolerance value is interpreted based on the AutoMask units.
  • The unit set as Current specifies voltage in the vertical direction, therefore tolerance will be in voltage.
  • The unit set as Divisions specifies division, therefore the tolerance will be in division.

    • Instrument Command

    :MTESt:AMASk:YDELta {value}
    :MTESt:AMASk:YDELta?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MaskTest
    AgInfiniiVision


AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT Attribute

AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT Attribute
MaskTest See Also

Read Only - The total number of waveforms acquired in the current mask test run.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MaskTest\Waveform Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT 1150071

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:MTESt:COUNt:WAVeforms?

Requirements

Supported Models

All supported

See Also

Reference

MaskTest
AgInfiniiVision


Math

Math
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math

Branches

Name
Bus
FFT
FFT2
FilterFrequency
Integrate
Linear
MeasurementTrend
Top

Attributes

 | Name | Description
Attribute | Enabled | Enables/Disables the math function.
Attribute | Offset | Voltage or vertical value represented at center screen for the selected function.
Attribute | Operation | Waveform math operation
Attribute | Source1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.
Attribute | Source2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>
Attribute | Vertical Range | Range of Full-scale vertical axis for the selected function.
Attribute | Vertical Scale | Vertical scale, or units per division, of the selected function.
Top

See Also

Reference

AgInfiniiVision


Bus

Bus
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus

Attributes

 | Name | Description
Attribute | Bus Clock Source | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | Bus Slope | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | Bus YIncrement | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | Bus YOrigin | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | Bus YUnits | Specifies the vertical units for the Chart Logic Bus operations.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE Attribute
Bus See Also

Specifies the clock signal source for the Chart Logic Bus State operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus\Bus Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE 1150364

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be specified in one of the following formats:

  • "DigitalChannel<d>", where d: 0 to the number of digital channels available minus 1.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:CLOCk {value}
:FUNCtion:BUS:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Bus
AgInfiniiVision


AGINFINIIVISION_ATTR_BUS_SLOPE Attribute

AGINFINIIVISION_ATTR_BUS_SLOPE Attribute
Bus See Also

Specifies the clock signal edge for the Chart Logic Bus State operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus\Bus Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_BUS_SLOPE 1150365

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_BUS_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionMathBusSlopeNegative - specifies negative slope.
  • AgInfiniiVisionMathBusSlopePositive - specifies the positive slope.
  • AgInfiniiVisionMathBusSlopeEither - specifies either negative or positive slope.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:SLOPe {NEG|POS|EITH}
:FUNCtion:BUS:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_NEGATIVE | Specifies negative slope.
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_POSITIVE | Specifies the positive slope.
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_EITHER | Specifies either negative or positive slope.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Bus
AgInfiniiVision


AGINFINIIVISION_ATTR_BUS_Y_INCREMENT Attribute

AGINFINIIVISION_ATTR_BUS_Y_INCREMENT Attribute
Bus See Also

Specifies the value associated with each increment in Chart Logic Bus data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus\Bus YIncrement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_BUS_Y_INCREMENT 1150361

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_BUS_Y_INCREMENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The units for this property are selected using the YUnits property.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YINCrement {value}
:FUNCtion:BUS:YINCrement?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Bus
AgInfiniiVision


AGINFINIIVISION_ATTR_BUS_Y_ORIGIN Attribute

AGINFINIIVISION_ATTR_BUS_Y_ORIGIN Attribute
Bus See Also

Specifies the value associated with Chart Logic Bus data equal to zero.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus\Bus YOrigin
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_BUS_Y_ORIGIN 1150362

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_BUS_Y_ORIGIN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The units for this property are selected using the YUnits property.

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YORigin {value}
:FUNCtion:BUS:YORigin?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Bus
AgInfiniiVision


AGINFINIIVISION_ATTR_BUS_Y_UNITS Attribute

AGINFINIIVISION_ATTR_BUS_Y_UNITS Attribute
Bus See Also

Specifies the vertical units for the Chart Logic Bus operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Bus\Bus YUnits
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_BUS_Y_UNITS 1150363

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_BUS_Y_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionMathBusYUnitsVolts - specifies the units as Volts
  • AgInfiniiVisionMathBusYUnitsAmps - specifies the units as Amperes
  • AgInfiniiVisionMathBusYUnitsNone - specifies the units as None

This feature is only available if MSO and ADVMATH licenses are installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:BUS:YUNits {VOLT|AMP|NONE}
:FUNCtion:BUS:YUNits?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_VOLTS | Specifies the units as Volts.
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_AMPS | Specifies the units as Amperes.
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_NONE | Specifies the units as None.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Bus
AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_ENABLED Attribute

AGINFINIIVISION_ATTR_MATH_ENABLED Attribute
Math See Also

Enables/Disables the math function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_ENABLED 1150049

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:DISPlay {ON|OFF}
    :FUNCtion:DISPlay?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


FFT

FFT
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT

Attributes

 | Name | Description
Attribute | Center Frequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | Internal Operation | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.
Attribute | Internal Source1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | Internal Source2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | Span | Frequency span of the display when FFT is selected.
Attribute | Window Type | Windowing transforms for the FFT.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY Attribute

AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY Attribute
FFT See Also

Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Center Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY 1150059

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The Unit of Frequency is Hz.
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:CENTer {value}
    :FUNCtion:CENTer?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION Attribute

AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION Attribute
FFT See Also

Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Internal Operation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION 1150060

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:OPERation {ADD|SUBT|MULT}
    :FUNCtion:GOFT:OPERation?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_INT_OPERATION_ADD | ADD = Source1 + source2.
AGINFINIIVISION_VAL_MATH_INT_OPERATION_SUBTRACT | SUBTract = Source1 - source2.
AGINFINIIVISION_VAL_MATH_INT_OPERATION_MULTIPLY | MULTiply = Source1 * source2.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1 Attribute

AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1 Attribute
FFT See Also

Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Internal Source1
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1 1150061

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:SOURce1 {value}
    :FUNCtion:GOFT:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2 Attribute

AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2 Attribute
FFT See Also

Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Internal Source2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2 1150062

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:GOFT:SOURce2 {value}
    :FUNCtion:GOFT:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_SPAN Attribute

AGINFINIIVISION_ATTR_MATH_FFT_SPAN Attribute
FFT See Also

Frequency span of the display when FFT is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Span
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_SPAN 1150058

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_SPAN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SPAN {value}
    :FUNCtion:SPAN?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE Attribute

AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE Attribute
FFT See Also

Windowing transforms for the FFT.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT\Window Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE 1150057

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:WINDow {RECT|HANN|FLAT|BHAR}
    :FUNCtion:WINDow?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_RECTANGULAR | RECTangular: Useful for transient signals, and signals where there are an integral number of cycles in the time record
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_HANNING | HANNing: Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_FLAT_TOP | FLATtop: Best for making accurate amplitude measurements of frequency peaks.
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPEB_HARRIS | BHARris (Blackman-Harris): Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


FFT2

FFT2
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT2

Attributes

 | Name | Description
Attribute | FFT Vertical Units | Specifies the FFT vertical units.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS Attribute

AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS Attribute
FFT2 See Also

Specifies the FFT vertical units.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FFT2\FFT Vertical Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS 1150271

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The VerticalUnits property can be set to one of the following values:

  • AgInfiniiVisionMathFFTVerticalUnitsdB - specifies the FFT vertical units as Decibel
  • AgInfiniiVisionMathFFTVerticalUnitsVRMS - specifies the FFT vertical units as Vrms

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:VTYPe {DEC|VRMS}
:FUNCtion:VTYPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSDB | Specifies FFT vertical units as Decibels.
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSVRMS | Specifies the FFT vertical units as VRMS.
Top

Requirements

Supported Models

All supported

See Also

Reference

FFT2
AgInfiniiVision


FilterFrequency

FilterFrequency
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\FilterFrequency

Attributes

 | Name | Description
Attribute | FilterFrequency High Pass Bandwidth | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | FilterFrequency Low Pass Bandwidth | Specifies the low-pass filter's -3 dB cutoff frequency.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH Attribute

AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH Attribute
FilterFrequency See Also

Specifies the high-pass filter's -3 dB cutoff frequency.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FilterFrequency\FilterFrequency High Pass Bandwidth
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH 1150359

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This feature is only available if an ADVMATH license is installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:FREQuency:HIGHpass {value}
:FUNCtion:FREQuency:HIGHpass?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FilterFrequency
AgInfiniiVision


AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH Attribute

AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH Attribute
FilterFrequency See Also

Specifies the low-pass filter's -3 dB cutoff frequency.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\FilterFrequency\FilterFrequency Low Pass Bandwidth
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH 1150358

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This feature is only available if an ADVMATH license is installed.

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:FREQuency:LOWPass {value}
:FUNCtion:FREQuency:LOWPass?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FilterFrequency
AgInfiniiVision


Integrate

Integrate
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\Integrate

Attributes

 | Name | Description
Attribute | Integrate Input Offset | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET Attribute

AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET Attribute
Integrate See Also

Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Integrate\Integrate Input Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET 1150360

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

Instrument Command

:FUNCtion:INTegrate:IOFFset {value}
:FUNCtion:INTegrate:IOFFset?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Integrate
AgInfiniiVision


Linear

Linear
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\Linear

Attributes

 | Name | Description
Attribute | Linear Gain | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | Linear Offset | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_LINEAR_GAIN Attribute

AGINFINIIVISION_ATTR_LINEAR_GAIN Attribute
Linear See Also

Specifies the Gain ("A" in Ax + B) for the Linear Math operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Linear\Linear Gain
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_LINEAR_GAIN 1150366

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_LINEAR_GAIN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This feature is only available if an ADVMATH license is installed.

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:LINear:GAIN {value}
    :FUNCtion:LINear:GAIN?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Linear
    AgInfiniiVision


AGINFINIIVISION_ATTR_LINEAR_OFFSET Attribute

AGINFINIIVISION_ATTR_LINEAR_OFFSET Attribute
Linear See Also

Specifies the Offset ("B" in Ax + B) for the Linear Math operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Linear\Linear Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_LINEAR_OFFSET 1150367

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_LINEAR_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This feature is only available if an ADVMATH license is installed.

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:LINear:OFFSet {value}
    :FUNCtion:LINear:OFFSet?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Linear
    AgInfiniiVision


MeasurementTrend

MeasurementTrend
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Math\MeasurementTrend

Attributes

 | Name | Description
Attribute | Measurement Trend Type | Specifies the measurement whose trend is shown in the math waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE Attribute
MeasurementTrend See Also

Specifies the measurement whose trend is shown in the math waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\MeasurementTrend\Measurement Trend Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE 1150368

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • Note: On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 2 (M2) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:TRENd:MEASurement {FREQ|PER|DUTY|PWID|NWID|RIS|FALL|VRAT|VAV|ACRM}
    :FUNCtion:TRENd:MEASurement?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_FREQUENCY | Specifies the measurement type as Frequency.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_PERIOD | Specifies the measurement type as Period.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_DUTY_CYCLE | Specifies the measurement type as Duty Cycle.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_POSITIVE_WIDTH | Specifies the measurement type as Positive Width.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_NEGATIVE_WIDTH | Specifies the measurement type as Negative Width.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_RISE_TIME | Specifies the measurement type as Rise Time.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_FALL_TIME | Specifies the measurement type as Fall Time.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEV_RATIO | Specifies the measurement type as Voltage Ratio.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEV_AVERAGE | Specifies the measurement type as Voltage Average
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEAC_RMS | Specifies the measurement type as AC RMS.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    MeasurementTrend
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_OFFSET Attribute

AGINFINIIVISION_ATTR_MATH_OFFSET Attribute
Math See Also

Voltage or vertical value represented at center screen for the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_OFFSET 1150056

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:OFFSet {value}
    :FUNCtion:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_OPERATION Attribute

AGINFINIIVISION_ATTR_MATH_OPERATION Attribute
Math See Also

Waveform math operation

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Operation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_OPERATION 1150050

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_OPERATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The Bus Timing and Bus State Selections are only available if an MSO license is installed.
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:OPERation {ADD|SUBT|MULT|FFT|INT|DIFF|SQRT|MAGN|ABS|LN|LOG|EXP|TEN|LOWP|HIGH|DIV|LIN|TREN|BTIM|BST|SQU|AVER|MAXHold|MINHold|CLOCk|SMOoth|ENV|FFTP}
    :FUNCtion:OPERation?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_OPERATIONS_ADD | ADD = Source1 + source2.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SUBTRACT | SUBTract = Source1 - source2.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MULTIPLY | MULTiply = Source1 * source2.
AGINFINIIVISION_VAL_MATH_OPERATIONSFFT | Using the Fast Fourier Transform (FFT), this operation displays the magnitudes of the frequency content that makes up the source waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_INTEGRATE | Integration on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_DIFFERENTIATION | Differentiation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SQUARE_ROOT | Square Root of the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MAGNIFY | Magnify.
AGINFINIIVISION_VAL_MATH_OPERATIONS_ABSOLUTE | Absolute.
AGINFINIIVISION_VAL_MATH_OPERATIONS_NATURAL_LOGARITHM | Natural Logarithm on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_COMMON_LOGARITHM | Common Logarithm on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_EXPONENTIAL | Exponential on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_BASE_TEN_EXPONENTIAL | Base Ten Exponential on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_LOW_PASS_FILTER | Low Pass Filter
AGINFINIIVISION_VAL_MATH_OPERATIONS_HIGH_PASS_FILTER | High Pass Filter.
AGINFINIIVISION_VAL_MATH_OPERATIONS_DIVIDE | Divide operation.
AGINFINIIVISION_VAL_MATH_OPERATIONS_LINEAR | Linear operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MEASURMENT_TREND | Measurement Trend.
AGINFINIIVISION_VAL_MATH_OPERATIONS_BUS_TIMING | Bus Timing
AGINFINIIVISION_VAL_MATH_OPERATIONS_BUS_STATE | Bus State
AGINFINIIVISION_VAL_MATH_OPERATIONS_SQUARE | Square operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_AVERAGE | Average operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MAX_HOLD | Operates on a single analog channel source or on a lower math function. The Max Hold (or Max Envelope) operator records the maximum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MIN_HOLD | Operates on a single analog channel source or on a lower math function. The Min Hold (or Min Envelope) operator records the minimum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_CLOCK_RECOVERY | You can display recovered clocks from different sources using multiple math function waveforms; however, the same clock recovery method applies to all recovered clocks.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SMOOTHING | The smoothing operator limits the bandwidth of the source waveform. The smoothing operator can be used, for example, to smooth measurement trend waveforms.
AGINFINIIVISION_VAL_MATH_OPERATIONS_ENVELOPE | The resulting math waveform is the amplitude envelope for an amplitude modulated (AM) input signal.
AGINFINIIVISION_VAL_MATH_OPERATIONS_FFT_PHASE | Using the Fast Fourier Transform (FFT), this operation shows the phase relationships of the frequency content that makes up the source waveform
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_SOURCE1 Attribute

AGINFINIIVISION_ATTR_MATH_SOURCE1 Attribute
Math See Also

First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Source1
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_SOURCE1 1150054

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_SOURCE1.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source1 property can be specified in one of the following string formats:

  • Channel<n>, where n: 1 to the number of analog channels available
  • GOFT
  • Bus<m>, where m: 1 or 2
  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SOURce1 {value}
    :FUNCtion:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_SOURCE2 Attribute

AGINFINIIVISION_ATTR_MATH_SOURCE2 Attribute
Math See Also

Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Source2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_SOURCE2 1150055

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_SOURCE2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SOURce2 {value}
    :FUNCtion:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE Attribute

AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE Attribute
Math See Also

Range of Full-scale vertical axis for the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Vertical Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE 1150051

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:RANGe {value}
    :FUNCtion:RANGe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE Attribute

AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE Attribute
Math See Also

Vertical scale, or units per division, of the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Math\Vertical Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE 1150053

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 3000T/4000X/6000X/M924x/P924x Series, this operation affects the oscilloscope's Math 1 (M1) channel.
  • On 3000T/4000X/6000X/M924x/P924x Series, use MathFunctions interface for new math channels.

    • Instrument Command

    :FUNCtion:SCALe {value}
    :FUNCtion:SCALe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Math
    AgInfiniiVision


MathFunction

MathFunction
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction

Branches

Name
Average
Bus
FFT
FilterFrequency
Integrate
Linear
MeasurementTrend
Top

Functions

 | Name | Description
Function | Get Math Function Name | Returns the mathfunction name that corresponds to the one-based index that the user specifies.
Top

Attributes

 | Name | Description
Attribute | Math Enabled | Enables/Disables the math function.
Attribute | Math Offset | Voltage or vertical value represented at center screen for the selected function.
Attribute | Math Operation | Waveform math operation.
Attribute | Math Source1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.
Attribute | Math Source2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).
Attribute | MathFunction Count | Attribute that contains the number of MathFunctions available on the instrument. This is the maximum index that may be used with the GetMathFunctionName() function.
Attribute | Smoothing Points | The number of smoothing points to use.
Attribute | Vertical Range | Range of Full-scale vertical axis for the selected function.
Attribute | Vertical Scale | Vertical scale, or units per division, of the selected function.
Top

See Also

Reference

AgInfiniiVision


Average

Average
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Average

Attributes

 | Name | Description
Attribute | Count | Specify the number of waveforms to be averaged together.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_AVERAGE_COUNT Attribute

AGINFINIIVISION_ATTR_AVERAGE_COUNT Attribute
Average See Also

Specify the number of waveforms to be averaged together.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Average\Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_AVERAGE_COUNT 1150446

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_AVERAGE_COUNT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The number of averages can be set from 2 to 65536 in increments of powers of 2.
  • NOTE: Not supported by 1000X/2000X/3000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:AVERage:COUNt {value}
    :FUNCtion{MathFunction}:AVERage:COUNt?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Average
    AgInfiniiVision


Bus

Bus
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus

Attributes

 | Name | Description
Attribute | Bus Clock Source | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | Bus Slope | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | Bus Y Increment | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | Bus Y Origin | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | Bus Y Units | Specifies the vertical units for the Chart Logic Bus operations.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE Attribute
Bus See Also

Specifies the clock signal source for the Chart Logic Bus State operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus\Bus Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE 1150450

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source2 property can be specified in one of the following string formats:

  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "NONE" - read-only, used by single-source math operations.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:CLOCk {value}
    :FUNCtion{MathFunction}:BUS:CLOCk?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Bus
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE Attribute
Bus See Also

Specifies the clock signal edge for the Chart Logic Bus State operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus\Bus Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE 1150451

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionMathBusSlopeNegative - specifies negative slope.
  • AgInfiniiVisionMathBusSlopePositive - specifies the positive slope.
  • AgInfiniiVisionMathBusSlopeEither - specifies either negative or positive slope.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:SLOPe {NEG|POS|EITH}
    :FUNCtion{MathFunction}:BUS:SLOPe?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_NEGATIVE | Specifies negative slope.
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_POSITIVE | Specifies the positive slope.
AGINFINIIVISION_VAL_MATH_BUS_SLOPE_EITHER | Specifies either negative or positive slope.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Bus
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT Attribute
Bus See Also

Specifies the value associated with each increment in Chart Logic Bus data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus\Bus Y Increment
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT 1150447

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units for this property are selected using the YUnits property.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YINCrement {value}
    :FUNCtion{MathFunction}:BUS:YINCrement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Bus
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN Attribute
Bus See Also

Specifies the value associated with Chart Logic Bus data equal to zero.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus\Bus Y Origin
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN 1150448

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The units for this property are selected using the YUnits property.
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YORigin {value}
    :FUNCtion{MathFunction}:BUS:YORigin?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Bus
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS Attribute
Bus See Also

Specifies the vertical units for the Chart Logic Bus operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Bus\Bus Y Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS 1150449

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The YUnits property can be set to one of the following values:

  • AgInfiniiVisionMathBusYUnitsVolts - specifies the units as Volts
  • AgInfiniiVisionMathBusYUnitsAmps - specifies the units as Amperes
  • AgInfiniiVisionMathBusYUnitsNone - specifies the units as None
  • This feature is only available if MSO and ADVMATH licenses are installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:BUS:YUNits {VOLT|AMP|NONE}
    :FUNCtion{MathFunction}:BUS:YUNits?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_VOLTS | Specifies the units as Volts.
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_AMPS | Specifies the units as Amperes.
AGINFINIIVISION_VAL_MATH_BUSY_UNITS_NONE | Specifies the units as None.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Bus
    AgInfiniiVision


FFT

FFT
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT

Attributes

 | Name | Description
Attribute | Center Frequency | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | Span | Frequency span of the display when FFT is selected.
Attribute | Start Frequency | The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | Stop Frequency | The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | Vertical Units | Specifies the FFT vertical units.
Attribute | Window Type | Windowing transforms or operations for the FFT.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY Attribute
FFT See Also

Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Center Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY 1150455

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The Unit of Frequency is Hz.
  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:CENTer {value}
    :FUNCtion{MathFunction}:CENTer?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN Attribute
FFT See Also

Frequency span of the display when FFT is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Span
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN 1150454

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • NOTE: 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:SPAN {value}
    :FUNCtion{MathFunction}:SPAN?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY Attribute
FFT See Also

The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Start Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY 1150595

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 0.

    • Instrument Command

    :FUNCtion{MathFunction}:FFT:FREQuency:STARt {value}
    :FUNCtion{MathFunction}:FFT:FREQuency:STARt?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY Attribute
FFT See Also

The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Stop Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY 1150596

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 100.0000E+03.

    • Instrument Command

    :FUNCtion{MathFunction}:FFT:FREQuency:STOP {value}
    :FUNCtion{MathFunction}:FFT:FREQuency:STOP?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS Attribute
FFT See Also

Specifies the FFT vertical units.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Vertical Units
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS 1150452

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The VerticalUnits property can be set to one of the following values:

  • AgInfiniiVisionMathFFTVerticalUnitsdB - specifies the FFT vertical units as Decibel
  • AgInfiniiVisionMathFFTVerticalUnitsVRMS - specifies the FFT vertical units as Vrms
  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:VTYPe {DEC|VRMS}
    :FUNCtion{MathFunction}:VTYPe?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSDB | Specifies FFT vertical units as Decibels.
AGINFINIIVISION_VAL_MATHFFT_VERTICAL_UNITSVRMS | Specifies the FFT vertical units as VRMS.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE Attribute
FFT See Also

Windowing transforms or operations for the FFT.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FFT\Window Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE 1150453

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • NOTE: On 1000X/2000X/3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

    • Instrument Command

    :FUNCtion{MathFunction}:WINDow {RECT|HANN|FLAT|BHAR}
    :FUNCtion{MathFunction}:WINDow?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_RECTANGULAR | RECTangular: Useful for transient signals, and signals where there are an integral number of cycles in the time record
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_HANNING | HANNing: Useful for frequency resolution and general purpose use. It is good for resolving two frequencies that are close together, or for making frequency measurements. This is the default window
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPE_FLAT_TOP | FLATtop: Best for making accurate amplitude measurements of frequency peaks.
AGINFINIIVISION_VAL_MATHFFT_WINDOW_TYPEB_HARRIS | BHARris (Blackman-Harris): Reduces time resolution compared to the rectangular window, but it improves the capacity to detect smaller impulses due to lower secondary lobes (provides minimal spectral leakage).
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FFT
    AgInfiniiVision


FilterFrequency

FilterFrequency
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FilterFrequency

Attributes

 | Name | Description
Attribute | High Pass Bandwidth | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | Low Pass Bandwidth | Specifies the low-pass filter's -3 dB cutoff frequency.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH Attribute
FilterFrequency See Also

Specifies the high-pass filter's -3 dB cutoff frequency.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FilterFrequency\High Pass Bandwidth
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH 1150457

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:FREQuency:HIGHpass {value}
    :FUNCtion{MathFunction}:FREQuency:HIGHpass?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FilterFrequency
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH Attribute
FilterFrequency See Also

Specifies the low-pass filter's -3 dB cutoff frequency.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\FilterFrequency\Low Pass Bandwidth
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH 1150456

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:FREQuency:LOWPass {value}
    :FUNCtion{MathFunction}:FREQuency:LOWPass?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FilterFrequency
    AgInfiniiVision


AgInfiniiVision_GetMathFunctionName Function

AgInfiniiVision_GetMathFunctionName Function
MathFunction See Also

Returns the mathfunction name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Get Math Function Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetMathFunctionName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Remarks

On 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


Integrate

Integrate
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Integrate

Attributes

 | Name | Description
Attribute | Input Offset | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET Attribute
Integrate See Also

Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Integrate\Input Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET 1150458

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:INTegrate:IOFFset {value}
    :FUNCtion{MathFunction}:INTegrate:IOFFset?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Integrate
    AgInfiniiVision


Linear

Linear
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Linear

Attributes

 | Name | Description
Attribute | Linear Gain | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | Linear Offset | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN Attribute
Linear See Also

Specifies the Gain ("A" in Ax + B) for the Linear Math operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Linear\Linear Gain
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN 1150459

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:LINear:GAIN {value}
    :FUNCtion{MathFunction}:LINear:GAIN?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Linear
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET Attribute
Linear See Also

Specifies the Offset ("B" in Ax + B) for the Linear Math operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Linear\Linear Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET 1150460

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • NOTE: On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:LINear:OFFSet {value}
    :FUNCtion{MathFunction}:LINear:OFFSet?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Linear
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED Attribute
MathFunction See Also

Enables/Disables the math function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Math Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED 1150445

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: On 3000X and 2000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:DISPlay {ON|OFF}
:FUNCtion{MathFunction}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET Attribute
MathFunction See Also

Voltage or vertical value represented at center screen for the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Math Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET 1150462

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.

Instrument Command

:FUNCtion{MathFunction}:OFFSet {value}
:FUNCtion{MathFunction}:OFFSet?

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION Attribute
MathFunction See Also

Waveform math operation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Math Operation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION 1150463

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The Bus Timing and Bus State Selections are only available if an MSO license is installed.
  • NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE : Here "Math1" controls the g(t) and "Math2" controls the f(t).

    • Instrument Command

    :FUNCtion{MathFunction}:OPERation {ADD|SUBT|MULT|FFT|INT|DIFF|SQRT|MAGN|ABS|LN|LOG|EXP|TEN|LOWP|HIGH|DIV|LIN|TREN|BTIM|BST|SQU|AVER|MAXHold|MINHold|CLOCk|SMOoth|ENV|FFTP}
    :FUNCtion{MathFunction}:OPERation?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_OPERATIONS_ADD | ADD = Source1 + source2.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SUBTRACT | SUBTract = Source1 - source2.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MULTIPLY | MULTiply = Source1 * source2.
AGINFINIIVISION_VAL_MATH_OPERATIONSFFT | Using the Fast Fourier Transform (FFT), this operation displays the magnitudes of the frequency content that makes up the source waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_INTEGRATE | Integration on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_DIFFERENTIATION | Differentiation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SQUARE_ROOT | Square Root of the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MAGNIFY | Magnify.
AGINFINIIVISION_VAL_MATH_OPERATIONS_ABSOLUTE | Absolute.
AGINFINIIVISION_VAL_MATH_OPERATIONS_NATURAL_LOGARITHM | Natural Logarithm on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_COMMON_LOGARITHM | Common Logarithm on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_EXPONENTIAL | Exponential on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_BASE_TEN_EXPONENTIAL | Base Ten Exponential on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_LOW_PASS_FILTER | Low Pass Filter
AGINFINIIVISION_VAL_MATH_OPERATIONS_HIGH_PASS_FILTER | High Pass Filter.
AGINFINIIVISION_VAL_MATH_OPERATIONS_DIVIDE | Divide operation.
AGINFINIIVISION_VAL_MATH_OPERATIONS_LINEAR | Linear operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MEASURMENT_TREND | Measurement Trend.
AGINFINIIVISION_VAL_MATH_OPERATIONS_BUS_TIMING | Bus Timing
AGINFINIIVISION_VAL_MATH_OPERATIONS_BUS_STATE | Bus State
AGINFINIIVISION_VAL_MATH_OPERATIONS_SQUARE | Square operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_AVERAGE | Average operation on the selected waveform source.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MAX_HOLD | Operates on a single analog channel source or on a lower math function. The Max Hold (or Max Envelope) operator records the maximum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_MIN_HOLD | Operates on a single analog channel source or on a lower math function. The Min Hold (or Min Envelope) operator records the minimum vertical values found at each horizontal bucket across multiple analysis cycles and uses those values to build a waveform.
AGINFINIIVISION_VAL_MATH_OPERATIONS_CLOCK_RECOVERY | You can display recovered clocks from different sources using multiple math function waveforms; however, the same clock recovery method applies to all recovered clocks.
AGINFINIIVISION_VAL_MATH_OPERATIONS_SMOOTHING | The smoothing operator limits the bandwidth of the source waveform. The smoothing operator can be used, for example, to smooth measurement trend waveforms.
AGINFINIIVISION_VAL_MATH_OPERATIONS_ENVELOPE | The resulting math waveform is the amplitude envelope for an amplitude modulated (AM) input signal.
AGINFINIIVISION_VAL_MATH_OPERATIONS_FFT_PHASE | Using the Fast Fourier Transform (FFT), this operation shows the phase relationships of the frequency content that makes up the source waveform
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MathFunction
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1 Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1 Attribute
MathFunction See Also

The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Math Source1
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1 1150465

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Higher math functions can operate on lower math functions when using operators other than the simple arithmetic operations (+, - , *, /). For example, if "Math1" is a subtraction of Channel1 and Channel2, the "Math2" could be set up as a FFT operation on "Math1". These are called cascaded math functions.
  • To cascade math functions, select the lower math function as the source for the current math function.
  • When cascading math functions, to get the most accurate results, be sure to vertically scale lower math functions so that their waveforms take up the full screen without being clipped.
  • The Source1 property can be specified in one of the following string formats:
  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "Math<m>", where m is any lower math channel (for cascading).
  • "BUS<b>", where b: 1 or 2, for bus charting visualization functions.
  • NOTE: On 1000X, 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

    • Instrument Command

    :FUNCtion{MathFunction}:SOURce1 {value}
    :FUNCtion{MathFunction}:SOURce1?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MathFunction
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2 Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2 Attribute
MathFunction See Also

Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Math Source2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2 1150466

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source2 property can be specified in one of the following string formats:

  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "NONE" - read-only, used by single-source math operations.

    • Instrument Command

    :FUNCtion{MathFunction}:SOURce2 {value}
    :FUNCtion{MathFunction}:SOURce2?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    MathFunction
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT Attribute

AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT Attribute
MathFunction See Also

Attribute that contains the number of MathFunctions available on the instrument. This is the maximum index that may be used with the GetMathFunctionName() function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\MathFunction Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT 1150432

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Remarks

On 1000X, 2000X and 3000X series, "Math1" controls the g(t) function and "Math2" controls the f(t) function of the oscilloscope.

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


MeasurementTrend

MeasurementTrend
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\MeasurementTrend

Attributes

 | Name | Description
Attribute | Slot | The measurement whose trend is shown in the math waveform.
Attribute | Trend Type | Specifies the measurement whose trend is shown in the math waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT Attribute
MeasurementTrend See Also

The measurement whose trend is shown in the math waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\MeasurementTrend\Slot
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT 1150599

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Note: This property is supported by 3000T/4000X/6000X/M924x/P924x with firmware revision >= 6.00. For older revisions, please use the IAgInfiniiVisionMathFunctionMeasurementTrend::Type property instead.

  • If no measurements are installed, this returns AgInfiniiVisionMeasurementSlotNone.
  • Preset value is AgInfiniiVisionMeasurementSlotNone.

    • Instrument Command

    :FUNCtion{MathFunction}:TRENd:NMEasurement {NONE|MEAS1|MEAS2|MEAS3|MEAS4|MEAS5|MEAS6|MEAS7|MEAS8|MEAS9|MEAS10}
    :FUNCtion{MathFunction}:TRENd:NMEasurement?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_NONE | None.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_1 | Measurement 1.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_2 | Measurement 2.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_3 | Measurement 3.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_4 | Measurement 4.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_5 | Measurement 5.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_6 | Measurement 6.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_7 | Measurement 7.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_8 | Measurement 8.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_9 | Measurement 9.
AGINFINIIVISION_VAL_MEASUREMENT_SLOT_10 | Measurement 10.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    MeasurementTrend
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE Attribute
MeasurementTrend See Also

Specifies the measurement whose trend is shown in the math waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\MeasurementTrend\Trend Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE 1150461

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • This feature is only available if an ADVMATH license is installed.
  • This property is not supported for 6000X series. use IAgInfiniiVision4MathFunctionMeasurementTrend2.Slot property.
  • For 3000T/4000X/6000X/M924x/P924x/P924x A models with firmware revision greater than 6.0, please use the IAgInfiniiVision4MathFunctionMeasurementTrend2.Slot property, as the "Type" property has been obsoleted.
  • On 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property.
  • NOTE: This property is not supported by 1000X and 2000X series.

    • Instrument Command

    :FUNCtion{MathFunction}:TRENd:MEASurement {FREQ|PER|DUTY|PWID|NWID|RIS|FALL|VRAT|VAV|ACRM}
    :FUNCtion{MathFunction}:TRENd:MEASurement?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_FREQUENCY | Specifies the measurement type as Frequency.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_PERIOD | Specifies the measurement type as Period.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_DUTY_CYCLE | Specifies the measurement type as Duty Cycle.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_POSITIVE_WIDTH | Specifies the measurement type as Positive Width.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_NEGATIVE_WIDTH | Specifies the measurement type as Negative Width.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_RISE_TIME | Specifies the measurement type as Rise Time.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPE_FALL_TIME | Specifies the measurement type as Fall Time.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEV_RATIO | Specifies the measurement type as Voltage Ratio.
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEV_AVERAGE | Specifies the measurement type as Voltage Average
AGINFINIIVISION_VAL_MATH_MEASUREMENT_TREND_TYPEAC_RMS | Specifies the measurement type as AC RMS.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    MeasurementTrend
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS Attribute
MathFunction See Also

The number of smoothing points to use.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Smoothing Points
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS 1150597

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • An odd number of points can be choosed as input from 3 up to half of the measurement record or precision analysis record.
  • Preset value is 5.

    • Instrument Command

    :FUNCtion{MathFunction}:SMOoth:POINts {value}
    :FUNCtion{MathFunction}:SMOoth:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    MathFunction
    AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE Attribute
MathFunction See Also

Range of Full-scale vertical axis for the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Vertical Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE 1150464

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:RANGe {value}
:FUNCtion{MathFunction}:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE Attribute

AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE Attribute
MathFunction See Also

Vertical scale, or units per division, of the selected function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\MathFunction\Vertical Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE 1150467

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the MathFunction repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: On 1000X, 2000X and 3000X series, this property can only be used by "Math2". All other math functions (i.e. "Math1", "Math3" and "Math4") does not use this property

Instrument Command

:FUNCtion{MathFunction}:SCALe {value}
:FUNCtion{MathFunction}:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

MathFunction
AgInfiniiVision


Measurement

Measurement
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Measurement

Branches

Name
Configuration
Statistics
Top

Functions

 | Name | Description
Function | Fetch Jitter Measurement | Returns the measured value of the selected measurement.
Function | Get Measurement Name | Returns the measurement name that corresponds to the one-based index that the user specifies.
Function | Measurement Configure Jitter Measurement | Configure and adds the selected Jitter measurement.
Function | Measurement Fetch Min Max Waveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | Measurement Fetch Waveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | Measurement Fetch Waveform Measurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | Measurement Read Jitter Measurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.
Function | Measurement Read Min Max Waveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | Measurement Read Waveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | Measurement Read Waveform Measurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | Measurements Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | Measurements Acquisition Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | Measurements Auto Setup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | Measurements Clear | Clears all selected measurements and markers from the screen
Function | Measurements Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Function | Measurements Is Invalid Wfm Element | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Top

Attributes

 | Name | Description
Attribute | Measurement Count | Attribute that contains the number of Measurements available on the instrument. This is the maximum index that may be used with the GetMeasurementName() function.
Top

See Also

Reference

AgInfiniiVision


Configuration

Configuration
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration

Functions

 | Name | Description
Function | ConfigureDelay | Configures the edge specifications for the delay and phase measurements.
Top

Attributes

 | Name | Description
Attribute | Delay Occurrence1 | The occurrence count for the first waveform source of a generic delay measurement.
Attribute | Delay Occurrence2 | The occurrence count for the second waveform source of a generic delay measurement.
Attribute | Delay Slope1 | The polarity of the slope for the first waveform source of a generic delay measurement.
Attribute | Delay Slope2 | The polarity of the slope for the second waveform source of a generic delay measurement.
Attribute | Markers Enabled | Enables markers for tracking measurements on the display. This feature is always on.
Attribute | Source2 | Second source for measurements such as Delay, Phase etc.
Attribute | Time At Edge Occurrence | The occurrence count for the TimeAtEdge measurement.
Attribute | Time At Edge Slope | The edge slope for a TimeAtEdge measurement.
Attribute | Time At Value Occurrence | The occurrence count for the TimeAtValue measurement.
Attribute | Time At Value Slope | The edge slope for a TimeAtValue measurement.
Attribute | Time At Value Value | The voltage for the TimeAtValue measurement.
Attribute | Value At Time Time | The time (in seconds) used to make the ValueAtTime measurement.
Attribute | Window | Measurement window when zoomed time base is selected.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_MeasurementConfigurationConfigureDelay Function

AgInfiniiVision_MeasurementConfigurationConfigureDelay Function
Configuration See Also

Configures the edge specifications for the delay and phase measurements.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\ConfigureDelay
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementConfigurationConfigureDelay(
    ViSession Vi,
    ViInt32 Source2BufferSize,
    ViConstString Source2,
    ViInt32 DelaySlope1,
    ViInt32 DelaySlope2,
    ViInt32 DelayOccurrence1,
    ViInt32 DelayOccurrence2
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Source2BufferSize

Number of elements in Source2.

Source2

Second source for measurements such as Delay, Phase etc.

DelaySlope1

The polarity of the slope for the first waveform source of a generic delay measurement.

DelaySlope2

The polarity of the slope for the second waveform source of a generic delay measurement.

DelayOccurrence1

The occurrence count for the first waveform source of a generic delay measurement.

DelayOccurrence2

The occurrence count for the second waveform source of a generic delay measurement.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter DelaySlope1

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

Defined Values For Parameter DelaySlope2

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1 Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1 Attribute
Configuration See Also

The occurrence count for the first waveform source of a generic delay measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Delay Occurrence1
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1 1150168

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:DEFine DEL
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2 Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2 Attribute
Configuration See Also

The occurrence count for the second waveform source of a generic delay measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Delay Occurrence2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2 1150169

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:DEFine DEL
:MEASure:DEFine? DEL

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1 Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1 Attribute
Configuration See Also

The polarity of the slope for the first waveform source of a generic delay measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Delay Slope1
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1 1150172

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:DEFine DEL {POS|NEG}
:MEASure:DEFine? DEL

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2 Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2 Attribute
Configuration See Also

The polarity of the slope for the second waveform source of a generic delay measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Delay Slope2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2 1150170

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:DEFine DEL {POS|NEG}
:MEASure:DEFine? DEL

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED Attribute
Configuration See Also

Enables markers for tracking measurements on the display. This feature is always on.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Markers Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED 1150173

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:SHOW {ON|OFF}
:MEASure:SHOW?

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2 Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2 Attribute
Configuration See Also

Second source for measurements such as Delay, Phase etc.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Source2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2 1150203

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE Attribute
Configuration See Also

The occurrence count for the TimeAtEdge measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Time At Edge Occurrence
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE 1150175

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Need to Cache for use at actual measurement call

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE Attribute
Configuration See Also

The edge slope for a TimeAtEdge measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Time At Edge Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE 1150176

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Need to Cache for use at actual measurement call

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE Attribute
Configuration See Also

The occurrence count for the TimeAtValue measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Time At Value Occurrence
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE 1150177

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Need to Cache for use at actual measurement call

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE Attribute
Configuration See Also

The edge slope for a TimeAtValue measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Time At Value Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE 1150178

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Need to Cache for use at actual measurement call.

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_POSITIVE | A positive (rising) edge
AGINFINIIVISION_VAL_MEASUREMENT_SLOPE_NEGATIVE | A negative (falling) edge
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE Attribute
Configuration See Also

The voltage for the TimeAtValue measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Time At Value Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE 1150180

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME Attribute
Configuration See Also

The time (in seconds) used to make the ValueAtTime measurement.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Value At Time Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME 1150179

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW Attribute
Configuration See Also

Measurement window when zoomed time base is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Configuration\Window
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW 1150174

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:WINDow {MAIN|ZOOM|AUTO|GATE}
:MEASure:WINDow?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_WINDOW_TYPE_MAIN | Upper measurement window
AGINFINIIVISION_VAL_MEASUREMENT_WINDOW_TYPE_ZOOM | Lower measurement window
AGINFINIIVISION_VAL_MEASUREMENT_WINDOW_TYPE_AUTO | Attempts to select the lower Zoom window,if it cannot be made there, the upper Main window is used.
AGINFINIIVISION_VAL_MEASUREMENT_WINDOW_TYPE_GATE | Measurement window is between the X1 and X2 cursors.
Top

Requirements

Supported Models

All supported

See Also

Reference

Configuration
AgInfiniiVision


AgInfiniiVision_FetchJitterMeasurement Function

AgInfiniiVision_FetchJitterMeasurement Function
Measurement See Also

Returns the measured value of the selected measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Fetch Jitter Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FetchJitterMeasurement(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 MeasFunction,
    ViInt32 Slope,
    ViInt32 NumberOfPeriods,
    ViInt32 Unit,
    ViReal64* Result
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Measurement repeated capability.

MeasFunction

The Jitter measurement.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Result

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the ConfigureJitterMeasurement method.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEAure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth}? , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    Defined Values For Parameter MeasFunction

    Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIECLOCK | The Clock TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIEDATA | The Data TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NCJITTER | The N-Cycle Period-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NPERIOD | The N-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCNWIDTH | The -Width to -Width (cycle-to-cycle negative width) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCPWIDTH | The +Width to +Width (cycle-to-cycle positive width) jitter measurement.
    Top

    Defined Values For Parameter Slope

    Name | Description
AGINFINIIVISION_VAL_EDGE_SLOPE_RISING | Rising slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_FALLING | Falling Slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_BOTH | Both Rising and Falling slope.
    Top

    Defined Values For Parameter Unit

    Name | Description
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_SECONDS | Seconds.
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_INTERVAL | Unit Interval.
    Top

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_GetMeasurementName Function

AgInfiniiVision_GetMeasurementName Function
Measurement See Also

Returns the measurement name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Get Measurement Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetMeasurementName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementConfigureJitterMeasurement Function

AgInfiniiVision_MeasurementConfigureJitterMeasurement Function
Measurement See Also

Configure and adds the selected Jitter measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Configure Jitter Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementConfigureJitterMeasurement(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 MeasFunction,
    ViInt32 Slope,
    ViInt32 NumberOfPeriods,
    ViInt32 Unit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Measurement repeated capability.

MeasFunction

The Jitter measurement.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEASure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth} , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    Defined Values For Parameter MeasFunction

    Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIECLOCK | The Clock TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIEDATA | The Data TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NCJITTER | The N-Cycle Period-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NPERIOD | The N-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCNWIDTH | The -Width to -Width (cycle-to-cycle negative width) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCPWIDTH | The +Width to +Width (cycle-to-cycle positive width) jitter measurement.
    Top

    Defined Values For Parameter Slope

    Name | Description
AGINFINIIVISION_VAL_EDGE_SLOPE_RISING | Rising slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_FALLING | Falling Slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_BOTH | Both Rising and Falling slope.
    Top

    Defined Values For Parameter Unit

    Name | Description
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_SECONDS | Seconds.
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_INTERVAL | Unit Interval.
    Top

    See Also

    Reference

    Measurement
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEASUREMENT_COUNT Attribute

AGINFINIIVISION_ATTR_MEASUREMENT_COUNT Attribute
Measurement See Also

Attribute that contains the number of Measurements available on the instrument. This is the maximum index that may be used with the GetMeasurementName() function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEASUREMENT_COUNT 1150001

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEASUREMENT_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementFetchMinMaxWaveform Function

AgInfiniiVision_MeasurementFetchMinMaxWaveform Function
Measurement See Also

Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Fetch Min Max Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementFetchMinMaxWaveform(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 WaveformSize,
    ViReal64[] MinWaveform,
    ViReal64[] MaxWaveform,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

Measurment.For valid values, see the Measurement repeated capability.

WaveformSize

Waveform size.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementFetchWaveform Function

AgInfiniiVision_MeasurementFetchWaveform Function
Measurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Fetch Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementFetchWaveform(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 WaveformSize,
    ViReal64[] WaveformArray,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

Measurment.For valid values, see the Measurement repeated capability.

WaveformSize

Waveform size.

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementFetchWaveformMeasurement Function

AgInfiniiVision_MeasurementFetchWaveformMeasurement Function
Measurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Fetch Waveform Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementFetchWaveformMeasurement(
    ViSession Vi,
    ViConstString Measurement2,
    ViInt32 MeasFunction,
    ViReal64* Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement2

Measurment.For valid values, see the Measurement repeated capability.

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Instrument Command

    :MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT}?

    Requirements

    Supported Models

    All supported

    Defined Values For Parameter MeasFunction

    Name | Description
AGINFINIIVISION_VAL_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGINFINIIVISION_VAL_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGINFINIIVISION_VAL_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGINFINIIVISION_VAL_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGINFINIIVISION_VAL_VOLTAGE_RMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_RMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_OVERSHOOT | The relative waveform distortion that follows an edge transition.
AGINFINIIVISION_VAL_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MAX2 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_FREQUENCY_COUNTER2 | The High precision frequency measurement made with an internal frequency counter.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MIN2 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_DELAY2 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AGINFINIIVISION_VAL_MEASUREMENT_VALUE_AT_TIME2 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_PHASE2 | This measures the relative phase of one waveform with respect to the period on another waveform.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_VALUE2 | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_OF_EDGE2 | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_AREA2 | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_BURST_WIDTH2 | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_STANDARD_DEVIATION2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
    Top

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementReadJitterMeasurement Function

AgInfiniiVision_MeasurementReadJitterMeasurement Function
Measurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Read Jitter Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementReadJitterMeasurement(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 MeasFunction,
    ViInt32 MaxTimeMilliseconds,
    ViInt32 Slope,
    ViInt32 NumberOfPeriods,
    ViInt32 Unit,
    ViReal64* Result
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Measurement repeated capability.

MeasFunction

The Jitter measurement.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Slope

Edge Slope. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.The AgInfiniiVisionEdgeSlopeBoth value is not available for AgInfiniiVisionMeasurementJitterNPeriod.

NumberOfPeriods

Number of periods from 1 to 99. This parameter is not available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData, AgInfiniiVisionMeasurementJitterTIEClock,AgInfiniiVisionMeasurementJitterCTCPWidth, or AgInfiniiVisionMeasurementJitterCTCNWidth.

Unit

Units. This parameter is available when MeasFunction is AgInfiniiVisionMeasurementJitterTIEData or AgInfiniiVisionMeasurementJitterTIEClock.

Result

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Remarks

  • Prior to using this method, enable the jitter analysis using the IAgInfiniiVision4Jitter.AnalysisEnabled property.
  • Configure and add the measurement using the ConfigureJitterMeasurement method.
  • AgInfiniiVisionMeasurementJitterCTCNWidth: The -Width to -Width (cycle-to-cycle negative width) jitter measurement subtracts the first cycle's negative pulse width from the second cycle's negative pulse width for the first measurement result. Then, the second cycle's negative pulse width is subtracted from the third cycle's negative pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterCTCPWidth: The +Width to +Width (cycle-to-cycle positive width) jitter measurement subtracts the first cycle's positive pulse width from the second cycle's positive pulse width for the first measurement result. Then, the second cycle's positive pulse width is subtracted from the third cycle's positive pulse width for the second measurement result, and so on, until all of the cycles of the waveform have been measured.
  • AgInfiniiVisionMeasurementJitterNCJitter: The N-Cycle Period-Period jitter measurement takes a group of cycles and measures the period from the first edge of the first cycle of the group to the final edge of the last cycle of the group. The N-period of the first group is measured and subtracted from the N-period of the second group. After shifting ahead one cycle the next measurement is made.
  • AgInfiniiVisionMeasurementJitterNPeriod: The N-Period jitter measurement measures the time span of N consecutive periods. Then, it shifts ahead one period and measures the time span of the next N consecutive periods, and so on.
  • AgInfiniiVisionMeasurementJitterTIEClock: The Clock TIE (Time Interval Error) jitter measurement compares edges in a clock signal with the edges in an ideal clock signal determined by the clock recovery feature.
  • AgInfiniiVisionMeasurementJitterTIEData: The Data TIE (Time Interval Error) jitter measurement compares edges in a data signal with the edges in an ideal data signal determined by the clock recovery feature.

    • Instrument Command

    :MEAure:{TIEClock|TIEData|NCJitter|NPERiod|CTCNwidth|CTCPwidth}? , {RISing|FALLing|BOTH}, {NumberOfPeriods}, {SECond|UNITinterval}

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    Defined Values For Parameter MeasFunction

    Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIECLOCK | The Clock TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_TIEDATA | The Data TIE (Time Interval Error) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NCJITTER | The N-Cycle Period-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_NPERIOD | The N-Period jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCNWIDTH | The -Width to -Width (cycle-to-cycle negative width) jitter measurement.
AGINFINIIVISION_VAL_MEASUREMENT_JITTER_CTCPWIDTH | The +Width to +Width (cycle-to-cycle positive width) jitter measurement.
    Top

    Defined Values For Parameter Slope

    Name | Description
AGINFINIIVISION_VAL_EDGE_SLOPE_RISING | Rising slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_FALLING | Falling Slope.
AGINFINIIVISION_VAL_EDGE_SLOPE_BOTH | Both Rising and Falling slope.
    Top

    Defined Values For Parameter Unit

    Name | Description
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_SECONDS | Seconds.
AGINFINIIVISION_VAL_JITTER_MEASUREMENT_UNIT_INTERVAL | Unit Interval.
    Top

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementReadMinMaxWaveform Function

AgInfiniiVision_MeasurementReadMinMaxWaveform Function
Measurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Read Min Max Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementReadMinMaxWaveform(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 WaveformSize,
    ViInt32 MaxTimeMilliseconds,
    ViReal64[] MinWaveform,
    ViReal64[] MaxWaveform,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

Measurment.For valid values, see the Measurement repeated capability.

WaveformSize

Waveform size.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementReadWaveform Function

AgInfiniiVision_MeasurementReadWaveform Function
Measurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Read Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementReadWaveform(
    ViSession Vi,
    ViConstString Measurement,
    ViInt32 WaveformSize,
    ViInt32 MaxTimeMilliseconds,
    ViReal64[] WaveformArray,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement

Measurment.For valid values, see the Measurement repeated capability.

WaveformSize

Waveform size.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

WaveformArray

The array contains the acquired waveform. Units for the individual array elements are in volts.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Requirements

    Supported Models

    All supported

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementReadWaveformMeasurement Function

AgInfiniiVision_MeasurementReadWaveformMeasurement Function
Measurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurement Read Waveform Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementReadWaveformMeasurement(
    ViSession Vi,
    ViConstString Measurement2,
    ViInt32 MeasFunction,
    ViInt32 MaxTimeMilliseconds,
    ViReal64* Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Measurement2

Measurment.For valid values, see the Measurement repeated capability.

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Remarks

Possible source names include (availability of channel depends on model and available licenses):

  • "Channel<1-4>"
  • "DigitalChannel<0-15>"
  • "FUNC", for 2000X/3000X
  • "Math<1-4>"
  • "WMEM<1-4>"

    • Instrument Command

    :MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT}?

    Requirements

    Supported Models

    All supported

    Defined Values For Parameter MeasFunction

    Name | Description
AGINFINIIVISION_VAL_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGINFINIIVISION_VAL_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGINFINIIVISION_VAL_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGINFINIIVISION_VAL_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGINFINIIVISION_VAL_VOLTAGE_RMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_RMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_OVERSHOOT | The relative waveform distortion that follows an edge transition.
AGINFINIIVISION_VAL_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MAX2 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_FREQUENCY_COUNTER2 | The High precision frequency measurement made with an internal frequency counter.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MIN2 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_DELAY2 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AGINFINIIVISION_VAL_MEASUREMENT_VALUE_AT_TIME2 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_PHASE2 | This measures the relative phase of one waveform with respect to the period on another waveform.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_VALUE2 | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_OF_EDGE2 | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_AREA2 | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_BURST_WIDTH2 | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_STANDARD_DEVIATION2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
    Top

    See Also

    Reference

    Measurement
    AgInfiniiVision


AgInfiniiVision_MeasurementsAbort Function

AgInfiniiVision_MeasurementsAbort Function
Measurement See Also

Aborts an acquisition and returns the oscilloscope to the Idle state.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Abort
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsAbort(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:STOP

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementsAcquisitionStatus Function

AgInfiniiVision_MeasurementsAcquisitionStatus Function
Measurement See Also

Returns whether an acquisition is in progress, complete, or if the status is unknown.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Acquisition Status
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsAcquisitionStatus(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Status

Acquisition Status. May be one of the values define by IviScopeAcquisitionStatusEnum.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGINFINIIVISION_VAL_ACQ_IN_PROGRESS | The oscilloscope is still acquiring data.
AGINFINIIVISION_VAL_ACQ_COMPLETE | The oscilloscope has completed the acquisition.
AGINFINIIVISION_VAL_ACQ_STATUS_UNKNOWN | The oscilloscope cannot determine the status of the acquisition.
Top

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementsAutoSetup Function

AgInfiniiVision_MeasurementsAutoSetup Function
Measurement See Also

Automatically configures all the oscilloscopes settings based on the input signals.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Auto Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsAutoSetup(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:AUToscale

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementsClear Function

AgInfiniiVision_MeasurementsClear Function
Measurement See Also

Clears all selected measurements and markers from the screen

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsClear(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:MEASure:CLEar

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementsInitiate Function

AgInfiniiVision_MeasurementsInitiate Function
Measurement See Also

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Initiate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsInitiate(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:DIGitize;*OPC?

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


AgInfiniiVision_MeasurementsIsInvalidWfmElement Function

AgInfiniiVision_MeasurementsIsInvalidWfmElement Function
Measurement See Also

Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Measurements Is Invalid Wfm Element
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MeasurementsIsInvalidWfmElement(
    ViSession Vi,
    ViReal64 elementValue,
    ViBoolean* IsInvalid
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

elementValue

Pass one of the values from the waveform array returned by the read and fetch waveform methods.

IsInvalid

Returns whether true when the elementValue is a valid voltage or false for a value indicating that the oscilloscope could not sample a voltage.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgInfiniiVision


Statistics

Statistics
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics

Functions

 | Name | Description
Function | Get Statistics Results | Returns the results of the continuously displayed measurements.
Function | Increment Statistics | This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.
Function | Install Measurement Statistics | Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.
Function | Reset Statistics | This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.
Top

Attributes

 | Name | Description
Attribute | Statistics Count | Specifies the maximum number of values used when calculating measurement statistics.
Attribute | Statistics Display Enabled | Enables or disables the display of the measurement statistics.
Attribute | Statistics Format | Specifies the type of information returned by the GetResults() method.
Attribute | Statistics Relative Std Dev Enabled | Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetStatisticsResults Function

AgInfiniiVision_GetStatisticsResults Function
Statistics See Also

Returns the results of the continuously displayed measurements.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Get Statistics Results
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetStatisticsResults(
    ViSession Vi,
    ViInt32 ResultsBufferSize,
    ViChar[] Results
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ResultsBufferSize

Number of elements in Results.

Results

The results for the continuously displayed measurements.

Return Value

Success or failure code.

Remarks

  • If more than one measurement is running continuously, the return values are duplicated for each continuous measurement from the first to last (left to right) result displayed. Each result returned is separated from the previous result by a comma. There is a maximum of four continuous measurements that can be continuously displayed at a time.
  • When no quick measurements are installed, this method returns nothing (empty string). When the count for any of the measurements is 0, the value of infinity (9.9E+37) is returned for the min, max, mean, and standard deviation.
  • Measurement label, current, min, max, mean, std dev, and count are only returned if the Configuration.ResultsStatistics property is set to ON.
  • The following shows the order of values received for a single measurement:
    • Measurement label current min max mean std dev count

    If Configuration.ResultsStatistics property is set to Current, Min, Max, Mean, Standard Deviation or Count, only that particular statistic value is returned for each measurement that is on.

    Instrument Command

    :MEASure:RESults?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Statistics
    AgInfiniiVision


AgInfiniiVision_IncrementStatistics Function

AgInfiniiVision_IncrementStatistics Function
Statistics See Also

This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Increment Statistics
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_IncrementStatistics(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • This command lets you, for example, gather statistics over multiple pulses captured in a single acquisition. To do this, change the horizontal position and enter the command for each new pulse that is measured.
  • This method is only valid when the oscilloscope is stopped and quick measurements are on.
  • The method is valid in segmented acquisition mode even though the corresponding front panel softkey is not available.

    • Instrument Command

    :MEASure:STATistics:INCRement

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Statistics
    AgInfiniiVision


AgInfiniiVision_InstallMeasurementStatistics Function

AgInfiniiVision_InstallMeasurementStatistics Function
Statistics See Also

Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Install Measurement Statistics
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_InstallMeasurementStatistics(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

Specifies the source for the measurement.

Measurement

Specifies the type of the measurement to install.

Return Value

Success or failure code.

Remarks

The Source parameter can be specified in one of the following formats:

  • DigitalChannel<d>, where d: 0 to the number of digital channels available minus 1.
    This format is valid only for the following measurement types: FrequencyCounter, DutyCycle, Frequency, Negative Pulse Width, Positive Pulse Width, Period.
  • Channel<n>, where n: 1 to the number of analog channels available.
  • FUNC
  • MATH
  • WMEM<r>, where n: 1 to 2.
  • VAL_EXTERNAL
    This format is valid only for the FrequencyCounter measurement.

The Measurement parameter can be set to one of the following values:
  • AgInfiniiVisionMeasurementRiseTime - starts a rise-time measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallTime - starts a fall-time measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFrequency - starts a frequency measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementPeriod - starts the period measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageRMS - starts an RMS value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltagePeakToPeak - starts a vertical peak-to-peak measurement.
  • AgInfiniiVisionMeasurementVoltageMax - starts a maximum vertical value measurement.
  • AgInfiniiVisionMeasurementVoltageMin - starts a minimum vertical value measurement.
  • AgInfiniiVisionMeasurementVoltageHigh - starts a waveform top value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageLow - starts a waveform base value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageAverage - starts an average value measurement.
  • AgInfiniiVisionMeasurementWidthNeg - starts the negative pulse width measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementWidthPos - starts the positive pulse width measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementDutyCycleNeg - starts a duty cycle measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementDutyCycePos - starts a duty cycle measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementAmplitude - starts a vertical amplitude measurement.
  • AgInfiniiVisionMeasurementVoltageCycleRMS - starts an RMS value measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementVoltageCycleAverage - starts an average value measurement.
  • AgInfiniiVisionMeasurementOverShoot - starts an overshoot measurement. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementPreShoot - starts a preshoot measurement.
  • AgInfiniiVisionMeasurementFrequencyCounter - starts a counter measurement. Only valid Sources are: DIG<d> or CHAN<n> or EXT
  • AgInfiniiVisionMeasurementTimeAtMax - starts an X-at-Max-Y measurement on the selected window.
  • AgInfiniiVisionMeasurementTimeAtMin - starts an X-at-Min-Y measurement on the selected window.
  • AgInfiniiVisionMeasurementDelay - places the instrument in continuous measurement mode and starts a delay measurement.
  • AgInfiniiVisionMeasurementPhase - places the instrument in continuous measurement mode and starts a phase measurement.
  • AgInfiniiVisionMeasurementArea - installs an area measurement on screen. Area measurements show the are between the waveform and the ground level. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementBurstWidth - installs a burst width measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallingEdgeCount - installs a falling edge count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementFallingPulseCount - installs a falling pulse count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementRisingEdgeCount - installs a rising edge count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementRisingPulseCount - installs a rising pulse count measurement on screen. This measurement is not available if the source selected is FFT.
  • AgInfiniiVisionMeasurementStandardDeviation - starts standard deviation measurement. This measurement is not available if the source selected is FFT.

Instrument Command

:MEASure:{RISetime|FALLtime|FREQuency|PERiod|VRMS|VPP|VMAX|VMIN|VTOP|VBASe|VAVerage|NWIDth|PWIDth|DUTYcycle|DUTYcycle|VAMPlitude|VRMS|VAVerage|OVERshoot|PREShoot|COUNter|XMAX|XMIN|DELay|PHASe|VTIMe|TVALue|TEDGe|ARE|BWID|NEDG|NPUL|PEDG|PPUL|SDEV|BRAT} {Source}

Requirements

Supported Models

All supported

Defined Values For Parameter Measurement

Name | Description
AGINFINIIVISION_VAL_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGINFINIIVISION_VAL_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGINFINIIVISION_VAL_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGINFINIIVISION_VAL_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGINFINIIVISION_VAL_VOLTAGE_RMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_RMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_OVERSHOOT | The relative waveform distortion that follows an edge transition.
AGINFINIIVISION_VAL_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MAX2 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_FREQUENCY_COUNTER2 | The High precision frequency measurement made with an internal frequency counter.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MIN2 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_DELAY2 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AGINFINIIVISION_VAL_MEASUREMENT_VALUE_AT_TIME2 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_PHASE2 | This measures the relative phase of one waveform with respect to the period on another waveform.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_VALUE2 | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_OF_EDGE2 | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_AREA2 | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_BURST_WIDTH2 | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_STANDARD_DEVIATION2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
Top

See Also

Reference

Statistics
AgInfiniiVision


AgInfiniiVision_ResetStatistics Function

AgInfiniiVision_ResetStatistics Function
Statistics See Also

This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Reset Statistics
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetStatistics(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:MEASure:STATistics:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Statistics
AgInfiniiVision


AGINFINIIVISION_ATTR_STATISTICS_COUNT Attribute

AGINFINIIVISION_ATTR_STATISTICS_COUNT Attribute
Statistics See Also

Specifies the maximum number of values used when calculating measurement statistics.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Statistics Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_STATISTICS_COUNT 1150356

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_STATISTICS_COUNT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Count property can be specified in one of the following string formats:

  • "Infinite"
  • "n", where n: an integer from 2 to 2000

Instrument Command

:MEASure:STATistics:MCOunt {value}
:MEASure:STATistics:MCOunt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Statistics
AgInfiniiVision


AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED Attribute

AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED Attribute
Statistics See Also

Enables or disables the display of the measurement statistics.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Statistics Display Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED 1150430

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:STATistics:DISPlay {ON|OFF}
:MEASure:STATistics:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Statistics
AgInfiniiVision


AGINFINIIVISION_ATTR_STATISTICS_FORMAT Attribute

AGINFINIIVISION_ATTR_STATISTICS_FORMAT Attribute
Statistics See Also

Specifies the type of information returned by the GetResults() method.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Statistics Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_STATISTICS_FORMAT 1150355

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_STATISTICS_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Format property can be set to one of the following values:

  • AgInfiniiVisionMeasurementStatisticsFormatOn - All statistics are on
  • AgInfiniiVisionMeasurementStatisticsFormatCurrent - Only the Current statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMinimum - Only the Minimum statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMaximum - Only the Maximum statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatMean - Only the Mean statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatStandardDeviation - Only the Standard Deviation statistic is on
  • AgInfiniiVisionMeasurementStatisticsFormatCount - Only the Count statistic is on

Instrument Command

:MEASure:STATistics {ON|CURR|MIN|MAX|MEAN|STDD|COUN}
:MEASure:STATistics?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_ALL | All statistics are returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_CURRENT | Current Statistic is returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_MINIMUM | Minimum statistic is returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_MAXIMUM | Maximum statistic is returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_MEAN | Mean statistic is returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_STANDARD_DEVIATION | Standard Deviation statistic is returned.
AGINFINIIVISION_VAL_MEASUREMENT_STATISTICS_FORMAT_COUNT | Count statistic is returned.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Statistics
AgInfiniiVision


AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED Attribute

AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED Attribute
Statistics See Also

Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Measurement\Statistics\Statistics Relative Std Dev Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED 1150357

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:MEASure:STATistics:RSDeviation {ON|OFF}
:MEASure:STATistics:RSDeviation?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Statistics
AgInfiniiVision


Memory

Memory
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Memory

Branches

Name
ResultFormat
Top

Functions

 | Name | Description
Function | Memory Recall | Recall option for Mask, Oscilloscope Setup and Reference memory.
Function | Memory Save | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.
Top

Attributes

 | Name | Description
Attribute | Current Recall Directory | Present working directory for recall operations.
Attribute | Current Recall File | File for recall operations.
Attribute | Current Save Directory | Present working directory for save operations.
Attribute | Current Save File | File for save operations.
Attribute | Image Format | Type of image format
Attribute | Image Palette | Image palette color.
Attribute | Invert Color Enabled | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.
Attribute | Reference Waveform Source | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>
Attribute | Save Factors Enabled | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.
Attribute | Save Option | The segments to be included when the waveform is saved.
Attribute | Serial Recall Destination | This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).
Attribute | Waveform Format | Data format of waveform
Attribute | Waveform Length | Waveform data length (number of points saved).
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY Attribute

AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY Attribute
Memory See Also

Present working directory for recall operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Current Recall Directory
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY 1150127

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:RECall:PWD "{value}"
:RECall:PWD?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE Attribute

AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE Attribute
Memory See Also

File for recall operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Current Recall File
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE 1150125

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

It is the file's base name only, without path information or an extension

Instrument Command

:RECall:FILename {value}
:RECall:FILename?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY Attribute

AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY Attribute
Memory See Also

Present working directory for save operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Current Save Directory
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY 1150126

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:PWD {value}
:SAVE:PWD?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE Attribute

AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE Attribute
Memory See Also

File for save operations.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Current Save File
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE 1150124

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

It is the file's base name only, without path information or an extension

Instrument Command

:SAVE:FILename {value}
:SAVE:FILename?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT Attribute

AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT Attribute
Memory See Also

Type of image format

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Image Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT 1150117

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NONE is returned, when a waveform data file format is currently selected

Instrument Command

:SAVE:IMAGe:FORMat {BMP|BMP8bit|PNG}
:SAVE:IMAGe:FORMat?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEMORY_IMAGE_FORMATBMP | BMP
AGINFINIIVISION_VAL_MEMORY_IMAGE_FORMATBMP_8BIT | BMP8bit
AGINFINIIVISION_VAL_MEMORY_IMAGE_FORMATPNG | PNG
Top

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE Attribute

AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE Attribute
Memory See Also

Image palette color.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Image Palette
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE 1150119

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:IMAGe:PALette {COL|GRAY}
:SAVE:IMAGe:PALette?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEMORY_IMAGE_PALETTE_COLOR | Color
AGINFINIIVISION_VAL_MEMORY_IMAGE_PALETTE_GRAYSCALE | GrayScale
Top

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED Attribute
Memory See Also

Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Invert Color Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED 1150118

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:IMAGe:INKSaver {ON|OFF}
:SAVE:IMAGe:INKSaver?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AgInfiniiVision_MemoryRecall Function

AgInfiniiVision_MemoryRecall Function
Memory See Also

Recall option for Mask, Oscilloscope Setup and Reference memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Memory Recall
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MemoryRecall(
    ViSession Vi,
    ViInt32 Options,
    ViConstString FileName
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Options

Recall Options

FileName

Specifies file to be recalled

Return Value

Success or failure code.

Remarks

When recalling an LDF or DBC file, ensure that the destination has been set via Memory::SerialRecallDestination before calling Memory::Recall

Instrument Command

:RECall{:MASK|:SETup|:WMEMory1|:WMEMory2|:ARBitrary|:ARBitrary|:WMEMory3|:WMEMory4|:LDF|:DBC} {FileName}

Requirements

Supported Models

All supported

Defined Values For Parameter Options

Name | Description
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_MASK | Recalls a mask.
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_SETUP | Recalls an oscilloscope setup
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_REFERENCE_WAVEFORM1 | Recalls reference waveform 1
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_REFERENCE_WAVEFORM2 | Recalls reference waveform 2
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_ARB_CSV | Recalls the saved arbitrary waveform 1.
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_ARB_CSV2 | Recalls the saved arbitrary waveform 2.
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_REFERENCE_WAVEFORM3 | Recalls reference waveform 3
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONS_REFERENCE_WAVEFORM4 | Recalls reference waveform 4
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONSLDF | Loads a LIN description file (LDF) symbolic data file into the oscilloscope.
AGINFINIIVISION_VAL_MEMORY_RECALL_OPTIONSDBC | Load a CAN DBC (communication database) symbolic data file into the oscilloscope.
Top

See Also

Reference

Memory
AgInfiniiVision


AgInfiniiVision_MemorySave Function

AgInfiniiVision_MemorySave Function
Memory See Also

Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Memory Save
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_MemorySave(
    ViSession Vi,
    ViInt32 Options,
    ViConstString FileName
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Options

Save options

FileName

Specifies file to be saved

Return Value

Success or failure code.

Remarks

  • AgInfiniiVisionMemorySaveOptionsArbCsv2 option is not available for 2000X and 3000X model series.

    • Instrument Command

    :SAVE{:IMAGe|:WAVeform|:WMEMory|:SETup|:MASK|:LIST|:ARBitrary|:ARBitrary|:MULTi|:RESults} {FileName}

    Requirements

    Supported Models

    All supported

    Defined Values For Parameter Options

    Name | Description
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_IMAGE | Saves an Image
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_WAVEFORM | Saves waveform data
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_REFERENCE_WAVEFORM | Saves oscilloscope waveform data to a reference waveform file.
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_SETUP | Saves an oscilloscope setup
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_MASK | Saves a mask
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_LISTER | ONLY SUPPORTED ON THE 3000X SERIES- Saves the Lister display data
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_ARB_CSV | Saves the currently-loaded Arbitrary waveform 1 to the file location specified (internal or external).
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_ARB_CSV2 | Saves the currently-loaded Arbitrary waveform 2 to the file location specified (internal or external).
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_MULTI_WAVEFORM_DATA | Save multiple oscilloscope waveform to a h5 waveform file.
AGINFINIIVISION_VAL_MEMORY_SAVE_OPTIONS_ANALYSIS_RESULTS | Saves analysis results to a comma-separated values (*.csv) file on a USB storage device.
    Top

    See Also

    Reference

    Memory
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE Attribute

AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE Attribute
Memory See Also

The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Reference Waveform Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE 1150123

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Only ADD or SUBtract math operations can be saved as reference waveforms
  • The ReferenceWaveformSource property can be specified in one of the following string formats:
  • "Channel<n>", where n: 1 to the number of available analog channels.
  • "Math<m>", where m : 1 t o 4.
  • "WMEM<m>", where m : 1 t o 4.

    • Instrument Command

    :SAVE:WMEMory:SOURce {value}
    :SAVE:WMEMory:SOURce?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Memory
    AgInfiniiVision


ResultFormat

ResultFormat
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat

Attributes

 | Name | Description
Attribute | Cursor Enabled | Enables or disables whether the cursor values will be included when analysis results are saved.
Attribute | Histogram Enabled | Enables or disables whether the histogram statistics will be included when analysis results are saved.
Attribute | Mask Enabled | Enables or disables whether the mask statistics will be included when analysis results are saved.
Attribute | Measurement Enabled | Enables or disables whether the measurement results will be included when analysis results are saved.
Attribute | Search Enabled | Enables or disables whether the found search event times will be included when analysis results are saved.
Attribute | Segmented Enabled | Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the cursor values will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Cursor Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED 1150601

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:CURSor {1|0}
    :SAVE:RESults:FORMat:CURSor?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the histogram statistics will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Histogram Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED 1150602

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:HISTogram {1|0}
    :SAVE:RESults:FORMat:HISTogram?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the mask statistics will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Mask Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED 1150603

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:MASK {1|0}
    :SAVE:RESults:FORMat:MASK?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the measurement results will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Measurement Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED 1150604

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:MEASurement {1|0}
    :SAVE:RESults:FORMat:MEASurement?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the found search event times will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Search Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED 1150605

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:SEARch {1|0}
    :SAVE:RESults:FORMat:SEARch?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED Attribute
ResultFormat See Also

Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\ResultFormat\Segmented Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED 1150606

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Analysis results are saved using Save method with Options parameter selected as AgInfiniiVisionMemorySaveOptionsAnalysisResults.
  • Preset value is false.

    • Instrument Command

    :SAVE:RESults:FORMat:SEGMented {1|0}
    :SAVE:RESults:FORMat:SEGMented?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ResultFormat
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED Attribute

AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED Attribute
Memory See Also

Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Save Factors Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED 1150128

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:IMAGe:FACTors {}
:SAVE:IMAGe:FACTors?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION Attribute

AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION Attribute
Memory See Also

The segments to be included when the waveform is saved.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Save Option
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION 1150122

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:WAVeform:SEGMented {ALL|CURR}
:SAVE:WAVeform:SEGMented?

Defined Values

Name | Description
AGINFINIIVISION_VAL_MEMORY_SEGMENT_OPTION_ALL | All acquired segments are saved
AGINFINIIVISION_VAL_MEMORY_SEGMENT_OPTION_CURRENT | Currently selected segment is saved
Top

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION Attribute

AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION Attribute
Memory See Also

This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Serial Recall Destination
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION 1150668

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS1 | Selects Serial Bus 1 as the recall destination for LDF or DBC files.
AGINFINIIVISION_VAL_SERIAL_BUS2 | Selects Serial Bus 2 as the recall destination for LDF or DBC files.
Top

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT Attribute

AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT Attribute
Memory See Also

Data format of waveform

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Waveform Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT 1150120

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input value AgInfiniiVisionMemoryWaveformFormatALB is not supported for 4000x and M9240X series models.

    • Instrument Command

    :SAVE:WAVeform:FORMat {ALB|ASC|CSV|BIN}
    :SAVE:WAVeform:FORMat?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MEMORY_WAVEFORM_FORMATALB | Agilent module binary format file
AGINFINIIVISION_VAL_MEMORY_WAVEFORM_FORMATASCI_IXY | Comma-separated value files for each analog channel that is turned on
AGINFINIIVISION_VAL_MEMORY_WAVEFORM_FORMATCSV | Single comma-separated value file that contains information for all analog channels that are turned on
AGINFINIIVISION_VAL_MEMORY_WAVEFORM_FORMAT_BINARY | Binary data format file
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Memory
    AgInfiniiVision


AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH Attribute

AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH Attribute
Memory See Also

Waveform data length (number of points saved).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Memory\Waveform Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH 1150121

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SAVE:WAVeform:LENGth {value}
:SAVE:WAVeform:LENGth?

Requirements

Supported Models

All supported

See Also

Reference

Memory
AgInfiniiVision


ReferenceWaveform

ReferenceWaveform
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform

Functions

 | Name | Description
Function | Reference Waveform Clear | Clears the specified reference waveform location.
Function | Reference Waveform Enable | Enables/Disables the specified reference waveform.
Function | Reference Waveform Get Label | Returns the Label associated with a specified reference waveform.
Function | Reference Waveform Get Offset | Returns the Current offset value for the selected reference waveform.
Function | Reference Waveform Get Range | Returns the Current full-scale range for the specified reference waveform.
Function | Reference Waveform Get Skew Factor | Returns the Current skew factor for the selected reference waveform.
Function | Reference Waveform Get Vertical Scale | Returns the Current vertical units per division for the specified reference waveform.
Function | Reference Waveform Is Enabled | Returns the Current display setting of the specified reference waveform.
Function | Reference Waveform Save | Copies the analog channel or math function waveform to the specified reference waveform location.
Function | Reference Waveform Set Label | Label for the specified reference waveform.
Function | Reference Waveform Set Offset | Offset value that is represented at center screen for the selected reference waveform.
Function | Reference Waveform Set Range | Full-scale range of vertical axis of the selected reference waveform.
Function | Reference Waveform Set Skew Factor | Skew factor for the specified reference waveform.
Function | Reference Waveform Set Vertical Scale | Vertical scale, or units per division, of the selected reference waveform.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ReferenceWaveformClear Function

AgInfiniiVision_ReferenceWaveformClear Function
ReferenceWaveform See Also

Clears the specified reference waveform location.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformClear(
    ViSession Vi,
    ViInt16 WaveformLocation
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:CLEar

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformEnable Function

AgInfiniiVision_ReferenceWaveformEnable Function
ReferenceWaveform See Also

Enables/Disables the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Enable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformEnable(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViBoolean DisplayState
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

DisplayState

On|Off Display State

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:DISPlay {}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformGetLabel Function

AgInfiniiVision_ReferenceWaveformGetLabel Function
ReferenceWaveform See Also

Returns the Label associated with a specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Get Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformGetLabel(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

ValBufferSize

Buffer Size.

Val

A quoted ASCII string.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:LABel?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformGetOffset Function

AgInfiniiVision_ReferenceWaveformGetOffset Function
ReferenceWaveform See Also

Returns the Current offset value for the selected reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Get Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformGetOffset(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Val

Vertical offset value.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YOFFset?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformGetRange Function

AgInfiniiVision_ReferenceWaveformGetRange Function
ReferenceWaveform See Also

Returns the Current full-scale range for the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Get Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformGetRange(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Val

The vertical full-scale range value.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YRANge?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformGetSkewFactor Function

AgInfiniiVision_ReferenceWaveformGetSkewFactor Function
ReferenceWaveform See Also

Returns the Current skew factor for the selected reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Get Skew Factor
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformGetSkewFactor(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Val

Time in seconds.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:SKEW?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformGetVerticalScale Function

AgInfiniiVision_ReferenceWaveformGetVerticalScale Function
ReferenceWaveform See Also

Returns the Current vertical units per division for the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Get Vertical Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformGetVerticalScale(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Val

Vertical units per division.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YSCale?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformIsEnabled Function

AgInfiniiVision_ReferenceWaveformIsEnabled Function
ReferenceWaveform See Also

Returns the Current display setting of the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Is Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformIsEnabled(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Val

Possible values are: (1 or ON) or (0 or OFF).

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSave Function

AgInfiniiVision_ReferenceWaveformSave Function
ReferenceWaveform See Also

Copies the analog channel or math function waveform to the specified reference waveform location.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Save
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSave(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViInt32 SourceBufferSize,
    ViConstString Source
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

SourceBufferSize

Number of elements in Source.

Source

Waveform Source

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:SAVE {Source}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSetLabel Function

AgInfiniiVision_ReferenceWaveformSetLabel Function
ReferenceWaveform See Also

Label for the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Set Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSetLabel(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViInt32 LabelBufferSize,
    ViConstString Label
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

LabelBufferSize

Number of elements in Label.

Label

Label can have maximum of 10 characters, ASCII characters are allowed. Lower case are automatically converted to upper case.

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:LABel "{Label}"

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSetOffset Function

AgInfiniiVision_ReferenceWaveformSetOffset Function
ReferenceWaveform See Also

Offset value that is represented at center screen for the selected reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Set Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSetOffset(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64 OffsetValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

OffsetValue

Offset Value

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YOFFset {OffsetValue}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSetRange Function

AgInfiniiVision_ReferenceWaveformSetRange Function
ReferenceWaveform See Also

Full-scale range of vertical axis of the selected reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Set Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSetRange(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64 Range
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Range

Vertical axis range

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YRANge {Range}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSetSkewFactor Function

AgInfiniiVision_ReferenceWaveformSetSkewFactor Function
ReferenceWaveform See Also

Skew factor for the specified reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Set Skew Factor
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSetSkewFactor(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64 Skewfactor
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

Skewfactor

Skew Factor

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:SKEW {Skewfactor}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


AgInfiniiVision_ReferenceWaveformSetVerticalScale Function

AgInfiniiVision_ReferenceWaveformSetVerticalScale Function
ReferenceWaveform See Also

Vertical scale, or units per division, of the selected reference waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\ReferenceWaveform\Reference Waveform Set Vertical Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReferenceWaveformSetVerticalScale(
    ViSession Vi,
    ViInt16 WaveformLocation,
    ViReal64 VerticalScale
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveformLocation

Reference waveform Location 1 or 2

VerticalScale

Vertical Scale or Units per Division

Return Value

Success or failure code.

Instrument Command

:WMEMory{WaveformLocation}:YSCale {VerticalScale}

Requirements

Supported Models

All supported

See Also

Reference

ReferenceWaveform
AgInfiniiVision


Search

Search
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search

Branches

Name
Edge
Glitch
Peak
Runt
Serial
Transition
USB
Top

Attributes

 | Name | Description
Attribute | Search Count | Read Only - Gets the number of search events found.
Attribute | Search Mode | The oscilloscope search mode.
Top

See Also

Reference

AgInfiniiVision


Edge

Edge
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Edge

Functions

 | Name | Description
Function | Configure Search Edge | Configures the Source and Slope properties for an Edge search.
Top

Attributes

 | Name | Description
Attribute | Search Edge Slope | The slope of the edge for the search.
Attribute | Search Edge Source | The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureSearchEdge Function

AgInfiniiVision_ConfigureSearchEdge Function
Edge See Also

Configures the Source and Slope properties for an Edge search.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Edge\Configure Search Edge
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureSearchEdge(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Slope
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The channel on which to search for edges. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Slope

The slope of the edge for the search.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_NEGATIVE | Negative slope of the edge.
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_POSITIVE | Positive slope of the edge.
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_EITHER | Either negative or positive slope of the edge.
Top

See Also

Reference

Edge
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE Attribute

AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE Attribute
Edge See Also

The slope of the edge for the search.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Edge\Search Edge Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE 1150209

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionSearchEdgeSlopeNegative - specifies the negative slope
  • AgInfiniiVisionSearchEdgeSlopePositive - specifies the positive slope
  • AgInfiniiVisionSearchEdgeSlopeEither - specifies either the negative or positive slope

Instrument Command

:SEARch:EDGE:SLOPe {NEG|POS|EITH}
:SEARch:EDGE:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_NEGATIVE | Negative slope of the edge.
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_POSITIVE | Positive slope of the edge.
AGINFINIIVISION_VAL_SEARCH_EDGE_SLOPE_EITHER | Either negative or positive slope of the edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Edge
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE Attribute

AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE Attribute
Edge See Also

The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Edge\Search Edge Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE 1150210

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:EDGE:SOURce {value}
:SEARch:EDGE:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Edge
AgInfiniiVision


Glitch

Glitch
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch

Functions

 | Name | Description
Function | Configure Search Glitch | Configures the Source, Polarity and Condition properties for the Glitch search.
Function | Get Search Glitch Range | Gets the pulse width duration time (in seconds) for the selected source.
Function | Set Search Glitch Range | Sets the pulse width duration time (in seconds) for the selected source.
Top

Attributes

 | Name | Description
Attribute | Search Glitch Condition | Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.
Attribute | Search Glitch Max Pulse Width Duration | The maximum pulse width duration time (in seconds) for the selected source.
Attribute | Search Glitch Min Pulse Width Duration | The minimum pulse width duration time (in seconds) for the selected source.
Attribute | Search Glitch Polarity | The polarity for the glitch (pulse width) source.
Attribute | Search Glitch Source | The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureSearchGlitch Function

AgInfiniiVision_ConfigureSearchGlitch Function
Glitch See Also

Configures the Source, Polarity and Condition properties for the Glitch search.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Configure Search Glitch
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureSearchGlitch(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Polarity,
    ViInt32 Condition
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The channel on which to search for glitches (pulse widths). The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Polarity

The polarity for the glitch (pulse width) source.

Condition

The mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Polarity

Name | Description
AGINFINIIVISION_VAL_SEARCH_GLITCH_POLARITY_POSITIVE | Positive polarity.
AGINFINIIVISION_VAL_SEARCH_GLITCH_POLARITY_NEGATIVE | Negative polarity.
Top

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_GREATER_THAN | To Search for a pulse width greater than a time value.
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_LESS_THAN | To Search for a pulse width less than a time value.
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_RANGE | To Search for a pulse width within a range of time values.
Top

See Also

Reference

Glitch
AgInfiniiVision


AgInfiniiVision_GetSearchGlitchRange Function

AgInfiniiVision_GetSearchGlitchRange Function
Glitch See Also

Gets the pulse width duration time (in seconds) for the selected source.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Get Search Glitch Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetSearchGlitchRange(
    ViSession Vi,
    ViReal64* LowerLimit,
    ViReal64* UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimit

The lower limit for the pulse width duration time (in seconds) for the selected source

UpperLimit

The upper limit for the pulse width duration time (in seconds) for the selected source

Return Value

Success or failure code.

Instrument Command

:SEARch:GLITch:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION Attribute
Glitch See Also

Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Search Glitch Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION 1150351

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchGlitchConditionGreaterThan - to search for a pulse width greater than a time value
  • AgInfiniiVisionSearchGlitchConditionLessThan - to search for a pulse width less than a time value
  • AgInfiniiVisionSearchGlitchConditionRange - to search for a pulse width within a range of time values

Instrument Command

:SEARch:GLITch:QUALifier {GRE|LESS|RANG}
:SEARch:GLITch:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_GREATER_THAN | To Search for a pulse width greater than a time value.
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_LESS_THAN | To Search for a pulse width less than a time value.
AGINFINIIVISION_VAL_SEARCH_GLITCH_CONDITION_RANGE | To Search for a pulse width within a range of time values.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION Attribute

AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION Attribute
Glitch See Also

The maximum pulse width duration time (in seconds) for the selected source.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Search Glitch Max Pulse Width Duration
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION 1150214

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:GLITch:LESSthan {value}
:SEARch:GLITch:LESSthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION Attribute

AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION Attribute
Glitch See Also

The minimum pulse width duration time (in seconds) for the selected source.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Search Glitch Min Pulse Width Duration
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION 1150215

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:GLITch:GREaterthan {value}
:SEARch:GLITch:GREaterthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY Attribute

AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY Attribute
Glitch See Also

The polarity for the glitch (pulse width) source.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Search Glitch Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY 1150212

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSearchGlitchPolarityPositive - to specify positive polarity for the glitch search
  • AgInfiniiVisionSearchGlitchPolarityNegative - to specify negative polarity for the glitch search

Instrument Command

:SEARch:GLITch:POLarity {POS|NEG}
:SEARch:GLITch:POLarity?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_GLITCH_POLARITY_POSITIVE | Positive polarity.
AGINFINIIVISION_VAL_SEARCH_GLITCH_POLARITY_NEGATIVE | Negative polarity.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE Attribute

AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE Attribute
Glitch See Also

The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Search Glitch Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE 1150211

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If all the channels are off, the current pulse width source is returned as "NONE".

Instrument Command

:SEARch:GLITch:SOURce {value}
:SEARch:GLITch:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


AgInfiniiVision_SetSearchGlitchRange Function

AgInfiniiVision_SetSearchGlitchRange Function
Glitch See Also

Sets the pulse width duration time (in seconds) for the selected source.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Glitch\Set Search Glitch Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetSearchGlitchRange(
    ViSession Vi,
    ViReal64 LowerLimit,
    ViReal64 UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimit

The lower limit for the pulse width duration time (in seconds) for the selected source

UpperLimit

The upper limit for the pulse width duration time (in seconds) for the selected source

Return Value

Success or failure code.

Remarks

The parameters can be entered in any order. The smaller value becomes LowerLimit and the larger value becomes UpperLimit.

Instrument Command

:SEARch:GLITch:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Glitch
AgInfiniiVision


Peak

Peak
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Peak

Attributes

 | Name | Description
Attribute | Excursion | The change in level that must occur (in other words, hysteresis) to be recognized as a peak.
Attribute | Number Of Peaks | The maximum number of FFT peaks to find.
Attribute | Source | The FFT math function waveform to search.
Attribute | Threshold | The threshold level necessary to be considered a peak.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION Attribute

AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION Attribute
Peak See Also

The change in level that must occur (in other words, hysteresis) to be recognized as a peak.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Peak\Excursion
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION 1150592

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 0.

    • Instrument Command

    :SEARch:PEAK:EXCursion {value}
    :SEARch:PEAK:EXCursion?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Peak
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS Attribute

AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS Attribute
Peak See Also

The maximum number of FFT peaks to find.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Peak\Number Of Peaks
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS 1150591

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input range is 1 to 10.
  • Preset value is 4.

    • Instrument Command

    :SEARch:PEAK:NPEaks {value}
    :SEARch:PEAK:NPEaks?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Peak
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE Attribute

AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE Attribute
Peak See Also

The FFT math function waveform to search.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Peak\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE 1150594

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input range is None or Function1 to Function4.

    • Instrument Command

    :SEARch:PEAK:SOURce {value}
    :SEARch:PEAK:SOURce?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Peak
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD Attribute

AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD Attribute
Peak See Also

The threshold level necessary to be considered a peak.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Peak\Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD 1150593

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Preset value is 0.

    • Instrument Command

    :SEARch:PEAK:THReshold {value}
    :SEARch:PEAK:THReshold?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Peak
    AgInfiniiVision


Runt

Runt
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt

Functions

 | Name | Description
Function | Configure Search Runt | Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.
Top

Attributes

 | Name | Description
Attribute | Search Runt Condition | Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.
Attribute | Search Runt Polarity | Sets/Gets the polarity for the runt search.
Attribute | Search Runt Qualifier Time | When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).
Attribute | Search Runt Source | The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureSearchRunt Function

AgInfiniiVision_ConfigureSearchRunt Function
Runt See Also

Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt\Configure Search Runt
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureSearchRunt(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Polarity,
    ViInt32 Condition,
    ViReal64 QualifierTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The channel on which to search for the runt pulse. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Polarity

Sets/Gets the polarity for the runt search.

Condition

Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.

QualifierTime

When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Polarity

Name | Description
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_POSITIVE | Positive polarity.
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_NEGATIVE | Negative polarity.
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_EITHER | Either positive or negative polarity.
Top

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_GREATER_THAN | To search for a runt greater than a time value.
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_LESS_THAN | To search for a runt less than a time value.
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_NONE | To search for a runt for any time value.
Top

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION Attribute
Runt See Also

Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt\Search Runt Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION 1150216

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchRuntConditionGreaterThan - to search for a runt that is greater than a time value
  • AgInfiniiVisionSearchRuntConditionLessThan - to search for a runt that is less than a time value
  • AgInfiniiVisionSearchRuntConditionNone - to search for a runt for any time value

Instrument Command

:SEARch:RUNT:QUALifier {GRE|LESS|NONE}
:SEARch:RUNT:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_GREATER_THAN | To search for a runt greater than a time value.
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_LESS_THAN | To search for a runt less than a time value.
AGINFINIIVISION_VAL_SEARCH_RUNT_CONDITION_NONE | To search for a runt for any time value.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY Attribute

AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY Attribute
Runt See Also

Sets/Gets the polarity for the runt search.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt\Search Runt Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY 1150217

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSearchRuntPolarityPositive - to specify positive polarity for the runt search
  • AgInfiniiVisionSearchRuntPolarityNegative - to specify negative polarity for the runt search
  • AgInfiniiVisionSearchRuntPolarityEither - to specify either negative or positive polarity for the runt search

Instrument Command

:SEARch:RUNT:POLarity {POS|NEG|EITH}
:SEARch:RUNT:POLarity?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_POSITIVE | Positive polarity.
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_NEGATIVE | Negative polarity.
AGINFINIIVISION_VAL_SEARCH_RUNT_POLARITY_EITHER | Either positive or negative polarity.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME Attribute

AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME Attribute
Runt See Also

When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt\Search Runt Qualifier Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME 1150218

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:RUNT:TIME {value}
:SEARch:RUNT:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE Attribute

AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE Attribute
Runt See Also

The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Runt\Search Runt Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE 1150219

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:RUNT:SOURce {value}
:SEARch:RUNT:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_COUNT Attribute

AGINFINIIVISION_ATTR_SEARCH_COUNT Attribute
Search See Also

Read Only - Gets the number of search events found.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Search Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_COUNT 1150206

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SEARch:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Search
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_MODE Attribute
Search See Also

The oscilloscope search mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Search Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_MODE 1150207

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchModeEdge - the Edge search mode
  • AgInfiniiVisionSearchModeGlitch - the Glitch search mode
  • AgInfiniiVisionSearchModeRunt - the Runt search mode
  • AgInfiniiVisionSearchModeTransition - the Transition search mode
  • AgInfiniiVisionSearchModeSerial1 - the Serial1 search mode
  • AgInfiniiVisionSearchModeSerial2 - the Serial2 search mode
  • AgInfiniiVisionSearchModeOff - disables the search mode

Instrument Command

:SEARch:MODE {EDGE|GLIT|RUNT|TRAN|SER1|SER2|OFF|PEAK}
:SEARch:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_MODE_EDGE | Edge mode.
AGINFINIIVISION_VAL_SEARCH_MODE_GLITCH | Glitch mode.
AGINFINIIVISION_VAL_SEARCH_MODE_RUNT | Runt mode.
AGINFINIIVISION_VAL_SEARCH_MODE_TRANSITION | Transition mode.
AGINFINIIVISION_VAL_SEARCH_MODE_SERIAL1 | Serial1 mode.
AGINFINIIVISION_VAL_SEARCH_MODE_SERIAL2 | Serial2 mode.
AGINFINIIVISION_VAL_SEARCH_MODE_OFF | Search is disabled.
AGINFINIIVISION_VAL_SEARCH_MODE_PEAK | Peak mode.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Search
AgInfiniiVision


Serial

Serial
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial

Branches

Name
ARINC429
CAN
FlexRay
I2S
IIC
LIN
M1553
SENT
SPI
UART
Top

See Also

Reference

AgInfiniiVision


ARINC429

ARINC429
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429

Attributes

 | Name | Description
Attribute | ARINC429 Label | Specifies the ARINC 429 label value when labels are used in the selected search mode.
Attribute | ARINC429 PatternSDI | Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.
Attribute | ARINC429 PatternSSM | Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.
Attribute | Search Serial ARINC429 Mode | Specifies the type of ARINC 429 information to find in the Lister display.
Attribute | Search Serial ARINC429 Pattern Data | Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ARINC429_LABEL Attribute

AGINFINIIVISION_ATTR_ARINC429_LABEL Attribute
ARINC429 See Also

Specifies the ARINC 429 label value when labels are used in the selected search mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429\ARINC429 Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARINC429_LABEL 1150416

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARINC429_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Label property is specified in of the following formats:

  • "n", where n: 8-bit integer in decimal format
  • "#Hnn", where n: { 0,..,9 | A,..,F }
  • "#Qnnn", where n: { 0,..,7 }
  • "0xnn", where n: { 0,..,9 | A,..,F }
  • The return value for this property is in decimal format.

    • Instrument Command

    :SEARch:SERial:A429:LABel {value}
    :SEARch:SERial:A429:LABel?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    ARINC429
    AgInfiniiVision


AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI Attribute

AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI Attribute
ARINC429 See Also

Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429\ARINC429 PatternSDI
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI 1150417

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The specified SDI is only used if the IAgInfiniiVisionSerialBusARINC429.DisplayFormat property includes the SDI field. The PatternSDI property is specified in the following format:

  • "nn", where n: {0 | 1}

Instrument Command

:SEARch:SERial:A429:PATTern:SDI "{value}"
:SEARch:SERial:A429:PATTern:SDI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM Attribute

AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM Attribute
ARINC429 See Also

Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429\ARINC429 PatternSSM
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM 1150418

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The specified SSM is only used if the IAgInfiniiVisionSerialBusARINC429.DisplayFormat property includes the SSM field. The PatternSSM property is specified in the following format:

  • "nn", where n: {0 | 1}

Instrument Command

:SEARch:SERial:A429:PATTern:SSM "{value}"
:SEARch:SERial:A429:PATTern:SSM?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE Attribute
ARINC429 See Also

Specifies the type of ARINC 429 information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429\Search Serial ARINC429 Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE 1150402

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialARINC429ModeLabel - Specifies the Label search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeLabelBits - Specifies the Label + Bits search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeParityError - Specifies the Parity Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeWordError - Specifies the Word Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeGapError - Specifies the Gap Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeWordOrGapError - Specifies the Word or Gap Error search mode.
  • AgInfiniiVisionSearchSerialARINC429ModeAllErrors - Specifies All Errors search mode.

Instrument Command

:SEARch:SERIAL:A429:MODE {LAB|LBIT|PERR|WERR|GERR|WGER|ALL}
:SEARch:SERIAL:A429:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_LABEL | Specifies the Label search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_LABEL_BITS | Specifies the Label + Bits search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_PARITY_ERROR | Specifies the Parity Error search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_WORD_ERROR | Specifies the Word Error search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_GAP_ERROR | Specifies the Gap Error search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_WORD_OR_GAP_ERROR | Specifies the Word or Gap Error search mode.
AGINFINIIVISION_VAL_SEARCH_SERIALARINC429_MODE_ALL_ERRORS | Specifies All Errors search mode.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA Attribute
ARINC429 See Also

Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\ARINC429\Search Serial ARINC429 Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA 1150401

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property is specified in the following format:

  • "nn...n", where n: {0 | 1}

The pattern string will be truncated on the left-hand-side if the length exceeds the pattern length of the particular ARINC format.

Pattern length for the different formats:
  • LDSDi
    • Label - 8 bits.
    • SDI - 2 bits.
    • Data - 19 bits.
    • SSM - 2 bits.
    • Label - 8 bits.
    • Data - 21 bits.
    • SSM - 2 bits.
    • Label - 8 bits.
    • Data - 23 bits.

Instrument Command

:SEARch:SERial:A429:PATTern:DATA "{value}"
:SEARch:SERial:A429:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


CAN

CAN
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN

Attributes

 | Name | Description
Attribute | Search Serial CAN Mode | Specifies the type of CAN information to find in the Lister display.
Attribute | Search Serial CAN Pattern Data | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | Search Serial CAN Pattern Data Length | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.
Attribute | Search Serial CAN PatternID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | Search Serial CAN PatternID Type | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.
Attribute | Symbolic Message | Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.
Attribute | Symbolic Signal | Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Attribute | Symbolic Value | Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE Attribute
CAN See Also

Specifies the type of CAN information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Search Serial CAN Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE 1150228

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchCANTypeData - searches for CAN Data frames matching the specified ID, Data, and the DLC (Data length code)
  • AgInfiniiVisionSearchCANTypeIDData - searches for CAN frames matching the specified ID of a Data frame
  • AgInfiniiVisionSearchCANTypeIDEither - searches for the specified ID, regardless if it is a Remote frame or a Data frame
  • AgInfiniiVisionSearchCANTypeIDRemote - searches for CAN frames matching the specified ID of a Remote frame
  • AgInfiniiVisionSearchCANTypeAllErrors - searches for CAN active error frames and unknown bus conditions
  • AgInfiniiVisionSearchCANTypeOverload - searches for CAN overload frames
  • AgInfiniiVisionSearchCANTypeError - searches for CAN Error frame

Instrument Command

:SEARch:SERial:CAN:MODE {DATA|IDD|IDE|IDR|ALL|OVER|ERR|ACK|FORM|STUF|CRC|MSIG|MESSage}
:SEARch:SERial:CAN:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHCAN_MODE_DATA | Search for CAN Data frames matching the specified ID, Data, and the DLC (Data length code).
AGINFINIIVISION_VAL_SEARCHCAN_MODEID_DATA | Search for CAN frames matching the specified ID of a Data frame.
AGINFINIIVISION_VAL_SEARCHCAN_MODEID_EITHER | Search for the specified ID, regardless if it is a Remote frame or a Data frame.
AGINFINIIVISION_VAL_SEARCHCAN_MODEID_REMOTE | Search for CAN frames matching the specified ID of a Remote frame.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_ALL_ERRORS | Search for CAN active error frames and unknown bus conditions.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_OVERLOAD | Search for CAN overload frames.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_ERROR | Search for CAN Error frame.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_ACK_ERROR | The acknowledge bit if the polarity is incorrect.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_FORM_ERROR | The reserved bit errors.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_STUFF_ERROR | Find 6 consecutive 1s or 6 consecutive 0s, while in a non-error or non overload frame.
AGINFINIIVISION_VAL_SEARCHCAN_MODECRC_ERROR | Finds when the calculated CRC does not match the transmitted CRC.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_MSG_SIG | Finds a symbolic message and a signal value.
AGINFINIIVISION_VAL_SEARCHCAN_MODE_MSG | Finds a symbolic message.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA Attribute
CAN See Also

Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Search Serial CAN Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA 1150224

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The length of the data value is specified using the PatternDataLength property.

Instrument Command

:SEARch:SERial:CAN:PATTern:DATA "{value}"
:SEARch:SERial:CAN:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH Attribute
CAN See Also

Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Search Serial CAN Pattern Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH 1150225

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The data value is specified using the PatternData property.

Instrument Command

:SEARch:SERial:CAN:PATTern:DATA:LENGth {value}
:SEARch:SERial:CAN:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID Attribute
CAN See Also

Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Search Serial CAN PatternID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID 1150226

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ID value can be a standard ID or an extended ID, depending on the value of the PatternIDType property.

Instrument Command

:SEARch:SERial:CAN:PATTern:ID "{value}"
:SEARch:SERial:CAN:PATTern:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE Attribute
CAN See Also

Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Search Serial CAN PatternID Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE 1150227

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternIDType property can be set to one of the following values:

  • AgInfiniiVisionSearchCANPatternIDTypeStandard - specifies that a standard ID value is used for searching
  • AgInfiniiVisionSearchCANPatternIDTypeExtended - specifies that an extended ID value is used for searching
  • The ID value is specified using the PatternID property.

    • Instrument Command

    :SEARch:SERial:CAN:PATTern:ID:MODE {STAN|EXT}
    :SEARch:SERial:CAN:PATTern:ID:MODE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_SEARCHCAN_PATTERNID_TYPE_STANDARD | Uses a standard ID value when searching for a CAN event.
AGINFINIIVISION_VAL_SEARCHCAN_PATTERNID_TYPE_EXTENDED | Uses an extended ID value when searching for a CAN event.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    CAN
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE Attribute
CAN See Also

Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Symbolic Message
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE 1150662

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:CAN:SYMBolic:MESSage {value}
:SEARch:SERial:CAN:SYMBolic:MESSage?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL Attribute
CAN See Also

Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Symbolic Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL 1150663

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:CAN:SYMBolic:SIGNal {value}
:SEARch:SERial:CAN:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE Attribute
CAN See Also

Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\CAN\Symbolic Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE 1150664

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:CAN:SYMBolic:VALue {value}
:SEARch:SERial:CAN:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


FlexRay

FlexRay
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay

Attributes

 | Name | Description
Attribute | Search Serial FlexRay Cycle Number | Specifies the cycle value to find when searching for FlexRay frames.
Attribute | Search Serial FlexRay FrameID | Specifies the frame ID value to find when searching for FlexRay frames.
Attribute | Search Serial FlexRay Mode | Specifies the type of FlexRay information to find in the Lister display.
Attribute | Search Serial FlexRay Pattern Data | Specifies the data value to find when searching for FlexRay frames.
Attribute | Search Serial FlexRay Pattern Data Length | Specifies the length of data values when searching for FlexRay frames.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER Attribute
FlexRay See Also

Specifies the cycle value to find when searching for FlexRay frames.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay\Search Serial FlexRay Cycle Number
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER 1150406

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The CycleNumber property can be specified in one of the following formats:

  • "ALL"
  • "n", where n: an integer from 0-63

Instrument Command

:SEARch:SERial:FLEXray:CYCLe {value}
:SEARch:SERial:FLEXray:CYCLe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID Attribute
FlexRay See Also

Specifies the frame ID value to find when searching for FlexRay frames.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay\Search Serial FlexRay FrameID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID 1150409

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The FrameID property can be specified in one of the following formats:

  • "ALL"
  • "n", where n is an integer from 1-2047

Instrument Command

:SEARch:SERial:FLEXray:FRAMe {value}
:SEARch:SERial:FLEXray:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE Attribute
FlexRay See Also

Specifies the type of FlexRay information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay\Search Serial FlexRay Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE 1150410

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialFlexRayModeFrameID - Finds frames with the specified ID.
  • AgInfiniiVisionSearchSerialFlexRayModeCycleNumber - Finds frames with the specified cycle number and ID.
  • AgInfiniiVisionSearchSerialFlexRayModeData - Finds frames with the specified data, cycle number and frame ID.
  • AgInfiniiVisionSearchSerialFlexRayModeHeaderCRC - Finds cyclic redundancy check errors in headers.
  • AgInfiniiVisionSearchSerialFlexRayModeFrameCRC - Finds cyclic redundancy check errors in frames.
  • AgInfiniiVisionSearchSerialFlexRayModeAllErrors - Finds all errors.

Instrument Command

:SEARch:SERial:FLEXray:MODE {FRAM|CYCL|DATA|HERR|FERR|AERR}
:SEARch:SERial:FLEXray:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_FRAMEID | Finds frames with the specified ID.
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_CYCLE_NUMBER | Finds frames with the specified cycle number and ID.
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_DATA | Finds frames with the specified data, cycle number and frame ID.
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_HEADERCRC | Finds cyclic redundancy check errors in headers.
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_FRAMECRC | Finds cyclic redundancy check errors in frames.
AGINFINIIVISION_VAL_SEARCH_SERIAL_FLEX_RAY_MODE_ALL_ERRORS | Finds all errors.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA Attribute
FlexRay See Also

Specifies the data value to find when searching for FlexRay frames.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay\Search Serial FlexRay Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA 1150407

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in the following format:

  • "nn..n", where n: {0 | 1 | X}

Instrument Command

:SEARch:SERial:FLEXray:DATA "{value}"
:SEARch:SERial:FLEXray:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH Attribute
FlexRay See Also

Specifies the length of data values when searching for FlexRay frames.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\FlexRay\Search Serial FlexRay Pattern Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH 1150408

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:FLEXray:DATA:LENGth {value}
:SEARch:SERial:FLEXray:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


I2S

I2S
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S

Functions

 | Name | Description
Function | Get Search SerialI2S Range | Gets the data value range when searching for I2S events.
Function | Set Search SerialI2S Range | Sets the data value range when searching for I2S events.
Top

Attributes

 | Name | Description
Attribute | Search Serial I2S Audio Channel | Specifies the channel on which to search for I2S events: right, left, or either channel.
Attribute | Search Serial I2S Mode | Specifies the type of I2S information to find in the Lister display.
Attribute | Search Serial I2S Pattern Data | Specifies the data word value when searching for I2S events.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetSearchSerialI2SRange Function

AgInfiniiVision_GetSearchSerialI2SRange Function
I2S See Also

Gets the data value range when searching for I2S events.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S\Get Search SerialI2S Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetSearchSerialI2SRange(
    ViSession Vi,
    ViInt32* LowerLimit,
    ViInt32* UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimit

The lower limit for the data value range when searching for I2S events.

UpperLimit

The upper limit for the data value range when searching for I2S events.

Return Value

Success or failure code.

Instrument Command

:SEARch:SERial:I2S:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL Attribute
I2S See Also

Specifies the channel on which to search for I2S events: right, left, or either channel.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S\Search Serial I2S Audio Channel
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL 1150229

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The AudioChannel property can be set to one of the following values:

  • AgInfiniiVisionSearchI2SAudioChannelRight - for the right audio channel
  • AgInfiniiVisionSearchI2SAudioChannelLeft - for the left audio channel
  • AgInfiniiVisionSearchI2SAudioChannelEither - for either left or right audio channel

Instrument Command

:SEARch:SERial:I2S:AUDio {LEFT|RIGH|EITH}
:SEARch:SERial:I2S:AUDio?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHI2S_AUDIO_CHANNEL_LEFT | The left audio channel.
AGINFINIIVISION_VAL_SEARCHI2S_AUDIO_CHANNEL_RIGHT | The right audio channel.
AGINFINIIVISION_VAL_SEARCHI2S_AUDIO_CHANNEL_EITHER | Either left or right audio channel.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE Attribute
I2S See Also

Specifies the type of I2S information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S\Search Serial I2S Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE 1150230

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchI2STypeEqual - searches for the specified audio channel's data word when it equals the specified word
  • AgInfiniiVisionSearchI2STypeNotEqual - searches for any word other than the specified word
  • AgInfiniiVisionSearchI2STypeLessThan - searches for channel data words less than the specified value
  • AgInfiniiVisionSearchI2STypeGreaterThan - searches for channel data words greater than the specified value
  • AgInfiniiVisionSearchI2STypeInRange - searches for channel data words in the range
  • AgInfiniiVisionSearchI2STypeOutRange - searches for channel data words outside the range

Data word values are specified using the PatternData property.
Values ranges are specified using the SetRange() and GetRange() methods.

Instrument Command

:SEARch:SERial:I2S:MODE {EQU|NOT|LESS|GRE|INR|OUTR}
:SEARch:SERial:I2S:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHI2S_MODE_EQUAL | Search for the specified audio channel's data word when it equals the specified word.
AGINFINIIVISION_VAL_SEARCHI2S_MODE_NOT_EQUAL | Searches for any word other than the specified word.
AGINFINIIVISION_VAL_SEARCHI2S_MODE_LESS_THAN | Search for channel data words less than the specified value.
AGINFINIIVISION_VAL_SEARCHI2S_MODE_GREATER_THAN | Search for channel data words greater than the specified value.
AGINFINIIVISION_VAL_SEARCHI2S_MODE_IN_RANGE | Search for channel data words in the range.
AGINFINIIVISION_VAL_SEARCHI2S_MODE_OUT_RANGE | Searches for channel data words outside the range.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA Attribute
I2S See Also

Specifies the data word value when searching for I2S events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S\Search Serial I2S Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA 1150231

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The data word value is a string, which can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 | X}
  • "0xnn...n" where n: {0,..,9 | A,..,F | X}

Instrument Command

:SEARch:SERial:I2S:PATTern:DATA "{value}"
:SEARch:SERial:I2S:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AgInfiniiVision_SetSearchSerialI2SRange Function

AgInfiniiVision_SetSearchSerialI2SRange Function
I2S See Also

Sets the data value range when searching for I2S events.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\I2S\Set Search SerialI2S Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetSearchSerialI2SRange(
    ViSession Vi,
    ViInt32 LowerLimitBufferSize,
    ViConstString LowerLimit,
    ViInt32 UpperLimitBufferSize,
    ViConstString UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimitBufferSize

Number of elements in LowerLimit.

LowerLimit

The lower limit for the data value range when searching for I2S events.

UpperLimitBufferSize

Number of elements in UpperLimit.

UpperLimit

The upper limit for the data value range when searching for I2S events.

Return Value

Success or failure code.

Remarks

The LowerLimit and UpperLimit parameters of the data value range can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

This method is only used when Mode is set to AgInfiniiVisionSearchI2STypeInRange or AgInfiniiVisionSearchI2STypeOutRange.
You may enter the parameters in any order. The smaller value becomes LowerLimit and the larger value becomes UpperLimit.

Instrument Command

:SEARch:SERial:I2S:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


IIC

IIC
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC

Attributes

 | Name | Description
Attribute | Search Serial IIC Address | Specifies the address values when searching for IIC events.
Attribute | Search Serial IIC Condition | Specifies the data value qualifier used when searching for IIC EEPROM data read events.
Attribute | Search Serial IIC Mode | Selects the type of IIC information to find in the Lister display.
Attribute | Search Serial IIC Pattern Data | Specifies the data values when searching for IIC events.
Attribute | Search Serial IIC Pattern Data2 | Specifies the second data value when searching for IIC events with two data values.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS Attribute
IIC See Also

Specifies the address values when searching for IIC events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC\Search Serial IIC Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS 1150233

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Address property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

The returned value is always in an integer string format

Instrument Command

:SEARch:SERial:IIC:PATTern:ADDRess "{value}"
:SEARch:SERial:IIC:PATTern:ADDRess?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION Attribute
IIC See Also

Specifies the data value qualifier used when searching for IIC EEPROM data read events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC\Search Serial IIC Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION 1150236

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchIICConditionEqual
  • AgInfiniiVisionSearchIICConditionNotEqual
  • AgInfiniiVisionSearchIICConditionLessThan
  • AgInfiniiVisionSearchIICConditionGreaterThan

Instrument Command

:SEARch:SERial:IIC:QUALifier {EQU|NOT|LESS|GRE}
:SEARch:SERial:IIC:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHIIC_CONDITION_EQUAL | To search for a value equal to the specified value.
AGINFINIIVISION_VAL_SEARCHIIC_CONDITION_NOT_EQUAL | To search for a value not equal to the specified value.
AGINFINIIVISION_VAL_SEARCHIIC_CONDITION_LESS_THAN | To search for a value less than the specified value.
AGINFINIIVISION_VAL_SEARCHIIC_CONDITION_GREATER_THAN | To search for a value greater than the specified value.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE Attribute
IIC See Also

Selects the type of IIC information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC\Search Serial IIC Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE 1150232

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchIICTypeRead7 - searches for 7-bit address frames containing Start:Address7:Read:Ack:Data
  • AgInfiniiVisionSearchIICTypeWrite7 - searches for 7-bit address frames containing Start:Address7:Write:Ack:Data
  • AgInfiniiVisionSearchIICTypeMissingAcknowledge - searches for missing acknowledge events
  • AgInfiniiVisionSearchIICTypeNoAcknowledge - searches for address with no acknowledge events
  • AgInfiniiVisionSearchIICTypeR7Data2 - searches for 7-bit address frames containing Start:Address7:Read:Ack:Data:Ack:Data2
  • AgInfiniiVisionSearchIICTypeW7Data2 - searches for 7-bit address frames containing Start:Address7:Write:Ack:Data:Ack:Data2
  • AgInfiniiVisionSearchIICTypeRestart - searches for another start condition occurring before a stop condition
  • AgInfiniiVisionSearchIICTypeReadEprom - searches for EEPROM data reads

When searching for events containing addresses, address values are specified using the Address property.
When searching for events containing data, data values are specified using the PatternData and PatternData2 properties.

Instrument Command

:SEARch:SERial:IIC:MODE {READ7|WRIT7|NACK|ANAC|R7D2|W7D2|REST|READE|ADDR}
:SEARch:SERial:IIC:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_READ7 | Searches for 7-bit address frames containing Start:Address7:Read:Ack:Data.
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_WRITE7 | Searches for 7-bit address frames containing Start:Address7:Write:Ack:Data
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_MISSING_ACKNOWLEDGE | Searches for missing acknowledge events
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_NO_ACKNOWLEDGE | Searches for address with no acknowledge events
AGINFINIIVISION_VAL_SEARCHIIC_TYPER7_DATA2 | Searches for 7-bit address frames containing Start:Address7:Read:Ack:Data:Ack:Data2
AGINFINIIVISION_VAL_SEARCHIIC_TYPEW7_DATA2 | Searches for 7-bit address frames containing Start:Address7:Write:Ack:Data:Ack:Data2
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_RESTART | Searches for another start condition occurring before a stop condition.
AGINFINIIVISION_VAL_SEARCHIIC_TYPE_READ_EPROM | Searches for EEPROM data reads
AGINFINIIVISION_VAL_SEARCHIIC_MODE_ADDRESS | Searches for a packet with the specified address.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA Attribute
IIC See Also

Specifies the data values when searching for IIC events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC\Search Serial IIC Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA 1150234

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

When searching for IIC EEPROM data read events, you specify the data value qualifier using the Condition property.

Instrument Command

:SEARch:SERial:IIC:PATTern:DATA "{value}"
:SEARch:SERial:IIC:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2 Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2 Attribute
IIC See Also

Specifies the second data value when searching for IIC events with two data values.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\IIC\Search Serial IIC Pattern Data2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2 1150235

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData2 property can be specified in one of the following string formats:

  • "n" where n is an integer
  • "0xnn" where n: {0,..,9 | A,..,F}

Instrument Command

:SEARch:SERial:IIC:PATTern:DATA2 "{value}"
:SEARch:SERial:IIC:PATTern:DATA2?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

IIC
AgInfiniiVision


LIN

LIN
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN

Attributes

 | Name | Description
Attribute | Search Serial LIN ID | Specifies the frame ID value when searching for LIN events
Attribute | Search Serial LIN Mode | Selects the type of LIN information to find in the Lister display
Attribute | Search Serial LIN Pattern Data | Specifies the data value when searching for LIN events.
Attribute | Search Serial LIN Pattern Data Length | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.
Attribute | Symbolic Frame | Sets and Gets the specific message when LIN serial search mode is set to Frame.
Attribute | Symbolic Signal | Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.
Attribute | Symbolic Value | Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID Attribute
LIN See Also

Specifies the frame ID value when searching for LIN events

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Search Serial LIN ID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID 1150237

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ID property can be specified in one of the following string formats:

  • "n" where n: 7-bit integer in signed decimal
  • "#Hnn" where n: {0,..,9 | A,..,F}
  • "#Bnn" where n: {0 | 1 }
  • "0xnn" where n: {0,..,9 | A,..,F}

Valid range of values are: 0 to 63 or 0x00 to 0x3f

Instrument Command

:SEARch:SERial:LIN:ID {value}
:SEARch:SERial:LIN:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE Attribute
LIN See Also

Selects the type of LIN information to find in the Lister display

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Search Serial LIN Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE 1150238

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchLINModeID - searches for a frame ID
  • AgInfiniiVisionSearchLINModeData - searches for a frame ID and data
  • AgInfiniiVisionSearchLINModeError - searches for errors
  • AgInfiniiVisionSearchLINModeFrame - searches for symbolic frames
  • AgInfiniiVisionSearchLINModeFrameSig - searches for symbolic frames and signal values

Frame IDs are specified using the ID property.
Data values are specified using the PatternData property.

Instrument Command

:SEARch:SERial:LIN:MODE {ID|DATA|ERR|FRAM|FSIG}
:SEARch:SERial:LIN:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHLIN_MODEID | Searches for a frame ID.
AGINFINIIVISION_VAL_SEARCHLIN_MODE_DATA | Searches for a frame ID and data.
AGINFINIIVISION_VAL_SEARCHLIN_MODE_ERROR | Searches for errors.
AGINFINIIVISION_VAL_SEARCHLIN_MODE_FRAME | Searches for symbolic frames.
AGINFINIIVISION_VAL_SEARCHLIN_MODE_FRAME_SIG | Searches for symbolic frames and a signal values.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA Attribute
LIN See Also

Specifies the data value when searching for LIN events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Search Serial LIN Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA 1150239

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n" where n: 32-bit integer in signed decimal
  • "0xnn...n" where n: {0,..,9 | A,..,F | X}

The length of the data value entered is specified using the PatternDataLength property.

Instrument Command

:SEARch:SERial:LIN:PATTern:DATA "{value}"
:SEARch:SERial:LIN:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH Attribute
LIN See Also

Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Search Serial LIN Pattern Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH 1150240

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The data value is specified using the PatternData property

Instrument Command

:SEARch:SERial:LIN:PATTern:DATA:LENGth {value}
:SEARch:SERial:LIN:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME Attribute
LIN See Also

Sets and Gets the specific message when LIN serial search mode is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Symbolic Frame
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME 1150651

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:LIN:SYMBolic:FRAMe {value}
:SEARch:SERial:LIN:SYMBolic:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL Attribute
LIN See Also

Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Symbolic Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL 1150652

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:LIN:SYMBolic:SIGNal {value}
:SEARch:SERial:LIN:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE Attribute
LIN See Also

Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\LIN\Symbolic Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE 1150653

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:SERial:LIN:SYMBolic:VALue {value}
:SEARch:SERial:LIN:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


M1553

M1553
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\M1553

Attributes

 | Name | Description
Attribute | Search Serial M1553 Mode | Specifies the type of MIL-STD-1553 information to find in the Lister display.
Attribute | Search Serial M1553 Pattern Data | Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.
Attribute | Search Serial M1553 RTA | Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE Attribute
M1553 See Also

Specifies the type of MIL-STD-1553 information to find in the Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\M1553\Search Serial M1553 Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE 1150403

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSerialM1553ModeDataStart - Finds the start of a data word (at the end of a valid Data Sync pulse).
  • AgInfiniiVisionSearchSerialM1553ModeCommandStart - Finds the start of a Command/Status word (at the end of a valid C/S Sync pulse).
  • AgInfiniiVisionSearchSerialM1553ModeRTA - Finds the Command/Status Word whose RTA matches the specified value. The value is specified in hex.
  • AgInfiniiVisionSearchSerialM1553ModeRTA11 - Finds the RTA and the remaining 11 bits that match the specified criteria. The RTA can be specified as a hex value and the remaining bits are specified as 1 or 0.
  • AgInfiniiVisionSearchSerialM1553ModeParityError - Finds (odd) parity bits that are incorrect for the data in the word.
  • AgInfiniiVisionSearchSerialM1553ModeSyncError - Finds invalid sync pulses.
  • AgInfiniiVisionSearchSerialM1553ModeManchesterError - Finds Manchester encoding errors.

Instrument Command

:SEARch:SERial:M1553:MODE {DSTA|CSTA|RTA|RTA11|PERR|SERR|MERR}
:SEARch:SERial:M1553:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODE_DATA_START | Finds the start of a data word (at the end of a valid Data Sync pulse).
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODE_COMMAND_START | Finds the start of a Command/Status word (at the end of a valid C/S Sync pulse).
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODERTA | Finds the Command/Status Word whose RTA matches the specified value. The value is specified in hex.
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODERTA11 | Finds the RTA and the remaining 11 bits that match the specified criteria. The RTA can be specified as a hex value and the remaining bits are specified as 1 or 0.
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODE_PARITY_ERROR | Finds (odd) parity bits that are incorrect for the data in the word.
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODE_SYNC_ERROR | Finds invalid sync pulses.
AGINFINIIVISION_VAL_SEARCH_SERIALM1553_MODE_MANCHESTER_ERROR | Finds Manchester encoding errors.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA Attribute
M1553 See Also

Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\M1553\Search Serial M1553 Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA 1150404

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in one of the following formats:

  • "nn...n", where n: {0 | 1 | X}

Instrument Command

:SEARch:SERial:M1553:PATTern:DATA "{value}"
:SEARch:SERial:M1553:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA Attribute
M1553 See Also

Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\M1553\Search Serial M1553 RTA
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA 1150405

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The RTA property can be specified in one of the following formats:

  • "n", where n is an integer from 0-31
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SEARch:SERial:M1553:RTA {value}
:SEARch:SERial:M1553:RTA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


SENT

SENT
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT

Branches

Name
Fast
Slow
Top

Attributes

 | Name | Description
Attribute | Mode | Sets and gets the search mode settings.
Top

See Also

Reference

AgInfiniiVision


Fast

Fast
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Fast

Attributes

 | Name | Description
Attribute | Data | Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_DATA3 Attribute

AGINFINIIVISION_ATTR_DATA3 Attribute
Fast See Also

Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Fast\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DATA3 1150628

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DATA3.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The input format of string is

  • <Input String> :: = "nnnn..." where n :: = { 0 | 1 | X }

    • or

  • <Input String> :: = "0xn..." where n :: = { 0,..,9 | A,..,F | X |$}

    • Instrument Command

    :SEARch:SERial:SENT:FAST:DATA "{value}"
    :SEARch:SERial:SENT:FAST:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Fast
    AgInfiniiVision


AGINFINIIVISION_ATTR_MODE Attribute

AGINFINIIVISION_ATTR_MODE Attribute
SENT See Also

Sets and gets the search mode settings.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MODE 1150631

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • AgInfiniiVisionSearchSentFCData - finds Fast Channel data nibbles that match the values entered using additional softkeys.
  • AgInfiniiVisionSearchSentSCMid - finds Slow Channel Message IDs that match the value entered using additional softkeys.
  • AgInfiniiVisionSearchSentSCData - finds Slow Channel Message IDs and Data that match the values entered using additional softkeys.
  • AgInfiniiVisionSearchSentCRCerror - finds any CRC error, Fast or Slow.
  • AgInfiniiVisionSearchSentPPERror - finds where a nibble is either too wide or too narrow (for example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, or checksum pulse periods are checked.

    • Instrument Command

    :SEARch:SERial:SENT:MODE {FCD|SCM|SCD|CRC|PPER}
    :SEARch:SERial:SENT:MODE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_SEARCH_SENTFC_DATA | FCData - finds Fast Channel data nibbles that match the values entered using additional softkeys.
AGINFINIIVISION_VAL_SEARCH_SENTSC_MSGID | SCMid - finds Slow Channel Message IDs that match the value entered using additional softkeys.
AGINFINIIVISION_VAL_SEARCH_SENTSC_DATA | SCData - finds Slow Channel Message IDs and Data that match the values entered using additional softkeys.
AGINFINIIVISION_VAL_SEARCH_SENTCRC_ERROR | CRCerror - finds any CRC error, Fast or Slow.
AGINFINIIVISION_VAL_SEARCH_SENTPP_ERROR | PPERror - finds where a nibble is either too wide or too narrow.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    SENT
    AgInfiniiVision


Slow

Slow
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Slow

Attributes

 | Name | Description
Attribute | Data | Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.
Attribute | ID | Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_DATA4 Attribute

AGINFINIIVISION_ATTR_DATA4 Attribute
Slow See Also

Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Slow\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_DATA4 1150629

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_DATA4.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The format of Data is look like

  • <Input String Data> :: =From -1 (don't care) to 65535, in NR1 format.

    • Instrument Command

    :SEARch:SERial:SENT:SLOW:DATA {value}
    :SEARch:SERial:SENT:SLOW:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Slow
    AgInfiniiVision


AGINFINIIVISION_ATTR_ID2 Attribute

AGINFINIIVISION_ATTR_ID2 Attribute
Slow See Also

Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SENT\Slow\ID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ID2 1150630

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ID2.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • <Input String Data> :: =From -1 (don't care) to 255, in NR1 format (depending on the message length).

    • Instrument Command

    :SEARch:SERial:SENT:SLOW:ID {value}
    :SEARch:SERial:SENT:SLOW:ID?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Slow
    AgInfiniiVision


SPI

SPI
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SPI

Attributes

 | Name | Description
Attribute | Search Serial SPI Mode | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Attribute | Search Serial SPI Pattern Data | Specifies the data value when searching for SPI events.
Attribute | Search Serial SPI Pattern Width | Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE Attribute
SPI See Also

Specifies whether the SPI search will be on the MOSI data or the MISO data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SPI\Search Serial SPI Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE 1150241

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSearchSPITypeMOSI - to specify that the search will be on MOSI data
  • AgInfiniiVisionSearchSPITypeMISO - to specify that the search will be on MISO data

Data values are specified using the PatternData property.

Instrument Command

:SEARch:SERial:SPI:MODE {MOSI|MISO}
:SEARch:SERial:SPI:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHSPI_MODEMOSI | Searches on MOSI data.
AGINFINIIVISION_VAL_SEARCHSPI_MODEMISO | Searches on MISO data.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA Attribute
SPI See Also

Specifies the data value when searching for SPI events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SPI\Search Serial SPI Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA 1150242

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in the following string format:

  • "0xnnnnnn", where n: {0,..,9 | A,..,F | X}

The width of the data value is specified using the PatternWidth property.

Instrument Command

:SEARch:SERial:SPI:PATTern:DATA "{value}"
:SEARch:SERial:SPI:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH Attribute
SPI See Also

Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\SPI\Search Serial SPI Pattern Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH 1150243

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The data value is specified using the PatternData property.

Instrument Command

:SEARch:SERial:SPI:PATTern:WIDTh {value}
:SEARch:SERial:SPI:PATTern:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


UART

UART
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\UART

Attributes

 | Name | Description
Attribute | Search Serial UART Condition | Specifies the data value qualifier when searching for UART/RS232 events.
Attribute | Search Serial UART Mode | Selects the type of UART/RS232 information to find in the Lister display
Attribute | Search Serial UART Pattern Data | Specifies a data value when searching for UART/RS232 events.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION Attribute
UART See Also

Specifies the data value qualifier when searching for UART/RS232 events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\UART\Search Serial UART Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION 1150246

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchUARTConditionEqual - Equal
  • AgInfiniiVisionSearchUARTConditionNotEqual - Not Equal
  • AgInfiniiVisionSearchUARTConditionGreaterThan - Greater Than
  • AgInfiniiVisionSearchUARTConditionLessThan - Less Than

Instrument Command

:SEARch:SERial:UART:QUALifier {EQU|NOT|GRE|LESS}
:SEARch:SERial:UART:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHUART_CONDITION_EQUAL | Searches for a value equal to the specified value.
AGINFINIIVISION_VAL_SEARCHUART_CONDITION_NOT_EQUAL | Searches for a value not equal to the specified value.
AGINFINIIVISION_VAL_SEARCHUART_CONDITION_GREATER_THAN | Searches for a value greater than the specified value.
AGINFINIIVISION_VAL_SEARCHUART_CONDITION_LESS_THAN | Searches for a value less than the specified value.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE Attribute
UART See Also

Selects the type of UART/RS232 information to find in the Lister display

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\UART\Search Serial UART Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE 1150244

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Type property can be set to one of the following values:

  • AgInfiniiVisionSearchUARTTypeRData - searches for a receive data value when data words are from 5 to 8 bits long
  • AgInfiniiVisionSearchUARTTypeRD1 - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 1
  • AgInfiniiVisionSearchUARTTypeRD0 - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 0
  • AgInfiniiVisionSearchUARTTypeRDX - searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X)
  • AgInfiniiVisionSearchUARTTypeTData - searches for a transmit data value when data words are from 5 to 8 bits long
  • AgInfiniiVisionSearchUARTTypeTD1 - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 1
  • AgInfiniiVisionSearchUARTTypeTD0 - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 0
  • AgInfiniiVisionSearchUARTTypeTDX - searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X)
  • AgInfiniiVisionSearchUARTTypeParityError - searches for parity errors
  • AgInfiniiVisionSearchUARTTypeAnyError - searches for any error

Data values are specified using the PatternData property.
Data value qualifiers are specified using the Condition property.

Instrument Command

:SEARch:SERial:UART:MODE {RDAT|RD1|RD0|RDX|TDAT|TD1|TD0|TDX|PAR|AERR}
:SEARch:SERial:UART:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHUART_MODER_DATA | Searches for a receive data value when data words are from 5 to 8 bits long.
AGINFINIIVISION_VAL_SEARCHUART_MODERD1 | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 1
AGINFINIIVISION_VAL_SEARCHUART_MODERD0 | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is 0
AGINFINIIVISION_VAL_SEARCHUART_MODERDX | Searches for a receive data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X).
AGINFINIIVISION_VAL_SEARCHUART_MODET_DATA | Searches for a transmit data value when data words are from 5 to 8 bits long.
AGINFINIIVISION_VAL_SEARCHUART_MODETD1 | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 1.
AGINFINIIVISION_VAL_SEARCHUART_MODETD0 | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is 0.
AGINFINIIVISION_VAL_SEARCHUART_MODETDX | Searches for a transmit data value when data words are 9 bits long and the 9th (alert) bit is a don't care (X).
AGINFINIIVISION_VAL_SEARCHUART_MODE_PARITY_ERROR | Searches for parity errors.
AGINFINIIVISION_VAL_SEARCHUART_MODE_ANY_ERROR | Searches for any error.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA Attribute
UART See Also

Specifies a data value when searching for UART/RS232 events.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Serial\UART\Search Serial UART Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA 1150245

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The PatternData property can be specified in one of the following string formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F} from 0x00-0xff
  • "#Bnn...n", where n: {0 | 1}
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00-0xff
  • Any of the 128 valid 7-bit ASCII characters (or standard abbreviations)

The data value qualifier is specified using the Condition property.

Instrument Command

:SEARch:SERial:UART:DATA {value}
:SEARch:SERial:UART:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UART
AgInfiniiVision


Transition

Transition
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition

Functions

 | Name | Description
Function | Configure Search Transition | Configures the Source, Slope, Condition and QualifierTime properties for a transition search.
Top

Attributes

 | Name | Description
Attribute | Search Transition Condition | Specifies whether to search for edge transitions greater than or less than a time.
Attribute | Search Transition Qualifier Time | The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.
Attribute | Search Transition Slope | Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.
Attribute | Search Transition Source | The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureSearchTransition Function

AgInfiniiVision_ConfigureSearchTransition Function
Transition See Also

Configures the Source, Slope, Condition and QualifierTime properties for a transition search.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition\Configure Search Transition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureSearchTransition(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Slope,
    ViInt32 Condition,
    ViReal64 QualifierTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The channel on which to search for edge transitions. The source is a string specified in the format: Channel<n>, where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Slope

Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.

Condition

Specifies whether to search for edge transitions greater than or less than a time.

QualifierTime

The time of the transition to search for. You can search for transitions greater than or less than this time.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_SEARCH_TRANSITION_SLOPE_NEGATIVE | Search for falling edge transitions (Negative slope).
AGINFINIIVISION_VAL_SEARCH_TRANSITION_SLOPE_POSITIVE | Search for rising edge transitions (Positive slope).
Top

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_SEARCH_TRANSITION_CONDITION_GREATER_THAN | Search for edge transitions greater than a time.
AGINFINIIVISION_VAL_SEARCH_TRANSITION_CONDITION_LESS_THAN | Search for edge transitions less than a time.
Top

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION Attribute
Transition See Also

Specifies whether to search for edge transitions greater than or less than a time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition\Search Transition Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION 1150220

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionSearchTransitionConditionGreaterThan - to search for transitions greater than a time
  • AgInfiniiVisionSearchTransitionConditionLessThan - to search for transitions less than a time

Instrument Command

:SEARch:TRANsition:QUALifier {GRE|LESS}
:SEARch:TRANsition:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_TRANSITION_CONDITION_GREATER_THAN | Search for edge transitions greater than a time.
AGINFINIIVISION_VAL_SEARCH_TRANSITION_CONDITION_LESS_THAN | Search for edge transitions less than a time.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME Attribute

AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME Attribute
Transition See Also

The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition\Search Transition Qualifier Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME 1150223

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:TRANsition:TIME {value}
:SEARch:TRANsition:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE Attribute

AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE Attribute
Transition See Also

Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition\Search Transition Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE 1150221

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTransitionSlopeNegative - to specify negative slope
  • AgInfiniiVisionTransitionSlopePositive - to specify positive slope

Instrument Command

:SEARch:TRANsition:SLOPe {NEG|POS}
:SEARch:TRANsition:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCH_TRANSITION_SLOPE_NEGATIVE | Search for falling edge transitions (Negative slope).
AGINFINIIVISION_VAL_SEARCH_TRANSITION_SLOPE_POSITIVE | Search for rising edge transitions (Positive slope).
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE Attribute

AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE Attribute
Transition See Also

The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\Transition\Search Transition Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE 1150222

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SEARch:TRANsition:SOURce {value}
:SEARch:TRANsition:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


USB

USB
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB

Attributes

 | Name | Description
Attribute | Address | Specifies the 7-bit Address portion of the search value, in hex.
Attribute | Condition | Specifies the USB search mode.
Attribute | CRC | Specifies the CRC portion of the search value, in hex.
Attribute | Data | Specifies the Data portion of the trigger, in hex.
Attribute | Data Length | Specifies the data length in bytes.
Attribute | End Point | Specifies the 4-bit Endpoint portion of the search value, in hex.
Attribute | ET | Specifies the 2-bit ET portion of the search value, in hex.
Attribute | Frame | Specifies the 11-bit Frame portion of the search value, in hex.
Attribute | Hub Address | Specifies the 7-bit Hub Address portion of the search value, in hex.
Attribute | Pid Data | Specifies the USB data PID to find.
Attribute | Pid Handshake | Specifies the USB handshake PID to find.
Attribute | Pid Special | Specifies the USB special PID to find.
Attribute | Pid Token | Specifies the USB token PID to find.
Attribute | Port | Specifies the 7-bit Port portion of the search value, in hex.
Attribute | SC | Specifies the 1-bit SC portion of the search value, in hex.
Attribute | SEU | Specifies the 2-bit S and E or U portion of the search value, in hex.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS Attribute
USB See Also

Specifies the 7-bit Address portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS 1150498

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ADDRess {value}
:SEARch:SERial:USB:ADDRess?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION Attribute
USB See Also

Specifies the USB search mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION 1150492

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:MODE {TOK|DATA|HAND|SPEC|ALL|PID|CRC5|CRC16|GLIT|STUFF|SE1}
:SEARch:SERial:USB:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_TOKEN | Token.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_DATA | Data state.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_HANDSHAKE | Handshake.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_SPECIAL | Special.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_ALL_ERRORS | All errors.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITIONPID_ERROR | PID error.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITIONCRC5_ERROR | CRC5 error.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITIONCRC16_ERROR | CRC16 error.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_GLITCH_ERROR | Glitch error.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITION_STUFF_ERROR | Stuff error.
AGINFINIIVISION_VAL_SEARCHUSB_CONDITIONSE1_ERROR | SE1 error.
Top

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_CRC Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_CRC Attribute
USB See Also

Specifies the CRC portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\CRC
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_CRC 1150499

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_CRC.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:CRC {value}
:SEARch:SERial:USB:CRC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_DATA Attribute
USB See Also

Specifies the Data portion of the trigger, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_DATA 1150500

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xn..." where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:DATA {value}
:SEARch:SERial:USB:DATA?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH Attribute
USB See Also

Specifies the data length in bytes.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH 1150501

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • It range is from 1 to 20.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:DATA:LENGth {value}
    :SEARch:SERial:USB:DATA:LENGth?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT Attribute
USB See Also

Specifies the 4-bit Endpoint portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\End Point
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT 1150502

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ENDPoint {value}
:SEARch:SERial:USB:ENDPoint?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_ET Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_ET Attribute
USB See Also

Specifies the 2-bit ET portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\ET
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_ET 1150503

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_ET.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | 2 | 3 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:ET {value}
:SEARch:SERial:USB:ET?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_FRAME Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_FRAME Attribute
USB See Also

Specifies the 11-bit Frame portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Frame
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_FRAME 1150504

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_FRAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xnnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:FRAMe {value}
:SEARch:SERial:USB:FRAMe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS Attribute
USB See Also

Specifies the 7-bit Hub Address portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Hub Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS 1150505

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:HADDress {value}
:SEARch:SERial:USB:HADDress?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA Attribute
USB See Also

Specifies the USB data PID to find.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Pid Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA 1150507

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The DATA USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:DATA {DATA0|DATA1|DATA2|MDAT}
    :SEARch:SERial:USB:PID:DATA?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_DATA_DATA0 | DATA0
AGINFINIIVISION_VAL_PID_DATA_DATA1 | DATA1
AGINFINIIVISION_VAL_PID_DATA_DATA2 | DATA2
AGINFINIIVISION_VAL_PID_DATAM_DATA | MDATA
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE Attribute
USB See Also

Specifies the USB handshake PID to find.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Pid Handshake
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE 1150508

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The HANDshake USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:HANDshake {ACK|NAK|STALL|NYET}
    :SEARch:SERial:USB:PID:HANDshake?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_HANDSHAKEACK | ACK Handshake.
AGINFINIIVISION_VAL_PID_HANDSHAKENAK | NAK Handshake
AGINFINIIVISION_VAL_PID_HANDSHAKESTALL | STALL Handshake.
AGINFINIIVISION_VAL_PID_HANDSHAKENYET | NYET (No Response Yet)
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL Attribute
USB See Also

Specifies the USB special PID to find.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Pid Special
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL 1150509

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The SPECial USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:SPECial {PING|PRE|ERR|SPLIT}
    :SEARch:SERial:USB:PID:SPECial?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_SPECIAL_PING | Ping.
AGINFINIIVISION_VAL_PID_SPECIAL_PREAMBLE | Preamble.
AGINFINIIVISION_VAL_PID_SPECIALERR | ERR.
AGINFINIIVISION_VAL_PID_SPECIAL_SPLIT | Split.
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN Attribute
USB See Also

Specifies the USB token PID to find.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Pid Token
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN 1150510

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The TOKen USB search mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SEARch:SERial:USB:PID:TOKen {OUT|IN|SET|SOF}
    :SEARch:SERial:USB:PID:TOKen?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_TOKEN_OUT | OUT Token.
AGINFINIIVISION_VAL_PID_TOKEN_IN | IN Token.
AGINFINIIVISION_VAL_PID_TOKEN_SETUP | SETUP Token.
AGINFINIIVISION_VAL_PID_TOKEN_SOF | SOF Token.
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_PORT Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_PORT Attribute
USB See Also

Specifies the 7-bit Port portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\Port
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_PORT 1150511

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_PORT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:PORT {value}
:SEARch:SERial:USB:PORT?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_SC Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_SC Attribute
USB See Also

Specifies the 1-bit SC portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\SC
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_SC 1150512

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_SC.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:SC {value}
:SEARch:SERial:USB:SC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SEARCH_USB_SEU Attribute

AGINFINIIVISION_ATTR_SEARCH_USB_SEU Attribute
USB See Also

Specifies the 2-bit S and E or U portion of the search value, in hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Search\USB\SEU
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SEARCH_USB_SEU 1150513

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SEARCH_USB_SEU.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in hexadecimal format.
    • "0xn" where n ::= {0 | 1 | 2 | 3 | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SEARch:SERial:USB:SEU {value}
:SEARch:SERial:USB:SEU?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


SegmentedMemory

SegmentedMemory
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SegmentedMemory

Functions

 | Name | Description
Function | Segmented Memory Analyze | Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.
Top

Attributes

 | Name | Description
Attribute | Index | The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).
Attribute | Segment Count | The number of memory segments to acquire.
Attribute | Time Tag | Read Only - Returns the time tag of the currently selected segmented memory index.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX Attribute

AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX Attribute
SegmentedMemory See Also

The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SegmentedMemory\Index
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX 1150139

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:ACQuire:SEGMented:INDex {value}
:ACQuire:SEGMented:INDex?

Requirements

Supported Models

All supported

See Also

Reference

SegmentedMemory
AgInfiniiVision


AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT Attribute

AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT Attribute
SegmentedMemory See Also

The number of memory segments to acquire.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SegmentedMemory\Segment Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT 1150138

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:ACQuire:SEGMented:COUNt {value}
:ACQuire:SEGMented:COUNt?

Requirements

Supported Models

All supported

See Also

Reference

SegmentedMemory
AgInfiniiVision


AgInfiniiVision_SegmentedMemoryAnalyze Function

AgInfiniiVision_SegmentedMemoryAnalyze Function
SegmentedMemory See Also

Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SegmentedMemory\Segmented Memory Analyze
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SegmentedMemoryAnalyze(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:ACQuire:SEGMented:ANALyze

Requirements

Supported Models

All supported

See Also

Reference

SegmentedMemory
AgInfiniiVision


AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG Attribute

AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG Attribute
SegmentedMemory See Also

Read Only - Returns the time tag of the currently selected segmented memory index.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SegmentedMemory\Time Tag
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG 1150140

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:SEGMented:TTAG?

Requirements

Supported Models

All supported

See Also

Reference

SegmentedMemory
AgInfiniiVision


SerialBus

SerialBus
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus

Branches

Name
ARINC429
CAN
FlexRay
I2S
IIC
LIN
Lister
M1553
SENT
SPI
UART
USB
Top

Functions

 | Name | Description
Function | Get Serial Bus Name | Returns the serialbus name that corresponds to the one-based index that the user specifies.
Top

Attributes

 | Name | Description
Attribute | SerialBus Count | Attribute that contains the number of Serial Buses available on the instrument. This is the maximum index that may be used with the GetSerialBusName() function.
Attribute | SerialBus Enabled | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.
Attribute | SerialBus Mode | Determines the decode mode for the serial bus.
Top

See Also

Reference

AgInfiniiVision


ARINC429

ARINC429
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429

Functions

 | Name | Description
Function | Get SerialBus ARINC429 Trigger Range | Gets the range for the Label Range trigger mode for the selected bus.
Function | Reset SerialBus ARINC429 Counters | Resets the ARINC 429 counters.
Function | SerialBus ARINC429 Auto Setup | Automatically configures settings for the ARINC 429 serial bus mode.
Function | Set SerialBus ARINC429 Trigger Range | Sets the range for the Label Range trigger mode for the selected bus.
Top

Attributes

 | Name | Description
Attribute | SerialBus ARINC429 Base | Selects between hexadecimal and binary display of the decoded data.
Attribute | SerialBus ARINC429 Display Format | Specifies the word decode format.
Attribute | SerialBus ARINC429 Error Count | Read Only - Returns the ARINC 429 error count.
Attribute | SerialBus ARINC429 Signal Type | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Attribute | SerialBus ARINC429 Source | Specifies which signal is used as the source for the selected bus.
Attribute | SerialBus ARINC429 Speed | Specifies the speed of the ARINC 429 interface for the selected bus.
Attribute | SerialBus ARINC429 Trigger Label | Specifies the Label portion of the trigger for the selected bus.
Attribute | SerialBus ARINC429 Trigger Pattern Data | Specifies the Data portion of the trigger for the selected bus, in binary.
Attribute | SerialBus ARINC429 Trigger Pattern SDI | Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | SerialBus ARINC429 Trigger Pattern SSM | Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | SerialBus ARINC429 Trigger Threshold High | The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | SerialBus ARINC429 Trigger Threshold Low | The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | SerialBus ARINC429 Trigger Type | Specifies the ARINC 429 trigger mode for the selected bus.
Attribute | SerialBus ARINC429 Word Count | Read Only - Returns the ARINC 429 word count.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetSerialBusARINC429TriggerRange Function

AgInfiniiVision_GetSerialBusARINC429TriggerRange Function
ARINC429 See Also

Gets the range for the Label Range trigger mode for the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\Get SerialBus ARINC429 Trigger Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetSerialBusARINC429TriggerRange(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32* LowerLimit,
    ViInt32* UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

LowerLimit

The lower limit for the Label Range trigger mode for the selected bus.

UpperLimit

The upper limit for the Label Range trigger mode for the selected bus.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AgInfiniiVision_ResetSerialBusARINC429Counters Function

AgInfiniiVision_ResetSerialBusARINC429Counters Function
ARINC429 See Also

Resets the ARINC 429 counters.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\Reset SerialBus ARINC429 Counters
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetSerialBusARINC429Counters(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:A429:COUNt:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AgInfiniiVision_SerialBusARINC429AutoSetup Function

AgInfiniiVision_SerialBusARINC429AutoSetup Function
ARINC429 See Also

Automatically configures settings for the ARINC 429 serial bus mode.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Auto Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusARINC429AutoSetup(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Remarks

It sets the upper/lower trigger threshold to 3.0V and -3.0V repsectively, turn Noise Reject off, sets the probe attenuation to 10:0, sets the vertical scale to 4V/div, turn Serial Decode on, sets the base to Hex, sets the format to Label/SDI/Data/SSM, sets the trigger to the currently active serial bus and sets the trigger mode to Word Start.

Instrument Command

:SBUS{SerialBus}:A429:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE Attribute
ARINC429 See Also

Selects between hexadecimal and binary display of the decoded data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE 1150372

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429BaseBinary - specifies binary base
  • AgInfiniiVisionSerialBusARINC429BaseHexadecimal - specifies hexadecimal base

The Base property has no effect on the SDI and SSM fields, which are always displayed in binary, nor the Label field, which is always displayed in octal.

Instrument Command

:SBUS{SerialBus}:A429:BASe {BIN|HEX}
:SBUS{SerialBus}:A429:BASe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_BASE_BINARY | Specifies the base to be binary.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_BASE_HEXADECIMAL | Specifies the base to be hexadecimal.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT Attribute
ARINC429 See Also

Specifies the word decode format.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Display Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT 1150373

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DisplayFormat property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelSDIDataSSM - specifies the Label/SDI/Data/SSM format
  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelDataSSM - specifies the Label/Data/SSM format
  • AgInfiniiVisionSerialBusARINC429DisplayFormatLabelData - specifies the Label/Data format

Instrument Command

:SBUS{SerialBus}:A429:FORMat {LDSD|LDSS|LDAT}
:SBUS{SerialBus}:A429:FORMat?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_DISPLAY_FORMAT_LABELSDI_DATASSM | Specifies the Label/SDI/Data/SSM format.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_DISPLAY_FORMAT_LABEL_DATASSM | Specifies the Label/Data/SSM format.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_DISPLAY_FORMAT_LABEL_DATA | Specifies the Label/SDI format.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT Attribute
ARINC429 See Also

Read Only - Returns the ARINC 429 error count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Error Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT 1150374

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:A429:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE Attribute
ARINC429 See Also

Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Signal Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE 1150371

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The SignalType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429SignalTypeLineA - specifies the Line A (non-inverted) signal type.
  • AgInfiniiVisionSerialBusARINC429SignalTypeLineB - specifies the Line B (inverted) signal type.
  • AgInfiniiVisionSerialBusARINC429SignalTypeDifferential - specifies the Differential (A - B) signal type.

Instrument Command

:SBUS{SerialBus}:A429:SIGNal {A|B|DIFF}
:SBUS{SerialBus}:A429:SIGNal?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_SIGNAL_TYPE_LINEA | Specifies the Line A (non-inverted) signal type.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_SIGNAL_TYPE_LINEB | Specifies the Line B (inverted) signal type.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_SIGNAL_TYPE_DIFFERENTIAL | Specifies the Differential (A - B) signal type.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE Attribute
ARINC429 See Also

Specifies which signal is used as the source for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE 1150369

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source property can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels.

Instrument Command

:SBUS{SerialBus}:A429:SOURce {value}
:SBUS{SerialBus}:A429:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED Attribute
ARINC429 See Also

Specifies the speed of the ARINC 429 interface for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Speed
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED 1150370

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Speed property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429SpeedLow - specifies low speed (12.5kb/s)
  • AgInfiniiVisionSerialBusARINC429SpeedHigh - specifies high speed (100kb/s)

Instrument Command

:SBUS{SerialBus}:A429:SPEed {LOW|HIGH}
:SBUS{SerialBus}:A429:SPEed?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_SPEED_LOW | Specifies low speed (12.5kb/s).
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_SPEED_HIGH | Specifies high speed (100kb/s).
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL Attribute
ARINC429 See Also

Specifies the Label portion of the trigger for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Label
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL 1150377

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerLabel property can be specified in one of the following formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "#Qnn", where n: {0,..,7}
  • "0xnn", where n: {0,..,9 | A,..,F}
  • "0xXX" (don't care)

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:LABel {value}
:SBUS{SerialBus}:A429:TRIGger:LABel?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA Attribute
ARINC429 See Also

Specifies the Data portion of the trigger for the selected bus, in binary.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA 1150378

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData property can be specified in the following format:

  • "nn..n", where n: {0 | 1 | X}

The length depends on the value of the DisplayFormat property:
  • If DisplayFormat is set to Label/SDI/Data/SSM, then the data length is 19 bits
  • If DisplayFormat is set to Label/Data/SSM, then the data length is 21 bits
  • If DisplayFormat is set to Label/Data, then the data length is 23 bits

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI Attribute
ARINC429 See Also

Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Pattern SDI
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI 1150379

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternSDI property can be specified in the following format:

  • "nn", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:SDI "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:SDI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM Attribute
ARINC429 See Also

Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Pattern SSM
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM 1150380

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternSSM property can be specified in the following format:

  • "nn", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:PATTern:SSM "{value}"
:SBUS{SerialBus}:A429:TRIGger:PATTern:SSM?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH Attribute
ARINC429 See Also

The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Threshold High
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH 1150424

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW Attribute
ARINC429 See Also

The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Threshold Low
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW 1150425

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE Attribute
ARINC429 See Also

Specifies the ARINC 429 trigger mode for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE 1150376

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordStart - Word start mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordStop - Word stop mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabel - Label mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabelBits - Label + Bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeLabelRange - Label range mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeParityError - Parity error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordError - Word error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeGapError - Gap error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeWordOrGapError - Word or Gap error mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllErrors - All errors mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllBits - All bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllZeroBits - All zero bits mode
  • AgInfiniiVisionSerialBusARINC429TriggerTypeAllOneBits - All one bits mode

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:TYPE {WSTA|WSTO|LAB|LBIT|LRAN|PERR|WERR|WGER|ALL|ABIT|AZB|AOB|GERR}
:SBUS{SerialBus}:A429:TRIGger:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_WORD_START | Word Start trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_WORD_STOP | Word Stop trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_LABEL | Label trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_LABEL_BITS | Label + Bits trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_LABEL_RANGE | Label Range trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_PARITY_ERROR | Parity Error trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_WORD_ERROR | Word Error trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_WORD_OR_GAP_ERROR | Word or Gap Error trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_ALL_ERRORS | All Errors trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_ALL_BITS | All bits trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_ALL_ZERO_BITS | All zero bits trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_ALL_ONE_BITS | All one bits trigger mode.
AGINFINIIVISION_VAL_SERIAL_BUSARINC429_TRIGGER_TYPE_GAP_ERROR | Gap error trigger mode.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT Attribute
ARINC429 See Also

Read Only - Returns the ARINC 429 word count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\SerialBus ARINC429 Word Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT 1150375

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:A429:COUNt:WORD?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


AgInfiniiVision_SetSerialBusARINC429TriggerRange Function

AgInfiniiVision_SetSerialBusARINC429TriggerRange Function
ARINC429 See Also

Sets the range for the Label Range trigger mode for the selected bus.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\ARINC429\Set SerialBus ARINC429 Trigger Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetSerialBusARINC429TriggerRange(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 LowerLimitBufferSize,
    ViConstString LowerLimit,
    ViInt32 UpperLimitBufferSize,
    ViConstString UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

LowerLimitBufferSize

Number of elements in LowerLimit.

LowerLimit

The lower limit for the Label Range trigger mode for the selected bus.

UpperLimitBufferSize

Number of elements in UpperLimit.

UpperLimit

The upper limit for the Label Range trigger mode for the selected bus.

Return Value

Success or failure code.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "#Qnn", where n: {0,..,7}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:A429:TRIGger:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

ARINC429
AgInfiniiVision


CAN

CAN
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN

Branches

Name
FD
Top

Functions

 | Name | Description
Function | Reset Serial Bus Counters | Resets the frame counters.
Top

Attributes

 | Name | Description
Attribute | SerialBus CAN Baud Rate | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | SerialBus CAN Display | Sets and Gets the CAN decode display type.
Attribute | SerialBus CAN Error Count | Read Only - Gets the error frame count.
Attribute | SerialBus CAN Overload Count | Read Only - Gets the overload frame count.
Attribute | SerialBus CAN Sample Point | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.
Attribute | SerialBus CAN Signal Type | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).
Attribute | SerialBus CAN Source | Specifies the source for the CAN signal
Attribute | SerialBus CAN Total Count | Read Only - Gets the total frame count.
Attribute | SerialBus CAN Trigger Condition | Specifies the CAN trigger on condition
Attribute | SerialBus CAN Trigger Pattern Data | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.
Attribute | SerialBus CAN Trigger Pattern Data Length | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | SerialBus CAN Trigger PatternID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.
Attribute | SerialBus CAN Trigger PatternID Type | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.
Attribute | SerialBus CAN Utilization | Read Only - Gets the percent utilization.
Attribute | Trigger Symbolic Message | Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.
Attribute | Trigger Symbolic Signal | Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Attribute | Trigger Symbolic Value | Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Top

See Also

Reference

AgInfiniiVision


FD

FD
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD

Attributes

 | Name | Description
Attribute | Baud Rate | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | Data Length Code | Sets and gets the DLC value to be used in the CAN FD data trigger mode.
Attribute | Sample Point | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | Spec Error Count | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.
Attribute | Standard | Sets and Gets the frame decode standard.
Attribute | Trigger Pattern Start Byte Position | Sets and gets the starting byte position for CAN FD data triggers.
Attribute | TriggerID Filter Enabled | Enable and disable the triggers filtering by CAN IDs.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE Attribute
FD See Also

Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Baud Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE 1150608

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:FDBaudrate {value}
:SBUS{SerialBus}:CAN:SIGNal:FDBaudrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE Attribute
FD See Also

Sets and gets the DLC value to be used in the CAN FD data trigger mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Data Length Code
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE 1150610

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

A specific valid FD value can be specified, or -1 can be specified to indicate "don't care".

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:DLC {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:DLC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT Attribute
FD See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Sample Point
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT 1150611

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are: The even numbered percentages from 30% to 90%of time between the beginning of the bit time to the end of the bit time.

Instrument Command

:SBUS{SerialBus}:CAN:FDSPoint {value}
:SBUS{SerialBus}:CAN:FDSPoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT Attribute
FD See Also

Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Spec Error Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT 1150612

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:SPEC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD Attribute
FD See Also

Sets and Gets the frame decode standard.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Standard
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD 1150646

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Supported by 3000T, 4000X, 6000X, M924x and P924x.

    • Instrument Command

    :SBUS{SerialBus}:CAN:FDSTandard {ISO|NISO}
    :SBUS{SerialBus}:CAN:FDSTandard?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSCANFD_STANDARDISO | ISO Standard that will be used when decoding or triggering on FD frames
AGINFINIIVISION_VAL_SERIAL_BUSCANFD_STANDARDNISO | Non-ISO Standard will be used when decoding or triggering on FD frames
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FD
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION Attribute
FD See Also

Sets and gets the starting byte position for CAN FD data triggers.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\Trigger Pattern Start Byte Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION 1150614

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

CAN FD frames can have up to 64 bytes of data. You can trigger on up to 8 bytes of data. The starting byte position setting lets you trigger on data anywhere within the frame.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:STARt {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED Attribute
FD See Also

Enable and disable the triggers filtering by CAN IDs.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\FD\TriggerID Filter Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED 1150613

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:IDFilter {ON|OFF}
:SBUS{SerialBus}:CAN:TRIGger:IDFilter?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

FD
AgInfiniiVision


AgInfiniiVision_ResetSerialBusCounters Function

AgInfiniiVision_ResetSerialBusCounters Function
CAN See Also

Resets the frame counters.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\Reset Serial Bus Counters
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetSerialBusCounters(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:RESet

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE Attribute
CAN See Also

Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Baud Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE 1150279

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If the baud rate you select does not match the system baud rate, false triggers may occur.
Valid values are from 10000 to 1000000 in 100b/s increments.

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:BAUDrate {value}
:SBUS{SerialBus}:CAN:SIGNal:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY Attribute
CAN See Also

Sets and Gets the CAN decode display type.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Display
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY 1150669

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:DISPlay {HEX|SYMB}
:SBUS{SerialBus}:CAN:DISPlay?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSCAN_DISPLAY_HEXADECIMAL | Hexadecimal values are displayed
AGINFINIIVISION_VAL_SERIAL_BUSCAN_DISPLAY_SYMBOLIC | Symbolic values are displayed
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, EDU-X 1002A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT Attribute
CAN See Also

Read Only - Gets the error frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Error Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT 1150274

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT Attribute
CAN See Also

Read Only - Gets the overload frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Overload Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT 1150275

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:OVERload?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT Attribute
CAN See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Sample Point
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT 1150278

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are: 30.0 to 90.0 in NR3 format for 6000x For others valid values are: 60, 62.5, 68, 70, 75, 80, 87.5

Instrument Command

:SBUS{SerialBus}:CAN:SAMPlepoint {value}
:SBUS{SerialBus}:CAN:SAMPlepoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE Attribute
CAN See Also

Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Signal Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE 1150280

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The SignalType property can be set to one of the following values:

  • Dominant high signals:
    • AgInfiniiVisionSerialBusCANSignalTypeCANH - the actual CAN_H differential bus signal
    • AgInfiniiVisionSerialBusCANSignalTypeDIFH - the CAN differential (H-L) bus signal connected to an analog source channel using a differential probe
  • Dominant low signals:
    • AgInfiniiVisionSerialBusCANSignalTypeCANL - the actual CAN_L differential bus signal
    • AgInfiniiVisionSerialBusCANSignalTypeRX - the Receive signal from the CAN bus transceiver
    • AgInfiniiVisionSerialBusCANSignalTypeTX - the Transmit signal to the CAN bus transceiver
    • AgInfiniiVisionSerialBusCANSignalTypeDIFL - the CAN differential (L-H) bus signal connected to an analog source channel using a differential probe
    • AgInfiniiVisionSerialBusCANSignalTypeDifferential - the CAN differential bus signal connected to an analog source channel using a differential probe. This is the same as AgInfiniiVisionSerialBusCANSignalTypeDIFL

Instrument Command

:SBUS{SerialBus}:CAN:SIGNal:DEFinition {CANH|CANL|RX|TX|DIFF|DIFL|DIFH}
:SBUS{SerialBus}:CAN:SIGNal:DEFinition?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPECANH | The actual CAN_H differential bus signal.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPECANL | The actual CAN_L differential bus signal.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPERX | The Receive signal from the CAN bus transceiver
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPETX | The Transmit signal to the CAN bus transceiver.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPE_DIFFERENTIAL | The CAN differential bus signal connected to an analog source channel using a differential probe. This is the same as DIFL.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPEDIFL | The CAN differential (L-H) bus signal connected to an analog source channel using a differential probe.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_SIGNAL_TYPEDIFH | The CAN differential (H-L) bus signal connected to an analog source channel using a differential probe.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE Attribute
CAN See Also

Specifies the source for the CAN signal

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE 1150281

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:CAN:SOURce {value}
:SBUS{SerialBus}:CAN:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT Attribute
CAN See Also

Read Only - Gets the total frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Total Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT 1150276

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:TOTal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION Attribute
CAN See Also

Specifies the CAN trigger on condition

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Trigger Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION 1150282

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusCANTriggerConditionSOF - will trigger on the Start of Frame (SOF) bit of a Data frame, Remote Transfer Request (RTR) frame, or an Overload frame
  • AgInfiniiVisionSerialBusCANTriggerConditionData - will trigger on CAN Data frames matching the specified Id, Data, and the DLC (Data length code)
  • AgInfiniiVisionSerialBusCANTriggerConditionError - will trigger on CAN Error frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDData - will trigger on CAN frames matching the specified Id of a Data frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDEither - will trigger on the specified Id, regardless if it is a Remote frame or a Data frame
  • AgInfiniiVisionSerialBusCANTriggerConditionIDRemote - will trigger on CAN frames matching the specified Id of a Remote frame
  • AgInfiniiVisionSerialBusCANTriggerConditionAllErrors - will trigger on CAN active error frames and unknown bus conditions
  • AgInfiniiVisionSerialBusCANTriggerConditionOverload - will trigger on CAN overload frames
  • AgInfiniiVisionSerialBusCANTriggerConditionAckError - will trigger on a data or remote frame acknowledge bit that is recessive

The table below shows the remote programming parameter and the corresponding front-panel softkey selection:
Remote Parameter | Front-panel Trigger on: softkey selection (softkey text - softkey popup text)
SOF | SOF - Start of Frame
Data | ID & Data - Data Frame ID and Data
Error | Error - Error frame
IDData | ID & ~RTR - Data Frame ID (~RTR)
IDEither | ID - Remote or Data Frame ID
IDRemote | ID & RTR - Remote Frame ID (RTR)
AllErrors | All Errors - All Errors
Overload | Overload - Overload Frame
AckError | Ack Error - Acknowledge Error

CAN Id specification is set by the TriggerPatternID and TriggerPatternIDType properties.
CAN Data specification is set by the TriggerPatternData property.
CAN Data Length Code is set by the TriggerPatternDataLength property.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger {SOF|DATA|ERR|IDD|IDE|IDR|ALL|OVER|ACK|EOF|FDD|FORM|STUF|CRC|SPEC|BRSB|CRCD|EBA|EBP|MESS|MSIG|FDMS}
:SBUS{SerialBus}:CAN:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONSOF | Will trigger on the Start of Frame (SOF) bit of a Data frame, Remote Transfer Request (RTR) frame, or an Overload frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_DATA | Will trigger on CAN Data frames matching the specified Id, Data, and the DLC (Data length code).
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_ERROR | Will trigger on CAN Error frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONID_DATA | Will trigger on CAN frames matching the specified Id of a Data frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONID_EITHER | Will trigger on the specified Id, regardless if it is a Remote frame or a Data frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONID_REMOTE | Will trigger on CAN frames matching the specified Id of a Remote frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_ALL_ERRORS | Will trigger on CAN active error frames and unknown bus conditions.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_OVERLOAD | Will trigger on CAN overload frames.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_ACK_ERROR | Will trigger on a data or remote frame acknowledge bit that is recessive.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONEOF | Triggers at the end of any frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONFD_DATA | Triggers on CAN FD frames at the end of the last data byte defined in the trigger. You can trigger on up to 8 bytes of data anywhere within the CAN FD data, which can be up to 64 bytes long.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_FORM_ERROR | Triggers on reserved bit errors.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_STUFF_ERROR | Triggers on 6 consecutive 1s or 6 consecutive 0s, while in a non-error or non overload frame.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONCRC_ERROR | Triggers when the calculated CRC does not match the transmitted CRC.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_SPEC_ERROR | Triggers on Ack, Form, Stuff, or CRC errors.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONBRS_BIT | Triggers on the BRS bit of CAN FD frames.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONCRC_DBIT | Triggers on the CRC delimiter bit in CAN FD frames.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONEB_ACTIVE | Triggers on the ESI bit if set active.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONEB_PASSIVE | Triggers on the ESI bit if set passive.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_MSG | Triggers on a symbolic message.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITION_MSG_SIG | Triggers on a symbolic message and a signal value.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_TRIGGER_CONDITIONFD_MSG_SIG | Triggers on a symbolic message and a signal value, limited to the first 8 bytes of FD data.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA Attribute
CAN See Also

Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA 1150283

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData property can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

If more bits are sent than specified by the TriggerPatternDataLength property, the most significant bits will be truncated. If the data length is changed after the string is programmed, the added or deleted bits will be added to or deleted from the least significant bits.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH Attribute
CAN See Also

Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Trigger Pattern Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH 1150284

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:LENGth {value}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID Attribute
CAN See Also

Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Trigger PatternID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID 1150285

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternID property can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

If more bits are sent than allowed (11 bits in standard mode, 29 bits in extended mode) by the TriggerPatternIDType property, the most significant bits will be truncated. If the ID mode is changed after the string is programmed, the added or deleted bits will be added to or deleted from the most significant bits.

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID "{value}"
:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE Attribute
CAN See Also

Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Trigger PatternID Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE 1150286

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternIDType can be set to one of the following values:

  • AgInfiniiVisionSerialBusCANPatternIDTypeStandard - selects the standard 11-bit identifier
  • AgInfiniiVisionSerialBusCANPatternIDTypeExtended - selects the extended 29-bit identifier

Instrument Command

:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID:MODE {STAN|EXT}
:SBUS{SerialBus}:CAN:TRIGger:PATTern:ID:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSCAN_PATTERNID_TYPE_STANDARD | Selects the standard 11-bit identifier.
AGINFINIIVISION_VAL_SERIAL_BUSCAN_PATTERNID_TYPE_EXTENDED | Selects the extended 29-bit identifier.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION Attribute
CAN See Also

Read Only - Gets the percent utilization.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\SerialBus CAN Utilization
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION 1150277

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:CAN:COUNt:UTILization?

Requirements

Supported Models

All supported

See Also

Reference

CAN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE Attribute
CAN See Also

Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\Trigger Symbolic Message
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE 1150665

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:MESSage {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:MESSage?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    CAN
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL Attribute
CAN See Also

Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\Trigger Symbolic Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL 1150666

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:SIGNal {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:SIGNal?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    CAN
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE Attribute
CAN See Also

Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\CAN\Trigger Symbolic Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE 1150667

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Supported Models: 3000T, 4000X, 6000X, M924x and P924x series.

    • Instrument Command

    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:VALue {value}
    :SBUS{SerialBus}:CAN:TRIGger:SYMBolic:VALue?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    CAN
    AgInfiniiVision


FlexRay

FlexRay
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay

Functions

 | Name | Description
Function | Reset SerialBus FlexRay Counters | Resets the FlexRay frame counters.
Function | SerialBus FlexRay Auto Setup | Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.
Function | SerialBus FlexRay Trigger Event AutoSetup | Presets oscilloscope parameters for the selected event type.
Top

Attributes

 | Name | Description
Attribute | SerialBus FlexRay BaudRate | Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.
Attribute | SerialBus FlexRay Channel | Specifies the bus channel, A or B, of the FlexRay signal.
Attribute | SerialBus FlexRay Error Count | Read Only - Gets the FlexRay error frame count.
Attribute | SerialBus FlexRay Null Count | Read Only - Gets the FlexRay null frame count.
Attribute | SerialBus FlexRay Source | Specifies the input source for the FlexRay signal.
Attribute | SerialBus FlexRay Sync Count | Read Only - Gets the FlexRay sync frame count.
Attribute | SerialBus FlexRay Total Count | Read Only - Gets the FlexRay total frame count.
Attribute | SerialBus FlexRay Trigger Error Type | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Attribute | SerialBus FlexRay Trigger Event BSS ID | Specifies the ByteStart Sequence ID.
Attribute | SerialBus FlexRay Trigger Event Type | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Attribute | SerialBus FlexRay Trigger Frame CCBase | Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | SerialBus FlexRay Trigger Frame CCRepetition | Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | SerialBus FlexRay Trigger Frame ID | Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | SerialBus FlexRay Trigger Frame Type | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | SerialBus FlexRay Trigger Type | Specifies the FlexRay trigger on condition.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ResetSerialBusFlexRayCounters Function

AgInfiniiVision_ResetSerialBusFlexRayCounters Function
FlexRay See Also

Resets the FlexRay frame counters.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\Reset SerialBus FlexRay Counters
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetSerialBusFlexRayCounters(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:RESET

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AgInfiniiVision_SerialBusFlexRayAutoSetup Function

AgInfiniiVision_SerialBusFlexRayAutoSetup Function
FlexRay See Also

Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Auto Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusFlexRayAutoSetup(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Remarks

Sets the selected source channel's impedance to 50 Ohms, sets the selected source channel's probe attenuation to 10:1, sets the trigger level (on the selected source channel) to -300 mV, turns on trigger Noise Reject, turns on Serial Decode and sets the trigger type to FlexRay.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE Attribute
FlexRay See Also

Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay BaudRate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE 1150388

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:BAUDrate {value}
:SBUS{SerialBus}:FLEXray:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL Attribute
FlexRay See Also

Specifies the bus channel, A or B, of the FlexRay signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Channel
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL 1150389

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The channel property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayChannelA - specifies bus channel A
  • AgInfiniiVisionSerialBusFlexRayChannelB - specifies bus channel B

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:CHANnel {A|B}
:SBUS{SerialBus}:FLEXray:CHANnel?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_CHANNELA | Specifies that the FlexRay Signal is for Bus A.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_CHANNELB | Specifies that the FlexRay Signal is for Bus B.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT Attribute
FlexRay See Also

Read Only - Gets the FlexRay error frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Error Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT 1150390

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:ERRor?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT Attribute
FlexRay See Also

Read Only - Gets the FlexRay null frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Null Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT 1150391

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:NULL?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE Attribute
FlexRay See Also

Specifies the input source for the FlexRay signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE 1150387

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels available.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:SOURce {value}
:SBUS{SerialBus}:FLEXray:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT Attribute
FlexRay See Also

Read Only - Gets the FlexRay sync frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Sync Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT 1150392

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:SYNC?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT Attribute
FlexRay See Also

Read Only - Gets the FlexRay total frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Total Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT 1150393

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:FLEXray:COUNt:TOTal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE Attribute
FlexRay See Also

Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Error Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE 1150400

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerErrorType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeAll - triggers on ALL errors.
  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeHeaderCRC - triggers on only Header CRC errors.
  • AgInfiniiVisionSerialBusFlexRayTriggerErrorTypeFrameCRC - triggers on only Frame CRC errors.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:ERRor:TYPE {ALL|HCRC|FCRC}
:SBUS{SerialBus}:FLEXray:TRIGger:ERRor:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_ERROR_TYPE_ALL | Triggers on ALL errors.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_ERROR_TYPE_HEADERCRC | Triggers on only Header CRC errors.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_ERROR_TYPE_FRAMECRC | Triggers on only Frame CRC errors.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AgInfiniiVision_SerialBusFlexRayTriggerEventAutoSetup Function

AgInfiniiVision_SerialBusFlexRayTriggerEventAutoSetup Function
FlexRay See Also

Presets oscilloscope parameters for the selected event type.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Event AutoSetup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusFlexRayTriggerEventAutoSetup(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:AUToset

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID Attribute
FlexRay See Also

Specifies the ByteStart Sequence ID.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Event BSS ID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID 1150395

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerEventBSSID property can be specified in one of the following formats:

  • "All"
  • "n", where n: 1-2047

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:BSS:ID {value}
:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:BSS:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE Attribute
FlexRay See Also

Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Event Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE 1150394

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerEventType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeWakeUp - triggers on Wake-Up event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeTSS - triggers on Transmission Start Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeBSS - triggers on Byte Start Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeFES - triggers on Frame End Sequence event.
  • AgInfiniiVisionSerialBusFlexRayTriggerEventTypeDTS - triggers on Dynamic Trailing Sequence event.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:TYPE {WAK|TSS|BSS|FES|DTS}
:SBUS{SerialBus}:FLEXray:TRIGger:EVENt:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_EVENT_TYPE_WAKE_UP | Triggers on Wake-Up event.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_EVENT_TYPETSS | Triggers on Transmission Start Sequence event.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_EVENT_TYPEBSS | Triggers on Byte Start Sequence event.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_EVENT_TYPEFES | Triggers on Frame End Sequence event. This is equivalent to DTS.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_EVENT_TYPEDTS | Triggers on Dynamic Trailing Sequence event. This is equivalent to FES.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE Attribute
FlexRay See Also

Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Frame CCBase
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE 1150396

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerFrameCCBase property can be set to a value from 0 through the Cycle Count Repetition factor minus 1).

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCBase {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCBase?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION Attribute
FlexRay See Also

Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Frame CCRepetition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION 1150397

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerFrameCCRepetition property can be specified in one of the following formats:

  • "All"
  • "n", where n is an integer from 2 to 64

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCRepetition {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:CCRepetition?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID Attribute
FlexRay See Also

Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Frame ID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID 1150399

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerFrameID property can be specified in one of the following formats:

  • "All"
  • "n", where n is an integer from 1-2047

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:ID {value}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE Attribute
FlexRay See Also

Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Frame Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE 1150398

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerFrameType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNormal - will trigger on only normal (NSTArtup and NNULl and NSYNc) frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeStartup - will trigger on only startup frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNull - will trigger on only null frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeSync - will trigger on only sync frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotStartup - will trigger on frames other than startup frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotNull - will trigger on frames other than null frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeNotSync - will trigger on frames other than sync frames.
  • AgInfiniiVisionSerialBusFlexRayTriggerFrameTypeAll - will trigger on all FlexRay frame types.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:TYPE {NORM|STAR|NULL|SYNC|NSTA|NNUL|NSYN|ALL}
:SBUS{SerialBus}:FLEXray:TRIGger:FRAMe:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_NORMAL | Trigger on only normal frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_STARTUP | Trigger on only startup frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_NULL | Trigger on only null frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_SYNC | Trigger on only sync frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_NOT_STARTUP | Trigger on frames other than startup frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_NOT_NULL | Trigger on frames other than null frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_NOT_SYNC | Trigger on frames other than sync frames.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_FRAME_TYPE_ALL | Trigger on all FlexRay frame types.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE Attribute
FlexRay See Also

Specifies the FlexRay trigger on condition.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\FlexRay\SerialBus FlexRay Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE 1150386

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusFlexRayTriggerTypeFrame - triggers on specified frames (without errors).
  • AgInfiniiVisionSerialBusFlexRayTriggerTypeError - triggers on selected active error frames and unknown bus conditions.
  • AgInfiniiVisionSerialBusFlexRayTriggerTypeEvent - triggers on specified FlexRay event/symbol.

This command is only valid when the FlexRay triggering and serial decode option (Option FLX) has been licensed.

Instrument Command

:SBUS{SerialBus}:FLEXray:TRIGger {FRAM|ERR|EVEN}
:SBUS{SerialBus}:FLEXray:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_TYPE_FRAME | Triggers on specified frames (without errors).
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_TYPE_ERROR | Triggers on selected active error frames and unknown bus conditions.
AGINFINIIVISION_VAL_SERIAL_BUS_FLEX_RAY_TRIGGER_TYPE_EVENT | Triggers on specified FlexRay event/symbol.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

FlexRay
AgInfiniiVision


AgInfiniiVision_GetSerialBusName Function

AgInfiniiVision_GetSerialBusName Function
SerialBus See Also

Returns the serialbus name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\Get Serial Bus Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetSerialBusName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

SerialBus
AgInfiniiVision


I2S

I2S
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S

Functions

 | Name | Description
Function | Get Serial BusI2S Trigger Range | Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Function | Set Serial BusI2S Trigger Range | Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Top

Attributes

 | Name | Description
Attribute | SerialBus I2S Base | Specifies the base to use for the I2S decode display.
Attribute | SerialBus I2S Clock Slope | Specifies which edge of the I2S serial clock signal clocks in data
Attribute | SerialBus I2S Clock Source | Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.
Attribute | SerialBus I2S Data Alignment | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.
Attribute | SerialBus I2S Data Source | Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.
Attribute | SerialBus I2S Receiver Width | Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits
Attribute | SerialBus I2S Transmitted Width | Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.
Attribute | SerialBus I2S Trigger Audio Channel | Specifies the audio channel to trigger on.
Attribute | SerialBus I2S Trigger Condition | Specified the I2S trigger operator.
Attribute | SerialBus I2S Trigger Pattern Data | Specifies the I2S trigger data pattern searched for in each I2S message.
Attribute | SerialBus I2S Word Select Polarity | Specifies the polarity of the word select (WS) signal.
Attribute | SerialBus I2S Word Select Source | Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetSerialBusI2STriggerRange Function

AgInfiniiVision_GetSerialBusI2STriggerRange Function
I2S See Also

Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\Get Serial BusI2S Trigger Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetSerialBusI2STriggerRange(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 LowerLimitBufferSize,
    ViInt32* LowerLimit,
    ViInt32 UpperLimitBufferSize,
    ViInt32* UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

LowerLimitBufferSize

Number of elements in LowerLimit.

LowerLimit

The lower range boundary.

UpperLimitBufferSize

Number of elements in UpperLimit.

UpperLimit

The upper range boundary.

Return Value

Success or failure code.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

Note that for AgInfiniiVisionSerialBusI2STriggerConditionIncreasing and AgInfiniiVisionSerialBusI2STriggerConditionDecreasing, the LowerLimit and UpperLimit values correspond to the "Armed" and "Trigger" softkeys.

The length of the LowerLimit and UpperLimit values is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the length is equal to the transmitter word size.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE Attribute
I2S See Also

Specifies the base to use for the I2S decode display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE 1150288

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SBaseDecimal - specifies Decimal base
  • AgInfiniiVisionSerialBusI2SBaseHexadecimal - specifies Hexadecimal base

Instrument Command

:SBUS{SerialBus}:I2S:BASE {DEC|HEX}
:SBUS{SerialBus}:I2S:BASE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_BASE_DECIMAL | Specifies the decimal base.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_BASE_HEXADECIMAL | Specifies the hexadecimal base.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE Attribute
I2S See Also

Specifies which edge of the I2S serial clock signal clocks in data

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Clock Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE 1150289

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSlope property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SClockSlopeNegative - falling edge
  • AgInfiniiVisionSerialBusI2SClockSlopePositive - rising edge

Instrument Command

:SBUS{SerialBus}:I2S:CLOCk:SLOPe {NEG|POS}
:SBUS{SerialBus}:I2S:CLOCk:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_CLOCK_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_CLOCK_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE Attribute
I2S See Also

Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE 1150291

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:CLOCk {value}
:SBUS{SerialBus}:I2S:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT Attribute
I2S See Also

Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Data Alignment
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT 1150287

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DataAlignment property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SDataAlignmentStandard - Standard alignment
  • AgInfiniiVisionSerialBusI2SDataAlignmentLeftJustified - left justified
  • AgInfiniiVisionSerialBusI2SDataAlignmentRightJustified - right justified

The word select polarity is specified separately with the WordSelectPolarity property.

Instrument Command

:SBUS{SerialBus}:I2S:ALIGnment {I2S|LJ|RJ}
:SBUS{SerialBus}:I2S:ALIGnment?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_DATA_ALIGNMENT_STANDARD | Standard alignment.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_DATA_ALIGNMENT_LEFT_JUSTIFIED | Left Justified.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_DATA_ALIGNMENT_RIGHT_JUSTIFIED | Right Justified.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE Attribute
I2S See Also

Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Data Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE 1150292

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:DATA {value}
:SBUS{SerialBus}:I2S:SOURce:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH Attribute
I2S See Also

Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Receiver Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH 1150290

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 4 to 32.

Instrument Command

:SBUS{SerialBus}:I2S:RWIDth {value}
:SBUS{SerialBus}:I2S:RWIDth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH Attribute
I2S See Also

Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Transmitted Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH 1150297

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 4 to 32.

Instrument Command

:SBUS{SerialBus}:I2S:TWIDth {value}
:SBUS{SerialBus}:I2S:TWIDth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL Attribute
I2S See Also

Specifies the audio channel to trigger on.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Trigger Audio Channel
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL 1150295

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerAudioChannel property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2STriggerAudioChannelLeft - Left channel
  • AgInfiniiVisionSerialBusI2STriggerAudioChannelRight - Right channel
  • AgInfiniiVisionSerialBusI2STriggerAudioChannelEither - Right or Left channel

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:AUDio {LEFT|RIGH|EITH}
:SBUS{SerialBus}:I2S:TRIGger:AUDio?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_AUDIO_CHANNEL_LEFT | Left audio channel.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_AUDIO_CHANNEL_RIGHT | Right audio channel.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_AUDIO_CHANNEL_EITHER | Either left or right audio channel.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION Attribute
I2S See Also

Specified the I2S trigger operator.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Trigger Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION 1150294

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniivisionSerialBusI2STriggerConditionEqual - triggers on the specified audio channel's data word when it equals the specified word
  • AgInfiniivisionSerialBusI2STriggerConditionNotEqual - triggers on any word other than the specified word
  • AgInfiniivisionSerialBusI2STriggerConditionLessThan - triggers when the channel's data word is less than the specified value
  • AgInfiniivisionSerialBusI2STriggerConditionGreaterThan - triggers when the channel's data word is greater than the specified value
  • AgInfiniivisionSerialBusI2STriggerConditionInRange - enter upper and lower values to specify the range in which to trigger
  • AgInfiniivisionSerialBusI2STriggerConditionOutRange - enter upper and lower values to specify range in which trigger will not occur
  • AgInfiniivisionSerialBusI2STriggerConditionIncreasing - triggers when the data value makes a certain increase over time and the specified value is met or exceeded. Use the SetTriggerRange() method to set "Trigger" and "Armed" values. The "Trigger" value is the value that must be met or exceeded to cause the trigger. The "Armed" value is the value the data must go below in order to re-arm the oscilloscope (ready it to trigger again)
  • AgInfiniivisionSerialBusI2STriggerConditionDecreasing - similar to the Increasing trigger condition except the trigger occurs on a certain decrease over time and the "Trigger" data value is less than the "Armed" data value

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger {EQU|NOT|LESS|GRE|INR|OUTR|INCR|DECR}
:SBUS{SerialBus}:I2S:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_EQUAL | Triggers on the specified audio channel's data word when it equals the specified word.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_NOT_EQUAL | Triggers on any word other than the specified word.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_LESS_THAN | Triggers when the channel's data word is less than the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_GREATER_THAN | Triggers when the channel's data word is greater than the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_IN_RANGE | Enter upper and lower values to specify the range in which to trigger.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_OUT_RANGE | Enter upper and lower values to specify range in which trigger will not occur.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_INCREASING | Triggers when the data value makes a certain increase over time and the specified value is met or exceeded
AGINFINIIVISION_VAL_SERIAL_BUSI2S_TRIGGER_CONDITION_DECREASING | Similar to Increasing except the trigger occurs on a certain decrease over time and the "Trigger" data value is less than the "Armed" data value.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA Attribute
I2S See Also

Specifies the I2S trigger data pattern searched for in each I2S message.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA 1150296

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData can be specified in one of the following string formats:

  • "n", where n: 32-bit integer in signed decimal
  • "#Bnn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

Set a string bit to "0" or "1" to set the corresponding bit in the data pattern to low or high, respectively.
Set a string bit to "X" to ignore (mask off) that bit in the data pattern.
Use the "$" character to indicate that the value of the corresponding bit will not be changed (the existing bit value is used).

The TriggerPatternData property specifies the I2S trigger data pattern used by the Equal, NotEqual, GreaterThan, and LessThan trigger conditions. If the GreaterThan or LessThan trigger condition is selected, the bits specified to be masked off ("X") will be interpreted as 0's.

The length of the trigger data value is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the data length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the data length is equal to the transmitter word size.

If more bits are sent than the specified trigger data length, the most significant bits will be truncated. If the word size is changed after the string is programmed, the added or deleted bits will be added to or deleted from the least significant bits.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:I2S:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY Attribute
I2S See Also

Specifies the polarity of the word select (WS) signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Word Select Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY 1150298

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The WordSelectPolarity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusI2SWordSelectPolarityLeft - a word select (WS) state of low indicates left channel data is active on the I2S bus, and a WS state of high indicates right channel data is active on the bus
  • AgInfiniiVisionSerialBusI2SWordSelectPolarityRight - a word select (WS) state of low indicates right channel data is active on the I2S bus, and a WS state of high indicates left channel data is active on the bus

Instrument Command

:SBUS{SerialBus}:I2S:WSLow {LEFT|RIGH}
:SBUS{SerialBus}:I2S:WSLow?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSI2S_WORD_SELECT_POLARITY_LEFT | A word select (WS) state of low indicates left channel data is active on the I2S bus, and a WS state of high indicates right channel data is active on the bus.
AGINFINIIVISION_VAL_SERIAL_BUSI2S_WORD_SELECT_POLARITY_RIGHT | A word select (WS) state of low indicates right channel data is active on the I2S bus, and a WS state of high indicates left channel data is active on the bus.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE Attribute
I2S See Also

Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\SerialBus I2S Word Select Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE 1150293

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The WordSelectSource property can be specified in one of the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:SBUS{SerialBus}:I2S:SOURce:WSELect {value}
:SBUS{SerialBus}:I2S:SOURce:WSELect?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


AgInfiniiVision_SetSerialBusI2STriggerRange Function

AgInfiniiVision_SetSerialBusI2STriggerRange Function
I2S See Also

Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\I2S\Set Serial BusI2S Trigger Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetSerialBusI2STriggerRange(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 LowerLimitBufferSize,
    ViConstString LowerLimit,
    ViInt32 UpperLimitBufferSize,
    ViConstString UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

LowerLimitBufferSize

Number of elements in LowerLimit.

LowerLimit

The lower range boundary.

UpperLimitBufferSize

Number of elements in UpperLimit.

UpperLimit

The upper range boundary.

Return Value

Success or failure code.

Remarks

The LowerLimit and UpperLimit parameters can be specified in one of the following formats:

  • "n" where n: 32-bit integer in signed decimal
  • "#Bnn...n" where n: {0 | 1 }
  • "0xnn...n" where n: {0,..,9 | A,..,F}

Note that for AgInfiniiVisionSerialBusI2STriggerConditionIncreasing and AgInfiniiVisionSerialBusI2STriggerConditionDecreasing, the LowerLimit and UpperLimit values correspond to the "Armed" and "Trigger" softkeys.

The length of the LowerLimit and UpperLimit values is determined by the ReceiverWidth and TransmittedWidth properties. When the receiver word size is less than the transmitter word size, the length is equal to the receiver word size. When the receiver word size is greater than the transmitter word size, the length is equal to the transmitter word size.

Instrument Command

:SBUS{SerialBus}:I2S:TRIGger:RANGe {LowerLimit},{UpperLimit}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

I2S
AgInfiniiVision


IIC

IIC
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC

Attributes

 | Name | Description
Attribute | SerialBus IIC Address Width | Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Attribute | SerialBus IIC Clock Source | Specifies the source for the IIC serial clock (SCL).
Attribute | SerialBus IIC Data Source | Specifies the source for IIC serial data (SDA).
Attribute | SerialBus IIC Trigger Condition | Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom
Attribute | SerialBus IIC Trigger Pattern Address | Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.
Attribute | SerialBus IIC Trigger Pattern Data | Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | SerialBus IIC Trigger Pattern Data2 | Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | SerialBus IIC Trigger Type | Specifies the IIC trigger type.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH Attribute
IIC See Also

Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Address Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH 1150299

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The AddressWidth property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICAddressWidthBit7 - Bit 7
  • AgInfiniiVisionSerialBusIICAddressWidthBit8 - Bit 8

Instrument Command

:SBUS{SerialBus}:IIC:ASIZe {BIT7|BIT8}
:SBUS{SerialBus}:IIC:ASIZe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSIIC_ADDRESS_WIDTH_BIT7 | Bit 7
AGINFINIIVISION_VAL_SERIAL_BUSIIC_ADDRESS_WIDTH_BIT8 | Bit 8
Top

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE Attribute
IIC See Also

Specifies the source for the IIC serial clock (SCL).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE 1150300

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:IIC:SOURce:CLOCk {value}
:SBUS{SerialBus}:IIC:SOURce:CLOCk?

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE Attribute
IIC See Also

Specifies the source for IIC serial data (SDA).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Data Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE 1150301

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:IIC:SOURce:DATA {value}
:SBUS{SerialBus}:IIC:SOURce:DATA?

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION Attribute
IIC See Also

Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Trigger Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION 1150305

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICTriggerConditionEqual - Equal
  • AgInfiniiVisionSerialBusIICTriggerConditionNotEqual - Not Equal
  • AgInfiniiVisionSerialBusIICTriggerConditionGreaterThan - Greater Than
  • AgInfiniiVisionSerialBusIICTriggerConditionLessThan - Less Than

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:QUALifier {EQU|NOT|LESS|GRE}
:SBUS{SerialBus}:IIC:TRIGger:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_CONDITION_EQUAL | Equal to the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_CONDITION_NOT_EQUAL | Not equal to the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_CONDITION_LESS_THAN | Less than the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_CONDITION_GREATER_THAN | Greater than the specified value.
Top

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS Attribute
IIC See Also

Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Trigger Pattern Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS 1150302

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternAddress can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:ADDRess {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:ADDRess?

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA Attribute
IIC See Also

Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA 1150303

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATA {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATA?

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2 Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2 Attribute
IIC See Also

Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Trigger Pattern Data2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2 1150304

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData2 can be specified in one of the following string formats:

  • "n", where n is an integer.
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATa2 {value}
:SBUS{SerialBus}:IIC:TRIGger:PATTern:DATa2?

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE Attribute
IIC See Also

Specifies the IIC trigger type.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\IIC\SerialBus IIC Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE 1150306

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusIICTriggerTypeStart - Start condition
  • AgInfiniiVisionSerialBusIICTriggerTypeStop - Stop condition
  • AgInfiniiVisionSerialBusIICTriggerTypeRead7 - 7-bit address frame containing (Start:Address7:Read:Ack:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeR7Data2 - 7-bit address frame containing (Start:Address7:Read:Ack:Data:Ack:Data2)
  • AgInfiniiVisionSerialBusIICTriggerTypeReadEprom - EEPROM data read
  • AgInfiniiVisionSerialBusIICTriggerTypeWrite7 - 7-bit address frame containing (Start:Address7:Write:Ack:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeW7Data2 - 7-bit address frame containing (Start:Address7:Write:Ack:Data:Ack:Data2)
  • AgInfiniiVisionSerialBusIICTriggerTypeWrite10 - 10-bit address frame containing (Start:Address byte1:Write:Ack:Address byte 2:Data)
  • AgInfiniiVisionSerialBusIICTriggerTypeMissingAcknowledge - Missing acknowledge
  • AgInfiniiVisionSerialBusIICTriggerTypeNoAcknowledge - Address with no acknowledge
  • AgInfiniiVisionSerialBusIICTriggerTypeRestart - Another start condition occurs before a stop condition

Instrument Command

:SBUS{SerialBus}:IIC:TRIGger:TYPE {STAR|STOP|READ7|R7D2|READE|WRIT7|W7D2|WRIT10|NACK|ANAC|REST|ADDR|DNAC}
:SBUS{SerialBus}:IIC:TRIGger:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_START | Start condition.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_STOP | Stop condition.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_READ7 | 7-bit address frame containing (Start:Address7:Read:Ack:Data).
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPER7_DATA2 | 7-bit address frame containing (Start:Address7:Read:Ack:Data:Ack:Data2).
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_READ_EPROM | EEPROM data read.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_WRITE7 | 7-bit address frame containing (Start:Address7:Write:Ack:Data).
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPEW7_DATA2 | 7-bit address frame containing (Start:Address7:Write:Ack:Data:Ack:Data2).
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_WRITE10 | 10-bit address frame containing (Start:Address byte1:Write:Ack:Address byte 2:Data).
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_MISSING_ACKNOWLEDGE | Missing acknowledge.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_NO_ACKNOWLEDGE | Address with no acknowledge.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_RESTART | Another start condition occurs before a stop condition.
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_ADDRESS | Triggers on the selected address. The R/W bit is ignored
AGINFINIIVISION_VAL_SERIAL_BUSIIC_TRIGGER_TYPE_DATA_NO_ACK | Write data with no acknowledge
Top

Requirements

Supported Models

All supported

See Also

Reference

IIC
AgInfiniiVision


LIN

LIN
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN

Attributes

 | Name | Description
Attribute | SerialBus LIN Baud Rate | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s
Attribute | SerialBus LIN Display | Sets and Gets the LIN decode display type.
Attribute | SerialBus LIN Parity Enabled | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.
Attribute | SerialBus LIN Sample Point | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | SerialBus LIN Source | Specifies the source for the CAN signal.
Attribute | SerialBus LIN Standard | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Attribute | SerialBus LIN Sync Break Length | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.
Attribute | SerialBus LIN Trigger Condition | Specifies the LIN trigger condition.
Attribute | SerialBus LIN Trigger Pattern Data | Specifies the LIN trigger data pattern searched for in each LIN data field.
Attribute | SerialBus LIN Trigger Pattern Data Length | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | SerialBus LIN TriggerID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.
Attribute | Trigger Symbolic Frame | Sets and Gets the specific message when the LIN trigger mode is set to Frame.
Attribute | Trigger Symbolic Signal | Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.
Attribute | Trigger Symbolic Value | Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE Attribute
LIN See Also

Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Baud Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE 1150309

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 2400 to 625000 in 100 b/s increments

Instrument Command

:SBUS{SerialBus}:LIN:SIGNal:BAUDrate {value}
:SBUS{SerialBus}:LIN:SIGNal:BAUDrate?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY Attribute
LIN See Also

Sets and Gets the LIN decode display type.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Display
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY 1150647

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:DISPlay {HEX|SYMB}
:SBUS{SerialBus}:LIN:DISPlay?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSLIN_DISPLAY_HEXADECIMAL | Hexadecimal values.
AGINFINIIVISION_VAL_SERIAL_BUSLIN_DISPLAY_SYMBOLIC | Symbolic values.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED Attribute
LIN See Also

Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Parity Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED 1150307

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:PARity {ON|OFF}
:SBUS{SerialBus}:LIN:PARity?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT Attribute
LIN See Also

Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Sample Point
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT 1150308

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are: 60, 62.5, 68, 70, 75, 80, 87.5

The sample point values are not limited by the baud rate.

Instrument Command

:SBUS{SerialBus}:LIN:SAMPlepoint {value}
:SBUS{SerialBus}:LIN:SAMPlepoint?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE Attribute
LIN See Also

Specifies the source for the CAN signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE 1150310

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:LIN:SOURce {value}
:SBUS{SerialBus}:LIN:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD Attribute
LIN See Also

Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Standard
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD 1150311

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Standard property can be set to one of the following values:

  • AgInfiniiVisionSerialBusLINStandardLIN13 - to specify the LIN1.3 standard for triggering and decoding
  • AgInfiniiVisionSerialBusLINStandardLIN20 - to specify the LIN2.0 standard for triggering and decoding

Instrument Command

:SBUS{SerialBus}:LIN:STANdard {LIN13|LIN20}
:SBUS{SerialBus}:LIN:STANdard?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSLIN_STANDARDLIN13 | Specifies the LIN 1.3 standard.
AGINFINIIVISION_VAL_SERIAL_BUSLIN_STANDARDLIN20 | Specifies the LIN 2.0 standard.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH Attribute
LIN See Also

Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Sync Break Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH 1150312

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are: 11, 12, 13

Instrument Command

:SBUS{SerialBus}:LIN:SYNCbreak {value}
:SBUS{SerialBus}:LIN:SYNCbreak?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION Attribute
LIN See Also

Specifies the LIN trigger condition.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Trigger Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION 1150313

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusLINTriggerConditionSyncBreak - Sync Break
  • AgInfiniiVisionSerialBusLINTriggerConditionID - Frame ID
  • AgInfiniiVisionSerialBusLINTriggerConditionData - Frame ID and Data

Use the TriggerID property to specify the frame ID.
Use the TriggerPatternDataLength and TriggerPatternData properties to specify the data string length and value.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger {SYNC|ID|DATA|PAR|CSUM|FRAM|FSIG}
:SBUS{SerialBus}:LIN:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_SYNC_BREAK | Sync Break.
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITIONID | Frame ID.
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_DATA | Frame ID and Data
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_PARITY_ERR | Parity Errors
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_CHECKSUM_ERR | Checksum Errors
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_FRAME | Triggers on a symbolic frame
AGINFINIIVISION_VAL_SERIAL_BUSLIN_TRIGGER_CONDITION_FRAME_SIG | Triggers on a symbolic frame and a signal value
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA Attribute
LIN See Also

Specifies the LIN trigger data pattern searched for in each LIN data field.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA 1150315

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData property can be specified in one of the following string formats:

  • "n", where n: 32-bit integer in unsigned decimal
  • "#Bnn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

Set a string bit to "0" or "1" to set the corresponding bit in the data pattern to low or high, respectively.
Set a string bit to "X" to ignore (mask off) that bit in the data pattern.
Use the "$" character to indicate that the value of the corresponding bit will not be changed (the existing bit value is used).

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH Attribute
LIN See Also

the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN Trigger Pattern Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH 1150316

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA:LENGth {value}
:SBUS{SerialBus}:LIN:TRIGger:PATTern:DATA:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID Attribute
LIN See Also

Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\SerialBus LIN TriggerID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID 1150314

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerID property can be specified in one of the following string formats:

  • "n", where n: 7-bit integer in decimal from 0-63
  • "#Bnn..n", where n: {0 | 1}
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 to 0x3f

Setting the ID to a value of "-1" results in "0xXX" which is equivalent to all IDs.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:ID {value}
:SBUS{SerialBus}:LIN:TRIGger:ID?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME Attribute
LIN See Also

Sets and Gets the specific message when the LIN trigger mode is set to Frame.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\Trigger Symbolic Frame
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME 1150648

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:FRAMe "{value}"
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL Attribute
LIN See Also

Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\Trigger Symbolic Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL 1150649

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:SIGNal "{value}"
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:SIGNal?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE Attribute
LIN See Also

Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\LIN\Trigger Symbolic Value
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE 1150650

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:VALue {value}
:SBUS{SerialBus}:LIN:TRIGger:SYMBolic:VALue?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

LIN
AgInfiniiVision


Lister

Lister
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\Lister

Functions

 | Name | Description
Function | Get Lister Data | Gets the lister data as a string.
Top

Attributes

 | Name | Description
Attribute | Serial Bus Lister Display | The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.
Attribute | Serial Bus Lister Time Reference | Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_GetListerData Function

AgInfiniiVision_GetListerData Function
Lister See Also

Gets the lister data as a string.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\Lister\Get Lister Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetListerData(
    ViSession Vi,
    ViInt32 DataBufferSize,
    ViChar[] Data
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DataBufferSize

Buffer Size.

Data

The lister data in a string format.

Return Value

Success or failure code.

Instrument Command

:LISTer:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Lister
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY Attribute
Lister See Also

The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\Lister\Serial Bus Lister Display
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY 1150353

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Display property can be set to one of the following values:

  • AgInfiniiVisionSerialBusListerDisplayOff - for turning the Lister off
  • AgInfiniiVisionSerialBusListerDisplaySerialBus1 - to display SerialBus1 in the Lister
  • AgInfiniiVisionSerialBusListerDisplaySerialBus2 - to display SerialBus2 in the Lister
  • AgInfiniiVisionSerialBusListerDisplayAll - to display information for all serial buses. The decode information for different buses is interleaved in time in this case

Serial bus decode must be on (using the IAgInfiniiVisionSerialBus.Enabled property) before it can be displayed in the Lister.

Instrument Command

:LISTer:DISPlay {OFF|SBUS1|SBUS2|ALL}
:LISTer:DISPlay?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_LISTER_DISPLAY_OFF | The lister is off.
AGINFINIIVISION_VAL_LISTER_DISPLAY_SBUS1 | Display Serial Bus 1 in the lister.
AGINFINIIVISION_VAL_LISTER_DISPLAY_SBUS2 | Not Supported on 2000X series. Display Serial Bus 2 in the lister.
AGINFINIIVISION_VAL_SERIAL_BUS_LISTER_DISPLAY_ALL | Not Supported on 2000X series. Display all serial buses in the lister. The decode information for different buses is interleaved in time.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Lister
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE Attribute
Lister See Also

Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\Lister\Serial Bus Lister Time Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE 1150354

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TimeReference property can be set to one of the following values:

  • AgInfiniiVisionSerialBusListerTimeReferenceTrigger - to specify that the time value for a Lister row is relative to the trigger
  • AgInfiniiVisionSerialBusListerTimeReferencePrevious - to specify that the time value for a Lister row is relative to the previous Lister row

Instrument Command

:LISTer:REFerence {TRIG|PREV}
:LISTer:REFerence?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_LISTER_TIME_REFERENCE_TRIGGER | The time value for a Lister row is relative to the trigger.
AGINFINIIVISION_VAL_SERIAL_BUS_LISTER_TIME_REFERENCE_PREVIOUS | The time value for a Lister row is relative to the previous Lister row.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Lister
AgInfiniiVision


M1553

M1553
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553

Functions

 | Name | Description
Function | SerialBus M1553 AutoSetup | This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.
Top

Attributes

 | Name | Description
Attribute | SerialBus M1553 Base | Specifies the base to use for the MIL-STD 1553 decode display.
Attribute | SerialBus M1553 Source | Specifies which signal is used as the source for the selected bus.
Attribute | SerialBus M1553 Trigger Pattern Data | Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.
Attribute | SerialBus M1553 Trigger RTA | Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.
Attribute | SerialBus M1553 Trigger Threshold High | The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | SerialBus M1553 Trigger Threshold Low | The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | SerialBus M1553 Trigger Type | Specifies the type of MIL-STD 1553 trigger to be used.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_SerialBusM1553AutoSetup Function

AgInfiniiVision_SerialBusM1553AutoSetup Function
M1553 See Also

This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 AutoSetup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusM1553AutoSetup(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Remarks

Its also sets the upper/lower probe attenuation to 10:1, turns on serial decode, turns off trigger noise reject and sets the trigger mode to MIL-STD 1553.

Instrument Command

:SBUS{SerialBus}:M1553:AUTosetup

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE Attribute
M1553 See Also

Specifies the base to use for the MIL-STD 1553 decode display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE 1150381

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusM1553BaseBinary - specifies the binary base
  • AgInfiniiVisionSerialBusM1553BaseHexadecimal - specifies the hexadecimal base

Instrument Command

:SBUS{SerialBus}:M1553:BASe {BIN|HEX}
:SBUS{SerialBus}:M1553:BASe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSM1553_BASE_BINARY | Specifies binary base for the MIL-STD 1553 decode display.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_BASE_HEXADECIMAL | Specifies hexadecimal base for the MIL-STD 1553 decode display.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE Attribute
M1553 See Also

Specifies which signal is used as the source for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE 1150382

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Source property can be specified in the following format:

  • "Channel<n>", where n: 1 to the number of analog channels.

Instrument Command

:SBUS{SerialBus}:M1553:SOURce {value}
:SBUS{SerialBus}:M1553:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA Attribute
M1553 See Also

Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Trigger Pattern Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA 1150385

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternData property can be specified in the following format:

  • "nn...n", where n: {0 | 1 | X}

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:PATTern:DATA "{value}"
:SBUS{SerialBus}:M1553:TRIGger:PATTern:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA Attribute
M1553 See Also

Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Trigger RTA
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA 1150383

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerRTA property can be specified in one of the following formats:

  • "n", where n is an integer from 0-31
  • "#Hnn", where n: {0,..,9 | A,..,F}
  • "0xnn", where n: {0,..,9 | A,..,F}

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:RTA {value}
:SBUS{SerialBus}:M1553:TRIGger:RTA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH Attribute
M1553 See Also

The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Trigger Threshold High
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH 1150426

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW Attribute
M1553 See Also

The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Trigger Threshold Low
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW 1150427

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE Attribute
M1553 See Also

Specifies the type of MIL-STD 1553 trigger to be used.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\M1553\SerialBus M1553 Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE 1150384

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusM1553TriggerTypeDataStart - (Data Word Start) triggers on the start of a Data word (at the end of a valid Data Sync pulse).
  • AgInfiniiVisionSerialBusM1553TriggerTypeDataStop - (Data Word Stop) triggers on the end of a Data word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeCommandStart - (Command/Status Word Start) triggers on the start of Comamnd/Status word (at the end of a valid C/S Sync pulse).
  • AgInfiniiVisionSerialBusM1553TriggerTypeCommandStop - (Command/Status Word Stop) triggers on the end of a Command/Status word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeRTA - (Remote Terminal Address) triggers if the RTA of the Command/Status word matches the specified value. The value is specified in hex.
  • AgInfiniiVisionSerialBusM1553TriggerTypeRTA11 - (RTA + 11 Bits) triggers if the RTA and the remaining 11 bits match the specified criteria. The RTA can be specifed as a hex value, and the remaining 11 bits can be specifed as a 1, 0, or X (don't care).
  • AgInfiniiVisionSerialBusM1553TriggerTypeParityError - (Parity Error) triggers if the (odd) parity bit is incorrect for the data in the word.
  • AgInfiniiVisionSerialBusM1553TriggerTypeManchesterError - (Manchester Error) triggers if a Manchester encoding error is detected.
  • AgInfiniiVisionSerialBusM1553TriggerTypeSyncError - (Sync Error) triggers if an invalid Sync pulse is found.

Instrument Command

:SBUS{SerialBus}:M1553:TRIGger:TYPE {DSTA|DSTO|CSTA|CSTO|RTA|RTA11|PERR|MERR|SERR}
:SBUS{SerialBus}:M1553:TRIGger:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_DATA_START | (Data Word Start) triggers on the start of a Data word (at the end of a valid Data Sync pulse).
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_DATA_STOP | (Data Word Stop) triggers on the end of a Data word.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_COMMAND_START | (Command/Status Word Start) triggers on the start of Comamnd/Status word (at the end of a valid C/S Sync pulse).
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_COMMAND_STOP | (Command/Status Word Stop) triggers on the end of a Command/Status word.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPERTA | (Remote Terminal Address) triggers if the RTA of the Command/Status word matches the specified value. The value is specified in hex.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPERTA11 | (RTA + 11 Bits) triggers if the RTA and the remaining 11 bits match the specified criteria. The RTA can be specifed as a hex value, and the remaining 11 bits can be specifed as a 1, 0, or X (don't care).
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_PARITY_ERROR | (Parity Error) triggers if the (odd) parity bit is incorrect for the data in the word.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_MANCHESTER_ERROR | (Manchester Error) triggers if a Manchester encoding error is detected.
AGINFINIIVISION_VAL_SERIAL_BUSM1553_TRIGGER_TYPE_SYNC_ERROR | (Sync Error) triggers if an invalid Sync pulse is found.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

M1553
AgInfiniiVision


SENT

SENT
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT

Branches

Name
Trigger
Top

Functions

 | Name | Description
Function | Get Signal Display | This method specifies whether the given signal is on or off.
Function | Get Signal Length | Gets the bit length of the signal being defined.
Function | Get Signal Multiplier | Gets the multiplier value for the Fast Channel Signal.
Function | Get Signal Nibble Order | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | Get Signal Offset | Gets the offset value for the Fast Channel Signal.
Function | Get Signal Start Position | Gets the starting bit of the Fast Signal being defined.
Function | Set Signal Display | Set the given signal is on or off.
Function | Set Signal Length | Sets the bit length of the signal being defined.
Function | Set Signal Multiplier | Sets the multiplier value for the Fast Channel Signal.
Function | Set Signal Nibble Order | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | Set Signal Offset | Sets the offset value for the Fast Channel Signal.
Function | Set Signal Start Position | Sets the starting bit of the Fast Signal being defined.
Top

Attributes

 | Name | Description
Attribute | Clock | Sets and gets the nominal clock period (tick), from 1us to 300us.
Attribute | CRC Format | Set and get the format of the CRC.
Attribute | Format | Sets and gets the message decode/triggering format.
Attribute | Idle State | Sets and gets the idle state of the SENT bus.
Attribute | Number Base | Sets and gets the number base used by the decoder.
Attribute | Number Of Nibble | Sets and gets the number of nibbles in a SENT message, from 1 to 6.
Attribute | Pause Pulse | This command specifies whether the SENT messages are followed by a pause pulse.
Attribute | Source | Sets and gets the input channel for SENT decode and triggering.
Attribute | Tolerance | Sets and gets the tolerance for determing if the sync pulse is valid.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK Attribute
SENT See Also

Sets and gets the nominal clock period (tick), from 1us to 300us.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Clock
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK 1150615

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:CLOCk {value}
:SBUS{SerialBus}:SENT:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT Attribute
SENT See Also

Set and get the format of the CRC.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\CRC Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT 1150616

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Enhanced Serial Message CRCs are always calculated using the recommended format, but for the Fast Channel Messages, and for Short Serial Message CRCs, this setting is used.

Instrument Command

:SBUS{SerialBus}:SENT:CRC {LEG|REC}
:SBUS{SerialBus}:SENT:CRC?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENTCRC_LEGACY | Legacy.
AGINFINIIVISION_VAL_SERIAL_BUSSENTCRC_RECOMENDED | Recomended.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT Attribute
SENT See Also

Sets and gets the message decode/triggering format.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT 1150617

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • AgInfiniiVisionSerialBusSENTFormatNibbles - displays the raw transmitted nibble values.
  • AgInfiniiVisionSerialBusSENTFormatFSIGnal - displays Fast Channel Message Signals.
  • AgInfiniiVisionSerialBusSENTFormatFSSerial - displays both Fast and Slow Messages (Short format) simultaneously.
  • AgInfiniiVisionSerialBusSENTFormatFESerial - displays both Fast and Slow Messages (Enhanced format) simultaneously.
  • AgInfiniiVisionSerialBusSENTFormatSSERial - displays Slow Channel Messages in Short format.
  • AgInfiniiVisionSerialBusSENTFormatESERial - displays Slow Channel Messages in Enhanced format.

This selection affects both decoding and triggering. The decode is affected both in how the system interprets the data, and what will be displayed. The trigger is affected in that the trigger hardware needs to be configured to trigger on serial messages correctly.

Instrument Command

:SBUS{SerialBus}:SENT:FORMat {NIBB|FSIG|FSS|FES|SSER|ESER}
:SBUS{SerialBus}:SENT:FORMat?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMAT_NIBBLES | Shows the fast channel message in raw hex.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMATFSI_GNAL | Shows the defined Signals of the Fast Channel in Hex or Decimal based on the BASE command.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMATFS_SERIAL | Shows the Fast Signals and Short Serial Messages.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMATFE_SERIAL | Shows the Fast Signals and Enhanced Serial Messages.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMATSSE_RIAL | Shows only Short Serial Messages.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_FORMATESE_RIAL | Shows only Enhanced Serial Messages.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalDisplay Function

AgInfiniiVision_SerialBusSentGetSignalDisplay Function
SENT See Also

This method specifies whether the given signal is on or off.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Display
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalDisplay(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

SENT decode number base

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:DISPlay?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalLength Function

AgInfiniiVision_SerialBusSentGetSignalLength Function
SENT See Also

Gets the bit length of the signal being defined.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalLength(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

Signal bit length 1 to 6

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalMultiplier Function

AgInfiniiVision_SerialBusSentGetSignalMultiplier Function
SENT See Also

Gets the multiplier value for the Fast Channel Signal.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Multiplier
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalMultiplier(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

Multiplier value 1 to 24

Return Value

Success or failure code.

Remarks

The multiplier to be used in calculating a physical value displayed for a Fast Channel Signal.

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:MULTiplier?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalNibbleOrder Function

AgInfiniiVision_SerialBusSentGetSignalNibbleOrder Function
SENT See Also

Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Nibble Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalNibbleOrder(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

Nibble order 1 to 6.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:ORDer?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Val

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_SIGNAL_ORDERMSNF | Most Significant Nibble first.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_SIGNAL_ORDERLSNF | Least Significant Nibble first.
Top

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalOffset Function

AgInfiniiVision_SerialBusSentGetSignalOffset Function
SENT See Also

Gets the offset value for the Fast Channel Signal.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalOffset(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

Offset value 1 to 6.

Return Value

Success or failure code.

Remarks

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:OFFSet?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentGetSignalStartPosition Function

AgInfiniiVision_SerialBusSentGetSignalStartPosition Function
SENT See Also

Gets the starting bit of the Fast Signal being defined.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Get Signal Start Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentGetSignalStartPosition(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Val

Fast Signal starting bit 1 to 6

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:STARt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE Attribute
SENT See Also

Sets and gets the idle state of the SENT bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Idle State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE 1150620

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:IDLE {LOW|HIGH}
:SBUS{SerialBus}:SENT:IDLE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_IDLE_STATE_LOW | Low.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_IDLE_STATE_HIGH | High.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE Attribute
SENT See Also

Sets and gets the number base used by the decoder.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Number Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE 1150621

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The chosen base is used for the data nibbles in Raw decode format, the defined Signals in the other formats, and for the data field of the Serial Messages.

Instrument Command

:SBUS{SerialBus}:SENT:DISPlay {HEX|DEC|SYMB}
:SBUS{SerialBus}:SENT:DISPlay?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_NUMBER_BASE_HEX | Hex number.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_NUMBER_BASE_DECIMAL | Decimal number.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_NUMBER_BASE_SYMBOLIC | Symbolic.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE Attribute
SENT See Also

Sets and gets the number of nibbles in a SENT message, from 1 to 6.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Number Of Nibble
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE 1150622

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:LENGth {value}
:SBUS{SerialBus}:SENT:LENGth?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE Attribute
SENT See Also

This command specifies whether the SENT messages are followed by a pause pulse.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Pause Pulse
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE 1150623

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:PPULse {ON|OFF}
:SBUS{SerialBus}:SENT:PPULse?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalDisplay Function

AgInfiniiVision_SerialBusSentSetSignalDisplay Function
SENT See Also

Set the given signal is on or off.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Display
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalDisplay(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViBoolean StateEnabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

StateEnabled

True or false

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:DISPlay {ON|OFF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalLength Function

AgInfiniiVision_SerialBusSentSetSignalLength Function
SENT See Also

Sets the bit length of the signal being defined.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalLength(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32 Length
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Length

Length

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:LENGth {Length}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalMultiplier Function

AgInfiniiVision_SerialBusSentSetSignalMultiplier Function
SENT See Also

Sets the multiplier value for the Fast Channel Signal.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Multiplier
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalMultiplier(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViReal64 Multiplier
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Multiplier

Multiplier.

Return Value

Success or failure code.

Remarks

The multiplier to be used in calculating a physical value displayed for a Fast Channel Signal.

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:MULTiplier {Multiplier}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalNibbleOrder Function

AgInfiniiVision_SerialBusSentSetSignalNibbleOrder Function
SENT See Also

Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Nibble Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalNibbleOrder(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32 Order
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Order

Order.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:ORDer {MSNF|LSNF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Order

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_SIGNAL_ORDERMSNF | Most Significant Nibble first.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_SIGNAL_ORDERLSNF | Least Significant Nibble first.
Top

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalOffset Function

AgInfiniiVision_SerialBusSentSetSignalOffset Function
SENT See Also

Sets the offset value for the Fast Channel Signal.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Offset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalOffset(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViReal64 Offset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Offset

Offset.

Return Value

Success or failure code.

Remarks

When the display mode setting is SYMBolic (IAgInfiniiVision2SerialBus2SENT.NumberBase property), the IAgInfiniiVision2SerialBus2SENT.SignalOffset property is used in calculating a physical value displayed for the Fast Channel Signal:

PhysicalValue = (Multiplier * SignalValueAsUnsignedInteger) + Offset

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:OFFSet {Offset}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AgInfiniiVision_SerialBusSentSetSignalStartPosition Function

AgInfiniiVision_SerialBusSentSetSignalStartPosition Function
SENT See Also

Sets the starting bit of the Fast Signal being defined.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Set Signal Start Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SerialBusSentSetSignalStartPosition(
    ViSession Vi,
    ViConstString SerialBus,
    ViInt32 Index,
    ViInt32 Position
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the SerialBus repeated capability.

Index

From 1 to 6.

Position

Position.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:SENT:SIGNal{Index}:STARt {Position}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE Attribute
SENT See Also

Sets and gets the input channel for SENT decode and triggering.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE 1150619

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:SOURce {value}
:SBUS{SerialBus}:SENT:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE Attribute
SENT See Also

Sets and gets the tolerance for determing if the sync pulse is valid.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Tolerance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE 1150618

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values range from 3% to 30%.

Instrument Command

:SBUS{SerialBus}:SENT:TOLerance {value}
:SBUS{SerialBus}:SENT:TOLerane?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SENT
AgInfiniiVision


Trigger

Trigger
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger

Branches

Name
FastChannel
SlowChannel
Top

Attributes

 | Name | Description
Attribute | Mode | Sets and Gets the SENT trigger mode setting.
Attribute | Tolerance | Sets and Gets the tolerance variation percent setting.
Top

See Also

Reference

AgInfiniiVision


FastChannel

FastChannel
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\FastChannel

Attributes

 | Name | Description
Attribute | Data | Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA Attribute
FastChannel See Also

Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\FastChannel\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA 1150624

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The input format of string is

  • <Input String> :: = "nnnn..." where n :: = { 0 | 1 | X }

    • or

  • <Input String> :: = "0xn..." where n :: = { 0,..,9 | A,..,F | X |$}

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:FAST:DATA "{value}"
    :SBUS{SerialBus}:SENT:TRIGger:FAST:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    FastChannel
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE Attribute
Trigger See Also

Sets and Gets the SENT trigger mode setting.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE 1150661

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger {SFCM|SSCM|FCD|SCM|SCD|TOL|FCC|SCC|CRC|PPER|SSP}
:SBUS{SerialBus}:SENT:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_FAST_CHAN_MSG | SFCMessage — triggers on the start of any Fast Channel Message (after 56 Synchronization/Calibration ticks).
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_SLOW_CHAN_MSG | SSCMessage — trigger on the start of any Slow Channel Message.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_FAST_CHAN_SC_DATA | FCData — triggers on a Fast Channel Message when the Status & Communication nibble and the data nibbles match the values entered using additional softkeys.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_SLOW_CHAN_MSG_ID | SCMid — triggers when a Slow Channel Message ID matches the value entered using additional softkeys.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_SLOW_CHAN_MSG_ID_DATA | SCData — triggers when a Slow Channel Message ID and Data field both match the values entered using additional softkeys.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_TOLERANCE_ERR | TOLerror — triggers when the sync pulse width varies from the nominal value by greater than the entered percentage.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_FAST_CHAN_CRC_ERR | FCCerror — triggers on any Fast Channel Message CRC error.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_SLOW_CHAN_CRC_ERR | SCCerror — triggers on any Slow Channel Message CRC error.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_ALL_CRC_ERR | CRCerror — triggers on any CRC error, Fast or Slow.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_PULSE_PERIOD_ERR | PPERror — triggers if a nibble is either too wide or too narrow (for example, data nibble < 12 (11.5) or > 27 (27.5) ticks wide). Sync, S&C, data, or checksum pulse periods are checked.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGER_MODE_SYNC_PULSE_ERR | SSPerror — triggers on a sync pulse whose width varies from the previous sync pulse's width by greater than 1/64 (1.5625%, as defined in the SENT specification).
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Trigger
AgInfiniiVision


SlowChannel

SlowChannel
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\SlowChannel

Attributes

 | Name | Description
Attribute | Data | Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.
Attribute | ID | Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.
Attribute | ID Data Length | Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA Attribute
SlowChannel See Also

Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\SlowChannel\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA 1150625

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The format of Data is look like

  • <Data> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthShort, from -1 (don't care) to 65535, in NR1 format.
  • <Data> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthLong, from -1 (don't care) to 4096, in NR1 format.

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:SLOW:DATA {value}
    :SBUS{SerialBus}:SENT:TRIGger:SLOW:DATA?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    SlowChannel
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID Attribute
SlowChannel See Also

Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\SlowChannel\ID
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID 1150626

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The format of ID is look like

  • <ID> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthShort, from -1 (don't care) to 15, in NR1 format.
  • <ID> :: = when IAgInfiniiVisionSerialBus3SENTTriggerSlowChannel.IDDataLength = AgInfiniiVisionSerialBusSENTTriggerIDLengthLong, from -1 (don't care) to 255, in NR1 format.

    • Instrument Command

    :SBUS{SerialBus}:SENT:TRIGger:SLOW:ID {value}
    :SBUS{SerialBus}:SENT:TRIGger:SLOW:ID?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    SlowChannel
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH Attribute
SlowChannel See Also

Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\SlowChannel\ID Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH 1150627

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger:SLOW:ILENgth {SHOR|LONG}
:SBUS{SerialBus}:SENT:TRIGger:SLOW:ILENgth?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGERID_LENGTH_SHORT | "SHORt" the 16-bit data, 4-bit ID format.
AGINFINIIVISION_VAL_SERIAL_BUSSENT_TRIGGERID_LENGTH_LONG | "LONG" for the 12-bit data, 8-bit ID format.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SlowChannel
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE Attribute
Trigger See Also

Sets and Gets the tolerance variation percent setting.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SENT\Trigger\Tolerance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE 1150657

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Value ::= from 1-28, in NR1 format.

Instrument Command

:SBUS{SerialBus}:SENT:TRIGger:TOLerance {value}
:SBUS{SerialBus}:SENT:TRIGger:TOLerance?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_COUNT Attribute
SerialBus See Also

Attribute that contains the number of Serial Buses available on the instrument. This is the maximum index that may be used with the GetSerialBusName() function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SerialBus Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_COUNT 1150272

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

SerialBus
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_ENABLED Attribute

AGINFINIIVISION_ATTR_SERIALBUS_ENABLED Attribute
SerialBus See Also

Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SerialBus Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_ENABLED 1150350

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This property is only valid when a serial decode option has been licensed.
Two I2S buses or two SPI buses cannot be decoded on both SerialBus1 and SerialBus2 at the same time.

Instrument Command

:SBUS{SerialBus}:DISPlay {ON|OFF}
:SBUS{SerialBus}:DISPlay?

Requirements

Supported Models

All supported

See Also

Reference

SerialBus
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_MODE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_MODE Attribute
SerialBus See Also

Determines the decode mode for the serial bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SerialBus Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_MODE 1150273

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Mode property can be set to one of the following values:

  • AgInfiniiVisionSerialBusModeCAN - CAN mode
  • AgInfiniiVisionSerialBusModeI2S - I2S mode
  • AgInfiniiVisionSerialBusModeIIC - IIC mode
  • AgInfiniiVisionSerialBusModeLIN - LIN mode
  • AgInfiniiVisionSerialBusModeSPI - SPI mode
  • AgInfiniiVisionSerialBusModeUART - UART mode
  • AgInfiniiVisionSerialBusModeARINC429 - ARINC 429 mode
  • AgInfiniiVisionSerialBusModeM1553 - MIL-STD 1553 mode
  • AgInfiniiVisionSerialBusModeFlexRay - FlexRay mode
  • AgInfiniiVisionSerialBusModeSENT - SENT mode

In addition to the above values, the current serial bus decode mode setting can also return the following value:
  • AgInfiniiVisionSerialBusModeNONE

This property is only valid when a serial decode option has been licensed.

Instrument Command

:SBUS{SerialBus}:MODE {CAN|I2S|IIC|LIN|SPI|UART|NONE|A429|M1553|FLEX|USB|SENT}
:SBUS{SerialBus}:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUS_MODECAN | CAN mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEI2S | I2S mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEIIC | IIC mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODELIN | LIN mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODESPI | SPI mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEUART | UART mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODE_NONE | None.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEARINC429 | ARINC 429 Mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEM1553 | MIL-STD 1553 Mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODE_FLEX_RAY | FlexRay mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODEUSB | USB Mode.
AGINFINIIVISION_VAL_SERIAL_BUS_MODESENT | SENT Mode.
Top

Requirements

Supported Models

All supported

See Also

Reference

SerialBus
AgInfiniiVision


SPI

SPI
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI

Attributes

 | Name | Description
Attribute | SerialBus SPI Bit Order | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Attribute | SerialBus SPI Clock Slope | Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Attribute | SerialBus SPI Clock Source | Specifies the source for the SPI serial clock.
Attribute | SerialBus SPI Clock Timeout | Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.
Attribute | SerialBus SPI Frame Source | Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.
Attribute | SerialBus SPI Framing | Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.
Attribute | SerialBus SPI MISO Source | Specifies the source for the SPI serial MISO data.
Attribute | SerialBus SPI MOSI Source | Specifies the source for the SPI serial MOSI data.
Attribute | SerialBus SPI Trigger PatternMISO Data | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | SerialBus SPI Trigger PatternMISO Width | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | SerialBus SPI Trigger PatternMOSI Data | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | SerialBus SPI Trigger PatternMOSI Width | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | SerialBus SPI Trigger Type | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Attribute | SerialBus SPI Width | Specifies the number of bits in a word of data for SPI.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER Attribute
SPI See Also

Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Bit Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER 1150317

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The BitOrder property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPIBitOrderLSBF - Least Significant Bit First
  • AgInfiniiVisionSerialBusSPIBitOrderMSBF - Most Significant Bit First

Instrument Command

:SBUS{SerialBus}:SPI:BITorder {LSBF|MSBF}
:SBUS{SerialBus}:SPI:BITorder?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSPI_BIT_ORDERLSB_FIRST | LSB first.
AGINFINIIVISION_VAL_SERIAL_BUSSPI_BIT_ORDERMSB_FIRST | MSB first.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE Attribute
SPI See Also

Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Clock Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE 1150318

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPIClockSlopeNegative - falling edge
  • AgInfiniiVisionSerialBusSPIClockSlopePositive - rising edge

Instrument Command

:SBUS{SerialBus}:SPI:CLOCk:SLOPe {NEG|POS}
:SBUS{SerialBus}:SPI:CLOCk:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSPI_CLOCK_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_SERIAL_BUSSPI_CLOCK_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE Attribute
SPI See Also

Specifies the source for the SPI serial clock.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE 1150321

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:CLOCk {value}
:SBUS{SerialBus}:SPI:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT Attribute
SPI See Also

Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Clock Timeout
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT 1150319

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SPI:CLOCk:TIMeout {value}
:SBUS{SerialBus}:SPI:CLOCk:TIMeout?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE Attribute
SPI See Also

Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Frame Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE 1150323

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The FrameSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:FRAMe {value}
:SBUS{SerialBus}:SPI:SOURce:FRAMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING Attribute
SPI See Also

Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Framing
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING 1150320

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:SPI:FRAMing {CHIP|NCH|TIM}
:SBUS{SerialBus}:SPI:FRAMing?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSPI_FRAMING_CHIP_SELECT | Chip Select.
AGINFINIIVISION_VAL_SERIAL_BUSSPI_FRAMINGN_CHIP_SELECT | Not Chip select
AGINFINIIVISION_VAL_SERIAL_BUSSPI_FRAMING_TIMEOUT | Timeout.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE Attribute
SPI See Also

Specifies the source for the SPI serial MISO data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI MISO Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE 1150324

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The MISOSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:MISO {value}
:SBUS{SerialBus}:SPI:SOURce:MISO?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE Attribute
SPI See Also

Specifies the source for the SPI serial MOSI data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI MOSI Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE 1150325

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The MOSISource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:SPI:SOURce:MOSI {value}
:SBUS{SerialBus}:SPI:SOURce:MOSI?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA Attribute
SPI See Also

Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Trigger PatternMISO Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA 1150326

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternMISOData can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

The TriggerPatternMISOWidth property should be set before the TriggerPatternMISOData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:DATA "{value}"
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH Attribute
SPI See Also

Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Trigger PatternMISO Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH 1150327

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 4 to 64.

The TriggerPatternMISOWidth property should be set before the TriggerPatternMISOData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:WIDTh {value}
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MISO:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA Attribute
SPI See Also

Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Trigger PatternMOSI Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA 1150328

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerPatternMOSIData can be specified in one of the following string formats:

  • "nn...n", where n: {0 | 1 | X | $}
  • "0xnn...n", where n: {0,..,9 | A,..,F | X | $}

If the string parameter starts with "0x", it is a hexadecimal string made up of hexadecimal and X (don't care) characters; otherwise, it is a binary string made up of 0, 1, and X (don't care) characters.

The TriggerPatternMOSIWidth property should be set before the TriggerPatternMOSIData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:DATA "{value}"
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH Attribute
SPI See Also

Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Trigger PatternMOSI Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH 1150329

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 4 to 64.

The TriggerPatternMOSIWidth property should be set before the TriggerPatternMOSIData

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:WIDTh {value}
:SBUS{SerialBus}:SPI:TRIGger:PATTern:MOSI:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE Attribute
SPI See Also

Specifies whether the SPI trigger will be on the MOSI data or the MISO data.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE 1150330

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusSPITriggerTypeMOSI - MOSI
  • AgInfiniiVisionSerialBusSPITriggerTypeMISO - MISO

When triggering on MOSI data , the data value is specified by the TriggerPatternMOSIData and TriggerPatternMOSIWidth properties.

When triggering on MISO data , the data value is specified by the TriggerPatternMISOData and TriggerPatternMISOWidth properties.

Instrument Command

:SBUS{SerialBus}:SPI:TRIGger:TYPE {MOSI|MISO}
:SBUS{SerialBus}:SPI:TRIGger:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSSPI_TRIGGER_TYPEMOSI | SPI trigger will be on the MOSI data.
AGINFINIIVISION_VAL_SERIAL_BUSSPI_TRIGGER_TYPEMISO | SPI trigger will be on the MISO data.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH Attribute
SPI See Also

Specifies the number of bits in a word of data for SPI.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\SPI\SerialBus SPI Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH 1150331

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are fomr 4-16

Instrument Command

:SBUS{SerialBus}:SPI:WIDTh {value}
:SBUS{SerialBus}:SPI:WIDTh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

SPI
AgInfiniiVision


UART

UART
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART

Functions

 | Name | Description
Function | Reset Serial BusUART Counters | This method resets the UART frame counters.
Top

Attributes

 | Name | Description
Attribute | SerialBus UART Base | Specifies the base to use for the UART decode and Lister display.
Attribute | SerialBus UART Baud Rate | Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.
Attribute | SerialBus UART Bit Order | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Attribute | SerialBus UART Error Count | Read Only - Gets the UART error frame count.
Attribute | SerialBus UART Framing | Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.
Attribute | SerialBus UART Parity | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Attribute | SerialBus UART Polarity | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Attribute | SerialBus UART Rx Frame Count | Read Only - Gets the UART Rx frame count.
Attribute | SerialBus UART Rx Source | Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.
Attribute | SerialBus UART Trigger Base | Specifies the front panel UART/RS232 trigger setup data selection.
Attribute | SerialBus UART Trigger Burst | Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.
Attribute | SerialBus UART Trigger Condition | Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.
Attribute | SerialBus UART Trigger Data | Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.
Attribute | SerialBus UART Trigger Idle Time | Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.
Attribute | SerialBus UART Trigger Type | Specifies the UART Trigger Type
Attribute | SerialBus UART Tx Frame Count | Read Only - Gets the UART Tx frame count.
Attribute | SerialBus UART Tx Source | Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.
Attribute | SerialBus UART Width | Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ResetSerialBusUARTCounters Function

AgInfiniiVision_ResetSerialBusUARTCounters Function
UART See Also

This method resets the UART frame counters.

Function Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\Reset Serial BusUART Counters
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetSerialBusUARTCounters(
    ViSession Vi,
    ViConstString SerialBus
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SerialBus

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single serialbus.For valid values, see the SerialBus repeated capability.

Return Value

Success or failure code.

Instrument Command

:SBUS{SerialBus}:UART:COUNt:RESet

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE Attribute
UART See Also

Specifies the base to use for the UART decode and Lister display.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE 1150332

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Base property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTBaseASCII - ASCII
  • AgInfiniiVisionSerialBusUARTBaseBinary - Binary
  • AgInfiniiVisionSerialBusUARTBaseHexadecimal - Hexadecimal

Instrument Command

:SBUS{SerialBus}:UART:BASE {ASC|BIN|HEX}
:SBUS{SerialBus}:UART:BASE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_BASEASCII | ASCII base
AGINFINIIVISION_VAL_SERIAL_BUSUART_BASE_BINARY | Binary base.
AGINFINIIVISION_VAL_SERIAL_BUSUART_BASE_HEXADECIMAL | Hexadecimal base.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE Attribute
UART See Also

Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Baud Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE 1150333

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.

Valid values are from 1200 to 8000000 in 100b/s increments.

If the baud rate you select does not match the system baud rate, false triggers may occur.

Instrument Command

:SBUS{SerialBus}:UART:BAUDrate {value}
:SBUS{SerialBus}:UART:BAUDrate?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER Attribute
UART See Also

Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Bit Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER 1150334

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The BitOrder property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTBitOrderMSBFirst - MSB First
  • AgInfiniiVisionSerialBusUARTBitOrderLSBFirst - LSB First

AgInfiniiVisionSerialBusUARTBitOrderLSBFirst sets the least significant bit of each message "byte" as transmitted first. AgInfiniiVisionSerialBusUARTBitOrderMSBFirst sets the most significant bit as transmitted first.

Instrument Command

:SBUS{SerialBus}:UART:BITorder {LSBF|MSBF}
:SBUS{SerialBus}:UART:BITorder?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_BIT_ORDERLSB_FIRST | LSB first.
AGINFINIIVISION_VAL_SERIAL_BUSUART_BIT_ORDERMSB_FIRST | MSB first.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT Attribute
UART See Also

Read Only - Gets the UART error frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Error Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT 1150335

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:UART:COUNt:ERRor?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING Attribute
UART See Also

Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Framing
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING 1150338

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Framing property can be specified in one of the following formats:

  • "OFF"
  • "n", where n: 8-bit integer in decimal from 0 - 255
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 - 0xff
  • "#Bnn..n", where n: {0 | 1}

Instrument Command

:SBUS{SerialBus}:UART:FRAMing {value}
:SBUS{SerialBus}:UART:FRAMing?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY Attribute
UART See Also

Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Parity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY 1150339

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Parity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTParityEven - Even parity
  • AgInfiniiVisionSerialBusUARTParityOdd - Odd parity
  • AgInfiniiVisionSerialBusUARTParityNone - No parity

Instrument Command

:SBUS{SerialBus}:UART:PARity {EVEN|ODD|NONE}
:SBUS{SerialBus}:UART:PARity?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_PARITY_EVEN | Even parity.
AGINFINIIVISION_VAL_SERIAL_BUSUART_PARITY_ODD | Odd parity.
AGINFINIIVISION_VAL_SERIAL_BUSUART_PARITY_NONE | No parity.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY Attribute
UART See Also

Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY 1150340

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Polarity property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTPolarityHigh - High polarity
  • AgInfiniiVisionSerialBusUARTPolarityLow - Low polarity

Instrument Command

:SBUS{SerialBus}:UART:POLarity {HIGH|LOW}
:SBUS{SerialBus}:UART:POLarity?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_POLARITY_HIGH | High polarity.
AGINFINIIVISION_VAL_SERIAL_BUSUART_POLARITY_LOW | Low polarity.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT Attribute
UART See Also

Read Only - Gets the UART Rx frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Rx Frame Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT 1150336

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:UART:COUNt:RXFRames?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE Attribute
UART See Also

Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Rx Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE 1150341

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The RxSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:UART:SOURce:RX {value}
:SBUS{SerialBus}:UART:SOURce:RX?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE Attribute
UART See Also

Specifies the front panel UART/RS232 trigger setup data selection.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE 1150343

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerBase property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerBaseASCII - front panel data selection is from ASCII values
  • AgInfiniiVisionSerialBusUARTTriggerBaseHexadecimal - front panel data selection is from hexadecimal values

The TriggerBase property does not affect the TriggerData property which can always setdata values using ASCII or hexadecimal values.

The TriggerBase property is independent of the Base property which affects decode and Lister only.

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:BASE {ASC|HEX}
:SBUS{SerialBus}:UART:TRIGger:BASE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_BASEASCII | Front panel data selection is from ASCII values.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_BASE_HEXADECIMAL | Front panel data selection is from hexadecimal values.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST Attribute
UART See Also

Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Burst
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST 1150344

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerBurst property can be specified in one of the following formats:

  • "Off"
  • "n", where n is integer from 1 to 4096

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:BURSt {value}
:SBUS{SerialBus}:UART:TRIGger:BURSt?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION Attribute
UART See Also

Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION 1150347

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerCondition property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerConditionEqual - Equal
  • AgInfiniiVisionSerialBusUARTTriggerConditionNotEqual - Not Equal
  • AgInfiniiVisionSerialBusUARTTriggerConditionGreaterThan - Greater Than
  • AgInfiniiVisionSerialBusUARTTriggerConditionLessThan - Less Than

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:QUALifier {EQU|NOT|GRE|LESS}
:SBUS{SerialBus}:UART:TRIGger:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_CONDITION_EQUAL | Equal to the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_CONDITION_NOT_EQUAL | Not equal to the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_CONDITION_GREATER_THAN | Greater than the specified value.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_CONDITION_LESS_THAN | Less than the specified value.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA Attribute
UART See Also

Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA 1150345

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerData property can be specified in one of the following string formats:

  • "n", where n: 8-bit integer from 0-255
  • "#Hnn", where n: {0,..,9 | A,..,F} from 0x00 to 0xff
  • "0xnn", where n: {0,..,9 | A,..,F} from 0x00 to 0xff
  • "#Bnn..n", where n: {0 | 1}
  • any of the 128 valid 7-bit ASCII characters (or standard abbreviations)

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:DATA {value}
:SBUS{SerialBus}:UART:TRIGger:DATA?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME Attribute
UART See Also

Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Idle Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME 1150346

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:IDLE {value}
:SBUS{SerialBus}:UART:TRIGger:IDLE?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE Attribute
UART See Also

Specifies the UART Trigger Type

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE 1150348

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TriggerType property can be set to one of the following values:

  • AgInfiniiVisionSerialBusUARTTriggerTypeRStart - RStart
  • AgInfiniiVisionSerialBusUARTTriggerTypeRStop - RStop
  • AgInfiniiVisionSerialBusUARTTriggerTypeRData - RData
  • AgInfiniiVisionSerialBusUARTTriggerTypeRD1 - RD1
  • AgInfiniiVisionSerialBusUARTTriggerTypeRD0 - RD0
  • AgInfiniiVisionSerialBusUARTTriggerTypeRDX - RDX
  • AgInfiniiVisionSerialBusUARTTriggerTypeParityError - Parity Error
  • AgInfiniiVisionSerialBusUARTTriggerTypeTStart - TStart
  • AgInfiniiVisionSerialBusUARTTriggerTypeTStop - TStop
  • AgInfiniiVisionSerialBusUARTTriggerTypeTData - TData
  • AgInfiniiVisionSerialBusUARTTriggerTypeTD1 - TD1
  • AgInfiniiVisionSerialBusUARTTriggerTypeTD0 - TD0
  • AgInfiniiVisionSerialBusUARTTriggerTypeTDX - TDX

When one of the RD or TD types is selected, the TriggerData and TriggerCondition properties are used to specify the data value and comparison operator.

The RD1, RD0, RDX, TD1, TD0, and TDX types (for triggering on data and alert bit values) are only valid when a 9-bit width has been selected.

Instrument Command

:SBUS{SerialBus}:UART:TRIGger:TYPE {RSTA|RSTO|RDAT|RD1|RD0|RDX|PAR|TSTA|TSTO|TDAT|TD1|TD0|TDX}
:SBUS{SerialBus}:UART:TRIGger:TYPE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPER_START | RStart trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPER_STOP | RStop trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPER_DATA | RData trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPERD1 | RD1 trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPERD0 | RD0 trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPERDX | RDX trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPE_PARITY_ERROR | Parity Error trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPET_START | TStart trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPET_STOP | TStop trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPET_DATA | TData trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPETD1 | TD1 trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPETD0 | TD0 trigger type.
AGINFINIIVISION_VAL_SERIAL_BUSUART_TRIGGER_TYPETDX | TDX trigger type.
Top

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT Attribute
UART See Also

Read Only - Gets the UART Tx frame count.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Tx Frame Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT 1150337

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:SBUS{SerialBus}:UART:COUNt:TXFRames?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE Attribute
UART See Also

Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Tx Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE 1150342

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The TxSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1. For 2000X series DigitalChannels are not supported as source.

Instrument Command

:SBUS{SerialBus}:UART:SOURce:TX {value}
:SBUS{SerialBus}:UART:SOURce:TX?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH Attribute
UART See Also

Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\UART\SerialBus UART Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH 1150349

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Valid values are from 5 to 9

Instrument Command

:SBUS{SerialBus}:UART:WIDTh {value}
:SBUS{SerialBus}:UART:WIDTh?

Requirements

Supported Models

All supported

See Also

Reference

UART
AgInfiniiVision


USB

USB
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB

Attributes

 | Name | Description
Attribute | Address | Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.
Attribute | Base | Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.
Attribute | Condition | Specifies USB trigger mode for the selected bus.
Attribute | CRC | Specifies the CRC portion of the trigger for the selected bus, in binary or hex.
Attribute | Data | Specifies the Data portion of the trigger for the selected bus, in binary or hex.
Attribute | Data Length | Specifies the data length in bytes.
Attribute | Differential Source | Specifies which signal is used as the differential source for the selected bus.
Attribute | DMinus Source | Specifies which signal is used as the USB D- source for the selected bus.
Attribute | DPlus Source | Specifies which signal is used as the USB D+ source for the selected bus.
Attribute | End Point | Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.
Attribute | ET | Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.
Attribute | Frame | Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.
Attribute | Hub Address | Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.
Attribute | PID Check | Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.
Attribute | PID Data | Specifies the USB data PID to trigger on for the selected bus.
Attribute | PID Handshake | Specifies the USB handshake PID to trigger on for the selected bus.
Attribute | PID Special | Specifies the USB special PID to trigger on for the selected bus
Attribute | PID Token | Specifies the USB token PID to trigger on for the selected bus.
Attribute | Port | Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.
Attribute | SC | Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.
Attribute | SEU | Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.
Attribute | Speed | Specifies the speed of the USB interface for the selected bus.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS Attribute
USB See Also

Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS 1150476

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ADDRess {value}
:SBUS{SerialBus}:USB:TRIGger:ADDRess?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE Attribute
USB See Also

Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Base
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE 1150471

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • All other fields are displayed in hex.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:BASE {ASC|BIN|DEC|HEX}
    :SBUS{SerialBus}:USB:BASE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUSB_BASEASCII | ASCII values.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_BASE_BINARY | Binary values.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_BASE_DECIMAL | Decimal values.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_BASE_HEXADECIMAL | Hexadecimal values.
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION Attribute
USB See Also

Specifies USB trigger mode for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION 1150470

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.Condition property.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger {SOP|EOP|ENT|EXIT|RES|TOK|DATA|HAND|SPEC|ALL|PID|CRC5|CRC16|GLIT|STUFF|SE1}
:SBUS{SerialBus}:USB:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_START_OF_PACKET | Start of packet.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_END_OF_PACKET | End of packet.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_ENTER_SUSPEND | Enter suspend state.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_EXIT_SUSPEND | Exit suspend state.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_RESET | Reset complete.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_TOKEN | Token.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_DATA | Data state.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_HANDSHAKE | Handshake.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_SPECIAL | Special
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_ALL_ERRORS | All errors.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_PACKETID_ERROR | Packet ID error
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITIONCRC5_ERROR | CRC5 error.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITIONCRC16_ERROR | CRC6 error.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_GLITCH_ERROR | Glitch error.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITION_STUFF_ERROR | Stuff error.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_CONDITIONSE1_ERROR | SE1 error.
Top

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC Attribute
USB See Also

Specifies the CRC portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\CRC
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC 1150477

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:CRC {value}
:SBUS{SerialBus}:USB:TRIGger:CRC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA Attribute
USB See Also

Specifies the Data portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA 1150478

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn..." where n = {0 | 1 | X}
    • "0xn..." where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:DATA {value}
:SBUS{SerialBus}:USB:TRIGger:DATA?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH Attribute
USB See Also

Specifies the data length in bytes.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Data Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH 1150479

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • It range is from 1 to 20.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:DATA:LENGth {value}
    :SBUS{SerialBus}:USB:TRIGger:DATA:LENGth?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE Attribute
USB See Also

Specifies which signal is used as the differential source for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Differential Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE 1150474

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • "Channel<n>", where <n> can be from 1 to the number of analog channels.

    • NOTE: Only supported for 4000X and 6000X series models.

    Instrument Command

    :SBUS{SerialBus}:USB:SOURce:DIFFerential {value}
    :SBUS{SerialBus}:USB:SOURce:DIFFerential?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE Attribute
USB See Also

Specifies which signal is used as the USB D- source for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\DMinus Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE 1150472

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DMinusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.DMinusSource property.

Instrument Command

:SBUS{SerialBus}:USB:SOURce:DMINus {value}
:SBUS{SerialBus}:USB:SOURce:DMINus?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE Attribute
USB See Also

Specifies which signal is used as the USB D+ source for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\DPlus Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE 1150473

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DPlusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.DPlusSource property.

Instrument Command

:SBUS{SerialBus}:USB:SOURce:DPLus {value}
:SBUS{SerialBus}:USB:SOURce:DPLus?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT Attribute
USB See Also

Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\End Point
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT 1150480

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ENDPoint {value}
:SBUS{SerialBus}:USB:TRIGger:ENDPoint?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_ET Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_ET Attribute
USB See Also

Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\ET
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_ET 1150481

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_ET.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:ET {value}
:SBUS{SerialBus}:USB:TRIGger:ET?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME Attribute
USB See Also

Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Frame
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME 1150482

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnnnnnn" where n = {0 | 1 | X}
    • "0xnnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:FRAMe {value}
:SBUS{SerialBus}:USB:TRIGger:FRAMe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS Attribute
USB See Also

Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Hub Address
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS 1150483

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:HADDress {value}
:SBUS{SerialBus}:USB:TRIGger:HADDress?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK Attribute
USB See Also

Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\PID Check
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK 1150484

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:PCHeck {value}
:SBUS{SerialBus}:USB:TRIGger:PCHeck?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA Attribute
USB See Also

Specifies the USB data PID to trigger on for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\PID Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA 1150485

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The DATA USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:DATA {DATA0|DATA1|DATA2|MDAT}
    :SBUS{SerialBus}:USB:TRIGger:PID:DATA?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_DATA_DATA0 | DATA0
AGINFINIIVISION_VAL_PID_DATA_DATA1 | DATA1
AGINFINIIVISION_VAL_PID_DATA_DATA2 | DATA2
AGINFINIIVISION_VAL_PID_DATAM_DATA | MDATA
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE Attribute
USB See Also

Specifies the USB handshake PID to trigger on for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\PID Handshake
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE 1150486

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The HANDshake USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:HANDshake {ACK|NAK|STALL|NYET}
    :SBUS{SerialBus}:USB:TRIGger:PID:HANDshake?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_HANDSHAKEACK | ACK Handshake.
AGINFINIIVISION_VAL_PID_HANDSHAKENAK | NAK Handshake
AGINFINIIVISION_VAL_PID_HANDSHAKESTALL | STALL Handshake.
AGINFINIIVISION_VAL_PID_HANDSHAKENYET | NYET (No Response Yet)
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL Attribute
USB See Also

Specifies the USB special PID to trigger on for the selected bus

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\PID Special
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL 1150487

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The SPECial USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:SPECial {PING|PRE|ERR|SPLIT}
    :SBUS{SerialBus}:USB:TRIGger:PID:SPECial?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_SPECIAL_PING | Ping.
AGINFINIIVISION_VAL_PID_SPECIAL_PREAMBLE | Preamble.
AGINFINIIVISION_VAL_PID_SPECIALERR | ERR.
AGINFINIIVISION_VAL_PID_SPECIAL_SPLIT | Split.
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN Attribute
USB See Also

Specifies the USB token PID to trigger on for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\PID Token
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN 1150488

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The specified PID does not include the PID check value, which is specified using the PIDCheck property.
  • The TOKen USB trigger mode can be selected using the Condition property.

    NOTE: Only supported for 4000X and 6000X series models.

    • Instrument Command

    :SBUS{SerialBus}:USB:TRIGger:PID:TOKen {OUT|IN|SET|SOF}
    :SBUS{SerialBus}:USB:TRIGger:PID:TOKen?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_PID_TOKEN_OUT | OUT Token.
AGINFINIIVISION_VAL_PID_TOKEN_IN | IN Token.
AGINFINIIVISION_VAL_PID_TOKEN_SETUP | SETUP Token.
AGINFINIIVISION_VAL_PID_TOKEN_SOF | SOF Token.
    Top

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    USB
    AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT Attribute
USB See Also

Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Port
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT 1150489

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nnnnnnn" where n = {0 | 1 | X}
    • "0xnn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:PORT {value}
:SBUS{SerialBus}:USB:TRIGger:PORT?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_SC Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_SC Attribute
USB See Also

Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\SC
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_SC 1150490

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_SC.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "n" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:SC {value}
:SBUS{SerialBus}:USB:TRIGger:SC?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU Attribute
USB See Also

Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\SEU
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU 1150491

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Its value can be in binary format or in hexadecimal format.
    • "nn" where n = {0 | 1 | X}
    • "0xn" where n ::= {0,..,9 | A,..,F | X | $}

NOTE: Only supported for 4000X and 6000X series models.

Instrument Command

:SBUS{SerialBus}:USB:TRIGger:SEU {value}
:SBUS{SerialBus}:USB:TRIGger:SEU?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED Attribute

AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED Attribute
USB See Also

Specifies the speed of the USB interface for the selected bus.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\SerialBus\USB\Speed
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED 1150475

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the SerialBus repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

NOTE: Only supported for 4000X and 6000X series models. For 2000x/3000x series use Trigger.USB.Speed property.

Instrument Command

:SBUS{SerialBus}:USB:SPEed {LOW|FULL|HIGH}
:SBUS{SerialBus}:USB:SPEed?

Defined Values

Name | Description
AGINFINIIVISION_VAL_SERIAL_BUSUSB_SPEED_LOW | Low speed for USB interface.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_SPEED_FULL | Full speed for USB interface.
AGINFINIIVISION_VAL_SERIAL_BUSUSB_SPEED_HIGH | High speed for USB interface.
Top

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

USB
AgInfiniiVision


Status

Status
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Status

Functions

 | Name | Description
Function | Status Clear | Clears all event registers and error queue. The enable registers are unaffected.
Function | Status Configure Service Request | Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.
Function | Status Get Register | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Function | Status Preset | Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.
Function | Status Set Register | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Top

Attributes

 | Name | Description
Attribute | Status Serial Poll | Read Only - Serial poll the instrument status byte.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_StatusClear Function

AgInfiniiVision_StatusClear Function
Status See Also

Clears all event registers and error queue. The enable registers are unaffected.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Clear
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StatusClear(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

*CLS

Requirements

Supported Models

All supported

See Also

Reference

Status
AgInfiniiVision


AgInfiniiVision_StatusConfigureServiceRequest Function

AgInfiniiVision_StatusConfigureServiceRequest Function
Status See Also

Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Configure Service Request
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StatusConfigureServiceRequest(
    ViSession Vi,
    ViInt32 Reason
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Reason

The defined values are powers of two, 1, 2, 4, etc. The client can OR several reasons together so multiple events can generate a service request.

Return Value

Success or failure code.

Remarks

All other events are disabled from generating a service request. To detect a service request the client application must poll the status byte using the Status.SerialPoll method or Status.Register property and test the request service bit.

Instrument Command

*CLS;*SRE;*ESE;:OPEE;:OVL

Requirements

Supported Models

All supported

Defined Values For Parameter Reason

Name | Description
AGINFINIIVISION_VAL_SRQ_REASON_STB_MAV3 | Message Available. Bit 4 in the status byte.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_STB_USR | An enabled user event condition has occurred. Bit 1 of Status Byte Register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_STB_MSG | An advisory has been displayed on the oscilloscope. Bit 2 of Status Byte Register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_STBTRIG | A trigger has occurred. Bit 0 of Status Byte Register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_OPC3 | Operation Complete. Bit 0 of the standard event status register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_QUERY_ERROR3 | Query Error. Bit 2 of the standard event status register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_DEVICE_ERROR3 | Device Dependent Error. Bit 3 of the standard event status register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_EXECUTION_ERROR3 | Execution Error. Bit 4 of the standard event status register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_COMMAND_ERROR3 | Command Error. Bit 5 of the standard event status register.
AGINFINIIVISION_VAL_SRQ_REASON_ESR_USER_REQUEST3 | User Request. Bit 6 of the standard event status register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_ESR_REQUEST_CONTROL | The device is requesting control. Bit 1 of Standard Event Status Register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_ESR_POWER_ON | An OFF to ON transition has occurred. Bit 7 of Standard Event Status Register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OPER_RUN | The oscilloscope has gone from a stop state to a single or running state. Bit 3 of Operation Status Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OPER_AER_WAITTRIG | The trigger is armed. Bit 5 of Operation Status Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL1_FAULT | Fault has occurred on Channel 1 input. Bit 6 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL2_FAULT | Fault has occurred on Channel 2 input. Bit 7 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL3_FAULT | Fault has occurred on Channel 3 input. Bit 8 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL4_FAULT | Fault has occurred on Channel 4 input. Bit 9 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_EXTERNAL_TRIGGER_FAULT | Bit 10 of overload event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL1_OVERLOAD | Overload has occurred on Channel 1 input. Bit 0 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL2_OVERLOAD | Overload has occurred on Channel 2 input. Bit 1 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL3_OVERLOAD | Overload has occurred on Channel 3 input. Bit 2 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_CHANNEL4_OVERLOAD | Overload has occurred on Channel 4 input. Bit 3 of Overload Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_OVLR_EXTERNAL_TRIGGER_OVERLOAD | Bit 4 of overload event register
AGINFINIIVISION_VAL_STATUSSRQ_REASON_MTER_COMPLETE | The mask test is complete. Bit 0 of Mask Test Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_MTER_FAIL | The mask test failed. Bit 1 of Mask Test Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_MTER_STARTED | Mask testing started. Bit 8 of Mask Test Event register.
AGINFINIIVISION_VAL_STATUSSRQ_REASON_MTER_AUTO_MASK | Auto mask creation completed. Bit 10 of Mask Test Event register.
Top

See Also

Reference

Status
AgInfiniiVision


AgInfiniiVision_StatusGetRegister Function

AgInfiniiVision_StatusGetRegister Function
Status See Also

The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Get Register
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StatusGetRegister(
    ViSession Vi,
    ViInt32 Register,
    ViInt32 SubRegister,
    ViInt32* RetVal
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Register

The status register to access. See StatusRegisterEnums for available registers.

SubRegister

The status sub register to access. See StatusSubRegisterEnums for available sub registers.

RetVal

Instrument status registers.

Return Value

Success or failure code.

Remarks

See SCPI Volume 1: Syntax and Style, Section 9. The Register parameter refers to the entire set of registers. The SubRegister parameter refers to a particular register in a Register. Some Registers do not have all the possible sub-registers.

Requirements

Supported Models

All supported

Defined Values For Parameter Register

Name | Description
AGINFINIIVISION_VAL_STATUS_REGISTER_STATUS_BYTE3 | Status Byte register. Conditions defined by IEEE 488.2.
AGINFINIIVISION_VAL_STATUS_REGISTER_STANDARD_EVENT3 | Standard Event Status register. Conditions defined by IEEE 488.2.
AGINFINIIVISION_VAL_STATUS_REGISTER_OPERATION3 | Operation register. Conditions which are part of the instrument's normal operation.
AGINFINIIVISION_VAL_STATUS_REGISTER_QUESTIONABLE3 | Questionable register. Conditions which give an indication of the quality of various aspects of the signal.
AGINFINIIVISION_VAL_STATUS_REGISTER_MASK_TEST_EVENT | Mask Test Event Register.
AGINFINIIVISION_VAL_STATUS_REGISTER_ARM_EVENT | Arm Event Register
AGINFINIIVISION_VAL_STATUS_REGISTER_TRIGGER_EVENT | Trigger Event Register.
Top

Defined Values For Parameter SubRegister

Name | Description
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_CONDITION3 | Conditions Register. Read only and not available with the Standard Event Status register. Condition bits represent the current instrument state. Reading a condition register does not change the value of the bits.
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_EVENT3 | Event Register. Read only and not available with the Status Byte register. Event bits capture changes in condition bits. Reading an event register clears it.
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_ENABLE3 | Enable Register. Can be read or written and is available for all registers. Enable bits select whether an event bit causes a register summary bit, a kind of condition bit, to become true.
Top

See Also

Reference

Status
AgInfiniiVision


AgInfiniiVision_StatusPreset Function

AgInfiniiVision_StatusPreset Function
Status See Also

Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Preset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StatusPreset(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

*RST

Requirements

Supported Models

All supported

See Also

Reference

Status
AgInfiniiVision


AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL Attribute

AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL Attribute
Status See Also

Read Only - Serial poll the instrument status byte.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Serial Poll
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL 1150019

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Status
AgInfiniiVision


AgInfiniiVision_StatusSetRegister Function

AgInfiniiVision_StatusSetRegister Function
Status See Also

The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Status\Status Set Register
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StatusSetRegister(
    ViSession Vi,
    ViInt32 Register,
    ViInt32 SubRegister,
    ViInt32 Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Register

The status register to access. See StatusRegisterEnums for available registers.

SubRegister

The status sub register to access. See StatusSubRegisterEnums for available sub registers.

Val

Instrument status registers.

Return Value

Success or failure code.

Remarks

See SCPI Volume 1: Syntax and Style, Section 9. The Register parameter refers to the entire set of registers. The SubRegister parameter refers to a particular register in a Register. Some Registers do not have all the possible sub-registers.

Requirements

Supported Models

All supported

Defined Values For Parameter Register

Name | Description
AGINFINIIVISION_VAL_STATUS_REGISTER_STATUS_BYTE3 | Status Byte register. Conditions defined by IEEE 488.2.
AGINFINIIVISION_VAL_STATUS_REGISTER_STANDARD_EVENT3 | Standard Event Status register. Conditions defined by IEEE 488.2.
AGINFINIIVISION_VAL_STATUS_REGISTER_OPERATION3 | Operation register. Conditions which are part of the instrument's normal operation.
AGINFINIIVISION_VAL_STATUS_REGISTER_QUESTIONABLE3 | Questionable register. Conditions which give an indication of the quality of various aspects of the signal.
AGINFINIIVISION_VAL_STATUS_REGISTER_MASK_TEST_EVENT | Mask Test Event Register.
AGINFINIIVISION_VAL_STATUS_REGISTER_ARM_EVENT | Arm Event Register
AGINFINIIVISION_VAL_STATUS_REGISTER_TRIGGER_EVENT | Trigger Event Register.
Top

Defined Values For Parameter SubRegister

Name | Description
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_CONDITION3 | Conditions Register. Read only and not available with the Standard Event Status register. Condition bits represent the current instrument state. Reading a condition register does not change the value of the bits.
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_EVENT3 | Event Register. Read only and not available with the Status Byte register. Event bits capture changes in condition bits. Reading an event register clears it.
AGINFINIIVISION_VAL_STATUS_SUB_REGISTER_ENABLE3 | Enable Register. Can be read or written and is available for all registers. Enable bits select whether an event bit causes a register summary bit, a kind of condition bit, to become true.
Top

See Also

Reference

Status
AgInfiniiVision


System

System
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\System

Branches

Name
Precision
Top

Functions

 | Name | Description
Function | System ClearIO | Performs an IEEE 488.1-style clear of the device.
Function | System Disable Local Controls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.
Function | System Enable Local Controls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.
Function | System Get State | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.
Function | System Put State | Writes binary instrument state as saved by GetState method.
Function | System Read Bytes | Reads a complete response from the instrument and returns it as an array of bytes.
Function | System Read String | Reads a complete response from the instrument and returns it as a string.
Function | System Recall State | Restore the instrument to a state previously stored in the instrument's internal memory.
Function | System Save State | Save the instrument's state to the instrument's internal memory.
Function | System Wait For Operation Complete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.
Function | System Write Bytes | Write an array of bytes to the device.
Function | System Write String | Write a string to the device.
Function | System Write String2 | Write a string to the device.
Function | vi Read | Reads a complete response from the instrument and returns it as an array of bytes.
Function | vi Write | Write an array of bytes to the device.
Top

Attributes

 | Name | Description
Attribute | Message | Writes a message(excluding quotation marks) to a text box in the center of the display
Attribute | Protection Enabled | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status
Attribute | System Date | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.
Attribute | System Io Timeout | The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.
Attribute | System Serial Number | Read Only - Instrument serial number.
Attribute | System Time | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.
Attribute | System Timeout Milliseconds | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.
Attribute | System Touch Screen Enabled | Disables or enables the touchscreen.
Attribute | System Trace Enabled | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_MESSAGE Attribute

AGINFINIIVISION_ATTR_SYSTEM_MESSAGE Attribute
System See Also

Writes a message(excluding quotation marks) to a text box in the center of the display

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\Message
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_MESSAGE 1150196

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_MESSAGE.

AttributeValue

The value to which to set the attribute.

Instrument Command

:SYSTem:DSP "{value}"

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


Precision

Precision
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\System\Precision

Attributes

 | Name | Description
Attribute | Enabled | Enables or disables the oscilloscope's precision analysis setting.
Attribute | Record Length | The length of the precision analysis record (when precision measurements and math functions mode is enabled).
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED Attribute

AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED Attribute
Precision See Also

Enables or disables the oscilloscope's precision analysis setting.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\Precision\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED 1150588

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When set to false provides the maximum oscilloscope waveform update rate by performing measurements and math functions on the default 65535-point (maximum) measurement record.
  • When set to true then at the expense of oscilloscope waveform update rate, this setting allows measurements and math functions to be performed on a longer, precision analysis record.
  • Preset value is false.

    • Precision analysis is not available when:
    • Realtime sampling mode is off.
    • Averaging acquisition modes is selected.
    • XY or Roll time modes are selected.

    Instrument Command

    :SYSTem:PRECision {1|0}
    :SYSTem:PRECision?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Precision
    AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH Attribute

AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH Attribute
Precision See Also

The length of the precision analysis record (when precision measurements and math functions mode is enabled).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\Precision\Record Length
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH 1150589

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Input range is from 100k to 1M points.
  • Preset value is 200000 points.

    • Instrument Command

    :SYSTem:PRECision:LENGth {value}
    :SYSTem:PRECision:LENGth?

    Requirements

    Supported Models

    DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Precision
    AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED Attribute

AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED Attribute
System See Also

Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\Protection Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED 1150130

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SYSTem:PROTection:LOCK {ON|OFF}
:SYSTem:PROTection:LOCK?

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemClearIO Function

AgInfiniiVision_SystemClearIO Function
System See Also

Performs an IEEE 488.1-style clear of the device.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System ClearIO
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemClearIO(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE Attribute

AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE Attribute
System See Also

Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Date
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE 1150020

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SYSTem:DATE {value}
:SYSTem:DATE?

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemDisableLocalControls Function

AgInfiniiVision_SystemDisableLocalControls Function
System See Also

Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Disable Local Controls
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemDisableLocalControls(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

The client program can ensure that an operator cannot change the state of an instrument through its front panel. This method is only supported by instruments using a GPIB connection.

Instrument Command

:SYSTem:LOCK 1

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemEnableLocalControls Function

AgInfiniiVision_SystemEnableLocalControls Function
System See Also

Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Enable Local Controls
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemEnableLocalControls(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

This method is only supported by instruments using a GPIB connection.

Instrument Command

:SYSTem:LOCK 0

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemGetState Function

AgInfiniiVision_SystemGetState Function
System See Also

Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Get State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemGetState(
    ViSession Vi,
    ViInt32 DataBufferSize,
    ViByte[] Data,
    ViInt32* DataActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DataBufferSize

Number of elements in Data.

Data

Binary data representation of the current instrument state.

DataActualSize

Actual number of elements in Data.

Return Value

Success or failure code.

Instrument Command

*LRN?

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT Attribute

AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT Attribute
System See Also

The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Io Timeout
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT 1150607

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemPutState Function

AgInfiniiVision_SystemPutState Function
System See Also

Writes binary instrument state as saved by GetState method.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Put State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemPutState(
    ViSession Vi,
    ViInt32 DataBufferSize,
    ViByte[] Data
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DataBufferSize

Number of elements in Data.

Data

Binary data representation of the instrument state as read from the instrument using the GetState method.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemReadBytes Function

AgInfiniiVision_SystemReadBytes Function
System See Also

Reads a complete response from the instrument and returns it as an array of bytes.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Read Bytes
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemReadBytes(
    ViSession Vi,
    ViInt32 ValBufferSize,
    ViByte[] Val,
    ViInt32* ValActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValBufferSize

Number of elements in Val.

Val

An array of bytes returned from the device.

ValActualSize

Actual number of elements in Val.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemReadString Function

AgInfiniiVision_SystemReadString Function
System See Also

Reads a complete response from the instrument and returns it as a string.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Read String
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemReadString(
    ViSession Vi,
    ViInt32 ValBufferSize,
    ViChar[] Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValBufferSize

Buffer Size.

Val

A string returned from the device.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemRecallState Function

AgInfiniiVision_SystemRecallState Function
System See Also

Restore the instrument to a state previously stored in the instrument's internal memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Recall State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemRecallState(
    ViSession Vi,
    ViInt32 MemoryLocation
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

MemoryLocation

An integer which identifies which one of many internal memory locations was used to store the instrument's state.

Return Value

Success or failure code.

Instrument Command

*RCL {0|1|2|3|4|5|6|7|8|9}

Requirements

Supported Models

All supported

Defined Values For Parameter MemoryLocation

Name | Description
AGINFINIIVISION_VAL_MEMORY_LOCATION0 | Memory Location 0
AGINFINIIVISION_VAL_MEMORY_LOCATION1 | Memory Location 1
AGINFINIIVISION_VAL_MEMORY_LOCATION2 | Memory Location 2
AGINFINIIVISION_VAL_MEMORY_LOCATION3 | Memory Location 3
AGINFINIIVISION_VAL_MEMORY_LOCATION4 | Memory Location 4
AGINFINIIVISION_VAL_MEMORY_LOCATION5 | Memory Location 5
AGINFINIIVISION_VAL_MEMORY_LOCATION6 | Memory Location 6
AGINFINIIVISION_VAL_MEMORY_LOCATION7 | Memory Location 7
AGINFINIIVISION_VAL_MEMORY_LOCATION8 | Memory Location 8
AGINFINIIVISION_VAL_MEMORY_LOCATION9 | Memory Location 9
Top

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemSaveState Function

AgInfiniiVision_SystemSaveState Function
System See Also

Save the instrument's state to the instrument's internal memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Save State
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemSaveState(
    ViSession Vi,
    ViInt32 MemoryLocation
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

MemoryLocation

An integer which identifies which one of many internal memory locations is to be used to store the instrument's state.

Return Value

Success or failure code.

Instrument Command

*SAV {0|1|2|3|4|5|6|7|8|9}

Requirements

Supported Models

All supported

Defined Values For Parameter MemoryLocation

Name | Description
AGINFINIIVISION_VAL_MEMORY_LOCATION0 | Memory Location 0
AGINFINIIVISION_VAL_MEMORY_LOCATION1 | Memory Location 1
AGINFINIIVISION_VAL_MEMORY_LOCATION2 | Memory Location 2
AGINFINIIVISION_VAL_MEMORY_LOCATION3 | Memory Location 3
AGINFINIIVISION_VAL_MEMORY_LOCATION4 | Memory Location 4
AGINFINIIVISION_VAL_MEMORY_LOCATION5 | Memory Location 5
AGINFINIIVISION_VAL_MEMORY_LOCATION6 | Memory Location 6
AGINFINIIVISION_VAL_MEMORY_LOCATION7 | Memory Location 7
AGINFINIIVISION_VAL_MEMORY_LOCATION8 | Memory Location 8
AGINFINIIVISION_VAL_MEMORY_LOCATION9 | Memory Location 9
Top

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER Attribute

AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER Attribute
System See Also

Read Only - Instrument serial number.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Serial Number
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER 1150021

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_TIME Attribute

AGINFINIIVISION_ATTR_SYSTEM_TIME Attribute
System See Also

Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_TIME 1150022

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_TIME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SYSTem:TIME {value}
:SYSTem:TIME?

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS Attribute

AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS Attribute
System See Also

The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Timeout Milliseconds
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS 1150023

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Driver methods and properties with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value. Some methods provide a MaxTimeMilliseconds parameter which gives the client direct control over the timeout value for that method. Sometimes, however, increasing the timeout value can work around an obscure driver defect.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED Attribute

AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED Attribute
System See Also

Disables or enables the touchscreen.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Touch Screen Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED 1150514

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:SYSTem:TOUCh {ON|OFF}
:SYSTem:TOUCh?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

System
AgInfiniiVision


AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED Attribute

AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED Attribute
System See Also

If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\System\System Trace Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED 1150024

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

A new file is generated each time the driver is initialized. You may specify the trace file name using 'TraceName=' the 'DriverSetup=' option string parameter to the Initialize() method. For example: 'DriverSetup= TraceName=TraceOutput'

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemWaitForOperationComplete Function

AgInfiniiVision_SystemWaitForOperationComplete Function
System See Also

Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Wait For Operation Complete
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemWaitForOperationComplete(
    ViSession Vi,
    ViInt32 MaxTimeMilliseconds
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

MaxTimeMilliseconds

How long to wait, in milliseconds, for all the operations started in the instrument to complete.

Return Value

Success or failure code.

Instrument Command

*OPC?

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemWriteBytes Function

AgInfiniiVision_SystemWriteBytes Function
System See Also

Write an array of bytes to the device.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Write Bytes
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemWriteBytes(
    ViSession Vi,
    ViInt32 BufferBufferSize,
    ViByte[] Buffer
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BufferBufferSize

Number of elements in Buffer.

Buffer

The array of bytes to be written to the device.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemWriteString Function

AgInfiniiVision_SystemWriteString Function
System See Also

Write a string to the device.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Write String
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemWriteString(
    ViSession Vi,
    ViInt32 DataBufferSize,
    ViConstString Data
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DataBufferSize

Number of elements in Data.

Data

String to the device.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_SystemWriteString2 Function

AgInfiniiVision_SystemWriteString2 Function
System See Also

Write a string to the device.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\System Write String2
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SystemWriteString2(
    ViSession Vi,
    ViConstString Data
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Data

The string to be written to the device.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_viRead Function

AgInfiniiVision_viRead Function
System See Also

Reads a complete response from the instrument and returns it as an array of bytes.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\vi Read
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_viRead(
    ViSession Vi,
    ViInt64 BufferSize,
    ViByte[] Buffer,
    ViInt64* ReturnCount
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

BufferSize

The size of the array, in bytes, passed into the function to hold the results.

Buffer

An array allocated by the calling program and passed into the function to hold the bytes returned by the device.

ReturnCount

The number of bytes in the array that were filled in by the function.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


AgInfiniiVision_viWrite Function

AgInfiniiVision_viWrite Function
System See Also

Write an array of bytes to the device.

Function Tree Node: \AgInfiniiVision\Instrument Specific\System\vi Write
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_viWrite(
    ViSession Vi,
    ViInt64 Count,
    ViByte[] Buffer,
    ViInt64* ReturnCount
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Count

The number of bytes to write to the device. Count must be less than or equal to the size of the data array.

Buffer

The array of bytes to be written to the device.

ReturnCount

The number of bytes actually written.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgInfiniiVision


Timebase

Timebase
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Timebase

Attributes

 | Name | Description
Attribute | Horizontal Scale | Horizontal scale or seconds per division for the main window.
Attribute | Horizontal Scale | Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window
Attribute | Mode | Current time base mode.
Attribute | Position | Horizontal window position in the zoomed view of the main sweep.
Attribute | Range | Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.
Attribute | Time Reference | Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen
Attribute | Vernier Enabled | Time base control's vernier.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE Attribute

AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE Attribute
Timebase See Also

Horizontal scale or seconds per division for the main window.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Horizontal Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE 1150111

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:SCALe {value}
:TIMebase:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE Attribute

AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE Attribute
Timebase See Also

Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Horizontal Scale
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE 1150115

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:WINDow:SCALe {value}
:TIMebase:WINDow:SCALe?

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_MODE Attribute

AGINFINIIVISION_ATTR_TIMEBASE_MODE Attribute
Timebase See Also

Current time base mode.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_MODE 1150107

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:MODE {MAIN|WIND|XY|ROLL}
:TIMebase:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TIMEBASE_MODE_MAIN | The normal time base mode (Default)
AGINFINIIVISION_VAL_TIMEBASE_MODE_WINDOW | Zoomed or delayed time base mode
AGINFINIIVISION_VAL_TIMEBASE_MODEXY | In the XY mode, HorizontalScale() and TimeReference() is not available. Measurements are disabled as well.
AGINFINIIVISION_VAL_TIMEBASE_MODE_ROLL | In the ROLL mode, data moves continuously across the display from left to right. The oscilloscope runs continuously and is untriggered. The Timebase reference selection changes to right
Top

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION Attribute

AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION Attribute
Timebase See Also

Horizontal window position in the zoomed view of the main sweep.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Position
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION 1150113

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:WINDow:POSition {value}
:TIMebase:WINDow:POSition?

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE Attribute

AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE Attribute
Timebase See Also

Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE 1150114

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:WINDow:RANGe {value}
:TIMebase:WINDow:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE Attribute

AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE Attribute
Timebase See Also

Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Time Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE 1150110

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This affects the trigger point on the display, and does affect IAgInfiniiVisionAcquisition.StartTime, as StartTime() always refers to the left-edge of the screen.

Instrument Command

:TIMebase:REFerence {LEFT|CENT|RIGH}
:TIMebase:REFerence?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TIMEBASE_REFERENCE_LEFT | Left side of the screen
AGINFINIIVISION_VAL_TIMEBASE_REFERENCE_CENTER | Center of the screen
AGINFINIIVISION_VAL_TIMEBASE_REFERENCE_RIGHT | Right side of the screen
Top

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED Attribute

AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED Attribute
Timebase See Also

Time base control's vernier.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Timebase\Vernier Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED 1150112

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TIMebase:VERNier {ON|OFF}
:TIMebase:VERNier?

Requirements

Supported Models

All supported

See Also

Reference

Timebase
AgInfiniiVision


Trigger

Trigger
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger

Branches

Name
AcLine
Delay
Edge
EdgeBurst
Glitch
Modulation
OR
Pattern
PXI
RandomHoldoff
Runt
SetupAndHold
Transition
TV
USB
Width
Zone
Top

Functions

 | Name | Description
Function | Force Trigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.
Function | Trigger Auto Setup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.
Top

Attributes

 | Name | Description
Attribute | HF Reject Filter Enabled | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.
Attribute | Noise Reject Filter Enabled | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.
Attribute | Trigger Type Ag | The kind of event that triggers the oscilloscope.
Top

See Also

Reference

AgInfiniiVision


AcLine

AcLine
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\AcLine

Attributes

 | Name | Description
Attribute | Slope | The slope of the zero crossing upon which the scope triggers.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE Attribute
AcLine See Also

The slope of the zero crossing upon which the scope triggers.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\AcLine\Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE 1150556

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger[:EDGE]:SLOPe {POS|NEG}
:TRIGger[:EDGE]:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_AC_LINE_POSITIVE | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_NEGATIVE | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_EITHER | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

AcLine
AgInfiniiVision


Delay

Delay
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay

Functions

 | Name | Description
Function | Configure Trigger Delay | Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.
Top

Attributes

 | Name | Description
Attribute | Trigger Delay Arming Slope | Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.
Attribute | Trigger Delay Arming Source | Selects the input used for the arming edge in the Edge Then Edge trigger.
Attribute | Trigger Delay Edge Count | Sets/Gets the Nth edge of the trigger source to trigger on
Attribute | Trigger Delay Slope | Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.
Attribute | Trigger Delay Time | Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureTriggerDelay Function

AgInfiniiVision_ConfigureTriggerDelay Function
Delay See Also

Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Configure Trigger Delay
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerDelay(
    ViSession Vi,
    ViInt32 TriggerSourceBufferSize,
    ViConstString TriggerSource,
    ViInt32 TriggerSlope,
    ViInt32 EdgeCount,
    ViInt32 ArmingSourceBufferSize,
    ViConstString ArmingSource,
    ViInt32 ArmingSlope,
    ViReal64 DelayTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

TriggerSourceBufferSize

Number of elements in TriggerSource.

TriggerSource

Specifies the input used for the trigger edge in the Edge Then Edge trigger.

TriggerSlope

Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.

EdgeCount

Sets the Nth edge of the trigger source to trigger on

ArmingSourceBufferSize

Number of elements in ArmingSource.

ArmingSource

Selects the input used for the arming edge in the Edge Then Edge trigger.

ArmingSlope

Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.

DelayTime

Sets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter TriggerSlope

Name | Description
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_POSITIVE | Rising edge.
Top

Defined Values For Parameter ArmingSlope

Name | Description
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_POSITIVE | Rising edge.
Top

See Also

Reference

Delay
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE Attribute
Delay See Also

Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Trigger Delay Arming Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE 1150263

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ArmingSlope property can be set to one of the following values:

  • AgInfiniiVisionTriggerDelaySlopeNegative - specifies falling (Negative) for the arming edge in the Edge Then Edge trigger
  • AgInfiniiVisionTriggerDelaySlopePositive - specifies rising (Positive) for the arming edge in the Edge Then Edge trigger

Instrument Command

:TRIGger:DELay:ARM:SLOPe {NEG|POS}
:TRIGger:DELay:ARM:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Delay
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE Attribute
Delay See Also

Selects the input used for the arming edge in the Edge Then Edge trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Trigger Delay Arming Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE 1150264

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ArmingSource property can be specified in one the following string formats:

  • "Channel<n>", where <n> can be from 1 to the number of analog channels.
  • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:DELay:ARM:SOURce {value}
:TRIGger:DELay:ARM:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Delay
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT Attribute

AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT Attribute
Delay See Also

Sets/Gets the Nth edge of the trigger source to trigger on

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Trigger Delay Edge Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT 1150267

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:DELay:TRIGger:COUNt {value}
:TRIGger:DELay:TRIGger:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Delay
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE Attribute
Delay See Also

Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Trigger Delay Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE 1150266

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerDelaySlopeNegative - specifies falling (Negative) for the trigger edge in the Edge Then Edge trigger
  • AgInfiniiVisionTriggerDelaySlopePositive - specifies rising (Positive) for the trigger edge in the Edge Then Edge trigger

Instrument Command

:TRIGger:DELay:TRIGger:SLOPe {NEG|POS}
:TRIGger:DELay:TRIGger:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_DELAY_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Delay
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME Attribute
Delay See Also

Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Delay\Trigger Delay Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME 1150265

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:DELay:TDELay:TIME {value}
:TRIGger:DELay:TDELay:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Delay
AgInfiniiVision


Edge

Edge
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Edge

Attributes

 | Name | Description
Attribute | Reject Filter Type | Enable the type of reject filter.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE Attribute
Edge See Also

Enable the type of reject filter.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Edge\Reject Filter Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE 1150135

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger[:EDGE]:REJect {HFR|LFR|OFF}
:TRIGger[:EDGE]:REJect?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_EDGE_REJECT_FILTER_TYPE_HIGH_FREQUENCY | High frequency reject filter: adds a 50 kHz low-pass filter in the trigger path
AGINFINIIVISION_VAL_TRIGGER_EDGE_REJECT_FILTER_TYPE_LOW_FREQUENCY | Low frequency reject filter: adds a 50 kHz high-pass filter in series with the trigger waveform
AGINFINIIVISION_VAL_TRIGGER_EDGE_REJECT_FILTER_TYPE_OFF | Disable any reject filter
Top

Requirements

Supported Models

All supported

See Also

Reference

Edge
AgInfiniiVision


EdgeBurst

EdgeBurst
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\EdgeBurst

Functions

 | Name | Description
Function | Configure Trigger Edge Burst | Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.
Top

Attributes

 | Name | Description
Attribute | Trigger Edge Burst Idle Time | Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.
Attribute | Trigger Edge Burst NthEdge | Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.
Attribute | Trigger Edge Burst Slope | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureTriggerEdgeBurst Function

AgInfiniiVision_ConfigureTriggerEdgeBurst Function
EdgeBurst See Also

Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\EdgeBurst\Configure Trigger Edge Burst
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerEdgeBurst(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Slope,
    ViReal64 IdleTime,
    ViInt32 NthEdge
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

Specifies the input that produces the Nth edge burst trigger.

Slope

Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.

IdleTime

Sets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.

NthEdge

Sets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_TRIGGER_EDGE_BURST_SLOPE_NEGATIVE | Falling Edge.
AGINFINIIVISION_VAL_TRIGGER_EDGE_BURST_SLOPE_POSITIVE | Rising edge.
Top

See Also

Reference

EdgeBurst
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME Attribute
EdgeBurst See Also

Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\EdgeBurst\Trigger Edge Burst Idle Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME 1150248

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:EBURst:IDLE {value}
:TRIGger:EBURst:IDLE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

EdgeBurst
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE Attribute

AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE Attribute
EdgeBurst See Also

Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\EdgeBurst\Trigger Edge Burst NthEdge
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE 1150247

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:EBURst:COUNt {value}
:TRIGger:EBURst:COUNt?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

EdgeBurst
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE Attribute
EdgeBurst See Also

Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\EdgeBurst\Trigger Edge Burst Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE 1150249

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerEdgeBurstSlopeNegative - specifies that the falling edge (Negative) of the Nth edge in a burst will generate a trigger
  • AgInfiniiVisionTriggerEdgeBurstSlopePositive - specifies that the rising edge (Positive) of the Nth edge in a burst will generate a trigger

Instrument Command

:TRIGger:EBURst:SLOPe {NEG|POS}
:TRIGger:EBURst:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_EDGE_BURST_SLOPE_NEGATIVE | Falling Edge.
AGINFINIIVISION_VAL_TRIGGER_EDGE_BURST_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

EdgeBurst
AgInfiniiVision


AgInfiniiVision_ForceTrigger Function

AgInfiniiVision_ForceTrigger Function
Trigger See Also

This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Force Trigger
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ForceTrigger(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Instrument Command

:TRIGger:FORCe

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


Glitch

Glitch
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Glitch

Functions

 | Name | Description
Function | Trigger Glitch Get Range | READ ONLY- Gets the pulse width duration time for trigger source.
Function | Trigger Glitch Set Range | Pulse width duration for the selected source.
Top

Attributes

 | Name | Description
Attribute | Level | Trigger level voltage for the active pulse width trigger.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL Attribute

AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL Attribute
Glitch See Also

Trigger level voltage for the active pulse width trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Glitch\Level
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL 1150134

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:GLITch:LEVel {value}
:TRIGger:GLITch:LEVel?

Requirements

Supported Models

All supported

See Also

Reference

Glitch
AgInfiniiVision


AgInfiniiVision_TriggerGlitchGetRange Function

AgInfiniiVision_TriggerGlitchGetRange Function
Glitch See Also

READ ONLY- Gets the pulse width duration time for trigger source.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Glitch\Trigger Glitch Get Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerGlitchGetRange(
    ViSession Vi,
    ViReal64* LowerLimit,
    ViReal64* UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimit

LowerLimit

UpperLimit

UpperLimit

Return Value

Success or failure code.

Instrument Command

:TRIGger:GLITch:RANGe?

Requirements

Supported Models

All supported

See Also

Reference

Glitch
AgInfiniiVision


AgInfiniiVision_TriggerGlitchSetRange Function

AgInfiniiVision_TriggerGlitchSetRange Function
Glitch See Also

Pulse width duration for the selected source.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Glitch\Trigger Glitch Set Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerGlitchSetRange(
    ViSession Vi,
    ViReal64 LowerLimit,
    ViReal64 UpperLimit
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LowerLimit

LowerLimit. Permissible values are from 10 ns to 9.99 seconds

UpperLimit

UpperLimit. Permissible values are from 15 ns to 10 seconds

Return Value

Success or failure code.

Remarks

You can enter the parameters in any order,the smaller value becomes the greater than time and the larger value becomes the less than time.

Instrument Command

:TRIGger:GLITch:RANGe {LowerLimit}, {UpperLimit}

Requirements

Supported Models

All supported

See Also

Reference

Glitch
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED Attribute

AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED Attribute
Trigger See Also

The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\HF Reject Filter Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED 1150137

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Use this filter to remove high-frequency noise, such as AM or FM broadcast stations, from the trigger path. This property is not valid in TV trigger mode

Instrument Command

:TRIGger:HFReject {ON|OFF}
:TRIGger:HFReject?

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED Attribute

AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED Attribute
Trigger See Also

Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Noise Reject Filter Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED 1150136

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This property is not valid in TV trigger mode.

Instrument Command

:TRIGger:NREJect {ON|OFF}
:TRIGger:NREJect?

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


OR

OR
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\OR

Attributes

 | Name | Description
Attribute | Trigger OR Edge Pattern | Specifies the edges to include in the OR'ed edge trigger.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN Attribute

AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN Attribute
OR See Also

Specifies the edges to include in the OR'ed edge trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\OR\Trigger OR Edge Pattern
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN 1150262

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The EdgePattern property is specified in the following string format:

  • "nn..n", where n: {R | F | E | X}
R = rising edge,
F = faling edge,
E = either edge,
X = don't care.

In the string format shown above, each bit corresponds to a channel as described in the following table:
Oscilloscope Models | Value and Mask Bit Assignments
4 analog + 16 digital channels (mixed-signal) | Bits 0 through 15 - digital channels 0 through 15. Bits 16 through 19 - analog channels 4 through 1
2 analog + 16 digital channels (mixed-signal) | Bits 0 through 15 - digital channels 0 through 15. Bits 16 and 17 - analog channels 2 and 1
4 analog channels only | Bits 0 through 3 - analog channels 4 through 1
2 analog channels only | Bits 0 and 1 - analog channels 2 and 1

Instrument Command

:TRIGger:OR "{value}"
:TRIGger:OR?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

OR
AgInfiniiVision


Pattern

Pattern
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern

Functions

 | Name | Description
Function | Trigger Pattern Configure | Configures the pattern trigger
Function | Trigger Pattern Get Range | Returns the duration time for the defined pattern.
Function | Trigger Pattern Set Range | Duration for the defined pattern when the pattern condition is set to INRange or OUTRange
Top

Attributes

 | Name | Description
Attribute | Analog Pattern | The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | Condition | The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.
Attribute | Digital Pattern | The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | Max Duration | Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.
Attribute | Min Duration | Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN Attribute

AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN Attribute
Pattern See Also

The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Analog Pattern
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN 1150193

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

For Example if input string is "01010101XXXXXXX" and the model has 4 analog channels only "01010" will be accepted.

Requirements

Supported Models

All supported

See Also

Reference

Pattern
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION Attribute

AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION Attribute
Pattern See Also

The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION 1150195

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Only ENTER condition is supported in 2000X Series

Defined Values

Name | Description
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_ENTER | Pattern is entered.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_GREATER_THAN | Pattern present for less than a time value.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_LESS_THAN | Pattern present for greater than a time value.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_IN_RANGE | Pattern present for a time within a range of values. Trigger occurs when the pattern exits not when the GREaterthan time value is exceeded.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_OUT_RANGE | Pattern present for a time outside of range of values.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_TIMEOUT | Pattern present for greater than a time value. Trigger occurs when the GREaterthan time value is exceeded not when the pattern exits.
Top

Requirements

Supported Models

All supported

See Also

Reference

Pattern
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN Attribute

AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN Attribute
Pattern See Also

The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Digital Pattern
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN 1150194

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

For Example if input string is "01010101XXXXXXX" and the model has 8 digital channels only "01010101" will be accepted.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Pattern
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION Attribute

AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION Attribute
Pattern See Also

Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Max Duration
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION 1150166

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PATTern:LESSthan {value}
:TRIGger:PATTern:LESSthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Pattern
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH Attribute

AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH Attribute
Pattern See Also

Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Min Duration
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH 1150158

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PATTern:GREaterthan {value}
:TRIGger:PATTern:GREaterthan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Pattern
AgInfiniiVision


AgInfiniiVision_TriggerPatternConfigure Function

AgInfiniiVision_TriggerPatternConfigure Function
Pattern See Also

Configures the pattern trigger

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Trigger Pattern Configure
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerPatternConfigure(
    ViSession Vi,
    ViConstString AnalogPattern,
    ViConstString DigitalPattern,
    ViInt32 Condition
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

AnalogPattern

The analog channel pattern.

DigitalPattern

The digital channel pattern. This parameter will only be taken into account when MSO is licensed.

Condition

The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_ENTER | Pattern is entered.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_GREATER_THAN | Pattern present for less than a time value.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_LESS_THAN | Pattern present for greater than a time value.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_IN_RANGE | Pattern present for a time within a range of values. Trigger occurs when the pattern exits not when the GREaterthan time value is exceeded.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_OUT_RANGE | Pattern present for a time outside of range of values.
AGINFINIIVISION_VAL_PATTERN_MATCHING_MODE_TIMEOUT | Pattern present for greater than a time value. Trigger occurs when the GREaterthan time value is exceeded not when the pattern exits.
Top

See Also

Reference

Pattern
AgInfiniiVision


AgInfiniiVision_TriggerPatternGetRange Function

AgInfiniiVision_TriggerPatternGetRange Function
Pattern See Also

Returns the duration time for the defined pattern.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Trigger Pattern Get Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerPatternGetRange(
    ViSession Vi,
    ViReal64* LessThanTime,
    ViReal64* GreaterThanTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LessThanTime

Less than time.

GreaterThanTime

Greater than time.

Return Value

Success or failure code.

Instrument Command

:TRIGger:PATTern:RANGe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Pattern
AgInfiniiVision


AgInfiniiVision_TriggerPatternSetRange Function

AgInfiniiVision_TriggerPatternSetRange Function
Pattern See Also

Duration for the defined pattern when the pattern condition is set to INRange or OUTRange

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Pattern\Trigger Pattern Set Range
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerPatternSetRange(
    ViSession Vi,
    ViReal64 LessThanTime,
    ViReal64 GreaterThanTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LessThanTime

Less than time. Permissible values are from 10ns to 9.99 seconds.

GreaterThanTime

Greater than time.. Permissible values are from 15ns to 10 seconds

Return Value

Success or failure code.

Remarks

You can enter the parameters in any order,the smaller value becomes the greater than time, and the larger value becomes the less than time.

Instrument Command

:TRIGger:PATTern:RANGe {LessThanTime},{GreaterThanTime}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Pattern
AgInfiniiVision


PXI

PXI
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI

Functions

 | Name | Description
Function | Get Master Arm Line | Queries the PXI slave to master arm lines on or off.
Function | Set Master Arm Line | Sets the PXI slave to master arm lines on or off.
Top

Attributes

 | Name | Description
Attribute | Mode | Sets and gets the PXI trigger mode to bus master/slave or off.
Attribute | Slave Arm Line | Sets and gets the PXI slave to master arm line or off.
Attribute | Slot | Sets and gets the PXI master slot number.
Attribute | Trigger Line | Sets and gets the PXI master to slave trigger line.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_TriggerPXIGetMasterArmLine Function

AgInfiniiVision_TriggerPXIGetMasterArmLine Function
PXI See Also

Queries the PXI slave to master arm lines on or off.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Get Master Arm Line
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerPXIGetMasterArmLine(
    ViSession Vi,
    ViInt32 Index,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

Index.

Val

True or false

Return Value

Success or failure code.

Instrument Command

:TRIGger:PXI:MALine{Index}:ENABle?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE Attribute

AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE Attribute
PXI See Also

Sets and gets the PXI trigger mode to bus master/slave or off.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE 1150670

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PXI:MODE {OFF|MAST|SLAV}
:TRIGger:PXI:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_PXI_MODEOFF | OFF.
AGINFINIIVISION_VAL_TRIGGER_PXI_MODE_MASTER | Master.
AGINFINIIVISION_VAL_TRIGGER_PXI_MODE_SLAVE | Slave.
Top

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


AgInfiniiVision_TriggerPXISetMasterArmLine Function

AgInfiniiVision_TriggerPXISetMasterArmLine Function
PXI See Also

Sets the PXI slave to master arm lines on or off.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Set Master Arm Line
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerPXISetMasterArmLine(
    ViSession Vi,
    ViInt32 Index,
    ViBoolean State
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

Index.

State

State.

Return Value

Success or failure code.

Instrument Command

:TRIGger:PXI:MALine{Index}:ENABle {ON|OFF}

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE Attribute

AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE Attribute
PXI See Also

Sets and gets the PXI slave to master arm line or off.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Slave Arm Line
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE 1150672

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PXI:SALine {PTR1|PTR2|PTR3|PTR4|PTR5|PTR6|PTR7|PTR0|OFF}
:TRIGger:PXI:SALine?

Defined Values

Name | Description
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE1 | PXI Trigger Line 1.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE2 | PXI Trigger Line 2.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE3 | PXI Trigger Line 3.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE4 | PXI Trigger Line 4.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE5 | PXI Trigger Line 5.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE6 | PXI Trigger Line 6.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE7 | PXI Trigger Line 7.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE0 | PXI Trigger Line 0.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE_OFF | PXI Trigger Line OFF.
Top

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT Attribute

AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT Attribute
PXI See Also

Sets and gets the PXI master slot number.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Slot
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT 1150674

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PXI:MSLot {value}
:TRIGger:PXI:MSLot?

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE Attribute

AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE Attribute
PXI See Also

Sets and gets the PXI master to slave trigger line.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\PXI\Trigger Line
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE 1150671

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Not supported enum AgInfiniiVisionTriggerPXITriggerLineOff.

Instrument Command

:TRIGger:PXI:TLINe {PTR1|PTR2|PTR3|PTR4|PTR5|PTR6|PTR7|PTR0|OFF}
:TRIGger:PXI:TLINe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE1 | PXI Trigger Line 1.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE2 | PXI Trigger Line 2.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE3 | PXI Trigger Line 3.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE4 | PXI Trigger Line 4.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE5 | PXI Trigger Line 5.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE6 | PXI Trigger Line 6.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE7 | PXI Trigger Line 7.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE0 | PXI Trigger Line 0.
AGINFINIIVISION_VAL_PXI_TRIGGER_LINE_OFF | PXI Trigger Line OFF.
Top

Requirements

Supported Models

M9241A, M9242A, M9243A

See Also

Reference

PXI
AgInfiniiVision


RandomHoldoff

RandomHoldoff
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\RandomHoldoff

Attributes

 | Name | Description
Attribute | Enabled | Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.
Attribute | Time Max | The maximum random holdoff time in seconds.
Attribute | Time Min | The minimum random holdoff time in seconds.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED Attribute

AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED Attribute
RandomHoldoff See Also

Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\RandomHoldoff\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED 1150682

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Random trigger holdoff is used to avoid a fixed trigger interval that could miss capturing effects during the holdoff time on a repetitive signal like a pulse train. The usage could also be thought as the reverse of the convention holdoff usage that is to randomize the trigger event and could generates an unstable trigger.

    • Instrument Command

    :TRIGger:HOLDoff:RANDom {1|0}
    :TRIGger:HOLDoff:RANDom?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    RandomHoldoff
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX Attribute

AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX Attribute
RandomHoldoff See Also

The maximum random holdoff time in seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\RandomHoldoff\Time Max
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX 1150683

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Default value is 10s.

    • Instrument Command

    :TRIGger:HOLDoff:MAXimum {value}
    :TRIGger:HOLDoff:MAXimum?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    RandomHoldoff
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN Attribute

AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN Attribute
RandomHoldoff See Also

The minimum random holdoff time in seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\RandomHoldoff\Time Min
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN 1150684

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Default value is 40ns.

    • Instrument Command

    :TRIGger:HOLDoff:MINimum {value}
    :TRIGger:HOLDoff:MINimum?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    RandomHoldoff
    AgInfiniiVision


Runt

Runt
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Runt

Functions

 | Name | Description
Function | Trigger Runt Configure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Top

Attributes

 | Name | Description
Attribute | Condition | Condition used for specifying runt pulse widths.
Attribute | Qualifier Time | Time used for triggering on runt pulses whose width is greater than or less than the specified time value.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION Attribute

AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION Attribute
Runt See Also

Condition used for specifying runt pulse widths.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Runt\Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION 1150189

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:RUNT:QUALifier {NONE|LESS|GRE}
:TRIGger:RUNT:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_RUNT_CONDITION_NONE | Triggers on runt pulses of any width
AGINFINIIVISION_VAL_TRIGGER_RUNT_CONDITION_LESS_THAN | Triggers on runt pulses whose width is less than the qualifier time.
AGINFINIIVISION_VAL_TRIGGER_RUNT_CONDITION_GREATER_THAN | Triggers on runt pulses whose width is greater than the qualifier time.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME Attribute
Runt See Also

Time used for triggering on runt pulses whose width is greater than or less than the specified time value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Runt\Qualifier Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME 1150191

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:RUNT:TIME {value}
:TRIGger:RUNT:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Runt
AgInfiniiVision


AgInfiniiVision_TriggerRuntConfigure Function

AgInfiniiVision_TriggerRuntConfigure Function
Runt See Also

Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Runt\Trigger Runt Configure
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerRuntConfigure(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViReal64 ThresholdLow,
    ViReal64 ThresholdHigh,
    ViInt32 Polarity
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

Specifies the trigger source. This value sets the Trigger Source property.

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

Polarity

Sets the runt polarity.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Polarity

Name | Description
AGINFINIIVISION_VAL_RUNT_POSITIVE | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
AGINFINIIVISION_VAL_RUNT_NEGATIVE | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
AGINFINIIVISION_VAL_RUNT_EITHER | The oscilloscope triggers on either a positive or negative runt.
Top

See Also

Reference

Runt
AgInfiniiVision


SetupAndHold

SetupAndHold
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold

Functions

 | Name | Description
Function | Configure Trigger Setup And Hold | Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.
Top

Attributes

 | Name | Description
Attribute | Trigger Setup And Hold Clock Source | Selects the channel used to produce the trigger.
Attribute | Trigger Setup And Hold Data Source | Selects the channel used to produce the trigger.
Attribute | Trigger Setup And Hold Hold Time | Sets/Gets the hold time.
Attribute | Trigger Setup And Hold Setup Time | Sets/Gets the setup time.
Attribute | Trigger Setup And Hold Slope | Selects the clock signal's active edge.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureTriggerSetupAndHold Function

AgInfiniiVision_ConfigureTriggerSetupAndHold Function
SetupAndHold See Also

Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Configure Trigger Setup And Hold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerSetupAndHold(
    ViSession Vi,
    ViInt32 ClockSourceBufferSize,
    ViConstString ClockSource,
    ViInt32 Slope,
    ViInt32 DataSourceBufferSize,
    ViConstString DataSource,
    ViReal64 SetupTime,
    ViReal64 HoldTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ClockSourceBufferSize

Number of elements in ClockSource.

ClockSource

Selects the channel used to produce the trigger.

Slope

Selects the clock signal's active edge.

DataSourceBufferSize

Number of elements in DataSource.

DataSource

Selects the channel used to produce the trigger.

SetupTime

Sets the setup time.

HoldTime

Sets the hold time.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_TRIGGER_SETUP_AND_HOLD_SLOPE_NEGATIVE | Negative polarity.
AGINFINIIVISION_VAL_TRIGGER_SETUP_AND_HOLD_SLOPE_POSITIVE | Positive polarity.
Top

See Also

Reference

SetupAndHold
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE Attribute
SetupAndHold See Also

Selects the channel used to produce the trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Trigger Setup And Hold Clock Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE 1150253

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ClockSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:SHOLd:SOURce:CLOCk {value}
:TRIGger:SHOLd:SOURce:CLOCk?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SetupAndHold
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE Attribute
SetupAndHold See Also

Selects the channel used to produce the trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Trigger Setup And Hold Data Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE 1150254

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DataSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

Instrument Command

:TRIGger:SHOLd:SOURce:DATA {value}
:TRIGger:SHOLd:SOURce:DATA?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SetupAndHold
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME Attribute
SetupAndHold See Also

Sets/Gets the hold time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Trigger Setup And Hold Hold Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME 1150251

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:SHOLd:TIME:HOLD {value}
:TRIGger:SHOLd:TIME:HOLD?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SetupAndHold
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME Attribute
SetupAndHold See Also

Sets/Gets the setup time.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Trigger Setup And Hold Setup Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME 1150252

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:SHOLd:TIME:SETup {value}
:TRIGger:SHOLd:TIME:SETup?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SetupAndHold
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE Attribute
SetupAndHold See Also

Selects the clock signal's active edge.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\SetupAndHold\Trigger Setup And Hold Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE 1150250

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerSHoldSlopeNegative - Negative slope
  • AgInfiniiVisionTriggerSHoldSlopePositive - Positive slope

Instrument Command

:TRIGger:SHOLd:SLOPe {NEG|POS}
:TRIGger:SHOLd:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_SETUP_AND_HOLD_SLOPE_NEGATIVE | Negative polarity.
AGINFINIIVISION_VAL_TRIGGER_SETUP_AND_HOLD_SLOPE_POSITIVE | Positive polarity.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

SetupAndHold
AgInfiniiVision


Transition

Transition
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition

Functions

 | Name | Description
Function | Configure Trigger Transition | Configures the source, slope, condition and qualifier time parameters for the Transition trigger.
Top

Attributes

 | Name | Description
Attribute | Trigger Transition Condition | Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.
Attribute | Trigger Transition Qualifier Time | Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.
Attribute | Trigger Transition Slope | Specifies a Positive rising edge or a Negative falling edge.
Attribute | Trigger Transition Threshold High | The high threshold the oscilloscope uses for the transition trigger. The units are volts.
Attribute | Trigger Transition Threshold Low | The low threshold the oscilloscope uses for the transition trigger. The units are volts.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureTriggerTransition Function

AgInfiniiVision_ConfigureTriggerTransition Function
Transition See Also

Configures the source, slope, condition and qualifier time parameters for the Transition trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Configure Trigger Transition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerTransition(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViInt32 Slope,
    ViInt32 Condition,
    ViReal64 QualifierTime
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

Specifies the channel used to produce the trigger.

Slope

Specifies a Positive rising edge or a Negative falling edge.

Condition

Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.

QualifierTime

Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Slope

Name | Description
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_SLOPE_POSITIVE | Rising edge.
Top

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_CONDITION_GREATER_THAN | Look for rise/fall times greater than a certain time value.
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_CONDITION_LESS_THAN | Look for rise/fall times less than a certain time value.
Top

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION Attribute

AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION Attribute
Transition See Also

Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Trigger Transition Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION 1150255

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionTriggerTransitionConditionGreaterThan - specifies that we are looking for rise/fall times greater than a certain time value.
  • AgInfiniiVisionTriggerTransitionConditionLessThan - specifies that we are looking for rise/fall times less than a certain time value.

Instrument Command

:TRIGger:TRANsition:QUALifier {GRE|LESS}
:TRIGger:TRANsition:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_CONDITION_GREATER_THAN | Look for rise/fall times greater than a certain time value.
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_CONDITION_LESS_THAN | Look for rise/fall times less than a certain time value.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME Attribute

AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME Attribute
Transition See Also

Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Trigger Transition Qualifier Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME 1150257

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:TRANsition:TIME {value}
:TRIGger:TRANsition:TIME?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE Attribute
Transition See Also

Specifies a Positive rising edge or a Negative falling edge.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Trigger Transition Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE 1150256

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Slope property can be set to one of the following values:

  • AgInfiniiVisionTriggerTransitionSlopeNegative - specifies a negative falling edge
  • AgInfiniiVisionTriggerTransitionSlopePositive - specifies a positive rising edge

Instrument Command

:TRIGger:TRANsition:SLOPe {NEG|POS}
:TRIGger:TRANsition:SLOPe?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_SLOPE_NEGATIVE | Falling edge.
AGINFINIIVISION_VAL_TRIGGER_TRANSITION_SLOPE_POSITIVE | Rising edge.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH Attribute

AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH Attribute
Transition See Also

The high threshold the oscilloscope uses for the transition trigger. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Trigger Transition Threshold High
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH 1150428

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW Attribute

AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW Attribute
Transition See Also

The low threshold the oscilloscope uses for the transition trigger. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Transition\Trigger Transition Threshold Low
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW 1150429

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Transition
AgInfiniiVision


AgInfiniiVision_TriggerAutoSetup Function

AgInfiniiVision_TriggerAutoSetup Function
Trigger See Also

It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Trigger Auto Setup
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerAutoSetup(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • When High and Low (dual) trigger levels are used (as with Rise/Fall Time and Runt triggers, for example), this method has no effect.

    • Instrument Command

    :TRIGger:LEVel:ASETup

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Trigger
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG Attribute

AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG Attribute
Trigger See Also

The kind of event that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Trigger Type Ag
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG 1150557

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:MODE {EDGE|PATT|RUNT|GLIT|TV|ACL|PATT|DEL|EBUR|SHOL|TRAN|SBUS1|SBUS2|USB|NONE|OR}
:TRIGger:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_EDGE | Trigger on Edge
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_WIDTH | Trigger on Width
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_RUNT | Trigger on Runt
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_GLITCH | Trigger on Glitch
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_TV | Trigger on TV
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_AC_LINE | Trigger on ACLine
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_PATTERN | Trigger on Pattern
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_DELAY | Edge Then Edge Trigger.
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_E_BURST | EBurst trigger.
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_S_HOLD | Setup and Hold trigger.
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_TRANSITION | Trigger on Transition.
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_SERIAL_BUS1 | Trigger on SerialBus1
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_SERIAL_BUS2 | Trigger on SerialBus2
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_USB | Trigger on USB
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_NONE | Read Only - No Trigger type selected.
AGINFINIIVISION_VAL_TRIGGER_TYPE_AG_OR | OR-logic Trigger.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


TV

TV
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV

Branches

Name
UDTV
Top

See Also

Reference

AgInfiniiVision


UDTV

UDTV
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV\UDTV

Attributes

 | Name | Description
Attribute | UDTV Edge Number | Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.
Attribute | UDTV Horizontal Sync Enabled | Enables or disables the horizontal sync control in the Generic video trigger.
Attribute | UDTV Horizontal Sync Time | When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.
Attribute | UDTV Min Time | Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER Attribute

AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER Attribute
UDTV See Also

Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV\UDTV\UDTV Edge Number
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER 1150420

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:ENUMber {value}
:TRIGger:TV:UDTV:ENUMber?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UDTV
AgInfiniiVision


AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED Attribute

AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED Attribute
UDTV See Also

Enables or disables the horizontal sync control in the Generic video trigger.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV\UDTV\UDTV Horizontal Sync Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED 1150421

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

For interleaved video, setting the HorizontalSyncEnabled property to true and setting the HorizontalSyncTime property to the sync time of the probed video signal allows the ENUMber function to count only lines and not double count during equalization. Additionally, the Field Holdoff can be adjusted so that the oscilloscope triggers once per frame.
Similarly, for progressive video with a tri-level sync, setting the HorizontalSyncEnabled property to true and setting the HorizontalSyncTime property to the sync time of the probed video signal allows the EdgeNumber property to count only lines and not double count during vertical sync.
This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:HSYNc {ON|OFF}
:TRIGger:TV:UDTV:HSYNc?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UDTV
AgInfiniiVision


AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME Attribute

AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME Attribute
UDTV See Also

When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV\UDTV\UDTV Horizontal Sync Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME 1150422

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:HTIMe {value}
:TRIGger:TV:UDTV:HTIMe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UDTV
AgInfiniiVision


AGINFINIIVISION_ATTR_UDTV_MIN_TIME Attribute

AGINFINIIVISION_ATTR_UDTV_MIN_TIME Attribute
UDTV See Also

Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\TV\UDTV\UDTV Min Time
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_UDTV_MIN_TIME 1150423

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_UDTV_MIN_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This command is available with the DSOX3VID extended Video triggering license.

Instrument Command

:TRIGger:TV:UDTV:PGTHan {value}
:TRIGger:TV:UDTV:PGTHan?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

UDTV
AgInfiniiVision


USB

USB
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB

Functions

 | Name | Description
Function | Configure Trigger USB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.
Top

Attributes

 | Name | Description
Attribute | Trigger USB Condition | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.
Attribute | Trigger USB D Minus Source | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.
Attribute | Trigger USB D Plus Source | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.
Attribute | Trigger USB Speed | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ConfigureTriggerUSB Function

AgInfiniiVision_ConfigureTriggerUSB Function
USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB\Configure Trigger USB
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ConfigureTriggerUSB(
    ViSession Vi,
    ViInt32 Condition,
    ViInt32 Speed,
    ViInt32 DPlusSourceBufferSize,
    ViConstString DPlusSource,
    ViInt32 DMinusSourceBufferSize,
    ViConstString DMinusSource
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Condition

Specifies where the USB trigger will occur.

Speed

Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).

DPlusSourceBufferSize

Number of elements in DPlusSource.

DPlusSource

Specifies the source for the USB D+ signal.

DMinusSourceBufferSize

Number of elements in DMinusSource.

DMinusSource

Specifies the source for the USB D- signal.

Return Value

Success or failure code.

Remarks

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB interface.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_START_OF_PACKET | Start of packet.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_END_OF_PACKET | End of packet.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_ENTER_SUSPEND | Enter suspend state.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_EXIT_SUSPEND | Exit suspend state.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_RESET | Reset complete.
Top

Defined Values For Parameter Speed

Name | Description
AGINFINIIVISION_VAL_TRIGGERUSB_SPEED_LOW | Low Speed (1.5 Mb/s)
AGINFINIIVISION_VAL_TRIGGERUSB_SPEED_FULL | Full Speed (12 Mb/s)
Top

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION Attribute

AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION Attribute
USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB\Trigger USB Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION 1150261

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Condition property can be set to one of the following values:

  • AgInfiniiVisionTriggerUSBConditionStartOfPacket - Start of packet
  • AgInfiniiVisionTriggerUSBConditionEndOfPacket - End of packet
  • AgInfiniiVisionTriggerUSBConditionEnterSuspend - Enter suspend state
  • AgInfiniiVisionTriggerUSBConditionExitSuspend - Exit suspend state
  • AgInfiniiVisionTriggerUSBConditionReset - Reset complete

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.Condition property.

Instrument Command

:TRIGger:USB:TRIGger {SOP|EOP|ENT|EXIT|RES}
:TRIGger:USB:TRIGger?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_START_OF_PACKET | Start of packet.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_END_OF_PACKET | End of packet.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_ENTER_SUSPEND | Enter suspend state.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_EXIT_SUSPEND | Exit suspend state.
AGINFINIIVISION_VAL_TRIGGERUSB_CONDITION_RESET | Reset complete.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE Attribute
USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB\Trigger USB D Minus Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE 1150259

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DMinusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.DMinusSource property.

Instrument Command

:TRIGger:USB:SOURce:DMINus {value}
:TRIGger:USB:SOURce:DMINus?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE Attribute
USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB\Trigger USB D Plus Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE 1150258

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The DPlusSource property can be specified in one the following string formats:

  • For DSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "VAL_EXTERNAL" - for External
  • For MSO Models:
    • "Channel<n>", where <n> can be from 1 to the number of analog channels.
    • "DigitalChannel<d>", where <d> can be from 0 to the number of digital channels minus 1.

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.DPlusSource property.

Instrument Command

:TRIGger:USB:SOURce:DPLus {value}
:TRIGger:USB:SOURce:DPLus?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

USB
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED Attribute

AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED Attribute
USB See Also

CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\USB\Trigger USB Speed
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED 1150260

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The Speed property can be set to one of the following values:

  • AgInfiniiVisionTriggerUSBSpeedLow - sets the expected USB signal speed to be Low Speed (1.5 Mb/s)
  • AgInfiniiVisionTriggerUSBSpeedFull - sets the expected USB signal speed to be Full Speed (12 Mb/s)

NOTE: Only supported for 3000X/3000T series models. For 4000X series use SerialBuses.USB.Speed property.

Instrument Command

:TRIGger:USB:SPEed {LOW|FULL}
:TRIGger:USB:SPEed?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGERUSB_SPEED_LOW | Low Speed (1.5 Mb/s)
AGINFINIIVISION_VAL_TRIGGERUSB_SPEED_FULL | Full Speed (12 Mb/s)
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T

See Also

Reference

USB
AgInfiniiVision


Width

Width
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width

Functions

 | Name | Description
Function | Trigger Width Configure | Configures the width trigger.
Top

Attributes

 | Name | Description
Attribute | Condition | Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.
Attribute | Polarity | The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.
Attribute | Threshold High | The high width threshold time in seconds.
Attribute | Threshold Low | The low width threshold time in seconds.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION Attribute

AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION Attribute
Width See Also

Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width\Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION 1150197

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:TRIGger:PATTern:QUALifier {INR|OUTR}
:TRIGger:PATTern:QUALifier?

Defined Values

Name | Description
AGINFINIIVISION_VAL_TRIGGER_WIDTH_CONDITION_WITHIN | Width Within a range of values
AGINFINIIVISION_VAL_TRIGGER_WIDTH_CONDITION_OUTSIDE | Width outside a range of values
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Width
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY Attribute

AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY Attribute
Width See Also

The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width\Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY 1150200

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_WIDTH_POLARITY_POSITIVE | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_POLARITY_NEGATIVE | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Width
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH Attribute

AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH Attribute
Width See Also

The high width threshold time in seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width\Threshold High
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH 1150198

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Width
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW Attribute

AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW Attribute
Width See Also

The low width threshold time in seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width\Threshold Low
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW 1150199

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Width
AgInfiniiVision


AgInfiniiVision_TriggerWidthConfigure Function

AgInfiniiVision_TriggerWidthConfigure Function
Width See Also

Configures the width trigger.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Width\Trigger Width Configure
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerWidthConfigure(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source,
    ViReal64 Level,
    ViReal64 ThresholdLow,
    ViReal64 ThresholdHigh,
    ViInt32 Polarity,
    ViInt32 Condition
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The source the trigger monitors for a trigger event.

Level

The voltage threshold for the trigger sub-system.

ThresholdLow

The low width threshold time in seconds.

ThresholdHigh

The high width threshold time in seconds.

Polarity

The polarity of the pulse that triggers the oscilloscope.

Condition

Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.

Return Value

Success or failure code.

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Polarity

Name | Description
AGINFINIIVISION_VAL_WIDTH_POLARITY_POSITIVE | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_POLARITY_NEGATIVE | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
Top

Defined Values For Parameter Condition

Name | Description
AGINFINIIVISION_VAL_TRIGGER_WIDTH_CONDITION_WITHIN | Width Within a range of values
AGINFINIIVISION_VAL_TRIGGER_WIDTH_CONDITION_OUTSIDE | Width outside a range of values
Top

See Also

Reference

Width
AgInfiniiVision


Zone

Zone
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone

Functions

 | Name | Description
Function | Trigger Zone Get Enabled | Specifies the state for Zone 1 or Zone 2.
Function | Trigger Zone Get Mode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | Trigger Zone Get Validity | Read Only - Query returns the validity of Zone 1 or Zone 2.
Function | Trigger Zone Get Zone Placement | Queries the size and location of Zone 1 or Zone 2.
Function | Trigger Zone Set Enabled | Specifies the state for Zone 1 or Zone 2.
Function | Trigger Zone Set Mode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | Trigger Zone Set Zone Placement | Sets the size and location of Zone 1 or Zone 2.
Top

Attributes

 | Name | Description
Attribute | Source | Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE Attribute
Zone See Also

Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE 1150468

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The StateEnabled property must also be true for a zone to be active.

Instrument Command

:TRIGger:ZONE:SOURce {value}
:TRIGger:ZONE:SOURce?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneGetEnabled Function

AgInfiniiVision_TriggerZoneGetEnabled Function
Zone See Also

Specifies the state for Zone 1 or Zone 2.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Get Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneGetEnabled(
    ViSession Vi,
    ViInt32 Zone,
    ViBoolean* StateEnabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

StateEnabled

Return if enabled or disabled.

Return Value

Success or failure code.

Remarks

Setting this property to true, sets the Enabled property to true.

Instrument Command

:TRIGger:ZONE{1|2}:STATe?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneGetMode Function

AgInfiniiVision_TriggerZoneGetMode Function
Zone See Also

Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Get Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneGetMode(
    ViSession Vi,
    ViInt32 Zone,
    ViInt32* Mode
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

Mode

Mode.

Return Value

Success or failure code.

Instrument Command

:TRIGger:ZONE{1|2}:MODE?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

Defined Values For Parameter Mode

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE_MODE_INTERSECT | "Must Intersect" qualifying condition.
AGINFINIIVISION_VAL_TRIGGER_ZONE_MODE_NOT_INTERSECT | "Must Not Intersect" qualifying condition.
Top

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneGetValidity Function

AgInfiniiVision_TriggerZoneGetValidity Function
Zone See Also

Read Only - Query returns the validity of Zone 1 or Zone 2.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Get Validity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneGetValidity(
    ViSession Vi,
    ViInt32 Zone,
    ViInt32* Validity
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

Validity

Validity.

Return Value

Success or failure code.

Remarks

  • AgInfiniiVisionTriggerZoneValidityInvalid is returned (for Zone 2 only) when Zone 1 and Zone 2 overlap and have opposing qualifying conditions (modes). Zone 1 can never be invalid.
  • AgInfiniiVisionTriggerZoneValidityOffScreen is returned when the associated zone is off-screen, and thus not being used to qualify the trigger.
  • AgInfiniiVisionTriggerZoneValidityValid is returned when Zone is valid. A zone is valid when it is neither invalid nor off-screen.

    • Instrument Command

    :TRIGger:ZONE{1|2}:VALidity?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    Defined Values For Parameter Zone

    Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
    Top

    Defined Values For Parameter Validity

    Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE_VALIDITY_VALID | Trigger valid on the selected zone.
AGINFINIIVISION_VAL_TRIGGER_ZONE_VALIDITY_INVALID | When Zone 1 and Zone 2 overlap and have opposing qualifying conditions (modes).
AGINFINIIVISION_VAL_TRIGGER_ZONE_VALIDITY_OFF_SCREEN | When the associated zone is off-screen.
    Top

    See Also

    Reference

    Zone
    AgInfiniiVision


AgInfiniiVision_TriggerZoneGetZonePlacement Function

AgInfiniiVision_TriggerZoneGetZonePlacement Function
Zone See Also

Queries the size and location of Zone 1 or Zone 2.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Get Zone Placement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneGetZonePlacement(
    ViSession Vi,
    ViInt32 Zone,
    ViReal64* Width,
    ViReal64* Height,
    ViReal64* XCenter,
    ViReal64* YCenter
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

Width

Width of zone to be specified.

Height

Height of zone to be specified.

XCenter

X axis center of Zone to be specified.

YCenter

Y axis center of Zone to be specified.

Return Value

Success or failure code.

Instrument Command

:TRIGger:ZONE{1|2}:PLACement?

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneSetEnabled Function

AgInfiniiVision_TriggerZoneSetEnabled Function
Zone See Also

Specifies the state for Zone 1 or Zone 2.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Set Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneSetEnabled(
    ViSession Vi,
    ViInt32 Zone,
    ViBoolean StateEnabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

StateEnabled

Return if Enabled or disabled.

Return Value

Success or failure code.

Remarks

Setting this property to true, sets the Enabled property to true.

Instrument Command

:TRIGger:ZONE{1|2}:STATe {ON|OFF}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneSetMode Function

AgInfiniiVision_TriggerZoneSetMode Function
Zone See Also

Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Set Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneSetMode(
    ViSession Vi,
    ViInt32 Zone,
    ViInt32 Mode
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

Mode

Mode.

Return Value

Success or failure code.

Instrument Command

:TRIGger:ZONE{1|2}:MODE {INT|NOT}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

Defined Values For Parameter Mode

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE_MODE_INTERSECT | "Must Intersect" qualifying condition.
AGINFINIIVISION_VAL_TRIGGER_ZONE_MODE_NOT_INTERSECT | "Must Not Intersect" qualifying condition.
Top

See Also

Reference

Zone
AgInfiniiVision


AgInfiniiVision_TriggerZoneSetZonePlacement Function

AgInfiniiVision_TriggerZoneSetZonePlacement Function
Zone See Also

Sets the size and location of Zone 1 or Zone 2.

Function Tree Node: \AgInfiniiVision\Instrument Specific\Trigger\Zone\Trigger Zone Set Zone Placement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TriggerZoneSetZonePlacement(
    ViSession Vi,
    ViInt32 Zone,
    ViReal64 Width,
    ViReal64 Height,
    ViReal64 XCenter,
    ViReal64 YCenter
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Zone

Specifies the Zone Number.

Width

Width of zone to be specified.

Height

Height of zone to be specified.

XCenter

X axis center of Zone to be specified.

YCenter

Y axis center of Zone to be specified.

Return Value

Success or failure code.

Instrument Command

:TRIGger:ZONE{1|2}:PLACement {Width}, {Height}, {XCenter}, {YCenter}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

Defined Values For Parameter Zone

Name | Description
AGINFINIIVISION_VAL_TRIGGER_ZONE1 | Specifies the Zone 1.
AGINFINIIVISION_VAL_TRIGGER_ZONE2 | Specifies the Zone 2.
Top

See Also

Reference

Zone
AgInfiniiVision


Waveform

Waveform
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\Waveform

Functions

 | Name | Description
Function | Waveform Preamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel
Top

Attributes

 | Name | Description
Attribute | Byte Order | Output sequence of the WORD data. It decides which significant byte to be transmitted first.
Attribute | Data Format | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.
Attribute | Point Count | Number of waveform points to be transferred with the Waveform data
Attribute | Point Mode | Type of data record to be transferred
Attribute | Source | Source for the waveform.
Attribute | Sub Soource | Selects the sub-source for those sources that have more than one possibility.
Attribute | Unsigned Mode Enable | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.
Attribute | View | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.
Attribute | X Origin | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.
Attribute | X Reference | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value
Attribute | XIncrement | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.
Attribute | Y Increment | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".
Attribute | Y Origin | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.
Attribute | Y Reference | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER Attribute

AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER Attribute
Waveform See Also

Output sequence of the WORD data. It decides which significant byte to be transmitted first.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Byte Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER 1150085

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

This property affects the transmitting sequence only when DataFormat is set to WORD.

Instrument Command

:WAVeform:BYTeorder {LSBF|MSBF}
:WAVeform:BYTeorder?

Defined Values

Name | Description
AGINFINIIVISION_VAL_WAVEFORM_BYTE_ORDERLSB_FIRST | LSBFirst sets the least significant byte to be transmitted first
AGINFINIIVISION_VAL_WAVEFORM_BYTE_ORDERMSB_FIRST | MSBFirst sets the most significant byte to be transmitted first
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT Attribute

AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT Attribute
Waveform See Also

Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Data Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT 1150086

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WAVeform:FORMat {WORD|BYTE|ASC}
:WAVeform:FORMat?

Defined Values

Name | Description
AGINFINIIVISION_VAL_WAVEFORM_DATA_FORMAT_WORD | WORD: Formatted data transfers 16-bit data as two bytes
AGINFINIIVISION_VAL_WAVEFORM_DATA_FORMAT_BYTE | BYTE: Formatted data is transferred as 8-bit bytes.
AGINFINIIVISION_VAL_WAVEFORM_DATA_FORMAT_ASCII | ASCii: Formatted data converts the internal integer data values to real Y-axis values. Values are transferred as ASCii digits in floating point notation, separated by commas
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT Attribute

AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT Attribute
Waveform See Also

Number of waveform points to be transferred with the Waveform data

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Point Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT 1150141

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WAVeform:POINts {value}
:WAVeform:POINts?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE Attribute
Waveform See Also

Type of data record to be transferred

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Point Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE 1150087

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WAVeform:POINts:MODE {NORM|MAX|RAW}
:WAVeform:POINts:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_WAVEFORM_POINT_MODE_NORMAL | Normal: The measurement record is transferred. It is a 62,500-point (maximum) representation of the raw acquisition record
AGINFINIIVISION_VAL_WAVEFORM_POINT_MODE_MAXIMUM | Maximum: Whichever record contains the maximum amount of points is used.
AGINFINIIVISION_VAL_WAVEFORM_POINT_MODE_RAW | Raw: Raw acquisition record is transferred. The maximum number of points available in this record is determined by number of points available to be transferred.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_SOURCE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_SOURCE Attribute
Waveform See Also

Source for the waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_SOURCE 1150091

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

    Permissible Values are:
  • "Channel<n>", where n = 1 to (# of analog channels)
  • "Math<n>", where n = 1 to (# of math functions)
  • "FUNC" (for 1000X, 2000X and 3000X only)
  • "POD<n>", where n = 1 or 2 (for MSO models only)
  • "BUS<n>", where n = 1 or 2 (for MSO models only)
  • "WMEM<n>", where n = 1 to (# of reference waveforms)
  • "SerialBus<n>", where n = 1 to 2

    • Instrument Command

    :WAVeform:SOURce {value}
    :WAVeform:SOURce?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Waveform
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE Attribute
Waveform See Also

Selects the sub-source for those sources that have more than one possibility.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Sub Soource
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE 1150609

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • If the IAgInfiniiVisionWaveform.Source is serial decode, more than one data set may be available, and this command lets you choose from the available data sets.
  • When using UART serial decode, this option lets you get "TX" data. (TX is an alias for SUB1.) The default, SUB0, specifies "RX" data. (RX is an alias for SUB0.)
  • When using SPI serial decode, this option lets you get "MISO" data. (MISO is an alias for SUB1.) The default, SUB0, specifies "MOSI" data. (MOSI is an alias for SUB0.)
  • When using SENT serial decode, this option lets you get "SLOW" data. (SLOW is an alias for SUB1.) The default, SUB0, specifies "FAST" data. (FAST is an alias for SUB0.)
  • If the IAgInfiniiVisionWaveform.Source is not SBUS, or the IAgInfiniiVision2SerialBus.Mode is not UART, SPI, or SENT, the only valid subsource is SUB0.

    • Instrument Command

    :WAVeform:SOURce:SUBSource {SUB0|SUB1|SLOW|FAST|RX|TX|MISO|MOSI}
    :WAVeform:SOURce:SUBSource?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCESUB0 | SUB0.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCESUB1 | SUB1.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCE_SLOW | SLOW alias of SUB1 for SENT protocol.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCE_FAST | FAST alias of SUB0 for SENT protocol.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCE_RX | RX alias of SUB0 for UART protocol.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCE_TX | TX alias of SUB1 for UART protocol.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCEMISO | MISO alias of SUB1 for SPI protocol.
AGINFINIIVISION_VAL_WAVEFORM_SUB_SOURCEMOSI | MOSI alias of SUB0 for SPI protocol.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Waveform
    AgInfiniiVision


AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE Attribute

AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE Attribute
Waveform See Also

Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Unsigned Mode Enable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE 1150092

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WAVeform:UNSigned {ON|OFF}
:WAVeform:UNSigned?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_VIEW Attribute

AGINFINIIVISION_ATTR_VIEW Attribute
Waveform See Also

View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\View
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_VIEW 1150142

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_VIEW.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WAVeform:VIEW {value}
:WAVeform:VIEW?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AgInfiniiVision_WaveformPreamble Function

AgInfiniiVision_WaveformPreamble Function
Waveform See Also

Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel

Function Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Waveform Preamble
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveformPreamble(
    ViSession Vi,
    ViInt32 ValBufferSize,
    ViReal64[] Val,
    ViInt32* ValActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValBufferSize

Number of elements in Val.

Val

Preamble block.

ValActualSize

Actual number of elements in Val.

Return Value

Success or failure code.

Instrument Command

:WAVeform:PREamble?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN Attribute

AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN Attribute
Waveform See Also

Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\X Origin
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN 1150147

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:XORigin?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE Attribute
Waveform See Also

Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\X Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE 1150145

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Remarks

The x-reference point is the first point displayed and XREFerence is always 0.

Instrument Command

:WAVeform:XREFerence?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT Attribute

AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT Attribute
Waveform See Also

Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\XIncrement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT 1150143

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:XINCrement?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT Attribute

AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT Attribute
Waveform See Also

Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Y Increment
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT 1150144

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:YINCrement?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN Attribute

AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN Attribute
Waveform See Also

Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Y Origin
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN 1150148

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:YORigin?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE Attribute
Waveform See Also

Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\Waveform\Y Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE 1150146

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Instrument Command

:WAVeform:YREFerence?

Requirements

Supported Models

All supported

See Also

Reference

Waveform
AgInfiniiVision


WaveformGenerator

WaveformGenerator
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator

Branches

Name
Arbitrary
Top

Functions

 | Name | Description
Function | Reset Waveform Generator | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Top

Attributes

 | Name | Description
Attribute | Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | Duty Cycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | Function | Type of waveform.
Attribute | High Voltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | Low Voltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | Offset Voltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | Output Enabled | Enables/Disables waveform generator signal output.
Attribute | Output Load Impedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | Pulse Width | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | Ramp Symmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Attribute | Waveform Generator Additional Noise | Specifies the amount of noise to add to the currently selected signal.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE Attribute
WaveformGenerator See Also

Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Amplitude
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE 1150103

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage {value}
    :WGEN:VOLTage?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


Arbitrary

Arbitrary
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary

Branches

Name
Attribute
Top

Functions

 | Name | Description
Function | Reset Arbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | Set Arbitrary DAC Data | Downloads an arbitrary waveform in integer (DAC) values.
Function | Set Arbitrary Data | Downloads an arbitrary waveform in floating-point values format.
Function | Store Arbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top

Attributes

 | Name | Description
Attribute | Arbitrary Byte Order | Specifies the byte order for binary transfers.
Attribute | Arbitrary Interpolation | Enables or disables the Interpolation control.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER Attribute

AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER Attribute
Arbitrary See Also

Specifies the byte order for binary transfers.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Arbitrary Byte Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER 1150415

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ByteOrder property can be set to one of the following values:

  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderLSBFirst - specifies the LSB first byte order
  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderMSBFirst - specifies the MSB first byte order

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:BYTeorder {LSBF|MSBF}
    :WGEN:ARBitrary:BYTeorder?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_ARBITRARY_BYTE_ORDERLSB_FIRST | Specifies the LSB first byte order for binary transfers.
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_ARBITRARY_BYTE_ORDERMSB_FIRST | Specifies the MSB first byte order for binary transfers.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION Attribute

AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION Attribute
Arbitrary See Also

Enables or disables the Interpolation control.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Arbitrary Interpolation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION 1150411

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Interpolation specifies how lines are drawn between arbitrary waveform points:
When ON, lines are drawn between points in the arbitrary waveform. Voltage levels change linearly between one point and the next.
When OFF, all line segments in the arbitrary waveform are horizontal. The voltage level of one point remains until the next point.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:INTerpolate {ON|OFF}
    :WGEN:ARBitrary:INTerpolate?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


Attribute

Attribute
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Attribute

Attributes

 | Name | Description
Attribute | Arbitrary Attribute Number Of Points | Read Only - Queries the number of points used by the current Arbitrary waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS Attribute

AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS Attribute
Attribute See Also

Read Only - Queries the number of points used by the current Arbitrary waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Attribute\Arbitrary Attribute Number Of Points
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS 1150414

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:ATTRibute:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Attribute
    AgInfiniiVision


AgInfiniiVision_ResetArbitrary Function

AgInfiniiVision_ResetArbitrary Function
Arbitrary See Also

Clears the Arbitrary waveform memory and loads it with the default waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Reset Arbitrary
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetArbitrary(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:CLEar

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_SetArbitraryDACData Function

AgInfiniiVision_SetArbitraryDACData Function
Arbitrary See Also

Downloads an arbitrary waveform in integer (DAC) values.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Set Arbitrary DAC Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetArbitraryDACData(
    ViSession Vi,
    ViInt32 ValuesBufferSize,
    ViInt16[] Values
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValuesBufferSize

Number of elements in Values.

Values

Specifies the decimal-integer values between -512 and +511 for the arbitrary waveform.

Return Value

Success or failure code.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA:DAC {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_SetArbitraryData Function

AgInfiniiVision_SetArbitraryData Function
Arbitrary See Also

Downloads an arbitrary waveform in floating-point values format.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Set Arbitrary Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_SetArbitraryData(
    ViSession Vi,
    ViInt32 ValuesBufferSize,
    ViReal64[] Values
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ValuesBufferSize

Number of elements in Values.

Values

Specifies the floating-point values between -1.0 and +1.0 for the arbitrary waveform.

Return Value

Success or failure code.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:DATA {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_StoreArbitrary Function

AgInfiniiVision_StoreArbitrary Function
Arbitrary See Also

Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Arbitrary\Store Arbitrary
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_StoreArbitrary(
    ViSession Vi,
    ViInt32 SourceBufferSize,
    ViConstString Source
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SourceBufferSize

Number of elements in Source.

Source

The source for the waveform.

Return Value

Success or failure code.

Remarks

The Source parameter can be specified in one of the following formats:

  • Channel<n>, where n: from 1 to the number of analog channels.
  • WMEM<r>, where r: 1-2
  • Math<m>, where m: 1-4

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.
  • Not supported by 1000X and 2000X.

    • Instrument Command

    :WGEN:ARBitrary:STORe {Source}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE Attribute
WaveformGenerator See Also

Square wave duty cycle(20% to 80%) for Square waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Duty Cycle
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE 1150099

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Duty cycle is the percentage of the period that the waveform is high.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:SQUare:DCYCle {value}
    :WGEN:FUNCtion:SQUare:DCYCle?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY Attribute
WaveformGenerator See Also

Frequency for Sine, Square, Ramp, and Pulse waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY 1150095

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FREQuency {value}
    :WGEN:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION Attribute
WaveformGenerator See Also

Type of waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Function
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION 1150096

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion {SIN|SQU|RAMP|PULS|NOIS|DC|SINC|EXPR|EXPF|CARD|GAUS|ARB}
    :WGEN:FUNCtion?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SINUSOID | Sine signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SQUARE | Square Wave signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_RAMP | Ramp Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_PULSE | Pulse Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_NOISE | Noise Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTIONDC | DC Level
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SINE_CARDINAL | -- NOT SUPPORTED IN 2000 X-SERIES -- Sine Cardinal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_EXPONENTIAL_RISE | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Rise
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_EXPONENTIAL_FALL | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Fall
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_CARDIAC | -- NOT SUPPORTED IN 2000 X-SERIES -- Cardiac
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_GAUSSIAN_PULSE | -- NOT SUPPORTED IN 2000 X-SERIES -- Gaussian Pulse
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_ARBITRARY | -- NOT SUPPORTED IN 2000 X-SERIES -- Arbitrary Waveform
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE Attribute
WaveformGenerator See Also

High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\High Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE 1150104

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:HIGH {value}
    :WGEN:VOLTage:HIGH?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE Attribute
WaveformGenerator See Also

Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Low Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE 1150105

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:LOW {value}
    :WGEN:VOLTage:LOW?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE Attribute
WaveformGenerator See Also

Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Offset Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE 1150106

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:VOLTage:OFFSet {value}
    :WGEN:VOLTage:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED Attribute
WaveformGenerator See Also

Enables/Disables waveform generator signal output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Output Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED 1150100

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:OUTPut {}
    :WGEN:OUTPut?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE Attribute
WaveformGenerator See Also

Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Output Load Impedance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE 1150101

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If the actual load impedance is different than the selected value, the displayed amplitude and offset levels will be incorrect.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:OUTPut:LOAD {ONEM|FIFT}
    :WGEN:OUTPut:LOAD?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_ONE_MEG | One Mega Ohm
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_FIFTY | Fifty Ohm
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD Attribute
WaveformGenerator See Also

Period in seconds for Sine, Square, Ramp, and Pulse waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Period
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD 1150102

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:PERiod {value}
    :WGEN:PERiod?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH Attribute
WaveformGenerator See Also

Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Pulse Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH 1150097

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:PULSe:WIDTh {value}
    :WGEN:FUNCtion:PULSe:WIDTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY Attribute
WaveformGenerator See Also

Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Ramp Symmetry
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY 1150098

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:FUNCtion:RAMP:SYMMetry {value}
    :WGEN:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AgInfiniiVision_ResetWaveformGenerator Function

AgInfiniiVision_ResetWaveformGenerator Function
WaveformGenerator See Also

Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Reset Waveform Generator
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetWaveformGenerator(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:RST

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE Attribute

AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE Attribute
WaveformGenerator See Also

Specifies the amount of noise to add to the currently selected signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveformGenerator\Waveform Generator Additional Noise
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE 1150419

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The sum of the amplitude between the original signal and injected noise is limited to the regular amplitude limit (for example, 5 Vpp in 1 MOhm), so the range for input value varies according to current amplitude.

Note that adding noise affects edge triggering on the waveform generator source as well as the waveform generator sync pulse output signal. This is because the trigger comparator is located after the noise source.

  • Note: This interface will only control the first waveform generator of the oscilloscope. For models with two waveform generators (e.g. 4000X, 6000X), use the WaveGens interface for complete control.

    • Instrument Command

    :WGEN:MODulation:NOISe {value}
    :WGEN:MODulation:NOISe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveformGenerator
    AgInfiniiVision


WaveGen

WaveGen
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen

Branches

Name
Arbitrary
Modulation
Track
Top

Functions

 | Name | Description
Function | Get Wave Gen Name | Returns the wavegen name that corresponds to the one-based index that the user specifies.
Function | Wave Gen Reset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Function | WaveGen Output Single | Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.
Top

Attributes

 | Name | Description
Attribute | Output Mode | Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.
Attribute | WaveGen Additional Noise | Specifies the amount of noise to add to the currently selected signal.
Attribute | WaveGen Amplitude | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | WaveGen Count | Attribute that contains the number of WaveGens available on the instrument. This is the maximum index that may be used with the GetWaveGenName() function.
Attribute | WaveGen Duty Cycle | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | WaveGen Frequency | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | WaveGen Function | Type of waveform.
Attribute | WaveGen High Voltage | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | WaveGen Low Voltage | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | WaveGen Offset Voltage | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | WaveGen Output Enabled | Enables or Disables waveform generator signal output.
Attribute | WaveGen Output Inverted | Specifies whether the waveform generator output is inverted or not.
Attribute | WaveGen Output Load Impedance | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | WaveGen Period | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | WaveGen Pulse Width | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | WaveGen Ramp Symmetry | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Top

See Also

Reference

AgInfiniiVision


Arbitrary

Arbitrary
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary

Branches

Name
Attribute
Top

Functions

 | Name | Description
Function | Wave Gen Reset Arbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | Wave Gen Set Arbitrary Data | Downloads an arbitrary waveform in floating-point values format.
Function | Wave Gen Set ArbitraryDAC Data | Downloads an arbitrary waveform in integer (DAC) values.
Function | Wave Gen Store Arbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top

Attributes

 | Name | Description
Attribute | Arbitrary Byte Order | Specifies the byte order for binary transfers.
Attribute | Arbitrary Interpolation | Enables or disables the Interpolation control.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER Attribute
Arbitrary See Also

Specifies the byte order for binary transfers.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Arbitrary Byte Order
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER 1150544

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The ByteOrder property can be set to one of the following values:

  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderLSBFirst - specifies the LSB first byte order
  • AgInfiniiVisionWaveformGeneratorArbitraryByteOrderMSBFirst - specifies the MSB first byte order
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:BYTeorder {LSBF|MSBF}
    :WGEN{WaveGen}:ARBitrary:BYTeorder?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_ARBITRARY_BYTE_ORDERLSB_FIRST | Specifies the LSB first byte order for binary transfers.
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_ARBITRARY_BYTE_ORDERMSB_FIRST | Specifies the MSB first byte order for binary transfers.
    Top

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION Attribute
Arbitrary See Also

Enables or disables the Interpolation control.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Arbitrary Interpolation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION 1150543

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Interpolation specifies how lines are drawn between arbitrary waveform points:
When ON, lines are drawn between points in the arbitrary waveform. Voltage levels change linearly between one point and the next.
When OFF, all line segments in the arbitrary waveform are horizontal. The voltage level of one point remains until the next point.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:INTerpolate {ON|OFF}
    :WGEN{WaveGen}:ARBitrary:INTerpolate?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


Attribute

Attribute
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Attribute

Attributes

 | Name | Description
Attribute | Arbitrary Attribute Number Of Points | Read Only - Queries the number of points used by the current Arbitrary waveform.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS Attribute
Attribute See Also

Read Only - Queries the number of points used by the current Arbitrary waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Attribute\Arbitrary Attribute Number Of Points
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS 1150542

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:ATTRibute:POINts?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Attribute
    AgInfiniiVision


AgInfiniiVision_WaveGenResetArbitrary Function

AgInfiniiVision_WaveGenResetArbitrary Function
Arbitrary See Also

Clears the Arbitrary waveform memory and loads it with the default waveform.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Wave Gen Reset Arbitrary
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveGenResetArbitrary(
    ViSession Vi,
    ViConstString WaveGen
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

Return Value

Success or failure code.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:CLEar

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_WaveGenSetArbitraryData Function

AgInfiniiVision_WaveGenSetArbitraryData Function
Arbitrary See Also

Downloads an arbitrary waveform in floating-point values format.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Wave Gen Set Arbitrary Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveGenSetArbitraryData(
    ViSession Vi,
    ViConstString WaveGen,
    ViInt32 ValuesBufferSize,
    ViReal64[] Values
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

ValuesBufferSize

Number of elements in Values.

Values

Specifies the floating-point values between -1.0 and +1.0 for the arbitrary waveform.

Return Value

Success or failure code.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_WaveGenSetArbitraryDACData Function

AgInfiniiVision_WaveGenSetArbitraryDACData Function
Arbitrary See Also

Downloads an arbitrary waveform in integer (DAC) values.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Wave Gen Set ArbitraryDAC Data
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveGenSetArbitraryDACData(
    ViSession Vi,
    ViConstString WaveGen,
    ViInt32 ValuesBufferSize,
    ViInt16[] Values
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

ValuesBufferSize

Number of elements in Values.

Values

Specifies the decimal-integer values between -512 and +511 for the arbitrary waveform.

Return Value

Success or failure code.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only (i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:ARBitrary:DATA:DAC {Values}

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    Arbitrary
    AgInfiniiVision


AgInfiniiVision_WaveGenStoreArbitrary Function

AgInfiniiVision_WaveGenStoreArbitrary Function
Arbitrary See Also

Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Arbitrary\Wave Gen Store Arbitrary
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveGenStoreArbitrary(
    ViSession Vi,
    ViConstString WaveGen,
    ViInt32 SourceBufferSize,
    ViConstString Source
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

SourceBufferSize

Number of elements in Source.

Source

The source for the waveform.

Return Value

Success or failure code.

Remarks

The Source parameter can be specified in one of the following formats:

  • Channel<n>, where n: from 1 to the number of analog channels.
  • WMEM<r>, where r: 1-2
  • Math<m>, where m: 1-4
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only (i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

Instrument Command

:WGEN{WaveGen}:ARBitrary:STORe {Source}

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

Arbitrary
AgInfiniiVision


AgInfiniiVision_GetWaveGenName Function

AgInfiniiVision_GetWaveGenName Function
WaveGen See Also

Returns the wavegen name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Get Wave Gen Name
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetWaveGenName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

WaveGen
AgInfiniiVision


Modulation

Modulation
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation

Branches

Name
AM
FM
FSK
Top

Attributes

 | Name | Description
Attribute | Modulation Enabled | Enables or disables modulated waveform generator output.
Attribute | Modulation Function | Specifies the shape of the modulating signal.
Attribute | Modulation Ramp Symmetry | Specifies the amount of time per cycle that the ramp waveform is rising.
Attribute | Modulation Type | Specifies the modulation type.
Top

See Also

Reference

AgInfiniiVision


AM

AM
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\AM

Attributes

 | Name | Description
Attribute | AM Depth | Specifies the amount of amplitude modulation.
Attribute | AM Frequency | Specifies the frequency of the modulating signal. Frequency in Hz .
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH Attribute
AM See Also

Specifies the amount of amplitude modulation.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\AM\AM Depth
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH 1150546

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • AM Depth refers to the portion of the amplitude range that will be used by the modulation. For example, a depth setting of 80% causes the output amplitude to vary from 10% to 90% (90% ? 10% = 80%) of the original amplitude as the modulating signal goes from its minimum to maximum amplitude.
  • Input ranges from 0 to 100.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:AM:DEPTh {value}
    :WGEN{WaveGen}:MODulation:AM:DEPTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    AM
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY Attribute
AM See Also

Specifies the frequency of the modulating signal. Frequency in Hz .

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\AM\AM Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY 1150547

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:AM:FREQuency {value}
    :WGEN{WaveGen}:MODulation:AM:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    AM
    AgInfiniiVision


FM

FM
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FM

Attributes

 | Name | Description
Attribute | FM Deviation | Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.
Attribute | FM Frequency | Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FM_DEVIATION Attribute

AGINFINIIVISION_ATTR_FM_DEVIATION Attribute
FM See Also

Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FM\FM Deviation
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FM_DEVIATION 1150548

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FM_DEVIATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FM:DEViation {value}
    :WGEN{WaveGen}:MODulation:FM:DEViation?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FM
    AgInfiniiVision


AGINFINIIVISION_ATTR_FM_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FM_FREQUENCY Attribute
FM See Also

Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FM\FM Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FM_FREQUENCY 1150549

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FM_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FM:FREQuency {value}
    :WGEN{WaveGen}:MODulation:FM:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FM
    AgInfiniiVision


FSK

FSK
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FSK

Attributes

 | Name | Description
Attribute | FSK Frequency | Specifies the "hop frequency". Hop frequency in Hz
Attribute | FSK Modulation Rate | Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_FSK_FREQUENCY Attribute

AGINFINIIVISION_ATTR_FSK_FREQUENCY Attribute
FSK See Also

Specifies the "hop frequency". Hop frequency in Hz

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FSK\FSK Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FSK_FREQUENCY 1150550

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FSK_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FSKey:FREQuency {value}
    :WGEN{WaveGen}:MODulation:FSKey:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FSK
    AgInfiniiVision


AGINFINIIVISION_ATTR_FSK_MODULATION_RATE Attribute

AGINFINIIVISION_ATTR_FSK_MODULATION_RATE Attribute
FSK See Also

Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\FSK\FSK Modulation Rate
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_FSK_MODULATION_RATE 1150551

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_FSK_MODULATION_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FSKey:RATE {value}
    :WGEN{WaveGen}:MODulation:FSKey:RATE?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    FSK
    AgInfiniiVision


AGINFINIIVISION_ATTR_MODULATION_ENABLED Attribute

AGINFINIIVISION_ATTR_MODULATION_ENABLED Attribute
Modulation See Also

Enables or disables modulated waveform generator output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\Modulation Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MODULATION_ENABLED 1150554

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MODULATION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • You can enable modulation for all waveform generator function types except pulse, DC, and noise.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:STATe {ON|OFF}
    :WGEN{WaveGen}:MODulation:STATe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Modulation
    AgInfiniiVision


AGINFINIIVISION_ATTR_MODULATION_FUNCTION Attribute

AGINFINIIVISION_ATTR_MODULATION_FUNCTION Attribute
Modulation See Also

Specifies the shape of the modulating signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\Modulation Function
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MODULATION_FUNCTION 1150552

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MODULATION_FUNCTION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When the AgInfiniiVisionModulationFunctionRamp is selected, you can specify the amount of time per cycle that the ramp waveform is rising with the RampSymmetry property.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FUNCtion {SIN|SQU|RAMP}
    :WGEN{WaveGen}:MODulation:FUNCtion?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MODULATION_FUNCTION_SINUSOIDAL | Sinusoidal function for waveform generator.
AGINFINIIVISION_VAL_MODULATION_FUNCTION_SQUARE | Square function for waveform generator.
AGINFINIIVISION_VAL_MODULATION_FUNCTION_RAMP | Ramp function for waveform generator.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Modulation
    AgInfiniiVision


AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY Attribute

AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY Attribute
Modulation See Also

Specifies the amount of time per cycle that the ramp waveform is rising.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\Modulation Ramp Symmetry
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY 1150553

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • The ramp modulating waveform shape is specified with the Function property.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:FUNCtion:RAMP:SYMMetry {value}
    :WGEN{WaveGen}:MODulation:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Modulation
    AgInfiniiVision


AGINFINIIVISION_ATTR_MODULATION_TYPE Attribute

AGINFINIIVISION_ATTR_MODULATION_TYPE Attribute
Modulation See Also

Specifies the modulation type.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Modulation\Modulation Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MODULATION_TYPE 1150555

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MODULATION_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

AgInfiniiVisionModulationTypeAM - the amplitude of the original carrier signal is modified according to the amplitude of the modulating signal.

  • Use the IAgInfiniiVisionWaveGenModulationAM.Frequency property to set the modulating signal frequency.
  • Use the IAgInfiniiVisionWaveGenModulationAM.Depth property to specify the amount of amplitude modulation.

    • AgInfiniiVisionModulationTypeFM - the frequency of the original carrier signal is modified according to the amplitude of the modulating signal.
  • Use the IAgInfiniiVisionWaveGenModulationFM.Frequency property to set the modulating signal frequency.
  • Use the IAgInfiniiVisionWaveGenModulationFM.Deviation property to specify the frequency deviation from the original carrier signal frequency.

    • AgInfiniiVisionModulationType - the output frequency "shifts" between the original carrier frequency and a "hop frequency" at the specified FSK rate.
    The FSK rate specifies a digital square wave modulating signal.
  • Use the IAgInfiniiVisionWaveGenModulationFSK.Frequency property to specify the "hop frequency".
  • Use the IAgInfiniiVisionWaveGenModulationFSK.Rate property to specify the rate at which the output frequency "shifts".

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:TYPE {AM|FM|FSK}
    :WGEN{WaveGen}:MODulation:TYPE?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_MODULATION_TYPEAM | AM modulation.
AGINFINIIVISION_VAL_MODULATION_TYPEFM | FM modulation.
AGINFINIIVISION_VAL_MODULATION_TYPEFSK | FSK modulation.
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    Modulation
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE Attribute
WaveGen See Also

Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Output Mode
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE 1150658

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WGEN{WaveGen}:OUTPut:MODE {NORM|SING}
:WGEN{WaveGen}:OUTPut:MODE?

Defined Values

Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_MODE_NORMAL | Defined waveform is output continuously.
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_MODE_SINGLE | One cycle of the defined waveform is output.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

WaveGen
AgInfiniiVision


Track

Track
See Also

Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track

Functions

 | Name | Description
Function | Copy Signal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).
Top

Attributes

 | Name | Description
Attribute | Amplitude | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | Enabled | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | Frequency | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | Phase | Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE Attribute

AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE Attribute
Track See Also

If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track\Amplitude
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE 1150527

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:AMPLitude {ON|OFF}
    :WGEN{WaveGen}:TRACk:AMPLitude?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Track
    AgInfiniiVision


AgInfiniiVision_TrackingCopySignal Function

AgInfiniiVision_TrackingCopySignal Function
Track See Also

Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track\Copy Signal
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_TrackingCopySignal(
    ViSession Vi,
    ViConstString WaveGen
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

Return Value

Success or failure code.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:CSIGnal

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Track
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRACKING_ENABLED Attribute

AGINFINIIVISION_ATTR_TRACKING_ENABLED Attribute
Track See Also

If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track\Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRACKING_ENABLED 1150526

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRACKING_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Not all waveform shapes can be frequency tracked.
  • When Enabled or Frequency property is true, the other generator's waveform selections IAgInfiniiVisionWaveGen.Function must be in the same group as this generator's waveform.
  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk {ON|OFF}
    :WGEN{WaveGen}:TRACk?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Track
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRACKING_FREQUENCY Attribute

AGINFINIIVISION_ATTR_TRACKING_FREQUENCY Attribute
Track See Also

If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track\Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRACKING_FREQUENCY 1150528

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRACKING_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Not all waveform shapes can be frequency tracked.
  • When Enabled property or Frequency property is true, the other generator's waveform selections IAgInfiniiVisionWaveGen.Function must be in the same group as this generator's waveform.
  • When Enabled property is true, adjustments for tracked settings in the other waveform generator become unavailable.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:TRACk:FREQuency {ON|OFF}
    :WGEN{WaveGen}:TRACk:FREQuency?

    Requirements

    Supported Models

    DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

    See Also

    Reference

    Track
    AgInfiniiVision


AGINFINIIVISION_ATTR_TRACKING_PHASE Attribute

AGINFINIIVISION_ATTR_TRACKING_PHASE Attribute
Track See Also

Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Track\Phase
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRACKING_PHASE 1150659

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRACKING_PHASE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Instrument Command

:WGEN{WaveGen}:TRACk:PHASe {value}
:WGEN{WaveGen}:TRACk:PHASe?

Requirements

Supported Models

DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A

See Also

Reference

Track
AgInfiniiVision


AgInfiniiVision_WaveGenReset Function

AgInfiniiVision_WaveGenReset Function
WaveGen See Also

Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\Wave Gen Reset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_WaveGenReset(
    ViSession Vi,
    ViConstString WaveGen
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single wavegen.For valid values, see the WaveGen repeated capability.

Return Value

Success or failure code.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:RST

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE Attribute
WaveGen See Also

Specifies the amount of noise to add to the currently selected signal.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Additional Noise
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE 1150529

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The sum of the amplitude between the original signal and injected noise is limited to the regular amplitude limit (for example, 5 Vpp in 1 MOhm), so the range for input value varies according to current amplitude.

Note that adding noise affects edge triggering on the waveform generator source as well as the waveform generator sync pulse output signal. This is because the trigger comparator is located after the noise source.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:MODulation:NOISe {value}
    :WGEN{WaveGen}:MODulation:NOISe?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE Attribute
WaveGen See Also

Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Amplitude
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE 1150530

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage {value}
    :WGEN{WaveGen}:VOLTage?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVEGEN_COUNT Attribute

AGINFINIIVISION_ATTR_WAVEGEN_COUNT Attribute
WaveGen See Also

Attribute that contains the number of WaveGens available on the instrument. This is the maximum index that may be used with the GetWaveGenName() function.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Count
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVEGEN_COUNT 1150525

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVEGEN_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

WaveGen
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE Attribute
WaveGen See Also

Square wave duty cycle(20% to 80%) for Square waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Duty Cycle
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE 1150531

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • Duty cycle is the percentage of the period that the waveform is high.
  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:SQUare:DCYCle {value}
    :WGEN{WaveGen}:FUNCtion:SQUare:DCYCle?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY Attribute
WaveGen See Also

Frequency for Sine, Square, Ramp, and Pulse waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Frequency
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY 1150532

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FREQuency {value}
    :WGEN{WaveGen}:FREQuency?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION Attribute
WaveGen See Also

Type of waveform.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Function
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION 1150533

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion {SIN|SQU|RAMP|PULS|NOIS|DC|SINC|EXPR|EXPF|CARD|GAUS|ARB}
    :WGEN{WaveGen}:FUNCtion?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SINUSOID | Sine signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SQUARE | Square Wave signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_RAMP | Ramp Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_PULSE | Pulse Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_NOISE | Noise Signal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTIONDC | DC Level
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_SINE_CARDINAL | -- NOT SUPPORTED IN 2000 X-SERIES -- Sine Cardinal
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_EXPONENTIAL_RISE | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Rise
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_EXPONENTIAL_FALL | -- NOT SUPPORTED IN 2000 X-SERIES -- Exponential Fall
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_CARDIAC | -- NOT SUPPORTED IN 2000 X-SERIES -- Cardiac
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_GAUSSIAN_PULSE | -- NOT SUPPORTED IN 2000 X-SERIES -- Gaussian Pulse
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_FUNCTION_ARBITRARY | -- NOT SUPPORTED IN 2000 X-SERIES -- Arbitrary Waveform
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE Attribute
WaveGen See Also

High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen High Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE 1150534

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:HIGH {value}
    :WGEN{WaveGen}:VOLTage:HIGH?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE Attribute
WaveGen See Also

Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Low Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE 1150535

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:LOW {value}
    :WGEN{WaveGen}:VOLTage:LOW?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE Attribute
WaveGen See Also

Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Offset Voltage
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE 1150536

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:VOLTage:OFFSet {value}
    :WGEN{WaveGen}:VOLTage:OFFSet?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED Attribute
WaveGen See Also

Enables or Disables waveform generator signal output.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Output Enabled
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED 1150537

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut {ON|OFF}
    :WGEN{WaveGen}:OUTPut?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED Attribute
WaveGen See Also

Specifies whether the waveform generator output is inverted or not.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Output Inverted
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED 1150545

ViStatus AgInfiniiVision_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • True => Inverted
    • False => Normal

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut:POLarity {INV|NORM}
    :WGEN{WaveGen}:OUTPut:POLarity?

    Requirements

    Supported Models

    C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE Attribute
WaveGen See Also

Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Output Load Impedance
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE 1150538

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

If the actual load impedance is different than the selected value, the displayed amplitude and offset levels will be incorrect.

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:OUTPut:LOAD {ONEM|FIFT}
    :WGEN{WaveGen}:OUTPut:LOAD?

    Defined Values

    Name | Description
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_ONE_MEG | One Mega Ohm
AGINFINIIVISION_VAL_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE_FIFTY | Fifty Ohm
    Top

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AgInfiniiVision_OutputSingle Function

AgInfiniiVision_OutputSingle Function
WaveGen See Also

Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.

Function Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Output Single
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_OutputSingle(
    ViSession Vi,
    ViConstString WaveGen
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

WaveGen

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the WaveGen repeated capability.

Return Value

Success or failure code.

Instrument Command

:WGEN{WaveGen}:OUTPut:SINGle

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 3012T, DSO-X 3014T, DSO-X 3022T, DSO-X 3024T, DSO-X 3032T, DSO-X 3034T, DSO-X 3052T, DSO-X 3054T, DSO-X 3102T, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, M9241A, M9242A, M9243A, MSO-X 3012T, MSO-X 3014T, MSO-X 3022T, MSO-X 3024T, MSO-X 3032T, MSO-X 3034T, MSO-X 3052T, MSO-X 3054T, MSO-X 3102T, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

WaveGen
AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD Attribute
WaveGen See Also

Period in seconds for Sine, Square, Ramp, and Pulse waveforms

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Period
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD 1150539

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:PERiod {value}
    :WGEN{WaveGen}:PERiod?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH Attribute
WaveGen See Also

Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Pulse Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH 1150540

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:PULSe:WIDTh {value}
    :WGEN{WaveGen}:FUNCtion:PULSe:WIDTh?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY Attribute

AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY Attribute
WaveGen See Also

Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.

Attribute Tree Node: \AgInfiniiVision\Instrument Specific\WaveGen\WaveGen Ramp Symmetry
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY 1150541

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the WaveGen repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

  • On 4000X series, it supports both waveform generators (i.e. WaveGen1, WaveGen2).
  • On 3000X series, it supports one waveform generator only(i.e WaveGen1).
  • On 2000X series, it supports one waveform generator only (i.e WaveGen1).

    • Instrument Command

    :WGEN{WaveGen}:FUNCtion:RAMP:SYMMetry {value}
    :WGEN{WaveGen}:FUNCtion:RAMP:SYMMetry?

    Requirements

    Supported Models

    All supported

    See Also

    Reference

    WaveGen
    AgInfiniiVision


Trigger

Trigger
See Also

Tree Node: \AgInfiniiVision\Trigger

Branches

Name
AC Line Triggering
Edge Triggering
Glitch Triggering
Runt Triggering
TV Triggering
Width Triggering
Top

Attributes

 | Name | Description
Attribute | Trigger Coupling | How the oscilloscope couples the trigger source.
Attribute | Trigger Holdoff | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Attribute | Trigger Level | The voltage threshold for the trigger subsystem. The units are volts.
Attribute | Trigger Modifier | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Attribute | Trigger Source | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Attribute | Trigger Type | The kind of event that triggers the oscilloscope.
Top

See Also

Reference

AgInfiniiVision


AC Line Triggering

AC Line Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\AC Line Triggering

Attributes

 | Name | Description
Attribute | AC Line Trigger Slope | The slope of the zero crossing upon which the scope triggers.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE Attribute

AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE Attribute
AC Line Triggering See Also

The slope of the zero crossing upon which the scope triggers.

Attribute Tree Node: \AgInfiniiVision\Trigger\AC Line Triggering\AC Line Trigger Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE 1250701

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_AC_LINE_POSITIVE | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_NEGATIVE | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
AGINFINIIVISION_VAL_AC_LINE_EITHER | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.
Top

Requirements

Supported Models

C7302, C7302C, C7304, C7304C, C7312, C7312C, C7314, C7314C, C7322, C7322C, C7324, C7324C, C7332, C7332C, C7334, C7334C, C7352, C7352C, C7354, C7354C, DSO-X 1102A, DSO-X 1102G, DSO-X 2002A, DSO-X 2004A, DSO-X 2012A, DSO-X 2014A, DSO-X 2022A, DSO-X 2024A, DSO-X 3012A, DSO-X 3012T, DSO-X 3014A, DSO-X 3014T, DSO-X 3022T, DSO-X 3024A, DSO-X 3024T, DSO-X 3032A, DSO-X 3032T, DSO-X 3034A, DSO-X 3034T, DSO-X 3052A, DSO-X 3052T, DSO-X 3054A, DSO-X 3054T, DSO-X 3102A, DSO-X 3102T, DSO-X 3104A, DSO-X 3104T, DSO-X 4022A, DSO-X 4024A, DSO-X 4032A, DSO-X 4034A, DSO-X 4052A, DSO-X 4054A, DSO-X 4104A, DSO-X 4154A, DSO-X 6002A, DSO-X 6004A, DSOX1204A, DSOX1204G, EDU-X 1002A, EDU-X 1002G, MSO-X 2002A, MSO-X 2004A, MSO-X 2012A, MSO-X 2014A, MSO-X 2022A, MSO-X 2024A, MSO-X 3012A, MSO-X 3012T, MSO-X 3014A, MSO-X 3014T, MSO-X 3022T, MSO-X 3024A, MSO-X 3024T, MSO-X 3032A, MSO-X 3032T, MSO-X 3034A, MSO-X 3034T, MSO-X 3052A, MSO-X 3052T, MSO-X 3054A, MSO-X 3054T, MSO-X 3102A, MSO-X 3102T, MSO-X 3104A, MSO-X 3104T, MSO-X 4022A, MSO-X 4024A, MSO-X 4032A, MSO-X 4034A, MSO-X 4052A, MSO-X 4054A, MSO-X 4104A, MSO-X 4154A, MSO-X 6002A, MSO-X 6004A, P9241A, P9242A, P9243A

See Also

Reference

AC Line Triggering
AgInfiniiVision


Edge Triggering

Edge Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\Edge Triggering

Attributes

 | Name | Description
Attribute | Trigger Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SLOPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_SLOPE Attribute
Edge Triggering See Also

The slope, a rising or a falling edge, that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Trigger\Edge Triggering\Trigger Slope
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SLOPE 1250018

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Edge Triggering
AgInfiniiVision


Glitch Triggering

Glitch Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\Glitch Triggering

Attributes

 | Name | Description
Attribute | Glitch Condition | The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.
Attribute | Glitch Polarity | The polarity of the glitch that triggers the oscilloscope.
Attribute | Glitch Width | The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_GLITCH_CONDITION Attribute

AGINFINIIVISION_ATTR_GLITCH_CONDITION Attribute
Glitch Triggering See Also

The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.

Attribute Tree Node: \AgInfiniiVision\Trigger\Glitch Triggering\Glitch Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_GLITCH_CONDITION 1250403

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_GLITCH_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_GLITCH_LESS_THAN | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
AGINFINIIVISION_VAL_GLITCH_GREATER_THAN | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.
AGINFINIIVISION_VAL_GLITCH_CONDITION_RANGE | The oscilloscope triggers within a range of time values
Top

Requirements

Supported Models

All supported

See Also

Reference

Glitch Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_GLITCH_POLARITY Attribute

AGINFINIIVISION_ATTR_GLITCH_POLARITY Attribute
Glitch Triggering See Also

The polarity of the glitch that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Trigger\Glitch Triggering\Glitch Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_GLITCH_POLARITY 1250402

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_GLITCH_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_GLITCH_POSITIVE | The oscilloscope triggers on a positive glitch.
AGINFINIIVISION_VAL_GLITCH_NEGATIVE | The oscilloscope triggers on a negative glitch.
AGINFINIIVISION_VAL_GLITCH_EITHER | The oscilloscope triggers on either a positive or negative glitch.
Top

Requirements

Supported Models

All supported

See Also

Reference

Glitch Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_GLITCH_WIDTH Attribute

AGINFINIIVISION_ATTR_GLITCH_WIDTH Attribute
Glitch Triggering See Also

The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.

Attribute Tree Node: \AgInfiniiVision\Trigger\Glitch Triggering\Glitch Width
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_GLITCH_WIDTH 1250401

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_GLITCH_WIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Glitch Triggering
AgInfiniiVision


Runt Triggering

Runt Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\Runt Triggering

Attributes

 | Name | Description
Attribute | Runt High Threshold | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | Runt Low Threshold | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | Runt Polarity | The polarity of the runt that triggers the oscilloscope.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD Attribute

AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD Attribute
Runt Triggering See Also

The high threshold the oscilloscope uses for runt triggering. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Trigger\Runt Triggering\Runt High Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD 1250301

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Runt Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD Attribute

AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD Attribute
Runt Triggering See Also

The low threshold the oscilloscope uses for runt triggering. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Trigger\Runt Triggering\Runt Low Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD 1250302

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Runt Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_RUNT_POLARITY Attribute

AGINFINIIVISION_ATTR_RUNT_POLARITY Attribute
Runt Triggering See Also

The polarity of the runt that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Trigger\Runt Triggering\Runt Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_RUNT_POLARITY 1250303

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_RUNT_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_RUNT_POSITIVE | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
AGINFINIIVISION_VAL_RUNT_NEGATIVE | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
AGINFINIIVISION_VAL_RUNT_EITHER | The oscilloscope triggers on either a positive or negative runt.
Top

Requirements

Supported Models

All supported

See Also

Reference

Runt Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_COUPLING Attribute

AGINFINIIVISION_ATTR_TRIGGER_COUPLING Attribute
Trigger See Also

How the oscilloscope couples the trigger source.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Coupling
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_COUPLING 1250014

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_COUPLING.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_AC | The oscilloscope AC couples the trigger signal.
AGINFINIIVISION_VAL_DC | The oscilloscope DC couples the trigger signal.
AGINFINIIVISION_VAL_HF_REJECT | The oscilloscope filters out the high frequencies from the trigger signal.
AGINFINIIVISION_VAL_LF_REJECT | The oscilloscope filters out the low frequencies from the trigger signal.
AGINFINIIVISION_VAL_NOISE_REJECT | The oscilloscope filters out the noise from the trigger signal.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF Attribute

AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF Attribute
Trigger See Also

The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Holdoff
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF 1250016

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_LEVEL Attribute

AGINFINIIVISION_ATTR_TRIGGER_LEVEL Attribute
Trigger See Also

The voltage threshold for the trigger subsystem. The units are volts.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Level
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_LEVEL 1250017

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_LEVEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_MODIFIER Attribute

AGINFINIIVISION_ATTR_TRIGGER_MODIFIER Attribute
Trigger See Also

The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Modifier
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_MODIFIER 1250102

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_MODIFIER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_NO_TRIGGER_MOD | The oscilloscope waits until the trigger the end-user specifies occurs.
AGINFINIIVISION_VAL_AUTO | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.
AGINFINIIVISION_VAL_AUTO_LEVEL | The oscilloscope adjusts the trigger level if the trigger the end-user specifies does not occur.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_SOURCE Attribute

AGINFINIIVISION_ATTR_TRIGGER_SOURCE Attribute
Trigger See Also

The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Source
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_SOURCE 1250013

ViStatus AgInfiniiVision_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


AGINFINIIVISION_ATTR_TRIGGER_TYPE Attribute

AGINFINIIVISION_ATTR_TRIGGER_TYPE Attribute
Trigger See Also

The kind of event that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Trigger\Trigger Type
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TRIGGER_TYPE 1250012

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_EDGE_TRIGGER | Configures the oscilloscope for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source property passes the voltage threshold specified with the Trigger Level property &amp; Trigger Slope property.
AGINFINIIVISION_VAL_WIDTH_TRIGGER | Configures the oscilloscope for width triggering. Use the IviScopeWidthTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_RUNT_TRIGGER | Configures the oscilloscope for runt triggering. Use the IviScopeRuntTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_GLITCH_TRIGGER | Configures the oscilloscope for glitch triggering. Use the IviScopeGlitchTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_TV_TRIGGER | Configures the oscilloscope for triggering on TV signals. Use the IviScopeTVTrigger extension properties and methods to configure the trigger.
AGINFINIIVISION_VAL_IMMEDIATE_TRIGGER | NOT SUPPORTED
AGINFINIIVISION_VAL_AC_LINE_TRIGGER | Configures the oscilloscope for AC Line triggering. Use the IviScopeACLineTrigger extension properties and methods to configure the trigger.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgInfiniiVision


TV Triggering

TV Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\TV Triggering

Attributes

 | Name | Description
Attribute | TV Trigger Event | The event on which the oscilloscope triggers.
Attribute | TV Trigger Line Number | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Attribute | TV Trigger Polarity | The polarity of the TV signal.
Attribute | TV Trigger Signal Format | The format of the TV signal on which the oscilloscope triggers.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT Attribute

AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT Attribute
TV Triggering See Also

The event on which the oscilloscope triggers.

Attribute Tree Node: \AgInfiniiVision\Trigger\TV Triggering\TV Trigger Event
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT 1250205

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_TV_EVENT_FIELD1 | Sets the oscilloscope to trigger on field 1 of the video signal.
AGINFINIIVISION_VAL_TV_EVENT_FIELD2 | Sets the oscilloscope to trigger on field 2 of the video signal.
AGINFINIIVISION_VAL_TV_EVENT_ANY_FIELD | Sets the oscilloscope to trigger on any field.
AGINFINIIVISION_VAL_TV_EVENT_ANY_LINE | Sets the oscilloscope to trigger on any line.
AGINFINIIVISION_VAL_TV_EVENT_LINE_NUMBER | Sets the oscilloscope to trigger on a specific line number you specify with the TV Trigger Line Number property.
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_LINE_NUMBER_ALTERNATE2 | NOT SUPPORTED
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_LINE_NUMBER_VERTICAL2 | NOT SUPPORTED
AGINFINIIVISION_VAL_TV_TRIGGER_EVENT_VERTICAL2 | NOT SUPPORTED
Top

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER Attribute

AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER Attribute
TV Triggering See Also

The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.

Attribute Tree Node: \AgInfiniiVision\Trigger\TV Triggering\TV Trigger Line Number
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER 1250206

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY Attribute

AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY Attribute
TV Triggering See Also

The polarity of the TV signal.

Attribute Tree Node: \AgInfiniiVision\Trigger\TV Triggering\TV Trigger Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY 1250204

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_TV_POSITIVE | Configures the oscilloscope to trigger on a positive video sync pulse.
AGINFINIIVISION_VAL_TV_NEGATIVE | Configures the oscilloscope to trigger on a negative video sync pulse.
Top

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT Attribute

AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT Attribute
TV Triggering See Also

The format of the TV signal on which the oscilloscope triggers.

Attribute Tree Node: \AgInfiniiVision\Trigger\TV Triggering\TV Trigger Signal Format
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT 1250201

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_NTSC | Configures the oscilloscope to trigger on the NTSC signal format.
AGINFINIIVISION_VAL_PAL | Configures the oscilloscope to trigger on the PAL signal format
AGINFINIIVISION_VAL_SECAM | Configures the oscilloscope to trigger on the SECAM signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATPALM2 | Configures the oscilloscope to trigger on the PALM signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMAT_GENERIC2 | Configures the oscilloscope to trigger on the Generic signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP4802 | Configures the oscilloscope to trigger on the P480 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATI10802 | Configures the oscilloscope to trigger on the I1080 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP7202 | Configures the oscilloscope to trigger on the P720 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP10802 | Configures the oscilloscope to trigger on the P1080 signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L25HZ2 | Configures the oscilloscope to trigger on the P1080L25Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L60HZ2 | Configures the oscilloscope to trigger on the P1080L60Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATP1080L50HZ2 | Configures the oscilloscope to trigger on the P1080L50Hz signal format
AGINFINIIVISION_VAL_TV_SIGNAL_FORMATI1080L60HZ2 | Configures the oscilloscope to trigger on the I1080L60Hz signal format
Top

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgInfiniiVision


Width Triggering

Width Triggering
See Also

Tree Node: \AgInfiniiVision\Trigger\Width Triggering

Attributes

 | Name | Description
Attribute | Width Condition | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Attribute | Width High Threshold | The high width threshold time. The units are seconds.
Attribute | Width Low Threshold | The low width threshold time. The units are seconds.
Attribute | Width Polarity | The polarity of the pulse that triggers the oscilloscope.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_WIDTH_CONDITION Attribute

AGINFINIIVISION_ATTR_WIDTH_CONDITION Attribute
Width Triggering See Also

The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.

Attribute Tree Node: \AgInfiniiVision\Trigger\Width Triggering\Width Condition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WIDTH_CONDITION 1250504

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WIDTH_CONDITION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_WIDTH_WITHIN | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold.
AGINFINIIVISION_VAL_WIDTH_OUTSIDE | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold.
Top

Requirements

Supported Models

All supported

See Also

Reference

Width Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD Attribute

AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD Attribute
Width Triggering See Also

The high width threshold time. The units are seconds.

Attribute Tree Node: \AgInfiniiVision\Trigger\Width Triggering\Width High Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD 1250502

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Width Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD Attribute

AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD Attribute
Width Triggering See Also

The low width threshold time. The units are seconds.

Attribute Tree Node: \AgInfiniiVision\Trigger\Width Triggering\Width Low Threshold
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD 1250501

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Width Triggering
AgInfiniiVision


AGINFINIIVISION_ATTR_WIDTH_POLARITY Attribute

AGINFINIIVISION_ATTR_WIDTH_POLARITY Attribute
Width Triggering See Also

The polarity of the pulse that triggers the oscilloscope.

Attribute Tree Node: \AgInfiniiVision\Trigger\Width Triggering\Width Polarity
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_WIDTH_POLARITY 1250503

ViStatus AgInfiniiVision_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_WIDTH_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGINFINIIVISION_VAL_WIDTH_POSITIVE | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_NEGATIVE | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
AGINFINIIVISION_VAL_WIDTH_EITHER | Configures the oscilloscope to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
Top

Requirements

Supported Models

All supported

See Also

Reference

Width Triggering
AgInfiniiVision


Utility

Utility
See Also

Tree Node: \AgInfiniiVision\Utility

Functions

 | Name | Description
Function | Clear Error | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | Error Message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | Error Query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | Get Error | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | Get Next Coercion Record | Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | Invalidate All Attributes | Invalidates all of the driver's cached values.
Function | Is Waveform Element Invalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Function | Lock Session | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | Reset With Defaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | Revision Query | Retrieves revision information from the instrument.
Function | Self Test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | Unlock Session | Releases a previously obtained mutlithread lock.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_ClearError Function

AgInfiniiVision_ClearError Function
Utility See Also

This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.

Function Tree Node: \AgInfiniiVision\Utility\Clear Error
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ClearError(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_Disable Function

AgInfiniiVision_Disable Function
Utility See Also

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

Function Tree Node: \AgInfiniiVision\Utility\Disable
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_Disable(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_error_message Function

AgInfiniiVision_error_message Function
Utility See Also

Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Function Tree Node: \AgInfiniiVision\Utility\Error Message
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_error_message(
    ViSession Vi,
    ViStatus ErrorCode,
    ViChar[] ErrorMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Instrument driver status code.

ErrorMessage

Instrument driver error message.

Return Value

Success or failure code.

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_error_query Function

AgInfiniiVision_error_query Function
Utility See Also

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Function Tree Node: \AgInfiniiVision\Utility\Error Query
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_error_query(
    ViSession Vi,
    ViInt32* ErrorCode,
    ViChar[] ErrorMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Instrument error code

ErrorMessage

Instrument error message

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_GetError Function

AgInfiniiVision_GetError Function
Utility See Also

This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.

Function Tree Node: \AgInfiniiVision\Utility\Get Error
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetError(
    ViSession Vi,
    ViStatus* ErrorCode,
    ViInt32 ErrorDescriptionBufferSize,
    ViChar[] ErrorDescription
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Returns the error code. Zero indicates that no error occurred. A positive value indicates a warning. A negative value indicates an error. The user can pass VI_NULL if the user does not want to retrieve this value.

ErrorDescriptionBufferSize

The number of bytes in the ViChar array that the user specifies for the ErrorDescription parameter.

ErrorDescription

Buffer into which the function copies the full formatted error string. The string describes the error code and any extra information regarding the error or warning condition. The buffer shall contain at least as many bytes as the user specifies in the ErrorDescriptionBufferSize parameter. The user can pass VI_NULL if the ErrorDescriptionBufferSize parameter is zero.

Return Value

Success or failure code.

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_GetNextCoercionRecord Function

AgInfiniiVision_GetNextCoercionRecord Function
Utility See Also

Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Function Tree Node: \AgInfiniiVision\Utility\Get Next Coercion Record
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_GetNextCoercionRecord(
    ViSession Vi,
    ViInt32 CoercionRecordBufferSize,
    ViChar[] CoercionRecord
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CoercionRecordBufferSize

Buffer Size.

CoercionRecord

The coercion record string shall contain the following information: (1) The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant. (2) If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.(3) If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.(4) The value that the user specified for the attribute.(5) The value to which the attribute was coerced.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_InvalidateAllAttributes Function

AgInfiniiVision_InvalidateAllAttributes Function
Utility See Also

Invalidates all of the driver's cached values.

Function Tree Node: \AgInfiniiVision\Utility\Invalidate All Attributes
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_InvalidateAllAttributes(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_IsInvalidWfmElement Function

AgInfiniiVision_IsInvalidWfmElement Function
Utility See Also

Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Function Tree Node: \AgInfiniiVision\Utility\Is Waveform Element Invalid
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_IsInvalidWfmElement(
    ViSession Vi,
    ViReal64 elementValue,
    ViBoolean* IsInvalid
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

elementValue

Pass one of the values from the waveform array returned by the read and fetch waveform methods.

IsInvalid

Returns whether true when the elementValue is a valid voltage or false for a value indicating that the oscilloscope could not sample a voltage.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_LockSession Function

AgInfiniiVision_LockSession Function
Utility See Also

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

Function Tree Node: \AgInfiniiVision\Utility\Lock Session
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_LockSession(
    ViSession Vi,
    ViBoolean* CallerHasLock
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CallerHasLock

Return if Caller has lock.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_reset Function

AgInfiniiVision_reset Function
Utility See Also

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

Function Tree Node: \AgInfiniiVision\Utility\Reset
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_reset(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_ResetWithDefaults Function

AgInfiniiVision_ResetWithDefaults Function
Utility See Also

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Function Tree Node: \AgInfiniiVision\Utility\Reset With Defaults
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ResetWithDefaults(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_revision_query Function

AgInfiniiVision_revision_query Function
Utility See Also

Retrieves revision information from the instrument.

Function Tree Node: \AgInfiniiVision\Utility\Revision Query
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_revision_query(
    ViSession Vi,
    ViChar[] DriverRev,
    ViChar[] InstrRev
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DriverRev

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision attribute. Refer to the Specific Driver Revision attribute for more information.

InstrRev

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision attribute. Refer to the Instrument Firmware Revision attribute for more information.

Return Value

Success or failure code.

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_self_test Function

AgInfiniiVision_self_test Function
Utility See Also

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

Function Tree Node: \AgInfiniiVision\Utility\Self Test
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_self_test(
    ViSession Vi,
    ViInt16* TestResult,
    ViChar[] TestMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

TestResult

The numeric result from the self test operation. 0 = no error (test passed)

TestMessage

The self test status message

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


AgInfiniiVision_UnlockSession Function

AgInfiniiVision_UnlockSession Function
Utility See Also

Releases a previously obtained mutlithread lock.

Function Tree Node: \AgInfiniiVision\Utility\Unlock Session
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_UnlockSession(
    ViSession Vi,
    ViBoolean* CallerHasLock
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CallerHasLock

Return if caller has lock.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgInfiniiVision


Waveform Acquisition

Waveform Acquisition
See Also

Tree Node: \AgInfiniiVision\Waveform Acquisition

Branches

Name
Low-Level Acquisition
Top

Functions

 | Name | Description
Function | Read Min Max Waveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | Read Waveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | Read Waveform Measurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Top

See Also

Reference

AgInfiniiVision


Low-Level Acquisition

Low-Level Acquisition
See Also

Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition

Functions

 | Name | Description
Function | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | Acquisition Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | Fetch Min Max Waveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | Fetch Waveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | Fetch Waveform Measurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | Initiate Acquisition | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Top

See Also

Reference

AgInfiniiVision


AgInfiniiVision_Abort Function

AgInfiniiVision_Abort Function
Low-Level Acquisition See Also

Aborts an acquisition and returns the oscilloscope to the Idle state.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Abort
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_Abort(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_AcquisitionStatus Function

AgInfiniiVision_AcquisitionStatus Function
Low-Level Acquisition See Also

Returns whether an acquisition is in progress, complete, or if the status is unknown.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Acquisition Status
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_AcquisitionStatus(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Status

Acquisition Status. May be one of the values define by IviScopeAcquisitionStatusEnum.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGINFINIIVISION_VAL_ACQ_IN_PROGRESS | The oscilloscope is still acquiring data.
AGINFINIIVISION_VAL_ACQ_COMPLETE | The oscilloscope has completed the acquisition.
AGINFINIIVISION_VAL_ACQ_STATUS_UNKNOWN | The oscilloscope cannot determine the status of the acquisition.
Top

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_FetchMinMaxWaveform Function

AgInfiniiVision_FetchMinMaxWaveform Function
Low-Level Acquisition See Also

Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Fetch Min Max Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FetchMinMaxWaveform(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 WaveformSize,
    ViReal64[] MinWaveform,
    ViReal64[] MaxWaveform,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

WaveformSize

Waveform size.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_FetchWaveform Function

AgInfiniiVision_FetchWaveform Function
Low-Level Acquisition See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FetchWaveform(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 WaveformSize,
    ViReal64[] WaveformArray,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

WaveformSize

Waveform size.

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_FetchWaveformMeasurement Function

AgInfiniiVision_FetchWaveformMeasurement Function
Low-Level Acquisition See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_FetchWaveformMeasurement(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 MeasFunction,
    ViReal64* Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter MeasFunction

Name | Description
AGINFINIIVISION_VAL_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGINFINIIVISION_VAL_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGINFINIIVISION_VAL_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGINFINIIVISION_VAL_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGINFINIIVISION_VAL_VOLTAGE_RMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_RMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_OVERSHOOT | The relative waveform distortion that follows an edge transition.
AGINFINIIVISION_VAL_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MAX2 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_FREQUENCY_COUNTER2 | The High precision frequency measurement made with an internal frequency counter.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MIN2 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_DELAY2 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AGINFINIIVISION_VAL_MEASUREMENT_VALUE_AT_TIME2 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_PHASE2 | This measures the relative phase of one waveform with respect to the period on another waveform.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_VALUE2 | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_OF_EDGE2 | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_AREA2 | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_BURST_WIDTH2 | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_STANDARD_DEVIATION2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
Top

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_InitiateAcquisition Function

AgInfiniiVision_InitiateAcquisition Function
Low-Level Acquisition See Also

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Low-Level Acquisition\Initiate Acquisition
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_InitiateAcquisition(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgInfiniiVision


AgInfiniiVision_ReadMinMaxWaveform Function

AgInfiniiVision_ReadMinMaxWaveform Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Read Min Max Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReadMinMaxWaveform(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 WaveformSize,
    ViInt32 MaxTimeMilliseconds,
    ViReal64[] MinWaveform,
    ViReal64[] MaxWaveform,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

WaveformSize

Waveform size.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgInfiniiVision


AgInfiniiVision_ReadWaveform Function

AgInfiniiVision_ReadWaveform Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Read Waveform
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReadWaveform(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 WaveformSize,
    ViInt32 MaxTimeMilliseconds,
    ViReal64[] WaveformArray,
    ViInt32* ActualPoints,
    ViReal64* InitialX,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

WaveformSize

Waveform size.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

WaveformArray

The array contains the acquired waveform. Units for the individual array elements are in volts.

ActualPoints

Number of points acquired.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgInfiniiVision


AgInfiniiVision_ReadWaveformMeasurement Function

AgInfiniiVision_ReadWaveformMeasurement Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Function Tree Node: \AgInfiniiVision\Waveform Acquisition\Read Waveform Measurement
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
ViStatus AgInfiniiVision_ReadWaveformMeasurement(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 MeasFunction,
    ViInt32 MaxTimeMilliseconds,
    ViReal64* Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviScope_init or IviScope_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel.For valid values, see the Channel repeated capability.

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter MeasFunction

Name | Description
AGINFINIIVISION_VAL_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGINFINIIVISION_VAL_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGINFINIIVISION_VAL_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGINFINIIVISION_VAL_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGINFINIIVISION_VAL_VOLTAGE_RMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods.
AGINFINIIVISION_VAL_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGINFINIIVISION_VAL_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGINFINIIVISION_VAL_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGINFINIIVISION_VAL_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_RMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGINFINIIVISION_VAL_OVERSHOOT | The relative waveform distortion that follows an edge transition.
AGINFINIIVISION_VAL_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MAX2 | The time of the maximum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_FREQUENCY_COUNTER2 | The High precision frequency measurement made with an internal frequency counter.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_MIN2 | The time of the minimum amplitude found in the entire waveform. The units are seconds.
AGINFINIIVISION_VAL_MEASUREMENT_DELAY2 | This measure the delay between any two user specified edges. The edges can be from the same waveform or different waveform.
AGINFINIIVISION_VAL_MEASUREMENT_VALUE_AT_TIME2 | This returns the Value at the user-specified time. This time is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_PHASE2 | This measures the relative phase of one waveform with respect to the period on another waveform.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_AT_VALUE2 | This returns the Time at the user-specified vertical value. This vertical value is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_TIME_OF_EDGE2 | This returns the Time at the user specified edge crossing. This edge is user specified in the Configurable Measurement interface.
AGINFINIIVISION_VAL_MEASUREMENT_AREA2 | Area measurements show the area between the waveform and the ground level. This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_BURST_WIDTH2 | -- NOT SUPPORTED IN 2000 X-SERIES -- the width of the burst on the screen. The burst width is calculated as follows: burst width = (last edge on screen - first edge on screen)This option is not available if the source is FFT (Fast Fourier Transform).
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling edge count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_EDGE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising edge count.
AGINFINIIVISION_VAL_MEASUREMENT_FALLING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen falling pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_RISING_PULSE_COUNT2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the on-screen rising pulse count.
AGINFINIIVISION_VAL_MEASUREMENT_STANDARD_DEVIATION2 | -- NOT SUPPORTED IN 2000 X-SERIES -- Measures the standard deviation of the selected waveform. The oscilloscope computes the standard deviation on all displayed data points.
Top

See Also

Reference

Waveform Acquisition
AgInfiniiVision


Waveform Measurement

Waveform Measurement
See Also

Tree Node: \AgInfiniiVision\Waveform Measurement

Attributes

 | Name | Description
Attribute | Measurement High Reference | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | Measurement Low Reference | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | Measurement Middle Reference | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

See Also

Reference

AgInfiniiVision


AGINFINIIVISION_ATTR_MEAS_HIGH_REF Attribute

AGINFINIIVISION_ATTR_MEAS_HIGH_REF Attribute
Waveform Measurement See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgInfiniiVision\Waveform Measurement\Measurement High Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEAS_HIGH_REF 1250607

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEAS_HIGH_REF.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Measurement
AgInfiniiVision


AGINFINIIVISION_ATTR_MEAS_LOW_REF Attribute

AGINFINIIVISION_ATTR_MEAS_LOW_REF Attribute
Waveform Measurement See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgInfiniiVision\Waveform Measurement\Measurement Low Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEAS_LOW_REF 1250608

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEAS_LOW_REF.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Measurement
AgInfiniiVision


AGINFINIIVISION_ATTR_MEAS_MID_REF Attribute

AGINFINIIVISION_ATTR_MEAS_MID_REF Attribute
Waveform Measurement See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgInfiniiVision\Waveform Measurement\Measurement Middle Reference
Declaration: AgInfiniiVision.h
Implementation: AgInfiniiVision.dll

Syntax

Visual C++
#define AGINFINIIVISION_ATTR_MEAS_MID_REF 1250609

ViStatus AgInfiniiVision_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgInfiniiVision_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGINFINIIVISION_ATTR_MEAS_MID_REF.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Measurement
AgInfiniiVision


Functions and Attributes

Functions and Attributes

Functions

 | Name | Description
Function | AgInfiniiVision_Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | AgInfiniiVision_AcquisitionSetSampleMode | Sets the acquisition mode of the oscilloscope.
Function | AgInfiniiVision_AcquisitionSingleAcquisition | Acquires a single trigger of data.
Function | AgInfiniiVision_AcquisitionStatus | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | AgInfiniiVision_AcquisitionStop | Stops the acquisition.
Function | AgInfiniiVision_ActualRecordLength | This function returns the actual number of points the oscilloscope acquires per channel. After configuring the oscilloscope for an acquisition, call this function to determine the size of the waveforms that the oscilloscope acquires. The value is equal to or greater than the minimum number of points specified in the Configure Acquisition Record function. For IVI-C drivers, allocate a ViReal64 array of this size or greater to pass as the WaveformArray parameter of the IviScope_ReadWaveform and IviScope_FetchWaveform functions. The oscilloscope may use different size records depending on the acquisition type. Specify the acquisition type with the Configure Acquisition Type function.
Function | AgInfiniiVision_AnalogBusClear | Excludes all of the analog channels from the selected bus definition.
Function | AgInfiniiVision_AnalogBusGetBit | Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.
Function | AgInfiniiVision_AnalogBusGetBits | Returns the definition for the specified bus.
Function | AgInfiniiVision_AnalogBusSetBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | AgInfiniiVision_AnalogBusSetBits | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Function | AgInfiniiVision_AutoProbeSenseValue | The function returns the probe attenuation value the oscilloscope senses. The capability is enabled by setting the probeAttenuation parameter of the Configure Channel function to Probe Sense On. If the automatic probe sense capability is disabled, this function returns the manual probe attenuation setting.
Function | AgInfiniiVision_AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | AgInfiniiVision_CalibrationCalibrate | Starts the user calibration procedure. See the User's Guide for details.
Function | AgInfiniiVision_CalibrationResult | Read Only- Summary results of the last user calibration procedure.
Function | AgInfiniiVision_ChannelClearProtection | Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.
Function | AgInfiniiVision_ClearError | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | AgInfiniiVision_ClockRecoveryGetMethod | Returns the currently selected clock recovery method.
Function | AgInfiniiVision_ClockRecoverySetMethod | Sets the clock recovery method.
Function | AgInfiniiVision_close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | AgInfiniiVision_ConfigureAcLineTriggerSlope | This function configures the slope of the AC Line trigger. This function affects instrument behavior only if the trigger type is AC Line Trigger. Call the Configure Trigger function to set the trigger type before calling this function.
Function | AgInfiniiVision_ConfigureAcquisitionRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Function | AgInfiniiVision_ConfigureAcquisitionType | This function configures how the oscilloscope acquires data and fills the waveform record.
Function | AgInfiniiVision_ConfigureChanCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Function | AgInfiniiVision_ConfigureChannel | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Function | AgInfiniiVision_ConfigureEdgeTriggerSource | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Function | AgInfiniiVision_ConfigureGlitchTriggerSource | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Function | AgInfiniiVision_ConfigureInitiateContinuous | This function configures the oscilloscope to perform a continuous acquisition.
Function | AgInfiniiVision_ConfigureInterpolation | This function configures the interpolation method the oscilloscope uses when it cannot sample a voltage for a point in the waveform record.
Function | AgInfiniiVision_ConfigureNumAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Function | AgInfiniiVision_ConfigureNumEnvelopes | This function configures the number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms.
Function | AgInfiniiVision_ConfigureRefLevels | Configures the reference levels for waveform measurements, low, mid, and high.
Function | AgInfiniiVision_ConfigureRuntTriggerSource | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Function | AgInfiniiVision_ConfigureSearchEdge | Configures the Source and Slope properties for an Edge search.
Function | AgInfiniiVision_ConfigureSearchGlitch | Configures the Source, Polarity and Condition properties for the Glitch search.
Function | AgInfiniiVision_ConfigureSearchRunt | Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.
Function | AgInfiniiVision_ConfigureSearchTransition | Configures the Source, Slope, Condition and QualifierTime properties for a transition search.
Function | AgInfiniiVision_ConfigureTrigger | Configures trigger Type and Holdoff. Holdoff units are seconds.
Function | AgInfiniiVision_ConfigureTriggerCoupling | This function sets the trigger coupling attribute.
Function | AgInfiniiVision_ConfigureTriggerDelay | Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.
Function | AgInfiniiVision_ConfigureTriggerEdgeBurst | Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.
Function | AgInfiniiVision_ConfigureTriggerModifier | This function configures the oscilloscope's trigger modifier.
Function | AgInfiniiVision_ConfigureTriggerSetupAndHold | Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.
Function | AgInfiniiVision_ConfigureTriggerTransition | Configures the source, slope, condition and qualifier time parameters for the Transition trigger.
Function | AgInfiniiVision_ConfigureTriggerUSB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.
Function | AgInfiniiVision_ConfigureTVTriggerLineNumber | This function configures the TV line upon which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal. This function affects instrument behavior only if the trigger type is set to the TV Trigger value and the TV trigger event is set to the TV Event Line Number value. Call the Configure TV Trigger Source function to set the TV trigger event before calling this function.
Function | AgInfiniiVision_ConfigureTVTriggerSource | Configures the TV trigger source, signal format, event and polarity.
Function | AgInfiniiVision_ConfigureWidthTriggerSource | Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Function | AgInfiniiVision_CounterConfigure | This method sets the Counter mode, source and Number of digits of resolution.
Function | AgInfiniiVision_CounterTotalizeClear | Zeros the edge event counter.
Function | AgInfiniiVision_CounterTotalizeGatedConfigure | This method sets the totalize gated source and polarity.
Function | AgInfiniiVision_DigitalChannelBusClear | Excludes all of the digital channels from the selected bus definition.
Function | AgInfiniiVision_DigitalChannelBusEnable | Display the selected bus.
Function | AgInfiniiVision_DigitalChannelBusGetChannelBit | Returns the definition for the specified bus.
Function | AgInfiniiVision_DigitalChannelBusGetLabel | Returns the label of the specified bus.
Function | AgInfiniiVision_DigitalChannelBusGetMaskBit | Returns the mask value for the specified bus.
Function | AgInfiniiVision_DigitalChannelBusIsDigitalBitEnabled | Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.
Function | AgInfiniiVision_DigitalChannelBusIsEnabled | Returns the flag indicating whether the specified bus is enabled or disabled.
Function | AgInfiniiVision_DigitalChannelBusSetChannelBit | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Function | AgInfiniiVision_DigitalChannelBusSetDigitalBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | AgInfiniiVision_DigitalChannelBusSetLabel | The bus label.
Function | AgInfiniiVision_DigitalChannelBusSetMaskBit | Bits to be included and excluded in the selected bus according to the mask.
Function | AgInfiniiVision_DigitalChannelFetchDigitalWaveform | Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.
Function | AgInfiniiVision_DigitalChannelReadActivity | Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.
Function | AgInfiniiVision_DigitalChannelReadDigitalWaveform | Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.
Function | AgInfiniiVision_DigitalChannelResetActivity | Clears the logic activity registers of the oscilloscope.
Function | AgInfiniiVision_Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | AgInfiniiVision_DisplayAnnotationGetBackground | Gets the background of the annotation.
Function | AgInfiniiVision_DisplayAnnotationGetColor | Gets the annotation color.
Function | AgInfiniiVision_DisplayAnnotationGetEnabled | Get the state of annotation.
Function | AgInfiniiVision_DisplayAnnotationGetText | Gets the annotation string.
Function | AgInfiniiVision_DisplayAnnotationGetX1Position | Gets the annotation's horizontal X1 position.
Function | AgInfiniiVision_DisplayAnnotationGetY1Position | Gets the annotation's vertical Y1 position.
Function | AgInfiniiVision_DisplayAnnotationSetBackground | Sets the background of the annotation.
Function | AgInfiniiVision_DisplayAnnotationSetColor | Sets the annotation color.
Function | AgInfiniiVision_DisplayAnnotationSetEnabled | Enable or disable the annotation.
Function | AgInfiniiVision_DisplayAnnotationSetText | Sets the annotation string.
Function | AgInfiniiVision_DisplayAnnotationSetX1Position | Sets the annotation's horizontal X1 position.
Function | AgInfiniiVision_DisplayAnnotationSetY1Position | Sets the annotation's vertical Y1 position.
Function | AgInfiniiVision_DisplayErase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.
Function | AgInfiniiVision_DisplayGetScreenBitmap | Reads screen image data
Function | AgInfiniiVision_error_message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | AgInfiniiVision_error_query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | AgInfiniiVision_FetchJitterMeasurement | Returns the measured value of the selected measurement.
Function | AgInfiniiVision_FetchMinMaxWaveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgInfiniiVision_FFTClear | Clears the number of evaluated waveforms.
Function | AgInfiniiVision_ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.
Function | AgInfiniiVision_FRAFetchData | Fetch the frequency response analysis data.
Function | AgInfiniiVision_FRAGetAmplitudeProfile | Returns waveform generator amplitude in the frequency response analysis.
Function | AgInfiniiVision_FRARun | Initiates the Frequency Response Analysis.
Function | AgInfiniiVision_FRASetAmplitudeProfile | Return the waveform generator's output sine wave amplitude.
Function | AgInfiniiVision_GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetChannelName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the ChannelIndex parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the ChannelName parameter and returns an error.
Function | AgInfiniiVision_GetDigitalChannelName | Returns the digitalchannel name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetError | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | AgInfiniiVision_GetListerData | Gets the lister data as a string.
Function | AgInfiniiVision_GetMathFunctionName | Returns the mathfunction name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetMeasurementName | Returns the measurement name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetNextCoercionRecord | Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | AgInfiniiVision_GetProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Function | AgInfiniiVision_GetSearchGlitchRange | Gets the pulse width duration time (in seconds) for the selected source.
Function | AgInfiniiVision_GetSearchSerialI2SRange | Gets the data value range when searching for I2S events.
Function | AgInfiniiVision_GetSerialBusARINC429TriggerRange | Gets the range for the Label Range trigger mode for the selected bus.
Function | AgInfiniiVision_GetSerialBusI2STriggerRange | Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Function | AgInfiniiVision_GetSerialBusName | Returns the serialbus name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetStatisticsResults | Returns the results of the continuously displayed measurements.
Function | AgInfiniiVision_GetWaveGenName | Returns the wavegen name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_HistogramGetResult | Returns the histogram result of the selected result type.
Function | AgInfiniiVision_HistogramReset | Zeros the histogram counters.
Function | AgInfiniiVision_IncrementStatistics | This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.
Function | AgInfiniiVision_init | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgInfiniiVision_InitiateAcquisition | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Function | AgInfiniiVision_InitWithOptions | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgInfiniiVision_InstallMeasurementStatistics | Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.
Function | AgInfiniiVision_InvalidateAllAttributes | Invalidates all of the driver's cached values.
Function | AgInfiniiVision_IsInvalidWfmElement | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Function | AgInfiniiVision_JitterConfigureHistogram | Auto-configures and turns on the jitter measurement histogram for the selected measurement.
Function | AgInfiniiVision_JitterSpectrumConfigure | Auto-configures and turns on the jitter spectrum for the selected measurement.
Function | AgInfiniiVision_JitterTrendConfigure | Auto-configures and turns on the jitter measurement trend for the selected measurement.
Function | AgInfiniiVision_JitterTrendConfigureSmoothing | Auto-configures and turns on smoothing for the jitter measurement trend.
Function | AgInfiniiVision_LockSession | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | AgInfiniiVision_MaskTestDelete | Deletes the currently loaded mask.
Function | AgInfiniiVision_MaskTestReset | Resets the mask statistics.
Function | AgInfiniiVision_MastTestAutoMask | Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.
Function | AgInfiniiVision_MeasurementConfigurationConfigureDelay | Configures the edge specifications for the delay and phase measurements.
Function | AgInfiniiVision_MeasurementConfigureJitterMeasurement | Configure and adds the selected Jitter measurement.
Function | AgInfiniiVision_MeasurementFetchMinMaxWaveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_MeasurementFetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_MeasurementFetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgInfiniiVision_MeasurementReadJitterMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.
Function | AgInfiniiVision_MeasurementReadMinMaxWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | AgInfiniiVision_MeasurementReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | AgInfiniiVision_MeasurementReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgInfiniiVision_MeasurementsAbort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | AgInfiniiVision_MeasurementsAcquisitionStatus | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | AgInfiniiVision_MeasurementsAutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | AgInfiniiVision_MeasurementsClear | Clears all selected measurements and markers from the screen
Function | AgInfiniiVision_MeasurementsInitiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Function | AgInfiniiVision_MeasurementsIsInvalidWfmElement | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Function | AgInfiniiVision_MemoryRecall | Recall option for Mask, Oscilloscope Setup and Reference memory.
Function | AgInfiniiVision_MemorySave | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.
Function | AgInfiniiVision_OutputSingle | Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.
Function | AgInfiniiVision_ReadMinMaxWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | AgInfiniiVision_ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | AgInfiniiVision_ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgInfiniiVision_ReferenceWaveformClear | Clears the specified reference waveform location.
Function | AgInfiniiVision_ReferenceWaveformEnable | Enables/Disables the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetLabel | Returns the Label associated with a specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetOffset | Returns the Current offset value for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetRange | Returns the Current full-scale range for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetSkewFactor | Returns the Current skew factor for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetVerticalScale | Returns the Current vertical units per division for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformIsEnabled | Returns the Current display setting of the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSave | Copies the analog channel or math function waveform to the specified reference waveform location.
Function | AgInfiniiVision_ReferenceWaveformSetLabel | Label for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetOffset | Offset value that is represented at center screen for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetRange | Full-scale range of vertical axis of the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetSkewFactor | Skew factor for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetVerticalScale | Vertical scale, or units per division, of the selected reference waveform.
Function | AgInfiniiVision_reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | AgInfiniiVision_ResetArbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | AgInfiniiVision_ResetSerialBusARINC429Counters | Resets the ARINC 429 counters.
Function | AgInfiniiVision_ResetSerialBusCounters | Resets the frame counters.
Function | AgInfiniiVision_ResetSerialBusFlexRayCounters | Resets the FlexRay frame counters.
Function | AgInfiniiVision_ResetSerialBusUARTCounters | This method resets the UART frame counters.
Function | AgInfiniiVision_ResetStatistics | This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.
Function | AgInfiniiVision_ResetWaveformGenerator | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Function | AgInfiniiVision_ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | AgInfiniiVision_revision_query | Retrieves revision information from the instrument.
Function | AgInfiniiVision_SampleMode | This function returns the sample mode the oscilloscope is currently using.
Function | AgInfiniiVision_SampleRate | This function returns the effective sample rate of the acquired waveform using the current configuration in samples per second.
Function | AgInfiniiVision_SegmentedMemoryAnalyze | Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.
Function | AgInfiniiVision_self_test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | AgInfiniiVision_SerialBusARINC429AutoSetup | Automatically configures settings for the ARINC 429 serial bus mode.
Function | AgInfiniiVision_SerialBusFlexRayAutoSetup | Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.
Function | AgInfiniiVision_SerialBusFlexRayTriggerEventAutoSetup | Presets oscilloscope parameters for the selected event type.
Function | AgInfiniiVision_SerialBusM1553AutoSetup | This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.
Function | AgInfiniiVision_SerialBusSentGetSignalDisplay | This method specifies whether the given signal is on or off.
Function | AgInfiniiVision_SerialBusSentGetSignalLength | Gets the bit length of the signal being defined.
Function | AgInfiniiVision_SerialBusSentGetSignalMultiplier | Gets the multiplier value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentGetSignalNibbleOrder | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | AgInfiniiVision_SerialBusSentGetSignalOffset | Gets the offset value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentGetSignalStartPosition | Gets the starting bit of the Fast Signal being defined.
Function | AgInfiniiVision_SerialBusSentSetSignalDisplay | Set the given signal is on or off.
Function | AgInfiniiVision_SerialBusSentSetSignalLength | Sets the bit length of the signal being defined.
Function | AgInfiniiVision_SerialBusSentSetSignalMultiplier | Sets the multiplier value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentSetSignalNibbleOrder | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | AgInfiniiVision_SerialBusSentSetSignalOffset | Sets the offset value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentSetSignalStartPosition | Sets the starting bit of the Fast Signal being defined.
Function | AgInfiniiVision_SetArbitraryDACData | Downloads an arbitrary waveform in integer (DAC) values.
Function | AgInfiniiVision_SetArbitraryData | Downloads an arbitrary waveform in floating-point values format.
Function | AgInfiniiVision_SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetSearchGlitchRange | Sets the pulse width duration time (in seconds) for the selected source.
Function | AgInfiniiVision_SetSearchSerialI2SRange | Sets the data value range when searching for I2S events.
Function | AgInfiniiVision_SetSerialBusARINC429TriggerRange | Sets the range for the Label Range trigger mode for the selected bus.
Function | AgInfiniiVision_SetSerialBusI2STriggerRange | Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Function | AgInfiniiVision_StatusClear | Clears all event registers and error queue. The enable registers are unaffected.
Function | AgInfiniiVision_StatusConfigureServiceRequest | Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.
Function | AgInfiniiVision_StatusGetRegister | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Function | AgInfiniiVision_StatusPreset | Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.
Function | AgInfiniiVision_StatusSetRegister | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Function | AgInfiniiVision_StoreArbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Function | AgInfiniiVision_SystemClearIO | Performs an IEEE 488.1-style clear of the device.
Function | AgInfiniiVision_SystemDisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.
Function | AgInfiniiVision_SystemEnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.
Function | AgInfiniiVision_SystemGetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.
Function | AgInfiniiVision_SystemPutState | Writes binary instrument state as saved by GetState method.
Function | AgInfiniiVision_SystemReadBytes | Reads a complete response from the instrument and returns it as an array of bytes.
Function | AgInfiniiVision_SystemReadString | Reads a complete response from the instrument and returns it as a string.
Function | AgInfiniiVision_SystemRecallState | Restore the instrument to a state previously stored in the instrument's internal memory.
Function | AgInfiniiVision_SystemSaveState | Save the instrument's state to the instrument's internal memory.
Function | AgInfiniiVision_SystemWaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.
Function | AgInfiniiVision_SystemWriteBytes | Write an array of bytes to the device.
Function | AgInfiniiVision_SystemWriteString | Write a string to the device.
Function | AgInfiniiVision_SystemWriteString2 | Write a string to the device.
Function | AgInfiniiVision_TrackingCopySignal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).
Function | AgInfiniiVision_TriggerAutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.
Function | AgInfiniiVision_TriggerGlitchGetRange | READ ONLY- Gets the pulse width duration time for trigger source.
Function | AgInfiniiVision_TriggerGlitchSetRange | Pulse width duration for the selected source.
Function | AgInfiniiVision_TriggerPatternConfigure | Configures the pattern trigger
Function | AgInfiniiVision_TriggerPatternGetRange | Returns the duration time for the defined pattern.
Function | AgInfiniiVision_TriggerPatternSetRange | Duration for the defined pattern when the pattern condition is set to INRange or OUTRange
Function | AgInfiniiVision_TriggerPXIGetMasterArmLine | Queries the PXI slave to master arm lines on or off.
Function | AgInfiniiVision_TriggerPXISetMasterArmLine | Sets the PXI slave to master arm lines on or off.
Function | AgInfiniiVision_TriggerRuntConfigure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Function | AgInfiniiVision_TriggerWidthConfigure | Configures the width trigger.
Function | AgInfiniiVision_TriggerZoneGetEnabled | Specifies the state for Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneGetMode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | AgInfiniiVision_TriggerZoneGetValidity | Read Only - Query returns the validity of Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneGetZonePlacement | Queries the size and location of Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneSetEnabled | Specifies the state for Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneSetMode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | AgInfiniiVision_TriggerZoneSetZonePlacement | Sets the size and location of Zone 1 or Zone 2.
Function | AgInfiniiVision_UnlockSession | Releases a previously obtained mutlithread lock.
Function | AgInfiniiVision_UseCursorPosition | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
Function | AgInfiniiVision_viRead | Reads a complete response from the instrument and returns it as an array of bytes.
Function | AgInfiniiVision_viWrite | Write an array of bytes to the device.
Function | AgInfiniiVision_WaveformPreamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel
Function | AgInfiniiVision_WaveGenReset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Function | AgInfiniiVision_WaveGenResetArbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | AgInfiniiVision_WaveGenSetArbitraryDACData | Downloads an arbitrary waveform in integer (DAC) values.
Function | AgInfiniiVision_WaveGenSetArbitraryData | Downloads an arbitrary waveform in floating-point values format.
Function | AgInfiniiVision_WaveGenStoreArbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top

Attributes

 | Name | Description
Attribute | AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE | The slope of the zero crossing upon which the scope triggers.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX | The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT | The number of memory segments to acquire.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG | Read Only - Returns the time tag of the currently selected segmented memory index.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_START_TIME | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_TYPE | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
Attribute | AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED | It enables or disables the view of the selected bus.
Attribute | AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL | The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND | Specifies the background of the annotation.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_COLOR | Specifies the annotation color.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_ENABLED | Enables or disables the annotation.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_TEXT | Specifies the annotation string.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS | Read Only - Queries the number of points used by the current Arbitrary waveform.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER | Specifies the byte order for binary transfers.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION | Enables or disables the Interpolation control.
Attribute | AGINFINIIVISION_ATTR_ARINC429_LABEL | Specifies the ARINC 429 label value when labels are used in the selected search mode.
Attribute | AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI | Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM | Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_AVERAGE_COUNT | Specify the number of waveforms to be averaged together.
Attribute | AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_BUS_SLOPE | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_INCREMENT | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_ORIGIN | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_UNITS | Specifies the vertical units for the Chart Logic Bus operations.
Attribute | AGINFINIIVISION_ATTR_CACHE | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL | Calibration string(up to 32 characters not including the quotes).
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_DATE | Read Only - Gets the date of the last calibration.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_ENABLED | Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE | Signal on the rear panel trigger out BNC.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE | Read Only - Change in temperature since the last user calibration procedure.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_TIME | Read Only - Time of the last calibration.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_COUNT | The number of channels.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_ENABLED | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_INVERT | Inverts the input signal for the specified channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_LABEL | The analog channel label.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW | Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROBEID | Read Only - Type of probe attached to the specified oscilloscope channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROTECTION | Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).
Attribute | AGINFINIIVISION_ATTR_CHANNEL_SCALE | Vertical scale, or units per division, of the selected channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_UNITS | Measurement units for the connected probe.
Attribute | AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED | Enable or disable the display of the recovered clock.
Attribute | AGINFINIIVISION_ATTR_COUNTER_CURRENT | Read Only - the current counter value.
Attribute | AGINFINIIVISION_ATTR_COUNTER_ENABLED | Enables or disables the counter feature.
Attribute | AGINFINIIVISION_ATTR_COUNTER_MODE | The counter mode.
Attribute | AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS | The number of digits of resolution used for the frequency or period counter.
Attribute | AGINFINIIVISION_ATTR_COUNTER_SOURCE | The waveform source that the counter measures.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE | Specifies whether positive or negative edges are counted.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED | Enables or disables totalizer gating.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY | The gating signal condition under which totalizer edges are counted.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE | The analog channel that has the totalizer gating signal.
Attribute | AGINFINIIVISION_ATTR_CURSORS_MODE | The cursors mode.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X_DELTA | Read Only - The value difference between the current X1 and X2 cursor positions.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X_UNITS | The X cursors units.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X1_POSITION | Specifies the X1 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X2_POSITION | Specifies the X2 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y_DELTA | Read Only - The value difference between the current Y1 and Y2 cursor positions.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y_UNITS | The Y cursors units.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION | Specifies the Y1 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION | Specifies the Y2 cursor position.
Attribute | AGINFINIIVISION_ATTR_DATA3 | Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.
Attribute | AGINFINIIVISION_ATTR_DATA4 | Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT | Attribute that contains the number of DigitalChannels available on the instrument. This is the maximum index that may be used with the GetDigitalChannelName() function.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED | Enables/Disables the specified digital channel.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL | Enables/Disables analog and digital channel labels.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION | The position of the specified channel.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE | Size of digital channels on the display.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD | Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).
Attribute | AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED | Specifies whether the graticule colors are inverted or not.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED | Enable/Disables the analog and digital channel labels.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE | Enables or disables infinite-persistence mode of the oscilloscope display.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR | Write Only. Specifies the sidebar dialog to display on the screen.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED | Enables or disables the lines drawn between acquired data points on the screen.
Attribute | AGINFINIIVISION_ATTR_DRIVER_SETUP | Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED | Enables or disables the Digital Voltmeter's Auto Range capability.
Attribute | AGINFINIIVISION_ATTR_DVM_CURRENT | Read Only - Returns the displayed 3-digit DVM value based on the current mode.
Attribute | AGINFINIIVISION_ATTR_DVM_ENABLED | Enables or disables the Digital Voltmeter (DVM) analysis feature.
Attribute | AGINFINIIVISION_ATTR_DVM_FREQUENCY | Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.
Attribute | AGINFINIIVISION_ATTR_DVM_MODE | Specifies the digital voltmeter (DVM) mode.
Attribute | AGINFINIIVISION_ATTR_DVM_SOURCE | Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.
Attribute | AGINFINIIVISION_ATTR_ENABLED | Enable or disable the display of the FFT function.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_ENABLED | Enables or disables the external trigger input display.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_LABEL | The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION | Scaling factor by which the probe attached to the external trigger attenuates the input.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE | Read Only - Probe attenuation value that the oscilloscope automatically senses.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_RANGE | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD | The external trigger input threshold (trigger) voltage level in volts.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_UNITS | The measurement units for the probe connected to the external trigger input.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION | The external trigger input waveform's vertical position on the oscilloscope display.
Attribute | AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT | Sets and gets the number of waveforms to be averaged together.
Attribute | AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY | Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.
Attribute | AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE | Sets and gets the FFT waveform display modes.
Attribute | AGINFINIIVISION_ATTR_FFT_OFFSET | Sets and gets the FFT vertical value represented at center screen.
Attribute | AGINFINIIVISION_ATTR_FFT_RANGE | Sets and gets the full-scale vertical axis for the FFT function.
Attribute | AGINFINIIVISION_ATTR_FFT_SOURCE | Sets and gets the source for the FFT function.
Attribute | AGINFINIIVISION_ATTR_FFT_SPAN | Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.
Attribute | AGINFINIIVISION_ATTR_FFT_START_FREQUENCY | Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY | Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE | Windowing transforms for the FFT.
Attribute | AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH | Specifies the low-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_FM_DEVIATION | Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.
Attribute | AGINFINIIVISION_ATTR_FM_FREQUENCY | Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.
Attribute | AGINFINIIVISION_ATTR_FRA_AMPLITUDE | The waveform generator amplitude in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE | Enables or disables the ability to specify amplitude ramping within different decades
Attribute | AGINFINIIVISION_ATTR_FRA_ENABLED | Enables or disables the Frequency Response Analysis (FRA) feature.
Attribute | AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE | The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE | The current expected output load impedance
Attribute | AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE | The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE | The number of points per decade in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_START_FREQUENCY | The frequency sweep start value.
Attribute | AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY | The frequency sweep stop value.
Attribute | AGINFINIIVISION_ATTR_FRA_SWEEP_MODE | Select between the normal swept frequency response analysis or analysis at a single frequency
Attribute | AGINFINIIVISION_ATTR_FSK_FREQUENCY | Specifies the "hop frequency". Hop frequency in Hz
Attribute | AGINFINIIVISION_ATTR_FSK_MODULATION_RATE | Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.
Attribute | AGINFINIIVISION_ATTR_GLITCH_CONDITION | The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.
Attribute | AGINFINIIVISION_ATTR_GLITCH_POLARITY | The polarity of the glitch that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_GLITCH_WIDTH | The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.
Attribute | AGINFINIIVISION_ATTR_GROUP_CAPABILITIES | Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_AXIS | The orientation of the histogram.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED | Enable or disable the histogram display.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT | The measurement to analyze.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_MODE | The type of histogram or disables the histogram analysis feature.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_SIZE | The number of divisions the histogram bar graph should use.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_TYPE | The histogram type.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM | The histogram limits window's bottom boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT | The histogram limits window's left boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT | The histogram limits window's right boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP | The histogram limits window's top boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE | The waveform that is used as the histogram source.
Attribute | AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Attribute | AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.
Attribute | AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE | The effective digitizing rate using the current configuration. The units are samples per second.
Attribute | AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD | The time in seconds that corresponds to the record length.
Attribute | AGINFINIIVISION_ATTR_ID2 | Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.
Attribute | AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Attribute | AGINFINIIVISION_ATTR_INPUT_IMPEDANCE | The input impedance of this channel. The units are ohms.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION | Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER | Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_MODEL | Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Attribute | AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Attribute | AGINFINIIVISION_ATTR_INTERCHANGE_CHECK | Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | AGINFINIIVISION_ATTR_INTERPOLATION | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Attribute | AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR | Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED | Enables or disables the jitter analysis feature.
Attribute | AGINFINIIVISION_ATTR_JITTER_MEASUREMENT | The measurement to analyze.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY | The center frequency for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN | The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET | The vertical value represented at center screen for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE | The full-scale vertical range for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT | The vertical units for the jitter spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW | Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS | The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET | The vertical value represented at center screen for the jitter measurement trend.
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE | The full-scale vertical range for the jitter measurement trend.
Attribute | AGINFINIIVISION_ATTR_LINEAR_GAIN | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_LINEAR_OFFSET | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_LOGICAL_NAME | Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED | Enables all analog channels to be included in the mask test or only selected channels.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED | Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL | Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION | The termination conditions for the mask test.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED | Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME | The number of seconds for a mask test to run. Permissible Range is 1 to 86400.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM | The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME | Read Only - Elapsed time (in seconds) in the current mask test run.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ENABLED | Enables/Disables the mask test features.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE | Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED | Enables/Disables the mask lock.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA | The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE | The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE | Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE | Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT | Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED | Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED | Enables/Disables printing on mask failure.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED | Enables/Disables saving on mask failure.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_SOURCE | The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_TITLE | Read Only - Returns the mask title which is a string of up to 128 characters
Attribute | AGINFINIIVISION_ATTR_MASKTEST_UNITS | Measurement units for automask which interprets the tolerance parameters for automasking.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE | The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT | Read Only - The total number of waveforms acquired in the current mask test run.
Attribute | AGINFINIIVISION_ATTR_MATH_ENABLED | Enables/Disables the math function.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_SPAN | Frequency span of the display when FFT is selected.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE | Windowing transforms for the FFT.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS | Specifies the vertical units for the Chart Logic Bus operations.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED | Enables/Disables the math function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN | Frequency span of the display when FFT is selected.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY | The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY | The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE | Windowing transforms or operations for the FFT.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH | Specifies the low-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT | The measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE | Specifies the measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET | Voltage or vertical value represented at center screen for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION | Waveform math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS | The number of smoothing points to use.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE | Range of Full-scale vertical axis for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE | Vertical scale, or units per division, of the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_OFFSET | Voltage or vertical value represented at center screen for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_OPERATION | Waveform math operation
Attribute | AGINFINIIVISION_ATTR_MATH_SOURCE1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.
Attribute | AGINFINIIVISION_ATTR_MATH_SOURCE2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>
Attribute | AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE | Range of Full-scale vertical axis for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE | Vertical scale, or units per division, of the selected function.
Attribute | AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT | Attribute that contains the number of MathFunctions available on the instrument. This is the maximum index that may be used with the GetMathFunctionName() function.
Attribute | AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Attribute | AGINFINIIVISION_ATTR_MEAS_HIGH_REF | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEAS_LOW_REF | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEAS_MID_REF | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1 | The occurrence count for the first waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2 | The occurrence count for the second waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1 | The polarity of the slope for the first waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2 | The polarity of the slope for the second waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED | Enables markers for tracking measurements on the display. This feature is always on.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2 | Second source for measurements such as Delay, Phase etc.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE | The occurrence count for the TimeAtEdge measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE | The edge slope for a TimeAtEdge measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE | The occurrence count for the TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE | The edge slope for a TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE | The voltage for the TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME | The time (in seconds) used to make the ValueAtTime measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW | Measurement window when zoomed time base is selected.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_COUNT | Attribute that contains the number of Measurements available on the instrument. This is the maximum index that may be used with the GetMeasurementName() function.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE | Specifies the measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY | Present working directory for recall operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE | File for recall operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY | Present working directory for save operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE | File for save operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT | Type of image format
Attribute | AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE | Image palette color.
Attribute | AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.
Attribute | AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED | Enables or disables whether the cursor values will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED | Enables or disables whether the histogram statistics will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED | Enables or disables whether the mask statistics will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED | Enables or disables whether the measurement results will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED | Enables or disables whether the found search event times will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED | Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION | The segments to be included when the waveform is saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION | This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).
Attribute | AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT | Data format of waveform
Attribute | AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH | Waveform data length (number of points saved).
Attribute | AGINFINIIVISION_ATTR_MODE | Sets and gets the search mode settings.
Attribute | AGINFINIIVISION_ATTR_MODULATION_ENABLED | Enables or disables modulated waveform generator output.
Attribute | AGINFINIIVISION_ATTR_MODULATION_FUNCTION | Specifies the shape of the modulating signal.
Attribute | AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY | Specifies the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_MODULATION_TYPE | Specifies the modulation type.
Attribute | AGINFINIIVISION_ATTR_NUM_AVERAGES | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Attribute | AGINFINIIVISION_ATTR_NUM_ENVELOPES | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Attribute | AGINFINIIVISION_ATTR_PROBE_ATTENUATION | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Attribute | AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Attribute | AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | AGINFINIIVISION_ATTR_RANGE_CHECK | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | AGINFINIIVISION_ATTR_RECORD_COERCIONS | Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | AGINFINIIVISION_ATTR_REFERENCE_SIGNAL | Selects the 10 MHz Reference Signal Mode.
Attribute | AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | AGINFINIIVISION_ATTR_RUNT_POLARITY | The polarity of the runt that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_SAMPLE_MODE | The sample mode the oscilloscope is currently using.
Attribute | AGINFINIIVISION_ATTR_SEARCH_COUNT | Read Only - Gets the number of search events found.
Attribute | AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE | The slope of the edge for the search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE | The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION | Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION | The maximum pulse width duration time (in seconds) for the selected source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION | The minimum pulse width duration time (in seconds) for the selected source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY | The polarity for the glitch (pulse width) source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE | The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_MODE | The oscilloscope search mode.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION | The change in level that must occur (in other words, hysteresis) to be recognized as a peak.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS | The maximum number of FFT peaks to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE | The FFT math function waveform to search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD | The threshold level necessary to be considered a peak.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION | Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY | Sets/Gets the polarity for the runt search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME | When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE | The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE | Specifies the type of ARINC 429 information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA | Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE | Specifies the type of CAN information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE | Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE | Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER | Specifies the cycle value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID | Specifies the frame ID value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE | Specifies the type of FlexRay information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA | Specifies the data value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH | Specifies the length of data values when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL | Specifies the channel on which to search for I2S events: right, left, or either channel.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE | Specifies the type of I2S information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA | Specifies the data word value when searching for I2S events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS | Specifies the address values when searching for IIC events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION | Specifies the data value qualifier used when searching for IIC EEPROM data read events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE | Selects the type of IIC information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA | Specifies the data values when searching for IIC events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2 | Specifies the second data value when searching for IIC events with two data values.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID | Specifies the frame ID value when searching for LIN events
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE | Selects the type of LIN information to find in the Lister display
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA | Specifies the data value when searching for LIN events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME | Sets and Gets the specific message when LIN serial search mode is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE | Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE | Specifies the type of MIL-STD-1553 information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA | Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA | Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA | Specifies the data value when searching for SPI events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH | Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION | Specifies the data value qualifier when searching for UART/RS232 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE | Selects the type of UART/RS232 information to find in the Lister display
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA | Specifies a data value when searching for UART/RS232 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION | Specifies whether to search for edge transitions greater than or less than a time.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME | The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE | Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE | The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS | Specifies the 7-bit Address portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION | Specifies the USB search mode.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_CRC | Specifies the CRC portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_DATA | Specifies the Data portion of the trigger, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH | Specifies the data length in bytes.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT | Specifies the 4-bit Endpoint portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_ET | Specifies the 2-bit ET portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_FRAME | Specifies the 11-bit Frame portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS | Specifies the 7-bit Hub Address portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA | Specifies the USB data PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE | Specifies the USB handshake PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL | Specifies the USB special PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN | Specifies the USB token PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PORT | Specifies the 7-bit Port portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_SC | Specifies the 1-bit SC portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_SEU | Specifies the 2-bit S and E or U portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE | Selects between hexadecimal and binary display of the decoded data.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT | Specifies the word decode format.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT | Read Only - Returns the ARINC 429 error count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE | Specifies which signal is used as the source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED | Specifies the speed of the ARINC 429 interface for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL | Specifies the Label portion of the trigger for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA | Specifies the Data portion of the trigger for the selected bus, in binary.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI | Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM | Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW | The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE | Specifies the ARINC 429 trigger mode for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT | Read Only - Returns the ARINC 429 word count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE | Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL | Specifies the bus channel, A or B, of the FlexRay signal.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT | Read Only - Gets the FlexRay error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT | Read Only - Gets the FlexRay null frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE | Specifies the input source for the FlexRay signal.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT | Read Only - Gets the FlexRay sync frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT | Read Only - Gets the FlexRay total frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID | Specifies the ByteStart Sequence ID.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE | Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION | Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID | Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE | Specifies the FlexRay trigger on condition.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY | The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE | Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE | Specifies the base to use for the MIL-STD 1553 decode display.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE | Specifies which signal is used as the source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA | Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA | Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW | The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE | Specifies the type of MIL-STD 1553 trigger to be used.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY | Sets and Gets the CAN decode display type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT | Read Only - Gets the error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE | Sets and gets the DLC value to be used in the CAN FD data trigger mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD | Sets and Gets the frame decode standard.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION | Sets and gets the starting byte position for CAN FD data triggers.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED | Enable and disable the triggers filtering by CAN IDs.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT | Read Only - Gets the overload frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE | Specifies the source for the CAN signal
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT | Read Only - Gets the total frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION | Specifies the CAN trigger on condition
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE | Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE | Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION | Read Only - Gets the percent utilization.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_COUNT | Attribute that contains the number of Serial Buses available on the instrument. This is the maximum index that may be used with the GetSerialBusName() function.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_ENABLED | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE | Specifies the base to use for the I2S decode display.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE | Specifies which edge of the I2S serial clock signal clocks in data
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE | Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE | Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH | Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH | Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL | Specifies the audio channel to trigger on.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION | Specified the I2S trigger operator.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA | Specifies the I2S trigger data pattern searched for in each I2S message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY | Specifies the polarity of the word select (WS) signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE | Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH | Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE | Specifies the source for the IIC serial clock (SCL).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE | Specifies the source for IIC serial data (SDA).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION | Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS | Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA | Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2 | Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE | Specifies the IIC trigger type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY | Sets and Gets the LIN decode display type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE | Specifies the source for the CAN signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION | Specifies the LIN trigger condition.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA | Specifies the LIN trigger data pattern searched for in each LIN data field.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME | Sets and Gets the specific message when the LIN trigger mode is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE | Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_MODE | Determines the decode mode for the serial bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK | Sets and gets the nominal clock period (tick), from 1us to 300us.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT | Set and get the format of the CRC.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT | Sets and gets the message decode/triggering format.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE | Sets and gets the idle state of the SENT bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE | Sets and gets the number base used by the decoder.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE | Sets and gets the number of nibbles in a SENT message, from 1 to 6.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE | This command specifies whether the SENT messages are followed by a pause pulse.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE | Sets and gets the input channel for SENT decode and triggering.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE | Sets and gets the tolerance for determing if the sync pulse is valid.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA | Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE | Sets and Gets the SENT trigger mode setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA | Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID | Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH | Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE | Sets and Gets the tolerance variation percent setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE | Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE | Specifies the source for the SPI serial clock.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT | Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE | Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING | Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE | Specifies the source for the SPI serial MISO data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE | Specifies the source for the SPI serial MOSI data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH | Specifies the number of bits in a word of data for SPI.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE | Specifies the base to use for the UART decode and Lister display.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE | Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT | Read Only - Gets the UART error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING | Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT | Read Only - Gets the UART Rx frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE | Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE | Specifies the front panel UART/RS232 trigger setup data selection.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST | Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION | Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA | Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME | Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE | Specifies the UART Trigger Type
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT | Read Only - Gets the UART Tx frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE | Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH | Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS | Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE | Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION | Specifies USB trigger mode for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC | Specifies the CRC portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE | Specifies which signal is used as the USB D- source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE | Specifies which signal is used as the USB D+ source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA | Specifies the Data portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH | Specifies the data length in bytes.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE | Specifies which signal is used as the differential source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT | Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_ET | Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME | Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS | Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK | Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA | Specifies the USB data PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE | Specifies the USB handshake PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL | Specifies the USB special PID to trigger on for the selected bus
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN | Specifies the USB token PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT | Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SC | Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU | Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED | Specifies the speed of the USB interface for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SIMULATE | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_COUNT | Specifies the maximum number of values used when calculating measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED | Enables or disables the display of the measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_FORMAT | Specifies the type of information returned by the GetResults() method.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED | Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL | Read Only - Serial poll the instrument status byte.
Attribute | AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS | Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT | The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_MESSAGE | Writes a message(excluding quotation marks) to a text box in the center of the display
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED | Enables or disables the oscilloscope's precision analysis setting.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH | The length of the precision analysis record (when precision measurements and math functions mode is enabled).
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status
Attribute | AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER | Read Only - Instrument serial number.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TIME | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED | Disables or enables the touchscreen.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE | Horizontal scale or seconds per division for the main window.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_MODE | Current time base mode.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE | Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED | Time base control's vernier.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE | Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION | Horizontal window position in the zoomed view of the main sweep.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE | Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.
Attribute | AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_ENABLED | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_FREQUENCY | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_PHASE | Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE | The slope of the zero crossing upon which the scope triggers.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_COUPLING | How the oscilloscope couples the trigger source.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE | Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE | Selects the input used for the arming edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT | Sets/Gets the Nth edge of the trigger source to trigger on
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE | Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME | Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME | Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE | Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE | Enable the type of reject filter.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL | Trigger level voltage for the active pulse width trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED | Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX | The maximum random holdoff time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN | The minimum random holdoff time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_LEVEL | The voltage threshold for the trigger subsystem. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_MODIFIER | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN | Specifies the edges to include in the OR'ed edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN | The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION | The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN | The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION | Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH | Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE | Sets and gets the PXI trigger mode to bus master/slave or off.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE | Sets and gets the PXI slave to master arm line or off.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT | Sets and gets the PXI master slot number.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE | Sets and gets the PXI master to slave trigger line.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION | Condition used for specifying runt pulse widths.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME | Time used for triggering on runt pulses whose width is greater than or less than the specified time value.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE | Selects the channel used to produce the trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE | Selects the channel used to produce the trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME | Sets/Gets the hold time.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME | Sets/Gets the setup time.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE | Selects the clock signal's active edge.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SLOPE | The slope, a rising or a falling edge, that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SOURCE | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION | Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME | Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE | Specifies a Positive rising edge or a Negative falling edge.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the transition trigger. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW | The low threshold the oscilloscope uses for the transition trigger. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TYPE | The kind of event that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG | The kind of event that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION | Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY | The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH | The high width threshold time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW | The low width threshold time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE | Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT | The event on which the oscilloscope triggers.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY | The polarity of the TV signal.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT | The format of the TV signal on which the oscilloscope triggers.
Attribute | AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER | Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.
Attribute | AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED | Enables or disables the horizontal sync control in the Generic video trigger.
Attribute | AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME | When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.
Attribute | AGINFINIIVISION_ATTR_UDTV_MIN_TIME | Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.
Attribute | AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_COUPLING | How the oscilloscope couples the input signal.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_OFFSET | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_RANGE | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Attribute | AGINFINIIVISION_ATTR_VIEW | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE | Specifies the amount of noise to add to the currently selected signal.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH | Specifies the amount of amplitude modulation.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY | Specifies the frequency of the modulating signal. Frequency in Hz .
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS | Read Only - Queries the number of points used by the current Arbitrary waveform.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER | Specifies the byte order for binary transfers.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION | Enables or disables the Interpolation control.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION | Type of waveform.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED | Enables or Disables waveform generator signal output.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED | Specifies whether the waveform generator output is inverted or not.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE | Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER | Output sequence of the WORD data. It decides which significant byte to be transmitted first.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE | Specifies the amount of noise to add to the currently selected signal.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION | Type of waveform.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED | Enables/Disables waveform generator signal output.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT | Number of waveform points to be transferred with the Waveform data
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE | Type of data record to be transferred
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_SOURCE | Source for the waveform.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE | Selects the sub-source for those sources that have more than one possibility.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii
Attribute | AGINFINIIVISION_ATTR_WAVEGEN_COUNT | Attribute that contains the number of WaveGens available on the instrument. This is the maximum index that may be used with the GetWaveGenName() function.
Attribute | AGINFINIIVISION_ATTR_WIDTH_CONDITION | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD | The high width threshold time. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD | The low width threshold time. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_POLARITY | The polarity of the pulse that triggers the oscilloscope.
Top


Functions

Functions

 | Name | Description
Function | AgInfiniiVision_Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | AgInfiniiVision_AcquisitionSetSampleMode | Sets the acquisition mode of the oscilloscope.
Function | AgInfiniiVision_AcquisitionSingleAcquisition | Acquires a single trigger of data.
Function | AgInfiniiVision_AcquisitionStatus | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | AgInfiniiVision_AcquisitionStop | Stops the acquisition.
Function | AgInfiniiVision_ActualRecordLength | This function returns the actual number of points the oscilloscope acquires per channel. After configuring the oscilloscope for an acquisition, call this function to determine the size of the waveforms that the oscilloscope acquires. The value is equal to or greater than the minimum number of points specified in the Configure Acquisition Record function. For IVI-C drivers, allocate a ViReal64 array of this size or greater to pass as the WaveformArray parameter of the IviScope_ReadWaveform and IviScope_FetchWaveform functions. The oscilloscope may use different size records depending on the acquisition type. Specify the acquisition type with the Configure Acquisition Type function.
Function | AgInfiniiVision_AnalogBusClear | Excludes all of the analog channels from the selected bus definition.
Function | AgInfiniiVision_AnalogBusGetBit | Returns the value indicating whether the specified bit is included or excluded from the specified bus definition.
Function | AgInfiniiVision_AnalogBusGetBits | Returns the definition for the specified bus.
Function | AgInfiniiVision_AnalogBusSetBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | AgInfiniiVision_AnalogBusSetBits | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Function | AgInfiniiVision_AutoProbeSenseValue | The function returns the probe attenuation value the oscilloscope senses. The capability is enabled by setting the probeAttenuation parameter of the Configure Channel function to Probe Sense On. If the automatic probe sense capability is disabled, this function returns the manual probe attenuation setting.
Function | AgInfiniiVision_AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | AgInfiniiVision_CalibrationCalibrate | Starts the user calibration procedure. See the User's Guide for details.
Function | AgInfiniiVision_CalibrationResult | Read Only- Summary results of the last user calibration procedure.
Function | AgInfiniiVision_ChannelClearProtection | Reset the analog channel input impedance to 50 Ohms after clearing the overvoltage protection.
Function | AgInfiniiVision_ClearError | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | AgInfiniiVision_ClockRecoveryGetMethod | Returns the currently selected clock recovery method.
Function | AgInfiniiVision_ClockRecoverySetMethod | Sets the clock recovery method.
Function | AgInfiniiVision_close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | AgInfiniiVision_ConfigureAcLineTriggerSlope | This function configures the slope of the AC Line trigger. This function affects instrument behavior only if the trigger type is AC Line Trigger. Call the Configure Trigger function to set the trigger type before calling this function.
Function | AgInfiniiVision_ConfigureAcquisitionRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Function | AgInfiniiVision_ConfigureAcquisitionType | This function configures how the oscilloscope acquires data and fills the waveform record.
Function | AgInfiniiVision_ConfigureChanCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Function | AgInfiniiVision_ConfigureChannel | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Function | AgInfiniiVision_ConfigureEdgeTriggerSource | Configures the conditions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Function | AgInfiniiVision_ConfigureGlitchTriggerSource | Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Function | AgInfiniiVision_ConfigureInitiateContinuous | This function configures the oscilloscope to perform a continuous acquisition.
Function | AgInfiniiVision_ConfigureInterpolation | This function configures the interpolation method the oscilloscope uses when it cannot sample a voltage for a point in the waveform record.
Function | AgInfiniiVision_ConfigureNumAverages | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Function | AgInfiniiVision_ConfigureNumEnvelopes | This function configures the number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms.
Function | AgInfiniiVision_ConfigureRefLevels | Configures the reference levels for waveform measurements, low, mid, and high.
Function | AgInfiniiVision_ConfigureRuntTriggerSource | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Function | AgInfiniiVision_ConfigureSearchEdge | Configures the Source and Slope properties for an Edge search.
Function | AgInfiniiVision_ConfigureSearchGlitch | Configures the Source, Polarity and Condition properties for the Glitch search.
Function | AgInfiniiVision_ConfigureSearchRunt | Configures the Source, Polarity, Condition and QualifierTime properties for a Runt search.
Function | AgInfiniiVision_ConfigureSearchTransition | Configures the Source, Slope, Condition and QualifierTime properties for a transition search.
Function | AgInfiniiVision_ConfigureTrigger | Configures trigger Type and Holdoff. Holdoff units are seconds.
Function | AgInfiniiVision_ConfigureTriggerCoupling | This function sets the trigger coupling attribute.
Function | AgInfiniiVision_ConfigureTriggerDelay | Configures the trigger source, trigger slope, edge count, arming source, arming slope and the delay time parameters for the Edge Then Edge trigger.
Function | AgInfiniiVision_ConfigureTriggerEdgeBurst | Configures the trigger source, trigger slope, idle time and edge count parameters for the Nth Edge Burst trigger.
Function | AgInfiniiVision_ConfigureTriggerModifier | This function configures the oscilloscope's trigger modifier.
Function | AgInfiniiVision_ConfigureTriggerSetupAndHold | Configures the clock source, slope, data source, setup time and hold time parameters for the Setup and Hold trigger.
Function | AgInfiniiVision_ConfigureTriggerTransition | Configures the source, slope, condition and qualifier time parameters for the Transition trigger.
Function | AgInfiniiVision_ConfigureTriggerUSB | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Configures the condition, speed, D+ source and D- source parameters for a USB trigger.
Function | AgInfiniiVision_ConfigureTVTriggerLineNumber | This function configures the TV line upon which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal. This function affects instrument behavior only if the trigger type is set to the TV Trigger value and the TV trigger event is set to the TV Event Line Number value. Call the Configure TV Trigger Source function to set the TV trigger event before calling this function.
Function | AgInfiniiVision_ConfigureTVTriggerSource | Configures the TV trigger source, signal format, event and polarity.
Function | AgInfiniiVision_ConfigureWidthTriggerSource | Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Function | AgInfiniiVision_CounterConfigure | This method sets the Counter mode, source and Number of digits of resolution.
Function | AgInfiniiVision_CounterTotalizeClear | Zeros the edge event counter.
Function | AgInfiniiVision_CounterTotalizeGatedConfigure | This method sets the totalize gated source and polarity.
Function | AgInfiniiVision_DigitalChannelBusClear | Excludes all of the digital channels from the selected bus definition.
Function | AgInfiniiVision_DigitalChannelBusEnable | Display the selected bus.
Function | AgInfiniiVision_DigitalChannelBusGetChannelBit | Returns the definition for the specified bus.
Function | AgInfiniiVision_DigitalChannelBusGetLabel | Returns the label of the specified bus.
Function | AgInfiniiVision_DigitalChannelBusGetMaskBit | Returns the mask value for the specified bus.
Function | AgInfiniiVision_DigitalChannelBusIsDigitalBitEnabled | Returns the flag indicating whether the specified bit is included or excluded from the specified bus definition.
Function | AgInfiniiVision_DigitalChannelBusIsEnabled | Returns the flag indicating whether the specified bus is enabled or disabled.
Function | AgInfiniiVision_DigitalChannelBusSetChannelBit | Includes/Excludes the selected bits in the channel list in the definition of the selected bus.
Function | AgInfiniiVision_DigitalChannelBusSetDigitalBit | Includes/Excludes the selected bit as part of the definition for the selected bus.
Function | AgInfiniiVision_DigitalChannelBusSetLabel | The bus label.
Function | AgInfiniiVision_DigitalChannelBusSetMaskBit | Bits to be included and excluded in the selected bus according to the mask.
Function | AgInfiniiVision_DigitalChannelFetchDigitalWaveform | Returns the waveform for the pod (Digital channels 0-7 or 8-15) containing the specified digital channel.
Function | AgInfiniiVision_DigitalChannelReadActivity | Reads digital channel activity into the edges and levels parameters. Levels: are current logic levels. Edges: are active edges since the last ResetActivity() call. In the values read, bit 0 is for digital channel 0, and bit 15 is for digital channel 15.
Function | AgInfiniiVision_DigitalChannelReadDigitalWaveform | Acquires and returns the waveform for the pod (digital channels 0-7 or 8-15) containing the specified digital channel.
Function | AgInfiniiVision_DigitalChannelResetActivity | Clears the logic activity registers of the oscilloscope.
Function | AgInfiniiVision_Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | AgInfiniiVision_DisplayAnnotationGetBackground | Gets the background of the annotation.
Function | AgInfiniiVision_DisplayAnnotationGetColor | Gets the annotation color.
Function | AgInfiniiVision_DisplayAnnotationGetEnabled | Get the state of annotation.
Function | AgInfiniiVision_DisplayAnnotationGetText | Gets the annotation string.
Function | AgInfiniiVision_DisplayAnnotationGetX1Position | Gets the annotation's horizontal X1 position.
Function | AgInfiniiVision_DisplayAnnotationGetY1Position | Gets the annotation's vertical Y1 position.
Function | AgInfiniiVision_DisplayAnnotationSetBackground | Sets the background of the annotation.
Function | AgInfiniiVision_DisplayAnnotationSetColor | Sets the annotation color.
Function | AgInfiniiVision_DisplayAnnotationSetEnabled | Enable or disable the annotation.
Function | AgInfiniiVision_DisplayAnnotationSetText | Sets the annotation string.
Function | AgInfiniiVision_DisplayAnnotationSetX1Position | Sets the annotation's horizontal X1 position.
Function | AgInfiniiVision_DisplayAnnotationSetY1Position | Sets the annotation's vertical Y1 position.
Function | AgInfiniiVision_DisplayErase | Clears the display and resets all associated measurements. If the oscilloscope is stopped, all currently displayed data is erased else all of the data for active channels and functions is erased.
Function | AgInfiniiVision_DisplayGetScreenBitmap | Reads screen image data
Function | AgInfiniiVision_error_message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | AgInfiniiVision_error_query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | AgInfiniiVision_FetchJitterMeasurement | Returns the measured value of the selected measurement.
Function | AgInfiniiVision_FetchMinMaxWaveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgInfiniiVision_FFTClear | Clears the number of evaluated waveforms.
Function | AgInfiniiVision_ForceTrigger | This method causes an acquisition to be captured even though the trigger condition has not been met. This command is equivalent to the front panel [Force Trigger] key.
Function | AgInfiniiVision_FRAFetchData | Fetch the frequency response analysis data.
Function | AgInfiniiVision_FRAGetAmplitudeProfile | Returns waveform generator amplitude in the frequency response analysis.
Function | AgInfiniiVision_FRARun | Initiates the Frequency Response Analysis.
Function | AgInfiniiVision_FRASetAmplitudeProfile | Return the waveform generator's output sine wave amplitude.
Function | AgInfiniiVision_GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_GetChannelName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the ChannelIndex parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the ChannelName parameter and returns an error.
Function | AgInfiniiVision_GetDigitalChannelName | Returns the digitalchannel name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetError | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | AgInfiniiVision_GetListerData | Gets the lister data as a string.
Function | AgInfiniiVision_GetMathFunctionName | Returns the mathfunction name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetMeasurementName | Returns the measurement name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetNextCoercionRecord | Not Supported - Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | AgInfiniiVision_GetProbeID | Read Only - Type of probe attached to the specified oscilloscope channel.
Function | AgInfiniiVision_GetSearchGlitchRange | Gets the pulse width duration time (in seconds) for the selected source.
Function | AgInfiniiVision_GetSearchSerialI2SRange | Gets the data value range when searching for I2S events.
Function | AgInfiniiVision_GetSerialBusARINC429TriggerRange | Gets the range for the Label Range trigger mode for the selected bus.
Function | AgInfiniiVision_GetSerialBusI2STriggerRange | Gets the currently set lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Function | AgInfiniiVision_GetSerialBusName | Returns the serialbus name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_GetStatisticsResults | Returns the results of the continuously displayed measurements.
Function | AgInfiniiVision_GetWaveGenName | Returns the wavegen name that corresponds to the one-based index that the user specifies.
Function | AgInfiniiVision_HistogramGetResult | Returns the histogram result of the selected result type.
Function | AgInfiniiVision_HistogramReset | Zeros the histogram counters.
Function | AgInfiniiVision_IncrementStatistics | This command updates the statistics once (incrementing the count by one) using the current measurement values. It corresponds to the front panel Increment Statistics softkey in the Measurement Statistics Menu.
Function | AgInfiniiVision_init | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgInfiniiVision_InitiateAcquisition | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Function | AgInfiniiVision_InitWithOptions | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgInfiniiVision_InstallMeasurementStatistics | Installs a measurement on the screen as a continuously running measurement. The source is specified using Source parameter and the measurement is specified using the Measurement parameter.
Function | AgInfiniiVision_InvalidateAllAttributes | Invalidates all of the driver's cached values.
Function | AgInfiniiVision_IsInvalidWfmElement | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Function | AgInfiniiVision_JitterConfigureHistogram | Auto-configures and turns on the jitter measurement histogram for the selected measurement.
Function | AgInfiniiVision_JitterSpectrumConfigure | Auto-configures and turns on the jitter spectrum for the selected measurement.
Function | AgInfiniiVision_JitterTrendConfigure | Auto-configures and turns on the jitter measurement trend for the selected measurement.
Function | AgInfiniiVision_JitterTrendConfigureSmoothing | Auto-configures and turns on smoothing for the jitter measurement trend.
Function | AgInfiniiVision_LockSession | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | AgInfiniiVision_MaskTestDelete | Deletes the currently loaded mask.
Function | AgInfiniiVision_MaskTestReset | Resets the mask statistics.
Function | AgInfiniiVision_MastTestAutoMask | Automatically constructs a mask around the current selected channel, using the tolerance parameters defined by the horizontalTolerance, VerticalTolerance and AutoMaskUnits.
Function | AgInfiniiVision_MeasurementConfigurationConfigureDelay | Configures the edge specifications for the delay and phase measurements.
Function | AgInfiniiVision_MeasurementConfigureJitterMeasurement | Configure and adds the selected Jitter measurement.
Function | AgInfiniiVision_MeasurementFetchMinMaxWaveform | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_MeasurementFetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Function | AgInfiniiVision_MeasurementFetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgInfiniiVision_MeasurementReadJitterMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measured value of the selected measurement.
Function | AgInfiniiVision_MeasurementReadMinMaxWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | AgInfiniiVision_MeasurementReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | AgInfiniiVision_MeasurementReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgInfiniiVision_MeasurementsAbort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Function | AgInfiniiVision_MeasurementsAcquisitionStatus | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Function | AgInfiniiVision_MeasurementsAutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Function | AgInfiniiVision_MeasurementsClear | Clears all selected measurements and markers from the screen
Function | AgInfiniiVision_MeasurementsInitiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Function | AgInfiniiVision_MeasurementsIsInvalidWfmElement | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Function | AgInfiniiVision_MemoryRecall | Recall option for Mask, Oscilloscope Setup and Reference memory.
Function | AgInfiniiVision_MemorySave | Save option for Mask, Image, Lister display data, Oscilloscope Setup, Waveform data and Reference memory.
Function | AgInfiniiVision_OutputSingle | Write Only - Specifies the single cycle of the defined waveform to be output. Supported by 3000T, 4000X, 6000X.
Function | AgInfiniiVision_ReadMinMaxWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Function | AgInfiniiVision_ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Function | AgInfiniiVision_ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgInfiniiVision_ReferenceWaveformClear | Clears the specified reference waveform location.
Function | AgInfiniiVision_ReferenceWaveformEnable | Enables/Disables the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetLabel | Returns the Label associated with a specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetOffset | Returns the Current offset value for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetRange | Returns the Current full-scale range for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetSkewFactor | Returns the Current skew factor for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformGetVerticalScale | Returns the Current vertical units per division for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformIsEnabled | Returns the Current display setting of the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSave | Copies the analog channel or math function waveform to the specified reference waveform location.
Function | AgInfiniiVision_ReferenceWaveformSetLabel | Label for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetOffset | Offset value that is represented at center screen for the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetRange | Full-scale range of vertical axis of the selected reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetSkewFactor | Skew factor for the specified reference waveform.
Function | AgInfiniiVision_ReferenceWaveformSetVerticalScale | Vertical scale, or units per division, of the selected reference waveform.
Function | AgInfiniiVision_reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | AgInfiniiVision_ResetArbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | AgInfiniiVision_ResetSerialBusARINC429Counters | Resets the ARINC 429 counters.
Function | AgInfiniiVision_ResetSerialBusCounters | Resets the frame counters.
Function | AgInfiniiVision_ResetSerialBusFlexRayCounters | Resets the FlexRay frame counters.
Function | AgInfiniiVision_ResetSerialBusUARTCounters | This method resets the UART frame counters.
Function | AgInfiniiVision_ResetStatistics | This method resets the measurement statistics, zeroing the counts. Note that the measurement (statistics) configuration is not deleted.
Function | AgInfiniiVision_ResetWaveformGenerator | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Function | AgInfiniiVision_ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | AgInfiniiVision_revision_query | Retrieves revision information from the instrument.
Function | AgInfiniiVision_SampleMode | This function returns the sample mode the oscilloscope is currently using.
Function | AgInfiniiVision_SampleRate | This function returns the effective sample rate of the acquired waveform using the current configuration in samples per second.
Function | AgInfiniiVision_SegmentedMemoryAnalyze | Calculates measurement statistics and/or infinite persistence over all segments that have been acquired. The oscilloscope must be stopped and in segmented acquisition mode, with either quick measurements or infinite persistence on.
Function | AgInfiniiVision_self_test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | AgInfiniiVision_SerialBusARINC429AutoSetup | Automatically configures settings for the ARINC 429 serial bus mode.
Function | AgInfiniiVision_SerialBusFlexRayAutoSetup | Automatically configures oscilloscope settings to facilitate FlexRay triggering and serial decode.
Function | AgInfiniiVision_SerialBusFlexRayTriggerEventAutoSetup | Presets oscilloscope parameters for the selected event type.
Function | AgInfiniiVision_SerialBusM1553AutoSetup | This method copies the position and volts/div from the upper threshold channel to the lower threshold channel, sets the upper/lower trigger levels to +/-500 mV.
Function | AgInfiniiVision_SerialBusSentGetSignalDisplay | This method specifies whether the given signal is on or off.
Function | AgInfiniiVision_SerialBusSentGetSignalLength | Gets the bit length of the signal being defined.
Function | AgInfiniiVision_SerialBusSentGetSignalMultiplier | Gets the multiplier value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentGetSignalNibbleOrder | Gets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | AgInfiniiVision_SerialBusSentGetSignalOffset | Gets the offset value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentGetSignalStartPosition | Gets the starting bit of the Fast Signal being defined.
Function | AgInfiniiVision_SerialBusSentSetSignalDisplay | Set the given signal is on or off.
Function | AgInfiniiVision_SerialBusSentSetSignalLength | Sets the bit length of the signal being defined.
Function | AgInfiniiVision_SerialBusSentSetSignalMultiplier | Sets the multiplier value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentSetSignalNibbleOrder | Sets the nibble order of the signal being defined, either Most Significant Nibble first, or Least Significant Nibble first.
Function | AgInfiniiVision_SerialBusSentSetSignalOffset | Sets the offset value for the Fast Channel Signal.
Function | AgInfiniiVision_SerialBusSentSetSignalStartPosition | Sets the starting bit of the Fast Signal being defined.
Function | AgInfiniiVision_SetArbitraryDACData | Downloads an arbitrary waveform in integer (DAC) values.
Function | AgInfiniiVision_SetArbitraryData | Downloads an arbitrary waveform in floating-point values format.
Function | AgInfiniiVision_SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgInfiniiVision_SetSearchGlitchRange | Sets the pulse width duration time (in seconds) for the selected source.
Function | AgInfiniiVision_SetSearchSerialI2SRange | Sets the data value range when searching for I2S events.
Function | AgInfiniiVision_SetSerialBusARINC429TriggerRange | Sets the range for the Label Range trigger mode for the selected bus.
Function | AgInfiniiVision_SetSerialBusI2STriggerRange | Sets the lower and upper range boundaries used by the InRange, OutRange, Increasing, and Decreasing trigger conditions.
Function | AgInfiniiVision_StatusClear | Clears all event registers and error queue. The enable registers are unaffected.
Function | AgInfiniiVision_StatusConfigureServiceRequest | Clears all the enable registers. It then sets the appropriate transition filters and enable registers so when the specified event(s) occur(s) the instrument requests service.
Function | AgInfiniiVision_StatusGetRegister | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Function | AgInfiniiVision_StatusPreset | Sets the SCPI defined enable registers and transition filters. It performs the actions specified by SCPI for the :STATus:PREset command, see SCPI Vol. 2: Command Reference, section 20.7.
Function | AgInfiniiVision_StatusSetRegister | The contents of one of the status registers. In an IEEE 488.2 instrument, status registers come in Registers. See IEEE 488.2, section 11.4. SCPI provides names for some register Registers.
Function | AgInfiniiVision_StoreArbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Function | AgInfiniiVision_SystemClearIO | Performs an IEEE 488.1-style clear of the device.
Function | AgInfiniiVision_SystemDisableLocalControls | Puts the instrument into a state where all local controls, including return to local, are disabled from changing the state of the instrument. The power switch is excluded.
Function | AgInfiniiVision_SystemEnableLocalControls | Allows an operator to examine and change the instrument's state through its local controls. The client can allow an operator to interact directly with the instrument through its front panel for a period of time.
Function | AgInfiniiVision_SystemGetState | Binary current instrument state. May be restored using PutState method. Data is in internal instrument format, do not alter.
Function | AgInfiniiVision_SystemPutState | Writes binary instrument state as saved by GetState method.
Function | AgInfiniiVision_SystemReadBytes | Reads a complete response from the instrument and returns it as an array of bytes.
Function | AgInfiniiVision_SystemReadString | Reads a complete response from the instrument and returns it as a string.
Function | AgInfiniiVision_SystemRecallState | Restore the instrument to a state previously stored in the instrument's internal memory.
Function | AgInfiniiVision_SystemSaveState | Save the instrument's state to the instrument's internal memory.
Function | AgInfiniiVision_SystemWaitForOperationComplete | Does not return until previously started operations complete or more MaxTimeMilliseconds milliseconds of time have expired.
Function | AgInfiniiVision_SystemWriteBytes | Write an array of bytes to the device.
Function | AgInfiniiVision_SystemWriteString | Write a string to the device.
Function | AgInfiniiVision_SystemWriteString2 | Write a string to the device.
Function | AgInfiniiVision_TrackingCopySignal | Sets the other waveform generator output to be identical to this waveform generator output (except that the shape of either output may be inverted).
Function | AgInfiniiVision_TriggerAutoSetup | It automatically sets the trigger levels of all displayed analog channels to their waveforms' 50% values.
Function | AgInfiniiVision_TriggerGlitchGetRange | READ ONLY- Gets the pulse width duration time for trigger source.
Function | AgInfiniiVision_TriggerGlitchSetRange | Pulse width duration for the selected source.
Function | AgInfiniiVision_TriggerPatternConfigure | Configures the pattern trigger
Function | AgInfiniiVision_TriggerPatternGetRange | Returns the duration time for the defined pattern.
Function | AgInfiniiVision_TriggerPatternSetRange | Duration for the defined pattern when the pattern condition is set to INRange or OUTRange
Function | AgInfiniiVision_TriggerPXIGetMasterArmLine | Queries the PXI slave to master arm lines on or off.
Function | AgInfiniiVision_TriggerPXISetMasterArmLine | Sets the PXI slave to master arm lines on or off.
Function | AgInfiniiVision_TriggerRuntConfigure | Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Function | AgInfiniiVision_TriggerWidthConfigure | Configures the width trigger.
Function | AgInfiniiVision_TriggerZoneGetEnabled | Specifies the state for Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneGetMode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | AgInfiniiVision_TriggerZoneGetValidity | Read Only - Query returns the validity of Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneGetZonePlacement | Queries the size and location of Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneSetEnabled | Specifies the state for Zone 1 or Zone 2.
Function | AgInfiniiVision_TriggerZoneSetMode | Specifies the zone qualifying condition for Zone 1 or Zone 2 as either "Must Intersect" or "Must Not Intersect".
Function | AgInfiniiVision_TriggerZoneSetZonePlacement | Sets the size and location of Zone 1 or Zone 2.
Function | AgInfiniiVision_UnlockSession | Releases a previously obtained mutlithread lock.
Function | AgInfiniiVision_UseCursorPosition | Sets X1Position to 0 and X2Position to 100 if the XUnits property is set to Percent, sets X1Position to 0 and X2Position to 360 if the XUnits property is set to Degrees.
Function | AgInfiniiVision_viRead | Reads a complete response from the instrument and returns it as an array of bytes.
Function | AgInfiniiVision_viWrite | Write an array of bytes to the device.
Function | AgInfiniiVision_WaveformPreamble | Returns the Preamble information for the selected waveform source. The preamble data contains information concerning the vertical and horizontal scaling of the data of the corresponding channel
Function | AgInfiniiVision_WaveGenReset | Restores the waveform generator factory default settings-1 kHz sine wave, 500 mVpp, 0 V offset.
Function | AgInfiniiVision_WaveGenResetArbitrary | Clears the Arbitrary waveform memory and loads it with the default waveform.
Function | AgInfiniiVision_WaveGenSetArbitraryDACData | Downloads an arbitrary waveform in integer (DAC) values.
Function | AgInfiniiVision_WaveGenSetArbitraryData | Downloads an arbitrary waveform in floating-point values format.
Function | AgInfiniiVision_WaveGenStoreArbitrary | Stores the source's waveform (source can be any analog channel, or reference waveforms) into the Arbitrary waveform memory.
Top


Attributes

Attributes

 | Name | Description
Attribute | AGINFINIIVISION_ATTR_AC_LINE_TRIGGER_SLOPE | The slope of the zero crossing upon which the scope triggers.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_INDEX | The index into the memory segments that have been acquired. Allowed values are from 1 to 1000 (w/4M memory).
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_SEGMENT_COUNT | The number of memory segments to acquire.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_SEGMENTEDMEMORY_TIME_TAG | Read Only - Returns the time tag of the currently selected segmented memory index.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_START_TIME | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | AGINFINIIVISION_ATTR_ACQUISITION_TYPE | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
Attribute | AGINFINIIVISION_ATTR_ANALOG_BUS_ENABLED | It enables or disables the view of the selected bus.
Attribute | AGINFINIIVISION_ATTR_ANALOG_BUS_LABEL | The label for analog bus. Setting a label for a bus will also result in the name being added to the label list.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_BACKGROUND | Specifies the background of the annotation.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_COLOR | Specifies the annotation color.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_ENABLED | Enables or disables the annotation.
Attribute | AGINFINIIVISION_ATTR_ANNOTATION_TEXT | Specifies the annotation string.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS | Read Only - Queries the number of points used by the current Arbitrary waveform.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_BYTE_ORDER | Specifies the byte order for binary transfers.
Attribute | AGINFINIIVISION_ATTR_ARBITRARY_INTERPOLATION | Enables or disables the Interpolation control.
Attribute | AGINFINIIVISION_ATTR_ARINC429_LABEL | Specifies the ARINC 429 label value when labels are used in the selected search mode.
Attribute | AGINFINIIVISION_ATTR_ARINC429_PATTERN_SDI | Specifies the ARINC 429 two-bit SDI pattern resource according to the string parameter. This pattern controls the SDI pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_ARINC429_PATTERN_SSM | Specifies the ARINC 429 two-bit SSM pattern resource according to the string parameter. This pattern controls the SSM pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_AVERAGE_COUNT | Specify the number of waveforms to be averaged together.
Attribute | AGINFINIIVISION_ATTR_BUS_CLOCK_SOURCE | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_BUS_SLOPE | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_INCREMENT | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_ORIGIN | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | AGINFINIIVISION_ATTR_BUS_Y_UNITS | Specifies the vertical units for the Chart Logic Bus operations.
Attribute | AGINFINIIVISION_ATTR_CACHE | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unnecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_CALIBRATION_LABEL | Calibration string(up to 32 characters not including the quotes).
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_DATE | Read Only - Gets the date of the last calibration.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_ENABLED | Read Only - Returns the rear-panel calibration protect (CAL PROTECT) button state.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_SIGNAL_SOURCE | Signal on the rear panel trigger out BNC.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_TEMPERATURE | Read Only - Change in temperature since the last user calibration procedure.
Attribute | AGINFINIIVISION_ATTR_CALIBRATION_TIME | Read Only - Time of the last calibration.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_COUNT | The number of channels.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_ENABLED | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_INVERT | Inverts the input signal for the specified channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_LABEL | The analog channel label.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROBE_SKEW | Channel-to-channel skew factor for the specified channel. Each analog channel can be adjusted + or -100 ns for a total of 200 ns difference between channels.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROBEID | Read Only - Type of probe attached to the specified oscilloscope channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_PROTECTION | Read Only - State of the input protection for specified channel. If a channel input has experienced an overload, TRIP (tripped) will be returned otherwise NORM (normal).
Attribute | AGINFINIIVISION_ATTR_CHANNEL_SCALE | Vertical scale, or units per division, of the selected channel.
Attribute | AGINFINIIVISION_ATTR_CHANNEL_UNITS | Measurement units for the connected probe.
Attribute | AGINFINIIVISION_ATTR_CLOCK_RECOVERY_DISPLAY_ENABLED | Enable or disable the display of the recovered clock.
Attribute | AGINFINIIVISION_ATTR_COUNTER_CURRENT | Read Only - the current counter value.
Attribute | AGINFINIIVISION_ATTR_COUNTER_ENABLED | Enables or disables the counter feature.
Attribute | AGINFINIIVISION_ATTR_COUNTER_MODE | The counter mode.
Attribute | AGINFINIIVISION_ATTR_COUNTER_NUMBER_OF_DIGITS | The number of digits of resolution used for the frequency or period counter.
Attribute | AGINFINIIVISION_ATTR_COUNTER_SOURCE | The waveform source that the counter measures.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_EVENT_SLOPE | Specifies whether positive or negative edges are counted.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_ENABLED | Enables or disables totalizer gating.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_POLARITY | The gating signal condition under which totalizer edges are counted.
Attribute | AGINFINIIVISION_ATTR_COUNTER_TOTALIZE_GATED_SOURCE | The analog channel that has the totalizer gating signal.
Attribute | AGINFINIIVISION_ATTR_CURSORS_MODE | The cursors mode.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X_DELTA | Read Only - The value difference between the current X1 and X2 cursor positions.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X_UNITS | The X cursors units.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X1_POSITION | Specifies the X1 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X1Y1_SOURCE | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X2_POSITION | Specifies the X2 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_X2Y2_SOURCE | The source for the cursors. The channel you specify must be enabled for cursors to be displayed.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y_DELTA | Read Only - The value difference between the current Y1 and Y2 cursor positions.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y_UNITS | The Y cursors units.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y1_POSITION | Specifies the Y1 cursor position.
Attribute | AGINFINIIVISION_ATTR_CURSORS_Y2_POSITION | Specifies the Y2 cursor position.
Attribute | AGINFINIIVISION_ATTR_DATA3 | Sets and gets the status and data nibbles that will be searched for when the FCData search mode is chosen.
Attribute | AGINFINIIVISION_ATTR_DATA4 | Sets and gets the data to search for in the Slow Channel Message ID and Data search mode.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_COUNT | Attribute that contains the number of DigitalChannels available on the instrument. This is the maximum index that may be used with the GetDigitalChannelName() function.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_ENABLED | Enables/Disables the specified digital channel.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_LABEL | Enables/Disables analog and digital channel labels.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_POSITION | The position of the specified channel.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_SIZE | Size of digital channels on the display.
Attribute | AGINFINIIVISION_ATTR_DIGITALCHANNEL_THRESHOLD | Logic threshold value for all channels in the same pod as the specified channel. The threshold is used for triggering purposes and for displaying the digital data as high(above the threshold) or low (below the threshold).
Attribute | AGINFINIIVISION_ATTR_DISPLAY_INVERT_COLOR_ENABLED | Specifies whether the graticule colors are inverted or not.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_LABEL_ENABLED | Enable/Disables the analog and digital channel labels.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE | Enables or disables infinite-persistence mode of the oscilloscope display.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_PERSISTENCE_TIME | Persistence time to specify how long acquisitions remain on the screen. Permissible Values are from 100E-3 to 60E0.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_SIDEBAR | Write Only. Specifies the sidebar dialog to display on the screen.
Attribute | AGINFINIIVISION_ATTR_DISPLAY_VECTOR_ENABLED | Enables or disables the lines drawn between acquired data points on the screen.
Attribute | AGINFINIIVISION_ATTR_DRIVER_SETUP | Read Only - The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | AGINFINIIVISION_ATTR_DVM_AUTO_RANGE_ENABLED | Enables or disables the Digital Voltmeter's Auto Range capability.
Attribute | AGINFINIIVISION_ATTR_DVM_CURRENT | Read Only - Returns the displayed 3-digit DVM value based on the current mode.
Attribute | AGINFINIIVISION_ATTR_DVM_ENABLED | Enables or disables the Digital Voltmeter (DVM) analysis feature.
Attribute | AGINFINIIVISION_ATTR_DVM_FREQUENCY | Read Only - Returns the displayed 5-digit frequency value that is displayed below the main DVM value.
Attribute | AGINFINIIVISION_ATTR_DVM_MODE | Specifies the digital voltmeter (DVM) mode.
Attribute | AGINFINIIVISION_ATTR_DVM_SOURCE | Specifies the selected analog channel on which digital voltmeter (DVM) measurements are made.
Attribute | AGINFINIIVISION_ATTR_ENABLED | Enable or disable the display of the FFT function.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_ENABLED | Enables or disables the external trigger input display.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_LABEL | The label for the external trigger digital waveform. Setting a label for the external waveform also adds the name to the label list in non-volatile memory (replacing the oldest label in the list).
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_PROBE_ATTENUATION | Scaling factor by which the probe attached to the external trigger attenuates the input.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_PROBE_SENSE | Read Only - Probe attenuation value that the oscilloscope automatically senses.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_RANGE | Full-scale range. If the probe attenuation is changed, the range value is multiplied by the probe attenuation factor.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_THRESHOLD | The external trigger input threshold (trigger) voltage level in volts.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_UNITS | The measurement units for the probe connected to the external trigger input.
Attribute | AGINFINIIVISION_ATTR_EXTERNAL_VERTICAL_POSITION | The external trigger input waveform's vertical position on the oscilloscope display.
Attribute | AGINFINIIVISION_ATTR_FFT_AVERAGE_COUNT | Sets and gets the number of waveforms to be averaged together.
Attribute | AGINFINIIVISION_ATTR_FFT_CENTER_FREQUENCY | Sets and gets the center frequency when FFT (Fast Fourier Transform) is selected.
Attribute | AGINFINIIVISION_ATTR_FFT_DISPLAY_MODE | Sets and gets the FFT waveform display modes.
Attribute | AGINFINIIVISION_ATTR_FFT_OFFSET | Sets and gets the FFT vertical value represented at center screen.
Attribute | AGINFINIIVISION_ATTR_FFT_RANGE | Sets and gets the full-scale vertical axis for the FFT function.
Attribute | AGINFINIIVISION_ATTR_FFT_SOURCE | Sets and gets the source for the FFT function.
Attribute | AGINFINIIVISION_ATTR_FFT_SPAN | Sets and gets the frequency span of the display (left graticule to right graticule) when FFT (Fast Fourier Transform) is selected.
Attribute | AGINFINIIVISION_ATTR_FFT_START_FREQUENCY | Sets and gets the start frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_FFT_STOP_FREQUENCY | Sets and gets the stop frequency in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_FFT_VERTICAL_UNIT | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_FFT_VERTICAL_UNITS | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_FFT_WINDOW_TYPE | Windowing transforms for the FFT.
Attribute | AGINFINIIVISION_ATTR_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH | Specifies the low-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_FM_DEVIATION | Specifies the frequency deviation from the original carrier signal frequency. Frequency deviation in Hz.
Attribute | AGINFINIIVISION_ATTR_FM_FREQUENCY | Specifies the frequency of the modulating signal. Modulating waveform frequency in Hz.
Attribute | AGINFINIIVISION_ATTR_FRA_AMPLITUDE | The waveform generator amplitude in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_AMPLITUDE_PROFILE_STATE | Enables or disables the ability to specify amplitude ramping within different decades
Attribute | AGINFINIIVISION_ATTR_FRA_ENABLED | Enables or disables the Frequency Response Analysis (FRA) feature.
Attribute | AGINFINIIVISION_ATTR_FRA_INPUT_SOURCE | The analog input channel that is probing the input voltage to the device under test (DUT) in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_OUTPUT_LOAD_IMPEDANCE | The current expected output load impedance
Attribute | AGINFINIIVISION_ATTR_FRA_OUTPUT_SOURCE | The analog input channel that is probing the output voltage from the device under test (DUT) in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_POINTS_PER_DECADE | The number of points per decade in the frequency response analysis.
Attribute | AGINFINIIVISION_ATTR_FRA_START_FREQUENCY | The frequency sweep start value.
Attribute | AGINFINIIVISION_ATTR_FRA_STOP_FREQUENCY | The frequency sweep stop value.
Attribute | AGINFINIIVISION_ATTR_FRA_SWEEP_MODE | Select between the normal swept frequency response analysis or analysis at a single frequency
Attribute | AGINFINIIVISION_ATTR_FSK_FREQUENCY | Specifies the "hop frequency". Hop frequency in Hz
Attribute | AGINFINIIVISION_ATTR_FSK_MODULATION_RATE | Specifies the rate at which the output frequency "shifts". FSK modulation rate in Hz.
Attribute | AGINFINIIVISION_ATTR_GLITCH_CONDITION | The glitch condition determines whether the oscilloscope triggers on a pulse with a width less than or greater than the glitch width value.
Attribute | AGINFINIIVISION_ATTR_GLITCH_POLARITY | The polarity of the glitch that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_GLITCH_WIDTH | The glitch width. The units are seconds. Set condition to either Greaterthan or LessThan, prior to Width.
Attribute | AGINFINIIVISION_ATTR_GROUP_CAPABILITIES | Read Only - A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_AXIS | The orientation of the histogram.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_DISPLAY_ENABLED | Enable or disable the histogram display.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_MEASUREMENT | The measurement to analyze.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_MODE | The type of histogram or disables the histogram analysis feature.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_SIZE | The number of divisions the histogram bar graph should use.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_TYPE | The histogram type.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_BOTTOM | The histogram limits window's bottom boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_LEFT | The histogram limits window's left boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_RIGHT | The histogram limits window's right boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_LIMITS_TOP | The histogram limits window's top boundary.
Attribute | AGINFINIIVISION_ATTR_HISTOGRAM_WINDOW_SOURCE | The waveform that is used as the histogram source.
Attribute | AGINFINIIVISION_ATTR_HORZ_MIN_NUM_PTS | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Attribute | AGINFINIIVISION_ATTR_HORZ_RECORD_LENGTH | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimum Number of Points property.
Attribute | AGINFINIIVISION_ATTR_HORZ_SAMPLE_RATE | The effective digitizing rate using the current configuration. The units are samples per second.
Attribute | AGINFINIIVISION_ATTR_HORZ_TIME_PER_RECORD | The time in seconds that corresponds to the record length.
Attribute | AGINFINIIVISION_ATTR_ID2 | Sets and gets the ID to seach for in the "Slow Channel Message ID" and "Slow Channel Message ID & Data" trigger modes.
Attribute | AGINFINIIVISION_ATTR_INITIATE_CONTINUOUS | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediately enters the wait for trigger state without passing through the idle state.
Attribute | AGINFINIIVISION_ATTR_INPUT_IMPEDANCE | The input impedance of this channel. The units are ohms.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_FIRMWARE_REVISION | Read Only - The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_MANUFACTURER | Read Only - The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition.
Attribute | AGINFINIIVISION_ATTR_INSTRUMENT_MODEL | Read Only - The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Attribute | AGINFINIIVISION_ATTR_INTEGRATE_INPUT_OFFSET | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Attribute | AGINFINIIVISION_ATTR_INTERCHANGE_CHECK | Not Supported - If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | AGINFINIIVISION_ATTR_INTERPOLATION | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Attribute | AGINFINIIVISION_ATTR_IO_RESOURCE_DESCRIPTOR | Read Only - The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | AGINFINIIVISION_ATTR_JITTER_ANALYSIS_ENABLED | Enables or disables the jitter analysis feature.
Attribute | AGINFINIIVISION_ATTR_JITTER_MEASUREMENT | The measurement to analyze.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_CENTER_FREQUENCY | The center frequency for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_HORIZONTAL_FREQUENCY_SPAN | The frequency span of the display (left graticule to right graticule) for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_OFFSET | The vertical value represented at center screen for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_RANGE | The full-scale vertical range for the jitter measurement spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_VERTICAL_UNIT | The vertical units for the jitter spectrum.
Attribute | AGINFINIIVISION_ATTR_JITTER_SPECTRUM_WINDOW | Allows the selection of four different windowing transforms or operations for the jitter spectrum FFT (Fast Fourier Transform).
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_SMOOTHING_POINTS | The number of smoothing points to use when jitter trend smoothing is enabled using ConfigureSmoothing method.
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_OFFSET | The vertical value represented at center screen for the jitter measurement trend.
Attribute | AGINFINIIVISION_ATTR_JITTER_TREND_VERTICAL_RANGE | The full-scale vertical range for the jitter measurement trend.
Attribute | AGINFINIIVISION_ATTR_LINEAR_GAIN | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_LINEAR_OFFSET | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_LOGICAL_NAME | Read Only - Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ALL_CHANNEL_ENABLED | Enables all analog channels to be included in the mask test or only selected channels.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_BIND_CONTROL_ENABLED | Enables/Disables Bind control 1 &amp; 0 Levels and Bind -1 &amp; 0 Levels for inverted masks. Gets the current bind control level settings.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_SIGMA_LEVEL | Sigma Level when the termination condition is set to Sigma. Allowed Range is 0.1 to 9.3.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_CONDITION | The termination conditions for the mask test.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TERMINATION_ENABLED | Enables/Disables stopping of mask test and acquisition on a mask failure. Gets the current stopping on mask failure setting.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_TIME | The number of seconds for a mask test to run. Permissible Range is 1 to 86400.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_CONFIGURATION_WAVEFORM | The number of waveform acquisitions that are mask tested. Permissible range is 1 to 2,000,000,000.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ELAPSED_TIME | Read Only - Elapsed time (in seconds) in the current mask test run.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_ENABLED | Enables/Disables the mask test features.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_HORIZONTAL_TOLERANCE | Tolerance in the X direction around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to horizontal values of the waveform to determine the boundaries of the mask.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_LOCK_ENABLED | Enables/Disables the mask lock.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X_DELTA | The position of the X2 marker with respect to the X1 marker. In the mask test coordinate system, the X1 marker defines where X=0; thus, the X2 marker defines where X=1.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_X1_COORDINATE | The position of X1 coordinate where X=0 in the base coordinate system used for mask testing. The X1 value is a time value specifying the location of the X1 coordinate, which will then be treated as X=0 for mask regions coordinates.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y1_COORDINATE | Position of Y1 coordinate where Y=0 in the base coordinate system used for mask testing.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MARKERS_Y2_COORDINATE | Position of the Y2 marker with respect to the Y1 marker. In the mask test coordinate system, the Y1 marker defines where Y=0; thus, the Y2 marker defines where Y=1.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_FAILED_WAVEFORM_COUNT | Read Only - Returns the total number of failed waveforms in the current mask test run for all regions and all waveforms.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_MEASUREMENT_ENABLED | Enables/Disables measuring only mask failures setting. Gets the current measure only mask failures settings
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_PRINT_FAILURES_ENABLED | Enables/Disables printing on mask failure.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_MASKFAILURES_SAVE_FAILURES_ENABLED | Enables/Disables saving on mask failure.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_SOURCE | The source that is used to create an AutoMask and for mask testing. In case IAgInfiniiVisionMaskTest.AllChannelEnabled is enabled all ON channels are tested.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_TITLE | Read Only - Returns the mask title which is a string of up to 128 characters
Attribute | AGINFINIIVISION_ATTR_MASKTEST_UNITS | Measurement units for automask which interprets the tolerance parameters for automasking.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_VERTICAL_TOLERANCE | The vertical tolerance around the waveform for the automasking feature. The absolute value of the tolerance will be added and subtracted to vertical values of the waveform to determine the boundaries of the mask.
Attribute | AGINFINIIVISION_ATTR_MASKTEST_WAVEFORM_COUNT | Read Only - The total number of waveforms acquired in the current mask test run.
Attribute | AGINFINIIVISION_ATTR_MATH_ENABLED | Enables/Disables the math function.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_CENTER_FREQUENCY | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_OPERATION | Sets the math operation for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE1 | Sets the first input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_INTERNAL_SOURCE2 | Sets the second input channel for the g(t) source that can be used as the input to the FFT, Integrate, Differentiate, or SQRT functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_SPAN | Frequency span of the display when FFT is selected.
Attribute | AGINFINIIVISION_ATTR_MATH_FFT_WINDOW_TYPE | Windowing transforms for the FFT.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_CLOCK_SOURCE | Specifies the clock signal source for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_SLOPE | Specifies the clock signal edge for the Chart Logic Bus State operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_INCREMENT | Specifies the value associated with each increment in Chart Logic Bus data.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_ORIGIN | Specifies the value associated with Chart Logic Bus data equal to zero.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_BUS_Y_UNITS | Specifies the vertical units for the Chart Logic Bus operations.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_ENABLED | Enables/Disables the math function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_CENTER_FREQUENCY | Center frequency for FFT function. Permissible values are 0 Hz to 25E9 Hz.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_SPAN | Frequency span of the display when FFT is selected.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_START_FREQUENCY | The start frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_STOP_FREQUENCY | The stop frequency in Hz in the FFT (Fast Fourier Transform) math function's displayed range.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_VERTICAL_UNITS | Specifies the FFT vertical units.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FFT_WINDOW_TYPE | Windowing transforms or operations for the FFT.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_HIGH_PASS_BANDWIDTH | Specifies the high-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_FILTER_FREQUENCY_LOW_PASS_BANDWIDTH | Specifies the low-pass filter's -3 dB cutoff frequency.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_INTEGRATE_INPUT_OFFSET | Specifies a DC offset correction factor for the Integrate math waveform input signal. This DC offset correction lets you level a ramped waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_GAIN | Specifies the Gain ("A" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_LINEAR_OFFSET | Specifies the Offset ("B" in Ax + B) for the Linear Math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_SLOT | The measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_MEASUREMENT_TREND_TYPE | Specifies the measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_OFFSET | Voltage or vertical value represented at center screen for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_OPERATION | Waveform math operation.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SMOOTHING_POINTS | The number of smoothing points to use.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE1 | The first source for the operation math functions or the single source for the transform functions, filter functions, or visualization functions.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_SOURCE2 | Specifies the second source for math operator functions that have two sources. It is not used for the transform functions, filter functions, or visualization functions (except when the measurement trend visualization's measurement requires two sources).
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_RANGE | Range of Full-scale vertical axis for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_FUNCTION_VERTICAL_SCALE | Vertical scale, or units per division, of the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_OFFSET | Voltage or vertical value represented at center screen for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_OPERATION | Waveform math operation
Attribute | AGINFINIIVISION_ATTR_MATH_SOURCE1 | First source for channel math operations or the single source for the transforms. If "GOFT" is selected as the source, the sources are determined by InternalSource1 and InternalSource2.
Attribute | AGINFINIIVISION_ATTR_MATH_SOURCE2 | Second source for math operations that have two sources. It is not used when FFT is used. Permissible Values are Channel<n> | NONE (in this format only).</n>
Attribute | AGINFINIIVISION_ATTR_MATH_VERTICAL_RANGE | Range of Full-scale vertical axis for the selected function.
Attribute | AGINFINIIVISION_ATTR_MATH_VERTICAL_SCALE | Vertical scale, or units per division, of the selected function.
Attribute | AGINFINIIVISION_ATTR_MATHFUNCTION_COUNT | Attribute that contains the number of MathFunctions available on the instrument. This is the maximum index that may be used with the GetMathFunctionName() function.
Attribute | AGINFINIIVISION_ATTR_MAX_INPUT_FREQUENCY | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Attribute | AGINFINIIVISION_ATTR_MEAS_HIGH_REF | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEAS_LOW_REF | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEAS_MID_REF | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE1 | The occurrence count for the first waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_OCCURRENCE2 | The occurrence count for the second waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE1 | The polarity of the slope for the first waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_DELAY_SLOPE2 | The polarity of the slope for the second waveform source of a generic delay measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_MARKERS_ENABLED | Enables markers for tracking measurements on the display. This feature is always on.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_SOURCE2 | Second source for measurements such as Delay, Phase etc.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_OCCURRENCE | The occurrence count for the TimeAtEdge measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_EDGE_SLOPE | The edge slope for a TimeAtEdge measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_OCCURRENCE | The occurrence count for the TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_SLOPE | The edge slope for a TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_TIME_AT_VALUE_VALUE | The voltage for the TimeAtValue measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_VALUE_AT_TIME_TIME | The time (in seconds) used to make the ValueAtTime measurement.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_CONFIGURATION_WINDOW | Measurement window when zoomed time base is selected.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_COUNT | Attribute that contains the number of Measurements available on the instrument. This is the maximum index that may be used with the GetMeasurementName() function.
Attribute | AGINFINIIVISION_ATTR_MEASUREMENT_TREND_TYPE | Specifies the measurement whose trend is shown in the math waveform.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_DIRECTORY | Present working directory for recall operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_RECALL_FILE | File for recall operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_DIRECTORY | Present working directory for save operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_CURRENT_SAVE_FILE | File for save operations.
Attribute | AGINFINIIVISION_ATTR_MEMORY_IMAGE_FORMAT | Type of image format
Attribute | AGINFINIIVISION_ATTR_MEMORY_IMAGE_PALETTE | Image palette color.
Attribute | AGINFINIIVISION_ATTR_MEMORY_INVERT_COLOR_ENABLED | Enable/Disables invert of the graticule colors. Returns a flag indicating whether graticule colors are inverted or not.
Attribute | AGINFINIIVISION_ATTR_MEMORY_REFERENCE_WAVEFORM_SOURCE | The source to be saved as a reference waveform file. Permissible Values are Channel<n> | Math<r> | WMEM<r>,(in this format only) where n: 1 to # analog channels; r: {1|2|3|4}.</r></r></n>
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_CURSOR_ENABLED | Enables or disables whether the cursor values will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_HISTOGRAM_ENABLED | Enables or disables whether the histogram statistics will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MASK_ENABLED | Enables or disables whether the mask statistics will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_MEASUREMENT_ENABLED | Enables or disables whether the measurement results will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEARCH_ENABLED | Enables or disables whether the found search event times will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_RESULT_FORMAT_SEGMENTED_ENABLED | Enables or disables whether the segmented memory acquisition times will be included when analysis results are saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SAVE_FACTORS_ENABLED | Enables/Disables saving oscilloscope factors along with the image. Returns a flag indicating whether oscilloscope factors are output along with the image.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SAVE_OPTION | The segments to be included when the waveform is saved.
Attribute | AGINFINIIVISION_ATTR_MEMORY_SERIAL_RECALL_DESTINATION | This command defines the destination Serial Bus (Serial Bus 1 or Serial Bus 2) when recalling an LDF or DBC file using the Memory::Recall function. A typical usage would be to first set the destination using Memory::SerialRecallDestination, followed by Memory::Recall (LDF or DBC).
Attribute | AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_FORMAT | Data format of waveform
Attribute | AGINFINIIVISION_ATTR_MEMORY_WAVEFORM_LENGTH | Waveform data length (number of points saved).
Attribute | AGINFINIIVISION_ATTR_MODE | Sets and gets the search mode settings.
Attribute | AGINFINIIVISION_ATTR_MODULATION_ENABLED | Enables or disables modulated waveform generator output.
Attribute | AGINFINIIVISION_ATTR_MODULATION_FUNCTION | Specifies the shape of the modulating signal.
Attribute | AGINFINIIVISION_ATTR_MODULATION_RAMP_SYMMETRY | Specifies the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_MODULATION_TYPE | Specifies the modulation type.
Attribute | AGINFINIIVISION_ATTR_NUM_AVERAGES | The number of values (in averaging mode) to be averaged for each time bucket before the acquisition is considered to be complete for that time bucket. The count can be set to any value from 2 to 65536.
Attribute | AGINFINIIVISION_ATTR_NUM_ENVELOPES | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Attribute | AGINFINIIVISION_ATTR_PROBE_ATTENUATION | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Attribute | AGINFINIIVISION_ATTR_PROBE_SENSE_VALUE | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Attribute | AGINFINIIVISION_ATTR_QUERY_INSTRUMENT_STATUS | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | AGINFINIIVISION_ATTR_RANGE_CHECK | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | AGINFINIIVISION_ATTR_RECORD_COERCIONS | Not Supported - If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | AGINFINIIVISION_ATTR_REFERENCE_SIGNAL | Selects the 10 MHz Reference Signal Mode.
Attribute | AGINFINIIVISION_ATTR_RUNT_HIGH_THRESHOLD | The high threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | AGINFINIIVISION_ATTR_RUNT_LOW_THRESHOLD | The low threshold the oscilloscope uses for runt triggering. The units are volts.
Attribute | AGINFINIIVISION_ATTR_RUNT_POLARITY | The polarity of the runt that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_SAMPLE_MODE | The sample mode the oscilloscope is currently using.
Attribute | AGINFINIIVISION_ATTR_SEARCH_COUNT | Read Only - Gets the number of search events found.
Attribute | AGINFINIIVISION_ATTR_SEARCH_EDGE_SLOPE | The slope of the edge for the search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_EDGE_SOURCE | The channel on which to search for edges. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_CONDITION | Specifies the mode of operation of the glitch (pulse width) search. The oscilloscope can search for a pulse width that is greater than a time value, less than a time value, or within a range of time values.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_MAX_PULSE_WIDTH_DURATION | The maximum pulse width duration time (in seconds) for the selected source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_MIN_PULSE_WIDTH_DURATION | The minimum pulse width duration time (in seconds) for the selected source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_POLARITY | The polarity for the glitch (pulse width) source.
Attribute | AGINFINIIVISION_ATTR_SEARCH_GLITCH_SOURCE | The channel on which to search for glitches (pulse widths). The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_MODE | The oscilloscope search mode.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_EXCURSION | The change in level that must occur (in other words, hysteresis) to be recognized as a peak.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_NUMBER_OF_PEAKS | The maximum number of FFT peaks to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_SOURCE | The FFT math function waveform to search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_PEAK_THRESHOLD | The threshold level necessary to be considered a peak.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_CONDITION | Specifies whether to search for a runt that is greater than a time value, less than a time value or any time value.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_POLARITY | Sets/Gets the polarity for the runt search.
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_QUALIFIER_TIME | When searching for runt pulses whose widths are greater than or less than a time, the QualifierTime property specifies the time value (in seconds).
Attribute | AGINFINIIVISION_ATTR_SEARCH_RUNT_SOURCE | The channel on which to search for the runt pulse. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_MODE | Specifies the type of ARINC 429 information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_ARINC429_PATTERN_DATA | Specifies the ARINC 429 data pattern resource according to the string parameter. This pattern controls the data pattern searched for in each ARINC 429 word.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_MODE | Specifies the type of CAN information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA | Specifies the data value when searching for Data Frame ID and Data. The data value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERN_DATA_LENGTH | Specifies the length of the data value when searching for Data Frame ID and Data. Permissible values are: 1 to 8.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID | Specifies the ID value when searching for a CAN event. The ID value is a string in the format: "0xnn...n" where n: {0,..,9|A,..,F|X} for hexadecimal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_PATTERNID_TYPE | Specifies whether a standard ID value or an extended ID value is used when searching for a CAN event.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_MESSAGE | Sets and Gets the specific message when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message or Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_CAN_SYMBOLIC_VALUE | Sets and Gets the specific signal value when CAN symbolic data has been loaded (recalled) into the oscilloscope and the CAN serial search mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_CYCLE_NUMBER | Specifies the cycle value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_FRAME_ID | Specifies the frame ID value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_MODE | Specifies the type of FlexRay information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA | Specifies the data value to find when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_FLEXRAY_PATTERN_DATA_LENGTH | Specifies the length of data values when searching for FlexRay frames.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_AUDIO_CHANNEL | Specifies the channel on which to search for I2S events: right, left, or either channel.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_MODE | Specifies the type of I2S information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_I2S_PATTERN_DATA | Specifies the data word value when searching for I2S events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_ADDRESS | Specifies the address values when searching for IIC events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_CONDITION | Specifies the data value qualifier used when searching for IIC EEPROM data read events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_MODE | Selects the type of IIC information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA | Specifies the data values when searching for IIC events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_IIC_PATTERN_DATA2 | Specifies the second data value when searching for IIC events with two data values.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_ID | Specifies the frame ID value when searching for LIN events
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_MODE | Selects the type of LIN information to find in the Lister display
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA | Specifies the data value when searching for LIN events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_PATTERN_DATA_LENGTH | Specifies the length of the data value when searching for LIN events. Valid values are from 1 to 8.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_FRAME | Sets and Gets the specific message when LIN serial search mode is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when LIN serial search mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_LIN_SYMBOLIC_VALUE | Sets and Gets the specific signal value when LIN serial search mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_MODE | Specifies the type of MIL-STD-1553 information to find in the Lister display.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_PATTERN_DATA | Specifies the additional 11 bits when searching for the MIL-STD-1553 Remote Terminal Address + 11 Bits.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_M1553_RTA | Specifies the Remote Terminal Address (RTA) value when searching for MIL-STD-1553 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_MODE | Specifies whether the SPI search will be on the MOSI data or the MISO data.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_DATA | Specifies the data value when searching for SPI events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_SPI_PATTERN_WIDTH | Specifies the width of the data value (in bytes) when searching for SPI events. Valid values are from 1 to 10.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_CONDITION | Specifies the data value qualifier when searching for UART/RS232 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_MODE | Selects the type of UART/RS232 information to find in the Lister display
Attribute | AGINFINIIVISION_ATTR_SEARCH_SERIAL_UART_PATTERN_DATA | Specifies a data value when searching for UART/RS232 events.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_CONDITION | Specifies whether to search for edge transitions greater than or less than a time.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_QUALIFIER_TIME | The time (in seconds) of the transition to search for. You can search for transitions greater than or less than this time.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SLOPE | Specifies whether to search for rising edge (Positive slope) transitions or falling edge (Negative slope) transitions.
Attribute | AGINFINIIVISION_ATTR_SEARCH_TRANSITION_SOURCE | The channel on which to search for edge transitions. The source is a string specified in the format: "Channel<n>", where <n> can be set to a value from 1 to the total number of analog channels available.</n></n>
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_ADDRESS | Specifies the 7-bit Address portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_CONDITION | Specifies the USB search mode.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_CRC | Specifies the CRC portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_DATA | Specifies the Data portion of the trigger, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_DATA_LENGTH | Specifies the data length in bytes.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_END_POINT | Specifies the 4-bit Endpoint portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_ET | Specifies the 2-bit ET portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_FRAME | Specifies the 11-bit Frame portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_HUB_ADDRESS | Specifies the 7-bit Hub Address portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_DATA | Specifies the USB data PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_HANDSHAKE | Specifies the USB handshake PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_SPECIAL | Specifies the USB special PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PID_TOKEN | Specifies the USB token PID to find.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_PORT | Specifies the 7-bit Port portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_SC | Specifies the 1-bit SC portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SEARCH_USB_SEU | Specifies the 2-bit S and E or U portion of the search value, in hex.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_BASE | Selects between hexadecimal and binary display of the decoded data.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_DISPLAY_FORMAT | Specifies the word decode format.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_ERROR_COUNT | Read Only - Returns the ARINC 429 error count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SIGNAL_TYPE | Specifies the type of ARINC 429 signal being probed. Line A (non-inverted), Line B (inverted), or Differential (A ? B).
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SOURCE | Specifies which signal is used as the source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_SPEED | Specifies the speed of the ARINC 429 interface for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_LABEL | Specifies the Label portion of the trigger for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_DATA | Specifies the Data portion of the trigger for the selected bus, in binary.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SDI | Specifies the SDI portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_PATTERN_SSM | Specifies the SSM portion of the trigger for the selected bus, in binary. Length is always 2 bits.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_THRESHOLD_LOW | The low threshold the oscilloscope uses for the ARINC429 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_TRIGGER_TYPE | Specifies the ARINC 429 trigger mode for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_ARINC429_WORD_COUNT | Read Only - Returns the ARINC 429 word count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_BAUDRATE | Specifies the baud rate. Valid values are: 2500000, 5000000, 10000000 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_CHANNEL | Specifies the bus channel, A or B, of the FlexRay signal.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_ERROR_COUNT | Read Only - Gets the FlexRay error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_NULL_COUNT | Read Only - Gets the FlexRay null frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SOURCE | Specifies the input source for the FlexRay signal.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_SYNC_COUNT | Read Only - Gets the FlexRay sync frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TOTAL_COUNT | Read Only - Gets the FlexRay total frame count.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_ERROR_TYPE | Specifies the FlexRay error type to trigger on. The error type setting is only valid when the FlexRay TriggerType property is set to Error.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_BSS_ID | Specifies the ByteStart Sequence ID.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_EVENT_TYPE | Specifies the FlexRay event to trigger on. The event setting is only valid when the FlexRay TriggerType property is set to Event.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCBASE | Specifies the base of the FlexRay cycle count (in the frame header) to trigger on. The cycle count base setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_CCREPETITION | Specifies the repetition number of the FlexRay cycle count (in the frame header) to trigger on. The cycle count repetition setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_ID | Specifies the FlexRay frame ID to trigger on. The frame ID setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_FRAME_TYPE | Specifies the FlexRay frame type to trigger on. The frame type setting is only valid when the FlexRay TriggerType property is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_FLEXRAY_TRIGGER_TYPE | Specifies the FlexRay trigger on condition.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_DISPLAY | The Lister Display setting. Configures which of the serial buses to display in the lister, or whether the lister is off.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_LISTER_TIME_REFERENCE | Selects whether the time value for a Lister row is relative to the trigger or the previous Lister row.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_BASE | Specifies the base to use for the MIL-STD 1553 decode display.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_SOURCE | Specifies which signal is used as the source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_PATTERN_DATA | Specifies the 11 bits to trigger on if the trigger type has been set to RTA11 (RTA + 11 Bits) using the TriggerType property.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_RTA | Specifies the Remote Terminal Address (RTA) to trigger on if the trigger type has been set to RTA using the TriggerType property.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_THRESHOLD_LOW | The low threshold the oscilloscope uses for the M1553 serial bus mode. The units are volts.
Attribute | AGINFINIIVISION_ATTR_SERIAL_BUS_M1553_TRIGGER_TYPE | Specifies the type of MIL-STD 1553 trigger to be used.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_BAUD_RATE | Specifies the standard baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_DISPLAY | Sets and Gets the CAN decode display type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_ERROR_COUNT | Read Only - Gets the error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_BAUD_RATE | Specifies the FD Rate baud rate of the CAN signal. The baud rate is set from 10 kb/s to 1 Mb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_DATA_LENGTH_CODE | Sets and gets the DLC value to be used in the CAN FD data trigger mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_SPEC_ERROR_COUNT | Read Only - Gets the Spec error (Ack + Form + Stuff + CRC errors) count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_STANDARD | Sets and Gets the frame decode standard.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGER_PATTERN_START_BYTE_POSITION | Sets and gets the starting byte position for CAN FD data triggers.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_FD_TRIGGERID_FILTER_ENABLED | Enable and disable the triggers filtering by CAN IDs.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_OVERLOAD_COUNT | Read Only - Gets the overload frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time. Query returns the current CAN sample point setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SIGNAL_TYPE | Specifies the CAN signal type when TriggerCondition is set to AgInfiniiVisionSerialBusCANTriggerConditionSOF (Start of Frame).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_SOURCE | Specifies the source for the CAN signal
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TOTAL_COUNT | Read Only - Gets the total frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_CONDITION | Specifies the CAN trigger on condition
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA | Specifies the CAN data pattern resource according to the string parameter. This pattern, along with the data length (set by the TriggerPatternDataLength property), control the data pattern searched for in each CAN message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERN_DATA_LENGTH | Specifies the number of 8-bit bytes in the CAN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID | Specifies the CAN identifier pattern resource according to the string parameter. This pattern, along with the identifier mode (set by the TriggerPatternIDType property), control the identifier pattern searched for in each CAN message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_PATTERNID_TYPE | Specifies the CAN identifier mode. The CAN identifier is set by the TriggerPatternID property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_MESSAGE | Sets and Gets the specific message when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message or Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_TRIGGER_SYMBOLIC_VALUE | Sets and Gets the specific signal value when CAN FD symbolic data has been loaded (recalled) into the oscilloscope and the CAN FD trigger mode is set to Message and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_CAN_UTILIZATION | Read Only - Gets the percent utilization.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_COUNT | Attribute that contains the number of Serial Buses available on the instrument. This is the maximum index that may be used with the GetSerialBusName() function.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_ENABLED | Specifies whether the serial decode bus will be displayed or not. When Enabled is set to true, the serial decode bus is displayed. When false, the serial decode bus is not displayed.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_BASE | Specifies the base to use for the I2S decode display.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SLOPE | Specifies which edge of the I2S serial clock signal clocks in data
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_CLOCK_SOURCE | Specifies which signal is used as the serial clock (SCLK) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_ALIGNMENT | Specifies the data alignment of the I2S bus for the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_DATA_SOURCE | Specifies which signal is used as the serial data (SDATA) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_RECEIVER_WIDTH | Specifies the width of the receiver (decoded) data word in I2S anywhere from 4 bits to 32 bits
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRANSMITTED_WIDTH | Specifies the width of the transmitted data word in I2S anywhere from 4 bits to 32 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_AUDIO_CHANNEL | Specifies the audio channel to trigger on.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_CONDITION | Specified the I2S trigger operator.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_TRIGGER_PATTERN_DATA | Specifies the I2S trigger data pattern searched for in each I2S message.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_POLARITY | Specifies the polarity of the word select (WS) signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_I2S_WORD_SELECT_SOURCE | Specifies which signal is used as the word select (WS) source by the serial decoder and/or trigger when in I2S mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_ADDRESS_WIDTH | Specifies whether the Read/Write bit is included as the LSB in the display of the IIC address field of the decode bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_CLOCK_SOURCE | Specifies the source for the IIC serial clock (SCL).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_DATA_SOURCE | Specifies the source for IIC serial data (SDA).
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_CONDITION | Specifies the IIC data qualifier when the TriggerType property is set to AgInfiniiVisionSerialBusIICTriggerTypeReadEprom
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_ADDRESS | Specifies the address for IIC data. The address can range from 0x00 to 0x7F (7-bit) or 0x3FF (10-bit) hexadecimal. Use the don't care address (-1 or 0xFFFFFFFF) to ignore the address value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA | Specifies the IIC data. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_PATTERN_DATA2 | Specifies the IIC data 2. The data value can range from 0x00 to 0x0FF (hexadecimal). Use the don't care data pattern (-1 or 0xFFFFFFFF) to ignore the data value.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_IIC_TRIGGER_TYPE | Specifies the IIC trigger type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_BAUD_RATE | Specifies the standard baud rate of the LIN signal from 2400 b/s to 625 kb/s in 100 b/s increments. If you enter a baud rate that is not divisible by 100 b/s, the baud rate is set to the nearest baud rate divisible by 100 b/s
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_DISPLAY | Sets and Gets the LIN decode display type.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_PARITY_ENABLED | Specifies whether the parity bits are included as the most significant bits (MSB) in the display of the Frame Id field in the LIN decode bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SAMPLE_POINT | Specifies the point during the bit time where the bit level is sampled to determine whether the bit is dominant or recessive. The sample point represents the percentage of time between the beginning of the bit time to the end of the bit time.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SOURCE | Specifies the source for the CAN signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_STANDARD | Specifies the LIN standard in effect for triggering and decoding to be LIN1.3 or LIN2.0.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_SYNC_BREAK_LENGTH | Specifies the length of the LIN sync break to be greater than or equal to 11, 12, or 13 clock lengths. The sync break is the idle period in the bus activity at the beginning of each packet that distinguishes one information packet from the previous one.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_CONDITION | Specifies the LIN trigger condition.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA | Specifies the LIN trigger data pattern searched for in each LIN data field.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_PATTERN_DATA_LENGTH | the number of 8-bit bytes in the LIN data string. The number of bytes in the string can be anywhere from 1 bytes to 8 bytes (64 bits). The value for these bytes is set by the TriggerPatternData property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_FRAME | Sets and Gets the specific message when the LIN trigger mode is set to Frame.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_SIGNAL | Sets and Gets the specific signal when the LIN trigger mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGER_SYMBOLIC_VALUE | Sets and Gets the specific signal value when the LIN trigger mode is set to Frame and Signal.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_LIN_TRIGGERID | Specifies the LIN identifier searched for in each CAN message when the LIN trigger mode is set to frame ID.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_MODE | Determines the decode mode for the serial bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_CLOCK | Sets and gets the nominal clock period (tick), from 1us to 300us.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_CRC_FORMAT | Set and get the format of the CRC.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_FORMAT | Sets and gets the message decode/triggering format.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_IDLE_STATE | Sets and gets the idle state of the SENT bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_BASE | Sets and gets the number base used by the decoder.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_NUMBER_OF_NIBBLE | Sets and gets the number of nibbles in a SENT message, from 1 to 6.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_PAUSE_PULSE | This command specifies whether the SENT messages are followed by a pause pulse.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_SOURCE | Sets and gets the input channel for SENT decode and triggering.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TOLERANCE | Sets and gets the tolerance for determing if the sync pulse is valid.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_FAST_CHANNEL_DATA | Sets and gets the status and data nibbles that will be triggered on when the FCData trigger mode is chosen.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_MODE | Sets and Gets the SENT trigger mode setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_DATA | Sets and gets the data to trigger on for the Slow Channel Message ID and Data trigger mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID | Sets and gets the ID to trigger on for the Slow Channel Message ID and Slow Channel Message ID & Data trigger modes.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_SLOW_CHANNEL_ID_DATA_LENGTH | Sets and gets the ID and data lengths for the Slow Message Enhanced messages. Either "SHORt" for the 4-bit ID, 16-bit data format, or "LONG" for the 8-bit ID, 12-bit data Format.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SENT_TRIGGER_TOLERANCE | Sets and Gets the tolerance variation percent setting.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_BIT_ORDER | Specifies the bit order, most significant bit first (MSB) or least significant bit first (LSB), used when displaying data in the serial decode waveform and in the Lister.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SLOPE | Specifies the rising edge (Positive) or falling edge (Negative) of the SPI clock source that will clock in the data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_SOURCE | Specifies the source for the SPI serial clock.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_CLOCK_TIMEOUT | Specifies the SPI signal clock timeout resource in seconds from 100 ns to 10 s when the Framing property is set to AgInfiniiVisionSerialBusSPIFramingTimeout. The timer is used to frame a signal by a clock timeout.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAME_SOURCE | Specifies the frame source when Framing property is set to AgInfiniiVisionSerialBusSPIFramingChipSelect or AgInfiniiVisionSerialBusSPIFramingNChipSelect.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_FRAMING | Specifies the SPI trigger framing value. If AgInfiniiVisionSerialBusSPIFramingTimeout is selected, the timeout value is set by the ClockTimeout property.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_MISO_SOURCE | Specifies the source for the SPI serial MISO data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_MOSI_SOURCE | Specifies the source for the SPI serial MOSI data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_DATA | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMISO_WIDTH | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_DATA | Specifies the SPI data pattern resource according to the string parameter. This pattern, along with the data width, control the data pattern searched for in the data stream.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_PATTERNMOSI_WIDTH | Specifies the width of the SPI data pattern anywhere from 4 bits to 64 bits.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_TRIGGER_TYPE | Specifies whether the SPI trigger will be on the MOSI data or the MISO data.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_SPI_WIDTH | Specifies the number of bits in a word of data for SPI.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BASE | Specifies the base to use for the UART decode and Lister display.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BAUD_RATE | Specifies the bit rate (in bps) for the serial decoder and/or trigger when in UART mode. The baud rate can be set from 1200 b/s to 8 Mb/s in 100 b/s increments.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_BIT_ORDER | Specifies the order of transmission used by the physical Tx and Rx input signals for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_ERROR_COUNT | Read Only - Gets the UART error frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_FRAMING | Specifies the byte value to use for framing (end of packet) or to turn off framing for UART decode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_PARITY | Specifies the parity to be used with each message "byte" for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_POLARITY | Specifies the polarity as idle low or idle high for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_FRAME_COUNT | Read Only - Gets the UART Rx frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_RX_SOURCE | Specifies which signal is used as the Rx source by the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BASE | Specifies the front panel UART/RS232 trigger setup data selection.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_BURST | Specifies the burst value (Nth frame after idle period) in the range 1 to 4096 or OFF, for the trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_CONDITION | Specifies the data qualifier when TriggerType is set to RData, RD1, RD0, RDX, TData, TD1, TD0, or TDX for the trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_DATA | Specifies the data byte value (0x00 to 0xFF) for the trigger condition when in UART mode. The data value is used when one of the RD or TD trigger types is selected.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_IDLE_TIME | Specifies the value of the idle period for burst trigger in the range from 1 us to 10 s when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TRIGGER_TYPE | Specifies the UART Trigger Type
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_FRAME_COUNT | Read Only - Gets the UART Tx frame count.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_TX_SOURCE | Specifies which signal is used as the Tx source by the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_UART_WIDTH | Specifies the number of bits (5-9) for each message "byte" for the serial decoder and/or trigger when in UART mode.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_ADDRESS | Specifies the 7-bit Address portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_BASE | Specifies the base to use for the USB decode and Lister display, controlling how the data or payload field is displayed.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_CONDITION | Specifies USB trigger mode for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_CRC | Specifies the CRC portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_D_MINUS_SOURCE | Specifies which signal is used as the USB D- source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_D_PLUS_SOURCE | Specifies which signal is used as the USB D+ source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA | Specifies the Data portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DATA_LENGTH | Specifies the data length in bytes.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_DIFFERENTIAL_SOURCE | Specifies which signal is used as the differential source for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_END_POINT | Specifies the 4-bit Endpoint portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_ET | Specifies the 2-bit ET portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_FRAME | Specifies the 11-bit Frame portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_HUB_ADDRESS | Specifies the 7-bit Hub Address portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_CHECK | Specifies the 4-bit PID check portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_DATA | Specifies the USB data PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_HANDSHAKE | Specifies the USB handshake PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_SPECIAL | Specifies the USB special PID to trigger on for the selected bus
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PID_TOKEN | Specifies the USB token PID to trigger on for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_PORT | Specifies the 7-bit Port portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SC | Specifies the 1-bit SC portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SEU | Specifies the 2-bit S and E or U portion of the trigger for the selected bus, in binary or hex.
Attribute | AGINFINIIVISION_ATTR_SERIALBUS_USB_SPEED | Specifies the speed of the USB interface for the selected bus.
Attribute | AGINFINIIVISION_ATTR_SIMULATE | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_DESCRIPTION | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_PREFIX | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_REVISION | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_SPECIFIC_DRIVER_VENDOR | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_COUNT | Specifies the maximum number of values used when calculating measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_DISPLAY_ENABLED | Enables or disables the display of the measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_FORMAT | Specifies the type of information returned by the GetResults() method.
Attribute | AGINFINIIVISION_ATTR_STATISTICS_RELATIVE_STD_DEV_ENABLED | Disables or enables relative standard deviations, that is, standard deviation/mean, in the measurement statistics.
Attribute | AGINFINIIVISION_ATTR_STATUS_SERIAL_POLL | Read Only - Serial poll the instrument status byte.
Attribute | AGINFINIIVISION_ATTR_SUPPORTED_INSTRUMENT_MODELS | Read Only - A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_IO_TIMEOUT | The I/O timeout in milliseconds. The client program should normally not need to set the timeout. Driver methods with operations which take a significant time to perform are responsible for adjusting the I/O timeout to an appropriate value.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_MESSAGE | Writes a message(excluding quotation marks) to a text box in the center of the display
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PRECISION_ENABLED | Enables or disables the oscilloscope's precision analysis setting.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PRECISION_RECORD_LENGTH | The length of the precision analysis record (when precision measurements and math functions mode is enabled).
Attribute | AGINFINIIVISION_ATTR_SYSTEM_PROTECTION_ENABLED | Enables/Disables the fifty ohm impedance setting for all analog channels. Query returns the analog channel protection lock status
Attribute | AGINFINIIVISION_ATTR_SYSTEM_SERIAL_NUMBER | Read Only - Instrument serial number.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_SYSTEM_DATE | Current date formatted as 'YYYY, MM, DD'. YYYY is a four-digit representation of the year including century and millennium information. MM is a two-digit representation of the month where January is 1 and December is 12. DD is the day of the month.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TIME | Current time formatted as 'HH, MM, SS.SSS'. HH is the hour and its range is 0 to 23 inclusive. MM is the minute and its range is 0 to 59 inclusive. SS is the second in the range 0 to 59.999.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TIMEOUT_MILLISECONDS | The value, in milliseconds, of the default timeout used by I/O operations. This property provides access to the driver's Visa Session Timeout. Only in rare, unusual circumstances should the client set this property.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TOUCH_SCREEN_ENABLED | Disables or enables the touchscreen.
Attribute | AGINFINIIVISION_ATTR_SYSTEM_TRACE_ENABLED | If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_HORIZONTAL_SCALE | Horizontal scale or seconds per division for the main window.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_MODE | Current time base mode.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_TIME_REFERENCE | Time reference selection can be made to one division from the left side of the screen, to the center of the screen, or to one division from the right side of the screen
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_VERNIER_ENABLED | Time base control's vernier.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_HORIZONTAL_SCALE | Horizontal scale or seconds/division of the zoomed(delayed) window, its maximum value can be half of horizontal scale of Main Window
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_POSITION | Horizontal window position in the zoomed view of the main sweep.
Attribute | AGINFINIIVISION_ATTR_TIMEBASE_WINDOW_RANGE | Full-scale horizontal time in seconds for the zoomed (delayed) window. The maximum value is one half of the horizontal time of main window.
Attribute | AGINFINIIVISION_ATTR_TRACKING_AMPLITUDE | If true, this property causes amplitude and offset adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_ENABLED | If true, this property true, causes frequency, amplitude, offset, and duty cycle adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_FREQUENCY | If true, this property causes frequency adjustments to this waveform generator output signal to be tracked by the other waveform generator output.
Attribute | AGINFINIIVISION_ATTR_TRACKING_PHASE | Sets and Gets the frequency-tracked waveform phase relationship setting. Supported by 4000X, 6000X.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_ACLINE_SLOPE | The slope of the zero crossing upon which the scope triggers.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_COUPLING | How the oscilloscope couples the trigger source.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SLOPE | Specifies rising (Positive) or falling (Negative) for the arming edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_ARMING_SOURCE | Selects the input used for the arming edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_EDGE_COUNT | Sets/Gets the Nth edge of the trigger source to trigger on
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_SLOPE | Specifies rising (Positive) or falling (Negative) for the trigger edge in the Edge Then Edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_DELAY_TIME | Sets/Gets the delay time between the arming edge and the trigger edge in the Edge Then Edge trigger. The time is in seconds and must be from 4 ns to 10 s.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_IDLE_TIME | Sets/Gets the Nth edge in a burst idle resource (in seconds from 10 ns to 10 s). The timer is used to set the minimum time before the next burst.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_NTH_EDGE | Sets/Gets the Nth edge at burst counter resource. The edge counter is used in the trigger stage to determine which edge in a burst will generate a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_BURST_SLOPE | Specifies whether the rising edge (Positive) or falling edge (Negative) of the Nth edge in a burst will generate a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_EDGE_REJECT_FILTER_TYPE | Enable the type of reject filter.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_GLITCH_LEVEL | Trigger level voltage for the active pulse width trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HF_REJECT_FILTER_ENABLED | The high frequency reject filter adds a 50 kHz low-pass filter in the trigger path to remove high frequency components from the trigger waveform.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_ENABLED | Enables or disables the random trigger holdoff with minimum and maximum holdoff settings.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MAX | The maximum random holdoff time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_HOLDOFF_RANDOM_TIME_MIN | The minimum random holdoff time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_LEVEL | The voltage threshold for the trigger subsystem. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_MODIFIER | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_NOISE_REJECT_FILTER_ENABLED | Enables/Disables the noise reject filter. When the noise reject filter is on, the trigger circuitry is less sensitive to noise but may require a greater amplitude waveform to trigger the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_OR_EDGE_PATTERN | Specifies the edges to include in the OR'ed edge trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_ANALOG_PATTERN | The analog channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_CONDITION | The pattern matching condition. This attribute specifies when the trigger event occurs with respect to the pattern, either trigger on entering the specified pattern or exiting the specified pattern.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_DIGITAL_PATTERN | The digital channel pattern. Only permissible character starting left side of the string will be accepted, rest of the string will be truncated.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MAX_DURATION | Maximum duration for the defined pattern when pattern condition is set to LESSthan. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PATTERN_MIN_WIDTH | Minimum duration for the defined pattern when pattern condition is set to GREaterthan. The units are seconds. It can also specify the timeout value when the pattern condition is set to TIMeout.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_MODE | Sets and gets the PXI trigger mode to bus master/slave or off.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_SLAVE_ARM_LINE | Sets and gets the PXI slave to master arm line or off.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_SLOT | Sets and gets the PXI master slot number.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_PXI_TRIGGER_LINE | Sets and gets the PXI master to slave trigger line.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_RUNT_CONDITION | Condition used for specifying runt pulse widths.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_RUNT_QUALIFIER_TIME | Time used for triggering on runt pulses whose width is greater than or less than the specified time value.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_CLOCK_SOURCE | Selects the channel used to produce the trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_DATA_SOURCE | Selects the channel used to produce the trigger.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_HOLD_TIME | Sets/Gets the hold time.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SETUP_TIME | Sets/Gets the setup time.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SETUP_AND_HOLD_SLOPE | Selects the clock signal's active edge.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SLOPE | The slope, a rising or a falling edge, that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_SOURCE | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_CONDITION | Specifies whether you are looking for rise/fall times greater than or less than a certain time value. The time value is set using the QualifierTime property.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_QUALIFIER_TIME | Specifies the time value for rise/fall time triggers. You also use the Condition property to specify whether you are triggering on times greater than or less than this time value.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_SLOPE | Specifies a Positive rising edge or a Negative falling edge.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_HIGH | The high threshold the oscilloscope uses for the transition trigger. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TRANSITION_THRESHOLD_LOW | The low threshold the oscilloscope uses for the transition trigger. The units are volts.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TYPE | The kind of event that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_TYPE_AG | The kind of event that triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_CONDITION | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies where the USB trigger will occur.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_D_MINUS_SOURCE | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D- signal.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_D_PLUS_SOURCE | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the source for the USB D+ signal.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_USB_SPEED | CURRENTLY NOT SUPPORTED FOR 4000X and 6000X SERIES. Specifies the expected USB signal speed to be Low Speed (1.5 Mb/s) or Full Speed (12 Mb/s).
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_CONDITION | Whether a pulse within or outside the high and low thresholds triggers the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_POLARITY | The polarity of the pulse that triggers the oscilloscope. Need to set Source before setting polarity.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_HIGH | The high width threshold time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_WIDTH_THRESHOLD_LOW | The low width threshold time in seconds.
Attribute | AGINFINIIVISION_ATTR_TRIGGER_ZONE_SOURCE | Specifies the analog source channel shared by all zones. Permissible Values are Channel<n>.</n>
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_EVENT | The event on which the oscilloscope triggers.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_LINE_NUMBER | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_POLARITY | The polarity of the TV signal.
Attribute | AGINFINIIVISION_ATTR_TV_TRIGGER_SIGNAL_FORMAT | The format of the TV signal on which the oscilloscope triggers.
Attribute | AGINFINIIVISION_ATTR_UDTV_EDGE_NUMBER | Specifies the Generic video trigger's Nth edge to trigger on after synchronizing with the vertical sync.
Attribute | AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_ENABLED | Enables or disables the horizontal sync control in the Generic video trigger.
Attribute | AGINFINIIVISION_ATTR_UDTV_HORIZONTAL_SYNC_TIME | When the HorizontalSyncEnabled property is set to true, this property sets the minimum time the horizontal sync pulse must be present to be considered valid.
Attribute | AGINFINIIVISION_ATTR_UDTV_MIN_TIME | Specifies the "greater than the sync pulse width" time in the Generic video trigger. This setting allows oscilloscope synchronization to the vertical sync.
Attribute | AGINFINIIVISION_ATTR_UNSIGNED_MODE_ENABLE | Enables/Disables unsigned mode of data values which sends integers as unsigned or signed.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_COUPLING | How the oscilloscope couples the input signal.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_OFFSET | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | AGINFINIIVISION_ATTR_VERTICAL_RANGE | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Attribute | AGINFINIIVISION_ATTR_VIEW | View setting associated with the currently selected waveform. The only legal value for the view setting is MAIN.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ADDITIONAL_NOISE | Specifies the amount of noise to add to the currently selected signal.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AM_DEPTH | Specifies the amount of amplitude modulation.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AM_FREQUENCY | Specifies the frequency of the modulating signal. Frequency in Hz .
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_AMPLITUDE | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_ATTRIBUTE_NUMBER_OF_POINTS | Read Only - Queries the number of points used by the current Arbitrary waveform.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_BYTE_ORDER | Specifies the byte order for binary transfers.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_ARBITRARY_INTERPOLATION | Enables or disables the Interpolation control.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_DUTY_CYCLE | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_FREQUENCY | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_FUNCTION | Type of waveform.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_HIGH_VOLTAGE | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_LOW_VOLTAGE | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OFFSET_VOLTAGE | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_ENABLED | Enables or Disables waveform generator signal output.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_INVERTED | Specifies whether the waveform generator output is inverted or not.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_LOAD_IMPEDANCE | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_OUTPUT_MODE | Sets and Gets the output mode setting. Supported by 3000T, 4000X, 6000X.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_PERIOD | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_PULSE_WIDTH | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | AGINFINIIVISION_ATTR_WAVE_GEN_RAMP_SYMMETRY | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_BYTE_ORDER | Output sequence of the WORD data. It decides which significant byte to be transmitted first.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_DATA_FORMAT | Data transmission mode for waveform data points. It controls how the data is formatted when sent from the oscilloscope.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_ADDITIONAL_NOISE | Specifies the amount of noise to add to the currently selected signal.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_AMPLITUDE | Amplitude in volts for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_DUTY_CYCLE | Square wave duty cycle(20% to 80%) for Square waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FREQUENCY | Frequency for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_FUNCTION | Type of waveform.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_HIGH_VOLTAGE | High-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_LOW_VOLTAGE | Low-level voltage for Sine, Square, Ramp, Pulse, and Noise waveforms.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OFFSET_VOLTAGE | Voltage offset for Sine, Square, Ramp, Pulse, and Noise waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_ENABLED | Enables/Disables waveform generator signal output.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_OUTPUT_LOAD_IMPEDANCE | Expected output load impedance. The output load selection lets the waveform generator display the correct amplitude and offset levels for the expected output load.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PERIOD | Period in seconds for Sine, Square, Ramp, and Pulse waveforms
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_PULSE_WIDTH | Pulse width in seconds for Pulse waveforms. The pulse width can be adjusted from 20 ns to the period minus 20 ns.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_GENERATOR_RAMP_SYMMETRY | Symmetry percentage from 0% to 100% for Ramp waveform. Symmetry represents the amount of time per cycle that the ramp waveform is rising.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_POINT_COUNT | Number of waveform points to be transferred with the Waveform data
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_POINT_MODE | Type of data record to be transferred
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_SOURCE | Source for the waveform.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_SUB_SOOURCE | Selects the sub-source for those sources that have more than one possibility.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_INCREMENT | Read Only - X-increment value for the currently specified source. This value is the time difference between consecutive data points in seconds.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_ORIGIN | Read Only - Returns the returns the x-origin value for the currently specified source. This value is first data point((XREFerence = 0) specified by IAgInfiniiVisionXReference.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_X_REFERENCE | Read Only - X-reference value for the currently specified source. This value specifies the index of the data point associated with the x-origin data value
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_INCREMENT | Read Only - Returns the y-increment value in volts for the currently specified source. This value is voltage difference between consecutive data values. For digital waveforms it is always "1".
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_ORIGIN | Read Only - Y-origin value for the currently specified source. This value is the voltage at center screen specified IAgInfiniVisionYReference.
Attribute | AGINFINIIVISION_ATTR_WAVEFORM_Y_REFERENCE | Read Only - Y-reference value for the currently specified source. This value specifies the data point value where the y-origin occurs. The data point is value of the center of the screen. It is undefined if the format is ASCii
Attribute | AGINFINIIVISION_ATTR_WAVEGEN_COUNT | Attribute that contains the number of WaveGens available on the instrument. This is the maximum index that may be used with the GetWaveGenName() function.
Attribute | AGINFINIIVISION_ATTR_WIDTH_CONDITION | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_HIGH_THRESHOLD | The high width threshold time. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_LOW_THRESHOLD | The low width threshold time. The units are seconds.
Attribute | AGINFINIIVISION_ATTR_WIDTH_POLARITY | The polarity of the pulse that triggers the oscilloscope.
Top


Errors and Warnings

Errors and Warnings

Errors

Name | Value (Hex) | Value (Decimal) | Description
AGINFINIIVISION_ERROR_CANNOT_RECOVER | 0xBFFA0000 | -1074135040 |
AGINFINIIVISION_ERROR_INSTRUMENT_STATUS | 0xBFFA0001 | -1074135039 |
AGINFINIIVISION_ERROR_CANNOT_OPEN_FILE | 0xBFFA0002 | -1074135038 |
AGINFINIIVISION_ERROR_READING_FILE | 0xBFFA0003 | -1074135037 |
AGINFINIIVISION_ERROR_WRITING_FILE | 0xBFFA0004 | -1074135036 |
AGINFINIIVISION_ERROR_INVALID_PATHNAME | 0xBFFA000B | -1074135029 |
AGINFINIIVISION_ERROR_INVALID_ATTRIBUTE | 0xBFFA000C | -1074135028 |
AGINFINIIVISION_ERROR_IVI_ATTR_NOT_WRITABLE | 0xBFFA000D | -1074135027 |
AGINFINIIVISION_ERROR_IVI_ATTR_NOT_READABLE | 0xBFFA000E | -1074135026 |
AGINFINIIVISION_ERROR_INVALID_VALUE | 0xBFFA0010 | -1074135024 |
AGINFINIIVISION_ERROR_FUNCTION_NOT_SUPPORTED | 0xBFFA0011 | -1074135023 |
AGINFINIIVISION_ERROR_ATTRIBUTE_NOT_SUPPORTED | 0xBFFA0012 | -1074135022 |
AGINFINIIVISION_ERROR_VALUE_NOT_SUPPORTED | 0xBFFA0013 | -1074135021 |
AGINFINIIVISION_ERROR_TYPES_DO_NOT_MATCH | 0xBFFA0015 | -1074135019 |
AGINFINIIVISION_ERROR_NOT_INITIALIZED | 0xBFFA001D | -1074135011 |
AGINFINIIVISION_ERROR_UNKNOWN_CHANNEL_NAME | 0xBFFA0020 | -1074135008 |
AGINFINIIVISION_ERROR_TOO_MANY_OPEN_FILES | 0xBFFA0023 | -1074135005 |
AGINFINIIVISION_ERROR_CHANNEL_NAME_REQUIRED | 0xBFFA0044 | -1074134972 |
AGINFINIIVISION_ERROR_MISSING_OPTION_NAME | 0xBFFA0049 | -1074134967 |
AGINFINIIVISION_ERROR_MISSING_OPTION_VALUE | 0xBFFA004A | -1074134966 |
AGINFINIIVISION_ERROR_BAD_OPTION_NAME | 0xBFFA004B | -1074134965 |
AGINFINIIVISION_ERROR_BAD_OPTION_VALUE | 0xBFFA004C | -1074134964 |
AGINFINIIVISION_ERROR_OUT_OF_MEMORY | 0xBFFA0056 | -1074134954 |
AGINFINIIVISION_ERROR_OPERATION_PENDING | 0xBFFA0057 | -1074134953 |
AGINFINIIVISION_ERROR_NULL_POINTER | 0xBFFA0058 | -1074134952 |
AGINFINIIVISION_ERROR_UNEXPECTED_RESPONSE | 0xBFFA0059 | -1074134951 |
AGINFINIIVISION_ERROR_FILE_NOT_FOUND | 0xBFFA005B | -1074134949 |
AGINFINIIVISION_ERROR_INVALID_FILE_FORMAT | 0xBFFA005C | -1074134948 |
AGINFINIIVISION_ERROR_STATUS_NOT_AVAILABLE | 0xBFFA005D | -1074134947 |
AGINFINIIVISION_ERROR_ID_QUERY_FAILED | 0xBFFA005E | -1074134946 |
AGINFINIIVISION_ERROR_RESET_FAILED | 0xBFFA005F | -1074134945 |
AGINFINIIVISION_ERROR_RESOURCE_UNKNOWN | 0xBFFA0060 | -1074134944 |
AGINFINIIVISION_ERROR_ALREADY_INITIALIZED | 0xBFFA0061 | -1074134943 |
AGINFINIIVISION_ERROR_CANNOT_CHANGE_SIMULATION_STATE | 0xBFFA0062 | -1074134942 |
AGINFINIIVISION_ERROR_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0xBFFA0063 | -1074134941 |
AGINFINIIVISION_ERROR_INVALID_RANGE_IN_SELECTOR | 0xBFFA0064 | -1074134940 |
AGINFINIIVISION_ERROR_UNKOWN_NAME_IN_SELECTOR | 0xBFFA0065 | -1074134939 |
AGINFINIIVISION_ERROR_BADLY_FORMED_SELECTOR | 0xBFFA0066 | -1074134938 |
AGINFINIIVISION_ERROR_UNKNOWN_PHYSICAL_IDENTIFIER | 0xBFFA0067 | -1074134937 |
AGINFINIIVISION_ERROR_INVALID_SESSION_HANDLE | 0xBFFA1190 | -1074130544 |
AGINFINIIVISION_ERROR_CHANNEL_NOT_ENABLED | 0xBFFA2001 | -1074126847 |
AGINFINIIVISION_ERROR_UNABLE_TO_PERFORM_MEASUREMENT | 0xBFFA2002 | -1074126846 |
AGINFINIIVISION_ERROR_MAX_TIME_EXCEEDED | 0xBFFA2003 | -1074126845 |
AGINFINIIVISION_ERROR_INVALID_ACQ_TYPE | 0xBFFA2004 | -1074126844 |
AGINFINIIVISION_ERROR_INVALID_PARAMETER | 0xBFFA40DC | -1074118436 | Invalid parameter Value.
AGINFINIIVISION_ERROR_HARDWARE_MISSING | 0xBFFA40F1 | -1074118415 | Feature is unavailable or unlicensed.
AGINFINIIVISION_ERROR_INVALID_MEASUREMENT_SOURCE | 0xBFFA420E | -1074118130 | Invalid Measurement Source
AGINFINIIVISION_ERROR_PERSONALITY_NOT_ACTIVE | 0xBFFA4211 | -1074118127 | Personality is not active.
AGINFINIIVISION_ERROR_PERSONALITY_NOT_INSTALLED | 0xBFFA4212 | -1074118126 | Personality is not installed.
AGINFINIIVISION_ERROR_PERSONALITY_NOT_LICENSED | 0xBFFA4213 | -1074118125 | Personality is not licensed.
AGINFINIIVISION_ERROR_IO_GENERAL | 0xBFFA4214 | -1074118124 | I/O error: %1.
AGINFINIIVISION_ERROR_IO_TIMEOUT | 0xBFFA4215 | -1074118123 | I/O timeout error: %1.
AGINFINIIVISION_ERROR_MODEL_NOT_SUPPORTED | 0xBFFA4216 | -1074118122 | Instrument model does not support this feature: %1.
AGINFINIIVISION_ERROR_SETTINGS_CONFLICT | 0xBFFA4217 | -1074118121 | Settings Conflict
AGINFINIIVISION_ERROR_OPTION_NOT_PRESENT | 0xBFFA4218 | -1074118120 | Option not present
AGINFINIIVISION_ERROR_BAD_PATTERN | 0xBFFA421C | -1074118116 | Bad Pattern
AGINFINIIVISION_ERROR_NO_DATA_FOR_OPERATION | 0xBFFA421E | -1074118114 | No Data for operation.
Top

Warnings

Name | Value (Hex) | Value (Decimal) | Description
AGINFINIIVISION_SUCCESS | 0x0 | 0 |
AGINFINIIVISION_WARN_NSUP_ID_QUERY | 0x3FFA0065 | 1073348709 |
AGINFINIIVISION_WARN_NSUP_RESET | 0x3FFA0066 | 1073348710 |
AGINFINIIVISION_WARN_NSUP_SELF_TEST | 0x3FFA0067 | 1073348711 |
AGINFINIIVISION_WARN_NSUP_ERROR_QUERY | 0x3FFA0068 | 1073348712 |
AGINFINIIVISION_WARN_NSUP_REV_QUERY | 0x3FFA0069 | 1073348713 |
AGINFINIIVISION_WARN_INVALID_WFM_ELEMENT | 0x3FFA2001 | 1073356801 |
Top


IVI Backgrounder

IVI Backgrounder

The IVI Foundation is an open consortium founded in 1998 to promote standards for programming test instruments. Composed primarily of instrument manufacturers, end-users, software vendors, and system integrators, the Foundation strives to create specifications that govern the development of instrument drivers.

IVI-compliant drivers offer a number of benefits, such as a consistent programming interface, better performance, seamless integration into a wide variety of development environments, and interchangeability. Interchangeability refers to the ability of an end user to replace one IVI driver in an application program with another IVI driver from a different vendor, without modifying or even recompiling the application program. To achieve interchangeability, IVI driver developers must carefully follow all of the requirements laid out in the IVI Foundation specifications.

The following sections present an overview of some of the most important IVI topics for driver developers. This document does not attempt to reproduce all of the details contained in the IVI specifications. For complete information on IVI and for the most up-to-date versions of all IVI specifications and components, visit the IVI Foundation web site.

In This Section

What All IVI Drivers Do -- Inherent Capabilities

Explains how to basic functionality that all IVI drivers support.

Two IVI Drivers -- IVI-COM and IVI-C

Compares IVI-COM and IVI-C drivers.

How IVI Drivers Provide Interchangeability

Explains the basics of how interchangeability works with IVI-COM and IVI-C.

Instrument-Specific Capabilities

Provides a brief explanation of non-interchangeable device-specific functionality in IVI drivers.

IVI Shared Components

Provides an introduction to the shared software components required for an IVI-based system.

IVI Configuration Store

Information on using the IVI Configuration Store with the driver.

Repeated Capabilities

Explains IVI repeated capabilities along with the notions of physical and virtual names.

Getting Assistance on the IVI Web Forum

Moderated web forum, IVI driver usage, and getting started guides from the IVI Foundation.

LXI Fundamentals

Presents an introduction to the LXI standards and how they relate to IVI drivers.

Installation

Where IVI drivers are installed and what components are required.


What All IVI Drivers Do -- Inherent Capabilities

What All IVI Drivers Do -- Inherent Capabilities

The IVI Foundation has established a set of functions and attributes that all IVI drivers must support -- irrespective of which IVI instrument class the driver supports. These common functions and attributes are called IVI inherent capabilities and they are documented in IVI-3.2 -- Inherent Capabilities Specification. Importantly, drivers that do not support any IVI instrument class must still support the IVI inherent capabilities.

Having a common set of basic functionality that all IVI drivers must support ensures that end users have a standard, recognizable way to perform basic operations with the IVI driver. If an end user has programmed with an IVI driver of any type before, they will immediately know how to perform at least basic tasks with any new IVI driver they encounter. Some of the tasks that fall under the inherent capabilities specification are:

  • Initializing the driver.
  • Querying errors from the driver.
  • Enabling standard driver features, such as simulation, state caching, and range checking.
  • Identifying the capabilities of the driver, such as the supported instrument classes, capability groups.
  • Reading driver and instrument identification information.
  • Performing instrument self-test and reset operations.

A detailed description of the IVI inherent capabilities can be found in the Reference section under the topic IviDriver.

Standard Driver Features

IVI drivers may offer several different features whose behavior has been standardized by the IVI Foundation. Although these are referred to as standard driver features, they are not all required to be supported by an IVI driver, as shown in the table below:

Feature | Required
State caching | No
Range checking | No
Coercion and coercion recording | No
Interchangeability checking | No
Simulation | Yes

The remainder of this topic discusses each driver feature in detail.

State Caching -- Optional

As a means to offer better performance in customer test applications, IVI drivers often support a feature known as state caching. The principle of state caching is quite simple, although in practice it can be extraordinarily difficult to implement properly.

When a end user enables state caching for an IVI driver, the driver attempts to determine if new settings passed into the driver are different from the actual instrument state. In this way, I/O traffic between the driver and the instrument is reduced, as fewer I/O calls are performed.

In the simplest example of when state caching improves performance, consider what happens when a user passes identical values several times in a row for the frequency property on a function generator driver. Without state caching, each call into the driver would result in an I/O function call to the instrument, whereas a driver performing state caching would detect that subsequent calls to the frequency property were redundant and should not result in any communication with the instrument. Correspondingly, the driver can "remember" the last known value for instrument properties so that queries can be performed by retrieving data from computer memory, rather than by performing instrument I/O.

As with caching schemes in other types of software systems, IVI driver state caching is frought with potential pitfalls. The chief challenge in properly implementing state caching is maintaining cache coherency. Complex instruments often have complex couplings between instrument settings, making it difficult for the driver to track whether or not settings stored in the driver cache are valid. Consequently, many instrument vendors choose not to implement state caching in the driver.

For more information on state caching, see IVI-3.1: Driver Architecture Specification.

Range Checking -- Optional

Range checking in IVI drivers simply refers to the ability for the driver to test whether or not input values passed to the driver are within an acceptable range. End users typically use range checking during debugging and, after validation is complete, disable it to maximize performance.

For more information on range checking, see IVI-3.1: Driver Architecture Specification.

Coercion and Coercion Recording -- Optional

Instruments often accept only a discrete set of values for certain properties. For example, a DMM might only accept values such as 10 V, 100 V, 300 V for the voltage range setting. These discrete value sets will necessarily be different for different vendor's instruments. An Keysight® DMM may accept 10 V, 100 V, 300 V while a Fluke DMM accepts 20 V, 200 V, and 400 V. As a result, IVI class specifications are forced to define such real-valued properties as accepting a continuous range of values, even though the underlying instrument only accepts a discrete set of values.

Following along with the DMM voltage range example, if a user sends a value of 150 V for the voltage range, the instrument will internally coerce the value to one of the accepted values, such as 300 V. To maximize interchangeability, the IVI class specifications provide guidance on how IVI drivers should coerce user requested values for specific properties.

To aid end users in building interchangeable applications, IVI drivers may implement a feature called coercion recording. If a user enables coercion recording, the IVI driver retains a log of each user value that it coerces. Standard functions in the IVI inherent capabilities provide the user with access to the driver's coercion log.

For more information on coercion, see IVI-3.1: Driver Architecture Specification.

Interchangeability checking -- Optional

A program written using an IVI driver will not be interchangeable if the program relies upon default settings within the instrument. This is because different instruments will have different default values for many important settings. Repeatable results can only be obtained if all of the instrument settings on which an operation depends are in a user-specified state.

IVI drivers may implement a feature called interchangeability checking to ensure that driver attributes relevant to a particular operation are in a user-specified state whenever that operation is performed. The IVI instrument class specifications all include class-specific sections detailing which driver attributes need to be in a known state for particular operations. The driver can then track these attributes and report a warning if one or more are not set explicitly by the client program before an important operation is performed.

Standard functions in the IVI inherent capabilities provide the user with the ability to enable interchangeability checking in the driver and to retrieve any warnings that occur. Typically, this feature is only used during development and debug of an application and disabled during normal operation, so as not to adversely impact performance.

For more information on interchangeability checking, see IVI-3.1: Driver Architecture Specification .

Simulation -- Required

IVI drivers are often constructed for complex instruments that are difficult to procure or that are in high demand at the end user facility. Consequently, it may be the case that end users need to be able to test their application programs without being physically connected to an instrument. IVI driver simulation is a feature that allows end users to use IVI drivers without a physical connection to the instrument.

When an end user enables simulation in an IVI driver, the driver performs no I/O communication whatsoever. IVI drivers are free in their choice of mechanisms for returning meaningful output values to the end user, but the intent is that the user program should be able to proceed normally when calling functions on the driver. This allows the end user to exercise their test application before the actual hardware is available.

For more information on simulation, see IVI-3.1: Driver Architecture Specification.


Two IVI Drivers -- IVI-COM and IVI-C

Two IVI Drivers -- IVI-COM and IVI-C

This driver supports two IVI APIs -- IVI-COM and IVI-C. Although the functionality offered by both types of driver is often very similar, the fundamental differences in application programming interface technology results in a very different end-user experience. This topic discusses some of the important differences between IVI-COM and IVI-C drivers.

IVI-COM and IVI-C at a Glance

The table below presents a summary of some of the important differences between IVI-COM and IVI-C drivers. A brief explanation of each point is given later in this topic.

IVI-COM IVI-C
Files Supplied
  • COM DLL (<Driver>.dll).
  • .NET DLL (<Company>.<Driver>.Interop.dll).
  • Windows DLL (<prefix>.dll).
  • Header file (<prefix>.h).
  • Import library (<prefix>.lib).
  • Function panel file (<prefix>.fp).
  • Attribute information file (<prefix>.sub).
ADEs of Choice
  • Visual C#.
  • Visual C++.
  • Visual Basic.NET.
  • LabWindows™/CVI.
.NET Support
  • Use interop assembly as per IVI specs.
  • No manual coding in client program.
  • Interchangeability supported.
  • No standard mechanism.
  • Manual coding in client program.
  • Interchangeability not possible.
Interchangeability
  • Use COM session factory.
  • No 3rd party components.
  • Multiple instrument classes per driver possible.
  • Requires 3rd-party class drivers.
  • Only one instrument class per driver.
Data Types
  • COM data types.
  • Strings and arrays are self-describing.
  • Memory can be allocated by the driver or by the client.
  • VISA data types.
  • Strings and arrays require extra parameters to indicate size.
  • Memory must be allocated by the client program.
Attribute Programming
  • Same as methods (built-in).
  • Attributes can have parameters.
  • Use attribute accessors and C macros.
  • GetAttributeViReal64, etc..
  • Attributes cannot have parameters.

IVI-COM Basics

IVI-COM drivers use Microsoft's standard COM technology to expose the driver's methods and properties. COM is a proven standard for building reusable, cross-language components on Windows. IVI-COM methods and properties are organized into interfaces that together form a hierarchy of driver functionality. IVI-COM drivers use standardized COM data types that can be understood in a wide variety of ADEs (application development environments).

IVI-COM Type Libraries

IVI-COM drivers are packaged as DLLs, like conventional Windows components. However, unlike conventional Windows components, IVI-COM DLLs contain description information about the functionality of the driver. This information is called the type library and offers such details as the name and signature of all driver functions, version information, parameter input/output direction, and even help information. Since the type library information is baked into the DLL, IVI-COM drivers are fully self-describing. This makes them easier to use in building programs because the developer only has to reference a single DLL to import the driver into their development environment. This also allows IVI-COM drivers to be used seamlessly in .NET programming languages, as is discussed later in this topic.

IVI-C Basics

IVI-C drivers are provided as conventional Windows DLLs with entry points exposed for each function supported by the driver. In addition to the DLL, IVI-C drivers include a header file (.h) and an import library (.lib). You use an IVI-C driver by including the header file in your program source code and then linking to the .lib file. IVI-C drivers use VISA data types, such as ViInt32, ViReal64, and ViChar.

IVI-C Function Panel and Attribute Files

Since IVI-C drivers rely upon basic Windows DLL technology, there is no way to represent a hierarchy of driver functionality in the DLL itself. Instead, IVI-C drivers use two additional files to present the logical organization of driver functions and attributes. The function panel file (.fp) is a variable-record binary file that presents the function hierarchy only. The attribute hierarchy is managed in a separate file called the attribute information file (.sub). The .sub file is a text file. The function and attribute hierarchies are managed separately because IVI-C development was heavily influenced by VXI Plug-n-Play driver standards, which had already established this bifurcation.

ADE Support for IVI-COM and IVI-C Drivers

Arguably the most important consideration in comparing IVI-COM and IVI-C drivers is the end user experience in various ADEs. Since IVI-COM drivers are based on Microsoft COM technology, it's not surprising that IVI-COM drivers offer the richest user experience in Microsoft ADEs. Users working in Visual C++, Visual C#, Visual Basic.NET and Visual Basic 6 will enjoy a host of features, such as object browsers, IntelliSense, and context-sensitive help.

IVI-COM drivers are also well-supported in environments targeting the test and measurement industry. Keysight® VEE® and MATLAB® provide built-in support for IVI-COM drivers, as does National Instruments® LabVIEW®. As of LabVIEW 8.0, a new feature called the Class Browser appeared, greatly simplifying the use of IVI-COM drivers in LabVIEW.

For more details on using an IVI-COM driver in various ADEs, see the topic Programming with the IVI-COM Driver in Various Development Environments.

The ADE story for IVI-C centers primarily around National Instruments LabWindows/CVI. IVI-C drivers work seamlessly in LabWindows/CVI, with built-in support for rendering the hierarchies and function panels stored in the .fp and .sub files. In all other environments, however, IVI-COM drivers provide a better user experience. LabWindows/CVI is a special case where IVI-COM drivers do not fare well. Users working in LabWindows/CVI will have a fundamental expectation that an IVI-C driver be provided for any instrument they need to use in that environment.

For more details on using an IVI-C driver in various ADEs, see the topic Programming with the IVI-C Driver in Various Development Environments.

.NET Support and Interop Assemblies

Microsoft provides excellent .NET support for all COM components through .NET wrappers called interop assemblies. These interop assemblies are generated automatically with standard Microsoft tools (such as Visual Studio) and present a familiar .NET interface to a COM component. Since IVI-COM drivers are standard COM components, these interop assemblies can be produced for IVI-COM drivers in precisely the same way as for any other COM component. Programmers working in any .NET environment (C#, VB.NET, C++) can work with the IVI-COM driver as if it were a native .NET component.

The IVI Foundation provides a specification prescribing how this should be done, so that end users have a consistent experience with IVI-COM drivers in .NET. Please see IVI-3.14: Primary Interop Assembly Specification for details on building IVI-COM interop assemblies. More importantly, the IVI Foundation provides the interop assemblies required for achieving .NET interchangeability with IVI-COM drivers. These are installed as part of the IVI Shared Components.

In the "\IVI\Bin\Primary Interop Assemblies" subfolder of your IVI installation directory, you will find the interop assemblies for the IVI instrument classes as well as those for specific instrument drivers. The interop assemblies shipped by the IVI Foundation have names such as Ivi.Dmm.Interop.dll and Ivi.SpecAn.Interop.dll. Correspondingly, all instrument-specific interop assemblies must follow an IVI-specified convention:
<Company>.<Driver>.Interop.dll

Since IVI-C drivers are conventional Windows DLLs, there is no standard mechanism for creating .NET wrappers for IVI-C drivers. Instead, client programmers must add special declarations to their program for any IVI-C driver function they wish to use in their application. These declarations must be adorned with special .NET attributes that instruct the .NET environment on what kind of function is inside the driver. (For details on what's required to call DLL functions in .NET, see the MSDN documentation regarding the "DllImport" attribute and a featured called "P/Invoke".) The critical thing to note is that because there is no standard mechanism for creating .NET wrappers on conventional Windows DLLs, the IVI Foundation cannot supply a standard mechanism for programming against IVI-C drivers in .NET. Thus, interchangeability with IVI-C drivers in .NET is not possible.

Interchangeability

IVI-COM drivers and IVI-C drivers differ fundamentally is how they allow you to write interchangeable programs. With IVI-COM drivers, the developer references a standard, IVI Foundation-supplied DLL that defines the functions and attributes for a particular instrument class. These Foundation-supplied DLLs are referred to as the IVI-COM type libraries, and they are automatically installed as part of the IVI Shared Components. Another shared component called the COM Session Factory is used to instantiate an IVI-COM driver without having a hard-coded reference to the specific driver in use.

One important distinction between IVI-COM and IVI-C drivers when considering interchangeability is the number of instrument classes a single driver can support. Some instruments actually have functionality that spans more than one instrument class. For instance, some popular switch measure units offer both IviDmm and IviSwtch functionality, so supporting both sets of IVI-defined interfaces is very useful. With IVI-COM, a single driver such an instrument can be accommodated, as IVI-COM drivers can support any number of instrument classes at once. IVI-C drivers, however, have a fundamental limitation imposed by the attribute model they use. Each attribute in IVI-C is assigned a numeric identifier, but these identifiers are only unique within an instrument class -- not between instrument classes. Because of this, an IVI-C driver would not be able to support attributes from more than one instrument class, and so only a single class can be supported by any IVI-C driver.

Data Types

IVI-COM and IVI-C drivers use two different sets of data types. IVI-COM drivers use a special subset of the COM data type system, called automation data types. Simply put, this type system is designed to allow common access from a wide range of programming languages -- from Visual Basic 6 to C++ to C#. IVI-C drivers, on the other hand, use the VISA data type system, which is based on classic C data types.

The primitive data types, such as integers, floating point numbers, and booleans are represented similarly in both IVI-COM and IVI-C drivers. The key differences are in how arrays and strings are handled. IVI-COM drivers use the SAFEARRAY data type to represent arrays and the BSTR data type to represent strings. These data types are self describing in that the SAFEARRAY contains the number of elements in the array and the BSTR contains the length of the string. This means that when passing array parameters into or out of an IVI-COM driver, no extra parameters are required to describe the array. IVI-C drivers, on the other hand, need to pass extra "size" parameters to any IVI-C function that uses an array or string. (It is also a useful note that BSTR strings are allowed to contain embedded NULL characters, whereas IVI-C ViString parameters must always be NULL-terminated.)

In the IVI-COM example below, a client program is calling an IVI-COM driver function to fetch an array of measurements from the instrument. Note how only the array parameter need be returned from the function, as the size of the array is embedded in the SAFEARRAY data type.

C++ Copy Code Copy Code
double[] data;
scope.Measurement.FetchWaveform(ref data);

In the IVI-C example below, a client program is calling an IVI-C driver function to read from the instrument. In constrast to the previous IVI-COM example, the IVI-C programmer must pass in two extra parameters to describe the array -- one for the client to tell the driver the size of the input array, and one for the driver to tell the client how many array elements were returned.

C++ Copy Code Copy Code
ViSession vi;
/* session initialization omitted for clarity */
ViReal64 waveform[1000];
ViInt32 waveformSize = 1000;
ViInt32 actualSize;
ViStatus status = IviScope_FetchWaveform(vi, VI_NULL, waveformSize, waveform, &actualSize);

Memory Allocation

IVI-COM and IVI-C drivers use opposite rules for memory allocation. This is important when dealing with string and array parameters. In IVI-COM, the driver typically allocates the memory associated with an output parameter, such as an array of measurement data. This is convenient for the end user because they do not need to know how much memory to allocate ahead of time. The driver simply allocates the memory required to return the output data. In some situations, such as when dealing with very large data sets, it may be desirable for the client program to pre-allocate memory and pass it to the driver. This allows memory to be reused across multiple calls to the driver. To support this use case, IVI-COM drivers allow pre-allocated memory to be passed in as well.

When using IVI-C drivers, the calling program must always allocate the memory for an output parameter. This requires the caller to know how much memory to allocate ahead of time and to pass in an extra parameter to the driver indicating the amount of memory that was allocated. This prevents the driver from writing too much data into the output parameter. The driver must then return an additional output parameter that indicates how much data was actually copied into the output buffer. It's up to the client program to determine whether or not all of the data has been retrieved.

Programming with Attributes

In both IVI-COM and IVI-C, drivers use functions and attributes to control the instrument. In both models, functions typically represent operations, such as taking a measurement, while attributes typically represent instrument settings, such as range or resolution. However, IVI-COM and IVI-C drivers have a very different model for programming attributes.

The IVI-COM model for programming attributes is straightforward. The functions and attributes are part of the same hierarchy. The user accesses an attribute using a simple assignment statement, as in the following:

C++ Copy Code Copy Code
// Set the sample rate to 1000
scope.Acquisition.SampleRate = 1000;

Conventional Windows DLLs have no built-in notion of attributes, so IVI-C drivers rely upon a special idiom where dedicated "getter" and "setter" functions are used along with C macro identifiers. Every IVI-C driver supports the following standard set of attribute accessors, organized based on the data type of the attribute:

  • GetAttributeViInt32, SetAttributeViInt32
  • GetAttributeViInt64, SetAttributeViInt64
  • GetAttributeViReal64, SetAttributeViReal64
  • GetAttributeViString, SetAttributeViString
  • GetAttributeViBoolean, SetAttributeViBoolean
  • GetAttributeViSession, SetAttributeViSession

Each IVI-C attribute has an associated #define'd constant in the driver header file, and this constant is passed to the appropriate getter or setter function to read or write the attribute, as in the following example:

C++ Copy Code Copy Code
ViSession vi;
/* session initialization omitted for clarity */
/* Set the sample rate to 1000 */
ViStatus status = IviScope_SetAttributeViReal64(vi, VI_NULL, IVISCOPE_ATTR_HORZ_SAMPLE_RATE, 1000);

A couple of things are noteworthy about the IVI-C attribute model. First, the programmer must take care to use the correct type of attribute setter or getter for the attribute in question. In the above example, the IVISCOPE_ATTR_HORZ_SAMPLE_RATE attribute is a double-precision floating-point value, and the end user must know this when programming with the driver. There is no way for the compiler to catch any error, such as using SetAttributeViInt32 with a boolean type attribute.

The other thing to note about the IVI-C attribute model is that since the setter and getter function signatures are fixed for all attributes, there is no way to have parameterized attributes. In contrast, IVI-COM drivers support attributes with parameters.


How IVI Drivers Provide Interchangeability

How IVI Drivers Provide Interchangeability

What is an IVI Instrument Class?

The IVI Foundation uses the term instrument class to refer to a distinct set of functionality for a canonical instrument type. Although there are many different types of instruments used in test and measurement and their functionality varies considerably, many of these instruments naturally fall into distinct categories, or types. Often these instruments are categorized based upon the type of measurements they can perform or the type of output they can produce.

For each instrument class, the IVI Foundation publishes a specification, known as the class specification. Each class specification lays out the requirements for compliance with that class specification. An IVI driver that complies with a class specification is said to be a class-compliant IVI driver. The primary purpose of an IVI class specification is to detail the set of functions and attributes that an IVI driver must support in order to be class-compliant. The class specification carefully prescribes the exact name of each function, along with the parameter list and the API hierarchy, as well as other behavior details.

Currently, the IVI Foundation has defined and approved specifications for twelve instrument classes. These specifications are available from the IVI Foundation.

  • IVI-4.1: IviScope Class Specification
  • IVI-4.2: IviDmm Class Specification
  • IVI-4.3: IviFgen Class Specification
  • IVI-4.4: IviDCPwr Class Specification
  • IVI-4.5: IviACPwr Class Specification
  • IVI-4.6: IviSwtch Class Specification
  • IVI-4.7: IviPwrMeter Class Specification
  • IVI-4.8: IviSpecAn Class Specification
  • IVI-4.10: IviRFSigGen Class Specification
  • IVI-4.12: IviCounter Class Specification
  • IVI-4.13: IviDownconverter Class Specification
  • IVI-4.14: IviUpconverter Class Specification
  • IVI-4.15: IviDigitizer Class Specification

Interchangeability and IVI

The term interchangeability in IVI refers to the ability to exchange an instrument of one class in a system with a different instrument from that same class. IVI interchangeability does not generally refer to the case of exchanging instruments from different instrument classes.

Client applications achieve interchangeability by writing their code such that it meets at least the following two conditions:

  1. It uses only functions and attributes from the IVI class specification.
  2. It has no references to a specific IVI instrument driver.

Since IVI drivers can contain functionality beyond the class specification (known as instrument-specific functionality), the client programmer must take care to only use functionality from the IVI specification if their program is to be interchangeable. Only the IVI-defined functionality is guaranteed to be supported by a class-compliant driver.

The second condition (excluding references to a specific driver) is a bit trickier to meet, and requires the use of extra software components. The mechanism by which this is achieved is different for IVI-COM drivers and IVI-C drivers.

IVI-COM Interchangeability

Interchangeability with IVI-COM relies upon special components shipped as part of the IVI Shared Components. The first component required for IVI-COM interchangeability is the COM Session Factory. This component allows users to instantiate a specific IVI-COM driver by name, rather than by a hard-coded program reference.

The name used to instantiate the driver is termed the logical name. The IVI Configuration Store holds all of the user-assigned logical names, and maps them to specific IVI drivers. When a different instrument is introduced into the system, the user need only change the specific driver referenced by their logical name in the IVI Configuration Store. No user code is modified, so the application will run without re-compiling or re-linking. The COM Session Factory will lookup the logical name in the IVI Configuration Store and instantiate the new driver.

The second component required for IVI-COM interchangeability is the type library associated with the IVI instrument class in use. The IVI-COM type libraries are also part of the IVI Shared Components. These DLLs contain the interface definitions (function signatures, property and parameter types, etc.) for a particular instrument class. Class-compliant IVI-COM drivers reference these type libraries to implement the functionality they define. Client applications reference these type libraries to access driver functionality in a driver-independent fashion.

The COM Session Factory and the IVI-COM type libraries are the basic machinery that enables interchangeability with IVI-COM drivers.

IVI-C Interchangeability

IVI-C interchangeability differs fundamentally from IVI-COM interchangeability in that IVI-C drivers require the use of a special 3rd-party component called a class driver.

Note:

It is crucial to understand that IVI-C class drivers are not shipped as part of the IVI Shared Components. Rather, IVI-C Class Drivers must be obtained from a 3rd party vendor. Furthermore, IVI-C interchangeability does not extend to interchanging class drivers. Specifically, a client application built using class drivers from Vendor A must be modified, re-compiled, and re-linked if it is to use a class driver from Vendor B.

The class driver exposes the functions defined in a particular IVI instrument class. All of the class driver functions have generic names, so that client applications have no driver-specific references. For example, rather than naming a function "AgInfiniiVision_Configure", which is obviously device-specific, the class driver will expose the function with the name "IviDmm_Configure".

IVI-C client applications link to the class driver and call into the class driver's Initialize function providing a logical name. This logical name is the same as that described for IVI-COM drivers above. Specifically, the logical name identifies a specific IVI-C driver that the class driver should load. Once the specific driver is loaded, subsequent function calls on the class driver are delegated to the corresponding function in the specific driver. In this way, IVI-C client applications can be written generically against a class driver and incorporate new specific drivers without modification.

Base Capabilities and Extension Groups

Each IVI class specification partitions IVI-defined functionality into two groups -- base capabilities and extension groups.

Base Capabilities Group

The Base Capabilities group contains functionality that all IVI drivers must implement if they wish to claim conformance with the instrument class in question. Typically, the Base Capabilities group represents the "least common denominator" of functionality for an instrument class, so most commercial instruments can be expected to support this level of capability.

As an example, the IviDmm Base Capabilities group contains functions for range, resolution, and triggering. Most commercial DMMs possess at least these capabilities, so any IVI driver that wishes to claim IviDmm-compliance must support this group of functionality.

Extension Groups

IVI uses Extension Groups to define functionality that is found in many instruments of a particular class but may not be as common as the functionality expressed in the Base Capabilities. One may think of Extension Groups as being standard definitions for "optional" functionality in an IVI driver.

Extension Groups provide a means for more advanced instruments to expose functionality in an interchangeable fashion, while still allowing simpler instruments to be class-compliant. For instance, not all DMMs have the ability to perform temperature measurements. Thus, the IviDmm class specification uses the IviDmmTemperature Extension Group to define temperature measurement capabilities.

Simply put, an Extension Group is making the statement to the driver developer, "You do not have to provide these capabilities in your IVI driver, but if you do, you must do it according to the IVI definition." An IVI driver can be class-compliant without supporting any of the extension groups in its instrument class. All IVI drivers expose a GroupCapabilities attribute that returns a comma-separated list of the extension groups supported by the driver. Using this attribute, client applications and tools can programmatically determine what optional functionality is present in an IVI driver.

For more information, see the Advanced Topics, Interchangability section of the Getting Started Guide on the IVI Foundation website.


Instrument-Specific Capabilities

Instrument-Specific Capabilities

Modern instruments typically possess much more functionality than is represented in the IVI instrument class specifications. End users must have a way to access the full capability of the instrument they have purchased. Thus, the driver must expose interfaces that are specific to that instrument alone. These are known as instrument-specific capabilities.

Instrument-specific capabilities are obviously not interchangeable. End users programming against a driver's instrument-specific interfaces typically do so to access functionality that is not available in the class-compliant interfaces . Nevertheless, for complex instruments such as spectrum analyzers, there will often be far more functionality in the IVI driver's instrument-specific hierarchy than in the class-compliant hierarchy.

Although, by definition, IVI does not dictate the syntax and semantics of instrument-specific interfaces, there are still guidelines that must be followed in the design of the interfaces if the driver is to be IVI compliant. Most of these rules are laid out in IVI-3.4: API Style Guide.


IVI Shared Components

IVI Shared Components

In order to facilitate IVI driver development and to ensure a consistent experience for end users building IVI-based test systems, the IVI Foundation develops and maintains a series of freely available software components. These components are collectively referred to as the IVI Shared Components, and they must be installed on any computer that will use IVI drivers. In fact, IVI driver installation programs are required to check for the presence of the IVI Shared Components before installing.

The following sections provide a brief overview of some of the most important IVI Shared Components.

IVI Shared Component Installer

The IVI Foundation provides an installer for the IVI Shared Components. Moreover, the Foundation's Shared Component installer is the only IVI-compliant way to install the IVI Shared Components. Third parties are not allowed to develop custom installation programs for the IVI Shared Components.

The IVI Shared Component installer creates a directory structure to house the IVI Shared Components as well as IVI drivers themselves. The root of this directory structure is referred to as the IVI install directory (<IviInstallDir>) and is typically <ProgramFilesDir>\IVI Foundation\IVI.

The IVI Shared Component installer is available for download from the IVI Foundation web site.

IVI Configuration Store

When the IVI Shared Components are installed, a special XML file named IviConfigurationStore.xml is placed in the <IviInstallDir>\Data directory. This file is known as the IVI Configuration Store and serves as a central repository for IVI driver configuration information.

IVI driver installers are required to populate the Configuration Store with information such as the instrument classes supported, the instrument models for which the driver is designed, and the physical channel names understood by the driver. End users add information to the Configuration Store to describe how they intend to use IVI drivers in their system. End users can specify logical names for IVI drivers and virtual names for channels.

For more information on the structure of the IVI Configuration Store, see IVI-3.5: Configuration Server Specification available on the IVI Foundation web site.

IVI Configuration Server

The IVI Foundation discourages users and driver developers from directly manipulating the Configuration Store XML file (IviConfigurationStore.xml). The Configuration Store is highly self-referential and easily corrupted if modified directly. Thus, the Foundation provides a COM component known as the IVI Configuration Server for programmatically reading and writing information to the Configuration Store.

The IVI Configuration Server is installed automatically by the IVI Shared Component installer. For more information on how to use the IVI Configuration Server, see IVI-3.5: Configuration Server Specification available on the IVI Foundation web site.

COM Session Factory

IVI-COM drivers, like all COM components, must be created using a specific, hard-coded reference to the main COM class. In Visual Basic, this reference takes the form of a class data type, while in Visual C++, a CLSID must be specified. Irrespective of the IDE in use, this identifier must somehow be provided to instantiate the driver and begin calling methods and properties. Yet, having a direct reference to such an instrument-specific item in an application program renders that application non-interchangeable. Specifically, if the user wishes to use a different instrument (and, hence, a different driver), then this CLSID (or class name in Visual Basic) must be manually changed and the program re-complied and re-linked.

The COM Session Factory (or, simply, the session factory)is a very simple COM component supplied with the IVI Shared Components. In spite of its simplicity, the session factory is a key to writing interchangeable applications that use IVI-COM drivers.

Rather than directly creating an IVI-COM driver using a CLSID (or the equivalent), the application program creates an instance of the session factory and then asks it to instantiate a specific IVI-COM driver. For this to work, the user must create a Logical Name in the IVI Configuration Store and associate that Logical Name with the specific IVI-COM driver they wish to instantiate. The COM Session Factory simply looks up the Logical Name in the IVI Configuration Store, locates the associated IVI-COM driver and instantiates it accordingly.

Note that, as the name implies, the COM Session Factory is only relevant for IVI-COM drivers. IVI-C drivers use a completely different mechanism (namely, IVI Class Drivers), to facilitate interchangeability.

The COM Session Factory is installed automatically by the IVI Shared Component installer. For more information on how to use the COM Session Factory, see IVI-3.6: COM Session Factory Specification available on the IVI Foundation web site.

IVI-COM Type Libraries

Part of the IVI Shared Components include a series of COM type libraries that contain the interface definitions for the IVI inherent capabilities as well as for all IVI instrument classes. These type libraries are installed in <IviInstallDir>\Bin and are generally named <IviClass>TypeLib.dll. For instance, the type library containing the interface definitions for the IviDmm instrument class is IviDmmTypeLib.dll.

Client applications must directly reference the IVI-COM type libraries from their projects in order to call methods and properties in IVI-defined interfaces. All client applications must include a reference to IviDriverTypeLib.dll, since this type library houses the interface definitions for the IVI inherent capabilities. Application programs must also reference the type library containing the interface definitions for any class-compliant interfaces they wish to support.


IVI Configuration Store

IVI Configuration Store

The IVI Configuration Store is part of the IVI Shared Components distributed by the IVI Foundation. The IVI Configuration Store serves as a central repository for driver registration information. Physically, the IVI Configuration Store is an XML file installed by the IVI Shared Component Installer in the following directory:
<IviInstallDir>\Data\IviConfigurationStore.xml.
where, <IviInstallDir> is typically C:\Program Files\IVI Foundation\IVI.

The AgInfiniiVision installer populates the IVI Configuration Store (Config Store) with the required entries for using the driver. Specifically, the driver installer adds a Software Module entry to the Config Store to represent the driver DLL itself. No other entries in the Config Store are created by the driver. If you only wish to access the instrument specific functionality of the driver, then no other entries in the Config Store are required.

To use the driver in application programs that will be interchangeable, you must edit the Config Store and add a few specific entries. Instrument vendors and other third parties provide graphical tools for conveniently editing the Config Store.

Note:

Although the IVI Configuration Store is a human readable XML file, the IVI Foundation strongly discourages you from directly editing this file. The Config Store file is highly self-referential and easily corrupted if directly modified. Instead, this is typically done using a 3rd-party IVI Configuration Store Editor utility. Alternatively, the IVI Shared Components include a programmatic interface to the Config Store, known as the IVI Configuration Server.

Editing the IVI Configuration Store

The driver installer creates only one entry in the Config Store -- the Software Module. This entry is removed by the driver uninstaller. End users should never modify the Software Module entry.

To author test programs that allow for interchangeability, you must create three additional entries in the Config Store:

  • Hardware Asset
  • Driver Session
  • Logical Name

The following sections provide descriptions of each of the Config Store entries mentioned here. Consult the documentation for your Config Store editor for detailed instructions on modifying these items.

Software Module

The Software Module identifies the instrument driver DLL, as well as various pieces of important driver information, such as any Repeated Capability Physical Names, additional IVI compliance information, and a variety of other items.

Hardware Asset

The Hardware Asset identifies a specific piece of instrument hardware. The main purpose of the Hardware Asset is to house the I/O resource descriptor used to communicate with the device.

Driver Session

The Driver Session associates the Software Module with the Hardware Asset. The Driver Session also specifies such things as driver initialization values and mappings between any Repeated Capability Physical Names and Virtual Names. Virtual names are used by client programs to access repeated capabilities in an interchangeable fashion.

For a discussion of repeated capabilities, physical names, and virtual names, see the Repeated Capabilities topic.

Users create a separate Driver Session for each unique combination of driver software, instrument hardware, and initialization settings. You may have multiple Driver Sessions for the same Software Module, if, for instance, the driver is being used to control several instances of the same instrument at different GPIB addresses.

Logical Name

The Logical Name allows users to associate an arbitrary name with a Driver Session. Since the Driver Session is tied to a particular driver and instrument, a level of indirection is needed to abstract these details in interchangeable client applications. The Logical Name serves as this extra level of abstraction -- a simple string identifier for a Driver Session.

The Logical Name is what client programs must use to build interchangeable systems. Applications create instances of IVI-COM drivers by using the COM Session Factory and specifying the Logical Name. Applications load IVI-C specific drivers by passing a Logical Name to the Initialize function on an IVI-C class driver. In either case, no instrument-specific details exist in the client program. Swapping instruments in such a system involves merely associating the Logical Name in the Config Store with a different Driver Session (i.e. a different driver-instrument combination).


Repeated Capabilities

Repeated Capabilities

Instruments often contain multiple instances of the same kind of functionality or capability. For instance, modern oscilloscopes may have multiple channels, each with independent settings for such things as vertical scale and input attenuation. IVI refers to functionality that is duplicated in an instrument as a repeated capability.

Physical Repeated Capability Names

Instances of repeated capabilities are identified by name. These names are passed as parameters to standard repeated capability accessor functions in order to change settings and execute methods on a driver's repeated capabilities. There are two types of repeated capability names -- physical names and virtual names. Physical repeated capability names are those that the driver writer specifies during driver development. These are the names that the driver natively understands and, as such, they cannot be modified by an end user. They can only be read by an end user. Virtual repeated capability names are explained below.

The physical repeated capability names (or simply physical names) understood by a particular driver can be discovered interactively or programmatically. Each IVI driver is required to register the set of physical names it understands with the IVI Configuration Store. This means an end user can use whatever IVI Configuration Store browser they have to look up the physical names supported by the driver.

Physical names can also be discovered programmatically using standard repeated capability functions. Example code for doing this is given below in the section on Parameter-Style Repeated Capabilities.

Virtual Repeated Capability Names

Virtual names allow end users to specify their own names for repeated capability instances and map those names to the physical names that the driver natively understands. The user establishes the virtual-to-physical name mappings in the IVI Configuration Store. At runtime, the user can supply a virtual channel name to the appropriate function the driver will use the mappings in the IVI Configuration Store to translate the virtual name into a physical name that the driver understands.

The purpose of virtual names is to facilitate driver interchangeability. If a user writes application code using virtual names, then no modifications to the application code are necessary when an existing driver is replaced with one that natively understands different physical names. The user need only modify the appropriate settings in the IVI Configuration Store to map their virtual names to the new driver's physical names.

Types of Repeated Capabilities

The IVI specifications define three different types of repeated capabilities -- parameter-style repeated capabilities, selector-style repeated capabilities, and collection-style repeated capabilities. Each type of repeated capability is often more appropriate depending upon such factors as how common the repeated capability is in a particular instrument class and whether one repeated capability instance is controlled at a time or multiple instances are commonly controlled at a time. Since IVI instrument classes use all three types of repeated capabilities in various instrument classes, it is important to understand the basics of each type of repeated capability.

Parameter-Style Repeated Capabilities

The simplest type of repeated capability is the parameter style. Parameter-style repeated capabilities are used most commonly in IVI-C drivers, though they can also appear in IVI-COM drivers. As the name implies, parameter-style repeated capabilities are supported by simply adding an extra string parameter to any function that applies to a repeated capability (as opposed to a function that applies to the driver as a whole). The client application passes in either a valid physical or virtual repeated capability name for this parameter to identify the particular repeated capability instance to access.

The code below shows an IVI-C driver client using the ConfigureOperationMode function from the IviFGen class specification:

C++ Copy Code Copy Code
ViSession vi;
// ...
IviFgen_ConfigureOperationMode(vi, "Output1", IVIFGEN_VAL_OPERATE_BURST);

In the code above, the second parameter is the repeated capability name. The repeated capability name almost always appears as the second parameter to a function that applies to a repeated capability. The example is setting the operation mode to burst for only the output channel identified by "Output1". The name "Output1" could be a physical name or a virtual name.

Drivers that expose a parameter-style repeated capability always expose a couple of additional functions and attributes that allow you to programmatically determine the number of repeated capabilities instances (e.g. "channels") and the physical names supported (e.g. channel names). The names of these support functions are also standardized, so that they can easily be identified when the name of the capability is know. IVI-COM drivers and IVI-C drivers differ slightly in the repeated capability support functions they expose for parameter-style repeated capabilities.

For IVI-COM drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • <Capability>Name attribute (Ex: "ChannelName")

For IVI-C drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • Get<Capability>Name attribute (Ex: "GetChannelName")

With either IVI-COM or IVI-C, the use model for these attributes is virtually identical. Specifically, the client code simply reads the value of the Count attribute and then uses this value to iterate through the repeated capability instances. The Name attribute (for IVI-COM) and the GetName function (for IVI-C) both accept a one-based index parameter to identify which repeated capability instance name is desired. The code below shows how to iterate through all of the physical names supported by an IVI-C FGen driver that exposes a "Channel" repeated capability.

C++ Copy Code Copy Code
ViSession vi;
ViInt32 i;
ViChar name[1024];
// ...
ViInt32 count;
IviFgen_GetAttributeViInt32(vi, VI_NULL, IVIFGEN_VAL_CHANNEL_COUNT);
for (i = 1; i <= count; i++)
{
  // Note: One-based indexing
  IviFgen_GetChannelName(vi, i, 1024, name);
  printf(name);
}

Selector-Style Repeated Capabilities

Selector-style repeated capabilities use a special selector function to set the "active" repeated capability. Subsequent function calls that apply to a repeated capability are understood to apply to the active instance. The active instance remains active until the client code sets the active instance to another repeated capability name.

Selector-style repeated capabilities can be used in both IVI-COM and IVI-C drivers, and, though less common than the parameter style and collection style (discussed shortly), selector-style repeated capabilities have the advantage of not requiring a repeated capability name to be passed to every function that applies to the repeated capability.

As with parameter-style repeated capabilities, drivers that expose a selector-style repeated capability always expose additional functions for managing the repeated capability instances. Indeed, the selector-style repeated capability uses the same functions and attributes as the parameter style, with the addition of one attribute and one function for setting and getting the active instance.

For IVI-COM drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • <Capability>Name attribute (Ex: "ChannelName")
  • Active<Capability> attribute (Ex: "ActiveChannel")
  • SetActive<Capability> function (Ex: "SetActiveChannel")

For IVI-C drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • Get<Capability>Name attribute (Ex: "GetChannelName")
  • Active<Capability> attribute (Ex: "ActiveChannel")
  • SetActive<Capability> function (Ex: "SetActiveChannel")

Since the selector-style repeated capability uses the same Count attribute and GetName function as the parameter style, the code required to iterate through the instance names for a selector-style repeated capability is identical to that shown above for the parameter style.

Collection-Style Repeated Capabilities (IVI-COM only)

By far, the most common type of repeated capability for IVI-COM drivers is the collection-style repeated capability. Collection-style repeated capabilities are not supported for IVI-C drivers.

As with the parameter and collection style, collection-style repeated capabilities always expose a Count and Name attribute for iterating through the list of available repeated capability names. Unique to collection-style repeated capabilities is the Item property, which provides access to individual repeated capability instances. The Item property accepts a repeated capability name (physical name or virtual name) and returns an interface pointer to the desired repeated capability instance. All method and property calls on the returned interface pointer implicitly apply to the repeated capability instance chosen with the Item property.

The C# code below demonstrates how to use the Item property to access a channel called "CH1" and enable it.

C# Copy Code Copy Code
IIviScope scope = new AcmeScopeClass();
// ... Initialize called
IIviScopeChannel channel = scope.Channels.get_Item("CH1");
channel.Enabled = true;

Note that in C#, the Item property is invoked using the get_Item accessor method. This is required for C# because that language does not support parameterized properties. Thus, any property that accepts one or more parameters must be accessed as if it were a method. The standard way in which such properties appear in C# is with a "get_" prefix (for reads) and a "set_" prefix (for writes).

Note also that declaring the intermediate variable for the IIviScopeChannel interface returned by get_Item is not necessary. Depending upon the client application, it may be more convenient to write the code as follows:

C# Copy Code Copy Code
IIviScope scope = new AcmeScopeClass();
// ... Initialize called
scope.Channels.get_Item("CH1").Enabled = true;

Static and Dynamic Repeated Capabilities

Many instruments have a fixed number of repeated capabilities. For instance, a function generator typically has a fixed number of output channels. However, some instruments can have a variable number of repeated capabilities, depending upon end-user configuration. For instance, a switching mainframe might have any of a number of combinations of multiplexer cards installed on a particular end-user system. Thus, the number of channels is not fixed and can only be determined at runtime. Such instruments possess what are termed dynamic repeated capabilities. Conversely, instruments that always have a fixed number of repeated capabilities use the term static repeated capabilities.

A driver that exposes dynamic repeated capabilities cannot register the supported repeated capability names during driver installation. Instead, during the driver Initialize call, the driver typically queries the instrument to determine its exact configuration. The mechanism by which a driver determines the name and number of the supported repeated capabilities is always instrument specific, but the net result is that the end user must use the Count and Name attributes to programmatically determine what repeated capability instances are available. An IVI Configuration Store browser is useless in determining what dynamic repeated capabilities a driver supports. It relies only upon static information in the IVI Configuration Store, so it can only report details on static repeated capabilities.

Finally, it is worth noting that a driver can contain both static and dynamic repeated capabilities.


Getting Assistance on the IVI Web Forum

Getting Assistance on the IVI Web Forum

IVI Web Forum

The IVI Foundation hosts an open, moderated discussion forum for everything related to IVI. Topics for discussion include use and development of IVI drivers, SCPI, VISA, and VXI Plug&Play.

The IVI Web Forum is located at the following URL:

IVI Web Forum

The forum is monitored by active members of the IVI Foundation itself, including many of the chief architects of the IVI specifications. It can be an excellent resource for understanding many of the general issues one encounters when using IVI drivers in various application development environments (ADEs).

Note:

While the IVI Web Forum can be a helpful resource for general IVI usage issues, questions related to the specifics of the AgInfiniiVision driver or those related to the instrument itself should be directed to Agilent Technologies.

Other IVI Learning Resources

The IVI Foundation also maintains several other resources for learning about IVI driver usage. These resources include:

  • The IVI Getting Started Guide provides short introductory guides on using IVI drivers in specific ADEs.
  • The IVI Getting Started Videos provide guided tutorials on using IVI drivers in various ADEs.
  • The Understanding the Benefits of IVI whitepaper provides an overview of many of the main motivations for using IVI drivers to build test systems.
  • The IVI Driver Fundamentals Course is a 2-hour instructor-led session open to the public and offered free of charge at IVI Foundation meetings in the U.S., Europe, and China.

All of these resources can be accessed at the following URL:

IVI Learning Resources


LXI Fundamentals

LXI Fundamentals

What is LXI?

The LXI Consortium was formed in 2005 with the goal of using LAN-based communication to control instrumentation. LXI stands for (LAN eXtensions for Instrumentation) and the hope is that high-performance, low cost systems can be built based on standard Ethernet technology, as an alternative to the popular, but more industry-specific GPIB communication interface.

Note:

A full discussion of the LXI specifications and their requirements is far beyond the scope of this document. Only a basic introduction to LXI is given here. Please see the LXI Consortium web site for full details.

The LXI standards prescribe hardware and firmware requirements for building LXI-compliant instruments. These requirements are grouped into Core features and optional Extension feature groups. The level of support for these groups was previously referred to as three classes of LXI compliance - Class A, Class B, and Class C (Note that the use of the term "Class" here has no relation to the notion of "IVI Instrument Class"). Use of LXI class designation has been discontinued. However, for backwards compatability, the features of each class are summarized in the following table:

Feature | Class C | Class B | Class A
IVI Driver (Core) | X | X | X
Programmatic Control via LAN (Core) | X | X | X
LAN-based Discovery (Core) | X | X | X
Web-based Configuration Page (Core) | X | X | X
LXI Event Messaging Extension |  | X | X
LXI Clock Synchronization Extension |  | X | X
LXI Event Logs Extension |  | X | X
LXI Timestamped Data Extension |  | X | X
LXI Wired Trigger Bus Extension |  |  | X

Features of LXI Devices

As the table in the previous section shows, LXI devices possess a variety of useful features, based on the LXI Core and Extension features. The Core features of LXI are required for LXI compliance. First and foremost, an IVI driver (either IVI-COM or IVI-C) must be provided with any instrument claiming LXI compliance. Next, the instrument must provide a configuration web page so that users can simply open a browser, navigate to the LAN address of the instrument, and interact with the device. In addition, all LXI devices must support a standard discovery mechanism so that tools and client applications can determine what devices are connected to the network.

LXI Event Messaging Extension - With LXI Event Messaging, an LXI Event message containing triggering information (including a timestamp) is sent directly from one device to another via the LAN, without computer intervention, which improves execution speed. LAN-based triggers provide programmatically triggered events through driver commands from the controller to the LXI device or by message exchange between LXI devices. They emulate traditional hardware triggers but can carry information that hardware triggers cannot such as trigger slope and time stamps based on synchronized system clocks. This extension defines how devices format, send and receive special LAN packets used to communicate between devices using a standard set of eight LAN packets. This forms a sort of virtual LAN-based trigger bus, with each of the standard LAN packets (known as "LAN0...LAN7") serving as individual trigger lines. LXI devices can be programmed to trigger a measurement or sweep based on receipt of a LAN packet or they can be told to send a specific LAN packet (an event) when a particular operation has completed or the device enters some other interesting operational state.

LXI Clock Synchronization Extension - LXI clock synchronization inherits IEEE 1588-2008, a protocol used to synchronize real-time clocks with sub microsecond accuracy in devices of a networked distributed system. This allows common timer events to be tied to absolute times for very precise triggering and synchronization and also enables the correlation between instruments in order to aid monitoring and debugging.

LXI Event Logs Extension - The LXI Event Log utility contains records of LAN events that have occurred, permitting observation of an instrument – or of an entire system – in action. The event log helps you understand what is happening in your instrument or system.

LXI Timestamped Data Extension - LXI Timestamping enables the capability of marking a LAN event at a point in time – events such as triggering, measuring, or connecting channels. You can understand what happened in time sequence in your test programs.

LXI Wired Trigger Bus Extension - The LXI Wired Trigger Bus (WTB) is a hard-wired interface to specify input or output configurability, wired-OR, and shielding and cabling for the most demanding triggering applications. This method of triggering increases your accuracy to the nanosecond range compared to software triggering via the LAN, which is typically in the millisecond range. This trigger bus, if supported, can be useful in applications that demand extremely precise timing and ultra-low latency triggering between components.

The IviLxiSync Specification

In 2006, the IVI Foundation and the LXI Consortium joined forces to define a standard API for controlling the triggering and eventing capabilities of LXI devices. The result of this cooperation was the IviLxiSync specification, formally known as IVI-3.15: IviLxiSync Specification. The IviLxiSync specification is not an instrument class specification, because it does not define functionality for a particular type of instrument. Rather, it defines operations common to any LXI-compliant device, whether that device is a DMM, oscilloscope, or spectrum analyzer.

Since the IviLxiSync specification spans devices of all instrument classes, it is common that an IVI driver will support IviLxiSync as well as one or more IVI instrument classes. Some of the operations that a client application can perform through the IviLxiSync interfaces include:

  • Configuring a device to trigger on a specific LAN packet.
  • Configuring a device to send an event upon receipt of a particular event from another LXI device.
  • Using filtering to control from which devices an instrument "sees" incoming LAN triggers.
  • Retrieving event log entries from the device.

Just as with IVI instrument classes, the standard functions and attributes defined in the IviLxiSync specification are compiled into an IVI-COM type library. This type library is shipped as part of the IVI Shared Components. Also, as with IVI instrument classes, users can program interchangeably with LXI devices by referencing the IviLxiSync type library and using only IviLxiSync-defined interfaces in their application.

IviLxiSync Subsystems

The IviLxiSync API is divided into five subsystems. Each subsystem controls different aspects of LXI device operation in a system. Depending upon a device's functional class, it may support only some of these subsystems. Class C devices, for example, need not support any of the functionality defined in the IviLxiSync specification. Also, only Class A devices will typically support arming, triggering, and events using the hardware trigger bus. The following table gives the different IviLxiSync subsystems along with their functionality:

Subsystem | Description
IviLxiSyncArm | Controls when triggers are accepted by the LXI device.
IviLxiSyncTrigger | Controls when the LXI device starts a measurement or other operation.
IviLxiSyncEvent | Controls when the LXI device signals specific conditions to other LXI devices.
IviLxiSyncEventLog | Provides access to the event logging features of an LXI device.
IviLxiSyncTime | Exposes functionality for access to the 1588 timebase of the LXI bus.

IviLxiSync Programming Example

This section presents an example LXI test system with common programming tasks using the IviLxiSync interfaces. The example code is based upon the stimulus/response test system shown in the figure below:

In the system above, an arbitrary waveform generator (arb) is used to stimulate a device under test with waveforms at various frequencies, in order to measure the distortion characteristics of the device across its operating range. The stimulus waveform is up-converted to microwave frequencies using an upconverter module and the receiver uses a downconverter to translate the DUT output signal into a range suitable for processing by the digitizer.

The up and down converters are capable of frequency stepped sweep operations (start Frequency, stop Frequency, step Frequency) and can initiate each step based on a trigger signal. The LXI-defined LAN events will be used for this triggering. At each frequency in the sweep, the digitizer acquires the DUT's output waveform using an internal signal level to trigger the acquisition. At each step in the frequency step sweep, the digitizer will wait for a LAN signal from the upconverter and downconverter modules indicating that their signals have settled.

The first task is to configure the digitizer to output a synchronization signal to trigger the arb. The LXI-defined LAN packet named "LAN1" will be used for this purpose. We want the digitizer to send the LAN1 event to the arb when the digitizer is in the waiting-for-trigger state (also known as "armed"). IviLxiSync defines the "WaitingForTrigger" event name as a standard string to identify precisely this device state. This is referred to as the "source" of the outgoing event, because when it occurs (e.g. when the digitizer enters the waiting-for-trigger state), the digitizer will send an outbound LAN packet ("LAN1" in our example).

C# Copy Code Copy Code
// Instantiate drivers for all four devices and retrieve the IIviLxiSync interface from all
IIviLxiSync digitizer = (IIviLxiSync) new AcmeDigitizerClass();
IIviLxiSync arb = (IIviLxiSync) new AcmeArbClass();
IIviLxiSync upconverter = (IIviLxiSync) new AcmeUpconverterClass();
IIviLxiSync downconverter = (IIviLxiSync) new AcmeDownconverterClass();
// Call the Initialize function on all drivers (omitted for clarity)
// ...
// Tell the digitizer to send LAN1 when it arms -- used to trigger the arb
digitizer.Events.get_Item("LAN1").Source = "WaitingForTrigger";
digitizer.Events.get_Item("LAN1").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
// Configuring the "slope" here refers to the slope of the "WaitingForTrigger" event
// that causes the digitizer to send a LAN1 packet
digitizer.Events.get_Item("LAN1").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeRise;

We next configure the arb to accept a trigger on the rising edge of the LAN1 packet that the digitizer will be sending.

C# Copy Code Copy Code
// Tell the arb to trigger on the rising edge of LAN1
arb.Trigger.get_Item("LAN1").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
arb.Trigger.TriggerSource = "LAN1";

Next, we configure the digitizer to send an event on LAN2 on the falling edge of the IviLxiSync-defined "WaitingForArm". As with "WaitingForTrigger", the "WaitingForArm" event name provides a standard way to refer to common events that occur within an LXI device. We use the falling edge of the LAN2 packet to trigger the upconverter and downconverter, which must be configured to accept LAN2 as their trigger source.

C# Copy Code Copy Code
// Tell the digitizer to send LAN2 on the falling edge of WaitingForArm
digitizer.Events.get_Item("LAN2").Source = "WaitingForArm";
digitizer.Events.get_Item("LAN2").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
digitizer.Events.get_Item("LAN2").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeFall;
// Tell the up and downconverters to trigger on the rising edge of LAN2
upconverter.Trigger.get_Item("LAN2").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
upconverter.Trigger.TriggerSource = "LAN2";
downconverter.Trigger.get_Item("LAN2").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
downconverter.Trigger.TriggerSource = "LAN2";

The digitizer needs to begin processing when the output signals from both the upconverter and downconverter have settled to a point suitable for processing. This can be accomplished by configuring the upconverter to send a LAN3 packet when the "Settling" event occurs. Similarly, the downconverter will send a LAN4 packet when its "Settling" event occurs.

C# Copy Code Copy Code
// Tell the upconverter to output LAN3 when the "Settling" event occurs
upconverter.Events.get_Item("LAN3").Source = "Settling";
upconverter.Events.get_Item("LAN3").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
upconverter.Events.get_Item("LAN3").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeNegative;
// Tell the downconverter to output LAN4 when the "Settling" event occurs
downconverter.Events.get_Item("LAN4").Source = "Settling";
downconverter.Events.get_Item("LAN4").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
downconverter.Events.get_Item("LAN4").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeNegative;
// Tell the digitizer to arm when *both* LAN3 and LAN4 are "High"
digitizer.Arm.Sources.get_Item("LAN3").Enabled = true;
digitizer.Arm.Sources.get_Item("LAN3").Detection = IviLxiSyncArmSourceDetectionEnum.IviLxiSyncArmSourceDetectionHigh;
digitizer.Arm.Sources.get_Item("LAN4").Enabled = true;
digitizer.Arm.Sources.get_Item("LAN4").Detection = IviLxiSyncArmSourceDetectionEnum.IviLxiSyncArmSourceDetectionHigh;
digitizer.Arm.Sources.OrEnabled = false;	// "false" means use AND-summing of all enabled arm sources

With the LAN signals "wired" appropriately, the remaining tasks involve configuring and initiating the actual measurements. This might involve configuring other aspects of the digitizer (acquisition length, etc.) and loading a signal file into the arb. The frequency sweep parameters of the upconverter and downconverter also need to be configured.

C# Copy Code Copy Code
// Load signal file into arb and get it ready to go
// ...
// Setup rest of digitizer parameters (acquisition length, SignalLevel trigger, etc.)
// ...
// Start digitizer
digitizer.Arm.ArmCount = 100;  // acquire 100 signal packets
digitizer.Initiate();          // digitizer will now wait until it sees Settled from the up and down converters
// Setup frequencies for up and down converters
// NOTE: Functions used here are *not* part of the IviLxiSync specification.  They are just included
// as examples of sweep configuration functions in drivers.
upconverter.Frequency.Sweep.Start = 2e9;
upconverter.Frequency.Sweep.Stop = 3e9;
upconverter.Frequency.Sweep.Step = 10e6;
downconverter.Frequency.Sweep.Start = 2e9;
downconverter.Frequency.Sweep.Stop = 3e9;
downconverter.Frequency.Sweep.Step = 10e6;
// As soon as both converters settle, the digitizer will trigger the arb and take the first measurement
// Call Fetch function on digitizer to retrieve data
// ...


Installation

Installation

Updating to a New Driver Version

It is important to note that only a single version of an IVI driver can be installed on a system at once. This rule is dictated by the IVI specifications. To ensure that only a single version of the AgInfiniiVision driver exists on the machine, the AgInfiniiVision installer will automatically uninstall a previous version of the driver. Although you can always explicitly uninstall the driver, this is typically not necessary.

Location of Files

The AgInfiniiVision installer deploys and registers a variety of files on the target computer. The notation <IviInstallDir> is used to denote the directory in which the IVI Shared Components have been installed. By default, this is C:\Program Files\IVI Foundation\IVI. Substitute your install directory if the IVI Shared Components were installed in an alternate location.

File | Description
<IviInstallDir>\Bin\AgInfiniiVision.dll | Driver DLL.
<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgInfiniiVision.Interop.dll | Interop assembly for using the driver in .NET environments.
<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgInfiniiVision.Interop.xml | XML documentation file for providing IntelliSense support in .NET environments.
<IviInstallDir>\Include\AgInfiniiVision.h | Driver header file.
<IviInstallDir>\Lib\msc\AgInfiniiVision.lib | Microsoft-format import library.
<IviInstallDir>\Drivers\AgInfiniiVision\AgInfiniiVision.fp | Function panel file.
<IviInstallDir>\Drivers\AgInfiniiVision\AgInfiniiVision.sub | Attribute information file.
<IviInstallDir>\Drivers\AgInfiniiVision\AgInfiniiVision.chm | HTML 1.0 format help file.
<IviInstallDir>\Drivers\AgInfiniiVision\AgInfiniiVision.HxS | HTML 2.0 format help file.

Installation on a System with the .NET Framework

The AgInfiniiVision installer detects if the .NET Framework is installed and, if so, registers the driver's Primary Interop Assembly (PIA) and deploys it in the .NET Global Assembly Cache (GAC).

Note:

If the .NET Framework is installed on the target computer after the AgInfiniiVision installer runs, then the PIA must be registered manually. This must be done from a Visual Studio command prompt (not a regular command prompt). The Visual Studio command prompt can be found from Start -> Programs -> Microsoft Visual Studio 2005 -> Visual Studio Tools -> Visual Studio 2005 Command Prompt.

From the Visual Studio command prompt, perform the following two steps:

  1. Navigate to the PIA (<IviInstallDir>\Bin\Primary Interop Assemblies\AgInfiniiVision.dll) and execute the following command: "gacutil -i AgInfiniiVision.dll". You can also drag-n-drop the PIA from Windows explorer into the GAC folder (C:\Windows\Assembly).
  2. Execute the following command: "regasm /codebase AgInfiniiVision.dll".

IVI Shared Components

Before any IVI driver may be installed on a system, the IVI Shared Components must be properly installed. For an introduction to the IVI Shared Components, see the topic IVI Shared Components.

For additional information on the IVI Shared Components, visit the IVI Foundation web site.

To determine which version of the IVI Shared Components are installed on your system

  1. Navigate to <IviInstallDir>\Bin. Typically this is C:\Program Files\IVI Foundation\IVI\Bin.
  2. Locate the file IviSharedComponentVersion.dll.
  3. Right-click on that file and choose Properties.
  4. In the Properties Window, click the Version tab.
  5. The File version field indicates which version of the IVI Shared Components are installed.

Uninstallation

The only proper way to explicitly remove the driver from the system is to use the uninstallation program. Simply removing the installed files will not properly uninstall the driver.

To uninstall the driver

  1. From the Windows Start menu, choose All Programs and select Control Panel .
  2. Double-click Add or Remove Programs.
  3. Select the driver and click Remove.
Note:

In order to prevent loss of important user configuration information between uninstall/reinstall operations, the uninstallation program does not remove any of the following items from the IVI Configuration Store:

  • Logical Name
  • Driver Session
  • Hardware Asset
The only IVI Configuration Store item that is deleted during an uninstall is the Software Module.
For a discussion of IVI Configuration Store entries, such as the Software Module, see Configuring the Driver.


Copyright

Copyright

Agilent Technologies may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Agilent Technologies, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

Copyright Keysight Technologies 2011-2019

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Classes

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Driver.Interop Classes


Classes

[image]

AgInfiniiVision IVI Driver Reference Keysight Technologies
Ivi.Scope.Interop Classes