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Getting Started

1 Introduction

Use the instructions in this Guide to install and set up the N109310CA SFF-8431 Compliance Test 
Application. Once the procedures in this document are completed, you can begin compliance testing. 
Information on using the application is included in the application’s Online Help.

Your licenses determine where you install the N109310CA and FlexDCA applications. The 
N109310CA license allows you to install the application on either a specific PC or a specific 86100D 
DCA-X or N1000A DCA-X instrument. This selection is made at the time you redeem your licenses.

Configuration DCA-X Supported Configurations DCA-M Supported Configurations

N109310CA on a PC with 
FlexDCA

A PC attached to N1000A or 86100D 
DCA-X oscilloscope (in Legacy 
configuration) over LAN. The PC has 
N109310CA SFF-8431, N1010A FlexDCA, 
86100DU-401 or N1010100A License, 
Microsoft Excel, and IO Connection Expert 
installed on it.

A PC directly connected to the N109X with a USB cable. The PC has N109310CA 
SFF-8431, N1010A FlexDCA, N109x-401 or N1010100A License, Microsoft Excel, 
and IO Connection Expert installed on it.

N109310CA on a PC without 
FlexDCA

A PC attached to N1000A or 86100D 
DCA-X oscilloscope (in Standard 
configuration) over LAN. The PC has 
N109310CA SFF-8431, 86100DU-401 or 
N1010100A License, Microsoft Excel, and 
IO Connection Expert installed on it.

Configuration 1: Connect the primary test system PC to a low-cost modern PC via 
LAN. The FlexDCA interface resides on the second PC. The second PC is then 
connected to the N109X via USB. This eliminates most issues of compatibility 
between an existing test system PC and the N109X hardware and can greatly simplify 
converting an 86100D system to an N109X system.
Configuration 2: An N1000A or 86100D mainframe connected to the N109X with a 
USB cable. The N1000A or 86100D has FlexDCA installed on it. The N1000A or 
86100D can then be controlled via GPIB or LAN by a PC that has N109310CA 
installed on it. 
The PC with N109310CA has N109x-401 or N1010100A License, Microsoft Excel, 
and IO Connection Expert installed on it.

N109310CA on the 
oscilloscope

N1000A or 86100D DCA-X oscilloscope in 
Standard configuration. The oscilloscope 
has N109310CA SFF-8431, 86100DU-401 
or N1010100A License, Microsoft Excel, 
and IO Connection Expert installed on it.

An N1000A or 86100D mainframe connected to the N109X with a USB cable. The 
N1000A or 86100D has FlexDCA and N109310CA installed on it.

NOTE If you plan to run all of the N109310CA tests, the N109310CA license will suffice. If using older 
licenses, host testing requires option N1014A-HST and Module Testing requires option 
N1014A-MOD.
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Installing the N109310CA SFF-8431 Compliance Test Application

1 Select from one of three different test-equipment configurations shown in the following pages. 
The configuration that you select depends on where the N109310CA SFF-8431 Compliance Test 
Application is installed, as determined by the licenses, and whether you are using the N1010A 
FlexDCA application.

2 After locating the figure that matches your setup, follow the recommended procedure.
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Recommended Equipment and Software

Table 1 Recommended equipment to run tests on the N109310CA SFF-8431 Compliance Test Application

Equipment Configuration

Single Plug-In Module Setup Multiple Module Setup

Oscilloscope N1000A DCA-X
N1000A-LOJ Low jitter timebase

N1000A-PLK Pattern lock trigger hardware
F-JIT Enhanced Jitter Analysis option under N1010100A R&D package

F-EQ Equalizers option under N1010100A R&D package
Or

86100D DCA-X* with options:
86100D-ETR Extended Trigger

86100D-200 Enhanced Jitter Analysis or F-JIT Enhanced Jitter Analysis option under N1010100A R&D package
86100D-201 Advanced Waveform Analysis or F-EQ Equalizers option under N1010100A R&D package

Or any of these
N1092 C/E Optical + Two Electrical Channels

N1094A Two Electrical Channels
N1094B Four Electrical Channels

86100D Plug-In Module 86108A or 86108B with options LBW/HBW and 216/232. 
Option JSA provides improved jitter measurement accuracy 
(optional).
N1060A for N1000A.

86112A, 54754A, 86117A, or 86118A-H01.
86107A (any option).
N1045A, N1045B, N1055A, N1046A 75/85/100 GHz.

Clock/Data Recovery and 
Demultiplexer

N4877A-216/232 Clock Data Recovery & Demultiplexer.†

N1076 A/B, N1077A, N1078A Clock Data Recovery.

Software N109310CA SFF-8431 Compliance Application.
N1010A FlexDCA Software‡ (Optional)**

86100DU-401 Advanced Eye Software License †† or F-AEYE under N1010100A R&D package.
Keysight I/O Libraries, 16.3 or higher, 16.3 if running N1010A on a PC.

Microsoft® Excel 2007 or greater
MATLAB Compiler Run Time (MCR) 7.10

Performance Network Analyzer 
(PNA) or Economy Network Analyzer 
(ENA)

Any 4-port model with frequency range of at least 12 GHz
(ENA also covers the 1 MHz termination mismatch test)

Matched Cable Set 86108B-CA3

Phase Trimmers 86108B-PT3 (quantity 2)

DC Blocks 86108B-DC3, N9398C, N9399C, or 11742A (quantity 2)

Pick-Off N/A N4915A-015 (quantity 2)

* FlexDCA version A.05.80 or greater

† If you have access to the clock for the device, you can connect the clock to the 86100D’s Trigger input instead of 
using the N4877A

‡ Revision A.05.80 or greater

**Required if running FlexDCA on the PC

†† A version of the 86100DU-401 is automatically installed with the N109310CA. However, the license must be 
purchased and installed
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NOTE The N109310CA SFF-8431 Compliance Test Application cannot be installed on an 86100A, 
86100B, or 86100C.
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Installing N109310CA and N1010A FlexDCA on a PC

If your licenses allow for installing the software as marked by the red star in the following 
diagrams, go to Chapter 2, “Installing N109310CA and N1010A FlexDCA on a PC”.

N109310CA and N1010A FlexDCA installed on PC connected to 86100D DCA-X Oscilloscope
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Figure 1 N109310CA and N1010A FlexDCA installed on PC connected to N1000A DCA-X Oscilloscope
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Figure 2 N109310CA and N1010A FlexDCA Installed on PC connected to N1094B DCA-M Oscilloscope
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Installing the N109310CA on a PC without FlexDCA

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 3, “Installing N109310CA on a PC Without N1010A FlexDCA”.

Figure 3 N109310CA Installed on PC connected to 86100D DCA-X Oscilloscope
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Figure 4 N109310CA Installed on PC connected to N1000A DCA-X Oscilloscope
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Figure 5 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via an-
other PC
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Figure 6 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
86100 DCA-X Oscilloscope
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Figure 7 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
N1000A DCA-X Oscilloscope
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Installing N109310CA on the 86100D or N1000A Oscilloscope

If your licenses allow for installing the software as marked by the red star in this diagram, 
go to Chapter 4, “Installing N109310CA on the 86100D or N1000A”.

Figure 8 N109310CA Installed on 86100D

Figure 9 N109310CA Installed on N1000A
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Figure 10 N109310CA Installed on N1000A connected to a DCA-M setup
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Figure 11 N109310CA Installed on N1000A connected to a DCA-M setup
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Starting the N109310CA SFF-8431 Compliance Test Application

After you install the N109310CA SFF-8431 Compliance Test Application on a PC (with or without the 
N1010A FlexDCA interface) or on the 86100D or N1000A Oscilloscope, refer to the following sections 
to start the N109310CA SFF-8431 Compliance Test Application:

• If the N109310CA SFF-8431 Compliance Test Application and the N1010A FlexDCA Software are 
installed on the same PC and the DCA-X or DCA-M Oscilloscope is being accessed remotely, see  
“Starting the N109310CA SFF-8431 Compliance Test Application” on page 53.

• If the N109310CA SFF-8431 Compliance Test Application is installed on a PC (but the N1010A 
FlexDCA Software is not installed) and the DCA-X or DCA-M Oscilloscope is being accessed 
remotely, see  “Starting the N109310CA SFF-8431 Compliance Test Application” on page 79.

• If the N109310CA SFF-8431 Compliance Test Application is installed on the 86100D or N1000A 
Oscilloscope, see  “Starting the N109310CA SFF-8431 Compliance Test Application” on page 94.
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Connecting to External Instruments

Most of the measurements in the N109310CA SFF-8431 Compliance Test Application use an 86100D 
or N1000A DCA-X or a supported DCA-M (N1092C/E, N1094A, N1094B) sampling oscilloscope. 
However, for S-Parameter measurements, a network analyzer is required. If properly configured, the 
Compliance Test Application can communicate with a network analyzer for making the 
measurements, and include the S-parameter results in the test application report.

Previous versions of the N109310CA SFF-8431 Compliance Test Application required Instrument 
protocol connections to the LAN for ENAs and Socket connections for PNAs. However, version 1.11 
and higher require Socket connections for ENAs as well as PNAs.

Note that the Keysight I/O Library Suite must be installed before you proceed with connecting to the 
network analyzer. The user interface for Keysight Connection Expert 2017 (Version 18.0) and higher 
is slightly different from its previous versions, such as Version 17.2 or earlier.

Connection using Keysight Connection Expert v17.2 (or earlier)

1 Locate and record the ENA/PNA instrument’s Hostname (Full Computer Name). Refer to the 
respective network analyzer’s documentation for locating this information.

2 From the Windows Start menu, click All Programs>Keysight Connection Expert to launch Connection 
Expert. Refer to Keysight IO Libraries Suite for information on how to install the Keysight 
Connection Expert.

Figure 12 Launching the Keysight Connection Expert

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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3 In Keysight Connection Expert, click the Manual Configuration tab.

Figure 13 Tabs within Keysight Connection Expert

4 Under Add New Instruments / Interfaces, select LAN instrument.

Figure 14 Performing Manual Configuration in Keysight Connection Expert
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5 In the Add a LAN device pane, 

a Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

b Under Set Protocol:, select Socket and enter the port number.

c Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 15 Adding a LAN device information in the Keysight Connection Expert

6 Once you verify the entered data, click Accept to complete the process.
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7 Copy Network Analyzer SICL Address to the Clipboard:

a Click the Instruments tab of the Keysight Connection Expert.

b Click the ENA/VNA listing on the left pane, and copy the SICL address using Ctrl + C keys. 
Note that the address on your end will be different from what is shown in the image.

Figure 16 Copying Network Analyzer’s SICL Address

8 Start the N109310CA SFF-8431 Compliance Test Application. Refer to “Starting the N109310CA 
SFF-8431 Compliance Test Application” on page 20 for instructions.
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9 Connect to the Network Analyzer:

Figure 17 Default view of External Instruments area in the N109310CA SFF-8431 Application

a In the Name: field of the External Instruments area at the bottom of the N109310CA SFF-8431 
application’s main window, select either N4877A/N1076/7A, VNA or ENA from the drop-down 
list, depending on your network analyzer. In the example below, ENA is selected.

Figure 18 Selecting a Network Analyzer in the N109310CA SFF-8431 Application

b Click Connect. The Connect to ENA window appears.

Figure 19 Connecting to the selected Network Analyzer

c In the Enter/Select VISA address/alias (or SICL address) field, paste the SICL address using Ctrl + V 
keys.

d Click Get to confirm the connection.

e Click OK to close the dialog box. 

f The External Instruments field displays the relevant information once the connection to the 
selected network analyzer is established.
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Connection using Keysight Connection Expert 2017 (v18.0) and higher

1 Locate and record the ENA/PNA instrument’s Hostname (Full Computer Name). Refer to the 
respective network analyzer’s documentation for locating this information.

2 From the Windows Start menu, click All Programs>Keysight Connection Expert to launch Connection 
Expert 2017. Refer to Keysight IO Libraries Suite for information on how to install the Keysight 
Connection Expert 2017.

Figure 20 Launching the Keysight Connection Expert 2017

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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3 In Keysight Connection Expert 2017, click the + Add button to manually add instruments and 
interfaces.

Figure 21 Adding LAN device manually in the Keysight Connection Expert 2017

4 From the drop-down list that appears, select LAN instrument.

Figure 22 Selecting LAN instrument in the Keysight Connection Expert 2017
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5 In the Add a LAN device window, 

a Select the Enter Address tab.

b Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

c Under Set Protocol:, select Socket and enter the port number.

d Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 23 Adding a LAN device information in the Keysight Connection Expert 2017

6 Once you verify the entered data, click OK to complete the process.
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7 Copy Network Analyzer SICL Address to the Clipboard:

a Click the Instruments tab of the Keysight Connection Expert 2017.

Figure 24 Selecting the connected Network Analyzer for SICL Address information
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b Click the ENA/VNA listing on the left pane, and copy the SICL address using Ctrl + C keys. 
Note that the address on your end will be different from what is shown in the image.

Figure 25 Copying Network Analyzer’s SICL Address

8 Start the N109310CA SFF-8431 Compliance Test Application. Refer to “Starting the N109310CA 
SFF-8431 Compliance Test Application” on page 20 for instructions.
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9 Connect to the Network Analyzer:

Figure 26 Default view of External Instruments area in the N109310CA SFF-8431 Application

a In the Name: field of the External Instruments area at the bottom of the N109310CA SFF-8431 
application’s main window, select either N4877A/N1076/7A, VNA or ENA from the drop-down 
list, depending on your network analyzer. In the example below, ENA is selected.

Figure 27 Selecting a Network Analyzer in the N109310CA SFF-8431 Application

b Click Connect. The Connect to ENA window appears.

Figure 28 Connecting to the selected Network Analyzer

c In the Enter/Select VISA address/alias (or SICL address) field, paste the SICL address using Ctrl + V 
keys.

d Click Get to confirm the connection.

e Click OK to close the dialog box. 

f The External Instruments field displays relevant information once the connection to the selected 
network analyzer is established.
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2 Installing N109310CA and 
N1010A FlexDCA on a PC

Follow the instructions in this chapter when you are installing both the N109310CA SFF-8431 
application and the N1010A FlexDCA application on the PC. You must purchase and install a license 
for the 86100DU-401 or N1010100A.

Figure 29 N109310CA and N1010A FlexDCA Installed on PC (using 86100D DCA-X oscilloscope)

NOTE When you redeem an N109310CA SFF-8431 license, you must select whether to install the 
application on a supported DCA-X or DCA-M Oscilloscope or a specific PC.
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Figure 30 N109310CA and N1010A FlexDCA Installed on PC (using N1000A DCA-X oscilloscope)
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Figure 31 N109310CA and N1010A FlexDCA Installed on PC connected to N1094B DCA-M Oscilloscope

NOTE If you do not connect a network analyzer, you will not be able to perform the S-parameter Tests 
and Impedance Tests for the following test categories: Host Transmitter Output, Module Receiver 
Output, Host Receiver Limiting Module Test Signal, Host Receiver Linear Module Test Signal, and 
Module Transmitter Input Signal.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 2 into the 
oscilloscope.

Table 2 Module combinations for DCA-X Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 3 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in the connection diagrams above and power on all of the 
instruments.

4 Install Microsoft Excel on the PC.

Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the PC.

Installed Module Configurations Single Plug-In Module 
Setup

Multiple Plug-In
Module Setup

Description

86108A/B Available The 86108B can have either options LBW or 
HBW plus 216 or 232.

86112A, 54754A, 86117A, or 86118A-H01
86107A (any option)
N4877A, N1076 A/B, N1077A, N1078A Clock Data 
Recovery Options 216/232*

N1045A, N1045B, N1055A, N1046A 75/85/100 GHz, 
N1060A

Available Option 216 provides a maximum data rate of 16 
Gb/s. Option 232 provides a maximum data rate 
of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the oscilloscope’s Trigger input instead of using the CDR.

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The 
N109310CA SFF-8431 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N1010A FlexDCA Application

Follow the steps below to install the N1010A FlexDCA Software and its license as well as the license 
for the 86100DU-401.

1 Search for N1010A FlexDCA Software from the Keysight website. 

2 Download the installer file and install the application on the PC for which you have redeemed the 
license.

3 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

4 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 32 Launching Keysight Connection Expert from the Start menu

NOTE When you redeem an N1010A FlexDCA Remote Access Software license, you must specify the 
information for the PC, where the software will be installed for remotely accessing the 
Oscilloscope.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.

http://www.keysight.com/en/pd-1851900-pn-N1010A/flexdca-remote-access-software?nid=-32976.937137&cc=IN&lc=eng
http://www.keysight.com/en/pd-1851900-pn-N1010A/flexdca-remote-access-software?nid=-32976.937137&cc=IN&lc=eng


2 Installing N109310CA and N1010A FlexDCA on a PC

38 SFF-8431 Compliance and Debug Application Getting Started

To install the N1010A FlexDCA Software license using Keysight License Manager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 33 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 34 Selecting license file from the folder

3 Navigate to the folder where the N1010A FlexDCA Software licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.
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Figure 35 Licenses displayed in Keysight License Manager version 5.1 & above

5 Close the Keysight License Manager.

To install the N1010A FlexDCA Software license using Keysight License Manager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 36 Installing license file on Keysight License Manager version 5.0 or earlier
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2 The Install License File(s) dialog box appears.

Figure 37 Selecting license file from the folder

3 Navigate to the folder where the N1010A FlexDCA Software licenses are saved.
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4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

Figure 38 Licenses displayed in Keysight License Manager version 5.0 or earlier

5 Close the Keysight License Manager.
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Installing the N109310CA SFF-8431 Compliance Test Application

Follow the steps below to install the N109310CA SFF-8431 Compliance Test Application and its 
license as well as the license for the 86100CU-401 or N1010100A. A version of the 86100CU-401 is 
automatically installed for use with the N109310CA.

1 Search for the N109310CA SFF-8431 Compliance Test Application on the Keysight website.

2 Download the installer file and install the application on the PC for which you have redeemed the 
license.

3 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

4 If not already done, purchase an 86100DU-401, N109x-401, or N1010100A license. Save the 
license file that you received from Keysight in a folder on the local disk or in an accessible 
memory device.

5 If the N1010A FlexDCA is running on your PC, close FlexDCA.

6 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 39 Launching Keysight Connection Expert from the Start menu

NOTE If you plan to run all of the N109310CA tests, the N109310CA license will suffice. If using older 
licenses, host testing requires option N1014A-HST and Module Testing requires option 
N1014A-MOD.

NOTE When you redeem an N109310CA SFF-8431 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 40 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 41 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.
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Figure 42 Licenses displayed in Keysight License Manager version 5.1 & above

5 Close the Keysight License Manager.

To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 43 Installing license file on Keysight License Manager version 5.0 or earlier

2 The Install License File(s) dialog box appears.
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Figure 44 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

Figure 45 Licenses displayed in Keysight License Manager version 5.0 or earlier

5 Close the Keysight License Manager.
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Connecting N1010A FlexDCA to 86100D or N1000A

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 46 86100D Oscilloscope’s hostname

4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

86100D Computer Name: ________________________

NOTE This section lists the steps for 86100D DCA-X oscilloscope. Perform similar steps for the 
N1000A DCA-X oscilloscope.

NOTE If you are using the N1010A FlexDCA Software on your PC to launch the N109310CA SFF-8431 
Compliance Test Application, make sure that the Oscilloscope and your PC are connected to 
the LAN.
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5 Close the About 86100D dialog box.

6 On the Windows Start menu on your PC, click All Programs>Keysight FlexDCA>Keysight FlexDCA to 
launch the N1010A FlexDCA Software.

Figure 47 Launching the N1010A FlexDCA Software on PC

NOTE If you are accessing the 86100D Oscilloscope’s FlexDCA interface remotely on your PC using 
any remote connectivity applications, Keysight recommends closing the remote-connection 
application before you try establishing connectivity between FlexDCA Software and the remote 
86100D Oscilloscope.
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7 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. Click 
Connect if the 86100D Oscilloscope’s Hostname is already displayed else click Setup.

Figure 48 Extended Module Configuration dialog box for connecting N1010A FlexDCA to 86100D

If the Extended Module Configuration window does not appear, from the FlexDCA interface’s main 
menu, click Setup>DCA Connection Setup.
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8 On the FlexDCA Connection Setup dialog box,

a Ensure that LAN is selected in the Connect Using: area.

b Enter the 86100D’s Hostname that you recorded in step 4.

Alternatively, you may also enter the IP Address of the remote 86100D Oscilloscope.

Figure 49 N1010A FlexDCA Connection Setup to connect to 86100D Oscilloscope
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9 Click Connect.

If connection is established successfully, the FlexDCA Connection Setup dialog box displays status 
as Connected.

Figure 50 86100D Oscilloscope connection status on the FlexDCA Connection Setup

10 Click Close to exit the FlexDCA Connection Setup dialog box.

11 Click Close to exit the Extended Module Configuration window.

Figure 51 86100D Oscilloscope connection status on the Extended Module Configuration window
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12 Once the connection is established, you may proceed to launch the N109310CA SFF-8431 
Compliance Test Application on your PC.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109310CA SFF-8431 
Compliance Test Application on your PC.
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Starting the N109310CA SFF-8431 Compliance Test Application

After you install the N109310CA SFF-8431 Compliance Test Application on a PC along with the 
N1010A FlexDCA interface, start the N109310CA SFF-8431 Compliance Test Application in one of 
the following ways:

Access the N109310CA SFF-8431 Compliance Test Application directly from the Start menu

Refer to “Starting the N109310CA SFF-8431 Compliance Test Application” on page 79, where the 
procedure to start the application directly (that is, without launching the N1010A FlexDCA Software) 
is described.

Access the N109310CA SFF-8431 Compliance Test Application using the N1010A FlexDCA Software on 
your PC

1 Ensure that the N1010A FlexDCA Software is connected to the Oscilloscope. Refer to 
“Connecting N1010A FlexDCA to 86100D or N1000A” on page 46.

2 After a connection between the N1010A FlexDCA Software and the Oscilloscope is established, 
the N1010A FlexDCA Software on your PC may indicate that it is remotely controlled, as shown in 
Figure 52.

Figure 52 N1010A FlexDCA under Remote Control

To view the N1010A FlexDCA's main menu, click the Local button (towards the upper right 
corner).

Figure 53 N1010A FlexDCA free from Remote Control
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3 From the FlexDCA's main menu, click Apps>Automated Test Apps>N109310CA SFF-8431.

4 The N109310CA SFF-8431 Compliance Test Application banner appears.
Afterwards, the default view of the N109310CA SFF-8431 Compliance Test Application appears.

Figure 54 Default window of the N109310CA SFF-8431 Compliance Test Application
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.

Configuring the Network Analyzer on the N109310CA SFF-8431 Application

After you establish a connection with a network analyzer, you must configure certain settings to run 
the S-parameter and Impedance Tests on the N109310CA SFF-8431 Compliance Test Application.

1 In the N109310CA SSF-8431 Compliance Test Application, click the Configure tab.

2 With the Mode: option set to Compliance (for compliance testing), select Source for S-parameter 
values on the left pane.

3 In the corresponding Settings For: pane, select the type of network analyzer that is connected.

Figure 55 Configuring S-parameter value source

NOTE It is recommended to connect VNA/ENA through VNC for S-parameter tests in order to allow the 
test application to capture and include required measurement screen-shots in the HTML Report. 
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4 Select Source for Termination Mismatch Values on the left pane.

5 Select ENA if you are using an ENA. For VNA, select Enter Manually.

Figure 56 Configuring Termination Mismatch value source

The setup of the N109310CA SFF-8431 Compliance Test Application with N1010A FlexDCA installed 
on PC is now complete. You may begin to select, setup, and run compliance tests. Refer to Keysight 
N109310CA SFF-8431 Compliance Test Application Online Help to understand the functionality of 
the application to run tests.
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Installing WDP Measurement Script

This step is required before you can perform the following TWDP (Transmitter Waveform Dispersion 
Penalty) test, which is selected under the “Host Transmitter Output - Cu” tests in the application:

• Output TWDPc - Host Cu

This step is also required for the following WDP (Waveform Dispersion Penalty) test, which is 
selected under the “Host Receiver Stress Generator Signal” tests in the application:

• WDP of ISI Gen - Host Stress Gen
1 On your PC’s web browser, go to the following site:

https://ta.snia.org/higherlogic/ws/public/documents

2 On this site, locate and open the SFF-8431.PDF file.

3 In the document, go to APPENDIX G MATLAB CODE FOR TWDP.

4 Copy the script and place it in a text editor.

5 Comment out line 40 and add a new line after line 40. The two lines should look like the following:

%% TXDataFile = ‘prbs9_950.txt’;
TXDataFile = ‘C:\Temp\XmitBits.csv’;

6 Compile the WDP script file in a 32-bit MATLAB (Version 2009a & above) to create an executable 
to run on the 86100D or PC.

7 Name the executable file SFF8431xWDP.exe, and save the file in the following folder:

C:\ProgramData\Keysight\N5467A\User Defined Application\uda\
distrib_CSIDL_COMMON_APPDATA\App\ExternalAppScripts\SFF8431xWDP.exe
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Keysight N109310CA SFF-8431 Compliance and Debug Application

Getting Started

3 Installing N109310CA on a PC 
Without N1010A FlexDCA

Follow the instructions in this chapter when you are installing the N109310CA SFF-8431 application 
on a PC, but you are not installing the N1010A FlexDCA application on the same PC. You must 
purchase and install a license for the 86100DU-401 or N1010100A.

Figure 57 N109310CA Installed on PC Without N1010A FlexDCA connected to 86100D DCA-X Oscilloscope
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Figure 58 N109310CA Installed on PC Without N1010A FlexDCA connected to N1000A DCA-X Oscilloscope
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Figure 59 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via an-
other PC
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Figure 60 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
86100 DCA-X Oscilloscope
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Figure 61 N109310CA Installed on PC Without N1010A FlexDCA connected to N1094B DCA-M Oscilloscope via 
N1000A DCA-X Oscilloscope

NOTE If you do not connect a network analyzer, you will not be able to perform the S-parameter Tests 
and Impedance Tests for the following test categories: Host Transmitter Output, Module Receiver 
Output, Host Receiver Limiting Module Test Signal, Host Receiver Linear Module Test Signal, and 
Module Transmitter Input Signal.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 4 into the 
oscilloscope.

Table 4 Module combinations for DCA-X Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 5 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in the connection diagrams above and power on all of the 
instruments.

4 Install Microsoft Excel on the PC.

Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the PC.

Installed Module Configurations Single Plug-In Module 
Setup

Multiple Plug-In
Module Setup

Description

86108A/B Available The 86108B can have either options LBW or 
HBW plus 216 or 232.

86112A, 54754A, 86117A, or 86118A-H01
86107A (any option)
N4877A, N1076 A/B, N1077A, N1078A Clock Data 
Recovery Options 216/232*

N1045A, N1045B, N1055A, N1046A 75/85/100 GHz, 
N1060A

Available Option 216 provides a maximum data rate of 16 
Gb/s. Option 232 provides a maximum data rate 
of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the DCA-X oscilloscope’s Trigger input instead of using the CDR.

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)

NOTE Keysight’s I/O Library Suite is a free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The 
N109310CA SFF-8431 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N109310CA SFF-8431 Compliance Test Application

Follow the steps below to install the N109310CA SFF-8431 Compliance Test Application and its 
license as well as the license for the 86100DU-401 or N1010100A. A version of the 86100DU-401 is 
automatically installed for use with the N109310CA.

1 Search for the N109310CA SFF-8431 Compliance Test Application on the Keysight website. 
Install the application on the PC for which you have redeemed the license.

2 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

3 If not already done, purchase an 86100DU-401 or N1010100A license. Save the license file that 
you received from Keysight in a folder on the local disk or in an accessible memory device.

4 If the N1010A FlexDCA is running on your PC, close FlexDCA.

5 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 62 Launching Keysight Connection Expert from the Start menu

NOTE If you plan to run all of the N109310CA tests, the N109310CA license will suffice. If using older 
licenses, host testing requires option N1014A-HST and Module Testing requires option 
N1014A-MOD.

NOTE When you redeem an N109310CA SFF-8431 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 63 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 64 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.
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Figure 65 Licenses displayed in Keysight License Manager version 5.1 & above

5 Close the Keysight License Manager.

To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 66 Installing license file on Keysight License Manager version 5.0 or earlier
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2 The Install License File(s) dialog box appears.

Figure 67 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

Figure 68 Licenses displayed in Keysight License Manager version 5.0 or earlier

5 Close the Keysight License Manager.
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Validating DCA-X Oscilloscope’s SCPI Server Setup

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 Click Tools > SCPI Programming Tools > SCPI Server Setup.

3 In the SCPI Server Setup dialog, confirm that the Sockets and HiSLIP interfaces are selected and 
enabled as shown in Figure 69.

Figure 69 86100D’s SCPI Server Setup Dialog Box

4 Close the SCPI Server Setup dialog box.

NOTE This section lists the steps for 86100D DCA-X oscilloscope. Perform similar steps for the 
N1000A DCA-X oscilloscope.
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Adding 86100D or N1000A to Keysight Connection Expert

Most of the measurements in the N109310CA SFF-8431 Compliance Test Application use a 
supported DCA-X or DCA-M sampling oscilloscope.

Note that the Keysight I/O Library Suite must be installed before you proceed with connecting to the 
network analyzer. The user interface for Keysight Connection Expert 2017 (Version 18.0) or higher is 
slightly different from its previous versions, such as Version 17.2 or earlier.

Connection using Keysight Connection Expert v17.2 (or earlier) or higher

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 70 86100D Oscilloscope’s hostname

NOTE This section lists the steps for 86100D DCA-X oscilloscope. Perform similar steps for the 
N1000A DCA-X oscilloscope.
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4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

86100D Computer Name: ________________________

5 Close the About 86100D dialog box.

6 On the Windows Start menu of your PC, click All Programs>Keysight Connection Expert to launch 
Connection Expert. Refer to Keysight IO Libraries Suite for information on how to install the 
Keysight Connection Expert.

Figure 71 Launching the Keysight Connection Expert

7 In Keysight Connection Expert, click the Manual Configuration tab.

Figure 72 Tabs within Keysight Connection Expert

8 Under Add New Instruments / Interfaces, select LAN instrument.

Figure 73 Performing Manual Configuration in Keysight Connection Expert

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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9 In the Add a LAN device pane, 

a Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

b Under Set Protocol:, select Socket and enter the port number.

c Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 74 Adding the 86100D device information in the Keysight Connection Expert

10 Once you verify the entered data, click Accept to complete the process.



SFF-8431 Compliance and Debug Application Getting Started 73

Installing N109310CA on a PC Without N1010A FlexDCA 3

11 To verify that the 86100D Oscilloscope is connected, click the Instruments tab of the Keysight 
Connection Expert.

12 Click the 86100D Oscilloscope’s listing on the left pane. A check mark encircled in green 
indicates that the Oscilloscope is connected to your PC remotely on the LAN. Note that the 
address on your end will be different from what is shown in the image.

Figure 75 Validating 86100D Oscilloscope’s connection

13 Close the Keysight Connection Expert window.
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Connection using Keysight Connection Expert 2017 (v18.0)

1 On the 86100D Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA’s main menu, click Help > About FlexDCA.... The About 86100D dialog box 
appears.

3 In the System Information area, scroll down to view the Computer Name entry.

Alternatively, you can obtain the computer name from the Windows System properties.

Figure 76 86100D Oscilloscope’s hostname

4 Record the Computer Name (corresponds to hostname) as you will need this name later in this 
procedure.

86100D Computer Name: ________________________

5 Close the About 86100D dialog box.

6 On the Windows Start menu of your PC, click All Programs>Keysight Connection Expert to launch 
Connection Expert 2017. Refer to Keysight IO Libraries Suite for information on how to install the 
Keysight Connection Expert 2017.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuiteproductcounter
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Figure 77 Launching the Keysight Connection Expert 2017

7 In Keysight Connection Expert 2017, click the + Add button to manually add instruments and 
interfaces.

Figure 78 Adding 86100D Oscilloscope manually in the Keysight Connection Expert 2017

8 From the drop-down list that appears, select LAN instrument.

Figure 79 Selecting LAN instrument in the Keysight Connection Expert 2017
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9 In the Add a LAN device window, 

a Select the Enter Address tab.

b Under Set LAN Address:, enter the Hostname (recorded in step 1) in the Hostname or IP Address: 
field. Note that your Hostname entry will be different from what is shown in the image.

c Under Set Protocol:, select Socket and enter the port number.

d Under Verify Connection:, click Test This VISA Address to verify the connection.

Figure 80 Adding 86100D Oscilloscope’s device information in the Keysight Connection Expert 2017

10 Once you verify the entered data, click OK to complete the process.
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11 To verify that the 86100D Oscilloscope is connected, click the Instruments tab of the Keysight 
Connection Expert. 

12 Click the 86100D Oscilloscope’s listing on the left pane. A check mark encircled in green 
indicates that the Oscilloscope is connected to your PC remotely on the LAN. Note that the 
address on your end will be different from what is shown in the image.

Figure 81 Validating 86100D Oscilloscope’s connection

13 Close the Keysight Connection Expert window.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109310CA SFF-8431 
Compliance Test Application on your PC.
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Starting the N109310CA SFF-8431 Compliance Test Application

After you install the N109310CA SFF-8431 Compliance Test Application on a PC without the N1010A 
FlexDCA interface, follow the steps below to start the N109310CA SFF-8431 Compliance Test 
Application:

1 Ensure that the 86100D or N1000A Oscilloscope is added to the Keysight Connection Expert and 
that the connection is active. Refer to “Adding 86100D or N1000A to Keysight Connection 
Expert” on page 70.

2 From the Windows Start menu, navigate to Start>All Programs>Keysight FlexDCA 
Applications>N109310CA SFF-8431 and click Launch 'N109310CA SFF-8431'.

3 The N109310CA SFF-8431 Compliance Test Application banner appears followed by the Connect 
to FlexDCA dialog.

Figure 82 N109310CA SFF-8431 Application Connect to FlexDCA dialog

4 Enter the SICL address or VISA alias, if known, else select the Select from Keysight Connection Expert 
option to find the SICL Address/VISA alias.

5 Click OK to connect.
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• The default view of the N109310CA SFF-8431 Compliance Test Application appears.

Figure 83 Default window of the N109310CA SFF-8431 Compliance Test Application

NOTE If you click the View 'N109310CA SFF-8431' in Demo Mode option under Start>All 
Programs>Keysight FlexDCA Applications>N109310CA SFF-8431, click File>Connect to 
Scope... to access the Connect to FlexDCA dialog. However, since it is a demo application, it 
has limited features.
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.

Configuring the Network Analyzer on the N109310CA SFF-8431 Application

After you establish a connection with a network analyzer, you must configure certain settings to run 
the S-parameter and Impedance Tests on the N109310CA SFF-8431 Compliance Test Application.

1 In the N109310CA SSF-8431 Compliance Test Application, click the Configure tab.

2 With the Mode: option set to Compliance (for compliance testing), select Source for S-parameter 
values on the left pane.

3 In the corresponding Settings For: pane, select the type of network analyzer that is connected.

Figure 84 Configuring S-parameter value source
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4 Select Source for Termination Mismatch Values on the left pane.

5 Select ENA if you are using an ENA. For VNA, select Enter Manually.

Figure 85 Configuring Termination Mismatch value source

The setup of the N109310CA SFF-8431 Compliance Test Application without N1010A FlexDCA 
installed on PC is now complete. You may begin to select, setup, and run compliance tests. Refer to 
Keysight N109310CA SFF-8431 Compliance Test Application Online Help to understand the 
functionality of the application to run tests.
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Installing WDP Measurement Script

This step is required before you can perform the following TWDP (Transmitter Waveform Dispersion 
Penalty) test, which is selected under the “Host Transmitter Output - Cu” tests in the application:

Output TWDPc - Host Cu

This step is also required for the following WDP (Waveform Dispersion Penalty) test, which is 
selected under the “Host Receiver Stress Generator Signal” tests in the application:

WDP of ISI Gen - Host Stress Gen

1 On your PC’s web browser, go to the following site:

https://ta.snia.org/higherlogic/ws/public/documents

2 On this site, locate and open the SFF-8431.PDF file.

3 In the document, go to APPENDIX G MATLAB CODE FOR TWDP.

4 Copy the script and place it in a text editor.

5 Comment out line 40 and add a new line after line 40. The two lines should look like the following:

%% TXDataFile = ‘prbs9_950.txt’;
TXDataFile = ‘C:\Temp\XmitBits.csv’;

6 Compile the WDP script file in a 32-bit MATLAB (Version 2009a & above) to create an executable 
to run on the 86100D or PC.

7 Name the executable file SFF8431xWDP.exe, and save the file in the following folder:

C:\ProgramData\Keysight\N5467A\User Defined Application\uda\
distrib_CSIDL_COMMON_APPDATA\App\ExternalAppScripts\SFF8431xWDP.exe
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Keysight N109310CA SFF-8431 Compliance and Debug Application

Getting Started

4 Installing N109310CA on the 
86100D or N1000A

Follow the instructions in this chapter when you are installing both the N109310CA application and 
the FlexDCA application on the 86100D or N1000A oscilloscope. You must purchase and install a 
license for the 86100DU-401 or N1010100A.

Figure 86 N109310CA Installed on 86100D

Figure 87 N109310CA Installed on N1000A



4 Installing N109310CA on the 86100D or N1000A Oscilloscope

86 SFF-8431 Compliance and Debug Application Getting Started

Figure 88 N109310CA Installed on 86100D connected to a DCA-M setup
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Figure 89 N109310CA Installed on N1000A connected to a DCA-M setup

NOTE If you do not connect a network analyzer, you will not be able to perform the S-parameter Tests 
and Impedance Tests for the following test categories: Host Transmitter Output, Module Receiver 
Output, Host Receiver Limiting Module Test Signal, Host Receiver Linear Module Test Signal, and 
Module Transmitter Input Signal.
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Connecting the Equipment

1 For a DCA-X oscilloscope, install one of the module combinations listed in Table 6 into the 
oscilloscope.

Table 6 Module combinations for DCA-X Oscilloscope

2 For a DCA-M oscilloscope, keep in mind the information in the following table.

Table 7 Supported configurations for DCA-M Oscilloscope

3 Connect the equipment as shown in the connection diagrams above and turn on all of the 
instruments.

4 Install Microsoft Excel on the oscilloscope.

Installing the I/O Library Suite

1 Navigate to www.keysight.com/find/iosuite and download the Keysight I/O Library Suite.

2 Install the I/O Library Suite on the PC.

Installed Module Configurations
Single Plug-In Module 
Setup

Multiple Plug-In
Module Setup Description

86108A/B Available The 86108B can have either options LBW or 
HBW plus 216 or 232.

86112A, 54754A, 86117A, or 86118A-H01
86107A (any option)
N4877A, N1076 A/B, N1077A, N1078A Clock Data 
Recovery Options 216/232*

N1045A, N1045B, N1055A, N1046A 75/85/100 GHz, 
N1060A

Available Option 216 provides a maximum data rate of 16 
Gb/s. Option 232 provides a maximum data rate 
of 32 Gb/s.

* If you have access to the clock for the device, you can connect the clock to the oscilloscope’s Trigger input instead of using the CDR.

Configurations for DCA-M Requires N107x

N1094A √ (N107xA-232)

N1094B √ (N107xA-232)

N1092 C/E √ (N107xA-232)

NOTE Keysight’s I/O Library Suite is free software that automatically detects instruments connected to 
your PC and configures the interfaces. It reduces the overall setup and configuration time. The 
N109310CA SFF-8431 Compliance Test Application requires I/O Libraries Suite 16.3 or higher.

http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
http://www.keysight.com/en/pd-1985909/io-libraries-suite?nid=-33330.977662.00&cc=IN&lc=eng&cmpid=zzfindiosuite
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Installing the N109310CA SFF-8431 Compliance Test Application

Follow the steps below to install the N109310CA SFF-8431 Compliance Test Application and its 
license as well as the license for the 86100DU-401. A version of the 86100DU-401 is automatically 
installed for use with the N109310CA.

1 Search for the N109310CA SFF-8431 Compliance Test Application on the Keysight website. 
Install the application on the Oscilloscope for which you have redeemed the license.

2 Save the license file that you received from Keysight in a folder on the local disk or in an 
accessible memory device.

3 If not already done, purchase an 86100DU-401 or N1010100A license. Save the license file that 
you received from Keysight in a folder on the local disk or in an accessible memory device.

4 If the N1010A FlexDCA is running on the Oscilloscope, close FlexDCA.

5 From the Windows Start menu, click All Programs>Keysight License Manager to launch the Keysight 
License Manager.

Figure 90 Launching Keysight Connection Expert from the Start menu

NOTE If you plan to run all of the N109310CA tests, the N109310CA license will suffice. If using older 
licenses, host testing requires option N1014A-HST and Module Testing requires option 
N1014A-MOD.

NOTE When you redeem an N109310CA SFF-8431 license, you must select whether to install the 
application on the Oscilloscope or a specific PC.

NOTE Keysight License Manager version 5.1 (and higher) have a different user interface than version 
5.0 (or earlier). Even though the path to launch the Keysight License Manager is the same for 
both versions, refer to the Keysight License Manager Online Help for the respective versions to 
find more information about the functionality of the application.
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To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.1 or higher

1 Click the Tools icon on the top-right corner of the Keysight License Manager window.

Figure 91 Installing license file on Keysight License Manager version 5.1 & above

2 Click Install License File.... The Select License File(s) to Install on <PC Hostname> appears.

Figure 92 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.

4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.
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Figure 93 Licenses displayed in Keysight License Manager version 5.1 & above

5 Close the Keysight License Manager.

To install the N109310CA SFF-8431 Compliance Test Application’s license using Keysight License Man-
ager version 5.0 or earlier

1 From the Keysight License Manager window’s main menu, click File>Install... or right-click within 
the left pane of the Keysight License Manager window and select Install....

Figure 94 Installing license file on Keysight License Manager version 5.0 or earlier

2 The Install License File(s) dialog box appears.

Figure 95 Selecting license file from the folder

3 Navigate to the folder where the N109310CA SFF-8431 licenses are saved.
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4 Select the license and click Open. The license files are installed and an entry is displayed in the 
Keysight License Manager.

Figure 96 Licenses displayed in Keysight License Manager version 5.0 or earlier

5 Close the Keysight License Manager.
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Connecting N1010A FlexDCA to N109X Oscilloscope and N107X

Perform the following steps to connect your N109X oscilloscope with N107X clock data recovery 
using FlexDCA:

1 Launch FlexDCA.

2 When FlexDCA starts, the Extended Module Configuration window is displayed automatically. If the 
Extended Module Configuration window does not appear, from the FlexDCA interface’s main menu, 
click Setup>Configure Extended Modules....

3 Configure Slot 7 to be the N109X module.

4 Configure Slot 8 to be the N107X module.

5 Remove any other N109X/N107X that is configured for Slot 5 and Slot 6.

6 Click Close to exit the Extended Module Configuration window.

7 Once the connection is established, you may proceed to launch the N109310CA SFF-8431 
Compliance Test Application on your PC.
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Starting the N109310CA SFF-8431 Compliance Test Application

After you install the N109310CA SFF-8431 Compliance Test Application on the 86100D or N1000A 
Oscilloscope, follow the steps below to start the N109310CA SFF-8431 Compliance Test Application:

1 On the 86100D or N1000A Oscilloscope, launch the Keysight FlexDCA application.

2 From the FlexDCA's main menu, click Apps>Automated Test Apps>N109310CA SFF-8431.

3 The N109310CA SFF-8431 Compliance Test Application banner appears.
Afterwards, the default view of the N109310CA SFF-8431 Compliance Test Application appears.

Figure 97 Default window of the N109310CA SFF-8431 Compliance Test Application
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Connecting to the Network Analyzer

Refer to “Connecting to External Instruments” on page 21 for connecting to the network analyzer you 
are using.

Configuring the Network Analyzer on the N109310CA SFF-8431 Application

After you establish a connection with a network analyzer, you must configure certain settings to run 
the S-parameter and Impedance Tests on the N109310CA SFF-8431 Compliance Test Application.

1 In the N109310CA SFF-8431 Compliance Test Application, click the Configure tab.

2 With the Mode: option set to Compliance (for compliance testing), select Source for S-parameter 
values on the left pane.

3 In the corresponding Settings For: pane, select the type of network analyzer that is connected.

Figure 98 Configuring S-parameter value source
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4 Select Source for Termination Mismatch Values on the left pane.

5 Select ENA if you are using an ENA. For VNA, select Enter Manually.

Figure 99 Configuring Termination Mismatch value source

The setup of the N109310CA SFF-8431 Compliance Test Application on the 86100D or N1000A 
Oscilloscope is now complete. You may begin to select, setup, and run compliance tests. Refer to 
Keysight N109310CA SFF-8431 Compliance Test Application Online Help to understand the 
functionality of the application to run tests.
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Installing WDP Measurement Script

This step is required before you can perform the following TWDP (Transmitter Waveform Dispersion 
Penalty) test, which is selected under the “Host Transmitter Output - Cu” tests in the application:

Output TWDPc - Host Cu

This step is also required for the following WDP (Waveform Dispersion Penalty) test, which is 
selected under the “Host Receiver Stress Generator Signal” tests in the application:

WDP of ISI Gen - Host Stress Gen

1 On your PC’s web browser, go to the following site:

https://ta.snia.org/higherlogic/ws/public/documents

2 On this site, locate and open the SFF-8431.PDF file.

3 In the document, go to APPENDIX G MATLAB CODE FOR TWDP.

4 Copy the script and place it in a text editor.

5 Comment out line 40 and add a new line after line 40. The two lines should look like the following:

%% TXDataFile = ‘prbs9_950.txt’;
TXDataFile = ‘C:\Temp\XmitBits.csv’;

6 Compile the WDP script file in a 32-bit MATLAB (Version 2009a & above) to create an executable 
to run on the 86100D or PC.

7 Name the executable file SFF8431xWDP.exe, and save the file in the following folder:

C:\Documents and Settings\All Users\Application Data\Keysight\FlexDCA\Apps\N109310CA 
SFF-8431\App\ExternalAppScripts\SFF8431xWDP.exe
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