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Agilent N5412C Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412C Software Version 3.02 
Released Date: 9 May 2014 
File Name: SetupInfSAS303020000.exe 
 
Minimum Infiniium Oscilloscope Baseline Version: 4.10.0008 
Minimum JBERT-B Firmware Version: 7.10 
SAS3_EYEOPENING Script Version: 2.3 
 
Additions: 
 

 Supports for Serial Attached SCSI-3 (SAS-3) Specification Revision 06. 

 Update the SAS3_EYEOPENING script to Version 2.3. 

 Support remote programming for the TX Coefficient Requests and Circuit 
Response test’s coefficient request selection using GenericMessageEvent.  

o Establish two-way channel using Agilent.Infiniium.AppFW.Remote.dll 
AteEventSink class by remote client. 

o  Add the Even Handler for the GenericMessageEvent of the 
AteEventSink class: 
mAteEventSink.GenericMessageEvent += OnGenericMessage 

o Remote client will be called when the N5412C SAS Compliance 
Application required coefficient request. The OnGenericMessage 
handler will received an array: 
object[] { "Coefficient 1 Request", "Coefficient 2 Request", "Coefficient 3 Request" }  

o Remote client need to response to the N5412C SAS Compliance 
Application with the coefficient request needed. For example: 
private object[] OnGenericMessage(object[] data) 
{ 

if (data.Length == 3) 
{ 

if ((data[0].ToString() == "Coefficient 1 Request") && (data[1].ToString() == 
"Coefficient 2 Request") && (data[2].ToString() == "Coefficient 3 Request")) 

{ 
return new object[] { "dec", "dec", "hold" }; 

      } 
 } 
return new object[0]; 

       } 

 Update the second order low pass filter’s frequency’s bandwidth for TX 
SSC Modulation Deviation test and TX SSC DFDT test. 

 Support user configurable first order low pass filter’s bandwidth for TX 
Physical Link Rate Long Term Stability test. Please refer to Programmer’s 
Reference for more details (see Help > Remote Interface). 
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 Support user configurable acquisition averaging for TX Peak-to-Peak 
Voltage, IT test and TX Peak-to-Peak Voltage, ET (with *.tf4 file) test. 
Please refer to Programmer’s Reference for more details (see Help > 
Remote Interface). 

 Support user selectable TX Peak-to-Peak Voltage, ET test method on Set 
Up tab. 

 Add TX Peak-to-Peak Voltage, ET (with *.tf4 file) test to measure the 
peak-to-peak voltage at ET test point by de-embedding the transfer 
function file.  

 Added feature to export TX Coefficient Requests and Circuit Response 
test result into CSV file in the project folder. 

 Report K0 value for TX Coefficient Requests and Circuit Response test, 
Tx Pre-cursor Equalization Ratio (Rpre) test and Tx Post-cursor 
Equalization Ratio (Rpost) test. 

 Included the screenshot of waveform for TX Pre-cursor Equalization Ratio 
(Rpre) test, TX Post-cursor Equalization Ratio (Rpost) test, TX No 
Equalization Coefficient Preset test, TX Reference 1 Coefficient Preset 
test and TX Reference 2 Coefficient Preset test. 

 InfiniiSim now includes new Normalize Gain option. 

 
Modifications: 
 

 Fix the issue of no result display for the TX Waveform Distortion Penalty 
(WDP) test. 

 Fix the position of the dialog for TX Coefficient Requests and Circuit 
Response test.  

 Remote Interface updated to version 2.50. 

 Fixed Connection tab "Suppress" checkbox. 

 When using BitifEye BIT2100 instrument for switch matrix, now requires 
minimum firmware version: 3.4-1.10. 

 
Note: 
 

 This will be the last version to support Infiniium Oscilloscope Baseline Version 
4.20. 
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Agilent N5412C Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412C Software Version 3.01 
Released Date: 02 September 2013 
Minimum Infiniium Oscilloscope Baseline Version: 4.10.0008 (90000 and 
90000X) 
Minimum JBERT-B Firmware Version: 7.10 
File Name: SetupInfSAS303010000.exe 
 
Additions: 
 

 Add the TX Peak-to-Peak Voltage, ET test to measure the peak-to-peak 
voltage at ET test point for minimum limit value. 

 
Modifications: 
 

 Supports 81134A test pattern source for 12.0Gbps bit rate DUT.  

 Tx Physical Link Rate Long Term Stability low pass filter changed from 
smoothing to Butterworth filter with configurable bandwidth. Please refer to 
Programmer’s Reference for more details (see Help > Remote Interface). 

 Update the SAS3_EYEOPENING script to Version 2.2 and End-to-End 
simulation transfer function files. 

 Fix the issue of SAS3_EYEOPENING script’s result by setting the auto 
correct error to true by default. 

 Remove the TX Pre-cursor Equalization Ratio (Rpre), Min and TX Post-cursor 
Equalization Ratio (Rpost), Min tests.  

 Remove the TX No Equalization Peak-to-peak Voltage (VHL), TX Reference 
1 Peak-to-peak Voltage (VHL) and TX Reference 2 Peak-to-peak Voltage 
(VHL) tests. 

 COMSAS OOB trigger mask changed to take into consideration of the 
negation time in the specification.  

 Preserves line breaks for “User Comments” field in HTML Report.  

 Includes new Delay option in InfiniiSim. 

 New option to control jump behavior when user double-click a test name on the 
Select Tests tab. See View > Preferences > Report. 

 Remote Interface updated to version 2.40. 
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Agilent N5412C Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412C Software Version 3.00 
Released Date: 15 April 2013 
Minimum Infiniium Oscilloscope Baseline Version: 4.10.0008 (90000 and 
90000X) 
Minimum JBERT-B Firmware Version: 7.10 
File Name: SetupInfSAS303000000.exe 
 
Additions: 
 

 Supports for Serial Attached SCSI-3 (SAS-3) Specification Revision 05a. 

 New configuration variables (RJ Method, Jitter Pattern Length and etc.) 
added for the Tx Jitter test. Please refer to Programmer’s Reference for more 
details (see Help > Remote Interface). 

 User can now suppress connection prompts from the user interface (see 
Connect tab). 

 If a project opens as Read-Only and there are no settings conflicts with the 
current version of the app, user may use File > Save Project (Settings-Only) As…  
menu item to extract the configuration (and no results) from that project. 

 If user creates the folder: 
(Win7) C:\ProgramData\ Agilent\Infiniium\Apps\<app_name>\app\scripts 
(WinXP) C:\Documents and Settings\All Users\Application 

Data\Agilent\Infiniium\Apps\<app_name>\app\scripts 
Then menu item File > Execute Script… becomes visible and enables user to 
pick a file to execute (e.g a.Python or Visual Basic script). Scripts in this folder 
may also be executed via the Automation tab or remote interface. 

 HTML reports include probe info. 
 
Modifications: 
 

 Projects saved by previous versions of this application will open in read-only 
mode. 

 Supports for multiple SSC Modulation Type tests selections in single trial run. 

 Fixed the issue of the histogram window in Tx Maximum Noise During OOB 
Idle test.  

o The histogram window’s top and bottom limit should be changed base 
on the Min and Max of the idle time instead of fixed value. 

 Fixed the issue of the histogram window in Tx OOB Offset Delta test. 
o The histogram window’s top and bottom limit should cover whole OOB 

burst instead of fixed value. 

 Last location when saving/opening/exporting project/ files/etc. will be saved. 
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 ARSL scripts supports for .txt file extension. 

 Last Test Date reported using international format. 

 Fixed launch on Win7 for non-admin user. 

 Fixed statistics display for items in the Referenced Values section. 
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Agilent N5412B Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412B Software Version 1.32 
Released Date: 27 April 2012 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 7.10 
File Name: SetupInfSAS201320000.exe 
 
Additions: 
 

 Supports for JBERT-B as stimulus. 

 Application’s project file for version 1.31 and below will be opened as read-
only. 

 
Modifications: 
 

 Remove the InfiniiSim button on Set Up tab. User may access Infiniium’s 
InfiniiSim feature through the main menu (see Tools > Infiniium > InfiniiSim). 

 Config variable for stimulus device has changed according to Table 1.32.1. 
Please refer to Programmer’s Reference for more details (see Help > Remote 
Interface). 

 
 

GUI 
Location 

Label Old Variable Old Values 
New 

Variable 
New Value 

Setup Stimulus Device Withpulsegen Yes,No StimulusDevice 
81134A, N4903B, 

None 

Setup cmbIPaddr cmbIPaddr 
(Accepts  

user-defined text) 
IP_Address 

(Accepts  
user-defined text) 

Setup cmbSicladdr cmbSicl 
(Accepts  

user-defined text) 
Sicl_Address 

(Accepts  
user-defined text) 

Setup optConnection optConnection 
none, pulsegen, 

pulsegenSicl 
optConnection 

None, PPG_IP, 
PPG_Sicl, 
JBERT_IP, 
JBERT_Sicl 

Table 1.32.1 
 

 
 



 

 Page 7 of 16   

Agilent N5412B Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412B Software Version 1.31 
Released Date: 20 February 2012 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 
File Name: SetupInfSAS201310000.exe 
 
Additions: 
 

 Supports latest baseline 3.21. 

 Infiniium’s Precision Probe and Precision Cable feature configuration setup 
can be accessed through the main menu (see Tools > Infiniium > 
PrecisionProbe/PrecisionCable). 

 Bandwidth Limit feature for acquisition setup set the frequency limit to be 
used during a run for all tests (Debug Mode only). To access the Bandwidth 
Limit feature see menu: Tools > Infiniium > Acquisition Setup.  

 Remote interface help and PDF files can be accessed through the main menu 
(see Help > Remote Interface).  

 New ‘Automation’ tab enables you to create command scripts that modify 
settings and execute tests.  

 New user preference to set default project location (Menu: View > 
Preferences > Save/Load: Default Location). 

 
Modifications: 
 

 TX WDP Test support for variable pattern length. 

 Fixed issue of no display of DFDT UDF in TX SSC DFDT test. 

 Fixed issue of unable to load saved waveform.  

 Optional way of access Infiniium’s InfiniiSim feature through the main menu 
(see Tools > Infiniium > InfiniiSim). 

 InfiniiSim and PrecisionProbe dialog screens now have tooltips and remote 
hints.  

 A calibration creation wizard is added to the PrecisionProbe dialog box.  

 Now supports Remote Interface version 2.11. For more information, see 
Agilent’s N5452A Remote Programming Toolkit (www.agilent.com/find/scope-
apps).  

 Fixed app startup under Windows Standard User login. 

 

http://www.agilent.com/find/scope-apps
http://www.agilent.com/find/scope-apps
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Agilent N5412B Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412B Software Version 1.30 
Released Date: 30 September 2011 
Minimum Infiniium Oscilloscope Baseline Version: 3.10 
File Name: SetupInfSAS201300000.exe 
 
Additions: 
 

 Supports for Win 7. 

 Supports minimum baseline 3.10. 

 Support pattern verification for HFTP, MFTP, D30.3 (LFTP), CJTPAT. 

 Support pattern verification optionally for Scramble0 (enabled default in config 
tab). 

 Added TX WDP Test (required SASWDP.m script file and Matlab). 
 
Modifications: 
 

 Fixed BIST-L 6.0Gbps outputting 3.0Gbps issue. 

 Fixed TX Rise/Fall Time measurement issue.  

 Removed TX Physical Link Rate Long Term Frequency Test Min & Max Test, 
maintained Mean Test. 

 Test Report Images now include scope result panel as part of screen shot. 
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Agilent N5412B Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412B Software Version 1.10 
Released Date: 23 September 2010 
Minimum Infiniium Oscilloscope Baseline Version: 2.51 (90000) and 
2.95(90000X)  
File Name: SetupInfSAS201100000.exe 
 
Additions: 
 

 Supports minimum baseline 2.51 for 90000 frame and 2.95 for 90000X frame.  
 
Modifications: 
 

 Changed TX Rise/Fall Time Spec from dynamic spec to static spec in 
accordance to SAS2.1r5. 

 Fixed Clock Recovery Settings for SSC related signal tests. 

 Added “notification splash screen” during scope setup for non-OOB tests. 

 Fixed connection diagram prompt sequence logic. 

 Fixed RJ result to be 14 times of RJ1sigma at 1E-12. 
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Agilent N5412B Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412B Software Version 1.00 
Released Date: 13 August 2010 
Minimum Infiniium Oscilloscope Baseline Version: 2.50.0003 (90000 series) 
File Name: SetupInfSAS20100.exe 
 
Additions: 
 

 Supports minimum baseline 2.50.0003 for 90000 Series only. 

 Supports Clause5 SAS-2 6Gbps Physical Layer Test Suite V1.01 
o TX OOB Signaling 
o TX Spread Spectrum Clocking(SSC) Requirements 
o TX NRZ Data Signaling Requirements 

 Supports InfiniiSim. 

 Test Pattern Source Mode: 
o Supports BIST-Transmit Mode 
o Supports BIST-Loopback Mode (Experimental) 
o Supports Saved WFM Feature (Refer to Help CHM for more details on 

this section on usage criteria) 
 
Miscellaneous: 
 

 Only 6 OOB Bursts of OOB are supported for OOB testing. 
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Agilent N5412A Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412A Software Version 1.60 
Released Date: 14 May 2010 
Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000 series), 
2.10.0008 (90000A series) . This is the last version that supports 80000 
scopes.  
File Name: SetupInfSAS0160.exe 
 
Additions: 
 

 Supports minimum baseline v5.71 for 80000 series scopes and v2.10.0008 
for 90000A Series. 

 
Modifications: 
 

 Fixed OOB Trigger Issue with new behavior:  
o OOB Response Simulated on 81134A pulse generator single channel 

amplitude sweep of 100mV to 2V.  
o Supports OOB Response timing spec up to 1000ns gap between 

subsequent OOB Signals (current implementation does not guarantee 
accurate trigger if OOB detection if OOB Burst response are less than 
1000ns after each other); tested on DUT with 500ms gap between 
subsequent OOB signal.  

o Triggers message box error signal if amplitude imbalance of more than 
20% detected to avoid subsequent errors. 

o Supports 2 different trigger Method Attempt for extracting COMINIT 
signal: 

 Pulse Generator YES: 
1. Turning off the Pulse Generator to acquire COMINIT from 

DUT (same as Pulse Generator NO) 
2. If trigger method 1 cannot work, switch to method 2 by 

using pulse generator to send stimulus to SAS DUT for 
response by outputting 320ns idle time COMINIT signals 
with 3200ns negation time between subsequent 
COMINIT(s) pattern. 

 Pulse Generator NO: 
1. Does not use Pulse Generator 

o Supports only 1 trigger Method Attempt for extracting COMSAS signal: 
 Pulse Generator YES: 
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1. Stimulate the DUT for reponse by outputting 320ns idle 
time COMINIT signals with 3200ns negation time 
between subsequent COMINIT(s) pattern. 

o Supports only 1 trigger Method Attempt for extracting COMWAKE 
signal:  

 Pulse Generator YES: 
1. Simulate the DUT for reponse by outputting 320ns idle 

time COMINIT signals with 3200ns negation time 
between subsequent COMINIT(s) pattern. 

o Supports Variable OOB Amplitude Output from DUT. 
o Does not support OOB single ended signal phenomena below as the 

advanced trigger mode might mistaken the sharp spike as part of the 
OOB signal: 

 

 
 

 There is a chance of the app detecting the OOB signal if some 
OOB stream portion does not have the spike shown above. If 
this is the case, the tester should try to rerun the test again.  

 Changed Device name selection: 
o “Drive”: equivalent to “Target” in SAS terminology 
o “Host”: equivalent to “Initiator” in SAS terminology 

 Fixed HTML Report Test Header, removed PulseGen Report Header Field 

 Removed OOB configure variables in configure tab that are no longer 
relevant after major OOB trigger change. 

 Maximum Noise during OOB Idle Time Test in “IR & CR Device Test Point” 
now using the same algorithm as Maximum Transmitter Device Off Voltage 
Test. 
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Recommendations: 
 

 For “OOB Signaling Test” group, the user is encouraged to select Pulsegen 
“Yes” as priority selection than Pulsegen “No” as this will cover more tests 
and also has maximum 2 stimulus strategy approaches.  
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Agilent N5412A Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412A Software Version 1.51 
Released Date: 17 March 2008 
Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00 
(90000 series)  
File Name: SetupInfSAS0151.exe 
 
Modifications: 
 

 Fixed the issue of application hangs when restoring the oscilloscope settings 
upon exiting the application. 
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Agilent N5412A Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412A Software Version 1.5 
Released Date: 11 Jan 2008 
Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00 
(90000 series)  
File Name: SetupInfSAS0150.exe 
 
Modifications: 
 

 Supports the DSO 90000 series baseline 1.00. 

 Added the OOB signals idle time tests. 

 Fixed the connection diagrams for the OOB and signaling tests. 
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Agilent N5412A Serial Attached SCSI (SAS) Electrical 
Performance Validation & Compliance Software Release 
Notes 
 
 
Agilent N5412A Software Version 1.1 
Released Date: 19 Jan 2006 
Minimum Infiniium Oscilloscope Baseline Version: 04.21 
File Name: SetupInfSASTest0101.exe 
 
Modifications: 
 

 Fixed the timeout issue for the rise/fall/skew Group of Test. 

 Fixed the test description error for the rise/fall/skew Group of Test. 

 Supports the baseline 5.02. 
 
 


