
 

Release Notes 

D9030SATC 

Serial ATA (SATA) 

Compliance Test Software 

Keysight D9030SATC Software Version 1.89.0002 

Released Date: 23 August 2019 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

10.11.04711 (UXR Series) 

6.40.01001 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01890002.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 6.40. 

– Supports Infiniium Oscilloscope Software version 10.11 for UXR-Series oscilloscope. 

– Implements PPKS feature. 

– Compliance application GUI changes in QuickSilver. 

Modification 

– Re-enables COM trigger for non-Gmax scope and remains Infiniiscan trigger for Gmax 

scope. 

Bug Fixes 

– Enhance the histogram measurement on Differential Output Voltage tests. 
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Known Issue 

– Compliance application supports only M8070A system software for M8000 series of BER 

test solutions. 

– There is no license found message when user clicks on Tools->Infiniium->InfiniiSim or 

Precision Prob if InfiniiSim & Precision Prob licenses are not available in the scope. 

Keysight N5411B Software Version 1.88 

Released Date: 27 February 2019 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

10.00.04104 (UXR Series) 

6.30.01102 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01880000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 10.00 for UXR-Series oscilloscope. 

Modification 

– Updated the OOB Tx+ and Tx- single-ended signal mismatch based on amplitude voltage 

(Vamplitude) instead of peak to peak voltage (Vpp) using histogram method.  

– Enhanced Trigger Channel vertical range in Gap Detection Windows OOB tests. 

– Changed triggering method from COMM Trigger to Infiniscan Trigger. 

– Implemented HiSLIP protocol from VXI-11. 

Known Issue 

- Slowness in test time on Differential Output Voltage Tests are noticeable. This is because 

hardware trigger is no longer supported hence software trigger Infiniiscan is implemented 

which will bring the slowness in test time.  

Keysight N5411B Software Version 1.87 

Released Date: 17 October 2018 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 
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Requirements category (e.g., minimum instrument 

software version): 

6.30.00609 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01870000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 6.30. 

– Supports user configurable sampling rate for OOB Gap Detection Windows & Signal 

Detection Threshold Tests remotely via “SampRate_OOBDetectionTest” configuration 

variable. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

Modification 

– Updated the OOB Tx+ and Tx- single-ended signal mismatch based on amplitude voltage 

(Vamplitude) instead of peak to peak voltage (Vpp).  

Keysight N5411B Software Version 1.86 

Released Date: 13 April 2018 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

6.20.00620 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01860000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 6.20. 

– Supports M8020A BIST mode automation by loading the sequence file and pattern file to 

M8020A JBERT. 

o Note: Only N4903B sequence file and pattern file supported (Generated using 

JBIST-GUI) 

– Supports user configurable edge detection threshold voltage mode for OOB response or 

rejects tests via “EdgeDetectionVThreshMode” configuration variable. Please refer to 

Programmer’s Reference for more details (see Help > Remote Interface). 
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Modification 

– Updated the “Pattern Length (Pattern Check)” configuration variable from Debug mode to 

Compliance mode. 

– Updated the PHY-04[c]: Spread-Spectrum Modulation DFDT (Min) and PHY-04[d]: 

Spread-Spectrum Modulation DFDT (Max) tests to informative tests. 

– Updated the “Edge Detection Voltage Threshold (%)” to calculate the edge threshold level 

based on the amplitude of the filtered OOB signal (mode) rather than based on the peak-

to-peak of the filtered OOB signal. 

Bug Fixes 

– Fixed the issue of incorrect result for OOB-06[a], OOB-06[b] Drive Response to COMWAKE. 

Note 

– Keysight recommends running the SATA application with Infiniium user interface disabled. 

Please refer to Online Help for more details (see Help > Contents… > Running Tests > To 

Set the Run Preferences). 

– Keysight recommends the user to remains active for the same session of Remote Desktop 

on the same machine if Remote Desktop is required.   

– Keysight recommends viewing the SATA application’s html report with Internet Explorer. 

Keysight N5411B Software Version 1.85 

Released Date: 21 March 2017 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

6.00.00624 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01850000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 6.00.  

– Supports user configurable stimulus’s Spread Spectrum Clocking (SSC) if SSC is checked 

for N4903B and M8020A JBERT remotely via “PulsegenStimulusSSC” configuration 

variable under debug mode. Please refer to Programmer’s Reference for more details (see 

Help > Remote Interface). 



N5411B Serial ATA (SATA) Compliance Test Software Release Notes 

5 

 

Modification 

– Support both disparity for the LBP test pattern for pattern check. 

Bug Fixes 

– Fixed the OutOfMemoryException error issue during the run of the test or export the HTML 

results. 

– Fixed the issue of the “InfiniiScan trigger not found” error. 

Keysight N5411B Software Version 1.84 

Released Date: 19 September 2016 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

5.70.00707 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01840000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 5.70. 

Modification 

– Removed TSG-17[a]: Gen3 (6 Gb/s) Tx Emphasis test with HFTP and LFTP test pattern. 

Please refer to Serial ATA Technical Proposal TPR_059 and TPR_069 for more details. 

– Updated the TSG-17[b]: Gen3 (6Gb/s) Tx Emphasis test to include CIC by default for 

Gen3i. 

– Updated the following test name: 

o OOB-01[a] : Host Rejects Min Vthresh COMINIT to OOB-01[c] : Host Rejects Min 

Vthresh COMINIT for Gen I and Gen II. 

o OOB-01[a] : Drive Rejects Min Vthresh COMRESET to OOB-01[c] : Drive Rejects 

Min Vthresh COMRESET for Gen I and Gen II. 

o OOB-01[b] : Host Responds to Max Vthresh COMINIT to OOB-01[b/d] : Host 

Responds to Max Vthresh COMINIT. 
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o OOB-01[b] : Drive Responds to Max Vthresh COMRESET to OOB-01[b/d] : Drive 

Responds to Max Vthresh COMRESET. 

– Updated the OOB transmit burst and gap analysis run once instead of twice for the same 

OOB signal.  

Bug Fixes 

– Fixed the SICL error issue in PHY-04: Spread-Spectrum Modulation DFDT with Infiniium 

version 5.70. 

– Fixed the issue of unit interval measurement trend is out of the display grid in PHY-01: 

Channel Speed, FBaud & Unit Interval and PHY-03: Spread-Spectrum Modulation 

Frequency tests if the SSC profile is not consistent. 

– Fixed the issue of incorrect screenshot for the OOB-03: COMRESET/COMINIT and 

COMWAKE Transmit Burst Length tests. 

– Fixed the issue of inconsistence test result for OOB-06: COMWAKE Gap Detection 

Windows tests for Host with ASR. 

Keysight N5411B Software Version 1.83 

Released Date: 5 April 2016 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

5.60.0000 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01830000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 5.60. 

– Supports Infiniium Oscilloscope Software version 5.60 for V-Series oscilloscope. 

– Supports user configurable to enable BIST mode automation for N4903B remotely via 

“BISTModeAutomationN4903B” configuration variable. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface). 
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Modification 

– Updated “OOB Sequence” user configurable to support host DUT that required long idle 

time for DUT response after ASR COMINIT. Please refer to Programmer’s Reference for 

more details (see Help > Remote Interface). 

Bug Fixes 

– Fixed the issue of pattern sequence are not loaded into the N4903B J-BERT for multiple 

trial run when the user the enable BIST mode automation. 

– Fixed the issue of unable to detect COMRESET/COMINIT response from the DUT after 

10us from the stimulus generated COMRESET/COMINIT. 

– Fixed the issue of OOB-02 to OOB-05 tests unable to run with Infiniium version 5.60 and 

above. 

Keysight N5411B Software Version 1.82 

Released Date: 9 November 2015 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

5.50.0035 (90000 Series, 90000 X-Series, 90000 Q-

Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01820000.exe 

New Features 

– Supports TSG-17[b]: Gen3 (6 Gb/s) Tx Emphasis test with MFTP test pattern. Please refer 

to Serial ATA Technical Proposal TPR_069 for more details. 

– Supports user configurable sleep time before the screenshot of the jitter related graph 

plot. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

– Supports Infiniium user interface disabled feature during the run of the test. Please refer to 

Online Help for more details (see Help > Contents… > Running Tests > To Set the Run 

Preferences). 

Modification 

– Updated the test name label for “PHY-02: Frequency Long-Term Stability” to “PHY-02: 

Frequency Long-Term Stability / Accuracy”. 
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– Updated the test name label for “TSG-17: Gen3 (6 Gb/s) Tx Emphasis” test with HFTP and 

LFTP test pattern to “TSG-17[a]: Gen3 (6 Gb/s) Tx Emphasis”. 

Bug Fixes 

– Fixed the display SICL command error when running in Infiniium 4.60 or below. 

– Fixed the InfiniiSim and the InfiniiScan SICL command error when running the SATA 

application without the InfiniiSim or InfiniiScan licenses installed in the Infiniium. 

– Fixed the issue of the selected stimulus tab for Configure Device dialog do not update base 

on the Stimulus selected in the Set Up tab of the SATA Compliance Application.  

– Fixed the issue of Configure Devices dialog does not always stay at the top of the 

application. 

– Fixed the issue stimulus calibration status reset after the Configure Devices dialog reopen. 

– Fixed the issue of elapsed time do not update during the calibration of the N4903N JBERT 

and M8020A JBERT for OOB Signal Detection Threshold Tests. 

– Fixed the issue of M8020A J-BERT trigger configuration warning when the SATA 

Compliance Application controls the M8020A J-BERT stimulus. 

– Fixed the issue of inconsistency font for the html report that included OOB tests. 

– Fixed the issue of missing screenshot in TSG-03: Differential Skew test for x-interface. 

– Fixed the issue of additional display window for TSG-06 [a]: Amplitude Imbalance tests. 

– Fixed the issue of incorrect horizontal display for LBP bit display in TSG-01: Differential 

Output Voltage (Min) test.  

– Fixed the issue of missing line in BER bathtub plot. 

– Fixed the issue of OOB COMWAKE response inconsistent result as the COMWAKE signal is 

out of the display screen. 

Note 

– Keysight recommends running the SATA application with Infiniium user interface disabled. 

Please refer to Online Help for more details (see Help > Contents… > Running Tests > To 

Set the Run Preferences). 
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Keysight N5411B Software Version 1.81 

Released Date: 10 April 2015 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

4.60.0005 (90000 Series, 90000 X-Series, 90000 Q-

Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSATA6G01810000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 5.50. 

– Supports M8020A J-BERT (High Performance Serial BERT) as stimulus source. 

– Supports TSG-17: Gen3 (6 Gb/s) Tx Emphasis test. Please refer to Serial ATA Technical 

Proposal TPR_059 for more details. 

Modification 

– Update the u interface SATA tests available for host device only. 

– Update the test name label for TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests. 

– Update the OOB sequence with D10.2 for OOB-06 COMWAKE Gap Detection Windows 

tests for devices.  

– Remote Interface updated to version 3.40. For more information, see Keysight’s N5452A 

Remote Programming Toolkit (www.keysight.com/find/scope-apps). 

Bug Fixes 

– Fixed the issue of wrong histogram placement in TSG-01: Differential Output Voltage tests 

in Infiniium 5.00 and above. 

– Fixed the issue of unhandled error in TSG-15: Gen3 (6Gb/s) TX Minimum Differential 

Voltage Amplitude (UI=5E6) in Infiniium 5.50 and above. 

– Fixed the issue of error when perform the calibration for OOB-01: OOB Signal Detection 

Threshold tests. 

– Fixed the issue of no full screen jitter plot displayed in the Transmit Jitter tests in Infiniium 

5.00 and above. 

http://www.keysight.com/find/scope-apps
http://www.keysight.com/find/scope-apps
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Agilent N5411B Software Version 1.80 

Released Date: 2 June 2014 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

4.60.0005 (90000 Series, 90000 X-Series, 90000 Q-

Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01800000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 5.00. 

– Supports Infiniium Oscilloscope Software version 4.60.0005 for 90000 Z-Series 

oscilloscope. 

– New Help > Support > Collect Files menu item simplifies collecting files needed by Agilent 

support engineers 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 4.60.0005. 

Agilent N5411B Software Version 1.71 

Released Date: 23 May 2014 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

4.20.0000 (Microsoft Windows XP for 90000 Series, 

90000 X-Series, 90000 Q-Series), 

4.60.0005 (Microsoft Windows 7 for 90000 Series, 90000 

X-Series, 90000 Q-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01710000.exe 

New Features 

– Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document 

Version 0.99b. 

– Supports user configurable OOB sequence with/without D10.2 (Device) or ALIGN (Host) via 

“OOB Sequence” configuration variable under debug mode. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface). 
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– Supports user configurable ISI Filter Leading Bit and Lagging Bit for Transmit Jitter test via 

“ISI Filter Leading Bit” and “ISI Filter Lagging Bit” configuration variables under debug 

mode. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

Modification 

– InfiniiSim now includes new Normalize Gain option. 

– When using BitifEye BIT2100 instrument for switch matrix, now requires minimum firmware 

version: 3.4-1.10. 

– Remote Interface updated to version 2.50. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps). 

Bug Fixes 

– Fixed the issue of the progress window appear in the screenshot of the report. 

– Fixed the issue of unhandled error when running the application in MSO oscilloscope. 

– Fixed the issue of error when performing the calibration for OOB-01: OOB Signal Detection 

Threshold tests. 

– Fixed the issue of missing SSC profile in PHY-03 Spread-Spectrum Modulation Frequency 

tests and PHY-04 Spread-Spectrum Modulation Deviation tests. 

– Fixed the issue of wrong histogram placement in TSG-01: Differential Output Voltage tests 

for Infiniium Oscilloscope Software Version 5.00 and above. 

– Fixed the issue of run error in TSG-03 Differential Skew tests. 

– Fixed the issue of signal clipping in TSG-04 AC Common Mode Voltage tests. 

– Fixed the issue of invalid total jitter limit in TSG-13 Gen3 (6Gb/s) Transmitter Jitter used 

RJ tests. 

– Fixed Connection tab "Suppress" checkbox. 

 Miscellaneous Notes 

– This will be the last version to support Infiniium Oscilloscope Software Version 4.20. 

http://www.agilent.com/find/scope-apps
http://www.agilent.com/find/scope-apps
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 Agilent N5411B Software Version 1.70 

Released Date: 13 December 2013 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

4.20.0000 (Microsoft Windows XP for 90000 Series, 

90000 X-Series, 90000 Q-Series), 

4.60.0005 (Microsoft Windows 7 for 90000 Series, 90000 

X-Series, 90000 Q-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01700000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 4.60.0005 for 90000 Q-Series 

oscilloscope. 

– Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document 

draft version. 

– Supports u interface SATA tests. 

– Supports N4903B BIST mode automation by loading the sequence file and pattern file to 

N4903B JBERT. 

– Supports pattern checking for the input signal via “Pattern Check” configuration variable. 

Please refer to Programmer’s Reference for more details (see Help > Remote Interface). 

– Supports user configurable CDR setting in jitter tests via “Override Default”, “Clock 

Recovery Loop Bandwidth” and “Clock Recovery Damping Factor” configuration variables. 

Please refer to Programmer’s Reference for more details (see Help > Remote Interface). 

– Supports user configurable low pass filter’s bandwidth in OOB tests via “OOB Low Pass 

Filter Bandwidth” configuration variable. Please refer to Programmer’s Reference for more 

details (see Help > Remote Interface). 

– Supports debug feature for OOB-07/08 OOB Gap Detection Windows tests under debug 

mode. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

– User can now suppress connection prompts from the user interface (see Connect tab). 

– If a project opens as Read-Only and there are no settings conflicts with the current version 

of the app, user may use File > Save Project (Settings-Only) As…  menu item to extract the 

configuration (and no results) from that project. 
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– If user creates the folder: 

o (Win7) C:\ProgramData\ Agilent\Infiniium\Apps\<app_name>\app\scripts 

o (WinXP) C:\Documents and Settings\All Users\Application 

Data\Agilent\Infiniium\Apps\<app_name>\app\scripts 

Then menu item File > Execute Script… becomes visible and enables user to pick a file to 

execute (e.g. Python or Visual Basic script). Scripts in this folder may also be executed via 

the Automation tab or remote interface. 

– HTML reports include probe info. 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 4.20.0000 for Window XP 

oscilloscope. 

– Minimum Infiniium Oscilloscope Software updated to version 4.60.0005 for Window 7 

oscilloscope.  

– Application’s project file saved for version 1.65 and below will be opened as read-only. 

– Update the SATA CIC embedding by using InfiniiSim instead of user defined function.  

– Update the test limit for PHY-04 Spread-Spectrum Modulation DFDT tests to +/-1250 

ppm/µs range limit. 

– Update the OOB sequence by adding the D10.2 in the sequence for OOB-06 COMWAKE 

Gap Detection Windows tests devices.  

– Last location when saving/opening/exporting project/ files/etc. will be saved. 

– ARSL scripts supports for .txt file extension. 

– Last Test Date reported using international format. 

– Preserves line breaks for “User Comments” field in HTML report. 

– Includes new Delay option in InfiniiSim. 

– New option to control jump behavior when user double-click a test name on the Select 

Tests tab. See View > Preferences > Report.  

– Remote Interface updated to version 2.40. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps). 

http://www.agilent.com/find/scope-apps
http://www.agilent.com/find/scope-apps
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Bug Fixes 

– Fixed launch on Win7 for non-admin user. 

– Fixed statistics display for items in the Referenced Values section. 

Agilent N5411B Software Version 1.65 

Released Date: 16 July 2013 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

3.21 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01650000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 3.21 for 90000 MSOX -Series 

oscilloscope. 

Agilent N5411B Software Version 1.64 

Released Date: 27 July 2012 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

3.21 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01640000.exe 

New Features 

– Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document 

Version 0.99b. 

– Supports InfiniiSim feature for all PHY tests and TSG tests. InfiniiSim feature can be access 

through the main menu (see Tools > Infiniium > InfiniiSim).  

Modification 

– Update the response detection window in OOB-07 COMINIT /COMRESET Gap Detection 

Windows tests from 10.0μs to 20.0μs. 
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Bug Fixes 

– Fixed the issue of slow measurement in OOB-2/3/4/5 COMINIT/COMRESET/COMWAKE 

Transmit Burst and Gap Length tests for Infiniium Oscilloscope Software Version 3.50.0001 

and above. 

– Fixed the issue of wrong judgment in OOB-06 COMWAKE Gap Detection Windows tests 

(for non-continuous ALIGN response from the device).  

Agilent N5411B Software Version 1.63 

Released Date: 17 April 2012 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

3.21 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01630000.exe 

New Features 

– Supports for Serial ATA Interoperability Program Revision 1.4.3 Unified Test Document 

Version 1.00. Please refer to the Table 1.63.1 for more details. 

– Supports user configurable enable or disable of the use of SATA CIC via “Use SATA CIC” 

configuration variable. Please refer to Programmer’s Reference for more details (see Help > 

Remote Interface). 

– Supports user configurable frequency window for the TSG-16 Gen3 (6Gb/s) Tx AC 

Common Mode Voltage tests via “FFT Frequency Window, Min” and “FFT Frequency 

Window, Max” configuration variables. Please refer to Programmer’s Reference for more 

details (see Help > Remote Interface).  

Modification 

– Update several tests from mandatory tests to informative tests base on Serial ATA 

Interoperability Program Revision 1.4.3 Unified Test Document Version 1.00. Please refer 

to the Table 1.63.1 for more details. 

– Update the Bandwidth Limit feature for acquisition setup to be available for both 

Compliance Mode and Debug Mode. Bandwidth Limit feature can be access through the 

main menu (see Tools > Infiniium > Acquisition Setup). 
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– Update the default sample size for PHY-01 Channel Speed, FBaud and Unit Interval test 

and PHY-02 Frequency Long-Term Stability from 100,000UI to 200,000 UI (covers at least 

one SSC profile). 

– Update the stimulus differential voltage output of compliance mode in all PHY tests and 

TSG tests to 600mV.  

– Update the test limit for TSG-02 Rise/Fall Time tests base on Serial ATA Interoperability 

Program Revision 1.4.3 Unified Test Document Version 1.00. 

– Remove the “Memory Depth” configuration variable for TSG-16 Gen3 (6Gb/s) Tx AC 

Common Mode Voltage tests. 

Bug Fixes 

– Fixed the issue of incorrect number of histogram hits in TSG-01[b] Differential Output 

Voltage (Max) test. 

– Fixed the issue of ALIGN field detection in OOB-06 COMWAKE Gap Detection Windows 

tests. 

Table 1.63.1 

Before UTD 1.4.3 UTD 1.4.3 

Comments 
Test Name 

Test 

ID 
Test Name 

Test 

ID 

TSG-01[b] : Differential 

Output Voltage (Max) 

(Informative) 

20121 

TSG-01[b] : 

Differential Output 

Voltage (Max) 

(Informative) 

20121 
Change to Informative Test 

in all UTD 

TSG-02[a] : Rise Time 

20211 

TSG-02[a] : Rise Time 

(Informative) 

20231 

Change to Informative Test 

in UTD 1.4.3. 

20212 20232 

20213 20233 

20214 20234 

TSG-02[a] : Fall Time 

20221 

TSG-02[a] : Fall Time 

(Informative) 

20241 

Change to Informative Test 

in UTD 1.4.3 

20222 20242 

20223 20243 

20224 20244 

TSG-03[a] : Differential 

Skew, HFTP 

20311 TSG-03[a] : 

Differential Skew, 

HFTP (Informative) 

20331 
Change to Informative Test 

in UTD 1.4.3 20312 20332 

TSG-13[a] : RJ before 

CIC, MFTP, Clock To 

Data, JTF Defined 

20311 

TSG-13[a] : RJ before 

CIC, MFTP, Clock To 

Data, JTF Defined 

(Informative) 

21312 
Change to Informative Test 

in UTD 1.4.3 

TSG-13[f] : TJ after 21511 TSG-13[f] : TJ after 21517 Change to Informative Test 



N5411B Serial ATA (SATA) Compliance Test Software Release Notes 

17 

 

CIC, HFTP, Clock To 

Data, JTF Defined 

(BER=1E-12) 

CIC, HFTP, Clock To 

Data, JTF Defined 

(BER=1E-12) 

(Informative) 

in UTD 1.4.3 

TSG-13[g] : TJ after 

CIC, HFTP, Clock To 

Data, JTF Defined 

(BER=1E-6) 

21513 

TSG-13[g] : TJ after 

CIC, HFTP, Clock To 

Data, JTF Defined 

(BER=1E-6) 

(Informative) 

21517 
Change to Informative Test 

in UTD 1.4.3 

- - 
TSG-04 : AC Common 

Mode Voltage, HFTP  
20412 

New test added in UTD 

1.4.3 for 3.0Gb/s 

- - 
TSG-04 : AC Common 

Mode Voltage, MFTP  
20423 

New test added in UTD 

1.4.3 for 6.0Gb/s 

- - 
TSG-04 : AC Common 

Mode Voltage, HFTP  
20424 

New test added in UTD 

1.4.3 for 6.0Gb/s 

Agilent N5411B Software Version 1.62 

Released Date: 2 February 2012 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

3.21 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01620000.exe 

New Features 

– Supports user selectable Serial ATA Interoperability Program Unified Test Document, e.g. 

UTD 1.1, UTD 1.2. UTD 1.3, UTD 1.4, UTD 1.4.1, UTD 1.4.2 and UTD 1.4.3. Please refer to 

each of the Serial ATA Interoperability Program Unified Test Document for more tests 

details. 

– Supports User-Defined Compliance Limits feature for user to select, edit and create tests 

limit. User-Defined Compliance Limits feature can be access through the main menu (see 

Tools > Compliance limits).  

– Supports Bandwidth Limit feature for acquisition setup for all PHY tests and TSG tests 

under Debug Mode. Bandwidth Limit feature can be access through the main menu (see 

Tools > Infiniium > Acquisition Setup).  

– Supports Precision Probe and Precision Cable feature. Precision Probe and Precision Cable 

feature configuration setup can be accessed through the main menu (see Tools > Infiniium 

> PrecisionProbe/PrecisionCable). 
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– Remote interface help and PDF files can be accessed through the main menu (see Help > 

Remote Interface).  

– New ‘Automation’ tab enables you to create command scripts that modify settings and 

execute tests.  

– New user preference to set default project location (Menu: View > Preferences > 

Save/Load: Default Location). 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 3.21. 

– Update the test name base on the naming in Serial ATA Interoperability Program Unified 

Test Document. Please refer to each of the Serial ATA Interoperability Program Unified 

Test Document for more tests details. 

– Update the test limit for PHY-04 Spread-Spectrum Modulation DFDT tests from +/- 1200 

ppm/µs range limit to +/-1250 ppm/µs range limit. 

– Update the maximum test limit for TSG-02 Rise/Fall Time tests for 6Gb/s from 68ps to 

80ps. Please refer to ECN053 for more details. 

– Update the analysis bandwidth for TSG-04 AC Common Mode Voltage to low end at 

200MHz and high end at 4.5GHz for UTD 1.4.2. 

– Update the eye height measurement location for TSG-15 Gen3 (6Gb/s) TX Minimum 

Differential Voltage Amplitude tests from [0.45, 0.55] UI location to 0.50 UI location. 

– Update the test limit for OOB-03 COMINIT/COMRESET and COMWAKE Transmit Burst 

Length from [Min = 103.5ns, Max = 109.9ns] to [Min = 103.5ns, Max = 110.9ns] for UTD 

1.4.1 and above. 

– Update the test limit for OOB-05 COMWAKE Transmit Gap Length from [Min = 103.5ns, 

Max = 109.9ns] to [Min = 102.4ns, Max = 109.9ns] for UTD 1.4.1 and above. 

– PrecisionProbe dialog screens now have tooltips and remote hints.  

– A calibration creation wizard is added to the PrecisionProbe dialog box.  

– Remote Interface updated to version 2.00. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps). 

http://www.agilent.com/find/scope-apps
http://www.agilent.com/find/scope-apps
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Bug Fixes 

– Fixed the issue of error in TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage 

Amplitude tests. 

– Fixed the issue of triggering alogorithm in OOB-2/3/4/5 COMINIT/COMRESET/COMWAKE 

Transmit Burst and Gap Length tests. 

– Fixed the issue of file not found in OOB-01 OOB Signal Detection Threshold tests. 

– Fixed app startup under Windows Standard User login. 

Agilent N5411B Software Version 1.61 

Released Date: 30 September 2011 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument 

software version): 

3.10 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01610000.exe 

New Features 

– Supports for Window 7 Infiniium oscilloscope. 

Agilent N5411B Software Version 1.60 

Released Date: 12 August 2011 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

3.10 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 

File Name: SetupInfSATA6G01600000.exe 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 3.10. 

– Update the test methodology for TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage 

Amplitude tests. Please refer to ECN050 for more details. 

– Update the test ID for several tests. Please refer to the Table 1.60.1 for more details. 
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o Merge test ID: Old tests ID are auto substitute by the application to ensure 

backward compatible. 

▪ 20112, 20113, 20114 -> 20111 

▪ 20122, 20123, 20124 -> 20121 

o Split test ID: Old tests ID are split into several test ID. 

▪ 20115 -> 20115 for drive DUT and 20116 for host DUT 

Bug Fixes 

– Fixed the issue of incorrect termination mode from 50 ohm termination to 25 ohm 

termination in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage at 3GHz tests.  

o FFT_dBmV_3GHz = FFT_dBm_3GHz  + 43.9794 

– Fixed the issue of incomplete number of acquisition hits for histogram in TSG-01 

Differential Output Voltage tests for Gen1 and Gen2.  

Table 1.60.1 

Old Test ID New Test ID Notes 

20112 20111 Merge to test ID 20111 

20113 20111 Merge to test ID 20111 

20114 20111 Merge to test ID 20111 

20122 20121 Merge to test ID 20121 

20123 20121 Merge to test ID 20121 

20124 20121 Merge to test ID 20121 

20115 
20115 Split from test ID 20115 

 20115 for drive DUT 

20115 for host DUT 20116 

Agilent N5411B Software Version 1.50 

Released Date: 11 February 2011 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

3.03 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

6.80 
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File Name: SetupInfSATA6G01500000.exe 

New Features 

– Supports N4903B J-BERT (High Performance Serial BERT) as stimulus source. 

o The calibration procedure for J-BERT does not require the use of attenuator. The 

calibration might not work well if attenuators are added to the connections. 

– Supports jitter measurement at 1E-12 and 1E-6 for Gen1, Gen2 and Gen3. 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 3.03. 

– Update the stimulus calibration routine GUI to improve the calibration. 

– Update the Set Up tab GUI to improve the use model. “SSC”, “ASR” and “BIST Mode” 

options are group under “Capabilities” of the DUT. 

– Update the configuration variable. Please refer to Programmer’s Reference for more details 

(see Help > Remote Interface). 

o “HostASR” configuration variable supports “1.0” (checked) and “0.0” (unchecked) 

options. 

o  “BISTMode” configuration variable supports “BIST-L” and “BIST-T” options. (This 

configuration variable replaced “TPSource” configuration variable ) 

o “OptConnection” configuration variable supports “none”, “PPG_IP”, “PPG_Sicl”, 

“JBERT_IP” and “JBERT_Sicl” options.  

– Update the application to not uncheck the selected tests in Select Test tab when select 

Debug mode. 

– Update the stimulus single-ended voltage output of compliance mode in all PHY tests and 

TSG tests to 600mV.  

– Update the test methodology to disable averaging for in TSG-16 Gen3 (6Gb/s) Tx AC 

Common Mode Voltage tests. 

– Update the OOB test verification to accommodate changes in the Infiniium Oscilloscope 

Software. 

– Update the COMWAKE response gap length from 155 UI and 165 UI to 153 UI and 167 UI 

in OOB-06 COMWAKE Gap Detection Windows tests for UTD 1.4.1 and above. 
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Bug Fixes 

– COMWAKE minimum and maximum response test for host with ASR enabled: Previously 

there is an issue of some hosts treating the COMINIT from the stimulus instrument to be an 

unsolicited COMINIT sometimes with a certain probability, which results in an initial 

COMRESET reply from host instead. In this version, the app will now retry 10 times to re-

fire the stimulus instrument (81134A or N4903B) to get an initial COMWAKE, whereby from 

the host’s perspective, is supposed to be an in reply to a solicited COMINIT from the 

stimulus instrument.     

Miscellaneous Notes 

– Please ensure the memory depth for the Infiniium oscilloscope is at least 25.0Mpts to 

ensure proper run of the compliance tests. 

Agilent N5411B Software Version 1.30 

Released Date: 20 September 2010 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

2.51 (90000 Series), 

2.95 (90000 X-Series) 

File Name: SetupInfSATA6G01300000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 2.95 for 90000 X-Series oscilloscope. 

– Supports user configurable RJ bandwidth of either Wide (White) or Narrow (Pink) for the 

jitter tests. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface).  

– Supports jitter measurement at 1E-12 (default) and 1E-6 (informative) for Gen1, Gen2 and 

Gen3. 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 2.51 for 90000 Series 

oscilloscope. 

– Default the response for BIST-T and BIST-L dialog when the message box suppression is 

enabled. 

– Update the TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests. TSG-13 Gen3 (6Gb/s) 

Transmitter Jitter tests consists of the following tests: 
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o RJ Before CIC 

o TJ Before CIC HFTP, using RJ  

o TJ Before CIC LBP, using RJ 

o TJ after CIC HFTP, using RJ 

o TJ after CIC LBP, using RJ 

o TJ 1E12 after CIC HFTP 

o TJ 1E6 after CIC HFTP 

o TJ 1E12 after CIC LBP 

o TJ 1E6 after CIC LBP 

Bug Fixes 

– Fixed the issue of slow loading for Far End Retimed connection diagram. 

– Fixed the issue of missing Periodic/Arbitrary selection in Configure tab for jitter tests. 

– Fixed the issue of missing MFTP test when Pulsegen Usage = “No” and SSC = “Yes” 

– Fixed the issue of incorrect termination mode from 50 ohm termination to 25 ohm 

termination in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests at 6GHz.  

o FFT_dBmV_6GHz = FFT_dBm_6GHz + 43.9794 

Agilent N5411B Software Version 1.20 

Released Date: 22 January 2010 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.71 (80000 Series), 

2.10 (90000 Series) 

File Name: SetupInfSATA6G01200000.exe 

New Features 

– Supports user configurable jitter BER level for the jitter tests. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface).  

– Supports jitter measurement at 1E-12 (default) and 1E-6 (informative) for Gen1, Gen2 and 

Gen3.  
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Modification 

– Minimum Infiniium Oscilloscope Software updated to version 2.10 for 90000 Series 

oscilloscope. 

– Update the report fields for jitter tests to include DCD value (informative). The DCD value 

does not affect overall jitter tests results. 

Miscellaneous Notes 

– This will be the last version to support 80000 Series oscilloscope. 

Agilent N5411B Software Version 1.11 

Released Date: 21 December 2009 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.71 (80000 Series), 

2.01 (90000 Series) 

File Name: SetupInfSATA6G01110000.exe 

Bug Fixes 

– Fixed the issue of unable to run OOB-01 OOB Signal Detection Threshold tests with non-

debug mode calibration. 

Agilent N5411B Software Version 1.10 

Released Date: 23 November 2009 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.71 (80000 Series), 

2.01 (90000 Series) 

File Name: SetupInfSATA6G01100000.exe 

New Features 

– Supports BIST-L loopback mode for Gen3i DUT. 

– Supports TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage Amplitude tests for Gen3i 

DUT. 

– Supports debug mode for OOB-01 OOB Signal Detection Threshold tests by sweeping 

down the differential voltage level of the stimulus from a defined voltage level to the 

voltage level where the first rejection or no response encountered. 
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Modification 

– Minimum Infiniium Oscilloscope Software updated to version 5.71 for 80000 Series 

oscilloscope. 

– Minimum Infiniium Oscilloscope Software updated to version 2.01 for 90000 Series 

oscilloscope. 

– Update the CIC S parameter file from SATA_Gen3i CIC.txt or SATA_Gen3m_CIC.txt files to 

standardized SATA_CIC_Spec.s4p file. 

– Update the configuration variable. Please refer to Programmer’s Reference for more details 

(see Help > Remote Interface). 

o “Jitter_DataLength” and “Jitter_PatternMode” configuration variables are asserted 

when “OverrideJitterDefault” configuration variable is “ENABLED” in debug mode.  

o “Jitter_DataLength” configuration variable moved to debug mode. 

o “DifferentialSkew_RetrialGlitch” configuration variable is added. 

o Redefinition and addition configuration variables:  

▪ “VthreshDebugResponsetoInconsistent” 

▪ “VthreshDebugResponsetoInconsistentStartVdiff” 

▪ “VthreshDebugInconsistentToReject” 

▪ “VthreshDebugInconsistentToRejectStartVdiff” 

– Update the threshold level for all PHY tests and TSG tests to use threshold at 0V with 

hysteresis +/- 10mV, except TSG-02 Rise/Fall Time tests. 

– Update the algorithm for the jitter tests. 

o Infiniium Oscilloscope Software update algorithm for the jitter separation to 

improve the measurement accuracy. 

o Infiniium Oscilloscope Software increases the memory depth of 2.048Mpts for 

arbitrary mode jitter separation. 

o Update the configuration variables for the jitter test with details descriptions. 

– Update the test methodology in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests 

at 3GHz and 6GHz to allow peak to peak measurement from -5350 ppm to 350 ppm. 
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– Update the vertical markers measurement boundary to +/-2 UI centered at the trigger in 

TSG-14 Gen3 (6Gb/s) TX Maximum Differential Voltage Amplitude tests. 

– Update the measurement details for TSG-15 TX Minimum Differential Voltage Amplitude 

tests.  

o Eye Height = (Vtop_mean – 3 Vtop_stddev) – (Vbase_mean – 3 Vbase_stddev) 

– Update the sampling rate for OOB-01/06/07 OOB Signal Detection Threshold and OOB 

Gap Detection Threshold tests to 10GSa/s to preserve better signal integrity prior the low 

pass filter. This will also enhance OOB signal response detection accuracy and precision.  

Agilent N5411B Software Version 1.02 

Released Date: 24 April 2009 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.60 (80000 Series), 

1.40 (90000 Series) 

File Name: SetupInfSATA6G01020000.exe 

Modification 

– Update the test methodology for TSG-14 Gen3 (6Gb/s) TX Maximum Differential Voltage 

Amplitude tests to use acquisition averaging instead of histogram peak to peak (worst case 

amplitude). 

Bug Fixes 

– Fixed the issue of conversion in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests 

by reporting the value in unit of “dBmV” instead of “dBm” in HTML report. 

– Fixed the issue of total jitter value in TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests by 

reporting the total jitter value extracted directly from the EZJIT jitter result panel. 

Agilent N5411B Software Version 1.01 

Released Date: 16 March 2009 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.60 (80000 Series), 

1.40 (90000 Series) 

File Name: SetupInfSATA6G01010000.exe 
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Bug Fixes 

– Fixed the issue of loop bandwidth error in jitter tests for Gen1 and Gen2. 

Agilent N5411B Software Version 1.00 

Released Date: 9 February 2009 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.60 (80000 Series), 

1.40 (90000 Series) 

File Name: SetupInfSATA6G01000000.exe 

New Features 

– Supports user configurable RJ bandwidth of either Wide (White) or Narrow (Pink) for the 

jitter tests. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface).  

– Supports Gen3i tests for BIST-T mode: 

o Channel Speed, FBaud & Unit Interval 

o Frequency Long Term Stability 

o TX Differential Voltage Test ( Maximum) 

o TX Rise/Fall Time 

o TX Differential Skew 

▪ HFTP 

▪ MFTP 

o TX AC Common Mode Voltage 

o TJ & DJ at Connector, Clk-Data 

▪ RJ before CIC 

▪ TJ before CIC, HFTP 

▪ TJ before CIC, LBP 

▪ TJ after CIC, HFTP 

▪ TJ after CIC, LBP 
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– Supports user configurable threshold level for OOB-01/06/07 OOB Signal Detection 

Threshold and OOB Gap Detection Threshold tests to allow manual adjustment when 

default threshold level touches the low passed filter ripples. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface).  

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 5.60 for 80000 Series 

oscilloscope. 

– Minimum Infiniium Oscilloscope Software updated to version 1.40 for 90000 Series 

oscilloscope. 

– Application’s project file saved for N5411A SATA II application will not be able to open 

using N5411B SATA6G application. Please use the internet browser to load the old report 

file. 

– Update the Matlab MCR to Matlab 7.5. 

– Expanded UTD required patterns on the Select Test tab:  

o Test pattern options are removed for these tests. 

– Added cancel button to abandon the calibration request on the calibration dialog box. 

– Update the message box for BIST-T mode to display once for the same test pattern. 

– Update the sampling rate for spread-spectrum clocking tests sampling rate for 90000 

Series oscilloscope to 40GSa/s and 80000 Series oscilloscope to 20GSa/s. 

– Update the limit for memory depth rate for spread-spectrum clocking tests for 90000 

Series oscilloscope to 10Mpts to provide safety margin to match the with the memory 

analysis limitation in Infiniium software. 

– Update the test pattern for TSG-02 Rise/Fall Time to LFTP with 8 UI on screen.  

– Update the reporting variables in TSG-03 Differential Skew tests to non-absolute values 

for debugging purpose (“Tx+ Rising to Tx- Falling” and “Tx+ Falling to Tx- Rising”). 

However the final compliance result formula still remains the same as intended by SATA-

IO:  

o Differential Skew = average(abs[(mean(TX+ rising)) – (mean(TX- falling))] + 

abs[(mean(TX+falling)) – (mean(TX- rising))]) 

– Update the methodology and test point for x interface DUT in jitter tests from “at 

connector” algorithm to “after CIC” algorithm. 
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– Update the Differential Output Voltage tests: 

o Update the reporting statistics redundancy 

o Update the histogram location from 0.5 UI to 0.45 UI - 0.55 UI for Gen1. 

o Fix the issue of inaccurate timebase for LBP waveform  

– Remove the DC Coupled Common Mode Voltage test.  

Bug Fixes 

– Fixed the issue of timebase accuracy for x interface DUT in TSG-06 Amplitude Imbalance 

tests. 

– Fixed the issue of smearing in OOB OOB tests with 2GSa/s sampling rate limitation when 

interpolation is turned off.  

Known Issues 

– In some very rare cases of OOB Transmit Burst and Gap Length tests, the desired COMINIT 

and COMWAKE bursts are not easily captured (the probability of capturing is low) by using 

automation due to OOB response inconsistencies. In such cases, the user should opt for 

manual testing or retry manually.  

Agilent N5411A Software Version 2.60 

Released Date: 7 November 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.50 (80000 Series), 

1.30 (90000 Series) 

File Name: SetupInfSATAII02600000.exe 

New Features 

– Supports SSC Optimization Memory Buffer for the last SSC acquisition (if required) 

– Supports the Asynchronous Signal Recovery (ASR) for host DUT response 

COMRESET/COMINIT/COMWAKE Gap Detection Windows tests and OOB Signal Detection 

Threshold tests. 

– Supports debug mode for OOB Signal Detection Threshold tests by sweeping down the 

differential voltage level of the stimulus from a upper voltage level (Vthresh = 210mV) to 

the voltage level where the first rejection or no response encountered. 
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Modification 

– Minimum Infiniium Oscilloscope Software updated to version 5.50 for 80000 Series 

oscilloscope. 

– Minimum Infiniium Oscilloscope Software updated to version 1.30 for 90000 Series 

oscilloscope. 

– Update the configuration variable. Please refer to Programmer’s Reference for more details 

(see Help > Remote Interface). 

o “VthreshDebugResponsetoInconsistent” configuration variable is added. 

o “HostASR” configuration variable is added. 

o “DebugAmplitudeImbalance” configuration variable is added. 

– Enhanced the OOB signal calibration acquisition to 100 acquisitions average for every 

calibration target pair in 90000 Series oscilloscope.  

– Split the Spread Spectrum Modulation Deviation into two tests: 

o Spread Spectrum Modulation Deviation (Max) 

o Spread Spectrum Modulation Deviation (Min) 

– Split the Amplitude Imbalance test into two tests: 

o Amplitude Imbalance HFTP 

o Amplitude Imbalance MFTP 

– Update the test methodology for Amplitude Imbalance tests to Real Time Eye 

implementation test for better match with SATA-IO measurement definition and faster 

execution speed. 

– Enhanced the comments field information for COMRESET/COMINIT/COMWAKE Gap 

Detection Windows tests and OOB Signal Detection Threshold tests in the HTML report. 

Bug Fixes 

– Fixed the issue of dialog box mismatch with the windows resolution of 640×480 for 80000 

Series oscilloscope during calibration. 

– Fixed the issue of Advanced Communication Trigger not found error for the single ended 

signals which is approximately below 200Vpp during the setup for any PHY tests or TSG 

tests. 
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– Fixed the issue of change connection dialog box hidden behind the SATAII application 

during OOB-01 OOB Signal Detection Threshold tests. 

– Fixed the low pass filter smearing issue for COMRESET/COMINIT/COMWAKE Gap 

Detection Windows tests and OOB Signal Detection Threshold tests by adding tolerance 

for burst, gap and align length as a workaround.  

Known Issues 

– Supports the 54855 and 80000A Series oscilloscope with limitation for the 

COMRESET/COMINIT/COMWAKE Gap Detection Windows tests and OOB Signal Detection 

Threshold tests due to the graphics limitation of older oscilloscope hardware.  It is 

recommended to use the 80000B Series or 90000 Series oscilloscopes with 12GHz and 

above bandwidth.  

– In some very rare cases of OOB Transmit Burst and Gap Length tests, the desired COMINIT 

and COMWAKE bursts are not easily captured (the probability of capturing is low) by using 

automation due to OOB response inconsistencies. In such cases, the tester should opt for 

manual testing. 

– In some very rare cases of COMRESET/COMINIT/COMWAKE Gap Detection Windows tests 

and OOB Signal Detection Threshold tests, especially ‘Responds to in-spec COMWAKE’ 

measurement, it is difficult to determine a valid response by using automation due to the 

differences in SATA product behavior. In such cases, the tester should opt for manual 

visual verification. This control is located in the N5411A application Configure tab, and is 

called “OOB Gap and Vthresh Detection Mode”.  Select ‘Manual’.  This will allow the tester 

to determine either PASS or FAIL per the specification’s requirement and mark the 

measurement correctly.  This is not the default mode. 

Agilent N5411A Software Version 2.52 

Released Date: 30 May 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.40 (80000 Series), 

1.20 (90000 Series) 

File Name: SetupInfSATAII02520000.exe 

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 1.20 for 90000 Series 

oscilloscope. 

– Removed the long/short patterns configuration variable option in the Configure tab. 
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– Removed the additional COMRESET options in Configure tab. 

– Moved the ‘#aligns’ option from compliance mode to debug mode in the Configure tab. 

– Update the application to allow the use of either 2*10dB attenuators or 2*20dB 

attenuators in the OOB signal calibration. 

– Added retries to the Tx Differential Voltage tests in the event when the trigger fails in the 

BIST-T mode. 

– Added filtering to the glitches in Differential Skew tests at certain parallel edges which 

results to double UI reporting (e.g. 666ps). 

– Enhanced the AC Common Mode Voltage test to be more robust in handling high AC 

common mode spikes. 

– Update the reset DUT message box for the OOB tests of host DUT. 

– Increased the number of images that can be reported to the maximum of 25 images. 

Bug Fixes 

– Fixed the issue of missing MWArray.dll for Differential Skew tests. 

– Fixed the issue of pulse pattern generator SICL address unable to close during certain 

sequences. 

– Fixed the issue of incorrect trigger for OOB tests by increasing the default OOB trigger 

level to avoid triggering during power-up glitches. 

– Fixed the issue of display inconsistency for “Set DUT to OOB Mode” message box. 

– Fixed the issue of missing calibration information for OOB Signal Detection Threshold tests. 

Agilent N5411A Software Version 2.51 

Released Date: 29 February 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.40 (80000 Series), 

1.00 (90000 Series) 

File Name: SetupInfSATAII02510000.exe 

Modification 

– Modified the connection diagram display logic to match the new attenuator configuration 

requirements. 
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– Modified from previous implementation of: two 10dBs or four 10dBs attenuator (as 

illustrated in the calibration diagram) to two 20dBs attenuator for Gen1 host/drive OOB 

Signal Detection Threshold tests using attenuators checkbox is removed. 

– Modified the drive OOB Signal Detection Threshold tests calibration procedure to use 

amplitude voltage (VAmpt) measurement on one OOB Burst instead of peak to peak (Vpp) 

measurement to take the corresponding voltages between the oscilloscope and pulse 

pattern generator.  

– Modified the Long Term Frequency Accuracy tests to acquire the maximum SSC cycles in 

maximum memory available. The algorithm is generic to 80000 Series and 90000 Series 

oscilloscope. 

– Modified the Differential Skew test to Matlab implementation, where InfiniiScan is no 

longer required. The previous implementation uses the InfiniiScan whenever available. 

– Provided workaround on the DUTs that show trigger error messages and report unfound 

signal when the histogram is turned on for 90000 Series oscilloscope. 

Bug Fixes 

– Fixed the issue of inconsistent results in Differential Skew tests. 

Agilent N5411A Software Version 2.50 

Released Date: 11 January 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.40 (80000 Series), 

1.00 (90000 Series) 

File Name: SetupInfSATAII02500000.exe 

New Features 

– Supports Infiniium Oscilloscope Software version 1.00 for 90000 Series oscilloscope. 

– Supports for Serial ATA Interoperability Program Revision 1.2 Unified Test Document 

Version 1.00.  

– General Specifications and Transmitted Signal Requirements: 

o Added periodic mode option for the Jitter Tests in the debug mode.  

o Added Long Term Frequency Stability Test for the Non-SSC Tests 
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o Dynamic Test Pattern Generation with alignment to improve the Loopback 

functionality 

o Implemented Fbaud/500 or JTF Loop Bandwidth selection for the Clock to Data 

Jitter Test. This selection is only available for i and m interfaces. Removed the 

Data-Data Jitter Tests. 

– Compliance Test Framework and miscellaneous: 

o ECN 006 - FB10removal 

o ECN 008 - fbaud/500 Jitter Parameter Clarification 

o ECN 016 - Long Term Frequency Accuracy and SSC Profile Tests for Transmitters 

o ECN 017 - OOB Burst/Gap Duration Clarification 

o Supports the Remote Interface Control 

o Calibration and attenuators usage options: 

▪ With attenuators, all tests are available. Calibration factors which are 

generated by performing the calibration will be required. 

▪ Without attenuators, the OOB Signal Detection Threshold tests will be 

hidden.  

Modification 

– Minimum Infiniium Oscilloscope Software updated to version 5.40 for 80000 Series 

oscilloscope. 

– OOB Specifications:  

o Amended the UTD1.2: OOB1 Signal Detection Threshold boundary limits at 40mV, 

210mV for Gen1, and 60mV, 210mV for Gen2 

o Amended the UTD1.2: OOB6, OOB7: 

▪ Implemented a new algorithm for the COMINIT/COMRESET/COMWAKE 

Gap Detection Windows tests. 

o Amended the OOB Burst Length Test Information and Specification to comply with 

UTD1.2 

o Amended OOB Gap Length Test Information and Specification to comply with 

UTD1.2 
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o For Host COMRESET tests, an additional COMINIT is sent to the host after user 

resets the DUT. 

– General Specifications and Transmitted Signal Requirements: 

o Amended the specification range for the TX Differential Skew for Gen2x from 20ps 

to 15ps. 

o Reduced the SSC Measurement test time by  

▪ Disable interpolation 

▪ Sampling Rate = 10GSa/s 

▪ Memory Depth = 1.03Mpts 

o Amended the Amplitude Imbalance Test for the HFTP and MFTP patterns’ 

measurement algorithm.  

▪ For the HFTP, it is required that the measurement points be taken at 0.5UI 

of the bit within the pattern.  All amplitude values for this measurement 

shall be the mode value measured at 0.5 UI nominal over a minimum of 

10,000 UI 

▪ For the MFTP, it is required that the measurement points be taken at 0.5UI 

of the 2nd bit within the pattern.  All amplitude values for this measurement 

shall be the mode value measured at 0.5 UI nominal over a minimum of 

10,000 UI 

o Enhanced the “Sample Size” Configuration Variable to reflect the approximated 

sample size values corresponding to the measured edges. 

o Enhanced the Data Rate and Unit Interval Variables in the Unit Interval Test to be 

able to correlate with each other. 

o Decreased the sampling rate and memory depth for the SSC Tests to reduce the 

test time and also prevent the waveforms from being discarded due to edges not 

found during the SSC Frequency Measurement. 

o Amended the Skew Test Algorithm by using the measured mid point value instead 

of zero value reference to measure the skew. The new algorithm uses Infiniiscan, 

effectively reject the Aligns whenever the Infiniiscan license exists. 

o Amended the Rise/Fall Time measurement to use the mean value instead of the 

mode value. 
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o Improved the Amplitude Imbalance Test reporting. The test reports both HFTP and 

MFTP values instead of just the worst case value. 

– Compliance Test Framework and miscellaneous: 

o Improved the overall connectivity experience of the pulse generator dialog box. 

o Added MultiTrials feature. 

o Amended the pattern files to comply with the latest 81134 pulse generator 

commands. 

o Updated test references to SATA 2.60 Gold. 

o Connection Diagram Updated 

o Differential probe is not needed anymore for OOB Signal Threshold Detection Tests 

Agilent N5411A Software Version 2.01 

Released Date: 18 December 2006 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.00 (80000 Series) 

File Name: SetupInfSATAII02010000.exe 

New Features 

– Supports user configurable output voltage for the 81134A pulse pattern generator under 

debug mode. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface).  

– Supports user configurable SSC smoothing point for the spread-spectrum clocking tests 

under debug mode. Please refer to Programmer’s Reference for more details (see Help > 

Remote Interface).  

– Supports signal checking and verification before test run. 

– Supports trigger verification for basic trigger integrity checking before the test run. 

– Supports Amplitude Imbalance tests. 

– Supports dynamic vertical scaling for OOB tests when using the mask for COM Response 

tests. 
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Modification 

– Updated the connection pages to include the DC blockers into the illustration. 

– Enhanced SSC measurement algorithm to work with DUTs with heavily distorted SSC 

waveform. The algorithm is also enhanced to test and measure multiple SSC if no edges 

are found during the acquisitions.  

– Update the timing for OOB tests. 

– Added boundary limits to the number of UI for OOB tests. 

– Rise/Fall Imbalance with results swapped for Tx- Rise and Tx- Fall. 

– Changed skew measurement technique due to MOI changes. 

– TJ / DJ measurement will report 0UI if the measured TJ / DJ is in the Femto Second 

Range. 

– Gen1 Jitter Description Data-Data was changed to Clock-Data. 

– SSC smoothing point for Gen1 and Gen 2 SSC measurement was updated to 335 and 670 

respectively. 

– Added break for OOB measurement. The previous implementation was using a cancellation 

message box which will prompt for 6 times before the test is canceled. 

– Connection page changed to include COMAX connector labeling. 

– Added checking to allow the usage of Periodic Jitter measurement if the pattern selected 

is short ( 80 bits pattern ) whereas longer patterns will use Arbitrary. 

– The entire host connection page had descriptions mismatched with the illustration. The 

descriptions were updated. 

Bug Fixes 

– Fixed the issue of timeout for Gen 2 Host TJ & DJ tests. 

Agilent N5411A Software Version 2.00 

Released Date: 18 December 2006 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument 

software version): 

5.00 (80000 Series) 

File Name: SetupInfSATAII02000000.exe 
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