
RELEASE NOTES 

 

Keysight D9010UDAA  

User Defined Application 
Keysight D9010UDAA User Defined Application Version 04.20 

Released Date: 1 May 2023 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

10.00 (UXR Series) 

11.05 (MXR Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp04200000.exe 

Additions: 

App Generator 

• Now supports variables in Parse Multiple Values “Use value #” field. 

Generated App 

• Now supports tagging results with arbitrary data (see Run tab). 

• Added user preference to manage double-click jump from Results tab to HTML tab (see 

Preferences :: Display tab). 

• Added remote hints for user preferences. 

• Enabled resetting user preferences to default values. 
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Modifications: 

Application Generator 

• Updated End User License Agreement. 

• Enabled setting the 3rd segment of the Application Version. 

Generated App 

• Updated End User License Agreement. 

• Now supports unlimited number of HTML tables. 

• Improved Messages tab usability. 

• Improved file transfer to socket connections. 

• No longer compatible with Agilent Technologies remote client utility. 
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Keysight D9010UDAA User Defined Application Version 04.10 

Released Date: 1 July 2020 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

10.00 (UXR Series) 

11.05 (MXR Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp04100000.exe 

Additions: 

App Generator 

• Supports compliance apps requiring Add-In Interface versions 4.0 - 4.99. 

• Customizable HTML table caption. 

Generated App 

• Enhanced Automaton Tab, including new control commands. 

• Option to auto-refresh HTML report at end of run. 

Modifications: 

Application Generator 

• Fixes support for Add-In Interface 3.21. 

Generated App 

• Upgradeable even after D9010UDAA support subscription expires. 
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Keysight D9010UDAA User Defined Application Version 04.00 

Released Date: 1 June 2019 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

10.00 (UXR Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp04000000.exe 

Additions: 

App Generator 

• Now supports Add-In development for FlexDCA and InfiniiVision compliance applications 

Generated App 

• Uses new Keysight License Manager-based model D9010UDAA (node-locked, 

transportable, server/floating and USB-Dongle); see the Installation and Setup chapter in 

the Users Guide for details. 

Modifications: 

Application Generator 

• Switch Matrix window: New checkbox for including simulators in generated app installer. 

Generated App 

• Switch Matrix and Repository features are now standard; no additional license required. 
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Keysight N1019A-N5467B/C User Defined Application Version 

03.30 

Released Date: 7 January 2019 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

10.00 (UXR Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp03300000.exe 

Additions: 

App Generator 

• New Reserved Variable for Channel Count 

Generated App 

• Remote Interface supports Pause & Resume 

• Alternative CSV export format now supported (controllable via Menu: View > Preferences). 

• Remote Interface ‘GetResults’ command may now include CSV and MHTML results; ‘

ExportResultsHtmlXxx’ supports exporting an MHTML file; and ‘DefaultInstrument’ 

resets the primary instrument and alerts subsystems in the Tools Menu which only initialize 

after a default. 

• Connection Prompt now beeps (controllable via Menu: View > Preferences). 

Modifications: 

Application Generator 

– (Infiniium-Only) You may now specify separate Infiniium version requirements for 

9000/90000-Series and UXR-Series 

– Now supports Add-In Interface version 3.21 

– Improved instrument discovery performance on large networks 

Generated App 

• Now reports primary instrument version using same formatting as the instrument uses. 
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• Fixed issue affecting 2-Channel UXR-Series scopes. 

• Fixed case: variable being used to provide multiple, numeric csv parameters for a SCPI 

command. 

• Fixed memory leaks. 
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Keysight N1019A-N5467B/C User Defined Application Version 

03.20 

Released Date: 11 October 2018 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

10.00 (UXR Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp03200000.exe 

Additions: 

Added support for N8844A data analytics web service. 

App Generator 

• Tools > Manage > Repository 

• Steps: You may now mark Intermediate Value and Final Result steps as eligible for 

analytics repository upload 

• Configs: You may now mark configs as eligible for analytics repository upload 

Generated App 

• File > Export to Repository 

Modifications: 

Generated App 

– When connecting to a different primary instrument, now checks for compatibility using 

same criteria 

– (FlexDCA only) When you exit the app, it unlocks FlexDCA’s graphical user interface 
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Keysight N1019A-N5467B/C User Defined Application Version 

03.10 

Released Date: 1 October 2017 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

Microsoft Windows 10 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

(InfiniiVision Generated App) Minimum InfiniiVision 

Version: 

7.11 

File Name: SetupInfUserDefApp03100000.exe 

Highlights 

Breaking Change: Add-Ins created by UDA 3.10 may only be installed into Keysight-branded 

compliance apps supporting Add-In Interfaces 2.19 through 3.999 (see compliance app’s menu: 

Help > About to determine compatibility). 

Additions: 

App Generator 

New Project Window 

• New option to create apps targeting InfiniiVision oscilloscopes 

Modifications: 

Generated App 

– User interface updated (dockable tabs, color schemes, integrated message viewer) 

– Remote Interface updated to version 5.51 
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Keysight N1019A-N5467B/C User Defined Application Version 

02.22 

Released Date: 12 August 2015 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp02220002.exe 

Additions: 

App Generator 

Events tab 

• New option to control whether Gen App user will be able to request Infiniium GUI lockouts 

during run (supported by Infiniium 5.50 and newer) 

Modifications: 

App Generator 

Fixed: Use of config variables in conditional predicates (If steps, While steps) 

Fixed: Use of variables in Final Result step image paths 

Fixed: Use of variables in Intermediate Value step image paths 

Fixed: Display Message step Message Type Info now displays with correct type 

Generated App 

– Remote command ExportResultsCsvCustom now creates the destination directory 

– (Infiniium Real-time only) Improved screen shot reliability with scope firmware versions 

5.50 and newer. 

– (Infiniium Real-time only) Fixed remote command: Attempting to turn off PP/PC for a 

channel with no cals now silently completes 



 

 
Keysight D9010UDAA User Defined Application Release Notes 10 / 66 

Keysight N1019A-N5467B/C User Defined Application Version 

02.21 

Released Date: 28 April 2015 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp02210000.exe 

Highlights 

Breaking Change: Removed support for release notes. 

Additions: 

Generated App 

(Infiniium Real-time only) Now disables Infniium GUI during run (except during screenshots); 

improves run-time performance. 

View Menu 

– Preferences: (Infiniium Real-time only) New user preference to override GUI disable 

behavior (View > Preferences > Run). 

 

Modifications: 

Generated App 

– Improved performance with large switch matrices. 

– Installer now completes all prompts before uninstalling previous version 

– Fixed loading of projects containing multi-select configs (test plans) 

– Fixed sorting of reported items in CSV export 

– (Infiniium Real-time only) Improved compatibility with Infiniium Offline 

– (Infiniium Real-time only) Improved startup and shutdown reliability when scope is busy 

– (Infiniium Real-time version 4.60 and older) Fixed multi-trial runs with screen shots. 
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Keysight N1019A-N5467B/C User Defined Application Version 

02.20 

Released Date: 20 January 2015 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp02200000.exe 

Highlights 

Application Generator 

– Generates Keysight-branded applications. 

Breaking Change: Custom math libraries must be recompiled using 

Keysight.N5467X.MathLibraryUtilities.dll and custom text libraries must be recompiled using 

Keysight.N5467X.StringLibraryUtilities.dll. 
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Additions: 

Application Generator 

Steps 

– New “Insert Variable” option: Display config choice’s name or value in a prompt. 

Connections 

– New “Insert Variable” option: Display config choice’s name or value in instructions text. 

Events 

– (Application mode only) New option to reset scope at the start of every run. 

Miscellaneous 

• Added buttons to clear file paths. 

Generated App 

Tools Menu 

– (FlexDCA only) Now supports InfiniiSim-DCA 4-port operations. 

Modifications: 

Application Generator 

– You may now install add-ins into compliance applications that run on a PC. 

Compatibility 

– Supports UDA Add-In Version 2.19. 

Miscellaneous 

– You may no longer specify custom images for the generated app’s splash screen or title 

bar. 

Generated App 

– Supports Remote Interface version 3.40. 

– Splash screen now notifies user if a startup prompt is waiting for attention. 

– Fixed NoScope mode. 

– Fixed AutoIterate permutation sequencing and performance. 

– Improved handling of scopes that are executing CPU-intensive operations when the app 

first connects. 



 

 13 / 66 Keysight D9010UDAA User Defined Application Release Notes 

– (Real-time only) Installed app now automatically connects to Infiniium when running on a 

PC. 

Tools Menu 

– (FlexDCA only) InfiniiSim-DCA is now available outside of switch matrix contexts 
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Agilent N1019A-N5467B/C User Defined Application Version 02.00 

Released Date: 4 June 2014 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series, 

Z-Series), 

2.00 (9000 Series, S-Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp02000000.exe 

Highlights 

Application Generator 

– (Real-Time only) Added support for Infiniium version 5.00, both online (Infiniium running on 

scope) and offline (Infiniium running on PC). 

Additions: 

Application Generator 

– Now creates Restore Points that you can revert a project back to. 

Tools Menu 

– (Real-Time Only) Manage > Other Files: you may now include UDF files for multiple 

versions of Matlab MCR, enabling one app to work with all of the corresponding versions of 

Infiniium. 

Steps 

– Display Message: Each message now has a unique identifier to reduce need for remote 

clients to depend on the message text. 

Generated App 

Supports Remote Interface version 2.90. 

Tools Menu 

– InfiniiSim-DCA is now also available for apps that aren’t using Switch Matrix automation. 

The feature now also supports ApplyS2P and RemoveS2P. 

Modifications: 

Application Generator 

– Added productivity enhancements and “unsaved changes” warnings to many dialogs. 

Steps 
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– If / While: You may now include an unlimited number of terms in the predicate. 

Debug Run 

– Fixed: Reserved Variable debug run values are now saved with the project. 

Generated App 

• (Real-Time only) When installing on a PC, registers the generated app with real-time 

Infiniium so it will be accessible via the Analyze menu. 

• (Real-Time only) When launched on a PC, automatically finds and connects to a running 

instance of Infiniium on the PC. 

• (FlexDCA only) Fixed Demo Mode. 



 

 
Keysight D9010UDAA User Defined Application Release Notes 16 / 66 

Agilent N1019A-N5467B/C User Defined Application Version 01.82 

Released Date: 28 March 2014 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-

Series), 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01820000.exe 

Additions: 

Application Generator 

Edit Menu 

• Find… has new option to replace text. 

• Find… has new option to filter results by step type. 

Generated App 

Tools Menu 

• Infiniium > InfiniiSim: New option to disable Automatic Probe Correction 

Tests Tab 

• New step type: Display List Selection enables prompting user to select from a list of items 

Modifications: 

Application Generator 

Configs Tab 

• Fixed bug: Renaming a config now propagates new name to Switch matrix signal path 

definitions 
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Connections Tab 

• Switch Matrix: 

o Enabled single-ended test points to be routed to a diff probe 

o Enabled either side of a diff test point to be routed to either side of a diff probe 

o You can now assign a scope channel to any switch’s output 

o Fixed case of a positive-input test point being diff-probe-paired with different 

negative-input test points in different connections 

Generated App 

Automation 

• Remote interface updated to version 2.70. For more information, see N5452A Remote 

Toolkit version 2.70 release notes. 
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Agilent N1019A-N5467B/C User Defined Application Version 01.81 

Released Date: 6 December 2013 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01810000.exe 

Additions: 

Application Generator 

Tools Menu 

• Manage > Switch Matrix: Added support for these Agilent switch instruments: N8990C-

R46,-R47,-R64,-R70 

Events Tab 

• New ‘New Project Started’ event fires when generated app creates a new project 

Generated App 

• Now automatically reports every multi-select config permutation in each test’s results 

Modifications: 

Generated App 

Breaking Change: Now uses a VXI-11 (non-sockets) or USBTMC driver to control BitifEye BIT2100 

switch (you must upgrade your switch to firmware version 3.4-1.10 or newer) 

Select Tests Tab 

• Fixed completion indicators for apps having one or more multi-select configs 
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Agilent N1019A-N5467B/C User Defined Application Version 01.80 

Released Date: 15 November 2013 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01800000.exe 

Highlights 

Optional integrated switch matrix control: 

• Supports instruments from Agilent, BitifEye and Giga-tronics. 

• Add path correction using Infiniium real-time options PrecisionProbe or InfiniiSim, or 

FlexDCA option InfiniiSim DCA. 

• Instrument simulators included to support development and testing. 

Automatically execute tests over a range of config variable settings. 

Additions: 

Application Generator 

Edit Menu 

• New Find menu option to search only test steps 

Tools Menu 

• New Manage > Switch Matrix menu 

• New Options > Generated App > Use Simulators option 

Config Tab 

• Editor: New “reset connection” option 

• Editor: New “allow multi-select” option 

Connections Tab 

• Editor: New option to define signal paths for switch matrix control 

Events Tab 
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• New Permutation event fires as multi-select configs cycle through choices 

Generated App 

Tools Menu 

• New Switch Matrix menu (when app designed to control switch matrix) 

o Requires option: N5467B/C-7xx (Infiniium real-time) or N1010A-7xx (FlexDCA) 

Setup Tab 

• New permutation management tabs (when app designed to allow multi-select configs) 

Modifications: 

Application Generator 

You may no longer create Add-Ins that target compliance apps supporting only Add-In Interface 

1.0. 

Tools Menu 

• Options > Launch items moved to new Generated App tab. 
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Agilent N1019A-N5467A User Defined Application Version 01.76 

Released Date: 11 October 2013 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01760000.exe 

Additions: 

Application Generator 

Tools Menu 

• Option > Miscellaneous: New option to preserve the generated app's In-Tool Launch 

documents directory (default project location). 

Set Up Tab 

• New external instrument option to disconnect from the instrument during In-Tool Launch 

(useful for externals such as Agilent VSA which only allow one client connection at a time). 

Steps 

• DisplayMessage step now has a "Browse Button" option in the AskForData group so you 

can prompt user for a file location. 

Modifications: 

Application Generator 

Connections Tab 

• When you add a connection alternative value, the tool no longer automatically prepends 

the name of the connection. 

• You may embed spaces in a connection alternative value. 
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Steps 

• Fixed use of 'Launch External App' step in a While loop. 

• Added more error checking to Text expressions. 

Math Library 

• Fixed: Math:WorstForRange(Double,Double,Double[]) may return wrong value 

Debug Run 

• When you start a Step Debugger session, the tool now automatically sets the 

Reserved_OtherFilesDir variable 

• In-Tool Launch from PC: When you exit the generated app it now prompts you to restore 

the scope's previous setup. 

• Fixed: Parse Multiple Values when parse characters = space plus any other characters 

• Fixed bug: After defining external instrument with wrong "sockets" setting and trying to 

connect, failed to allow you to change the "sockets" setting until you restarted the tool. 

Generated App 

(FlexDCA only) Removed DefaultSetup command that was executing before the start of every run. 

Fixed uninstaller.  

Note: To manually remove a generated app, delete these directories from the machine where the 

app is installed: 

(FlexDCA App, WinXP) 

C:\Documents and Settings\All Users\Application Data\Agilent\FlexDCA\Apps\User 

Defined\<appname> 

C:\Program Files\Agilent\FlexDCA\Apps\User Defined\<appname> 

(FlexDCA App, Win7) 

C:\ProgramData\Agilent\FlexDCA\Apps\User Defined\<appname> 

C:\Program Files (x86)\Agilent\FlexDCA\Apps\User Defined\<appname> 

(Infiniiium App, WinXP) 

C:\Documents and Settings\All Users\Application Data\Agilent\Infiniium\Apps\User 

Defined\<appname> 

C:\Program Files\Agilent\Infiniium\Apps\User Defined\<appname> 

(Infiniium App, Win7) 

C:\ProgramData\Agilent\Infiniium\Apps\User Defined\<appname> 

C:\Program Files (x86)\Agilent\Infiniium\Apps\User Defined\<appname> 
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Agilent N1019A-N5467A User Defined Application Version 01.75 

Released Date: 7 May 2013 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01750000.exe 

Additions: 

Application Generator 

File Menu 

• Export Definitions: Exports a summary of key aspects (steps, variables) of the project. 

Tools Menu 

• Manage > Text Libraries: Added FormatNumber function. 

Events Tab 

• Added “App Shown – Demo Mode” event to execute steps when generated app is started 

in “no scope” demo mode. 

Modifications: 

Application Generator 

On launch, warns user if their PC's current regional settings use a character other than period (.) 

for number decimal. 

Fixed various keyboard shortcuts. 

Fixed screen relocation bug on multi-monitor computers. 

Edit Menu 

• Find: Now finds text in math expressions and in Single SCPI Command steps that target 

external instruments. 

Connections Tab 

• Fixed Connection Alternatives when connection name contains underscore (_) characters. 

Debug Tab 

• Fixed IO with 81134A pulse generators. 
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Generated App 

Fixed memory management when opening large projects with lots of images. 

Fixed intermittent control-related exceptions thrown by Run dialog during very long runs. 
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Agilent N1019A-N5467A User Defined Application Version 01.74 

Released Date: 7 March 2013 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01740000.exe 

Highlights: 

Application Generator 

• You can now search for text you typed in the project (see Edit > Find) 

• You can now transfer files between the scope application and the generated app when 

they are on different machines. 

• You can now include sample results projects, created by your generated app, in your 

installer. 

Additions: 

Application Generator 

Steps 

• Transfer File step: You can now transfer files between the machine the scope application 

(FlexDCA or Infiniium) is running on and the machine the generated app is running on. For 

an add-in, this feature requires Add-In Interface 1.16. 

Miscellaneous Tab 

• You can now include sample results projects, created by your generated app, in your 

installer. 
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Modifications: 

Application Generator 

On launch, warns user if their PC's current regional settings use a character other than period (.) 

for number decimal. 

Fixed various keyboard shortcuts. 

File Menu 

• (Export/Import) Fixed behavior when group-associated connection prompts exist. 

Edit Menu 

• (Find) You can now search for text you typed in the project. 

Tools Menu 

• (Scope Option Requirements) Fixed editing of existing “Required Alternatives” and 

“Optional Alternatives”. 

• (Manage Internal Variables) Fixed variable renaming impact on “Connection Alternatives”. 

Set Up Tab 

• You can no longer assign nickname ‘scope’ to an external instrument. 

Steps 

• Single SCPI Command: Fixed error message when editing existing step after renaming an 

external instrument. 

• If/While steps: Fixed text comparisons when operands contain commas. 

Step Debugger 

• If you execute a single SCPI command that generates more than 1 entry in the 

instrument's error queue, all errors are now read and reported at the same time. 

Connection Prompts 

• Connection Alternative values are now checked to ensure they contain only alphanumerics 

and underscores. 
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Debug Run 

• When opening a project, the tool no longer automatically connects to the saved scope 

address. 

• Projects saved with version 1.74 or newer will not restore Debug Run tab settings when 

opened on a different PC. 

Build 

• "Generate Installer" and "Install Now" are no longer aborted if the tool was unable to 

generate the remote interface help file. 

Generated App 

Installer 

• Now removes _mcr directories for UDFs being installed. 

• (Add-In Only) Fixed installation of "Other" files. 

Everywhere units are specified (limits, results, etc.) they are now separated from the number by a 

space, e.g. 1.5 GHz 

Instrument Connection 

• You may now refer to sockets-based instruments using Visa Aliases and SICL addresses 

with host names or IP address. 

Steps 

• Fixed :SYSTEM:PRESET command when sent to external instruments. 

• Now restores user-specified bandwidth limit (Tools > Infiniium > Acquisition Setup) after a 

LoadMask step executes. 

• If a single SCPI command generates more than 1 entry in the instrument's error queue, all 

errors are now read and reported at the same time. 

Configs 

• Fixed use of config variables whose names are values are numbers and whose values = 

name - 1. 

Tools 

• (Real-Time Only) When using Infiniium 4.20 or newer, checking Tools > Acquistion Setup > 

Enable no longer causes recalculation of existing on-screen measurements. 

Automation 

• SuppressSimpleMessages now suppresses Compliance/Debug mode toggle prompts. 
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HTML Report 

• (Real-Time Infiniium Only): HTML Report now includes probe info. 

• Now supports multi-line user comments. 
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Agilent N1019A-N5467A User Defined Application Version 01.73 

Released Date: 1 December 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 Series), 

1.41 (90000 Series, 90000 X-Series, 90000 Q-Series) 

, 

2.00 (9000 Series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01730000.exe 

Highlights: 

Application Generator 

• Breaking Change: Removed Operation Complete step. Now use new "Query Operation 

Complete" option inside the Single SCPI Command step editor. 

• Infiniium apps may now be enabled for installation on a PC. 

Additions: 

Application Generator 

Tools Menu 

• (Manage > Reserved Variables) New Reserved_XxxAddress (Xxx = Infiniium or FlexDca) 

variable holds the connected scope application’s address. 

Modifications: 

Application Generator 

• Breaking Change: Removed Operation Complete step. Now use new "Query Operation 

Complete" option inside the Single SCPI Command step editor. 

• Added ability to see reference counts and to see and set Debug Run value to more places. 

• Enhanced scope family/firmware minimum/required version cross-checking. 
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File Menu: 

• (Save) No longer tries to save previously-entered custom .html file when connection is 

changed back to "Simple". 

• You may now import fragments into a project that has no tests. 

Tools Menu:  

• Options: Fixed NoScope (Preview) Mode 

• (FlexDCA Only) Added support for Scope Option (86100DU-401) Advanced Eye Analysis 

Tests Tab: 

• Fixed use of channel variables in ApplyTransferFunction step. 

Build Tab: 

• Infiniium apps may now be enabled for installation on a PC. 

DebugRunTab: 

• Connect To Instrument prompt now offers sockets-based connections when appropriate. 

• (Infiniium Real-Time Only) Simplified DebugRun setup requirements when the connected 

scope supports file transfer (Infiniium 4.10 or later). 

Generated App 

• (FlexDCA only) Fixed screen shots when image label contains an apostrophe (‘) 

• (FlexDCA only) Fixed screen shots when N1019A and FlexDCA are running on same 

machine but N1019A is connected to another address. 
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Agilent N1019A-N5467A User Defined Application Version 01.72 

Released Date: 1 October 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series, 90000-X series) , 

2.00 (9000 series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01720000.exe 

Modifications: 

Application Generator 

Setup Tab: 

• Fixed renaming of external instrument nickname. 

Build Tab: 

• Fixed premature build error regarding image full path exceeding 259 characters. 
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Agilent N1019A-N5467A User Defined Application Version 01.71 

Released Date: 1 September 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series, 90000-X series) , 

2.00 (9000 series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01710002.exe 

Additions: 

Application Generator 

SetupTab: 

• You may now execute SetVariable steps when the GeneratedApp’s user selects a test 

group filter on the Set Up tab. 

Generated App 

• New File > Execute Script menu item and automation command enables end users to 

launch arbitrary scripts. 

How To 

• New “How To” topic in User’s Guide describes how to create custom-formatted tests 

results. 

Modifications: 

Application Generator 

File Menu: 

• Now when you open a project that uses Full Path variables in Load Setup/Mask steps and 

Apply Transfer Function steps, you no longer get prompts to export missing files. 

Config Tab: 

• Fixed missing Find References to internal and config vars in various steps 

Generated App 

• You may now suppress prompts during installation using switch: /noprompt 

• AskForData dialog instruction field is now a multi-line, scrollable textbox. 

• (Infiniium Real-Time Only) Restored error text reporting for SCPI commands and queries. 
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Agilent N1019A-N5467A User Defined Application Version 01.70 

Released Date: 20 July 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Infiniium Real-Time Generated App) Minimum 

Infiniium Oscilloscope Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series, 90000-X series) , 

2.00 (9000 series) 

(FlexDCA Generated App) Minimum FlexDCA Version: 1.80 

File Name: SetupInfUserDefApp01700006.exe 

Highlights: 

Application Generator 

• Supports application development for FlexDCA (as model number N1019A). 

• Requires Agilent IO Libraries Suite version 16.2 or newer. 

• (N1019A only) You can now install the  license in a PC-based FlexDCA to enable control of 

any DCA-X. 

• New steps: Default Scope Setup, Transfer External File, HTML Table, Operation Complete. 

Generated App 

• (FlexDCA only) You can now install generated apps on a PC. 

• (Infiniium Real-Time only) Loads as read-only: all test results created by UDA 1.60 or older 

apps. 

Additions: 

Application Generator 

Tools Menu: 

• Manage > Reserved Variables: New variable, "Reserved_DebugMode" equals "True" when 

the app is in Debug mode. 

• Options > Debug: “Maintain” option now split into two options. 

Compatibility Tab: 

• New Add-In Interface Level: 14 

 

SetupTab: 
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• New field for specifying minimum required scope firmware version for your generated 

application. 

Tests Tab: 

• New steps: Default Scope Setup, Transfer External File, HTML Table, Operation Complete, 

Get SCPI Error, Clear SCPI Error Cache. 

• Single SCPI Command: New option to disable automatic SCPI Error checking to manually 

inspect errors. 

• New text compare operators for If and While step predicates: "StartsWith", "EndsWith" and 

"Contains". 

• Intermediate/Final Result steps: New option to disable engineering formatting 

Step Debugger: 

• New 'Return' button to make it clearer how to exit a subroutine or event after you Step In. 

Configs Tab: 

• For user-editable configs, you can now validate what the user enters against a min/max. 

Connections Tab: 

• You can now use a variable to determine which connection prompt to display. 

Events Tab: 

• New option to not default scope when generated app launches. 

Miscellaneous Tab: 

• You can now specify a "Getting Started" document to be included in the help. 

Modifications: 

Application Generator 

Tests Tab: 

• You can now put line breaks (\n) in a test's Description and Reference fields. 

• When you copy a test group, the tests it contains now get copied. 

• Now supports variables in the full path of these steps: Load Scope Setup, Load Scope 

Mask File, Apply Transfer Function. 

• You can now edit a subroutine from inside the Call Subroutine step editor 

• WriteToFile Step: Now interprets "\n" as a line break 
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• Query *OPC? now supported in command files. 

• Disabled test steps are no longer displayed in Tests tab preview pane. 

• Fixed ExternalApp step Args path substitution on Win7. 

• Fixed error checking of full paths when they contain a variable and illegal path characters. 

• Fixed build reporting of illegal file path characters. 

Connections Tab: 

• Fixed connection diagram variable: Variable rename now updates variables in the 

Instructions. 

Build Tab: 

• Fixed Install Now for non-admin users on Win7. 

'Connect to Instrument' dialog now allows faster display of IO Libs instrument names without 

attempting to connect to each one. 

Improved appearance on high resolutions screens. 

Generated App/Add-In 

Renamed Run Tests tab button from "Run" to "Start". 

Now supports .txt file extension for ARSL scripts. 

Now installs to c:\program files (x86)\... on Win7 scopes 

Fixed launch from Infiniium Analyze menu on Win7 scopes. 

Improved appearance on high resolutions screens. 
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Agilent N5467A User Defined Application Version 01.61 

Released Date: 6 April 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series, 90000-X series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01610000.exe 

Modifications: 

Generated App/Add-In 

Fixed installer/uninstaller issues. 

Fixed Reserved_XxxPath variables. 
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Agilent N5467A User Defined Application Version 01.60 

Released Date: 1 March 2012 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista, 

Microsoft Windows 7 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series, 90000-X series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01600000.exe 

Highlights: 

Application Generator 

• You may set internal text variables equal to quoted text, variables of any type, and text 

library properties and functions. 

• You can now define tests as “No Result” for use as subroutines in Add-Ins 

• Simplified and improved use of external instruments. 

• You can now execute a file containing variable name/value pairs to quickly set many 

variables at once (See: Debug Runner > Set Variables screen). 

• New instrument address finder. 

Generated App 

• Installer supports Windows 7 scopes (as long as app is built with N5467A version 1.50 or 

newer). 

• No longer requires a license to use its remote interface. 

• New Acquisition Setup controls (see: Tools > Infiniium). 

Additions: 

Application Generator 

Tools Menu: 

• Manage > Internal Variables 

o You can now define internal variables that hold text and use them anywhere you 

can use internal numeric variables, except for math expressions 

• Manage > Text Libraries 

o You can now import libraries containing custom text properties and functions. 



 

 
Keysight D9010UDAA User Defined Application Release Notes 38 / 66 

• Options > Miscellaneous 

o New option to preserve generated app’s user preferences during In-Tool Launch 

Tests Tab: 

• You can now define tests as “No Result” for use as subroutines in Add-Ins (See: Final 

Result Step Limit Type). 

• Steps may now use text expressions consisting of quoted text, variables of any type, and 

text library properties and functions. 

Configs Tab: 

• (App only) You can specify a config as “Debug Only” (displays only when generated app is 

in Debug Mode). 

Debug Run Tab: 

• ‘Set Address’ feature now includes an instrument address finder. 

Step Debugger: 

• You can now set a reserved variable’s value 

• You can now execute a file containing variable name/value pairs to quickly set many 

variables at once (See: Set Variables screen) 

Generated App/Add-In 

The address a user enters for an external instrument is now stored in reserved variable named: 

Reserved_<name>Address. 

 (App only) 

• New Acquisition Setup controls (see: Tools > Infiniium). 

• Set Up tab now helps you find addresses of required external instruments. 

• New calibration wizard on PrecisionProbe/PrecisionCable input screen. 

Modifications: 

Application Generator 

Installation: Updated Agilent Licensing component to latest version. 

(Add-In only) No longer hides features that are not available at too low an add-in interface level; 

instead issues error if they are used. 

File Menu: 

• The Generator tool now prevents you from overlapping your “working files” and “saved 

project” locations. 
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• Fixed conversion to add-in of apps containing test groups. 

• Import Fragment now updates imported steps affected by a config rename and updates 

imported pass limits affected by an internal variable rename. 

Set Up Tab: 

• Simplified construction external instrument definition by offering “standard” error 

query/response rules. 

Tests Tab: 

• You can now use variables in an External Application step to specify the entire Program 

‘Full path’ or Script ‘Full path’. 

• You can now set a timeout value for LoadSetup, LoadMask and ApplyTransferFunction 

steps. 

• More types of combinations and comparisons are now allowed in conditional predicates. 

• Fixed multi-value parsing when the parse character is a double-quote. 

Configs Tab: 

• Changing a config’s variable name now correctly updates SetVariable steps. 

• Reference search now finds config variables on the right hand side of a IfStep or WhileStep 

predicate. 

Automation Tab: 

• You no longer need an N5452A remote interface license to use the N5467A's automation 

feature. 

• The automation tab now works when you are using a custom remote interface port. 

Step Debugger: 

• Variable window now shows variables found in Verify Condition Step pass limits. 

Generated App/Add-In 

Now automatically handles internal numeric variable and internal string variable name collisions 

between add-in and host compliance application. 

(App only) At start of run, no longer verifies connectivity of external instruments with empty 

addresses. 

(App only) Fixed “Previous session terminated unsuccessfully…restore recovered data” action. 

(App only) Fixed scope setup restoration upon app shutdown. 

(App only) Fixed Remote User Port usage on Win7 scopes. 
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(App only) Fixed remote interface startup warning when last session left an automation script 

open. 
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Agilent N5467A User Defined Application Version 01.50 

Released Date: 1 September 2011 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01500000.exe 

Highlights: 

Application Generator 

• You may now control which oscilloscopes your generated applications can be executed on: 

contact your Agilent sales representative for information on custom UDA licensing. 

• You can now specify which scope features your generated app or add-in requires (to help 

your users avoid run-time surprises); see Tools > Scope Option Requirements. 

Generated App 

• You can now use Infiniium’s InfiniiSim and PrecisionProbe features. 

• New Automation Tab enables click-free test selection, configuration and execution. 

Additions: 

Application Generator 

Tools Menu: 

• New Scope Option Requirements feature enables you to: 

o Inject an Infiniium dependency specification into your generated app. When you 

launch the generated app, missing scope options will be reported. 

o Detect when optional Infiniium features are present. You will be able to abort 

optional tests or select alternative steps when the scope doesn’t have the option(s) 

you specify. 

Events Tab: 

• New “Any Test Ends” event. 
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Miscellaneous Tab: 

• You can now specify maximum number of trial details & images per test (these affect the 

corresponding generated app View > Preferences > Report > Trial Display settings). 

Generated App 

• Now supports the InfiniiSim feature (See Tools->Infiniium). 

• Now supports the PrecisionProbe/PrecisionCable feature (See Tools->Infiniium). 

• New Automation Tab enables click-free test selection, configuration and execution. In this 

tab, you can now create a script of commands that can automatically select items found in 

the Set Up, Select Tests, Configure, Connect and Run tabs.  It’s like having a remote 

interface client built right into the app. 

• Supports Remote Interface Version 2.00.  

• When installed on the scope, the generated app now enables you to access its remote 

interface help file through menu button: help > 

Modifications: 

Application Generator 

Installer now requires PC to have Agilent IO Libraries 15.1 or newer. 

File Menu: 

• During “Open Project”, if you export “additional” external app scripts the path to the files 

will now be adjusted in the “Manage External Application Scripts” dialog box. 

Tests Tab: 

• Editing an If or While step predicate no longer produces “Please specify a variable to be 

compared” error. 

• When you create an internal variable from within the Predicate Term Definition dialog, the 

variable is now selected. 

Debug Runner: 

• Fixed :SYSTEM:PRESET execution from within DebugRun. 

• Setting a variable in the Debug Run dialog no longer produces “Please select an internal 

variable to set” error. 

Generated App/Add-In 

• (Generated App only) Remote interface no longer requires the Infiniium scope option “App 

Remote” (ID=”CRI”). You can now remotely control your generated app on any scope. 
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• (Generated App only) Improved behavior of Run progress meter. 

• The installer now requires the logged-in user to have administrator privileges. 
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Agilent N5467A User Defined Application Version 01.41 

Released Date: 30 April 2011 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01410000.exe 

Highlights: 

(Add-In projects only) Now supports Add-In Interface version 1.11. 

(App projects only) New ‘App Exits’ event. 

New ‘Ask For Data’ prompt. 

Increased availability of Reserved variables. 

Improved ‘Insert Variable’. 

Improved pass limits handling of zero case. 

New generated app remote interface command: SelectAllTests. 

Additions: 

Application Generator 

Tools Menu: 

• Options: Added new ‘Display’ tab entries. 

Tests Tab: 

• User Message Step: New ‘Ask For Data’ prompt to get input from users. 

• Margin formulas are now shown in the info pane. 

Debug Runner: 

• Added an 'Apply' button to the Set Variable For Debug Run screen so you can continue 

setting other variables. 
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Events Tab: 

• (App projects only) New ‘App Exits’ event executes its steps when the user exits the 

generated app. 

Generated App/Add-In 

New remote interface command: SelectAllTests. 

Modifications: 

Application Generator 

Changed the screen displayed when you exit the tool while unsaved changes exist. 

Tools Menu: 

• Manage Internal Variables:  Restored ‘Add’ behavior to close dialog by default. ‘Leave 

Open’ behavior is now optional (see Tools->Options::Display). 

(Add-In projects only) Compatibility Tab: 

• Now supports Add-In Interface version 1.11. 

Set Up Tab: Fixed external instrument description field. 

Tests Tab: 

• Fixed Verify Condition Step rounding for PrecisionLevel  > 0 case. 

• Improved variable validation in dialog boxes that allow you to enter %var% substitutions. 

• Pass Limits 

o For variable or zero single-ended limits, now provides a default Nominal value. 

o For variable single-ended limits, now enables user to enter a Nominal value. 

• You may now do the following with a Reserved variable: 

o Set Config variable equal to a Reserved variable (if the config is editable). 

o Write the Reserved variable's value to a file. 

o Report the Reserved variable's value in the results. 

o Use the Reserved variable on the right hand side of a conditional predicate (text 

comparisons only), e.g. if (MyConfig = Reserved_xxx). 

• In the Specify Value Source screen, when the ‘Source’ is ‘Text’ you may now insert 

variables. 

• You can now report arbitrary text in an Intermediate Value step. 
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• When using Insert Variable to choose a variable: 

o You no longer have to match the case of the variable you are looking for, e.g. 

“myvar” matches “MyVar” 

o You can add a trailing space to match the end of the name, e.g. "myvar " matches 

"MyVar" but not "MyVar2". 

o You can access the Manage screen to add new internal variables. 

• Restored ‘Edit’ behavior to open ‘Test Definition’ screen by default. “Auto Manage” 

behavior is now optional (see Tools->Options::Display). 

Config tab: 

• Deprecated config variable names containing characters other than alphanumeric or 

underscore. Recommend existing ones be changed to meet new criteria, although legacy 

projects with deprecated names will build and run as before. 

Connections Tab: 

• Connection Editor now enables you to specify whether you want this connection prompt to 

reset the scope or not. 

Debug Runner: 

• No longer initializes internal variables to NaN (Not a Number); this enables steps to fail if 

an internal variable has not been set before being used (which is what happens in the 

generated app). Resetting internal variables now puts them in an "uninitialized" state. 

• Improved variable identification in the Debug Run dialog box’s variable watch window. 

Automation Tab: 

• Default automation script uses new remote interface command: SelectAllTests 

• When automation script encounters an Exit step, it now aborts the rest of the script or file. 

Generated App/Add-In 

For final result steps with rounding > 10E2, now performs rounding before comparing to pass 

limits. (This behavior already existed for rounding < 10E2.) 

Fixed “File not found” error when external app scripts executed from within Subroutines or Events. 

Fixed the User Message Step’s Ask prompt “Suppression Response”. 

(Generated App only) Existing Results screen (which may display at the start of a run) now shows 

you how many trials exist for each test result to be modified. 

(Generated App only) Fixed HTML Report Logo. 
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(Generated App only) HTML Report now shows you the limit set that was active during the last 

run, not the one currently active. 
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Agilent N5467A User Defined Application Version 01.40 

Released Date: 18 February 2011 

(Application Generator) Supported Operating 

Systems: 

Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01400001.exe 

Highlights: 

You can now: 

• Create dynamic pass limits using internal variables. 

• Create information-only tests that have no pass limits. 

• Set internal and config variables during a Debug Run. 

• Launch an add-in from within the generator. 

• Get full-screen scope images. 

• Use a helper to insert %var% clauses. 

(Details below) 

Additions: 

Application Generator 

Tools Menu: 

• (Add-Ins) Options->Miscellaneous tab: New setting for choosing the default minimum 

Add-In interface for new projects. 

Various screens now provide an “Insert Variable” helper to construct “%var% clauses. 
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Tests/Subroutines/Events Tabs: 

• Manage Steps screens have a new 'Extract' button that will move the selected steps into a 

new subroutine. 

• You can now set internal and config variable values from the Debug Runner screen. 

Tests/Subroutine Tabs: 

• You can now select a "full screen" image for an Intermediate Value step. 

(Add-Ins) New ‘Compatibility’ Tab: 

• Enables you to trade off new features in your add-in for increased legacy application 

compatibility. 

Tests Tab: 

• You can now select a "full screen" image for a Final Result step. 

Miscellaneous Tab: 

• You can now specify a .txt Release Notes file. 

Modifications: 

Application Generator 

Increased enforcement of internal variable case sensitivity. 

File Menu: 

• ‘New Project’ now resets all internal and config variable values. 

• ‘Open Project’ now restores the Debug Run values for internal and config variables to what 

they were when the project was saved (Ensure Tools->Options::Debug::Maintain is 

checked before you start the Debug Run to avoid resetting these). 

• ‘Open Project’ now restores the build number (3rd segment of version field). 

• You can no longer use an older version of the N5467A application generator to import a 

fragment created by a newer version. (You may find that some fragments created by 1.40 

will fail to import into 1.30 projects. Please upgrade to N5467A version 1.40) 

Build Menu: 

• You can now ‘Launch’ an add-in to test it without having to install it in a real compliance 

application. 
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Tools Menu: 

• Manage->Internal Variables: You can now add multiple internal variables more easily. 

• Options::Debug: “Persist” user preference option setting (now called “Maintain”) is now 

saved/restored between application generator sessions. 

Tests/Connections/Subroutines/Events Tabs: 

• Now filters entries in a VariableName combo box as you type. 

Tests/Subroutines/Events Tabs: 

• You can now use internal variables in a Verify Condition Step’s limits. 

• Debug Run: 

o Added protection to prevent errors that occur during Debug Runs from terminating 

the application generator. 

o (Add-Ins) Now lets you include the ‘User Defined Group Ended’ event. 

Tests/Configs/Connection Tabs: 

• You can now rename tests, configs and connections using names that differ only by 

capitalization. 

Tests Tab: 

• You can now use internal variables in a test’s Final Result pass limits. 

• You can now define tests that have no pass limits. 

• You can now create test groups for your add-in’s tests. 

• Now when you edit a test that has steps, the Step Editor automatically opens. 

Configs Tab: 

• You can no longer set the value to use for a Debug Run from the Config editor screen (now 

use Debug Runner screen). 

Connections Tab: 

• You can now associate connection instructions with whole test groups instead of with 

individual tests, enabling a diagram to display before the group’s event steps execute. 
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Events Tab: 

• You can now add steps to an add-in’s sub-group events. 

• Fixed use of WriteFileStep in Events (no longer get “malformed run option” error during 

generated app startup). 

Build Tab: 

• Add-In installer filename now includes guidance to help you identify compatible 

compliance applications. 

Automation Tab: 

• Now available for use with add-in projects. 

Generated App/Add-In 

Installer now verifies Microsoft .NET 3.5 or newer is installed on scope before proceeding. 

“Verify Condition Step” now responds correctly to frequency measurement query when no 

waveform is present. 

(App) Legacy projects will be loaded as read-only (can’t append) due to changes in the data 

model. (Mention this in your generated app’s Release Notes so users will not be surprised by this 

when they upgrade). 

(App) Fixed ‘Set Up’ tab test group filters. 

(App) Exceptions thrown in “Create/Edit User Defined Limit Set” screen no longer terminate the 

application. 

(App) Fixed bug in “Create/Edit User Defined Limit Set” screen: You can now set a nominal value 

for case: value < 0 

(App) New user preference to autoscroll the HTML Report to the selected test result 

(View:Preferences:Report). 

(App) HTML Report:  

• Overall Pass/Fail status now displayed at top. 

• Application name now appears in the HTML Report title instead of in the Test 

Configuration table. 

• Now reports if any test was run while in ‘Debug’ mode (see ‘Configure’ tab). 

• Added navigation buttons in between result detail sections 

(App) When you open a project made by a different application, the error message now correctly 

reports the version the app that saved the project.  

(App) Fixed loading of projects made by different applications when the application’s name is 

listed as a “compatible” app.  
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(Add-In) Fixed installation of custom “other” files when the destination directory does not already 

exist. 

(Add-In) Add-In tests now identify themselves as “User Defined” in the host application’s HTML 

Report (Add-In Interface 1.10 or later). 

(Add-In) Add-In now reports its beta/release status in the host application’s Help->About screen 

and HTML Report (Add-In Interface 1.10 or later). 



 

 53 / 66 Keysight D9010UDAA User Defined Application Release Notes 

Agilent N5467A User Defined Application Version 01.30 

Released Date: 2 November 2010 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01300004.exe 

Additions: 

Generator Tool 

You can now create “Add-Ins” that can be installed into existing compliance applications. 

New ‘Automation’ tab enables you to automate generated app behavior. 

Tools Menu: 

• Manage 

o New Reserved Variable: Reserved_ProjectAppPath 

• Options 

o New ‘Build’ tab 

o New ‘Debug’ tab 

Steps: 

• New ‘Apply Transfer Function’ Step 

• New ‘Write File’ Step 

Events: 

• New ‘Any Trial Ends’ Event 

Miscellaneous: 

• You can now include a test procedure PDF file in a generated app 

• Manage > Other Files: You may now have a period (.) in your custom install directory, e.g. 

c:\temp\mydir.something\ 

Modifications: 

Generator Tool 
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Custom Math Libraries compiled against previous versions of N5467A must be rebuilt to 

work with this version. See the “Managing Math Libraries” topic in the user manual. 

Removed Basic Mode. 

Build:  

- Generator tool no longer hangs when you build an event step that calls a recursive 

subroutine. 

- Now generates build error if a non-CommandFile step refers to a non-existent 

external instrument. 

Set Up tab:  

- Displayed build number now dynamically updates each build. 

- When you rename an external instrument, the change is now propagated to the 

steps. 

Tests tab:  

- Now warns when you are about to delete a test group that has run events 

associated with it. 

Debug Run: 

- You can now persist internal variable values across debug runs via the Tools-

>Options dialog. 

- Debug Run Echo Console now displays Console App launch command args. 

- Fixed on-scope debug run involving external instruments. 

Step Editor: 

- Console App step no longer complains about missing success text when verification is 

turned off. 
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Miscellaneous: 

Parsing: Wherever you can specify how text is parsed, you can now specify more than one 

character; the text will be split every time any of those characters is found. This includes 

special characters enabling parsing of multi-line files. 

%var:% syntax now returns a non-engineering formatted string if the value is a whole 

number. 

The External Instrument Definition dialog now warns about reference changes only when 

you change the nickname (case sensitive). 

You can now control external instruments via a SICL socket address, such as the N4903A 

J-BERT high-performance serial BERT. 

Build Results Pane: Fixed build error line number when error step is preceded by one or 

more comments. 

When you enable or disable a step, it now moves to the center of the visible window (now 

matches the edit step behavior). 

In While blocks containing a ContinueWhile followed by BreakWhile, the Break is now 

skipped. 

Generated App 

Added splash screen to installer. 

Now supports Remote Interface version 1.70. 

Fixed a crash that could occur when the generated app contained a long-running while 

loop. 

Application installer is now fully automated. 

Scope: When a scope is missing the UDA option license, installed UDA apps now appear 

under Analyze->Unlicensed Apps submenu. 

When an abort step fires in a Run Event, you can now see the message you specified in 

the step. 

No longer throws exception when you use a config value that looks like a numeric too big 

to fit inside a double precision float var, e.g. 1E9841345714544. 

An IntermediateValue step followed by an AbortStep will no longer terminate the 

application. 
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Agilent N5467A User Defined Application Version 01.22 

Released Date: 13 July 2010 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01220001.exe 

Modifications: 

Generator Tool 

File Menu: 

• Now you can open projects when your PC has language localization enabled. 

Configs: 

• Now removes leading and trailing spaces from config definition entries, preventing 

phantom config issues. 

Generated App 

Launch: 

• No longer reports "malformed run options" when an event contains a SetVariableStep 

whose source is a SCPI command. 
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Agilent N5467A User Defined Application Version 01.21 

Released Date: 14 May 2010 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01210001.exe 

Modifications: 

Generator Tool 

File Menu: 

• Build: Fixed a “recursive subroutine error” that would sometimes be reported when there 

was no recursion. 

Steps: 

• You are now prevented from creating a Math Expression in which you pass a multi-term 

expression as an argument to a function call, e.g.“Math:Abs(x – y)”(The UDA step 

execution engine does not handle these types of arguments yet.). 

• You are now prevented from including library functions or properties in IF and WHILE step 

predicates, e.g.“if (x < Math:Abs(y))” (The UDA step execution engine does not handle 

these types of predicates yet.). 

Generated App 

Installer: 

• Now opens up port exceptions in the oscilloscope’s firewall to enable control of the 

generated app via its remote interface (in case no previous app had ever opened these 

ports.) 
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Agilent N5467A User Defined Application Version 01.20 

Released Date: 15 March 2010 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01200000.exe 

Additions: 

Generator Tool 

File Menu:  

• You may now export and import individual tests and subroutines. 

Tools Menu: 

• Debug Run: You may now reset each config’s Debug Run value to its default value. 

Steps: 

• “If”, “Else” and “EndIf” Steps now enable you to create conditional blocks of steps. 

• “While”, “Break”. “Continue”, and “EndWhile” Steps now enable you to repeat blocks of 

steps. 

• “Abort” Step now enables you to stop the test or run in progress. 

• “Return” Step now enables you to exit a subroutine or event before its last step. 

Modify Steps dialog:  

• <ctrl>A now selects all steps. 

• Improved cursor behavior when adding and deleting test steps. 

Events: 

• “Any Test Group Starts”: Fires every time test flow enters a new group, at any level, 

including the RootGroup. 

• "App Shown": Fires as soon as the generated app is launched. 
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Modifications: 

Generator Tool 

File Menu: 

• New Project now removes group-specific events. 

• Make Project Editable now works when the project has no user files. 

Tools Menu: 

• Moved Predefined Variables button to Tools > Manage > Reserved Variables. You can now 

find references to reserved variables.  

• Some keyboard shortcuts in the Manage menu and in the Choose Step Type dialog were 

changed to make the two lists consistent. 

External Instruments: 

• Fixed error message when you edit an existing definition. 

Debug Run Dialog: 

• At the start of each Debug Run session, now sets all internal variable values to value “NaN” 

(Not a Number). 

• Now displays the current values of all internal and config variables directly referenced by 

the steps in the list. 

• Breakpoints now indicated as a “B” in the first column. 

• No longer executes commented-out steps inside subroutines. 

• When running the generator tool on a scope, no longer asks you for the SICL address; now 

automatically uses lan[localhost]:inst0. 

• Added protection against recursive subroutine calls. 

Steps: 

• You may now copy and paste steps between step containers. The <ctrl>+x keyboard 

shortcut has been removed. 

• Now when you add steps, they get inserted above the selected line.  

• When you edit a step whose value source is a Config, the Specify Value Source dialog now 

defaults to the correct config. 

• DisplayMessage Step: Now you can display messages with response choices, such as “OK 

/ Cancel”, “Yes / No”, etc. and access the user's response in a variable. 
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• LoadMask Step: Build now works when running on PC even if you have not entered the 

Mask File Path on the ‘Debug Run’ tab yet. 

• SetVariable Step: You can now set a user-editable config to arbitrary text. 

• SleepStep: You may now use a math expression to define the duration. 

Configs: 

• Fixed “Rename” action when the label is a superset of the variable name. 

Subroutines: 

• Now you can delete steps causing recursive loops. 

Events: 

• Now prevents you from adding a call to a subroutine directly or indirectly containing an 

Intermediate Value step. 

• When you rename a test group, the associated group-specific Event is now renamed 

instead of replaced. 

Build: 

• Now you no longer get an error when launching the generated app from within the tool 

when the scope does not have an App Remote license. 

Managers: 

• Internal Variables: You may now change references from one internal variable to another. 

Internal Variable Names may now also contain underscores (_) 

• ManageConsoleApps: Removed “Substitute” option; now use “Change Refs”. 

• You may now export search results to a file. 

• Math Libraries: IDs may now also contain numbers and underscores (_). You may no longer 

load the same library twice. 

• Other Files: you can now edit an entry to point to the same named file in a different 

directory. 

Generated App 

Remote interface upgraded to version 1.60. 
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Agilent N5467A User Defined Application Version 01.11 

Released Date: 27 January 2010 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01110000.exe 

Additions: 

Generator Tool 

Non-Agilent Technologies external instruments (SCPI-compliant) are now supported. 

Modifications: 

Generator Tool 

Fixed intermittent N5467A installer upgrade failures. 

An event may no longer include Intermediate Value steps or subroutines that call them (causes 

error at generated app runtime). 

When you abort an "Open Project" action, a new project is now started. 

Now finds references to config variables used inside connection definitions. 

Now respects user-provided timeouts for queries when value source is “scope” or “external 

instrument”. 

Debug Run now works with steps involving configs that have parentheses in their labels. 

Now handles bad external instrument addresses more gracefully. 

Display dialogs containing tree views starting at the top of the tree. 

The project is now marked dirty when you add/remove additional files in the Manage External 

Scripts dialog. 

When you load a project that contains Console Application definitions, the Supporting Files list 

box no longer shows duplicates. 
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Agilent N5467A User Defined Application Version 01.10 

Released Date: 04 December 2009 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01100000.exe 

Additions: 

Generator Tool 

You can now define subroutines of steps that can be called by Tests, Events, and other 

subroutines. 

• See: ‘Subroutine’ tab in main dialog 

Math expressions may now include properties and function calls for external math libraries.  

• A core math library is included with the generator tool. 

• You may also plug in custom libraries that you create as well. 

• See: Tools > Manage > Math Functions 

New step type: Load Scope Mask which enables mask testing and loads the specified mask file. 

• As with scope setup files, in order to run this step from a PC you will need to provide a 

scope-centric path on the ‘Debug Run’ tab 

You may now install User Defined Function files into Infiniium’s UDF directory. 

• See: Tools > manage > Miscellaneous Files 

You may now set breakpoints in the Debug Run dialog. 

You can now disable an individual Test step or Event step to temporarily exclude it from the build. 

You can now add comments to Test step lists and Event step lists. 

“Find References” results are now available in the main dialog Results pane, ‘Find’ tab. 

Added support for installing miscellaneous files (those not already handled by another 

mechanism). 

• See: Tools > Manage > Miscellaneous Files  

Added predefined variables to enable you to discover certain runtime paths. 

• See: Tools > Predefined Variables 
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Verify Condition step now has “Abort Test” option which respects the generated app’s Preference 

setting, Run: Test Abort Action. 

Added F1 help support for build errors 

Generated App 

Screen shots now include waveform memory scales if a waveform is displayed 

 

Modifications: 

Generator Tool 

Buttons for managing external instruments have been moved to a separate dialog, accessible 

from: 

• Menu: Tools > Manage > External Instruments 

• ‘Set Up’ tab: Manage buttons 

You may now set user-editable Config variables in Set Variable steps. 

You may now use Config variables as the source for Final Result value. 

Tool now warns you if you try to load a scope setup or mask from within a Command or Command 

File step (suggests you use the specialized step for these). 

In Tests and Event step lists, copied steps are now inserted immediately after the selection. 

Tool now warns you upon renaming a config or internal variable that references in command files 

will not be updated. 

Test and Event step lists are now editable via a separate dialog. 

The Debug Run button in the Test Definition dialog now enables you to combine that test’s steps 

with associated events to exercise a more complete run. 

The Debug Run button in the Events tab now enables you to combine events to exercise a more 

complete run. 

The Events combo box entries are now listed in order of runtime execution. 

Build now catches conditions leading to image file paths that would exceed the file system max of 

259 characters. 

Find Config References now finds usages in Intermediate Value and Final Result steps. 

Set Variable step exceptions are now handled by the standard runtime abort handler (no dialog 

will interrupt the run now). 

When you change a config’s label, all steps referring to that config by label are now updated. 

When Intermediate or Final Result step reports either a config variable or a math expression, you 

can now include an image. 
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%VAR:% clauses in External App step Args field now work correctly. 

When you edit a test whose pass limit is a single-ended (non-range) value of 0, you no longer get 

false limit-changing warning if you do not change the limit. 

When you edit a Set Variable step, the variable box now defaults to the current variable name. 

The requirement to make Intermediate and Final Result step labels unique is now a case sensitive 

comparison. 

The Connection Changing event now only fires if the user actually changes the connection (clicks 

‘Next’, not ‘Ignore’). 

When developing on an oscilloscope, you can now execute a Load Setup step within a Debug Run.  

Fixed various text boxes that would jump the cursor to the end when you typed in them. 

While a generated app is running, the main dialog status bar now indicates this and you can no 

longer perform a build. 

Added validation to pass limits “Nominal” field. 

Console App Step: “Use Timeout” now unchecked when disabled. 

Now you can only add Test Groups when either the Tests or Config tab is active. 

Generated App 

Now uses remote interface version 1.40. 

Improved stability on runs > 48 hours in duration. 

When you save a project, now warns if the path length you choose would cause one or more of the 

project’s files to exceed operating system max path length. 

File > Export Results > CSV output is now sorted the same way as results are displayed in the 

‘Results’ tab. 

‘Configure’ tab combo box caption now says “Select a value” or “Select or type in a value” to 

indicate whether or not it accepts user-defined text. 
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Agilent N5467A User Defined Application Version 01.01 

Released Date: 28 August 2009 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series) , 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01010000.exe 

Additions: 

Added new entries in the Tools->Manage menu to support connection diagrams and external 

application scripts. 

Modifications: 

External Application Dialog: 

• Redesigned to clarify difference between executing a program and a script. 

• Scripts are now always installed. 

• Scripts are now installed in the generated application's installation location. 

• You may use %VAR variables in the Script Full Path filename. 

If you abort an "open project" action after selecting the project, a new project is now always 

started. 

You can now modify a connection definition to use a different image or custom HTML file even 

when the new file has the same name as the old one, as long as the old file is not currently used 

by any other connection definition. 

External app step scripts are now always saved with the project. 

In the “Manage CommandFiles/ConnectionXxx/ScopeSetupFiles” dialogs, the 'Browse' button in 

the 'Change References' action now starts in the last directory used for that file type. 
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Agilent N5467A User Defined Application Version 01.00 

Released Date: 1 July 2009 

(Generator tool) Supported Operating Systems: Microsoft Windows XP Service Pack 2 or later, 

Microsoft Windows Vista 

(Generated App) Minimum Infiniium Oscilloscope 

Baseline Version: 

5.70 (80000 series), 

1.41 (90000 series), 

2.00 (9000 series) 

File Name: SetupInfUserDefApp01000000.exe 

Initial Release 
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