Contact an Expert

Thread: PNA-X: How to set LO to 'Not controlled'?


Permlink Replies: 7 - Pages: 1 - Last Post: Jul 18, 2012 5:54 PM Last Post By: rok Threads: [ Previous | Next ]
rok

Posts: 155
Registered: 04/27/11
PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 1:07 PM
Click to report abuse...   Click to reply to this thread Reply
Hello,

I have a test setup that has the ability to test either downconverter DUTs with and without embedded LOs. For the IMDX measurement channels, I want to change the LO from a specified external source to 'Not Controlled' for the embedded LO case. I looked at the pnahelp9_50 .chm help file and found the command of "SENSe<ch>:MIXer:LO<n>:NAME <value>". It states that the default value is "Not Controlled". But if I try to issue this command:

SENS:MIX:NAME "Not Controlled"

I get an 'Error 1147 Specified external device was not found.'

I looked at the rest of the :SENSE:MIXER:LO tree of commands and couldn't find any comparable command. Is there some way to set the LO to 'Not Controlled' value using scpi programming?

Thanks,
rok
rok

Posts: 155
Registered: 04/27/11
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 1:11 PM   in response to: rok in response to: rok
Click to report abuse...   Click to reply to this thread Reply
Hi again,

I noticed a typo in the command in my last post. The correct command I sent out is:

SENSE:MIX:LO:NAME "Not Controlled"

I forgot to include the 'LO' portion in my post, but the error message does indicate not being able to find the LO source in question.

rok
rok

Posts: 155
Registered: 04/27/11
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 1:14 PM   in response to: rok in response to: rok
Click to report abuse...   Click to reply to this thread Reply
Hi again,

I noticed one more typo in the Error number. I tried the command again and the correct error number is 1037 "Specified external source not found', not 1147.

Sorry about that,
rok
zwwong

Posts: 3
Registered: 07/18/12
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 2:46 PM   in response to: rok in response to: rok
Click to report abuse...   Click to reply to this thread Reply
Hi,

I guess you are using A.09.42.xx or A.09.50.xx firmware version because I am aware of this problem in these two releases. This problem is that the "SENS:MIX:LO:NAME" is case-sensitive. To get around this problem, set the LO to "Not controlled" (lower case 'c') instead of "Not Controlled". We fixed this problem in our upcoming web release so that the command is not case-sensitive for "Not controlled". Unfortunately, A.09.42.xx and A.09.50.xx releases don't have this fix.

I will let our Learning Products Engineer know and change this in our help document.
Dr_joel


Posts: 2,687
Registered: 12/01/05
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 3:49 PM   in response to: zwwong in response to: zwwong
Click to report abuse...   Click to reply to this thread Reply
Stupid Unix: I hate case sensitive anything! good job Zhi.
rok

Posts: 155
Registered: 04/27/11
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 4:06 PM   in response to: zwwong in response to: zwwong
Click to report abuse...   Click to reply to this thread Reply
Hi,

Yes, I'm trying out the A.09.50.13 firmware. I tried out the command with the lowercase 'c'. (i.e. SENS:MIX:LO:NAME 'Not controlled') I was able to send it out with no error generated. However, it didn't change the LO to 'Not Controlled' when I checked it by clicking on 'Stimulus'-'Freq'-'Mixer Setup' and then the 'Mixer Setup' tab. I tried it on an existing SMC measurement channel and then create an SMC channel from scratch, but it still didn't change the LO name to 'Not Controlled'. (it just remembered the previous external source assigned to it). Could this be another bug in the firmware?

Thanks,
rok
zwwong

Posts: 3
Registered: 07/18/12
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 5:06 PM   in response to: rok in response to: rok
Click to report abuse...   Click to reply to this thread Reply
Hi,

To change the mixer state, you have to call "Apply" to apply the new settings. Try calling SENS:MIX:APPLY after you set the LO source.
rok

Posts: 155
Registered: 04/27/11
Re: PNA-X: How to set LO to 'Not controlled'?
Posted: Jul 18, 2012 5:54 PM   in response to: zwwong in response to: zwwong
Click to report abuse...   Click to reply to this thread Reply
Hi,

Thanks for the follow-up reply. It works now with the extra command! I forgot it was not an immediate command.

Thanks again,
rok

Point your RSS reader here for a feed of the latest messages in all forums