Contact an Expert

Thread: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear


Permlink Replies: 5 - Pages: 1 - Last Post: Oct 9, 2012 11:39 AM Last Post By: lhornburg Threads: [ Previous | Next ]
evilempire

Posts: 1
Registered: 04/24/12
Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Apr 24, 2012 4:34 PM
Click to report abuse...   Click to reply to this thread Reply
Has anyone ever seen the following error message from an Agilent 33522A?

"Application Garfield.exe encountered a serious error and must shut down."

I have received this error message three times, and it:

1. Locks the GPIB bus (can't talk to it from Matlab, using Matlab instrument control toolbox, NI GPIB-USB bridge, and NI 488.2 software)
2. Locks the CH1 offset at the current value (can't change it from the front panel or remotely).
3. Pops up an error box on the front panel of the instrument. The only way to clear it is to power cycle the unit.

As far as I can tell, the error occurs after long periods of remotely changing the waveform offset voltage. For completeness sake, I'm using the unit in ARB mode, step filter off, sample rate 1kSa/s, burst mode, N-cycle, infinite number of cycles, trigger on CH1, trigger sync mode carrier. The connection is from a PC USB port to the GPIB port on the back of the 33522A unit using a National Instruments GPIB-USB+ dongle.

Can this be fixed, or should I return the unit for warranty service? I've been using it for about four months now, and seen this error three times. I can't reproduce it, but it hangs my program and I have to abort the experiment and restart. Very frustrating. Google has never heard of "Garfield.exe" for Agilent equipment, and the forum search doesn't turn up anything either.

Thanks in advance for your help
lhornburg

Posts: 476
Registered: 01/15/10
Re: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Apr 24, 2012 5:34 PM   in response to: evilempire in response to: evilempire
Click to report abuse...   Click to reply to this thread Reply
Hello,

This can be fixed with a firmware upgrade.

You can download the firmware upgrade tool and 1.14 firmware from here:

http://www.home.agilent.com/sec/editorial.jspx?cc=US&lc=eng&ckey=1974550&nid=-536902257.940638&id=1974550

You should never get this error if you have firmware rev 1.14 installed. If you do get it after you update, please let us know.
dnao2

Posts: 9
Registered: 04/22/12
Re: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Jul 6, 2012 8:45 AM   in response to: lhornburg in response to: lhornburg
Click to report abuse...   Click to reply to this thread Reply
Hi Lhornburg,

I am using Agilent 33521A and the firmware as stated under the About page is 1.14-1.19-1.01-50-00. When I run my vb.net application with arb wave forms, I am getting the "Garfield.exe" error and unit must be restarted. Should the firmware I am currently on have corrected this problem?

thanks!
lhornburg

Posts: 476
Registered: 01/15/10
Re: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Jul 10, 2012 10:45 AM   in response to: dnao2 in response to: dnao2
Click to report abuse...   Click to reply to this thread Reply
Hello,

Can you attach your vb.net application? This is the first I have heard of anyone getting this error message since the 1.14 update.

If you don't want it on here publicly you can private message it to me.
mguw

Posts: 1
Registered: 10/17/11
Re: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Oct 2, 2012 3:39 AM   in response to: evilempire in response to: evilempire
Click to report abuse...   Click to reply to this thread Reply
Hello

I have the same error message, but mine is during boot, so that the boot never finishes, and thus I cannot reflash the firmware.
powercyling always boots until this same error.

what can I do ?

regards
Marcel
lhornburg

Posts: 476
Registered: 01/15/10
Re: Agilent 33522A - "Garfield.exe" error - must power cycle unit to clear
Posted: Oct 9, 2012 11:39 AM   in response to: mguw in response to: mguw
Click to report abuse...   Click to reply to this thread Reply
Hello Marcel,

Call agilent customer service number and have this unit sent back as an OBD (out of box defect)

Point your RSS reader here for a feed of the latest messages in all forums