Contact an Expert

Thread: DSOX3024 FFT Strange Behavior


Permlink Replies: 2 - Pages: 1 - Last Post: Jun 14, 2012 7:40 PM Last Post By: swperk
Willco788

Posts: 110
Registered: 05/28/11
DSOX3024 FFT Strange Behavior
Posted: May 2, 2012 8:02 AM
Click to report abuse...   Click to reply to this thread Reply
Attachment scope_4.bmp (1.2 MB)
Attachment fft_problems.bmp (1.2 MB)
Attachment fft_problems1.bmp (1.2 MB)
This has nothing to do with the ASV but it's something I discovered while fiddling with channel impedance. When I first turn-on the scope, the FFT that was configured previously, launches automatically. When I change the channel impedance from 50 ohm to 1 MegOhm, the Max measurement changes from dbm to dbv. It stays that way when I toggle the impedance back to 50 Ohms. When I go the the FFT/More FFT/Vertical Units, the default is Decibels. When I toggle the menu to V RMS and back to Decibles, then Max measurements is locked to dbm.

After fiddling with FFT/More FFT/Vertical Units again, It's in a mode where when I select V RMS, the FFT dissapears and the Max Measurement shows 0dbm. When I launch FFT/More Auto Setup, the measurement is back to 0dbm but when I select V RMS the the measurement is 223mv, the noise floor and the level drops. Back to Decibles and the measurement is correct.

Things aren't consistant and it appears the the measurements are all out of wack. There's no clear way to correct the problem and by changing other settings, the FFT can shut down.

Edited by: Willco788 on Jun 9, 2012 6:25 AM
Willco788

Posts: 110
Registered: 05/28/11
Re: DSOX3024 FFT Strange Behavior
Posted: Jun 9, 2012 6:31 AM   in response to: Willco788 in response to: Willco788
Click to report abuse...   Click to reply to this thread Reply
I have had zero responses to this thread. Is there anyone out there that experienced this anomaly or can explain this?
swperk


Posts: 89
Registered: 01/11/08
Re: DSOX3024 FFT Strange Behavior
Posted: Jun 14, 2012 7:40 PM   in response to: Willco788 in response to: Willco788
Click to report abuse...   Click to reply to this thread Reply
I have an MSO-X 3034A, and I tried to reproduce the problem you're having. I found that with the vertical units set to decibels, I consistently got vertical scaling in dBm for a 50 ohm input impedance setting, and dBV for a 1 Mohm input impedance setting. I could switch back and forth between the two input impedances and the units were always correct.

When I switched the vertical units to V RMS, my vertical scaling was always in volts, no matter which input impedance was selected.

I think this is the correct behavior. What you're seeing when the default units are set to V RMS is a linear (vs. logarithmic) vertical scale, so the display appears much less sensitive (and much less noisy) than with a logarithmic scale. This is the same behavior as with a traditional spectrum analyzer.

What firmware version are you using? I'm using 2.12 (the newest).

Point your RSS reader here for a feed of the latest messages in all forums