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Warranty

THE MATERIAL CONTAINED IN THIS 
DOCUMENT IS PROVIDED “AS IS,” 
AND IS SUBJECT TO BEING 
CHANGED, WITHOUT NOTICE, IN 
FUTURE EDITIONS. FURTHER, TO 
THE MAXIMUM EXTENT PERMITTED 
BY APPLICABLE LAW, KEYSIGHT 
DISCLAIMS ALL WARRANTIES, 
EITHER EXPRESS OR IMPLIED WITH 
REGARD TO THIS MANUAL AND 
ANY INFORMATION CONTAINED 
HEREIN, INCLUDING BUT NOT 
LIMITED TO THE IMPLIED 
WARRANTIES OF 
MERCHANTABILITY AND FITNESS 
FOR A PARTICULAR PURPOSE. 
KEYSIGHT SHALL NOT BE LIABLE 
FOR ERRORS OR FOR INCIDENTAL 
OR CONSEQUENTIAL DAMAGES IN 
CONNECTION WITH THE 
FURNISHING, USE, OR 
PERFORMANCE OF THIS 
DOCUMENT OR ANY INFORMATION 
CONTAINED HEREIN. SHOULD 
KEYSIGHT AND THE USER HAVE A 
SEPARATE WRITTEN AGREEMENT 
WITH WARRANTY TERMS 

COVERING THE MATERIAL IN THIS 
DOCUMENT THAT CONFLICT WITH 
THESE TERMS, THE WARRANTY 
TERMS IN THE SEPARATE 
AGREEMENT WILL CONTROL.

Technology Licenses

The hardware and/or software 
described in this document are 
furnished under a license and may be 
used or copied only in accordance 
with the terms of such license.

U.S. Government Rights

The Software is “commercial 
computer software,” as defined 
by Federal Acquisition Regulation 
(“FAR”) 2.101. Pursuant to FAR 
12.212 and 27.405-3 and 
Department of Defense FAR 
Supplement (“DFARS”) 227.7202, 
the U.S. government acquires 
commercial computer software 
under the same terms by which 
the software is customarily 
provided to the public. 
Accordingly, Keysight provides 
the Software to U.S. government 
customers under its standard 
commercial license, which is 
embodied in its End User License 
Agreement (EULA), a copy of 
which can be found at 
http://www.keysight.com/find/sweula
The license set forth in the EULA 
represents the exclusive authority 
by which the U.S. government 
may use, modify, distribute, or 
disclose the Software. The EULA 
and the license set forth therein, 
does not require or permit, 
among other things, that 
Keysight: (1) Furnish technical 
information related to 
commercial computer software 
or commercial computer 
software documentation that is 
not customarily provided to the 
public; or (2) Relinquish to, or 
otherwise provide, the  
government rights in excess of 
these rights customarily provided 
to the public to use, modify, 
reproduce, release, perform, 
display, or disclose commercial 
computer software or 
commercial computer software 

documentation. No additional 
government requirements 
beyond those set forth in the 
EULA shall apply, except to the 
extent that those terms, rights, or 
licenses are explicitly required 
from all providers of commercial 
computer software pursuant to 
the FAR and the DFARS and are 
set forth specifically in writing 
elsewhere in the EULA. Keysight 
shall be under no obligation to 
update, revise or otherwise 
modify the Software.  With 
respect to any technical data as 
defined by FAR 2.101, pursuant 
to FAR 12.211 and 27.404.2 and 
DFARS 227.7102, the U.S. 
government acquires no greater 
than Limited Rights as defined in 
FAR 27.401 or DFAR 227.7103-5 
(c), as applicable in any technical 
data.

Safety Notices

A CAUTION notice denotes a hazard. It 
calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in damage to the 
product or loss of important data. Do 
not proceed beyond a CAUTION 
notice until the indicated conditions 
are fully understood and met. 

A WARNING notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in personal injury or 
death. Do not proceed beyond a 
WARNING notice until the indicated 
conditions are fully understood and 
met.
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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about these products, including instrument software 
upgrades, application information, and product information, browse to one of the following URLs, according to the name 
of your product:

http://www.keysight.com/find/psg

To receive the latest updates by email, subscribe to Keysight Email Updates at the following URL:

http://www.keysight.com/find/MyKeysight

Information on preventing instrument damage can be found at:

www.keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. To search 
for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

http://www.keysight.com/find/techsupport
http://www.keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/MyKeysight
http://www.keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/PreventingInstrumentRepair
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Keysight Technologies
E8257D/67D & E8663D PSG Signal Generators

User’s Guide

1 Signal Generator Overview

In the following sections, this chapter describes the models, options, and 
features available for Keysight E8257D/67D and E8663D PSG signal 
generators. The modes of operation, front panel user interface, and front and 
rear panel connectors are also described.

— “Signal Generator Models and Features” on page 16

— “Options” on page 22

— “Firmware Upgrades” on page 22

— “Modes of Operation” on page 24

— “Front Panel” on page 26

— “Front Panel Display” on page 35

— “Rear Panel” on page 41

For more information about the PSG, such as data sheets, configuration guides, 
application notes, frequently asked questions, technical support, software and 
more, visit the Keysight PSG web page at http://www.keysight.com/find/psg.
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Signal Generator Models and Features
Table 1-1 lists the available PSG signal generator models and frequency–range 
options.

Table 1-1 PSG Signal Generator Models

Model Frequency Range Options

E8257D PSG analog signal generator 250 kHz to 13 GHz (Option 513)
250 kHz to 20 GHz (Option 520)
10 MHz to 20 GHz (Option 521)
250 kHz to 31.8 GHz (Option 532)
250 kHz to 40 GHz (Option 540)
250 kHz to 50 GHz (Option 550)
250 kHz to 67 GHz (Option 567)a

E8267D PSG vector signal generator 250 kHz to 13 GHz (Option 513)
250 kHz to 20 GHz (Option 520)
250 kHz to 31.8 GHz (Option 532)
250 kHz to 44 GHz (Option 544)

E8663D PSG analog signal generator 100 kHz to 3.2 GHz (Option 503)
100 kHz to 9 GHz (Option 509)

a. Instruments with Option 567 are functional, but unspecified, above 67 GHz to 
70 GHz
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E8257D PSG Analog Signal Generator Features

The E8257D PSG includes the following standard features:

— a source module interface that is compatible with Keysight 83550 Series 
millimeter–wave source modules for frequency extension up to 110 GHz 
and Oleson Microwave Labs (OML) AG–Series millimeter–wave modules for 
frequency extensions up to 325 GHz

— automatic leveling control (ALC) on and off modes; power calibration in 
ALC–off mode is available, even without power search

— CW output from 250 kHz to the highest operating frequency, depending on 
the option

— external diode detector leveling

— frequency resolution to 0.001 Hz

— list and step sweep of frequency and amplitude, with multiple trigger 
sources

— optimized signal to noise ratio

— 10 MHz reference oscillator with external output

— RS–232, GPIB, and 10Base–T LAN I/O interfaces

— user flatness correction

— attenuator burnout protection (with Option 521 instruments that have 
Option 1E1)

The E8257D PSG also offers the following optional features:

Option 007—analog ramp sweep

Option 0081—8 GB removable compact flash drive

Option 521—ultra high output power, frequency range from 0.1-20 GHz 

Option 1E1—step attenuator

Option 1EA (Discontinued)—high output power

Option 1ED—Type–N female RF output connector

Option 1EH —improved harmonics below 2 GHz

Option 1EU—high output power (standard with E8267D)

Option 1EM—moves all front panel connectors to the rear panel

To provide analog frequency sweeps and for optimum swept scalar measurements 
with the 8757D scalar analyzer, the E8257D requires 007 (analog ramp sweep).

1. Instruments with serial prefix ≥ US4928/SG4928/MY4928.
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Option 1SM—provides improved performance in Exponential (Log) AM 
mode

Option UK6—commercial calibration certificate and test data

Option UNR (Discontinued)—enhanced phase noise

Option UNX—ultra low phase noise

Option UNY—enhanced ultra low phase noise

Option UNT—AM, FM, phase modulation, and LF output

— open–loop or closed–loop AM

— dc–synthesized FM to 10 MHz rates; maximum deviation depends on 
the carrier frequency

— external modulation inputs for AM, FM, and ΦM

— simultaneous modulation configurations (except: FM with ΦM or 
Linear AM with Exponential AM)

— dual function generators that include the following:

——50–ohm low–frequency output, 0 to 3 Vp, available through 
the LF output

——selectable waveforms: sine, dual–sine, swept–sine, triangle, 
positive ramp, negative ramp, square, uniform noise, Gaussian 
noise, and dc

——adjustable frequency modulation rates

——selectable triggering in list and step sweep modes: free run 
(auto), trigger key (single), bus (remote), and external

Option UNU—pulse modulation

— internal pulse generator

— external modulation inputs

— selectable pulse modes: internal square, internal free–run, internal 
triggered, internal doublet, internal gated, and external pulse; 
internal triggered, internal doublet, and internal gated require an 
external trigger source

— adjustable pulse rate

— adjustable pulse period

— adjustable pulse width (150 ns minimum)

— adjustable pulse delay

— selectable external pulse triggering: positive or negative

Option UNW—narrow pulse modulation
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— generate narrow pulses across the operational frequency band of the 
PSG

— includes all the same functionality as Option UNU

E8267D PSG Vector Signal Generator Features

The E8267D PSG provides the same standard functionality as the E8257D PSG, 
plus the following:

— internal I/Q modulator

— external analog I/Q inputs

— single–ended and differential analog I/Q outputs

— high output power (optional for the E8257D & E8663D)

— step attenuator (optional for the E8257D)

The E8267D PSG offers the same options as the E8257D PSG, plus the 
following:

Option 003—PSG digital output connectivity with N5102A

Option 004—PSG digital input connectivity with N5102A

Option 0051 (Discontinued)—6 GB internal hard drive

Option 0092—8 GB removable compact flash drive

Option 015 (Discontinued)—single–ended wideband external I/Q inputs

Option 016—differential wideband external I/Q inputs

Option 018—wideband IQ/FM mode (<3.2 GHz)

Option 403—calibrated noise, AWGN

Option 601 (Discontinued)—internal baseband generator with 8 
megasamples of memory

Option 602—internal baseband generator with 64 megasamples of memory

E8663D PSG Analog Signal Generator Features

The E8663D PSG includes the following standard features:

— a source module interface that is compatible with Keysight 83550 Series 
millimeter–wave source modules for frequency extension up to 110 GHz 
and Oleson Microwave Labs (OML) AG–Series millimeter–wave modules for 
frequency extensions up to 325 GHz

1. Instruments with serial prefix < US4829/SG4829/MY4829.
2. Instruments with serial prefix ≥ US4829/SG4829/MY4829.
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— automatic leveling control (ALC) on and off modes; power calibration in 
ALC–off mode is available, even without power search

— CW output from 100 kHz to the highest operating frequency, depending on 
the option

— external diode detector leveling

— frequency resolution to 0.001 Hz

— list and step sweep of frequency and amplitude, with multiple trigger 
sources

— optimized signal to noise ratio

— 10 MHz reference oscillator with external output

— RS–232, GPIB, and 10Base–T LAN I/O interfaces

— user flatness correction

— pulse modulation

— internal pulse generator

— external modulation inputs

— selectable pulse modes: internal square, internal free–run, internal 
triggered, internal doublet, internal gated, and external pulse; 
internal triggered, internal doublet, and internal gated require an 
external trigger source

— adjustable pulse rate

— adjustable pulse period

— adjustable pulse width (150 ns minimum)

— adjustable pulse delay

— selectable external pulse triggering: positive or negative

The E8663D PSG also offers the following optional features:

Option 007—analog ramp sweep

Option 0081—8 GB removable compact flash drive

Option 503—frequency range from 100 kHz to 3.2 GHz

Option 509—frequency range from 100 kHz to 9.0 GHz

To provide analog frequency sweeps and for optimum swept scalar measurements 
with the 8757D scalar analyzer, the E8663D requires 007 (analog ramp sweep).

1. Instruments with serial prefix ≥ US4928/SG4928/MY4928.
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Option 521—ultra 0.1-3.2 GHz (with Option 503) or 0.1-9 GHz (with Option 
509) power

Option 1E1—step attenuator

Option 1EA (Discontinued)—high output power

Option 1ED—Type–N female RF output connector

Option 1EH —improved harmonics below 2 GHz

Option 1EU—high output power (standard with E8267D)

Option 1EM—moves all front panel connectors to the rear panel

Option 1EZ—extended support life

Option 1SM—provides improved performance in Exponential (Log) AM 
mode

Option UK6—commercial calibration certificate and test data

Option UNX—ultra low phase noise

Option UNY—enhanced ultra low phase noise

Option UNT—AM, FM, phase modulation, and LF output

— open–loop or closed–loop AM

— dc–synthesized FM to 10 MHz rates; maximum deviation depends on 
the carrier frequency

— external modulation inputs for AM, FM, and ΦM

— simultaneous modulation configurations (except: FM with ΦM or 
Linear AM with Exponential AM)

— dual function generators that include the following:

——50–ohm low–frequency output, 0 to 3 Vp, available through 
the LF output

——selectable waveforms: sine, dual–sine, swept–sine, triangle, 
positive ramp, negative ramp, square, uniform noise, Gaussian 
noise, and dc

——adjustable frequency modulation rates

——selectable triggering in list and step sweep modes: free run 
(auto), trigger key (single), bus (remote), and external

Option UNW—narrow pulse modulation

— generate narrow pulses across the operational frequency band of the 
PSG

— includes all the same functionality as Option UNU
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Options
PSG signal generators have hardware, firmware, software, and documentation 
options. The Data Sheet shipped with your signal generator provides an 
overview of available options. For more information, visit the Keysight PSG web 
page at http://www.keysight.com/find/psg, select the desired PSG model, 
and then click the Options tab.

Firmware Upgrades
You can upgrade the firmware in your signal generator whenever new firmware 
is released. New firmware releases, which can be downloaded from the 
Keysight website, may contain signal generator features and functionality not 
available in previous firmware releases.

To determine the availability of new signal generator firmware, visit the Signal 
Generator Firmware Upgrade Center web page at 
http://www.keysight.com/find/upgradeassistant, or call the number listed at 
http://www.keysight.com/find/assist.

To Upgrade Firmware

The following procedure shows you how to download new firmware to your 
PSG using a LAN connection and a PC. For information on equipment 
requirements and alternate methods of downloading firmware, such as GPIB, 
refer to the Firmware Upgrade Guide, which can be accessed at 
http://www.keysight.com/find/upgradeassistant. 

1. Note the IP address of your signal generator. To view the IP address on the 
PSG, press Utility > GPIB/RS–232 LAN > LAN Setup.

2. Use an internet browser to visit 
http://www.keysight.com/find/upgradeassistant.

3. Scroll down to the “Documents and Downloads” table and click the link in 
the “Latest Firmware Revision” column for the E8257D/67D or E8663D 
PSG.

4. In the File Download window, select Run.

5. In the Welcome window, click Next and follow the on–screen instructions. 
The firmware files download to the PC.

6. In the “Documents and Downloads” table, click the link in the “Upgrade 
Assistant Software” column for the E8257D/67D or E8663D PSG to 
download the PSG/ESG Upgrade Assistant.

7. In the File Download window, select Run.

8. In the Welcome window, click OK and follow the on–screen instructions. 

9. At the desktop shortcut prompt, click Yes.
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10.Once the utility downloads, close the browser and double–click the 
PSG/ESG Upgrade Assistant icon on the desktop.

11.In the upgrade assistant, set the connection type you wish to use to 
download the firmware, and the parameters for the type of connection 
selected. For LAN, enter the instrument’s IP address, which you recorded 
in step 1.

12.Click Browse, and double–click the firmware revision to upgrade your 
signal generator.

13.In the Upgrade Assistant, click Next.

14.Once connection to the instrument is verified, click Next and follow the 
on–screen prompts.

When the upgrade completes, the Upgrade Assistant displays a summary.

15.Click OK and close the Upgrade Assistant.

If the PSG’s dynamic host configuration protocol (DHCP) is enabled, the network 
assigns the instrument an IP address at power on. Because of this, when DHCP is 
enabled, the IP address may be different each time you turn on the instrument. 
DHCP does not affect the hostname.

Once the download starts, it cannot be aborted.

When the User Attention message appears, you must first cycle the instrument’s power, then 
click OK.
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Modes of Operation
Depending on the model and installed options, the PSG signal generator 
provides up to four basic modes of operation: continuous wave (CW), swept 
signal, analog modulation, and digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The 
signal generator is set to a single frequency and power level. The E8257D, 
E8267D, and E8663D can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or 
power levels. The E8257D, E8267D, and E8663D provide list and step sweep 
functionality. Option 007 adds analog ramp sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog 
signal. The analog modulation types available depend on the installed options.

Option UNT provides amplitude, frequency, and phase modulations. Some of 
these modulations can be used together. Options UNU and UNW provide 
standard and narrow pulse modulation capability, respectively. Option UNU is 
standard on the E8663D. 

Option 1SM provides improved Exponential (Log) AM mode. 

Digital Modulation

In this mode, the signal generator modulates a CW signal with either a 
real–time I/Q signal or arbitrary I/Q waveform. I/Q modulation is only available 
on the E8267D. An internal baseband generator (Option 601/602) adds the 
following digital modulation formats:

— Custom Arb Waveform Generator mode can produce a single–modulated 
carrier or multiple–modulated carriers. Each modulated carrier waveform 
must be calculated and generated before it can be output; this signal 
generation occurs on the internal baseband generator. Once a waveform 
has been created, it can be stored and recalled, which enables repeatable 
playback of test signals. To learn more, refer to “Custom Arb Waveform 
Generator” on page 199.

— Custom Real Time I/Q Baseband mode produces a single carrier, but it can 
be modulated with real–time data that allows real–time control over all of 
the parameters that affect the signal. The single–carrier signal that is 
produced can be modified by applying various data patterns, filters, symbol 
rates, modulation types, and burst shapes. To learn more, refer to “Custom 
Real Time I/Q Baseband” on page 227.
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— Two Tone mode produces two separate continuous wave signals (or tones). 
The frequency spacing between the two signals and the amplitudes are 
adjustable. To learn more, refer to “ Two–Tone Waveform Generator” on 
page 277.

— Multitone mode produces up to 64 continuous wave signals (or tones). Like 
Two Tone mode, the frequency spacing between the signals and the 
amplitudes are adjustable. To learn more, refer to “Multitone Waveform 
Generator” on page 265.

— Dual ARB mode is used to control the playback sequence of waveform 
segments that have been written into the ARB memory located on the 
internal baseband generator. These waveforms can be generated by the 
internal baseband generator using the Custom Arb Waveform Generator 
mode, or downloaded through a remote interface into the ARB memory. To 
learn more, refer to “Using the Dual ARB Waveform Player” on page 117.
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Front Panel
This section describes each item on the PSG front panel. Figure 1-1 shows an 
E8267D front panel, which includes all items available on the E8257D and 
E8663D.

Figure 1-1 Standard E8267D Front Panel Diagram

Table 1-2 

1. Display 10. Help 19. SYNC OUT 28. Local 

2. Softkeys 11. EXT 1 INPUT 20. VIDEO OUT 29. Preset 

3. Knob 12. EXT 2 INPUT 21. Incr Set 30. Line Power 
LED 

4. 
Amplitude 

13. LF OUTPUT 22. GATE/ PULSE/ TRIGGER 
INPUT 

31. LINE 
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Frequency 
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1. Display

The LCD screen provides information on the current function. Information can 
include status indicators, frequency and amplitude settings, and error 
messages. Softkeys labels are located on the right–hand side of the display. 
For more detail on the front panel display, see “Front Panel Display” on 
page 35.

2. Softkeys

Softkeys activate the displayed function to the left of each key.

3. Knob

Use the knob to increase or decrease a numeric value, change a highlighted 
digit or character, or step through lists or select items in a row.

4. Amplitude

Pressing this hardkey makes amplitude the active function. You can change the 
output amplitude or use the menus to configure amplitude attributes such as 
power search, user flatness, and leveling mode.

5. Frequency

Pressing this hardkey makes frequency the active function. You can change the 
output frequency or use the menus to configure frequency attributes such as 
frequency multiplier, offset, and reference.

7. Recall 16. RF On/Off 25. Return 34. DATA 
CLOCK 

8. Trigger 17. Numeric 
Keypad 

26. Contrast Decrease 35. DATA 

9. MENUS 18. RF OUTPUT 27. Contrast Increase 36. Q Input 

37. I Input 

Table 1-2 
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6. Save

Pressing this hardkey displays a menu of choices that enable you to save data 
in the instrument state register. The instrument state register is a section of 
memory divided into 10 sequences (numbered 0 through 9), each containing 
100 registers (numbered 00 through 99). It is used to store and recall 
frequency, amplitude, and modulation settings.

The Save hardkey provides a quick alternative to reconfiguring the signal 
generator through the front panel or SCPI commands when switching between 
different signal configurations. Once an instrument state has been saved, all of 
the frequency, amplitude, and modulation settings can be recalled with the 
Recall hardkey. For more information on saving and recalling instrument 
states, refer to “Using the Instrument State Registers” on page 86.

7. Recall

This key restores an instrument state saved in a memory register. To recall an 
instrument state, press Recall and enter the desired sequence number and 
register number. To save a state, use the Save hardkey. For more information 
on saving and recalling instrument states, refer to “Using the Instrument State 
Registers” on page 86.

The Save hardkey does not save table configurations, such as list sweep, 
multitone, or ARB.
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8. Trigger

This key initiates an immediate trigger event for a function such as a list, step, 
or ramp sweep (Option 007 only). Before this hardkey can be used to initiate a 
trigger event, the trigger mode must be set to Trigger Key. For example: press 
the Sweep/List hardkey, then one of the following sequences of softkeys:

— More (1 of 2) > Sweep Trigger > Trigger Key 
— More (1 of 2) > Point Trigger > Trigger Key

9. MENUS

These keys open softkey menus for configuring various functions. For 
descriptions, see the Keysight PSG Signal Generators Key Reference.

10. Help

Pressing this hardkey causes a short description of any hardkey or softkey to be 
displayed and, in most cases, a listing of related remote–operation SCPI 
commands. There are two help modes available on the signal generator: single 
and continuous. The single mode is the factory preset condition. Toggle 
between single and continuous mode by pressing Utility > Instrument 
Info/Help Mode > Help Mode Single Cont.

— In single mode, help text is provided for the next key you press without 
activating the key’s function. Any key pressed afterward exits the help mode 
and its function is activated.

— In continuous mode, help text is provided for each subsequent key press 
until you press the Help hardkey again or change to single mode. In 
addition, each key is active, meaning that the key function is executed 
(except for the Preset key).

Table 1-3 Hardkeys in Front Panel MENUS Group

E8257D and E8663D PSG Analog E8267D PSG Vector

AM
Sweep/List
FM/FM
Utility
Pulse
LF Out

Mode
Mux
AM
Sweep/List
Mode Setup
Aux Fctn

FM/FM
Utility
I/Q
Pulse
LF Out

Some menus are optional. Refer to “Options” on page 22 for more information.
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11. EXT 1 INPUT

This female BNC input connector (functional only with Options UNT, UNU, or 
UNW or on the E8663D) accepts a ±1 Vp signal for AM, FM, and ΦM. For these 
modulations, ±1 Vp produces the indicated deviation or depth. When 
ac–coupled inputs are selected for AM, FM, or ΦM and the peak input voltage 
differs from 1 Vp by more than 3 percent, the HI/LO display annunciators light. 
The input impedance is selectable as either 50 or 600 ohms; the damage levels 
are 5 Vrms and 10 Vp. On signal generators with Option 1EM, this connector is 
located on the rear panel.

12. EXT 2 INPUT

This female BNC input connector (functional only with Options UNT, UNU, or 
UNW or on the E8663D) accepts a ±1 Vp signal for AM, FM, and ΦM. With AM, 
FM, or ΦM, ±1 Vp produces the indicated deviation or depth. When 
ac–coupled inputs are selected for AM, FM, or ΦM and the peak input voltage 
differs from 1 Vp by more than 3 percent, the HI/LO annunciators light on the 
display. The input impedance is selectable as either 50 or 600 ohms and 
damage levels are 5 Vrms and 10 Vp. On signal generators with Option 1EM, 
this connector is located on the rear panel.

13. LF OUTPUT

This female BNC output connector (functional only with Option UNT or on the 
E8663D) outputs modulation signals generated by the low frequency (LF) 
source function generator. This output is capable of driving 3Vp (nominal) into 
a 50 ohm load. On signal generators with Option 1EM, this connector is 
located on the rear panel.

14. Mod On/Off

This hardkey (E8267D and E8257D with Options UNT, UNU, or UNW) enables 
or disables all active modulation formats (AM, FM, ΦM, Pulse, or I/Q) applied 
to the output carrier signal available through the RF OUTPUT connector. This 
hardkey does not set up or activate an AM, FM, ΦM, Pulse, or I/Q format; each 
modulation format must still be set up and activated (for example, AM > AM 
On) or nothing is applied to the output carrier signal when the Mod On/Off 
hardkey is enabled. The MOD ON/OFF annunciator indicates whether active 
modulation formats have been enabled or disabled with the Mod On/Off 
hardkey.

15. ALC INPUT

This female BNC input connector is used for negative external detector 
leveling. This connector accepts an input of −0.2 mV to −0.5 V. The nominal 
input impedance is 120 kohms and the damage level is ±15 V. On signal 
generators with Option 1EM, this connector is located on the rear panel.
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16. RF On/Off

Pressing this hardkey toggles the operating state of the RF signal present at 
the RF OUTPUT connector. Although you can set up and enable various 
frequency, power, and modulation states, the RF and microwave output signal 
is not present at the RF OUTPUT connector until RF On/Off is set to On. The RF 
On/Off annunciator is always visible in the display to indicate whether the RF is 
turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point 
hardkey, and a backspace hardkey ( ). The backspace hardkey enables 
you to backspace or alternate between a positive and a negative value. When 
specifying a negative numeric value, the negative sign must be entered prior to 
entering the numeric value.

18. RF OUTPUT

This connector outputs RF and microwave signals. The nominal output 
impedance is 50 ohms. The reverse–power damage levels are 0 Vdc, 0.5 watts 
nominal. On signal generators with Option 1EM, this connector is located on 
the rear panel. The connector type varies according to frequency option.

19. SYNC OUT

This female BNC output connector (functional only with Options UNU or UNW 
or on the E8663D) outputs a synchronizing TTL–compatible pulse signal that is 
nominally 50 ns wide during internal and triggered pulse modulation. The 
nominal source impedance is 50 ohms. On signal generators with Option 1EM, 
this connector is located on the rear panel.

20. VIDEO OUT

This female BNC output connector (functional only with Options UNU or UNW 
or on the E8663D) outputs a TTL–level compatible pulse signal that follows the 
output envelope in all pulse modes. The nominal source impedance is 
50 ohms. On signal generators with Option 1EM, this connector is located on 
the rear panel.

21. Incr Set

This hardkey enables you to set the increment value of the current active 
function. The increment value of the current active function appears in the 
active entry area of the display. Use the numeric keypad, arrow hardkeys, or 
the knob to adjust the increment value.
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22. GATE/ PULSE/ TRIGGER INPUT

This female BNC input connector (functional only with Options UNU or UNW or 
on the E8663D) accepts an externally supplied pulse signal for use as a pulse 
or trigger input. With pulse modulation, +1 V is on and 0 V is off (trigger 
threshold of 0.5 V with a hysteresis of 10 percent; so 0.6 V would be on and 0.4 
V would be off). The damage levels are ±5 Vrms and 10 Vp. The nominal input 
impedance is 50 ohms. On signal generators with Option 1EM, this connector 
is located on the rear panel.

23. Arrow Keys

These up and down arrow hardkeys are used to increase or decrease a numeric 
value, step through displayed lists, or to select items in a row of a displayed 
list. Individual digits or characters may be highlighted using the left and right 
arrow hardkeys. Once an individual digit or character is highlighted, its value 
can be changed using the up and down arrow hardkeys.

24. Hold

Pressing this hardkey blanks the softkey label area and text areas on the 
display. Softkeys, arrow hardkeys, the knob, the numeric keypad, and the Incr 
Set hardkey have no effect once this hardkey is pressed.

25. Return

Pressing this hardkey displays the previous softkey menu. It enables you to 
step back through the menus until you reach the first menu you selected.

26. Contrast Decrease

Pressing this hardkey causes the display background to darken.

27. Contrast Increase

Pressing this hardkey causes the display background to lighten.

28. Local

Pressing this hardkey deactivates remote operation and returns the signal 
generator to front–panel control.

29. Preset

Pressing this hardkey sets the signal generator to a known state (factory or 
user–defined).
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30. Line Power LED

This green LED indicates when the signal generator power switch is set to the 
on position.

31. LINE

In the on position, this switch activates full power to the signal generator; in 
standby, it deactivates all signal generator functions. In standby, the signal 
generator remains connected to the line power and power is supplied to some 
internal circuits.

32. Standby LED

This yellow LED indicates when the signal generator power switch is set to the 
standby condition.

33. SYMBOL SYNC

This female BNC input connector is CMOS–compatible and accepts an 
externally supplied symbol sync signal for use with the internal baseband 
generator (Option 601/602). The expected input is a 3.3 V CMOS bit clock 
signal (which is also TTL compatible). SYMBOL SYNC might occur once per 
symbol or be a single one–bit–wide pulse that is used to synchronize the first 
bit of the first symbol. The maximum clock rate is 50 MHz. The damage levels 
are > +5.5 V and < −0.5V. The nominal input impedance is not definable. 
SYMBOL SYNC can be used in two modes:

— When used as a symbol sync in conjunction with a data clock, the signal 
must be high during the first data bit of the symbol. The signal must be 
valid during the falling edge of the data clock signal and may be a single 
pulse or continuous.

— When the SYMBOL SYNC itself is used as the (symbol) clock, the CMOS 
falling edge is used to clock the DATA signal.

On signal generators with Option 1EM, this connector is located on the rear 
panel.

34. DATA CLOCK

This female BNC input connector is CMOS compatible and accepts an 
externally supplied data–clock input signal to synchronize serial data for use 
with the internal baseband generator (Option 601/602). The expected input is 
a 3.3 V CMOS bit clock signal (which is also TTL compatible) where the rising 
edge is aligned with the beginning data bit. The falling edge is used to clock 
the DATA and SYMBOL SYNC signals. The maximum clock rate is 50 MHz. The 
damage levels are > +5.5 V and < −0.5V. The nominal input impedance is not 
definable. On signal generators with Option 1EM, this connector is located on 
the rear panel.
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35. DATA

This female BNC input connector (Options 601/602 only) is CMOS compatible 
and accepts an externally supplied serial data input for digital modulation 
applications. The expected input is a 3.3 V CMOS signal (which is also TTL 
compatible) where a CMOS high = a data 1 and a CMOS low = a data 0. The 
maximum input data rate is 50 Mb/s. The data must be valid on the falling 
edges of the data clock (normal mode) or the on the falling edges of the 
symbol sync (symbol mode). The damage levels are > +5.5 and < −0.5V. The 
nominal input impedance is not definable. On signal generators with Option 
1EM, this connector is located on the rear panel.

36. Q Input

This female BNC input connector (E8267D only) accepts the quadrature–phase 
(Q) component of an externally supplied, analog, I/Q modulation. The in–phase 
(I) component is supplied through the I INPUT. The signal level is  = 

0.5 Vrms for a calibrated output level. The nominal input impedance is 50 or 
600 ohms. The damage level is 1 Vrms and 10 Vpeak. To activate signals applied 
to the I and Q input connectors, press Mux > I/Q Source 1 or I/Q Source 2 and 
then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with 
Option 1EM, these connectors are located on the rear panel.

37. I Input

This female BNC input connector (E8267D only) accepts the in–phase (I) 
component of an externally supplied, analog, I/Q modulation. The 
quadrature–phase (Q) component is supplied through the Q INPUT. The signal 
level is  = 0.5 Vrms for a calibrated output level. The nominal input 

impedance is 50 or 600 ohms. The damage level is 1 Vrms and 10 Vpeak. To 
activate signals applied to the I and Q input connectors, press Mux > I/Q 
Source 1 or I/Q Source 2 and then select either Ext 50 Ohm or Ext 600 Ohm. 
On signal generators with Option 1EM, these connectors are located on the 
rear panel.
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Front Panel Display
Figure 1-2 shows the various regions of the PSG display. This section describes 
each region.

Figure 1-2 Front Panel Display Diagram

Table 1-4 

1. Active Entry Area 5. Amplitude Area

2. Frequency Area 6. Error Message Area

3. Annunciators 7. Text Area

4. Digital Modulation Annunciators 8. Softkey Label Area
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1. Active Entry Area

The current active function is shown in this area. For example, if frequency is 
the active function, the current frequency setting will be displayed here. If the 
current active function has an increment value associated with it, that value is 
also displayed. 

2. Frequency Area

The current frequency setting is shown in this portion of the display. Indicators 
are also displayed in this area when the frequency offset or multiplier is used, 
the frequency reference mode is turned on, or a source module is enabled.

3. Annunciators

The display annunciators show the status of some of the signal generator 
functions and indicate any error conditions. An annunciator position may be 
used by more than one function. This does not create a problem, because only 
one function that shares an annunciator position can be active at a time.

ΦM  This annunciator (Option UNT only) appears when 
phase modulation is on. If frequency modulation is on, 
the FM annunciator replaces ΦM.

ALC OFF  This annunciator appears when the ALC circuit is 
disabled. A second annunciator, UNLEVEL, appears in 
the same position if the ALC is enabled and cannot 
maintain the output level.

AM  This annunciator (Option UNT only) appears when 
amplitude modulation is on.

ARMED  This annunciator appears when a sweep has been 
initiated and the signal generator is waiting for the 
sweep trigger event.

ATTEN HOLD  This annunciator (E8267D, E8257D, or E8663D with 
Option 1E1 only) appears when the attenuator hold 
function is on. When this function is on, the attenuator 
is held at its current setting. 

DIG BUS  This annunciator (Options 003/004 only) appears when 
the digital bus is active, and the internal oven reference 
oscillator is not cold (OVEN COLD appears in this same 
location). 

ENVLP  This annunciator appears if a burst condition exists, 
such as when marker 2 is set to enable RF blanking in 
the Dual ARB format. 
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ERR  This annunciator appears when an error message is in 
the error queue. This annunciator does not turn off until 
you either view all the error messages or cleared the 
error queue. To access error messages, press Utility > 
Error Info.

EXT  This annunciator appears when external leveling is on.

EXT1 LO/HI  This annunciator (Options UNT, UNU, or UNW only or 
on the E8663D) appears as either EXT1 LO or EXT1 HI, 
when the ac–coupled signal to the EXT 1 INPUT is < 
0.97 Vp or > 1.03 Vp.

EXT2 LO/HI  This annunciator (Options UNT, UNU, or UNW only or 
on the E8663D) is displayed as either EXT2 LO or 
EXT2 HI. This annunciator appears when the 
ac–coupled signal to the EXT 2 INPUT is < 0.97 Vp or > 
1.03 Vp.

EXT REF  This annunciator appears when an external frequency 
reference is applied.

FM  This annunciator (Option UNT only) appears when 
frequency modulation is turned on. If phase modulation 
is turned on, the ΦM annunciator will replace FM.

I/Q  This annunciator (E8267D only) appears when I/Q 
modulation is turned on.

L  This annunciator appears when the signal generator is 
in listener mode and is receiving information or 
commands over the RS–232, GPIB, or VXI–11 LAN 
interface.

MOD ON/OFF  This annunciator (E8267D and E8257D with Options 
UNT, UNU, or UNW only or on the E8663D) indicates 
whether active modulation formats have been enabled 
or disabled. Pressing the Mod On/Off hardkey enables 
or disables all active modulation formats (AM, FM, ΦM, 
Pulse, or I/Q) that are applied to the output carrier 
signal available through the RF OUTPUT connector. The 
Mod On/Off hardkey does not set up or activate an AM, 
FM, ΦM, Pulse, or I/Q format; each individual 
modulation format must still be set up and activated 
(for example, AM > AM On) or nothing will be applied to 
the output carrier signal when the Mod On/Off hardkey 
is enabled.

OVEN COLD  This annunciator (Option UNR/UNX only) appears when 
the temperature of the internal oven reference oscillator 
has dropped below an acceptable level. When this 
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annunciator is on, frequency accuracy is degraded. This 
condition should occur for several minutes after the 
signal generator is first connected to line power.

PULSE  This annunciator (Options UNU or UNW only or on the 
E8663D) appears when pulse modulation is on.

R  This annunciator appears when the signal generator is 
remotely controlled over the GPIB, RS–232, or 
VXI–11/Sockets LAN interface (TELNET operation does 
not activate the R annunciator). When the R 
annunciator is on, the front panel keys are disabled, 
except for the Local key and the line power switch. For 
information on remote operation, refer to the Keysight 
PSG Signal Generators Programming Guide.

RF ON/OFF  This annunciator indicates when the RF or microwave 
signal is present (RF ON) or not present (RF OFF) at the 
RF OUTPUT. Either condition of this annunciator is 
always visible in the display.

S  This annunciator appears when the signal generator has 
generated a service request (SRQ) over the RS–232, 
GPIB, or VXI–11 LAN interface.

SWEEP  This annunciator appears when the signal generator is 
in list, step, or ramp sweep mode (ramp sweep is 
available with Option 007 only). List mode is when the 
signal generator can jump from point to point in a list 
(hop list); the list is traversed in ascending or 
descending order. The list can be a frequency list, a 
power level list, or both. Step mode is when a start, 
stop, and step value (frequency or power level) are 
defined and the signal generator produces signals that 
start at the start value and increment by the step value 
until it reaches the stop value. Ramp sweep mode 
(Option 007 only) is when a start and stop value 
(frequency or power level) are defined and the signal 
generator produces signals that start at the start value 
and produce a continuous output until it reaches the 
stop value.

T  This annunciator appears when the signal generator is 
in talker mode and is transmitting information over the 
GPIB, RS–232, or VXI–11 LAN interface.

UNLEVEL  This annunciator appears when the signal generator is 
unable to maintain the correct output level. The 
UNLEVEL annunciator is not necessarily an indication of 
instrument failure. Unleveled conditions can occur 
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during normal operation. A second annunciator, 
ALC OFF, will appear in the same position when the 
ALC circuit is disabled.

UNLOCK  This annunciator appears when any of the phase locked 
loops are unable to maintain phase lock. You can 
determine which loop is unlocked by examining the 
error messages.

4. Digital Modulation Annunciators

All digital modulation annunciators (E8267D with Option 601/602 only) appear 
in this location. These annunciators appear only when the modulation is active, 
and only one digital modulation can be active at any given time.

5. Amplitude Area

The current output power level setting is shown in this portion of the display. 
Indicators are also displayed in this area when amplitude offset is used, 
amplitude reference mode is turned on, external leveling mode is enabled, a 
source module is enabled, and when user flatness is enabled.

6. Error Message Area

Abbreviated error messages are reported in this space. When multiple error 
messages occur, only the most recent message remains displayed. Reported 
error messages with details can be viewed by pressing Utility > Error Info.

7. Text Area

This text area of the display:

— shows signal generator status information, such as the modulation status, 
sweep lists, and file catalogs

— displays the tables

— enables you to perform functions such as managing information, entering 
information, and displaying or deleting files

8. Softkey Label Area

The labels in this area define the function of the softkeys located immediately 
to the right of the label. The softkey label may change depending upon the 
function selected.

ARB Dual Arbitrary Waveform Generator M–TONE Multitone Waveform Generator

CUSTOM Custom Real Time I/Q Baseband T–TONE Two–Tone Waveform Generator

DIGMOD Custom Arb Waveform Generator
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Rear Panel
This section describes each item on the PSG rear panel. Four consecutive 
drawings show the standard and Option 1EM rear panels for the E8267D, 
E8257D, and the E8663D. (Option 1EM moves all front panel connectors to the 
real panel.)

Figure 1-3 Standard E8267D Rear Panel

Table 1-5 

1. EVENT 1 11. WIDEBAND Q INPUTS 21. LAN

2. EVENT 2 12. COH CARRIER (Serial Prefixes 
>=US4646/MY4646)

22. 10 MHz OUT

3. PATTERN TRIG IN 13. 1 GHz REF OUT (Serial Prefixes 
>=US4646/MY4646)

23. STOP SWEEP IN/OUT

4. BURST GATE IN 14. Q–bar OUT 24. BASEBAND GEN CLK IN

5. AUXILIARY I/O 15. AC Power Receptacle 25. Z–AXIS BLANK/MKRS

6. DIGITAL BUS 16. GPIB 26. SWEEP OUT

7. Q OUT 17. 10 MHz EFC 27. TRIGGER OUT

8. I OUT 18. ALC HOLD (Serial Prefixes 
>=US4722/MY4722)

28. TRIGGER IN

9. WIDEBAND I INPUTS 19. AUXILIARY INTERFACE 29. SOURCE SETTLED

10. I–bar OUT 20. 10 MHz IN 30. SOURCE MODULE INTERFACE
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Figure 1-4 E8267D Option 1EM Rear Panel

44. Flash Drive (Serial Prefixes 
>=US4829/SG4829/MY4829 
(E8267D) and 
>=US4928/SG4928/MY4928 
(E8257D))

Table 1-6 

1. EVENT 1 16. GPIB 31. RF OUT

2. EVENT 2 17. 10 MHz EFC 32. EXT 1

3. PATTERN TRIG IN 18. ALC HOLD (Serial Prefixes 
>=US4722/MY4722)

33. EXT 2

4. BURST GATE IN 19. AUXILIARY INTERFACE 34. PULSE SYNC OUT

5. AUXILIARY I/O 20. 10 MHz IN 35. PULSE VIDEO OUT

6. DIGITAL BUS 21. LAN 36. PULSE/TRIG GATE INPUT

7. Q OUT 22. 10 MHz OUT 37. ALC INPUT

8. I OUT 23. STOP SWEEP IN/OUT 38. DATA CLOCK

9. WIDEBAND I INPUTS 24. BASEBAND GEN CLK IN 39. I IN

10. I–bar OUT 25. Z–AXIS BLANK/MKRS 40. SYMBOL SYNC 

Table 1-5 
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Figure 1-5 Standard E8257D and E8663D Rear Panel

11. WIDEBAND Q INPUTS 26. SWEEP OUT 42. DATA

12. COH CARRIER (Serial Prefixes 
>=US4646/MY4646)

27. TRIGGER OUT 41. Q IN

13. 1 GHz REF OUT (Serial Prefixes 
>=US4646/MY4646)

28. TRIGGER IN 43. LF OUT

14. Q–bar OUT 29. SOURCE SETTLED

15. AC Power Receptacle 30. SOURCE MODULE INTERFACE

Table 1-7 

5. AUXILIARY I/O 19. AUXILIARY INTERFACE 26. SWEEP OUT

12. COH CARRIER (Serial Prefixes 
>=US4646/MY4646)

20. 10 MHz IN 27. TRIGGER OUT

13. 1 GHz REF OUT (Serial Prefixes 
>=US4646/MY4646)

21. LAN 28. TRIGGER IN

15. AC Power Receptacle 22. 10 MHz OUT 29. SOURCE SETTLED

16. GPIB 23. STOP SWEEP IN/OUT 30. SOURCE MODULE INTERFACE

17. 10 MHz EFC 25. Z–AXIS BLANK/MKRS 44. Flash Drive (Serial Prefixes 
>=US4829/SG4829/MY4829 
(E8267D) and 
>=US4928/SG4928/MY4928 
(E8257D))

Table 1-6 

30 44 22 13 20

29 28 27 26 25 23 21 19 17 16 15
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Figure 1-6 E8257D and E8663D Option 1EM Rear Panel

Table 1-8 

13. 1 GHz REF OUT (Serial Prefixes 
>=US4646/MY4646)

22. 10 MHz OUT 32. EXT 1

15. AC Power Receptacle 23. STOP SWEEP IN/OUT 33. EXT 2

16. GPIB 25. Z–AXIS BLANK/MKRS 34. PULSE SYNC OUT

17. 10 MHz EFC 26. SWEEP OUT 35. PULSE VIDEO OUT

19. AUXILIARY INTERFACE 27. TRIGGER OUT 36. PULSE/TRIG GATE INPUT

20. 10 MHz IN 28. TRIGGER IN 37. ALC INPUT

21. LAN 29. SOURCE SETTLED 43. LF OUT

31. RF OUT 44. Flash Drive (Serial Prefixes 
>=US4829/SG4829/MY4829 
(E8267D) and 
>=US4928/SG4928/MY4928 
(E8257D))

29 28 27 26 25 23 21 19 17 16 15

30 44 22 13203736353443333231
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1. EVENT 1

This female BNC connector is used with an internal baseband generator 
(Option 601/602). On signal generators without Option 601/602, this female 
BNC connector is non–functional.

In real–time mode, the EVENT 1 connector outputs a pattern or frame 
synchronization pulse for triggering or gating external equipment. It may be set 
to start at the beginning of a pattern, frame, or timeslot and is adjustable to 
within ± one timeslot with one bit resolution.

In arbitrary waveform mode, the EVENT 1 connector outputs a timing signal 
generated by Marker 1. A marker (3.3 V CMOS high for both positive and 
negative polarity) is output on the EVENT 1 connector whenever a Marker 1 is 
turned on in the waveform.

The reverse damage levels for this connector are > +8 V and < −4 V. The 
nominal output impedance is not defined.

2. EVENT 2

This female BNC connector is used with an internal baseband generator 
(Option 601/602). On signal generators without Option 601/602, this female 
BNC connector is non–functional.

In real–time mode, the EVENT 2 connector outputs a data enable signal for 
gating external equipment. This is applicable when external data is clocked 
into internally generated timeslots. Data is enabled when the signal is low.

In arbitrary waveform mode, the EVENT 2 connector outputs a timing signal 
generated by Marker 2. A marker (3.3 V CMOS high for both positive and 
negative polarity) is output on the EVENT 2 connector whenever a Marker 2 is 
turned on in the waveform.

The reverse damage levels for this connector are > +8 V and < −4 V. The 
nominal output impedance is not defined.

3. PATTERN TRIG IN

This female BNC connector is used with an internal baseband generator 
(Option 601/602). On signal generators without Option 601/602, this female 
BNC connector is non–functional. This connector accepts a signal that triggers 
an internal pattern or frame generator to start a single–pattern output. 
Minimum pulse width is 100 ns. Damage levels are > +5.5 V and < −0.5 V. The 
nominal input impedance is not defined.
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4. BURST GATE IN

This female BNC connector is used with an internal baseband generator 
(Option 601/602). On signal generators without Option 601/602, this 
connector is non–functional. This connector accepts a 3–volt CMOS input 
signal for gating burst power. Burst gating is used when you are externally 
supplying data and clock information.

The input signal must be synchronized with the external data input that will be 
output during the burst. The burst power envelope and modulated data are 
internally delayed and re–synchronized. The input signal must be CMOS high 
for normal burst RF power or CW RF output power and CMOS low for RF off. 
Damage levels are > +5.5 V and < −0.5 V. The nominal input impedance is not 
defined.

5. AUXILIARY I/O

This female 37–pin connector is active only on instruments with an internal 
baseband generator (Option 601/602); on signal generators without Option 
601/602, this connector is non–functional. This connector provides access to 
the inputs and outputs described in the following figure.
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Figure 1-7 Auxiliary I/O Connector (Female 37–Pin) 

6. DIGITAL BUS

This is a proprietary bus used for Keysight Baseband Studio products, which 
require an E8267D with Options 003/004 and 601/602. This connector is not 
operational for general–purpose customer use. Signals are present only when 
a Baseband Studio option is installed (for details, refer to 
http://www.keysight.com/find/basebandstudio). The DIG BUS annunciator 
appears on the display when the Digital Bus is active (and the internal oven 
reference oscillator is not cold—OVEN COLD appears in this same location).

7. Q OUT

This female BNC connector (E8267D only) is used with an internal baseband 
generator (Option 601/602) to output the analog, quadrature–phase 
component of I/Q modulation. On signal generators without Option 601/602, 

ALT PWR IN: Used with an internal baseband 
generator. This pin accepts a CMOS signal for 
synchronization of external data and alternate power 
signal timing. Damage levels are > +8 V and < −4 V.

View looking into
rear panel connector

DATA CLK OUT: Used with an internal baseband 
generator. This pin relays a CMOS bit clock signal for 
synchronizing serial data.

DATA OUT: Used with an internal baseband generator. 
This pin outputs data (CMOS) from the internal data 
generator or the externally supplied signal at data input. 

EVENT 3: Used with an internal baseband generator. In arbitrary waveform mode, 
this pin outputs a timing signal generated by Marker 3. A marker (3.3 V CMOS 
high for both positive and negative polarity) is output on this pin when a Marker 3 is 
turned on in the waveform. Reverse damage levels: > +8 V and < −4 V.

PATT TRIG IN 2: Accepts a signal that triggers an 
internal pattern or frame generator to start single 
pattern output. Minimum pulse width: 100 ns. 
Damage levels: > +5.5 V and < −0.5 V.

SYM SYNC OUT: Used with an internal baseband 
generator. This pin outputs the CMOS symbol clock for 
symbol synchronization, one data clock period wide.

EVENT 4: Used with an internal baseband generator. In arbitrary 
waveform mode, this pin outputs a timing signal generated by 
Marker 4. A marker (3.3V CMOS high for both positive and 

negative polarity) is output on this pin when a Marker 4 is 
turned on in the waveform. Reverse damage levels: > +8 V 
and < −4 V.
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this female BNC connector is used to output the quadrature–phase component 
of an external I/Q modulation that has been fed into the Q input connector. The 
nominal output impedance of the Q OUT connector is 50 ohms, dc–coupled.

8. I OUT

This female BNC connector (E8267D only) is used with an internal baseband 
generator (Option 601/602) to output the analog, in–phase component of I/Q 
modulation. On signal generators without Option 601/602, this female BNC 
connector is used to output the in–phase component of an external I/Q 
modulation that has been fed into the I input connector. The nominal output 
impedance of the I OUT connector is 50 ohms, dc–coupled.

9. WIDEBAND I INPUTS

These female SMA connectors: I IN (+) and I–bar IN (−) (Option 016 only) are 
used with differential wideband external I/Q inputs. They accept wideband AM 
and allow direct high–bandwidth analog inputs to the I/Q modulator in the 
3.2-44 GHz range (frequency limit is dependant on the option). This input is 
not calibrated. The recommended input power level is −1 dBm with a +/− 1 
VDC input voltage. The nominal impedance for this connector is 50 ohms.

The signal generator uses lowside mixing in the 20–28.5 GHz frequency range 
(Options 532 and 544), which reverses the phase relationship for I and Q 
signals. For internally generated I/Q signals the signal generator’s firmware 
compensates for this. However, for wideband external I/Q inputs (Option 016) 
there is no compensation and the I and Q inputs at the rear panel must be 
reversed to maintain the correct phase relationships in this frequency band. 
Refer to the Data Sheet and to the A37 Upconverter description in the 
Keysight PSG Signal Generators Service Guide for more information.

For instruments with Option 015 (discontinued), single–ended wideband I/Q, 
there is a single BNC I input. The recommended power level at this input 
connector is 0 dBM.

10. I–bar OUT

This female BNC connector (E8267D only) is used with an internal baseband 
generator (Option 601/602) to output the complement of the analog, in–phase 
component of I/Q modulation. On signal generators without Option 601/602, 
this female BNC connector is used to output the complement of the in–phase 
component of an external I/Q modulation that has been fed into the I input 
connector. 

I–bar OUT is used in conjunction with I OUT to provide a balanced baseband 
stimulus. Balanced signals are signals present in two separate conductors that 
are symmetrical relative to ground and are opposite in polarity (180 degrees 
out of phase). The nominal output impedance of the I–bar OUT connector is 50 
ohms, dc–coupled.
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11. WIDEBAND Q INPUTS

These female SMA connectors: Q IN (+) and Q–bar IN (−) (Option 016 only) are 
used with differential wideband external I/Q inputs. They accept wideband AM 
and allow direct high–bandwidth analog inputs to the I/Q modulator in the 
3.2-44 GHz range (frequency limit is dependant on the option). This input is 
not calibrated. The recommended input power level is −1 dBm with a +/− 1 
VDC input voltage. The nominal impedance for this connector is 50 ohms.

The signal generator uses lowside mixing in the 20–28.5 GHz frequency range 
(Options 532 and 544), which reverses the phase relationship for I and Q 
signals. For internally generated I/Q signals the signal generator’s firmware 
compensates for this. However, for wideband external I/Q inputs (Option 016) 
there is no compensation and the I and Q inputs at the rear panel must be 
reversed to maintain the correct phase relationships in this frequency band. 
Refer to the Data Sheet and to the A37 Upconverter description in the 
Keysight PSG Signal Generators Service Guide for more information.

For instruments with Option 015 (discontinued), single–ended wideband I/Q, 
there is a single BNC Q input. The recommended power level at this input 
connector is 0 dBM.

12. COH CARRIER (Serial Prefixes >=US4646/MY4646)

This female SMA connector (Option UNT only) outputs an RF signal that is 
phase coherent with the signal generator carrier. The coherent carrier 
connector outputs RF that is not modulated with AM, pulse, or I/Q modulation, 
but is modulated with FM or ΦM (when FM or ΦM are on). 

The output power is nominally 0 dBm. The output frequency range is from 
249.99900001 MHz to 3.2 GHz; this output is not useful for output frequencies 
> 3.2 GHz. If the RF output frequency is below 249.99900001 MHz, the 
coherent carrier output signal will have the following frequency:

Frequency of coherent carrier = (1E9 − Frequency of RF output) in Hz.

Damage levels are 20 Vdc and 13 dBm reverse RF power. The nominal output 
impedance of this connector is 50 ohms.

13. 1 GHz REF OUT (Serial Prefixes >=US4646/MY4646)

This female SMA connector (Option UNX only) provides a 1 GHz output that is 
100 times the frequency of the internal or external 10 MHz reference. The 
nominal output level is 7 dBM. The nominal output impedance is 50 ohms. 
When not in use, this connector must be terminated with a 50 ohm load.

14. Q–bar OUT

This female BNC connector (E8267D only) can be used with an internal 
baseband generator (Option 601/602) to output the complement of the 
analog, quadrature–phase component of I/Q modulation. On signal generators 
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without Option 601/602, this female BNC connector can be used to output the 
complement of the quadrature–phase component of an external I/Q 
modulation that has been fed into the Q input connector.

Q–bar OUT is used in conjunction with Q OUT to provide a balanced baseband 
stimulus. Balanced signals are signals present in two separate conductors that 
are symmetrical relative to ground and are opposite in polarity (180 degrees 
out of phase). The nominal output impedance of the Q–bar OUT connector is 
50 ohms, dc–coupled.

15. AC Power Receptacle

The ac line voltage is connected here. The power cord receptacle accepts a 
three–pronged power cable that is shipped with the signal generator.

16. GPIB

This GPIB interface allows listen and talk capability with compatible IEEE 488.2 
devices.

17. 10 MHz EFC

This female BNC input connector (Options UNR/UNX only) accepts an external 
dc voltage, ranging from −5 V to +5 V, for electronic frequency control (EFC) of 
the internal 10 MHz reference oscillator. This voltage inversely tunes the 
oscillator about its center frequency (approximately −0.0025 ppm/V). The 
nominal input impedance is greater than 1 Mohms. When not in use, this 
connector should be shorted using the supplied shorting cap to assure a stable 
operating frequency.

Always use the three-prong AC power cord supplied with this product. 
Failure to ensure adequate earth grounding by not using this cord can 
cause product damage.

This instrument has auto-ranging line voltage input; be sure the supply 
voltage is within the specified range and voltage fluctuations do not to 
exceed 10 percent of the nominal supply voltage:

E8257D: 100/120 VAC 50/60/400 Hz, 220/240, VAC 50/60 Hz, < 250 W 
typical, 450 W maximum

E8267D: 100/120 VAC 50/60/400 Hz; or 220/240 VAC 50/60 Hz, 
(automatically selected); < 400 W typical, 650 W maximum

E8663D: 100/120 VAC 50/60/400 Hz; or 220/240 VAC 50/60 Hz, 
(automatically selected); < 250 W typical, 450 W maximum
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18. ALC HOLD (Serial Prefixes >=US4722/MY4722)

This female BNC connector (E8267D only) is a TTL–compatible input that 
controls ALC action with bursted I/Q signals from an arbitrary waveform 
generator (AWG). A high signal allows the ALC to track the RF signal and 
maintain constant RF output level as the I/Q inputs vary. A low input signal 
allows the ALC to be held for a brief time (less than 1 second) and not track the 
RF signal. When driving the external I/Q inputs from an external arbitrary 
waveform generator supplying a bursted waveform, the ALC Hold line should 
be driven from a marker output from the AWG that is high when the bursted 
signal is at the proper level and low when the bursted signal is not at the 
proper level Damage levels are > 5.5 V and < −0.5 V.

19. AUXILIARY INTERFACE

This 9–pin D–subminiature female connector is an RS–232 serial port that can 
be used for serial communication and Host–Device source synchronization.

Figure 1-8 

20. 10 MHz IN

This female BNC connector accepts an external timebase reference input 
signal level of > −3 dBm. The reference must be 1, 2, 2.5, 5, or 10 MHz, within 
±1 ppm. The signal generator detects when a valid reference signal is present 
at this connector and automatically switches from internal to external 
reference operation.

Table 1-9 Auxiliary Interface Connector

Pin Number Signal Description Signal Name

1 No Connection (default operation)/
Retrace (Host–Device operation)

2 Receive Data RECV

3 Transmit Data XMIT

4 +5V (Default operation)/
Sweep Stop (Host–Device operation)

5 Ground, 0V

6 No Connection

7 Request to Send RTS

8 Clear to Send CTS

9 No Connection

View looking into 
rear panel connector
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For Option UNR/UNX or instruments with serial prefixes > US4805/MY4805, 
this BNC connector accepts a signal with a nominal input level of 5 ±5 dBm. 
The external frequency reference must be 10 MHz, within ±1 ppm.

The nominal input impedance is 50 ohms with a damage level of ≥ 10 dBm.

21. LAN

This LAN interface allows ethernet local area network communication through 
a 10Base–T LAN cable. The yellow LED on the interface illuminates when data 
transmission (transfer/receive) is present. The green LED illuminates when 
there is a delay in data transmission or no data transmission is present.

22. 10 MHz OUT

This female BNC connector outputs a nominal signal level of > +4 dBm and has 
an output impedance of 50 ohms. The accuracy is determined by the timebase 
used.

23. STOP SWEEP IN/OUT

This female BNC connector (Option 007 only) provides an open–collector, 
TTL–compatible input/output signal that is used during ramp sweep operation. 
It provides low–level (nominally 0 V) output during sweep retrace and 
band–cross intervals. It provides high–level (nominally +5 V) output during the 
forward portion of the sweep. Sweep stops when this input/output connector is 
grounded externally. When operating as an input, the nominal impedance for 
this connector is less than 10 ohms. When operating as an output, the nominal 
impedance is approximately 4.2 kohms.

24. BASEBAND GEN CLK IN

This female BNC connector accepts a sine or square wave PECL clock input 
with a frequency range of 200 MHz to 400 MHz, resulting in sample rates of 
50 MSa/s to 100 MSa/s. The recommended input level is approximately 1 
Vpeak–to–peak for a square wave and 1 dBm to 6 dBm for a sine wave. This 
allows baseband generators from multiple signal sources to run off the same 
clock.

25. Z–AXIS BLANK/MKRS

This female BNC connector (Option 007 only) supplies a +5 V (nominal) level 
during retrace and band–switch intervals of a step, list, or ramp sweep. During 
ramp sweep, this female BNC connector supplies a –5 V (nominal) level when 
the RF frequency is at a marker frequency and intensity marker mode is on. 
This signal is derived from an operational amplifier output so the load 
impedance should be greater than or equal to 5 kohms. This connection is 
most commonly used to interface with an Keysight 8757D Scalar Network 
Analyzer.
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26. SWEEP OUT

This female BNC connector outputs a voltage proportional to the RF power or 
frequency sweep ranging from 0 V at the start of sweep and goes to +10 V 
(nominal) at the end of sweep, regardless of sweep width.

The nominal output impedance is less than 1 ohm and can drive a 2 kohm load.

When connected to an Keysight Technologies 8757D network analyzer, it 
generates a selectable number of equally spaced 1 ms, 10 V pulses (nominal) 
across a ramp (analog) sweep. The number of pulses can be set from 101 to 
1601 by remote control through the 8757D.

27. TRIGGER OUT

This female BNC connector, in step/list sweep mode, outputs a TTL signal that 
is high at the start of a dwell sequence or when waiting for a point trigger in 
manual sweep mode. The signal is low when the dwell is over or when a point 
trigger is received. In ramp sweep mode, the output provides 1601 equally 
spaced 1 μs pulses (nominal) across a ramp sweep. When using LF Out, the 
output provides a 2 μs pulse at the start of an LF sweep. The nominal 
impedance for this connector is less than 10 ohms.

28. TRIGGER IN

This female BNC connector accepts a 3.3V CMOS signal, which is used for 
point–to–point triggering in manual sweep mode, or in a low frequency (LF 
output) or analog (AM, FM, and ΦM) external sweep trigger setup. Triggering 
can occur on either the positive or negative edge of the signal start. The 
damage level is ≤ −4 V or ≥ +10 V. The nominal input impedance for this 
connector is approximately 4.2 kohms.

29. SOURCE SETTLED

This female BNC connector provides a 3–volt CMOS output trigger, indicating 
when the signal generator has settled to a new frequency or power level. A 
high indicates that the source has not settled. A low indicates that the source 
has settled. The nominal output impedance for this connector is less than 
10 ohms.

30. SOURCE MODULE INTERFACE

This interface is used to connect to compatible Keysight Technologies 83550 
Series mm–wave source modules.
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Figure 1-9 Interface Signals of the Source Module Connector

The codes indicated on the illustration above translate as follows.

Mod D0  Source module data line zero. Signals MOD D0 through 
MOD D3 are the mm source module data bus lines 
(bi-directional).

MOD D1  Data line one.

MOD D2  Data line two.

MOD D3  Data line three.

MOD C1  Source module control line zero. Signals MOD C0 and 
MOD C1 are the control lines for the read/write to and 
from the mm source module.

MOD C1  Control line one.

CLAMP CNTL  Source module clamp control (not used).

MOD SENSE  Source module sense. A 1 mA current is injected on this 
line by the mm source module to indicate its presence. 
This signal always equals 0V.

L MOD RF OFF  Low = RF off. Source module RF is turned off.

EXT LVL RET  Source module external leveling return.

EXT LVL  Source module external leveling input, from the mm 
source module.

0.5V/GHz  Internal 0.5 V/GHz to the mm source module.

–15V  Power Supply. Range is –14.25 to –15.90V.

+15V  Power Supply. Range is +14.25 to +16.40V.

+8V  Power Supply. Range is +7.75 to +8.25V.

+5V  Power Supply. Range is +4.75 to +5.45V.

DIG GND  Digital ground.

MOD ANLG GND  Source module analog ground.
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ANLG GND RET  Analog ground return.

31. RF OUT

This connector outputs RF and microwave signals. The nominal output 
impedance is 50 ohms. The reverse power damage levels are 0 Vdc, 0.5 watts 
nominal. On signal generators without Option 1EM, this connector is located 
on the front panel. The connector type varies according to frequency option.

32. EXT 1

This female BNC input connector (functional only with Options UNT, UNU, or 
UNW) accepts a ±1 Vp signal for AM, FM, and ΦM. For these modulations, 
±1 Vp produces the indicated deviation or depth. When ac–coupled inputs are 
selected for AM, FM, or ΦM and the peak input voltage differs from 1 Vp by 
more than 3 percent, the HI/LO display annunciators light. The input 
impedance is selectable as either 50 or 600 ohms; the damage levels are 
5 Vrms and 10 Vp. On signal generators without Option 1EM, this connector is 
located on the front panel.

33. EXT 2

This female BNC input connector (functional only with Options UNT, UNU, or 
UNW) accepts a ±1 Vp signal for AM, FM, and ΦM. With AM, FM, or ΦM, ±1 Vp 
produces the indicated deviation or depth. When ac–coupled inputs are 
selected for AM, FM, or ΦM and the peak input voltage differs from 1 Vp by 
more than 3 percent, the HI/LO annunciators light on the display. The input 
impedance is selectable as either 50 or 600 ohms and damage levels are 
5 Vrms and 10 Vp. On signal generators without Option 1EM, this connector is 
located on the front panel.

34. PULSE SYNC OUT

This female BNC output connector (functional only with Options UNU or UNW) 
outputs a synchronizing TTL–compatible pulse signal that is nominally 50 ns 
wide during internal and triggered pulse modulation. The nominal source 
impedance is 50 ohms. On signal generators without Option 1EM, this 
connector is located on the front panel.

35. PULSE VIDEO OUT

This female BNC output connector (functional only with Options UNU or UNW) 
outputs a TTL–level compatible pulse signal that follows the output envelope 
in all pulse modes. The nominal source impedance is 50 ohms. On signal 
generators without Option 1EM, this connector is located on the front rear 
panel.
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36. PULSE/TRIG GATE INPUT

This female BNC input connector (functional only with Options UNU or UNW) 
accepts an externally supplied pulse signal for use as a pulse or trigger input. 
With pulse modulation, +1 V is on and 0 V is off (trigger threshold of 0.5 V with 
a hysteresis of 10 percent; so 0.6 V would be on and 0.4 V would be off). The 
damage levels are ±5 Vrms and 10 Vp. The nominal input impedance is 50 
ohms. On signal generators without Option 1EM, this connector is located on 
the front panel.

37. ALC INPUT

This female BNC input connector is used for negative external detector 
leveling. This connector accepts an input of −0.2 mV to −0.5 V. The nominal 
input impedance is 120 kohms and the damage level is ±15 V. On signal 
generators without Option 1EM, this connector is located on the front panel.

38. DATA CLOCK

This female BNC input connector (E8267D only) is CMOS compatible and 
accepts an externally supplied data clock input signal to synchronize serial 
data for use with the internal baseband generator (Option 601/602). The 
expected input is a 3.3 V CMOS bit clock signal (which is also TTL compatible) 
where the rising edge is aligned with the beginning data bit. The falling edge is 
used to clock the DATA and SYMBOL SYNC signals. The maximum clock rate is 
50 MHz. The damage levels are > +5.5 V and < −0.5V. The nominal input 
impedance is not defined. On signal generators without Option 1EM, this 
connector located on the front panel.

39. I IN

This female BNC input connector (E8267D only) accepts the in–phase (I) 
component an externally supplied, analog, I/Q modulation. The 
quadrature–phase (Q) component is supplied through the Q IN connector. The 
signal level is  = 0.5 Vrms for a calibrated output level. The nominal input 

impedance is 50 or 600 ohms. The damage level is 1 Vrms and 10 Vpeak. To 
activate signals applied to the I and Q input connectors, press Mux > I/Q 
Source 1 or I/Q Source 2 and then select either Ext 50 Ohm or Ext 600 Ohm. 
On signal generators without Option 1EM, this connector is located on the 
front panel.

40. SYMBOL SYNC

This female BNC input connector (E8267D only) is CMOS–compatible and 
accepts an externally supplied symbol synchronization signal for use with the 
internal baseband generator (Option 601/602). The expected input is a 3.3 V 
CMOS bit clock signal (which is also TTL compatible). SYMBOL SYNC might 
occur once per symbol or be a single one–bit–wide pulse that is used to 
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synchronize the first bit of the first symbol. The maximum clock rate is 50 MHz. 
The damage levels are > +5.5 V and < −0.5V. The nominal input impedance is 
not defined. SYMBOL SYNC can be used in two modes:

— When used as a symbol synchronization in conjunction with a data clock, 
the signal must be high during the first data bit of the symbol. The signal 
must be valid during the falling edge of the data clock signal and may be a 
single pulse or continuous.

— When the SYMBOL SYNC itself is used as the (symbol) clock, the CMOS 
falling edge is used to clock the DATA signal.

On signal generators without Option 1EM, this connector is located on the 
front panel.

41. Q IN

This female BNC input connector (E8267D only) accepts the quadrature–phase 
(Q) component an externally supplied, analog, I/Q modulation. The in–phase (I) 
component is supplied through the I IN connector. The signal level is  = 

0.5 Vrms for a calibrated output level. The nominal input impedance is 50 or 
600 ohms. The damage level is 1 Vrms and 10 Vpeak. To activate signals applied 
to the I and Q input connectors, press Mux > I/Q Source 1 or I/Q Source 2 and 
then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators without 
Option 1EM, this connector is located on the front panel.

42. DATA

This female BNC input connector (Option 601/602 only) is CMOS compatible 
and accepts an externally supplied serial data input for digital modulation 
applications. The expected input is a 3.3 V CMOS signal (which is also TTL 
compatible) where a CMOS high = a data 1 and a CMOS low = a data 0. The 
maximum input data rate is 50 Mb/s. The data must be valid on the falling 
edges of the data clock (normal mode) or on the falling edges of the symbol 
synchronization (symbol mode). The damage levels are > +5.5 and < −0.5V. The 
nominal input impedance is not defined. On signal generators without Option 
1EM, this connector is located on the front panel.

43. LF OUT

This female BNC output connector (functional only with Option UNT) outputs 
modulation signals generated by the low frequency (LF) source function 
generator. This output is capable of driving 3Vp (nominal) into a 50–ohm load. 
On signal generators without Option 1EM, this connector is located on the 
front panel.
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44. Flash Drive (Serial Prefixes >=US4829/SG4829/MY4829 (E8267D) 
and >=US4928/SG4928/MY4928 (E8257D))

The removable compact flash drive is not hot swappable – always turn the 
power off to the instrument when removing or inserting the memory. Use only 
Keysight provided or certified compact flash cards. 

This flash drive (Options 008 and 009 only) outputs data to a removable flash 
card. The 8 GB memory capacity easily stores user data files; including flatness 
calibrations, IQ calibration, instrument states, waveforms (including header 
and marker data), modulation definitions, and sweep lists. Refer to Table 2-5, 
“Flash Drive Memory (Options 008 and 009),” on page 93.
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User’s Guide

2 Basic Operation

In the following sections, this chapter describes operations common to all 
Keysight PSG signal generators:

— “Using Table Editors” on page 60

— “Using the User-Defined RF Output Power Limit (Option 1EU, or 521 only)” 
on page 62

— “Configuring a Continuous Wave RF Output” on page 64

— “Configuring a Swept RF Output” on page 68

— “Using Ramp Sweep (Option 007)” on page 73

— “Extending the Frequency Range” on page 82

— “Turning On a Modulation Format” on page 83

— “Applying a Modulation Format to the RF Output” on page 84

— “Using Data Storage Functions” on page 85

— “Using the Instrument State Registers” on page 86

— “Using Security Functions” on page 90

— “Enabling Options” on page 99

— “Using the Web Server” on page 100
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Using Table Editors
Table editors simplify configuration tasks, such as creating a list sweep. This 
section provides information to familiarize you with basic table editor 
functionality using the List Mode Values table editor as an example.

Press Preset > Sweep/List > Configure List Sweep.

The signal generator displays the List Mode Values table editor, as shown 
below.

Figure 2-1 

Active Function Area  displays the active table item while its value 
is edited

Cursor  an inverse video identifier used to highlight 
specific table items for selection and editing

Table Softkeys  select table items, preset table values, and 
modify table structures

Table Items  values arranged in numbered rows and titled 
columns (The columns are also known as 
data fields. For example, the column below 
the Frequency title is known as the 
Frequency data field).

Cursor

Table Softkeys Table Name Table Items

Active Function Area
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Table Editor Softkeys

The following table editor softkeys are used to load, navigate, modify, and 
store table item values.

Edit Item  displays the selected item in the active function area of 
the display where the item’s value can be modified

Insert Row  inserts an identical row of table items above the 
currently selected row

Delete Row  deletes the currently selected row

Goto Row  opens a menu of softkeys (Enter, Goto Top Row, Goto 
Middle Row, Goto Bottom Row, Page Up, and Page 
Down) used to quickly navigate through the table items

Insert Item  inserts an identical item in a new row below the 
currently selected item

Delete Item  deletes the currently selected item

Page Up and
Page Down  displays table items that occupy rows outside the limits 

of the ten–row table display area

More (1 of 2)  accesses Load/Store and its associated softkeys

Load/Store  opens a menu of softkeys (Load From Selected File, 
Store To File, Delete File, Goto Row, Page Up, and 
Page Down) used to load table items from a file in the 
memory catalog, or to store the current table items as a 
file in the memory catalog

Modifying Table Items in the Data Fields

1. If not already displayed, open the List Mode Values table editor (Figure 
2-1 on page 60): 
Press Preset > Sweep/List > Configure List Sweep

2. Use the arrow keys or the knob to move the table cursor over the desired 
item.

In Figure 2-1, the first item in the Frequency data field is selected.

3. Press Edit Item.

The selected item is displayed in the active function area of the display.

4. Use the knob, arrow keys, or the numeric keypad to modify the value.

5. Press Enter.

The modified item is now displayed in the table.
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Using the User-Defined RF Output Power Limit (Option 1EU, or 521 
only)

Selecting a User-Defined RF Output Power Limit

To protect external components and instruments against damage the PSG has 
a user-defined RF output limit (see Figure 2-2). The factory default value of the 
RF output limit is set to 25 dBm and the RF adjusting limit value softkey is not 
available (see Figure 2-2). Presetting the instrument, resets the value to 
25 dBm and disables any user-defined RF adjusting limit values (i.e. the 
user-defined RF output limit values are not persistent).

If a persistent RF output limit is required, a user-defined setup is 
recommended. Use the “Save User Preset” softkey under the Utility > Power 
On/Preset softkey menu or use the save instrument state register softkeys 
(Refer to “Using the Instrument State Registers” on page 86).

In internal leveling mode, when the set amplitude is within ±1 dBm of the 
RF output limit’s value, the RF output limit is printed in bold text in the 
Frequency and Amplitude status information display. When the user 
attempts to set an amplitude that exceeds the RF Output Power Limit, the 
amplitude will be restricted and the following error message is displayed: 
“Value clipped to maximum user defined RF Output Limit”. 

In internal leveling mode, if the RF output limit is exceeded, a warning 
message is displayed that reads “UNLEVEL”. When this message is 
displayed, the RF output is maximized out at the specified RF output limit 
and the connected devices are protected.

The RF output limit can be used with an external ALC detector connected 
to the PSG. When the instrument is in external leveling mode, no 
indications or warnings are displayed, but the power is restricted if it 
exceeds the ±1 dBm limits.
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Figure 2-2 User-Defined RF Output Limit Softkey Menu

The following example enables the RF Output power limit and changes the 
value to 20 dBm.

1. To change the RF output limit value:

Press Amplitude > More > More > RF Output Limit Lock Adjust to Adjust.

2. To change the RF output limit value: 

Press RF Output Limit > 20 dBm

By default, the RPG and increment/decrement controls are disabled to 
avoid accidental changing of the RF output limit. Press the left/right 
cursor hardkeys to select a digit and enable the RPG or use the keypad to 
enter the dBm. The minimum settable value is 15 dBm. The maximum 
settable value is the unleveled power of the instrument. For settings 
accuracy, refer to the Data Sheet.

3. To prevent accidently changing the RF Output Limit level:

Press RF Output Limit Lock Adjust to Lock.

Amplitude > More > More 

SCPI Commands:

To enable changing the RF output limit:

SCPI Command:   [:SOURce]:POWer:LIMit[:MAX]:ADJust <ON|OFF|1|0>

SCPI Command:   [:SOURce]:POWer:LIMit[:MAX]:ADJust?

To change the RF output limit:

SCPI Command:   [:SOURce]:POWer:LIMit[:MAX] <ampl>

SCPI Command:   [:SOURce]:POWer:LIMit[:MAX]?

This softkey is only 
active when the RF 
Output Limit softkey 
is set to “Adjust”. 

The default RF 
Output Limit value is 
shown in here. 
When the amplitude 
is within 
1 dB of the RF 
output limit value or 
exceeds the RF 
Output Limit value, 
the value is 
displayed in bold 
text.
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Configuring the RF Output
This section provides information on how to create continuous wave and swept 
RF (page 68) outputs. It also has information on using a mm–Wave source 
module to extend the signal generator’s frequency range (page 82).

Configuring a Continuous Wave RF Output

These procedures demonstrate how to set the following parameters:

— setting the RF output frequency (page 64)
— setting the frequency reference and frequency offset (page 65)
— setting the low pass filter (Options 1EH and 521) (page 66)
— setting the RF output amplitude (page 66)
— setting the amplitude reference and amplitude offset (page 67)
— setting the optimize signal to noise ratio (page 67)

Setting the RF Output Frequency

Set the RF output frequency to 700 MHz, and increment or decrement the 
output frequency in 1 MHz steps.

1. Return the signal generator to the factory–defined state: Press Preset.

2. Observe the FREQUENCY area of the display (in the upper left–hand 
corner).

The value displayed is the maximum specified frequency of the signal 
generator.

3. Press RF On/Off.

The RF On/Off hardkey must be pressed before the RF signal is available at 
the 
RF OUTPUT connector. The display annunciator changes from RF OFF to 
RF ON. The maximum specified frequency should be output at the 
RF OUTPUT connector (at the signal generator’s minimum power level).

4. Press Frequency > 700 > MHz.

The 700 MHz RF frequency should be displayed in the FREQUENCY area of 
the display and also in the active entry area.

5. Press Frequency > Incr Set > 1 > MHz.

This changes the frequency increment value to 1 MHz.

You can change the preset condition of the signal generator to a user–defined 
state. For these examples, however, use the factory–defined preset state (set the 
Preset Normal User softkey in the Utility menu to Normal).
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6. Press the up arrow key.

Each press of the up arrow key increases the frequency by the increment 
value last set with the Incr Set hardkey. The increment value is displayed 
in the active entry area.

7. The down arrow decreases the frequency by the increment value set in the 
previous step. Practice stepping the frequency up and down in 1 MHz 
increments.

You can also adjust the RF output frequency using the knob. As long as 
frequency is the active function (the frequency is displayed in the active 
entry area), the knob will increase and decrease the RF output frequency.

8. Use the knob to adjust the frequency back to 700 MHz.

Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency 
to which all other frequency settings are relative. When the frequency reference 
is set, the display will read 0.00 Hz (the frequency output of the signal 
generator’s hardware minus the reference frequency). Although the display 
changes, the actual frequency output is 700 MHz (from step 8 above). Any 
subsequent frequency changes are shown as increments or decrements to the 
0 Hz reference.

The Frequency Reference Set function is not an active function. Once it is set, 
any change to the frequency setting appears as a frequency reading on the 
signal generator’s front panel display. For example,

1. Preset the signal generator: Press Preset.

2. Set the frequency reference to 700 MHz: 
Press: Frequency > 700 > MHz > More (1 of 3) > Freq Ref Set.

This activates the frequency reference mode, sets the output frequency 
(700 MHz) as the reference value, and toggles the Freq Ref softkey On. 
The FREQUENCY area displays 0.000 Hz. This reading is the frequency 
output of the signal generator’s hardware (700 MHz) minus the reference 
value (700 MHz). The signal generator’s true output frequency is 700 MHz. 
If the Freq Ref softkey is toggled to Off, the front panel will indicate the 
actual frequency: 700 MHz. The REF indicator appears on the front panel 
display and the Freq Ref Off On softkey toggles to On.

3. Turn on the RF output: Press RF On/Off.

The display annunciator changes from RF OFF to RF ON. The RF 
frequency at the RF OUTPUT connector is 700 MHz.

4. Set the frequency increment value to 1 MHz: Press Frequency > Incr Set > 
1 > MHz.
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5. Increment the output frequency by 1 MHz: Press the up arrow key.

The FREQUENCY area display changes to show 1.000 000 000 MHz, which 
is the frequency output by the hardware (700 MHz + 1 MHz) minus the 
reference frequency (700 MHz). The frequency at the RF OUTPUT changes 
to 701 MHz.

6. Enter a 1 MHz offset: Press More (1 of 3) > Freq Offset > 1 > MHz.

The FREQUENCY area displays 2.000 000 00 MHz, which is the frequency 
output by the hardware (701 MHz) minus the reference frequency 
(700 MHz) plus the offset (1 MHz). The OFFS indicator activates. The 
frequency at the RF OUTPUT connector is still 701 MHz.

Setting the Low Pass Filter (Options 1EH and 521)

Options 1EH and 521 improves the harmonic distortion performance for carrier 
frequencies ranging from 10 MHz to 2 GHz. Refer to the Data Sheet for 
specifications on these options. 

1. Press Preset.

Default Off

2. Press Frequency > More > More.

3. Press Low Pass Filter below 2 GHz to On.

Setting the RF Output Amplitude

1. Preset the signal generator: Press Preset.

The AMPLITUDE area of the display shows the minimum power level of the 
signal generator. This is the normal preset RF output amplitude.

2. Turn on the RF output: Press RF On/Off.
The display annunciator changes to RF ON. At the RF OUTPUT connector, 
the RF signal is output at the minimum power level.

3. Change the amplitude to −20 dBm: Press Amplitude > -20 > dBm.

The new output power displays in the AMPLITUDE area of the display and 
in the active entry area. Until you press a different front panel function key, 
amplitude remains the active function. You can also change the amplitude 
using the up and down arrow keys or the knob.

Option 1EH can degrade power below 2 GHz. Use Option 1EH when improved 
harmonics are desired but a degradation of power below 2 GHz is acceptable. 
Refer to the Data Sheet for details.
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Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to 
which all other amplitude parameters are relative. The amplitude initially 
shown on the display is 0 dB (the power output by the hardware minus the 
reference power). Although the display changes, the output power does not 
change. Any subsequent power changes are shown as incremental or 
decremental to 0 dB. 

1. Press Preset.

2. Set the amplitude to −20 dBm: Press Amplitude > –20 > dBm.

3. Activate the amplitude reference mode and set the current output power 
(−20 dBm) as the reference value: Press More (1 of 2) > Ampl Ref Set.

The AMPLITUDE area displays 0.00 dB, which is the power output by the 
hardware (−20 dBm) minus the reference value (−20 dBm). The REF 
indicator activates and the Ampl Ref Off On softkey toggles On.

4. Turn the RF output on: Press RF On/Off.
The display annunciator changes to RF ON. The power at the RF OUTPUT 
connector is −20 dBm. 

5. Change the amplitude increment value to 10 dB: Press Incr Set > 10 > dB.

6. Use the up arrow key to increase the output power by 10 dB.

The AMPLITUDE area displays 10.00 dB, which is the power output by the 
hardware (–20 dBm plus 10 dBm) minus the reference power (−20 dBm). 
The power at the RF OUTPUT connector changes to −10 dBm.

7. Enter a 10 dB offset: Press Ampl Offset > 10 > dB.

The AMPLITUDE area displays 20.00 dB, which is the power output by the 
hardware (−10 dBm) minus the reference power (−20 dBm) plus the offset 
(10 dB). The OFFS indicator activates. The power at the RF OUTPUT 
connector is still −10 dBm.

Setting the Optimize Signal to Noise Ratio

Enabling this softkey On optimizes the attenuator and ALC setting to provide 
optimal signal–to–noise; it does not change the RF output power.

1. Press Preset.

Default Off

2. Press Amplitude > More > More > Optimize S/N Off On.

3. Press Optimize S/N to On.

This mode is mutually exclusive with attenuator hold (Atten Hold), and any 
modulation type. A settings conflict error will be generated if attentuator hold or 
any modulation is activated when optimize signal–to–noise is active (On).
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Configuring a Swept RF Output

A PSG signal generator has up to three sweep types: step sweep, list sweep, 
and ramp sweep. Ramp sweep is available with Option 007.

The signal generator indicates the sweep advance in a progress bar on the 
front panel display. If the sweep time is greater than one second, the progress 
bar sweep advances according to the frequency span of each segment. For 
each segment in the span, the progress bar displays the full segment and then 
the sweep is taken. With sweep times less than one second, the progress bar is 
drawn, the sweep taken, and the progress bar is then blanked. 

Step sweep (see page 69) and ramp sweep (see page 70) provide a linear 
progression through the start–to–stop frequency and/or amplitude values, 
while list sweep enables you to create a list of arbitrary frequency, amplitude, 
and dwell time values and sweep the RF output based on that list.

The list sweep example uses the points created in the step sweep example as 
the basis for a new list sweep. 

Ramp sweep (see page 73) is faster than step or list sweep, and is designed to 
work with an 8757D Scalar Network Analyzer.

The signal generator provides a softkey, Sweep Retrace Off On, that lets you 
configure single sweep behavior. When sweep retrace is on, the signal 
generator will retrace the sweep to the first point of the sweep. If the sweep 
retrace is off, the sweep will stop and remain on the last point in the sweep. 

Activating Scalar Pulse in Sweep Configurations

If your sweep setup uses a scalar network analyzer and an AC detector, the 
PSG must modulate the swept signal with a 27 kHz square wave, also referred 
to as a scalar pulse. This pulse modulation is necessary for the AC detector to 
properly detect the swept signal. If the PSG is controlled by an 8757D through 
a GPIB connection, the scalar pulse automatically turns on when AC detection 
is selected on the 8757D. When using any other scalar analyzer, you can 
manually turn on the scalar pulse using either one of the following key–press 
sequences:

Press Sweep > Configure Ramp/Step Sweep > More > Scalar Pulse Off On 
to On

or

Press Pulse > Pulse Source > Scalar > Pulse Off On to On

List sweep data cannot be saved within an instrument state, but can be 
saved to the memory catalog. For instructions on saving list sweep data, 
see “Storing Files to the Memory Catalog” on page 85. 

During swept RF output, the FREQUENCY and AMPLITUDE areas of the 
signal generator’s display are deactivated, depending on what is being 
swept.
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Using Step Sweep

Step sweep provides a linear progression through the start–to–stop frequency 
and/or amplitude values. You can toggle the direction of the sweep, up or 
down. When the Sweep Direction Down Up softkey is set to Up, values are 
swept from the start amplitude/frequency to the stop amplitude/frequency. 
When set to Down, values are swept from the stop amplitude/frequency to the 
start amplitude/frequency.

When a step sweep is activated, the signal generator sweeps the RF output 
based on the values entered for RF output start and stop frequencies and 
amplitudes, a number of equally spaced points (steps) to dwell upon, and the 
amount of dwell time at each point; dwell time is the time that the signal is 
settled and you can make a measurement before the sweep moves to the next 
step. The total time at any step is the sum of the switching speed (from the 
datasheet) plus the dwell time at that step. The frequency, amplitude, or 
frequency and amplitude of the RF output will sweep from the start 
amplitude/frequency to the stop amplitude/frequency, dwelling at equally 
spaced intervals defined by the # Points softkey value.

To Configure a Single Step Sweep

In this procedure, you create a step sweep with nine, equally spaced points, 
and the following parameters:

— frequency range from 500 MHz to 600 MHz
— amplitude from −20 dBm to 0 dBm
— dwell time 500 ms at each point

1. Press Preset.

2. Press Sweep/List.
This opens a menu of sweep softkeys.

3. Press Sweep Repeat Single Cont.
This toggles the sweep repeat from continuous to single.

4. Press Configure Step Sweep.

5. Press Freq Start > 500 > MHz.
This changes the start frequency of the step sweep to 500 MHz.

6. Press Freq Stop > 600 > MHz.
This changes the stop frequency of the step sweep to 600 MHz.

7. Press Ampl Start > –20 > dBm.
This changes the amplitude level for the start of the step sweep.

8. Press Ampl Stop > 0 > dBm.
This changes the amplitude level for the end of the step sweep.

9. Press # Points > 9 > Enter.
This sets the number of sweep points to nine.

10.Press Step Dwell > 500 > msec.
This sets the dwell time at each point to 500 milliseconds.
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11.Press Return > Sweep > Freq & Ampl.

This sets the step sweep to sweep both frequency and amplitude data. 
Selecting this softkey returns you to the previous menu and turns on the 
sweep function.

12.Press RF On/Off.
The display annunciator changes from RF OFF to RF ON.

13.Press Single Sweep.

A single sweep of the frequencies and amplitudes configured in the step 
sweep is executed and available at the RF OUTPUT connector. On the 
display, the SWEEP annunciator appears for the duration of the sweep and 
a progress bar shows the progression of the sweep. The Single Sweep 
softkey can also be used to abort a sweep in progress. To see the 
frequencies sweep again, press Single Sweep to trigger the sweep.

To Configure a Continuous Step Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of 
the frequencies and amplitudes configured in the step sweep are now available 
at the RF OUTPUT connector. The SWEEP annunciator appears on the display, 
indicating that the signal generator is sweeping and progression of the sweep 
is shown by a progress bar. 

Using List Sweep

List sweep enables you to create a list of arbitrary frequency, amplitude, and 
dwell time values and sweep the RF output based on the entries in the List 
Mode Values table. 

Unlike a step sweep that contains linear ascending/descending frequency and 
amplitude values, spaced at equal intervals throughout the sweep, list sweep 
frequencies and amplitudes can be entered at unequal intervals, nonlinear 
ascending/descending, or random order. 

For convenience, the List Mode Values table can be copied from a previously 
configured step sweep. Each step sweep point’s associated frequency, 
amplitude and dwell time values are entered into a row in the List Mode Values 
table, as the following example illustrates.

To Configure a Single List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the 
sweep information by editing several points in the List Mode Values table. For 
information on using tables, see “Using Table Editors” on page 60.

1. Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single. The SWEEP 
annunciator is turned off. The sweep will not occur until it is triggered.

2. Press Sweep Type List Step.
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This toggles the sweep type from step to list.

3. Press Configure List Sweep.

This opens another menu displaying softkeys that you will use to create 
the sweep points. The display shows the current list data. (When no list 
has been previously created, the default list contains one point set to the 
signal generator’s maximum frequency, minimum amplitude, and a dwell 
time of 2 ms.)

4. Press More (1 of 2) > Load List From Step Sweep > Confirm Load From 
Step Data. 

The points you defined in the step sweep are automatically loaded into the 
list.

To Edit List Sweep Points

1. Press Return > Sweep > Off.

Turning the sweep off allows you to edit the list sweep points without 
generating errors. If sweep remains on during editing, errors occur 
whenever one or two point parameters (frequency, power, and dwell) are 
undefined.

2. Press Configure List Sweep.

This returns you to the sweep list table.

3. Use the arrow keys to highlight the dwell time in row 1.

4. Press Edit Item.

The dwell time for point 1 becomes the active function.

5. Press 100 > msec.

This enters 100 ms as the new dwell time value for row 1. Note that the 
next item in the table (in this case, the frequency value for point 2) 
becomes highlighted after you press the terminator softkey.

6. Using the arrow keys, highlight the frequency value in row 4.

7. Press Edit Item > 545 > MHz.

This changes the frequency value in row 4 to 545 MHz.

8. Highlight any column in the point 7 row and press Insert Row. 

This adds a new point between points 7 and 8. A copy of the point 7 row is 
placed between points 7 and 8, creating a new point 8, and renumbering 
the successive points.

9. Highlight the frequency item for point 8, then press Insert Item.
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Pressing Insert Item shifts frequency values down one row, beginning at 
point 8. Note that the original frequency values for both points 8 and 9 
shift down one row, creating an entry for point 10 that contains only a 
frequency value (the power and dwell time items do not shift down).

The frequency for point 8 is still active.

10.Press 590 > MHz.

11.Press Insert Item > –2.5 > dBm. 

This inserts a new power value at point 8 and shifts down the original 
power values for points 8 and 9 by one row.

12.Highlight the dwell time for point 9, then press Insert Item.

A duplicate of the highlighted dwell time is inserted for point 9, shifting 
the existing value down to complete the entry for point 10.

To Configure a Single List Sweep

1. Press Return > Sweep > Freq & Ampl

This turns the sweep on again. No errors should occur if all parameters for 
every point have been defined in the previous editing process.

2. Press Single Sweep.

The signal generator will single sweep the points in your list. The SWEEP 
annunciator activates during the sweep.

3. Press More (1 of 2) > Sweep Trigger > Trigger Key.

This sets the sweep trigger to occur when you press the Trigger hardkey.

4. Press More (2 of 2) > Single Sweep.

This arms the sweep. The ARMED annunciator is activated.

5. Press the Trigger hardkey.

The signal generator will single sweep the points in your list and the 
SWEEP annunciator will be activated during the sweep.

To Configure a Continuous List Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of 
the frequencies and amplitudes configured in the list sweep are now available 
at the RF OUTPUT connector. The SWEEP annunciator appears on the display, 
indicating that the signal generator is sweeping and progression of the sweep 
is shown by a progress bar. 
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Using Ramp Sweep (Option 007)

Ramp sweep provides a linear progression through the start–to–stop frequency 
and/or amplitude values. Ramp sweep is much faster than step or list sweep, 
and is designed to work with an 8757D Scalar Network Analyzer. This section 
describes the ramp sweep capabilities available in signal generators with 
Option 007. You will learn how to use basic ramp sweep, and how to configure 
a ramp sweep for a primary/secondary setup (see page 80).

Refer to the Keysight Signal Generators Programming Guide for an example 
program that uses pass–thru commands in a ramp sweep system (pass–thru 
commands enable you to temporarily interrupt ramp sweep system interaction 
so that you can send operating instructions to the PSG).

Using Basic Ramp Sweep Functions

This procedure demonstrates the following tasks (each task builds on the 
previous task):

— “Configuring a Frequency Sweep” on page 73

— “Using Markers” on page 76

— “Adjusting Sweep Time” on page 77

— “Using Alternate Sweep” on page 78

— “Configuring an Amplitude Sweep” on page 79

Configuring a 
Frequency Sweep

1. Set up the equipment as shown in Figure 2-3.

The PSG signal generator is not compatible with the GPIB system interface of an 
8757A, 8757C, or 8757E. For these older scalar network analyzers, do not connect 
the GPIB cable in Figure 2-3. These scalar network analyzers provide only a subset 
of 8757D functionality. See the Data Sheet for details. Use the 8757A/C/E 
documentation instead of this procedure.
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Figure 2-3 Equipment Setup

2. Turn on both the 8757D and the PSG.

3. On the 8757D, press System > More > Sweep Mode and verify that the 
SYSINTF softkey is set to ON.

This ensures that the system interface mode is activated on the 8757D. 
The system interface mode enables the instruments to work as a system.

4. Press Utility > GPIB/RS–232 LAN to view the PSG’s GPIB address under 
the GPIB Address softkey. If you want to change it, press GPIB Address 
and change the value.

5. On the 8757D, press LOCAL > SWEEPER and check the GPIB address. If it 
does not match that of the PSG, change the value.

6. Preset either instrument.

Presetting one of the instruments should automatically preset the other as 
well. If both instruments do not preset, check the GPIB connection, GPIB 
addresses, and ensure the 8757D is set to system interface mode 
(SYSINTF set to ON).

The PSG automatically activates a 2 GHz to maximum frequency ramp 
sweep with a constant amplitude of 0 dBm. Notice that the RF ON, SWEEP, 
and PULSE annunciators appear on the PSG display. The PULSE 
annunciator appears because the 8757D is operating in AC mode.
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The PSG also switches its remote language setting to 8757D System, 
allowing the PSG to talk to the 8757D during ramp sweep operations. You 
can confirm this by pressing Utility > GPIB/RS–232 LAN and observing the 
selection under the Remote Language softkey.

7. Press Frequency > Freq CW.

The current continuous wave frequency setting now controls the RF 
output and ramp sweep is turned off.

8. Press Freq Start.

The ramp sweep settings once again control the RF output and the CW 
mode is turned off. Pressing any one of the softkeys Freq Start, Freq Stop, 
Freq Center, or Freq Span activates a ramp sweep with the current 
settings.

9. Adjust the settings for Freq Center and Freq Span so that the frequency 
response of the device under test (DUT) is clearly seen on the 8757D 
display.

Notice how adjusting these settings also changes the settings for the Freq 
Start and Freq Stop softkeys. You may need to rescale the response on the 
8757D for a more accurate evaluation of the amplitude. Figure 2-4 on 
page 76 shows an example of a bandpass filter response.

During swept RF output, the FREQUENCY and/or AMPLITUDE areas of the signal 
generator’s display are deactivated, depending on what is being swept. In this 
case, since frequency is being swept, nothing appears in the FREQUENCY area of 
the display.

In a frequency ramp sweep, the start frequency must be lower than the stop 
frequency.
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Figure 2-4 Bandpass Filter Response on 8757D

Using Markers 1. Press Markers.

This opens a table editor and associated marker control softkeys. You can 
use up to 10 different markers, labeled 0 through 9.

2. Press Marker Freq and select a frequency value within the range of your 
sweep.

In the table editor, notice how the state for marker 0 automatically turns 
on. The marker also appears on the 8757D display.

3. Use the arrow keys to move the cursor in the table editor to marker 1 and 
select a frequency value within the range of your sweep, but different from 
marker 0.

Notice that marker 1 is activated and is the currently selected marker, 
indicated by the marker arrow pointing down. As you switch between 
markers, using the arrow keys, you will notice that the selected marker’s 
arrow points down, while all others point up.

Notice also that the frequency and amplitude data for the currently 
selected marker is displayed on the 8757D.

4. Move the cursor back to marker 0 and press Delta Ref Set > Marker Delta 
Off On to On.

In the table editor, notice that the frequency values for each marker are 
now relative to marker 0. Ref appears in the far right column (also labeled 
Ref) to indicate which marker is the reference. Refer to Figure 2-5.
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Figure 2-5 Marker Table Editor

5. Move the cursor back to marker 1 and press Marker Freq. Turn the front 
panel knob while observing marker 1 on the 8757D.

On the 8757D, notice that the displayed amplitude and frequency values 
for marker 1 are relative to marker 0 as the marker moves along the trace. 
Refer to Figure 2-6.

Figure 2-6 Delta Markers on 8757D

6. Press Turn Off Markers.

All active markers turn off. Refer to the Keysight PSG Signal Generators 
Key Reference for information on other marker softkey functions.

Adjusting Sweep 
Time

1. Press Sweep/List.
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This opens a menu of sweep control softkeys and displays a status screen 
summarizing all the current sweep settings.

2. Press Configure Ramp/Step Sweep.

Since ramp is the current sweep type, softkeys in this menu specifically 
control ramp sweep settings. When step is the selected sweep type, the 
softkeys control step sweep settings. Notice that the Freq Start and Freq 
Stop softkeys appear in this menu in addition to the Frequency hardkey 
menu.

3. Press Sweep Time to Manual > 5 > sec.

In auto mode, the sweep time automatically sets to the fastest allowable 
value. In manual mode, you can select any sweep time slower than the 
fastest allowable. The fastest allowable sweep time is dependent on the 
number of trace points and channels being used on the 8757D and the 
frequency span.

4. Press Sweep Time to Auto.

The sweep time returns to its fastest allowable setting.

Using Alternate 
Sweep

1. Press the Save hardkey.

This opens the table editor and softkey menu for saving instrument states. 
Notice that the Select Reg softkey is active. (For more information on 
saving instrument states refer to “Using the Instrument State Registers” 
on page 86.)

2. Turn the front panel knob until you find an available register and press 
SAVE. Remember this saved register number. If no registers are available, 
you can write over an in–use register, by pressing Re–SAVE.

3. Press Sweep/List > Configure Ramp/Step Sweep and enter new start and 
stop frequency values for the ramp sweep.

4. Press Alternate Sweep Register and turn the front panel knob to select the 
register number of the previously saved sweep state.

5. Press Alternate Sweep Off On to On.

The signal generator alternates between the original saved sweep and the 
current sweep. You may need to adjust 8757D settings to effectively view 
both sweeps, such as setting channel 2 to measure sensor A. Refer to 
Figure 2-7.

When using an 8757D network analyzer in manual sweep mode, you must activate 
the signal generator’s Manual Mode before using the Manual Freq softkey to 
control the sweep. Press Sweep/List > More (2 of 3) > Manual Mode On.

When you are using the PSG in a system with an 8757D network analyzer, you are 
limited to using registers 1 through 9 in sequence 0 for saving and recalling 
states.
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Figure 2-7 Alternating Sweeps on 8757D

Configuring an 
Amplitude Sweep

1. Press Return > Sweep > Off.

This turns off both the current sweep and the alternate sweep from the 
previous task. The current CW settings now control the RF output.

2. Press Configure Ramp/Step Sweep.

3. Using the Ampl Start and Ampl Stop softkeys, set an amplitude range to 
be swept.

4. Press Return > Sweep > Ampl.

The new amplitude ramp sweep settings control the RF output and the 
CW mode is turned off.

Configuring a Ramp Sweep for a Primary/Secondary Setup

This procedure shows you how to configure two PSGs and an 8757D to work in 
a primary/secondary setup. The primary/secondary control setup must use two 
instruments from the same signal generator family such as two PSG’s, or two 
83640B’s, or two 83751B’s. 

The primary/secondary setup applies to ramp sweep only, not step sweep or list 
sweep. To use this setup, you must have two sources from the same signal 
generator family. For example, you cannot us a PSG with an 83640B or a PSG with 
an 83751B.
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1. Set up the equipment as shown in Figure 2-8. Use a 9–pin, 
D–sub-miniature, male RS–232 cable with the pin configuration shown in 
Figure 2-9 to connect the auxiliary interfaces of the two PSGs. You can 
also order the cable (part number 8120–8806) from Keysight 
Technologies.

By connecting the primary PSG’s 10 MHz reference standard to the 
secondary PSG’s 10 MHz reference input, the primary’s timebase supplies 
the frequency reference for both PSGs.

2. Set up the secondary PSG’s frequency and power settings.

By setting up the secondary first, you avoid synchronization problems.

3. Set up the primary PSG’s frequency, power, and sweep time settings.

The two PSGs can have different frequency and power settings for ramp 
sweep.

4. Set the secondary PSG’s sweep time to match that of the primary.

Sweep times must be the same for both PSGs.

5. Set the secondary PSG to continuous triggering.

The secondary must be set to continuous triggering, but the primary can 
be set to any triggering mode.

6. On the secondary PSG, press Sweep/List > Sweep Type > Ramp Sweep 
Control > Slave.

This sets the PSG to operate in secondary mode.

7. On the primary PSG, press Sweep/List > Sweep Type > Ramp Sweep 
Control > Master. This sets the PSG to operate in primary mode.
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Figure 2-8 Primary/Secondary Equipment Setup

Figure 2-9 RS–232 Pin Configuration
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Extending the Frequency Range

You can extend the signal generator frequency range using an Keysight 83550 
series millimeter–wave source module or other manufacturer’s mm–source 
module. For information on using the signal generator with a millimeter–wave 
source module, refer to “Using Keysight Millimeter-Wave Source Modules” on 
page 324. 
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Modulating a Signal
This section describes how to turn on a modulation format, and how to apply it 
to the RF output.

Turning On a Modulation Format

A modulation format can be turned on prior to or after setting the signal 
parameters.

1. Access the first menu within the modulation format. 
This menu displays a softkey that associates the format’s name with off 
and on. For example, AM > AM Off On. For some formats, the off/on key 
may appear in additional menus other than the first one.

2. Press the modulation format off/on key until On highlights.
Figure 2-10 shows the portion of the AM modulation format’s first menu 
that displays the state of the modulation format, as well as the active 
modulation format annunciator.

The modulation format generates, but the carrier signal is not modulated 
until you apply it to the RF output (see page 84).

Depending on the modulation format, the signal generator may require a few 
seconds to build the signal. Within the digital formats (E8267D PSG with 
Option 601/602 only), you may see a BaseBand Reconfiguring status bar 
appear on the display. Once the signal is generated, an annunciator showing 
the name of the format appears on the display, indicating that the modulation 
format is active. For digital formats (E8267D PSG with Option 601/602 only), 
the I/Q annunciator appears in addition to the name of the modulation format.

Figure 2-10 Example of AM Modulation Format Off and On

First AM Menu 
Modulation format is off

 

 Modulation format is on

Active Modulation Format Annunciator
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Applying a Modulation Format to the RF Output

The carrier signal is modulated when the Mod On/Off key is set to On, and an 
individual modulation format is active. 

When the Mod On/Off key is set to Off, the MOD OFF annunciator appears on 
the display.When the key is set to On, the MOD ON annunciator shows in the 
display, whether or not there is an active modulation format. The annunciators 
simply indicate whether the carrier signal will be modulated when a 
modulation format is turned on.

To Turn RF Output Modulation On

Press the Mod On/Off key until the MOD ON annunciator appears in the display.

The carrier signal should be modulated with all active modulation formats. This 
is the factory default.

To Turn RF Output Modulation Off

Press the Mod On/Off key until the MOD OFF annunciator appears in the 
display.

The carrier signal is no longer modulated or capable of being modulated when 
a modulation format is active.

Figure 2-11 Carrier Signal Modulation Status

Mod Set to On—Carrier is Modulated

AM Modulation Format is Active

AM Modulation Format is Active

Mod Set to Off—Carrier is 
not Modulated

Mod Set to On—Carrier is 
not Modulated

No Active Modulation Format
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Using Data Storage Functions
This section explains how to use the two forms of signal generator data 
storage: the memory catalog and the instrument state register.

Using the Memory Catalog

The Memory Catalog is the signal generator’s interface for viewing, storing, 
and saving files; it can be accessed through the signal generator’s front panel 
or a remote controller. (For information on performing these tasks remotely, 
see the Keysight Signal Generators Programming Guide.)

Storing Files to the Memory Catalog

To store a file to the memory catalog, first create a file. For this example, use 
the default list sweep table.

1. Press Preset.

2. Press Sweep/List > Configure List Sweep > More (1 of 2) > Load/Store.

This opens the “Catalog of List Files”.

3. Press Store to File.

Table 2-1 Memory Catalog File Types and Associated Data

Binary binary data

State instrument state data (controlling instrument operating parameters, 
such as frequency, amplitude, and mode)

LIST sweep data from the List Mode Values table including frequency, 
amplitude, and dwell time

User Flatness user flatness calibration correction pair data (user–defined frequency 
and corresponding amplitude correction values)

FIR Finite Impulse Response (FIR) filter coefficients

ARB Catalog Types (E8267D PSG with Option 601/602 only) user created files –
Waveform Catalog Types: WFM1 (waveform file),
NVARB Catalog Types:
NVWFM (non–volatile, ARB waveform file),
NVMKR (non–volatile, ARB waveform marker file),
Seq (ARB sequence file),
MTONE (ARB multitone file),
DMOD (ARB digital modulation file), MDMOD (ARB multicarrier digital 
modulation file)

Modulation Catalog Types (E8267D PSG with Option 601/602 only) associated data for I/Q and 
FSK (frequency shift keying) modulation files

Shape burst shape of a pulse

Bit Bit
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This displays a menu of alphabetical softkeys for naming the file. Store 
to: is displayed in the active function area.

4. Enter the file name LIST1 using the alphabetical softkeys and the numeric 
keypad (for the numbers 0 to 9).

5. Press Enter.

The file should be displayed in the “Catalog of List Files”, showing the file 
name, file type, file size, and the date and time the file was modified.

Viewing Stored Files in the Memory Catalog

1. Press Utility > Memory Catalog > Catalog Type.

All files in the memory catalog are listed in alphabetical order, regardless 
of which catalog type you select. File information appears on the display 
and includes the file name, file type, file size, and the date and time the file 
was modified.

2. Press List.

The “Catalog of List Files” is displayed.

3. Press Catalog Type > State.

The “Catalog of State Files” is displayed.

4. Press Catalog Type > All.

The “Catalog of All Files” is displayed. For a complete list of file types, 
refer to Table  on page 85.

Using the Instrument State Registers

The instrument state register is a section of memory divided into 10 sequences 
(numbered 0 through 9) with each sequence consisting of 100 registers 
(numbered 00 through 99). Instrument state sequences and registers are used 
to store and recall instrument settings and provide a quick way to reconfigure 
the signal generator when switching between different instrument and signal 
configurations. 

The signal generator with either Option 005 (internal hard drive – 4 GB), or 
Options 008, and 009 (flash drive – 8 GB) installed, utilizes the memory for 
storing instrument state files and other user data. If these options are not 
installed, the signal generator has 20 MB available for data and instrument 
state storage. Instrument state files can vary in length depending on the signal 
generator’s configuration.

File data, such as modulation formats, arb setups, and table entries, are not 
stored with the save function. Only setups such as frequency, attenuation, 
power and other user–defined settings that do not survive a power cycle or 
instrument reset can be saved to a sequence and register. Any data file, such 
as an arb format file, associated with the instrument state will only be 
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referenced by its file name. Once an instrument state has been saved, recalling 
that state will setup the generator with the saved settings and load the 
associated file data. 

For more information on storing file data such as modulation formats, arb 
setups, and table entries refer to “Storing Files to the Memory Catalog” on 
page 85. Refer to the Keysight Signal Generators Programming Guide and 
the Keysight PSG Signal Generators Key Reference for more information on 
the save and recall function. 

Saving an Instrument State

1. Preset the signal generator, then turn on amplitude modulation (the AM 
annunciator will turn on):

a. Press Frequency > 800 > MHz.
b. Press Amplitude > 0 > dBm.
c. Press AM > AM Off On.

2. Press Save > Select Seq.

The sequence number becomes the active function. The signal generator 
displays the last sequence used. Using the arrow keys, set the sequence 
to 1.

3. Press Select Reg.

The register number in sequence 1 becomes the active function. The 
signal generator displays either the last register used accompanied by the 
text: (in use), or (if no registers are in use) register 00 accompanied by 
the text: (available). Use the arrow keys to select register 01.

4. Press Save Seq[1] Reg[01].

This saves this instrument state in sequence 1, register 01 of the 
instrument state register.

5. Press Add Comment to Seq[1] Reg[01].

This enables you to add a descriptive comment to sequence 1 register 01. 

6. Using the alphanumeric softkeys or the knob, enter a comment and press 
Enter.

7. Press Edit Comment In Seq[1] Reg[01].

If you wish, you can now change the descriptive comment for sequence 1 
register 01. 

After making changes to an instrument state, you can save it back to a specific 
register by highlighting that register and pressing Re–SAVE Seq[n] Reg[nn].

A reference to a file is saved along with the instrument state. However, no data is 
saved with the save function. You must store file data, using store commands, in a 
different memory location. 
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Recalling an Instrument State

Using this procedure, you will learn how to recall instrument settings saved to 
an instrument state register.

1. Press Preset.

2. Press the Recall hardkey.

Notice that the Select Seq softkey shows sequence 1. (This is the last 
sequence that you used.)

3. Press RECALL Reg.

The register to be recalled in sequence 1 becomes the active function. 
Press the up arrow key once to select register 1. Your stored instrument 
state settings should have been recalled.

Deleting Registers and Sequences

These procedures describe how to delete registers and sequences saved to an 
instrument state register.

Deleting a Specific Register within a Sequence

1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Select Seq and enter the sequence number containing the register 
you want to delete.

4. Press Select Reg and enter the register number you want to delete.

Notice that the Delete Seq[n] Reg[nn] should be loaded with the sequence 
and register you want to delete.

5. Press Delete Seq[n] Reg[nn].

This deletes the chosen register.

Deleting All Registers within a Sequence

1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Select Seq and enter the sequence number containing the registers 
you want to delete.

4. Press Delete all Regs in Seq[n].

This deletes all registers in the selected sequence.
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Deleting All Sequences

1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Delete All Sequences.

This deletes all of the sequences saved in the instrument state register.

8757 Network Analyzer Save and Recall Functions

The 8757 network analyzer family can save and recall signal generator 
instrument states although communication between the instruments is limited. 

A clear register command from the 8757 will cause the signal generator to 
replace a register’s contents with default values. Default values can be cleared 
from the signal generator by using the Delete All softkey menu or by using the 
corresponding SCPI (Standard Commands for Programmable Instruments) 
command.

The signal generator does not communicate directly with the 8757 network 
analyzer. If the 8757 saves an instrument state to a signal generator register 
and the user deletes that register, the 8757 will not recognize the deletion. An 
attempt, by the 8757, to recall a deleted state will cause the PSG to generate 
the error message: +700 “State Save Recall Error...”.

Be sure you want to delete the contents of all registers and all sequences in the 
instrument state register.
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Using Security Functions
This section describes how to use the PSG’s security functions to protect and 
remove classified proprietary information stored or displayed in the instrument. 
All security functions described in this section also have an equivalent SCPI 
command for remote operation. (Refer to the “System Commands” chapter of 
the Keysight PSG Signal Generators SCPI Command Reference for more 
information.)

Understanding PSG Memory Types

The PSG comprises several memory types, each used for storing a specific type 
of data. Before removing sensitive data, it is important to understand how each 
memory type is used in the PSG. The following tables describe each memory 
type used in the base instrument, baseband generator (Option 601, 602), hard 
disk (Option 005) or removable compact flash drive (Options 008 and 009).

Table 2-2 Base Instrument Memory 

Memory
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Location in Instrument and Remarks

Main 
Memory 
(SDRAM)

64 MB

Yes No firmware operating 
memory

operating system 
(not user)

CPU board, not battery backed.

Main 
Memory 
(Flash)

20 MB

Yes Yes factory 
calibration/configurati
on data

user file system, which 
includes instrument 
status backup, flatness 
calibration, IQ 
calibration, instrument 
states, waveforms 
(including header and 
marker data), 
modulation definitions, 
and sweep lists

firmware 
upgrades and 
user–saved data

CPU board (same chip as firmware memory, but 
managed separately)

User data is not stored in this memory if hard 
disk (Option 005) or the removable compact 
flash drive (Option 008 or 009) is installed.

Because this 32 MB memory chip contains 20 
MB of user data (described here) and 12 MB of 
firmware memory, a selective chip erase is 
performed. User data areas are selectively and 
completely sanitized when you perform the 
Erase and Sanitize function.
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Firmware 
Memory 
(Flash)

12 MB

No Yes main firmware image factory installed 
or firmware 
upgrade

CPU board (same chip as main flash memory, but 
managed separately)

During normal operation, this memory cannot be 
overwritten except for LAN configuration. It is 
only overwritten during the firmware installation 
or upgrade process.

Because this 32 MB memory chip contains 20 
MB of user data and 12 MB of firmware memory 
(described here), a selective chip erase is 
performed. User data areas are selectively and 
completely sanitized when you perform the 
Erase and Sanitize function.

Yes Yes LAN configuration front panel entry 
or remotely

Battery 
Backed 
Memory 
(SRAM)

512 kB

Yes Yes user–editable data 
(table editors)

last instrument state, 
last instrument state 
backup, and persistent 
instrument state and 
instrument status

firmware 
operations

CPU board

The battery can be removed to sanitize the 
memory, but must be reinstalled for the 
instrument to operate. The battery is located on 
the CPU board.

Bootrom 
Memory 
(Flash)

128 kB

No Yes CPU bootup program 
and firmware 
loader/updater

factory 
programmed

CPU board

During normal operation, this memory cannot be 
overwritten or erased. This read–only data is 
programmed at the factory.

Calibratio
n Backup 
Memory 
(Flash)

512 KB

No Yes factory 
calibration/configurati
on data backup

no user data

factory or service 
only

motherboard

Boards 
Memory 
(Flash)

512 
Bytes

No Yes factory calibration and 
information files, code 
images, and self–test 
limits

no user data

factory or service 
only

all RF boards, baseband generator, and 
motherboard

Micro– 
processo
r Cache 
(SRAM)

3 kB

Yes No CPU data and 
instruction cache

memory is 
managed by CPU, 
not user

CPU board, not battery backed.

Table 2-2 Base Instrument Memory  (Continued)

Memory
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Location in Instrument and Remarks
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Table 2-3 Baseband Generator Memory (Options 601 and 602) 

Memory
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Remarks

Waveform 
Memory 
(SDRAM)

40−320 MB

Yes No waveforms (including 
header and marker 
data) and PRAM

normal user 
operation

User data is completely sanitized when you 
perform the Erase and Sanitize function. 
Not battery backed.

BBG 
Firmware 
Memory 
(Flash)

32 MB

No Yes firmware image for 
baseband generator

firmware 
upgrade

Coprocessor 
Memory 
(SRAM)

32 MB

Yes No operating memory of 
baseband coprocessor 
CPU

During normal 
operation, some 
user information, 
such as payload 
data, can remain 
in the memory.

This memory is used during normal baseband 
generator operation. It is not directly accessible 
by the user. Not battery backed.

Buffer 
Memory 
(SRAM)

5 x 512 kB

No No support buffer memory 
for ARB and real–time 
applications

normal user 
operation

This memory is used during normal baseband 
generator operation. It is not directly accessible 
by the user. Not battery backed.

Table 2-4 Hard Disk Memory (Option 005)a

Memory 
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Remarks

Media 
Storage 
(Built–in 
Hard Disk)

6 GB or 
10 GB
(4 GB 
usable in 
both cases)

Yes Yes user files, including 
flatness calibrations, IQ 
calibration, instrument 
states, waveforms 
(including header and 
marker data), modulation 
definitions, and sweep 
lists

user–saved data The magnetic residue requires several 
rewrite cycles or drive removal and 
destruction.

The hard disk is an option and is therefore 
not installed in some instruments. If it is 
installed, these files are stored on the hard 
disk instead of in flash memory.

User data is completely sanitized when you 
perform the Erase and Sanitize 
function.
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Buffer 
Memory 
(DRAM)

512 kB

No No buffer (cache) memory normal operation 
through hard disk

a. Instruments with serial prefix < US4829/SG4829/MY4829. 

The removable compact flash drive is not hot swappable – always turn the power 
off to the instrument when removing or inserting the memory. Use only Keysight 
provided or certified compact flash cards. 

Table 2-5 Flash Drive Memory (Options 008a and 009b)

Memory 
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Remarks

Memory 
Storage 
(removable 
compact 
flash drive)

8 GB 
(usable 
81873740
80 bytes)

Yes Yes user files, including 
flatness calibrations, IQ 
calibration, instrument 
states, waveforms 
(including header and 
marker data), modulation 
definitions, and sweep 
lists

user–saved data The flash drive is an option and is therefore 
not installed in some instruments. If it is 
installed, these files are stored on the flash 
drive instead of in flash memory.

User data is completely sanitized when you 
perform the Erase and Sanitize 
function.

a. Instruments with serial prefix ³ US4928/SG4928/MY4928.
b. Instruments with serial prefix ³ US4829/SG4828/MY4829.

Table 2-4 Hard Disk Memory (Option 005)a

Memory 
Type 
and Size

W
rit

ab
le

 D
ur

in
g

Da
ta

 R
et

ai
ne

d

Purpose/Contents
Data Input 
Method

Remarks
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Removing Sensitive Data from PSG Memory

When moving the PSG from a secure development environment, you can 
remove any classified proprietary information stored in the instrument. This 
section describes several security functions you can use to remove sensitive 
data from your instrument.

Erase All

This function removes all user files, user flatness calibrations, user I/Q 
calibrations, and resets all table editors with original factory values, ensuring 
that user data and configurations are not accessible or viewable. The 
instrument appears as if it is in its original factory state, however, the memory 
is not sanitized. This action is relatively quick, taking less than one minute.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > 
Security > Erase All > Confirm Erase.

Erase and Overwrite All

This function performs the same actions as Erase All and then clears and 
overwrites the various memory types in accordance with Department of 
Defense (DoD) standards, as described below.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > 
Security > Erase and Overwrite All > Confirm Overwrite.

This function is different than pressing Utility > Memory Catalog > More (1 of 
2) > Delete All Files, which deletes all user files, but does not reset the table 
editors.

SRAM All addressable locations are overwritten with random characters.

CPU Flash All addressable locations are overwritten with random characters and then the flash blocks are erased. This 
accomplishes the same purpose of a chip erase, however, only the areas that are no longer in use are erased 
and the factory calibration files are left intact. System files are restored after erase.

DRAM/SDRAM Follow the Department of Defense (DoD) manual’s requirements. The instrument must be powered off to 
purge the memory contents. The instrument must remain powered off in a secure location for 3 minutes. 

Hard Disk All addressable locations are overwritten with a single character. (This is insufficient for top secret data, 
according to DoD standards. For top secret data, the hard drive must be removed and destroyed.)

Flash Drive All addressable locations are overwritten with a single character. (This is insufficient for top secret data, 
according to DoD standards. For top secret data, consult with your local security officer for approved 
procedures.)
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Erase and Sanitize All

This function performs the same actions as Erase and Overwrite All and then 
adds more overwriting actions. After executing this function, you must 
manually perform some additional steps for the sanitization to comply with 
Department of Defense (DoD) standards. These actions and steps are 
described below.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > 
Security > Erase and Sanitize All > Confirm Sanitize.

Removing Persistent State Information Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be 
toggled within predefined limits such as display intensity, contrast and the 
GPIB address. In vector models, the user IQ Cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal 
file and to set the operating states that are not affected by a signal generator 
power–on, preset, or *RST command to their factory default:

Instrument Setup

— On the front panel, press: Utility > Power On/Preset > Restore System 
Defaults > Confirm Restore Sys Defaults

— Or send the command: :SYSTem:PRESet:PERSistent
LAN Setup

The LAN setup (hostname, IP address, subnet mask, and default gateway) 
information is not defaulted with a signal generator power–on or *RST 
command. This information can only be changed or cleared by entering 
new data.

User IQ Cal File (Vector Models Only)

SRAM All addressable locations are overwritten with random characters.

CPU Flash All addressable locations are overwritten with random characters and then the flash blocks are erased. This 
accomplishes the same purpose of a chip erase, however, only the areas that are no longer in use are erased 
and the factory calibration files are left intact. System files are restored after erase.

DRAM/SDRAM Follow the Department of Defense (DoD) manual’s requirements. The instrument must be powered off to 
purge the memory contents. The instrument must remain powered off in a secure location for 3 minutes. 

Hard Disk All addressable locations are overwritten with a single character and then a random character. (This is 
insufficient for top secret data, according to DoD standards. For top secret data, the hard drive must be 
removed and destroyed.)

Flash Drive All addressable locations are overwritten with a single character and then a random character. (This is 
insufficient for top secret data, according to DoD standards. For top secret data, consult with your local 
security officer for approved procedures.)
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When a user–defined IQ calibration has been performed, the cal file data 
is removed by setting the cal file to default, as follows:

1. On the front panel, press: I/Q > I/Q Calibration > Revert to Default Cal 
Settings

2. Send these commands:

— :CAL:IQ:DEF
— :CAL:WBIQ:DEF

Using the Secure Mode

The secure mode automatically applies the selected Security Level action the 
next time the instrument’s power is cycled.

Setting the Secure Mode Level

1. Press Utility > Memory Catalog > More (1 of 2) > Security > 
Security Level.

2. Choose from the following selections:

None − equivalent to a factory preset, no user information is lost
Erase − equivalent to Erase All
Overwrite − equivalent to Erase and Overwrite All
Sanitize − equivalent to Erase and Sanitize All

Activating the Secure Mode

Press Utility > Memory Catalog > More (1 of 2) > Security > 
Enter Secure Mode > Confirm.

The Enter Secure Mode softkey changes to Secure Mode Activated.

If Your Instrument is Not Functioning

If the instrument is not functioning and you are unable to use the security 
functions, you may physically remove the processor board, hard disk or flash 
drive if installed, from the instrument. Once these assemblies are removed, 
proceed as follows:

For removal and replacement procedures, refer to the Keysight PSG Signal 
Generators Service Guide.

Once you activate secure mode (by pressing Confirm), you cannot 
deactivate or decrease the security level; the erasure actions for that 
security level execute at the next power cycle. Once you activate secure 
mode, you can only increase the security level until you cycle power. For 
example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but 
the secure mode is not activated.
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Processor Board

Either

— Discard the processor board and send the instrument to a repair facility. A 
new processor board will be installed and the instrument will be repaired 
and calibrated. If the instrument is still under warranty, you will not be 
charged for the new processor board.

or

— If you have another working instrument, install the processor board into that 
instrument and erase the memory. Then reinstall the processor board back 
into the non–working instrument and send it to a repair facility for repair 
and calibration. If you discover that the processor board does not function 
in the working instrument, discard the processor board and note that it 
caused the instrument failure on the repair order. If the instrument is still 
under warranty, you will not be charged for the new processor board.

Hard Disk 

Either

— Discard the hard disk and send the instrument to a repair facility. Indicate 
on the repair order that the hard disk was removed and must be replaced. A 
new hard disk will be installed and the instrument will be repaired and 
calibrated. If the instrument is still under warranty, you will not be charged 
for the new hard disk.

or

— Keep the hard disk and send the instrument to a repair facility. When the 
instrument is returned, reinstall the hard disk.

Flash Drive (Option 008 and 009 only)

Either

— Discard the flash memory card. Indicate on the repair order that the flash 
memory was removed and request a new memory card. If the instrument is 
still under warranty, you will not be charged for the new memory card.

or

— Keep the flash memory card and send the instrument to a repair facility. 
When the instrument is returned, reinstall the flash memory card.

Using the Secure Display

This function prevents unauthorized personnel from reading the instrument 
display and tampering with the current configuration through the front panel. 
The display is blanked, except for the message *** SECURE DISPLAY 
ACTIVATED ***, and the front panel keys are disabled. Once this function is 
activated, the power must be cycled to re–enable the display and front panel 
keys.
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To apply this function, press Utility > Display > More (1 of 2) > 
Activate Secure Display > Confirm Secure Display

Figure 2-12 PSG Screen with Secure Display Activated
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Enabling Options
You can retrofit your signal generator after purchase to add new capabilities. 
Some new optional features are implemented in hardware that you must 
install. Some options are implemented in software, but require the presence of 
optional hardware in the instrument. This example shows you how to enable 
software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each 
software option. 

1. Access the Software Options menu:
Utility > Instrument Adjustments > Instrument Options > Software 
Options. 
The following is an example of the signal generator display, which lists any 
enabled software options, and any software options that can be enabled:

2. Verify that the host ID shown on the display matches the host ID on the 
license key certificate. The host ID is a unique number for every 
instrument. If the host ID on the license key certificate does not match 
your instrument, the license key cannot enable the software option.

3. Verify that any required hardware is installed. Because some software 
options are linked to specific hardware options, before the software option 
can be enabled, the appropriate hardware option must be installed. For 
example, Option 420 (radar simulation modulation format) requires that 
Option 601/602 (internal baseband generator) be installed. If the software 
option that you intend to install is listed in a grey font, the required 
hardware may not be installed (look for an X in the “Selected” column of 
the appropriate hardware option in the Hardware Options menu).

4. Enable the software option:



100                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Basic Operation
Using the Web Server

a. Highlight the desired option.

b. Press Modify License Key, and enter the 12–character license key 
(from the license key certificate).

c. Verify that you want to reconfigure the signal generator with the 
new option:
Proceed With Reconfiguration > Confirm Change

The instrument enables the option and reboots.

Using the Web Server
You can communicate with the signal generator using the Web Server. This 
service uses TCP/IP (Transmission Control Protocol/Internet Protocol) to 
communicate with the signal generator over the internet. 

The Web Server uses a client/server model where the client is the web browser 
on your PC or workstation and the server is the signal generator. When you 
enable the Web Server, you can access a web page that resides on the signal 
generator. 

The Web–Enabled PSG web page, shown in Figure 2-13, provides general 
information on your signal generator and a means to control the instrument by 
using a remote front panel interface or using SCPI (Standard Communication 
for Programmable Instruments) commands. The web page also has links to 
Keysight’s products, support, manuals, and website. 

The Signal Generator Web Control menu button on the Web–Enabled PSG 
web page will access a second web page. This web page, shown in Figure 
2-14, provides a virtual instrument interface that can be used to control the 
signal generator. You can use the mouse to click on the signal generator’s front 
panel hardkeys, softkeys and number pad. There is also a text box that can be 
used to send SCPI commands to the instrument. 

Activating the Web Server 

Perform the following steps to access the Web Server. 

1. Turn on the Web Server by pressing Utility > GPIB/RS–232 LAN > LAN 
Services Setup > Web Server On.

2. Press the Proceed With Reconfiguration softkey.

3. Press the Confirm Change (Instrument will Reboot) softkey. The signal 
generator will reboot. 

4. Launch your PC or workstation web browser. 

The Web Server service is compatible with the latest version of the Microsoft 
Internet Explorer web browser.
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5. Enter the IP address of the signal generator in the web browser address 
field. For example, http://101.101.101.101. Replace 101.101.101.101 with 
your signal generator’s IP address. Press the Enter key on the computer’s 
keyboard.

6. Press the Enter key on the computer’s keyboard. The web browser will 
display the signal generator’s homepage as shown below in Figure 2-13. 
This web page displays information about the signal generator and 
provides access to Keysight’s website. 

Figure 2-13 Signal Generator Web Page

The IP (Internet Protocol) address can change depending on your LAN 
configuration. 

Use the LAN Config Manual DHCP softkey to select a Manual or DHCP 
(dynamic host communication protocol) LAN configuration. Refer to 
Keysight PSG Signal Generators Key Reference for more information.
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7. Click the Signal Generator Web Control menu button on the left of the 
page. A new web page will be displayed as shown below in Figure 2-14. 

Figure 2-14 Web Page Front Panel 

This web page remotely accesses all signal generator functions and 
operations. Use the mouse pointer to click on the signal generator’s hardkeys 
and softkeys. The results of each mouse click selection will be displayed on the 
web page. For example, click on the Frequency hardkey then use the 
front panel key pad to enter a frequency. You can also use the up and down 
arrow keys to increase or decrease the frequency. 

You can use the SCPI Command text box at the bottom of the front panel 
display to send commands to the signal generator. Enter a valid SCPI 
command, then click the SEND button. The results of the command will be 
displayed on a separate web page titled, “SCPI Command Processed”. You can 
continue using this web page to enter SCPI commands or you can return to the 
front panel web page. 

It may be necessary to use the web browser Refresh function if the web page does 
not update with new settings.
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This chapter provides information on the functions and features available for 
the E8267D PSG vector signal generator with Option 601 or 602.

— “Custom Modulation” on page  104

— “Arbitrary (ARB) Waveform File Headers” on page 106

— “Using the Dual ARB Waveform Player” on page 117

— “Using Waveform Markers” on page 125

— “Triggering Waveforms” on page 140

— “Using Waveform Clipping” on page 147

— “Using Waveform Scaling” on page 154

— “Setting the Baseband Frequency Offset” on page 157

See also: 

— “Custom Arb Waveform Generator” on page  199

— “Multitone Waveform Generator” on page  265

— “ Two–Tone Waveform Generator” on page  277
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Custom Modulation 
For creating custom modulation, the signal generator offers two modes of 
operation: the Arb Waveform Generator mode and the Real Time I/Q Baseband 
mode. The Arb Waveform Generator mode has built–in modulation formats 
such as NADC or GSM and pre–defined modulation types such as BPSK and 
16QAM that can be used to create a signal. The Real Time I/Q Baseband mode 
can be used to create custom data formats using built–in PN sequences or 
custom–user files along with various modulation types and different built–in 
filters such as Gaussian or Nyquist. 

Both modes of operation are used to build complex, digitally modulated 
signals that simulate communication standards with the flexibility to modify 
existing digital formats, define or create digitally modulated signals, and add 
signal impairments.
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Custom Arb Waveform Generator

The signal generator’s Arb Waveform Generator mode is designed for 
out–of–channel test applications. This mode can be used to generate data 
formats that simulate random communication traffic and can be used as a 
stimulus for component testing. Other capabilities of the Arb Waveform 
Generator mode include: 

 configuring single or multicarrier signals. Up to 100 carriers can be 
configured. 

 creating waveform files using the signal generator’s front panel interface. 

The waveform files, when created as random data, can be used as a stimulus 
for component testing where device performance such as adjacent channel 
power (ACP) can be measured. The AUTOGEN_WAVEFORM file that is 
automatically created when you turn the Arb Waveform Generator on can be 
renamed and stored in the signal generator’s non–volatile memory. This file 
can later be loaded into volatile memory and played using the Dual ARB 
waveform player. 

For more information, refer to the sections “Using the Dual ARB Waveform 
Player” on page 117 and “Modes of Operation” on page 24.

Custom Real Time I/Q Baseband

The real–time mode simulates single–channel communication using 
user–defined modulation types along with custom FIR filters, and symbol rates. 
Data can be downloaded from an external source into PRAM memory or 
supplied as real time data using an external input. The Real Time I/Q Baseband 
mode can also generate pre–defined data formats such as PN9 or FIX4. A 
continuous data stream generated in this mode can be used for receiver bit 
error analysis. This mode is limited to a single carrier. The Real Time I/Q 
Baseband mode:

 has more data and modulation types available than the Arb Waveform 
Generator mode. 

 supports custom I/Q constellation formats.

 has the capability to generate continuous PN sequences for bit error rate 
testing (BERT). 

 needs no waveform build time when signal parameters are changed. 

For more information, refer to the custom arb section “Overview” on page 200, 
the custom real time section “Overview” on page 228 and the section on 
“Digital Modulation” on page 24. 
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Arbitrary (ARB) Waveform File Headers
An ARB waveform file header enables you to save instrument setup information 
(key format settings) along with a waveform. When you retrieve a stored 
waveform, the header information is applied so that when the waveform starts 
playing, the dual ARB player is set up the same way each time.

Headers can also store a user–specified 32–character description of the 
waveform or sequence file.

A default header is automatically created whenever a waveform is generated, a 
waveform sequence is created, or a waveform file is downloaded to the PSG 
(for details on downloading files, see the Keysight Signal Generators 
Programming Guide).

The following signal generator settings are saved in a file header:

— ARB sample clock rate

— Runtime scaling (only in the dual ARB player)

Marker settings and routing functions (page 125)

— Polarity

— ALC hold

— RF blanking

— High crest mode (only in the dual ARB player)

— Modulator attenuation

— Modulator filter

— I/Q output filter (used when routing signals to the rear panel I/Q outputs)

— Other instrument optimization settings (for files generated by the PSG) that 
cannot be set by the user.

Creating a File Header for a Modulation Format Waveform

When you turn on a modulation format, the PSG generates a temporary 
waveform file (AUTOGEN_WAVEFORM), with a default file header. The default 
header has no signal generator settings saved to it. 

This procedure, which is the same for all ARB formats, demonstrates how to 
create a file header for a Custom digital modulation format.

1. Preset the signal generator.

2. Turn on the Custom modulation format:
Press Mode > Custom > ARB Waveform Generator > Digital Modulation 
Off On to On

A default file header is created, and the temporary waveform file 
(AUTOGEN_WAVEFORM) plays. Figure 3-1 shows the PSG’s display.



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                              107

Basic Digital Operation
Arbitrary (ARB) Waveform File Headers

Figure 3-1 Custom Digital Modulation First–Level Softkey Menu

At this point, a default file header has been created, with default 
(unspecified) settings that do not reflect the current signal generator 
settings for the active modulation. To save the settings for the active 
modulation, you must modify the default settings before you save the 
header information with the waveform file (see “Modifying Header 
Information in a Modulation Format” on page 107).

Modifying Header Information in a Modulation Format

This procedure builds on the previous procedure, explaining the different areas 
of a file header, and showing how to access, modify, and save changes to the 
information. 

In a modulation format, you can access a file header only while the modulation 
format is active (on). This procedure uses the Custom digital modulation 
format. All ARB modulation formats and the dual ARB player access the file 
header the same way, except that in some modulation formats, you may have 
to go to page two of the first–level softkey menu.

1. From the first–level softkey menu (shown in Figure 3-1 on page 107), open 
the Header Utilities menu:
Press ARB Setup > Header Utilities

First–Level Softkey Menu
(Some ARB formats have a 
second page)

Each time an ARB modulation format is turned on, a new temporary 
waveform file (AUTOGEN_WAVEFORM) and file header are generated, 
overwriting the previous temporary file and file header. Because all ARB 
formats use the same file name, this happens even if the previous 
AUTOGEN_WAVEFORM file was created by a different ARB modulation 
format.
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Figure 3-2 shows the default header for the Custom digital modulation 
waveform. The Saved Header Settings column, shows that the signal 
generator settings for the active format are Unspecified, which means 
that no settings have been saved to the file header.

The Current Inst. Settings column shows the current signal 
generator settings for the active modulation. These settings become the 
saved header settings when they are saved to the file header (as 
demonstrated in step 2). 

Figure 3-2 Custom Digital Modulation Default Header Display

2. Save the information in the Current Inst. Settings column to the file 
header:
Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. 
Settings column now display the same settings; the Saved Header 
Settings column lists the settings saved in the file header.

The file header contains the following signal generator settings:

If a setting is unspecified in the file header, the signal generator’s current 
value for that setting does not change when you select and play the 
waveform in the future.

 

Lets you enter/edit the 
Description field

Clears the Saved Header 
Settings column to the 
default settings
Saves the Current Inst. Settings 
column to the Saved Header 
Settings column

Current signal generator 
settings

Page 1

Default Header Settings

Note:
Parameters that are inactive (such as 
Runtime Scaling) can be set only in 
the dual ARB player.

Page 2

32–Character
Description:

A description entered for the header, such as a the waveform’s function (saved/edited with the 
Edit Description key, see Figure 3-2 on page 108).

Sample Rate: The ARB sample clock rate.

Runtime Scaling: The Runtime scaling value. Runtime scaling is applied in real–time while the waveform is playing. 
This setting can be changed only for files in the dual ARB player.

Marker 1...4 Polarity: The marker polarity, positive or negative (described on page 139). 
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3. Return to the ARB Setup menu: Press Return.

In the ARB Setup menu (shown in Figure 3-3), you can change the current 
instrument settings. Figure 3-3 also shows the softkey paths used in steps 
four through nine.

4. Set the ARB sample clock to 5 MHz: Press ARB Sample Clock > 5 > MHz.

5. Set the modulator attenuation to 15 dB:
Press More (1 of 2) > Modulator Atten n.nn dB Manual Auto to Manual > 
15 > dB.

6. Set the I/Q modulation filter to a through:
Press I/Q Mod Filter Manual Auto to Manual > Through.

7. Set marker one to blank the RF output at the set marker point(s):
Press More (2 of 2) > Marker Utilities > Marker Routing > Pulse/RF Blank 
> Marker 1.

For information on setting markers, see “Using Waveform Markers” on 
page 125.

8. Set the polarity of Marker 1 negative: 
Press Return > Marker Polarity > Marker 1 Polarity Neg Pos to Neg.

9. Return to the Header Utilities menu: Press Return > Return > Header 
Utilities.

Notice that the Current Inst. Settings column now reflects the 
changes made to the current signal generator setup in steps 4 through 8, 
but that the saved header values have not changed (as shown in Figure 3-4 
on page 111).

10.Save the current settings to the file header: Press Save Setup To Header 
softkey.

The settings from the Current Inst. Settings column now appear in 
the Saved Header Settings column. The file header has been modified 
and the current instrument settings saved. This is shown in Figure 3-5 on 
page 111.

ALC Hold Routing: Which marker, if any, implements the PSG’s ALC hold function (described on page 127). 

RF Blank Routing: Which marker, if any, implements the PSG’s RF blanking function (described on page 138).

I/Q Mod Filter: The I/Q modulator filter setting. The modulator filter affects the I/Q signal modulated onto the RF 
carrier.

I/Q Output Filter: The I/Q output filter setting. The I/Q output filter is used for I/Q signals routed to the rear panel I 
and Q outputs.

Mod Attenuation: The I/Q modulator attenuation setting.
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While a modulation format is active (is on), the waveform file 
(AUTOGEN_WAVEFORM) plays and you can modify the header information 
within the active modulation format. Once you turn the modulation format off, 
the header information is available only through the dual ARB player. 

Storing a waveform file (see page 124) stores the saved header information 
with the waveform. 

Figure 3-3 ARB Setup Softkey Menu and Marker Utilities

If you turn the modulation format off and then on, you overwrite the 
previous AUTOGEN_WAVEFORM file and its file header. To avoid this, 
rename the file before you turn the modulation format back on (see 
page 124).

Dual ARB Player softkey
(it does not appear in the ARB formats)
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Figure 3-4 Differing Values between Header and Current Setting Columns

Figure 3-5 Saved File Header Changes

Storing Header Information for a Dual ARB Player Waveform 
Sequence

When you create a waveform sequence (described on page 119), the PSG 
automatically creates a default file header, which takes priority over the 
headers for the waveform segments that compose the waveform sequence. 
During a waveform sequence playback, the waveform segment headers are 
ignored (except to verify that all required options are installed). When you store 
the waveform sequence, its file header is stored with it.

Values differ between 
the two columns

Page 1

Page 2

Values differ between 
the two columns

Page 1

Page 2



112                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Basic Digital Operation
Arbitrary (ARB) Waveform File Headers

Modifying and Viewing Header Information in the Dual ARB Player

Once a modulation format is turned off, the waveform file is available only to 
the dual ARB player. This is also true for downloaded waveform files. Because 
of this, future edits to a waveform’s header information must be performed 
using the dual ARB player. 

To modify header information in the dual ARB player, the waveform file must 
be playing in the dual ARB player (although you can view the header 
information in the dual ARB player without playing the file)

You can reapply saved header settings by reselecting the waveform file for 
playback. When you do this, the values from the Saved Header Settings 
column are applied to the PSG.

Modifying Header Information

All of the same header characteristics shown in Modifying Header Information 
in a Modulation Format are valid in the dual ARB player. This task guides you 
through selecting a waveform file and accessing the header for the selected 
file, then refers you back to the aforementioned procedure to perform the 
modifications.

1. Select a waveform:

a. Press Mode > Dual ARB > Select Waveform.

b. Using the arrow keys, highlight the desired waveform file.

c. Press the Select Waveform softkey.

2. Play the waveform: Press ARB Off On to On.

3. Access the header: Press ARB Setup > Header Utilities.

4. Refer to “Modifying Header Information in a Modulation Format” to edit 
the header information:

— For a default header, read the information in step one on page 107, 
then perform the remaining steps in the procedure.

— To modify an existing file header, start with step three on page 109.

The rest of this section focuses on the additional file header operations found 
in the dual ARB player.
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Viewing Header Information with the Dual ARB Player Off

One of the differences between a modulation format and the dual ARB player is 
that even when the dual ARB player is off, you can view a file header. You 
cannot, however, modify the displayed file header unless the dual ARB player 
is on, and the displayed header is selected for playback. With the dual ARB 
player off, perform the following steps.

1. Select a waveform:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform file.
c. Press the Select Waveform softkey.

2. Access the file header: Press ARB Setup > Header Utilities.
The header information is now visible in the PSG display. As shown in 
Figure 3-6, the header editing softkeys are grayed–out, meaning they are 
inactive.

Figure 3-6 Viewing Header Information

Header editing softkeys 
grayed–out

File header information and 
current signal generator 
settings

Page 1

Page 2

Note: When the dual ARB 
player is off, the current 
instrument settings column 
does not update; the values 
displayed may not be valid.
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Viewing Header Information for a Different Waveform File

While a waveform is playing in the dual ARB player, you can view the header 
information of a different waveform file, but you can modify the header 
information only for the waveform that is currently playing. When you select 
another waveform file, the header editing softkeys are grayed–out (see Figure 
3-6). This task guides you through the available viewing choices.

1. View the waveform file list: Press Mode > Dual ARB > ARB Setup > Header 
Utilities > View Different Header.

As shown in Figure 3-7, there is an alphabetical list of waveform files in the 
table. 

Figure 3-7 Waveform File List for Viewing a Different Header

2. View all waveform segments in non–volatile memory:

a. Press the Catalog Type softkey. As shown in Figure 3-7, you have a 
choice of three waveform file types that can be displayed in the 
table accessed in step one.

NVWFM  displays all waveform segments stored in 
non–volatile memory

Seq  displays all waveform sequence files

WFM1  displays all waveform segments stored in 
volatile memory

b. Press the NVWFM softkey. The table displays the waveform files in 
non–volatile memory.

3. View a waveform file’s header information: Highlight a file and press the 
View Header softkey.

The header information for the selected waveform file appears in the PSG 
display. If there is a waveform playing, its header information is replaced 
by this information, but the waveform settings used by the signal 
generator do not change. To return to the header information for the 

Current waveform file type

Waveform File Types

Table
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playing waveform, either press View Different Header, select the current 
playing waveform file, and press View Header, or 
press Return > Header Utilities.
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Playing a Waveform File that Contains a Header

After a waveform file (AUTOGEN_WAVEFORM) is generated in a modulation 
format and the format is turned off, the file becomes accessible to and can only 
be played back by the dual ARB player. This is true for downloaded waveform 
files (downloading files is described in the Keysight Signal Generators 
Programming Guide). When the waveform is selected for playback, the saved 
header information is used by the signal generator. Some of these settings 
appear as part of the labels of the softkeys used to set the parameters, and 
also appear on the dual ARB summary display (see Figure 3-8).

For details on applying file header settings and playing back a waveform, see 
“Playing a Waveform” on page  121.

To properly set up the instrument:

1. Select the waveform.
2. Modify the signal generator settings as desired.
3. Turn on the dual ARB.

Figure 3-8 File Header Settings

The signal generator used to play back a stored waveform file must have 
the same options as are required to generate the file.

Header setting same as 
preset setting

Header setting applied

Summary Display

The waveform is selected; 
saved header settings are 

applied.

Can change when a 
waveform is selected

Summary Display

The waveform is not selected; 
preset settings are applied.
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Using the Dual ARB Waveform Player
The dual arbitrary (ARB) waveform player is used to create, edit, and play 
waveform files. There are two types of waveform files: segments and 
sequences. A segment is a waveform file that is created using one of the signal 
generator’s pre–defined ARB formats. A sequence can be described as several 
segments strung together to create one waveform file. Waveform files can also 
be created remotely using another signal generator or using computer 
programs and downloaded to the PSG for playback by the Dual ARB waveform 
player. For information on downloading waveforms, refer to the Keysight 
Signal Generators Programming Guide.

A waveform file is automatically generated whenever an ARB modulation 
format is turned on. This automatically generated file is named 
AUTOGEN_WAVEFORM. Because this default file name is shared among all 
ARB formats, it must be renamed if you want to save the information. If the file 
is not renamed, it will be overwritten when another ARB format is turned on.

The Dual ARB waveform player provides markers (page 125), triggering 
(page 140), and clipping (page 147) capabilities.

Before you can work with any waveform file, it must reside in volatile memory. 
The signal generator has two types of memory, WFM1 (volatile waveform 
memory) and NVWFM (non–volatile waveform memory). A newly generated 
waveform file (AUTOGEN_WAVEFORM), created when the Arb Waveform 
Generator is turned on, initially resides in WFM1. If you want to save this file, 
rename it and store it in NVWFM. Load a stored waveform file from NVWFM 
into volatile memory (WFM1) where it can be edited or played by the ARB 
waveform player. Refer to Custom Modulation for more information.

Accessing the Dual ARB Player

Press Mode > Dual ARB.

This first–level softkey menu is shown in the following figure. Most procedures 
start from this menu. 
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Creating Waveform Segments

There are two ways to provide waveform segments for use by the waveform 
sequencer. You can either download a waveform via the remote interface, or 
generate a waveform using one of the ARB modulation formats. For 
information on downloading waveforms via the remote interface, see the 
Keysight Signal Generators Programming Guide.

A waveform sequence is made up of segments but can also contain other 
sequences. Any number of segments, up to 32768, can be used to create a 
sequence. This limit count is determined by the number of segments in the 
waveform sequence. Segments and sequences can be repeated within a 
waveform sequence and the total of all segments and repeated segments 
cannot exceed the limit count. The following diagram shows a waveform 
sequence made up of two sequences and three segments. In this example the 
segment count is eleven. 

Figure 3-9 Waveform Sequence Diagram

The following procedure describes how to create two waveform segments, 
then name and store them in ARB memory. After you name and store the two 
waveform segments in ARB memory, you can use them to build a waveform 
sequence, as described on page 119.

1. Generate the first waveform:

a. Press Preset > Mode > Two Tone > Alignment Left Cent Right to 
Right.

b. Press Two Tone Off On to On, then to Off.
You turn off the Two Tone mode after generation because a 
waveform cannot be renamed as a segment while it is in use.
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This generates a two tone waveform with the tone on the right placed at 
the carrier frequency. During waveform generation, the T–TONE and I/Q 
annunciators activate. The waveform is stored in volatile memory, with the 
default file name AUTOGEN_WAVEFORM.

2. Create the first waveform segment:

a. Press Mode > Dual ARB > Waveform Segments > Load Store to 
Store.

b. Highlight the default segment AUTOGEN_WAVEFORM.
c. Press Rename Segment > Editing Keys > Clear Text.
d. Enter a file name (for example, TTONE), and press Enter > Store 

Segment To NVWFM Memory.
This renames the waveform segment, and stores a copy in non 
volatile memory.

3. Generate the second waveform:

a. Press Mode > Multitone > Initialize Table > Number Of Tones > 9 > 
Enter > Done.

b. Press Multitone Off On to On, then Off.
Remember that a waveform cannot be renamed as a segment while 
it is in use.

This generates a multitone waveform with nine tones. During waveform 
generation, the M–TONE and I/Q annunciators activate. The waveform is 
stored in volatile memory with the default file name AUTOGEN_WAVEFORM.

4. Create the second waveform segment:

Repeat Step 2, giving this segment a descriptive name (for example, 
MTONE).

Building and Storing a Waveform Sequence

This example shows how to build and edit a waveform sequence using the two 
waveform segments created on page 118. To use a segment in a sequence, the 
segment must reside in volatile memory; for information on loading waveform 
segments from non volatile to volatile memory, see page 124.

1. Select the waveform segments:

Define a sequence as one repetition of the two–tone waveform segment 
followed by one repetition of the nine–tone multitone waveform segment.

a. Press Mode > Dual ARB > Waveform Sequences > Build New 
Waveform Sequence > Insert Waveform.

Because there can be only one AUTOGEN_WAVEFORM waveform in memory 
at any given time, you must rename this file to clear the way for a second 
waveform. 
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b. Highlight the a waveform segment (for example, TTONE) and press 
Insert Selected Waveform.

c. Highlight a second waveform segment (for example, MTONE) and 
press Insert Selected Waveform.

d. Press Done Inserting

2. Optional: Enable markers as desired for the segments in the new 
sequence: see page 135.

3. Name and store the waveform sequence to the Catalog of Seq Files 
in the memory catalog:

a. Press Name and Store.

b. Enter a file name (for example, TTONE+MTONE).

c. Press Enter.
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Playing a Waveform

This procedure applies to playing either a waveform segment or a waveform 
sequence.
This example plays the waveform sequence created in the previous procedure.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, TTONE+MTONE) 
from the Sequence column of the Select Waveform catalog, and 
press Select Waveform.

The display shows the currently selected waveform 
(for example, Selected Waveform: SEQ:TTONE+MTONE).

2. Generate the waveform: 
Press ARB Off On to On. 

This plays the selected waveform sequence. 
During the waveform sequence generation, the ARB and I/Q annunciators 
activate.

Editing a Waveform Sequence

This example shows how to edit waveform segments within a waveform 
sequence, and then save the edited sequence under a new name. Within the 
editing display, you can change the number of times each segment plays (the 
repetitions), delete segments, add segments, toggle markers (described on 
page 135), and save changes.

1. Press Waveform Sequences > Edit Selected Waveform Sequence, and 
highlight the first entry.

2. Press Edit Repetitions > 100 > Enter. The second segment is automatically 
selected.

3. Press Edit Repetitions > 200 > Enter.

4. Save the edited file as a new waveform sequence:

a. Press Name And Store.

b. Press Editing Keys > Clear Text, then enter a new file name (for 
example, TTONE100+MTONE200).

c. Press Enter.

If you do not store changes to the waveform sequence prior to exiting the 
waveform sequence editing display, the changes are removed.
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You have now changed the number of repetitions for each waveform segment 
entry from 1 to 100 and 200, respectively. The sequence has been stored under 
a new name to the Catalog of Seq Files in the signal generator’s memory 
catalog.

For information on playing a waveform sequence, refer to page 121.
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Adding Real–Time Noise to a Dual ARB Waveform (E8267D with 
Option 403)

The signal generator with option 403 can apply AWGN (additive white 
gaussian noise) to a carrier in real time while the modulating waveform file is 
being played by the Dual ARB waveform player. The AWGN can be configured 
using front panel softkeys. The Carrier to Noise Ratio softkey allows you to 
specify the amount of noise power relative to carrier power that is applied to 
the signal. The Carrier Bandwidth softkey sets the bandwidth over which the 
noise is integrated and the Noise Bandwidth Factor softkey allows you to 
select a flat noise bandwidth. The Output Mux softkey enables diagnostic 
control of additive noise, so that only the noise, only the carrier, or the sum of 
both the noise and the carrier are output from the internal baseband generator. 
With the ALC off, this feature enables direct measurement of the carrier or the 
noise contributions independently from the total power. The system still 
behaves as if both the noise and the carrier are present on the output when it 
comes to determining the Auto Modulation Attenuation and the RMS level for 
RMS Power Search.

These softkeys are described in the Keysight PSG Signal Generators Key 
Reference. 

The following procedure sets up a carrier and modulates it using the 
pre–defined SINE_TEST_WFM waveform file. AWGN is then applied to the 
carrier. 

Configuring AWGN

1. Preset the signal generator. Press the Preset hardkey.

2. Press the Frequency hardkey and enter 15 GHz. 

3. Press the Amplitude hardkey and enter –10 dBm.

4. Press RF On Off to On.

5. Press Mode > Dual ARB > Select Waveform and select the 
SINE_TEST_WFM waveform.

6. Press Select Waveform.

7. Press ARB Off On to On.

8. Press ARB Setup > ARB Sample Clock enter 50 MHz.

9. Press Real–time Noise Setup > Carrier to Noise Ratio and enter 30 dB.

10.Press Carrier Bandwidth and enter 40 MHz.

11.Press Real–time Noise Off On to On.

This procedure applies AWGN to the 15 GHz carrier. The displayed power level 
of the signal generator, –10 dBm, will include the noise power which is set as a 
carrier to noise ratio (C/N) of 30 dB. Noise power, for the purpose of C/N, is 
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applied across a carrier bandwidth of 40 MHz. The default noise bandwidth 
factor is 1, which provides a flat noise signal bandwidth of a least 0.8 times the 
50 MHz sample rate.

Storing and Loading Waveform Segments

Waveform segments can reside in volatile memory as WFM1 files, or they can 
be stored to non–volatile memory as NVWFM files, or both. To play or edit a 
waveform file, it must reside in volatile memory. Because files stored in volatile 
memory do not survive a power cycle, it is a good practice to store important 
files to non–volatile memory and load them to volatile memory whenever you 
want to use them.

Storing Waveform Segments to Non–volatile Memory

1. Press Mode > Dual ARB > Waveform Segments.

2. If necessary, press Load Store to Store.

3. Press Store All To NVWFM Memory.

Copies of all WFM1 waveform segment files have been stored in non–volatile 
memory as NVWFM files. To store files individually, highlight the file and press 
Store Segment To NVWFM Memory.

Loading Waveform Segments from Non–volatile Memory

1. Clear out the volatile memory and delete all WFM1 files: Power cycle the 
instrument.

2. Press Mode > Dual ARB > Waveform Segments.

3. If necessary, press Load Store to Load.

4. Press Load All From NVWFM Memory.

Copies of all NVWFM waveform segment files have been loaded into volatile 
memory as WFM1 files. 
To load files individually, highlight the file and press Load Segment From 
NVWFM Memory.

Renaming a Waveform Segment

1. Press Mode > Dual ARB > Waveform Segments.

2. Highlight the desired file and press Rename Segment > Editing Keys > 
Clear Text.

3. Enter the desired file name and then press Enter.
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Using Waveform Markers
The signal generator provides four waveform markers to mark specific points 
on a waveform segment. When the signal generator encounters an enabled 
marker, an auxiliary output signal is routed to the rear panel event connector 
(described in Rear Panel) that corresponds to the marker number. You can use 
this auxiliary output signal to synchronize another instrument with the 
waveform, or as a trigger signal to start a measurement at a given point on a 
waveform.

You can also configure markers to initiate ALC hold, or RF Blanking (which 
includes ALC hold). 

Creating a waveform segment (page 118) also creates a marker file that places 
a marker point on the first sample point of the segment for markers one and 
two. When a waveform file is downloaded that does not have a marker file 
associated with it, the signal generator creates a marker file without any 
marker points. Factory–supplied segments have a marker point on the first 
sample for all four markers.

The following procedures demonstrate how to use markers while working in 
the dual ARB player, but the process is the same when working in any ARB 
format. 

These procedures also discuss two types of points: a marker point and a 
sample point. A marker point is a point at which a given marker is set on a 
waveform; you can set one or more marker points for each marker. A sample 
point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

“1. Clearing Marker Points from a Waveform Segment” on page 131

“2. Setting Marker Points in a Waveform Segment” on page 132

“3. Controlling Markers in a Waveform Sequence (Dual ARB Only)” on 
page 135

This section also provides the following information:

— “Waveform Marker Concepts” on page 126

— “Accessing Marker Utilities” on page 129

— “Viewing Waveform Segment Markers” on page 130

— “Viewing a Marker Pulse” on page 137

— “Using the RF Blanking Marker Function” on page 138

— “Setting Marker Polarity” on page 139
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Waveform Marker Concepts

The signal generator’s ARB formats provide four waveform markers to mark 
specific points on a waveform segment. You can set each marker’s polarity and 
marker points (on a single sample point or over a range of sample points). Each 
marker can also perform ALC hold or RF Blanking and ALC hold.

Marker File Generation

Generating a waveform segment (see page 118) automatically creates a 
marker file that places a marker point on the first sample point of the segment 
for markers one and two.

Downloading a waveform file (as described in the Keysight Signal Generators 
Programming Guide) that does not have a marker file associated with it 
creates a marker file that does not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must 
reside in volatile memory (see “Loading Waveform Segments from 
Non–volatile Memory” on page  124).

In the dual ARB player, you can modify a waveform segment’s marker points 
without playing the waveform, or while playing the waveform in an ARB 
modulation format. 

In an ARB modulation format, you must play the waveform before you can 
modify a segment’s marker points. 

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset 
the signal generator, or cycle the PSG power. To ensure that a waveform uses 
the correct settings when it is played, set the marker polarities or routing (RF 
Blanking and ALC Hold), and save the information to the file header 

Marker 
File

Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF 

when Marker 
is Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC 

when Marker 
is Low

When the signal generator encounters an enabled marker Figure 1-3 on 
page 41 (described on page 135), an auxiliary output signal is generated and 
routed to the rear panel event connector that corresponds to the marker 
number (N). 
The EVENT 3 and 4 connectors are pins on the AUXILIARY I/O connector 
(connector locations are shown in Figure 1-3 on page 41).

RF Blank Only: includes ALC Hold
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(page 106). This is especially important when the segment plays as part of a 
sequence because the previously played segment could have different marker 
and routing settings.

ALC Hold Marker Function (For Instruments with serial prefixes 
>=US4722/MY4722)

While you can set a marker function (described as Marker Routing on the 
softkey label) either before or after you set marker points (page 132), setting a 
marker function before setting marker points may cause power spikes or loss of 
power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that 
incorporates idle periods, or when the increased dynamic range encountered 
with RF blanking (page 138) is not desired. 

The ALC hold marker function holds the ALC circuitry at the average (RMS) 
value of the sampled points set by the marker(s). For both positive and 
negative marker polarity, the ALC samples the RF output signal (the carrier 
plus any modulating signal) when the marker signal goes high:

The marker signal has a minimum of a two sample point delay in its response 
relative to the waveform signal response. To compensate for the marker signal 
delay, offset marker points from the waveform sample at which you want the 
ALC sampling to begin.

Positive: The signal is sampled during the on marker points.

Negative The signal is sampled during the off marker points.

Because it can affect the waveform’s output amplitude, do not use the ALC 
hold for longer than 100 ms. For longer time intervals, refer to “Setting 
Power Search Mode” on page 334.

Positive Polarity
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Incorrect ALC sampling can create a sudden unleveled condition that may 
create a spike in the RF output, potentially damaging a DUT or connected 
instrument. To prevent this condition, ensure that you set markers to let 
the ALC sample over an amplitude that accounts for the higher power 
levels encountered within the signal.

Close–up of averaging

The ALC samples the waveform when the marker signal 
goes high, and uses the average of the sampled waveform 
to set the ALC circuitry.

Here the ALC samples during the on marker points 
(positive polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points
Marker range: 95–97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s 
area of highest amplitude. Note that the marker is set well 
before the waveform’s area of lowest amplitude. This takes into 
account the response difference between the marker and the 
waveform signal.

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110–1022
Marker polarity: Positive

This example shows a marker set to sample the low part of 
the same waveform, which sets the ALC modulator 
circuitry for that level; this usually results in an unleveled 
condition for the signal generator when it encounters the 
high amplitude of the pulse.

MarkerMarker
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Accessing Marker Utilities

Use the following procedure to display the marker parameters. This procedure 
uses the Dual ARB player, but you can access the marker utilities through the 
ARB Setup softkey in all ARB formats.

1. Select the ARB waveform player:

press Mode > Dual ARB

2. Press ARB Setup > Marker Utilities.

Sample range begins on first point of signal

Negative range set between signal and 
off time

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110–1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low 
during the marker on points; the marker signal goes high 
during the off points. The ALC samples the waveform during 
the off marker points.

Marker On Marker On

Sampling both on and off time sets the modulator circuitry 
incorrectly for higher signal levels. Note the increased 
amplitude at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the 
markers set for a segment (this example uses the factory–supplied segment, 
SINE_TEST_WFM).

1. In the Marker Utilities menu (page 129), press Set Markers.

2. Highlight the desired waveform segment. 
In an ARB format, there is only one file (AUTOGEN_WAVEFORM) and it is 
already highlighted.

3. Press Display Markers > Zoom in Max. The maximum zoom in range is 28 
points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a 
sample point range greater than 460 points may not show the marker 
locations.

Most of the procedures in this section begin at the Marker Utilities softkey 
menu.

When using an ARB format other than 
Dual ARB, you must turn on the format 
to enable the Set Markers softkey.
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1. Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but 
are set in addition to existing points. Because markers are cumulative, before 
you set points, view the segment (page 130) and remove any unwanted points. 
With all markers cleared, the level of the event output signal is 0V.

Clearing All Marker Points

1. In the Marker Utilities menu (page 129), press Set Markers.

2. Highlight the desired waveform segment. 
In an ARB format, there is only one file (AUTOGEN_WAVEFORM) and it is 
already highlighted.

3. Highlight the desired marker number: 
Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected 
segment:
Press Set Marker Off All Points.

The Set Marker display

These softkeys 
change the range 
of waveform 
sample points 
shown on the 
marker display.
Each press of the 
softkey changes 
the sample range 
by approximately 
a factor of two

Marker 
points on
first sample 
point

First sample 
point shown on 
display

Select a segment

The display below shows the I and Q components of the waveform, and 
the marker points set in a factory–supplied segment.
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5. Repeat from step 3 for any remaining marker points that you want to 
remove.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set 
across points 10−20. This makes it easy to see the affected marker points. The 
same process applies whether the existing points are set over a range 
(page 133) or as individual points (page 133).

1. In the Marker Utilities menu (page 129), select the desired marker (for this 
example, Marker 1).

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than 
or equal to the number of points in the waveform, and greater than or 
equal to the value set in step 2 (for this example, 17):
Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

This turns off all marker points for the active marker within the range set in 
Steps 2 and 3, as shown in the following figure.

Clearing a Single Marker Point

Use the steps described in Clearing a Range of Marker Points, but set both the 
first and last marker point to the value of the point you want to clear. For 
example, if you want to clear a marker on point 5, set both the first and last 
value to 5.

2. Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in volatile 
memory (page 124).

When you set marker points, they do not replace points that already exist, but 
are set in addition to existing points. Because markers are cumulative, before 
you set marker points within a segment, view the segment (page 130) and 
remove any unwanted points (page 131).

Placing a Marker Across a Range of Points

1. In the Marker Utilities menu (page 129), press Set Markers.

Viewing markers is described on page 130
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2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN_WAVEFORM) and it is 
already highlighted.

3. Highlight the desired marker number:

Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the first 
marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on 
sample point 10, and ends on sample point 20, as shown in the following 
figure.

Placing a Marker on a Single Point

On the First Point

1. In the Marker Utilities menu (page 129), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN_WAVEFORM) and it is 
already highlighted.

3. Highlight the desired marker number:

Press Marker 1 2 3 4

4. Press Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number 
selected in step 3.

On Any Point

Viewing markers is described on page 130
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Use the steps described in Placing a Marker Across a Range of Points, but set 
both the first and last marker point to the value of the point you want to set. 
For example, if you want to set a marker on point 5, set both the first and last 
value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the 
spacing (skipped points) between each marker. You must set the spacing 
before you apply the marker settings; you cannot apply skipped points to a 
previously set range of points.

1. Remove any existing marker points (page 131).

2. In the Marker Utilities menu (page 129), press Set Markers.

3. Highlight the desired waveform segment.
In ARB formats there is only one file (AUTOGEN_WAVEFORM) and it is 
already highlighted. 

4. Highlight the desired marker number: Press Marker 1 2 3 4

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range to a value less than the number of 
points in the waveform, and 
greater than or equal to the first marker point (in this example, 25):
Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 
1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on every other point (one sample point is 
skipped) within the marker point range, as shown below.

One application of the skipped point feature is the creation of a clock signal as 
the auxiliary output.

Viewing markers is described on page 130
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3. Controlling Markers in a Waveform Sequence (Dual ARB Only)

In a waveform segment, an enabled marker point generates an auxiliary output 
signal that is routed to the rear panel event connector (described in Rear 
Panel) corresponding to that marker number. For a waveform sequence, you 
enable or disable markers on a segment–by–segment basis; this enables you 
to output markers for some segments in a sequence, but not for others. Unless 
you change the marker settings or cycle the power, the setting remains the 
same for the next loaded sequence.

As You Create a Waveform Sequence

After you select the waveform segments to create a waveform sequence, and 
before you name and save the sequence, you can enable or disable each 
segment’s markers independently. Enabling a marker that has no marker 
points (page 132) has no effect on the auxiliary outputs.

1. Select the waveform segments (step 1 on page 119).

2. Toggle the markers as desired: 

a. Highlight the first waveform segment.

b. Press Enable/Disable Markers.

c. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 
3, and Toggle Marker 4.
Toggling a marker that has no marker points (page 132) has no 
effect on the auxiliary outputs. 

An entry in the Mkr column (see figure below) indicates that the 
marker is enabled for that segment; no entry in the column means 
that all markers are disabled for that segment

d. In turn, highlight each of the remaining segments and repeat step c.

3. Press Return.

4. Name and store the waveform sequence (step 3 on page 120).

The following figure shows a sequence built reusing the same factory–supplied 
waveform segment; a factory–supplied segment has a marker point on the first 
sample for all four markers. In this example, Marker 1 is enabled for the first 
segment, Marker 2 is enable for the second segment, and markers 3 and 4 are 
enabled for the third segment.

Sequence Marker Column

This entry shows that 
markers 3 and 4 are enabled 
for this segment.
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For each segment, only the markers enabled for that segment produce a rear 
panel auxiliary output signal. In this example, the Marker 1 auxiliary signal 
appears only for the first segment, because it is disabled for the remaining 
segments. The Marker 2 auxiliary signal appears only for the second segment, 
and the marker 3 and 4 auxiliary signals appear only for the third segment.

In an Existing Waveform Sequence

If you have not already done so, create and store a waveform sequence that 
contains at least three segments (page 119). Ensure that the segment or 
segments are available in volatile memory (page 124).

1. Press Mode > Dual ARB > Waveform Sequences, and highlight the desired 
waveform sequence.

2. Press Edit Selected Waveform Sequence, and highlight the first 
waveform segment.

3. Press Enable/Disable Markers > Toggle Marker 1, Toggle Marker 2, 
Toggle Marker 3, and Toggle Marker 4.
Toggling a marker that has no marker points (page 132) has no effect on 
the auxiliary outputs. 

An entry in the Mkr column indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for 
that segment

4. Highlight the next waveform segment and toggle the desired markers (in 
this example, markers 1 and 4).

5. Repeat step 4 as desired (for this example, select the third segment and 
toggle marker 3).

6. Press Return > Name And Store > Enter.

The markers are enabled or disabled per your selections, and the changes have 
been saved to the selected sequence file.

 
Sequence Marker Column

This entry shows that only 
marker 3 is enabled for this 
segment.
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Viewing a Marker Pulse

When a waveform plays (page 121), you can detect a set and enabled marker’s 
pulse at the rear panel event connector that corresponds to that marker 
number. This example demonstrates how to view a marker pulse generated by 
a waveform segment that has at least one marker point set (page 132). The 
process is the same for a waveform sequence.  

This example uses the factory–supplied segment, SINE_TEST_WFM in the Dual 
ARB Player. Factory–supplied segments have a marker point on the first 
sample point for all four markers, as shown.

1. Press Mode > Dual ARB > Select Waveform, and highlight the desired 
segment (in this example, SINE_TEST_WFM).

2. Press ARB Off On to On.

3. Connect an oscilloscope input to the EVENT 1 connector, and trigger on 
the Event 1 signal.
When a marker is present, the oscilloscope displays a marker pulse, as 
shown in the following example.

Marker points on
first sample point of
waveform segment

Viewing markers is described on page 130.

RF Output

Marker pulse on the Event 1 signal.



138                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Basic Digital Operation
Using Waveform Markers

Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the 
softkey label) either before or after setting the marker points (page 132), 
setting a marker function before you set marker points may change the RF 
output. RF Blanking includes ALC hold (described on page 127, note Caution 
regarding unleveled power). The signal generator blanks the RF output when 
the marker signal goes low.

1. Using the factory–supplied segment SINE_TEST_WFM, set Marker 1 across 
points 1−180 (page 133).

2. From the Marker Utilities menu (page 129), assign RF Blanking to Marker 
1: 
Press Marker Routing > Pulse/RF Blank > Marker 1.

Marker Polarity = Positive
When marker polarity is positive (the 
default setting), the RF output is blanked 
during the off maker points.

200180Point 1
Marker

Segment

RF Signal

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on 
maker points

≈3.3V

0V

≈3.3V

0V
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In the Marker Utilities menu (page 129), press Marker Polarity.

2. Select the marker polarity as desired for each marker number.

As shown on page 138:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

Default Marker Polarity = Positive

Set each marker polarity independently.

See Also: “Saving Marker Polarity and Routing 
Settings” on page  126.
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Triggering Waveforms
Triggering is available in both ARB and real–time formats. ARB triggering 
controls the playback of a waveform file; real–time custom triggering controls 
the transmission of a data pattern. The examples and discussions in this 
section use the Dual ARB Player, but the functionality and method of access 
(described on page 142) are similar in all (ARB and real–time) formats. 

Triggers control data transmission by telling the PSG when to transmit the 
modulating signal. Depending on the trigger settings, the data transmission 
may occur once, continuously, or the PSG may start and stop the transmission 
repeatedly (Gated mode).

A trigger signal comprises both positive and negative signal transitions 
(states), which are also called high and low periods; you can configure the PSG 
to trigger on either state. It is common to have multiple triggers, also referred 
to as trigger occurrences or trigger events, occur when the signal generator 
requires only a single trigger. In this situation, the PSG recognizes the first 
trigger event and ignores the rest.

When you select a trigger mode, you may lose the signal (carrier plus 
modulation) from the RF output until you trigger the modulating signal. This is 
because the PSG sets the I and Q signals to zero volts prior to the first trigger 
event, which suppresses the carrier. If you create a data pattern with the initial 
I and Q voltages set to values other than zero, this does not occur. After the 
first trigger event, the signal’s final I and Q levels determine whether you see 
the carrier signal or not (zero = no carrier, other values = visible carrier). At the 
end of most data patterns, the final I and Q points are set to a value other than 
zero. 

There are four parts to configuring a waveform trigger: 

— Source determines how the PSG receives the trigger that initiates waveform 
play.

— Mode determines the waveform’s overall behavior when it plays.
— Response determines the specifics of how the waveform responds to a 

trigger.
— Polarity determines the state of the trigger to which the waveform responds 

(used only with an external trigger source); you can set either negative, or 
positive.
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Source

Mode and Response

The arbitrary waveform player provides four trigger modes; each mode has one 
or more possible responses:

— Single plays the waveform once. Arb formats have the following 
retriggering options:

— Off ignores triggers received during play; a trigger received after 
playback completes restarts the playback.

— On causes a trigger received during play to repeat the waveform after 
the current play completes.

— Immediate causes a trigger received during play to immediately 
restart the waveform.

— Gated causes the waveform to wait for the first active trigger signal state to 
begin transmission, then repeatedly start and stop in response to an 
externally applied gating signal (example on page 143). You select the 
active state with the Gate Active Low High softkey (see page 143).

In an ARB format, the waveform plays during the inactive state, and stops 
during the active state.

In real–time Custom, behavior depends on whether the signal incorporates 
framed or unframed data. 

Because the PSG provides only unframed data, to transmit a framed data 
signal you must create an external file that incorporates the framing and 
download it to the PSG (see the Keysight Signal Generators Programming 
Guide).

— Unframed data transmits during active states, and stops during 
inactive states. The signal stops at the last transmitted symbol and 
restarts at the next symbol.

— Framed data starts transmitting at the beginning of a frame during 
active states, and stops at the end of a frame when the end occurs 
during inactive states. If the end of the frame extends into the next 
active state, the signal transmits continuously. 

The Trigger hardkey

A command sent through the rear panel GPIB, LAN, or Auxiliary (RS–232) interface

An external trigger signal applied to either the PATTERN TRIG IN connector, or the PATT TRIG IN 2
pin on the AUXILIARY I/O connector (connector locations are shown in Figure 1-3 on page 41).

The following parameters affect an external trigger signal:
– The source (Input connector) of the external trigger signal (see page 142)
– The polarity of the external trigger (described on page 143)
– Any desired delay between when the PSG receives an external trigger and when the 
waveform responds to it (see page 142).
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— Segment Advance (Dual ARB only) causes a segment in a sequence to 
require a trigger to play. The trigger source controls how play moves from 
segment to segment (example on page 145). A trigger received during the 
last segment loops play to the first segment in the sequence. You have two 
choices as to how the segments play:

— Single causes a segment in a sequence to play once, then to stop 
and wait for a trigger before advancing to the next segment, which 
plays to completion. Triggers received during play cause the current 
segment to finish, then play advances to the next segment, which 
plays to completion.

— Continuous causes a segment in a sequence to play continuously 
until the waveform receives another trigger. Triggers received during 
play cause the current segment to finish, then play advances to the 
next segment, which plays continuously.

— Continuous repeats the waveform until you turn the signal off or select 
another waveform, trigger mode, or response. Continuous has the following 
options:

— Free Run immediately triggers and plays the waveform; triggers 
received during play are ignored.

— Trigger & Run plays the waveform when a trigger is received; 
subsequent triggers are ignored.

— Reset & Run (not available in real–time Custom) plays the waveform 
when a trigger is received; subsequent triggers restart the waveform.

Accessing Trigger Utilities

The following figures show the menus for the trigger parameters. These figures 
show the Dual ARB player, but you can access the trigger utilities through the 
Trigger softkey in all ARB formats, and the Pattern Trigger softkey in the Real 
Time I/Q Baseband (Custom) format.

— To display the trigger modes, press Mode > Dual ARB > Trigger.

Active only when
Ext is selected.

PAT TRIG IN 2 pin on 
the AUXILARY I/O connector

PATTERN TRIG IN connector
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— To display the response selections available for a given trigger mode, press 
Trigger Setup, then select the desired trigger mode. To see the selections 
for Single mode in an ARB format, select Retrigger Mode; in real–time 
Custom, selecting Single mode causes the data pattern to play once when 
triggered.

— To display the trigger source options, press Trigger Setup > Trigger 
Source.

Setting the Polarity of an External Trigger

Gated Mode 

The selections available with the gate active parameter refer to the low and 
high states of an external trigger signal. For example, when you select High, 
the active state occurs during the high of the trigger signal. 

ARB Formats  When the active state occurs, the PSG stops the 
waveform file playback at the last played sample point, 
and restarts the playback at the next sample point 
when the inactive state occurs. 

Real–Time Custom  When the active state occurs, the PSG transmits 
the data pattern. When the inactive state occurs, the 
transmission stops at the last transmitted symbol, and 
restarts at the next symbol when the active state 
occurs. 

Continuous, Single, or Segment Advance Modes

The Ext Polarity Neg Pos softkey selections refer to the low (negative) and high 
(positive) states of an external trigger. With Neg selected (the default), the 
PSG responds during the low state of the trigger signal.

Using Gated Triggering

Gated triggering enables you to define the on (playback) and off states of a 
modulating waveform. This example uses the factory supplied segment, 
SINE_TEST_WFM.
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1. Connect the output of a function generator to the signal generator’s rear 
panel PATTERN TRIG IN, as shown in the following figure. 

This connection is applicable to all external triggering methods. The 
optional oscilloscope connection enables you to see the effect that the 
trigger signal has on the RF output.

2. Preset the signal generator.

3. Configure the carrier signal output:

— Set the desired frequency.
— Set the desired amplitude.
— Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Preset the signal generator.

b. Press Mode > Dual ARB > Select Waveform.

c. Highlight a waveform file (for this example, SINE_TEST_WFM).

d. Press Select Waveform.

5. Select the waveform trigger method:

a. Press Trigger > Gated.

b. Press Trigger > Trigger Setup and note that for the Gate Active Low 
High softkey, the default selection is High, which is the selection 
used in this example.

6. Select the trigger source and rear panel input:

a. For the Trigger Source softkey, the default selection is Ext, which is 
the selection used in this example (gated triggering requires an 
external trigger). 

b. Press Trigger Source and note that for the Ext Source softkey, the 
default selection is Patt Trig In 1, which is the selection used in this 
example. 

7. Generate the waveform: 
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Press ARB Off On to On.

8. On the function generator, configure a TTL signal for the external gating 
trigger.

9. (Optional) Monitor the current waveform:

Configure the oscilloscope to display both the output of the signal 
generator, and the external triggering signal. You will see the waveform 
modulating the output during the gate inactive periods (low).

The following figure shows an example display.

Using Segment Advance Triggering

Segment advance triggering enables you to control the segment playback 
within a waveform sequence. The following example uses a waveform 
sequence that has two segments.

If you have not created and stored a waveform sequence, complete the steps in 
the sections, “Creating Waveform Segments” on page 118, and “Building and 
Storing a Waveform Sequence” on page 119.

1. Preset the signal generator.

2. Configure the RF output:

— Set the desired frequency.
— Set the desired amplitude.
— Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

Externally Applied Gating Signal
Gate Active = High

RF OutputModulating Waveform

In the real–time Custom mode, the behavior is reversed: when the gating 
signal is high, you see the modulated waveform.



146                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Basic Digital Operation
Triggering Waveforms

b. Highlight a waveform sequence file.

c. Press Select Waveform.

4. Select the waveform trigger method and trigger source:

a. Press Trigger > Segment Advance.

b. Press Trigger > Trigger Setup and note that the Seg Advance Mode 
softkey displays the default selection (Continuous), which is the 
selection used in this example.

c. Press Trigger Source > Trigger Key.

5. Generate the waveform sequence:
Press Return > Return > ARB Off On to On.

6. Trigger the first waveform segment to begin playing repeatedly: 
Press the Trigger hardkey.

7. (Optional) Monitor the current waveform:

Connect the output of the signal generator to the input of an oscilloscope, 
and configure the oscilloscope so that you can see the output of the signal 
generator.

8. Trigger the second segment: 
Press the Trigger hardkey.

The second segment in the sequence now plays. Pressing the Trigger 
hardkey causes the current playback to finish and the next segment to 
start; when the last segment plays, pressing the Trigger hardkey causes 
the first segment in the waveform sequence to start when the current 
segment finishes.
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Using Waveform Clipping 
Waveforms with high power peaks can cause intermodulation distortion, which 
generates spectral regrowth (a condition that interferes with signals in 
adjacent frequency bands). The clipping function enables you to reduce high 
power peaks by clipping the I and Q data to a selected percentage of its 
highest peak. 

The clipping feature is available only with the Dual ARB mode. 

How Power Peaks Develop

To understand how clipping reduces high power peaks, it is important to know 
how the peaks develop as the signal is constructed.

I/Q waveforms can be the summation of multiple channels (see Figure 3-10). 
Whenever most or all of the individual channel waveforms simultaneously 
contain a bit in the same state (high or low), an unusually high power peak 
(negative or positive) occurs in the summed waveform. This does not happen 
frequently because the high and low states of the bits on these channel 
waveforms are random, which causes a canceling effect.

Figure 3-10 Multiple Channel Summing

The I and Q waveforms combine in the I/Q modulator to create an RF 
waveform. The magnitude of the RF envelope is determined by the equation 

, where the squaring of I and Q always results in a positive value. 

As shown in Figure 3-11, simultaneous positive and negative peaks in the I and 
Q waveforms do not cancel each other, but combine to create an even greater 
peak.
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Figure 3-11 Combining the I and Q Waveforms

How Peaks Cause Spectral Regrowth

Because of the relative infrequency of high power peaks, a waveform will have 
a high peak–to–average power ratio (see Figure 3-12). Because a transmitter’s 
power amplifier gain is set to provide a specific average power, high peaks can 
cause the power amplifier to move toward saturation. This causes 
intermodulation distortion, which generates spectral regrowth.

Figure 3-12 Peak–to–Average Power
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Spectral regrowth is a range of frequencies that develops on each side of the 
carrier (similar to sidebands) and extends into the adjacent frequency bands 
(see Figure 3-13). Consequently, spectral regrowth interferes with 
communication in the adjacent bands. Clipping can provide a solution to this 
problem.

Figure 3-13 Spectral Regrowth Interfering with Adjacent Band

How Clipping Reduces Peak–to–Average Power

You can reduce peak–to–average power, and consequently spectral regrowth, 
by clipping the waveform to a selected percentage of its peak power. The PSG 
vector signal generator provides two different methods of clipping: circular and 
rectangular.

During circular clipping, clipping is applied to the combined I and Q waveform 
(|I + jQ|). Notice in Figure 3-14 that the clipping level is constant for all phases 
of the vector representation and appears as a circle. During rectangular 
clipping, clipping is applied to the I and Q waveforms separately (|I|, |Q|). Notice 
in Figure 3-15 on page 150 that the clipping level is different for I and Q; 
therefore, it appears as a rectangle in the vector representation. With either 
method, the objective is to clip the waveform to a level that effectively reduces 
spectral regrowth, but does not compromise the integrity of the signal. Figure 
3-16 on page 151 uses two complementary cumulative distribution plots to 
show the reduction in peak–to–average power that occurs after applying 
circular clipping to a waveform.

The lower you set the clipping value, the lower the peak power that is passed 
(or the more the signal is clipped). Often, the peaks can be clipped successfully 
without substantially interfering with the rest of the waveform. Data that might 
be lost in the clipping process is salvaged because of the error correction 
inherent in the coded systems. If you clip too much of the waveform, however, 
lost data is irrecoverable. You may have to try several clipping settings to find a 
percentage that works well.
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Figure 3-14 Circular Clipping

Figure 3-15 Rectangular Clipping
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Figure 3-16 Reduction of Peak–to–Average Power

Configuring Circular Clipping

This procedure shows you how to configure circular clipping. The circular 
setting clips the composite I/Q data (I and Q data are clipped equally). For 
more information about circular clipping, refer to “How Clipping Reduces 
Peak–to–Average Power” on page 149.

1. Press Preset > Mode > Custom > Arb Waveform Generator > Digital 
Modulation Off On to On. This generates a custom arbitrary waveform for 
use in this procedure. You can also use a previously stored or downloaded 
waveform.
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2. Press Mode > Dual ARB > Select Waveform and ensure that 
AUTOGEN_WAVEFORM is highlighted on the display. AUTOGEN_WAVEFORM 
is the default name assigned to the waveform you generated in the 
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the 
previous softkey menu.

4. Press ARB Off On to On. The Dual Arb player must be turned on to display 
the CCDF plot in the following steps.

5. Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure 
that AUTOGEN_WAVEFORM is highlighted on the display. 

6. Press CCDF Plot and observe the position of the waveform’s curve, which 
is the darkest line.

7. Press Return > Return > Clipping.

8. Ensure that the Clipping Type |I+jQ| |I|,|Q| softkey is set to |I+jQ|, which is 
circular clipping.

9. Press Clip |I+jQ| To > 80 > % > Apply to Waveform. The I and Q data are 
both clipped by 80%. Once clipping is applied to the waveform it cannot 
be undone. Repeated use of the clipping function has a cumulative effect 
on the waveform.

10.Press Waveform Statistics > CCDF Plot and observe the waveform’s curve. 
Notice the reduction in peak–to–average power, relative to the previous 
plot, after applying clipping. 

Configuring Rectangular Clipping

This procedure shows you how to configure rectangular clipping. The 
rectangular setting clips the I and Q data independently. For more information 
about rectangular clipping, refer to “How Clipping Reduces Peak–to–Average 
Power” on page 149.

1. Press Preset > Mode > Custom > Arb Waveform Generator > Digital 
Modulation Off On to On. This generates a custom arbitrary waveform for 
use in this procedure. You can also use a previously stored or downloaded 
waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that 
AUTOGEN_WAVEFORM is highlighted on the display. AUTOGEN_WAVEFORM 
is the default name assigned to the waveform you generated in the 
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the 
previous softkey menu.

4. Press ARB Off On to On. The Dual Arb player must be turned on to display 
the CCDF plot in the following steps.
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5. Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure 
that AUTOGEN_WAVEFORM is highlighted on the display. 

6. Press CCDF Plot and observe the position of the waveform’s curve, which 
is the darkest line.

7. Press Return > Return > Clipping.

8. Ensure that the Clipping Type |I+jQ| |I|,|Q| softkey is set to |I|,|Q|. This 
activates the Clip |I| To and Clip |Q| To softkeys that enable you to 
configure rectangular (independent) I and Q data clipping.

9. Press Clip |I| To > 80 > %.

10.Press Clip |Q| To > 40 > % > Apply to Waveform. The I and Q data are 
individually clipped by 80% and 40%, respectively. Once clipping is 
applied to the waveform it cannot be undone. Repeated use of the 
clipping function has a cumulative effect on the waveform.

11.Press Waveform Statistics > CCDF Plot and observe the waveform’s curve. 
Notice the reduction in peak–to–average power, relative to the previous 
plot, after applying clipping. 
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Using Waveform Scaling
Waveform scaling is used to eliminate DAC over–range errors. The PSG 
provides two methods of waveform scaling. You can perform runtime scaling, 
which enables you to make real–time scaling adjustments of a currently 
playing waveform, or you can permanently scale a non–playing waveform file 
residing in volatile memory. This section describes how DAC over–range errors 
occur and how you can use waveform scaling to eliminate these errors 
effectively.

The scaling feature is available only with the Dual ARB mode.

How DAC Over–Range Errors Occur

The PSG utilizes an interpolator filter in the conversion of the digital I and Q 
baseband waveforms into analog waveforms. The clock rate of the interpolator 
is four times that of the baseband clock. The interpolator therefore calculates 
sample points between the incoming baseband samples to equal the faster 
clock rate and smooth out the waveform, giving it a more curve–like 
appearance (see Figure 3-17).

Figure 3-17 Waveform Interpolation

The interpolation filters in the DAC’s have overshoot. If a baseband waveform 
has a fast–rising edge, the interpolator filter’s overshoot or frequency response 
becomes a component of the interpolated baseband waveform. This response 
causes a ripple or ringing effect at the peak of the rising edge. If this ripple 
exceeds (or overshoots) the upper limit of the DAC’s range, the interpolator 
calculates erroneous sample points and is unable to replicate the true form of 
the ripple (see Figure 3-18). As a result, the PSG reports a DAC over–range 
error.
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Figure 3-18 Waveform Overshoot

How Scaling Eliminates DAC Over–Range Errors

Scaling reduces or shrinks a baseband waveform’s amplitude while 
maintaining its basic shape and characteristics, such as peak–to–average 
power ratio. If the fast–rising baseband waveform is scaled enough to allow an 
adequate margin for the overshoot, the interpolator filter is then able to 
calculate sample points that include the ripple effect, thereby eliminating the 
over–range error 
(see Figure 3-19).

Figure 3-19 Waveform Scaling

Although scaling maintains the basic shape of the waveform, too much scaling 
can compromise its integrity because the bit resolution can be so low that the 
waveform becomes corrupted with quantization noise. Maximum accuracy and 
optimum dynamic range are achieved by scaling the waveform just enough to 
remove the DAC over–range error. Optimum scaling varies with waveform 
content.
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Scaling a Currently Playing Waveform (Runtime Scaling)

This procedure enables you to make real–time scaling adjustments to a 
currently playing waveform. This type of scaling does not affect the waveform 
file and is well suited for eliminating DAC over–range errors.

1. Press Preset > Mode > Custom > Arb Waveform Generator > Digital 
Modulation Off On to On. This generates a custom arbitrary waveform for 
use in this procedure. You can also use a previously stored or downloaded 
waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that 
AUTOGEN_WAVEFORM is highlighted on the display. AUTOGEN_WAVEFORM 
is the default name assigned to the waveform you generated in the 
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the 
previous softkey menu.

4. Press ARB Off On to On. This plays the selected waveform.

5. Press ARB Setup > More (1 of 2) > Waveform Runtime Scaling and adjust 
the front panel knob or use the number keys to enter a new value. The new 
scaling value is instantly applied to the playing waveform. Runtime 
scaling adjustments are not cumulative, as the values are always relative 
to original amplitude of the waveform file.

Scaling a Waveform File in Volatile Memory

This procedure enables you to permanently scale a waveform file. You can then 
store the scaled waveform segment to non–volatile memory for future use. 
Scaling is cumulative and non–reversible.

1. Press Preset > Mode > Custom > Arb Waveform Generator > Digital 
Modulation Off On to On. This generates a custom arbitrary waveform for 
use in this procedure. You can also use a previously stored or downloaded 
waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that 
AUTOGEN_WAVEFORM is highlighted on the display. AUTOGEN_WAVEFORM 
is the default name assigned to the waveform you generated in the 
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the 
previous softkey menu.

4. Press ARB Setup > Waveform Utilities and ensure that 
AUTOGEN_WAVEFORM is highlighted on the display.

5. Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform. The 
waveform is now reduced to 70 percent of its original amplitude. Once this 
type of scaling is applied to the waveform it cannot be undone. Repeated 
scaling applications have a cumulative effect on the waveform.
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Setting the Baseband Frequency Offset
The baseband frequency offset specifies a value to shift the baseband 
frequency up to ±20 MHz within the BBG 80 MHz signal bandwidth, depending 
on the signal generator’s baseband generator option. 

When the Baseband Frequency Offset is non–zero, the hardware rotator 
accumulates phase–shift of the baseband signal. This phase is automatically 
reset when the baseband frequency offset is returned to 0 Hz. 

Common uses for the offset feature include:

— offsetting the carrier from any LO feedthrough (carrier signal spur at the 
carrier frequency)

— sum the baseband signal with external I and Q inputs to create a 
multicarrier signal

— use the signal generator’s I/Q signal as an IF

The baseband frequency offset value is one of the file header parameters, 
which means you can store this value with the waveform. When you select a 
waveform with a stored frequency offset value, the signal generator changes 
the current value to match the stored file header value. If there is no stored 
baseband offset frequency value for the current waveform, the signal generator 
uses the last set frequency offset value. 

You can also use the Save function to store this value as part of the signal 
generator setup. When you Recall a setup stored with the Save function, the 
baseband frequency offset value becomes the current instrument setting value, 
disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This 
example uses the factory supplied waveform, SINE_TEST_WFM available in the 
Dual ARB Player. To view the output for this example, connect the RF OUTPUT 
of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the main display highlight the waveform: SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.

Changing the baseband frequency offset may cause a DAC over range 
condition that generates error 628, Baseband Generator DAC over 
range. The signal generator incorporates an automatic scaling feature to 
minimize this occurrence. For more information, see “How Scaling 
Eliminates DAC Over–Range Errors” on page 155.
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c. Turn on the RF OUTPUT.

4. Press ARB Setup > More (2 of 3) > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 
MHz.
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4 Optimizing Performance

In the following sections, this chapter describes procedures that improve the 
performance of the Keysight PSG signal generator.

— “Using the ALC” on page 159

— “Using External Leveling” on page 161

— “Creating and Applying User Flatness Correction” on page 166

— “Using the Option 521 Detector Calibration (Option 521)” on page 181

— “Adjusting Reference Oscillator Bandwidth (Option UNR/UNX/UNY)” on 
page 182

— “Optimizing Phase Noise and Harmonics Below 3.2 GHz (Option 
UNX/UNY)” on page 183

— “Wideband IQ/FM Mode <3.2 GHz (Option 018)” on page 186

Using the ALC 

Selecting ALC Bandwidth

For internal leveling, the signal generator uses automatic leveling control (ALC) 
circuitry prior to the RF output. ALC bandwidth has five selections: automatic, 
100 Hz, 1 kHz, 10 kHz, and 100 kHz. In automatic mode (the preset selection), 
the signal generator automatically selects the ALC bandwidth depending on 
the configuration and settings (see Figure 4-1).

Internal leveling works from –15 dBm to maximum power.
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Figure 4-1 Decision Tree for Automatic ALC Bandwidth Selection

To Select an ALC Bandwidth

Press Amplitude > ALC BW > 100 Hz, 1 kHz, 10 kHz, or 100 kHz. 
This overrides the signal generator’s automatic ALC bandwidth selection with 
your specific selection.

For waveforms with varying amplitudes, high crest factors, or both, the 
recommended ALC loop bandwidth is 100 Hz. Limiting the loop bandwidth of 
the ALC circuit will prevent the ALC from sampling the fast rising edges of 
pulsed waveforms with high crest factors found in formats such as 802.11b, 
CDMA, and OFDM. A limited, or narrow bandwidth will result in a longer ALC 
sample time and a more accurate representation of the signal’s level. 

RF OUTPUT
< 2 MHz

AM OFF
PULSE OFF

AM OFF
PULSE ON

AM ON
PULSE ON

AM ON
PULSE OFF

ALC BW
100 Hz

ALC BW
1 kHz

ALC BW
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No No No

Yes Yes Yes Yes

ALC BW
 100 kHz

ARB On

Yes

No No

Yes

Do not use the 10 kHz ALC bandwidth for any I/Q modulated signal, as the 
ALC integration time is too short. For CW signals, you can use higher ALC 
bandwidths.
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Using External Leveling

The PSG signal generator can be externally leveled by connecting an external 
sensor at the point where leveled RF output power is desired. This sensor 
detects changes in RF output power and returns a compensating voltage to 
the signal generator’s ALC input. The ALC circuitry raises or lowers (levels) the 
RF output power based on the voltage received from the external sensor, 
ensuring constant power at the point of detection.

There are two types of external leveling available on the PSG. You can use 
external leveling with a detector and coupler/power splitter setup, or a 
millimeter–wave source module.

To Level with Detectors and Couplers/Splitters

Figure 4-2 illustrates a typical external leveling setup. The power level 
feedback to the ALC circuitry is taken from the external negative detector, 
rather than the internal signal generator detector. This feedback voltage 
controls the ALC system, leveling the RF output power at the point of 
detection.

To use detectors and couplers/splitters for external leveling at an RF output 
frequency of 
10 GHz and an amplitude of 0 dBm, follow the instructions in this section.

Required Equipment

— Keysight 8474E negative detector

— Keysight 87301D directional coupler

— cables and adapters, as required

Connect the Equipment

Set up the equipment as shown in Figure 4-2.

Figure 4-2 External Detector Leveling with a Directional Coupler

External leveling works from –15 dBm to maximum power.
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Configure the Signal Generator

1. Press Preset.

2. Press Frequency > 10 > GHz.

3. Press Amplitude > 0 > dBm.

4. Press RF On/Off.

5. Press Leveling Mode > Ext Detector.

This deactivates the internal ALC detector and switches the ALC input 
path to the front panel ALC INPUT connector. The EXT indicator is 
activated in the AMPLITUDE area of the display.

6. Observe the coupling factor printed on the directional coupler at the 
detector port. Typically, this value is -10 to -20 dB.

Enter the positive dB value of this coupling factor into the signal 
generator.

7. Press More (1 of 2) > Ext Detector Coupling Factor > 16 (or the positive 
representation of the value listed at the detector port of the directional 
coupler) > dB.

Leveled output power is now available at the output of the directional 
coupler.

Determining the Leveled Output Power

Figure 4-3 shows the input power versus output voltage characteristics for 
typical Keysight Technologies diode detectors. Using this chart, you can 
determine the leveled power at the diode detector input by measuring the 
external detector output voltage. You must then add the coupling factor to 
determine the leveled output power. The range of power adjustment is 
approximately –20 to +25 dBm.

For signal generators with Option 1E1, notice that the ATTN HOLD 
(attenuator hold) annunciator is displayed. During external leveling, the 
signal generator automatically uncouples the attenuator from the ALC 
system for all external leveling points. While in this mode, the RF output 
amplitude adjustment is limited to -20 to +25 dBm, the adjustment range 
of the ALC circuitry. For more information, see “External Leveling with 
Option 1E1 Signal Generators” on page 164.

While operating in external leveling mode, the signal generator’s displayed 
RF output amplitude is affected by the coupling factor value, resulting in a 
calculated approximation of the actual RF output amplitude. To determine 
the actual RF output amplitude at the point of detection, measure the 
voltage at the external detector output and refer to Figure 4-3 or measure 
the power directly with a power meter.
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Figure 4-3 Typical Diode Detector Response at 25° C

External Leveling with Option 1E1 Signal Generators

Signal generators with Option 1E1 contain a step attenuator prior to the RF 
output connector. During external leveling, the signal generator automatically 
holds the present attenuator setting (to avoid power transients that may occur 
during attenuator switching) as the RF amplitude is changed. A balance must 
be maintained between the amount of attenuation and the optimum ALC level 
to achieve the required RF output amplitude. For optimum accuracy and 
minimum noise, the ALC level should be greater than -10 dBm.
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For example, leveling the CW output of a 30 dB gain amplifier to a level of -10 
dBm requires the output of the signal generator to be approximately -40 dBm 
when leveled. This is beyond the amplitude limits of the ALC modulator alone, 
resulting in an unleveled RF output. Inserting 45 dB of attenuation results in an 
ALC level of +5 dBm, well within the range of the ALC modulator.

To achieve the optimum ALC level at the signal generator RF output of -40 
dBm for an unmodulated carrier, follow these steps:

1. Press Amplitude > Set Atten > 45 > dB.

2. Press Set ALC Level > 5 > dBm. 

This sets the attenuator to 45 dB and the ALC level to +5 dBm, resulting in an 
RF output amplitude of –40 dBm, as shown in the AMPLITUDE area of the 
display.

To obtain flatness–corrected power, refer to “Creating and Applying User 
Flatness Correction” on page 166.

To Level with a mm–Wave Source Module

Millimeter–wave source module leveling is similar to external detector leveling. 
The power level feedback signal to the ALC circuitry is taken from the 
millimeter–wave source module, rather than the internal signal generator 
detector. This feedback signal levels the RF output power at the mm–wave 
source module output through the signal generator’s rear panel SOURCE 
MODULE interface connector.

For instructions and setups, see Chapter 12, “ Peripheral Devices”, on page  
289.

In the example above, 55 dB is the preferred attenuation choice, resulting 
in an ALC level of +15 dBm. This provides adequate dynamic range for AM 
or other functions that vary the RF output amplitude.
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Creating and Applying User Flatness Correction
User flatness correction allows the digital adjustment of RF output amplitude 
for up to 1601 frequency points in any frequency or sweep mode. Using an 
Keysight E4416A/17A or E4418B/19B power meter (controlled by the signal 
generator through GPIB) to calibrate the measurement system, a table of 
power level corrections is created for frequencies where power level variations 
or losses occur. These frequencies may be defined in sequential linear steps or 
arbitrarily spaced. 

To allow different correction arrays for different test setups or different 
frequency ranges, you may save individual user flatness correction tables to 
the signal generator’s memory catalog and recall them on demand.

Use the steps in the next sections to create and apply user flatness correction 
to the signal generator’s RF output.

Afterward, use the steps in Recalling and Applying a User Flatness Correction 
Array to recall a user flatness file from the memory catalog and apply it to the 
signal generator’s RF output.
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Creating a User Flatness Correction Array

In this example, you create a user flatness correction array. The flatness 
correction array contains ten frequency correction pairs (amplitude correction 
values for specified frequencies), from 1 to 10 GHz in 1 GHz intervals. 

An Keysight E4416A/17A/18B/19B power meter (controlled by the signal 
generator via GPIB) and E4413A power sensor are used to measure the RF 
output amplitude at the specified correction frequencies and transfer the 
results to the signal generator. The signal generator reads the power level data 
from the power meter, calculates the correction values, and stores the 
correction pairs in a user flatness correction array.

If you do not have the required Keysight power meter, or if your power meter 
does not have a GPIB interface, you can enter correction values manually. 

Required Equipment

— Keysight E4416A/17A or Keysight N1913A/14A power meter
— Keysight E4413A E Series CW power sensor
— GPIB interface cable
— adapters and cables, as required

Configure the Power Meter

1. Select SCPI as the remote language for the power meter.
2. Zero and calibrate the power sensor to the power meter.
3. Enter the appropriate power sensor calibration factors into the power 

meter as appropriate.
4. Enable the power meter’s cal factor array.

Connect the Equipment

Connect the equipment as shown in Figure 4-4.

If the setup has an external leveling configuration, the equipment setup in 
Figure 4-4 assumes that the steps necessary to correctly level the RF 
output have been followed. If you have questions about external leveling, 
refer to “Using External Leveling” on page 161.

For operating information on a particular power meter/sensor, refer to its 
operating guide.

During the process of creating the user flatness correction array, the power 
meter is secondary to the signal generator via GPIB. No other controllers 
are allowed on the GPIB interface.
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Figure 4-4 User Flatness Correction Equipment Setup

Configure the Signal Generator

1. Press Preset.

2. Configure the signal generator to interface with the power meter.

a. Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > 
Power Meter > E4416A, E4417A, E4418B, or E4419B.

b. Press Meter Address > enter the power meter’s GPIB address > 
Enter.

c. For E4417A and E4419B models, press Meter Channel A B to select 
the power meter’s active channel.

d. Press Meter Timeout to adjust the length of time before the 
instrument generates a timeout error if unsuccessfully attempting to 
communicate with the power meter.

3. Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > 
Confirm Preset.

This opens the User Flatness table editor and presets the cal array 
frequency/correction list.

4. Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

5. Press Freq Start > 1 > GHz.

6. Press Freq Stop > 10 > GHz.
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7. Press # of Points > 10 > Enter.

Steps 4, 5, and 6 enter the desired flatness–corrected frequencies into the 
step array.

8. Press Return > Load Cal Array From Step Array > Confirm Load From Step 
Data.

This populates the user flatness correction array with the frequency 
settings defined in the step array.

9. Press Amplitude > More (1 of 2) > Ampl Offset.

Enter a nominal (average) value for the gain or loss of any cables or other 
devices connected between the signal generator’s RF output and the 
power sensor. Refer to figure Figure 4-4. Gain is entered as a positive 
number while loss is entered as a negative number. 

10.Press RF On/Off.

This activates the RF output and the RF ON annunciator is displayed on 
the signal generator.

Perform the User Flatness Correction 

1. Press More (1 of 2) > User Flatness > Do Cal.

Pressing the Do Cal softkey causes the signal generator to perform the 
user flatness correction routine. A progress bar is shown on the front panel 
display as the routine runs. The routine generates a table of correction 
points with each correction point consisting of a frequency and amplitude 
correction value for that frequency. The correction value at each point is 
the difference between the power level, as measured by the power meter, 
and the output power of the signal generator. 

2. Press Done.

Pressing the Done softkey loads the amplitude correction values into the 
user flatness correction array.

If desired, press Configure Cal Array.

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if 
your power meter does not have a GPIB interface, you can perform the 
user flatness correction manually. For instructions, see “Performing the 
User Flatness Correction Manually” on page 170.

A power meter timeout may occur at low power levels. If a power meter 
timeout error message appears, increase the timeout value by pressing 
Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > Meter 
Timeout.
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This opens the user flatness correction array, where you can view the 
stored amplitude correction values. The user flatness correction array title 
displays User Flatness: (UNSTORED) indicating that the current user 
flatness correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your 
power meter does not have a GPIB interface, complete the steps in this section 
and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the 
frequency value 
(1 GHz) for row 1. The RF output changes to the frequency value of the 
table row containing the cursor and 1.000 000 000 00 is displayed in 
the AMPLITUDE area of the display. 

2. Observe and record the measured value from the power meter.

3. Subtract the measured value from 0 dBm.

4. Move the table cursor over the correction value in row 1.

5. Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the 
correction value entered.

6. Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Use the down arrow key to place the cursor over the frequency value 
for the next row. The RF output changes to the frequency value of the 
table row containing the cursor, as shown in the AMPLITUDE area of the 
display. 

8. Repeat steps 2 through 7 for every entry in the User Flatness table.

Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as in the 
signal generator’s memory catalog. With several user flatness correction files 
saved to the memory catalog, any file can be recalled, loaded into the 
correction array, and applied to the RF output to satisfy specific RF output 
flatness requirements.

1. Press Load/Store.

2. Press Store to File.

3. Enter the file name FLATCAL1 using the alphanumeric softkeys, numeric 
keypad, or the knob.

4. Press Enter.
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The user flatness correction array file FLATCAL1 is now stored in the memory 
catalog as a UFLT file.

Applying a User Flatness Correction Array

Press Return > Return > Flatness Off On to On.

This applies the user flatness correction array to the RF output. The UF 
indicator is activated in the AMPLITUDE section of the signal generator’s 
display and the frequency correction data contained in the correction array is 
applied to the RF output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete “Creating a User 
Flatness Correction Array” on page 167.

1. Press Preset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > 
More (1 of 2) > Preset List > Confirm Preset.

3. Press More (2 of 2) > Load/Store.

4. Ensure that the file FLATCAL1 is highlighted.

5. Press Load From Selected File > Confirm Load From File.

This populates the user flatness correction array with the data contained 
in the file FLATCAL1. The user flatness correction array title displays User 
Flatness: FLATCAL1.

6. Press Return > Flatness Off On to On.

This applies the user flatness correction data contained in FLATCAL1.

Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is secondary to 
the signal generator via GPIB, and no other controllers are allowed on the GPIB 
interface. The signal generator operates in GPIB talker mode, as a device 
controller for the power meter. In this operating mode, it cannot receive SCPI 
commands via GPIB.

If the signal generator is to be interfaced to a remote controller after 
performing the user flatness correction, its GPIB controller mode must be 
changed from GPIB talker to GPIB listener.

If an RF carrier has been previously configured, you must save the present 
instrument state before returning the signal generator to GPIB listener mode.

1. Save your instrument state to the instrument state register.

For instructions, see “Saving an Instrument State” on page 87.

2. Press Amplitude > More (1 of 2) > User Flatness > GPIB Listener Mode.
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This presets the signal generator and returns it to GPIB listener mode. The 
signal generator can now receive remote commands executed by a remote 
controller connected to the GPIB interface.

3. Recall your instrument state from the instrument state register.

For instructions, see “Saving an Instrument State” on page 87.
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Creating a User Flatness Correction Array with a mm–Wave Source 
Module

In this example, a user flatness correction array is created to provide 
flatness–corrected power at the output of an Keysight 83554A 
millimeter–wave source module driven by an E8257D. 

The flatness correction array contains 28 frequency correction pairs (amplitude 
correction values for specified frequencies), from 26.5 to 40 GHz in 500 MHz 
intervals. This will result in 28 evenly spaced flatness corrected frequencies 
between 26.5 GHz and 40 GHz at the output of the 83554A millimeter–wave 
source module.

An Keysight E4416A/17A/18B/19B power meter (controlled by the signal 
generator via GPIB) and R8486A power sensor are used to measure the RF 
output amplitude of the millimeter–wave source module at the specified 
correction frequencies and transfer the results to the signal generator. The 
signal generator reads the power level data from the power meter, calculates 
the correction values, and stores the correction pairs in the user flatness 
correction array.

If you do not have the required Keysight power meter, or if your power meter 
does not have a GPIB interface, you can enter correction values manually. 

Required Equipment

— Keysight 83554A millimeter–wave source module

— Keysight E4416A/17A/18B/19B power meter

— Keysight R8486A power sensor

— Keysight 8349B microwave amplifier (required for signal generators without 
Options 1EA, 1EU, or 521)

— GPIB interface cable

— adapters and cables as required

Option 521 signal generators can damage MM source modules. Consult 
the MM source module’s operating manual for input damage levels.

User Flatness correction is only applicable for Keysight 83550 series 
mm–wave source modules and does not function with other mm–wave 
modules such as OML modules.

The equipment setups in Figure 4-5 and Figure 4-6 assume that the steps 
necessary to correctly level the RF output have been followed. If you have 
questions about leveling with a millimeter–wave source module, refer to 
“To Level with a mm–Wave Source Module” on page 165.
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Configure the Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter.

3. Enter the appropriate power sensor calibration factors into the power 
meter as appropriate.

4. Enable the power meter’s cal factor array.

Connect the Equipment

1. Turn off the line power to the signal generator.

2. Connect the equipment. For standard signal generators, use the setup in 
Figure 4-5. For signal generators with Options 1EA, 1EU, or 521, use 
Figure 4-6.

For operating information on your particular power meter/sensor, refer to 
their operating guides.

To prevent damage to the signal generator, turn off the line power to the 
signal generator before connecting the source module interface cable to 
the rear panel SOURCE MODULE interface connector.

Option 521 signal generators can damage MM source modules. Consult 
the MM source module’s operating manual for input damage levels.

During the process of creating the user flatness correction array, the power 
meter is secondary to the signal generator via GPIB. No other controllers 
are allowed on the GPIB interface.
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Figure 4-5 User Flatness with mm–Wave Source Module for 
a Signal Generator without Options 1EA, 1EU, or 521
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Figure 4-6 User Flatness with mm–Wave Source Module for Signal Generators with 
Options 1EA, 1EU, or 521

Configure the Signal Generator

1. Turn on the signal generator’s line power. At power–up, the signal 
generator automatically does the following:

— senses the mm–wave source module
— switches the signal generator’s leveling mode to external/source 

module
— sets the mm–wave source module frequency and amplitude to the 

source module’s preset values
— displays the RF output frequency and amplitude available at the 

mm–wave source module output

The MMMOD indicator in the FREQUENCY area and the MM indicator in the 
AMPLITUDE area of the signal generator’s display indicate that the 
mm–wave source module is active

Option 521 signal generators can damage MM source modules. Consult 
the MM source module’s operating manual for input damage levels.

To ensure adequate RF amplitude at the mm–wave source module RF 
input when using Options 1EA, 1EU, or 521 signal generators, maximum 
amplitude loss through the adapters and cables connected between the 
signal generator’s RF output and the mm–wave source module’s RF input 
should be less than 1.5 dB.

For specific frequency/amplitude ranges, see the mm–wave source 
module specifications.
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2. Configure the signal generator to interface with the power meter.

a. Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > 
Power Meter > E4416A, E4417A, E4418B, or E4419B.

b. Press Meter Address > enter the power meter’s GPIB address > 
Enter.

c. For E4417A and E4419B models, press Meter Channel A B to select 
the power meter’s active channel.

d. Press Meter Timeout to adjust the length of time before the 
instrument generates a timeout error if unsuccessfully attempting to 
communicate with the power meter.

3. Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > 
Confirm Preset.

This opens the User Flatness table editor and resets the cal array 
frequency/correction list.

4. Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

5. Press Freq Start > 26.5 > GHz.

6. Press Freq Stop > 40 > GHz.

7. Press # of Points > 28 > Enter.

This enters the desired flatness–corrected frequencies (26.5 GHz to 40 
GHz in 500 MHz intervals) into the step array.

8. Press Return > Load Cal Array From Step Array > Confirm Load From Step 
Data.

This populates the user flatness correction array with the frequency 
settings defined in the step array.

9. Press Amplitude > 0 > dBm.

10.Press RF On/Off.

This activates the RF output and the RF ON annunciator is displayed on 
the signal generator.

Perform the User Flatness Correction 

1. Press More (1 of 2) > User Flatness > Do Cal.

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if 
your power meter does not have a GPIB interface, you can perform the 
user flatness correction manually. For instructions, see Performing the User 
Flatness Correction Manually below.
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This creates the user flatness amplitude correction value table entries. The 
signal generator begins the user flatness correction routine and a progress 
bar is shown on the display.

2. When prompted, press Done.

This loads the amplitude correction values into the user flatness 
correction array.

If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the list 
of defined frequencies and their calculated amplitude correction values. 
The user flatness correction array title displays User Flatness: 
(UNSTORED) indicating that the current user flatness correction array data 
has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Keysight E4416A/17A/18B/19B power meter, or if your 
power meter does not have a GPIB interface, complete the steps in this section 
and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the 
frequency value (26.5 GHz) for row 1. The RF output changes to the 
frequency value of the table row containing the cursor and 26.500 000 
000 00 is displayed in the AMPLITUDE area of the display. 

2. Observe and record the measured value from the power meter.

3. Subtract the measured value from 0 dBm.

4. Move the table cursor over the correction value in row 1.

5. Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the 
correction value entered.

6. Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Use the down arrow key to place the cursor over the frequency value for 
the next row. The RF output changes to the frequency value highlighted by 
the cursor, as shown in the AMPLITUDE area of the display.

8. Repeat steps 2 through 7 for each entry in the User Flatness table.

Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as a file in the 
signal generator’s memory catalog. With several user flatness correction files 
saved to the memory catalog, specific files can be recalled, loaded into the 
correction array, and applied to the RF output to satisfy various RF output 
flatness requirements.
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1. Press Load/Store.

2. Press Store to File.

3. Enter the file name FLATCAL2 using the alphanumeric softkeys and the 
numeric keypad.

4. Press Enter.

The user flatness correction array file FLATCAL2 is now stored in the memory 
catalog as a UFLT file.

Applying the User Flatness Correction Array

1. Press Return > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF 
indicator is activated in the AMPLITUDE section of the signal generator’s 
display and the frequency correction data contained in the correction 
array is applied to the RF output amplitude of the mm–wave source 
module.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete the section “Creating a 
User Flatness Correction Array with a mm–Wave Source Module” on 
page 173.

1. Press Preset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > 
More (1 of 2) > Preset List > Confirm Preset.

3. Press More (2 of 2) > Load/Store.

4. Ensure that the file FLATCAL2 is highlighted.

5. Press Load From Selected File > Confirm Load From File.

This populates the user flatness correction array with the data contained 
in the file FLATCAL2. The user flatness correction array title displays User 
Flatness: FLATCAL2.
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6. Press Return > Flatness Off On.

This activates flatness correction using the data contained in the file 
FLATCAL2.
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Using the Option 521 Detector Calibration (Option 521)

The purpose of this calibration is to improve the 500 MHz frequency transition 
to compensate for changes in temperature. The 500 MHz frequency transition 
can degrade as the temperature changes. By using the detector calibration, 
when the instrument temperature change occurs, the PSG’s flatness 
performance can be optimized. Refer to the Data Sheet.

Running the Option 521 Detector Calibration

Following the following steps to run the Detector calibration:

— Press Amplitude > More > More > Option 521 Detector Calibration > 
Execute

Restoring the Factory Flatness Calibration

The instrument’s original factory calibration settings can be restored by the 
following steps:

— Press Utility > Power On/Preset > Restore System Defaults

Using the Option 521 Detector Calibration softkey changes the factory 
calibration. Avoid using this feature unless following a service center’s 
recommendations.

This calibration should be done whenever the instrument temperature 
changes beyond specified parameters or and when greater amplitude 
flatness is required around the 500 MHz frequency transition. Refer to the 
Data Sheet.

If the Option 521 Detector Calibration is inadvertently used, the PSG has 
the ability to recall the factory amplitude flatness calibration. Refer to 
“Restoring the Factory Flatness Calibration”.
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Adjusting Reference Oscillator Bandwidth (Option UNR/UNX/UNY)
The reference oscillator bandwidth (sometimes referred to as loop bandwidth) 
in signal generators with Option UNR/UNX/UNY (improved close–in phase 
noise <1 kHz) is adjustable in fixed steps for either an internal or external 
10 MHz frequency reference. The reference oscillator bandwidth can be set to 
25, 55, 125, 300, or 650 Hz; models without Option UNR/UNX/UNY have a 
fixed reference oscillator bandwidth.

At frequency offsets below approximately 1 kHz, the stability and phase noise 
are determined by the internal or external frequency reference. At frequency 
offsets above 1 kHz, stability and phase noise are determined by the 
synthesizer hardware.

To optimize the overall phase noise of the signal generator for your particular 
application, make this adjustment depending on your confidence in the 
stability and phase noise of the external or internal reference versus the 
synthesizer hardware for various frequency offsets from the carrier. 

To Select the Reference Oscillator Bandwidth

When using the internal bandwidth reference:

1. Press Utility > Instrument Adjustments > Reference Oscillator 
Adjustment > Internal Ref Bandwidth.

2. Select the desired bandwidth.

When using an external bandwidth reference:

1. Press Utility > Instrument Adjustments > Reference Oscillator 
Adjustment > External Ref Bandwidth.

2. Select the desired bandwidth.

To Restore Factory Default Settings:

Internal Bandwidth: 125 Hz
External Bandwidth: 25 Hz (Option UNR), 650 Hz (Option UNX/UNY)

Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > 
Restore Factory Defaults.
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Optimizing Phase Noise and Harmonics Below 3.2 GHz (Option 
UNX/UNY)

Included with the Ultra-Low Phase Noise (Option UNX/UNY), is the ability to 
improve both phase noise and harmonic performance below 3.2 GHz. Refer to 
the PSG’s Data Sheet.

This section contains the following topics:

— “Optimizing Phase Noise Below 250 MHz (E8257D and E8663D with 
Option UNX or UNY, and serial prefix > xx4928 and higher)” on page 184

— “Optimizing Harmonics Below 2 GHz” on page 185

— “Wideband IQ/FM Mode <3.2 GHz (Option 018)” on page 186
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Optimizing Phase Noise Below 250 MHz (E8257D and E8663D with 
Option UNX or UNY, and serial prefix > xx4928 and higher)

This feature is available on instruments with Option UNX or Option UNY, and 
serial number prefix 

> xx4928 and higher.

The PSG’s low band phase noise can be improved below 250 MHz by using the 
Low Phase Noise Below 250 MHz softkey. Refer to the PSG’s Data Sheet. See 
also “Optimizing Harmonics Below 2 GHz” on page 185.

Figure 4-7 Low Band Phase Noise Below 250 MHz

Maximum available power below 3.2 GHz is lower when the Optimizing 
Phase Noise Below 250 MHz softkey is been pressed. Refer to the PSG’s 
Data Sheet

Frequency > More > More > RF Path

For SCPI commands, refer to the SCPI Command Reference.

When the 
Low Phase 
Noise 
Below 250 
MHz 
softkey has 
been 
pressed, the 
Frequency 
Status 
Information 
displays the 
setting in 
the RF Path 
annunciator
.

Enables 
improved 
phase noise 
below 
250 MHz.

Caution: 
Enabling 
this feature 
may 
degrade 
power below 
3.2 GHz.
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Optimizing Harmonics Below 2 GHz

The PSG’s harmonic performance can be improved below 3.2 GHz by using the 
Low Pass Filter Below 2 GHz softkey. Refer to the PSG’s Data Sheet. See also 
“Optimizing Phase Noise Below 250 MHz (E8257D and E8663D with Option 
UNX or UNY, and serial prefix > xx4928 and higher)” on page 184.

Figure 4-8 Low Band Phase Noise Below 2 GHz

Maximum available power below 3.2 GHz, is lower when the Low Pass 
Filter Below 2 GHz softkey is been pressed. Refer to the PSG’s Data Sheet.

Frequency > More > More 

For SCPI commands, refer to the SCPI Command Reference.

When the 
Low Pass 
Filter Below 
2 GHz 
softkey has 
been 
pressed, the 
Frequency 
Status 
Information 
displays the 
setting.

Enables a 
low pass 
filter that 
improves 
harmonics 
below 2 
GHz.

Caution: 
Enabling 
this feature 
may 
degrade 
power below 
3.2 GHz.
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Wideband IQ/FM Mode <3.2 GHz (Option 018)
Wideband IQ/FM mode (Option 018) provides the following features for 
frequencies <3.2 GHz: 

— Wideband I/Q bandwidth

— Improved IQ frequency response (with an internal BBG)

— Wider FM and Phase-modulation deviation

External differential inputs, on the rear panel (Wide I and Wide Q) are provided 
for direct access to the microwave I/Q modulator. 

To enable the wideband I/Q inputs refer to Figure 4-9.

Figure 4-9 Wideband IQ/FM Softkey Menu
Frequency > More > More > RF Path

This softkey selects the 
downconverted RF path 
below 3.2 GHz. When this 
path is active, the low 
band frequencies are 
generated by a 
downconverter. This 
enables very wide I/Q 
and FM performance.

This message is displayed when the Wideband IQ/FM softkey has been pressed.
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5 Analog Modulation

In the following sections, this chapter describes the standard continuous 
waveform and optional analog modulation capability in the Keysight E8257D 
PSG Analog, E8663D, Analog, and E8267D PSG Vector signal generators.

— “Analog Modulation Waveforms” on page 188

— “Configuring AM (Option UNT)” on page 189

— “Configuring FM (Option UNT)” on page 190

— “Configuring ΦM (Option UNT)” on page 191

— “Configuring Pulse Modulation (Option UNU/UNW)” on page 192

— “Configuring the LF Output (Option UNT)” on page 195
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Analog Modulation Waveforms
Available standard internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Dual–Sine  dual–sine waves with individually adjustable 
frequencies and a percent–of– peak–amplitude setting 
for the second tone (available from function generator 
only)

Swept–Sine  swept–sine wave with adjustable start and stop 
frequencies, sweep rate, and sweep trigger settings 
(available from function generator only)

Triangle  triangle wave with adjustable amplitude and frequency

Ramp  ramp with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Noise  noise with adjustable amplitude generated as a 
peak–to–peak value (RMS value is approximately 80% 
of the displayed value)

With Option UNT, the signal generator can modulate the RF carrier with 
amplitude, frequency, or phase modulation. Option UNT also provides 
low–frequency output capability. 

With Option UNU, the signal generator can modulate the RF carrier with 
standard pulse modulation (150 ns minimum pulse width).

With Option UNW, the signal generator can modulate the RF carrier with 
narrow pulse modulation. 
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Configuring AM (Option UNT)
In this example, you will learn how to generate an amplitude–modulated RF 
carrier. 

To Set the Carrier Frequency

1. Press Preset.

2. Press Frequency > 1340 > kHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the AM Depth and Rate

1. Press the AM hardkey.

2. Press AM Depth > 90 > %.

3. Press AM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, 
amplitude–modulated carrier at 1340 kHz with the AM depth set to 90% and 
the AM rate set to 10 kHz. The shape of the waveform is a sine wave. Notice 
that sine is the default selection for the AM Waveform softkey, which can be 
viewed by pressing (More 1 of 2).

To Turn on Amplitude Modulation

Follow these remaining steps to output the amplitude–modulated signal.

1. Press the AM Off On softkey to On.

2. Press the front panel RF On Off key.

The AM and RF ON annunciators are now displayed. This indicates that you 
have enabled amplitude modulation and the signal is now being transmitted 
from the RF OUTPUT connector.
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Configuring FM (Option UNT)
In this example, you will learn how to create a frequency–modulated RF carrier. 
For a E8267D with Option 018, see also “Wideband IQ/FM Mode <3.2 GHz 
(Option 018)” on page 186.

To Set the RF Output Frequency

1. Press Preset.

2. Press Frequency > 1 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the FM Deviation and Rate

1. Press the FM/ΦM hardkey.

2. Press FM Dev > 75 > kHz.

3. Press FM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, 
frequency–modulated carrier at 1 GHz with a 75 kHz deviation and a 10 kHz 
rate. The shape of the waveform is a sine wave. (Notice that sine is the default 
for the FM Waveform softkey. Press More (1 of 2) to see the softkey.) 

To Activate FM

1. Press FM Off On to On.

2. Press RF On/Off.

The FM and RF ON annunciators are now displayed. This indicates that you 
have enabled frequency modulation and the signal is now being transmitted 
from the RF OUTPUT connector.

DC Offset and External FM

Applying a DC offset to an external FM signal will shift the frequency of the FM 
signal above or below the carrier frequency, depending on the polarity of the 
DC level. The amount frequency shift is directly related to the amplitude of the 
DC level. A DC offset of +1.0 volt or greater will shift the external FM frequency 
by an amount equal to the maximum deviation setting. For example, if the 
signal generator CW frequency is 1 GHz and the maximum deviation setting is 
set to 100 kHz, an external DC–coupled signal with a +1.0 volt DC level used 
as the modulating source will center the FM signal at 1 GHz + 100 kHz. 
Keeping the same setup and settings and changing the DC level to +0.5 volts 
will center the FM signal at 1 GHz + 50 kHz. 
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Configuring ΦM (Option UNT)
In this example, you will learn how to create a phase–modulated RF carrier. For 
a E8267D with Option 018, see also “Wideband IQ/FM Mode <3.2 GHz (Option 
018)” on page 186.

To Set the RF Output Frequency

1. Press Preset.

2. Press Frequency > 3 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the FM Deviation and Rate

1. Press the FM/ΦM hardkey.

2. Press the FM ΦM softkey.

3. Press ΦM Dev > .25 > pi rad. 

4. Press ΦM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, phase–modulated 
carrier at 3 GHz with a 0.25 p radian deviation and 10 kHz rate. The shape of 
the waveform is a sine wave. (Notice that sine is the default for the 
ΦM Waveform softkey. Press More (1 of 2) to see the softkey.) 

To Activate FM

1. Press ΦM Off On.

2. Press RF On/Off.

The ΦM and RF ON annunciators are now displayed. This indicates that you 
have enabled phase modulation and the signal is now being transmitted from 
the RF OUTPUT connector.
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Configuring Pulse Modulation (Option UNU/UNW)
In this example, you will learn how to create a gated, pulse–modulated RF 
carrier with an external trigger. 

To Set the RF Output Frequency

1. Press Preset.

2. Press Frequency > 2 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the Pulse Period, Width, and Triggering

1. Press Pulse > Pulse Period > 100 > usec.

2. Press Pulse > Pulse Width > 24 > usec.

3. Press Pulse > Pulse Source > Int Gated.

4. Connect a TTL signal to the Trigger In connector on the rear panel of the 
signal generator. To configure the trigger signal polarity, Press Utility > 
Instrument Adjustments > Signal Polarity Setup > Trigger In Polarity.

The signal generator is now configured to output a 0 dBm, pulse–modulated 
carrier at 2 GHz with a 100-microsecond pulse period and 24-microsecond 
pulse width. The pulse source is set to internal gated. (Notice that Internal Free 
Run is the default for the Pulse Source softkey.) 

To Activate Pulse Modulation

Follow these remaining steps to output the pulse–modulated signal.

1. Press Pulse Off On to On.

2. Press RF On/Off.

The Pulse and RF ON annunciators are now displayed. This indicates that you 
have enabled pulse modulation and the signal is now being transmitted from 
the RF OUTPUT connector. The TTL trigger signal state will control pulse 
modulation output.

Triggering Simultaneous Pulses from Two PSGs Using an Internal or 
an External Pulse Source

Two PSG pulse generators can be triggered simultaneously using the PSG 
internal pulse generator or using an external pulse source. The pulse from 
PSG1 is triggered internally or by the external pulse generator and the pulse 
from PSG2 is triggered using the SYNC OUT signal from PSG1. Each PSG can 
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be set to different pulse widths, pulse repetition intervals (PRI), and RF output 
frequencies. Refer to “Configuring FM (Option UNT)” on page 190 and to 
“Configuring Pulse Modulation (Option UNU/UNW)” on page 192.

1. Ensure the two PSGs should have the same "Analog Mod Gen" PC board 
part numbers installed (i.e. E8251-60306) and board software code 
version (i.e. A0100). 

You can view this information by selecting the Utility hardkey, then 
selecting the Instrument Info/Help Mode and the Installed Board Info 
softkeys on each PSG.

2. Set PSG1 to its RF output frequency (f1) and PSG2 to its frequency (f2).

3. Connect the two PSGs as shown in Figure 5-1 on page 194. For 
connection details, refer to Table 5-1.

Figure 5-1 Setup Diagram for Triggering Simultaneous Pulses Using Two PSGs

4.  If you are using: 

The cables should be as short as possible.

Table 5-1 PSG Connectivity for Simultaneous Pulse Configuration

From (PSG1)a: To (PSG2):

10 MHz OUT 10 MHz IN

SYNC OUT GATE/PULSE/TRIGGER INPUT

a. If an external pulse source is being used as the 
pulse trigger, connect the pulse source’s pulse 
output connector to the PSG1 
GATE/PULSE/TRIGGER INPUT.
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— An external pulse source as the pulse trigger: 
Set the trigger mode to Internal Trigger for both PSGs by selecting the 
Pulse hardkey, and then selecting the Pulse Source and Internal Triggered 
on PSG 1 and PSG2. 

— PSG1 as the internal pulse source: 

a. Set PSG1 trigger modes to Free Run by selecting the Pulse hardkey, 
then selecting the Pulse Source and Int Free-Run softkeys.

b. Set PSG 2 trigger to the Internal Trigger mode by selecting the Pulse 
hardkey, then selecting the Pulse Source and Internal Triggered 
softkeys.

3. You can adjust the relative timing of the PSG pulses using the Pulse Delay 
softkey on each PSG. 
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Configuring the LF Output (Option UNT)
With Option UNT, the signal generator has a low frequency (LF) output 
(described on page 30). The LF output’s source can be switched between 
Internal 1 Monitor, Internal 2 Monitor, Function Generator 1, or Function 
Generator 2.

Using Internal 1 Monitor or Internal 2 Monitor as the LF output source, the LF 
output provides a replica of the signal from the internal source that is being 
used to modulate the RF output. The specific modulation parameters for this 
signal are configured through the AM, FM, or FM menus.

Using Function Generator 1 or Function Generator 2 as the LF output source, 
the function generator section of the internal modulation source drives the LF 
output directly. Frequency and waveform are configured from the LF output 
menu, not through the AM, FM, or FM menus. You can select the waveform 
shape from the following choices:

Sine  sine wave with adjustable amplitude and frequency

Dual–Sine  dual–sine waves with individually adjustable 
frequencies and a percent–of– peak–amplitude setting 
for the second tone (available from function generator 1 
only)

Swept–Sine  a swept–sine wave with adjustable start and stop 
frequencies, sweep rate, and sweep trigger settings 
(available from function generator 1 only)

Triangle  triangle wave with adjustable amplitude and frequency

Ramp  ramp with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Noise  noise with adjustable amplitude generated as a 
peak–to–peak value (RMS value is approximately 80% 
of the displayed value)

DC  direct current with adjustable amplitude

The LF Out Off On softkey controls the operating state of the LF output. 
However, when the LF output source selection is Internal Monitor, you 
have three ways of controlling the output. You can use the modulation 
source (AM, FM, or FM) on/off key, the LF output on/off key, or the Mod 
On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.
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To Configure the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source.

Configuring the Internal Modulation as the LF Output Source

1. Press Preset.

2. Press the FM/ΦM hardkey.

3. Press FM Dev > 75 > kHz.

4. Press FM Rate > 10 > kHz. 

5. Press FM Off On. 

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. 
The FM annunciator is activated indicating that you have enabled frequency 
modulation.

Configuring the Low Frequency Output

1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > Vp. 

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave 
form) output which is frequency modulated using the Internal 1 Monitor 
source selection (default source).

To Configure the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source

1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Out Source > Function Generator 1.

Configuring the Waveform

1. Press LF Out Waveform > Swept–Sine.

2. Press LF Out Start Freq > 100 > Hz.

3. Press LF Out Stop Freq > 1 > kHz.

4. Press Return > Return.

Internal modulation (Internal Monitor) is the default LF output source.
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This returns you to the top LF Output menu. 

Configuring the Low Frequency Output

1. Press LF Out Amplitude > 3 > Vp.

This sets the LF output amplitude to 3 Vp.

2. Press LF Out Off On.

The LF output is now transmitting a signal using Function Generator 1 that is 
providing a
3 Vp swept–sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.
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6 Custom Arb Waveform Generator

In the following sections, this chapter describes the custom arbitrary waveform 
generator mode, which is available only in E8267D PSG vector signal 
generators with Option 601 or 602:

— “Overview” on page  200

— “Working with Predefined Setups (Modes)” on page  201

— “Working with Filters” on page  205

— “Working with Symbol Rates” on page  213

— “Working with Modulation Types” on page  215

— “Configuring Hardware” on page  224

See also: Chapter 3, “Basic Digital Operation”, on page  103
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Overview
Custom Arb Waveform Generator mode can produce a single modulated 
carrier or multiple modulated carriers. Each modulated carrier waveform must 
be calculated and generated before it can be output; this signal generation 
occurs on the internal baseband generator (Option 601 or 602). Once a 
waveform has been created, it can be stored and recalled which enables 
repeatable playback of test signals.

To begin using the Custom Arb Waveform Generator mode, select whether to 
create a single modulated carrier or a multiple modulated carrier waveform:

— If you want to create a single modulated carrier waveform, start by selecting 
a Digital Modulation Setup from a set of predefined modes (setups). Once a 
predefined mode is selected, you can modify the Modulation Type, the Filter 
being used, the Symbol Rate, and the type of Triggering; the Data Pattern is 
random by default. This modified setup can then be stored and reused.

— If you want to create a multiple modulated carrier waveform, start by 
selecting a Multicarrier Setup from a set of predefined modes (setups). 
Once a predefined mode is selected, you can modify the number of carriers 
to be created, the frequency spacing between each carrier, whether the 
phase offset between each carrier is to be fixed or random, and the type of 
Triggering; the Data Pattern is random by default, the Filter is set to 
40 MHz by default, and the Symbol Rate is automatically specified by the 
selected Modulation Type being used.
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Working with Predefined Setups (Modes)
When you select a predefined mode, default values for components of the 
setup (including the filter, symbol rate, and modulation type) are automatically 
specified.

Selecting a Custom ARB Setup or a Custom Digital Modulation State

1. Preset the signal generator: press Preset.

2. Press Mode > Custom > Arb Waveform Generator > Setup Select.

3. Select either:

— one of the predefined modulation setups: NADC, PDC, PHS, GSM, 
DECT, EDGE, APCO 25 w/C4FM, APCO 25 w/CQPSK, CDPD, PWT, 
or TETRA

This selects a predefined setup where filtering, symbol rate, and 
modulation type are defined by the predefined modulation setup 
(mode) that you selected and returns you to the top–level custom 
modulation menu; it does not include bursting or channel coding.

or

— Custom Digital Mod State

This selects a custom setup stored in the Catalog of DMOD 
Files. (For information on creating a custom digital modulation 
setup, refer to “Working with User–Defined Setups (Modes)-Custom 
Arb Only” on page 202).
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Working with User–Defined Setups (Modes)-Custom Arb Only

Modifying a Single–Carrier NADC Setup

In this procedure, you learn how to start with a single–carrier NADC digital 
modulation and modify it to a custom waveform with customized modulation 
type, symbol rate, and filtering.

1. Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Setup Select > 
NADC.

3. Press Digital Mod Define > Modulation Type > PSK > QPSK and OQPSK > 
QPSK.

4. Press Symbol Rate > 56 > ksps.

5. Press Filter > Select > Nyquist.

6. Press Return > Return > Digital Modulation Off On.

This generates a waveform with the custom single–carrier NADC digital 
modulation state. The display changes to Dig Mod Setup: NADC 
(Modified). During waveform generation, the DIGMOD and I/Q 
annunciators appear and the custom single–carrier digital modulation 
state is stored in volatile memory.

7. Set the RF output frequency to 835 MHz. 

8. Set the output amplitude to 0 dBm. 

9. Press RF On/Off.

The user–defined NADC signal is now available at the RF OUTPUT 
connector.

10.Press Return > Return.

This returns to the top–level Digital Modulation menu, where Digital 
Modulation Off On is the first softkey.

11.Press Digital Mod Define > Store Custom Dig Mod State > Store To File.

If there is already a file name from the Catalog of DMOD Files 
occupying the active entry area, press: Edit Keys > Clear Text

12.Enter a file name (for example, NADCQPSK) using the alpha keys and the 
numeric keypad.

13.Press Enter.

The user–defined single–carrier digital modulation state should now be 
stored in non–volatile memory. The RF output amplitude, frequency, and 
operating state settings are not stored as part of a user–defined digital 
modulation state file.
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Customizing a Multicarrier Setup

In this procedure, you learn how to customize a predefined multicarrier digital 
modulation setup by creating a custom 3–carrier EDGE digital modulation 
state.

1. Press Preset.

2. Press Mode > Custom > Arb Waveform Generator > Multicarrier Off On.

3. Press Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done.

4. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2, 
and 
press Edit Item > -625 > kHz.

5. Highlight the Power value (0.00 dB) for the carrier in row 2, and press 
Edit Item > -10 > dB.

You have a custom 2–carrier EDGE waveform with a carrier at a frequency 
offset of -625 kHz and a power level of -10.00 dBm.

6. Press Return > Digital Modulation Off On.

This generates a waveform with the custom multicarrier EDGE state. The 
display changes to Dig Mod Setup: Multicarrier (Modified). 
During waveform generation, the DIGMOD and I/Q annunciators appear 
and the new custom multicarrier EDGE state is stored in volatile memory.

7.  Set the RF output frequency to 890.01 MHz. 

8. Set the output amplitude to -10 dBm. 

9. Press RF On/Off.

The custom multicarrier EDGE waveform is available at the RF OUTPUT 
connector; it does not include bursting or channel coding.

10.Press Mode > Custom > Arb Waveform Generator, where Digital 
Modulation Off On is the first softkey.

11.Press Multicarrier Off On > Multicarrier Define > More (1 of 2) > Load/ 
Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files 
occupying the active entry area, press Edit Keys > Clear Text.
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12.Enter a file name (for example, EDGEM1) using the alpha keys and the 
numeric keypad, and press Enter.

The user–defined multicarrier digital modulation state is now stored in 
non–volatile memory.

Recalling a User–Defined Custom Digital Modulation State

In this procedure, you learn how to select (recall) a previously stored custom 
digital modulation state from the Memory Catalog (the 
Catalog of DMOD Files).

1. Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Setup Select.

3. Press More (1 of 2) > Custom Digital Mod State.

4. Press Select File to select a custom modulation state from the Catalog 
of DMOD Files.

The user–defined custom digital modulation state should now be recalled 
from non–volatile memory. Because the RF output amplitude, frequency, 
and operating state settings are not stored as part of a user–defined 
digital modulation state file, they must still be set or recalled separately. 
For more information, refer to “Using Data Storage Functions” on page  85.

The RF output amplitude, frequency, and operating state settings (such as RF On/Off ) are not stored as part 
of a user–defined digital modulation state file. For more information, refer to “Using Data Storage 
Functions” on page  85.
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Working with Filters
This section provides information on using predefined (page 206) and 
user–defined (page 207) FIR filters.

The Filter menu selections enable you to apply a filter to the generated signal, 
define a finite impulse response (FIR) filter, change a Root Nyquist or Nyquist 
filter alpha, change a Gaussian filter BbT, or restore all filter parameters to 
their default state. In Custom Real Time I/Q mode, you can also optimize a FIR 
filter for Error Vector Magnitude (EVM) or Adjacent Channel Power (ACP)

Predefined Filters 
(Filter > Select)

— Root Nyquist is a root–raised cosine pre–modulation FIR filter. Use a Root 
Nyquist filter when you want to place half of the filtering in the transmitter 
and the other half in the receiver. The ideal root–raised cosine filter 
frequency response has unity gain at low frequencies, the square root of 
raised cosine function in the middle, and total attenuation at high 
frequencies. The width of the middle frequencies is defined by the roll off 
factor or Filter Alpha (0 < Filter Alpha < 1).

— Nyquist is a raised cosine pre–modulation FIR filter. You can use a Nyquist 
filter to reduce the bandwidth required by a signal without losing 
information. The ideal raised cosine filter frequency response comprises 
unity gain at low frequencies, a raised cosine function in the middle, and 
total attenuation at high frequencies. The width of the middle frequencies is 
defined by the roll off factor or Filter Alpha (0 < Filter Alpha < 1).

— Gaussian is a Gaussian pre–modulation FIR filter.

— User FIR enables you to select from a Catalog of FIR filters; use this 
selection if the other predefined FIR filters do not meet your needs. For 
more information, see Define User FIR, below.

— Rectangle is a rectangular pre–modulation FIR filter.

— APCO 25 C4FM is an APCO 25–specified C4FM filter; this is a Nyquist filter 
with an alpha of 0.200 that is combined with a shaping filter.

Filter Parameters — Define User FIR is available for when the predefined FIR filters do not meet 
your needs. You can define FIR coefficients and set the oversample ratio 
(number of filter coefficients per symbol) to be applied to a custom FIR 
filter.

— Filter Alpha enables you to adjust the filter alpha for a Nyquist or root 
Nyquist filter. If a Gaussian filter is used, you will see Filter BbT; this softkey 
is grayed out when any other filter is selected.

The procedures in this section apply only to filters created in either the 
Custom Arb Waveform Generator or Custom Real Time I/Q Baseband 
mode; they do not work with downloaded files, such as those created in 
Matlab.
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— (Custom Realtime I/Q Baseband Only) Optimize FIR for EVM ACP enables 
you to optimize a Nyquist or root Nyquist filter for minimized error vector 
magnitude (EVM) or for minimized adjacent channel power (ACP); the 
softkey is grayed out when any other filter is selected.

— Restore Default Filters replaces the current FIR filter with the default 
FIR filter for the selected format.

Using a Predefined FIR Filter

Selecting a Predefined FIR Filter

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 

Filter > Select
or
Mode > Custom > Real Time I/Q Baseband > Filter > Select > 

3. Select the desired filter. If the filter you want is not in the first list, press 
More (1 of 2).

Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist 
Filter

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 

Filter > Filter Alpha
or
Mode > Custom > Real Time I/Q Baseband > Filter > Filter Alpha

3. Enter a new Filter Alpha value and press Enter.

Adjusting the Bandwidth–Bit–Time (BbT) Product of a Predefined 
Gaussian Filter

1. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 
Filter > Select > Gaussian
or
Mode > Custom > Real Time I/Q Baseband > Filter > Select > Gaussian

2. Press Filter BbT.
3. Enter a new Bandwidth–Bit–Time (BbT) product filter parameter and 

press Enter.

Optimizing a Nyquist or Root Nyquist FIR Filter for EVM or ACP 
(Custom Realtime I/Q Baseband only)

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Filter > Optimize FIR 

For EVM or ACP.
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The FIR filter is now optimized for minimum error vector magnitude (EVM) 
or for minimum adjacent channel power (ACP). This feature applies only to 
Nyquist and root Nyquist filters; the softkey is grayed out when any other 
filter is selected.

Restoring Default FIR Filter Parameters

1. Preset the instrument: Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 
Filter > Restore Default Filter.

This replaces the current FIR filter with the default filter for the selected 
modulation format.

Using a User–Defined FIR Filter

FIR filters can be created and modified by defining the FIR coefficients or by 
defining the oversample ratio (number of filter coefficients per symbol) to be 
applied to your own custom FIR filter.

To Modify Predefined FIR Coefficients for a Gaussian Filter Using the 
FIR Values Editor

You can define from 1 to 32 FIR coefficients, where the maximum combination 
of symbols and oversample ratio is 1024 coefficients. While the FIR Values 
editor allows a maximum filter length of 1024 coefficients, the PSG hardware is 
limited to 64 symbols for real–time and 512 symbols for arbitrary waveform 
generation (the number of symbols equals the number of coefficients divided 
by the oversample ratio). 

If you enter more than 64 symbols for real–time or 512 symbols for arbitrary 
waveform generation, the PSG cannot use the filter; it will decimate the filter 
(throw away coefficients) until the required condition is met and then use the 
filter, but fine resolution may be lost from the impulse response.

FIR filters stored in signal generator memory can easily be modified using the 
FIR Values editor. In this example, you will load the FIR Values editor with 
coefficient values from a default FIR filter (or, if one has been defined, a 
user–defined FIR file that has been stored in the Memory Catalog), modify the 
coefficient values, and store the new file to the Memory Catalog. 

1. Press Preset.

2. Press Mode > Custom > Arb Waveform Generator > Digital Mod Define > 
Filter
or Mode > Custom > Real Time I/Q Baseband > Filter

3. Press Define User FIR > More (1 of 2) > Load Default FIR > Gaussian.

4. Press Filter BbT > 0.300 > Enter.

5. Press Filter Symbols > 8 > Enter.
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6. Press Generate. 

7. Press Display Impulse Response. A graph displays the impulse response 
of the current FIR coefficients.

8. Press Return.

9. Highlight coefficient 15.

10.Press 0 > Enter.

11.Press Display Impulse Response.

The graphic display can provide a useful troubleshooting tool (in this case, 
it indicates that a coefficient value is set incorrectly, resulting in an 
improper Gaussian response).

12.Press Return.

13.Highlight coefficient 15. 

14.Press 1 > Enter. 

15.Press Load/Store > Store To File. 

16.Name the file NEWFIR2, and press Enter.

The actual oversample ratio during modulation is automatically selected 
by the instrument. A value between 4 and 16 is chosen dependent on the 
symbol rate, the number of bits per symbol of the modulation type, and 
the number of symbols.
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The contents of the current FIR Values editor are stored to a file in the 
Memory Catalog and the Catalog of FIR Files is updated to show the new 
file.

To Create a User–Defined FIR Filter with the FIR Values Editor

In this procedure, you use the FIR Values editor to create and store an 
8–symbol, windowed, sinc function filter with an oversample ratio of 4. The 
Oversample Ratio (OSR) is the number of filter coefficients per symbol.

You can define from 1 to 32 FIR coefficients, where the maximum combination 
of symbols and oversample ratio is 1024 coefficients.

The FIR Values editor allows a maximum filter length of 1024 coefficients, but 
the PSG hardware is limited to 512 symbols for arbitrary waveform generation, 
and 64 symbols for real–time waveform generation. The number of symbols 
equals the number of coefficients divided by the oversample ratio. If you enter 
more than the maximum number of symbols, the PSG cannot use the filter; it 
decimates the filter (throws away coefficients) until the required condition is 
met and then uses the filter, but fine resolution may be lost from the impulse 
response.

1. Press Preset.

2. Press Mode > Custom > Arb Waveform Generator > Digital Mod Define > 
Filter
or
Mode > Custom > Real Time I/Q Baseband > Filter

3. Press Define User FIR > More (1 of 2). 

4. Press Delete All Rows > Confirm Delete Of All Rows > More (2 of 2). 

This brings up the FIR Values editor and clears the table of existing values.

5. Press Edit Item. The Value field for coefficient 0 should be highlighted.
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6. Use the numeric keypad to type the first value (-0.000076) from the 
following table and press Enter. As you press the numeric keys, the 
numbers are displayed in the active entry area. (If you make a mistake, you 
can correct it using the backspace key.) Continue entering the coefficient 
values from the table until all 16 values have been entered.

7. Press Mirror Table.

In a windowed sinc function filter, the second half of the coefficients are 
identical to the first half, but in reverse order. The signal generator 
provides a mirror table function that automatically duplicates the existing 
coefficient values in the reverse order; coefficients 16 through 31 are 
automatically generated and the first of these coefficients (number 16) 
highlights, as shown in the following figure. 

8. For this example, the desired OSR is 4, which is the default, so no action is 
necessary.

The Oversample Ratio (OSR) is the number of filter coefficients per 
symbol. Acceptable values range from 1 through 32; the maximum 
combination of symbols and oversampling ratio allowed by the FIR Values 
editor is 1024. Remember, however, that the instrument hardware is 

Table 6-1 

Coefficient Value Coefficient Value Coefficient Value

0 -0.000076 6 0.043940 12 0.123414

1 -0.001747 7 0.025852 13 0.442748

2 -0.005144 8 -0.035667 14 0.767329

3 -0.004424 9 -0.116753 15 0.972149

4 0.007745 10 -0.157348

5 0.029610 11 -0.088484



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 211

Custom Arb Waveform Generator
Working with Filters

limited to 64 symbols for real–time waveform generation, and 512 
symbols for arbitrary waveform generation. The number of symbols equals 
the number of coefficients divided by the oversample ratio.

9. Press More (1 of 2) > Display FFT (fast Fourier transform). 

A graph displays the fast Fourier transform of the current set of FIR 
coefficients. The signal generator has the capability of graphically 
displaying the filter in both time and frequency dimensions.

10.Press Return > Display Impulse Response. 

A graph shows the impulse response of the current set of FIR coefficients.

11. Press Return > Load/Store > Store To File.

The Catalog of FIR Files appears along with the amount of memory 
available.

12.If there is already a file name occupying the active entry area, press: Edit 
Keys > Clear Text

13.Using the alphabetic menu and the numeric keypad, enter NEWFIR1 as the 
file name.

14.Press Enter.

The NEWFIR1 file is the first file name listed. (If you have previously stored 
other FIR files, additional file names are listed below NEWFIR1.) The file 
type is FIR and the size of the file is 260 bytes. The amount of memory 
used is also displayed. The number of files that can be saved depends on 
the size of the files and the amount of memory used.
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Working with Symbol Rates
The Symbol Rate menu enables you to set the rate at which I/Q symbols are 
fed to the I/Q modulator. The default transmission symbol rate can also be 
restored in this menu.

— Symbol Rate (displayed as Sym Rate) is the number of symbols per second 
that are transmitted using the modulation (displayed as Mod Type) along 
with the filter and filter alpha (displayed as Filter). Symbol rate directly 
influences the occupied signal bandwidth.

Symbol Rate is the Bit Rate divided by the number of bits that can be 
transmitted with each symbol; this is also known as the Baud Rate.

— Bit Rate is the frequency of the system bit stream. The internal baseband 
generator (Option 602) automatically streams the selected Data Pattern at 
the appropriate rate to accommodate the symbol rate setting (Bit Rate = 
Symbols/s x Number of Bits/Symbol).

— Occupied Signal Bandwidth = Symbol Rate x (1 + Filter Alpha); therefore, 
the occupied signal bandwidth is dependent on the filter alpha of the 
Nyquist or Root Nyquist filter being used. (To change the filter alpha, refer 
to the procedure, “Adjusting the Filter Alpha of a Predefined Root Nyquist 
or Nyquist Filter” on page  206.)

To Set a Symbol Rate

1. Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 
Symbol Rate
or
Mode > Custom > Real Time I/Q Baseband > Symbol Rate

3. Enter a new symbol rate and press Msps, ksps, or sps.
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To Restore the Default Symbol Rate (Custom Real Time I/Q Only)

— Press Mode > Custom > Real Time I/Q Baseband > Symbol Rate > Restore 
Default Symbol Rate.

This replaces the current symbol rate with the default symbol rate for the 
selected modulation format.

Table 6-2 

Modulation Type

Bits 
Per 
Symbol

Bit Rate = 
Symbols/s x Number of 
Bits/Symbol

Internal Symbol Rate
(Minimum Maximum)

Custom Real Time 
Only
External Symbol Rate
(Minimum Maximum)

PSK

Phase 
Shift 
Keying

QPSK and OQPSK
(quadrature phase shift keying and
offset quadrature phase shift 
keying)
Includes: QPSK, IS95 QPSK,
Gray Coded QPSK, OQPSK,
IS95 OQPSK

2 90 bps - 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps

BPSK
(binary phase shift keying)

1 45 bps - 50 Mbps 45 sps - 50 Msps 45 sps - 50 Msps

p/4 DQPSK 2 90 bps - 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps

8PSK
(eight phase state shift keying)

3 135 bps - 150 Mbps 45 sps - 50 Msps 45 sps - 16.67 Msps

16PSK
(sixteen phase state shift keying)

4 180 sps - 200 Mbps 45 sps - 50 Msps 45 sps - 12.5 Msps

D8PSK
(eight phase state shift keying)

3 135 bps - 150 Mbps 45 sps - 50 Msps 45 sps - 16.67 Msps

MSK

Minimum 
Shift 
Keying

MSK

(GSM – Global System for 
Mobile Communications)

1 45 bps - 50 Mbps 45 sps - 50 Msps 45 sps - 50 Msps

FSK

Frequency 
Shift 
Keying

2–Lvl FSK 1 45 bps - 50 Mbps 45 sps - 50 Msps 45 sps - 50 Msps

4–Lvl FSK 2 90 bps - 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps

8–Lvl FSK 3 135 bps - 150 Mbps 45 sps - 50 Msps 45 sps - 16.67 Msps

16–Lvl FSK 4 180 bps - 200 Mbps 45 sps - 50 Msps 45 sps - 12.5 Msps

C4FM 2 90 bps - 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps

QAM

Quadrature 
Amplitude 
Modulation

4QAM 2 90 bps - 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps

16QAM 4 180 bps - 200 Mbps 45 sps - 50 Msps 45 sps - 12.5 Msps

32QAM 5 225 bps - 250 Mbps 45 sps - 50 Msps 45 sps - 10 Msps

64QAM 6 270 bps - 300 Mbps 45 sps - 50 Msps 45 sps - 8.33 Msps

128QAM
There is no preset value for this
modulation, it must be user 
defined.

7 315 bps - 350 Mbps 45 sps - 50 Msps 45 sps - 7.14 Msps

256QAM 8 360 bps - 400 Mbps 45 sps - 50 Msps 45 sps - 6.25 Msps
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Working with Modulation Types
The Modulation Type menu enables you to specify the type of modulation 
applied to the carrier signal when the Mod On Off hardkey is on.

When the Custom Off On softkey is on:

— For Custom Arb, the BBG  (baseband generator) creates a sampled version 
of the I/Q waveform based on a random data pattern and the modulation 
type that has been selected.

— For Custom Real Time I/Q, the real–time custom I/Q symbol builder creates 
I/Q symbols based on the data pattern and modulation type that has been 
selected (see “Working with Data Patterns” on page  229 for information on 
selecting a data pattern).

In Custom Real Time I/Q, you can also: 

— Create user–defined modulation type (see page 216) that can be used 
immediately or saved to the Memory Catalog.

— Restore all modulation parameters to their default state.

To Select a Predefined Modulation Type

1. Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > 
Modulation Type > Select
or
Mode > Custom > Real Time I/Q Baseband > Modulation Type > Select

3. Select one of the available modulation types.

If you select QPSK and OQPSK, you must make a specific selection from 
the menu that displays.
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To Use a User–Defined Modulation Type (Real Time I/Q Only)

Creating a 128QAM I/Q Modulation Type User File with the I/Q Values 
Editor

In I/Q modulation schemes, symbols appear in default positions in the I/Q 
plane. Using the I/Q Values editor, you can define your own symbol map by 
changing the position of one or more symbols. Use the following procedure to 
create and store a 128–symbol QAM modulation.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User I/Q > 
More (1 of 2) > Load Default I/Q Map > QAM > 256QAM.

This loads a default 256QAM I/Q modulation into the I/Q Values editor.

3. Press More (2 of 2) > Display I/Q Map.

In the next steps, you will delete specific portions of this I/Q constellation 
and change it into a 128QAM with 128 I/Q states.

4. Press Return > Goto Row > 0011 0000 > Enter; this is row 48.

Although this procedure provides a quick way to implement a 128QAM 
modulation format, it does not take full advantage of the I/Q modulator’s 
dynamic range. This is because you begin with a 256QAM constellation, 
and delete unwanted points. The remaining points that make up the 
128QAM constellation are closer together than if you had mapped each 
point specifically. Additionally, this approach does not enable you to 
define the bit pattern associated with each symbol point, as you could if 
the 128QAM constellation had been defined one point at a time.
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5. Press the Delete Row softkey 16 times.

Repeat this pattern of steps using the following table:

6. Press Display I/Q Map to view the new 
constellation that has been created. The 
I/Q State Map in this example has 128 
symbols.

7. Press Return. When the contents of an I/Q 
Values table have not been stored, I/Q 
Values (UNSTORED) appears on the 
display.

8. Press More (1 of 2) > Load/Store > Store To 
File.

If there is already a file name from the Catalog of IQ Files occupying 
the active entry area, press the following keys:

Editing Keys > Clear Text

9. Enter a file name (for example, 128QAM) using the alpha keys and the 
numeric keypad.

10.Press Enter.

The user–defined I/Q State Map should now be stored in the Catalog of 
IQ Files.

Goto Row... Press the Delete Row softkey...

0110 0000 (96) 16 times

1001 0000 (144) 16 times

1100 0000 (192) 16 times

0001 0000 (16) 4 times

0001 0100 (20) 4 times

0001 1000 (24) 8 times

0011 0000 (48) 4 times

0011 0100 (52) 4 times

0011 1000 (56) 4 times

0101 1000 (88) 8 times

0111 0000 (112) 4 times

0111 0100 (116) 4 times

0111 1000 (120) 8 times
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Creating a QPSK I/Q Modulation Type User File with the I/Q Values 
Editor

In I/Q modulation schemes, symbols appear in default positions in the I/Q 
plane. Using the I/Q Values editor, you can define your own symbol map by 
changing the position of one or more symbols. Use the following procedure to 
create and store a 4–symbol unbalanced QPSK modulation.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User I/Q > More (1 of 2) > Delete All Rows > Confirm Delete All 
Rows.

This loads a default 4QAM I/Q modulation and clears the I/Q Values 
editor.

3. Enter the I and Q values listed in the following table:

a. Press 0.5 > Enter.
b. Press 1 > Enter. 
c. Enter the remaining I and Q values.

As the I value updates, the highlight moves to the first Q entry (and 
provides a default value of 0) and an empty row of data appears below the 
first row. As the Q value updates, the highlight moves to the next I value. 
As you press the numeric keys, the numbers display in the active entry 
area. If you make a mistake, use the backspace key and retype.

Also note that 0.000000 appears as the first entry in the list of Distinct 
Values, and that 0.500000 and 1.000000 are listed as the distinct 
values.

4. Press More (2 of 2) > Display I/Q Map.

An I/Q State Map is displayed from the current values in the I/Q Values 
table.

The I/Q State Map in this example has four symbols. The I/Q State Map 
uses the following four unique values: 0.5, 1.0, -0.5, and -1.0 to create the 
four symbols. It is not the number of values that defines how many 
symbols a map has, but how those values are combined.

5. Press Return.

Symbol Data I Value Q Value

0 0000 0.500000 1.000000

1 0001 -0.500000 1.000000

2 0010 0.500000 -1.000000

3 0011 -0.500000 -1.000000
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When the contents of an I/Q Values table have not been stored, I/Q 
Values (UNSTORED) appears on the display.

6. Press More (1 of 2) > Load/Store > Store To File.

If there is already a file name from the Catalog of IQ Files occupying 
the active entry area, press the following keys: Editing Keys > Clear Text

7. Enter a file name (for example, NEW4QAM) using the alpha keys and the 
numeric keypad.

8. Press Enter. The user–defined I/Q State Map should now be stored in the 
Catalog of IQ Files and can be recalled even after the signal 
generator has been turned off.

Modifying a Predefined I/Q Modulation Type (I/Q Symbols) & 
Simulating Magnitude Errors & Phase Errors

Use the following procedure to manipulate symbol locations which simulate 
magnitude and phase errors. In this example, you edit a 4QAM constellation to 
move one symbol closer to the origin.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User I/Q > More (1 of 2) > Load Default I/Q Map > QAM > 4QAM.

This loads a default 4QAM I/Q modulation into the I/Q Values editor.

3. Press More (2 of 2).

4. In the I/Q Values editor, navigate to Data 00000000 and press Edit 
Item.

5. Press .235702 > Enter, then .235702 > Enter.

When you press Enter the first time, the I value updates and the highlight 
moves to the first Q entry. The second time, the Q value updates and the 
highlight moves to the following I entry.

6. Press Display I/Q Map. Note that one symbol has moved, as shown.
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Creating an FSK Modulation Type User File with the Frequency Values 
Editor

Use this procedure to set the frequency deviation for data 00, 01, 10, and 11 to 
configure a user–defined FSK modulation. 

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User FSK > More (1 of 2) > Delete All Rows > Confirm Delete All 
Rows.

This accesses the Frequency Values editor and clears the previous 
values.

3. Press 600 > Hz.

4. Press 1.8 > kHz.

5. Press –600 > Hz.

6. Press –1.8 > kHz.

Each time you enter a value, the Data column increments to the next 
binary number, up to a total of 16 data values (from 0000 to 1111). An 
unstored file of frequency deviation values is created for the custom 
4–level FSK file.

7. Press Load/Store > Store To File.

If there is already a file name from the Catalog of FSK Files occupying 
the active entry area, press the following keys:

Edit Keys > Clear Text

8. Enter a file name (for example, NEWFSK) using the alpha keys and the 
numeric keypad.

9. Press Enter.

The user–defined FSK modulation should now be stored in the Catalog 
of FSK Files.

Modifying a Predefined FSK Modulation Type User File with the 
Frequency Values Editor

Using the Frequency Values editor, you can define, modify, and store 
user–defined frequency shift keying modulation. The Frequency Values 
editor is available for custom Real–Time I/Q Baseband mode, but is not 
available for waveforms generated in custom Arb Waveform Generator mode. 
Use this example to learn how to add errors to a default FSK modulation.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User FSK > More (1 of 2) > Load Default FSK.
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3. Press Freq Dev > 1.8 > kHz.

4. Press 4–Lvl FSK.

This sets the frequency deviation and opens the Frequency Values 
editor with the 4–level FSK default values displayed. The frequency value 
for data 0000 is highlighted.

5. Press –1.81 > kHz.

6. Press –590 > Hz.

7. Press 1.805 > kHz.

8. Press 610 > Hz.

As you modify the frequency deviation values, the cursor moves to the 
next data row. An unstored file of frequency deviation values is created for 
your custom 4–level FSK file.

9. Press Load/Store > Store To File.

If there is already a file name from the Catalog of FSK Files occupying 
the active entry area, press the following keys:

Edit Keys > Clear Text

10.Enter a file name (for example, NEWFSK) using the alpha keys and the 
numeric keypad.

11.Press Enter.

The user–defined FSK modulation should now be stored in the Catalog 
of FSK Files.

Differential Wideband IQ (Option 016)

The signal generator with Option 016 can use an external I/Q modulation 
source such as a two channel arbitrary waveform generator to generate up to 2 
GHz modulation bandwidth at RF. To enable the wideband I/Q inputs:

1. Press the front panel I/Q hardkey.

2. Press I/Q Off.

3. Press I/Q Path Wide (Ext Rear Inputs).

4. Press I/Q On.

Connect the external I/Q modulation source to the signal generator’s rear 
panel, differential WIDEBAND I/Q INPUTS. The voltage level at the inputs is 
+/– 1 Vdc. Wideband IQ is available for RF above 3.2 GHz. Refer to the Data 
Sheet for more information. 
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It is possible to use the signal generator’s internal arbitrary waveform 
generator (ARB) as a baseband source while using the wideband inputs at RF. 
The internal ARB I and Q signals are available at the I and Q OUT and the I–bar 
and Q–bar OUT rear panel connectors. Use the following steps to set up the 
internal ARB as a baseband source and enable the wideband inputs. 

1. Set up the internal baseband generator with the desired signal.

2. Press the Mux hardkey.

3. Press I/Q Out.

4. Press BBG1

5. Press the front panel I/Q hardkey.

6. Press I/Q Off.

7. Press I/Q Path Wide (Ext Rear Inputs).

8. Press I/Q On.

Single–Ended Wideband IQ (Option 015 – Discontinued)

The signal generator with Option 015 can use an external I/Q modulation 
source such as a two channel arbitrary waveform generator to generate up to 2 
GHz modulation bandwidth at RF. To enable the wideband I/Q inputs:

1. Press the front panel I/Q hardkey.

2. Press I/Q Off.

3. Press I/Q Path Wide (Ext Rear Inputs).

4. Press I/Q On.

Connect the external I/Q modulation source to the signal generator’s rear 
panel WIDEBAND I INPUT and WIDEBAND Q INPUT. The voltage level at the 
inputs is +/– 1 Vdc. Wideband IQ is available for RF above 3.2 GHz. Refer to 
the Data Sheet for more information. 

It is possible to use the signal generator’s internal arbitrary waveform 
generator (ARB) as a baseband source while using the wideband inputs at RF. 
The internal ARB I and Q signals are available at the I and Q OUT and the I–bar 
and Q–bar OUT rear panel connectors. Use the following steps to setup the 
internal ARB as a baseband source and enable the wideband inputs. 

1. Set up the internal baseband generator with the desired signal.

2. Press the Mux hardkey.

3. Press I/Q Out.

4. Press BBG1

5. Press the front panel I/Q hardkey.

6. Press I/Q Off.
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7. Press I/Q Path Wide (Ext Rear Inputs).

8. Press I/Q On.
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Configuring Hardware

To Set a Delayed, Positive Polarity, External Single Trigger

Using this procedure, you learn how to utilize an external function generator to 
apply a delayed single–trigger to a custom multicarrier waveform.

1. Connect an Keysight 33120A function generator or equivalent to the signal 
generator PATT TRIGGER IN port, as shown in Figure 6-1.

Figure 6-1 

2. On the signal generator, press Preset.

3. Press Mode > Custom > Arb Waveform Generator.

4. Press Multicarrier Off On until On is highlighted.

5. Press Trigger > Single.

6. Press Trigger > Trigger Setup >Trigger Source > Ext.

7. Press Ext Polarity Neg Pos until Pos is highlighted.

8. Press Ext Delay Off On until On is highlighted.

9. Press Ext Delay Time > 100 > msec.

The Custom Arb Waveform Generator has been configured to play a single 
multicarrier waveform 100 milliseconds after it detects a change in TTL 
state from low to high at the PATT TRIG IN rear panel connector.

10.Set the function generator waveform to a 0.1 Hz square wave at an output 
level of 0 to 5V. 

11.On the signal generator, press Mode > Custom > Arb Waveform 
Generator > Digital Modulation Off On until On is highlighted.

This generates a waveform with the custom multicarrier state and the 
display changes to Dig Mod Setup: Multicarrier.

During waveform generation, the DIGMOD and I/Q annunciators activate 
and the new custom multicarrier state is stored in volatile ARB memory. 
The waveform should be modulating the RF carrier.

12.Press RF On/Off.
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The externally single–triggered custom multicarrier waveform should be 
available at the signal generator’s RF OUTPUT connector 100 ms after 
receiving a change in TTL state from low to high at the PATT TRIG IN.
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7 Custom Real Time I/Q Baseband

In the following sections, this chapter describes the custom real–time I/Q 
baseband mode, which is available only in E8267D PSG vector signal 
generators with Option 601 or 602:

— “Overview” on page  228

— “Working with Predefined Setups (Modes)” on page  228

— “Working with Data Patterns” on page  229

— “Working with Burst Shapes” on page  235

— “Configuring Hardware” on page  240

— “Working with Phase Polarity” on page  242

— “Working with Differential Data Encoding” on page  242

See also: Chapter 3, “Basic Digital Operation”, on page  103
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Overview
Custom Real Time I/Q Baseband mode can produce a single carrier, but it can 
be modulated with real time data that allows real time control over all of the 
parameters that affect the signal. The single carrier signal that is produced can 
be modified by applying various data patterns, filters, symbol rates, 
modulation types, and burst shapes.

To begin using the Custom Real Time I/Q Baseband mode, start by selecting 
from a set of predefined modes (setups) or specify a setup by selecting a Data 
Pattern, Filter, Symbol Rate, Modulation Type, Burst Shape, Configure 
Hardware, Phase Polarity, and whether Differential Data Encode is off or on.

Working with Predefined Setups (Modes)
When you select a predefined mode, default values for components of the 
setup (including the filter, symbol rate, and modulation type) are automatically 
specified.

Selecting a Predefined Real Time Modulation Setup

The following steps select a predefined mode where filtering, symbol rate, and 
modulation type are defined by the APCO 25 w/C4FM digital modulation 
standard, and return to the top–level custom modulation menu.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband.

3. Press More (1 of 3) > More (2 of 3) > Predefined Mode > APCO 25 
w/C4FM.

4. Press More (3 of 3).

Deselecting a Predefined Real Time Modulation Setup

To deselect any predefined mode that has been previously selected, and return 
to the top–level custom modulation menu:

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband.

3. Press More (1 of 3) > More (2 of 3) > Predefined Mode > None.

4. Press More (3 of 3).
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Working with Data Patterns
This section provides information on the following:

— “Using a Predefined Data Pattern” on page  230

— “Using a User–Defined Data Pattern” on page  230

— “Using an Externally Supplied Data Pattern” on page  234

The Data menu enables you to select from predefined and user defined data 
patterns. Data Patterns are used for transmitting continuous streams of 
unframed data. When the Custom Off On softkey is on, the real–time custom 
I/Q symbol builder creates I/Q symbols based on the data pattern and 
modulation type that has been selected. Refer to “Working with Modulation 
Types” on page  215 for information on selecting a modulation type.

The following data patterns are available:

— PN sequence allows you to access a menu (PN9, PN11, PN15, PN20, PN23) 
for internal data generation of pseudorandom sequences (pseudorandom 
noise sequences); a pseudorandom noise sequence is a periodic binary 
sequence approximating, in some sense, a Bernoulli “coin tossing” process 
with equiprobable outcomes.

— FIX4 0000 allows you to define a 4–bit repeating sequence data pattern and 
make it the active function. The selected 4–bit pattern will be repeated as 
necessary to provide a continuous stream of data.

— Other Patterns allows you to access a menu of choices (4 1’s & 4 0’s, 8 1’s & 
8 0’s, 16 1’s & 16 0’s, 32 1’s & 32 0’s, or 64 1’s & 64 0’s) from which you can 
select a data pattern. Each pattern contains an equal number of ones and 
zeroes. The selected pattern will be repeated as necessary to provide a 
continuous stream of data.

— User File allows you to access a menu of choices from which you can create 
a file and store it to the Catalog of Bit Files, select from a Catalog of Bit Files 
and use it, or select from a Catalog of Bit Files, edit the file, and resave the 
file.

— Ext allows data patterns to be fed into the I/Q symbol builder, through the 
DATA port, in real–time.
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Using a Predefined Data Pattern

Selecting a Predefined PN Sequence Data Pattern

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > PN Sequence.

3. Press one of the following: PN9, PN11, PN15, PN20, PN23.

Selecting a Predefined Fixed 4–bit Data Pattern

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > FIX4.

3. Press 1010 > Enter > Return.

Selecting a Predefined Data Pattern Containing 
an Equal Number of 1s & 0s

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > Other Patterns.

3. Press one of the following:

4 1’s & 4 0’s, 8 1’s & 8 0’s, 16 1’s & 16 0’s, 32 1’s & 32 0’s, or 64 1’s & 64 
0’s.

Using a User–Defined Data Pattern

User Files (user–defined data pattern files) can be created and modified using 
the signal generator’s Bit File Editor or they can be created on a remote 
computer and moved to the signal generator for direct use; these remotely 
created data pattern files can also be modified with the Bit File Editor. For 
information on creating user–defined data files on a remote computer, see the 
Keysight Signal Generators Programming Guide.

These procedures demonstrate how to use the Bit File Editor to create, 
edit, and store user–defined data pattern files for use within the custom 
real–time I/Q baseband generator modulation. For this example, a user file is 
defined within a custom digital communication.

Creating a Data Pattern User File with the Bit File Editor

This procedure uses the Bit File Editor to create a Data Pattern User File and 
stores the resulting file in the Memory Catalog (described on page 85).

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > User File > 
Create File. 
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This opens the Bit File Editor, which contains three columns, as shown in 
the following figure.

3. Using the numeric keypad (not the softkeys), enter the 32 bit values 
shown.

Bit data is entered into the Bit File Editor in 1–bit format. The current 
hexadecimal value of the binary data is shown in the Hex Data column 
and the cursor position (in hexadecimal) is shown in the Position 
indicator.

When you create a new file, the default name is UNTITLED, or UNTITLED1, 
and so forth. This prevents overwriting previous files.

 
 Hexadecimal Data File Name indicatorBit Data

Cursor Position 
indicator (in Hex)

Offset
(in Hex)
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4. Press More (1 of 2) > Rename > Editing Keys > Clear Text.

5. Enter a file name (for example, USER1) using the alpha keys and the 
numeric keypad.

6. Press Enter.

The user file should be renamed and stored to the Memory Catalog with 
the name USER1.

Selecting a Data Pattern User File from the Catalog of Bit Files

In this procedure, you learn how to select a data pattern user file from the 
Catalog of Bit Files. If you have not created and stored a user–defined data 
file, complete the steps in the previous section, “Creating a Data Pattern User 
File with the Bit File Editor” on page  230.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > User File.

3. Highlight the file to be selected (for example, USER1).

4. Press Edit File.

The Bit File Editor should open the selected file (for example, 
USER1).

Modifying an Existing Data Pattern User File

In this example, you learn how to modify an existing data pattern user file by 
navigating to a particular bit position and changing its value. Next, you will 
learn how to invert the bit values of an existing data pattern user file.

Enter These Bit Values  Hexadecimal DataCursor Position 
indicator
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If you have not already created, stored, and recalled a data pattern user file, 
complete the steps in the previous sections, “Creating a Data Pattern User File 
with the Bit File Editor” on page  230 and “Selecting a Data Pattern User File 
from the Catalog of Bit Files” on page 232.

Navigating the Bit Values of an Existing Data Pattern User File

1. Press Goto > 4 > C > Enter.

This moves the cursor to bit position 4C, of the table, as shown in the 
following figure.

Inverting the Bit Values of an Existing Data Pattern User File

1. On the keypad, press 1011.

Cursor moves to new position Position indicator changes
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This inverts the bit values that are positioned 4C through 4F. Notice that 
hex data in this row has now changed to 76DB6DB6, as shown in the 
following figure.

To Apply Bit Errors to an Existing Data Pattern User File 

This example demonstrates how to apply bit errors to an existing data pattern 
user file. If you have not created and stored a data pattern user file, first 
complete the steps in the previous section, “Creating a Data Pattern User File 
with the Bit File Editor” on page  230.

1. Press Apply Bit Errors.
2. Press Bit Errors > 5 > Enter.
3. Press Apply Bit Errors.

Notice both Bit Errors softkeys change value as they are linked.

Using an Externally Supplied Data Pattern

In this procedure, an external real time data pattern is supplied through DATA, 
DATA CLOCK, and SYMBOL SYNC connectors.

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Data > Ext.
3. Connect the real–time data to the DATA input.
4. Connect the data clock trigger signal to DATA CLOCK input.
5. Connect the symbol sync trigger to the SYMBOL SYNC input.

Bits 4C through 4F inverted Hex Data changed
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Working with Burst Shapes

— “Configuring the Burst Rise and Fall Parameters” on page  236

— “Using User–Defined Burst Shape Curves” on page  237

The Burst Shape menu enables you to modify the rise and fall time, rise and fall 
delay, and the burst shape (either sine or user file defined). In addition, you can 
define the shape of the burst and preview the burst shape through a Rise 
Shape Editor, or restore all of the burst shape parameters back to their original 
default state.

Rise time  the period of time, specified in bits, where the burst 
increases from a minimum of −70 dB (0) to full power 
(1).

Fall time  the period of time, specified in bits, where the burst 
decreases from full power (1) to a minimum of −70 dB 
(0).

Rise delay  the period of time, specified in bits, that the start of the 
burst rise is delayed. Rise delay can be either negative 
or positive. Entering a delay other than zero shifts the 
full power point earlier or later than the beginning of the 
first useful symbol.

Fall delay  the period of time, specified in bits, that the start of the 
burst fall is delayed. Fall delay can be either negative or 
positive. Entering a delay other than zero shifts the full 
power point earlier or later than the end of the last 
useful symbol.

User–defined 
burst shape  up to 256 user–entered values, which define the shape 

of the curve in the specified rise or fall time. The values 
can vary between 0 (no power) and 1 (full power) and 
are scaled linearly. Once specified, the values are 
resampled as necessary to create the cubic spline that 
passes through all of the sample points.

The default burst shape of each format is implemented according to the 
standards of the format selected. You can, however, modify the following 
aspects of the burst shape:
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Burst shape maximum rise and fall time values are affected by the following 
factors:

— the symbol rate
— the modulation type

When the rise and fall delays equal 0, the burst shape attempts to synchronize 
the maximum burst shape power to the beginning of the first valid symbol and 
the ending of the last valid symbol. 

If you find that the error vector magnitude (EVM) or adjacent channel power 
(ACP) increases when you turn bursting on, you can adjust the burst shape to 
assist with troubleshooting.

Configuring the Burst Rise and Fall Parameters

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Burst Shape.

3. Press Rise Time > 5 > bits.

4. Press Rise Delay > 1 > bits.

5. Press Fall Time > 5 > bits.

6. Press Fall Delay > 1 > bits.

This configures the burst shape for the custom real–time I/Q baseband digital 
modulation format. For instructions on creating and applying user–defined 
burst shape curves, see “To Create and Store User–Defined Burst Shape 
Curves” on page 237.
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Using User–Defined Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curve using 
the Rise Shape and Fall Shape editors. Each editor enables you to enter up 
to 256 values, equidistant in time, to define the shape of the curve. The values 
are then resampled to create the cubic spline that passes through all of the 
sample points.

The Rise Shape and Fall Shape editors are available for custom real–time 
I/Q baseband generator waveforms. They are not available for waveforms 
generated by the dual arbitrary waveform generator.

You can also design burst shape files externally and download the data to the 
signal generator. For more information, see the Keysight Signal Generators 
Programming Guide.

To Create and Store User–Defined Burst Shape Curves

Using this procedure, you learn how to enter rise shape sample values and 
mirror them as fall shape values to create a symmetrical burst curve.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Burst Shape.

3. Press Define User Burst Shape > More (1 of 2) > Delete All Rows > 
Confirm Delete Of All Rows.

4. Enter values similar to the sample values in the following table:

a. Highlight the value (1.000000) for sample 1.

b. Press .4 > Enter.

c. Press .6 > Enter.

d. Enter the remaining values for samples 3 through 9 from the table 
above.

e. Press More (2 of 2) > Edit Fall Shape > Load Mirror Image of Rise 
Shape > Confirm Load Mirror Image of Rise Shape.

Rise Shape Editor

Sample Value Sample Value

0 0.000000 5 0.900000

1 0.400000 6 0.950000

2 0.600000 7 0.980000

3 0.750000 8 0.990000

4 0.830000 9 1.000000
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This changes the fall shape values to a mirror image of the rise 
shape values.

Figure 7-1 

5. Press More (1 of 2) > Display Burst Shape.

This displays a graphical representation of the waveform’s rise and fall 
characteristics.

Figure 7-2 

6. Press Return > Load/Store > Store To File.

If there is already a file name from the Catalog of SHAPE Files 
occupying the active entry area, press the following keys: Editing Keys > 
Clear Text

7. Enter a file name (for example, NEWBURST) using the alpha keys and the 
numeric keypad.

To return the burst shape to the default conditions, press Return > Return 
> Confirm Exit From Table Without Saving > Restore Default Burst Shape.



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 239

Custom Real Time I/Q Baseband
Working with Burst Shapes

8. Press Enter.

The contents of the current Rise Shape and Fall Shape editors are 
stored to the Catalog of SHAPE Files. This burst shape can now be 
used to customize a modulation or as a basis for a new burst shape 
design.

To Select and Recall a User–Defined Burst Shape Curve from the 
Memory Catalog

Once a user–defined burst shape file is stored in the Memory Catalog, it can be 
recalled for use with real–time I/Q baseband generated digital modulation.

This example requires a user–defined burst shape file stored in memory. If you 
have not created and stored a user–defined burst shape file, complete the 
steps in the previous sections.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Burst Shape > Burst 
Shape Type > User File.

3. Highlight the desired burst shape file (for example, NEWBURST).

4. Press Select File.

The selected burst shape file is now applied to the current real–time I/Q 
baseband digital modulation state.

5. Press Return > Custom Off On.

This generates the custom modulation with user–defined burst shape 
created in the previous steps. During waveform generation, the CUSTOM 
and I/Q annunciators activate. The waveform is now modulating the RF 
carrier.

6. Press RF On/Off.

The current real–time I/Q baseband digital modulation format with 
user–defined burst shape should be available at the signal generator’s RF 
OUTPUT connector.
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Configuring Hardware

— “To Set the BBG Reference” on page  240

— “To Set the External DATA CLOCK to Receive Input as Either Normal or 
Symbol” on page  240

— “To Set the BBG DATA CLOCK to External or Internal” on page  241

— “To Adjust the I/Q Scaling” on page  241

To Set the BBG Reference

Setting for an External or Internal Reference

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > 
Configure Hardware.

Configure Hardware displays a menu where you can set the BBG 
Reference to External or Internal.

2. Press BBG Ref Ext Int to select either external or internal as the bit–clock 
reference for the data generator.

If external is selected, apply the reference frequency to the rear–panel 
BASEBAND GEN REF IN connector.

Setting the External Frequency

The BBG reference external frequency is used only when the BBG Ref Ext Int 
softkey has been set to Ext (external).

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > 
Configure Hardware.

Configure Hardware displays a menu where you can set the external BBG 
reference frequency.

2. Press Ext BBG Ref Freq.

3. Use the numeric keypad to a desired frequency, then press MHz, kHz, or 
Hz.

To Set the External DATA CLOCK to Receive Input as Either Normal or 
Symbol

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > 
Configure Hardware.

Configure Hardware allows you to access a menu from which you can set 
the external DATA CLOCK to receive input as either Normal or Symbol.

2. Press Ext Data Clock to select either Normal or Symbol; this setting has no 
effect in internal clock mode.
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— When set to Normal, the DATA CLOCK input connector requires a bit 
clock.

— When set to Symbol, a one–shot or continuous symbol sync signal 
must be provided to the SYMBOL SYNC input connector.

To Set the BBG DATA CLOCK to External or Internal

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > 
Configure Hardware.

Configure Hardware allows you to access a menu from which you can set 
the BBG DATA CLOCK to receive input from External or Internal.

2. Press BBG Data Clock Ext Int to select either external or internal.

— When set to Ext (external), the DATA CLOCK connector is used to 
supply the BBG Data Clock.

— When set to Int (internal), the internal data clock is used.

To Adjust the I/Q Scaling

Adjusting the I/Q Scaling (amplitude of the I/Q outputs) multiplies the I and Q 
data by the I/Q scaling factor that is selected and can be used to improve the 
Adjacent Channel Power (ACP). Lower scaling values equate to better ACP. 
This setting has no effect with MSK or FSK modulation.

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > 
Configure Hardware.

Configure Hardware allows you to access a menu from which you can 
adjust the I/Q Scaling.

2. Press I/Q Scaling, enter a desired I/Q scaling level, and press %.
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Working with Phase Polarity

To Set Phase Polarity to Normal or Inverted

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Phase 
Polarity Normal Invert.

Phase Polarity Normal Invert enables you to either leave the selection as 
Normal (so that the phase relationship between the I and Q signals is not 
altered by the phase polarity function), or set to Invert and invert the 
internal Q signal, reversing the rotation direction of the phase modulation 
vector.

When you choose Invert, the in–phase component lags the 
quadrature–phase component by 90° in the resulting modulation. Inverted 
phase polarity is required by some radio standards and it is useful for 
lower sideband mixing applications. The inverted selection also applies to 
the I, I–bar, Q, and Q–bar output signals.

Working with Differential Data Encoding
The Differential Data Encode Off On menu enables you to toggle the 
operational state of the signal generator’s differential data encoding.

— When set to Off, data bits are not encoded prior to modulation.

— When set to On, data bits are encoded prior to modulation. Differential 
encoding uses an exclusive–OR function to generate a modulated bit. 
Modulated bits will have a value of 1 if a data bit is different from the 
previous bit or they will have a value of 0 if a data bit is the same as the 
previous bit.

This section provides information about the following:

— Understanding Differential Encoding

— “Using Differential Encoding” on page  246

Understanding Differential Encoding

Differential encoding is a digital–encoding technique whereby a binary value is 
denoted by a signal change rather than a particular signal state. Using 
differential encoding, binary data in any user–defined I/Q or FSK modulation 
can be encoded during the modulation process via symbol table offsets 
defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. 
With a user–defined modulation based on the default 4QAM template, the I/Q 
Values editor contains data that represent four symbols (00, 01, 10, and 11) 
mapped into the I/Q plane using two distinct values, 1.000000 and –1.000000. 



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 243

Custom Real Time I/Q Baseband
Working with Differential Data Encoding

These four symbols can be differentially encoded during the modulation 
process by assigning symbol table offset values associated with each data 
value. Figure 7-3 on page 243 shows the 4QAM modulation in the I/Q 
Values editor.

Figure 7-3 

The following illustration shows a 4QAM modulation I/Q State Map.

Differential Data Encoding

In real–time I/Q baseband digital modulation waveforms, data (1’s and 0’s) are 
encoded, modulated onto a carrier frequency and subsequently transmitted to 
a receiver. In contrast to differential encoding, differential data encoding 
modifies the data stream prior to I/Q mapping. Where differential encoding 

The number of bits per symbol can be expressed using the following 
formula. Because the equation is a ceiling function, if the value of x 
contains a fraction, x is rounded up to the next whole number. 

Where x = bits per symbol, and y = the number of differential states.

12

3 4

1st Symbol
Data = 00000000
Distinct values: +1, +1

4th Symbol
Data = 00000011
Distinct values: +1, –1

2nd Symbol
Data = 00000001
Distinct values: –1, +1

3rd Symbol
Data = 00000010
Distinct values: –1, –1
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encodes the raw data by using symbol table offset values to manipulate I/Q 
mapping at the point of modulation, differential data encoding uses the 
transition from one bit value to another to encode the raw data.

Differential data encoding modifies the raw digitized data by creating a 
secondary, encoded data stream that is defined by changes in the digital state, 
from 1 to 0 or from 0 to 1, of the raw data stream. This differentially encoded 
data stream is then modulated and transmitted.

In differential data encoding, a change in a raw data bit’s digital state, from 1 
to 0 or from 0 to 1, produces a 1 in the encoded data stream. No change in 
digital state from one bit to the next, in other words a bit with a value of 1 
followed by another bit with a value of 1 or a bit with a value of 0 followed by 
the same, produces a 0 in the encoded data. For instance, differentially 
encoding the data stream containing 01010011001010 renders 
1111010101111.

Differential data encoding can be described by the following equation:

For a bit–by–bit illustration of the encoding process, see the following 
illustration: 

How Differential Encoding Works

Differential encoding employs offsets in the symbol table to encode 
user–defined modulation schemes. The Differential State Map editor is 
used to introduce symbol table offset values, which in turn cause transitions 
through the I/Q State Map based on their associated data value. Whenever a 
data value is modulated, the offset value stored in the Differential State Map is 
used to encode the data by transitioning through the I/Q State Map in a 
direction and distance defined by the symbol table offset value.

Entering a value of +1 causes a 1–state forward transition through the I/Q 
State Map. As an example, consider the following data/symbol table offset 
values. These symbol table offsets result in one of the transitions shown.

transmittedbit i( ) atabitd( ) i 1–( )= databit i( )⊕( )d

1 0 1 0 0 1 1 0 0 11 0

raw (unencoded) data

differentially encoded data

1 1 11 1 1 1 1 110 0 0

change =
no change =

0
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Example 2
transition 1 state backwa

Example 1
transition 1 state forward

Example 3
transition 2 states forward

Example 4
no transition

ple Data Offset
Value

00000000 +1

00000001 -1

00000010 +2

00000011 0

The following I/Q State Map illustrations show all possible state transitions 
using a particular symbol table offset value. The actual state–to–state 
transition depends on the state in which the modulation starts.

Data Value Symbol Table Offset
00
01
10
11

+1
–1
+2
+0

Data = 0011100001

{{

{ {

{

5th Symbol1st Symbol
3rd Symbol

4th Symbol2nd Symbol

1st 

2nd 

3rd 
5th 4th 
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When applied to the user–defined default 4QAM I/Q map, starting from the 1st 
symbol (data 00), the differential encoding transitions for the data stream (in 
2–bit symbols) 0011100001 appear in the previous illustration. 

As you can see, the 1st and 4th symbols, having the same data value (00), 
produce the same state transition (forward 1 state). In differential encoding, 
symbol values do not define location; they define the direction and distance of 
a transition through the I/Q State Map.

For instructions on configuring differential encoding, see “Understanding 
Differential Encoding” on page  242.

Using Differential Encoding

Differential encoding is a digital–encoding technique that denotes a binary 
value by a signal change rather than a particular signal state. It is available for 
Custom Real Time I/Q Baseband mode. It is not available for waveforms 
generated by Arb Waveform Generator mode.

The signal generator’s Differential State Map editor enables you to 
modify the differential state map associated with user–defined I/Q and 
user–defined FSK modulations. In this procedure, you create a user–defined 
I/Q modulation and then configure, activate, and apply differential encoding to 
the user–defined modulation. For more information, see “Understanding 
Differential Encoding” on page  242.

This section includes information on following:

— Configuring User–Defined I/Q Modulation

— “Accessing the Differential State Map Editor” on page  247

— “Editing the Differential State Map” on page  247

Configuring User–Defined I/Q Modulation

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > 
Define User I/Q > More (1 of 2) > Load Default I/Q Map > QAM > 4QAM.

This loads a default 4QAM I/Q modulation and displays it in the I/Q Values 
editor. The default 4QAM I/Q modulation contains data that represent 4 
symbols (00, 01, 10, and 11) mapped into the I/Q plane using 2 distinct values 
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(1.000000 and −1.000000). These 4 symbols will be traversed during the 
modulation process by the symbol table offset values associated with each 
symbol of data.

Accessing the Differential State Map Editor

— Press Configure Differential Encoding. 

This opens the Differential State Map editor. At this point, you see the 
data for the 1st symbol (00000000) and the cursor prepared to accept an offset 
value. You are now prepared to create a custom differential encoding for the 
user–defined default 4QAM I/Q modulation.

Editing the Differential State Map

1. Press 1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The 
symbol rotates forward through the state map by 1 value when a data 
value of 0 is modulated.

Symbol Table Offset Values Entry AreaData
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2. Press +/– > 1 > Enter. 

This encodes the second symbol by adding a symbol table offset of –1. 
The symbol rotates backward through the state map by 1 value when a 
data value of 1 is modulated.

3. Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The 
symbol rotates forward through the state map by 2 values when a data 
value of 10 is modulated.

4. Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The 
symbol does not rotate through the state map when a data value of 11 is 
modulated.

5. Press Return > Differential Encoding Off On. 

This applies the custom differential encoding to a user–defined 
modulation. 

At this point, the modulation has one bit per symbol. For the first two data 
values (00000000 and 00000001) only the last bits (the 0 and the 1, 
respectively) are significant. 

At this point, the modulation has two bits per symbol. For the data values 
00000000, 00000001, 00000010, 00000011, the symbol values are 00, 01, 
10, and 11 respectively.

Notice that (UNSTORED) appears next to Differential State Map on the signal 
generator’s display. Differential state maps are associated with the 
user–defined modulation for which they were created.

To save a custom differential state map, you must store the user–defined 
modulation for which it was designed. Otherwise the symbol table offset 
data is purged when you press the Confirm Exit From Table Without 
Saving softkey when exiting from the I/Q or FSK editor.
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8 GPS Modulation (Option 409)

Option 409 includes real time multiple-satellite and single-satellite global 
positioning system (GPS) signal generation capabilities. This feature is 
available only in E8267D PSG Vector Signal Generators with Option 602. The 
following topics are covered in this chapter:

— “Real Time MSGPS” on page 250 (multiple satellite GPS)

— “Real Time GPS” on page 257 (single satellite GPS)

The Keysight Scenario Generator for GPS software (Option 422) provides 
the ability to create custom scenario files for real-time playback using 
Option 409. 

The software is available as a free download, allowing you to investigate 
the features of the scenario generator, create and save scenario files, or 
download them to your E8267D signal generator. The signal generator 
must have licenses for Option 422 and 409 in order to use the scenario 
files created by the software.

For more information, go to: www.keysight.com/find/gps.
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Real Time MSGPS
In Real Time MSGPS mode, selectable scenario files define simulated 
multiple-satellite conditions. The E8267D generates a signal (C/A code only) 
simulating multiple satellite transmissions from the information in the selected 
scenario file. MSGPS signal generation capabilities include:

— selectable MSGPS scenario files that include the following information:

— simulated location (city, latitude, longitude, elevation)
— simulated date and time
— scenario duration
— satellite IDs present (in view) in the scenario

— pause and resume function for the currently playing scenario

— restart function that sets the currently playing scenario to the beginning 
(without turning off the RF output)

— adjustable number of satellites in view to include in the generated signal

— selectable internal or external chip clock reference source

— adjustable chip clock reference (10.23 Mcps ± 10%)

— selectable I/Q phase (normal or inverted)
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Signal Generation Block Diagram

Figure 8-1 shows how the signal is generated within the PSG for a four satellite 
MSGPS simulation. The PSG produces a simulated signal for each satellite and 
then sums them together to produce the MSGPS signal. Use the Number of 
Satellites softkey to specify the number of satellites in the MSGPS simulation.

Figure 8-1 MSGPS Signal Generation Diagram

Scenario Files

When you install option 409, a GPS directory is created in the PSG non-volatile 
memory and two MSGPS scenario files are loaded into the GPS directory. 
Additional scenario files are available for Option 409. 
(Go to http://www.Keysight.com/find/gps.)

After downloading a scenario file to your PC, you can download the scenario 
file to the PSG using FTP over a local area network (LAN) or using SCPI 
commands over a general purpose interface bus (GPIB) interface.
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Downloading Scenario Files Using the PSG Web Interface

The following procedure describes how to download scenario files to a PSG 
using the PSG Web interface and LAN connection:

1. Open your web browser and type in the IP address of your PSG. The PSG’s 
Welcome webpage is displayed.

2. Click Signal Generator FTP Access on the left hand side. An explorer file 
window will be opened.

3. If a view to your desktop is not already visible on the explorer file window, 
open one by selecting View/Explorer Bar/Folders from the drop down 
menu. This will provide a view of both your desktop and the PSG’s file 
system.

4. Locate the .GPS scenario file previously downloaded on your PC. 

5. Drag and drop the .GPS file into the USER/GPS directory on the PSG.

Downloading Scenario Files Using FTP (LAN)

The following procedure describes how to download scenario files to a PSG 
using FTP on a PC connected to your PSG through a LAN:

1. On the PC click Start > Programs > Accessories > Command Prompt.

2. At the command prompt enter: ftp <IP address> or <hostname>
3. At the user name prompt, press Enter.

4. At the password prompt, press Enter. You are now in the signal generator’s 
user directory.

5. Type cd GPS.

6. Type bin.

7. Type put <scenario_file>.

8. Type quit or bye to end your FTP session.

9. Type exit to end the command prompt session.

Downloading Scenario Files Using SCPI Commands (GPIB)

The following procedure describes how to download scenario files to a PSG 
using a SCPI command on a PC connected to your PSG through a GPIB 
interface:

1. Open your web browser and type in the IP address of your PSG. The PSG’s 
Welcome webpage is displayed.

Refer to the Programming Guide for more information on downloading files.
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2. Click Signal Generator Web Control. Below the graphical representation 
of the PSG front panel is a field for entering SCPI commands.

3. Enter the following command in the SCPI command field:
:MEMory:DATA "<GPS:file_name>",<data_block>
where file_name is the name of the destination file in PSG memory and 
GPS: specifies the destination directory. Refer to the Programming Guide 
for a description of the <data_block> parameter.

RF Power Level Considerations

When you set up your GPS test signal, pay special attention to the RF power 
level delivered to the GPS receiver. Because typical GPS sensitivities are 
between -155 dBm and -159 dBm, delivering a GPS signal to your device with 
a power level greater than -150 dBm or less than -160 dBm may produce 
invalid test results.

If you use a physical connection to apply the GPS signal to your antenna, keep 
in mind that most GPS antennas are active (a DC voltage is delivered to the 
antenna from the receiver). A DC block is therefore required between the signal 
generator and the antenna. For direct connection, Keysight recommends 
setting the signal generator RF output power to between -70 and -80 dBm and 
using an 80 dB attenuator and a DC blocking device between the signal 
generator output and the antenna input of the receiver under test.

If you use a radiated connection, place your receiver in a calibrated test fixture 
designed with a link budget that will deliver a -150 dBm to -160 dBm power 
level at the receiver antenna.

Using NMEA data to monitor signal power

One method to monitor the receiver’s perceived signal level is to monitor the 
National Marine Electronics Association (NMEA) data stream from the receiver. 
Most GPS receivers have the capability to output data via a serial RS232 
connection in NMEA format. An NMEA message called GPGSV reports the 
signal strength of the satellites that the GPS receiver is tracking. The GPGSV 
message reports a carrier-to-noise (CNO) value for each observed satellite. As 
you monitor this message, increase or decrease the power to the receiver until 
the receiver’s perceived CNO values are between 35 and 40. Table 8-1 on 
page 254 shows how to obtain the CNO value from the GPGSV message.

The following example is a set of three GPGSV messages. The receiver 
produces a maximum of three GPGSV messages every second. The fields are 
comma-separated; two adjacent commas signify a field for which a value is not 
assigned.

$GPGSV,3,1,12,21,71,000,,27,68,000,34,08,62,000,33,29,52,000,,*71

$GPGSV,3,2,12,24,39,000,,10,36,000,,26,35,000,,25,32,000,35*71

Refer to the Programming Guide for more information on downloading files.
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$GPGSV,3,3,12,19,29,000,,03,20,000,33,16,19,000,34,18,19,000,*71

Table 8-1 describes each field for the first of the three GPGSV messages in the 
example:

$GPGSV,3,1,12,21,71,000,,27,68,000,34,08,62,000,33,29,52,000,,*71

If no CNO value is reported for a particular satellite (satellites 21 and 29 in the 
table) the receiver is currently not tracking that satellite.

For more information, refer to the following document, available at 
http://www.nmea.org/pub/0183/.

NMEA 0183, Standard For Interfacing Marine Electronic Devices

Table 8-1 GPGSV Fields

GPGSV Field Description

$GPGSV,

3, Number of GPGSV messages in this set

1, Number of this GPGSV in the set (1 of 3)

12, Total number of satellites in view

21,71,000,, Satellite 21, elevation 71, azimuth 0, CNO unknown

27,68,000,34 Satellite 27, elevation 68, azimuth 0, CNO 34

08,62,000,33, Satellite 8, elevation 62, azimuth 0, CNO 33

29,52,000,, Satellite 29, elevation 52, azimuth 0, CNO unknown

*71 Checksum
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Generating a Real Time MSGPS Signal

This procedure uses the internal reference clock with the factory preset 
settings (the C/A chip rate is 1.023 Mcps with a clock reference of 10.23 Mcps). 

Set the carrier frequency and amplitude

1. Press the Preset hardkey.

2. Press the Frequency hardkey. Using the numeric keypad, set the signal 
generator RF output carrier frequency to 1.57542 GHz.

3. Press the Amplitude hardkey. Using the numeric keypad, set the signal 
generator RF output amplitude to −135 dBm.

4. Press RF On/Off to toggle the RF output on.

Select and play a multi-satellite scenario

1. Press Mode > More (1 of 2) > GPS > Real Time MSGPS. 

2. Press Scenario.

3. Use the navigation softkeys or the up and down arrow hardkeys to 
highlight the santarosa scenario file.

4. Press Select Scenario. A summary of the scenario is displayed including 
the simulated location, the date and time, and the satellites in view.

5. Press Number of Satellites and enter 5 to use only the first five satellites 
in view in the generated signal.

6. Press Real-time MSGPS Off On to On to play the selected scenario.

7. Press Pause. The scenario file stops playing.

8. Press Resume. The scenario file continues playing from the point at which 
it was paused.

9. Press Restart. The scenario file plays from the beginning without turning 
off the RF.

Figure 8-2 on page 256 shows the signal generator display with the santarosa 
MSGPS scenario selected. 

The scenario information within the box (Scenario State, Signal Play Duration, 
Satellites in View) is dynamic. The scenario information outside of the box 
(Location, Start Date, and so on) is static.

Selecting a new scenario, toggling Real-time MSGPS off and on, or 
pressing Restart sets the active scenario to the beginning. If Resume is 
active, the scenario immediately starts playing; if Pause is active, select 
Resume to start playing the scenario.
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Figure 8-2 Real Time MSGPS Scenario

Configuring the External Reference Clock

1. Connect the external reference clock source to the rear panel connector 
BASEBAND GEN REF IN.

2. Set the chip rate of the external clock to the desired value.

3. Press Mode > More (1 of 2) > GPS > Real Time MSGPS > More (1 of 2) > 
GPS Ref Clk Ext Int to Ext. 

4. Press GPS Ref (f0).

5. Use the numeric keypad to set the GPS reference clock to the same chip 
rate as the external clock.

The chip rate of the external source must match the chip rate of the reference clock set using the 
GPS Ref (f0) softkey.
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Real Time GPS
This real-time personality simulates GPS satellite transmissions for single 
channel receiver testing. Basic GPS signal building capabilities include:

— P code generation at 10.23 Mcps with the standard GPS 10.23 Mcps 
reference1

— C/A code generation at 1.023 Mcps with the standard GPS 10.23 Mcps 
reference

— navigation data output at 50 bps using PN9, PN15, a fixed 4-bit pattern, a 
user-defined file, or default data (TLM mode) for encoding with the C/A 
code or the C/A + P code

— three selectable ranging codes: C/A, P, or C/A+P

— satellite ID range of 1 to 32 with an additional range of 33 to 37 for other 
uses

— selectable data modes: Raw, Encoded, and TLM

— simulated doppler shift with a 250 kHz range

— selectable internal or external chip clock reference source

The signal generator’s pre-defined GPS signal setup includes a C/A ranging 
code, a satellite ID of 1, zero doppler shift, a 10.23 Mcps reference clock, and 
the Raw data mode enabled, using PN9 data. 

The satellite ID numbers match the pseudorandom numbers used to generate 
the C/A and P codes and dictate the amount of chip delay in compliance with 
the GPS standards.

The following advanced features are also available:

— P code power adjustment (-40 to 0 dB)

— adjustable chip clock reference (1 kcps to 12.5 Mcps)

— selectable I/Q phase

— selectable filters and the ability to create user-defined filters

Real Time GPS Introduction

Signal Generation Block Diagram

Figure 8-3 shows how the GPS signal is generated within the PSG. Notice that 
the C/A code modulates the L-band signal using the I axis of the I/Q 
modulator, and the P code modulates the L-band signal using the Q axis. 
Select the data provided by the data generator using the Data softkey or by 
choosing the TLM data mode.

1. P code signals are spectrally correct but do not contain valid data.
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Figure 8-3 GPS Signal Generation Diagram

Data Modes and Subframe Structures

You can select one of the three following data modes for use with the C/A or 
C/A+P ranging code:

— Raw - The Raw data mode enables the continuous transmission of 300 bits 
of data per subframe without incorporating parity bits. Use this mode for 
BER and low-level demodulation testing.

— Enc - The encoded (Enc) data mode enables the continuous transmission of 
10 words per subframe, with each word containing 24 bits of raw data and 6 
trailing parity bits (computed from the selected data by the PSG).

— TLM - The telemetry (TLM) mode enables the continuous transmission of a 
formatted TLM word, a handover word (HOW), and default navigation data 
as outlined in the Global Positioning System Standard Positioning Service 
Signal Specification, 2nd Edition, June 2, 1995. Use this mode for receiver 
testing.

Figure 8-4 shows the subframe structures for each data mode.
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Figure 8-4 Subframe Structures

The TLM word is 30-bits long, with an 8-bit preamble, 16 reserve bits (bits 9 to 
24, all set to zero), and 6 parity bits (bits 25 to 30).

The HOW word is 30-bits long, with the first 17 bits used for an incrementing 
time-of-week (TOW), bits 23 and 24 used for parity computation, and bits 25 
to 30 used for parity bits.

During a GPS signal transmission, a pulse signal is generated every 6 seconds 
at the 
EVENT 1 rear panel connector. This pulse coincides with the beginning of each 
subframe starting with the second subframe and is synchronized to the RF 
output to compensate for any internal signal delay.

Chip Clock Reference

The GPS reference clock (chip clock) is adjustable using the GPS Ref (f0) 
softkey. The factory-set value is 10.23 Mcps (the GPS standard). You can use 
the internal chip clock or an external source to provide the reference. To use an 
external reference, connect the external source to the DATA CLOCK input 
connector.

The P and C/A code chip rates are determined by the reference clock frequency 
whether you are using the internal or an external chip clock reference. The P 
code chip rate matches the reference clock frequency and the C/A code chip 

If you use an external source to provide the chip clock reference, the frequency of the external 
source must match the PSG’s reference clock frequency. Press the GPS Ref (f0) softkey then 
use the numeric keypad to enter the reference clock frequency.
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rate is one-tenth of the reference clock frequency. Refer to Figure 8-3 on 
page 258 for a block diagram showing how the GPS signal is generated within 
the PSG.

Rear Panel Signal Synchronization

Figure 8-5 illustrates the timing relationships of the GPS signals available at 
the signal generator rear panel. The AUX I/O connector outputs the SYMBOL 
SYNC OUT, DATA CLOCK OUT, and DATA OUT signals (refer to, “5. AUXILIARY 
I/O” on page 46 for more information). EVENT 1 and EVENT 2 are BNC 
connectors. If the signal generator is configured with Option 1EM, EVENT 1 
and EVENT 2 connectors are changed from BNC to SMB connectors. See “Rear 
Panel” on page 41.

Figure 8-5 GPS Signals

User Files

You can create data files internally in the PSG or create them externally and 
download them to the PSG. In either case, the size of user data files is limited 
by the amount of available PSG memory. If you develop data files externally, 
you can define signal structures that are not available internally in the PSG. For 
example, if you require a fully-coded signal consisting of frames structured 
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according to GPS standards (1 frame consisting of 5 subframes and 25 pages), 
you can develop this signal externally and download it to the PSG. User files 
can be in either binary or bit format. Save user files to the bin directory.

Select a data mode for your data file as you would for other data types (see 
“Data Modes and Subframe Structures” on page  258). If files are created 
externally and incorporate parity bits, use the Raw data mode to transmit the 
data in its original form. If your file does not contain parity bits and you want to 
incorporate parity bits in the transmitted signal, select the encoded (Enc) data 
mode. The PSG will compute parity bits for the last 6-bits of each word.

Setting Up the Real Time GPS Signal

If the signal generator is in the factory-defined preset mode, (Utility > Power 
On/Preset > Preset Normal User to Normal) a basic GPS signal is 
automatically set up when you press the Preset key. Perform step 2 and steps 
6 through 8 to generate a signal at the RF OUTPUT connector. To set up a 
signal using additional features of the GPS personality, complete this 
procedure starting with step 1.

1. Press Preset.

2. Press Mode > More (1 of 2) > GPS > Real Time GPS.

3. Press Satellite ID > 8 > Enter.

4. Press Doppler Shift > 2.5 > kHz.

5. Press Data Mode Enc TLM to Enc.

6. Press Data > PN Sequence > PN15.

7. Press Real-time GPS Off On to On.

8. Press the Frequency hardkey. Using the numeric keypad, set the signal 
generator RF output frequency to 1.57542 GHz (L1 carrier frequency).

9. Press the Amplitude hardkey. Using the numeric keypad, set the signal 
generator RF output amplitude to −120 dBm.

10.Turn the RF output on by pressing the RF On/Off hardkey on the signal 
generator front panel.

The real-time GPS signal is now available at the signal generator RF OUTPUT 
connector. Figure 8-6 on page 262 shows what the signal generator display 
should like after all steps have been completed. Notice the GPS, I/Q, and RF 
ON annunciators are on and the parameter settings for the signal are displayed 
in the status area of the signal generator display.

If you select the encoded mode for a user file that incorporates parity bits, 
the parity bits will be recomputed and their values changed.
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This procedure sets up a GPS signal that incorporates a subframe structure 
using 10 words, each with 24 raw data bits and 6 parity bits computed from the 
data source. The signal generator created this subframe structure when you 
selected Enc as the data mode and a PN15 sequence as the data type. The 
PN15 sequence was encoded with the C/A code at 50 bps. Using factory 
preset settings, the C/A chip rate is 1.023 Mcps with a clock reference of 10.23 
Mcps. A 2.5 kHz doppler shift simulates the relative motion of the satellite with 
respect to the receiver. For more information on the GPS option, refer to “Real 
Time GPS” on page 257.

Figure 8-6 Real Time GPS Setup with Internal Clock

Configuring the External Reference Clock

1. Access the real-time GPS personality (Mode > More(1 of 2) > GPS > Real 
Time GPS).

2. Press More (1 of 2) > GPS Ref Clk Ext Int to Ext.

3. Press GPS Ref (f0) > 11.03 > kcps. 

4. Connect the external reference clock source to the DATA CLOCK INPUT 
connector. 

The maximum clock rate for this input connector is 50 MHz with a voltage 
range of
−0.5 to 5.5 V.

5. Set the external reference clock source to the chip rate value entered in 
step 3. 
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The maximum data rate for this input connector is 50 Mb/s with a voltage 
range of 
−0.5 to 5.5 V.

Figure 8-7 on page 263 shows what the signal generator display should look 
like after all the steps have been completed. The CA Chip Rate, P Chip 
Rate, GPS Ref (f0), and GPS Ref Clk fields in the status area of the display 
show the new parameters you set in this procedure. Notice the settings 
Satellite ID, Doppler Shift, Data, and Data Mode, have not changed 
from the previous procedure, “Setting Up the Real Time GPS Signal” on page  
261. 

Figure 8-7 Real Time GPS Setup with External Clock

This procedure used an external source as the reference clock signal. The 
reference frequency was changed from the GPS standard of 10.23 Mcps to 
11.03 kcps. This change in the reference signal frequency automatically 
changed the P and C/A code chip rates. Since the P code chip rate matches 
the reference frequency, its chip rate is now 11.03 kcps; the C/A code rate is 
one-tenth of the reference frequency and so is now 1.103 kcps. For more 
information on the GPS option, refer to “Real Time GPS” on page  257.

Testing Receiver Sensitivity

Refer to Figure 8-8. 

1. Connect the cables between the receiver and the PSG as shown in Figure 
8-8.

The chip rate of the external source must match the chip rate value set using the GPS Ref (f0) 
softkey.
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Figure 8-8  Setup for a Receiver Sensitivity Test

2. Set the GPS data mode to TLM. 

3. Set the power level on the PSG.

4. Set the L-band frequency on the PSG.

5. Set up the UE (user equipment) to receive the signal from the PSG.

6. Turn on the GPS personality and the RF output on the PSG.
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9 Multitone Waveform Generator

In the following sections, this chapter describes the multitone mode, which is 
available only in E8267D PSG Vector Signal Generators with Option 601 or 
602:

— “Overview” on page 266

— “Creating, Viewing, and Optimizing Multitone Waveforms” on page 267

See also: Chapter 3, “Basic Digital Operation”, on page  103
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Overview
The multitone mode builds a waveform that has up to 64 CW signals, or tones. 
Using the Multitone Setup table editor, you can define, modify, and store 
waveforms for playback. Multitone waveforms are generated by the internal 
I/Q baseband generator.

The multitone waveform generator is typically used for testing the 
intermodulation distortion characteristics of multi–channel devices, such as 
mixers or amplifiers. Intermodulation distortion (IMD) occurs when non–linear 
devices with multiple input frequencies cause unwanted outputs at other 
frequencies or interfere with adjacent channels. The multitone waveform 
generator supplies a waveform with a user–specified number of tones whose 
IMD products can be measured using a spectrum analyzer and used as a 
reference when measuring the IMD generated by a device–under–test. 

Multitone waveforms are created using the internal I/Q baseband generator 
and stored in ARB memory for playback. Although the multitone mode 
generates a high–quality waveform, a small amount of IMD, carrier 
feedthrough, and feedthrough–related IMD occurs. Carrier feedthrough may 
be observed when an even number of tones are generated, since there are no 
tones at the center carrier frequency to mask the feedthrough. To minimize 
carrier feedthrough for an even–numbered multitone signal, it is necessary to 
manually adjust the I and Q offsets while observing the center carrier 
frequency with a spectrum analyzer. 

For measurements that require more than 64 tones or the absence of IMD and 
carrier feedthrough, you can create up to 1024 distortion–free multitone 
signals using Keysight Technologies Signal Studio software Option 408.

For more information about multitone waveform characteristics and the PSG vector 
signal generator multitone format, download Application Note 1410 from our website by 
going to http://www.keysight.com and searching for “AN 1410” in Test & 
Measurement.
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Creating, Viewing, and Optimizing Multitone Waveforms
This section describes how to set up, generate, and optimize a multitone 
waveform while viewing it with a spectrum analyzer. Although you can view a 
generated multitone signal using any spectrum analyzer that has sufficient 
frequency range, an Keysight Technologies PSA high–performance spectrum 
analyzer was used for this demonstration. Before generating your signal, 
connect the spectrum analyzer to the signal generator as shown in Figure 9-1.

Figure 9-1 Spectrum Analyzer Setup

To Create a Custom Multitone Waveform

Using the Multitone Setup table editor, you can define, modify and store 
user–defined multitone waveforms. Multitone waveforms are generated by the 
dual arbitrary waveform generator.

1. Preset the signal generator.

2. Set the signal generator RF output frequency to 20 GHz.

3. Set the signal generator RF output amplitude to 0 dBm.

4. Press Mode > Multitone > Initialize Table > Number of Tones > 9 > Enter.

5. Press Freq Spacing > 1 > MHz.

6. Press Initialize Phase Fixed Random to Random.

7. Press Done.

8. Press Multitone Off On to On.

9. Turn on the RF output.

The multitone signal should be available at the signal generator RF OUTPUT 
connector.
Figure 9-2 shows what the signal generator display should look like after all 
steps have been completed. Notice that the M–TONE, I/Q, RF ON, and MOD 
ON annunciators are displayed and the parameter settings for the signal are 
shown in the status area of the signal generator display. The multitone 
waveform is stored in volatile ARB memory.
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The waveform has nine tones spaced 1 MHz apart with random initial phase 
values. The center tone is placed at the carrier frequency, while the other eight 
tones are spaced in 1 MHz increments from the center tone. If you create an 
even number of tones, the carrier frequency will be centered between the two 
middle tones.

Figure 9-2 

To View a Multitone Waveform

This procedure describes how to configure the spectrum analyzer to view a 
multitone waveform and its IMD products. Actual key presses will vary, 
depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 20 GHz.

3. Set the frequency span to 20 MHz.

4. Set the amplitude for a 10 dB scale with a 4 dBm reference. 

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to 
expose the IMD products. A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.

7. Set the attenuation to 14 dB, so you’re not overdriving the input mixer on 
the spectrum analyzer. 

You should now see a waveform with nine tones and a 20 GHz center carrier 
frequency that is similar to the one shown in Figure 9-3. You will also see IMD 
products at 1 MHz intervals above and below the highest and lowest tones.
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Figure 9-3 

To Edit the Multitone Setup Table

This procedure builds upon the previous procedure.

1. Press Initialize Table > Number of Tones > 10 > Enter.

2. Press Done.

3. Highlight the value (On) in the State column for the tone in row 2.

4. Press Toggle State.

5. Highlight the value (0 dB) in the Power column for the tone in row 4.

6. Press Edit Item > –10 > dB.

7. Highlight the value (0) in the Phase column for the tone in row 4.

8. Press Edit Item > 123 > deg.

9. Press Apply Multitone.

 

Intermodulation
Distortion

Multitone
Channels

Whenever a change is made to a setting while the multitone generator is 
operating (Multitone Off On set to On), you must apply the change by 
pressing the Apply Multitone softkey before the updated waveform will be 
generated. When you apply a change, the baseband generator creates a 
multitone waveform using the new settings and replaces the existing 
waveform in ARB memory.
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You have now changed the number of tones to 10, disabled tone 2, and 
changed the power and phase of tone 4. Figure 9-4 shows what the multitone 
setup table display on the signal generator should look like after all steps have 
been completed. The spectrum analyzer should display a waveform similar to 
the one shown in Figure 9-5 on page 271. Notice that even–numbered 
multitone waveforms have a small amount of carrier feedthrough at the center 
carrier frequency.

Figure 9-4 

Figure 9-5 
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To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure 
the difference in power between the tones and their intermodulation distortion 
products. Carrier feedthrough can only be observed with even–numbered 
multitone waveforms.

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate 
of about 
100 to 200 ms. This will allow you to dynamically view the carrier 
feedthrough spike as you make adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments 
Off On to On.

3. Press I Offset and turn the rotary knob while observing the carrier 
feedthrough with the spectrum analyzer. Changing the I offset in the 
proper direction will reduce the feedthrough level. Adjust the level as low 
as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier 
feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier 
feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous 
setting.

7. Turn on waveform averaging.

8. Create a marker and place it on the peak of one of the end tones.

9. Create a delta marker and place it on the peak of the adjacent 
intermodulation product, which should be spaced 10 MHz from the 
marked tone.

10.Measure the power difference between the tone and its distortion 
product. 

You should now see a display that is similar to the one shown in Figure 9-6. 
Your optimized multitone signal can now be used to measure the IMD products 
generated by a device–under–test. 

Note that carrier feedthrough changes with time and temperature. Therefore, 
you will need to periodically readjust your I and Q offsets to keep the signal 
optimized.
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Figure 9-6 

To Determine Peak to Average Characteristics

This procedure describes how to set the phases of the tones in a multitone 
waveform and determine the peak to average characteristics by plotting the 
complementary cumulative distribution function (CCDF).

1. Press Mode > Multitone > Initialize Table > Number of Tones > 64 > Enter.

2. Press Freq Spacing > 20 > kHz.

3. Press Initialize Phase Fixed Random to Fixed.

4. Press Done.

5. Press Apply Multitone.

6. Press More (1 of 2) > ARB Setup > Waveform Utilities > Waveform 
Statistics > Plot CCDF.

You should now see a display that is similar to the one shown in Figure 
9-7. The CCDF plot displays the peak to average characteristics of the 
waveform with all phases set to zero.

Minimized
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Figure 9-7 CCDF Plot with Fixed Phase Set

7. Press Mode Setup > Initialize Table.

8. Press Initialize Phase Fixed Random to Random.

9. Press Random Seed Fixed Random to Random.

10.Press Done.

11.Press Apply Multitone.

12.Press More (1 of 2) > Waveform Statistics > Plot CCDF.

You should now see a display that is similar to the one shown in Figure 
9-8. The CCDF plot displays the peak to average characteristics of the 
waveform with randomly generated phases and a random seed. 

The random phase setup simulates the typically random nature of 
multitone waveforms. Notice that randomly distributed phases result in a 
much lower peak to average ratio than fixed phases. An increase in the 
number of tones with random phases will decrease the probability of a 
maximum peak power occurrence.

 

Peak
Power
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Figure 9-8 CCDF Plot with Random Phase Set
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10 Two–Tone Waveform Generator

In the following sections, this chapter describes the two–tone mode, which is 
available only in E8267D PSG vector signal generators with Option 601 or 602:

— “Overview” on page 278

— “Creating, Viewing, and Modifying Two–Tone Waveforms” on page 279

See also: “Arbitrary (ARB) Waveform File Headers” on page  106
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Overview
The two–tone mode builds a waveform that has two equal–powered CW 
signals, or tones. The default waveform has two tones that are symmetrically 
spaced from the center carrier frequency, and have user–defined amplitude, 
carrier frequency, and frequency separation settings. The user can also align 
the tones left or right, relative to the carrier frequency.

The two–tone waveform generator is designed for testing the intermodulation 
distortion characteristics of non–linear devices, such as mixers or amplifiers. 
Intermodulation distortion (IMD) occurs when non–linear devices with multiple 
input frequencies interfere with adjacent channels or cause unwanted outputs 
at other frequencies. The two–tone waveform generator supplies a signal 
whose IMD products can be measured using a spectrum analyzer and used as 
a reference when measuring the IMD generated by a device–under–test. 

Two–tone waveforms are created using the internal I/Q baseband generator 
and stored in ARB memory for playback. Although the two–tone mode 
generates a high–quality waveform, a small amount of IMD occurs. In addition 
to IMD, a small amount of carrier feedthrough and feedthrough–related IMD 
may be present when the spacing between the tones is centered on the carrier 
frequency. To minimize carrier feedthrough for a two–tone signal, you must 
manually adjust the I and Q offsets while observing the center carrier 
frequency with a spectrum analyzer. For measurements that require the 
absence of IMD and carrier feedthrough, you can create distortion–free 
multitone signals using Keysight Technologies’ Signal Studio software Option 
408.

For more information about two–tone waveform characteristics and the 
E8257D/67D PSG Vector Signal Generator two–tone format, download 
Application Note 1410 from our website by going to 
http://www.keysight.com and searching for “AN 1410” in Test & 
Measurement.
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Creating, Viewing, and Modifying Two–Tone Waveforms
This section describes how to set up, generate, and modify a two–tone 
waveform while viewing it with a spectrum analyzer. Although you can view a 
generated two–tone signal using any spectrum analyzer that has sufficient 
frequency range, an Keysight Technologies PSA Series High–Performance 
Spectrum Analyzer was used for this demonstration. Before generating your 
signal, connect the spectrum analyzer to the signal generator as shown in 
Figure 10-1.

Figure 10-1 Spectrum Analyzer Setup

To Create a Two–Tone Waveform

This procedure describes how to create and a basic, center–aligned, two–tone 
waveform.

1. Preset the signal generator.

2. Set the signal generator RF output frequency to 20 GHz.

3. Set the signal generator RF output amplitude to 0 dBm.

4. Press Mode > Two Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two–tone signal is now available at the signal generator RF OUTPUT 
connector. Figure 10-2 on page 280 shows what the signal generator display 
should look like after all steps have been completed. Notice that the T–TONE, 
I/Q, RF ON, and MOD ON annunciators are displayed and the parameter 
settings for the signal are shown in the status area of the signal generator 
display.



280                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Two–Tone Waveform Generator
Creating, Viewing, and Modifying Two–Tone Waveforms

Figure 10-2 

To View a Two–Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a 
two–tone waveform and its IMD products. Actual key presses will vary, 
depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 20 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a 4 dBm reference. 

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to 
expose the IMD products. A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.

7. Set the attenuation to 14 dB, so you’re not overdriving the input mixer on 
the spectrum analyzer. 

You should now see a two–tone waveform with a 20 GHz center carrier 
frequency that is similar to the one shown in Figure 10-3. You will also see IMD 
products at 10 MHz intervals above and below the generated tones, and a 
carrier feedthrough spike at the center frequency with carrier feedthrough 
distortion products at 10 MHz intervals above and below the center carrier 
frequency.
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Figure 10-3 

To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure 
the difference in power between the tones and their intermodulation distortion 
products. Carrier feedthrough only occurs with center–aligned two–tone 
waveforms.

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate 
of about 
100 to 200 ms. This will allow you to dynamically view the carrier 
feedthrough spike as you make adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments 
Off On to On.

3. Press I Offset and turn the rotary knob while observing the carrier 
feedthrough with the spectrum analyzer. Changing the I offset in the 
proper direction will reduce the feedthrough level. Adjust the level as low 
as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier 
feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier 
feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous 
setting.

Carrier
Feedthrough

Intermodulation
Distortion

Two–Tone
Channels

Carrier Feedthrough
Distortion



282                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Two–Tone Waveform Generator
Creating, Viewing, and Modifying Two–Tone Waveforms

7. Turn on waveform averaging.

8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent 
intermodulation product, which should be spaced 10 MHz from the 
marked tone.

10.Measure the power difference between the tone and its distortion 
product. 

You should now see a display that is similar to the one shown in Figure 10-4. 
Your optimized two–tone signal can now be used to measure the IMD products 
generated by a device–under–test. 

Note that carrier feedthrough changes with time and temperature. Therefore, 
you will need to periodically readjust your I and Q offsets to keep your signal 
optimized.

Figure 10-4 

To Change the Alignment of a Two–Tone Waveform

This procedure describes how to align a two–tone waveform left or right, 
relative to the center carrier frequency. Because the frequency of one of the 
tones is the same as the carrier frequency, this alignment eliminates carrier 
feedthrough. However, image frequency interference caused by left or right 
alignment may cause minor distortion of the two–tone signal. This procedure 
builds upon the previous procedure.

1. On the signal generator, press Mode Setup > Alignment Left Cent Right to 
Left.

2. Press Apply Settings to regenerate the waveform.

Minimized
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3. On the spectrum analyzer, temporarily turn off waveform averaging to 
refresh your view more quickly. You should now see a left–aligned 
two–tone waveform that is similar to the one shown in Figure 10-5.

Figure 10-5 

Whenever a change is made to a setting while the two–tone generator is 
operating (Two Tone Off On set to On), you must apply the change by 
pressing the Apply Settings softkey before the updated waveform will be 
generated. When you apply a change, the baseband generator creates a 
two–tone waveform using the new settings and replaces the existing 
waveform in ARB memory.
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11  AWGN Waveform Generator

In the following sections, this chapter contains examples for using the AWGN 
waveform generator, which is available only in E8267D vector PSGs with 
Options 601 or 602 and Option 403:

— “Arb Waveform Generator AWGN” on page 286

— “Real Time I/Q Baseband AWGN” on page 287

For adding real–time AWGN to waveforms using the Dual ARB player, see 
“Adding Real–Time Noise to a Dual ARB Waveform (E8267D with Option 
403)” on page  123
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Configuring the AWGN Generator
The AWGN (additive white Gaussian noise) generator is available for the Arb 
Waveform Generator mode and the Real Time I/Q Baseband mode. The AWGN 
generator can be configured with user–defined noise bandwidth, noise 
waveform length, and noise seed parameters. 

— Bandwidth – the noise bandwidth can be set from 50 kHz to 15 MHz.

— Waveform Length – the waveform length is the length in samples of the 
noise waveform. Longer waveform lengths provide more statistically correct 
noise waveforms. 

— Noise Seed – the noise seed selection can be either random or fixed. The 
noise seed determines whether the noise waveform data is repeatable 
(using the fixed selection) or random (using the random selection). 

When the AWGN generator is active, an annunciator, labeled AWGN, is 
displayed on the front panel of the signal generator. 

Arb Waveform Generator AWGN

1. Press Preset.

2. Press Mode > More (1 of 2) > AWGN > Arb Waveform Generator AWGN

3. Press Bandwidth > 1.25 > MHz.

4. Press Waveform Length > 131072.

5. Press Noise Seed Fixed Random until Random is highlighted.

This configures a randomly seeded AWGN waveform with a bandwidth of 1.25 
MHz and a waveform length of 131072 bits.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz. 

2. Set the output amplitude to −10 dBm. 

3. Press RF On/Off.

Generating the Waveform

Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the 
previous procedure. During waveform generation, the AWGN and I/Q 
annunciators activate and the AWGN waveform is stored in volatile ARB 
memory. The waveform is now modulating the RF carrier.
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Real Time I/Q Baseband AWGN

1. Press Preset.

2. Press Mode > More (1 of 2) > AWGN > Real Time I/Q Baseband AWGN

3. Press Bandwidth > 10 > MHz.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz. 

2. Set the output amplitude to −10 dBm. 

3. Press RF On/Off.

Generating the Waveform

Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the 
previous procedure. During waveform generation, the AWGN and I/Q 
annunciators activate. The waveform is now modulating the RF carrier.
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12  Peripheral Devices

This chapter provides information on peripheral devices used with PSG signal 
generators. The N5102A Baseband Studio digital signal interface module and 
extended frequency source module operation and features are described in the 
following sections:

N5102A Digital Signal Interface Module

— “Clock Timing” on page 290

— “Connecting the Clock Source and the Device Under Test” on page 301

— “Data Types” on page 303

— “Operating the N5102A Module in Output Mode” on page 304

— “Operating the N5102A Module in Input Mode” on page 314

Millimeter-Wave Source Modules

— “Using Keysight Millimeter-Wave Source Modules” on page  324

— “Using Other Source Modules” on page  326
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N5102A Digital Signal Interface Module

Clock Timing

This section describes how clocking for the digital data is provided. Clock 
timing information and diagrams are supplied for the different port 
configurations (serial, parallel, or parallel interleaved data transmission) and 
phase and skew settings. All settings for the interface module are available on 
the signal generator user interface (UI).

Clock and Sample Rates

A sample is a group of bits where the size of the sample is set using the Word 
Size softkey. The clock is the signal that tells when the bits of a sample are 
valid (in a non-transition state). The clock and sample rates are displayed in 
the first-level and data setup softkey menus. The clock rate and sample rate 
are usually the same. They will differ when serial mode is selected, or when 
there are multiple clocks per sample.

Figure 12-1 Data Setup Menu for a Parallel Port Configuration

The N5102A module clock rate is set using the Clock Rate softkey and has a 
range of 1 kHz to 
400 MHz. The sample rate is automatically calculated and has a range of 1 kHz 
to 100 MHz. These ranges can be smaller depending on logic type, data 
parameters, and clock configuration.

Maximum Clock Rates

The N5102A module maximum clock rate depends on the logic and signal 
type. Table 12-1 and 
Table 12-2 show the warranted rates and the maximum clock rates for the 
various logic and signal types. Notice that LVDS in the output mode using an IF 
signal is the only logic type where the warranted and maximum rates are the 
same.

Clock and sample ratesLeast significant bit
See the PSG User’s Guide for information information

Most significant bit
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The levels will degrade above the warranted level clock rates, but they may still 
be usable.

Serial Port Configuration Clock Rates

For a serial port configuration, the lower clock rate limit is determined by the 
word size (word size and sample size are synonymous), while the maximum 
clock rate limit remains constant at 150 MHz for LVTTL and CMOS logic types, 
and 400 MHz for an LVDS logic type. 

The reverse is true for the sample rate. The lower sample (word) rate value of 1 
kHz remains while the upper limit of the sample rate varies with the word size. 
For example, a five-bit sample for an LVTTL or CMOS logic type yields the 
following values in serial mode:

— Clock rate of 5 kHz through 150 MHz

— Sample rate of 1 kHz through 30 MHz

 Refer to Table 12-3 and Table 12-4, for the serial clock rates.

Table 12-1 Warranted Parallel Output Level Clock Rates and Maximum Clock Rates

Logic Type
Warranted Level Clock Rates Maximum Clock Rates (typical)

IQ Signal Type IF Signal Typea IQ Signal Type IF Signal Type

LVTTL and CMOS 100 MHz 100 MHz 150 MHz 150 MHz

LVDS 200 MHz 400 MHz 400 MHz 400 MHz

a. The IF signal type is not available for a serial port configuration.

Table 12-2 Warranted Parallel Input Level Clock Rates and Maximum Clock Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS 100 MHz 100 MHz

LVDS 100 MHz 400 MHz

Table 12-3 Output Serial Clock Rates

Logic Type Minimum Rate Maximum Rate 

LVDS 1 x (word size) kHz 400 MHz

LVTTL and CMOS 1 x (word size) kHz 150 MHz
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Parallel and Parallel Interleaved Port Configuration Clock Rates 

Parallel and parallel interleaved port configurations have other limiting factors 
for the clock and sample rates:

— logic type

— Clocks per sample selection

— IQ or IF digital signal type

Clocks per sample (clocks/sample) is the ratio of the clock to sample rate. For 
an IQ signal type, the sample rate is reduced by the clocks per sample value 
when the value is greater than one. For an IF signal or an input signal, clocks 
per sample is always set to one. Refer to Table 12-5 for the Output mode 
parallel and parallel interleaved port configuration clock rates.

For Input mode, the maximum clock rate is limited by the following factors:

— sample size

— data type

Table 12-4 Input Serial Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate 

LVDS Samples 1 x (word size) kHz 400

Pre-FIR 
Samples

1 x (word size) kHz the smaller of: 50a x (word size) MHz
or 
400 MHz

LVTTL and CMOS N/A 1 x (word size) kHz 150 MHz

a. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. 
Refer to “Input Mode” on page 303 for more information.

Table 12-5 Output Parallel and Parallel Interleaved Clock Rates

Logic Type Signal Type Minimum Rate Maximum Rate 

LVDS IQ 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
or 
400 MHz

IF 4 kHz 400 MHz

Other IQ 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz
or 
150 MHz

IF 4 kHz 150 MHz
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— selected filter for Pre-FIR Samples

Refer to Table 12-6 for the Input mode parallel and parallel interleaved port 
configuration clock rates.

Clock Source

The clock signal for the N5102A module is provided in one of three ways 
through the following selections:

— Internal: generated internally in the interface module (requires an external 
reference)

— External: generated externally through the Ext Clock In connector 

— Device: generated externally through the Device Interface connector

The clock source is selected using the N5102A module UI on the signal 
generator, as shown in 
Figure 12-2. 

Figure 12-2 Clock Source Selection

When you select a clock source, you must let the N5102A module know the 
frequency of the clock signal using the Clock Rate softkey. In the internal clock 
source mode, use this softkey to set the internal clock rate. For device and 
external clock sources, this softkey must reflect the frequency of the applied 
clock signal. 

Table 12-6 Input Parallel and Parallel Interleaved Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate 

N/A Samples 1 kHz 100 MHz

Pre-FIR Samples 1 kHz 50a MHz

a. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR 
Samples. Refer to “Input Mode” on page 303 for more information.

External and Device selection:
Set to match the clock rate
of the applied clock signal
Internal selection: Set the
internal clock rate

 

Internal clock source
selection: Set the frequency 
of the applied reference
signal.
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When the clock source is Internal, a frequency reference must be applied to the 
Freq Ref connector. The frequency of this applied signal needs to be specified 
using the Reference Frequency softkey, unless the current setting matches 
that of the applied signal. 

The selected clock source provides the interface module output clock signal at 
the Clock Out and the Device Interface connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting 
of arbitrary clock rates for the device under test. In general, the clock rate 
inside the PSG will be different from the interface module clock rate, so the 
interface module performs a rate conversion. An important aspect of this 
conversion is to have accurate clock rate information to avoid losing data. The 
module relies on relative clock accuracy, instead of absolute accuracy, that 
must be ensured by using a single frequency reference for all clock rates 
involved in the test setup. This can be implemented in various ways (see the 
five drawings in Figure 12-3 on page 295), but whatever way it is implemented, 
the clock inside the signal generator must have the same base frequency 
reference as the clock used by the device under test.

PSG Frequency Reference Connections

When a frequency reference is connected to the PSG, it is applied to one of two 
rear-panel connectors:

— 10 MHz IN

— BASEBAND GEN REF IN

The BASEBAND GEN REF IN connector will accept a frequency reference in the 
range of 1 to 100 MHz. If the external or device under test clock source cannot 
provide or accept a frequency reference, that clock signal can be applied to this 
connector and used as the frequency reference.

Whenever an external clock signal or frequency reference is connected to the 
BASEBAND GEN REF IN connector, its frequency needs to be entered into the 
current signal generator modulation format. For information on the 
BASEBAND GEN REF IN connector refer to “24. BASEBAND GEN CLK IN” on 
page 52. For information on the associated softkeys and fields for entering the 
frequency of the applied clock signal or frequency reference, refer to the 
Keysight PSG Signal Generators Key Reference.
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Figure 12-3 Frequency Reference Setup Diagrams for the N5102A Module Clock Signal

NOTE: Use only one of the two signal generator frequency reference inputs.

Internally Generated Clock

Device (DUT) Supplied Clock

Externally Supplied Clock

NOTE: Use only one of the two signal generator frequency reference inputs.
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Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A 
sample period consists of an I and Q sample). For parallel data transmissions, 
you can select one, two, or four clocks per sample. For clocks per sample 
greater than one, the I and Q samples are held constant to accommodate the 
additional clock periods. This reduces the sample rate relative to the clock rate 
by a factor equal to the clocks per sample selection. For example, when four is 
selected, the sample rate is reduced by a factor of four (sample rate to clock 
rate ratio). Figure 12-4 demonstrates the clock timing for each clocks per 
sample selection. For input mode, the clocks per sample setting is always one.

Figure 12-4 Clock Sample Timing for Parallel Port Configuration

1 Sample Period

Q sample

1 Clock Per Sample

1 Clock

Clock and sample rates are the same

I sample

Clock

4 bits per word 

4 bits per word 
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1 Sample Period

4 Clocks Per Sample

4 Clocks

Sample rate decreases by a factor of four

I sample 

Q sample 

Clock

4 bits per word 

4 bits per word 

1 Sample Period

2 Clocks Per Sample

2 Clocks

I sample

Q sample 

Sample rate decreases by a factor of two

Clock

4 bits per word

4 bits per word
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Clock Timing for Parallel Interleaved Data

The N5102A module provides the capability to interleave the digital I and Q 
samples. There are two choices for interleaving:

— IQ, where the I sample is transmitted first

— QI, where the Q sample is transmitted first

When parallel interleaved is selected, all samples are transmitted on the I data 
lines. This effectively transmits the same number of samples during a sample 
period on half the number of data lines as compared to non-interleaved 
samples. (A sample period consists of an I and Q sample.) Clocks per sample is 
still a valid parameter for parallel interleaved transmissions and creates a 
reduction in the sample rate relative to the clock rate. The clocks per sample 
selection is the ratio of the reduction. Figure 12-5 shows each of the clocks per 
sample selections, for a parallel IQ interleaved port configuration, using a word 
sized of four bits and the clock timing relative to the I and Q samples. For a 
parallel QI interleaved port configuration, just reverse the I and Q sample 
positions. For input mode, the clocks per sample setting is always one.

Figure 12-5 Clock Timing for a Parallel IQ Interleaved Port Configuration

Q sample 
4 bits per word 

I sample 
4 bits per word 

1 Sample Period

1 Clock Per Sample

1 Clock

The I sample is transmitted on one clock transition and the Q sample is transmitted on the

Clock

other transition; the sample and clock rates are the same.
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1 Sample Period

4 Clocks Per Sample

4 Clocks

The I sample is transmitted for the first two clock periods and the Q sample is transmitted during the se

Clock

Q sample 
4 bits per word 

I sample 
4 bits per word 

clock periods; the sample rate is decreased by a factor of four.

1 Sample Period

2 Clocks Per Sample

2 Clocks

The I sample is transmitted for one clock period and the Q sample is transmitted during the second 

Clock

Q sample 
4 bits per word 

I sample 
4 bits per word 

clock period; the sample rate decreases by a factor of two.
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Clock Timing for Serial Data

Figure 12-6 shows the clock timing for a serial port configuration. Notice that 
the serial transmission includes frame pulses that mark the beginning of each 
sample while the clock delineates the beginning of each bit. For serial 
transmission, the clock and the bit rates are the same, but the sample rate 
varies depending on the number of bits per word that are entered using the 
Word Size softkey. The number of bits per word is the same as the number of 
bits per sample.

Figure 12-6 Clock Timing for a Serial Port Configuration

Clock Timing for Phase and Skew Adjustments

The N5102A module provides phase and skew adjustments for the clock 
relative to the data and can be used to align the clock with the valid portion of 
the data. The phase has a 90 degree resolution (0, 90, 180, and 270 degree 
selections) for clock rates from 10 to 200 MHz and a 180 degree resolution (0 
and 180 degree selections) for clock rates below 10 MHz and greater than 200 
MHz. 

The skew is displayed in nanoseconds with a maximum range of ±5 ns using a 
maximum of ±127 discrete steps. Both the skew range and the number of 
discrete steps are variable with a dependency on the clock rate. The skew 
range decreases as the clock rate is increased and increases as the clock rate 
is decreased. The maximum skew range is reached at a clock rate of 
approximately 99 MHz and is maintained down to a clock rate of 25 MHz. For 
clock rates below 25 MHz, the skew adjustment is unavailable. 

A discrete step is calculated using the following formula:

The number of discrete steps required to reach the maximum skew range 
decreases at lower frequencies. For example, at a clock rate of 50 MHz, 127 
steps would exceed the maximum skew range of ±5 ns, so the actual number 
of discrete steps would be less than 127. 

Clock

4 bits per word 

1 Sample

Frame Marker

Data Bits

 1
256 Clock Rate×
-----------------------------------------
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Figure 12-7 is an example of a phase and skew adjustment and shows the 
original clock and its phase position relative to the data after each adjustment. 
Notice that the skew adjustment adds to the phase setting.

Figure 12-7 Clock Phase and Skew Adjustments

Connecting the Clock Source and the Device Under Test

As shown in Figure 12-3 on page 295, there are numerous ways to provide a 
common frequency reference to the system components (PSG, N5102A 
module, and the device under test). Figure 12-8 shows an example setup 
where the signal generator supplies the common frequency reference and the 
N5102A module provides the clock to the device.

See the N5102A Digital Signal Interface Module Installation Guide for 
detailed information on device interface connections.

Clock skew adjustment
90 degree phase adjustment

Clock

Phase adjusted

skew adjusted

clock

clock

Data

Phase and

The Device Interface connector on the interface module communicates 
using high speed digital data. Use ESD precautions to eliminate potential 
damage when making connections.

You must disconnect the digital bus cable and the digital module while 
downloading firmware to the signal generator.
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Figure 12-8 Example Setup using the PSG 10 MHz Frequency Reference

1. Refer to the five setup diagrams in Figure 12-3 on page 295 and connect 
the frequency reference cable according to the clock source.

2. If an external clock source is used, connect the external clock signal to the 
Ext Clock In connector on the interface module.

3. Select the break-out board that has the output connector suited for the 
application. See the N5102A Digital Signal Interface Module Installation 
Guide for information on breakout boards.

4. Refer to Figure 12-8. Connect the breakout board to the N5102A module’s 
Device Interface connector.

5. Connect the device to the break-out board. See the N5102A Digital Signal 
Interface Module Installation Guide for information on breakout board 
connectivity.

Signal generator 10 MHz Out

Freq Ref connector

Device interface connection

Device under test
Break-out board

User furnished ribbon cable(s) connect 
between the device and break-out board.

Common Freq Ref cable

The clock to the device is in the ribbon
cable.

If the Device Interface mating connector is used with the device under test, 
refer to Figure 12-8 for the device interface connection and connect the 
device to the N5102A module. Then proceed to “Operating the N5102A 
Module in Output Mode” on page 304 or “Operating the N5102A Module in 
Input Mode” on page 314.
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Data Types

The following block diagram indicates where in the PSG signal generation 
process the data is injected for input mode or tapped for output mode.

Output Mode

When using an ARB format, the data type is always Samples and no filtering is 
applied to the data samples.The samples are sent to the digital module at the 
ARB sample clock rate.

For real-time formats, choosing Samples as the data type will send filtered 
samples to the digital module at a rate between 50 MHz and 100 MHz. 
Selecting Pre-FIR Samples, sends unfiltered samples to the digital module at a 
rate equal to the sample rate of the current format.

Input Mode

When the data type is Samples, the data samples coming through the digital 
module are injected at a point that bypasses the filtering process. 

If Pre-FIR Samples is selected, the data samples are injected before the 
filtering process. The maximum rate will be determined by the selected filter. 
Refer to Table 12-7.

Data FIR

DACs

RF

Samples
Samples

Output 

Samples Samples
Pre-FIR

Mode

Filtering

I,Q

Modulator

LO

Input 
Mode

Pre-FIR

PSG

Generator I/Q
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 The Filter softkey accesses a menu that enables you set the desired filtering 
parameters. 

Operating the N5102A Module in Output Mode

This section shows how to set the parameters for the N5102A Option 003 
module in output mode using the front panel keys. Each procedure contains a 
figure that shows the softkey menu structure for the interface module function 
being performed. 

Setting up the Signal Generator Baseband Data

The digital signal interface module receives data from a baseband source and 
outputs a digital IQ or digital IF signal relative to the selected logic type. 
Because the PSG provides the baseband data, the first procedure in operating 
the interface module is configuring the PSG using one of the real-time or ARB 
modulation formats, or playing back a stored file using the Dual ARB player. 
For information on setting up real-time or ARB waveforms, or to learn about 
using the Dual ARB player, refer to the appropriate chapter in this guide.

1. Preset the signal generator.

2. Select the modulation format (TDMA, Custom, and so forth) and set the 
desired parameters.

3. Turn-on the modulation format.

Accessing the N5102A Module User Interface

Press Aux Fctn > N5102A Interface.

Table 12-7 Maximum Sample Rate for Selected Filter

Filter Maximum Rate

Gaussian
Nyquist
Root Nyquist
Rectangle
Edge
UN3/4 GSM Gaussian
IS-95
IS 95 w/EQ

50 MHz

IS-95 Mod
IS-95 Mod w/EQ

25 MHz

APCO 25 C4FM 12.5 MHz
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This accesses the UI (first-level softkey menu shown in Figure 12-9) that is 
used to configure the digital signal interface module. Notice the graphic in the 
PSG display showing a setup where the N5102A module is generating its own 
internal clock signal. This graphic changes to reflect the current clock source 
selection.

Figure 12-9 First-Level Softkey Menu

Choosing the Logic Type and Port Configuration

Figure 12-10 Logic and Port Configuration Softkey Menus

1. Refer to Figure 12-10. Press the Logic Type softkey.

Line is grayed out until the N5102A module interface is turned on
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From this menu, choose a logic type.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic 
types, and a softkey selection appears requesting confirmation.

3. Refer to Figure 12-10. Press the Port Configuration softkey.

In this menu, select either a serial, parallel, or parallel interleaved data 
transmission.

4. Select the port configuration for the device.

Selecting the Output Direction

Press Data Setup > Direction Input Output to Output and press Return. 

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have 
self-explanatory names are generally not mentioned. For example, the Word 
Size softkey. For more information on all of the softkeys, refer to Keysight PSG 
Signal Generators Key Reference.

1. Refer to Figure 12-11. Press the Data Setup softkey.

Changing the logic type can increase or decrease the signal voltage level 
going to the device under test. To avoid damaging the device and/or the 
N5102A module, ensure that both are capable of handling the voltage 
change.

Within the data and clock setup softkey menus, only softkeys that are 
relative to the current configuration are active. Softkeys that are grayed 
out are not available for the current setup. Refer to the help text to 
determine which parameter is causing the softkey to be unavailable. To 
get help information, press the Help hardkey, then press the unavailable 
softkey.

If Option 003 is the only option installed, the direction softkey will be unavailable and the mode 
will always be output. With both Option 003 (output mode) and Option 004 (input mode) 
installed, the default direction is output. 
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Figure 12-11 Data Setup Menu Location

This softkey menu accesses the various parameters that govern the data 
received by the device under test. The status area of the display shows the 
number of data lines used for both I and Q along with the clock position 
relative to the data. When the port configuration is parallel or parallel 
interleaved, the number of data lines indicated is equivalent to the word 
(sample) size. When the port configuration is serial, the display will show 
that only one I and one Q data line is being used along with the frame 
marker that delineates the beginning of a sample. Figure 12-12 shows the 
data setup menu structure.

Accesses the data setup menu
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Figure 12-12 Data Setup Softkey Menu with Parallel Port Configuration

2. If a real-time modulation format is being used, press the Data Type 
softkey. (This softkey is inactive when an ARB modulation format is turned 
on.)

In this menu, select whether the real-time baseband data from the signal 
generator is either filtered (Samples) or unfiltered (Pre-FIR Samples). The 
selection depends on the test needs. The Samples selection provides FIR 
filtered baseband samples based on the communication standard of the 
active modulation format. This is the preset selection and the one most 
commonly used. However if the device being tested already incorporates 
FIR filters, the Pre-FIR Samples selection should be used to avoid double 
filtering.

3. Select the data type that is appropriate for the test.

4. Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 
2’s complement allows both positive and negative data values. Use the 
Offset Binary selection when components cannot process negative values.

5. Select the numeric format required for the test.

6. Press the More (1 of 2) softkey.

Inactive for a serial port

Frame polarity is active

configuration 

for a serial port configuration

Inactive for ARB formats

Inactive for word 
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From this softkey menu, select the bit order, swap I and Q, select the 
polarity of the transmitted data, and access menus that provide data 
negation, scaling, gain, offset, and IQ rotation adjustments.

7. Press the Data Negation softkey.

Negation differs from changing the I and Q polarity. Applied to a sample, 
negation changes the affected sample by expressing it in the two's 
complement form, multiplying it by negative one, and converting the 
sample back to the selected numeric format. This can be done for I 
samples, Q samples, or both. 

 The choice to use negation is dependent on the device being tested and 
how it needs to receive the data.

8. Press the Gain, Offset & Scaling softkey.

Use the softkeys in this menu for the following functions:

— reduce sample values for both I and Q using the Scaling softkey

— increase or decrease the sample values independently for I and Q 
using the I Gain and Q Gain softkeys

— compensate for or add a DC offset using the I Offset and Q Offset 
softkeys

— rotate the data on the IQ plane using the Rotation softkey

9. Make any required scaling, gain, offset, or rotation adjustments to properly 
test the device.

10.Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal

1. Refer to Figure 12-13. Press the Clock Setup softkey.

Figure 12-13 Clock Setup Menu Location

Accesses the Clock Setup Menu
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From this softkey menu, set all of the clock parameters that synchronize 
the clocks between the N5102A module and the PSG. You can also 
change the clock signal phase so the clock occurs during the valid portion 
of the data. Figure 12-14 shows the clock setup menu.

Figure 12-14 Clock Setup Softkey Menu for a Parallel Port Configuration

The top graphic on the display shows the current clock source that 
provides the output clock signal at the Clock Out and Device Interface 
connectors. The graphic changes to reflect the clock source selection 
discussed later in this procedure. The bottom graphic shows the clock 
position relative to the data. The displayed clock signal will change to 
reflect the following:

— clocks per sample selection

— clock phase choice

— clock skew adjustment

— clock polarity selection

If the device or external clock does not match the frequency, one of the 
following error messages will appear on the PSG:

805  Digital module output FIFO overflow 
error; There are more samples being 
produced than can be consumed at the 
current clock rate. Verify that the 
digital module clock is set up 
properly.

Inactive for a serial port configuration and the IF signal type

Active for only the Internal clock source selection

Inactive for clock rates below 25 MHz

Inactive for clock rates 
below 
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This error is reported when the output FIFO is 
overflowing in the

digital module. This error can be generated if an 
external clock

or its reference is not set up properly, or if the 
internal VCO is

unlocked.

806  Digital module output FIFO underflow 
error; There are not enough samples 
being produced for the current clock 
rate. Verify that the digital module 
clock is set up properly.
This error is reported when the output FIFO is 
underflowing in the digital module. This error can 
be generated if an external clock or its reference is 
not set up properly, or if the internal VCO is 
unlocked.

2. If the port configuration is parallel or parallel interleaved, using an IQ 
signal type, press the 
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DACs 
require the ability to clock multiple times for each sample; having a clocks 
per sample value greater than one reduces the sample rate by a factor 
equal to the selected number of clocks per sample. The sample rate is 
viewed on the first-level and Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.

4. Press the Clock Source softkey.

From this menu, select the clock signal source. With each selection, the 
clock routing display in the signal generator clock setup menu will change 
to reflect the current clock source. This will be indicated by a change in 
the graphic.

5. Select the clock source.

If External or Device is Selected

Press the Clock Rate softkey and enter the clock rate of the externally 
applied clock signal. 

The clock phase and clock skew may need to be adjusted each time the clock rate setting is 
changed. Refer to “Clock Timing for Phase and Skew Adjustments” on page  
300.
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For the External selection, the signal is supplied by an external clock 
source and applied to the Ext Clock In connector. For the Device selection, 
the clock signal is supplied through the Device Interface connector, 
generally by the device under test.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its 
own internal clock signal. The reference frequency signal must be applied 
to the Freq Ref connector on the digital module.

a. Press the Reference Frequency softkey and enter the frequency of 
the externally applied frequency reference.

b. Press the Clock Rate softkey and enter the appropriate clock rate.

Table 12-8 provides a quick view of the settings and connections 
associated with each clock source selection.

6. Press the Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock 
relative to the data in 90 degree increments. The selections provide a 
coarse adjustment for positioning the clock on the valid portion of the 
data. Selecting 180 degrees is the same as selecting a negative clock 
polarity.

The 90 degree and 270 degree selections are not available when the clock 
rate is set below 10 MHz or above 200 MHz. If 90 degrees or 270 degrees 
is selected when the clock rate is set below 10 MHz or above 200 MHz, the 
phase will change to 0 degrees or 180 degrees, respectively. 

Table 12-8 Clock Source Settings and Connectors

Clock 
Source

Softkeys N5102A Module Connection

Reference 
Frequency

Clock Ratea

a. For the Internal selection, this sets the internal clock rate. For the External and Device 
selections, this tells the interface module the rate of the applied clock signal.

Freq Ref Ext Clock In Device 
Interface

External x x

Device x x

Internalb

b. There should be no clock signal applied to the Ext Clock In connector.

x x x

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  300.
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7. Enter the required phase adjustment.

8. Press the Return softkey to return to the clock setup menu.

9. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase 
position. The skew is a phase adjustment using increments of time. This 
enables greater skew adjustment capability at higher clock rates. For 
clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock 
rate. Refer to “Clock Timing for Phase and Skew Adjustments” on page  
300 for more information on skew settings.

10.Enter the skew adjustment that best positions the clock with the valid 
portion of the data.

11.Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the 
negative clock transition. This has the same affect as selecting the 180 
degree phase adjustment.

12.Make the clock polarity selection that is required for the device being 
tested.

13.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu 
graphic. For example, if the device is the new clock source, the graphic will 
show that the frequency reference is now connected to the DUT and the 
DUT has an input clock line going to the N5102A module.

Generating Digital Data

Press the N5102A Off On softkey to On.

Digital data is now being transferred through the N5102A module to the 
device. The green status light should be blinking. This indicates that the data 
lines are active. If the status light is solidly illuminated (not blinking), all the 
data lines are inactive. The status light comes on and stays on (blinking or 
solid) after the first time the N5102A module is turned on (N5102A Off On to 
On). The status light will stay on until the module is disconnected from its 
power supply.

The interface module can only be turned on while a modulation format is 
active. If the modulation format is turned off while the module is on, the 
module will turn off and an error will be reported.

If changes are made to the baseband data parameters, it is recommended 
that you first disable the digital output (N5102A Off On softkey to Off) to 
avoid exposing your device and the N5102A module to the signal 
variations that may occur during the parameter changes.
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Operating the N5102A Module in Input Mode

This section shows how to set the parameters for the N5102A Option 004 
module using the signal generator UI in the input direction. Each procedure 
contains a figure that shows the softkey menu structure for the interface 
module function being performed.

Refer to “Connecting the Clock Source and the Device Under Test” on 
page 301 and configure the test setup.

Accessing the N5102A Module User Interface

All parameters for the N5102A module are set with softkeys on the PSG signal 
generator.

Press Aux Fctn > N5102A Interface.

This accesses the UI (first-level softkey menu shown in Figure 12-15) that is 
used to configure the digital signal interface module. Notice the graphic, in the 
PSG display, showing a setup where the N5102A module is generating its own 
internal clock signal. This graphic changes to reflect the current clock source 
selection.

Figure 12-15 First-Level Softkey Menu

Selecting the Input Direction

If both Option 003 (output mode) and Option 004 (input mode) are installed, 
you must select the input direction.

Press Data Setup > Direction Input Output to Input and press Return. 

Line is grayed out until the N5102A module interface is turned on

Internal clock going to the DUT

If only Option 004 is installed, the direction softkey will be unavailable and 
the mode will always be input. 



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 315

Peripheral Devices
N5102A Digital Signal Interface Module

Choosing the Logic Type and Port Configuration

Figure 12-16 Logic and Port Configuration Softkey Menus

1. Refer to Figure 12-16. Press the Logic Type softkey.

From this menu, choose a logic type.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic 
types, and a softkey selection appears asking for confirmation.

3. Refer to Figure 12-16. Press the Port Configuration softkey.

In this menu, select either a serial, parallel, or parallel interleaved data 
transmission.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Press the Clock Setup softkey, as shown in Figure 12-17. 

Changing the logic type can increase or decrease the signal voltage level. 
To avoid damaging the device and/or the N5102A module, ensure that 
both are capable of handling the voltage change.

Within the data and clock setup softkey menus, only softkeys that are 
relative to the current configuration are active. Softkeys that are grayed 
out are not available for the current setup. Refer to the help text to 
determine which parameter is causing the softkey to be unavailable. To 
get help information, press the Help hardkey, then press the unavailable 
softkey.
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Figure 12-17 Clock Setup Menu Location

From this softkey menu, set all of the clock parameters that synchronize 
the data between the N5102A module and the device. From this menu, the 
clock signal phase can be changed so the clock occurs during the valid 
portion of the data. Figure 12-18 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the 
following error messages will appear on the PSG:

803  Digital module input FIFO overflow 
error; There are more samples being 
produced than can be consumed at the 
current clock rate. Verify that the 
digital module clock is set up 
properly.
This error is reported when the digital module clock 
setup is not

synchronized with the rate the samples are entering 
the digital

module. Verify that the input clock rate matches 
the specified

clock rate under the clock setup menu.

804  Digital module input FIFO underflow 
error; There are not enough samples 
being produced for the current clock 
rate. Verify that the digital module 
clock is set up properly.
This error is reported when the digital module clock 
setup is not

synchronized with the rate the samples are entering 
the digital

module. Verify that the input clock rate matches 
the specified

Accesses the Clock Setup Menu
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clock rate under the clock setup menu.

Figure 12-18 Clock Setup Softkey Menu for a Parallel Port Configuration

The top graphic on the display shows the current clock source that 
provides the output clock signal at the Clock Out and Device Interface 
connectors. The graphic changes to reflect the clock source selection 
discussed later in this procedure. The bottom graphic shows the clock 
edges relative to the data. The displayed clock signal will change to reflect 
the following:

— clock phase choice

— clock skew adjustment

— clock polarity selection

2. Press the Clock Source softkey.

From this menu, select the clock signal source. With each selection, the 
clock routing display in the signal generator clock setup menu will change 
to reflect the current clock source. This will be indicated by a change in 
the graphic.

3. Select the clock source.

If External or Device is Selected

Inactive for Input mode

Active for only the Internal clock source selection

Inactive for clock rates below 25 MHz

Inactive for clock rates below 
10 MHz and above 200 MHz
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Press the Clock Rate softkey and enter the clock rate of the externally 
applied clock signal. 

For the External selection, the signal is supplied by an external clock 
source and applied to the Ext Clock In connector. For the Device selection, 
the clock signal is supplied through the Device Interface connector, 
generally by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its 
own internal clock signal. The reference frequency signal must be applied 
to the Freq Ref connector on the digital module.

a. Press the Reference Frequency softkey and enter the frequency of 
the externally applied frequency reference.

b. Press the Clock Rate softkey and enter the appropriate clock rate.

Table 12-9 provides a quick view of the settings and connections 
associated with each clock source selection.

4. Press the Clock Phase softkey.

From the menu that appears, the phase of the clock relative to the data 
can be changed in 90 degree increments. The selections provide a coarse 
adjustment for positioning the clock on the valid portion of the data. 
Selecting 180 degrees is the same as selecting a negative clock polarity.

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  300.

Table 12-9 Clock Source Settings and Connectors

Clock 
Source

Softkeys N5102A Module Connection

Reference 
Frequency

Clock Ratea

a. For the Internal selection, this sets the internal clock rate. For the External and Device 
selections, this tells the interface module the rate of the applied clock signal.

Freq Ref Ext Clock In Device 
Interface

External x x

Device x x

Internalb

b. There should be no clock signal applied to the Ext Clock In connector when Internal is 
being used.

x x x
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The 90 degree and 270 degree selections are not available when the clock 
rate is set below 10 MHz or above 200 MHz. If 90 degrees or 270 degrees 
is selected when the clock rate is set below 10 MHz or above 200 MHz, the 
phase will change to 0 degrees or 180 degrees, respectively. 

5. Enter the required phase adjustment.

6. Press the Return softkey to return to the clock setup menu.

7. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase 
position. The skew is a phase adjustment using increments of time. This 
enables greater skew adjustment capability at higher clock rates. For 
clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock 
rate. Refer to “Clock Timing for Phase and Skew Adjustments” on page  
300 for more information on skew settings.

8. Enter the skew adjustment that best positions the clock with the valid 
portion of the data.

9. Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the 
negative clock transition. This has the same affect as selecting the 180 
degree phase adjustment.

10.Make the clock polarity selection that is required for the device being 
tested.

11.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu 
graphic. For example, if the device is the new clock source, you will see 
that the frequency reference is now connected to the DUT and the DUT 
has an input clock line going to the N5102A module.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have 
self-explanatory names (for example, the Word Size softkey) are generally not 
mentioned. For more information on all of the softkeys, refer to the Keysight 
PSG Signal Generators Key Reference.

1. Refer to Figure 12-19. Press the Data Setup softkey.

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  300.
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Figure 12-19 Data Setup Menu Location

This softkey menu accesses the various parameters that govern the data 
received by the PSG. The status area of the display shows the number of 
data lines used for both I and Q along with the clock position relative to 
the data. Figure 12-20 shows the data setup menu structure.

Figure 12-20 Data Setup Softkey Menu with Parallel Port Configuration

2. Press the Data Type softkey. 

Accesses the data setup menu

Inactive for a serial port

Frame polarity is active

configuration 

for a serial port configuration

Only available when the 
N5102A digital module is 
turned on

Only available when 
data type is 
Pre-FIR Samples
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In this menu, select the data type to be either filtered (Samples) or 
unfiltered (Pre-FIR Samples). The selection is dependent on the test needs 
and the device under test. However if the device being tested already 
incorporates FIR filters, the Pre-FIR Samples selection should be used to 
avoid double filtering. Refer to “Data Types” on page 303, for more 
information.

3. Select the data type that is appropriate for the test needs.

4. Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 
2’s complement allows both positive and negative data values. Use the 
Offset Binary selection when components cannot process negative values.

5. Select the numeric format required for the test.

6. Press the More (1 of 2) softkey.

From this softkey menu, select the bit order, swap I and Q, the polarity of 
the data, and access menus that provides data negation, scaling, and 
filtering parameters.
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7. Press the Data Negation softkey.

Negation differs from changing the I and Q polarity. Applied to a sample, 
negation changes the affected sample by expressing it in the two's 
complement form, multiplying it by negative one, and converting the 
sample back to the selected numeric format. This can be done for I 
samples, Q samples, or both. 

 The choice to use negation is dependent on the device being tested.

8. To access I/Q scaling and filter parameters, press Return > N5102A Off On 
to On. This will invoke the real time Custom format in the PSG baseband 
generator. This is needed to set the filter parameters when Pre-FIR 
Samples is selected as the data type. 

9. Press the Baseband Setup softkey.

Use this softkey menu to adjust the I/Q scaling and access filter 
parameters. If the selected data type is Samples, the Filter softkey is 
grayed out (inactive).

Digital Data

If the N5102A digital module is not on, press Return > Return > N5102A Off 
On to On.

Digital data is now being transferred through the N5102A module to the PSG. 
The green status light should be blinking. This indicates that the data lines are 
active. If the status light is solidly illuminated (not blinking), all the data lines 
are inactive. The status light comes on and stays on (blinking or solid) after the 
first time the N5102A module is turned on (N5102A Off On softkey to On). The 
status light will stay on until the module is disconnected from its power supply.

If changes are made to the baseband data parameters, it is recommended 
that you first disable the digital output (N5102A Off On softkey to Off) to 
avoid exposing the device and the N5102A module to the signal variations 
that may occur during the parameter changes.
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Millimeter-Wave Source Modules
You can extend the signal generator’s RF frequency using an Keysight 8355x 
series millimeter-wave source module or any other external source module. 
The output frequency range depends on the frequency range of the mm-wave 
source module. This section contains the following procedures:

— Using Keysight Millimeter-Wave Source Modules

— Using Other Source Modules

Using Keysight Millimeter-Wave Source Modules

The Keysight 8355x series millimeter-wave source module connects to the 
signal generator’s rear panel SOURCE MODULE INTERFACE connector and 
allows for direct communication between the instruments as well as providing 
for automatic leveling control of the source module. If you want to use an 
8355x series source module without the automatic leveling or multiplier 
selection features, then refer to the section “Using Other Source Modules” on 
page 326.

The following is a list of equipment required for extending the frequency range 
of the signal generator:

— Keysight 8355x series millimeter-wave source module

— Keysight 8349B microwave amplifier (required only for the E8257D PSG 
without Options 1EA, 1EU, or 521)

— RF output cables and adapters as required

Setting Up the External Source Module

1. Turn off the signal generator’s line power.

2. Connect the equipment as shown.

— E8257D PSG without Options 1EA, 1EU, or 521 

— E8257D PSG with Options 1EA, 1EU, 521, or E8267D PSG uses the 
setup in Figure 12-22.

Maximum insertion loss for cables and adapters connected to the E8267D 
PSG or E8257D PSG with Options 1EA, 1EU, or 521, should be less than 
1.5 dB. This will ensure maximum power from the external source module.

To prevent damage to the signal generator, turn off the line power to the 
signal generator before connecting the source module interface cable to 
the rear panel SOURCE MODULE INTERFACE connector.
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Figure 12-21 E8257D PSG without Option 1EA, 1EU, or 521

Figure 12-22 Setup for E8267D PSG and E8257D PSG with Option 1EA, 1EU, or 521
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Configuring the Signal Generator

1. Turn on the signal generator’s line power. 

2. Press Frequency > (3 of 3) > Source Module, toggle the Keysight 8355x 
Source Module Off On softkey to On. The signal generator will: 

— recognize the Keysight mm-wave source module,

— switch the leveling mode to external/source module (power is 
leveled at the mm-wave source module output),

— set the mm-wave source module frequency and amplitude to the 
source module’s preset values, and

— display the RF output frequency and amplitude values available at 
the mm-wave source module output when enabled

When the 8355x series mm-wave source is enable via the front panel 
Keysight 8355x Source Module Off On softkey, the MMOD indicator in the 
FREQUENCY area and the MM indicator in the AMPLITUDE area will 
appear on the signal generator’s display. 

3. If the RF OFF annunciator is displayed, press RF On/Off.

Leveled power should be available at the output of the millimeter-wave source 
module.

To obtain flatness-corrected power, refer to “Creating and Applying User 
Flatness Correction” on page 166.

Using Other Source Modules

Use the following procedure to extend the frequency range of the PSG with any 
external source module, or to use the Keysight 8355x series millimeter-wave 
source module’s without automatic leveling. The following is a list of 
equipment required for extending the frequency range of the signal generator:

— external millimeter-wave source module

— Keysight 8349B or other microwave amplifier (required only for the 
E8257D PSG without Option 1EA, 1EU, or 521)

— RF output cables and adapters as required

Setting Up the External Source Module

1. Turn off the signal generator’s line power.

2. Connect the equipment as shown.

— E8257D PSG without Option 1EA, 1EU, or 521

Refer to the mm-wave source module specifications for the specific 
frequency and amplitude ranges.



326                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Peripheral Devices
Millimeter-Wave Source Modules

— E8257D PSG with Option 1EA or E8267D PSG uses the setup in 
Figure 12-24.

Figure 12-23 E8257D PSG without Option 1EA, 1EU, or 521

Figure 12-24 Setup for E8267D PSG and E8257D PSG with Option 1EA, 1EU, or 521

Configuring the Signal Generator

The following procedure configures a PSG for use with any external source 
module that has a WR (waveguide rectangular) frequency range of 90-140 
GHz. You can modify the frequency range to match your source module.
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1. Turn on the signal generator’s line power. 

2. Press Frequency > (3 of 3) > Source Module. Toggle the Keysight 8355x 
Source Module Off On softkey to Off.

3. Toggle the OEM Source Off On softkey to On. 

4. Press OEM Source Module Config > Standard WR Freq Bands > WR8 
90-140GHz. 

The selections in the Standard WR Freq Bands menu are pre-defined 
frequency ranges and multipliers for the most common external source 
module frequency ranges. They are provided for setup convenience. If your 
source module has a frequency range not listed in the list of pre-defined 
setups, use the Min Band Freq, Max Band Freq, and Freq Multiplier 
softkeys to manually set the range and PSG frequency display multiplier. 
For more information on these manual settings, refer to the E8257D/67D 
PSG Signal Generators Key Reference. 

5. If the RF OFF annunciator is displayed, press RF On/Off.

To obtain flatness-corrected power, refer to “Creating and Applying User 
Flatness Correction” on page 166.

Automatic leveling at the source module output is not available with the 
OEM Source Module selection.
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13  Troubleshooting

This chapter provides basic troubleshooting information for Keysight PSG 
signal generators. If you do not find a solution here, refer to the Keysight PSG 
Signal Generators Service Guide.

— “RF Output Power Problems” on page 330

— “No Modulation at the RF Output” on page 336

— “Sweep Problems” on page 337

— “Data Storage Problems” on page 339

— “Cannot Turn Off Help Mode” on page 340

— “Signal Generator Locks Up” on page 341

— “Error Messages” on page 343

— “Contacting Keysight Sales and Service Offices” on page 346

— “Returning a Signal Generator to Keysight Technologies” on page 347

If the signal generator displays an error, always read the error message 
text by pressing Utility > Error Info.
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RF Output Power Problems
Check the RF ON/OFF annunciator on the display. If it reads RF OFF, press 
RF On/Off to toggle the RF output on.

No RF Output Power when Playing a Waveform File (E8267D only)

Preset the signal generator, then replay the waveform file.

If a header file is not specified for a waveform, the signal generator uses a 
default header file with unspecified settings. If you play a waveform file that 
has unspecified signal generator settings; (settings not saved to the file 
header, see page 121), the signal generator will use the header file settings 
from the previously played file. If the previous header file had a marker routed 
to RF blanking, the RF output power will be blanked. Preset the signal 
generator to return the RF blanking marker function to its default state (Off)). 
Refer to the Key Reference, Marker section, for more information.

RF Output Power too Low

1. Look for an OFFS or REF indicator in the AMPLITUDE area of the display.

OFFS tells you that an amplitude offset has been set. An amplitude offset 
changes the value shown in the AMPLITUDE area of the display but does 
not affect the output power. The amplitude displayed is equal to the 
current power output by the signal generator hardware plus the value for 
the offset.

To eliminate the offset, press the following keys:

Amplitude > More (1 of 2) > Ampl Offset > 0 > dB.

If the default marker file is used, ensure that the Pulse/RF Blank softkey is 
set to None. Markers may have been set to Pulse/RF Blank by a previous 
file header. 

In any correspondence or telephone conversation, refer to the product by its 
model number and full serial number. With this information, the Keysight 
representative can determine the warranty status of your unit.

On E8267D’s, an –222 Data out of range (“output power”) error can be 
caused by:

— An incorrect waveform RMS voltage when using the signal generator 
with the ALC off.

— The marker signal is not routed correctly to the ALC hold and the pulse 
modulator for complex wireless signals.

For these instrument setups, if the signal is unleveled, the instrument does 
not have sufficient power available.



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 331

Troubleshooting
RF Output Power Problems

REF tells you that the amplitude reference mode is activated. When this 
mode is on, the displayed amplitude value is not the output power level. It 
is the current power output by the signal generator hardware minus the 
reference value set by the Ampl Ref Set softkey.

To exit the reference mode, follow these steps:

a. Press Amplitude > More (1 of 2).

b. Press Ampl Ref Off On until Off is highlighted.

You can then reset the output power to the desired level.

2. If you are using the signal generator with an external mixer, see “Signal 
Loss While Working with a Mixer” on page 331.

3. If you are using the signal generator with a spectrum analyzer, see “Signal 
Loss While Working with a Spectrum Analyzer” on page 332.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no 
user–replaceable power supply fuse. Refer to the Keysight PSG Signal 
Generators Service Guide for instructions.

Signal Loss While Working with a Mixer

If you experience signal loss at the signal generator’s RF output during 
low–amplitude coupled operation with a mixer, you can solve the problem by 
adding attenuation and increasing the RF output amplitude of the signal 
generator.

Figure 13-1 shows a hypothetical configuration in which the signal generator 
provides a low amplitude signal to a mixer.

Figure 13-1 Effects of Reverse Power on ALC
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The internally leveled signal generator RF output (and ALC level) is –8 dBm. 
The mixer is driven with an LO of +10 dBm and has an LO–to–RF isolation of 15 
dB. The resulting LO feedthrough of –5 dBm enters the signal generator’s RF 
output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy 
to enter the detector. Since the detector responds to its total input power 
regardless of frequency, this excess energy causes the ALC to reduce the RF 
output of the signal generator. In this example, the reverse power across the 
detector is actually greater than the ALC level, which may result in loss of 
signal at the RF output.

Figure 13-2 shows a similar configuration with the addition of a 10 dB 
attenuator connected between the RF output of the signal generator and the 
input of the mixer. The signal generator’s ALC level is increased to +2 dBm and 
transmitted through a 10 dB attenuator to achieve the required –8 dBm 
amplitude at the mixer input. 

Figure 13-2 Reverse Power Solution

Compared to the original configuration, the ALC level is 10 dB higher while the 
attenuator reduces the LO feedthrough (and the RF output of the signal 
generator) by 10 dB. Using the attenuated configuration, the detector is 
exposed to a +2 dBm desired signal versus the –15 dBm undesired LO 
feedthrough. This 17 dB difference between desired and undesired energy 
results in a maximum 0.1 dB shift in the signal generator’s RF output level.

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the signal generator’s RF 
output when the signal generator is used with a spectrum analyzer that does 
not have preselection capability.

Some spectrum analyzers have as much as +5 dBm LO feedthrough at their RF 
input port at some frequencies. If the frequency difference between the LO 
feedthrough and the RF carrier is less than the ALC bandwidth, the LO’s 
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reverse power can cause amplitude modulation of the signal generator’s RF 
output. The rate of the undesired AM equals the difference in frequency 
between the spectrum analyzer’s LO feedthrough and the RF carrier of the 
signal generator.

Reverse power problems can be solved by using one of two unleveled 
operating modes: ALC off or power search.

Setting ALC Off Mode

ALC off mode deactivates the automatic leveling circuitry prior to the signal 
generator’s RF output. In this mode, a power meter is required to measure the 
output of the signal generator and assist in achieving the required output 
power at the point of detection. 

Use the following steps to set the signal generator to the ALC off mode:

1. Preset the signal generator: press Preset.
2. Set the desired frequency: press Frequency and enter the desired 

frequency.
3. Set the desired amplitude: press Amplitude and enter the desired 

amplitude.
4. Turn the RF on: set RF On/Off to On
5. Turn the signal generator’s automatic leveling control (ALC) off: press 

Amplitude > ALC Off On to Off.
6. Monitor the RF output amplitude as measured by the power meter.

Press Amplitude and adjust the signal generator’s RF output amplitude 
until the desired power is measured by the power meter.

Poor Pulse Performance

For pulse widths <1 microsecond, you may need to do a power search to 
optimize the pulse performance of the instrument. Refer to “Setting Power 
Search Mode” on page 334.
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Setting Power Search Mode

Power search mode executes a power search routine that temporarily closes 
the ALC, calibrates the power of the current RF output, and then opens the 
ALC circuitry. See the Keysight PSG Signal Generators Key Reference for more 
information on the Power Search function. 

There are three power search modes: manual, automatic, and span.

Manual  When Power Search is set to Manual, pressing Do 
Power Search executes the power search calibration 
routine for the current RF frequency and amplitude. In 
this mode, if there is a change in RF frequency or 
amplitude, you will need to press Do Power Search 
again. 

Auto  When Power Search is set to Auto, the calibration 
routine is executed whenever the frequency or 
amplitude of the RF output is changed.

Span  When Power Search is set to Span, pressing Do Power 
Search executes the power search calibration routine 
over a selected range of frequencies at one time. The 
power search corrections are then stored and used 
whenever the signal generator is tuned within the 
selected range of frequencies. Span power search 
settings are only valid for a single power level.

Use the following steps to set the signal generator to manual fixed power 
search mode:

1. Press Preset.
2. Press Frequency and enter the desired frequency.
3. Press Amplitude and enter the desired amplitude.
4. Press Amplitude > ALC Off On to Off.
5. Press Power Search (Manual, Fixed) > Minimum. (The Minimum softkey 

sets the internal attenuator to its maximum setting during power search to 
protect the power sensitive circuits. Refer to the Key Help.)

6. Press RF On/Off to On.
7. Press Do Power Search.

There are two “RF During Power Search” settings available for the power 
search, Minimum and Normal. The Minimum softkey sets the internal 
attenuator to its maximum setting during power search to protect the 
power sensitive circuits. When the power search has completed the 
attenuator is returned to the last attenuator setting before the power 
search was executed. The Normal softkey executes the power search 
without this added attenuator protection.

A successful power search is dependent on a valid power search reference 
and the instrument’s ability to level at a set power level without 
modulation.
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This executes the manual fixed power search routine, which is the default 
mode.

Setting the Power Search Reference (E8267D only)

Additionally, on the E8267D, there are up to four Power Search Reference 
modes: ARB RMS, Fixed, Manual RMS or Manual, and Modulated. These four 
reference modes select the reference voltage used while the RF signal is being 
I/Q modulated. (Power search reference modes are not used for analog 
modulation: FM, PM, or pulse modulation.)

Figure 13-3 Calculating the Output Power Error for a Single Waveform Sample Point

Figure 13-4 Calculating the RMS Voltage of the Waveform

ARB RMS  During ARB RMS, the Power Search Reference is set to 
ARB RMS, the I/Q modulation is disabled, and the I/Q 
modulator is biased with a DC level that is equivalent 
to the RMS voltage of the modulating signal. This 
selection is typically used with internally generated 

A successful power search is dependent on a valid power search reference.

If the power search reference has the incorrect RMS voltage, the output power will be incorrect. 
Refer to Figure 13-3, "Calculating the Output Power Error for a Single 
Waveform Sample Point" and Figure 13-4, “Calculating the RMS Voltage of 
the Waveform.”

20 10 V( )1( ) V( )2( )⁄( )log×=

Where:

V1 is the actual waveform RMS voltage

V2 is the entered RMS voltage

The Output Power Error

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired. 
If the RMS voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

Because the RMS calculation, that is done by the signal generator, is slow 
and may not be appropriate for your application, it is recommended that 
the user calculate and enter in their measured RMS value for the 
waveform file. 

RMS value for the waveform =

SCPI Commands:

[:SOURce]:RADio:ARB:HEADER:RMS <"file_name">,<val>|UNSPecified
[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide and to the 
Documentation CD that came with this instrument.
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baseband I/Q modulations. When the search is 
complete, the DC bias is removed and the I/Q signal is 
reapplied to the I/Q modulator.

The RMS voltage value can be found in the waveform 
header (Refer to Chapter 3, “Basic Digital Operation.”) 
The RMS voltage value can be set by the user or 
calculated by the signal generator. 

Fixed  During Fixed, the Power Search Reference is set fixed 
RMS reference level and is used to bias the I/Q 
modulator.

Manual RMS  During the Manual RMS, the user selects a DC bias 
level (0 to 1.414 Vrms) as a Power Search Reference to 
be applied to the I/Q modulator during the power 
search.

Modulated  During the Modulated power search, the Power Search 
Reference is set to Modulated, the actual modulating 
signal is used to provide the AC bias on the I/Q 
modulator. Modulated can be used with either 
internally generated or externally supplied I/Q 
modulation. 

No Modulation at the RF Output
Check the MOD ON/OFF annunciator on the display. If it reads MOD OFF, press 
Mod On/Off to toggle the modulation on. 

Although you can set up and enable various modulations, the RF carrier is 
modulated only when you have also set Mod On/Off to On.

On the E8267D, for digital modulation, make sure that I/Q Off On is set to On.

The ARB RMS softkey is only available when the internal Arb is enabled.

Due to the time varying nature of the I/Q data, a modulated reference 
search can take longer to settle and be less accurate than the other 
reference bias types. The modulated search reference bias type is not 
recommended for use with low symbol rate modulated formats.

The modulated power search reference cannot be used with a bursted 
signal.
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Sweep Problems

Sweep Appears to be Stalled

The current status of the sweep is indicated as a shaded rectangle in the 
progress bar. You can observe the progress bar to determine if the sweep is 
progressing. If the sweep appears to have stalled, check the following:

— Have you turned on the sweep by pressing any of the following key 
sequences?

  Sweep/List > Sweep > Freq

  Sweep/List > Sweep > Ampl

  Sweep/List > Sweep > Freq & Ampl

— Is the sweep in continuous mode? If the sweep is in single mode, be sure 
that you have pressed the Single Sweep softkey at least once since 
completion of the prior sweep. Try setting the mode to continuous to 
determine if the missing single sweep is blocking the sweep.

— Is the signal generator receiving the appropriate sweep trigger? Try setting 
the
Sweep Trigger softkey to Free Run to determine if a missing sweep trigger 
is blocking the sweep.

— Is the signal generator receiving the appropriate point trigger? Try setting 
the Point Trigger softkey to Free Run to determine if a missing point trigger 
is blocking the sweep.

— Is the dwell time appropriate? Try setting the dwell time to one second to 
determine if the dwell time was set to a value which was too slow or too fast 
for you to see.

— Do you have at least two points in your step sweep or list sweep?

Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.

In the sweep mode menu you can choose to set the sweep to various sweep 
types or to turn sweep off.

Incorrect List Sweep Dwell Time

If the signal generator does not dwell for the correct period of time at each 
sweep list point, follow these steps:

1. Press Sweep/List > Configure List Sweep.

This displays the sweep list values.

2. Check the sweep list dwell values for accuracy.
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3. Edit the dwell values if they are incorrect.

If the list dwell values are correct, continue to the next step.

4. Observe if the Dwell Type List Step softkey is set to Step.

When Step is selected, the signal generator will sweep the list points 
using the dwell time set for step sweep rather than the sweep list dwell 
values.

To view the step sweep dwell time, follow these steps:

a. Press Configure Step Sweep.

b. Observe the value set for the Step Dwell softkey.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an 
instrument state register. Only the current list sweep is available to the signal 
generator. List sweep data can be stored in the instrument catalog. For 
instructions, see “Storing Files to the Memory Catalog” on page 85.

The effective dwell time at the RF OUTPUT connector is the sum of the 
value set for the dwell plus processing time, switching time, and settling 
time. This additional time added to the dwell is generally a few 
milliseconds. The TTL/CMOS output available at the TRIG OUT connector, 
however, is asserted high only during the actual dwell time.
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Data Storage Problems

Registers With Previously Stored Instrument States are Empty

The save/recall registers are backed–up by a battery when line power to the 
signal generator is not connected. The battery may need to be replaced. 

To verify that the battery has failed:

1. Turn off line power to the signal generator.

2. Unplug the signal generator from line power.

3. Plug in the signal generator.

4. Turn on the signal generator.

5. Observe the display for error messages.

If either error message −311 or −700 is stored in the error message queue, 
the signal generator’s battery has failed. 

6. Refer to the Keysight PSG Signal Generators Service Guide for battery 
replacement instructions.

Saved Instrument State, but Register is Empty or Contains Wrong 
State

If you select a register number greater than 99, the signal generator 
automatically selects register 99 to save the instrument state.

If the register number you intended to use is empty or contains the wrong 
instrument state, recall register 99:

Press Recall > 99 > Enter.

The lost instrument state may be saved there.
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Cannot Turn Off Help Mode

1. Press Utility > Instrument Info/Help Mode 

2. Press Help Mode Single Cont until Single is highlighted.

The signal generator has two help modes; single and continuous. 

When you press Help in single mode (the factory preset condition), help text is 
provided for the next key you press. Pressing another key will exit the help 
mode and activate the key’s function.

When you press Help in continuous mode, help text is provided for the next key 
you press and that key’s function is also activated (except for Preset). You will 
stay in help mode until you press Help again or change to single mode.
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Signal Generator Locks Up
If the signal generator is locked up, check the following:

— Make sure that the signal generator is not in remote mode (in remote mode, 
the R annunciator appears on the display). To exit remote mode and unlock 
the front panel keypad, press Local.

— Make sure that the signal generator is not in local lockout condition. Local 
lockout prevents front panel operation. For more information on local 
lockout, refer to the Keysight Signal Generators Programming Guide.

— Check for a progress bar on the signal generator display, which indicates 
that an operation is in progress.

— Press Preset.

— Cycle power on the signal generator.

Fail–Safe Recovery Sequence

Use the fail–safe recovery sequence only if the previous suggestions do not 
resolve the problem. 

To run the fail–safe sequence, follow these steps:

1. Hold down the Preset key while cycling power. 

2. Continue to hold down the Preset key until the following message is 
displayed:

3. Release the Preset key.

This process does reset the signal generator, but it also destroys the 
following types of data:

— all user files (instrument state and data files) 
— DCFM/DCFM calibration data
— persistent states

Do not attempt to perform any other front panel or remote operations 
during the fail–safe sequence. 

You are entering the diagnostics menu which can cause 
unpredictable instrument behavior. Are you sure you want to 
continue?

Carefully read the entire message! It may list additional risks with this 
procedure.
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4. To continue with the sequence, press Continue (to abort with no lost files, 
press Abort).

5. When the sequence concludes, do the following:

a. Cycle power. 

Cycling power restores all previously installed options. Because 
calibration files are restored from EEPROM, you should see several 
error messages.

b. Perform the DCFM/DCΦM calibration. 

Refer to the DCFM/DCΦM Cal softkey description in the Keysight 
PSG Signal Generators Key Reference.

c. Keysight Technologies is interested in the circumstances that made 
it necessary for you to initiate this procedure. Please contact us at 
the telephone number listed at 
http://www.keysight.com/find/assist. We would like to help you 
eliminate any repeat occurrences.



Keysight E8257D/67D & E8663D PSG User’s Guide                                                                                                 343

Troubleshooting
Error Messages

Error Messages
If an error condition occurs in the signal generator, it is reported to both the 
front panel display error queue and the SCPI (remote interface) error queue. 
These two queues are viewed and managed separately; for information on the 
SCPI error queue, refer to the Keysight Signal Generators Programming 
Guide.

Error Message File

A complete list of error messages is provided in the file errormessages.pdf, on 
the CDROM supplied with your instrument.

In the error message list, an explanation is generally included with each error 
to further clarify its meaning. The error messages are listed numerically. In 
cases where there are multiple listings for the same error number, the 
messages are in alphabetical order. 

Error Message Format

When accessing error messages through the front panel display error queue, 
the error numbers, messages and descriptions are displayed on an enumerated 
(“1 of N”) basis.

When there is an unviewed message in the front panel error queue, the 
ERR annunciator appears on the signal generator’s display.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling
Circular (rotating).
Drops oldest error as new error comes in.

Viewing Entries Press: Utility > Error Info > View Next (or Previous) Error Page

Clearing the Queue Press: Utility > Error Info > Clear Error Queue(s)

Unresolved Errorsa Re–reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue:
0 No Error Message(s) in Queue

a. Errors that must be resolved. For example, unlock.
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Error messages appear in the lower–left corner of the display as they occur.

Error Message Types

Events do not generate more than one type of error. For example, an event that 
generates a query error will not generate a device–specific, execution, or 
command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue 
control has detected a problem with the message exchange protocol described 
in IEEE 488.2, Chapter 6. Errors in this class set the query error bit (bit 2) in the 
event status register (IEEE 488.2, section 11.5.1). These errors correspond to 
message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

— Either an attempt is being made to read data from the output queue when 
no output is either present or pending, or

— data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate 
that a device operation did not properly complete, possibly due to an abnormal 
hardware or firmware condition. These codes are also used for self–test 
response errors. Errors in this class set the device–specific error bit (bit 3) in the 
event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A 
positive error indicates that the instrument detected an error within the GPIB 
system, within the instrument’s firmware or hardware, during the transfer of 
block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by 
the instrument’s execution control block. Errors in this class set the execution 
error bit (bit 4) in the event status register (IEEE 488.2, section 11.5.1). In this 
case:

— Either a <PROGRAM DATA> element following a header was evaluated by 
the device as outside of its legal input range or is otherwise inconsistent 
with the device’s capabilities, or

— a valid program message could not be properly executed due to some 
device condition.

Explanation provided in the Error Message List
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Execution errors are reported after rounding and expression evaluation 
operations are completed. Rounding a numeric data element, for example, is 
not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser 
detected an IEEE 488.2 syntax error. Errors in this class set the command error 
bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1). In this case:

— Either an IEEE 488.2 syntax error has been detected by the parser (a 
control–to–device message was received that is in violation of the IEEE 
488.2 standard. Possible violations include a data element that violates 
device listening formats or whose type is unacceptable to the device.), or

— an unrecognized header was received. These include incorrect 
device–specific headers and incorrect or unimplemented IEEE 488.2 
common commands.



346                                                                                              Keysight E8257D/67D & E8663D PSG User’s Guide

Troubleshooting
Contacting Keysight Sales and Service Offices

Contacting Keysight Sales and Service Offices
Assistance with test and measurement needs, and information on finding a 
local Keysight office are available on the Internet at:
http://www.keysight.com/find/assist

You can also purchase E8257D/67D or E8663D PSG accessories or 
documentation items on the Internet at: http://www.keysight.com/find/psg

If you do not have access to the Internet, contact your field engineer.

In any correspondence or telephone conversation, refer to the signal 
generator by its model number and full serial number. With this 
information, the Keysight representative can determine whether your unit 
is still within its warranty period.
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Returning a Signal Generator to Keysight Technologies
To return your signal generator to Keysight Technologies for servicing, follow 
these steps:

1. Gather as much information as possible regarding the signal generator’s 
problem. 

2. Call the phone number listed on the Internet 
(http://www.keysight.com/find/assist) that is specific to your geographic 
location. If you do not have access to the Internet, contact your field 
engineer. 

After sharing information regarding the signal generator and its condition, 
you will receive information regarding where to ship your signal generator 
for repair.

3. Ship the signal generator in the original factory packaging materials, if 
available, or use similar packaging to properly protect the signal 
generator.
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description 19, 24
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symbol rates 213
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A
AC power receptacle 50
ACP 104, 206, 236
active entry area (display) 36
adding & editing (instrument state) 87
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ALC
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off mode, setting 333
with attenuator option 164

ALC hold
description 127
saving setting 126

ALC HOLD connector 51
ALC INPUT connector 30, 56
alpha adjustment (filter) 206
alternate ramp sweep 78
AM 36, 189
amplifier, microwave 324, 326
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display area 39
hardkey 27
LF output 196
modulation. See AM
ramp sweep 79
reference & offset 67

analog modulation 24, 187–197
analog PSG

optional features 17, 20
annunciators 36
application notes

obtaining 15
ARB

AWGN 285
file catalogs 85
triggers 140
waveform clipping 147–153
waveform file headers 106–116
waveform scaling 154–156
See also custom arb waveform generator
See also dual arbitrary waveform generator

arb 104
ARMED annunciator 36
arrow hardkeys 32
ATTEN HOLD annunciator 36
attenuator, external leveling 164
AUTOGEN_WAVEFORM file 117
automatic leveling control. See ALC
AUXILIARY I/O connector 46
AUXILIARY INTERFACE connector 51
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AWGN
ARB 285
dual ARB player 123
real-time 285

B
bandwidth

ALC, selecting 159
reference oscillator, adjusting 182

baseband
clipping 147–153
frequency offset

softkey location 157
scaling 154–156

BASEBAND GEN CLK IN connector 52
baseband generator 104

AWGN 285
custom arb mode 24, 199
custom real-time I/Q mode 24, 227
dual arb mode 25, 103
multitone mode 25, 265
settings 240, 241
two-tone mode 25, 277

basic operation
digital 103
standard 59
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binary files 85
bit files 85
bits per symbol, equation 243
block diagrams
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GPS subframe structures 258
MSGPS signal generation 251

BURST GATE IN connector 46
burst shapes 235–239
bursted signals 160

C
carrier bandwidth 123
carrier feedthrough, minimizing 272, 281
carrier signal, modulating 84
carrier to noise ratio 123
CCDF curve 151–152, 273
CDMA 160
ceiling function, bits per symbol 243
certificate, license key 99
circular clipping 151
clipping

CCDF curve 151–152
circular 149, 151
concepts 147–151
procedure 151, 152
rectangular 149, 152

clock adjustment
phase and skew 300

clock rate limits, logic type output 290
clock source

setting 311, 318
clock timing

parallel data 296
parallel interleaved data 298
phase and skew 300
serial data 300

clocking, frequency reference 294
clocking, frequency reference diagrams 295
Clocks Per Sample

parallel data 296
parallel interleaved data 298

COH CARRIER connector 49
comments, adding & editing (instrument state) 87
common frequency reference diagrams 295
component test 104
concepts

differential data encoding 242
FIR filters 205
waveform clipping 147–151
waveform markers 126
waveform scaling 154–155

confidential data 90
connections

common frequency reference 295
connectors

external triggering 144
external triggering source 144
front panel 26
rear panel 41

continuous
list sweep 72
step sweep 70
triggering 142

continuous wave
configuring 64
description 24

contrast adjustments 32
correction array (user flatness)

configuration 168
load from step array 169
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custom arb waveform generator 24, 199–225
custom mode 104
custom real-time I/Q baseband 24, 227–248
CW mode

configuring 64
description 24

D
DAC over range error 157
DAC over-range errors 154–156
data

clock 240, 241
encoding, differential 242–248
fields, editing 61
files 85
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input methods 90
patterns

triggering 140
using 229

removal 94
sensitive 90, 94
storage

problems 339
security 90
See also instrument state register
See also memory catalog

unframed 141
DATA CLOCK connector 33, 56
DATA connector 34, 57
data filtering, pre or post fir 308, 322
data sheets 15
data types 303
DC detector 68
DC offset 190
declassification 90
default FIR filter, restoring 207
default navigation data, GPS 258
delay, external trigger signal 142
Delete Item softkey 61
Delete Row softkey 61
description, adding & editing (instrument state) 87
detector

diode response 163
using 161

device clock source selection 311, 318
DHCP 100
diagram

data types 303
diagrams

clock timing, parallel data 296
clock timing, parallel interleaved data 298
clock timing, phase and skew 300
clock timing, serial data 300
common frequency reference 295

differential data encoding 242–248
DIG BUS annunciator 36
Digital Bus connector 47
digital modulation

annunciators 39
custom 199–225, 227–248
formats 24
multicarrier 200, 203, 224
multitone 265–275
two tone 277–283

digital signal interface 290
digital signal interface module 290
diode detector response 163
discrete steps, skew range 300
display

blanking 97
contrast decrease 32
contrast increase 32
descriptions 35
overview 35
secure 97

DMOD files 85
documentation options 22
documentation, list of 13
downloading firmware 22
dual arb 104
dual ARB player 25, 117–124
Dual ARB real-time noise 123
dual arbitrary waveform generator 25, 117–124
dwell time 69

E
E8257D

optional features 17
E8267D

optional features 19
standard features 19

E8663D
optional features 20
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Edit Item softkey 61
Erase All 94, 95, 96, 97
erase and overwrite 94
erase and sanitize 95
erasing memory 90, 94, 95, 96, 97
ERR annunciator 37, 343
error messages

DAC over range 157
DAC over-range 154–156
display 39
message format 343
overview 343
queue 343
types 344

EVENT connectors 45
EVM 206, 236
EXT

annunciators 37
EXT 1 connector 55
EXT 1 INPUT connectors 30
EXT 2 connector 55
EXT 2 INPUT connector 30
extend frequency 82
extend frequency range 82
external

data clock, setting 240
detector, diode response 163
simultaneous triggering pulse source 192

external clock source selection 311, 318
external FM 190
external I/Q modulation 221, 222
external source module 324
external trigger

connection 144
gated, setting 143
single, setting 224
source connector 144

F
fail-safe recovery sequence 341
failures. See troubleshooting
fall delay, burst shape 236
fall time, burst shape 236
FAQ 15
features, signal generator 16
feedthrough, carrier, minimizing 281
file headers (ARB waveform) 106–116
file store
files 86

catalogs 85
using 85
waveform segments 118–124
waveform sequences 119–124
See also instrument state register
See also memory catalog

filtered & unfiltered samples 308, 322
filters

interpolation 154–155
using 205–212

FIR 85, 205
firmware

options 22
upgrades

obtaining 22
using GPIB 22
using LAN 22
using RS-232 22

Flash Drive Input Connector 58
flatness correction. See user flatness correction
FM 37, 190
formula, skew discrete steps 300
framed data 141
free run trigger response 142
frequency

display area 36
hardkey 27
modulation. See FM
offset 65
offset, softkeys 157
ramp sweep 73
ranges 16
reference 65
RF output, setting 64

frequency extension 82
frequency output limits, clock rates & logic levels
290
frequency range 82
frequency reference

common 294
hookup diagrams 295

front panel
description 26–35
disabling keys 97

FSK
files 85
modulation 215, 220, 221
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G
GATE/PULSE/TRIGGER connector 32
gated 192
gated triggering 141, 143
Gaussian filter, selecting 206
Goto Row softkey 61
GPIB 50, 171
GPS

chip clock reference 259
configuring external reference clock 262
data modes 258
default navigation data 258
handover word 258
overview 257
satellite ID range 257
sensitivity testing 263
signal generation diagram 257
subframe indicator 259
subframe structures 258
TLM word 258
user files 260

H
handover word, GPS 258
hardkeys 26–32
hardware, configuring 224, 240
harmonics, below 2 GHz, option UNX 185
Help hardkey 29
help mode troubleshooting 340
Hold hardkey 32

I
I IN connector 56
I Input connector 34
I OUT connector 48
I/O connector, auxiliary 46
I/Q

4QAM state map 243
annunciator 37
files 85
input connectors 34
modulation 219, 246
scaling, adjusting 241

I/Q waveform
clipping 147–153
scaling 154–156

I-bar OUT connector 48
IMD. See intermodulation distortion
Incr Set hardkey 31

information
additional PSG 15
protecting sensitive 90

Insert Item softkey 61
Insert Row softkey 61
installing firmware 22
instrument state register

comments, adding and editing 87
troubleshooting 339
using 86
See also memory catalog

instrument states 78
int gated 192
interface connectors

AUXILIARY INTERFACE 51
GPIB 50
LAN 52
RS-232 51

interface, remote 171
intermodulation distortion

how to minimize 148
testing non-linear devices 266, 278

internal
simultaneous triggering pulse source 192

internal clock source selection 311, 318
interpolation filter 154–155
IQ

clock rates 292
modulation 221, 222

IQ modulation 221, 222

K
key, license 99
keypad, numeric 31
keys

disabling 97
front panel 26–32

Keysight PSG web page 15
knob, front panel 27

L
L (listener mode) annunciator 37
lan configuration 100
LAN connector 52
LEDs 33
leveling

ALC 333
external 161–165
internal 159
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mm-wave source module, using 324
LF OUT connector 57
LF output 195–197
LF OUTPUT connector 30
license key 99
limits, clock & sample rates, logic outputs 290
line power LED 33
line switch 33
list

error messages 343
files 85
mode values table editor 60
sweep 70, 337

listener mode annunciator 37
Load/Store softkey 61
Local hardkey 32
logic type

output levels 290
selecting 305

low frequency output. See LF output
Low pass filter

improved harmonic distortion performance 66

M
magnitude error simulation 219
manual freq softkey 78
manual sweep 78
markers

output 52
ramp sweep 76
waveform 125–139

MDMOD files 85
media storage 90
memory 117

base instrument 90
baseband generator 90
catalog 85, 339

See also instrument state register
erasing 90, 94
flash drive 90
hard disk 90
overwriting 94
persistence 90
physical location 90
sanitizing 95
secure mode 96
size 90
types 90
waveform 90

writing to 90
menus

marker 129
marker polarity 139
trigger 142

MENUS hardkeys 29
microwave amplifier 324, 326
Millimeter 324
millimeter-wave source module 324
mixer, signal loss while using 331
mm-source 82
mm-wave source module

extending frequency range with 324
leveling with 165
user flatness correction array, creating 173–180

mod on/off 37
Mod On/Off hardkey 30
models, signal generator 16
modes of operation 24
modes, triggering 141
modulation

amplitude. See AM
analog 24, 187–197
analog waveforms 188
annunciators 36–39
applying 83
digital 24
file catalogs 85
frequency. See FM
multicarrier 200, 203, 224
phase. See ΦM
predefined setups 201, 228
pulse 24, 192
pulse, simultaneous triggering 192
types 215
user-defined 202, 246
See also digital modulation

modulation, pulse 20
module user interface location 304, 314
MSGPS

chip rate 256
external reference clock 256
generating a signal 255
RF power level 253
scenario files 250, 251, 255
signal generation diagram 251

MSK modulation 215
MTONE files 85
multicarrier waveform 200, 203, 224
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multitone 104
multitone mode 25
multitone waveform generator 265–275

N
N5102A 290

baseband data 304
clock rates 290
clock settings 309, 316
clock source

description 293
clock timing 290, 296
common frequency reference 294
connections to clock and device 301
data parameters, setting 306, 320
data types 303
digital data 323
frequency reference connector 294
generating data 313
input direction 315
input mode 303, 314
interleaving clock timing 298
logic type, port configuration 315
logic types 305
output direction 306
output mode 303, 304
phase and skew clock timing 300
serial clock timing 300
user interface 304
user interface module 314

N5102A digital signal interface module 290
negation description 309, 323
noise 123, 285
noise bandwidth factor 123
non-linear devices, testing 266, 278
non-volatile memory 117
numeric format selection 308, 322
numeric keypad 31
NVMKR files 85
nvwfm 117
NVWFM files 85
Nyquist filters 206

O
OFDM 160
offset 65, 67, 190
offset binary use 308, 322
on/off switch 33
operation

basics 59
digital basics 103
modes of 24

Optimize Signal-to-Noise ratio
softkey 67

Option 422 249
options

003 19
004 19
005 19
007 17, 20, 21, 24, 73
008 17, 20
009 19
015 19, 48, 49, 222
016 19, 48, 49, 221
1E1 17, 21
1EA 17, 21
1ED 17, 21
1EH 17, 21, 66
1EM 18, 21
1EU 17, 21
1SM 18, 21
403 123
403/403

description 19
409, GPS 257
424, GPS 257
424, MSGPS 250
521 17, 21
601/602

basic digital operation 103
custom arb mode 199, 200
custom real-time mode 227, 228
description 19, 24
multitone mode 265, 266
two-tone mode 277, 278
using symbol rates 213

additional information 22
enabling 99
UK6 18, 21
UNR/UNX 18, 21, 182
UNT 18, 21, 24, 187–191, 195
UNU 18, 24, 187, 188, 192
UNW 19, 21, 24, 187, 188, 192
UNY 18, 21

Options, UNX 183
oscillator, reference, adjusting BW 182
output levels, logic types 290
output power, troubleshooting 330
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output. See LF output and RF output
OVEN COLD annunciator 37
over-range errors 154–156
overview, GPS 257
overwriting memory 94

P
Page Down softkey 61
Page Up softkey 61
parallel

clock rates 292
data clock timing 296
interleaved data clock timing 298
sample rates 292

PATTERN TRIG IN connector 45
peak to average power

CCDF curve 151, 273
high ratios 148
multitone characteristics 273
reducing 149

performance, optimizing 159–186
peripheral devices 290

digital signal interface module 289
millimeter wave source module 289

phase
error simulation 219
modulation. See ΦM
polarity 242

phase clock timing 300
phase noise, below 250 MHz, option UNX 184
player, dual ARB 117–124
polarity

marker setting, saving 106
markers 139
trigger, external 143

port configuration, selecting 305
power

meter 167, 333
output, troubleshooting 330
peaks 147–151
receptacle, AC 50
search mode 334
supply troubleshooting 331
switch 33

PRAM 104
predefined filters 205
predefined modulation setups 201, 228
pre-fir samples selection 308, 322
Preset hardkey 32

primary/secondary setup 80
private data 90
problems. See troubleshooting
product information 15
proprietary data 90
protecting data 90
PSG

additional information 15
firmware 22
modes of operation 24
options 22
web page 15

PSK modulation 215
pulse 160

annunciator 38
modulation 192

pulse modulation 20, 24, 68
simultaneous triggering 192

pulse performance, improving 333
pulse source 68, 192
PULSE SYNC OUT connector 55
PULSE VIDEO OUT connector 55
pulse width 333
pulse, marker, viewing 137
PULSE/TRIG GATE INPUT connector 56

Q
Q IN connector 57
Q Input connector 34
Q OUT connector 47
QAM modulation 215, 243
Q-bar OUT connector 49
QPSK I/Q modulation, creating 218
queue, error 343

R
R (remote) annunciator 38
ramp sweep 73–81
real time 104
real-time AWGN 285
real-time I/Q 227–248
real-time mode 24, 105
real-time noise 123
real-time triggers 140
rear panel description 41
Recall hardkey 28
recall state 78
recall states 86
receiver test 104
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recovery sequence, fail-safe 341
rectangular clipping 152
reference

amplitude, setting 67
frequency, setting 65
GPS chip clock 259
MSGPS chip clock 256
oscillator bandwidth, adjusting 182

registers 86, 88
remote operation 171
remote operation annunciator 38
reset & run trigger response 142
response, triggering mode 141
restricted data 90
Return hardkey 32
returning a signal generator 347
RF blanking 330

marker function 138
settings, saving 126

RF On/Off hardkey 31
RF OUT connector 55
RF output

annunciator 38
configuring 64
connector 31
leveling, external 161–165
limit, setting 62
mm-wave source module, using 324
sweeping 68
troubleshooting 330
user flatness correction 166–180

rise delay, burst shape 236
rise time, burst shape 236
root Nyquist filters 206
routing, marker

ALC hold 127
RF blanking 138
saving settings 126
settings, saving 106

RS-232 connector 51
runtime scaling 156

S
S (service request) annunciator 38
sample

rates 290
rates, parallel/parallel intrlvd port configuration 

292
rates, serial port configuration 291

type selection 308, 322
samples

baseband 154–155
interpolated 154–155

sanitizing memory 95
satellite ID range, GPS 257
save and recall 78
save and recall states 86
save files
Save hardkey 28
scalar network analyzer 68, 73–81
scalar pulse 68
scaling

concepts 154–155
procedure 156
runtime 156
waveform data 156

scenario files
MSGPS 250, 251

downloading 252, 253
playing 255

SCPI 100
secure display 97
secure mode 96
security functions 90, 96
security level 96
segment advance triggering 142, 145
sensitive data 90
sensitivity testing, GPS 263
Seq files 85
sequences

building and storing 119
deleting 88
editing 121
instrument state register 86
marker control 135
playing 121
triggering 140

serial
clock and sample rates 291
clock timing 300

service request annunciator 38
service, Keysight sales and service offices 346
setting

user-defined, RF output limits 62
shape files 85
signal generator

features 16
firmware 22
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models 16
modes 24
options 22
overview 15

signal loss, troubleshooting 330
Signal Studio software 266, 278
Signal to noise ratio

setting 67
single step sweep 69
single trigger mode 141
single trigger, setting 224
skew

clock timing 300
range 300

SMI connector 53
softkeys 27, 40, 61
software

available for PSG 15
options 22

source module 324
source module interface 53
SOURCE SETTLED connector 53
source, external trigger 143
spectral regrowth 148
spectrum analyzer, troubleshooting signal loss 332
square pulse 68
standby LED 33
state files 85
state registers 78
step array (user flatness) 167

See also user flatness correction
step attenuator, external leveling 164
step sweep 69–70
STOP SWEEP IN/OUT connector 52
storage, troubleshooting 339
subframe indicator, GPS 259
sweep

27 kHz pulse 68
8757D Scalar Network Analyzer 68
annunciator 38
DC detector 68
list 70
mode 24
ramp 73–81
RF output 68
scalar network analyzer 68
scalar pulse 68
step 69
trigger 72

troubleshooting 337
SWEEP OUT connector 53
sweep progress bar 68
switch, power 33
symbol rates 213
SYMBOL SYNC connector 33, 56
SYNC OUT connector 31

T
T (talker mode) annunciator 38
table editor, using 60–61
talker mode annunciator 38
TCP/IP 100
technical support 15
text display area 39
TLM word, GPS 258
trigger

hardkey 29
inputs

PATTERN TRIG IN 45
setting 72

trigger & run 142
trigger in 192
TRIGGER IN connector 53
TRIGGER OUT connector 53
trigger polarity 192
triggers 140–146, 224
troubleshooting 329–347
two tone 25, 104, 277–283

U
UK6, option 18, 21
unfiltered & filtered samples 308, 322
unframed data 141
UNLEVEL annunciator 38
UNLOCK annunciator 39
UNR/UNX, option 18, 21, 182
UNT, option 18, 21, 24, 187–191, 195
UNU, option 18, 24, 187, 188, 192
UNW, option 19, 21, 24, 187, 188, 192
UNX, option 183
UNY, option 18, 21
upgrading firmware 22
user files

GPS usage 260
user flatness 85, 166–180
user interface location, module 304, 314
user-defined

burst shape curves 237
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data patterns 230
files 85
filters 207, 209
modulation type

custom arb 202
real-time I/Q 216, 246

V
vector PSG

optional features 19
standard features 19

VIDEO OUT connector 31
volatile memory 117

W
warranted logic output clock rates 290
waveform memory 90
waveforms

analog modulation 188
ARB file headers 106–116
CCDF curve 151–152
clipping 147–153
custom 199–225
custom real-time I/Q baseband 227–248
DAC over-range errors 154–156
file catalogs 85
interpolation 154–155
markers 125
multicarrier 200, 203, 224
multitone 265–275
player, dual ARB 117–124
samples 154–155
scaling 154–156
segments 118–124
sequences 119–124, 135
statistics 151–152
triggering 140
two-tone 277–283
utilities 151–152

web server 100
website 15
wfm1 117
WFM1 files 85
WIDEBAND I INPUT connectors 48
wideband IQ 221, 222
WIDEBAND Q INPUT connectors 49

Z
Z-AXIS BLANK/MKRS connector 52
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