Welcome

This help file contains LabVIEW G programming information for the M9195A and M9195B Digital Stimulus/Response modules.

  • Getting Started

  • Programming Examples

  • Method (VI) Reference

  • Related Documentation
  • Additional information specific to the M9195A/B DSR modules such as descriptions of the STIL language, SITES, patterns, Edge Placement, and more.

The M9195A/B Digital Stimulus/Response Module Startup Guide provides instructions for installing the module in a PXIe chassis and installing the necessary software and drivers. The Startup Guide is available on the M9195A/B Software and Product Information CD that shipped with your module. Any updated information is available at www.keysight.com/find/M9195B.

Most of the LabVIEW VIs in this driver apply to both the M9195A and the M9195B modules. However, the M9195B module supports features such as triggering and multi-module synchronization that are not supported in the M9195A module.

LabVIEW G Programming Information

The goal of this help system is to enable you to quickly become productive at developing LabVIEW programs that interface to the M9195A/B DSR module. It is assumed that you're familiar with the M9195A/B module architecture and capabilities as described in the M9195A/B Startup Guide and the M9195A/B User Guide. Familiarity with the M9195A/B module soft front panel (SFP) is beneficial. To find the Startup Guide, the User Guide, and the SFP help system, please see Additional Information below.

The M9195A/B modules are supported by two types of drivers, IVI drivers and LabVIEW drivers. This help system focuses only on the LabVIEW drivers. For information on the IVI drivers, see Additional Information below.

This LabVIEW help file references the KtMDsr Programming Guide help file. The M9195B driver installation program installs both of these help files in the same folder. If they are not in the same folder then the links between them will not work correctly.

Additional Information

  • System Requirements
  • Getting Started
  • Additional M9195A/B Information
  • Programming Reference

© Keysight Technologies, Inc. 2014 - 2018

Version 2.1 January 2018

LabVIEW is a registered trademark of National Instruments


System Requirements

To install and run the required software (Microsoft .NET, Keysight IO Libraries version 17.0 or later, and module device drivers), the host PC requires the following:

 | For Better Performance
Operating System | Windows 10, 32-bit or 64-bit Windows 7 (SP1), 32-bit or 64-bit Windows 8.1, 32-bit or 64-bit
Browser | Microsoft Internet Explorer 6 (or later)
Processor | 800 MHz or greater
Minimum RAM | 4 GB for 32-bit OS 8 GB for 64-bit
Available Hard Disk Space | 1.5 GB

In addition, the host PC must be able to enumerate the PXIe chassis.

Many computers are not capable of enumerating a sufficient number of PCIe slots to ensure that slots in an external chassis are enumerated. Keysight maintains a document listing the integrated, rack mount, desktop and laptop computers that have been verified to properly enumerate PCIe devices in the PXIe chassis, at www.keysight.com/find/pxie-chassis. Keysight’s M9536A Embedded Controller must have BIOS AG16 or later.


Getting Started

Installation

Keysight IO Libraries Suite 2018 (or later) is required for the M9195A/B LabVIEW driver. It includes the Keysight Connection Expert, the IVI Shared Components, and the VISA Shared Components.

Keysight IO Libraries version 2018 (or later) must be installed prior to installing and running any other software and prior to powering the PXI chassis with the module installed. The latest version can be downloaded from: www.keysight.com/find/iosuite.

Install the LabVIEW driver from the Keysight M9195A/B Software and Product Information CD.

  1. Insert the Software and Product Information CD into the CD-ROM drive of your PC.

    Wait a few seconds for the auto-run window to appear. If the auto-run window does not appear automatically:

    • Click Start > Run..

    • Type: <drive>:Autorun.exe where <drive> is your CD drive letter.

  2. Select the Install Software link. Follow the installer prompts to install the drivers. Accept all of the default directories specified during installation if prompted. Setup type Typical is applicable for most users.

    The software installer installs the following drivers:

    • Interchangeable Virtual Instrument (IVI) driver is available for programming the Keysight M9195A/B using Microsoft® development environments (e.g., Visual Studio®, C, C++, C#, Visual Basic), Keysight VEE, MATLAB®, or National Instruments® LabVIEWTM.

    • The LabVIEW driver provides access to the functionality of the module through LabVIEW VIs.This driver works in National Instruments LabVIEW development environment. Before this driver can be installed, your computer must already have the IVI Shared Components installed.

    • The driver installer program also installs the Soft Front Panel (SFP) interface. Refer to the SFP help file on the Software and Product information CD for information on using the SFP.

Additional Information

  • Additional M9195A/B Information
  • VIs in Alphabetical Order


Programming Reference

The instrument driver provides access to the functionality of the Keysight M9195A/B Digital Stimulus/Response (DSR) module from National Instruments LabVIEW software.

Related Documentation

The following are related user documentation related to the module:

M9195A/B DSR Startup Guide -- See the M9195A/B Software and Product Information CD or check on the web.

M9195A/B User Guide --Provides configuration, setuip and use information for the module. See the User Guide on the M9195A/B Software and Product Information CD.

Web information on the module: www.keysight.com/find/M9195B.

More Information

  • Additional M9195A/B Information
  • VIs in Alphabetical Order
  • For more information about this driver and other instrument drivers and software available from Keysight Technologies visit: www.keysight.com/find/drivers

  • A list of contact information is available from: www.keysight.com/find/assist


VIs in Alphabetical Order

This topic provides an alphabetic listing of all VIs.

LabVIEW VI Name | Description
Capture Site Fetch Result Byte | Returns the captured result in an array of bytes. Results must fit in a byte.
Capture Sites Set Requested Result Count | Sets the number of Results per channel to be collected.
Capture Sites Set Trigger Mode | Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated or if the execution waits for a trigger event before executing.
Capture Site Abort | Asynchronously stop the execution of the pattern. That is, stop the capture of data.
Capture Site Fetch Result Int16 | Returns the captured result in an array of 16-bit values. Results must fit in a 16-bit integer.
Capture Site Fetch Result Segment Byte | Returns a segment from the captured result. Result must fit in a byte.
Capture Site Fetch Result Segment Int16 | Returns a segment from the captured result. Result must fit in a 16-bit integer.
Capture Site Edge Placement Resolution Auto | Returns the value of EdgePlacementResolutionAuto with which the site was activated.
Capture Site Get Edge Placement Resolution | Returns the EdgePlacementResolution specified when this site was activated. Or, if EdgePlacementResolutionAuto was set to True, this is the edge placement resolution selected by the DSR.
Capture Site Initiate | Begin the execution of a pattern. If the Trigger Mode is set to Immediate, execution will begin immediately. If set to Trigger, the hardware will fully initialize, but will wait for a trigger event before proceeding.
Capture Site Wait for Acquisition Complete | The function will not return until this pattern is done executing. If a pattern has not been initiated or if it has already completed, the function will return immediately.
Capture Sites Activate | Activates a site for data capture.
Capture Sites Get Name | Returns the capture site name that corresponds to the one-based index that the user specifies.
Capture Sites Inactivate | Releases the resources associated with this site. The individual channels are disabled.
Capture Sites Inactivate and Disable | Releases the resources associated with this site. The individual channels are disabled.
Capture Sites Set Trigger Source | Gets or sets the trigger source for this pattern. One or more bits may be set to reference SoftwareTriggers 0-15.
Channel Clamp Voltages | Sets the protection voltages to which inputs are clamped when the clamps are active.
Channel Clamp Voltage Ppmu Enable | Specifies whether the voltage clamps are active when the DSR is in PPMU force current mode. (Note: Voltage clamps are never active when the PPMU is forcing a voltage.)
Channel Line Compensation | Compensates for transmission line effects. The degree can be set from 0 to 7.
Channel Query Clamp Voltage Ppmu Enable | Queries whether the voltage clamps are enabled when producing current for the specified channel of the PPMU.
Channel Clamp Voltage | Queries the voltages to which the inputs clamps are configured.
Channel Query Line Compensation | Queries the line compensation settings for the specified channel.
Channel Query Remote Sense Enable | Queries the line compensation settings for the specified channel.
Channel Query Response Delay Compensation | Queries the response delay compensation for the specified channel.
Channel Query Stimulus Delay | Queries the stimulus delay for the specified channel.
Channel Remote Sense Enable | Controls whether stimulus and measurements use the same physical conductors from the DSR.
Channel Response Delay Compensation | Sets a channel-specific response delay compensation. The delay time is set to the round-trip time for a simultaneous event to begin at the DSR output, go out to the DUT, and the response to arrive back at the DSR.
Channel Stimulus Delay | Sets a channel-specific delay in the output. This delay is relative to the start trigger. Use StimulusDelay to adjust the channels with respect to each other to ensure signals arrive simultaneously at the DUT.
Channels Load Response Delay Compensation | Load previously stored ResponseDelayCompensation values.
Channels Measure Leakage | A measurement to calculate the leakage on specificed channels in order to null them out during PatternSite execution.
Channels Store Response Delay Compensation | Store all current ResponseDelayCompenstion values to a file.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
DC Levels Add | Adds a DcLevel with the specified name.
DC Levels Get Name | Returns the Dclevel name that corresponds to the one-based index that the user specifies.
DC Levels Get Signals | Gets a comma-separated list of Signals for which levels have been defined for this DcLevels block.
DC Levels Query DcLevels | Gets all the DcLevel values for a Signal. If the DcLevel was created from STIL or if it was altered using SetDcLevels, the logic family value will return custom.
DC Levels Remove | Removes the DcLevel block with the specified name.
DC Levels Set DcLevel | Sets an individual DcLevel value for all of the Signals in the SignalExpression. Calling this function will set the Logic Family to custom.
DC Levels Set DcLevels | Sets all the DcLevel values for all the Signals in the SignalExpression. Calling this function will set the Logic Family to custom.
DC Levels Set Logic Family | Sets the Logic Family for all the Signals in the SignalExpression using one of the LogicFamiliesEnum presettings. All DcLevel values are written.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. As a side effect of this call, the instrument is Reset.
Error Message | Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
GetAttributeViBoolean | Gets a Boolean attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
GetAttributeViInt32 | Gets an Int32 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
GetAttributeViReal64 | Gets a Real64 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
GetAttributeViString | Gets a String attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
Initialize with Options | Opens a session with the DSR. Performs a Reset and optionally queries the instrument to validate the model. After initialization, the DSR is then accessible by the Driver methods and properties.
Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Instrument Automatic Corrections Execute | Runs an algorithm which automatically calculates corrections for the instrument. Before calling this function, any external fixtures (inputs to the instrument) must be disconnected from the instrument.
Instrument Available Versions | Returns a comma-delimited string specifying previous software revisions of the product. Any of the revisions returned by this method can be used in a call to the DowngradeFirmware method.
Instrument Clear Cache | Clears all downloaded patterns in the cache. There must not be any active patterns or capture sites.
Instrument Configure Memory | Configures how memory is allocated between storing compiled patterns and results. The memory size is specified for pattern compilation; the return value is the amount of memory available for results.
Instrument Downgrade Firmware | Downgrades the instrument firmware to the firmware used with an earlier version of the product software.
Instrument Get Automatic Corrections Needed | Returns True if the module requires that AutomaticCorrections be performed to guarantee specifications. This occurs if the current module temperature has deviated by more than 5 degrees C from the temperature at which the current corrections were made.
Instrument Get Pattern Cache Size | Gets the current pattern cache size that was set with ConfigureMemory.
Instrument Get Remaining Cache | Calculates and returns the amount of cache memory remaining and available for compiled patterns.
Instrument Get Result Size | Result size as determined by ConfigureMemory.
Instrument Get Slot | The chassis slot number that the module occupies.
Instrument Get Temperature | Return the module temperature in degrees Celsius.
Instrument Measure and Apply Response Delay Compensation | Measures the cable delay of an unterminated cable along with delays internal to the DSR and stores the compensation values into Channels Response Delay Compensation.
Instrument Query Auxiliary Output Control | Queries whether the specified auxiliary, open drain output pin on the module is currently grounded or in a high impedance state.
Instrument Reference Clock Configure | Configures the reference clock source and frequency.
Instrument Remove All Dynamic Items | Removes all of the STIL components, and inactivates any active sites on the instrument.
Instrument Set Auxiliary Output Control | Writes the logical value to one of the four auxiliary, open drain output pins on the module. The pins are numbered 0-3. Writing 1 sets the pin to its high impedance state. Writing zero sets the pin to ground.
Instrument Set Identify | If True, this property causes an indicator LED on the front panel to flash. This assists in identifying the module being programmed. The special indication persists as long as the Boolean is True.
IVI Error Convertor | This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.
MacroDef Define Macros | Defines the patterns to be used as macros.
MacroDef Get Macros | Returns a comma-separated list of Macros defined in this MacroDef.
MacroDefs Add | Adds a MacroDef block of the specified name.
MacroDefs Get Name | Returns the MacroDename that corresponds to the one-based index that the user specifies.
MacroDefs Remove | Removes the MacroDef block with the specified name.
Modules Get Name | Returns the module name that corresponds to the one-based index that the user specifies.
Non Volatile Clear | Clears/discards any changes to cached values and resets cached values to the current nonvolatile settings.
Non Volatile Write | Writes all cached values from the System.Nonvolatile.Item interface to nonvolatile memory. If certain values have changed (see below) the current Passphrase must be supplied to Write.
Pattern Cross Reference | Places a CrossReference instruction in the pattern at the specified Index. CrossReferences are used to relate the result from the pattern execution to a specific line in the pattern.
Pattern Delete Element at Index | Deletes the Pattern element at the specified Index.
Pattern Get Highest Pattern Index | The highest pattern index currently defined. For best efficiency, the next pattern element should be defined at this index+1.
Pattern Get Pattern Length | The current length of the pattern. First index is 1. Note that when loading a file, this is the highest element position in the pattern.
Pattern Get Signals | Returns a comma-separated list of all signals in this pattern.
Pattern Go To | Places a GoTo instruction in the pattern at the specified Index. GoTo causes execution to transfer to the specified label within this pattern.
Pattern Label Vector | Inserts a label on the vector at the specified Index. The index must identify a vector. Labels are used to identify destinations for GoTo statements and to identify locations in a compiled pattern for PatternSite functions that modify the pattern.
Pattern Loop | Places a Loop instruction in the pattern at the specified Index. Loop causes a sequence of instructions to be executed the specified number of times.
Pattern Macro With Substitution | Inserts a Macro expansion at this point, with STIL style parameter substitution.
Pattern Macro | Places a Macro invocation in the pattern at the specified Index. Macro invocation takes no time.
Pattern Match Loop | The loop defined by Index and FinalIndex is executed until each Compare operation in the loop returns true or the LoopCount (if non-zero) is exceeded.
Pattern Query Line Type | Returns information about the pattern element at the given index. This is used to read a pattern that has been defined.
Pattern Query Vector | Provides a way to read back the pattern information for lines that are Vectors. Returns an error if a Vector is not defined at this Index (for instance, if it is outside of the pattern range, or if this Index contains a control instruction).
Pattern Shift | Adds a Shift block to a Macro. If this pattern is executed directly (instead of being used as a macro), this will generate an error upon compilation.
Pattern Site Fetch Result Segment Wide | Returns the result as an array of 32-bit integers. It is only needed when the result data is wider than16 bits (Ordinals for results data are > 15).
Pattern Site Fetch Result Wide | Returns the result as an array of 32-bit integers. It is only needed when the result data is wider than16 bits (Ordinals for results data are > 15).
PatternSite Fetch Trinary Result Segment | Returns an array of captured results. The 32 bits for each element contain two bits for each ordinal (0 - 15); this indicates the actual state of the DUT response on logged compares.
Pattern Site Fetch Trinary Result Segment Wide | Returns a segment from the captured result as an array of 32-bit integers. Only needed when the result data is wider than 32 bits.
Pattern Vector | Specifies the waveform characters for the specified signals at the specified index. This function may be called multiple times for a single index, providing definitions for various signals with each call.
Pattern Watch Loop | Adds a WatchLoop block to a pattern. The DSR will execute the WatchLoop repeatedly until the specified Trigger is received. The only instructions that can be within a WatchLoop are Vectors.
PatternBurst Set Macro Defs | Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.
PatternBurst Set Patterns | omma-separated list of Pattern blocks or other PatternBursts to execute when this Pattern Burst is executed. The patterns are executed in the order specified and any macros are compiled using the MacroDefs block in this PatternBurst.
PatternBursts Add | Adds a PatternBurst block of the specified name.
PatternBursts Get Name | Returns the patternburst name that corresponds to the one-based index that the user specifies.
PatternBursts Remove | Removes the PatternBurst block with the specified name.
PatternExec Set Dc Levels | DcLevels block to be used by the PatternExec.
PatternExec Set Pattern Burst | PatternBurst block to be used by the PatternExec.
PatternExecs Add | Adds a PatternExec block of the specified name.
PatternExecs Get Name | Returns the patternexec name that corresponds to the one-based index that the user specifies.
PatternExecs Remove | Removes the PatternExec block with the specified name.
PatternFile Get Error Count | Returns the number of parsing errors from the last Load. The OpenXML and BulkData parsers may return multiple errros. The STIL parser terminates on the first error, so it always returns 0 or 1 for STIL. Use GetNextError to read the errors.
PatternFile Get Next Error | Returns the next parsing error. If there are no errors, returns "No Error."
PatternFile Load And Update Open Xml | This function loads an OpenXml file and creates STIL components based on the content of the file. The STIL components created are dependent on the file contents. Syntax errors are written to a new sheet in the original OpenXml file.
PatternFile Load Bulk Data Deferred | Loads a Pattern directly into on board memory.
PatternFile Load | This function loads a STIL, OpenXml, or bulk data file and creates objects based on the content of the file. If an element is loaded and there is already one by that name in the same namespace, the new element will replace the original one.
PatternFile Store Stil | Stores all components loaded to a STIL file. Note that it does not preserve comments or annotations from the original file.
Patterns Add | Adds a Pattern block of the specified name.
Patterns Get Name | Returns the pattern name that corresponds to the one-based index that the user specifies.
Patterns Load Bulk Data | Loads the data file into a pattern of a specified name using the bulk data format.
Patterns Remove | Removes the Pattern block with the specified nam
PatternSite Abort | Asynchronously stops the execution of a pattern. The pattern aborts and discards any intermediate results.
PatternSite Fetch Line Information | Gets the information associated with the specified index in the result array.
PatternSite Fetch Result Byte | Gets an array of results and returns them as bytes. The FetchResultByte function works for sites where all ordinals are less than 8 (0-7).
PatternSite Fetch Result Int16 | Gets results in an array of 16-bit integers. The FetchResultInt16 function works for sites with ordinals less than 16 (0-15).
PatternSite Fetch Result Segment Byte | Gets the specified segment of the result as an array of bytes. The FetchResultSegmentByte function works for sites with ordinals less than 8 (0-7).
PatternSite Fetch Result Segment Int16 | Returns the specified segment of the results as an array of 16-bit integers. The FetchResultSegmentInt16 function works for sites with ordinals less than 16 (0-15).
PatternSite Fetch Trinary Result Segment | Returns an array of captured results. The 32 bits for each element contain two bits for each ordinal (0 - 15); this indicates the actual state of the DUT response on logged compares.
PatternSite Fetch Trinary Result | Returns an array of captured results. The 32 bits for each element contain two bits for each ordinal (0 - 15); this indicates the actual state of the DUT response on logged compares.
PatternSite Get Edge Placement Resolution Auto | Returns a Boolean that indicates whether this site was activated with EdgePlacementResolutionAuto.
PatternSite Get Edge Placement Resolution | Returns the edge placement resolution that was used when this pattern was activated. If EdgePlacementResolutionAuto was True at the time of activation, the return value is the value selected by the DSR.
PatternSite Get Execution Errors | Gets a comma-separated string containing errors that occurred during pattern execution. This should be consulted if the ExecutionResult returns an error.
PatternSite Get Execution Result | Gets a Boolean that indicates whether there are any results logged from the previous pattern execution. True indicates there are results.
PatternSite Get Execution State | Returns the state of the pattern execution hardware. Possible values are Stopped, Running, WaitingForTrigger, Complete, Aborted, and Error.
PatternSite Get Result Count | Gets the number of elements in the result from the last pattern execution.
PatternSite Get Result Width | Gets the width of the result, that is, the number of bits in each element of the response. The result width is established by the highest ordinal assigned to a response signal in the site definition.
PatternSite Initiate | Begin the execution of the pattern. If Trigger Mode is set to Immediate, the pattern will begin executing immediately. If Trigger Mode is set to Trigger, the hardware will fully initialize, then it will wait for a trigger event before proceeding.
PatternSite Revaluate Variables | Takes a list of variable expressions separated by semicolons (;), evaluates them, and then recalculates the values in the WaveformTables based on the new values of the variables.
PatternSite RevaluateDcLevels | Takes a list of variable expressions separated by semicolons (;), evaluates them, and then recalculates the values in the WaveformTables based on the new values of the variables.
PatternSite Save Results To File | Saves the results and all of the line information, as text, to the specified file. The individual elements are comma-separated.
PatternSite Set Conditional Loop Failure Mode | Match loops and watch loops include a loop counter which, if expired, indicates that the loop has failed. This property selects what will happen when the loop counter expires (either stop execution or exit the loop and continue
PatternSite Set Conditional Loop Success Mode | Configures if the DSR will execute a MatchLoop or WatchLoop at least one extra time after a successful loop, or if the loop will require no compares in the final few vectors of the loop.
PatternSite Set DcLevel | Specifies a single DC level to apply on the given signal within this pattern. SetDcLevel cannot be called while the pattern is executing.
PatternSite Set Force Validate Enable | If true, any WaveformTables compiled will perform force validation by adding a compare operation to validate a successful force on the last cycle of operations that include force operations.
PatternSite Set Signal | Changes a single signal over a series of clock periods in the compiled waveform. That is, it writes the characters of the provided string into the designated signal in subsequent vectors.
PatternSite Set Vector | Overwrites the vector data at the specified location in a compiled pattern.
PatternSite Set Waveform Table | Overwrites the Waveform Table at the specified location in the compiled pattern.
PatternSite Wait For Acquisition Complete | This function waits for the pattern to complete execution before it returns. If a pattern has not been initiated or if it has already completed, the function will return immediately.
PatternSites Activate from Cache | Activates a previously-compiled PatternSite that has been saved in cache.
PatternSites Activate Pattern | Activates a site for pattern operations. Parameters specify the site, pattern, waveform table, DcLevels, and EdgePlacementResolution. The pattern is compiled and downloaded to the pattern cache.
PatternSites Activate | Activates a previously-compiled PatternSite that has been saved in cache.Activates a site for pattern operations using the specified PatternExec and with the specified EdgePlacementResolution. The pattern is compiled and downloaded to the pattern cache.
PatternSites Compile Pattern Exec | Compiles the components into a PatternSite and saves it to the specified destination (either a file or cache). The name will be used to later reference the PatternSite.
PatternSites Compile Pattern | Changes a single signal over a series of clock periods in the compiled waveform. That is, it writes the characters of the provided string into the designated signal in subsequent vectors.
PatternSites Download Pattern to Cache | Downloads the compiled pattern from the file system to the cache and assigns a name, CacheName, to the compiled pattern.
PatternSites Get Name | Returns the patternsite name that corresponds to the one-based index that the user specifies.
PatternSites Inactivate | Releases the resources associated with this site. The state of the individual channels is not changed (that is, the channels are not disabled).
PatternSites Inactivate and Disable | Releases the resources associated with this site. The individual channels are disabled.
PatternSites List Cache | Returns a comma-separated list of PatternSites previously saved in cache, and the amount of memory each is using.
PatternSites Set End Behavior | Sets the behavior of the signal lines upon completion of a pattern to either retain the last state of the signal lines from the last period or repeat the last waveform character of the last period.
PatternSites Set Result Buffer Size | Specifies the amount of memory, in bytes, to be reserved for results for this pattern. This memory is taken from the memory reserved for results using Instrument Configure Memory.
PatternSites Set Trigger Mode | The trigger mode determines whether the pattern begins executing immediately after it is initiated or whether it waits for a trigger event.
PatternSites Set Trigger Source | Gets or sets the trigger source used to begin execution for this pattern after calling Initiate.
PatternSites Set What to Log | Sets the compares to log during pattern execution (all compares; first failed compare; all failed compares). If "first failed compare" is selected, the first failure terminates the pattern execution.
PpmuSite Force Current Measure Current | Function that forces the specified current and measures the actual current. Note that the ability to force the current depends on the system impedance.
PpmuSite Force Current Measure Voltage | Function that forces the specified current and measures the voltage.
PpmuSite Force Nothing Measure Voltage | Stops any active forcing function (either current or voltage) and measures voltage.
PpmuSite Force Voltage Measure Current | Function that forces the specified voltage and measures the current.
PpmuSite Force Voltage Measure Voltage | Function that forces the specified voltage and measures the actual voltage. Note that the ability to force the voltage depends on the system impedance.
PpmuSite Force | This function forces a current, voltage or shuts off the force function. No measurement is performed.
PpmuSite Get Current Limit | Returns the maximum current the module can produce on this channel based on the current settings.
PpmuSite Get Force Mode | Allows querying of the Force Mode. To set the ForceMode property, use the Force function or one of the Force and Measure functions.
PpmuSite Get Level | Returns the force level currently in use. To set the Level property, use the Force function or one of the Force and Measure functions.
PpmuSite Set Average Mode | Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements.
PpmuSite Set Settling Delay | Specifies the delay, in seconds, between applying the Force and performing the measurement.
PpmuSites Activate | Activates a site for PPMU operations. Once activated, the site block name can be passed to the Item function to access PPMU functions for this site.
PpmuSites Get Name | Returns the ppmusite name that corresponds to the one-based index that the user specifies.
PpmuSites Inactivate and Disable | Releases PPMU resources associated with this site and places the channels into a high impedance state.
PpmuSites Inactivate | Releases PPMU resources associated with this site without altering the signals on the channels.
Reset With Defaults | Does the equivalent of Reset and then, configures the driver to option string settings used when Initialize was executed.
Reset | Places the instrument in the Initialized state. This is the same state the instrument is put in by Initialize, with the exception of PatternCache and TraceEnabled.
Revision Query | Retrieves revision information from the instrument.
Self-Test SetAttributeViBoolean | Performs a self-test on the module. If the module passes the test, the TestResult is zero and TestMessage is 'Self test passed'.
SetAttributeViBoolean | Sets a Boolean attribute from the instrument driver.
SetAttributeViInt32 | Sets an Int32 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
SetAttributeViReal64 | Sets a Real64 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
SetAttributeViString | Sets a String attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.
Signal Set Direction | Gets or sets the direction of this signal. The direction is relative to the DUT.
SignalGroup Set Signals | Sets the list of Signals to use for this SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL signal-reference-expression syntax. For instance "Sig1+Sig2+Bus[0..7]".
SignalGroups Add | Adds a SignalGroup block of the specified name.
SignalGroups Get Name | Returns the signalgroup name that corresponds to the one-based index that the user specifies.
SignalGroups Remove | Removes the SignalGroup block with the specified name.
Signals Add Signal List | Takes a list of Signal names and creates a new Signal for each, including an assigned direction. This provides a way to define several Signals at once.
Signals Add | Adds a Signal of the specified name.
Signals Remove | Removes the Signal block with the specified name.
Site Assign Signal List | Provides a simple way to define several signals from a comma-separated list of Signal names. Automatically assigns channels and ordinals. First Signal name is assigned Channels[0]; ordinals begin from highest ordinal already assigned for that site.
Site Assign Signal | Defines the mapping from a signal to a channel and specifies the ordinal. The ordinal specifies the bit or element number to use when packing measurement results into bytes or arrays.
Site Query Site | Returns the Signals, Channels, and Ordinals defined in the site.
Site Set Marker0 Destination | Sets the destination of all Marker0 references for patterns run on this site.
Site Set Marker1 Destination | Sets the destination of all Marker1 references for patterns run on this site.
Site Set Marker2 Destination | Sets the destination of all Marker2 references for patterns run on this site.
Site Set Trigger0 Source | Configures the trigger event that maps to Trigger0 in the WatchLoop.
Site Set Trigger1 Source | Configures the trigger event that maps to Trigger1 in the WatchLoop.
Site Set Trigger2 Source | Configures the trigger event that maps to Trigger2 in the WatchLoop.
Site Set Trigger3 Source | Configures the trigger event that maps to Trigger3 in the WatchLoop.
Site Set Trigger4 Source | Configures the trigger event that maps to Trigger4 in the WatchLoop.
Site Set Trigger5 Source | Configures the trigger event that maps to Trigger5 in the WatchLoop.
Sites Add | Adds a site with the specified name.
Sites Get Name | Returns the site name that corresponds to the one-based index that the user specifies.
Sites Remove | Removes the Site of the specified name. Fails if the Site is not defined.
StaticSite Read Three State Vector | Inputs a vector and builds it into two integers, one representing the data value and the other indicating if a valid 1 or 0 was detected. The bits of the integers are mapped to the channels based on the ordinals provided in the Site.
StaticSite Read Vector | Inputs a vector and builds it into an integer. The bits of the integer are mapped to the channels based on the ordinals provided in the site.
StaticSite Write Three State Vector | Stimulates the DUT with a vector based on two integers. The bits of the integer are mapped to the channels based on the ordinals provided in the site. The Data parameter sets the truth value; the Enable parameter enables the signal.
StaticSite Write Vector | Stimulates the DUT with a vector based on one integer. The bits of the integer are mapped to channels based on the ordinals in the Site. The Data parameter sets the truth value. All bits configured in the site as Signal In or InOut are written.
StaticSites Activate | Activates a site for StaticSite operations. Once activated, the site block name can be passed to the Item function to access the StaticSite functions for this site.
StaticSites Get Name | Returns the staticsite name that corresponds to the one-based index that the user specifies.
StaticSites Inactivate | Releases StaticSite resources associated with this site without altering the signals on the channels..
StaticSites Inactivate and Disable | Releases StaticSite resources associated with this site and disables the signals on the channels.
SystemGetSerialNumber | The module serial number.
System Get Timeout Milliseconds | Queries the timeout used for IO to the module. To set this value, use the OptionString parameter in the Initialize call.
System Get Trace Enabled | If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.
TriggerEvent Generate Software Events | Generates the events indicated by the bits set in the EventBits parameter. If set, the least significant bit generates the SoftwareTrigger0 event, and the corresponding bits, through bit 15, generate events up through SoftwareTrigger15.
Trigger Get Name | Returns the trigger name that corresponds to the one-based index that the user specifies.
Trigger Set Direction | Used to configure a line as either a Marker or a Trigger.
Trigger Set External Trigger Termination | Configure how the External Triggers are terminated. Default = HighImpedence.
Trigger Set External Trigger Threshold Level | Used to set the voltage level expected by a Trigger for External only.
Trigger Set MarkerPulseWidth | Used to set the width of the pulse generated by a Marker. Default = 100ns.
Trigger Set Polarity | Used to set the polarity of a Marker or expected by a Trigger.
VI Tree | The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.
WaveformTable Define Waveform Character | Defines a new waveform character. This then defines the waveform to be produced when this character is executed on one of the specified signals. This function is called once for each waveform character in the WaveformTable.
WaveformTable Define Waveform Character | Comma-separated list of Signals defined for this Waveform Table.
WaveformTable Get Signals | Returns an array of times and an array of events given the specified signal and waveform character.
WaveformTable Query Waveform Character | Returns all the Waveform Characters defined for the specified Signal.
WaveformTable Query Waveform Characters | The period of the waveforms in this WaveformTable. That is, the total time of each waveform.
WaveformTable Set Period | The period of the waveforms in this WaveformTable. That is, the total time of each waveform.
WaveformTables Add Simple Waveform Table | Creates a basic waveform table that defines commonly-defined waveform characters at a given drive time and compare time.
WaveformTables Get Name | Returns the waveformtable name that corresponds to the one-based index that the user specifies.
WaveformTables Remove | Removes the WaveformTable block of specified name.
WaveformTables Add | Adds a WaveformTable block of specified name.


Attributes

The following table provides an alphabetical listing of the attributes used in this driver.

Attribute | Functions using this Attribute | Description
CALIBRATION_USE_FIXTURE | GetAttributeViBoolean, SetAttributeViBoolean | Indicates whether the Calibration will be performed with the factory-provided fixture.
CALIBRATION_ADJUSTMENT_INFORMATION | GetAttributeViString | Returns a comma separated list of calibration adjustment information.
CALIBRATION_DUE_DATE | GetAttributeViString | Returns the computed date of the next required instrument calibration.
CALIBRATION_INSTRUMENT_IDENTIFIER | GetAttributeViString | Returns the unique identifier for the collection of modules that make up the current instrument.
CALIBRATION_STATUS | GetAttributeViInt32 | Returns the calibration status of the instrument.
CALIBRATION_VERIFICATION_INFORMATION | GetAttributeViString | Returns a comma separated list of calibration verification information.
Capture Site_EDGE_PLACEMENT_RESOLUTION | GetAttributeViBoolean GetAttributeViReal64 | Returns the EdgePlacementResolution specified when this site was activated. Or, if EdgePlacementResolutionAuto was set to True, this is the edge placement resolution selected by the DSR.
Capture Site_EDGE_PLACEMENT_RESOLUTION_AUTO | GetAttributeViBoolean | Returns the value of EdgePlacementResolutionAuto with which the site was activated.
Capture Site_EXECUTION_STATE | GetAttributeViInt32 | Returns the execution state. Execution States are : Executing (0), Stopped (1), Waiting for initiate Trigger (2), Complete (3), Aborted (4), Error (5), Waiting for Match Loop (6), Watching for Trigger0 (7), Watching for Trigger1 (8), Watching for Trigger2 (9), Watching for Trigger3 (A), Watching for Trigger4 (B), Watching for Trigger5 (C).
Capture Site_REQUESTED_RESULT_COUNT | SetAttributeViInt32 | Number of Results per channel to be collected.
Capture Site_RESULT_COUNT | GetAttributeViInt32 | Gets the number of elements in the result in memory.
CATURESITES_COUNT | GetAttributeViInt32 | Number of capture sites.
Capture SiteS_TRIGGER_MODE | GetAttributeViInt32 SetAttributeViInt32 | Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated (0) or if the execution waits for a trigger event before executing (1).
Capture SiteS_TRIGGER_SOURCE | GetAttributeViString SetAttributeViString | Gets or sets the trigger source for this pattern. String format is: SoftwareTrigger<0-15>.
DCLEVEL_SIGNALS | GetAttributeViString | Gets a comma-separated list of Signals for which levels have been defined for this DcLevels block.
DCLEVELS_COUNT | DC Levels Get Name GetAttributeViInt32 | Number of DcLevels.
DRIVER_SETUP | GetAttributeViString | Returns the driver setup string that the user specified in the IVI configuration store when the instrument driver session was initialized or passed in the OptionString parameter of the Initialize function.
INSTRUMENT_AUTOMATIC_CORRECTIONS_NEEDED | GetAttributeViBoolean | Returns True if the module requires that AutomaticCorrections be performed to guarantee specifications. This occurs if the current module temperature has deviated by more than 5 degrees C from the temperature at which the current corrections were made.
INSTRUMENT_CACHE_SIZE | GetAttributeViInt32 | Gets the current pattern cache size that was set with ConfigureMemory.
INSTRUMENT_FIRMWARE_REVISION | GetAttributeViString | The firmware revision loaded onto the module. The string is of the form <Major>.<Minor>.<Build>.<Patch>.
INSTRUMENT_IDENTIFY | GetAttributeViBoolean SetAttributeViBoolean | If True, this attribute causes an indicator LED on the front panel to flash. This assists in identifying the module being programmed. The special indication persists as long as the Boolean is True.
INSTRUMENT_LOST_LOCK | GetAttributeViBoolean | True indicates that the reference clock PLL has lost lock since it was last tested.
INSTRUMENT_MANUFACTURER | GetAttributeViString | Returns the instrument manufacturer, "Keysight Technologies".
INSTRUMENT_MODEL | GetAttributeViString | The model number of the instrument. Returns "M9195A".
INSTRUMENT_REFERENCECLOCK_FREQUENCY | GetAttributeViReal64 | This attribute returns the frequency, in Hz, specified with Configure.
INSTRUMENT_REFERENCECLOCK_SOURCE | GetAttributeViInt32 | This attribute returns the reference frequency source specified with Configure. Sources are : DStarA (0), Front Panel (1), PXI100 (2).
INSTRUMENT_REMAINING_CACHE | GetAttributeViInt32 | Calculates and returns the amount of cache memory remaining and available for compiled patterns.
INSTRUMENT_RESULT_SIZE | GetAttributeViInt32 | Result size as determined by ConfigureMemory.
INSTRUMENT_SLOT | GetAttributeViInt32 | The chassis slot number that the module occupies.
INSTRUMENT_TEMPERATURE | GetAttributeViReal64 | The module temperature in degrees Celsius.
IO_RESOURCE_DESCRIPTOR | GetAttributeViString | The resource descriptor specifies the connection to module. It may be specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is null if the driver is not initialized.
LOGICAL_NAME | GetAttributeViString | The Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If empty, the driver was initialized without using the Configuration Store.
MACRODEF_MACROS | GetAttributeViString | Returns a comma-separated list of Macros defined in this MacroDef.
MACRODEFS_COUNT | GetAttributeViInt32 | Number of MacroDefs.
MODULE_CALIBRATION_ADJUSTMENT_INFORMATION | GetAttributeViString | Returns a multi-line list of calibration adjustment information.
MODULE_CALIBRATION_DUE_DATE | GetAttributeViString | Returns the computed date of the next required module calibration date.
MODULE_CALIBRATION_STATUS | GetAttributeViInt32 | Returns the calibration status of the module.
MODULE_CALIBRATION_VERIFICATION_INFORMATION | GetAttributeViString | Returns a multi-line list of calibration verification information. Each system that the module calibration has been verified with will generate a line that includes the calibration date and instrument identifier.
MODULE_IDENTIFY | GetAttributeViBoolean | Flashes the light on the front of the module.
MODULE_NONVOLATILE_ASSET_NUMBER | GetAttributeViString | Returns the asset number of the module.
MODULE_NONVOLATILE_CAL_DUE_REMINDER | GetAttributeViInt32 | Returns the "reminder" period, in days, prior to any calibration due.
MODULE_NONVOLATILE_ENABLE_INSTRUMENT_CAL_WARNINGS | GetAttributeViBoolean | Enable/disable of instrument cal checks/warnings.
MODULE_NONVOLATILE_ENABLE_MODULE_CAL_WARNINGS | GetAttributeViBoolean | Enable/disable of module cal checks/warnings.
MODULE_NONVOLATILE_ENABLE_PERIODIC_CAL | GetAttributeViBoolean | Enable/disable of "subject to periodic cal".
MODULE_NONVOLATILE_INSTRUMENT_CAL_INTERVAL | GetAttributeViInt32 | Returns the instrument (multi-module) calibration interval in days.
MODULE_NONVOLATILE_MODULE_CAL_INTERVAL | GetAttributeViInt32 | Returns the module calibration interval in days.
MODULE_NONVOLATILE_PASSPHRASE | GetAttributeViString | Returns a passphrase used to protect various values in Nonvolatile
MODULE_NONVOLATILE_SYSTEM_IDENTIFICATION | GetAttributeViString | Returns a persistent arbitrary string with a maximum length of 32 characters nominally intended to provide a user customizable method to distinguish modules.
MODULE_OPTIONS | GetAttributeViString | Returns a comma separated list of the options installed in the module.
MODULE_SERIAL_NUMBER | GetAttributeViString | Returns the serial number of the module.
MODULE_SLOT | GetAttributeViInt32 | Returns the chassis slot the module occupies.
MODULE_TEMPERATURE | GetAttributeViReal64 | Returns the module temperature in degrees Celsius.
MODULES_COUNT | GetAttributeViInt32 | Returns the number of modules.
PATTERN_HIGHEST_PATTERN_INDEX | GetAttributeViInt32 | The highest pattern index currently defined. For best efficiency, the next pattern element should be defined at this index+1.
PATTERN_PATTERN_LENGTH | GetAttributeViInt32 | The current length of the pattern. First index is 1. Note that when loading a file, this is the highest element position in the pattern.
PATTERN_SIGNALS | GetAttributeViString | Returns a comma-separated list of all signals in this pattern.
PATTERNBURST_MACRO_DEFS | GetAttributeViString SetAttributeViString | Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.
PATTERNBURST_PATTERNS | GetAttributeViString SetAttributeViString | Comma-separated list of Pattern blocks or other PatternBursts to execute when this Pattern Burst is executed. The patterns are executed in the order specified and any macros are compiled using the MacroDefs block in this PatternBurst.
PATTERNBURSTS_COUNT | GetAttributeViInt32 | Number of PatternBursts.
PATTERNEXEC_DC_LEVELS | GetAttributeViString | DcLevels block to be used by the PatternExec.
PATTERNEXEC_PATTERN_BURST | GetAttributeViString | PatternBurst block to be used by the PatternExec.
PATTERNEXECS_COUNT | GetAttributeViInt32 | Number of PatternExecs.
PATTERNFILE_ERROR_COUNT | GetAttributeViInt32 | Returns the number of parsing errors from the last Load. The OpenXML and BulkData parsers may return multiple errros. The STIL parser terminates on the first error, so it always returns 0 or 1 for STIL. Use GetNextError to read the errors.
PATTERNS_COUNT | GetAttributeViInt32 | Number of Patterns.
PATTERNSITE_CONDITIONAL_LOOP_FAILURE_MODE | GetAttributeViInt32 SetAttributeViInt32 | Match loops and watch loops include a loop counter which, if expired, indicates that the loop has failed. This attribute selects what will happen when the loop counter expires (either stop execution (0) or exit the loop and continue (1)).
PATTERNSITE_CONDITIONAL_LOOP_SUCCESS_MODE | GetAttributeViInt32 SetAttributeViInt32 | Configures if the DSR will execute a MatchLoop at least one extra time after a successful loop (0), or if the MatchLoop will require no compares in the final few cycles of the loop (1).
PATTERNSITE_EDGE_PLACEMENT_RESOLUTION | GetAttributeViReal64 | Returns the edge placement resolution that was used when this pattern was activated. If EdgePlacementResolutionAuto was True at the time of activation, the return value is the value selected by the DSR.
PATTERNSITE_EDGE_PLACEMENT_RESOLUTION_AUTO | GetAttributeViBoolean | Returns a Boolean that indicates whether this site was activated with EdgePlacementResolutionAuto.
PATTERNSITE_EXECUTION_RESULT | GetAttributeViBoolean | Gets a Boolean that indicates whether there are any results logged from the previous pattern execution. True indicates there are results.
PATTERNSITE_EXECUTION_STATE | GetAttributeViInt32 | Returns the state of the pattern execution hardware. Possible values are Running (0),Stopped (1), WaitingForTrigger (2), Complete (3), Aborted (4), and Error (5).
PATTERNSITE_FORCE_VALIDATE_ENABLE | GetAttributeViBoolean SetAttributeViBoolean | If true, any WaveformTables compiled will perform force validation by adding a compare operation to validate a successful force on the last cycle of operations that include force operations.
PATTERNSITE_RESULT_COUNT | GetAttributeViInt32 | Gets the number of elements in the result from the last pattern execution.
PATTERNSITE_RESULT_WIDTH | GetAttributeViInt32 | Gets the width of the result, that is, the number of bits in each element of the response. The result width is established by the highest ordinal assigned to a response signal in the site definition.
PATTERNSITE_TERMINATION_REASON | GetAttributeViString | Gets a comma-separated string containing errors that occurred during pattern execution. This should be consulted if the ExecutionResult returns an error.
PATTERNSITES_COUNT | GetAttributeViInt32 | Number of PatternSites.
PATTERNSITES_END_BEHAVIOR | GetAttributeViInt32 SetAttributeViInt32 | Sets the behavior of the signal lines upon completion of a pattern to either retain the last state of the signal lines from the last period (0) or repeat the last waveform character of the last period (1).
PATTERNSITES_RESULT_BUFFER_SIZE | GetAttributeViInt32 SetAttributeViInt32 | Specifies the amount of memory, in bytes, to be reserved for results for this pattern. This memory is taken from the memory reserved for results using Instrument Configure Memory.
PATTERNSITES_TRIGGER_MODE | GetAttributeViInt32 SetAttributeViInt32 | The trigger mode determines whether the pattern begins executing immediately after it is initiated (0) or whether it waits for a trigger event (1).
PATTERNSITES_TRIGGER_SOURCE | GetAttributeViString SetAttributeViString | Gets or sets the trigger source used to begin execution for this pattern after calling Initiate.
PATTERNSITES_WHAT_TO_LOG | GetAttributeViInt32 SetAttributeViInt32 | Sets the compares to log during pattern execution (all compares; first failed compare; all failed compares). If "first failed compare" is selected, the first failure terminates the pattern execution.
PPMUSITE_AVERAGE_MODE | GetAttributeViInt32 SetAttributeViInt32 | Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements.
PPMUSITE_CURRENT_LIMIT | GetAttributeViReal64 | Returns the maximum current the module can produce on this channel based on the current settings.
PPMUSITE_FORCE_MODE | GetAttributeViInt32 | Allows querying of the Force Mode. To set the ForceMode attribute, use the Force function or one of the Force and Measure functions.
PPMUSITE_LEVEL | GetAttributeViReal64 | Returns the force level currently in use. To set the Level attribute, use the Force function or one of the Force and Measure functions.
PPMUSITE_SETTLING_DELAY | GetAttributeViReal64 SetAttributeViReal64 | Specifies the delay, in seconds, between applying the Force and performing the measurement.
PPMUSITES_COUNT | GetAttributeViInt32 | Number of PPMU sites.
SIGNAL_DIRECTION | GetAttributeViInt32 SetAttributeViInt32 | Gets or sets the direction of this signal. The direction is relative to the DUT.
SIGNALGROUP_SIGNALS | GetAttributeViString SetAttributeViString | Sets the list of Signals to use for this SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL signal-reference-expression syntax. For instance "Sig1+Sig2+Bus[0..7]".
SIGNALGROUPS_COUNT | GetAttributeViInt32 | Number of SignalGroups.
SIGNALS_COUNT | GetAttributeViInt32 | Number of Signals.
SIMULATE | GetAttributeViBoolean SetAttributeViBoolean | If True, the driver does not perform I/O to the instrument, but returns simulated values for output parameters and results.
SITES_COUNT | GetAttributeViInt32 | Number of Sites.
SITE_MARKER0_DESTINATION | GetAttributeViString SetAttributeViString | Sets the destination of all Marker0 references for patterns run on this site.
SITE_MARKER1_DESTINATION | GetAttributeViString SetAttributeViString | Sets the destination of all Marker1 references for patterns run on this site.
SITE_MARKER2_DESTINATION | GetAttributeViString SetAttributeViString | Sets the destination of all Marker2 references for patterns run on this site.
SITE_TRIGGER0_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger0 in the WatchLoop.
SPECIFIC_DRIVER_DESCRIPTION | GetAttributeViString | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
SPECIFIC_DRIVER_REVISION | GetAttributeViString | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
SPECIFIC_DRIVER_VENDOR | GetAttributeViString | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
STATICSITES_COUNT | GetAttributeViInt32 | Number of StaticSites.
SUPPORTED_INSTRUMENT_MODELS | GetAttributeViString | A comma-separated list of instrument models that the IVI specific driver can control. Returns "M9195A".
SYSTEM_ABOUT | GetAttributeViString | Returns addition information about the system beyond the firmware and hardware versions.
SYSTEM_LICENSING_HOST_IDENTIFIER | GetAttributeViString | The unique key identifying the system controller for licensing purposes. Also called HostID.
SYSTEM_LICENSING_INSTALLED_LICENSES | GetAttributeViString | A semicolon-separated list of the software licenses installed on the system controller. Each software license consists of a comma-separated Feature Name and Description.
SYSTEM_OPTIONS | GetAttributeViString | Returns a comma-separated list of the options installed on the instrument, such as "MMS, S04, SR2, M12".
SYSTEM_SERIAL_NUMBER | GetAttributeViString | The module serial number.
SYSTEM_TIMEOUT_MILLISECONDS | GetAttributeViInt32 | Queries the timeout used for IO to the module. To set this value, use the OptionString parameter in the Initialize call.
SYSTEM_TRACE_ENABLED | GetAttributeViBoolean SetAttributeViBoolean | If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.
TRIGGER_COUNT | GetAttributeViInt32 | Returns the number of trigger and marker signals supported by the DSR module.
TRIGGER_DIRECTION | GetAttributeViInt32 SetAttributeViInt32 | This property sets the direction of those DSR signals that are bi-directional and can be either a trigger input or a marker output.
TRIGGER_EXTERNAL_TRIGGER_TERMINATION | GetAttributeViInt32 SetAttributeViInt32 | This property configures the input termination impedance of the two front panel trigger inputs, GPIO1 (External1) and GPIO2 (External2).
TRIGGER_EXTERNAL_TRIGGER_THRESHOLD_LEVEL | GetAttributeViReal64 SetAttributeViReal64 | Sets the threshold voltage levels for the front panel signals, GPIO1 (External1) and GPIO2 (External2), when they are programmed as trigger inputs.
TRIGGER_MARKER_PULSE_WIDTH | GetAttributeViReal64 SetAttributeViReal64 | This property sets the pulse width of marker outputs.
TRIGGER_POLARITY | GetAttributeViInt32 SetAttributeViInt32 | For a marker output, Polarity controls whether the marker will go high (positive) or low (negative). For a trigger input, Polarity controls whether a trigger will be detected on the rising (positive) edge or on the falling (negative) edge of the input.
TRIGGER1_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger1 in the WatchLoop. The Trigger1Source attribute assigns the source of trigger events to use when the pattern references Trigger1. For instance, in the pattern below, Vector WXYZ; Vector ABCD; WatchLoop 10 Trigger1 { Vector EFGH; } code similar to this would set the above WatchLoop to watch for SoftwareTrigger1: myDriver.Site.Item["mySite"].Trigger1Source="SoftwareTrigger1"; For more information on the Sites interface, see the Sites Overview
TRIGGER2_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger2 in the WatchLoop. The Trigger2Source attribute assigns the source of trigger events to use when the pattern references Trigger2. For instance, in the pattern below, Vector WXYZ; Vector ABCD; WatchLoop 10 Trigger2 { Vector EFGH; } code similar to this would set the above WatchLoop to watch for SoftwareTrigger1: myDriver.Site.Item["mySite"].Trigger2Source="SoftwareTrigger1"; For more information on the Sites interface, see the Sites Overview.
TRIGGER3_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger3 in the WatchLoop. The Trigger3Source attribute assigns the source of trigger events to use when the pattern references Trigger3. For instance, in the pattern below, Vector WXYZ; Vector ABCD; WatchLoop 10 Trigger3 { Vector EFGH; } code similar to this would set the above WatchLoop to watch for SoftwareTrigger1: myDriver.Site.Item["mySite"].Trigger3Source="SoftwareTrigger1"; For more information on the Sites interface, see the Sites Overview.
TRIGGER4_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger4 in the WatchLoop. The Trigger4Source attribute assigns the source of trigger events to use when the pattern references Trigger4. For instance, in the pattern below, Vector WXYZ; Vector ABCD; WatchLoop 10 Trigger4 { Vector EFGH; } code similar to this would set the above WatchLoop to watch for SoftwareTrigger1: myDriver.Site.Item["mySite"].Trigger4Source="SoftwareTrigger1"; For more information on the Sites interface, see the Sites Overview.
TRIGGER5_SOURCE | GetAttributeViString SetAttributeViString | Configures the trigger event that maps to Trigger5 in the WatchLoop. The Trigger5Source attribute assigns the source of trigger events to use when the pattern references Trigger5. For instance, in the pattern below, Vector WXYZ; Vector ABCD; WatchLoop 10 Trigger5 { Vector EFGH; } code similar to this would set the above WatchLoop to watch for SoftwareTrigger1: myDriver.Site.Item["mySite"].Trigger5Source="SoftwareTrigger1"; For more information on the Sites interface, see the Sites Overview.
WAVEFORMTABLE_PERIOD | GetAttributeViReal64 SetAttributeViReal64 | The period of the waveforms in this WaveformTable. That is, the total time of each waveform.
WAVEFORMTABLE_SIGNALS | GetAttributeViString | Comma-separated list of Signals defined for this Waveform Table.
WAVEFORMTABLES_COUNT | GetAttributeViInt32 | Number of WaveFormTables.


Utility VIs

VI Tree

Close

Disable

Error Message

Initialize

Initialize with Options

IVI Error Convertor

Reset

Reset With Defaults

Revision Query

Self-Test

TriggerEvent Generate Software Events


Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Disable

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. As a side effect of this call, the instrument is Reset.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Error Message

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ErrorCode

Instrument driver status code.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Error Message

Instrument driver error message.


Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource name

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Keysight devices may not appear in NI Max).

id query (Off)

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that are supported by the driver. If the model is not supported, Initialize will fail with the E_IVI_ID_QUERY_FAILED error code..

reset device (Off)

This parameter is ignored, as the DSR is always reset upon initialization.

Closed Instrument error in

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Initialize with Options

Opens a session with from one to twelve DSR modules. Performs a Reset and optionally queries the instrument to validate the model. After initialization, the DSR module(s) are accessible by the driver methods and properties.

Inputs

resource name

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Keysight devices may not appear in NI Max).

id query (Off)

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that are supported by the driver. If the model is not supported, Initialize will fail with the E_IVI_ID_QUERY_FAILED error code..

reset device (Off)

This parameter is ignored, as the DSR is always reset upon initialization.

Closed Instrument error in

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

option string

The OptionsString parameter can be used to set various initial values and modes of the driver. Notably, simulation can be enabled with the string "Simulation=True".

Outputs

Closed Instrument handle out and error out

instrument handle out

Unique identifier for an IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


IVI Error Convertor

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

IVI error code (0)

Error code returned from an IVI instrument driver operation.

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None


Reset

Places the instrument in the Initialized state. This is the same state the instrument is put in by Initialize, with the exception of PatternCache and TraceEnabled.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Reset

Patterns that have been downloaded to cache via DownloadPatternToCache and CompilePattern remain in cache, and are accessible after the Reset.

Patterns that have been downloaded to cache via ActivatePattern are not accessible after the reset.

If Instrument ConfigureMemory has been executed, it will remain in effect after the Reset.

The setting of System TraceEnabled is not changed by Reset.


Reset With Defaults

Does the equivalent of Reset and then, configures the driver to option string settings used when Initialize was executed.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Revision Query

Retrieves revision information from the instrument.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.


Self-Test

Performs a self-test on the module. If self-test passes, TestResult is zero and TestMessage is 'Self test passed'. If self-test fails, TestResult will always return the error code -2147205102, and TestMessage will provide information on the failure(s).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

self test result

The numeric result from the self-test operation. 0 = no error (test passed).

self-test message

The self-test status message.

Remarks:

If there are multiple self-test failures, the TestMessage string will contain a message for each failure, each separated by a newline.

The SelfTest function is only supported on a single-module instrument. Attempting to run self-test on a multi-module instrument will generate an exception. However, self-test can be run on a multi-module instrument using the DSR SFP. See the SFP help for more information.

For information about multi-module operation, see Multi-module Operation.


TriggerEvent Generate Software Events

Generates the events indicated by the bits set in the EventBits parameter. If set, the least significant bit generates the SoftwareTrigger0 event, and the corresponding bits, through bit 15, generate events up through SoftwareTrigger15.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EventBits

Integer whose bits indicate the software triggers to generate.

Software trigger TriggerSource string EventBits value

Software0 "SoftwareTrigger0" 1

Software1 "SoftwareTrigger1" 2

Software2 "SoftwareTrigger2" 4

Software3 "SoftwareTrigger3" 8

Software4 "SoftwareTrigger4" 16

Software5 "SoftwareTrigger5" 32

Software6 "SoftwareTrigger6" 64

Software7 "SoftwareTrigger7" 128

Software8 "SoftwareTrigger8" 256

Software9 "SoftwareTrigger9" 512

Software10 "SoftwareTrigger10" 1024

Software11 "SoftwareTrigger11" 2048

Software12 "SoftwareTrigger12" 4096

Software13 "SoftwareTrigger13" 8192

Software14 "SoftwareTrigger14" 16384

Software15 "SoftwareTrigger15" 32768

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

GenerateSoftwareEvents is useful to trigger various operations. Triggers can be used to start pattern execution, or to satisfy a WatchLoop condition.

The following scenarios are useful:

  • Several sequencers can be started at the same time, either by having them wait on the same event, or by sending multiple simultaneous events with this function.
  • WatchLoop operations can be released by issuing a software trigger. This may be especially useful if the pattern needs to be synchronized with software. For instance, a test can be divided up into several steps, with each step beginning with a WatchLoop. Trigger events can then be generated to step the pattern through each step with minimum software overhead.
  • Pattern execution can watchloop synchronization can be combined so that one pattern can be started, and another released from a WatchLoop by the same call to GenerateSoftwareEvents.

The table below shows the relationship between Software Triggers, TriggerSource strings, and EventBits. Multiple bits may be set to generate multiple software triggers.

TriggerSource string | Set EventBits to this value when calling GenerateSoftwareEvents
"SoftwareTrigger0" | 1
"SoftwareTrigger1" | 2
"SoftwareTrigger2" | 4
"SoftwareTrigger3" | 8
"SoftwareTrigger4" | 16
"SoftwareTrigger5" | 32
"SoftwareTrigger6" | 64
"SoftwareTrigger7" | 128
"SoftwareTrigger8" | 256
"SoftwareTrigger9" | 512
"SoftwareTrigger10" | 1024
"SoftwareTrigger11" | 2048
"SoftwareTrigger12" | 4096
"SoftwareTrigger13" | 8192
"SoftwareTrigger14" | 16348
"SoftwareTrigger15" | 32768

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on triggers and markers, see Trigger and Marker Overview.


Get-Set Attribute VIs

GetAttributeViBoolean

GetAttributeViInt32

GetAttributeViReal64

GetAttributeViString

SetAttributeViBoolean

SetAttributeViInt32

SetAttributeViReal64

SetAttributeViString


GetAttributeViBoolean

Gets a Boolean attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

CALIBRATION_USE_FIXTURE

Capture Site_EDGE_PLACEMENT_RESOLUTION_AUTO *

INSTRUMENT_AUTOMATIC_CORRECTIONS_NEEDED

INSTRUMENT_IDENTIFY

INSTRUMENT_LOST_LOCK

MODULE_IDENTIFY

MODULE_NONVOLATILE_ENABLE_INSTRUMENT_CAL_WARNINGS

MODULE_NONVOLATILE_ENABLE_MODULE_CAL_WARNINGS

MODULE_NONVOLATILE_ENABLE_PERIODIC_CAL

PATTERNSITE_EDGE_PLACEMENT_RESOLUTION_AUTO *

PATTERNSITE_EXECUTION_RESULT *

PATTERNSITE_FORCE_VALIDATE_ENABLE

SIMULATE

SYSTEM_TRACE_ENABLED

Inputs

Closed Instrument handle in and error in
instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RepCapIdentifier

Some attributes will require a Repeated Capability Identifier string in this field, otherwise, it should be left empty. See the Context Help for the AttributeID field below to determine if that AttributeID requires a string entry for the RepCapIdentifier.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

CALIBRATION_USE_FIXTURE : Indicates whether the Calibration will be performed with the factory-provided fixture.

Capture Site_EDGE_PLACEMENT_RESOLUTION_AUTO (Required RepCap Identifier : Capture Site Name) : Returns the value of EdgePlacementResolutionAuto with which the site was activated.

INSTRUMENT_AUTOMATIC_CORRECTIONS_NEEDED : Returns True if the module requires that AutomaticCorrections be performed to guarantee specifications. This occurs if the current module temperature has deviated by more than 5 degrees C from the temperature at which the current corrections were made.

INSTRUMENT_IDENTIFY : If True, this attribute causes an indicator LED on the front panel to flash. This assists in identifying the module being programmed. The special indication persists as long as the Boolean is True.

INSTRUMENT_LOST_LOCK : True indicates that the reference clock PLL has lost lock since it was last tested.

MODULE_IDENTIFY : Flashes the light on the front of the module.

MODULE_NONVOLATILE_ENABLE_INSTRUMENT_CAL_WARNINGS : Enable/disable of instrument cal checks/warnings. If this value is true and module calibration date + ModuleCalInterval is close or past, then a warning will be generated. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is false. This value is not affected by Reset or power cycle.

MODULE_NONVOLATILE_ENABLE_MODULE_CAL_WARNINGS : Enable/disable of module cal checks/warnings. If this value is true and module calibration date + ModuleCalInterval is close or past, then a warning will be generated. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is false. This value is not affected by Reset or power cycle.

MODULE_NONVOLATILE_ENABLE_PERIODIC_CAL : Enable/disable of "subject to periodic cal". If this value is false, no checks of cal dates/intervals should be done and the SFP should display "Not subject to periodic cal". Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is false. This value is not affected by Reset or power cycle.

PATTERNSITE_EDGE_PLACEMENT_RESOLUTION_AUTO (Required RepCap Identifier : Pattern Site Name) : Returns a Boolean that indicates whether this site was activated with EdgePlacementResolutionAuto.

PATTERNSITE_EXECUTION_RESULT (Required RepCap Identifier : Pattern Site Name) : Gets a Boolean that indicates whether there are any results logged from the previous pattern execution. True indicates there are results.

PATTERNSITE_FORCE_VALIDATE_ENABLE : If true, any WaveformTables compiled will perform force validation by adding a compare operation to validate a successful force on the last cycle of operations that include force operations.

SIMULATE : If True, the driver does not perform I/O to the instrument, but returns simulated values for output parameters and results.

SYSTEM_TRACE_ENABLED : If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.

Outputs

Closed Instrument handle out and error out
instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViInt32

Gets an Int32 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

CALIBRATION_STATUS

Capture Site_EXECUTION_STATE *

Capture Site_REQUESTED_RESULT_COUNT

Capture Site_RESULT_COUNT *

Capture SiteS_COUNT

Capture SiteS_TRIGGER_MODE

DCLEVELS_COUNT

INSTRUMENT_CACHE_SIZE

INSTRUMENT_REFERENCECLOCK_SOURCE

INSTRUMENT_REMAINING_CACHE

INSTRUMENT_RESULT_SIZE

INSTRUMENT_SLOT

MACRODEFS_COUNT

MODULE_CALIBRATION_STATUS

MODULE_NONVOLATILE_CAL_DUE_REMINDER

MODULE_NONVOLATILE_INSTRUMENT_CAL_INTERVAL

MODULE_NONVOLATILE_MODULE_CAL_INTERVAL

MODULE_SLOT

MODULES_COUNT

PATTERN_HIGHEST_PATTERN_INDEX *

PATTERN_PATTERN_LENGTH *

PATTERNBURSTS_COUNT

PATTERNEXECS_COUNT

PATTERNFILE_ERROR_COUNT

PATTERNS_COUNT

PATTERNSITE_CONDITIONAL_LOOP_FAILURE_MODE

PATTERNSITE_CONDITIONAL_LOOP_SUCCESS_MODE

PATTERNSITE_EXECUTION_STATE *

PATTERNSITE_RESULT_COUNT *

PATTERNSITE_RESULT_WIDTH *

PATTERNSITES_COUNT

PATTERNSITES_END_BEHAVIOR

PATTERNSITES_RESULT_BUFFER_SIZE

PATTERNSITES_TRIGGER_MODE

PATTERNSITES_WHAT_TO_LOG

PPMUSITE_AVERAGE_MODE *

PPMUSITE_FORCE_MODE *

PPMUSITES_COUNT

SIGNAL_DIRECTION *

SIGNALGROUPS_COUNT

SIGNALS_COUNT

SITES_COUNT

STATICSITES_COUNT

SYSTEM_TIMEOUT_MILLISECONDS

TRIGGER_COUNT

TRIGGER_DIRECTION*

TRIGGER_POLARITY*

TRIGGER_EXTERNAL_TRIGGER_TERMINATION*

WAVEFORMTABLES_COUNT

Inputs

Closed Instrument handle in and error in
Instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

Capture Site_EXECUTION_STATE (Required RepCap Identifier : Capture Site Name) : Returns the state of the data capture hardware. Execution States are : Executing (0), Stopped (1), Waiting for initiate Trigger (2), Complete (3), Aborted (4), Error (5), Waiting for Match Loop (6), Watching for Trigger0 (7), Watching for Trigger1 (8), Watching for Trigger2 (9), Watching for Trigger3 (A), Watching for Trigger4 (B), Watching for Trigger5 (C).
This property is used to poll the DSR to determine if a CaptureSite has completed execution or not. Use WaitForAcquisitionComplete to stop the execution of a client program until the CaptureSite finishes executing. The values returned have the following meaning:

  • Stopped : The pattern has not yet been initiated.
  • Executing : The pattern has not yet been initiated.
  • WaitingForTrigger : The pattern is waiting for a trigger. This could be waiting for a trigger to begin execution, or waiting for a trigger in a WatchLoop.
  • Complete : The pattern has completed execution without error.
  • Aborted : The pattern execution was aborted by the user.
  • Error : An error occurred during pattern execution. (Check ExecutionErrors.)

For more information on the Capture Sites interface, see the Capture Sites Overview.

CALIBRATION_STATUS : Returns the calibration status of the instrument. The status is determined by comparing the (calibration due date - cal due reminder value) to the current date.

The defined calibration status values are:

  • KTMDSR_VAL_CALIBRATION_STATUS_INSTRUMENT_CALIBRATED
  • KTMDSR_VAL_CALIBRATION_STATUS_DUE
  • KTMDSR_VAL_CALIBRATION_STATUS_EXPIRED
  • KTMDSR_VAL_CALIBRATION_STATUS_NOT_CALIBRATED
  • KTMDSR_VAL_CALIBRATION_STATUS_NOT_SUBJECT_TO_CALIBRATION
  • KTMDSR_VAL_CALIBRATION_STATUS_MODULE_CALIBRATED

Capture Site_REQUESTED_RESULT_COUNT : Number of Results per channel to be collected.

Capture Site_RESULT_COUNT (Required RepCap Identifier : Capture Site Name) : Gets the number of elements in the result in memory.

Capture SiteS_COUNT : The number of Capture SiteS defined.

Capture SiteS_TRIGGER_MODE : Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated (0) or if the execution waits for a trigger event before executing (1).

DCLEVELS_COUNT : The number of DCLevels defined.

INSTRUMENT_CACHE_SIZE : Gets the current pattern cache size that was set with ConfigureMemory.

INSTRUMENT_REFERENCECLOCK_SOURCE : This attribute returns the reference frequency source specified with Configure. Sources are : DStarA (0), Front Panel (1), PXI100 (2).

INSTRUMENT_REMAINING_CACHE : Calculates and returns the amount of cache memory remaining and available for compiled patterns.

INSTRUMENT_RESULT_SIZE : Result size as determined by ConfigureMemory.

INSTRUMENT_SLOT : The chassis slot number that the module occupies.

MODULE_CALIBRATION_STATUS : Returns the calibration status of the module. The status is determined by comparing the (module calibration due date - cal due reminder value) to the current date.

The defined calibration status values are:

  • KTMDSR_VAL_CALIBRATION_STATUS_INSTRUMENT_CALIBRATED
  • KTMDSR_VAL_CALIBRATION_STATUS_DUE
  • KTMDSR_VAL_CALIBRATION_STATUS_EXPIRED
  • KTMDSR_VAL_CALIBRATION_STATUS_NOT_CALIBRATED
  • KTMDSR_VAL_CALIBRATION_STATUS_NOT_SUBJECT_TO_CALIBRATION
  • KTMDSR_VAL_CALIBRATION_STATUS_MODULE_CALIBRATED

MODULE_NONVOLATILE_CAL_DUE_REMINDER : Returns the "reminder" period, in days, prior to any calibration due. Range 0..1000 days. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is 30 days. This value is not affected by Reset or power cycle.

MODULE_NONVOLATILE_INSTRUMENT_CAL_INTERVAL :Returns the instrument (multi-module) calibration interval in days. Range 1..10000 days. Checks for "cal due" are based on the instrument's calibration date (set by Keysight manufacturing/service) + InstrumentCalInterval. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is 365 days. This value is not affected by Reset or power cycle.

MODULE_NONVOLATILE_MODULE_CAL_INTERVAL :Returns the module calibration interval in days. Range 1..10000 days. Checks for "cal due" are based on the module's calibration date (set by Keysight manufacturing/service) + ModuleCalInterval. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is 365 days. This value is not affected by Reset or power cycle.

MODULE_SLOT : Returns the chassis slot the module occupies.

MODULES_COUNT : Returns the number of modules.

MACRODEFS_COUNT : The number of MacroDefs defined.

PATTERN_HIGHEST_PATTERN_INDEX (Required RepCap Identifier : Pattern Name) : The highest pattern index currently defined. For best efficiency, the next pattern element should be defined at this index+1.

PATTERN_PATTERN_LENGTH (Required RepCap Identifier : Pattern Name) : The current length of the pattern. First index is 1. Note that when loading a file, this is the highest element position in the pattern.

PATTERNBURSTS_COUNT : The number of Pattern Burstsdefined.

PATTERNEXECS_COUNT : The number of Pattern Execs defined.

PATTERNFILE_ERROR_COUNT : Returns the number of parsing errors from the last Load. The OpenXML and BulkData parsers may return multiple errros. The STIL parser terminates on the first error, so it always returns 0 or 1 for STIL. Use GetNextError to read the errors.

PATTERNS_COUNT : The number of Patterns defined.

PATTERNSITE_CONDITIONAL_LOOP_FAILURE_MODE : Match loops and watch loops include a loop counter which, if expired, indicates that the loop has failed. This attribute selects what will happen when the loop counter expires (either stop execution (0) or exit the loop and continue (1)).

PATTERNSITE_CONDITIONAL_LOOP_SUCCESS_MODE : Configures if the DSR will execute a MatchLoop at least one extra time after a successful loop (0), or if the MatchLoop will require no compares in the final few cycles of the loop (1).

PATTERNSITE_EXECUTION_STATE (Required RepCap Identifier : Pattern Site Name) : Returns the state of the pattern execution hardware. Possible values are Running (0),Stopped (1), WaitingForTrigger (2), Complete (3), Aborted (4), and Error (5).

PATTERNSITE_RESULT_COUNT (Required RepCap Identifier : Pattern Site Name) : Gets the number of elements in the result from the last pattern execution.

PATTERNSITE_RESULT_WIDTH (Required RepCap Identifier : Pattern Site Name) : Gets the width of the result, that is, the number of bits in each element of the response. The result width is established by the highest ordinal assigned to a response signal in the site definition.

PATTERNSITES_COUNT : The number of Pattern Sites defined.

PATTERNSITES_END_BEHAVIOR : Sets the behavior of the signal lines upon completion of a pattern to either retain the last state of the signal lines from the last period (0) or repeat the last waveform character of the last period (1).

PATTERNSITES_RESULT_BUFFER_SIZE : Specifies the amount of memory, in bytes, to be reserved for results for this pattern. This memory is taken from the memory reserved for results using Instrument Configure Memory.

PATTERNSITES_TRIGGER_MODE : The trigger mode determines whether the pattern begins executing immediately after it is initiated (0) or whether it waits for a trigger event (1).

PATTERNSITES_WHAT_TO_LOG : Sets the compares to log during pattern execution (all compares; first failed compare; all failed compares). If "first failed compare" is selected, the first failure terminates the pattern execution.

The WhatToLog setting controls the logging of compares during pattern execution.

WhatToLog setting | DSR logs
EveryCycleWithCompare | Every cycle with a compare. Use this setting when the pattern is defined with the intent of capturing all compares.
EveryCycleWithFailingCompare | All failed compares. This setting is useful when the pattern expects specific values for all DUT response signals.
FirstCycleWithFailingCompareAndTerminate

The first failed compare. After the failed compare, the pattern execution terminates.

This setting is supported only on single-module instruments, not on multi-module instruments. An error will be generated if this setting is programmed on a multi-module instrument.

A successful completion (no failed compares) will result in ExecutionState of "Complete" and ExecutionErrors = "None."

To use the DSR to log data, set WhatToLog to EveryCycleWithCompare. The bits which contain data are normally configured to compare the input with a logical low. In this case, the state of the compare reflects the binary information. When WhatToLog is set to EveryCycleWithCompare, this will place both 0's and 1's in the result.

For details on generating software triggers, see TriggerEvent Generate Software Events.

For more information on the PatternSites interface, see the PatternSites Overview.

PPMUSITE_AVERAGE_MODE (Required RepCap Identifier : Ppmu Site Name) : Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements. Modes are :

  • None (0) : A single measurement is performed.
  • Average 64 (1) : 64 measurements are performed as quickly as possible and averaged together.
  • Windows 50Hz (2) : Measurements are made over a single 50 Hz power-line cycle in order to maximize noise immunity in 50 Hz environments.
  • Windows 60 Hz (3) : Measurements are made over a single 60 Hz power-line cycle in order to maximize noise immunity in 60 Hz environments.

PPMUSITE_FORCE_MODE (Required RepCap Identifier : Ppmu Site Name) : Allows querying of the Force Mode. To set the ForceMode attribute, use the Force function or one of the Force and Measure functions. Force Modes are :

  • Nothing(0)
  • Voltage (1)
  • Current (2)

PPMUSITES_COUNT : The number of PPMU sites defined.

SIGNAL_DIRECTION (Required RepCap Identifier : Signal Name) : Gets or sets the direction of this signal. The direction is relative to the DUT. Directions are :

  • Direction In (0)
  • Direction Out (1)
  • Direction InOut (2).

SIGNALGROUPS_COUNT : The number of Signal Groups defined.

SIGNALS_COUNT : The number of Signals defined.

SITES_COUNT : The number of Sites defined.

STATICSITES_COUNT : The number of Static Sites defined.

SYSTEM_TIMEOUT_MILLISECONDS : Queries the timeout used for IO to the module. The default value of TimeoutMilliseconds is 5000 ms. For a conventional Windows OS, it may be unreliable to set the timeout value to less than 500 ms. In some cases, several IO operations are completed to the module by a single method call. In these cases the actual amount of time required for an operation to fail and return may be several times the specified TimeoutMilliseconds. The WaitForAcquisitionComplete functions of CaptureSite and Pattern Site specify the maximum time to wait for the pattern to complete executing. That time is independent of this attribute.

TRIGGER_COUNT : Returns the number of triggers. This property always returns 15 for the DSR. While there are only 13 physical triggers and markers, the two front panel trigger/marker signals can each be accessed by two different names.

The front panel signal labeled "GPIO1" can be accessed using either "GPIO1" or "External1", while the front panel signal labeled "GPIO2" can be accessed using either "GPIO2" or "External2".

The net addition of two names results in this property returning 15, not 13.

TRIGGER_DIRECTION (Required RepCap Identifier : Trigger Name) : Used to configure a line as either a Marker or a Trigger. Values are : Marker (1), & Trigger (0).

For the bi-directional signals listed above, the Direction property is used to specify whether the signal is a trigger input (enum of KtMDsrTriggerDirectionTrigger) or is a marker output (enum of KtMDsrTriggerDirectionMarker). The default value of Direction for all bi-directional trigger/marker signals is as a trigger input.

The Direction property does not apply to the trigger input signal PXIe_DSTARB nor the marker output signal PXIe_DSTARC. The direction of these signals cannot be changed.

Care should be taken to ensure that a DSR marker output isn't inadvertently connected to a marker output from another module or from the chassis.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_POLARITY (Required RepCap Identifier : Trigger Name) : Used to get or set the polarity of a Marker or expected by a Trigger. Values are : Positive (0), & Negative (1).

After a marker output goes high or low as specified by Polarity, it will return to its quiescent state after a period of time specified by the MarkerPulseWidth. If Polarity is positive, the marker will begin as a logic low then go high for the specified MarkerPulseWidth followed by returning low. If Polarity is negative, the marker will begin as a logic high then go low for the specified MarkerPulseWidth followed by returning high.

Polarity affects which edge of a trigger input will cause the DSR to respond. If Polarity is positive, the DSR will trigger on the rising edge of the trigger input signal. If Polarity is negative, the DSR will trigger on the falling edge of the trigger input signal.

While triggers are often thought of as pulses, the DSR only looks for the specified edge, either rising or falling as specified by Polarity. After triggering has occurred on the specified edge, when the next edge occurs is inconsequential other than the next edge needs to occur at some point in order to make it possible for another trigger to be received on the specified edge. The time between any trigger edges must be greater than 20 ns.

Polarity can be programmed independently for each of the 13 DSR signals that can be used as markers and triggers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, PXIe_DSTARB (trigger input only), and PXIe_DSTARC (marker output only).

If a signal can be both a marker output and a trigger input (such as GPIO1), there is only one Polarity value associated with the signal. In other words, the signal does not have one Polarity value that is used when the signal is programmed as a marker output and a different Polarity value that is used when the signal is programmed as a trigger input.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_EXTERNAL_TRIGGER_TERMINATION (Required RepCap Identifier : Trigger Name) : Configure how the External Triggers are terminated. Default = HighImpedence. Values are : Low Impedance 50 Ohm (1), & High Impedance 10K Ohm (0).

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals have been programmed to be trigger inputs using the Direction property. The termination impedances are disconnected when these signals are programmed to be marker outputs.

For more information on triggers and markers, see Trigger and Marker Overview.

WAVEFORMTABLES_COUNT : The number of Waveform Tables defined.

Outputs

Closed Instrument handle out and error out
instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViReal64

Gets a Real64 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

Capture Site_EDGE_PLACEMENT_RESOLUTION *

INSTRUMENT_REFERENCECLOCK_FREQUENCY

INSTRUMENT_TEMPERATURE

MODULE_TEMPERATURE

PATTERNSITE_EDGE_PLACEMENT_RESOLUTION *

PPMUSITE_CURRENT_LIMIT *

PPMUSITE_LEVEL *

PPMUSITE_SETTLING_DELAY *

TRIGGER_MARKER_PULSE_WIDTH*

TRIGGER_EXTERNAL_TRIGGER_THRESHOLD_LEVEL*

WAVEFORMTABLE_PERIOD *

Inputs

Instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
Closed Instrument error in

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

Capture Site_EDGE_PLACEMENT_RESOLUTION (Required RepCap Identifier : Capture Site Name) : Returns the EdgePlacementResolution specified when this site was activated. Or, if EdgePlacementResolutionAuto was set to True, this is the edge placement resolution selected by the DSR.

INSTRUMENT_REFERENCECLOCK_FREQUENCY : This attribute returns the frequency, in Hz, specified with Configure.

INSTRUMENT_TEMPERATURE : Return the instrument temperature in degrees Celsius.

MODULE_TEMPERATURE : Returns the module temperature in degrees Celsius.

PATTERNSITE_EDGE_PLACEMENT_RESOLUTION (Required RepCap Identifier : Pattern Site Name) : Returns the edge placement resolution that was used when this pattern was activated. If EdgePlacementResolutionAuto was True at the time of activation, the return value is the value selected by the DSR.

PPMUSITE_CURRENT_LIMIT (Required RepCap Identifier : Ppmu SiteName) : Returns the maximum current the module can produce on this channel based on the current settings.

PPMUSITE_LEVEL (Required RepCap Identifier : Ppmu SiteName) : Returns the force level currently in use. To set the Level attribute, use the Force function or one of the Force and Measure functions.

PPMUSITE_SETTLING_DELAY (Required RepCap Identifier : Ppmu SiteName) : Specifies the delay, in seconds, between applying the Force and performing the measurement.

TRIGGER_MARKER_PULSE_WIDTH (Required RepCap Identifier : Trigger Name) : Used to get or set the width of the pulse generated by a Marker. Default = 100ns.

The range of marker pulse widths that can be programmed depends on the edge placement resolution (EPR). The maximum pulse width for any marker is 256 x 4 x EPR. For example, for an EPR of 1ns, the maximum marker pulse width will be 256 x 4 x 1ns = 1,024ns.

For an EPR of 100ns, the maximum marker pulse width will be 102.4us.

Marker pulse widths will be rounded to the closest integer multiple of 4 x EPR. For example, if a pulse width of 90ns is programmed when the EPR is 10ns (4 x EPR = 40 ns), the actual pulse width will be 80ns.

The minimum marker pulse width is 20ns. The DSR will use a pulse width of 20ns if a pulse width shorter than 20ns is programmed. If no pulse width is programmed for a particular marker, a default pulse width of 100ns is used.

Doing a read of the marker pulse width will always return the programmed value. In other words, the returned value will not be modified based on the operations performed to actually generate a marker, such as rounding up to the minimum pulse width or limiting the pulse width to the EPR-dependent maximum value.

Likewise, no error messages will be generated if marker pulse widths are programmed above or below the limits that are used to actually generate a marker. The appropriate rounding up or rounding down will occur, and no error message will be generated.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_EXTERNAL_TRIGGER_THRESHOLD_LEVEL (Required RepCap Identifier : Trigger Name) : Used to get or set the voltage level expected by a Trigger for External only.

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals are programmed as trigger inputs. An error is generated if the programmed threshold voltage level is outside of the range -2VDC to 4VDC.

The default threshold voltage level for this property is .75V. The programmed threshold voltage levels have a nominal accuracy of +/- 100mV.

For more information on triggers and markers, see Trigger and Marker Overview.

WAVEFORMTABLE_PERIOD (Required RepCap Identifier : Waveform table Name) : The period of the waveforms in this WaveformTable, in seconds. The period can be set from 4 ns (corresponding to the maximum data rate of 250 MHz) to 200 seconds (corresponding to the minimum date rate of .005 Hz). Once a site has been activated, its Period cannot be changed. Changing the Period property will affect the Period used by subsequently-activated sites.For more information on the WaveformTables interface, see the WaveformTables Overview .

Outputs

Closed Instrument handle out and error out
instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViString

Gets a String attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

CALIBRATION_ADJUSTMENT_INFORMATION

CALIBRATION_DUE_DATE

CALIBRATION_INSTRUMENT_IDENTIFIER

CALIBRATION_VERIFICATION_INFORMATION

Capture SiteS_TRIGGER_SOURCE

DCLEVEL_SIGNALS *

DRIVER_SETUP

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

LOGICAL_NAME

MACRODEF_MACROS *

MODULE_CALIBRATION_ADJUSTMENT_INFORMATION

MODULE_CALIBRATION_DUE_DATE

MODULE_CALIBRATION_VERIFICATION_INFORMATION

MODULE_NONVOLATILE_ASSET_NUMBER

MODULE_NONVOLATILE_PASSPHRASE

MODULE_NONVOLATILE_SYSTEM_IDENTIFICATION

MODULE_OPTIONS

MODULE_SERIAL_NUMBER

PATTERN_SIGNALS *

PATTERNBURST_MACRO_DEFS *

PATTERNBURST_PATTERNS *

PATTERNEXEC_DC_LEVELS *

PATTERNEXEC_PATTERN_BURST *

PATTERNSITE_TERMINATION_REASON *

PATTERNSITES_TRIGGER_SOURCE

SIGNALGROUP_SIGNALS *

SITE_TRIGGER0_SOURCE *

SITE_TRIGGER1_SOURCE *

SITE_TRIGGER2_SOURCE *

SITE_TRIGGER3_SOURCE *

SITE_TRIGGER4_SOURCE *

SITE_TRIGGER5_SOURCE *

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

SYSTEM_ABOUT

SYSTEM_LICENSING_HOST_IDENTIFIER

SYSTEM_LICENSING_INSTALLED_LICENSES

SYSTEM_OPTIONS

SYSTEM_SERIAL_NUMBER

WAVEFORMTABLE_SIGNALS *

Inputs

Instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
Closed Instrument error in

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RepCapIdentifier

Some attributes will require a Repeated Capability Identifier string in this field, otherwise, it should be left empty. See the Context Help for the AttributeID field below to determine if that AttributeID requires a string entry for the RepCapIdentifier.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

CALIBRATION_ADJUSTMENT_INFORMATION : Returns a comma separated list of calibration adjustment information. Includes the calibration date and instrument identification. Returns an empty string if any of the modules in the current system have not been calibrated.

The instrument identifier is a 10 character hash code followed by each module's model and serial number.

If the response is empty, it does not mean that the modules have not been calibrated, but that they haven't been calibrated as a set. Use Modules Calibration AdjustmentInformation to determine all the systems a particular module has been calibrated in.

CALIBRATION_DUE_DATE : Returns the computed date of the next required instrument calibration. If the instrument is not subject to calibration, this will return "n/a". If the instrument is not calibrated this will return "unknown". If the instrument is calibrated this will return a date formatted for the current locale.

Computing the calibration due date takes several things into account:

  • User specified setting of 'EnablePeriodicCal'
  • User specified setting of 'InstrumentCalInterval' and 'ModuleCalInterval'
  • The calibration verification date of each module (if any)
  • The calibration verification date of the instrument

The instrument will be considered calibrated if either

  • Calibration.VerificationInformation is not empty
  • At least one module has a calibration verification date and EnablePeriodCal=true and all other modules in the instrument have either
    • a calibration verification date
    • EnablePeriodicCal=false

The instrument uses the EnablePeriodicCal and InstrumentCalInterval settings from the Synthesizer module for computing the instrument calibration due date. Each module uses its own settings for computing the module due date.

The typical cases for computing due date are:

  • The system has only Calibration.VerificationInformation (which excludes the reference) and the system does not include a reference. The due date is simply the date from the verification information plus the instrument calibration interval specified by the synthesizer module.
  • The system has Calibration.VerificationInformation and module verification for the reference -- the due date is the earlier of
    • the date from the verification information plus the instrument calibration interval specified by the synthesizer module.
    • the date from the reference verification date plus the module calibration interval specified by the reference module.
  • The system has only module verification.The due date is simply the earliest of each module's due date (that module's verification date plus that module's ModuleCalInterval setting).

A less typical case is when there is "overlapping" Calibration.VerificationInformation and module verification.If the instrument level calibration information has not expired, it is used to determine instrument calibration status and due date.

CALIBRATION_INSTRUMENT_IDENTIFIER : Returns a unique identifier for the collection of modules that make up the current instrument. This will not include modules that are independently calibrated (typically just the M9300A reference module). This value is used in tracking instrument calibration verification.

An instrument is comprised of the modules the IVI driver is currently controlling. For the instrument to be calibrated, the current set of modules must have been calibrated as a system. The instrument identifier is a 10 character hash code followed by each module's model and serial number..

CALIBRATION_VERIFICATION_INFORMATION : Returns a comma separated list of calibration verification information. Includes the calibration date and instrument identification. Returns an empty string if any of the modules in the current system have not been calibrated.

The instrument identifier is a 10 character hash code followed by each module's model and serial number.

If the response is empty, it does not mean that the modules have not been calibrated, but that they haven't been calibrated as a set. Use Modules.Item.Calibration.VerificationInformation to determine all the systems a particular module has been calibrated in.

Capture SiteS_TRIGGER_SOURCE : Gets or sets the trigger source for this pattern. String format is: SoftwareTrigger<0-15>.

DCLEVEL_SIGNALS (Required RepCap Identifier : DC Level Name) : Gets a comma-separated list of Signals for which levels have been defined for this DcLevels block.

DRIVER_SETUP : Returns the driver setup string that the user specified in the IVI configuration store when the instrument driver session was initialized or passed in the OptionString parameter of the Initialize function.

INSTRUMENT_FIRMWARE_REVISION : The firmware revision loaded onto the module. The string is of the form <Major>.<Minor>.<Build>.<Patch>.

INSTRUMENT_MANUFACTURER : Returns the instrument manufacturer, "Keysight Technologies".

INSTRUMENT_MODEL : The model number of the instrument. Returns "M9195A".

IO_RESOURCE_DESCRIPTOR : The resource descriptor specifies the connection to module. It may be specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is null if the driver is not initialized.

LOGICAL_NAME : The Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If empty, the driver was initialized without using the Configuration Store.

MACRODEF_MACROS (Required RepCap Identifier : MacroDef Name) : Returns a comma-separated list of Macros defined in this MacroDef.

MODULE_CALIBRATION_ADJUSTMENT_INFORMATION : Returns a multi-line list of calibration adjustment information. Each system with this module that a system calibration has been performed with will generate a line that includes the calibration date and instrument identifier.

MODULE_CALIBRATION_DUE_DATE : Returns the computed date of the next required module calibration date. If the module is not subject to periodic calibration, this returns "n/a". If the module has not been calibrated, this returns "unknown". If the module is calibrated, this returns a date formatted for the current locale.

Due Date depends on

  • The module having module verification date (not all modules do)
  • User specified settings EnablePeriodicCal and ModuleCalInterval

The value of Modules.Item.Calibration.DueDate (MODULES_CALIBRATION_DUE_DATE) will affect the values of Calibration.DueDate (CALIBRATION_DUE_DATE)and Calibration.Status (CALIBRATION_STATUS) see those properties for more details.

MODULE_CALIBRATION_VERIFICATION_INFORMATION : Returns a multi-line list of calibration verification information. Each system that the module calibration has been verified with will generate a line that includes the calibration date and instrument identifier. The instrument identifier is a 10 character hash code followed by each module's model and serial number.

MODULE_NONVOLATILE_ASSET_NUMBER : Returns the asset number of the module.

MODULE_NONVOLATILE_PASSPHRASE : Returns a passphrase used to protect various values in Nonvolatile. Passphrase must be provided to Write if any of these values have changed. Setting this property caches the value in memory. To persist it use System Nonvolatile Write.

If this value has never been set, the value is "" (empty string). This value is not affected by Reset or power cycle. The values protected by Passphrase are

  • EnablePeriodicCalChecks
  • EnableModuleCalWarnings
  • EnableInstrumentCalWarnings
  • ModuleCalInterval
  • InstrumentCalInterval
  • Passphrase

If the passphrase has been forgotten, it can be reset programmatically using Modules.Item.Nonvolatile.Clear() OldPassphrase = Modules.Item.Nonvolatile.Passphrase Modules.Item.Nonvolatile.Passphrase = NewPassphrase Modules.Item.Nonvolatile.Write( OldPassphrase )

MODULE_NONVOLATILE_SYSTEM_IDENTIFICATION : Returns a persistent arbitrary string with a maximum length of 32 characters nominally intended to provide a user customizable method to distinguish modules. Setting this property caches the value in memory. To persist it use System Nonvolatile Write. If this value has never been set, the value is " " (empty string). This value is not affected by Reset or power cycle. This value is unused by the IVI driver.

MODULE_OPTIONS : Returns a comma separated list of the options installed in the module.

MODULE_SERIAL_NUMBER : Returns the serial number of the module.

PATTERN_SIGNALS (Required RepCap Identifier : Pattern Name) : Returns a comma-separated list of all signals in this pattern.

PATTERNBURST_MACRO_DEFS (Required RepCap Identifier : Pattern Burst Name) : Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.

PATTERNBURST_PATTERNS (Required RepCap Identifier : Pattern Burst Name) : Comma-separated list of Pattern blocks or other PatternBursts to execute when this Pattern Burst is executed. The patterns are executed in the order specified and any macros are compiled using the MacroDefs block in this PatternBurst.

PATTERNEXEC_DC_LEVELS (Required RepCap Identifier : Pattern Exec Name) : DcLevels block to be used by the PatternExec.

PATTERNEXEC_PATTERN_BURST (Required RepCap Identifier : Pattern Exec Name) : PatternBurst block to be used by the PatternExec.

PATTERNSITE_TERMINATION_REASON (Required RepCap Identifier : Pattern Site Name) : Gets a comma-separated string containing errors that occurred during pattern execution. This should be consulted if the ExecutionResult returns an error. The ExecutionErrors string indicates whether errors occurred during pattern execution. It is cleared by Initiate and updated to reflect any errors that occurred during pattern execution. If one or more errors occured during pattern execution, the string contains a comma-separated list of errors.

Error | Indicates
Reference Unlocked | The reference clock PLL was unlocked at some point between Initiate and the completion of pattern execution.
Pattern Error | The hardware detected an error at some point during pattern execution. This will occur if the pattern generation hardware is unable to produce the pattern; for example, if loops in the pattern are less than the required lengths. See below for additional details.
Conditional Loop Count Exceeded | MatchLoop or WatchLoop exceeded the specified LoopCount parameter.
Overheated | The drivers in the pin electronics overheated during pattern execution.
None | No error

Pattern errors should not occur if the WaveformTable Period property is set to 1 us or greater. If a pattern error does occur in your program, possible causes are:

  • Pattern loops that are too short -- For example, a loop containing just two vectors may cause a pattern error. Either increase the number of vectors in the loop, if possible, or "flatten" the loop by repeating the vectors individually the same number of times that are specified by the LoopCount parameter in the Loop method.
  • Nested loops -- Nested loops can also cause a pattern error. Either avoid nested loops, if possible, or flatten the inner loop(s) as described above.

For more information on the PatternSites interface, see the PatternSites Overview.

PATTERNSITES_TRIGGER_SOURCE : Gets or sets the trigger source used to begin execution for this pattern after calling Initiate.

SIGNALGROUP_SIGNALS (Required RepCap Identifier : Signal Group Name) : Sets the list of Signals to use for this SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL signal-reference-expression syntax. For instance "Sig1+Sig2+Bus[0..7]".

SITE_MARKER0_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker0 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_MARKER1_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker1 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_MARKER2_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker2 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_TRIGGER0_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger0 in the WatchLoop.

SITE_TRIGGER1_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger1 in the WatchLoop.

SITE_TRIGGER2_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger2 in the WatchLoop.

SITE_TRIGGER3_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger3 in the WatchLoop.

SITE_TRIGGER4_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger4 in the WatchLoop.

SITE_TRIGGER5_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger5 in the WatchLoop.

SPECIFIC_DRIVER_DESCRIPTION : Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_REVISION : Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_VENDOR : Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SUPPORTED_INSTRUMENT_MODELS : A comma-separated list of instrument models that the IVI specific driver can control. Returns "M9195A".

SYSTEM_ABOUT : Returns addition information about the system beyond the firmware and hardware versions. This is typically included in an SFP (Soft Front Panel) About Box dialog.

SYSTEM_LICENSING_HOST_IDENTIFIER : The unique key identifying the system controller for licensing purposes. Also called HostID.

SYSTEM_LICENSING_INSTALLED_LICENSES : A semicolon-separated list of the software licenses installed on the computer. Each software license consists of a comma-separated Feature Name and Description. This property is not supported by the DSR driver; an empty string is returned.

SYSTEM_OPTIONS : Returns a comma-separated list of the options installed on the instrument, such as "MMS, S04, SR2, M12". For a multi-module instrument (consisting of two or more M9195B modules), the Options property that is returned reflects the minimum capability of each of the modules. For example, if one module of a 2-module instrument has the "M12" memory option installed while the second module has the "M06" memory option installed, the Options property will return the minimum of these two options, namely "M06". In addition to programmatically fetching the Options property, the installed options can also be viewed using the SFP About dialog under the Help menu. Furthermore, the SFP can be used to install new options that you have purchased. This is done using the "Hardware Options Upgrade" menu under the "Utilities" tab.

SYSTEM_SERIAL_NUMBER : The module serial number.

WAVEFORMTABLE_SIGNALS (Required RepCap Identifier : Waveform Table Name) : Comma-separated list of Signals defined for this Waveform Table.

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

Outputs

Closed Instrument handle out and error out
instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note: Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


SetAttributeViBoolean

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

CALIBRATION_USE_FIXTURE

INSTRUMENT_IDENTIFY

PATTERNSITE_FORCE_VALIDATE_ENABLE

SIMULATE

SYSTEM_TRACE_ENABLED

Inputs

Closed Instrument handle in and error in
instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI.

CALIBRATION_USE_FIXTURE : Indicates whether the Calibration will be performed with the factory-provided fixture.

INSTRUMENT_IDENTIFY : If True, this attribute causes an indicator LED on the front panel to flash. This assists in identifying the module being programmed. The special indication persists as long as the Boolean is True.

PATTERNSITE_FORCE_VALIDATE_ENABLE : If true, any WaveformTables compiled will perform force validation by adding a compare operation to validate a successful force on the last cycle of operations that include force operations.

SIMULATE : If True, the driver does not perform I/O to the instrument, but returns simulated values for output parameters and results.

SYSTEM_TRACE_ENABLED : If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.

AttributeValue (Off)

The value to which to set the property.

Outputs

Closed Instrument handle out and error out

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SetAttributeViInt32

Sets an Int32 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

Capture Site_REQUESTED_RESULT_COUNT

Capture SiteS_TRIGGER_MODE

PATTERNSITE_CONDITIONAL_LOOP_FAILURE_MODE

PATTERNSITE_CONDITIONAL_LOOP_SUCCESS_MODE

PATTERNSITES_END_BEHAVIOR

PATTERNSITES_RESULT_BUFFER_SIZE

PATTERNSITES_TRIGGER_MODE

PATTERNSITES_WHAT_TO_LOG

PPMUSITE_AVERAGE_MODE *

SIGNAL_DIRECTION *

TRIGGER_DIRECTION*

TRIGGER_POLARITY*

TRIGGER_EXTERNAL_TRIGGER_TERMINATION*

Inputs

Closed Instrument handle in and error in
instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RepCapIdentifier

Some attributes will require a Repeated Capability Identifier string in this field, otherwise, it should be left empty. See the Context Help for the AttributeID field below to determine if that AttributeID requires a string entry for the RepCapIdentifier.

.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

Capture Site_REQUESTED_RESULT_COUNT : Number of Results per channel to be collected.

Capture SiteS_TRIGGER_MODE : Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated (0)or if the execution waits for a trigger event before executing (1).

PATTERNSITE_CONDITIONAL_LOOP_FAILURE_MODE : Match loops and watch loops include a loop counter which, if expired, indicates that the loop has failed. This attribute selects what will happen when the loop counter expires (either stop execution (0) or exit the loop and continue (1)).

PATTERNSITE_CONDITIONAL_LOOP_SUCCESS_MODE : Configures if the DSR will execute a MatchLoop at least one extra time after a successful loop (0) , or if the MatchLoop will require no compares in the final few cycles of the loop (1).

PATTERNSITES_END_BEHAVIOR : Sets the behavior of the signal lines upon completion of a pattern to either retain the last state of the signal lines from the last period (0) or repeat the last waveform character of the last period (1).

PATTERNSITES_RESULT_BUFFER_SIZE : Specifies the amount of memory, in bytes, to be reserved for results for this pattern. This memory is taken from the memory reserved for results using Instrument Configure Memory.

PATTERNSITES_TRIGGER_MODE : The trigger mode determines whether the pattern begins executing immediately after it is initiated (0) or whether it waits for a trigger event (1).

PATTERNSITES_WHAT_TO_LOG : Sets the compares to log during pattern execution (all compares; first failed compare; all failed compares). If "first failed compare" is selected, the first failure terminates the pattern execution.

The WhatToLog setting controls the logging of compares during pattern execution.

WhatToLog setting | DSR logs
EveryCycleWithCompare | Every cycle with a compare. Use this setting when the pattern is defined with the intent of capturing all compares.
EveryCycleWithFailingCompare | All failed compares. This setting is useful when the pattern expects specific values for all DUT response signals.
FirstCycleWithFailingCompareAndTerminate

The first failed compare. After the failed compare, the pattern execution terminates.

This setting is supported only on single-module instruments, not on multi-module instruments. An error will be generated if this setting is programmed on a multi-module instrument.

A successful completion (no failed compares) will result in ExecutionState of "Complete" and ExecutionErrors = "None."

To use the DSR to log data, set WhatToLog to EveryCycleWithCompare. The bits which contain data are normally configured to compare the input with a logical low. In this case, the state of the compare reflects the binary information. When WhatToLog is set to EveryCycleWithCompare, this will place both 0's and 1's in the result.

For details on generating software triggers, see TriggerEvent Generate Software Events.

For more information on the PatternSites interface, see the PatternSites Overview.

PPMUSITE_AVERAGE_MODE (Required RepCap Identifier : Ppmu Site Name) : Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements. Average Modes are :

  • None (0) : A single measurement is performed.
  • Average 64 (1) : 64 measurements are performed as quickly as possible and averaged together.
  • Window 50 Hz (2) : Measurements are made over a single 50 Hz power-line cycle in order to maximize noise immunity in 50 Hz environments.
  • Window 60Hz (3) : Measurements are made over a single 60 Hz power-line cycle in order to maximize noise immunity in 60 Hz environments.

SIGNAL_DIRECTION (Required RepCap Identifier : Signal Name) : Gets or sets the direction of this signal. The direction is relative to the DUT.

Directions are : Direction In (0), Direction Out (1), & DirectionInOut (2).

TRIGGER_DIRECTION (Required RepCap Identifier : Trigger Name) : Used to configure a line as either a Marker or a Trigger. Values are : Marker (1), & Trigger (0).

For the bi-directional signals listed above, the Direction property is used to specify whether the signal is a trigger input (enum of KtMDsrTriggerDirectionTrigger) or is a marker output (enum of KtMDsrTriggerDirectionMarker). The default value of Direction for all bi-directional trigger/marker signals is as a trigger input.

The Direction property does not apply to the trigger input signal PXIe_DSTARB nor the marker output signal PXIe_DSTARC. The direction of these signals cannot be changed.

Care should be taken to ensure that a DSR marker output isn't inadvertently connected to a marker output from another module or from the chassis.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_POLARITY (Required RepCap Identifier : Trigger Name) : Used to get or set the polarity of a Marker or expected by a Trigger. Values are : Positive (0), & Negative (1).

After a marker output goes high or low as specified by Polarity, it will return to its quiescent state after a period of time specified by the MarkerPulseWidth. If Polarity is positive, the marker will begin as a logic low then go high for the specified MarkerPulseWidth followed by returning low. If Polarity is negative, the marker will begin as a logic high then go low for the specified MarkerPulseWidth followed by returning high.

Polarity affects which edge of a trigger input will cause the DSR to respond. If Polarity is positive, the DSR will trigger on the rising edge of the trigger input signal. If Polarity is negative, the DSR will trigger on the falling edge of the trigger input signal.

While triggers are often thought of as pulses, the DSR only looks for the specified edge, either rising or falling as specified by Polarity. After triggering has occurred on the specified edge, when the next edge occurs is inconsequential other than the next edge needs to occur at some point in order to make it possible for another trigger to be received on the specified edge. The time between any trigger edges must be greater than 20 ns.

Polarity can be programmed independently for each of the 13 DSR signals that can be used as markers and triggers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, PXIe_DSTARB (trigger input only), and PXIe_DSTARC (marker output only).

If a signal can be both a marker output and a trigger input (such as GPIO1), there is only one Polarity value associated with the signal. In other words, the signal does not have one Polarity value that is used when the signal is programmed as a marker output and a different Polarity value that is used when the signal is programmed as a trigger input.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_EXTERNAL_TRIGGER_TERMINATION (Required RepCap Identifier : Trigger Name) : Configure how the External Triggers are terminated. Default = HighImpedence. Values are : Low Impedance 50 Ohm (1), & High Impedance 10K Ohm (0).

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals have been programmed to be trigger inputs using the Direction property. The termination impedances are disconnected when these signals are programmed to be marker outputs.

For more information on triggers and markers, see Trigger and Marker Overview.

AttributeValue

The value to which to set the property.

Outputs

Closed Instrument handle out and error out

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SetAttributeViReal64

Sets a Real64 attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

PPMUSITE_SETTLING_DELAY *

TRIGGER_MARKER_PULSE_WIDTH*

TRIGGER_EXTERNAL_TRIGGER_THRESHOLD_LEVEL*

WAVEFORMTABLE_PERIOD *

Inputs

Closed Instrument handle in and error in
instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RepCapIdentifier

Some attributes will require a Repeated Capability Identifier string in this field, otherwise, it should be left empty. See the Context Help for the AttributeID field below to determine if that AttributeID requires a string entry for the RepCapIdentifier.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

PPMUSITE_SETTLING_DELAY (Required RepCap Identifier : Ppmu SiteName) : Specifies the delay, in seconds, between applying the Force and performing the measurement.

TRIGGER_MARKER_PULSE_WIDTH (Required RepCap Identifier : Trigger Name) : Used to get or set the width of the pulse generated by a Marker. Default = 100ns.

The range of marker pulse widths that can be programmed depends on the edge placement resolution (EPR). The maximum pulse width for any marker is 256 x 4 x EPR. For example, for an EPR of 1ns, the maximum marker pulse width will be 256 x 4 x 1ns = 1,024ns.

For an EPR of 100ns, the maximum marker pulse width will be 102.4us.

Marker pulse widths will be rounded to the closest integer multiple of 4 x EPR. For example, if a pulse width of 90ns is programmed when the EPR is 10ns (4 x EPR = 40 ns), the actual pulse width will be 80ns.

The minimum marker pulse width is 20ns. The DSR will use a pulse width of 20ns if a pulse width shorter than 20ns is programmed. If no pulse width is programmed for a particular marker, a default pulse width of 100ns is used.

Doing a read of the marker pulse width will always return the programmed value. In other words, the returned value will not be modified based on the operations performed to actually generate a marker, such as rounding up to the minimum pulse width or limiting the pulse width to the EPR-dependent maximum value.

Likewise, no error messages will be generated if marker pulse widths are programmed above or below the limits that are used to actually generate a marker. The appropriate rounding up or rounding down will occur, and no error message will be generated.

For more information on triggers and markers, see Trigger and Marker Overview.

TRIGGER_EXTERNAL_TRIGGER_THRESHOLD_LEVEL (Required RepCap Identifier : Trigger Name) : Used to get or set the voltage level expected by a Trigger for External only.

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals are programmed as trigger inputs. An error is generated if the programmed threshold voltage level is outside of the range -2VDC to 4VDC.

The default threshold voltage level for this property is .75V. The programmed threshold voltage levels have a nominal accuracy of +/- 100mV.

For more information on triggers and markers, see Trigger and Marker Overview.

WAVEFORMTABLE_PERIOD (Required RepCap Identifier : Waveform Table Name) : The period of the waveforms in this WaveformTable, in seconds. The period can be set from 4 ns (corresponding to the maximum data rate of 250 MHz) to 200 seconds (corresponding to the minimum date rate of .005 Hz). Once a site has been activated, its Period cannot be changed. Changing the Period property will affect the Period used by subsequently-activated sites.For more information on the WaveformTables interface, see the WaveformTables Overview .

AttributeValue

The value to which to set the property.

Outputs

Closed Instrument handle out and error out

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SetAttributeViString

Sets a String attribute from the instrument driver. * indicates that a non-empty RepCapIdentifier is required to access this attribute.

The following Attributes are supported:

Capture SiteS_TRIGGER_SOURCE

PATTERNBURST_MACRO_DEFS *

PATTERNBURST_PATTERNS *

PATTERNEXEC_DC_LEVELS *

PATTERNEXEC_PATTERN_BURST *

PATTERNSITES_TRIGGER_SOURCE

SIGNALGROUP_SIGNALS *

SITE_TRIGGER0_SOURCE *

SITE_TRIGGER1_SOURCE *

SITE_TRIGGER2_SOURCE *

SITE_TRIGGER3_SOURCE *

SITE_TRIGGER4_SOURCE *

SITE_TRIGGER5_SOURCE *

Inputs

Closed Instrument handle in and error in
instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RepCapIdentifier

Some attributes will require a Repeated Capability Identifier string in this field, otherwise, it should be left empty. See the Context Help for the AttributeID field below to determine if that AttributeID requires a string entry for the RepCapIdentifier.

AttributeID

Selects which attribute will be accessed. For details on the attribute options, refer to the Context Help for the VI

Capture SiteS_TRIGGER_SOURCE : Gets or sets the trigger source for this pattern. String format is: SoftwareTrigger<0-15>.

PATTERNBURST_MACRO_DEFS (Required RepCap Identifier : Pattern Burst Name) : Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.

PATTERNBURST_PATTERNS (Required RepCap Identifier : Pattern Burst Name) : Comma-separated list of Pattern blocks or other PatternBursts to execute when this Pattern Burst is executed. The patterns are executed in the order specified and any macros are compiled using the MacroDefs block in this PatternBurst.

PATTERNEXEC_DC_LEVELS (Required RepCap Identifier : Pattern Exec Name) : DcLevels block to be used by the PatternExec.

PATTERNEXEC_PATTERN_BURST (Required RepCap Identifier : Pattern Exec Name) : PatternBurst block to be used by the PatternExec.

PATTERNSITES_TRIGGER_SOURCE : Gets or sets the trigger source used to begin execution for this pattern after calling Initiate.

SIGNALGROUP_SIGNALS (Required RepCap Identifier : Signal Group Name) : Sets the list of Signals to use for this SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL signal-reference-expression syntax. For instance "Sig1+Sig2+Bus[0..7]".

SITE_MARKER0_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker0 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_MARKER1_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker1 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_MARKER2_DESTINATION (Required RepCap Identifier : Site Name) : Sets the destination of all Marker2 references for patterns run on this site. The destination specifies on what signal the marker is generated.

SITE_TRIGGER0_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger0 in the WatchLoop.

SITE_TRIGGER1_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger1 in the WatchLoop.

SITE_TRIGGER2_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger2 in the WatchLoop.

SITE_TRIGGER3_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger3 in the WatchLoop.

SITE_TRIGGER4_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger4 in the WatchLoop.

SITE_TRIGGER5_SOURCE (Required RepCap Identifier : Site Name) : Configures the trigger event that maps to Trigger5 in the WatchLoop.

AttributeValue

The value to which to set the property.

Outputs

Closed Instrument handle out and error out

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Note:

Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Capture Sites VIs

Capture Site Fetch Result Byte

Capture Site Fetch Result Int16

Capture Site Fetch Result Segment Byte

Capture Site Fetch Result Segment Int16

Capture Site Get Edge Placement Resolution

Capture Site Edge Placement Resolution Auto

Capture Site Initiate

Capture Sites Activate

Capture Sites Get Name

Capture Sites Inactivate

Capture Sites Inactivate and Disable

Capture Sites Set Requested Result Count

Capture Sites Set Trigger Mode

Capture Sites Set Trigger Source

Capture Site Wait for Acquisition Complete

Capture Sites Overview


Capture Site Abort

Asynchronously stop the execution of the pattern. That is, stop the capture of data.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Site Fetch Result Byte

Returns the captured result in an array of bytes. Results must fit in a byte.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

ValActualSize

Actual number of Results

Remarks

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Site Fetch Result Int16

Returns the captured result in an array of 16-bit values. Results must fit in a 16-bit integer.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Site Fetch Result Segment Byte

Returns a segment from the captured result. Result must fit in a byte.

Inputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Offset(0)

Offset into the Results data to start. That is, the index of the first element to return in the result array.

Count(1)

Number of bytes to return.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

ValActualSize

Actual number of Results.

Remarks

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Site Fetch Result Segment Int16

Returns a segment from the captured result. Result must fit in a 16-bit integer.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Offset(0)

Offset into the Results data to start. That is, the index of the first element to return in the result array.

Count(1)

Number of 16-bit integers to return.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the Capture Sites interface, see the Capture Sites Overview


Capture Site Get Edge Placement Resolution

Returns the EdgePlacementResolution specified when this site was activated. Or, if EdgePlacementResolutionAuto was set to True, this is the edge placement resolution selected by the DSR.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EdgePlacementResolution (ns)

EdgePlacementResolution that was used to Activate the Capture Site.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview..


Capture Site Edge Placement Resolution Auto

Returns the value of EdgePlacementResolutionAuto with which the site was activated.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EdgePlacementResolutionAuto

If True, EdgePlacementResolutionAuto was used to Activate the Capture Site.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Site Initiate

Begin the execution of a pattern. If the Trigger Mode is set to Immediate, execution will begin immediately. If set to Trigger, the hardware will fully initialize, but will wait for a trigger event before proceeding.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Sites Activate

Activates a site for data capture.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

The name of the Site. See the Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

WaveformTable

Name of WaveformTable that describes timing information for capturing data on the Capture Site. Each Signal should define one and only one waveform. DUT input signals define one waveform per Signal, and that waveform may specify only a compare or a clock.

DcLevels

The DcLevels settings to apply to the Channels. Must include each Channel assigned in the Site.

EdgePlacementResolutionAuto (Off

When True, the DSR automatically chooses an edge placement resolution suitable for the digital test (the PatternExec) that is being activated. The DSR generally chooses the finest resolution that is able to produce the pattern.

EdgePlacementResolution (ns)

Specifies the edge placement resolution (when EdgePlacementResolutionAuto is False). Sets the finest resolution available when selecting pattern timing parameters. Range is 1 ns to 100 ns. This resolution determines how the times specified are rounded to values produced.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Activate locks the channels for exclusive use by the specified site and creates a capture pattern from the specified Site, Waveform table, DcLevels and Edge Placement Resolution.

The pattern information is compiled and downloaded to the pattern cache; it is later removed when this site is inactivated.

For more information on the Capture Sites interface, see the Capture Sites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.


Capture Sites Get Name

Returns the capture site name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the Capture SiteS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities


Capture Sites Inactivate

Releases the resources associated with this site. The state of the individual channels is not changed.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The block name of the active Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview

For more information on the dynamic repeated capability Inactivate function, see Dynamic Repeated Capabilities .


Capture Sites Inactivate and Disable

Releases the resources associated with this site. The individual channels are disabled.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture SiteThe name of the active Capture Site. See the ' Capture Sites Get Name" in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

In addition to inactivating the site, this function also disables the channels. That is, the DSR isolates itself from the DUT in a fashion that minimizes the possibility of either the DUT or the DSR being harmed.

For more information on the Capture Sites interface, see the Capture Sites Overview.

For more information on the dynamic repeated capability, see Dynamic Repeated Capabilities .


Capture Sites Set Requested Result Count

Sets the number of Results per channel to be collected.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RequestedResultCount

Number of Results per channel to be collected..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.


Capture Sites Set Trigger Mode

Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated or if the execution waits for a trigger event before executing.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TriggerMode (Immediate)

Sets the Trigger Mode. The trigger mode determines if execution of the pattern begins immediately when initiated or if the execution waits for a trigger event before executing.

Immediate : Triggered by Initiate.

Triggered : Trigger set in TriggerSource starts execution.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview .


Capture Sites Set Trigger Source

Gets or sets the trigger source for this pattern. One or more bits may be set to reference SoftwareTriggers 0-15.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TriggerSource

String format is: SoftwareTrigger<0-15>.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Capture Sites interface, see the Capture Sites Overview.

For details on generating software triggers, see TriggerEvent Generate Software Events.


Capture Site Wait for Acquisition Complete

This function waits for the CaptureSite to complete execution before it returns. A MaximumSeconds timeout parameter is provided which causes an exception to be generated if the function does not return before the timeout period elapses.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Capture Site

The name of the Capture Site. See the ‘ Capture Sites Get Name’ in Action/Status section of menu to obtain the valid names.

.

MaximumSeconds

Maximum number of seconds to wait.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

ExecutionStateEnum indicating the current state of the Capture Site.

0 - Executing

1 - Stopped

2 - Waiting for Initiate Trigger

3 - Complete

4 - Aborted

5 - Error

6 - Waiting for Match loop

7 - Watching for Trigger0

8 - Watching for Trigger1

9 - Watching for Trigger2

10 - Watching for Trigger3

11 - Watching for Trigger4

12 - Watching for Trigger5

Remarks

After a CaptureSite is initiated, your program can call the WaitForAcquisitionComplete function to await completion of the data capture. If the DSR is collecting results in Results Memory, the results will be available when this function returns.

A MaximumSeconds timeout parameter can be specified to determine if the WaitForAcquisitionComplete function fails to return within a certain time. The function can fail to return if an expected start trigger never occurs.

If a timeout does occur, an exception will be generated which your program can catch. Your program can then check the status of the CaptureSite ExecutionState property to help identify the issue.

The MaximumSeconds parameter should be set long enough to ensure that a timeout doesn't occur with CaptureSites that execute and complete normally. The following minimum timeout value is recommended, in seconds:

MaximumSeconds = Period * (number of cycles in pattern * 1.03 + 0.2)

For example, if the Period of your data being captured is 1 us and if the number of cycles in your pattern is 10,000, the MaximumSeconds value is:

1 us * (10,000 * 1.03 + .2) = 10.3 ms

If a CaptureSite has never been initiated or if it has already completed when the WaitForAcquisitionComplete function is called, the function will return immediately.

For more information on the Capture Sites interface, see the Capture Sites Overview.


Channel VIs

Channel Clamp Voltage Ppmu Enable

Channel Clamp Voltages

Channel Line Compensation

Channel Clamp Voltage

Channel Query Clamp Voltage Ppmu Enable

Channel Query Line Compensation

Channel Query Remote Sense Enable

Channel Query Response Delay Compensation

Channel Query Stimulus Delay

Channel Remote Sense Enable

Channel Response Delay Compensation

Channels Load Response Delay Compensation

Channels Measure Leakage

Channels Store Response Delay Compensation

Channel Stimulus Delay

Channels Overview


Channel Clamp Voltage Ppmu Enable

Specifies whether the voltage clamps are active when the DSR is in PPMU force current mode. (Note: Voltage clamps are never active when the PPMU is forcing a voltage.)

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing the list of channels to modify. Valid channel range is 0 to 15.

Numeric

Enable (Off)

Enables or disables PPMU on the specified channels. True enables; False disables.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This setting determines if the DSR should enable the clamps when the PPMU is forcing a current. The clamps are never active when the PPMU is forcing a voltage.

Setting and clearing the ClampVoltagePpmuEnable has no effect on the settings of the clamp voltages.

For more information on the voltage clamps and when they are active, see: Channel Clamp Voltages

For more information on the Channels interface, see the Channels Overview.


Channel Clamp Voltages

Sets the protection voltages to which inputs are clamped when the clamps are active.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing the list of channels to modify. Valid channel range is 0 to 15.

Numeric

Minimum Voltage

Minimum clamp voltage. Must be between -2 and 6.2 Volts

Maximum Voltage

Maximum clamp voltage. Must be between -1.2 and 7 Volts.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The specified clamp voltages are active in two situations:

  • When the DSR is sourcing a digital signal via the PatternSite or the StaticSite
  • When the DSR is in PPMU mode, and the PPMU is forcing a current, the clamps are enabled or disabled using the Channel Clamp Voltage Ppmu Enable function

At other times, the clamps are inactive. This includes:

  • When the pattern, capture, or static sites are sensing an input
  • When the PPMU is forcing a voltage
  • When the channels are disabled
  • When the DSR is forcing a voltage from an active pattern site or static site

Setting the clamp voltages does not change the setting of ClampVoltagePpmuEnable.

For more information on the Channels interface, see the Channels Overview.


Channel Line Compensation

Compensates for transmission line effects. The degree can be set from 0 to 7.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing the list of channels to modify. Valid channel range is 0 to 15.

Numeric

DriveCompensation

An integer value indicating the degree of compensation (from 0 to 7).

ReceiveCompensation

An integer value indicating the degree of compensation (from 0 to 7).

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The LineCompensation settings are used to adjust the product input and output impedances to match the lines being driven.

The default value of zero presents a termination as close to purely resistive as possible. Increasing the value to 7 can be used to compensate for line impedances.

For more information on the Channels interface, see the Channels Overview.


Channel Clamp Voltage

Queries the voltages to which the inputs clamps are configured.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

MinimumVoltage

Voltage clamp minimum level set for the specified channel.

MaximumVoltage

Voltage clamp maximum level set for the specified channel.

Remarks

For more information on the Channels interface, see the Channels Overview.


Channel Query Clamp Voltage Ppmu Enable

Queries whether the voltage clamps are enabled when producing current for the specified channel of the PPMU.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The state of the PPMU Clamp Enable on the specified channel.

Remarks

For more information on the Channels interface, see the Channels Overview.


Channel Query Line Compensation

Queries the line compensation settings for the specified channel.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DriveCompensation

Returns the value specified for DriveCompensation on the specified channel. DriveCompensation outputs an integer vaule indicating the degree of compensation (from 0 to 7).

ReceiveCompensaton

Returns the value specified for ReceiveCompensation on the specified channel. ReceiveCompensation outputs an integer value indicating the degree of compensation (from 0 to 7).

Remarks

For more information on the Channels interface, see the Channels Overview .


Channel Query Remote Sense Enable

Queries the line compensation settings for the specified channel.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The state of RemoteSenseEnable on the specified channel.

Remarks

For more information on the Channels interface, see the Channels Overview.


Channel Query Response Delay Compensation

Queries the response delay compensation for the specified channel.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The ResponseDelayCompensation, in seconds, on the specified channel.

Remarks

For more information on the Channels interface, see the Channels Overview.

See also Channel Response Delay Compensation.


Channel Query Stimulus Delay

Queries the stimulus delay for the specified channel.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel

Channel number to query. Valid channel range is 0 to 15.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The StimulusDelay, in seconds, on the specified channel.

Remarks

The StimulusDelay is a channel-specific delay introduced at the output of the DSR. The primary use of this is to align the arrival of signals at the DUT..

For more information on the Channels interface, see the Channels Overview and Channel Stimulus Delay.


Channel Remote Sense Enable

Controls whether stimulus and measurements use the same physical conductors from the DSR.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing a list of channel numbers to query. Valid channel range is 0 to 15.

Numeric

Enable

Enables or disables remote sense lines on the specified channels. True enables; False disables.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

RemoteSenseEnable controls how the PPMU senses signals.

If remote sense is enabled, the signal is sensed via the PPMU sense lines on the DIO connector.

If remote sense is disabled, the signal is sensed via the channel lines that are also used to stimulate the DUT.

For more information on the Channels interface, see the Channels Overview.


Channel Response Delay Compensation

Sets a channel-specific response delay compensation. The delay time is set to the round-trip time for a simultaneous event to begin at the DSR output, go out to the DUT, and the response to arrive back at the DSR.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing the list of channels to modify. Valid channel range is 0 to 15..

Numeric

Delay

The delay in seconds. The resolution of the delay is the EdgePlacementResolution or 100 picoseconds, whichever is higher.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The response delay compensation compensates for delays external to the DSR which affect the arrival of responses back at the DSR. Thus, the specified delay compensation time is equal to the amount of time it takes a response to arrive at the DSR module relative to when stimulus events are emitted by the DSR.

For EdgePlacementResolution less than or equal to 1.3ns, the resolution is 24 picoseconds. For EdgePlacementResolution greater than 1.3ns, the resolution is the EdgePlacementResolution.

Stimulus delays are not incorporated in the response delay compensation. That is, the response delay compensation is the compensation for delays a signal encounters traveling from the DSR to the DUT and back, not including any delay programmed with stimulus delay.

For instance, if equal stimulus delays and response delay compensations are programmed, the net impact is that the stimulus and response remain aligned as they were with no delays, however the comparisons performed by the DSR occur later in time.

The DSR has an internal delay of approximately 10ns. This time must be included in the response delay compensation that is programmed. Use MeasureAndApplyResponseDelayCompensation to determine the total compensation required for a given cable, including internal delays.

Example

If a stimulus takes 5 nanoseconds to reach the DUT, and an additional 5 nanoseconds to return to the DSR, the ResponseDelayCompensation should be set to 10 nanoseconds.

In this example, if one signal followed a shorter path so it arrived at the DUT after 4.9ns. Setting a stimulus delay of 100 picoseconds would cause all the stimulus signals to arrive at the DUT simultaneously. The ResponseDelayCompensation would still be set to 10 nanoseconds so that responses are processed at the DSR 10ns after the stimulus is produced.

However, if one signal took 100 picoseconds longer to return to the DSR, then increasing the ResponseDelayCompensation by 100 picoseconds to 10.1 nanoseconds would then realign the signals for response processing.

For more information on the Channels interface, see the Channels Overview.

See also Channel Query Response Delay Compensation


Channel Stimulus Delay

Sets a channel-specific delay in the output. This delay is relative to the start trigger. Use StimulusDelay to adjust the channels with respect to each other to ensure signals arrive simultaneously at the DUT.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channels

Array containing the list of channels to modify. Valid channel range is 0 to 15..

Numeric

Delay

The delay in seconds. The resolution of the delay is the EdgePlacementResolution or 100 picoseconds, whichever is higher.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The StimulusDelay is used to compensate for variations in timing between channels. It can also be used to introduce a delay between the receipt of a trigger and the pattern being produced.

For EdgePlacementResolution less than or equal to 1.3ns, the resolution is 24 picoseconds. For EdgePlacementResolution greater than 1.3ns, the resolution is the EdgePlacementResolution.

The minimum value of StimulusDelay is zero and the maximum value is the EdgePlacementResolution multiplied by 250.

For more information on the Channels interface, see the Channels Overview.

See also Channel Query Stimulus Delay.


Channels Load Response Delay Compensation

Load previously stored Response Delay Compensation values.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr | FileName

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Channels Measure Leakage

A measurement to calculate the leakage on specificed channels in order to null them out during PatternSite execution.

Keysight MDsr.lvlib:Channels Measure Leakage.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

c1di32 | Channels Channel numbers to measure leakage on. Valid channel range is 0 to 15.

    ci32

            Numeric

cdbl

TestVoltage

Voltage level to minimize leakage at.

cdbl

SettlingDelay (s)

Delay in seconds for measurement. Based on cable length.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This measured leakage compensation value will be automatically applied when running a PatternSite on all Signals defined as Outs that also do not have VIT or VCOM DcLevels defined. If the Signal is defined as an In or InOut, or if VIT or VCOM DcLevels are defined, the PatternSite will still execute, but the low leakge setting will be ignored.


Channels Store Response Delay Compensation

Store all current ResponseDelayCompenstion values to a file.

Keysight MDsr.lvlib:Channels Store Response Delay Compensation.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

FileName

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


DC Levels VIs

DC Levels Add

DC Levels Get Name

DC Levels Get Signals

DC Levels Query DcLevels

DC Levels Remove

DC Levels Set DcLevel

DC Levels Set DcLevels

DC Levels Set Logic Family

DcLevels Overview


DC Levels Add

Adds a DcLevel with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of the DcLevel to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


DC Levels Get Name

Returns the dclevel name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the DCLEVELS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.

For more information on using the dynamic repeated capability Item.Name attribute, see Dynamic Repeated Capabilities .


DC Levels Get Signals

Gets a comma-separated list of Signals for which levels have been defined for this DcLevels block.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

Name of DcLevel. See the ‘DcLevels Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

Gets a comma-separated list of Signals for which levels have been defined for this DcLevels block.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.


DC Levels Query DcLevels

Gets all the DcLevel values for a Signal. If the DcLevel was created from STIL or if it was altered using SetDcLevels, the logic family value will return custom.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

Name of DcLevel. See the ‘ DC Levels Get Name’ in Advanced Action/Status section of menu to obtain the valid names..

Signal

The name of the Signal to query.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

VOL

DUT Output low threshold.

VOH

DUT Output high threshold.

VHYST

Hysteresis applied to the DUT output.

VIL

DUT low voltage input.

VIH

DUT High voltage input.

VIT

Module sourced termination voltage for 50 Ohm input termination.

VCOM

Input commutation voltage for the active load.

IOL

Active load low current forced by the DSR active load when the input is below the commutation voltage.

IOH

Active load low current forced by the DSR active load when the input is below the commutation voltage.

VHH

Voltage forced by the DSR on the high voltage pin when high voltage is active.

LogicFamily

Logic family. Will return custom if not configured by specifying the logic family. Logic families are:

LVCMOS_1_2 (0) : 1.2 V Low Voltage CMOS.

LVCMOS_1_8 (1) : 1.8 V Low Voltage CMOS.

LVCMOS_2_5 (2) : 2.5 V Low Voltage CMOS.

CMOS_5 (3) : 5 V CMOS.

TTL (4) : 3.3 V Low Voltage Transistor-Transistor Logic.

LVTTL (5) : 5 V Transistor-Transistor Logic.

LVDS (6) : Low voltage differential signaling.

Custom (7) : The DSR sets DcLevel logic family to CUSTOM whenever the DcLevels are not set to a specific logic family. That is, when SetDcLevels or SetDcLevel is called, or a STIL file is loaded, or an OpenXML file does not specify a logic family.

PECL (8) : Positive Emitter Coupled Logic.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.


DC Levels Remove

Removes the DcLevel block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

Name of DcLevels to be removed. See the ‘ DC Levels Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.

For more information on using the dynamic repeated capability Item.Name attribute, see Dynamic Repeated Capabilities .


DC Levels Set DcLevel

Sets an individual DcLevel value for all of the Signals in the SignalExpression. Calling this function will set the Logic Family to custom.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

The name of the DC Level. See the ‘ DC Levels Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

SignalExpression

Signal Expression specifying the signals to which the DcLevel is applied.

DcLevelEnum (IOH)

Specifies the DcLevel to set.

IOH : This is the current output by the active load when the input voltage is over the commutation voltage (VCOM). It is used with IOL and VCOM to configure the active load.

IOL : This is the current output by the active load when the input voltage is under the commutation voltage (VCOM). It is used with IOH and VCOM to configure the active load.

VIT : Module sourced termination voltage for 50 Ohm input termination. Setting this to a value other than NaN turns on the 50 Ohm load.

VCOM : This is the active load commutation voltage, the voltage at which the load switches from sinking current to sourcing current. It is used with IOH and IOL to configure the active load.

VHH : Voltage forced by the DSR on the high voltage pin when high voltage is active.

VIH : DUT high voltage input. This is the voltage produced by the DSR for a 1.

VIL : DUT low voltage input. This is the voltage produced by the DSR for a 0.

VOH : DUT output high threshold.

VOL : DUT output low threshold.

VHYST : Hysteresis applied to the DUT output. This is the peak-to-peak hysteresis voltage. Inputs are coerced to 0, 50 mV or 100 mV.

Value

Double specifying the DcLevel value.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the DcLevels interface, see the DcLevels Overview.

For general information on using signal expressions, see Signal Expressions.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


DC Levels Set DcLevels

Sets all the DcLevel values for all the Signals in the SignalExpression. Calling this function will set the Logic Family to custom.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

The name of the DC Level. See the DC Levels Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

SignalExpressionBufferSize

Number of elements in SignalExpression.

SignalExpression

Signal Expression specifying the signals to which the DcLevels are applied.

VOL

DUT Output low threshold.

VOH

DUT Output high threshold.

VHYST

Hysteresis applied to the DUT output low and high thresholds, VOL and VOH. This is the peak-to-peak hysteresis voltage. Inputs are coerced to 0, 50 mV or 100 mV.

VIL

DUT low voltage input. This is the voltage produced by the DSR for a 0.

VIH

DUT High voltage input.This is the voltage produced by the DSR for a 1.

VIT

Module sourced termination voltage for 50 Ohm input termination. Setting this to a value other than NaN turns on the 50 Ohm load.

VCOM

Active load commutation voltage; the voltage at which the load switches from sinking current to sourcing current. It is used with IOH and IOL to configure the active load.

IOL

This is the current output by the active load when the input voltage is under the commutation voltage (VCOM). It is used with IOH and VCOM to configure the active load.

IOH

This is the current output by the active load when the input voltage is over the commutation voltage (VCOM). It is used with IOL and VCOM to configure the active load.

VHH

Voltage forced by the DSR on the high voltage pin when high voltage is active.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Sets every DcLevel to the specified value for all of the signals indicated by the SignalExpression.

  • Note that values associated with only one type of termination can be specified. That is, Vit for 50 Ohm termination or Vcom/Ioh/Iol for the active load.
  • If using the active load, all three values (Vcom, Iol, and Ioh) must be specified.
  • If you do not wish to enable the 50 Ohm termination or active load, set it to Not a Number (NaN).
  • It is an error to specify Vhh for channels other than the high voltage channels. When programming the high-speed channels, set Vhh to NaN (Not a Number).

For more information on the DcLevels interface, see the DcLevels Overview.

For general information on using signal expressions, see Signal Expressions.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


DC Levels Set Logic Family

Sets the Logic Family for all the Signals in the SignalExpression using one of the LogicFamiliesEnum presettings. All DcLevel values are written.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

DcLevel

The name of the DC Level. See the ‘DcLevels Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

SignalExpression

Signal Expression to which to apply Logic Family settings.

Logic Family (LVCOMS_1_2)

DcLevel LogicFamilies.

LVCMOS_1_2 : 1.2 V Low Voltage CMOS

LVCMOS_1_8 : 1.8 V Low Voltage CMOS

LVCMOS_2_5 : 2.5 V Low Voltage CMOS

CMOS_5 : 5 V CMOS

TTL : 3.3 V Low Voltage Transistor-Transistor Logic

LVTTL : 5 V Transistor-Transistor Logic

LVDS : Low voltage differential signaling

Custom : The DSR sets DcLevel logic family to CUSTOM whenever the DcLevels are not set to a specific logic family. That is, when SetDcLevels or SetDcLevel is called, or a STIL file is loaded, or an OpenXML file does not specify a logic family.

PECL : Positive Emitter Coupled Logic

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This sets the DC Levels for the specified signal expression to conventional values for common logic families.

It is acceptable to modify any of the settings made for a logic family using SetDcLevel.

For details on assigning Logic Families see Logic Family Enumeration.

The termination is high impedance for all logic families.

For more information on the DcLevels interface, see the DcLevels Overview.

For general information on using signal expressions, see Signal Expressions.


Instrument VIs

Instrument Available Versions

Instrument Automatic Corrections Execute

Instrument Clear Cache

Instrument Configure Memory

Instrument Downgrade Firmware

Instrument Get Automatic Corrections Needed

Instrument Get Pattern Cache Size

Instrument Get Remaining Cache

Instrument Get Result Size

Instrument Get Slot

Instrument Get Temperature

Instrument Measure and Apply Response Delay Compensation

Instrument Query Auxiliary Output Control

Instrument Reference Clock Configure

Instrument Remove All Dynamic Items

Instrument Set Auxiliary Output Control

Instrument Set Identify

Additional M9195A/B Information


Instrument Available Versions

Returns a comma-delimited string specifying previous software revisions of the product. Any of the revisions returned by this method can be used in a call to the DowngradeFirmware method.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Available VersionsBufferSize

Number of elements in RevisionHistory.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Available Versions

A comma-delimited list specifying all previous product software revisions..


Instrument Automatic Corrections Execute

Runs an algorithm which automatically calculates corrections for the instrument. Before calling this function, any external fixtures (inputs to the instrument) must be disconnected from the instrument.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

AverageMode (AVERAGE64)

Average64, Window50Hz or Window60Hz.

Average64 : 64 measurements are performed as quickly as possible and averaged together.

Window50Hz : Measurements are made over a single 50 Hz power-line cycle in order to maximize noise immunity in 50 Hz environments.

Window60Hz : Measurements are made over a single 60 Hz power-line cycle in order to maximize noise immunity in 60 Hz environments.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

All inputs must be disconnected from the instrument before performing automatic corrections.

If the instrument is more than 5 degrees Celsius from the temperature where automatic corrections were last calculated, measurement values from the PPMU may not be within specifications.

To determine whether the current temperature is within 5 degrees Celsius of the temperature of the last automatic correction, use Instrument Get Automatic Corrections Needed.


Instrument Clear Cache

Clears all downloaded patterns in the cache. There must not be any active patterns or capture sites.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This function will fail if any pattern or capture site is currently active.


Instrument Configure Memory

Configures how memory is allocated between storing compiled patterns and results. The memory size is specified for pattern compilation; the return value is the amount of memory available for results.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternCacheSize

Specifies the amount of memory, in bytes, for compiled pattern storage (cache).

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ResultSize

Returns the amount of memory, in bytes, available for result storage.

Remarks

Configures the memory split between the pattern cache and result storage.

The CacheSize specifies the total memory available for patterns across all banks. This memory stores both patterns that are automatically stored in the cache when they are activated (using PatternSites Activate), and patterns that are stored to cache using Patternsites DownloadPatternToCache.

To determine the size of a compiled pattern, use the Instrument Get Remaining Cache function.

Results are packed into memory in response words. Each response word contains up to 24 consecutive response vectors, that is, data from up to 24 consecutive clock cycles. If the clock cycles generating response data are not within 24-cycles of each other, a full response word is required for each response element.

When the DSR module is configured to run four separate 4-channel banks, the response word from each bank is 64 bytes. When the DSR module is configured to run a single 16-channel bank, each response word is 256 bytes.

Configure Memory will clear any patterns in the cache. All pattern sites must be inactivated before calling this function. A total of approximately 2GBytes of memory is available. By default, the CacheSize is approximately 1.9 GBytes, and the Response size is approximately 100 Mbytes.


Instrument Downgrade Firmware

Downgrades the instrument firmware to the firmware used with an earlier version of the product software.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Revision

Specifies the revision of an earlier product software release. The firmware that was part of that earlier product software release will be loaded onto the product FPGAs. If this is the first release of the product software, this function will do nothing.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Once the firmware downgrade is complete, the DSR module will not work with this version of the software until the firmware is upgraded back to the current version.

Use the DSR soft front panel (SFP) to perform an upgrade.


Instrument Get Automatic Corrections Needed

Returns True if the module requires that AutomaticCorrections be performed to guarantee specifications. This occurs if the current module temperature has deviated by more than 5 degrees C from the temperature at which the current corrections were made.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Instrument Get Pattern Cache Size

Gets the current pattern cache size that was set with ConfigureMemory.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternCacheSize

Gets the current pattern cache size that was set with ConfigureMemory.


Instrument Get Remaining Cache

Calculates and returns the amount of cache memory remaining and available for compiled patterns.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

RemainingCache

RemainingCache memory in Bytes.


Instrument Get Result Size

Result size as determined by ConfigureMemory.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ResultSize

Result size as determined by ConfigureMemory.


Instrument Get Slot

The chassis slot number that the module occupies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Slot

The chassis slot number that the module occupies.


Instrument Get Temperature

Return the module temperature in degrees Celsius.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Temperature

Return the module temperature in degrees Celsius.

Remarks

Note:

  • Temperatures should not be read while executing a list.
  • Reading board temperatures is time consuming, and should be sused sparingly.


Instrument Measure and Apply Response Delay Compensation

Measures the cable delay of an unterminated cable along with delays internal to the DSR and stores the compensation values into Channels Response Delay Compensation.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This measurement requires that the cable be unterminated. After the delay compensation is calculated, the results are written to the Channels Response Delay Compensation.

This measurement includes internal DSR delays and delays through the cable. This is the appropriate value to enter into the ResponseDelayCompensation setting.

The measurement does not include any delays introduced using the Stimulus Delay.

Additional delays beyond those measured for the cable can be added to the measured values in the response delay compensation. For instance, if there is an additional delay of 1.4 ns due to propagation from the end of the cable through the fixture to the actual DUT, it is appropriate to read back the value measured for the response delay compensation by this function, add 1.4 ns to it, then store it as the response delay compensation.

If one or more channels of the cable is terminated, then the cable will appear to be infinitely long. This is not treated as a measurement error, and the cable delay for that channel is set to 0.

It is appropriate to use this method to characterize various cables that extract the values from the driver using QueryResponseDelayCompensation. Subsequently, when using a particular cable, those values can be stored.

For more information on the Channels interface, see the Channels Overview.


Instrument Query Auxiliary Output Control

Queries whether the specified auxiliary, open drain output pin on the module is currently grounded or in a high impedance state.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pin

Pin number to query. This is one of the four auxiliary, open drain output pins on the module. The pins are numbered 0-3.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Current state of the Auxiliary pin. Possible States are:

0 -Ground

1 - High Impedance


Instrument Reference Clock Configure

This function specifies the reference clock source and frequency. The clock source can be selected from a system timing module, the DSR front panel, and the chassis backplane. The clock frequency can be either 10 MHz or 100 MHz, depending on the source.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Source (PXI100)

Clock source to be used. Select what will be used as the Reference clock for PatternSites.

DStarA : D* A

Front panel : Front Panel

PXI100 : PXI 100MHz

Frequency (100 MHz)

Configures the reference frequency provided to the instrument. The following are accepted :

Source Frequency (Frequency must be entered in Hz)

DSTARA 10 MHz or 100 MHz

Front Panel 10 MHz or 100 MHz

PXI100 100 MHz

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The three selectable DSR clock sources are listed in the table below along with the supported frequencies of the clock cources.

Source | Frequency (Note that frequency must be entered in Hz)
DSTARA | 10 MHz or 100 MHz
Front Panel | 10 MHz or 100 MHz
PX100 | 100 MHz

The reference clocks are sourced as follows:

  • PXIe_DSTARA — This clock is generated by a system timing module, if present, and can be either 10 MHz or 100 MHz. In the Keysight M9018A chassis, the system timing module is installed in slot 10. System timing modules are available from 3rd parties, refer to their documentation for information on how to generate the PXIe_DSTARA clock.
  • Clock In connector — This connector is on the DSR front panel, and can be used to connect either a 10 MHz or 100 MHz clock.
  • PXIe_CLK100 — This clock is available on the chassis backplane and is fixed at 100 MHz. This clock is selected by default whenever the driver is Initialized.

All reference clock sources must be within +/- 40 PPM of their target frequency, either 10 MHz or 100 MHz.

As shown in the Syntax section above, enums are used to specify the clock source. The clock frequency is specified in Hz, and must either be 1E7 (10 MHz) or 1E8 (100 MHz), or equivalent notations.

After configuring the clock, checking of the LostLock attribute is recommended. LostLock will be False if locking occurred on the selected reference clock. In order to provide sufficient time for locking to occur on the selected clock, .5 seconds should be allowed between selecting a new clock and checking the LostLock attribute.

As described on the LostLock property page, anytime this property is read, it should be read twice in succession. The first read will clear out any history of a previously lost lock while the second read will provide the actual LostLock status.

NOTE: Care should be taken to avoid selecting an unavailable clock source. Selecting, for example, the front panel Clk In source when there is no clock present on the Clk In connector will render the DSR unable to generate patterns. The DSR will likewise be unable to generate patterns if the clock frequency is outside of the +/- 40 PPM frequency range. As mentioned above, the LostLock attribute can be checked to determine if locking has failed to occur (LostLock will be True if locking has failed).


Instrument Remove All Dynamic Items

Removes all of the STIL components, and inactivates any active sites on the instrument.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information about STIL components or active sites, see:

STIL Components

Active Sites


Instrument Set Auxiliary Output Control

Writes the logical value to one of the four auxiliary, open drain output pins on the module. The pins are numbered 0-3. Writing 1 sets the pin to its high impedance state. Writing zero sets the pin to ground.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pin

Pin number to set. This is one of the four auxiliary, open drain output pins on the module, numbered 0-3.

Value (Ground)

Logical value to write to the Auxilary Output pins.

GROUND : Select Set Ground to Auxilary Output pins.

HIGH IMPEDANCE : Set High Impedance to Auxilary Output pins.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Instrument Set Identify

If True, this property causes an indicator LED on the front panel to flash. This assists in identifying the module being programmed. The special indication persists as long as the Boolean is True.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Identify (Off)

If True, this attribute causes an indicator LED on the front panel to flash.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


MacroDef VIs

MacroDef Define Macros

MacroDef Get Macros

MacroDefs Add

MacroDefs Get Name

MacroDefs Remove

MacroDef (Macro) Overview


MacroDef Define Macros

Defines the patterns to be used as macros.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

MacroDef

The name of the MacroDef. See the ‘ MacroDefs Get Name’ in Action/Status section of menu to obtain the valid names.

MacroNames

Comma-separated list of macro names.

Patterns

Comma-separated list of Pattern names to be used as macros.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

DefineMacro designates one or more patterns to be used as macros. A pattern designated as a macro can be executed from another pattern by including a line that calls it in the invoking pattern.

Macros are invoked using the Macro line type from the API, or the appropriate language syntax from one of the pattern files.

The MacroNames are assigned to the Patterns at the same position in the comma-separated list. For instance, if the MacroNames are "Able, Boy, Cast" and the pattern block names are "Alfa, Bravo, Charlie", then invoking macro Boy, would execute the pattern defined in pattern block Bravo.

For more information on the MacroDef interface, see the MacroDef (Macro) Overview.


MacroDef Get Macros

Returns a comma-separated list of Macros defined in this MacroDef.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

MacroDef

The name of the MacroDef. See the ‘ MacroDefs Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Macros

Returns a comma-separated list of Macros defined in this MacroDef.


MacroDefs Add

Adds a MacroDef block of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of MacroDef to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the MacroDef interface, see the MacroDef (Macro) Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


MacroDefs Get Name

Returns the MacroDename that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the MACRODEFS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the MacroDef interface, see the MacroDef (Macro) Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities .


MacroDefs Remove

Removes the MacroDef block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

MacroDef

Name of MacroDef to remove. See the ‘MacroDefs Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the MacroDef interface, see the MacroDef (Macro) Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities .


Modules VI

Modules Get Name

Nonvolatile Clear

Nonvolatile Write


Modules Get Name

Returns the module name that corresponds to the one-based index that the user specifies.

Keysight MDsr.lvlib:Modules Get Name.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

Index (1)

A one-based index that defines which name to return. The number of available names is contained in the MODULES_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

istr

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.


Nonvolatile Clear

Clears/discards any changes to cached values and resets cached values to the current nonvolatile settings.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Module2

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single nonvolatile.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

See also:

  • Nonvolatile Write


Nonvolatile Write

Writes all cached values from the System.Nonvolatile.Item interface to nonvolatile memory. If certain values have changed (see below) the current Passphrase must be supplied to Write.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Module2

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single nonvolatile.

Passphrase

Passphrase used to protect certain values in Nonvolatile. If none of these values have changed, this parameter is ignored.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks:

Please note that the physical hardware supports a limited number of write cycles so the number of changes to Nonvolatile properties and calls to Write should be minimized. If any of the following values have changed, the current Passphrase value must be specified. The values protected by Passphrase are

  • EnablePeriodicCalChecks

  • EnableModuleCalWarnings

  • EnableInstrumentCalWarnings

  • ModuleCalInterval

  • InstrumentCalInterval

  • Passphrase

See also:

  • Nonvolatile Clear


Pattern VIs

Pattern Cross Reference

Pattern Delete Element at Index

Pattern Get Highest Pattern Index

Pattern Get Pattern Length

Pattern Get Signals

Pattern Go To

Pattern Label Vector

Pattern Loop

Pattern Macro

Pattern Macro With Substitution

Pattern Match Loop

Pattern Query Line Type

Pattern Query Vector

Pattern Shift

Pattern Vector

Patterns Add

Patterns Load Bulk Data

Patterns Remove

Patterns Overview

PatternBurst Overview

PatternExec Overview

PatternFile Overview

PatternSites Overview


Pattern Cross Reference

Places a CrossReference instruction in the pattern at the specified Index. CrossReferences are used to relate the result from the pattern execution to a specific line in the pattern. The Reference string parameter can also be u

sed in marker generation.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

The index within the pattern where the CrossReference instruction will be inserted.

Reference

The String identifying this cross reference that will appear in the Result line information.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

When the CrossReference instruction is executed, it sets a tag that is incorporated in the response data. Each recorded response includes the most recently executed tag, and the number of vectors executed since the tag. This information simplifies identifying where in the source pattern a certain result was generated, as the location of result data is identified both in terms of the vector position within the pattern, and also relative to the most recently executed CrossReference instruction.

The Reference string is also used in marker generation. When this string is set to "Marker0", "Marker1", or "Marker2", it causes a reference to their associated properties, either Marker0Destination, Marker1Destination, or Marker2Destination, respectively. These properties specify what marker signal will be used to generate the marker. See Triggers and Markers for more information.

Note that, when the Reference string is set to "Marker0", "Marker1", or "Marker2", the DSR will perform two operations: (1) Insert the string in the results data as with any Reference string and (2) the DSR will generate a marker when the CrossReference instruction is executed.

If a Reference string has a value other than "Marker0", "Marker1", or "Marker2", only the insertion of the string in the results data will be performed, and no marker will be generated.

The CrossReference instruction executes in zero time and it does not impact the stimulus data in any way.

This is the same functionality provided by the STIL X statement.

For more information on the Patterns interface, see the Patterns Overview.

For information on the response data format, and how the CrossReference is incorporated in the results, see PatternSite Fetch Line Information.


Pattern Delete Element at Index

Deletes the Pattern element at the specified Index.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

The Index in the pattern of the element to be deleted.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Patterns interface, see the Patterns Overview.


Pattern Get Highest Pattern Index

The highest pattern index currently defined. For best efficiency, the next pattern element should be defined at this index+1.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

HighestPatternIndex

The highest pattern index currently defined. For best efficiency, the next pattern element should be defined at this index+1.


Pattern Get Pattern Length

The current length of the pattern. First index is 1. Note that when loading a file, this is the highest element position in the pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternLength

The current length of the pattern. First index is 1. Note that when loading a file, this is the highest element position in the pattern.


Pattern Get Signals

Returns a comma-separated list of all signals in this pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

Returns a comma-separated list of all signals in this pattern.


Pattern Go To

Places a GoTo instruction in the pattern at the specified Index. GoTo causes execution to transfer to the specified label within this pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

The Index where the GoTo statement is placed.

DestinationLabelBufferSize

Number of elements in DestinationLabel.

DestinationLabel

The label to which the GoTo statement will transfer execution.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

GoTo takes zero time to execute.

The destination may be in a different pattern, but it must be within the same PatternBurst.

For more information on the Patterns interface, see the Patterns Overview.

For more information on the PatternBurst interface, see the PatternBurst Overview


Pattern Label Vector

Inserts a label on the vector at the specified Index. The index must identify a vector. Labels are used to identify destinations for GoTo statements and to identify locations in a compiled pattern for PatternSite functions that modify the pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

Index of the vector; specifies where the Label is to be applied. A Vector must already be defined at this index.

Lablel

String used to identify this Label.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Labels are useful to establishing GoTo destinations and to identify a location to modify in the compiled pattern.

The index must identify an existing vector.

VIs that modify a compiled pattern are: PatternSite Set DcLevel, PatternSite Set Signal, PatternSite Set Waveform Table, and PatternSite Set Vector.

For more information on the Patterns interface, see the Patterns Overview.


Pattern Loop

Places a Loop instruction in the pattern at the specified Index. Loop causes a sequence of instructions to be executed the specified number of times.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index (0)

The Index assigned to the Loop statement. The first instruction in the loop is the instruction with the next highest index.

FinalIndex (2)

The Index of the last instruction in the loop.

LoopCount

The numbers of times the loop will execute. 0 means the loop should execute indefinitely.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The loop executes instructions from the next highest index after "Index" to "FinalIndex" (inclusive).

A loop count of 0 indicates that the loop should execute indefinitely.

If the FinalIndex precedes the Index, an error is generated (only forward loops are supported).

For more information on the Patterns interface, see the Patterns Overview.


Pattern Macro

Places a Macro invocation in the pattern at the specified Index. Macro invocation takes no time.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

The name of the Macro to execute.

MacroName

The name of the Macro to execute.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Macro function provides a simple way to execute macros that do not have any parameters.

The Macro invocation takes no time to execute, so the first Vector of the Macro executes immediately after the previous Vector.

For more information on the Patterns interface, see the Patterns Overview.

For more information on Macros, see the MacroDef (Macro) Overview.


Pattern Macro With Substitution

Inserts a Macro expansion at this point, with STIL style parameter substitution..

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index

The Index assigned to the Macro instruction.

MacroName

The name of the Macro to execute.

SignalExpression

Comma-separated list of signals which the macro parameters are applied to.

WaveformCharacters

Comma-separated list of waveform character sequences to be used in parameter substitution on the signals specified in the SignalExpressions parameter.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Invokes a Macro at this line in the program, specifying parameters. The parameters are waveform characters that are filled into the macro in place of the wildcard characters percent (%) and (#).

If signal within the pattern contains the percent (%) character for a given signal, the waveform character associated with that signal in the macro invocation is used in the pattern. Using this mechanism, each signal can have a single waveform character replaced by the value specified in the invocation.

If the pattern contains the hash (#) character, the invocation is permitted to have a string of waveform characters defined for each signal. Each time the hash character is encountered in the macro definition, another character is consumed from the input string and used for the corresponding signal.

The hash (#) character can also be used in the special instruction Shift. The Shift instruction will continue to execute consuming an input waveform character on each execution until the parameter string is entirely consumed.

For more information on the Patterns interface, see the Patterns Overview.

For more information on Macros, see the MacroDef (Macro) Overview.


Pattern Match Loop

The loop defined by Index and FinalIndex is executed until each Compare operation in the loop returns true or the LoopCount (if non-zero) is exceeded.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index (0)

The Index assigned to the MatchLoop instruction. The first instruction in the loop is the instruction with the next highest index.

FinalIndex (2)

The Index of the last instruction to be included in the loop.

LoopCount

Specifies a maximum number of times the loop should execute. 0 indicates the should execute until the match condition is satisfied, that is, it sets the number of times the loop should execute to infinity.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The sequence of instructions in the defined loop are executed until an execution of the entire loop completes with each compare operation passing.

The LoopCount provides a timeout to permit the loop to exit if the DUT never passes. Execution controls are provided to determine if execution should continue on a timeout or stop execution with an error. See PatternSite Set Conditional Loop Failure Mode for information on how to configure this behavior.

For a compare operation to enable the loop to exit, there must be sufficient time between the compare and the end of the loop for the sequencer to exit the loop. If there is not enough time, the loop will continue to execute. Once the loop executes with all compares passing, it will exit. However, the loop will only exit from the end of the loop. That is, the loop is always entirely executed before it exits, it will never exit from the middle of the loop.

There are two components that contribute to the amount of time between the last successful compare in the loop and when the loop ultimately exits.

  • Delays internal to the implementation of the DSR. These are approximately 38 times the edge placement resolution.
  • Delays in the test system that result in the DUT response not arriving at the DSR until sometime after the corresponding stimulus. The DSR compensates for these delays using ResponseDelayCompensation, however the loop cannot exit till the responses arrive so the stimulus defined in the MatchLoop continues to repeat.

In summary, the last vector containing a compare in the MatchLoop establishes when the loop will exit. The loop will exit on the final instruction of the loop when that instruction executes after:

Loop Exit Time >= 38*EdgePlacementResolution+ResponseDelayCompensation

It is possible for an additional pass through the loop to be taken. See PatternSite Set Conditional Loop Success Mode for information on how to configure this behavior.

If the loop does not contain any Compare operations, it will pass on the first execution.

If the maximum count is reached in the Pattern Exec, the ExecutionState will always return the state "Error," with the specific error: "Conditional Loop Count Exceeded."

For more information on the Patterns interface, see the Patterns Overview.


Pattern Query Line Type

Returns information about the pattern element at the given index. This is used to read a pattern that has been defined.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name.vi’ in Advanced Action/Status section of menu to obtain the valid names..

Index

The index of the pattern element queried.

LabelBufferSize

Number of elements in Label.

ReferenceBufferSize

Number of elements in Reference.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Label

The label assigned to the specified pattern index. Null if not defined..

LineType

The type of pattern element at the specified index. Line Types are:

0 - Vector

1 - Match loop

2 - Loop

3 - Go To

4 - Blank

5 - Watch Loop

6 - Shift

7 - Macro

B - Stop

FinalIndex

A pattern index used to provide information about the line at the specified index. For loop operations, the FinalIndex is the final index included in the loop operation.

MaximumCount

A numeric parameter used to provide information about the line at the specified index. The MaximumCount is the loop count specified with the loop.
Reference

If the LineType is a Macro invocation or a GoTo, the Reference returns the destination label; for any other LineType, the Reference returns null.

Remarks

The QueryLineType instruction returns parameters that entirely describe the pattern index queried.

The Label always returns any label that is on the line being queried. The use of the other response parameters to this function varies slightly with the type of line being queried. Their usage is as follows:

LineType | FinalIndex | MaximumCount | Reference
MatchLoop | FinalIndex | Same as Index | null string
Vector | Same as Index | 1 | null string
Loop | FinalIndex | LoopCount | null string
GoTo | Index | 1 | Destination label
Blank (no line defined) | Same as Index | 1 | null string
WatchLoop | FinalIndex | MaximumCount | Trigger
Shift | FinalIndex | 1 | null string Macro Same as Index 1 Destination
Macro | Same as Index | 1 | Destination label

For more information on the Patterns interface, see the Patterns Overview.


Pattern Query Vector

Provides a way to read back the pattern information for lines that are Vectors. Returns an error if a Vector is not defined at this Index (for instance, if it is outside of the pattern range, or if this Index contains a control instruction).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names..

Index

The index of the pattern element queried.

Signal

The signal being queried.

WaveformCharacterBufferSize

Number of elements in WaveformCharacter.

WaveformTableBufferSize

Number of elements in WaveformTable.
LablelBufferSize

Number of elements in Label.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformCharacter

The waveform character defined for the specified signal at the specified index.

WaveformTable

The waveform table at the specified index..

Label

The label defined at the specified index. Null if not defined.

Remarks

If the specified signal is not defined at this Index, a hyphen (-) is returned.

If the signal is not specified at this index when executing the pattern, the DSR will repeat the waveform character from the previous index.

For more information on the Patterns interface, see the Patterns Overview.


Pattern Shift

Adds a Shift block to a Macro. If this pattern is executed directly (instead of being used as a macro), this will generate an error upon compilation.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index (0)

The Index assigned to the Shift instruction.

FinalIndex (2)

The Index of the last instruction to be included in the shift.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Shift block identifies a sequence of Vectors which contains at least one hash (#) style parameter. The macro invocation provides a string of waveform characters to substitute for the hash (#) character. The block specified in the shift is repeated, consuming characters from the macro invocation string until the entire string is consumed.

For instance, if the shift block included a single signal parameter with a single hash (#) character, and the invocation has a string with 12 characters, the Shift block would be executed 12 times, once with the waveform character set to each of the 12 input characters.

For more information on the Patterns interface, see the Patterns Overview.


Pattern Vector

Specifies the waveform characters for the specified signals at the specified index. This function may be called multiple times for a single index, providing definitions for various signals with each call.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single pattern..

Index

The index to add this signal definition to.

SignalExpression

The signals that are defined by the string of waveform characters. This is a signal reference expression.

WaveformCharachters

The waveform characters to assign to the specified signals. There must be one and only one waveform character for each signal specified.

WaveformTable

The waveform table for this vector. A single waveform table is used for all of the signals at this vector.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Specifies the waveform character to be output on the signals at a given vector number.

A given vector within the pattern may need to specify the signal values for several different signals. This can be done by specifying all of the signals in the SignalExpression and the corresponding characters in the WaveformCharacters parameter. This can also be done by calling the Vector function for the signals separately or in arbitrary combinations.

This function may be used to modify a vector that was loaded from a STIL file or from a bulk data file.

Multiple Vector calls that specify the same Index each specify the waveform table. The WaveformTable specified in the last call to Vector is used.

If this vector is contained in a macro pattern, then the vector can contain hash (#) or percent (%) characters which will be converted to waveform characters when the macro is invoked.

For more information on the Patterns interface, see the Patterns Overview.

For general information about Signal Expressions, see Signal Expressions.


Pattern Watch Loop

Adds a WatchLoop block to a pattern. The DSR will execute the WatchLoop repeatedly until the specified Trigger is received. The only instructions that can be within a WatchLoop are Vectors.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Pattern

Name of the Pattern. See the ‘ Patterns Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Index (0)

The Index assigned to the WatchLoop instruction. The first instruction in the loop is the instruction with the next highest index.

FinalIndex (2)

The Index of the last vector in the loop.

MaximumLoopCount

Specifies a maximum number of loops to dwell in the loop waiting for the trigger. 0 indicates to dwell indefinitely.

Trigger (Trigger0)

The event which will cause the WatchLoop to exit.

Trigger : Trigger 0 to Trigger 5

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The sequence of instructions in the loop are executed until the event designated by Trigger occurs.

The LoopCount provides a timeout to permit the loop to exit if the trigger never arrives. Execution controls are provided to determine if execution should continue on a timeout or stop execution with an error. See PatternSite Set Conditional Loop Failure Mode for information on how to configure this behavior.

If the trigger occurs near the end of the loop, the loop may execute an extra time after a successful pass through the loop has completed.

If the maximum count is reached in the Pattern Exec, the ExecutionState will always return the state "Error," with the specific error: "Conditional Loop Count Exceeded."

For more information on the Patterns interface, see the Patterns Overview.


Patterns Add

Adds a Pattern block of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of pattern to add..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Patterns interface, see the Patterns Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


Patterns Get Name

Returns the pattern name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A A one-based index that defines which name to return. The number of available names is contained in the PATTERNS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the Patterns interface, see the Patterns Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities .


Patterns Load Bulk Data

Loads the data file into a pattern of a specified name using the bulk data format.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

FileName

The file to be loaded, including an optional path.

PatternName

Name of the generated Pattern block. If null or a null string, the Pattern block name is the basename of the filename.

HeaderOverride

A header that overrides any header line defined in the file. Optional when header line is defined within the file. Required if header line is not defined in file. Syntax for this parameter is same as when header line is defined within a file.

WaveformTableName

Waveform table to apply to the pattern. If null or a null string, the waveform table name must be specified in the file.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Loads bulk data using a flexible file format. The file is read using the following rules:

  • Comments are designated with a hash (#) or double slash (//). Comments extend to the end of line. Blank lines are also treated as comments.
  • The first non-comment line of the file may be a header that indicates the syntax of the file. The header line begins with "[" and ends with "]". If the header begins with the word "Index," a numeric Index is parsed on each data line. If the header has the word "WaveformTable", then a WaveformTable is parsed on each line. Finally, the header has a list of signals, indicating the order and signal name to associate with each position in the data lines.
  • If no header line is present, the file is assumed to contain only bulk data with an unchanging waveform table and signals as provided via the API.
  • Data lines are parsed based on the header line. Individual waveform characters may be separated by comma or space or may be grouped together.
  • A hyphen (-) can be used in place of a waveform character. This indicates that the previous waveform character on that signal should be repeated. In STIL this is indicated by leaving the waveform character unspecified, but it must be explicit in bulk data.

Generally, values provided by the API override any values appear in the file. For instance, if the signal list is provided in the API, any signals appears on the header line are ignored.

The following are typical examples:

# This file includes a header showing indexes and waveform table

[ Index WaveformTable Signal1 Signal2 Signal3 Clock ]

  0 One 0 1 1 T

  1 0 1 1 T #waveform table defaults to previous line

  2 1 0 0 T #

  3 1 0 1 T #separators are ignored between characters

The following example shows a more terse description. When using this syntax, the waveform table must be specified in the function invocation and the indexes are automatically generated, counting from 0.

# this datafile only defines file includes a header showing indexes and waveform table

[ Signal1 Signal2 Signal3 Clock ]

  0 1 1 T

  0 1 1 T

  0 0 0 T

  0 0 1 T

The final example is the most dense, but has exactly the same meaning as the previous one, except the signal list must be provided via the API (and the comment has been left out).

  011T

  011-

  100-

  101-

For more information, see Bulk Data File Format.

For more information on the PatternFile interface, see the PatternFile Overview.

For information on using dynamic repeated capabilities, see Dynamic Repeated Capabilities .


Patterns Remove

Removes the Pattern block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of Pattern

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Patterns interface, see the Patterns Overview.

For more information on the dynamic repeated capability Remove function, see Dynamic Repeated Capabilities .


PatternBurst VIs

PatternBursts Add

PatternBurst Set Macro Defs

PatternBurst Set Patterns

PatternBursts Get Name

PatternBursts Remove

PatternBurst Overview


PatternBurst Set Macro Defs

Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternBurst

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

MacroDefs

Name of the MacroDefs block to use when compiling the macro definitions in this PatternBurst.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

All macros used in the Patterns and PatternBursts for this PatternBurst must be defined in the MacroDef block provided.

For more information on the PatternBurst interface, see the PatternBurst Overview.

For more information on Macro definitions, see the MacroDef (Macro) Overview.


PatternBurst Set Patterns

Comma-separated list of Pattern blocks or other PatternBursts to execute when this Pattern Burst is executed. The patterns are executed in the order specified and any macros are compiled using the MacroDefs block in this PatternBurst.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternBurst

Name of the Pattern Burst. See the ‘ PatternBursts Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Patterns

Property establishing the list of patterns in this pattern burst.The list can include other PatternBursts, however the complete list can not reference more than one Pattern to be used as the MacroDef. The string is a comma separated list of patterns.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The block references in the comma-separated strings can be either the names of Pattern blocks or of PatternBurst blocks.

The Pattern blocks are executed in the order in which they appear in the string. The same Pattern block can be referenced multiple times.

Blocks do not need to be defined before they are referenced.

For more information on the PatternBurst interface, see the PatternBurst Overview.

For more information on the Patterns block, see the Patterns Overview.


PatternBursts Add

Adds a PatternBurst block of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of PatternBurst to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternBurst interface, see the PatternBurst Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities


PatternBursts Get Name

Returns the patternburst name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the PATTERNBURSTS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the PatternBurst interface, see the PatternBurst Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities


PatternBursts Remove

Removes the PatternBurst block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternBursts

Name of the Pattern Burst to remove. See the ‘ PatternBursts Get Name’ in Advanced Action/Status section of menu to obtain the valid name.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternBurst interface, see the PatternBurst Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities


PatternExec VIs

PatternExecs Add

PatternExec Set Dc Levels

PatternExec Set Pattern Burst

PatternExecs Get Name

PatternExecs Remove

PatternExec Overview


PatternExecs Add

Adds a PatternExec block of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of PatternExec to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternExec interface, see the PatternExec Overview

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


PatternExecs Remove

Removes the PatternExec block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternExec

Name of the Pattern Exec to remove. See the ‘PatternExecs Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternExec interface, see the PatternExec Overview

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


PatternExec Set Dc Levels

DcLevels block to be used by the PatternExec.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternExec

Name of the PatternExec to remove. See the ‘ PatternExecs Get Name’ in Advanced Action/Status section of menu to obtain the valid name

DcLevels

DcLevels to be used by the PatternExec.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternExec interface, see the PatternExec Overview.


PatternExec Set Pattern Burst

PatternBurst block to be used by the PatternExec.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternExec

Name of the Pattern Exec. See the ‘PatternExecs Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

PatternBurst

PatternBurst to be used by the PatternExec.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternExec interface, see the PatternExec Overview.

For more information on the PatternBurst interface, see the PatternBurst Overview.


PatternFile VIs

Delete this text and replace it with your own content.


PatternFile Get Next Error

Returns the next parsing error. If there are no errors, returns "No Error."

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The next parsing error in the error queue.

Remarks

Decrements the ErrorCount property for each error it returns.

For more information on the PatternFile interface, see the PatternFile Overview.


PatternFile Get Error Count

Returns the number of parsing errors from the last Load. The OpenXML and BulkData parsers may return multiple errros. The STIL parser terminates on the first error, so it always returns 0 or 1 for STIL. Use GetNextError to read the errors.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StilErrorCount

Number of errors before parsing stopped.

Remarks

ErrorCount is reset when a new file is parsed, so it represents only the errors from the most recent Load or LoadAndUpdateXml operation.

ErrorCount is decremented for each error read back with PatternFile Get Next Error.

For more information on the PatternFile interface, see the PatternFile Overview.


PatternFile Load

This function loads a STIL, OpenXml, or bulk data file and creates objects based on the content of the file. If an element is loaded and there is already one by that name in the same namespace, the new element will replace the original one.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

FileName

The file, including an optional path to load.

NameSpace

Namespace to lad the STIL components in Use "" for the global namespace. Only supported when loading .stil files.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The specified file is loaded into the DSR STIL components.

If the file suffix is ".stil", the file is parsed as shown in STIL File Format. If the file suffix is ".xlsx", the file is read as an OpenXML file with the DSR defined STIL data (see OpenXML Pattern File Format). Otherwise, the file is read as an ASCII text file that contains bulk pattern data in the DSR defined format.

If the file is in Bulk Data File Format, the file must include a row that defines the Signals to which the waveform characters are to be applied, as described in the bulk data file overview. The name of the generated pattern block is the base portion of the file name. For instance, a file named "patternfile.txt" would produce a pattern block named "patternfile".

If an OpenXML file is loaded that does not contain either a PatternExec or a PatternBurst, they are created automatically for that file. If additional OpenXML files are loaded simultaneously, the names of the generated blocks may collide with the names created for the original file. Therefore, to load multiple OpenXML files simultaneously, you should include a definition of the PatternExec and PatternBurst.

Duplicate block names may appear within the pattern file. If they do, they replace existing block names.

For more information on the PatternFile interface, see the PatternFile Overview.

For information on using dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on specific file formats, see OpenXML file format, STIL file format, and Bulk Data file format.


PatternFile Load And Update Open Xml

This function loads an OpenXml file and creates STIL components based on the content of the file. The STIL components created are dependent on the file contents. Syntax errors are written to a new sheet in the original OpenXml file.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

FileName

The file, including an optional path to load.

NameSpace

For futue use: Namespace to load the STIL components in Use "" for the global namespace.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This function works just like PatternFile Load except that the file must be an OpenXML file (suffix .xlsx). If the file is loaded with this function, and the file has syntax errors, a sheet will be added to the file that contains the syntax errors found in the file. Note that this requires writing to the file.

For more information on the PatternFile interface, see the PatternFile Overview.

For information on using dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on the OpenXML (spreadsheet) file format, see OpenXML Pattern File Format.


PatternFile Load Bulk Data Deferred

Loads a Pattern directly into on board memory.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

FileNameBufferSize

Number of elements in FileName.

FileName

The file to be loaded, including an optional path.

PatternName

Name of the generated Pattern block. If null or a null string, the Pattern block name is the basename of the filename.

HeaderOverride

A header that overrides any header line defined in the file. Optional when header line is defined within the file. Required if header line is not defined in file. Syntax for this parameter is same as when header line is defined within a file.

WaveformTableName

Waveform table to apply to the pattern. If null or a null string, the waveform table name must be specified in the file

MaximumVectorCount

Maximum vector count to aid in module memory allocation. For more information on module memory configuration, refer to Instrument > ConfigureMemory in the DSR Help file.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternFile interface, see the .

For information on using dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For specific information on bulk data files, see Bulk Data File Format.


PatternFile Store Stil

Stores all components loaded to a STIL file. Note that it does not preserve comments or annotations from the original file.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

FileName

The file name in which to store the STIL file. Includes an optional path.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This method stores all of the STIL components currently defined, to a file.

The generated file will typically not have the same syntax as a STIL input file. For instance, an input file might define SignalGroups and then use those SignalGroups in the definition of the pattern and waveform tables. However, this function will output all of the current settings for each signal, without clumping them by SignalGroups. Therefore, the generated file does not provide a useful human-readable format. It does provide a robust record of the configuration of the DSR.

Loading a file generated from StoreStil returns the pattern definition memory of the DSR to the state it was in when StoreStil was called.

For more information on the PatternFile interface, see the PatternFile Overview.

See STIL Components for more information.


PatternSite VIs

PatternSite Abort

PatternSite Fetch Line Information

PatternSite Fetch Result Byte

PatternSite Fetch Result Int16

PatternSite Fetch Result Segment Byte

PatternSite Fetch Result Segment Int16

Pattern Site Fetch Result Segment Wide

Pattern Site Fetch Result Wide

PatternSite Fetch Trinary Result

PatternSite Fetch Trinary Result Segment

Pattern Site Fetch Trinary Result Segment Wide

Pattern Site Fetch Trinary Result Wide

PatternSite Get Edge Placement Resolution

PatternSite Get Edge Placement Resolution Auto

PatternSite Get Execution Errors

PatternSite Get Execution Result

PatternSite Get Execution State

PatternSite Get Result Count

PatternSite Get Result Width

PatternSite Initiate

PatternSite RevaluateDcLevels

PatternSite Revaluate Variables

PatternSites Activate

PatternSites Activate from Cache

PatternSites Activate Pattern

PatternSite Save Results To File

PatternSites Compile Pattern

PatternSites Compile Pattern Exec

PatternSites Download Pattern to Cache

PatternSite Set Conditional Loop Failure Mode

PatternSite Set Conditional Loop Success Mode

PatternSite Set DcLevel

PatternSite Set Force Validate Enable

PatternSite Set Signal

PatternSite Set Vector

PatternSite Set Waveform Table

PatternSites Get Name

PatternSites Inactivate

PatternSites Inactivate and Disable

PatternSites List Cache

PatternSites Set End Behavior

PatternSites Set Result Buffer Size

PatternSites Set Trigger Mode

PatternSites Set Trigger Source

PatternSites Set What to Log

PatternSite Wait For Acquisition Complete

PatternSites Overview


PatternSite Abort

Asynchronously stops the execution of a pattern. The pattern aborts and discards any intermediate results.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Fetch Line Information

Gets the information associated with the specified index in the result array.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See the ' PatternSites Get Name in Action/Status section of menu to obtain the valid names.

Index

Index in the result array being queried.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Time

The number of seconds elapsed since the pattern began executing and the compare operation that produced the result at the specified index.

VectorNumber

The vector offset within the pattern that produced the result at the specified index. This is determined as the difference between the current vector corresponding to the result element and the first vector in the pattern definition.

PatternIndex

The offset within the pattern that produced the result at the specified index, determined as the difference between the pattern index of the vector corresponding to the result element and the pattern index of the first line in the pattern definition.

CrossReference

The most recent CrossReference executed prior to the result at the specified index.

CrossReferenceOffset

The number of vectors executed since the most recent cross reference. This is determined as the difference between the pattern index of the vector corresponding to the result element and the pattern index of the line tagged with the cross reference.

Pattern

The pattern that produced the result at the specified index.

Remarks

This query is used to correlate the data in the result to the location in the pattern that produced this result.

The input to this function is the Index of a specific result in the result array.

The provided line information is independent of the type of fetch function called.

If fetch segment operations are used, the index in the response is offset by the specified Offset.

The outputs from this function (in the table below) provide information about the result.

Parameter | Contains
Pattern

The specific pattern that generated the result (since the compiled pattern may be produced from a PatternBurst).

If the result line was from the expansion of a macro, the name of the invoking pattern and its line number precedes the macro name using the syntax: <pattern>(<line number>):<macro name>

PatternIndex

The PatternIndex of the line that generated the response.

  • Patterns defined with OpenXML, BulkData, or the API include a pattern index that tags each line in the pattern definition.
  • Patterns defined in STIL have a PatternIndex automatically generated for them. The first line of the pattern is PatternIndex 0, and subsequent lines are numbered incrementally.
CrossReference | The CrossReference is a tag explicitly inserted into the pattern definition to facilitate correlating response data to the pattern input. If no CrossReferences have been executed, this parameter returns a null string.
VectorNumber | The vector offset within the pattern that produced the result at the specified index. This is determined as the difference between the current vector corresponding to the result element and the first vector in the pattern definition.
Time | The time, in seconds, from the beginning of pattern execution to the compare operation that logged the result.

For more information on the PatternSites interface, see the PatternSites Overview .


PatternSite Fetch Result Byte

Gets an array of results and returns them as bytes. The FetchResultByte function works for sites where all ordinals are less than 8 (0-7).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

ValActualSize

Actual number of Results.

Remarks

The site ordinals define which bit specific signals of the pattern occupy in the result.

If an ordinal is 8 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

The result may contain all compares, only compares with failures, or the first failure, based on the setting of the WhatToLog attribute.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Fetch Result Int16

Gets results in an array of 16-bit integers. The FetchResultInt16 function works for sites with ordinals less than 16 (0-15).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI to obtain valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

The site ordinals define which bit specific signals of the pattern occupy in the result.

If an ordinal is 16 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Fetch Result Segment Byte

Gets the specified segment of the result as an array of bytes. The FetchResultSegmentByte function works for sites with ordinals less than 8 (0-7).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Offset (0)

The offset of the first element returned within the segment.

Count (1)

The number of elements to return in the segment.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

ValActualSize

Actual number of Results.

Remarks

The site ordinals define which bit specific signals of the pattern occupy in the result.

If an ordinal is 8 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

Result may contain all compares, only compares with failures, or the first failure, based on the setting of the WhatToLog attribute.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Fetch Result Segment Int16

Returns the specified segment of the results as an array of 16-bit integers. The FetchResultSegmentInt16 function works for sites with ordinals less than 16 (0-15).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Offset (0)

The offset of the first element returned within the segment.

Count (1)

The number of elements to return in the segment.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

The site ordinals define which bit specific signals of the pattern occupy in the result.

If an ordinal is 16 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

Result may contain all compares, only compares with failures, or the first failure, based on the setting of the WhatToLog attribute.

For more information on the PatternSites interface, see the PatternSites Overview.


Pattern Site Fetch Result Segment Wide

Returns the result as an array of 32-bit integers. It is only needed when the result data is wider than 16 bits (Ordinals for results data are > 15).

Keysight MDsr.lvlib:Pattern Site Fetch Result Segment Wide.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

PatternSite

The name of the PatternSite. See the ‘PatternSite Get Name’ in Action/Status section of menu to obtain the valid names.

ci32

Offset (0)

The offset of the first element returned within the segment.

ci32

Count (1)

The number of elements to return in the segment.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ii32

ArrayElementsPerVector

The number of element in the returned array, for each results vector.

i1di32

Val

Result data from the pattern execution.

    ii32

            Numeric

ii32

ValActualSize

Remarks

An integer number of integers are inserted in the array for each cycle that produces a result. The number of integers for that cycle is the minimum number necessary to provide all the bit positions for all of the ordinals specified for the Out and InOut channels.


Pattern Site Fetch Result Wide

Returns the result as an array of 32-bit integers. It is only needed when the result data is wider than 16 bits (Ordinals for results data are > 15).

Keysight MDsr.lvlib:Pattern Site Fetch Result Wide.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

PatternSite

The name of the PatternSite. See the ‘PatternSite Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ii32

ArrayElementsPerVector

The number of element in the returned array, for each results vector.

i1di32

Val

Result data from the pattern execution.

    ii32

            Numeric

ii32

ValActualSize

Remarks

An integer number of integers are inserted in the array for each cycle that produces a result. The number of integers for that cycle is the minimum number necessary to provide all the bit positions for all of the ordinals specified for the Out and InOut channels.


Pattern Site Fetch Trinary Result Wide

Returns a segment from the captured result as an array of 32-bit integers. Only needed when the result data is wider than 32 bits.

Keysight MDsr.lvlib:Pattern Site Fetch Trinary Result Wide.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

PatternSite

The name of the PatternSite. See the ‘PatternSite Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ii32

ArrayElementsPerVector

The number of element in the returned array, for each results vector.

i1di32

Val

Result data from the pattern execution.

    ii32

            Numeric

ii32

ValActualSize

Remarks

An integer number of integers are inserted in the array for each cycle that produces a result. The number of integers for that cycle is the minimum number necessary to provide all the bit positions for all of the ordinals specified for the Out and InOut channels.


Pattern Site Fetch Trinary Result Segment Wide

Returns a segment from the captured result as an array of 32-bit integers. Only needed when the result data is wider than 32 bits.

Keysight MDsr.lvlib:Pattern Site Fetch Trinary Result Segment Wide.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

PatternSite

The name of the PatternSite. See the ‘PatternSite Get Name’ in Action/Status section of menu to obtain the valid names.

ci32

Offset (0)

The offset of the first element returned within the segment.

ci32

Count (1)

The number of elements to return in the segment.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ii32

ArrayElementsPerVector

The number of element in the returned array, for each results vector.

i1di32

Val

Result data from the pattern execution.

    ii32

            Numeric

ii32

ValActualSize

Remarks

An integer number of integers are inserted in the array for each cycle that produces a result. The number of integers for that cycle is the minimum number necessary to provide all the bit positions for all of the ordinals specified for the Out and InOut channels.


PatternSite Fetch Trinary Result

Returns an array of captured results. The 32 bits for each element contain two bits for each ordinal (0 - 15); this indicates the actual state of the DUT response on logged compares.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

The ordinal is multiplied by 2, so that two bits are available for each signal/pin. The bit values are mapped as follows:

Value | Indicates
00 | No Compare or No failure.
01 | Failed Low
02 | Failed, electrical state between high and low
03 | Failed High

Result may contain all compares, only compares with failures, or the first failure, based on the setting of the WhatToLog attribute.

If an ordinal is 16 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Get Edge Placement Resolution

Returns the edge placement resolution that was used when this pattern was activated. If EdgePlacementResolutionAuto was True at the time of activation, the return value is the value selected by the DSR.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EdgePlacementResolution (ns)

Returns the Timing Resolution that this pattern was activated with.

Remarks

EdgePlacementResolution sets the finest resolution available for various pattern timing parameters. This value can be set independently of the actual timing values, and the MDsr software will generally select the closest possible value that is consistent with the specified resolution.

Setting the EdgePlacementResolution too small limits the ability of the DSR to produce long durations; setting the EdgePlacementResolution too large limits the ability of the DSR to accurately represent times.

For more information on the PatternSites interface, see the PatternSites Overview

For detailed information on selecting the EdgePlacementResolution and its impact on various DSR settings, see Edge Placement Resolution. In addition, the Edge Placement Resolution Optimizer is a useful tool (in the DSR Soft Front Panel: Tools > Edge Placement Resolution Optimizer).


PatternSite Get Edge Placement Resolution Auto

Returns a Boolean that indicates whether this site was activated with EdgePlacementResolutionAuto.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of men to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EdgePlacementResolutionAuto

If true EdgePlacementResolutionAuto was used to Activate the PatternSite

Remarks

For more information on the PatternSites interface, see the PatternSites Overview.

For detailed information on selecting the EdgePlacementResolution and its impact on various DSR settings, see Edge Placement Resolution. In addition, the Edge Placement Resolution Optimizer is a useful tool (in the DSR Soft Front Panel: Tools > Edge Placement Resolution Optimizer).


PatternSite Get Execution Errors

Gets a comma-separated string containing errors that occurred during pattern execution. This should be consulted if the ExecutionResult returns an error.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

ExecutionErrorsBufferSize

Number of elements in TerminationType

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Execution Errors

Comma-separated list of Errors

Remarks

The ExecutionErrors string indicates whether errors occurred during pattern execution. It is cleared by Initiate and updated to reflect any errors that occurred during pattern execution. If one or more errors occured during pattern execution, the string contains a comma-separated list of errors.

Error | Indicates
Reference Unlocked | The reference clock PLL was unlocked at some point between Initiate and the completion of pattern execution.
Pattern Error | The hardware detected an error at some point during pattern execution. This will occur if the pattern generation hardware is unable to produce the pattern, for instance, if loops in the pattern exceed required lengths.
Conditional Loop Count Exceeded | MatchLoop or WatchLoop exceeded the specified LoopCount parameter.
Overheated | The drivers in the pin electronics overheated during pattern execution
None | No error

Pattern errors should not occur if the WaveformTable Period property is set to 1 us or greater. If a pattern error does occur in your program, possible causes are:

  • Pattern loops that are too short -- For example, a loop containing just two vectors may cause a pattern error. Either increase the number of vectors in the loop, if possible, or "flatten" the loop by repeating the vectors individually the same number of times that are specified by the LoopCount parameter in the Loop method.
  • Nested loops -- Nested loops can also cause a pattern error. Either avoid nested loops, if possible, or flatten the inner loop(s) as described above.

For more information on the PatternSites interface, see the PatternSites Overview


PatternSite Get Execution Result

Gets a Boolean that indicates whether there are any results logged from the previous pattern execution. True indicates there are results.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Execution Result

True at least 1 failure was logged.

Remarks

ExecutionResult may be used to indicate whether a pattern has a failing compare when used with the WhatToLog property to log failing compares. In this configuration an ExecutionResult of true may be used to quickly identify a pattern execution that completed with failing compares. On the other hand, logging all compares cannot rely on ExecutionResult as a failing compare check mechanism.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Get Execution State

Returns the state of the pattern execution hardware. Possible values are Stopped, Running, WaitingForTrigger, Complete, Aborted, and Error.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ExecutionState

Read the execution state. Execution States are :

0 - Executing

1 - Stopped

2 - Waiting for initiate trigger

3 - Complete

4 - Aborted

5 - Error

6 - Waiting for match loop

7 - Watching for Trigger0

8 - Watching for Trigger1

9 - Watching for Trigger2

10 - Watching for Trigger3

11 - Watching for Trigger4

12 - Watching for Trigger5

Remarks

Possible values for ExecutionState are:

Values | Indicates
Stopped | The pattern has not yet been initiated.
Executing | The pattern is currently running.
WaitingForTriggger | The pattern is waiting for a trigger. This could be waiting for a trigger to begin execution, or waiting for a trigger in a WatchLoop.
Complete | The pattern has completed execution without error.
Aborted | The pattern execution was aborted by the user.
Error | An error occurred during pattern execution. (Check ExecutionErrors.)
WaitingForMatchLoop | The pattern is waiting for a MatchLoop.
WatchingForTrigger0 WatchingForTrigger1 WatchingForTrigger2 WatchingForTrigger3 WatchingForTrigger4 WatchingForTrigger5 | Six values of WatchingForTrigger; these correspond to Trigger0 - Trigger 5, defined in the Site.

ExecutionState may be used to poll the DSR to determine whether a pattern has completed execution.

Use WaitForAcquisitionComplete to stop the execution of a client program until the pattern finishes executing.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Get Result Count

Gets the number of elements in the result from the last pattern execution.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ResultCount

Gets the number of results logged from last execution.

Remarks

ResultCount returns the number of elements in the result, regardless of how they were logged.

Any single element of the results may be retrieved with FetchResultSegment.

The WhatToLog setting specifies the results that are logged.

For more information on WhatToLog, see PatternSites Set What to Log.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Get Result Width

Gets the width of the result, that is, the number of bits in each element of the response. The result width is established by the highest ordinal assigned to a response signal in the site definition.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ResultWidth

The number of bits in each element of the response.

Remarks

To determine the number of elements in the response, use PatternSite Get Result Count.

For more information on the PatternSites interface, see the PatternSites Overview


PatternSite Initiate

Begin the execution of the pattern. If Trigger Mode is set to Immediate, the pattern will begin executing immediately. If Trigger Mode is set to Trigger, the hardware will fully initialize, then it will wait for a trigger event before proceeding.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For general information about working with patterns, including the sequence of operations from activation through execution, see the PatternSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


PatternSite Revaluate Variables

Takes a list of variable expressions separated by semicolons (;), evaluates them, and then recalculates the values in the WaveformTables based on the new values of the variables.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

VariableExpressions

String to evaluate, resulting in new variable values, and new values in WaveFormTables. Multiple variable assignments may be made by inserting semicolons between individual assignments.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

ReevaluateVariables provides a way to modify the waveform table times compiled in a pattern. This is especially useful for shmoo testing, which is testing where the same pattern needs to be executed repeatedly while adjusting the timing, the DcLevels settings, or both.

To use ReevaluateVariables, the pattern must be defined in STIL or OpenXML. When defined in STIL or OpenXML, the waveform timing may be defined with a string that is re-evaluated by ReevaluateVariables. By using variables in the string that defines an edge or period, the value can be changed by simply changing the value of the variable.

For instance, if the STIL file defined a waveform table like this:

WaveformTable TableName {

    Period '50ns+shmoo*10ns';

    Waveforms {

        AllSignals { 01 { '0ns+shmoo*1ns' D/U; }}

    }

}

The STIL Spec block can be used to declare and initialize variables.

Then a program similar to this, could be used to determine errors as a function of the shmoo control variable:

     var Site = Driver.PatternSites.Item["MySite"];

     for (var shmoo=0,shmoo <=1; shmoo +=0.01) {

         Site.ReevaluateVariables("shmoo=" + shmoo.ToString());

         Site.PatternSites.Item["MySite"].Initiate();

         Site.WaitForAcquisitionComplete();

         Console.WriteLine("Pattern failed: {0} times with shmoo={1}%",

                         Site.ResultSize,

                         shmoo*100);

     }

The variables are associated with this pattern site, and remain in place until the pattern is inactivated. Multiple variables can be used in the evaluation. The default value of all variables is 0; however, they may be initialized in the pattern source. This can be done by providing a variable assignment as part of any string that is part of the pattern definition. For instance, the following initializes shmoo to 1:

WaveformTable TableName {

    Period 'shmoo=1; 100ns'{

    ...

Levels in DC levels tables may also be defined in terms of strings to defer evaluation. In tests where it is necessary to adjust both amplitude and timing values, the same control variable can be used in the calculation of both values. For instance, the control variable could represent the percentage deviation from the nominal value. Since the variables for the waveform table evaluation and DC level calculations are in the same namespace, the control variable needs to be defined only once for both operations. See PatternSite RevaluateDcLevels for details on that function.

Note that the same expression evaluator is used for DcLevels and WaveformTables; a single control variable can be used to adjust both timing and amplitude; however, both reevaluate functions must be called. The second reevaluate function called can pass a null string if no other variables need to be evaluated.

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on expression evaluation, see Numeric Expressions.


PatternSite RevaluateDcLevels

Takes a list of variable expressions separated by semicolons (;), evaluates them, and then recalculates the values in the WaveformTables based on the new values of the variables.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI to obtain valid names.

VariableExpressions

String to evaluate, resulting in new variable values, and new values in WaveFormTables. Multiple variable assignments may be made by inserting semicolons between individual assignments.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

ReevaluateDcLevels provides a way to modify the DcLevels in a compiled pattern. This is especially useful for shmoo testing, which is testing where the same pattern needs to execute repeatedly while adjusting the timing, DcLevels settings, or both.

To use ReevaluateDcLevels, the pattern must be defined in STIL or OpenXML. When defined in STIL or OpenXML, the DcLevels may be defined with a string that is re-evaluated by ReevaluateDcLevels. By using variables in the string that defines a DcLevel, the value can be changed by simply changing the value of the variable.

For instance, if the STIL file defined a DC Level like this:

DcLevels DcLevelName {

    AllSignals { VIH '3+Overdrive'; VIL '0-Overdrive';}

}

Then a program similar to this could be used to determine errors as a function of increasing overdrive to the DUT:

    var Site = Driver.PatternSites.Item["MySite"];

    for (var Overdrive=0,Overdrive>=1; Overdrive +=0.1) {

        Site.ReevaluateDcLevels("Overdrive=" + Overdrive.ToString());

        Site.PatternSites.Item["MySite"].Initiate();

        Site.WaitForAcquisitionComplete();

        Console.WriteLine("Pattern failed: {0} times with overdrive={1}V",

                        Site.ResultSize,

                        Overdrive);

    }

The variables are associated with this pattern site, and remain in place until the pattern is inactivated. Multiple variables can be used in the evaluation. The default value of all variables is 0; however, they may be initialized in the pattern source. This can be done by providing a variable assignment as part of any string that is part of the pattern definition. For instance, the following initializes Overdrive to 1:

DcLevels DcLevelName {

    Ann {* ANN #8 *}{

    AllSignals { VIH 'Overdrive=1; 3+Overdrive'; VIL '0-Overdrive';}{

}

Timings in waveform tables may also be defined in terms of strings to defer evaluation. In tests where it is necessary to adjust both amplitude and timing values, the same control variable can be used in the calculation of both values. For instance, the control variable could represent the percentage deviation from the nominal value. Since the variables for the waveform table evaluation and DC level calculations are in the same namespace, the control variable needs to be defined only once for both operations. See PatternSite Revaluate Variables for details on that function.

Note that the same expression evaluator is used for DcLevels and WaveformTables, so a single control variable can be used to adjust both timing and amplitude, but both reevaluate functions must be called. The second reevaluate function called can pass a null string if no other variables need to be evaluated.

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on expression evaluation, see Numeric Expressions.


PatternSite Save Results To File

Saves the results and all of the line information, as text, to the specified file. The individual elements are comma-separated.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Filename

Name of file including filepath.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The result and all of the line information is stored to the specified file as text. Each line of the file has the following syntax:

  <Result><PatternName><PatternIndex><CrossReference><IndexSinceCrossReference><VectorNumber><Time>

Field position | Field | Meaning
0 | Result | The numeric value of the result, in decimal. This is the value returned by the various Fetch functions.
1 Pattern Name

This is the pattern that contained the compare that produced the result. If the pattern includes a macro expansion, the name of the macro and the line number where the macro was invoked in the pattern is included in this field using the following syntax:

<calling pattern>[<calling pattern index>]:<macro name>

For example,

  MyPattern[3]:Macro1

The subsequent information describes the pattern index (and cross reference, if it exists) within the macro.

2 Pattern Index

This indicates the pattern index in the pattern (or macro) that contained the vector that produced the result.

For patterns created with IVI or OpenXML, the pattern Index is in the pattern definition.

For patterns created with STIL, or if the pattern index was not included in an OpenXML file, the pattern index is the 0-based count of the vector within the pattern. That is, the first vector is 0, the second is 1 et cetera. Control statements are also assigned a pattern index. The control statements are:

Loop

WatchLoop

MatchLoop

Goto

Stop

3 Cross Reference
(XREF) 		Name of most recent cross reference.
4 Index Since
Cross Reference 		The offset since the most recent cross reference in the most recently executed vector.
5 | Vector Number | This is the 0-based count of vectors executed from the beginning of the pattern until the vector that produced this result
6 | Time | The time from the beginning of the pattern execution until this result.

Labels and cross references are not assigned a pattern index. They both apply a label the following vector statement.

The format parallels the result format displayed by the SFP.

For more information on cross references, see Pattern Cross Reference.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Set Conditional Loop Failure Mode

Match loops and watch loops include a loop counter which, if expired, indicates that the loop has failed. This property selects what will happen when the loop counter expires (either stop execution or exit the loop and continue).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ConditionalLoopFailureMode (STOP_ON_FAIL)

ConditionalLoop Failure Mode

STOP_ON_FAIL : Stop Execution if LoopCount exceeded.

CONTINUE_ON_FAIL : Continue Execution if LoopCount is exceeded.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The following behaviors are supported on a MatchLoop or WatchLoop count reaching 0 (that is, the counter expiring) without the condition being satisfied:

ContinueOnFail | When the count is satisfied, the loop exits as if the match or watch condition had been satisfied.
StopOnFail | When the count is satisfied, pattern execution terminates (default).

This failure mode setting is compiled into the pattern. Therefore, when compiling to cache, this setting must be specified at the time the pattern is compiled.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.

For conditional loops, see Pattern Match Loop and Pattern Watch Loop.


PatternSite Set Conditional Loop Success Mode

Configures if the DSR will execute a MatchLoop or WatchLoop at least one extra time after a successful loop, or if the loop will require no compares in the final few vectors of the loop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ConditionalLoopSuccessMode (Extra Loop)

Conditional Loop success mode.

EXTRA LOOP : Loop one or more additional times after a succesful MatchLoop.

NO COMPARE : Exit at the end of the first successful loop if no Compares exist at the end of the Loop.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The DSR supports two different behaviors for successfully exiting MatchLoops.

As described in Pattern Match Loop, it takes several edge placement resolution times for the MatchLoop success to be determined. Once that success has been determined, the sequencer can optionally perform an additional loop before exiting.

NoCompare | The loop exits at the end of the first successful pass through the Matchloop. If there are compares too close to the end of the loop the MatchLoop will exit after the first pass through the loop.
ExtraLoop | Once the MatchLoop succeeds, one or more additional passes through the loop will be executed. Failed MatchLoops on the extra passes through the loop will not effect when the MatchLoop exits.

This success mode setting is compiled into the pattern. Therefore, when compiling to cache, this setting must be specified at the time the pattern is compiled.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.

For conditional loops, see Pattern Match Loop and Pattern Watch Loop.


PatternSite Set DcLevel

Specifies a single DC level to apply on the given signal within this pattern. SetDcLevel cannot be called while the pattern is executing.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.
Signal Expression

Signals to which to apply the new DcLevel

DcLevelToSet (DCLEVEL_IOH)

Which DcLevel to change, that is, which of the DC settings will be changed. The termination mode may not be changed. Only active values may be adjusted.

DCLEVEL_IOH : This is the current output by the active load when the input voltage is over the commutation voltage (VCOM). It is used with IOL and VCOM to configure the active load.

DCLEVEL_IOL : This is the current output by the active load when the input voltage is under the commutation voltage (VCOM). It is used with IOH and VCOM to configure the active load.

DCLEVEL_VIT : Module sourced termination voltage for 50 Ohm input termination. Setting this to a value other than NaN turns on the 50 Ohm load.

DCLEVEL_VCOM : This is the active load commutation voltage, the voltage at which the load switches from sinking current to sourcing current. It is used with IOH and IOL to configure the active load.

DCLEVEL_VHH : Voltage forced by the DSR on the high voltage pin when high voltage is active.

DCLEVEL_VIH : DUT high voltage input. This is the voltage produced by the DSR for a 1.

DCLEVEL_VIL : DUT low voltage input. This is the voltage produced by the DSR for a 0.

DCLEVEL_VOH : DUT output high threshold.

DCLEVEL_VOL : DUT output low threshold.

DCLEVEL_VHYST : Hysteresis applied to the DUT output. This is the peak-to-peak hysteresis voltage. Inputs are coerced to 0, 50 mV or 100 mV.

Level

New value of DcLevel

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

SetDcLevel is useful for shmoo testing, or other applications where a single amplitude value needs to be adjusted after a pattern has been compiled.

The level is updated when this function is called; however, if no outputs are currently using this DcLevel, it will not be apparent.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Set Force Validate Enable

If true, any WaveformTables compiled will perform force validation by adding a compare operation to validate a successful force on the last cycle of operations that include force operations.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ForceValidate (Off)

If True, the waveform characters used by the PatternSite will have the last force events validated by a corresponding compare event. Force validation is only applied to waveform characters where the last force event is a ForceUp (U) or a ForceDown(D), there is no compare event defined, and there is at least one EdgePlacementResolution (EPR) between the last force event and the end of the Waveform period. WaveformCharacters that have these characteristics will have a compare event, based on the previous force event, added one EPR prior to the end of the period. This means a CompareHigh(H) will be added to validate a ‘U’ event and a CompareLow(L) will be added to validate a ‘D’ event. To disable the Force Validate on a waveform by waveform basis, specify a CompareUnknown(X) waveform event within a WaveformCharacter definition.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Force validation uses the DSR hardware to verify that forced outputs reach their designated level within the waveform period.

Force validation requires that the DcLevels defined for the pattern satisfactorily measure the forced signal. That is, if the the response thresholds (set with Vol, Voh) need to be set so that a properly settled stimulus (based on Vil and Vih) can be used to verify the levels.

Force validation works by introducing a compare operation into waveform characters that:

  • Are defined on InOut Signals
  • Have no defined compare operations
  • Have atleast two times the edge placement resolution between driving the output and the end of the cycle.

ForceValidate can be useful even if certain waveform characters within the pattern do not do the force validation.

ForceValidate can be disabled on a particular waveform character by specifying a CompareUnknown anywhere within the period.

For more information on the PatternSites interface, see the Patterns Overview.


PatternSite Set Signal

Changes a single signal over a series of clock periods in the compiled waveform. That is, it writes the characters of the provided string into the designated signal in subsequent vectors.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI to obtain valid names.

Pattern

Pattern to modify.

Label

Label within the pattern where the first change will be applied. This defines offset 0.

LabelOffset

PatternIndex offset from the label to modify. Must be within the same block of vectors, that is, within the same group of vectors enclosed in braces in STIL.

Signal

Name of signal to change

WaveformCharacters

Waveform characters to write into the pattern. Successive characters are written from the string into the pattern until the end of the string.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

SetSignal changes a specified signal data line over a series of clock periods. For instance, this is useful to change a data value in a serial protocol. The first waveform character in the waveform characters string is written to the designated signal in the vector described by parameters Label and LabelOffset. Subsequent waveform characters are written to the same signal in subsequent vectors until all of the waveform characters are used.

The changes to the signal must all be within a program segment. That is, the length of the waveform characters string must not cause the changes to span into a different segment.

Note that this instruction works on the currently active pattern.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Set Vector

Overwrites the vector data at the specified location in a compiled pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

Pattern

Pattern to modify.

Label

Label within the pattern where the first change will be applied.

LabelOffset

PatternIndex offset from the label to modify. Must be within the same block of vectors, that is, within the same group of vectors enclosed in braces in STIL.

SignalExpression

The signals that are modified. That is, the signals that are set to the provided waveform characters. These are specified in the order the signals appear in the SignalExpression parameter.

WaveformCharacters

The new waveform characters to use for the signals specified.
WaveformTable

The waveform table for this vector.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

SetVector completely replaces the vector at the given location with the pattern, label, offset, waveform characters, and waveform table specified in this function. The location modified is the location with the pattern index at the specified offset from the specified label within the pattern.

The new vector is formed by assigning the characters in WaveformCharacters to the corresponding signals in the SignalExpression. If a Signal is not specified in the SignalExpression, the DSR will repeat the waveform character specified in the previous vector.

The specified Waveform Table must have been defined in the original Pattern Exec unless 32 or fewer waveform tables were specified when the pattern was compiled.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Set Waveform Table

Overwrites the Waveform Table at the specified location in the compiled pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI to obtain valid names.

Pattern

Pattern to modify.

Label

Label within the pattern where the first change will be applied. This defines offset 0.

LabelOffset

PatternIndex offset from the label to modify. Must be within the same block of vectors, that is, within the same group of vectors enclosed in braces in STIL.
WaveformTable

The waveform table for this vector.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

SetWaveformTable changes the WaveformTable at a single clock period. Using this, the timing of a single bit period can be adjusted. Successive vectors will return to the WaveformTable with which they were compiled. This is useful for shmoo testing.

The specified Waveform Table must have been defined in the original Pattern Exec unless 32 or fewer waveform tables were specified when the pattern was compiled.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSite Wait For Acquisition Complete

This function waits for the pattern to complete execution before it returns. If a pattern has not been initiated or if it has already completed, the function will return immediately.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

TThe name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names.

MaximumSeconds

The length of time, in seconds, to wait for the pattern to complete execution.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

ExecutionStateEnum indicating the current state of the PatternSite.

0 - Executing

1 - Stopped

2 - Waiting For Initiate Trigger

3 - Complete

4 - Aborted

5 - Error

6 - Waiting For Match loop

7 - Watching For Trigger 0

8 - Watching For Trigger 1

9 - Watching For Trigger 2

10 - Watching For Trigger 3

11 - Watching For Trigger 4

12 - Watching For Trigger 5

Remarks

Use PatternSite Get Execution Result and PatternSite Get Execution Errors to determine why the acquisition terminated.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSites Activate

Activates a previously-compiled PatternSite that has been saved in cache.Activates a site for pattern operations using the specified PatternExec and with the specified EdgePlacementResolution. The pattern is compiled and downloaded to the pattern cache.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

Name of Site block to be activated.

PatternExec

Name of the PatternExec block that defines the pattern, DcLevels, and WaveformTables to execute.

EdgePlacementResolutionAuto (Off)

Indicates if the KtMDsr driver should select the EdgePlacementResolution or if the EdgePlacementResolution parameter will specify the value. True indicates the driver should select the value, in which case the EdgePlacementResolution parameter is ignored.

EdgePlacementResolution (ns)

Specifies the edge placement resolution (when EdgePlacementResolutionAuto is False). Sets the finest resolution available when selecting pattern timing parameters. Range is 1 ns to 100 ns. This resolution determines how the times specified are rounded to values produced.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Reserves the channels for exclusive use by the specified site and compiles the PatternExec for use on the specified channels using the EdgePlacementResolution.

Note that the PatternExec block refers to the necessary DcLevels, MacroDefs and a PatternBurst which contains one or more pattern blocks; this information is compiled to produce the pattern.

The pattern information is compiled and downloaded to the pattern cache; it is removed when the site is inactivated.

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.


PatternSites Activate from Cache

Activates a previously-compiled PatternSite that has been saved in cache.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

CacheName

Name of the compiled pattern in cache.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Reserve the channels for exclusive use by the specified site and activates the compiled PatternExec for use on the specified channels.

The compiled pattern includes all the PatternExec and Site information that was in the original pattern. The site name for the activated pattern is the CacheName.

When a pattern is activated using ActivateFromCache, the pattern remains in cache, even after it is later inactivated. In contrast, when a pattern is activated with Activate, a subsequent Inactivate will delete the pattern from cache.

Note that the compiled pattern has information about the entire PatternExec and the site incorporated into it, so a pattern must be compiled for every site on which it will be used.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolutionn.


PatternSites Activate Pattern

Activates a site for pattern operations. Parameters specify the site, pattern, waveform table, DcLevels, and EdgePlacementResolution. The pattern is compiled and downloaded to the pattern cache.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

Name of Site block to be activated. See the ‘ Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Pattern

Name of the Pattern block that will be executed.

DcLevels

Name of the DcLevels block that will be applied to the signals.

EdgePlacementResolutionAuto (Off)

If True, the KtMDsr driver will automatically select the edge placement resolution (in which case the EdgePlacementResolution parameter is ignored). If False, the resolution is set by the EdgePlacementResolution parameter.

EdgePlacementResolution (ns)

Specifies the edge placement resolution (when EdgePlacementResolutionAuto is False). Sets the finest resolution available when selecting pattern timing parameters. Range is 1 ns to 100 ns. This resolution determines how the times specified are rounded to values produced.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

ActivatePattern reserves the channels for exclusive use by the specified site and compiles the pattern and DcLevels for use on the specified channels using the edge placement resolution.

To activate a pattern that uses multiple patterns or macros, use Activate. This requires creating a PatternBurst and PatternExec.

The pattern information is compiled and downloaded to the pattern cache; it is removed when the site is inactivated.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.


PatternSites Compile Pattern

Compiles the pattern components for the specified site and saves the compiled pattern to the specified destination (either a file or cache). The name will be used to refer to the site when it is later activated from cache.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

The name of the Site. See the ‘ Sites Get Name’ in Action/Status section of menu to obtain the valid names.

Pattern

Name of the Pattern block that will be executed.

DcLevels

Name of the DcLevels block that will be applied to the signals.

EdgePlacementResolutionAuto (Off)

If True, the KtMDsr driver will automatically select the edge placement resolution (in which case the EdgePlacementResolution parameter is ignored). If False, the resolution is set by the EdgePlacementResolution parameter.

EdgePlacementResolution (ns)

Specifies the edge placement resolution (when EdgePlacementResolutionAuto is False). Sets the finest resolution available when selecting pattern timing parameters. Range is 1 ns to 100 ns. This resolution determines how the times specified are rounded to values produced.

Destination (FILE)

Where to save a Compiled PatternSite.

FILE : External file.

CACHE : On Board memory of the Dsr.

Name

The name of the compiled pattern. This is either the file system name or the name in cache.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Compiles the specified pattern for use on the specified site with the specified edge placement resolution. The compiled pattern is either placed in cache or saved to the file system.

The pattern is specified as a pattern block and the DcLevels to apply to the signal. To specify a pattern that uses macros or multiple patterns CompilePatternExec. This requires creating a PatternBurst and a PatternExec.

If the pattern is saved to the cache, it can be activated using the specifed Name. If the pattern is saved to the file system, the Name is the filename where the file is stored.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.


PatternSites Compile Pattern Exec

Compiles the components into a PatternSite and saves it to the specified destination (either a file or cache). The name will be used to later reference the PatternSite.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

The name of the Site. See the ‘ Sites Get Name’ in Action/Status section of menu to obtain the valid names

PatternExec

Name of the PatternExec to compile.

EdgePlacementResolutionAuto (Off)

If True, the KtMDsr driver will automatically select the edge placement resolution (in which case the EdgePlacementResolution parameter is ignored). If False, the resolution is set by the EdgePlacementResolution parameter.

EdgePlacementResolution (ns)

Specifies the edge placement resolution (when EdgePlacementResolutionAuto is False). Sets the finest resolution available when selecting pattern timing parameters. Range is 1 ns to 100 ns. This resolution determines how the times specified are rounded to values produced.

Destination (FILE)

Where to save a Compiled PatternSite.

FILE : External file.

CACHE : On Board memory of the Dsr.

Name

The name of the compiled pattern. This is either the file system name or the name in cache.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Compiles the specified pattern for use on the specified site with the specified edge placement resolution. The compiled pattern is either placed in cache or saved to the file system.

Note that the PatternExec block refers to the necessary DcLevels, MacroDefs, and a PatternBurst that contains one or more pattern blocks. This information is compiled to produce the pattern.

If the pattern is saved to the cache, it can be activated using the specifed Name. If the pattern is saved to the file system, the Name is the filename where the file is stored.

The compiler incorporates the site and PatternExec into the compiled pattern. Therefore, a pattern must be compiled for every site on which it will be used.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information about how the EdgePlacementResolution parameter is used, see Edge Placement Resolution.


PatternSites Download Pattern to Cache

Downloads the compiled pattern from the file system to the cache and assigns a name, CacheName, to the compiled pattern.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternFile

FilePath of compiled pattern (which was previously created using CompilePattern).

CacheName

Name of the compiled pattern in the pattern cache. This name is used to activate the pattern.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Downloads the compiled pattern to cache. No pattern-specific actions will take place until the compiled pattern is activated.

Note that the compiled pattern has information about the PatternExec and the site incorporated into it, so a pattern must be compiled for every site on which it will be used.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


PatternSites Get Name

Returns the patternsite name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the PATTERNSITES_COUNTattribute, which is read by using the GetAttributeViInt32

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities .


PatternSites Inactivate

Releases the resources associated with this site. The state of the individual channels is not changed (that is, the channels are not disabled).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

Name of PatternSite to inactivate. See the ‘ PatternSites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Channels will continue to output the level or waveform character specified in the EndCondition. This is not allow while a Pattern is Executing. To put the channels into a high impedance state, use PatternSites Inactivate and Disable.

If transitioning between sites that change the direction of the signals on the channels, PatternSites Inactivate and Disable should be used.

For more information on the PatternSites interface, see the Patterns Overview.

For more information on the dynamic repeated capability Inactivate function, see Dynamic Repeated Capabilities .


PatternSites Inactivate and Disable

Releases the resources associated with this site. The individual channels are disabled.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

Name of PatternSite to inactivate. See the ‘ PatternSites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

In addition to inactivating the site, this function also disables the channels. That is, the instrument will isolate itself from the DUT in a fashion that will minimize the possibility of the DUT or DSR being harmed.

If transitioning between sites that change the direction of the signals on the channels, PatternSites Inactivate and Disable should be used.

For more information on the PatternSites interface, see the PatternSites Overview.

For more information on Inactivate and other dynamic repeated capabilities, see Dynamic Repeated Capabilities .


PatternSites List Cache

Returns a comma-separated list of PatternSites previously saved in cache, and the amount of memory each is using.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternsBufferSize

Number of elements in Patterns.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Patterns

String containing a comma-separated list of cached patterns.

Sizes

Array containing the sizes of each compiled pattern. Element 0 of the array corresponds to the first pattern in the comma-separated list of patterns.

Numeric

SizesActualSize

Actual number of elements in Sizes.

Remarks

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSites Set End Behavior

Sets the behavior of the signal lines upon completion of a pattern to either retain the last state of the signal lines from the last period or repeat the last waveform character of the last period.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

EndBehavior (RETAIN_LAST_LEVEL)

What to do after the last Vector in Pattern execution.

RETAIN_LAST_LEVEL : Hold at last Level for all channels.

REPEAT_LAST_WAVEFORM_CHARACTER : Repeat last Vector for all Channels.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This capability is especially useful for applications where a clock signal needs to continue between pattern executions or while using the DSR in another way.

To generate a continuous clock, the last cycle of the pattern should specify unchanging values for signals that should remain at a fixed level. Clock signals should have a clock cycle defined that will continue to execute at the specified period until another pattern is initiated.

EndBehavior setting: | Specifies:
RepeatLastLevel | The last signal level of the last period will be retained on each signal.
RepeatLastWaveformCharacter | The last waveform character of the last period will be repeated until the channel is disabled or driven by some other operation.

For more information on the PatternSites interface, see the PatternSites Overview.

For information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


PatternSites Set Result Buffer Size

Specifies the amount of memory, in bytes, to be reserved for results for this pattern. This memory is taken from the memory reserved for results using Instrument Configure Memory.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ResultBufferSize

Amount of memory in Bytes to allocate for results.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The default value is generally appropriate for this attribute. It is useful to set ResultBufferSize to a specific size when an application is using multiple banks and it needs to allocate different amounts of result memory to each site.

If this pattern uses all of the module banks, the default value utilizes all of the memory reserved by the Instrument Configure Memory function.

If this pattern uses only a single bank, the default value will evenly divide the unused memory between this pattern and any inactive banks.

See Instrument Configure Memory for details on how memory allocation is controlled between patterns and results.

For more information on the PatternSites interface, see the PatternSites Overview Instrument Configure Memory.


PatternSites Set Trigger Mode

The trigger mode determines whether the pattern begins executing immediately after it is initiated or whether it waits for a trigger event.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TriggerMode (IMMEDIATE)

Sets the Trigger Mode. How Pattern generation will being.

IMMEDIATE : Triggered by Initiate. Execution of the pattern automatically begins when initiated.

TRIGGERED : Trigger set in TriggerSource starts execution. The execution waits for a trigger event before executing.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSites Set Trigger Source

Gets or sets the trigger source used to begin execution for this pattern after calling Initiate.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TriggerSource

Set how PatternSite will be initiated.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The table below shows the relationship between Software Triggers, TriggerSource strings, and the EventBits to set when calling GenerateSoftwareEvents. Multiple bits may be set to generate multiple software triggers.

TriggerSource string | Set EventBits to this value when calling GenerateSoftwareEvents
"SoftwareTrigger0" | 1
"SoftwareTrigger1" | 2
"SoftwareTrigger2" | 4
"SoftwareTrigger3" | 8
"SoftwareTrigger4" | 16
"SoftwareTrigger5" | 32
"SoftwareTrigger6" | 64
"SoftwareTrigger7" | 128
"SoftwareTrigger8" | 256
"SoftwareTrigger9" | 512
"SoftwareTrigger10" | 1024
"SoftwareTrigger11" | 2048
"SoftwareTrigger12" | 4096
"SoftwareTrigger13" | 8192
"SoftwareTrigger14" | 16348
"SoftwareTrigger15" | 32768

For more information on the PatternSites interface, see the PatternSites Overview.

For details on generating software triggers, see TriggerEvent Generate Software Events.


PatternSite Wait For Acquisition Complete

This function waits for the PatternSite to complete execution before it returns. A MaximumSeconds timeout parameter is provided which causes an exception to be generated if the function does not return before the timeout period elapses.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

TThe name of the PatternSite. See VI in Action/Status section of menu to obtain valid names.

MaximumSeconds

The length of time, in seconds, to wait for the pattern to complete execution.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

ExecutionStateEnum indicating the current state of the PatternSite.

0 - Executing

1 - Stopped

2 - Waiting For Initiate Trigger

3 - Complete

4 - Aborted

5 - Error

6 - Waiting For Match loop

7 - Watching For Trigger 0

8 - Watching For Trigger 1

9 - Watching For Trigger 2

10 - Watching For Trigger 3

11 - Watching For Trigger 4

12 - Watching For Trigger 5

Remarks

After a PatternSite is initiated, your program can call the WaitForAcquisitionComplete function to await completion of the pattern. If the DSR is collecting results in Results Memory, the results will be available when this function returns.

A MaximumSeconds timeout parameter can be specified to determine if the WaitForAcquisitionComplete function fails to return within a certain time. The function may fail to return for a number of reasons, including a programmed start trigger that never occurs, a WatchLoop that never receives its programmed trigger, or a MatchLoop that never detects the programmed pattern.

If a timeout does occur, an exception is generated which your program can catch. Your program can then check the status of the PatternSite ExecutionState property to help identify the issue. Your program can also look at the PatternSite ExecutionResult and PatternSite ExecutionErrors properties.

The MaximumSeconds parameter should be set long enough to ensure that a timeout doesn't occur with PatternSites that execute and complete normally. The following minimum timeout value is recommended, in seconds:

MaximumSeconds = Period * (number of cycles in pattern * 1.03 + 0.2)

For example, if the Period of your pattern is 1 us and if the number of cycles in your pattern is 10,000, the MaximumSeconds value is:

1 us * (10,000 * 1.03 + .2) = 10.3 ms

If a PatternSite has never been initiated or if it has already completed when the WaitForAcquisitionComplete function is called, the function will return immediately.

For more information on the PatternSites interface, see the PatternSites Overview.


PatternSites Set What to Log

Sets the compares to log during pattern execution (all compares; first failed compare; all failed compares). If "first failed compare" is selected, the first failure terminates the pattern execution.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WhatToLog (EVERY_CYCLE_WITH_COMPARE)

All compares; first failed compare; all failed compares. If "first failed compare" is selected, the first failure terminates the pattern execution.

EVERY_CYCLE_WITH_COMPARE : Every cycle with a compare. Use this setting when the pattern is defined with the intent of capturing all compares.

EVERY_CYCLE_WITH_FAILING_COMPARE : All failed compares. This setting is useful when the pattern expects specific values for all DUT response signals.

FIRST_CYCLE_WITH_FAILING_COMAPRE_AND_TERMINATE : The first failed compare. After the failed compare, the pattern execution terminates. A successful completion will result in ExecutionState of "Complete" and ExecutionErrors = "None."

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The WhatToLog setting controls the logging of compares during pattern execution.

WhatToLog setting | DSR logs
EveryCycleWithCompare | Every cycle with a compare. Use this setting when the pattern is defined with the intent of capturing all compares.
EveryCycleWithFailingCompare | All failed compares. This setting is useful when the pattern expects specific values for all DUT response signals.
FirstCycleWithFailingCompareAndTerminate

The first failed compare. After the failed compare, the pattern execution terminates.

This setting is supported only on single-module instruments, not on multi-module instruments. An error will be generated if this setting is programmed on a multi-module instrument.

A successful completion (no failed compares) will result in ExecutionState of "Complete" and ExecutionErrors = "None."

To use the DSR to log data, set WhatToLog to EveryCycleWithCompare. The bits which contain data are normally configured to compare the input with a logical low. In this case, the state of the compare reflects the binary information. When WhatToLog is set to EveryCycleWithCompare, this will place both 0's and 1's in the result.

For details on generating software triggers, see TriggerEvent Generate Software Events.

For more information on the PatternSites interface, see the PatternSites Overview.


PPMUSite VIs

PpmuSite Force

PpmuSite Force Current Measure Current

PpmuSite Force Current Measure Voltage

PpmuSite Force Nothing Measure Voltage

PpmuSite Force Voltage Measure Current

PpmuSite Force Voltage Measure Voltage

PpmuSite Get Current Limit

PpmuSite Get Force Mode

PpmuSite Get Level

PpmuSites Activate

PpmuSite Set Average Mode

PpmuSite Set Settling Delay

PpmuSites Get Name

PpmuSites Inactivate

PpmuSites Inactivate and Disable

PpmuSites Overview


PpmuSite Force

This function forces a current, voltage or shuts off the force function. No measurement is performed.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

ForceMode (NOTHING)

What to force prior to a Ppmu measurement.

NOTHING : Force nothing.

VOLTAGE : Force configured Voltage.

CURRENT : Force configured Current

Level

Level being forced. In Amps for current, in Volts for voltage. When ForceMode is Nothing, the Level parameter is ignored.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Force Current Measure Current

Function that forces the specified current and measures the actual current. Note that the ability to force the current depends on the system impedance.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

ForceCurrent

Level being forced, in Amps. Current must be between -40mA and 40mA, inclusive.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Returns an array containing the measured current on each channel in the site. Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

Numeric

ValActualSize

Actual number of Results.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

A positive current produces a current flow out of the DSR and into the DUT.

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Force Current Measure Voltage

Function that forces the specified current and measures the voltage.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

ForceCurrent

Level being forced, in Amps.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Returns an array containing the measured voltage on each channel in the site. Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

Numeric

ValActualSize

Actual number of Results.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

A positive current produces a current flow out of the DSR and into the DUT.

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Force Nothing Measure Voltage

Stops any active forcing function (either current or voltage) and measures voltage.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Returns an array containing the measured voltage on each channel in the site. Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

Numeric

ValActualSize

Actual number of Results.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

A positive current produces a current flow out of the DSR and into the DUT.

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Force Voltage Measure Current

Function that forces the specified voltage and measures the current.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names..

ForceVolage

Level being forced, in Volts.

CurrentRange

The maximum current expected. This configures the DSR to measure currents of this magnitude or below.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Returns an array containing the measured voltage on each channel in the site. Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

Numeric

ValActualSize

Actual number of Results.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

A positive current produces a current flow out of the DSR and into the DUT.

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Force Voltage Measure Voltage

Function that forces the specified voltage and measures the actual voltage. Note that the ability to force the voltage depends on the system impedance.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

ForceVoltage

Level being forced, in Volts.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Returns an array containing the measured voltage on each channel in the site. Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

Numeric

ValActualSize

Actual number of Results.

Remarks

Each channel's measurement result is placed at the index in the array specified by the ordinal in the site.

The maximum compliance voltage is dependent on the current range. Below is a table of values.

Current range | Voltage
±40 mA | -2.0 to +5.75 V
±25 mA | -2.0 to +6.0 V
±2 mA (and less) | -2.0 to +6.5 V

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For information on using active sites, see Active Sites.


PpmuSite Get Current Limit

Returns the maximum current the module can produce on this channel based on the current settings.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

CurrentLimit

Sets the maximum current to be produced when forcing voltage and measuring current. Also sets the source resistance when sourcing voltage. (Note: CurrentLimit is not used when measuring or sourcing current, as current level is implicit in other settings.)


PpmuSite Get Force Mode

Allows querying of the Force Mode. To set the ForceMode property, use the Force function or one of the Force and Measure functions.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ForceMode

Allows querying of the Force Mode. To set the ForceMode property, use the Force function or one of the Force and Measure functions. Force modes are :

0 - Nothing

1 - Voltage

2 - Current


PpmuSite Get Level

Returns the force level currently in use. To set the Level property, use the Force function or one of the Force and Measure functions.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name VI in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Level

Returns the force level currently in use. To set the Level property, use the Force function or one of the Force and Measure functions.


PpmuSite Set Average Mode

Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get Name

AverageMode (NONE)

Controls the averaging performed for measurements. Configures whether the PPMU should perform simple averaging, perform averaging to noise reduction (reject power-line frequency noise), or omit averaging to return the highest speed measurements.

NONE: A single measurement is performed.

AVERAGE64 : 64 measurements are performed as quickly as possible and averaged together.

WINDOW50_HZ : Measurements are made over a single 50 Hz power-line cycle in order to maximize noise immunity in 50 Hz environments.

WINDOW60_HZ : Measurements are made over a single 60 Hz power-line cycle in order to maximize noise immunity in 60 Hz environments..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


PpmuSite Set Settling Delay

Specifies the delay, in seconds, between applying the Force and performing the measurement.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. To find, use PpmuSites Get NameVI in Action/Status section of menu to obtain the valid names.

SettlingDelay

Delay, in seconds.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


PpmuSites Activate

Activates a site for PPMU operations. Once activated, the site block name can be passed to the Item function to access PPMU functions for this site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

The name of the Site. See the ‘Site Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Activate will reserve the channels for exclusive use by the specified site and initialize the PPMU capabilities associated with those channels.

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites


PpmuSites Inactivate

Releases PPMU resources associated with this site without altering the signals on the channels.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

Name of the site activated for PPMU operations to inactivate. See the ‘PpmuSite Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites


PpmuSites Inactivate and Disable

Releases PPMU resources associated with this site and places the channels into a high impedance state.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PpmuSite

The name of the PpmuSite. See the ‘PpmuSite Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites


Signals VIs

SignalGroups Add

SignalGroup Set Signals

SignalGroups Get Name

SignalGroups Remove

Signals Add

Signals Add Signal List

Signal Set Direction

Signals Remove

Signals Overview


Signal Set Direction

Gets or sets the direction of this signal. The direction is relative to the DUT.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signal

Signal name.

Direction (IN)

Get/Set the direction of the signal.

IN : Specifies that the signal is an input to the DUT (and output from the DSR).

OUT : Specifies that the signal is an output from the DUT (and input to the DSR).

IN_OUT : Specifies that the signal can be either an input to the DUT or an output from the DUT.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SignalGroup Set Signals

Sets the list of Signals to use for this SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL signal-reference-expression syntax. For instance "Sig1+Sig2+Bus[0..7]".

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SignalGroup

Signal group name. See SignalGroups Get Name in Advanced Action/Status section of menu to obtain the valid names.

Signals

Add/Remove signals from the SignalGroup. To add multiple signals at the same time, they should be defined using conventional STIL syntax. For instance: Sig1+Sig2.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This attribute contains the string that defines the group as defined Signal Groups.

For more information on the SignalGroups interface, see the SignalGroups Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

For more information on evaluating Signal and numeric expressions, see Signal Expressions and Numeric Expressionss.


SignalGroups Add

Adds a SignalGroup block of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of SignalGroup.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the SignalGroups interface, see the SignalGroups Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


SignalGroups Get Name

Returns the signalgroup name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the SIGNALGROUPS_COUNT attribute, which is read by using the GetAttributeViInt32 VI located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the SignalGroups interface, see the SignalGroups Overview.

For more information on the dynamic repeated capability Name attribute, see Dynamic Repeated Capabilities .

For more information on evaluating Signal and numeric expressions, see Signal Expressions and Numeric Expressions.


SignalGroups Remove

Removes the SignalGroup block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signal Group

Name of the Signal Group to remove. See the ‘ SignalGroups Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the SignalGroups interface, see the SignalGroups Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


Signals Add

Adds a Signal of the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of Signal to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Signals interface, see the Signals Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .

See STIL Components for more information on how patterns are defined.


Signals Add Signal List

Takes a list of Signal names and creates a new Signal for each, including an assigned direction. This provides a way to define several Signals at once.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

String containing a list of signal names.

Direction

Array of directions (relative to the DUT) to apply to the Signal list. Directions are assigned as follows: first enum in Direction array is assigned to first signal in the Signal list, second direction enum to second signal in list, and so on.

Direction In (0) - Specifies that the signal is an input to the DUT (and output from the DSR).

Direction Out (1) - Specifies that the signal is an output from the DUT (and input to the DSR).

Direction InOut (2) - Specifies that the signal can be either an input to the DUT or an output from the DUT.

Numeric

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

AddSignalList provides a simple way to Add several signals with a single function call.

The Signals string has the following syntax:

Plus (+) or comma (,) are used to list Signal names | Sig1+Sig2+Sig3 Sig1,Sig2,Sig3
A range of Signals can be added using square brackets | DataBus[0..16]
Minus (-) removes a signal from the expression | DataBus[0..16] - DataBus[16]

For more information on the Signals interface, see the Signals Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .

See STIL Components for more information on how patterns are defined.


Signals Remove

Removes the Signal block with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

Name of Signal block to Remove.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Signals interface, see the Signals Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .

See STIL Components for more information on how patterns are defined.


Sites VIs

Site Assign Signal

Site Assign Signal List

Site Query Site

Site Set Marker0 Destination

Site Set Marker1 Destination

Site Set Marker2 Destination

Site Set Trigger0 Source

Site Set Trigger1 Source

Site Set Trigger2 Source

Site Set Trigger3 Source

Site Set Trigger4 Source

Site Set Trigger5 Source

Sites Add

Sites Get Name

Sites Remove

Sites Overview


Site Assign Signal

Defines the mapping from a signal to a channel and specifies the ordinal. The ordinal specifies the bit or element number to use when packing measurement results (DUT outputs) into bytes or arrays.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

Name of site. See Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Signal

Name of Signal.

Channel

Channel number to map to the Signal. Valid channel range is 0 to 15.

Ordinal

Ordinal (Index used for data formatting). An ordinal is needed for Signals with direction of Out or InOut, and for Signals used for PPMU measurement. Use -1 to ignore this field.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Ordinal property is only needed when receiving output signals from the DUT as specified by the Direction property. The Direction property is set relative to the DUT, so DUT outputs have a Direction of either Out or InOut. When a signal Direction in set to In (an input to the DUT), the Ordinal property is not needed and should be set to -1.

For more information on the Sites interface, see the Sites Overview.

For more information on Signals, see the Signals Overview.


Site Assign Signal List

Provides a simple way to define several signals from a comma-separated list of Signal names. Automatically assigns channels and ordinals. First Signal name is assigned Channels[0]; ordinals begin from highest ordinal already assigned for that site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

Name of site. See Sites Get Name in Advanced Action/Status section of menu to obtain the valid names.

Signals

Comma-separated list of Signals

Channels

Channel numbers to pair with Signals. Index 0 applies to the first Signal in the string. Valid Channels are from 0 to 15.

Numeric

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

When ordinals are automatically assigned, the numbering starts from the highest ordinal already defined for that site (which may be 0).

AssignSignalList provides a shorthand for defining sites. It provides the same functionality as AssignSignal but requires that the Signals and Channels be provided in the order that ordinals should be assigned.

For more information on the Sites interface, see the Sites Overview.

For more information on Signals, see the Signals Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


Site Query Site

Returns the Signals, Channels, and Ordinals defined in the site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

Name of site. See Sites Get Name in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

Comma-separated list of signals.

Channels

Array containing all of the defined channels. Element 0 corresponds to the first Signal in the list.

Numeric

ChannelsActualSize

Ordinals

Array containing the ordinals for each channel. Element 0 corresponds to the first Signal in the list. Use -1 to indicate that no ordinal is defined for this channel.

Numeric

OrdinalsActualSize

Remarks

This function provides a way to read back all the settings from this site.

For more information on the Sites interface, see the Sites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


Site Set Marker0 Destination

Sets the destination of all Marker0 references for patterns run on this site. The destination specifies on what signal the marker is generated.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

Marker0Destination

Sets the destination of all the Marker0 references for patterns run on this site.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Site Set Marker1 Destination

Sets the destination of all Marker1 references for patterns run on this site. The destination specifies on what signal the marker is generated.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

Marker1Destination

Sets the destination of all the Marker1 references for patterns run on this site.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Site Set Marker2 Destination

Sets the destination of all Marker2 references for patterns run on this site. The destination specifies on what signal the marker is generated.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

Marker2Destination

Sets the destination of all the Marker2 references for patterns run on this site.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Site Set Trigger0 Source

Configures the trigger event that maps to Trigger0 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names

Trigger0Source

Configures the trigger event that maps to Trigger0 in the WatchLoop.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Site Set Trigger1 Source

Configures the trigger event that maps to Trigger1 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Trigger1Source

Configure the triggers looked for by the Watch and OnTrigger operation.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Trigger1Source attribute assigns the source of trigger events to use when the pattern references Trigger1.

For instance, in the pattern below,

Vector WXYZ;

Vector ABCD;

WatchLoop 10 Trigger1 {

Vector EFGH;

}

code similar to this would set the above WatchLoop to watch for SoftwareTrigger1:

myDriver.Site.Item["mySite"].Trigger1Source="SoftwareTrigger1";

For more information on the Sites interface, see the Sites Overview.


Site Set Trigger2 Source

Configures the trigger event that maps to Trigger2 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Trigger2Source

Configures the physical trigger that corresponds to Trigger2 in the WatchLoop.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Trigger2Source attribute assigns the source of trigger events to use when the pattern references Trigger2.

For instance, in the pattern below,

Vector WXYZ;

Vector ABCD;

WatchLoop 10 Trigger2 {

Vector EFGH;

}

code similar to this would set the above WatchLoop to watch for SoftwareTrigger1:

myDriver.Site.Item["mySite"].Trigger2Source="SoftwareTrigger1";

For more information on the Sites interface, see the Sites Overview.


Site Set Trigger3 Source

Configures the trigger event that maps to Trigger3 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Trigger2Source

CConfigures the physical trigger that corresponds to Trigger3 in the WatchLoop.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Trigger3Source attribute assigns the source of trigger events to use when the pattern references Trigger3.

For instance, in the pattern below,

Vector WXYZ;

Vector ABCD;

WatchLoop 10 Trigger3 {

Vector EFGH;

}

code similar to this would set the above WatchLoop to watch for SoftwareTrigger1:

myDriver.Site.Item["mySite"].Trigger3Source="SoftwareTrigger1";

For more information on the Sites interface, see the Sites Overview.


Site Set Trigger4 Source

Configures the trigger event that maps to Trigger4 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Trigger4Source

Configures the physical trigger that corresponds to Trigger4 in the WatchLoop.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Trigger4Source attribute assigns the source of trigger events to use when the pattern references Trigger4.

For instance, in the pattern below,

Vector WXYZ;

Vector ABCD;

WatchLoop 10 Trigger4 {

Vector EFGH;

}

code similar to this would set the above WatchLoop to watch for SoftwareTrigger1:

myDriver.Site.Item["mySite"].Trigger4Source="SoftwareTrigger1";

For more information on the Sites interface, see the Sites Overview.


Site Set Trigger5 Source

Configures the trigger event that maps to Trigger5 in the WatchLoop.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

The name of the site. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Trigger5Source

Configures the physical trigger that corresponds to Trigger5 in the WatchLoop.

TriggerSource string :

"SoftwareTrigger0"

"SoftwareTrigger1"

"SoftwareTrigger2"

"SoftwareTrigger3"

"SoftwareTrigger4"

"SoftwareTrigger5"

"SoftwareTrigger6"

"SoftwareTrigger7"

"SoftwareTrigger8"

"SoftwareTrigger9"

"SoftwareTrigger10"

"SoftwareTrigger11"

"SoftwareTrigger12"

"SoftwareTrigger13"

"SoftwareTrigger14"

"SoftwareTrigger15"

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The Trigger5Source attribute assigns the source of trigger events to use when the pattern references Trigger5.

For instance, in the pattern below,

Vector WXYZ;

Vector ABCD;

WatchLoop 10 Trigger5 {

Vector EFGH;

}

code similar to this would set the above WatchLoop to watch for SoftwareTrigger1:

myDriver.Site.Item["mySite"].Trigger5Source="SoftwareTrigger1";

For more information on the Sites interface, see the Sites Overview.


Sites Add

Adds a site with the specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of site to add.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Sites interface, see the Sites Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


Sites Get Name

Returns the site name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the SITES_COUNT attribute, which is read by using the GetAttributeViInt32 VI located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0..

Remarks

For more information on the Sites interface, see the Sites Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


Sites Remove

Removes the Site of the specified name. Fails if the Site is not defined.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Site

Name of Site block to Remove. See the ‘ Sites Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the Sites interface, see the Sites Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


StaticSites VIs

StaticSite Read Three State Vector

StaticSite Read Vector

StaticSites Activate

StaticSites Get Name

StaticSites Inactivate

StaticSites Inactivate and Disable

StaticSite Write Three State Vector

StaticSite Write Vector

StaticSites Overview


StaticSite Read Three State Vector

Inputs a vector and builds it into two integers, one representing the data value and the other indicating if a valid 1 or 0 was detected. The bits of the integers are mapped to the channels based on the ordinals provided in the Site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSite

.The name of the StaticSite. See StaticSites Get Name in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Data

Data read from the StaticSite. The ordinal from the Site definition specifies the mapping between bits of the Data result and the physical channels.

Valid

Indicates if the data read from the StaticSite is valid. The data is valid if the DUT output voltage is greater than Voh or less than Vol. The ordinal from the Site definition specifies the mapping between bits of the Data result and the physical channels.

Remarks

Reads the state of the site as binary values based on the DC Levels specified when the StaticSite was activated. High values are returned as a 1 in the appropriate bit of the integer. Low values are returned as a 0 in the appropriate bit of the integer. Intermediate values are considered invalid and are returned as a 0 in the Data integer, and indicated in the Valid response parameter.

The Valid response parameter has bits set to 1 in the bit positions where a valid 0 or 1 was read from the input.

Only the 32 least signifficant channels are programmed. To control more than 32 static lines, a second static site must be activated.

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) return 0.

If a bit is invalid, the data value returned is 0.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


StaticSite Read Vector

Inputs a vector and builds it into an integer. The bits of the integer are mapped to the channels based on the ordinals provided in the site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSiteThe name of the StaticSite. See StaticSites Get Name in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

The integer read. Invalid voltage inputs are converted to zero.

Remarks

Reads the state of the site as binary values based on the DC Levels specified when the StaticSite was activated. High values (those higher than Voh) are returned as a 1 in the result. Low values (those lower than Vol) are returned as a 0 in the result. Intermediate values (those where the input voltage is between Voh and Vol) are considered invalid and are returned as a 0 in the result.

This function returns the same value as the ReadThreeStateVector Data response parameter, but does not provide the Valid result that indicates voltage inputs fell between the Voh and Vol thresholds.

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) return 0.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


StaticSite Write Three State Vector

Stimulates the DUT with a vector based on two integers. The bits of the integer are mapped to the channels based on the ordinals provided in the site. The Data parameter sets the truth value; the Enable parameter enables the signal.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSite

The name of the StaticSite. See StaticSites Get Name’ in Action/Status section of menu to obtain the valid names StaticSites Overview

Data

The truth value to force on the channels.

Enable

Enables which channels are written.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Bits not enabled, but configured with Signals defined as DUT In or DUT InOut are placed in a high impedance state.

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT output (Direction is Out) are not affected by the write.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


StaticSite Write Vector

Stimulates the DUT with a vector based on one integer. The bits of the integer are mapped to channels based on the ordinals in the Site. The Data parameter sets the truth value. All bits configured in the site as Signal In or InOut are written.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSite

The name of the StaticSite. See StaticSites Get Name’ in Action/Status section of menu to obtain the valid names.

Data

The truth value to force on the channels.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT output (Direction is Out) are not affected by the write.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities .


StaticSites Activate

Activates a site for StaticSite operations. Once activated, the site block name can be passed to the Item function to access the StaticSite functions for this site.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SiteName

Name of the Site to activate. See the ‘ Sites Get Name’ in Action/Status section of menu to obtain the valid names.

DcLevels

Block name of the DcLevels block to use to generate the digital signals.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This will lock the channels for exclusive use by the specified site and initialize the StaticSite capabilities associated with those channels.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites.


StaticSites Get Name

Returns the staticsite name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the STATICSITES_COUNT attribute, which is read by using the GetAttributeViInt32 VI located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

This is useful when a reference to this block is acquired using the Item function and there is a subsequent need to determine which block this is.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on the dynamic repeated capability Item function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites.


StaticSites Inactivate

Releases StaticSite resources associated with this site without altering the signals on the channels..

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSite

Name of the site activated for StaticSite operations to inactivate. See StaticSites Get Name in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This is useful when a reference to this block is acquired using the Item function and there is a subsequent need to determine which block this is.

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on the dynamic repeated capability Inactivate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites.


StaticSites Inactivate and Disable

Releases StaticSite resources associated with this site and disables the signals on the channels.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

StaticSite

Name of the site activated for StaticSite operations to inactivate. See the ‘ StaticSites Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the StaticSites interface, see the StaticSites Overview.

For more information on the dynamic repeated capability Inactivate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites.


System VIs

SystemGetSerialNumber

System Get Timeout Milliseconds

System Get Trace Enabled


SystemGetSerialNumber

The module serial number.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

SerialNumber

The module serial number.


System Get Timeout Milliseconds

Queries the timeout used for IO to the module.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TimeoutMilliseconds

Queries the timeout used for IO to the module. To set this value, use the OptionString parameter in the Initialize call.


System Get Trace Enabled

If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

TraceEnabled

If True, output trace log of all driver calls to an XML file, using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.


Trigger VIs

TriggerEvent Generate Software Events

Trigger Get Name

Trigger Set Direction

Trigger Set External Trigger Termination

Trigger Set External Trigger Threshold Level

Trigger Set MarkerPulseWidth

Trigger Set Polarity


Trigger Get Name

Returns the trigger name that corresponds to the one-based index that the user specifies.

Keysight MDsr.lvlib:Trigger Get Name.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

Index (1)

A one-based index that defines which name to return. The number of available names is contained in the TRIGGER_COUNT attribute, which is read by using GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

istr

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

This table shows the Name strings that are returned for the different values of Index.

Index | Name
1 | "External1"
2 | "External2"
3 | "GPIO1"
4 | "GPIO2"
5 | "PXI_TRIG0"
6 | "PXI_TRIG1"
7 | "PXI_TRIG2"
8 | "PXI_TRIG3"
9 | "PXI_TRIG4"
10 | "PXI_TRIG5"
11 | "PXI_TRIG6"
12 | "PXI_TRIG7"
13 | "PXI_STAR"
14 | "PXIe_DSTARB"
15 | "PXIe_DSTARC"

For more information on triggers and markers, see Trigger and Marker Overview.


Trigger Set Direction

This property sets the direction of those DSR signals that are bi-directional and can be either a trigger input or a marker output. This property applies to GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], and PXI_STAR.

Keysight MDsr.lvlib:Trigger Set Direction.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Trigger

Name of the Trigger. See ‘Trigger Get Name’ in Action/Status section of menu to obtain the valid names.

ci32

Direction (Marker)

Used to configure a line as either a Marker or a Trigger.

Marker : The trigger is an input to the DSR (i.e., the DSR receives a trigger).

Trigger : The trigger is an output from the DSR (i.e., the DSR generates a trigger).

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For the bi-directional signals listed above, the Direction property is used to specify whether the signal is a trigger input (enum of KtMDsrTriggerDirectionTrigger) or is a marker output (enum of KtMDsrTriggerDirectionMarker). The default value of Direction for all bi-directional trigger/marker signals is as a trigger input.

The Direction property does not apply to the trigger input signal PXIe_DSTARB nor the marker output signal PXIe_DSTARC. The direction of these signals cannot be changed.

Care should be taken to ensure that a DSR marker output isn't inadvertently connected to a marker output from another module or from the chassis.

For more information on triggers and markers, see Trigger and Marker Overview.


Trigger Set External Trigger Termination

This property configures the input termination impedance of the two front panel trigger inputs, GPIO1 (External1) and GPIO2 (External2). Two values are programmable, 50 ohms and high impedance (the default, which is nominally 10K ohm).

Keysight MDsr.lvlib:Trigger Set External Trigger Termination.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Trigger

Name of the Trigger. See ‘Trigger Get Name’ in Action/Status section of menu to obtain the valid names.

ci32

Termination (Low Impedance 50 Ohm)

Configure how the External Triggers are terminated. Default = HighImpedence.

Low Impedance 50 Ohm : The module will connect a low impedance, nominally 50 ohms, to the trigger line.

High Impedance 10k Ohm : The module's trigger line will be high impedance (i.e. the low impedance termination will be disconnected).

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals have been programmed to be trigger inputs using the Direction property. The termination impedances are disconnected when these signals are programmed to be marker outputs.

For more information on triggers and markers, see Trigger and Marker Overview.


Trigger Set External Trigger Threshold Level

Sets the threshold voltage levels for the front panel signals, GPIO1 (External1) and GPIO2 (External2), when they are programmed as trigger inputs. The threshold voltages can be set independently for each trigger input over the range -2VDC to 4VDC.

Keysight MDsr.lvlib:Trigger Set External Trigger Threshold Level.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Trigger

Name of the Trigger. See ‘Trigger Get Name’ in Action/Status section of menu to obtain the valid names.

cdbl

ThresholdLevel

Used to set the voltage level expected by a Trigger for External only.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This property is only effective when the front panel GPIO1 (External1) or GPIO2 (External2) signals are programmed as trigger inputs. An error is generated if the programmed threshold voltage level is outside of the range -2VDC to 4VDC.

The default threshold voltage level for this property is .75V. The programmed threshold voltage levels have a nominal accuracy of +/- 100mV.

For more information on triggers and markers, see Trigger and Marker Overview.


Trigger Set MarkerPulseWidth

This property sets the pulse width of marker outputs. The pulse width can be programmed independently for the 12 DSR signals that can be used as markers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, and PXIe_DSTARC..

Keysight MDsr.lvlib:Trigger Set MarkerPulseWidth.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Trigger

Name of the Trigger. See ‘Trigger Get Name’ in Action/Status section of menu to obtain the valid names.

PulseWidth (ns)

Used to set the width of the pulse generated by a Marker. Default = 100ns.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The range of marker pulse widths that can be programmed depends on the edge placement resolution (EPR). The maximum pulse width for any marker is 256 x 4 x EPR. For example, for an EPR of 1ns, the maximum marker pulse width will be 256 x 4 x 1ns = 1,024ns.

For an EPR of 100ns, the maximum marker pulse width will be 102.4us.

Marker pulse widths will be rounded to the closest integer multiple of 4 x EPR. For example, if a pulse width of 90ns is programmed when the EPR is 10ns (4 x EPR = 40 ns), the actual pulse width will be 80ns.

The minimum marker pulse width is 20ns. The DSR will use a pulse width of 20ns if a pulse width shorter than 20ns is programmed. If no pulse width is programmed for a particular marker, a default pulse width of 100ns is used.

Doing a read of the marker pulse width will always return the programmed value. In other words, the returned value will not be modified based on the operations performed to actually generate a marker, such as rounding up to the minimum pulse width or limiting the pulse width to the EPR-dependent maximum value.

Likewise, no error messages will be generated if marker pulse widths are programmed above or below the limits that are used to actually generate a marker. The appropriate rounding up or rounding down will occur, and no error message will be generated.

For more information on triggers and markers, see Trigger and Marker Overview.


Trigger Set Polarity

For a marker output, Polarity controls whether the marker will go high (positive) or low (negative). For a trigger input, Polarity controls whether a trigger will be detected on the rising (positive) edge or on the falling (negative) edge of the input.

Keysight MDsr.lvlib:Trigger Set Polarity.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Trigger

Name of the Trigger. See ‘Trigger Get Name’ in Action/Status section of menu to obtain the valid names.

ci32

Polarity (Positive)

Used to set the polarity of a Marker or expected by a Trigger.

Positive polarity: rising edge for edge triggering, above threshold for level triggering.

Negative polarity: falling edge for edge triggering, below threshold for level triggering.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

After a marker output goes high or low as specified by Polarity, it will return to its quiescent state after a period of time specified by the MarkerPulseWidth. If Polarity is positive, the marker will begin as a logic low then go high for the specified MarkerPulseWidth followed by returning low. If Polarity is negative, the marker will begin as a logic high then go low for the specified MarkerPulseWidth followed by returning high.

Polarity affects which edge of a trigger input will cause the DSR to respond. If Polarity is positive, the DSR will trigger on the rising edge of the trigger input signal. If Polarity is negative, the DSR will trigger on the falling edge of the trigger input signal.

While triggers are often thought of as pulses, the DSR only looks for the specified edge, either rising or falling as specified by Polarity. After triggering has occurred on the specified edge, when the next edge occurs is inconsequential other than the next edge needs to occur at some point in order to make it possible for another trigger to be received on the specified edge. The time between any trigger edges must be greater than 20 ns.

Polarity can be programmed independently for each of the 13 DSR signals that can be used as markers and triggers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, PXIe_DSTARB (trigger input only), and PXIe_DSTARC (marker output only).

If a signal can be both a marker output and a trigger input (such as GPIO1), there is only one Polarity value associated with the signal. In other words, the signal does not have one Polarity value that is used when the signal is programmed as a marker output and a different Polarity value that is used when the signal is programmed as a trigger input.

For more information on triggers and markers, see Trigger and Marker Overview.


WaveformTable VIs

WaveformTable Define Waveform Character

WaveformTable Get Signals

WaveformTable Query Waveform Character

WaveformTable Query Waveform Characters

WaveformTables Add Simple Waveform Table

WaveformTable Set Period

WaveformTables Get Name

WaveformTables Remove

WaveformTables Add


WaveformTable Define Waveform Character

Defines a new waveform character. This character defines the waveform to be produced when this character is executed on one of the specified signals. This function is called once for each waveform character in the WaveformTable.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformTable

Name of the Waveform Table. See the ‘ WaveformTables Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

WaveformCharacter

The waveform character being defined. A one-character string.

SignalExpression

Signals for which this waveform character is defined.

Times

Array containing up to three times that correspond to the events specified in the Events parameter. There must be an event defined in the Events array for each time specified.

Numeric

Events

Events associated with each time. Maximum of 2 force events and 1 compare event may be specified. There must be a time defined in the Times array for each event specified.

Events are :

0 - Force Down

1 - Force Up

2 - Force Off

3 - Force Prior

4 - Compare Unknown

5 - Compare High

6 - Compare Low

7 - Compare Off.

Numeric

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the WaveformTables interface, see the WaveformTables Overview.

Additional information about waveform characters can be found in the DSR User Guide as follows:

  • The diagram "Generation of Results for PatternSites, CaptureSites, and StaticSites" in the chapter "Using the Four DSR Site Types".
  • The section "WaveformCharacter" in the chapter "Using the Four DSR Site Types".

In addition to specifying waveform characters programmatically, waveform characters can also be specified in pattern files. For supplemental information about waveform characters, see:

  • STIL File Format in this Programming Guide. In the DSR User Guide, see the section "Creating Waveforms and Waveform Tables" in the chapter "Using STIL Files".
  • OpenXML Pattern File Format in this Programming Guide. In the DSR User Guide, see the table of Action characters for OpenXML (spreadsheet) data files in the chapter "Using OpenXML (Spreadsheet) Data Files".
  • Bulk Data File Format in this Programming Guide. In the DSR User Guide, see the section "Notes and examples" in the chapter "Using Bulk Data Files".


WaveformTable Get Signals

Comma-separated list of Signals defined for this Waveform Table.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformTable

Name of the Waveform Table. See the ‘ WaveformTables Get Name ’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Signals

Comma-separated list of Signals defined for this Waveform Table


WaveformTable Query Waveform Character

Returns an array of times and an array of events given the specified signal and waveform character.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformTable

Name of the Waveform Table. See the ‘ WaveformTables Get Name ’ in Advanced Action/Status section of menu to obtain the valid names.

Waveformcharacter

Waveform character to be queried.

EventsBufferSize

Number of elements in Events

Signal

Signal to be queried.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Times

Array of times defined in the waveform. The first index is the first time, and corresponds to the first event in Events string.

Numeric

TimesActualSize

Comma-separated list of Signals defined for this Waveform Table

Events

Array of events defined in the waveform. The first event corresponds to the first time in the Times array.

Events are :

0 - Force Down

1 - Force Up

2 - Force Off

3 - Force Prior

4 - Compare Unknown

5 - Compare High

6 - Compare Low

7 - Compare Off.

Numeric

EventsActualSize

Actual number of elements in Events.

Remarks

This query returns the waveform that is executed for the specified waveform character on the specified signal. The waveform is a sequence of up to three events where up to two are force events and zero or one is a compare event.

For more information on the WaveformTables interface, see the WaveformTables Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


WaveformTable Query Waveform Characters

Returns all the Waveform Characters defined for the specified Signal.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformTable

Name of the Waveform Table. See the ‘ WaveformTables Get Name ’ in Advanced Action/Status section of menu to obtain the valid names.

Signal

Signal name.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

String of waveform characters.

Remarks

For more information on the WaveformTables interface, see the WaveformTables Overview.


WaveformTable Set Period

The period of the waveforms in this WaveformTable, in seconds. The period can be set from 4 ns (corresponding to the maximum data rate of 250 MHz) to 200 seconds (corresponding to the minimum date rate of .005 Hz).

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

WaveformTable

Name of the Waveform Table. See the ‘ WaveformTables Get Name ’ in Advanced Action/Status section of menu to obtain the valid names.

Period

R/W Property that specifies the period of the waveforms in this WaveformTable.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Once a site has been activated, its Period cannot be changed. Changing the Period property will affect the Period used by subsequently-activated sites.

For more information on the WaveformTables interface, see the WaveformTables Overview .


WaveformTables Add

Adds a WaveformTable block of specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of Waveform Table to add..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the WaveformTables interface, see the WaveformTables Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


WaveformTables Add Simple Waveform Table

Creates a basic waveform table that defines commonly-defined waveform characters at a given drive time and compare time.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Name of the Waveform Table to add.

Period

The period of the WaveformTable block.

ForceTime

The time that all drive events will be applied.

Compare

The time that all compare events will be applied.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The generated WaveformTable will define the waveform characters for all of the defined Signals as follows:

0 | ForceDown at DriveTime
1 | ForceUp at DriveTime
Z | ForceOff at DriveTime
P | ForcePrior at DriveTime
H | CompareHigh at CompareTime
L | CompareLow at CompareTime
T | CompareOff at CompareTime
X | CompareUnknown at CompareTime

For more information on the WaveformTables interface, see the WaveformTables Overview.

For more information on dynamic repeated capabilities, see Dynamic Repeated Capabilities s.


WaveformTables Get Name

Returns the waveformtable name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the WAVEFORMTABLES_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the WaveformTables interface, see the WaveformTables Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


WaveformTables Remove

Removes the WaveformTable block of specified name.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Waveform Table

Name of Waveform Table to remove. See the ‘ WaveformTables Get Name’ in Advanced Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

For more information on the WaveformTables interface, see the WaveformTables Overview.

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


Programming Examples

  • Basic Example
  • Simple Example
  • Complex Example
  • PPMU Example
  • RFFE Example
  • SPI Example
  • StaticSite Example

  • Example List of RepCap


Basic Example

Creates a driver object, reads a few Identity interface properties, and checks the instrument error queue.


Simple Example

This example is provided as an instructive set of LabVIEW functions for the M9195A/B for digital pattern download and execution. Two methods are shown:

  • using a STIL file to describe the digital patterns, timing and levels. The STIL file is named M9195AExample.stil.
  • using the LabVIEW VI to do the same.


Complex Example

This example is provided to demonstrate basic programming and key features of the Keysight model M9195A/B Digitial Stimulus/Response (DSR) PXIe module. Two methods for digital pattern creation and execution are demonstrated:

(1) A text based STIL file to describe digital patterns, timing and levels.

(2) LabVIEW driver programming to do similar setups and execution.

Text based STIL file import and LabVIEW modification method for setup and execution:

A STIL file is a text file that contains essential attributes necessary when defining digital patterns including physical channel mapping, timing, voltage levels, and patterns.

This example uses M9195AExampleComplex.STIL located in this project file, which can be opened and edited with a standard text editor such as Microsoft Notepad. This STIL file may be loaded directly with the M9195A/B soft front panel and basic patterns may be executed.

This STIL file may also be loaded and executed programatically as demonstrated with this project. Once the STIL file is imported using this program, LabVIEW VIs may be used to modify pattern and timing information for quick operation. The first section of this program will demonstrate those programming methods.

The second portion of this program will demonstrate those programming methods.

Section 1 Use STIL file to define pattern, levels and timing, then modify with IVI driver

1.1 Demonstrate STIL defined pattern using regular voltage levels

1.2 Advanced DSR feature: Re-evaluateVariables to modify timing

1.3 Advanced DSR feature: Re-evaluateDcLevels to modify Voltage source Levels

1.4 Advanced DSR feature: Channel stimulus delay to allow timing margin testing (shmoo)

1.5 Advanced DSR feature: Multi-site support

1.6 Advanced DSR feature: "Set-Signal" feature to support

1.7 Advanced DSR feature: Software Trigger

Section 2 Use IVI driver to define pattern, levels and timing

2.1 Create two sites: Bank1 and PpmuSite

2.2 Create and define two DC level blocks

2.3 Create and define two Waveform tables

2.4 Create PatternBurst and a micro block

2.5 Create two PatternExecs which:

2.6 Add Macro's blocks and populate with patterns

2.7 Add Patterns and populate with vectors

2.8 Archive into STIL file

2.9 Activate and Run Pattern

Setion 3 PPMU measurements

3.1 PPMU measurements, FVMI Ch12 - Ch15

3.2 PPMU measurements, enable remote sense and FVMI Ch15.


PPMU Example

This example is provided as an instructive set of LabVIEW VIs for M9195A/B for PPMU site development and execution. Two methods are shown: using a STIL file to describe IVI components and a second method using the IVI driver to do the same. STIL file is named M9195APPMUExample.stil

Initialize the Keysight MDsr driver and create two Ppmu sites, one for Inputs, one for Outputs. Test assumes following external connections channel to channel:

Inputs Outputs

Ch 8-----Ch 12

Ch 9-----Ch 13

Ch 10-----Ch 14

Ch 11-----Ch 15

Force voltage to the Output channels:

1. Force Current Measure Voltage at the Input channels.

2. Then Force Current Measure Current at the Input channels.

3. Then Force Nothing Measure Voltage at the Input channels.

Next, Force current to the Output channels:

4. Force Voltage Measure Current at the Input channels.

5. Then Force Voltage Measure Voltage at the Input channels.

Refer to LabVIEW help documentation for VI/attribute details


RFFE Example

This example is provided to demonstrate one method of programming RFFE commands representative of programming flows used in test environments. This example uses a STIL file template for simple, and easy to understand setups. The STIL file is located in the project file and is named RFFE_SetSignalTemplate.STIL. Two other "vec" files are also located in the project directory. Two methods of programming are shown: One uses M9195A/B unique set signal methods to quickly update and execute a RFFE command based on pre-compiled / downloaded "template" pattern, and a second shows bulk data import and setup. Bulk data import is useful for very large pattern file downloading and execution (such as a pre-defined Register I/O tests consisting of hundred of RFFE commands).


SPI Example

This example is provided to demonstrate one method of programming SPI commands representative of programming flows used in test environments. This example uses a STIL file template for simple and easy to understand setups. The STIL file is located in the project file .and is named SPI_SetSignalTemplate.STIL. Two other bulk data .csv files are also located in the project directory. Two methods of programming are shown: using a M9195A-unique set signal method to quickly update and execute a SPI command based on pre-compiled / downloaded "template"pattern, and a second method that shows bulk data import and setup. Bulk data import is useful for very large patterns and/or patterns pre-generated using 3rd party tools.


StaticSite Example

This example is provided as an instructive set of IVI commands for M9195A/B for static site development and execution. Two methods are shown: using a STIL file to describe IVI components and a second method using the IVI driver to do the same. STIL file is named M9195AStaticSiteExample.stil.

Initialize the KtMDsr driver and create two StaticSites, one for Inputs, one for Outputs. Test assumes following external connections channel to channel:

Inputs Outputs

Ch 8-----Ch 12

Ch 9-----Ch 13

Ch 10-----Ch 14

Ch 11-----Ch 15

1. Write out an integer to the Input StaticSite channels and read result from Output channels

2. Write out an integer and enable channels mask to the Input StaticSite channels and read result from Output channels.


Keysight MDsr - Example List of RepCap.vi

Example List of RepCap

This example provides the list of supported repeated capabilities and repeated capability names for the KtMDsr driver. All DSR repeated capabilities are dynamic, and do not have physical names since they are dynamic. It just represents a way to the user how to define these repcap parameters & how to use them.

Keysight MDsr - Example List of RepCap.vi


Additional M9195A/B Information

This section provides information specific to the M9195A/B DSR modules. Specifically, it provides information and descriptions of the STIL language, SITES, Patterns, Edge Placement, and more.

  • Acquiring Results and Data Collection
  • Active Sites
  • Bulk Data File Format
  • Capture Sites Overview
  • Channels Overview
  • DcLevels Overview
  • Edge Placement Resolution
  • MacroDef (Macro) Overview
  • Multi-module Operation
  • Not a Number (NaN)
  • Numeric Expressions
  • OpenXML Pattern File Format
  • PatternBurst Overview
  • PatternExec Overview
  • PatternFile Overview
  • Patterns Overview
  • PatternSites Overview
  • PpmuSites Overview
  • Signal Direction
  • Signal Expressions
  • SignalGroups Overview
  • Signals Overview
  • Sites Overview
  • StaticSites Overview
  • STIL Components
  • STIL File Format
  • Trigger and Marker Overview
  • WaveformTables Overview


Acquiring Results and Data Collection

Several functions are available for reading results back from the DSR.

Time | Usage
FetchResultByte | This is used when the result data fits in a single byte. Note that the width of the result data is established by the highest ordinal defined in the site.
FetchResultInt16 | This is used when the result data fits in a 16-bit integer. Note that the width of the result data is established by the highest ordinal defined in the site.
FetchResultSegmentByte | This permits fetching a subset of the collected data, but should only be used when the result data fits in a single byte. Note that the width of the result data is established by the highest ordinal defined in the site.
FetchTrinaryResult | FetchTrinaryResult is used when the data result represents a test failure, and the reason for the failure needs to be determined. This function returns 2-bits per channel and indicates if a failure occurred and if the input was low, high, or between the low and high thresholds.
FetchLineInformation | FetchLineInformation provides additional data about each result value. One of the above methods is used to fetch the result, then this function may be used to determine where in the pattern that data was collected, the time, the cross reference, and the duration since the pattern started executing.


Active Sites

Active Sites are dynamic repeated capabilities and have the functions and attributes described in Dynamic Repeated Capabilities . Active Sites differ slightly in that when they are created, they also reserve various resources and initialize various hardware components.

An Active site is created by calling an Activate function and passing it a site, which is a STIL component ( see STIL Components). The site contains a list of hardware channels and optionally other resources such as trigger paths. When a site is activated, a dynamic repeated capability is created that is used to perform operations on that site. The name for the dynamic repeated capability is the site name. For instance, to make PPMU measurements, a site is defined that contains the necessary channels, then that site is activated for PPMU measurements. Once activated, conventional repeated capabilities functions and attributes can be used to perform PPMU measurements on those sites.

The KtMDsr driver supports the following kinds of active sites:

Active Sites Usage
PPMU

A site is activated for PPMU measurements in order to perform various analog measurement and analog stimulus operations. This includes selecting a forcing function such as voltage, current, or none, and selecting a simultaneous measurement function which is voltage, current, or none.

For more information, see PpmuSites Overview.
Pattern

A PatternSite has the functions and attributes necessary to control the execution of a test pattern. This includes operations that are used to run the pattern, monitor its execution, and modify the pattern in cache memory so it can be modified between runs.

To activate a pattern, both a site and a pattern specification are provided. The driver implementation must compile a pattern for a specific site, then download it to the module. Since this can be a relatively slow operation for large patterns, functions are provided in the pattern site for loading a pre-compiled pattern site, and for activating a pattern site that has been stored in cache memory on the module.

For more information, see PatternSites Overview.
Static

A StaticSite provides a way to programmatically set the logical values of the signals in a site. The site, by definition, maps the signals to physical channels. This gives the opportunity to programmatically write the values to each channel. There are two primary utilities of StaticSite:

  • Verifying the physical connections and software configuration of a pattern site. By using the static site methods to read and write the signals, it is possible to verify the connectivity without the overhead of creating a pattern. This permits verifying the mapping of signals to the module outputs and inputs, including the software layers and the physical wiring.
  • Utilizing extra bits on the module for programmed IO when there are leftover bits not being used for pattern IO or PPMU.

For more information, see StaticSites Overview.
Capture

Capture Sites provide a straightforward mechanism to capture data in the DSR. They are similar to a pattern site except that no pattern definition is required. Instead of a pattern definition, a capture site requires only the timing information for the site (in terms of a WaveformTable block), the DC Levels for the site (in terms of a DcLevel block), and the amount of time to operate the capture.

For more information, see Capture Sites Overview.

Transitioning Between Active Sites

When PPMU, pattern, capture, or static operations are completed on a site, the channels can be released for use on another site by using one of two VIs.

The InactivateAndDisable VI releases the channels and places each channel in a disabled state (similar to the IVI Disable functions). That is, the drive on all channels is shut off.

The Inactivate VI releases the channels, but does not change their state. This is useful if a signal needs to be retained between different operations. For instance, an application may execute a digital pattern to configure a DUT, then transition to making PPMU measurements without causing unwanted signal transitions on the DUT inputs.

Once a site has been inactivated, yet retaining the signal states, individual channels from the site may be used in other sites. Channels that are not used in other sites will continue to retain the settings they had when Inactivate was called. Note that the signal lines will not be driven until the new active site defines a signal level. For PatternSites and Capture Sites, this occurs with Initiate. For Static sites, this occurs with one of the write VIs. For the PPMU, this occurs when one of the force VIs is applied.

The EndBehavior for pattern site and capture site are respected after the Inactivate VI is applied. Thus, clocks can be continuously generated while other channels are used for PPMU measurements or pattern or static operations.

When a channel transitions from being driven from a previous setting (because it was Inactivated and not disabled) to a new setting, the transition may pass through some intermediate values. The transition behaves as follows:

  • If the level being driven from the previous operation is the same as the target level, the transition will not disturb the signal. Therefore if transitioning between sites that use DC Levels to define the signal levels, and if using the same DC Levels block, the transitions will not disturb the signals.
  • If different DC Levels are specified between the sites, the new DC Levels settings are applied before new digital data is applied. If the old digital level is different from the new digital level, this can result in an intermediate level appearing.
  • If the transition is from the PPMU to a site controlled with DC Levels, the DC Levels settings are applied before new digital data is applied -- but before the PPMU is disabled. This momentarily activates both drive signals, resulting in a step occurring during the transition from one level to the next.
  • If the transition is from a site controlled with DC Levels to the PPMU, the PPMU is turned on before the DC Levels are withdrawn. This can result in a step occurring during the transition from one level to the next.

Common Operations on Active Sites

An active site is programmed very similarly to a conventional Dynamic Repeated Capabilities . The differences are:

  • The active site is created with an Activate VI (or one of the special activate VIs for the pattern sites). The activate site name is then the name of the site itself; a new name is not created.
  • When the application is done with the active site and the channels are to be used for other operations, the site is Inactivated rather than Removed. When a site is Inactivated, the site definition will still exist by the same name; however, the active site will no longer exist.
  • In addition to Inactivate, active sites have a function called InactivateAndDisable. It performs an inactivate operation and also disables the signals in the site. That is, the drive is turned off and each channel is put into a high impedance state.

Changes made to the site or other STIL components that define the site at the time of activation do not affect an activated site. The settings are all consulted when the site is activated; however, once the site is activated, subsequent changes make no difference.


Bulk Data File Format

The BulkData format provides a way to load basic pattern data into the DSR. When the data is loaded, a pattern STIL Components is created. The rest of the pattern definition must be provided using STIL, OpenXML, or the API.

Bulk data file syntax

The bulk data file is read using the following rules:

  • Comments are designated with a hash (#) or double slash (//). Comments extend to the end of line. Blank lines are also treated as comments.
  • The first non-comment line of the file may be a header that indicates the syntax of the file. It is recognized by square brackets. If the header begins with the word "Index", a numeric Index is expected on each data line. If the header has the word "WaveformTable", then a WaveformTable is parsed on each line. Finally, the header has a list of signals, indicating the order and signal name to associate with each position in the data lines.
  • If no header line is present, the file is assumed to only contain bulk data with an unchanging waveform table and signals as provided via the API.
  • Data lines are parsed based on the header line. Individual waveform characters may be separated by comma or space or may be grouped together.
  • A hyphen (-) can be from the previous vectors, and used in place of a waveform character. This indicates that the waveform character on that signal should be repeated. In STIL this is indicated by leaving the waveform character unspecified, but it must be explicit in bulk data.

Header line

The header line establishes the format that will be used to read the bulk data file.

The header line can be the first non-comment line in the file, or it can be provided via the API. By providing the header line in the API, an arbitrary file containing only the target data may be loaded.

The header line has the following format:

[["Index"] ["WaveformTable"] (<SignalList>)+ ]

Note that the entire header line is enclosed in square brackets [ ].

If the word Index is present, then an an optional Pattern Index is parsed from the input. If it is not present, then the parser will automatically assign an index starting with 0.

If the word WaveformTable is present, then an optional WaveformTable name is parsed from the input. If it is not present, the parser will use the waveform table specified in the LoadBulkData function call for each vector in the pattern.

The signal list is a space or comma (,) separated list of signals. This provides the list of signals associated with the columns of data.

Note that although signal names are separated by white space and comma in the header line, no separator is required between signals in the pattern area.

Notes

Generally, values provided by the API override any values appear in the file. For instance, if the signal list is provided in the API, any signals appears on the header line are ignored.

The following are typical examples:

# this file includes a header showing indexes

# and waveform table

[Index WaveformTable Signal1 Signal2 Signal3 Clock]

0 One 011T

1 011T #The waveform table defaults to previous line

2 100T

3 1 0 1 T #separators are ignored between characters

The following example shows a more terse description. When using this syntax, the waveform table must be specified in the function invocation and the indexes are automatically generated counting from 0.

# this datafile only defines file includes a header

# showing indexes and waveform table

[Signal1 Signal2 Signal3 Clock]

0 1 1 T

0 1 1 T

0 0 0 T

0 0 1 T

The final example is the most dense, but has exactly the same meaning as the previous one, except the signal list must be provided via the API (and the comment has been left out).

011T

011-

100-

101-

See STIL Components for more information on how to use the STIL Components.


Capture Sites Overview

A Capture Site provides a convenient mechanism to capture data on the DSR without defining a pattern. A Capture Site is designed to capture data, but is also capable of simultaneously generating clocks and/or DC signals.

The capture operation is defined by a Site, a DC Levels block, a Waveform Table block and the RequestedResultCount. The capture is applied to a site in the same fashion as other DSR operations. The capture site automatically creates a pattern to perform the capture by:

  • Repeating the waveforms defined in the waveform table...
  • ...at the specified DC Level...
  • ...on the specified site...
  • ...the number of times indicated in the RequestedResultCount.
Setting | Purpose
Site | Specifies the signals that will be generated and the physical channels to which they are applied.
WaveformTable

Specifies how the data is collected. Each signal defined in the site specification must have one and only one waveform character defined. This waveform character is repeated the number of times specified in the RequestedResultCount to capture the data.

The waveform character is defined and interpreted the same as it is for pattern sites. To produce a clock, a waveform including two force operations is used. It is possible to include a waveform with a single force operation, in which case the specified DC level will be output during pattern capture.
DC Levels | The specified DC Levels block is applied to the signals in this site.
RequestResultCount | Specifies the number of times the waveforms defined in the waveform table are repeated. This is the number of result bits that will be acquired, presuming at least one of the waveforms defines a compare operation.

Additional controls, such as the edge placement resolution, Initiate and other run control and status behave identically to PatternSite.

For more information on active sites, see Active Sites.

Other useful information for Capture Sites may be found in Edge Placement Resolution and Acquiring Results and Data Collection.


Channels Overview

The Channels interface provides channel specific control of settings that are set up independently of the specific pattern being executed. That is, the setup of the channels that is beyond the scope of the pattern definition.

The following are controlled from the Channels interface.

  • Channel Clamp Voltage Ppmu Enable
  • Channel Clamp Voltages Channel Response Delay Compensation
  • Channel Line Compensation
  • Channel Stimulus Delay
  • Channel Remote Sense Enable

All of the settings in the Channels interface are controlled by passing an array of channel numbers that indicates the channels on which the setting is adjusted. Channels that are not in the list are not impacted by the function.

Query calls are provided for each setting. The queries read back the setting for an individual channel.


DcLevels Overview

DcLevels is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

For more information, see STIL Components.

The DcLevels functions and attributes provide a way to set the various DcLevels associated with the generation and receipt of digital signals. This includes:

  • The thresholds that define the logic sense of the DUT outputs
  • The levels that are produced by the DSR, including the levels that are produced by the high voltage output pins, 20-23
  • The load characteristics

All input and output definitions are from the perspective of the DUT. For instance, the low output voltage level is the threshold that the DSR uses to detect a logical zero, thus the output of the DUT which is the input to the DSR must be below that level to produce a logical zero.

The DUT outputs are monitored by specifying the DUT output low voltage threshold (Vol) and the DUT output high voltage threshold (Voh). In addition, an optional hysteresis voltage (Vhyst) can be specified. When Vhyst is specified, it is applied to both the Vol and Voh thresholds. For the DUT input signals, the logic low voltage is set by Vil, while the logic high voltage is set by Vih.

DcLevels can be set independently for each signal in the pattern. Therefore the definition of the DcLevels is applied to a signal expression that can refer to a single signal or several signals. For details on signal expression handling, see Signal Expressions.

DUT output levels are defined with a low voltage threshold, a high voltage threshold, and a hysteresis that is applied to both the DUT output low and high thresholds.

The DSR module supports three types of input termination as follows:

  • High input impedance. This is the default mode and does not require any explicit configuration
  • 50 Ohm input impedance to a specified termination voltage. This mode is enabled by specifying the DC voltage to which the 50 Ohm input is connected.
  • Active load. The active load forces one of two specified currents. The current forced is based on whether the sensed input voltage is above or below a specified commutation voltage. The active load is specified as a commutation voltage, a current that is forced for signals below that voltage and a current that is forced for signals above that voltage.

The type of input termination is automatically determined based on the configuration information provided. For instance, if the input termination voltage is provided, the 50 Ohm input impedance is selected.

For the active load, the commutation voltage and the two current levels must be specified. For the 50 Ohm input impedance, the termination voltage is the one and only voltage specified. If none of these values are specified, the input goes to a high impedance.

Note that values associated with only one load type can be specified. To use the active load, all three values (Vcom, Iol, and Ioh) must be specified. Values for termination types not being used must be set to Not a Number (NaN). For instance, an application that uses the high input impedance termination must set Vcom, Iol, Ioh, and Vit to NaN.

Vhh can only be specified for the high voltage channels (20-23). When programming the high speed channels (0-15), set Vhh to NaN (not a number).

The default value for the DcLevels is NaN (not a number), therefore when programming the levels individually, there is no need to program them to NaN explicitly. However, when using SetDcLevels, the parameters for the unused values must be set to NaN.

The following table summarizes the various DC Levels and their limits:

DcLevel | Represents | Min | Max
Vol | DUT output Low threshold. This is the minimum voltage that will be treated as High as measured at the DUT output | -1.5 Volts | 6.5 Volts
Voh | DUT output High threshold. This is the maximum voltage that will be treated as Low as measured at the DUT output | -1.5 Volts | 6.5 Volts
Vhyst Hysteresis applied to the DUT output low and high thresholds, Vol and Voh. This is the peak-to-peak hysterisis voltage. Inputs are coerced to 0, 50 mV or 100 mV. 0, 50 mV,
or 100 mV 		--
Vil | DUT low voltage input for high voltage channels 20-23. The voltage produced by the DSR for a 0. | -1.5 Volts | 6.4 Volts
Vil (for Vhh) | DUT low voltage input for high voltage channels 20-23. The voltage produced by the DSR for a 0. | -0.1 Volts | 6.4 Volts
Vih | DUT high voltage input for high voltage channels 20-23. The voltage produced by the DSR for a 1. | -1.4 Volts | 6.5 Volts
Vih (for Vhh) | DUT high voltage input for high voltage channels 20-23. The voltage produced by the DSR for a 1. | 0 Volts | 6.5 Volts
Vit | Module sourced termination voltage for 50 Ohm input termination. Setting this to a value other than NaN turns on the 50 Ohm load. | -1.5 Volts | 6.5 Volts
Vcom | Active load commutation voltage; the voltage at which the load switches from sinking current to sourcing current. It is used with IOH and IOL to configure the active load. | -1.5 Volts | 6.5 Volts
Ioh

This is the current sunk by the active load when the input voltage is over the commutation voltage (VCOM). It is used with IOL and VCOM to configure the active load.

A positive setting produces a current flow into the DSR, testing the ability of the DUT to maintain a high voltage while sourcing current.

0 mAmps 25 mAmps
Iol

This is the current sourced by the active load when the input voltage is under the commutation voltage (VCOM). It is used with IOH and VCOM to configure the active load.

A positive setting produces a current flow out of the DSR, testing the ability of the DUT to maintain a low voltage while sinking current.

0 mAmps 25 mAmps
Vhh | Voltage forced by the DSR on the high voltage pin when high voltage is active. | 0 Volts | 13.5 Volts

For more information on setting values to NaN, see Not a Number (NaN).

For more information on repeated capabilities, see Dynamic Repeated Capabilities ..

For more information on the KtMDsr STIL Components, see STIL Components.


Edge Placement Resolution

The edge placement resolution determines the frequency setting of internal clocks that establish the resolution and dynamic range for edge placement. This includes generating the period of the signal, the transition times specified within the period, the resolution itself, and the dynamic range of the StimulusDelay and ResponseDelayCompensation.

The edge placement resolution is specified when a pattern site is activated. The client can either specify the edge placement resolution to use for pattern generation, or the client can have the DSR to automatically choose an edge placement resolution suitable for the digital test (that is, the PatternExec). The DSR generally chooses the smallest resolution that is able to produce the pattern. In some circumstances the value the DSR automatically chooses may not be an optimal choice, in which case it may be preferable to specify the edge placement resolution.

To specify that the DSR should select the edge placement resolution, set EdgePlacementResolutionAuto=True. To specify a specific value, EdgePlacementResolutionAuto must be set false, and the EdgePlacementResolution must be set to a value between 1 ns and 100 ns. Note that the resolution is specified as time (ns or us), not frequency (Hertz).

If the edge placement resolution is set to Auto, the DSR will choose either 1ns, 10ns, or 100ns for the edge placement resolution. It prefers the smallest value that can produce the pattern, but near boundaries it may choose the next larger value in order to provide more flexibility in pattern generation.

The DSR provides a tool for assisting in the selection of specific edge placement resolutions. That is the Edge Placement Optimizer tool available from the utilities menu on the SFP.

The edge placement resolution establishes the resolution to which various timing values are produced by the DSR. However, in some cases, the actual resolution of the setting may vary depending on other configuration values.

How the edge placement resolution affects various settings

The DSR produces the following times, based upon the edge placement resolution.

Time Usage
Waveform Table Settings

The WaveformTables include both a Period, and the times for edges within the period. The edges all occur within the period, so the Period is the longest duration in the waveform table, and it establishes the resolution of the other settings.

When the Period is less than approximately 250 times the edge placement resolution, the period, and all of the edges within the waveform table are rounded to the nearest multiple of the edge placement resolution. That is, they are produced with a resolution of the edge placement resolution.

If the Period is greater than approximately 250 times the edge placement resolution, the resolution for this waveform table is decreased by an integral power of 2 until the Period can be produced. Other edges within this waveform table are produced to that same resolution.

Each waveform table within a test has its resolution independently calculated, so a single waveform table with large times and low resolutions will not impact other waveform tables.
Stimulus delay

The stimulus delay is produced independently for each channel. The stimulus delay is primarily used to adjust the output timing of the DSR so that all output signals are synchronized when they arrive at the DUT. This is used to compensate for skew between the channels such as differences in cable length or signal path to the DUT.

The stimulus delay in implemented using two components. First, there are multi-tap delay lines that provide up to 1.3ns of delay with 50ps of resolution. Second, there is a digital delay based on the edge placement resolution.

If the edge placement resolution is less than 1.3ns, arbitrary values can be produced. For larger values of edge placement resolution, gaps will exist where a combination of the digital delay and the delay lines can not produce the specified times.

Response delay compensation

The response delay compensation is used to compensate for the total transmission time from the DSR to the DUT and back. The response delay compensation is independent for each channel. It is used to align the responses from the DUT with the expected responses that are included in the complete digital test.

The response delay compensation is set to the total time for the DSR stimulus signals to propagate to the DUT, and then propagate back to the DSR. The stimulus delay is part of that total path and is included in the compensation time.

For instance, suppose a single channel has a 100ps stimulus delay, and all channels have a 10ns response delay compensation. The stimulus for that channel is delayed by 100ps so that events are aligned at the DUT. The total path for that channel will be 10.1ns but the other channels will have a 10ns delay.

The DSR is capable of measuring the response delay compensation for a cable. To do so, an unterminated cable is attached to the instrument and the Instrument Measure and Apply Response Delay Compensation VI is applied. The values measured for the total cable delay are stored in the ResponseDelayCompensation settings for each cable channel.

Example

Consider a digital test that has a Period of 5 ns, and waveform table times at 1.25 ns and 2.5 ns.

  • If this waveform were produced using an edge placement resolution of 1.25 ns, each value would be hit precisely and arbitrary stimulus delays and response delay compensations could be produced.
  • However, if this same digital test were activated with an edge placement resolution of 1ns, the period would round to 4 ns, the first edge would round to 1 ns, and the 2.5 ns edge would round to 3 ns.
  • Clearly, 1 ns is a smaller resolution; however, a better signal is produced by using the slightly coarser edge placement resolution of 1.25 ns.


MacroDef (Macro) Overview

MacroDefs is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

See STIL Components for more information.

MacroDefs is used to designate one or more patterns as macros. A pattern designated as a macro can be executed from another pattern by including a line that calls it in the invoking pattern.

Macros are invoked using the Macro line type from the API, or the appropriate language syntax from one of the pattern files.

The MacroDef block assigns a macro name to each pattern to be used as a macro. This macro name is the name that is used to invoke the macro.

The MacroDef block is specified in the PatternBurst block. All of the patterns in that PatternBurst block are then evaluated with the macro specifications from the named MacroDef.

The DefineMacro method controls how macro names are assigned to patterns.


Multi-module Operation

This release of the driver (version 2.0.x.x) supports multi-module operation on the M9195B. Up to 12 M9195B modules can be configured in a multi-module instrument, providing up to 192 high-speed I/O channels (12 modules x 16 channels/module).

Keysight supplies two multi-module connection cables, one that connects up to 4 modules together and one that connects up to 12 modules together.

The M9195A supports single-module operation only. The M9195B can also be used as a single-module instrument.

Multi-module primary and secondary module nomenclature

In a multi-module configuration, one module is designated as the primary module while the remaining (1 to 11) modules are designated as secondary modules. The primary module is the module that is listed first when making a connection using the SFP or is listed first in the Initialize() method.

The table below shows the multi-module numbering conventions for a 4 module multi-module instrument. Notice that the indices used for calculating channel numbers (second column) and for accessing IVI repeated capabilities (fourth column) differ by 1.

Primary/secondary module | Index used for calculating channel numbers also used by SFP | Module channel numbers | IVI index used for repeated capabilities | Modules.Name(IVI index) syntax | Modules.Name(IVI index) returned string
Primary module | 0 | 0-15 | 1 | Modules.Name(1) | "DSR"
Secondary module #1 | 1 | 100-115 | 2 | Modules.Name(2) | "DSR2"
Secondary module #2 | 2 | 200-215 | 3 | Modules.Name(3) | "DSR3"
Secondary module #3 | 3 | 300-315 | 4 | Modules.Name(4) | "DSR4"

The numbering for a 12-module multi-module instrument can be extrapolated from the 4-module configuration in the above table.

Requirements for multi-module operation

This section describes what items are required and what items are optional to implement a multi-module instrument. Note that optional refers to a hardware item whose use discretionary based on your multi-module system objectives while option refers to a hardware upgrade capability that is orderable from Keysight.

  • Required: M9195B modules (a quantity of 2-12). The M9195A cannot be used in a multi-module instrument.
  • Required: The M9195B-MMS (multi-module sync) hardware upgrade option is required on all modules in a multi-module instrument. This option can be purchased at the same time the M9195B module is purchased or can be purchased subsequently.
  • Optional: Use of the coax cable that is included with the M9195B-MMS option. The coax cable can optionally be used to connect together (daisy-chain) the front panel Sync connectors between modules. This is needed if you are using the MatchLoop instruction in your patterns. Daisy-chaining of the Sync connectors is described in the instructions that accompany the M9195B-MMS option.
  • Required: Multi-module Sync cable. This cable provides the synchornization signals to ensure that all modules operate synchronously. The main connector of this cable plugs into the Multi-module Sync connector on the primary module while the individual connectors plug into the same connector on each secondary module. Two versions of the Multi-module Sync cable are available. The Y1250A accessory kit supports up to 4 modules while the Y1251A accessory kit supports up to 12 modules.

Licensing effects on multi-module operation

All modules in a multi-module instrument must have the same level of licensing in order for the licensing to be effective. For example, the M9195B supports the M9195B-SR1 option for a 125 MHz clock rate and the M9195B-SR2 option for a 250 MHz clock rate. If the desired clock rate for a multi-module configuration is 250 MHz, then all modules must have the M9195B-SR2 option.

If, for a particular capability, not all modules have the same option installed, the multi-module configuration will operate at the level of the lowest option. For example, if three modules have the M9195B-M12 option installed while one module has the M9195B-M06 option installed, the multi-module configuration will operate as if all modules have the M9195B-M06 option installed.


Not a Number (NaN)

Not a Number (NaN) is a special code that indicates a value is "Not a Number". NaN is defined by the IEEE 754 floating-point standard, and is typically used to refer to values that are unused or undefined. NaN also helps one to avoid expressions that might otherwise be divided by zero.

Examples of use:

  • Values for termination types not being used must be set to NaN (Not a Number). For instance, for an application that uses the high input impedance termination, Vcom, Iol, Ioh, and Vit must be set to NaN.

  • Since Vhh can be specified only for high voltage channels, Vhh must be set to NaN when programming high-speed channels.

  • When using SetDcLevels, the parameters for the unused values must be set to NaN. When programming the levels individually, there is no need to explicitly program them to NaN, as the default value for the DcLevels is NaN.


Numeric Expressions

The KtMDsr driver provides conventional numeric expression evaluation. There are several benefits:

  • There is utility in having units conversions built into the pattern file formats. For example, using the unit designators, a time of 22 nanoseconds can be specified as "22ns" instead of 22e-9 seconds.
  • The expressions can be used to evaluate times in the waveform table definition in terms of previous edges. For instance, the special character, "@" (commercial at) can be used to indicate the previously specified time. Using this, if an edge in a pattern specification were set to "@+5ns", the edge would be established relative to the previous edge.
  • Most importantly, the expression can be reevaluated after the pattern has been compiled. This provides a way to change a family of related values based on a variable setting without the overhead of recompiling a pattern.

Evaluating expressions

The KtMDsr expressions, in general, are strings that are evaluated to produce a number. The strings are reasonably conventional expressions that provide the usual meanings of the following.

Number Parsing | Interpretation
+ - * / | Numeric operations with conventional precedence
^ | Exponentiation
( ) | Conventional meaning of parenthesis
; | Semicolon separates multiple operations; the result of evaluating a string is the value obtained from the final semicolon separated string.
<identifier>=<expression> | An equal operation assigns the expression to a variable, and implicitly creates the variable.
<identifier> | When used in an expression, then an identifier is treated as a variable and replaced with the value most recently assigned to it.
@<digit> | The commercial at (@) followed by a digit indicates one of the ten expression evaluations on a logical line. Thus @1 is the value of the first expression evaluated on a logical line. This is convenient when defining waveform tables, so that the latter times in a waveform table can be defined based on the earlier values.
@ | The commercial at (@) without a digit indicates the most recently evaluated expression. The utility is similar to @<digit>.

The following examples illustrate valid expressions. All of the following yield 11:

"11"

"10+1"

"Variable=11"

"Variable=10; Variable+1"

"E=1;1+1E+1++1-E"

"1 +1E+1++1-E" // notice that the variable E has retained its definition.

"1+ 1E+1++1-E" // notice the first occurense of E is scientific notation exponent and the second is the variable

"1+1E+1 ++1-E" // notice the the binary operator + is followed by a unary + in this example

"1+1E+1+ +1-E"

"1+1E+1++1 -E"

"E=1;1+1E+1 ++1 - E" // notice multiple semicolon separated statements are permitted.

The following illustrate the use of variables in expressions:

"Pi=22/7 ; Radius=11.3; Area = Pi * Radius^(2)"

"e=1+1+1/2+1/(3*2)+1/(4*3*2)+1/(5*4*3*2)+1/(6*5*4*3*2)+1/(7*6*5*4*3*2)"

Reevaluating expressions after compiling a patern

As noted, the primary utility of the expressions is that both DC Levels and times within a waveform table may be reevaluated without recompiling a pattern. For details, see the functions: PatternSite > ReevaluateVariables and PatternSite > ReevaluateDcLevels.

Units

The DSR handles all the conventional engineering prefixes (a, f, p, n, u, m, k, M, G, T, P, E).

The DSR accepts physical units for inputs to help make the input more readable; however, it does not actually utilize the units in interpreting the numbers. The physical units accepted are seconds, Volts, and Amps.

Value Entered | Interpreted as
4ns | 4e-9 seconds
.000001kV | 13-3 Volts
33us | 33e-6 seconds
1uA | 1e-6 Amps


OpenXML Pattern File Format

The OpenXML format is a DSR-specific file format that uses STIL constructs inside a standard spreadsheet file (.xlsx).

For examples and detailed information about the OpenXML format, see the files MDsrAdvancedAnnotatedExample.xlsx and MDsrBasicAnnotatedExample.xlsx in the Help/User Guide Examples directory of the DSR installation.

General rules and patterns

The following rules are used to convert an OpenXML file into STIL Components:

  • The KtMDsr OpenXML syntax uses the sheets in the file to define STIL blocks (aka STIL Components). The kind of the sheet is taken from the sheet name or cell A1 (see below). The following are the types of sheets:
Signals | The Signals sheet defines the STIL signals and the STIL SignalGroups. The name of this sheet is always Signals since Signals are global and can never have a block name.
DcLevels | The DcLevels sheet defines a STIL DC Levels block.
WaveformTable | The WaveformTable sheet defines a STIL WaveformTable block.
Pattern | The Pattern sheet defines a STIL Pattern block.
Site | The Site sheet defines a STIL Site block.
  • The OpenXML reader looks at the name of the sheet (as it appears in the tab for the sheet) to determine the type and name of the sheet.
    To specify the type using the sheet name, the sheet name must start out with one of the defined type names. The name of the sheet may be optionally specified by concatenating that on the end of the name with an optional hyphen (-) separator. For instance, "Pattern-Beta" would indicate this is a pattern sheet and it is called Beta.
    It is also possible to specify the type and name in cell A1. To do this, the contents of the cell must be a string containing a colon. The substring to the left of the colon is the type of the sheet. The substring to the right of the colon indicates the name. For example, Pattern:Beta indicates a Pattern sheet where the name of the Pattern is Beta.
  • The pattern reader will ignore comments. These are lines that:
    • begin with the exclamation point (!) character
    • begin with a double slash (//)
    • Blank lines
  • The pattern reader looks for a rectangular table. The width of the table is defined by the first non-comment line. This first non-comment line contains headers that define the columns of the table. Comments may not appear on the header line.
    The table extends till the end of the sheet or a blank line. non-blank line comment lines are permitted in the table.
    No cells should be filled in to the right of the header, However once the header has established the width of the table, subsequent lines in the table can have comments on the right.
  • In cells where a numeric is required, either a spreadsheet number may be entered or a string. If a string is entered, the numeric expression evaluator is used to convert the string to a number. This permits using engineering units and prefixes, for instance, a time can be entered as the string "10ns".
    In addition, the numeric variables implemented by the KtMDsr may be used. This permits deferring the evaluating of the strings until the pattern is activated at which time the expressions may be evaluated with new variables using the ReevaluateExpressions function.

In general, formatting is ignored. It is generally useful to use cell shading to improve the readability of a pattern, however it is ignored by the DSR.

Signals sheet

The Signals sheet is used to define the STIL Signal components and the STIL Signal Groups components.

The Signals table requires two columns: Signal and Direction.

Signal Name of the signal or the signal group to define. The name follows STIL syntax and is basically an alpha-numeric beginning with an alphabetic character. This column may include a range or signal reference expression. For example, Data[0..15] defines 16 signals: Data[0], Data[1],..., Data[15]. .
Direction

If this column contains a signal direction (In|Out|InOut), then the Signal is defined with this direction. The direction is always DUT-centric. For example, "Out" means an output from the DUT, which is an input to the DSR.

If this column contains a valid signal reference expression, then the row defines a signal group. The group name is the signal name and the group is the signal reference expression appearing in the Direction column. For example, the Direction column could contain: ("Signal1+Signal2").

DcLevels sheet

The DcLevels sheet is used to define a STIL DcLevels block. Since there may be multiple DcLevels sheets, each DcLevels sheet must have a unique name.

The DcLevels sheet has the following columns:

Signal | Signal Expressions
Voh | The output high voltage from the DUT. This is the minimum voltage that will be treated as High as measured at the DUT output
Vol | The output low voltage from the DUT. This is the maximum voltage that will be treated as Low as measured at the DUT output
VHyst | This is the hysteresis used when measuring DUT outputs. The input value is rounded to either 0, 50 mV, or 100 mV.
Vih | This is the input to the DUT. This is the voltage that will be presented at the DUT input for a High.
Vil | This is the input to the DUT. This is the voltage that will be presented at the DUT input for a Low
Iol | This is the output current used by the active load when the input voltage is low. This current is output by the active load to ensure the DUT can sustain a low voltage while sinking the current. To turn on the active load, set values other than NaN for Ioh, Iol, and Vcom. When active load is on, and the DUT voltage output exceeds Vcom, Ioh is sunk by the DSR. If the DUT voltage is less than Vcom, Iol is sourced by the DSR.
Ioh | This is the output current used by the active load when the input is high. This current is sinked by the active load to ensure the DUT can sustain a high voltage while sourcing the current. To turn on the active load, set values other than NaN for Ioh, Iol, and Vcom. When active load is on, and the DUT voltage output exceeds Vcom, Ioh is sunk by the DSR. If the DUT voltage is less than Vcom, Iol is sourced by the DSR.
Vcom | This is the commutation voltage for use with the active load. To turn on the active load, set values other than NaN for Ioh, Iol, and Vcom. When active load is on, and the DUT voltage output exceeds Vcom, Ioh is sunk by the DSR. If the DUT voltage is less than Vcom, Iol is sourced by the DSR.
Vit | This is the termination voltage used with the 50ohm termination. To turn on this mode, set the Vit value and leave the active load settings of Ioh, Iol, and Vcom blank (or put in 'NaN' for not a number).
Vhh | Vhh is the high voltage output used in the high voltage output mode on the high voltage channels (20-23)

Any cell within the table can also specify a logical level from a standard logic family. Once a standard logic family is encountered (reading from top to bottom, then left to right), it is used for the rest of the blank cells in the table.

The following standard logic families are supported:

  • LVCMOS_1_2
  • LVCMOS_1_8
  • LVCMOS_2_5
  • CMOS_5
  • TTL
  • LVTTL
  • LVDS
  • PECL

All signals must have DC Levels specified for them.

WaveformTable sheet

The WaveformTable sheet is slightly different from the standard table format in that the upper left corner of the table specifies the waveform period. This is done with the syntax: Period=<period>. For example, Period= 40ns

The WaveformTable sheet contains the following columns:

Period=<period> | The entries in this column are the signal names. This can be Signal Expressions or simple signal names.
Character | The waveform character for which the transitions are being defined. As with STIL, multiple characters can be defined on the same line. To do so, each character is separated with a slash (/). Then the actions corresponding to each character are separated with a slash.
Up to 3 columns labeled Time | The nth time column is the time at which to apply the action specified in the nth action column.
Up to 3 columns labeled Action | The action columns specify an action character as follows:
Action Character | Type of Action | Action
U | Force | Force the DUT input to a 1
D | Force | Force the DUT output to a 0
Z | Force | Stop forcing, and do not drive the DUT input
P | Force | Continue Force from previous cycle
L | Compare | Compare the DUT output with a low
H | Compare | Compare the DUT output with a high
T | Compare | Verify the DUT output is three-state, that is, neither high nor low
X | Compare | Do not compare, doesn't matter what the signal is

Pattern sheets and MacroDef sheets

The Pattern sheet has the pattern definition. Multiple pattern sheets can be defined. A MacroDef sheet is very similar to a Pattern sheet, the only difference is that the MacroDef sheet is made up of macro definitions. Thus, the MacroDef sheet permits the pattern data to include MacroDef/EndMacro statements whereas the Pattern sheet does not. In addition, the MacroDef sheet does not permit GoTo.

The pattern table has the following columns:

Index

This is an optional column that permits entering a pattern index. The pattern index is returned with the comparison response data, so including it in the pattern makes it easier to identify the pattern line that was responsible for a given response.

If the pattern index is not filled in, consecutive numbers starting from 0 are used.

When assigning an index, it is beneficial to increment the previous line by one. This creates a more efficient compiled pattern than incrementing the index by other amounts.

Control This is an optional column for entering control information. The control strings are case sensitive. The following are supported:
Label: Appears on a line with a normal vector. The Control column just contains the label following by a colon. For instance: "HandleErr:"
X:Label Appears on a line with a normal vector. The control column has X:<label>. For instance: "X:Trial1".
GoTo Vector description must be blank. The control column contains Goto <label>. For instance: "Goto HandleErr".
Loop/EndLoop Loop and EndLoop constructs must be on a line with a blank vector. the control column for Loop has Loop <count>. For instance: Loop 42.
MatchLoop/EndLoop

MatchLoop and EndLoop constructs must be on a line with a blank vector. the control column for MatchLoop has MatchLoop <count>. For instance: MatchLoop 42.

The loop will execute either the number of times specified in count, or until all the compares in the loop test true. No response data is captured within a MatchLoop.

WatchLoop/EndLoop

WatchLoop and EndLoop constructs must be on a line with a blank vector. The control column for WatchLoop has WatchLoop <count> <trigger>. For instance: WatchLoop 42 Trigger2.

The loop will execute either the number of times specified in count, or until the specified trigger arrives. Response data is captured within a WatchLoop.

The site is used to bind the referenced trigger number to a physical trigger.

EndLoop EndLoop is used with all loop types to identify the end of the loop. This is the same as the close brace (}) in STIL. EndLoop must be on a line with a blank vector.
MacroDef/EndMacro

MacroDef and EndMacro constructs must be on a line with a blank vector. The control column for MacroDef has MacroDef:<MacroName>.

For instance, MacroDef:OutputByte. MacroDef blocks can be defined only within a MacroDef sheet.

Shift/EndShift

Shift and EndShift operations must appear on a line with a blank vector. Vectors within the Shift block are repeated until the macro parameters have all been used.

Shift and EndShift can appear only in a MacroDef sheet.

Macro invocation

Macro's are invoked with the syntax Macro:<MacroName>. For example: Macro:OutputByte. The signal columns in the pattern contain parameters that are passed to the macros. In STIL, a separate parameter may be passed for each signal, therefore in the OpenXML format, each signal column can designate another parameter.

Macro parameters can contain multiple characters. This is useful if the macro is defined using the special waveform character hash (#). Each time the macro expander sees the hash (#) character, another waveform character is used from the string.

If the macro definition uses the waveform character percent (%), it must be invoked with a single character parameter. That character is used in place of the percent (%) character in the macro expansion.

WaveformTable

This is an optional column that permits entering a WaveformTable for this row. Using this, a different WaveformTable, defining different characters, timings or period can be used for each vector.

If the column is specified, but the entry is blank, this vector will be produced with the same WaveformTable as the previous vector.

If no column is specified, and if there is a single WaveformTable defined, that will be used.

Signal columns

Additional columns can be put in the pattern sheet, where each column defines another signal. The column header is merely the name of the signal as defined on the Signal sheet.

Note that if the signal sheet defines a group of Signal using a syntax like: "Chan[0..10]", a separate column must be defined in the pattern for each Chan signal using the syntax: Chan[0], Chan[1], etc. (for all 11 signals in the range).

Site sheet

The Site sheet maps the logical signals that have been used to define the pattern onto the channels used to produce it. It also indicates how the Signals are mapped into bit positions and array elements of the API.

In OpenXML, the Trigger mapping, which STIL includes in the Site block, is done using the Settings sheet.

The following columns are defined for Site sheets:

Signal | The Signal column identifies the signal that is being specified.
Channel | The Channel column specifies the channel where the designated signals data will appear.
Ordinal | The ordinal controls how the physical channels are mapped to signals in the pattern definition. This permits arbitrary physical connections to the DUT. In the case of Pattern, Static and Capture operations, the ordinal is a zero-based bit position. For PPMU operations the results for each channel are returned as elements in an array. Therefore, the ordinal specifies the position in the array of a given signal. .

Settings sheet

The settings sheet is optional and contains general settings for the pattern.

The columns in the settings sheet are:

SheetType | This syntax indicates if this line is defining a PatternBurst or a DcLevels. Thus, this column needs to contain either the string "PatternBurst" or the string "DcLevels".
Name | This column identifies the names of the sheets to be used. For PatternBurst, it is a list of sheet names separated by plus (+) signs. For DcLevels, it is a single sheet name.
Value | This is the value to set the parameter to. The meaning is dependent on the setting and sheet type.

The syntaxes supported are:

Sheet contains the keyword: "PatternExec"

If the keyword "PatternExec" is used, a PatternExec block is created. The PatternExec block specifies a DcLevels and a PatternBurst. To specify the PatternBurst, the second column should have the keyword "PatternBurst", and the value column should define the PatternBurst using the syntax:<PatternBurstName> = <Pattern> + <Pattern> + ...

The PatternExec also specifies the DcLevels to use. To do this, put the keyword "DcLevels" in the Setting column, then put the name of the DcLevels in the Value field.

If a PatternExec is not specified, and only a single Pattern and single DcLevels is specified, one is generated automatically using the DcLevels and Pattern.

If greater control over the generated PatternExec is needed, use the PatternExec sheet type.

A PatternExec of the specified name is created with a pattern burst composed of the listed patterns.
Sheet contains the keyword: "Variable" | Variables may also be specified in the Settings sheet. To do so, the Sheet column has the keyword "Variable". The Setting column has the name of the variable. And the Value column has the numeric (or expression) that is evaluated for the variable. These variables should not be confused with spreadsheet variables. These variables are compiled into pattern being defined and can be reevaluated as part of executing the defined pattern.
Sheet is set to the name of a Site | The setting is set to Trigger <0|1|2|3|4|5>. | The value is set to a trigger source. For instance "SoftwareTrigger0". This syntax will bind the trigger source to the Trigger specified in the pattern, within the WatchLoop instructions.

PatternExec

If no PatternExec sheet is defined, a PatternExec and PatternBurst is automatically created named PatternExec_<filename> and PatternBurst_<filename> respectively. The PatternBurst contains the single default pattern (Pattern!Default), and the PatternExec references that PatternBurst and the default DC Levels (DcLevels!Default).

The PatternExec sheet permits explicitly defining a PatternExec instead of using the abbreviated syntax in the Settings sheet. The PatternExec provides the PatternBurst and the DcLevels that will be used to generate a named pattern.

The syntax for specifying the PatternBurst is a plus (+) separated list of pattern sheets. The syntax for specifying the DcLevels is just the name of the DcLevels sheet.

The columns in the PatternExec sheet are:

SheetType | This syntax indicates if this line is defining a PatternBurst or a DcLevels. Thus, this column needs to contain either the string "PatternBurst" or the string "DcLevels".
Name | This column identifies the names of the sheets to be used. For PatternBurst, it is a list of sheet names separated by plus (+) signs. For DcLevels, it is a single sheet name.


PatternBurst Overview

PatternBursts is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

A PatternBurst block defines a series of Pattern blocks to execute as part of a overall pattern execution. In addition to the Pattern blocks, the PatternBurst permits specifying the MacroDef block to use.

The PatternBurst provides a way to combine a fixed set of patterns in various fashions. Since it provides a way to use alternate macro definitions using the MacroDef block, it is possible then to use alternate implementations of certain operations.

See PatternExec Overview and STIL Components for more information.


PatternExec Overview

The PatternExec block provides the complete definition of the pattern independent of the physical channels and trigger pins. Thus, the PatternExec is a complete pattern definition that can be executed on any physical set of pins.

The PatternExec contains a single PatternBurst (which contains all of the Pattern blocks and macro definitions), and associates it with a DcLevel block that defines the amplitude settings.

PatternExecs is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

See PatternBurst Overview and STIL Components for more information.


PatternFile Overview

The PatternFile interface provides multiple methods for loading and storing pattern definitions from files. In addition to the API, the DSR supports the following three file formats:

PatternFile Format | Notes
IEEE 1450 ( STIL File Format)

STIL (pronouced like "style") is the IEEE Standard Test Interface Language (STIL) for Digital Test Vector Data. STIL is a standard pattern definition language, defined by a series of IEEE 1450 specifications. STIL is a very complete language for defining stimulus and response. The Keysight DSR implements a subset of STIL, and also adds a few custom block types. The DSR accepts syntaxes defined in IEEE 1450, IEEE 1450.1 and 1450.2.

Use the STIL format if you receive your data from a tool that produces the STIL standard format, or if you prefer your processes to follow a standard.

When loading a STIL file, only the first syntax error encountered is returned (even if there are multiple errors).

OpenXML Pattern File Format (xlsx)

OpenXML is a spreadsheet format (.xlsx) based on XML that is used by Microsoft Excel and several other spreadsheet programs. The KtMDsr accepts a format that is based on placing the same basic data elements from IEEE 1450 (STIL) into tables in a spreadsheet instead of the text format specified by IEEE 1450 (STIL).

The DSR can read a pattern definition out of a standard spreadsheet file. The file layout is defined by the ECMA 376 OpenXML standard. For the pattern definition, the arrangement of the data within the spreadsheet is defined by the DSR and closely follows the STIL format. A pattern definition can naturally be specified in terms of a series of spreadsheet tables, and this format is taken by the DSR.

Use the OpenXML format if you prefer to work with a spreadsheet program instead of the standard STIL text file format. When loading a spreadsheet file, all the syntax errors are returned at once. They can optionally be written into another sheet within the file to simplify the debugging process.

Bulk Data File Format

The BulkData format provides a way to load only the data that makes up the pattern. The result of loaded a bulk data file is a pattern STIL component that can be used with the additional definition information from STIL, OpenXML, or the KtMDsr API. A text file of pattern data is loaded directly into a pattern STIL Component. Other information such as cyclization and DC Levels can be added with driver API components, or by using one of the file formats. This provides a mechanism to easily load data from other sources into a pattern.

The BulkData format is a flexible format based on a text file. The content can be just the waveform characters that define the pattern, or waveform timing information and line numbers may be included.

A bulk data file may have its load operation deferred until the pattern is compiled and written to memory. This allows much larger patterns to be loaded.

Programmatic Interface (API) | Although clearly not a file format, the programmatic interface provides all of the flexibility of the file formats.

Notes

  • Any pattern, regardless of the source, can be listed to a STIL file. The resulting STIL file is not intended to be in a convenient human readable format, but it can be loaded back into the KtMDSR and executed to provide the same pattern as the original did.
  • Any pattern can also be compiled and saved either to cache or the file system.
  • The OpenXML and BulkData parsers provide a list of syntax errors. These can be queried from the driver by repeatedly calling GetNextError. ErrorCount indicates the number of errors remaining in the queue. If there are any errors, an error is generated by the call to Load or LoadAndUpdateOpenXml.
  • Cache size and Result size are specified in the Instrument.ConfigureMemory function.
    • A total of approximately 2GBytes of memory is available. By default, the CacheSize is approximately 1.9 GBytes, and the Response size is approximately 100 Mbytes.
    • The ConfigureMemory function will clear any patterns in the cache. All pattern sites must be inactivated before configuring memory.
  • When the DSR module is configured to run four separate 4-channel banks, the response word from each bank is 64 bytes. When the DSR module is configured to run a single 16-channel bank, each response word is 256 bytes.

.


Patterns Overview

The Patterns block provides the data that is used to stimulate the DUT and the data that is expected back from DUT. This data includes the stimulus and response values and also various non-data instructions.

The data output on each signal in the pattern in a single WaveformTable period is referred to as a Vector. Each Vector in the Pattern can be output using a different WaveformTable. Thus, each vector in the pattern includes the Signals being defined, the waveform character for each signal, and the WaveformTable that defines the waveform character and specifies the period for this cycle.

The Vector method may be called multiple times to provide a complete definition of a clock cycle. This permits independently specifying signals or signal groups with separate calls.

Vectors may be labelled using LabelVector. This makes them available as locations that are accessible with GoTo.

The following non-data instructions are supported:

Instruction | Notes
CrossReference | Places a mark in the pattern that is included in the response log. This simplifies relating the response log to the line in the pattern that generated it.
GoTo | Forces the execution to transer to a locations identified with a label.
Loop | Indicates a block to be repeated a fixed number of times.
Macro | Executes the pattern from the specified macro. Optionally includes parameter substitution if defined using the MacroWithSubstitution function.
MatchLoop | Indicates a block should be repeated until all Compare operations pass, or a specified number of loops are completed.
Shift | Shift is a parameter substitution operation. It indicates that the parameters from the input parameter list should be executed until the list is exhausted. Shift may only be used within a Pattern that is designated as a macro using MacroDef.
WatchLoop | Indicates a block should be repeated until an external trigger event is received, or a specified number of loops are completed.

Each instruction is programmed using an Index that indicates the location within the pattern. The Index begins at zero, althougth instructions can be located at any desired starting Index. When the Pattern is completely defined, the various instructions are sorted by Index and executed in that order. While there are performance benefits to using consecutive Indexes, instructions and vectors can be assigned to Indexes on a non-consecutive basis. Furthermore, assignments to Indexes can be made in any order as long as the contents are in the desired order of execution, from low Indexes to high Indexes. Although the Vector function may require multiple invocations to fully define a vector, no two distinct instructions can have the same Index.

In general, the mechanism for capturing data is to specify a CompareLow operation on the Signals where the data is being captured. Then the DSR is configured to log all compares. Thus if the input is low, the compare succeeds and 0 is logged; if the input is high, the compare fails and 1 is logged. Thus the log represents the data values of the input.

Patterns is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

For more information on STIL components, see STIL Components.


PatternSites Overview

PatternSites operates the pattern execution hardware on a specified site. The pattern definition includes symbolic signals and triggers; the site maps those signals and triggers to physical DSR channels and trigger sources. Once the pattern is activated, the PatternSite functions and attributes control the execution of the pattern on the DSR hardware.

To execute the pattern, a site must first be activated by calling one of the activate functions. The activate functions indicate the pattern to be generated and the site on which to generate it. Once activated, the site block name is passed to the Item function to get a pointer to access the various functions that control the pattern generator. When the site is activated, the channels are locked for these pattern operations until either Inactivate or InactivateAndDisable is called. The triggers are not locked since a trigger event may be used on multiple sites.

The site is defined using the sites interface Sites Overview) . The site definition provides a list of channels and ordinals for each channel. The ordinal establishes how data regarding each signal is packed into integers for the pattern site

The Keysight DSR module can be used in single-bank mode, or multi-bank mode. In multi-bank mode, up to four separate sites may be active and operated independently. However, the signals used on each pattern must come from a single bank. In single-bank mode, all of the channels in the instrument may be used; however, only a single pattern may be active at any one time.

In multi-bank mode, the banks are composed of the channels:

IO bank | Channels | Note
Bank 0 | High speed channels 0-3, and high voltage channel 20 | Channel 2 is unavailable when using high voltage channel 20
Bank 1 | High speed channels 4-7, and high voltage channel 21 | Channel 6 is unavailable when using high voltage channel 21
Bank 2 | High speed channels 8-11, and high voltage channel 22 | Channel 10 is unavailable when using high voltage channel 22
Bank 3 | High speed channels 12-15, and high voltage channel 23 | Channel 14 is unavailable when using high voltage channel 23

After the pattern has been executed and the channels must be activated for another application such as the PPMU or static site, Inactivate or InactivateAndDisable must be called to release the channels for use by another operation. Inactivate releases the channels without changing the signal levels on the channel. This permits the channels to be used in other ways, such as to generate another pattern or make PPMU measurements without ever glitching the signal lines.

InactivateAndDisable inactivates the channels and in addition sets them to a quiescent state (high output impedance).

For information on using active sites, see Active Sites.

Activating a PatternSite and the Pattern Cache

To activate a site for pattern execution, the pattern definition and site are required. The simplest function to do this is the Activate function which takes the name of a Site block, a PatternExec block, and the edge placement resolution. The PatternExec block provides a complete definition of the pattern, including DC levels, multiple patterns containing stimulus and response values (PatternBurst), and timing information (WaveformTables).

The ActivatePattern function provides a way to activate a pattern without creating the STIL components for the PatternExec and PatternBurst. The ActivatePattern function takes a single Pattern and DcLevels block. This provides a somewhat simpler approach, requiring only that those three blocks be defined. However, this approach is less flexible. Since ActivatePattern accepts only a single Pattern, multiple patterns cannot be executed with ActivatePattern.

When a pattern is activated using Activate or ActivatePattern, the pattern definition is compiled into the internal format used by the hardware, then the compiled format is downloaded to the hardware. This can take a substantial amount of time. For time critical applications, it is desirable to minimize the amount of time spent to compile and download patterns to the instrument.

There are two mechanisms provided to minimize the test time. First, the compile time can be saved by pre-compiling the pattern and storing it on the computer file system. The second mechanism downloads compiled patterns to the on-board pattern cache where they can be executed repeatedly without any recompile or download overhead.

For every case, the DSR software must have the target site and the EdgePlacementResolution to be able to compile a pattern. The target site is used to arrange the signals onto the appropriate pins, and the EdgePlacementResolution sets the basic resolution used to produce the timings specified in the WaveformTables.

The following VIs are involved in the management of patterns:

VI | Purpose
PatternSites Activate | Compiles and temporarily downloads a PatternExec
PatternSites Activate Pattern | Compiles and temporarily downloads a Pattern with DcLevels
PatternSites Compile Pattern Exec | Compiles a PatternExec and either downloads or saves to file system
PatternSites Compile Pattern | Compiles a Pattern with DcLevels and either downloads or saves to file system
PatternSites Download Pattern to Cache | Downloads a compiled pattern to cache for used by ActivateFromCache
PatternSites Activate from Cache | Activates a pattern stored in the pattern cache

The PatternSite Abort VI is used to stop execution.

Determining the EdgePlacementResolution

The EdgePlacementResolution is specified when a pattern is activated. The resolution may be set to Auto (EdgePlacementResolutionAuto) or by setting a specific value between 1 ns and 100 ns. This determines the frequency setting of internal clocks that establish the resolution and dynamic range for edge placement. Edge placement includes the generation of the period of the signal as well as the transition times specified within the period. Edge placement also determines the resolution and dynamic range of the StimulusDelay and ResponseDelayCompensation.

Edge placement resolution and waveform period are related. Refer to the Edge Placement Resolution topic for more details on edge placement resolution, including how edge placement resolution affects other times in a test.

Pattern Execution

The execution of a pattern follows this sequence:

Activate | The site is first activated using one of the activate functions. This may include a full compile and download, or the pattern may already be in cache. In any case, Activate locks the channels used in the pattern. Nothing changes on the physical ports of the device on Activate.
Initiate | At Initiate the pattern is prepared to execute. The settings for the initial clock period of the pattern are applied to the outputs. The DC Levels are also applied to the pins, so the output could change if DC Levels change or if the pins are changed from a PPMU level to a level set by the DcLevels.
Trigger occurs | If the TriggerMode is set to Immediate, execution will begin immediately after Initiate. If the TriggerMode is set to Triggered, the DSR will wait for the trigger specified with TriggerSource. An application program can verify that the Initiate functions are complete and the instrument is waiting for a trigger by reading the SequencerState which will indicate if the sequencer is waiting for a trigger.
Pattern executes | The pattern can execute without further management via the driver. However, if the pattern has included WatchLoop instructions to pace the execution, the API can satisfy those WatchLoop conditions by generating additional triggers.
Execution completes | The software can wait for execution to complete by calling WaitForAcquisitionComplete, or it can poll the status by calling QueryExecutionState. Once the execution is complete, TerminationReason can be read to determine details on the reason that execution terminated.
Optionally fetch results | If the test failed, or if it logged data, the reason for failure or the logged data can be read back using the Fetch functions.
Optionally Execute the pattern again | The pattern can be executed again by calling Initiate. Any results that have not been fetched will be cleared.

Fetching Results

The results of the execution are packed into integer data. The results from the compares on each signal are mapped into the bit positions specified using the ordinal in the Site block. Fetch operations for both bytes and 16-bit words are provided to optimize memory usage when reading results.

FetchTrinary functions are included that indicate the state of the response signal when the failing compare occurred. The response signal will be in one of three states, low, high, or at a level that is above the low threshold and below the high threshold. The FetchTrinary operations use two bits for each signal to indicate if the compare failed, and if so, the state of the response signal from the DUT. The result is placed in a 32-bit integer, and each response signal occupies two adjacent bits in the result. Therefore, the bit positions in the result are two times the ordinal and two times the orginal plus 1.

The bit positions in the result are encoded as:

Result | Indicates
00 | There was either no compare on this bit, or the compare succeeded
01 | Thee compare failed and the response signal was low
10 | The compare failed and the response signal was between Vol and Voh
11 | The compare failed and the response signal was high

Pattern Execution Options

The following table summarizes the pattern execution options:

Option | Purpose
ConditionalLoopFailureMode | This controls the behavior of the pattern execution when a MatchLoop or WatchLoop counter expires. The pattern can either abort or continue to execute after the loop.
ConditionalLoopSuccessMode | This controls the behavior of the pattern execution when a MatchLoop or WatchLoop succeeds. This selects how the DSR behaves when the success condition is detected close enough to the end of the loop that it is not possible to exit without completing a pass through the loop after the success condition is detected.
WhatToLog | This controls what data is saved into the results. Either all compares can be logged, only failing compares can be logged, or only the first failure can be logged. If only the first failure is logged, execution is stopped asynchronously after the first failure.

Altering Compiled Patterns

There are several applications that need to adjust a fixed pattern in some way. Generally, these adjustments could be done by recompiling a new pattern, but the overhead and complexity of creating an entire new pattern can be quite complex and may execute slowly.

The DSR provides the following mechanisms that can be used to adjust an existing pattern:

Function | Purpose
SetDcLevel | There was either no compare on this bit, or the compare succeeded
SetSignal | Thee compare failed and the response signal was low
SetVector | The compare failed and the response signal was between Vol and Voh
SetWaveformTable | The compare failed and the response signal was high
ReevaluateDcLevels | DcLevels may be specified with strings from a pattern file (although the API uses numeric settings). These strings can be numeric expressions that include variable evaluation. This method uses the expression evaluator to evaluate the provided expression. This is useful when one or more variables are changed so that the expression is updated. Then the DC Levels are each re-evaluated based on the new variable settings. This is useful for shmoo testing since it allows a series of values to be adjusted as a part of moving a single control variable. Note that the same expression evaluator is used for DcLevels and WaveformTables, so a single control variable can be used to adjust both timing and amplitude, but both Reevaluate functions must be called.
ReevaluateVariables | The timing information in the waveform tables may be specified with strings from a pattern file (although the API uses numeric settings). These strings can be numeric expressions that include variable evaluation. This method uses the expression evaluator to evaluate the provided expression. This is useful when one or more variables are changed so that the expression is updated. Then the waveform tables are each re-evaluated based on the new variable settings. This is useful for shmoo testing since it allows a series of values to be adjusted as a part of moving a single control variable. Note that the same expression evaluator is used for DcLevels and WaveformTables, so a single control variable can be used to adjust both timing and amplitude, but both Reevaluate functions must be called.

For details information on selecting the EdgePlacementResolution and its impact on various DSR settings, see Edge Placement Resolution.

For information on acquiring results and other data collection, see Acquiring Results and Data Collection.


PpmuSites Overview

PpmuSites operates the Per-pin Parametric Measurement Unit on a specified site. PPMU operations are conducted on each channel defined in the site; results are returned in arrays.

The site is defined using the Sites interface. The site definition provides a list of channels and ordinals for each channel. The ordinal establishes the location in the results array in which the results are placed. The Sites interface also associates a Signal with each channel; the Signal is not used by the PPMU functions.

PPMU site does not respect the direction specified for the Signals on the site. For example, if a Signal is defined as a DUT output, the PPMU may force that signal. This may be useful for DUT driver and receiver tests.

To use the PPMU, a site must first be activated by calling Activate with the site block name as the parameter. Once activated, the site block name is passed to the Item function to get a pointer to access the various PPMU functions. When the site is activated, the channels are locked for PPMU operations until either Inactivate or InactivateAndDisable is called.

Measurements are returned in arrays. The results for a given channel is returned at the index in the array specified in the Ordinal specified in the site. The array size is one more than the highest ordinal specified. For example, if the highest ordinal is 4, the array would be allocated with 5 doubles, indexed from 0 through 4. The array contains zero for any elements that do not have a channel mapped to them.

Inactivate and InactivateAndDisable release the channels for use by another operation. Inactivate does not change the signal levels on the channel. This permits the channels to be used in other ways, such as for pattern generation, without ever glitching the signal lines.

InactivateAndDisable inactivates the channels and in addition, sets them to a quiescent state (high output impedance).

The various force and measure operations are applied identically to each channel in the site. The order that operations are completed on the site is not guaranteed.

To complete an operation on a single channel, a site with only that channel must be defined.

See also Active Sites and Signal Direction.


Signal Direction

The use of signal direction is dependent on the Site type.

Site Type | Use of Signal Direction
Pattern | Stimulus is only applied to Signals defined as In or InOut, and Response is only taken from Signals defined as Out or InOut.
Static | Stimulus is only applied to Signals defined as In or InOut, and Response is only taken from Signals defined as Out or InOut.
PPMU | The Direction is ignored. All measurements may be performed on any channel in the Site.
Capture | Data is captured from Signals defined as Out, Clocks are generated on Signals defined as In. Signals defined as InOut generate an error.

In StaticSite read operations,

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) return 0.

In StaticSite write operations,

Bits in the read result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT output (Direction is Out) are not affected by the write.

In PatternSite or Capture Site with Fetch operations,

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

In a WaveformTable,

Force events are not permitted on signals that are defined as DUT outputs (Direction is Out).

Compare events are not permitted on signals that are defined as DUT inputs (Direction is In).

For more information on how Signal Direction is used, see StaticSites Overview, Capture Sites Overview, and WaveformTables Overview.


Signal Expressions

Purpose of Signal Expressions

When defining a pattern, it is frequently useful to deal with numerous signals at the same time. In many applications, such as when defining a bus, all signals may define the same waveform characters and DC levels. Signal Expressions provide a simple way to specify a group of signals.

Most of the DSR entries (including IVI, STIL, and OpenXML) that accept a signal, also accept a signal expression. Signal expressions are created using the following syntax:

"+" or "," | Signals can be added into the expression using plus or comma. So "Signal1+Signal2" refers to both signals.
".." | A range of signals that have a numeric suffix defined with square brackets can be added using "..". For instance, if you have defined "Signal[0]" , "Signal[1]", and "Signal[2]" , you can refer to all three with the syntax "Signal[0..2]".
"-" | Signals can be removed from an expression using minus. For instance, "Signal[0..2]-Signal[1]" is the same as "Signal[0]+Signal[2]".
"()" | Parenthesis can be used for grouping operations.

In addition, a SignalGroup can be defined. In OpenXML, this is done by merely defining a signal expression in the Direction column instead of one of the direction symbols.

In STIL, a signal group is defined using the SignalGroup block, which similarly permits defining a group as a signal reference expression. The signal expression in STIL is enclosed in single quotes ("'").

Once defined, a signal group can be used just like a signal expression that includes each signal in the group. The “-“ (minus) operation can be used to take signals away from a group within a larger expression. For instance, "Group-Signal"or "Group1-Group2" are both legal.

Examples of signal expressions
Expression | Example | Note
The sum (or difference) of signals or signal groups. | Signal1+Signal2 D3+D2+D1+D0 SignalGroup1+ SignalGroup2 | Operands may be signals or signal groups, separated by plus '+' or minus '-' signs, and grouped by parentheses.
Removing a signal reference expression from another signal or group | SignalGroup1 - Signal1 | Signal1 must be part of SignalGroup1 in order to remove it from SignalGroup1.
A comma-separated list Signals | Signal1, Signal2, Signal3, Signal10, Signal11, Signal12 | Data[0..15] yields 16 signals: Data[0], Data[1], … Data[15] Data[5..0] yields 6 signals: Data[5], Data[4], Data[3], Data[2], Data[1], Data[0]
A range of Signals, in either ascending or descending order | Data[0..15] Data[5..0] |
The sum (or difference) of signal ranges | Signal[0..7]+Data[0..3] Signal[0..7]-Signal[3] Data[0..15]-Data[2] |
Parenthesis for grouping | Data[0..15]-(Data[0]+Data[1]) |

Examples of signal expressions in OpenXML format file

The cells below are an excerpt from the Signals sheet of an OpenXML format file. Signals and SignalGroups are described on the Signals sheet. Note these signal expressions:

  • Ranges: OutputBus[0..3] and InputBus[0..3]

  • The summation of signals for group “All” and “Control”CD and on the web.

  • The difference in group “Buses”

 | Signal | Direction
 | OutputBus[0..3] | Out
 | InputBus[0..3] | In
 | Clock | In
 | Handshake | InOut
# | Group definitions | (This is a comment line)
 | All | OutputBus[0..3]+InputBus[0..3]+Clock+Handshake
 | Buses | All-Clock-Handshake
 | Control | Clock+Handshake

Examples of Signals block and SignalGroup block in STIL format

Signals {

Signal1 InOut;

Signal2 InOut;

Signal3 InOut;

Signal10 InOut;

Signal11 InOut;

Signal12 InOut;

D0 InOut;

D1 InOut;

D2 InOut;

D3 InOut;

Signal[0..7] InOut;

Data[0..15] InOut;

}

SignalGroups {

All = 'Signal1+Signal2+Signal3+Signal10+Signal11+Signal12+D0+D1+D2+D3+Signal[0..7]+Data[0..15]';

SignalGroup1 = 'Signal1+Signal2+Signal3';

SignalGroup2 = 'Signal10+Signal11+Signal12';

SignalGroup3 = 'All-SignalGroup1';

}


SignalGroups Overview

A SignalGroup is a list of Signals. Most interfaces that accept a Signal also accept a SignalGroup or a signal reference expression. The block name of the SignalGroup is the name of the SignalGroup and can be used in most places where a Signal is accepted.

A SignalGroup is defined with a signal reference expression which is a string that identifies a group of Signals. The following rules describe the syntax of signal reference expressions.

Syntax | Example
Plus (+) or comma (,) are used to list existing Signals and/or SignalGroups to include in the expression | Sig1+Sig2+Sig3+Group1 Sig1,Sig2,Sig3,Group1
Square brackets [x..y] are used to add a range of Signals | DataBus[0..16]
Minus (-) removes a signal from the expression | Group1 - Sig1 DataBus[0..16] - DataBus[16]
Parenthesis ( ) are used for grouping | Group1 - (Sig1+Sig2)

Notice that when a range is declared, the individual Signal names must be valid signals. The square brackets are included in the individual Signal names. For instance, in the example above, DataBus[16] is in the range, but there is not a Signal named DataBus16.

SignalGroups is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

See Signal Expressions and Numeric Expressions for more information on evaluating Signal and Numeric Expressions.


Signals Overview

Signals is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

Signals must be defined before they are used.

A Signal is a symbolic representation of a single DSR channel; however, it is not associated with a physical channel. By separating the concept of a Signal from a channel it is possible to define patterns that can be bound to a different set of channels. This separates the pattern definition from the details of the physical connector. It also permits the same pattern to be executed on multiple sites at the same time.

The Signals block differs somewhat from the other STIL Components.

  • The other STIL components are always referenced using the block name. For instance, the block name is passed to the Item method to access the block to configure it. The block name is also used whenever the block is referenced. Thus, the block name provides a way to manage multiple copies of the block.
  • For Signals, the block name for a Signal is the name of that Signal. This signal name is used primarily in the pattern definition itself, so the block name is not directly used. Signals also differ from other STIL components because they are defined for the entire DSR (that is, they are global in scope).
  • Signals must be defined before they are used.

See STIL Components for more information on how patterns are defined.


Sites Overview

Sites is used to specify how a pattern is applied to the physical DSR. This includes:

  • Mapping the Signals to DSR Channels
  • Specifying an Ordinal for each Signal and Channel that specifies the position that Signal will take in response data.
  • Mapping the Trigger references in the pattern to physical trigger sources.

Since the Site specifies this physical mapping, it is used to bind Patterns, PPMU operations, and StaticSite operations each to physical channels.

Sites is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

The Use of Signal Direction

The use of signal direction is dependent on the Site type. For details, refer to the Signal Direction article.

Note regarding high voltage channels

The DSR provides four high voltage channels. Each high voltage channel is associated with a high speed channel on its respective IO bank. It is important to note that a high speed channel may not be used at the same time as its corresponding high voltage channel (for example, channels 2 and 20 may not be used at the same time). These dependencies are outlined in the table below. Refer to the DSR User Guide for more detailed information on using high voltage channels.

I/O bank | High voltage channel | Corresponding high speed channel | Note
0 | 20 | 2 | Channel 2 is unavailable when using high voltage channel 20
1 | 21 | 6 | Channel 6 is unavailable when using high voltage channel 21
2 | 22 | 10 | Channel 10 is unavailable when using high voltage channel 22
3 | 23 | 14 | Channel 14 is unavailable when using high voltage channel 23


StaticSites Overview

StaticSites provides direct access to channels on a specified site by using reads and writes. StaticSite operations impact each channel defined in the site. StaticSite is useful for doing basic binary control of sites and also for validating fixtures and connectivity.

The site is defined using the Sites interface. The site definition provides a list of channels and ordinals for each channel. The ordinal maps the bit position between the read and write integers and the DSR channels. The Sites interface also associates a Signal with each channel; the Signal is only used to establish the signal direction.

To use the StaticSite, a site must first be activated by calling Activate with the Site block name as the parameter. Once activated, the Site block name is passed to the Item function to access the various StaticSite functions. When the site is activated, the channels are locked for StaticSite operations until either Inactivate or InactivateAndDisable is called.

Results are returned in integers. The value for a given channel is returned at the bit position in the integer specified by the Ordinal defined in the site.

The ordinal is limited to 31 for StaticSite operations since all channels are mapped to bits in an integer. There is no provision for controlling sites with more than 32 bits with StaticSites.

Inactivate and InactivateAndDisable release the channels for use by another operation.

  • Inactivate does not change the signal levels on the channel. The permits the channels to be used in other ways, such as for pattern generation, without ever glitching the signal lines.
  • InactivateAndDisable inactivates the channels and in addition, sets them to a quiescent state (high output impedance).

For information on using active sites, see Active Sites.


STIL Components

Patterns are constructed from building blocks that are collectively referred to as STIL components. The STIL components closely follow the block definitions that are provided by STIL (IEEE 1450). They are dynamically created and defined by either loading a pattern file or by programatically providing the definition. Before loading a pattern file or programatically providing the definition, the components do not exist.

In the API, the STIL components can be defined in most any order, as references to undefined STIL components are permitted. The single exception is that all signals must be defined before use.

The STIL specification requires that the component definitions in a STIL file occur in a specified order. So, although the DSR software will accept definitions in an arbitrary order, the STIL input file must be in the order defined by the IEEE 1450 specification.

STIL Components

The DSR supports the following STIL components:

Repeated
Capability 		STIL Block Name Usage
Signals Signals

Each repeated capability defines a single Signal. Signals differ from other repeated capabilities in that they must be defined before they are referenced. The name of the Signal is the same as the repeated capability name.

SignalGroups SignalGroups

SignalGroups permit referring to multiple signals with a single name. This simplifies defining items like DC Levels where numerous signals may need to be assigned at the same time.

A SignalGroup is defined with a string that contains one or more signals. There are basic operators available for referencing a series of signals and for adding and removing signals from a group.

Sites Sites (Keysight extension)

A STIL pattern is defined in terms of Signals. The Sites block specifies the physical DSR channels, that is, the module inputs and outputs that the signals will be bound to.

Since the pattern definition itself has no reference to the physical channels, a complete pattern can be defined independently of the physical outputs and the actual fixture that is used to execute the pattern.

The KtMDsr binds the physical definition to the pattern definition by Activating a site. The site name is used both for activating the site and for referring to it once it has been activated.

DcLevels DcLevels (IEEE 1450.1)

This block defines:

  • Signal Levels for digital stimulus
  • Thresholds to use to interpret a digital response
  • Load characteristics of the signal line .

The DcLevels block permits each of these settings to be made independently for each channel. The repeated capability name is an arbitrary block name that represents this set of definitions. Each block may contain independent DC Level settings for each signal.

WaveformTables WaveformTables

A WaveformTable defines the waveform that should be produced, or expected by the DSR when a particular waveform character is executed on a particular Signal.

The waveform table name is used in the pattern to specify a different set of waveforms for the pattern characters; these define how each vector of the pattern should be executed.
Patterns Pattern

The Pattern block contains the definition of the binary data that is used to create the stimulus and define the expected response.

The repeated capability name identifies the Pattern if it is referenced in a PatternBurst, or if it is referenced directly by an API.

Note that API's are provided to execute or compile a Pattern block directly. That is, these API's do not require definition of a PatternBurst or PatternExec.

MacroDefs MacroDefs

A MacroDef block contains references to patterns that may be used as macros. This differs slightly from STIL which has a separate block type for macros. However, since macros are very similar to patterns, the KtMDsr uses a pattern block to define macros, then those pattern blocks are referenced in the MacroDefs block.

The name of the MacroDef block is used to specify the set of Macros to be used in the evaluation of a pattern. This specification occurs in the PatternBurst block where the pattern is used.

By defining multiple MacroDef blocks, different implementations of a single set of macros can be switched in and out. For instance, this may be useful if a set of macros is used to implement some protocol, and different versions of the protocol need to be switched in without changing the pattern in any other way.

PatternBursts PatternBurst

A PatternBurst block defines a list of pattern blocks to execute when the digital test is executed. It also specifies the MacroDef block to use as macro definitions.

PatternExecs PatternExec

The PatternExec is the top level definition of a digital test. It includes a PatternBurst (which is made up of a series of patterns and macro definitions), and a DcLevel block that specifies the levels.

The name of the PatternExec is specified to execute the digital test.

Common Operations STIL Components

The following functions and attributes are used to work with the STIL Components:

Add

Adds a new instance of a repeated capability. For instance, this could be used to add a new signal to the signals collection.

Count

This attribute contains the number of instances of the repeated capability that have been defined. This is primarily useful for discovering the repeated capabilities in the driver, often after loading a STIL or OpenXML file.

Name

This property returns the name of a repeated capability at a given index. By reading the Count property, and calling name for each defined Index, a client can discover the repeated capabilities defined.

Remove

This function removes a repeated capability of the given name. This frees up memory and other resources associated with the repeated capability.

Item (Name)

The Item function provides access to the actual capability. The Item function returns an instance of the repeated capability. For IVI-COM, this is an object that has methods defined to read and write settings associated with that instance, or to do work with that instance.

The repeated capability is defined with a plural noun (for instance Signals ). The Item function takes the name of a particular member of that collection and return it. The type of this returned item is the singular form of the noun. For instance, the Signals repeated capability has an Item function that returns a Signal object, which has Direction defines for the Signal.

Item.Name

This attribute is defined on the repeated capability itself. This provides a way to get the name of this repeated capability. Thus, you pass the name to Item to get the repeated capability. Then you can check the Name attribute in the repeated capability to get that same name back again.

This is useful when the repeated capability has been passed to some operation that works with the repeated capability without access to its name. The Name function allows that client code to delete (or otherwise manipulate) the repeated capability without the context of how it was acquired.


STIL File Format

STIL is available from the IEEE. The KtMDsr driver primarily utilizes the syntax defined in the base specification (IEEE 1450-1999).

The KtMDsr driver also uses:

  • The X pattern statement (cross reference label) from the IEEE 1450.1-2005 specification.
  • The DcLevels blocks defined in IEEE 1450.2-2002.

In addition, there are several KtMDsr pattern extensions to the STIL specification, which are listed below.

Pattern Extension
Description Syntax Example
Site

The root level Site block is used to define how signals and triggers are bound to the physical device.

-Under the Site block, the Channels block is used to control settings associated with specific channels, independent of its use for PPMU or patterns.

- Also under the Site block is the Triggers block, which is used to assign a software trigger (SoftwareTrigger0 - SoftwareTrigger15) to a physical trigger input (Trigger0 - Trigger5).

For more information, see Sites Overview.

Site <Sitename> {

 (Channels {

   ( SIGNAL_NAME

      DECIMAL_INTEGER         // DSR channel #

      (DECIMAL_INTEGER) ; )+  // Ordinal #

(Order

                              // data is packed

                              // into results.)

   } )                        // end _Channels

 (Triggers {

        ( <Trigger0|Trigger1|Trigger2|Trigger3|

      Trigger4|Trigger5> “TRIGGER_SOURCE”; )

* })?

                  // Trigger source is string

                  // defining physical trigger

                  // input. Software triggers

                  // are Softwaretrigger0 -

                  // SoftwareTrigger15.

 })*

}

Site Sitename {

  Channels {
    A0 0 0;
   A1 1 1;

    A2 2 2;

    A3 3 3;

  }

  Triggers {

    Trigger0 =
"SoftwareTriggers0";
   Trigger1 =
"SoftwareTrigger1";

  }

}

WatchLoop

The KtMDsr driver provides a WatchLoop pattern statement.

WatchLoop is similar to the STIL MatchLoop, except that a WatchLoop continues to execute until either the number of loops specified are completed, or until the specified trigger condition occurs.

A LoopCount of 0 is interpreted as an infinite loop.

WatchLoop < LOOPCNT | Infinite > <Trigger0|

Trigger1|Trigger2|Trigger3|Trigger4|Trigger5>
  {
      (pattern-statements)+
 }

Pattern testpat1
 WaveformTable one;

WatchLoop 7 Trigger1 {
       V{ALL=100000;}
       V{ALL=010000;}
       V{ALL=1P1P1P;}=
       V{ALL=111111;}
        V{ALL=111111;}
    }
    V{ALL=111111;}
    V{ALL=000000;}
} // end Pattern

DcLevels:

- VCOM

- VHH

-VIT

-VHYST

- VCOM is the active load commutation voltage, the voltage at which the load switches from sinking current to sourcing current. VCOM is used with IOH and IOL to configure the active load.

- VHH is the voltage forced by the DSR on the high voltage pin when high voltage is active.

- VIT is the voltage forced by the DSR on the high voltage pin when high voltage is active.

- VHYST is the hysteresis applied to the DUT output low threshold (VOL) and DUT output high threshold (VOH). This is the peak-to-peak hysterisis voltage. Inputs are coerced to 0 mV, 50 mV, or 100 mV.

For more information, see DcLevels Overview.

 DcLevels <pattern> {

 Channels {
    VIH '<value>'; VIL '<value>';
    VOH '<value>'; VOL '<value>';
    VHYST '<value>'; VCOM '<value>';
    IOL '<value>'; IOH '<value>';
    VIT '<value>'; VHH '<value>';
  }

} 		DcLevels DelayPattern {

 Channels [0..15] {

   VIH '1V'; VIL '-1V';

   VOH '-0.1V'; VOL '2.77V';

   VHYST '0V'; VCOM 'NaN';

   IOL 'NaN'; IOH 'NaN';

   VIT '0V'; VHH 'NaN';

 }

}


Trigger and Marker Overview

This section describe how to program triggers and markers. The first release of the KtMDsr driver, version 1.0.10.1, supported only software triggers. Hardware triggers and markers have been added to version 2.0.x.x of the KtMDsr driver, referred to here as the "current driver". Hardware triggers and markers are supported on both the M9195A and M9195B modules with the current driver.

Triggers are inputs to the DSR, and can be used to initiate the generation of a pattern or the continuation of a pattern that has already been started. Markers are outputs from the DSR, and can be used to trigger other devices, either other modules in the same chassis or external devices.

Most of the DSR signals associated with triggers and markers are bi-directional, i.e. they can programmed to be either a trigger input or a marker output. Because of this, care must be taken to avoid contention between marker outputs. This can occur if two marker outputs from different devices are programmed on the same signal line, such as between the DSR module and another module in the same chassis.

Triggers

The triggers supported by the current driver are summarized below:

  • Software triggers — Software triggers were supported in the 1.0.10.1 release and continue to be supported in the current driver. Software triggers can be used to initiate the execution of one or more PatternSites or CaptureSites. In this manner, software triggers allow these sites to start synchronously under software control.
  • Hardware triggers — Hardware triggers are external inputs to the DSR and have two basic sources:
    • Front panel triggers — The DSR front panel has two signals labeled GPIO1 and GPIO2. Either of these signals can be configured as a trigger input.
    • Chassis backplane triggers — The chassis backplane has 10 signals which can be programmed to be trigger inputs to the DSR.

Markers

The markers supported by the current driver are summarized below:

  • Front panel markers—The two front panel signals labeled GPIO1 and GPIO2 can each be programmed to be a marker output. As noted above, the GPIO1 and GPIO2 signals can also be programmed to be trigger inputs.
  • Chassis backplane marker—The DSR can be programmed to generate markers on 10 chassis backplane signals. Most of these signals can also be programmed to be trigger inputs.

Trigger and marker signals

The table below shows the 13 signals that can be programmed to be triggers and markers. All signals except PXIe_DSTARB and PXIe_DSTARC are bi-directional and can be programmed to be either a trigger or a marker.

Trigger and marker signals

The table below shows the 13 signals that can be programmed to be triggers and markers. All signals except PXIe_DSTARB and PXIe_DSTARC are bi-directional and can be programmed to be either a trigger or a marker.

 | Front Panel Signals |  | Chassis Backplane Signals
 | GPIO1 (External 1) | GPIO2 External 2) | PXI_TRIG[0:7 (8 signals) | PXI_STAR | PXIe_DSTAR | PXIe_DSTARC
Trigger Inputs | X | X | X | X | X |
Marker Outputs | X | X | X | X |  |

Notes:

1. The DSR front panel signals labeled GPIO1 and GPIO2 signals are accessible in software using the names "GPIO1" and "GPIO2". In addition,and to follow industry conventions, these signals can also be accessed using the names "External1" and "External2" as shown in the table above. Wherever this document refers to "GPIO1" or "GPIO2", the names "External1" and "External2" may also be used.

2. The eight PXI_TRIG[0:7] signals form a trigger bus on the chassis backplane that is connected to all module slots. You can use any of these eight signals as either trigger inputs to the DSR or marker outputs from the DSR. However, the trigger bus signals are a shared resource on the backplane which any module can use. Therefore, your application should manage the usage of these signals to ensure that there is no signal contention between the different modules.

3. The trigger bus formed by PXI_TRIG[0:7] is divided into three trigger bus segments within the M9018 chassis. It is recommended that modules which use the PXI_TRIG[0:7] signlas for triggering between them be located on the same trigger bus segment. If this isn't possible, the M9018 chassis can be programmed to pass triggers and markers between trigger bus segments. Refer to your chassis documentation for information on triggering modules across trigger bus segments.

4. Those signals that include "STAR" in their name are either sourced from or are received by a system timing module. For the M9018 chassis, slot 10 is the system timing module slot. Using any of the STAR signals requires the installation of a 3rd party system timing module. This guide does not describe how to use a system timing module to generate trigger inputs to the DSR nor how to respond to marker outputs from the DSR.

Using triggers

This section describes how triggers can be used. This description applies to both hardware triggers and software triggers. Triggers can be used to:

  • Trigger the execution of a PatternSite or a CaptureSite
  • Trigger the exit of a WatchLoop

Each of these usages is described below. Note that, for brevity, a shortcut nomenclature is used here. For example, when referring to the TriggerSource property in the PatternSites interface, the driver object will be omitted and the property will be referred to as "PatternSites.TriggerSource". Note that, in many cases, direct links will be provided from the shortcut nomenclature to the property page.

Triggering the execution of a PatternSite or a CaptureSite

To specify which trigger signal is used to begin the execution of a PatternSite or a CaptureSite, use the PatternSites.TriggerSource property or the CaptureSites.TriggerSource property, respectively. These properties specify a string which can be one of the 12 hardware trigger signals listed above (such as "PXI_TRIG6") or it can be one of 16 software triggers, from "SoftwareTrigger0" through "SoftwareTrigger15".

Triggering the exit of a WatchLoop

A WatchLoop is a pattern instruction that can execute other instructions repetitively until a trigger occurs. See Pattern.WatchLoop for a description of the WatchLoop method. The Trigger string parameter of the WatchLoop method specifies the trigger event that will cause the WatchLoop to exit. However, the Trigger parameter does not specify a trigger event directly, such as "PXI_STAR". Instead, Trigger can have one of six string values: "Trigger0", "Trigger1", "Trigger2", "Trigger 3", "Trigger4", or "Trigger5".

To specify which trigger is associated with each of the six possible Trigger strings, the six Site.Trigger<N>Source properties are used, where <N> goes from 0 to 5. See, for example, Site.Trigger0Source. The associations between the Site.Trigger<N>Source properties and the Trigger parameter of the WatchLoop method are as follows:

  • The Site.Trigger0Source property specifies the trigger associated with Trigger when it has a value of "Trigger0".
  • The Site.Trigger1Source property specifies the trigger associated with Trigger when it has a value of "Trigger1".
  • The Site.Trigger2Source property specifies the trigger associated with Trigger when it has a value of "Trigger2".
  • The Site.Trigger3Source property specifies the trigger associated with Trigger when it has a value of "Trigger3".
  • The Site.Trigger4Source property specifies the trigger associated with Trigger when it has a value of "Trigger4".
  • The Site.Trigger5Source property specifies the trigger associated with Trigger when it has a value of "Trigger5".

The Trigger<N>Source string parameter provided by the Site.Trigger<N>Source property can be one of the 12 hardware triggers listed above (such as "PXI_TRIG5"), or it can be one of 16 software triggers, from "SoftwareTrigger0" through "SoftwareTrigger15".

This indirection (first define Trigger in the WatchLoop pattern element, then define the associated Trigger<N>Source string) allows the trigger for a compiled pattern to be changed without re-compiling the pattern. In doing this, only the Trigger<N>Source string needs to be changed. The Trigger string that is compiled into the WatchLoop pattern does not need to be changed.

Example to be added...??????

Using markers

This section describes how markers are used. A marker is a pulse of programmable pulse width. In order to use a marker, its destination (the signal that produces the pulse) must be specified from among the 12 signals listed above that can be marker outputs, such as "PXIe_DSTARC".

The destination is specified by the Marker<N>Destination property, where <N> goes from 0 to 2. See, for example, Site2.Trigger0Source.

Just as triggers can be detected from within a pattern, markers are generated from within a pattern. Markers are specified by the Pattern.CrossReference method. This method inserts a CrossReference instruction in a pattern at the specified index. The Reference string of the CrossReference method can ?????

  • The Site2.Marker0Destination property specifies the marker associated with Reference when it has a value of "Marker0".
  • The Site2.Marker1Destination property specifies the marker associated with Reference when it has a value of "Marker1".
  • The Site2.Marker2Destination property specifies the marker associated with Reference when it has a value of "Marker2".

Specifying Whether a Signal is a Trigger or a Marker

The Direction property specifies whether a particular signal is a trigger input or a marker output. This property applies to GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], and PXI_STAR. See Trigger.Direction for information on this property.

Note that, if a signal is programmed to be a trigger input, you can still program its marker properties such as its pulse width – the marker properties just won’t apply until the signal is programmed to be a marker. Likewise, if a signal is programmed as a marker, you can still program its trigger properties -- the trigger properties just won’t apply until the signal is programmed to be a trigger.

Triggers and markers each have different properties except for Polarity which applies to both triggers and markers as described below. In other words, there isn’t one Polarity property for a signal when it is a trigger and a separate Polarity property when the signal is a marker. Even though there is one Polarity property, it is described separately for triggers and markers below because of how this property differently affects triggers and markers.

The hardware trigger and marker properties are listed below. While software triggers exist (such as "SoftwareTrigger5"), there is no equivalent software marker -- markers exist only in hardware.

Hardware Trigger Properties

The following hardware trigger properties can be programmed:

  • Polarity -- If Polarity is positive, the DSR will trigger on the rising edge of the trigger input signal. If negative, the DSR will trigger on the falling edge of the trigger input signal. Polarity can be programmed independently on each of the 12 DSR signals that can be used as triggers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, and PXIe_DSTARB. See Trigger.Polarity for more information.
  • ExternalTriggerThresholdLevel -– This property only applies to the GPIO1 (External1) and GPIO2 (External2) signals, and allows the trigger input threshold voltage to be programmed individually for each of these signals. See Trigger.ExternalTriggerThresholdLevel for more information.
  • ExternalTriggerTermination -– This property likewise applies only to the GPIO1 (External1) and GPIO2 (External2) signals, and allows the input termination impedance to be programmed individually for each of these signals. See Trigger.ExternalTriggerTermination for more information.

Marker Properties

The following marker properties can be programmed:

  • Polarity -- Polarity controls whether a marker pulse will go high (positive) or low (negative). Polarity can be programmed independently on each of the 12 DSR signals that can be used as markers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, and PXIe_DSTARC. See Trigger.Polarity for more information.
  • MarkerPulseWidth -– This property sets the pulse width of marker outputs. The pulse width can be programmed independently on each the 12 DSR signals that can be used as markers: GPIO1 (External1), GPIO2 (External2), PXI_TRIG[0:7], PXI_STAR, and PXIe_DSTARC. See Trigger.MarkerPulseWidth for more information.

Triggers and Markers with a Multi-module Instrument

In a multi-module instrument, triggers and markers only apply to the primary module. The secondary modules can neither respond to triggers nor generate markers. See Multi-Module Operation for further information on multi-module instruments.

Therefore, triggers and markers are not used in creating a multi-module instrument. While the use of triggers and markers might seem like a logical way to synchronize multiple modules, all of the inter-module synchronization in a multi-module instrument is performed through the front panel connectors, either the Multi-module Sync connector and optionally the Sync connector.


WaveformTables Overview

A WaveformTable defines the waveform that should be produced, or expected by the DSR when a particular waveform character is executed on a particular Signal. The waveform table name is used in the pattern to specify how each vector of the pattern should be executed.

Force events are not permitted on signals that are defined as DUT outputs (Direction is Out).

Compare events are not permitted on signals that are defined as DUT inputs (Direction is In).

Since the waveform character will generally correspond to a stimulus such as a '0' or '1' from the DSR, it is appropriate to look at the waveform table as a description of how to produce a '0' or '1'. Since waveform characters also specify expected values from the DUT, the waveform table also describes how a response from the DUT should be clocked to determine the logic value of the response, and the expected value of the response.

The following is an example of information in a waveform table:

WaveformCharacter | Signals defined | Times of events | Events
'0' | Signal1 | 20e-9 | ForceDown
'1' | Signal1 | 20e-9 | ForceUp
'H' | Signal1 | 80e-9 | CompareHigh
'L' | Signal1 | 80e-9 | CompareLow
'Q' | Data[0..7] | 0, 50e-9 | ForceLow, ForceHigh

Some notes on the example in the above table:

  • The first four lines of the example show how a single signal may have four different waveform characters defined (0, 1, H, L). Conventional definitions for 0, 1 , H, and L are given.
  • The final line of the table (Q) shows how a group of signals can all be defined to have the same waveforms. This example also shows that when the Q character is in the input pattern for Data[0..7], two force events are acted on: the signal is forced low at time 0 and is then forced high at 50 nanoseconds.
  • Based on this waveform table alone, the pattern could use the Q character only on the Data[0..7] signals and the 0, 1, L, and H characters on Signal1.

The WaveformTable also contains the Period, which is another key piece of information. Every waveform character in a given waveform table is executed with the same period. Patterns that require changing the period dynamically do so by defining additional waveform table for each different signal period.

WaveformTables is one of the STIL Components. As with all STIL components, they can be created using the IVI API, or by loading a file in one of the file formats supported by the DSR software.

See also Edge Placement Resolution and STIL Components.


Related Documentation

The documentation listed below can be found on the M9195 Software and Product Information CD that came with your module.

Product specifications, available accessories, firmware and software may change over time. Please check the Keysight website at www.keysight.com/find/M9195B for the latest updates to the product software, Guides, Help files and Data Sheets.

  • M9195A/B Digital Stimulus/Response Startup Guide. Provided in print for with each new module, this manual is also provided in PDF on the Software and Product Information CD and on the web.
  • M9195A/B Digital Stimulus/Response User Guide. This manual is provided in PDF on the Software and Product Information CD and on the web.
  • Help file for the Keysight M9195A/B IVI-C and IVI-COM device drivers. The interactive help provides instruction for programming the module using Microsoft development environments.
  • Help file for the Keysight M9195A/B LabVIEW G device drivers. The interactive help provides instruction and reference materials for programming the module using National Instruments LabVIEW(TM).
  • Keysight M9195A/B Data Sheet. The Data Sheet contains complete physical and electrical specifications for the module.


Calibration Overview

The KtMDsr Calibration interface contains functions and attributes used to calibrate the PPMU measurements.

Initially, the module calibration fixture must be attached to the module. However, to complete the calibration the fixture must be removed before EndCalibration is called.

As part of the calibration process, precise current and voltage measurements must be made external to the instrument and provided back to the calibration software via the functions defined in this interface.

The calibration must be performed in the following order:

  1. Run Calibration Begin Calibration
  2. Calibrate each voltage range by completing the following three steps for each of the five voltage ranges:

    > Run Calibration Set Up Voltage to configure the module to output the high voltage level and measure the voltage externally.

    > Run Calibration Set Up Voltage to configure the module to output the low voltage level and measure the voltage externally.

    > Run Calibration Compute VoltageCorrection, passing it the voltages measured externally at the low and high settings.

  3. Calibrate each current range by completing the following two steps for each of the two current ranges:

    > Run Calibration Set Up Current to configure the module to output the current and measure the current externally.

    > Run Calibration Compute Current Correction, passing it the current measured externally.

  4. Disconnect the calibration fixture and run Calibration End Calibration to complete the calibration and store the calibration settings.

If any step of the process fails, no new calibration information is stored and the calibration settings revert to the settings that were active when the calibration was initiated.


Calibration VIs

Calibration Abort

Calibration Begin Calibration

Calibration Compute Current Correction

Calibration Compute VoltageCorrection

Calibration End Calibration

Calibration Set Up Current

Calibration Set Up Voltage

Calibration Set Use Fixture


Enums

The following enumerators are used in this driver.

Member name | Value | Description | Where Used
CalibrationCurrentRange | Minimum = 0x00000000 Maximum = 0x00000001 |  |
CalibrationLow/High | Low = 0x00000000 High = 0x00000001 |  |
CalibrationVoltageRange10p24 CalibrationVoltageRange5p12 CalibrationVoltageRange2p56 CalibrationVoltageRange0p64 CalibrationVoltageRange20p48 | 10p24 = 0x00000001 5p12 = 0x00000002 2p56 = 0x00000003 0p64 = 0x00000005 0p48 = 0x00000007 |  |
DcLevelIOH DcLevelIOL DcLevelVIT DcLevelVCOM DcLevelVHH DcLevelVIH DcLevelVIL DcLevelVOH DcLevelVOL DcLevelHYST | 0x00000000 0x00000001 0x00000002 0x00000003 0x00000004 0x00000005 0x00000006 0x00000007 0x00000008 0x00000009 | This is the current output by the active load when the input voltage is over the commutation voltage (VCOM). It is used with IOL and VCOM to configure the active load. |


Introduction

The instrument driver provides access to the functionality of the Keysight M9195A Digital Stimulus/Response (DSR) module from National Instruments LabVIEW software.

Related Documentation

The following are related user documentation related to the module:

M9195A DSR Startup Guide -- See the M9195A Software and Product Information CD or check on the web.

M9195A User Guide --Provides configuration, setuip and use information for the module. See the User Guide on the M9195A Software and Product Information CD.

Web information on the module: www.keysight.com/find/M9195A.

More Information

For more information about this driver and other instrument drivers and software available from Keysight Technologies visit: www.keysight.com/find/drivers

A list of contact information is available from: www.keysight.com/find/assist


LabVIEW Reference for M9195A Methods

This topic provides an alphabetic listing of all methods.

LabVIEW VI Name | Description
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????
????? | ?????


Logic Family Enumeration

Member Name | Value | Description
KtMDsrDcLevelsLogicFamilyLVCMOS_1_2 | 0x00000000 | 1.2 V Low Voltage CMOS
KtMDsrDcLevelsLogicFamilyLVCMOS_1_8 | 0x00000001 | 1.8 V Low Voltage CMOS
KtMDsrDcLevelsLogicFamilyLVCMOS_2_5 | 0x00000002 | 2.5 V Low Voltage CMOS
MDsrDcLevelsLogicFamilyCMOS_5 | 0x00000003 | 5 V CMOS
KtMDsrDcLevelsLogicFamilyTTL | 0x00000004 | 5 V Transistor-Transistor Logic
KtMDsrDcLevelsLogicFamilyLVTTL | 0x00000005 | 3.3 V Low Voltage Transistor-Transistor Logic
KtMDsrDcLevelsLogicFamilyLVDS | 0x00000006 |
KtMDsrDcLevelsLogicFamilyCustom | 0x00000007 | The DSR sets DcLevel logic family to CUSTOM whenever the DcLevels are not set to a specific logic family. That is, when SetDcLevels or SetDcLevel is called, or a STIL file is loaded, or an OpenXML file does not specify a logic family.
KtMDsrDcLevelsLogicFamilyPECL | 0x00000008 | Positive Emitter Coupled Logic


Dynamic Repeated Capabilities

Instruments often contain multiple instances of the same kind of functionality or capability. For instance, modern oscilloscopes may have multiple channels, each with independent settings for things such as vertical scale and input attenuation. IVI refers to this type of functionality that is duplicated in an instrument as a repeated capability.

If the content of the repeated capability is dynamically changed, then the repeated capability is referred to as a dynamic repeated capability. In the example of the oscilloscope, this would be an oscilloscope where the number of channels is determined dynamically, perhaps by plugging in hardware for additional channels. The KtMDsr driver has numerous dynamic repeated capabilities both for managing the various building blocks of patterns and for managing the way that the various DSR channels are used.

In the IVI-COM driver, each repeated capability is made up of two interfaces, one within the other. The higher level interface represents the complete collection of repeated capabilities. This interface is designated with a plural noun such as Signals. Functions and attributes within this interface are generally concerned with manipulating the collection.

The inner interface represents the repeated capability; therefore, functions and attributes within this interface are focused on manipulating the repeated capability itself. This interface is designated with a singular noun such as Signal or MySignal.

Example:

var myDsr = new KtMDsr();

myDsr.Signals.Add("MySignal");

my.Dsr.Signals.Item["MySignal"].Direction = KtMDsrSignalDirectionEnum.KtMDsrSignalDirectionInOut;

There are two types of repeated capabilities in the DSR:

STIL Components | These repeated capabilities are used to define all the building blocks in a digital test. They can be defined directly from the API, or they can be created by loading a pattern file in STIL or OpenXML format. See STIL Components for more information.
Active Sites | These repeated capabilities are used to act on a physical site on the DSR. This includes executing a pattern, doing PPMU measurements, or doing bit-oriented manipulation of individual digital channels. See Active Sites for more information.

All KtMDsr repeated capabilities have these functions:

Add or Activate

Adds a new instance of a repeated capability. For instance, this could be used to add a new signal to the signals collection. The STIL components all have Add functions.

Activate is also used to add a new instance of the repeated capability; however, it uses an existing site definition to do so. Therefore the specified site is activated for use to do the operations on the specified site. The active site repeated capabilities all have Activate functions.

Count | This attribute contains the number of instances of the repeated capability that have been defined. This is primarily useful for discovering the repeated capabilities in the driver. Perhaps after loading a STIL or OpenXML file.
Name | This attribute gets the name of a repeated capability at a given index. By reading the Count attribute, and calling name for each defined Index, a client can discover all the repeated capabilities defined.
Remove or Inactivate

This function removes a repeated capability of the given name. This frees up memory and other resources associated with the repeated capability.

The Active sites use Inactivate or InactivateAndDisable instead of Remove. With Inactivate, once a site is inactivated, the channels in the site retain the level they had; however, the site can no longer be used for the operations for which it was initially activated -- until it is activated again. InactivateAndDisable takes the further step of disabling all of the channels.

Item(Name)

The Item function provides access to the actual capability. The Item function returns an instance of the repeated capability. For IVI-COM, this is an object that has methods defined to read and write settings associated with that instance, or to do work with that instance.

The repeated capability is defined with a plural noun (for instance, Signals ). The Item function takes the name of a particular member of that collection and returns it. The type of this returned item is the singular form of the noun (for example, Signal). For instance, the Signals repeated capability has an Item function that returns a Signal object, which has Direction defined for the Signal. The Signal Direction is always relative to the DUT.

Item.Name

This attribute is defined on the repeated capability itself. This provides a way to get the name of this repeated capability. Thus, you pass the name to Item to get the repeated capability. Then you can check the Name attribute in the repeated capability to get that same name back again.

This is useful when the repeated capability has been passed to some operation that works with the repeated capability without access to its name. The Name function allows that client code to delete (or otherwise manipulate) the repeated capability without the context of how it was acquired.


SUBVIs

SubVI_Calc_Int_result

SubVI_RFFE_Reg0Write

SubVI_RFFE_RegRead

SubVI_RFFE_RegReadWithResult

SubVI_RFFE_RegWrite

SubVI_SerialIO_Read_With_Result

SubVI_SerialIO_Write

SubVI_SPI_Read

SubVI_SPI_Write


Name of VI (filename = KtM9xxx_NameOfVI.htm)

Generic_Intro:
VI description overview text. The information below is a sample of content. Paste the new Input and Output content into the Input and Output sections, but keep the "Instrument handle in and error in" and "Instrument handle out and error out" drop-down boilerplate content. Use what you need from the Image library list and I/O type samples, and delete that section when you're done.

Supported Models: XXXX, YYYY, ZZZZ

GetAttribute_Intro_Template:
Gets a <type> attribute. This provides a way to read back values that are set with either high-level configure VIs or the related SetAttribute VI.

SetAttribute_Intro_Template:
Sets a <type> attribute. Attributes provide low-level access to parameters that are either included in higher level configure VIs or adjust low-level instrument settings.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

<<Add input functions here. Use the fodder below (and the export from the LabVIEW VIs) as building blocks.>>

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

<<Add output functions here. Use the fodder below (and the export from the LabVIEW VIs) as building blocks.>>

Fodder for filling in the topics:

Input icons |
 | icon_IO_in.png
 | icon_Error_in.png
 | icon_TF_in.png
 | icon_I32_in.png
 | icon_abc.in.png
 | icon_DBL_in.png
 | icon_U32_in.png
Output icons |
 | icon_IO_out.png
 | icon_Error_out.png
 | icon_TF_out.png
 | icon_I32_out.png
 | icon_abc_out.png
 | icon_DBL_out.png
 | icon_U32_out.png

Title

BucketToFill.

Title

BucketToFillEspeciallyForAttributeLists:

  • List item A
  • List item B

Title

BucketToFill.

ColumnA | ColumnB | ColumnC | ColumnD
item1ColumnA | item1ColumnB | item1ColumnB | item1ColumnB
item2ColumnA | item2ColumnB | item2ColumnB | item2ColumnB
item3ColumnA | item3ColumnB | item3ColumnB | item3ColumnB

Title

Powers

An array of doubles with the list of powers in dBm, one per list point.

Numeric

See Also:
  • Close (inherent driver VI overview)
  • Disable (inherent driver VI overview)
  • Error Message (inherent driver VI overview)
  • Error-Query (inherent driver VI overview)
  • Initialize (inherent driver VI overview)
  • Initialize With Options (inherent driver VI overview)
  • Reset (inherent driver VI overview)
  • Reset With Defaults (inherent driver VI overview)
  • Revision Query (inherent driver VI overview)
  • Self-Test (inherent driver VI overview)

Table (blank)

Column A | Column B | Column C
Item A1 | Item B1 | Item C1
Item A2 | Item B2 | Item C2
Item A3 | Item B3 | Item C3
Item A4 | Item B4 | Item C4

Notes in the body of a VI description

This is a note statement. Use the p.Note style for this paragraph in your content. The DDS requires a graphic at the beginning, so use the note.png file.

This is a caution statement. Use the p.Caution style for this paragraph in your content. The DDS requires a graphic at the beginning, so use the caution.png file.

This is a warning statement. Use the p.Warning style for this paragraph in your content. The DDS requires a graphic at the beginning, so use the warning.png file.


Front Panel Connector Pinout

???????Delete this text and replace it with your own content.

Latch/GND | Pin # | Pin # | Latch/GND
GND | 59 | 60 | CH03
CH00 | 57 | 58 | GND
GND | 55 | 56 | CH01
CH02 | 53 | 54 | GND
GND | 51 | 52 | CH07
CH06 | 49 | 50 | GND
GND | 47 | 48 | CH05
CH04 | 45 | 46 | GND
GND | 43 | 44 | HV22
HV23 | 41 | 42 | GND
GND | 39 | 40 | HV21
HV20 | 37 | 38 | GND
GND | 35 | 36 | CH11
CH10 | 33 | 34 | GND
GND | 31 | 32 | CH09
CH08 | 29 | 30 | GND
GND | 27 | 28 | CH13
CH12 | 25 | 26 | GND
GND | 23 | 24 | CH15
CH14 | 21 | 22 | GND_SENSE
PPMU_Sense14 | 19 | 20 | PPMU_Sense12
PPMU_Sense15 | 17 | 18 | PPMU_Sense13
PPMU_Sense10 | 15 | 16 | PPMU_Sense11
PPMU_Sense08 | 13 | 14 | PPMU_Sense09
Open Drain 0 | 11 | 12 | Open Drain 2
Open Drain 1 | 9 | 10 | Open Drain 3
PPMU_Sense05 | 7 | 8 | PPMU_Sense06
PPMU_Sense04 | 5 | 6 | PPMU_Sense07
PPMU_Sense02 | 3 | 4 | PPMU_Sense01
PPMU_Sense03 | 1 | 2 | PPMU_Sense00
Latch/GND |  |  | Latch/GND


M9195A at a Glance

The Keysight M9195A is a single slot PXIe 250 MHz Digital Stimulus/Response PXIe module. It provides 16 bidrectional I/O channels, each with Pin Parametric Measurement Unit (PPMU); four high voltage lines for flash programming; and four open-drain lines for relay control. This Startup Guide provides detailed instructions for receiving and installing the module and cable(s) comprising the M9195A. Additionally, installing required software is documented.

??? Front Panel Photo with callouts ???

M9195A Features

Flexible Waveform Creation:

  • 32 waveform tables, 16 pattern characters used for flexible, on-the-fly, per vector waveform definition
  • Deep per channel pattern memory. Up to 125 M patterns
  • Digital real-time compare for serial or parallel patterns
  • Deep pattern capture for non-deterministic digital response
  • Flexible pattern sequencing: looping, goto, pause, SW advance, conditional pattern matching

Per Channel Features:

  • Programmable logic levels: –1.5 V to +6.5 V, ±2 mA to ±40 mA
  • Four Quadrant source PMU
  • Independent control of each channel
  • 100 pS programmable delay up to 1mS full range (12 pS resolution)
  • 1 nS edge placement resolution

Programming Tools

  • Standard Test Interface Language (STIL, IEEE 1450)
  • IVI-COM, I VI-C, LabVIEW G drivers
  • Open XML
  • Soft Front Panel (SFP)

Status LED

The M9195A has a Status LED on the front panel. In general, when the Status LEd is solid green (not flashing) the module is working correctly. Refer to the M9195A Service Guide for additional details. The following table lists the states (colors) of the Status LED.

LED Color | Description
Solid Green | Power OK Self-test passed Gateware Loaded Module Temp OK
Solid Blue | ?????
Solid Red | Module failure (i.e. self test failed ?????

Additional Information on the M9195A

  • Module Accessories
  • Module Block Diagram
  • Front Panel Connector Pinout
  • Operational Modes

© Keysight Technologies, Inc. 2014 - 2018

Version 2.1 January 2018


Operational Modes

Delete this text and replace it with your own content. ??????


Calibration Abort

Aborts the calibration procedure, discards any computed calibration constants, and reverts to the previous calibration constants.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This function is used to abandon a calibration that is already in process. No values are stored, and the module reverts to the values from before the calibration.

For more information on the Calibration interface, see the Calibration Overview.


Calibration Begin Calibration

Starts calibration process.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This is the first step in the calibration process. This function verifies that the calibration fixture is attached and that the module is not currently being used for anything else.

For more information on the overall calibration process, see the Calibration Overview.


Calibration Compute Current Correction

Indicates the externally measured current that was produced with SetUpCurrent at a given range. The driver then computes the corresponding correction.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Measured Current

The current measured externally with the SetupCurrent at the appropriate range.

Calibration Current Range (MINIMUM)

Current Range to use during Calibration.

MINIMUM : Minimum Calibration current range.

MAXIMUM : Maximum Calibration current range.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The third step of calibration is to calibrate the current ranges. The ComputeCurrentCorrection VI along with the SetupCurrent VI is used to do this calibration.

The currents are calibrated by setting up every current range using the Calibration Set Up Current VI, then using ComputeCurrentCorrection at each setting and specifying the externally measured current.

Every current range must be set up and measured for the calibration to be successful.

For a complete description of the calibration process, see the Calibration Overview.


Calibration Compute VoltageCorrection

Indicates the externally measured current that was produced with SetUpCurrent at a given range. The driver then computes the corresponding correction.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

HighMeasuredVoltage

The voltage measured externally with the Setup Voltage Programmed to High at the appropriate range.

LowMeasuredVoltage

The voltage measured externally with the Setup Voltage Programmed to Low at the appropriate range.

Calibration Voltage Range (10p24)

The range that is being calibrated. Select which Voltage range to use during Calibration.

10p24 : 10.24V

5p12 : 5.12V

2p56 : 2.56V

0p64 : 0.64V

20p48 : 20.48V

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The second step of calibration is to calibrate the voltages. The ComputeVoltageCorrection VI along with the Calibration Set Up Voltage are used to do this calibration.

The voltages are calibrated by setting up every voltage range for a high and and low voltage calibration using the Calibration Set Up Voltage VI, then running the ComputeVoltageCorrection VI at each setting and specifying the externally measured voltage.

Every voltage range must be setup and measured, both with a high setting and a low setting for the calibration to be successful.

For a complete description of the calibration process, see the Calibration Overview.


Calibration End Calibration

Completes the calibration process, and stores the calibration data to module memory. The calibration fixture must be disconnected before calling this function.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

EndCalibration is the fourth and final step in the calibration process. If the calibration completes successfully, the calibration values are stored to non-volatile memory on the module.

The calibration fixture must be disconnected before calling this function.

For a complete description of the calibration process, see the Calibration Overview


Calibration Set Up Current

Configures the instrument to output a current to be externally measured as part of calibration. The parameters indicate the value that the module should output.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

CalibrationCurrentRange (MINIMUM)

Current range to use during Calibration.

Minimum: Minimum Calibration current range.

Maximum: Maximum Calibration current range.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The third step of calibration is to calibrate the ranges for current. The SetupCurrent function is called to indicate to the module that it should output the current to calibrate the specified range.

The measured current is returned to the calibration algorithm as a parameter to Calibration Compute Current Correction function.

Every current range must be calibrated for the calibration to be successful.

For a complete description of the calibration process, see the Calibration Overview.


Calibration Set Up Voltage

Configures the instrument to output a voltage to be externally measured as part of calibration. The parameters indicate the value that the module should output.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

HighLow (LOW)

Specifies whether this is the high calibration point or the low calibration point.

CalibrationVoltageRange (10p24)

Specfies the voltage range to calibrate.

10p24 :10.24 V

5p12 : 5.12 V

2p56 : 2.56 V

0p64 : 0.64 V

20p48 : 20.48 V

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

The second step of calibration is to calibrate the voltage ranges. The SetupVoltage VI is used twice, once to get the module to output the low voltage and again to output the high voltage.

The two voltages that are output are provided to the calibration algorithm as parameters to the Calibration Compute VoltageCorrection VI.

Every voltage range must be calibrated for the calibration to be successful.

For a complete description of the calibration process, see the Calibration Overview


Calibration Set Use Fixture

Indicates whether the Calibration will be performed with the factory-provided fixture.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.
True indicates that the Calibration operations should verify presence of the fixture and switch the relay on the fixture for Voltage or Current calibration. If this Boolean is set: Any calibration operation will verify the fixture is attached or not as it expects and throw an exception if it is not what it expects. By default this will be true. Must be set before calibration begins. This is not checked if the fixture is changed after calibration begins..

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

This controls if the calibration algorithm should verify the presence of the available Keysight calibration fixture.

Using the DSR without the fixture requires external circuitry and should be attempted only with assistance from Keysight.

For a complete description of the calibration process, see the Calibration Overview.


Module Nonvolatile Clear

Clears/discards any changes to cached values and resets cached values to the current nonvolatile settings.

Keysight MDsr.lvlib:Module Nonvolatile Clear.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr

Module

The name of the Module. See the ‘Modules Get Name’ in Action/Status section of menu to obtain the valid names.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Module Nonvolatile Write

Writes all cached values from the System.Nonvolatile.Item interface to nonvolatile memory. If certain values have changed (see below) the current Passphrase must be supplied to Write.

Keysight MDsr.lvlib:Module Nonvolatile Write.vi

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cstr | Module The name of the Module. See the ‘Modules Get Name’ in Action/Status section of menu to obtain the valid names.

cstr

Passphrase

Passphrase used to protect certain values in Nonvolatile. If none of these values have changed, this parameter is ignored.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Remarks

Please note that the physical hardware supports a limited number of write cycles so the number of changes to Nonvolatile properties and calls to Write should be minimized. If any of the following values have changed, the current Passphrase value must be specified. The values protected by Passphrase are

  • EnablePeriodicCalChecks
  • EnableModuleCalWarnings
  • EnableInstrumentCalWarnings
  • ModuleCalInterval
  • InstrumentCalInterval
  • Passphrase


PatternExecs Get Name

Returns the patternexec name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the PATTERNEXECS_COUNT attribute, which is read by using the GetAttributeViInt32 located in the ‘Low Level Configure’ section of the menu.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the PatternExec interface, see the PatternExec Overview

For more information on the dynamic repeated capability Add function, see Dynamic Repeated Capabilities .


PatternSite Fetch Trinary Result Segment

Returns an array of captured results. The 32 bits for each element contain two bits for each ordinal (0 - 15); this indicates the actual state of the DUT response on logged compares.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

PatternSite

The name of the PatternSite. See PatternSites Get Name VI in Action/Status section of menu to obtain valid names

Offset (0)

The offset of the first element returned within the segment.

Count (1)

The number of elements to return in the segment.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Val

Result data from the pattern execution.

Numeric

ValActualSize

Actual number of Results.

Remarks

The ordinal is multiplied by 2, so that two bits are available for each signal/pin. The bit values are mapped as follows:

Value | Indicates
00 | No Compare or No failure.
01 | Failed Low
02 | Failed, electrical state between high and low
03 | Failed High

Result may contain all compares, only compares with failures, or the first failure, based on the setting of the WhatToLog attribute.

If an ordinal is 16 or higher, this function generates an error.

Bits in the result that are either not defined in the site specification or are assigned to a signal that is defined as a DUT input (Direction is In) are 0.

For more information on the PatternSites interface, see the PatternSites Overview.


PpmuSites Get Name

Returns the ppmusite name that corresponds to the one-based index that the user specifies.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that defines which name to return. The number of available names is contained in the PPMUSites_Count attribute, which is read by using the GetAttributeViInt32

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

Specifies the buffer into which the VI returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.

Remarks

For more information on the PpmuSites interface, see the PpmuSites Overview.

For more information on the dynamic repeated capability Activate function, see Dynamic Repeated Capabilities .

For general information on using active sites, see Active Sites


SubVI_Calc_Int_result

--SUB_VI-- This sub VI expects a result array with 9 elements in it verifies the parity (last bit) and returns the actual result.

Inputs

Closed Error in

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

c1di16

MyResult

    ci16

            Numeric

Outputs

ii32

iResult

ibool

Parity fault

ibool

Length Fault
Closed Error out

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SubVI_RFFE_Reg0Write

--SUB_VI-- This sub VI adds extended register I/O write. Register 0 Write per MIPI Spec.

Pattern = "010" + SA[3:0] + "1" + Data[6:0] + OddParitybit BusPark.

Example Register Write: 010 1111 1 0111000 0 B.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

SAAddr

ci32

Data

cstr

Site

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SubVI_RFFE_RegRead

--SUB_VI-- This sub VI performs Register Read per MIPI Spec.

Pattern SSC + SA3-SA0 + "011" + A[4:0] + OddParitybit1 + BusPark + Databyte + OddParityBit2 + BusPark.

Example Register Write: 010 1111 011 000001 0 LLLLLHLLL L B.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

SAAddr

ci32

Addr

ci32

Expected Result

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ibool

Execution Result

If True at least 1 failure was logged.


SubVI_RFFE_RegReadWithResult

--SUB_VI-- This sub VI performs Register Read per MIPI Spec.

Pattern SSC + SA3-SA0 + "011" + A[4:0] + OddParitybit1 + BusPark + Databyte + OddParityBit2 + BusPark.

Example Register Write: 010 1111 011 000001 0 LLLLLHLLL L B.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

Addr

ci32

SAAddr

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

i1di16

Val

Result data from the pattern execution.

    ii16

            Numeric

ibool

Execution Result

If True at least 1 failure was logged.


SubVI_RFFE_RegWrite

--SUB_VI-- This sub VI performs RFFE routines to construct and initiate commands using set signal.

Pattern SSC + SA3-SA0 + "010" + A4-A0 + OddParitybit + Databyte + OddParityBit + BusPark.

Example Register Write: 010 1111 010 11100 1 00111000 0 B.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

SAAddr

ci32

Addr

ci32

Data

cstr

Site

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SubVI_SerialIO_Read_With_Result

--SUB_VI-- This sub VI performs Register Read per MIPI Spec.

Pattern SSC + SA3-SA0 + "011" + A[4:0] + OddParitybit1 + BusPark + Databyte + OddParityBit2 + BusPark.

Example Register Read (L is expected results fields): 010 1111 011 000001 0 LLLLLLLLL L B.

Steps :

1) Build up RFFE command fields.

2) Modfiy SCLK to match length of command.

3) Clear out unused bits.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

SAAddr

ci32

Addr

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

i1di16

Val

Result data from the pattern execution.

    ii16

            Numeric


SubVI_SerialIO_Write

--SUB_VI-- This sub VI performs Routines for support of SerialIO examples using Set Signal.

Steps:

1) Construct RFFE command field and parity.

2) Construct RFFE Address field and parity.

3) Modfiy SCLK to match length of command.

4) Clear out unused bits.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

SAAddr

ci32

Addr

ci32

Data

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


SubVI_SPI_Read

--SUB_VI-- This sub VI performs SPI Write based on 8 bit address and 8 bit data.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

ci32

Addr

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

i1di16

Val

Result data from the pattern execution.

    ii16

            Numeric


SubVI_SPI_Write

--SUB_VI-- This sub VI performs SPI Read based on 8 bit address and 8 bit Data.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

cu16

Addr

cu16

Data

cstr

PatternSite

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single patternsite.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


System Licensing Get Host Identifier

The unique key identifying the system controller for licensing purposes. Also called HostID.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

HostIdentifier

The unique key identifying the system controller for licensing purposes. Also called HostID.


System Licensing Get Installed Licenses

A semicolon-separated list of the software licenses installed on the system controller. Each software license consists of a comma-separated Feature Name and Description.

Inputs

Closed Instrument handle in and error in

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

Closed Instrument handle out and error out

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    status

    The status boolean is either TRUE ( [image] ) for an error, or FALSE ( [image] ) for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

InstalledLicenses

A semicolon-separated list of the software licenses installed on the system controller. Each software license consists of a comma-separated Feature Name and Description.