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Data Analysis and Data Output 
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 Listing All Marker Values in All Displayed Traces 

Other topics about Data Analysis 

About Marker Functions 

The marker can be used in the following ways: 

  Reading a measured value as numerical data (as an absolute value or a 
relative value from the reference point) 

  Moving the marker to a specific point on the trace (marker search) 

  Using the value of the marker to change the stimulus (sweep range) and 
scale (value of the reference line) 

For more information, refer to Searching for Positions that Match Specified 
Criteria. 

For the procedure used to change the sweep range and scale by using the 
marker, refer to Specifying Sweep Range by Using Marker. 

The E5052B is capable of displaying up to 10 markers (10 normal markers or 9 
normal markers and 1 reference marker) on each trace. Each marker has a 
stimulus value (the value on the X-Axis) and a response value (the value on the 
Y-Axis). 
  

Reading Values on Trace 

You can read the value of a marker displayed on the trace. 

You can set the marker for the selected measurement window. 

The marker response value is always in the same data format as that of the Y-
Axis. 

Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker. At this point, marker 1 is turned on and becomes active (you 
can operate the marker). When using marker 1, you can omit Step3. 

3. Select a marker and turn it on. The softkey used to turn on a marker is 
used to activate that marker. 

Softkey Function 

Marker 1 Turns on marker 1, which has been turned off; 
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activates marker 1 

Marker 2 Turns on marker 2, which has been turned off; 
activates marker 2 

Marker 3 Turns on marker 3, which has been turned off; 
activates marker 3 

Marker 4 Turns on marker 4, which has been turned off; 
activates marker 4 

:   

Marker 
10 

Turns on marker 10, which has been turned off; 
activates marker 10 

4.   

5. Change the marker value in the entry area. This operation enables you to 
move the marker to a point on the desired trace. 
 
The marker value in the entry area can be changed by one of the following 
methods. 

 To change the value in the entry area, the figure in the box 
should be highlighted. If the figure is not highlighted, press the 
softkey for the marker you are using (marker 1 to marker 10) or 
Focus to highlight the figure. 

 Enter a numeric value using the ENTRY block key on the front panel. 

 Turn the rotary knob  on the front panel. 

 Press the up or down arrow key  ( ) on the front panel. 

 Using the mouse, click one of the buttons (  ) on the right side of 
the entry area. 

You can move the marker by dragging and dropping either one of the marker 
position pointers above or below the graph (  ) (pressing the button on the 
object to be moved and releasing the button on the destination). You can also 
move a marker itself by dragging and dropping it. 

5. When using other markers, repeat Step3 and Step4. 
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Read the marker stimulus value and marker response value displayed in the 
upper part of the trace screen. 

To turn off marker(s), press the Clear Marker Menu and then select the desired 
softkeys. 

Softkey Function 

All OFF Turns off all markers on active trace 

Marker 1 to Marker 
10 

Turns off one of markers 1 through 10 on active 
trace 

Changing Display Position of Marker Value	

You can change the display position of the marker value on the graph. 
Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Display. 

3. Press Marker Information to change the display position. 

Softkey Function 

Left Displays marker value in upper-left part of graph 

Right Displays marker value in upper-right part of graph 

You can also view the marker values in a list. For more information, refer to 
Listing All Marker Values in All Displayed Traces. 
  

Specifying Sweep Range by Using Marker 

You can copy the active marker value to the position of start, stop or center. If 
multiple markers are present on the active trace, only the active marker can be 
moved. 

For TR Measurement: Marker to Target Frequency and Phase reference can be 
set using Marker --> > Marker -> Target Freq (or N2 Target Freq)and Marker --> > 
Marker -> Phase Reference (or N2 Phase Reference). For more information on phase 
reference, refer to Using the phase reference frequency. 

 For AM / BB / PN / PS Measurement: An additional marker option 
is available at Marker --> > Marker -> Omit Spur. 
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It is recommended to use this function with the Discrete value ON as:  
Marker > More functions > Discrete > ON. When it is used this function 
with Discrete > Off, it is possible to specify the frequency data that is 
not effective at omit of the specific Spurious. 
 
In Omit Spur option, when X-axis data of Spurious List is not within 
the X-axis for Trace Data, the data equivalent to outside of scope is 
ignored. For information on Omit Spur, refer to Setting Omit Specified 
Spur. 

Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker -->. 

3. Press the corresponding softkey to specify the sweep range. 

Softkey Function 

Marker to 
Start 

Changes start value to be equal to stimulus value of 
active marker on current active trace 

Marker to 
Stop 

Changes stop value to be equal to stimulus value of 
active marker on current active trace 

Marker to 
Center 

Changes center value to be equal to stimulus value of 
active marker on current active trace 

4.   

  
  

Reading Relative Value From Reference Point on Trace 

You can convert the marker reading to a relative value from the reference point. 



294 

Reference Marker Mode 

 
Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker. 

3. Press More functions . 

4. Press Ref Marker to specify the reference marker (Marker 1 through 10). 
 
By default, marker 1 is set as the reference marker. 

5. Press Ref Marker Mode to turn on the reference mode. 
 
Activate the reference marker if it is not active. 
 
With the reference mode turned on, the stimulus values and response values 
are indicated in relative values referred to by the position of the reference 
marker. 

 While the reference marker mode is turned on, you cannot view 
the relative value from the reference point unless the delta marker 
mode is set to ‘ON’. 

Following Step4 in Reading Values on Trace, place the reference marker on the 
point to be used as the reference. 

Following Step3 to Step4 in Reading Values on Trace, place markers 1 through 10 
on the desired points to read the values. 
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To use the list view of the marker values, refer to Listing All Marker Values in All 
Displayed Traces. 
  

Reading Only Actual Measurement Point/Reading Value Interpolated 
Between Measurement Points 

The point on the trace on which a marker can be placed differs depending on how 
the discrete marker mode is set up. 

Setting Description 

Turning on 
discrete 
mode 
(Discrete 

ON) 

A marker moves only between actual measurement points. 
When a specific marker stimulus value is specified as a 
numerical value, the marker is placed at the measurement 
point closest to the specified value. A marker that is placed 
between interpolated points with the discrete mode off 
automatically moves to the nearest measurement point when 
the discrete mode turns on. 

Turning off 
discrete 
mode 
(Discrete 

OFF) 

The marker can move from one actual measurement point to 
another. Because it is interpolated, it can also move in the 
space between measurement points. 

  

Marker Discrete Mode 
Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker. 

3. Press More functions. 

4. Press Discrete to turn the discrete mode ON or OFF. 
  

Setting Up Markers for Each Trace/Setting up Markers for Coupled 
Operations Between Traces 

Markers can be set up and moved either in a coupled operation for all traces in a 
channel or independently for each trace. 

You can set up marker coupling for frequency/power measurement, transient 
measurement and the user window. 
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Marker Coupling 
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Setting Description 

Marker Couple 
is on 
(Couple ON) 

Markers are set up and moved in coupled operation on all 
traces in a channel. 

Marker Couple 
is off 
(Couple OFF) 

Markers are set up and moved independently for each 
trace. 

Operational Procedure	

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker. 

3. Press Couple to turn the marker coupling on or off. 

 For the transient measurement, both the marker coupling 
(Couple) and the marker discrete mode are turned on, where the 
active marker on the active trace operates in the discrete mode; 
however, the other subsequent markers are not always on the 
measurement point, since they are coupled with the value. 

Listing All Marker Values in All Displayed Traces 

You can list all of the marker values for all traces on the marker list display. 
Operational Procedure 

1. Press Marker. 

2. Press Marker List to turn on the marker list display. 
 
The marker list is displayed in the lower part of the screen as shown in the 
following figure. 
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Turning on Marker List 

 

Searching for Positions that Match Specified Criteria 

 Overview 

 Setting Search Range (Bandmarkers) 

 Searching in Specified Range 

 Setting up Bandmarker for Each Trace Setting up Markers for Coupled 
Operations Between Traces 

 Automatically executing search each time Sweep is done (search tracking) 

 Searching for Maximum and Minimum Measured Values 

 Searching for Target value 

 Searching for Peak 

 Searching for Multiple Peaks 
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 Searching for Spurious 

 Searching for Multiple Spurious 

Other topics about Data Analysis 

Overview 

You can search for a position that matches your specified criteria by using the 
Marker Search feature. 

Marker Search allows you to search for a position that matches the following 
criteria: 

 Maximum value 

  Minimum value 

 Target (a point that has a target measurement value) 

 Target nearest to marker position 
 Target nearest to left-hand side of marker position 
 Target nearest to right-hand side of marker position 

  Peak 

   Maximum peak (for a positive peak), minimum peak (for a negative 
peak) 

   Peak nearest to left-hand side of marker position 
   Peak nearest to right-hand side of marker position 

 Spurious 

 Spurious nearest to left-hand side of marker position 

 Spurious nearest to right-hand side of marker position 

Setting Search Range (Bandmarkers) 

The Marker Search feature allows you to set part of the sweep range as the 
search target (Bandmarker feature) as well as the entire search range. 

Procedure to Set Search Range 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker Fctn (or press Marker Search). 

3. To set the search range for the X-Axis, turn on Bandmarker X. 
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4. Set the search range using X start, X stop, X center and X span. 
 
Each value for the search range can be changed by one of the following 
methods. 
"   Enter a numeric value using the ENTRY block key on the front panel. 

"   Turn the rotary knob ( ) on the front panel. 
"   Press the up or down arrow key ( ) on the front panel. 
"   Using the mouse, click one of the buttons ( ) on the right side of the 
entry area. 
 
You can move the search range by dragging and dropping either one of the 
bandmarker position pointers (  ) above the graph (pressing the button 
on the object to be moved and releasing the button on the destination). You 
can also drag and drop the start/stop line of the search range. 

5. To set the search range for the Y-Axis, turn on Bandmarker Y. 

6. Set the search range using Y start, Y stop, Y center and Y span. 
 
Each value for the search range can be changed by one of the following 
methods. 
"   Enter a numeric value using the ENTRY block key on the front panel. 

"   Turn the rotary knob ( ) on the front panel. 
"   Press the up or down arrow key ( ) on the front panel. 
"   Using the mouse, click one of the buttons ( ) on the right side of the 
entry area. 
 
You can move the search range by dragging and dropping either one of the 
bandmarker position pointers (  ) above the graph (pressing the button 
on the object to be moved and releasing the button on the destination). You 
can also drag and drop the start/stop line of the search range. 

Searching in Specified Range 
Procedure to Set Search Range 

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker Search. 

3. To perform the partial search for the stimulus value (X-Axis), press Search 

Range(X) to select Bandmarker. 
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4. To perform the partial search for the response value (Y-Axis), press Search 

Range(Y) to select Bandmarker. 
  

Setting Description 

Full Range 
(Full Scale) 

All data are obtained from all traces. 

Bandmarker 
(Bandmarker) 

Partial data are obtained from within bandmarker. 

  

Setting up Bandmarker for Each Trace/Setting up Markers for Coupled 
Operations Between Traces 

The bandmarkers can be set up and moved either in coupled operation for all 
traces in a channel or independently for each trace. 

You can set up bandmarker coupling for frequency/power measurement, transient 
measurement and the user window. 
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Bandmarker Coupling 

 

Setting Description 

Bandmarker Couple 
is on 
(Couple ON) 

Bandmarkers are set up and moved in coupled 
operation on all traces in a channel. 

Bandmarker Couple 
is off 
(Couple OFF) 

Bandmarkers are set up and moved independently for 
each trace. 
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Operational Procedure	

1. Press Trace Next or Trace Max to activate the trace on which you want to use 
the marker. 

2. Press Marker Fctn (or press Marker Search). 

3. Now you can set up the bandmarker. For more information, refer to Setting 
Search Range (Bandmarkers). 

4. Press Couple to turn the marker coupling on or off. 

 You cannot turn on the bandmarker coupling for the X-Axis. 
  

Automatically Executing Search Each Time Sweep is Done (search 
tracking) 

Search tracking is a function that sets a search to be repeated every time a 
sweep is done. This function facilitates the observation of measurement results, 
such as the maximum value of traces. 

Operational Procedure 

1. Press Trace Next or Trace Max to activate the trace on which search tracking 
is set up. 

2. Press Marker Search. 

3. Press Tracking and specify the parameters of the search tracking function. 
  

Setting Description 

Off Turns off search tracking function. 

Maximum 
value 

Specifies the maximum value for search tracking 
function. 

Minimum 
value 

Specifies the minimum value for search tracking 
function. 

Peak Specifies the peak for search tracking function. 

Target Specifies the target for search tracking function. 

Spurious Specifies the spurious for search tracking function. 
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Searching for Maximum and Minimum Measured Values 

You can search for the maximum or minimum measured value on the trace and 
move a marker to that point. 

Searching for Maximum and Minimum Measured Values 

 

Setting Description 

Search for 
maximum 
(Max)  

Moves active marker to point on trace where measured 
value is greatest. 

Search for 
minimum 
(Min) 

Moves active marker to point on the trace where 
measured value is lowest. 

Operational Procedure	

1. Following Step1to Step3in Reading Values on Trace, activate the marker you 
will use to search for the maximum and minimum values. 

2. Press Marker Search. 

3. Press the corresponding softkey to move the marker to the maximum or 
minimum measured value. 

Softkey Function 

Search Max Performs a search for the maximum value. 

Search Min Performs a search for the minimum value. 
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Searching for Target Value (target search) 

The target search function enables you to move the marker to the point that has 
the target measured value. 

Target and Transition Types 

A target is a point that has a specific measurement value on the trace. Targets 
can be divided into the two groups shown below depending on their transition 
type. 

Setting Description 

Transition type: 
positive 
(Positive) 

When the value of the target is larger than the 
measurement value that immediately precedes it (on the 
left side). 

Transition type: 
negative 
(Negative) 

When the value of the target is smaller than the 
measurement value that immediately precedes it (on the 
left side). 

  

Target and Transition Types 

 
About Target Search Function 

The target search is a function that searches for a target that matches the pre-
defined target value and transition type(s) (positive, negative, or both positive 
and negative) and then moves to the peak with maximum response value if the 
peak polarity is Positive or Both or to the peak with minimum response value if 
the peak polarity is Negative. 
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The following three methods are available for executing the target search: 

Setting Description 

Search 
target 
(Search 

Target) 

The marker moves to the nearest target in the stimulus value 
from the position of a present marker. 

Left search 
(Search 

Left) 

Executes search from current marker position to the smaller 
stimulus values and moves marker to first target encountered 

Right 
search 
(Search 

Right) 

Executes search from current marker position to the larger 
stimulus values and moves marker to first target encountered 

  

Target Search (when transition type is set to both positive and negative) 

 
Operational Procedure 

1. Following Step1through Step3 in Reading Values on Trace, activate a marker 
you are using for the target search. 

2. Press Marker Search. 

3. Press Target. 
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4. Press Target Value and enter a target value in the entry box that appears. 
 
The marker target search will be executed based on the newly set target 
value and the transition type defined. 

5. Press Target Transition. 

6. Select a transition type. 
  

Softkey Function 

Positive Selects positive as transition type. 

Negative Selects negative as transition type. 

Both Selects both positive and negative as transition type. 

The marker target search will be executed based on the definitions of the 
currently set target value and the newly set transition type. Each marker is 
allowed to have the peak excursion value and the peak polarity individually. 

7. Press the corresponding softkey to move the marker to the target. 
 
  

Softkey Function 

Search Target Executes target search. 

Search Left Executes left search. 

Search Right Executes right search. 

Searching for Peak	

The peak search function enables you to move the marker to the peak on the 
trace. 

Definitions of Peaks 

A peak is a measurement point whose value is greater or smaller than the 
adjoining measurement points on its right and left sides. Peaks are classified into 
the following types depending on the difference in magnitude from the 
measurement points on either side of it. 
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Setting Description 

Positive peak 
(Positive) 

A peak whose measurement value is greater than those of 
the measurement points on either side of it (peak polarity: 
positive) 

Negative peak 
(Negative) 

A peak whose measurement value is smaller value than 
those of measurement points on either side of it (peak 
polarity: negative) 

About the peak search function	

The peak search is a function that searches for a peak that matches a pre-defined 
lower limit for the peak excursion value and peak polarity (positive or negative) 
and then moves the marker to this peak. 

The peak excursion is the smaller of the differences in measurement values from 
the adjoining peaks of the opposite polarity. 

Positive Peak, Negative Peak and Peak Excursion 
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The following four methods are available for executing the peak search: 

Setting Description 

Search 
peak 
(Search 

Peak) 

Moves marker to the maximum peak when peak polarity is 
Positive or Both; moves marker to the minimum peak when 
peak polarity is Negative 

Search all 
peaks 
(Search 

Peak All) 

Moves marker to the maximum peak when peak polarity is 
Positive or Both; moves marker to the minimum peak when 
peak polarity is Negative 

Search left 
(Search 

Left) 

Executes search from current marker position to the smaller 
stimulus values and moves marker to the first peak 
encountered 

Search 
right 
(Search 

Right) 

Executes search from current marker position to the larger 
stimulus values and moves marker to the first peak 
encountered 

  

Peak Search (when peak polarity is positive) 
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Operational Procedure 

1. Following Step1 through Step3 in Reading Values on Trace, activate a marker 
you are using for the peak search. 

2. Press Marker Search. 

3. Press Peak. 

4. Press Peak Excursion and enter the lower limit for the peak excursion value. 
 
The marker peak search will be executed based on the definitions of the 
newly set lower limit for the peak excursion value and the currently set peak 
polarity. 

5. Press Peak Polarity. 

6. Select a peak polarity. 

Softkey Function 

Positive Selects Positive as the peak polarity 

Negative Selects Negative as the peak polarity 

Both Selects Both Positive and Negative as the peak polarity 

   

The marker peak search will be executed based on the definitions of the 
currently set lower limit for the peak excursion value and the newly set peak 
polarity. Each marker is allowed to have the peak excursion value and the 
peak polarity individually. 

7. Press the corresponding softkey to move the marker to the peak. 
  

Softkey Function 

Search Peak Executes peak search 

Search Left Executes left search 

Search Right Executes right search 
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Searching for Multiple Peaks 

The multi-peak search function enables you to display markers on multiple peaks 
on traces. 

About Peak Search All Functions (Peak Search All) 

The peak-search-all is a function that searches for peaks that match a pre-defined 
lower limit for the peak excursion value and peak polarity (positive or negative) 
and then displays the markers on these peaks. Up to 10 markers can be 
displayed. 

The peak excursion is the smaller of the differences in measurement values from 
the adjoining peaks of the opposite polarity. 

 About the matched to peak definition see Searching_for_Peak. 

Peak Search All (when peak polarity is positive) 

 
Operational Procedure 

1. Following Step1 through Step3 in Reading Values on Trace, display the 
multiple markers you are using for the peak search. 

 The peak search is executed as many times as the number of 
markers displayed (up to 10). 

2. Press Marker Search. 

3. Press Peak. 

4. Press Peak Excursion and enter the lower limit for the peak excursion value. 
 
This sets the multiple peak searches to be executed based on the definitions 
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of the newly set lower limit for the peak excursion value and the currently set 
peak polarity. 

5. Press Peak Polarity. 

6. Select a peak polarity. 
  

Softkey Function 

Positive Selects Positive as the peak polarity. 

Negative Selects Negative as the peak polarity. 

Both Selects both Positive and Negative as the peak polarity. 

This sets the multiple peak searches to be executed based on the definitions 
of the currently set lower limit for the peak excursion value and the newly set 
peak polarity. 

7. Press Search Peak All to move the marker to the peak.  
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Searching for Spurious	

The spurious search function enables you to move the marker to the peak value 
on the trace. You can use this function when the spurious judgment is enabled. 
For more information, refer to Confirming Spurious. 

About spurious search function 

The spurious search is a function that searches for a spurious and then moves the 
marker to this spurious. 

The following three methods are available for executing the spurious search: 

Setting Description 

Search 
spurious 
(Search 

Spurious) 

Moves marker to the maximum spurious 

Search left 
(Search Left) 

Executes search from current marker position to the smaller 
stimulus values and moves marker to the first spurious 
encountered 

Search right 
(Search 

Right) 

Executes search from current marker position to the larger 
stimulus values and moves marker to the first spurious 
encountered 

  

Spurious Search 
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Operational Procedure 

1. Following Step1 through Step3 in Reading Values on Trace, activate a marker 
you are using for the peak search. 

2. Press Marker Search. 

3. Press Spurious. 

4. Press the corresponding softkey to move the marker to the peak. 

Softkey Function 

Search Spurious Executes spurious search 

Search Left Executes left search 

Search Right Executes right search 

Searching for Multiple Spurious	

The multi-peak spurious function enables you to display markers on multiple 
spurious on traces. 

About Spurious Search All Functions (Spurious Search All) 

The spurious-search-all is a function that searches for spurious and then displays 
the markers on these spurious. Up to 10 markers can be displayed. 

Spurious Search All 

 
Operational Procedure 

1. Following Step1 through Step3 in Reading Values on Trace, display the 
multiple markers you are using for the peak search. 
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 The spurious search is executed as many times as the number 
of markers displayed (up to 10). 

2. Press Marker Search. 

3. Press Spurious. 

4. Press Search Spurious All to move the marker to the spurious. 

Determining Mean, Standard Deviation, and Peak-to-Peak of the Trace 

 Specifying Range for Statistical Data 

 Displaying Statistical Data 

Other topics about Data Analysis 

You can easily determine the statistics data for the trace between bandmarkers 
(mean, standard deviation, and peak-to-peak). The following figure and table 
show the definitions for the statistics data elements. 

Parameters Used for Calculating Statistics Data 
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Statistics data element Definition 

Average 
(Mean) 

 

 

(n: number of points; xi: i measured 
value at the i-th measurement point) 

Standard deviation 
(S. Dev) 

 

(n: number of points; xi: measured 
value at the i-th measurement point; 
mean: mean) 

Peak-to- 
Peak (PtoP) 

Max - Min 

(Max: greatest measured value; Min: 
smallest measured value) 

  

  

Specifying Range for Statistical Data 
1. Press Trace Next or Trace Max to activate the trace for which you want to 

obtain statistical data. 

2. Press Marker Fctn > Analysis Range (X). 

3. Press Marker Fctn > Analysis Range (Y) 
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Specify the range (X/Y-Axis) from which you want to obtain statistical data. 

Analysis Range Description 

Full Range 
(Fullscale) 

Statistical data are obtained from all traces. 

Bandmarker 
(Bandmarker) 

Statistical data are obtained from within bandmarker. 

To set up the bandmarker, refer to Setting Search Range (Bandmarkers). 

Displaying Statistical Data 
1. Press Trace Next or Trace Max to activate the trace for which you want to 

obtain statistical data. 

2. Press Marker Fctn. 

3. Specify the range (X/Y-Axis) from which you want to obtain statistical data. 
For more information, refer to Specifying Range for Statistical Data. 

4. Set the Analysis Type to Integral | Statistics | Linear Regression. 

 The values of Analysis type depend upon selected 
measurement. The values are different for different measurements. 
 
Turning on the marker list displays statistics data in a list. To display 
the marker list, refer to Listing All Marker Values in All Displayed 
Traces. 

Comparing Traces/Performing Data Math 

 Overview 

 Operational Procedure 

Other topics about Data Analysis 

Overview 

Each of the traces for which measured data are displayed is provided with an 
additional trace, called a memory trace, that temporarily stores the measured 
data. You can use the memory trace to compare traces on the screen or to 
perform data math between the memory trace and measured data. 

The following data math operations are available: 



318 

 

Operation Description 

Data / Memory Divides measured data by the data in the memory 
trace; this function can be used to evaluate the ratio 
of two traces (e.g., evaluating gain or attenuation). 

Data * Memory Multiplies measured data by a memory trace. 

Data -   Memory Subtracts a memory trace from measured data. 

Data + Memory Adds measured data and data in the memory trace. 

Operational Procedure	
1. Press Trace Next or Trace Max to activate the trace that you want to save in 

the memory. 

2. Press Trace View. 

3. Press Data -> Mem to store the measured data in memory. 

4. Press Data Math. 

5. Select the data math operation to perform. 

Softkey Function 

OFF Turns off data math functions (Do not perform data 
math). 

Data / Mem Divides measured data by the memory trace and stores 
result in the data trace. 

Data * Mem Multiplies the data trace by the memory trace and 
stores result in the data trace. 

Data -   Mem Subtracts the memory trace from data trace and stores 
result in the data trace. 

Data + Mem Add the data trace and memory trace and store the 
result in the data trace. 

USER 
Equation 

Applies User Equation created in Equation Editor. 
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6. Press Display Trace. 

7. Select the type of data to display on the screen. 
  

Softkey Function 

Data Displays only data trace on the screen. 

Mem Displays only memory trace stored by Data > Mem 
operation on the screen. 

Data & Mem Displays data trace and memory trace on the screen 
(You can now easily compare the data trace and 
memory trace on the screen.) 

Off Turns off display of the trace 

8. Apply the trigger to make measurements. 

Comparing Measurement Results in User Window 

 Copy Traces to User Window 

 Add Annotation to Each Trace in User Window 

Other topics about Data Analysis 

Up to eight measurement data can be retained in a user window. You may want 
to copy the multiple data that were measured with different settings to the user 
window so that you can compare them on the same screen. 

When you copy traces of phase-noise measurement to the user window, carrier 
frequency and level are also copied in the upper-right area of the graph. Since 
this value is treated as annotation, you can change or delete it later. 

Copy Traces to User Window 
1. Press Trace Next or Trace Max to activate the trace you want to copy. 

2. Press Trace View > Copy to USER 

3. From Copy to USER1 to Copy to USER8, select user window trace of the copy 
destination. 

4. Press Meas/View > User to select the user window. The trace that has been 
copied to the user window is displayed. 
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 Note that you are viewing the sweep range of the active trace in 
the user window. 

Add Annotation to Each Trace in User Window 

You can add annotation to each active trace, and only the annotation of the active 
trace is displayed in the upper-right area of the graph. 

 The carrier frequency and/or level information in annotation will 
be hidden according to the setting of security level. 

1. Press Trace Next or Trace Max to activate the trace to be copied. 

2. Press Trace View > Trace Annotation 

3. When the dialog box appears, enter the annotation using either the on-
screen keyboard or a connected keyboard. 

Limit Test 

The limit test feature allows you to set the limit line for each trace and then 
perform the pass/fail judgment for the measurement result. 

 Concept of Limit Test 

 Displaying Judgment Result of Limit Test 

 Defining Limit Line 

 Initializing Limit Lines 

Other topics about Data Analysis 

Concept of Limit Test 

The limit test is a function to perform pass/fail judgment based on the limit line 
you set. 

In the limit test, if the upper limit or lower limit indicated by the limit line is not 
exceeded, the judgment result is pass; if it is exceeded, the judgment result is fail 
for all measurement points on the trace. Measurement points in a stimulus range 
with no limit line are judged as pass. 

 The targets of the pass/fail judgment are measurement points only. 
Parts interpolated between measurement points are not judged. 

You define the limit line by specifying the stimulus value (Begin Stimulus) and 
response value (Begin Response) of the begin point, the stimulus value (End 
Stimulus) and response value (End Response) of the end point. For more 
information, refer to Defining Limit Line. 
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When the limit test is on, measurement points that fail are displayed in red on the 
screen and the measurement’s pass/fail judgment result based on the results of 
individual measurement points (fail if one or more measurement points on the 
trace fail) is also displayed. For more information, refer to Displaying Judgment 
Result of Limit Test. 

In addition to viewing the screen, you can check the judgment result of the limit 
test by the following methods. 

•   Using the status register. 

•   24-bit I/O. 
  

Displaying Judgment Result of Limit Test 

Measurement points determined as “Fail” will be displayed red on the screen. The 
determination result of a measurement can be displayed in the following two 
methods: 

•   Either “Pass” or “Fail” is displayed in the lower-right part of the measurement 
window. The result can be seen whenever the limit test is turned on. 

•    “Fail” can be displayed in the center of the measurement window. You can 
specify display/hide by following the steps below. 

1. Press Display. 

2. Press Limit Test to display the limit test menu. 

3. Press Fail Sign. Each press toggles between on/off. 

 In the tester mode during the frequency/power measurement 
mode, either “Pass” or “Fail” is displayed in the lower and the upper 
right part of the measurement window. Measurement data determined 
as “Fail” will be shown in red. 

Turning On or Off the Beeper in Limit Test 

Turn on the warning beeper if you want to sound an alarm when a measurement 
is determined as “Fail” in the limit test. Refer to the Setting the Beeper (Built-in 
Speaker) to turn on or off the warning beeper. 

Defining Limit Line 

You must define the limit lines before you can use the limit test function. The 
upper and lower limit lines can be retained for each trace, and up to 100 limit 
lines (segments) can be defined in each limit line. 

Defining Segment 

Follow the steps below to define the segments. 
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1. Create upper and lower values for limit lines in the following format, and then 
save them in the CSV format (with the *.csv extension). 
x_start, y_start, x_stop, y_stop 
x_start, y_start, x_stop, y_stop 
: 
x_start, y_start, x_stop, y_stop 

Parameter Overview 

x_start The starting point for the stimulus value on the limit line 

y_start The starting point for the response value on the limit line 

x_stop The ending point for the stimulus value on the limit line 

y_stop The ending point for the response value on the limit line 

  

 Save the upper limit values together into one file, and the lower 
limit values into another. 
 
One line represents one segment. Even when specifying 0 for the 
stimulus range, you must provide both the start and the stop values. 
 
For the tester mode during the frequency/power measurement mode, 
the response value corresponding to a stimulus value of 0 will be used 
as the limit value. 

1. Activate the trace to which you want to apply the limit test function. 

2. Press Display > Limit Test to display the Limit Test menu. 

3. Press Import Upper Limit Line.../Import Lower Limit Line... to open the file with 
the *.csv extension, which contains the predefined upper/lower values. 

 In order to edit the predefined upper/lower values file and 
reflect it to the limit test, you must once again open the file by 
pressing Import Upper Limit Line.../Import Lower Limit Line.... 

 You can specify the limit lines so that they may overlap other 
limit lines as you like. If you set limit lines on which stimulus ranges 
overlap one another, the measurement points within the range will 
have multiple limit values. In that case, the limit value to be used for 
the limit test will be as follows: 
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*If multiple upper limit values exist within the same range, the lowest 
value will be used as the upper limit value. 
*If multiple lower limit values exist within the same range, the 
highest value will be used as the lower limit value. 

Turning On or Off the Limit Test 

You can set the limit test on/off for each trace individually. Follow the steps below 
to set the limit test to on/off. 

Operational Procedure 

The following steps describe how to save/call the limit table. Use the external 
keyboard and mouse for the operations listed below. 

1. Activate the trace to which you want to apply the limit test function. 

2. Press Display > Limit Test to display the Limit Test menu. 

3. Press Limit Test and turn on the Limit Test. You can also display the limit 
lines on the screen by turning on the Limit Line. In tester mode during the 
frequency/power measurement, the limit values can be turned on or off with 
the Limit Line softkey. 

Initializing Limit Lines 

The following operations initialize the limit lines. 

•   At power-on 

•   When presetting 

•   When Delete Upper Limit Line/Delete Lower Limit Line is pressed in the Limit Test 
menu 

Linearity Evaluation of Chirped FM Signal 

 Overview 

 Create Reference Regression Line 

 Evaluate the Linearity 

Other topics about Data Analysis 

Overview 

The linearity evaluation of a chirped FM signal is a function that statistically 
evaluates errors in test signals by using a reference regression line created by 
changing the test frbequency to the line’s values. 
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This function has two processes: creating the reference regression line and 
evaluating the linearity of test signals. When evaluating linearity, you can specify 
the analysis range by using the band marker. 

The linearity evaluation of chirped signals can be used for transient 
measurements. 

Create Reference Regression Line 

This section describes steps to create a reference regression line based on the 
following chirped FM signal in transient measurement. 

Measurement example of chirped FM signal in transient measurement 

 
Procedure 

1. Press Trace Next or Trace Max to activate the trace in which you want to save 
the trace memory. 

2. Press Marker Fctn. 

3. Press Band Marker X to enable it, and then set the analysis range. 

4. Press Return 
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5. Press Trace View. 

6. Press Memory Trace - Line(Y = AX + B) - A to enter the value (slope) of the 
regression line coefficient (Y = aX + b). 

7. Press B to enter the value of b (intercept) of the regression line coefficient (Y 
= aX + b). 

8. When you want to assign the measurement value currently displayed to the 
linear regression coefficient, the values of a and b can be obtained by 
pressing the DATA Trace -> A,B button. 

 When fewer than two measurement points are in the analysis 
range, the values of a and b return to zero. 

8. Press Set Line to Memory to write into the memory trace. 

Evaluate the Linearity 

After obtaining the regression line coefficient, calculate error from reference by 
comparing traces. Here, statistics are used for calculating error (refer to 
Determining Mean, Standard Deviation, and Peak-to-Peak of the Trace). 

Procedure 

1. Press Trace/View. 

2. Press Data Math and select Data - Mem to perform data math. 

3. Press Maker Fctn. 

4. Set Analysis Type to Statistics to display the analysis results. 

 When the marker list is on, statistics are displayed on the 
screen of another window. For display method of the marker list, refer 
to Listing All Marker Values in All Displayed Traces. 

When you want to compare traces, set Data Math to off and display traces and 
trace memory on the screen. For the display method, refer to Comparing 
Traces/Performing Data Math. 

Confirming Spurious 

 Spurious Criteria 

 Setting Minimum Spurious Level 

 Setting Spurious Sensibility 

 Confirming Spurious using Threshold table 

 Setting Omit Specified Spur 
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Other topics about Data Analysis 

Spurious Criteria 

Spurious can be defined by either of the following two methods. The threshold is 
defined by selected method. Then, when the measured value exceed over the 
threshold, it is defined as a spurious. 

 Define the threshold in terms of the standard deviation ( σ ) value which is 
calculated from the measurement result moving average.  
Threshold can be set at the standard deviation  ( σ ) × sensitivity.  Refer to 
Setting Spurious Sensibility. 

 Using the csv file which define the threshold. Refer to Confirming Spurious 
using Threshold table. The threshold csv file should be defined in advance. 

Setting Minimum Spurious Level 

If the spurious data is bigger than this minimum spurious level, it is omitted the 
spurious data, or displayed it with Power (dBc). 

For example, there are two peaks (C) and (D) which are detected as a spurious in 
the figure below. When it is displayed with Power (dBc), the part of peak (C) 
which is above the minimum spurious level is colored in white. 

 This function does not affect data itself even if the peak is detected as 
a spurious. 
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1. Press Trace/View > Spurious > Minimum Spur Level to adjust the minimum 
spurious level. 

 
Setting Spurious Sensibility 

Follow the steps below to use the spurious sensibility function. 

1. Press Trace/View > Spurious > Spur Sensibility 

2. Enter the spurious sensibility value in the data entry field that appears in the 
upper part of the screen. 

 The low peak has real sensibility when the value is small. 
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Spurious Judgement using spurious sensibility 

 
Confirming Spurious using Threshold table 

The E5052B obtains a reference waveform based on the moving average of the 
phase noise, AM noise, Baseband and segment phase noise measurement results, 
and regards any data as spurious that may vary significantly from the reference 
waveform. 

1. Press Trace/View > Spurious. 

2. Press Import Threshold table... to import the threshold data file that you 
defined in advance. 

3. Press Power (dBc for Phase Noise/AM noise and dBV for BaseBand). The data 
regarded as spurious is displayed by highlight. You can view the stimulus and 
response values for each peak of spurious in a text file by pressing Spurious 

List. 
 
By Pressing Omit, the data regarded as spurious is replaced by the reference 
waveform that the E5052B calculated. By pressing Normalized (dBc/Hz for 
Phase Noise/AM noise and dBV/Hz for BaseBand), the data displayed is back 
to the measurement data. 
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4. Press Trace/View > Spurious > Minimum Spur Level to adjust the minimum 
spurious level. 
 
If the spurious data is bigger than this minimum spurious level, it is omitted 
the spurious data, or displayed it with Power (dBc). 

 By pressing Clear Threshold Table, the threshold table is cleared 
and set to the initial value, 0, 2, 30. By pressing Explorer, the file 
explorer is activated to find a file. 

Spurious Judgment using threshold table 

 
You can view the measurement points regarded as spurious in power (dBc). You 
can also provide any user-defined threshold for determining spurious. 
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Spurious judgment 

(A), 
(E) 

For measurement values falling in the range for which no threshold is 
specified (A), or between the upper and lower thresholds (E), the 
E5052B determines whether or not they are spurious based on its 
own determination criteria. 

(B) The E5052B considers the spurious smaller than the lower threshold 
as non-spurious regardless of its own determination criteria. 

(C), 
(D) 

The E5052B considers the spurious greater than the upper threshold 
as spurious regardless of its own determination criteria. 

Define the threshold table	

To specify the threshold for spurious, you must define the threshold table in 
advance. Define the threshold data in the following format, and then save it in the 
CSV format (with the extension of *.csv). 

freq_from, threshold_min, threshold_max 

freq_from, threshold_min, threshold_max 

: 

freq_from, threshold_min, threshold_max 

Parameter Overview 

freq_from Setting the start point of the threshold for spurious. You can 
not specify the end point. If the next start point and 
upper/lower threshold values are not specified, this 
threshold is valid until the stop frequency. 

threshold_min Lower threshold value 

threshold_max Upper threshold value 

 One line represents one segment, and you can specify up to 50 
segments in the threshold table. 
 
If the upper threshold is smaller than the lower threshold, the former 
will take precedence. 
 
You can comment out the line by placing "#" at the beginning of the 
line. 
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 Phase Noise is usually presented logarithmically as a plot of phase 
modulation sidebands in the frequency domain, expressed in dB 
relative to the carrier power per Hertz of bandwidth [dBc/Hz]. The 
default setting of the phase noise measurement on the SSA is 
[dBc/Hz] and the bandwidth is almost 1% of the offset frequency. The 
spurious is distinguished from noise, and the spurious power level is 
expressed in dB relative to the carrier power normally. 

 The difference between the phase noise measurement and a spectrum 
analyzer in measuring single sided spurious is 6 dB. If single sided 
spurious is present, its level can be measured on a spectrum 
analyzer. However, the measured data in phase noise measurement 
for a single sided spurious is 6dB lower from its true amplitude 
because the phase noise measurement assumes double sided 
spurious.   
 
The E5052B employs a phase detector method like other phase noise 
measurement systems, which measures double side band (DSB) noise 
and then converts it to single side band (SSB) noise. 

Setting Omit Specified Spur 

This function analyzes the data state to omit specific spurious. Log interpolation is 
applied to deleted data by using the neighbouring data. 

1. Press Trace/View > Spurious > Omit specified Spur. 

2. Select Omit > On | Off from the softkey menu list. 

  OmitS is displayed at the bottom of screen. 

3. Select Import Spurious Table... to import the spurious data file. 

4. Select Export Spurious Table... from the softkey menu list. 

5. By pressing Clear Spurious Table, the spurious list is cleared. 

 It is available to set the value of frequency to be Omit, using 
marker. For information on Marker to Spurious, refer to Specifying 
Sweep Range by Using Marker 

 It is not possible to be likely to omit the spurious only by 
specifying the frequency at one point. When it is judged the spurious 
still remains, it is required to expand the specified frequency and 
target it in omit. 
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Registering Spurious 

The existing Spurious list data cannot be read directly due to jitter value so it is 
read corresponding to the X-axis frequency. 

Input/Output for Spurious Frequency List 

The operation for input/output is same as Limit test. Enter the number of spurious 
input with COUNt, then register the spurious with FLISt. The following commands 
are used for input/output spurious frequency list: 

SCPI.CALCulate.AM(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.CLEar 

SCPI.CALCulate.AM(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.COUNt 

SCPI.CALCulate.AM(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.DATA 

SCPI.CALCulate.BB(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.CLEar 

SCPI.CALCulate.BB(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.COUNt 

SCPI.CALCulate.BB(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.DATA 

SCPI.CALCulate.PN(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.CLEar 

SCPI.CALCulate.PN(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.COUNt 

SCPI.CALCulate.PN(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.DATA 

SCPI.CALCulate.PS(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.CLEar 

SCPI.CALCulate.PS(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.COUNt 

SCPI.CALCulate.PS(Ch).TRACe(Tr).SPURious.OSSPur.FLISt.DATA 
Input/Output through csv file 

The following command enables to read the matrix data array with csv: 

SCPI.MMEMory.AM(Ch).TRACe(Tr).LOAD.SPURious.OSSPur.FLISt 

SCPI.MMEMory.AM(Ch).TRACe(Tr).STORe.SPURious.OSSPur.FLISt 

SCPI.MMEMory.BB(Ch).TRACe(Tr).LOAD.SPURious.OSSPur.FLISt 

SCPI.MMEMory.BB(Ch).TRACe(Tr).STORe.SPURious.OSSPur.FLISt 

SCPI.MMEMory.PN(Ch).TRACe(Tr).LOAD.SPURious.OSSPur.FLISt 

SCPI.MMEMory.PN(Ch).TRACe(Tr).STORe.SPURious.OSSPur.FLISt 

SCPI.MMEMory.PS(Ch).TRACe(Tr).LOAD.SPURious.OSSPur.FLISt 

SCPI.MMEMory.PS(Ch).TRACe(Tr).STORe.SPURious.OSSPur.FLISt 

Equation Editor 

 Overview 

 Starting Equation Editor 
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 Using Equation Editor 

 Applying User Equation 

 Equation History 

 Functions and Constants 

 Operators 

Other topics about Data Analysis 

Overview 

Equation Editor allows you to enter an algebraic equation of standard 
mathematical operators and functions, referencing data that is available in the 
E5052B. Once a valid equation is entered and enabled, the display of the active 
trace is replaced with the results of the equation, and updated in real-time as new 
data is acquired. For equations that can be expressed with Equation Editor's 
supported functions, operators, and data, there is no need for off-line processing 
in a separate program. 

Starting Equation Editor 

Equation Editor can be accessed through Trace/View > Equation Editor  (1 in the 
Figure below). 

Using Equation Editor 

Equation Editor can be used to enter an algebraic equation with measurement 
functions available in the trace. For example, "Eq1 = data + 52.555", can be 
applied to the measurement where the "Eq1' will be displayed on the 
measurement as a label. In case you do not wish to apply a label to be displayed, 
enter the equation directly, for example as "= data + 52.555". 

 The length of the equation should be within 254 characters, and the 
length of equation label should be within 20 characters. If the label is 
more than 20 characters, then the equation label is truncated to 20 
characters. 

 If the equation label contains an invalid character, then an error 
(Error No: 170, Invalid equation label) is generated. 

 If the equation is more than 254 characters, or if the equation 
formula is invalid (For example, if the case arc is not pair), then an 
error (Error No: 171,Invalid equation expression) is generated. 

The available data is the data that is able to be measured by an active source 
port in the same channel. The equation can be entered by the on-screen key 
board (3 and 4). 
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Applying User Equation 

User Equation created in Equation Editor can be applied to a measurement by 
selecting Trace/View > Data Math > User Equation. 

Equation History 

The Equation Editor has the capability to store and use all previously used 
equations, and can be accessed by clicking the ... button shown as 5 in the figure 
above. The ... button in E5052B Equation Editor provides an option to view either 
the List or the History of Equation entered in the Equation Editor. 

The  key difference between History and List is that History contains all the 
equations that are used in the Equation Editor and List stores specific equations 
that are manually added using the Edit button in the Equation History dialog box. 
The commands visible in History are lost when the firmware is restarted but 
commands manually saved in List are stored permanently in a text file located at 
F:\Equ_list.txt. 

To save the equations in List, follow this procedure: 
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1. Open Equation Editor by Trace/View > Equation Editor 

2. Enter the equation you wish to store permanently, say 
"5kHz_filtered=data-20*log10(sqrt(1+pow(5E3,2)/pow(x,2)))”, click 
Apply, and click ... button (5 in the figure above). This open the Equation 
History dialog box. 
 

 

 To store an equation, the equation must be applied first. This 
can be done by clicking on the Apply button. 

3. Click Edit. The Equation History Edit dialog box appears. 
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4. Select the equation/s you wish to store permanently in History tab and click 
Add to add them in the List tab. 

5. Click OK to save the equations. The equations are stored in a text file located 
at F:\Equ_list.txt. 

 The List/History button in Equation History dialog box (as 
shown in Step 2) opens the saved List of equations. If History 
contains 3 equations and you have saved only 1 equation in the List, 
then pressing this button will display only 1 equation in the List. 

 The History can save a maximum of 10 equations and  List can 
save a maximum of 15 equations. 

Functions and Constants 

The following table describes the different functions and constant available in the 
E5052B Equation Editor: 

Functions 

abs(a) returns the absolute value of a 

acos(a) returns the arc cosine of a in radians 

asin(a) returns the arc sine of a in radians 

atan(a) returns the arc tangent of a in radians 

atan2(a, b) returns the phase of (a, b) in radians 

cos(a) gets a in radians and returns the cosine 

exp(a) returns the exponential of a 

ln(a) returns the natural logarithm of a 

log10(a) returns the base 10 logarithm of a 

pow(a,b) returns a to the power b 

sin (a) takes a in radians and returns the sine 

sqrt(a) returns the square root of a 

tan(a) takes a in radians and returns the tangent 

max(a, b) returns the maximum value a or b 
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min (a, b) returns the minimum value a or b 

Constants 

e 2.718281828459045 

PI 3.141592653589793 

 a and b are of double data type. 

Operators 

The following table describes the various operators that can be used in the 
E5052B Equation Editor: 

Operators 

+ Addition 

- Subtraction 

* Multiplication 

/ Division 

( Open parenthesis 

) Close parenthesis 

, Comma - separator for arguments 

= Equal (optional) 

E Exponent (as in 23.45E6) 

  

Data Output 

Data Output 

 Managing Files/Folders 

 Saving Trace on File 

 Hiding Numeric Information 

 File Saving and Loading Instrument Status Settings 
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 Saving Display Screen 

 Printing Screen Image 

Managing Files/Folders 

 Running Windows Explorer 

 Copying Files/Folders 

 Moving Files/Folders 

 Removing Files/Folders 

 Changing the Name of File/Folder 

Other topics about Data Output 

You can manage the files and folders by using Windows ® Explorer, which 
provides such standard operations as copy, move, remove, change name, and 
format floppy disk. 

 Do not change any content (i.e. folders or files) of the drives other 
than A and F: This may cause serious damage to the E5052B ’s 
functions and performance. 

Running Windows Explorer 
1. Press Save/Recall. 

2. Press Explorer... to open Windows Explorer. 

Copying Files/Folders 
1. In Windows Explorer, select any source file or folder for copying. 

2. On the menu bar, select Edit > Copy. 

3. Open the target folder for copying. 

4. On the menu bar, select Edit > Paste. 

Moving Files/Folders 
1. In Windows Explorer, select the file or folder of origin. 

2. On the menu bar, select Edit > Cut. 

3. Open the destination folder. 

4. On the menu bar, select Edit > Paste. 
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Removing Files/Folders 
1. In Windows Explorer, select the file or folder to be removed. 

2. On the menu bar, select File > Delete. 

Changing the Name of File/Folder 
1. In Windows Explorer, select the file or folder for which you want to change 

name. 

2. On the menu bar, select File > Rename. 

3. Type the new name for the file or folder and then press Enter on the 
keyboard. 

Saving Trace on File 

 Specifying Carrier Information 

 Saving Trace Data File 

 Saving Trace Memory 

Other topics about Data Output 

Specifying Carrier Information 

You can set the carrier information (additional information) on/off when you want 
to save the trace data. Follow the steps below to set the carrier information to 
On/Off. 

This function is available in Phase Noise, AM Noise and Segment PN. 

 This function cannot be used when you want to save the trace 
memory. In addition, even if you recall the file with carrier 
information into the trace memory, the carrier information is not set 
on the E5052B. 

 When the security level is set at Frequency Blank, the carrier 
frequency value is saved as "***"  into the file. 

Operational Procedure 

Follow the steps below to save the trace data of the E5052B. 

1. Press Trace Next or Trace Max to activate the trace on which you want to save 
the trace data. 

2. Press Save/Recall. 

3. Press Additional Info to toggle ON/OFF the carrier information. 

Save Condition as follows: 
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  Additional 
Info : ON 

Additional 
Info : OFF 

DATA MEM DATA MEM 

SAVE Y N N N 

Y:Possible  N:Impossible 

Recall Condition as follows: 

  Additional 
Info : ON 

Additional 
Info : OFF 

DATA MEM DATA MEM 

SAVE Y N Y N 

Y:Possible  N:Impossible 

 E5052B with rev. A.03.10 can recall the trace data with additional 
information. In that case, the additional information is not set. 

 E5052B can recall the file which has only the data of carrier information 
(both or either frequency and/or power). The additional information can be 
set. 

About User Measurement 

When the trace data is copied to the User Measurement with Copy to User 
function, the additional information is also copied. 

Saving Trace Data File 

You can save the trace data of the E5052B’s active trace in the CSV format (with 
the extension of “*.csv”) to recall them for later use on the PC application 
software. 

The trace data are saved in following format (Carrier Information : ON) 

Example of Saved Trace Data (phase noise measurement) 

Carrier Frequency (Hz),+1.00000000000e+008 

Carrier Power (dBm),+0.00000000000e+000 

Offset Frequency (Hz),Phase Noise (dBc/Hz) 

+1.00000000000e+002,-6.11082572643e+001 

+1.01800975118e+002,-6.14881381403e+001 

+1.03634385350e+002,-5.77826152313e+001 
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+1.05500814844e+002,-5.81658293608e+001 

The first line is a title and a data of carrier frequency. 

The second line is a title and a data of carrier power. 

The third line is a header indicating the trace data items that are output from the 
fourth line onward. 

From the fourth line, the trace data are output at an amount equivalent to the 
number of frequency points. 

The trace data are saved in following format (Carrier Information : OFF) 

Example of Saved Trace Data (phase noise measurement) 

Offset Frequency (Hz),Phase Noise (dBc/Hz) 

+1.00000000000e+002,-6.11082572643e+001 

+1.01800975118e+002,-6.14881381403e+001 

+1.03634385350e+002,-5.77826152313e+001 

+1.05500814844e+002,-5.81658293608e+001 

The first line is a header indicating the trace data items that are output from the 
second line onward. 

From the second line, the trace data are output at an amount equivalent to the 
number of frequency points. 

Operational Procedure 

Follow the steps below to save the trace data of the E5052B. 

1. Press Trace Next or Trace Max to activate the trace on which you want to save 
the trace data. 

2. Press Save/Recall to open the Save/Recall menu. 

3. Press Save Data Trace to open the “Save As” dialog box. This operation should 
be conducted using the external keyboard and/or mouse. For information on 
the Save As dialog box, refer to the description of Save As dialog box. Here, 
the CSV Files (with the extension of *.csv) are selected for the file type. 

4. Specify the destination folder for saving, enter file name, and then press 
Save to save the file. 

 For TR measurements, additional option to save scroll data is 
available at Save/Recall > Save Scroll Data... 

  

Saving Trace Memory 
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You can save the trace memory of the E5052B’s active trace in the CSV format 
(with the extension of “.csv”) to recall them for later use on the PC application 
software. 

The trace memory is saved in the following format: 

Example of Saved Trace Memory (phase noise measurement) 

Offset Frequency (Hz),Phase Noise (dBc/Hz) 

+1.00000000000e+002,-6.11082572643e+001 

+1.01800975118e+002,-6.14881381403e+001 

+1.03634385350e+002,-5.77826152313e+001 

+1.05500814844e+002,-5.81658293608e+001 

The first line is a header indicating the trace memory items that are output from 
the second line onward. 

From the second line, the trace memory is output at an amount equivalent to the 
number of frequency points. 

Operational Procedure 

Follow the steps below to save the trace memory of the E5052B. 

1. Press Trace Next or Trace Max to activate the trace on which you want to save 
the trace memory. 

2. Press Save/Recall to open the Save/Recall menu. 

3. Press Save Memory Trace to open the “Save As” dialog box. This operation 
should be done with the external keyboard and/or mouse. For information on 
the Save As dialog box, refer to the description of Save As dialog box. Here, 
the CSV Files (with the extension of *.csv) are selected for the file type. 

4. Specify the destination folder for saving, enter the file name, and then press 
Save to save the file. 

Hiding Numeric Information 

 Hiding Frequency Information on Screen 

 Hiding All Numeric Information Screen 

Other topics about Data Output 

You can hide numeric information on the screen for purposes such as security. 

Hiding Frequency Information on Screen 

Follow these steps to display frequency information on the measurement screen 
and frequency information in softkeys and data entry box as asterisks (***...). 
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1. Press Display > Security Level. 

2. Select Frequency Blank from the security level setting. 

Security Level Setting 

Softkey Function 

None Displays all information on the screen. 

Frequency 
Blank 

Displays frequency information as asterisks. You cannot 
return the setting to None with the Security Level menu. You 
need to execute Preset or Recall to return the display setting 
to None. 

All Numeric 
Blank 

Displays all numeric information as asterisks. You cannot 
change the security level with the Security Level menu. You 
need to execute Preset or Recall to return the display setting 
to None or Frequency Blank. 

 Once you set the security level to Frequency Blank, the frequency 
readouts are disabled (any frequency readouts are marked as 
asterisks, “***”) unless cycling power, executing Preset or recall a 
setting whose security level is None. 

Hiding All Numeric Information Screen 

Follow these steps to display all numeric information on the measurement screen 
and numeric information in softkeys and data entry box as asterisks (***...). 

1. Press Display > Security Level. 

2. Select All Numeric Blank from the security level setting. 

 Once you set the security level to All Numeric Blank, the Security 

Level is no more changed by the user unless cycling power, executing 
Preset or recall a setting whose security level is None or Frequency 
Blank. 

File Saving and Loading Instrument Status Settings 

 Saving Procedure 

 Recalling Procedure 

 Recall Procedure Using Recall by File Name Feature 

Other topics about Data Output 
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You can save the state of the instrument as a file in a hard disk, or any storage 
equipment via USB connector, and recall the file for later use. You can choose one 
of the two options below for file saving. 

Type Content to be saved and used 

State 
Only 

You can save the E5052B's state settings and recall them later to 
set up the instrument to the same state as previously used. 

State 
and 
Data 

You can save the E5052B's state settings and trace (formatted 
data arrays and formatted memory arrays) and recall them later to 
set up the instrument to the same state as previously used. Here, 
the trace can also be recalled and displayed on the screen. 

 Irrespective of the selected measurement window, all of the state 
settings and settings/data are saved or recalled. 
 
If an incompatible file is recalled, the settings will be preset due to 
error. 

Compatibility of Files Related to Saving and Recalling 

  Recalling 

Standard Option 011 

Saving Standard Yes Yes 

Option 011 Yes Yes 
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Parameter Value saved with 
the standard 
model 

Value will be changed 
when recalling with the 
option 011 

Phase noise - 
Correlation 

Other than 1 1 

Phase noise - IF 
Gain 

Higher than or equal 
to 20 dB 

Changed to 20 dB 

Frequency & power 
- Trigger mode 

Analyzer mode Tester mode 

Phase noise -- Start 
offset frequency 

1 (Hz) 10 (Hz) 

  

Type Content to be saved and used 

State 
Only 

You can save the E5052Bs state settings and recall them later to 
set up the instrument to the same state as previously used. 

State 
and 
Data 

You can save the E5052Bs state settings and trace (formatted data 
arrays and formatted memory arrays) and recall them later to set 
up the instrument to the same state as previously used. Here, the 
trace can also be recalled and displayed on the screen. 

  

  

  

Saving Procedure 
Selecting Content To Be Saved 

 The following steps affect both file saving and memory saving of the 
instrument state. 

1. Press Save/Recall. 

2. Press Save State. 

3. Press Save Type. 

4. Press the softkey corresponding to the content of the instruments state you 
want to save. 
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Softkey Function 

State Only Selects State Only to save only the state settings of the 
E5052B 

State & 
Data 

Selects State and Data to save the state settings and the trace 
of the E5052B 

  

Saving Data 

Follow the steps below to save the internal data of the E5052B. 

1. Press Save/Recall. 

2. Press Save State. 

3. When you save the state using the defined file on drive F (State01.sta - 
State06.sta, Autorec.sta): 

4. Press State01 - State06 or Autorec. 

Softkey Description 

State01 
to 
 State06 

Save the instrument state into the state number. 

Autorec Save the instrument state as the auto recall setting. The 
E5052B is automatically configured with this state at the 
startup. 

This key saves the state into the "C:Autorec.sta". 

When Autorec.sta file is found on the C: drive at startup, the 
E5052B is automatically configured using the saved settings. 
To disable the auto recall function, delete the Autorec.sta 
files. 

You must have a preset setting file that has been saved with 
the state at AutoRec, to execute the user-preset function. 

  

 Irrespective of the selected measurement window, all of the 
state settings and settings/data are saved. 

 F:\Autorec.sta (F drive) can be recalled automatically whenever 
the E5052B is powered on. If both C:\Autorec.sta and F:\Autorec.sta 



Data Analysis and Data Output 

347 

exist, the former is called. To disable the auto recall function, remove 
Autorec.sta.  

 If the file already exists, the * mark will appear to the right of 
the softkey label. If you specified overwrite of the existing file, it will 
be copied with the name backup.sta, and then the original file will be 
overwritten. 

When you save the state with any file name: 

1. Press File Dialog... to open the dialog box. This operation should be done with 
the external keyboard and/or mouse. The figure below shows the user 
interface elements in the Save As dialog box. 

2. Specify any folder, and enter the file name. 

3. Press Save. 
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Save As dialog box 

 
The E5052B provides the following drives to save/recall files. Select a drive in the 
Save In area of the Save as dialog box . 

Drive name Description 

[F:] Uses a hard disk (F) drive for saving/recalling the file. 

 Do not change any content (i.e. folders or files) in the drives other 
than C and F. Doing this may cause serious damage to the E5052Bs 
functions and performance. 
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Recalling Procedure 

 In recalling the file in which the trace is saved (State & Data is 
specified for saving the content), the trigger sources are recalled and 
trigger mode is automatically set to HOLD. 

1. Press Save/Recall. 

2. Press Recall State. 

3. When you recall State01.sta - State06.sta - Autorec.sta: 

4. Press State01 - State06 or Autorec. 

When you recall any file: 

1.   Press File Dialog... to open the Open dialog box. This operation should be 
conducted using the external keyboard and/or mouse. The figure below shows 
the user interface elements on the Open dialog box. 

2.   Specify the folder that contains the file, and then select the file. Press Open to 
recall the saved internal data. 

 Irrespective of the selected measurement window, all of the 
state settings and settings/data are recalled. 
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Open Dialog Box 

 
Recall Procedure Using Recall by File Name Feature 

You can use the recall feature with the Recall by File Name softkey for files you 
have named freely and saved in the F:\State folder. This function lets you recall a 
file you have named freely and saved by simple softkey operation, eliminating 
annoying operation using the Open dialog box. 

 Although there is no limit to the number of files saved in a folder, only 
up to 50 files are displayed on the softkeys. If more than 50 files are 
saved in a folder, they are sorted in the order of numbers 0 to 9 and 
alphabetic characters A to Z and the first 50 files are displayed as 
softkeys. 
 
Although there is no limit to the number of characters of a file name, 
only up to 12 characters are displayed on the softkey. If a file name 
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exceeds 12 characters, the first 12 characters are displayed on the 
softkey and the remaining characters are omitted and replaced with 
.... 

Note that different files may be displayed on softkeys with the same name or a saved file 

is not displayed on any softkey because of the above limitations. 

1. Press Save/Recall. 

2. Press Recall by File Name. 

Files that have been named and saved in the F:\State folder are displayed on 
softkeys. Press the key for the file you want to recall. 

 E5052B firmware Rev. A.03.00 can recall files saved with State Only 
of E5052A firmware Rev. A.02.50. 
 
When attempting to recall files saved with State & Data of E5052A 
firmware Rev. A.02.50 or lower, a warning “Incompatible recall file" 
may appear and some data cannot be recalled. 
 
E5052A firmware Rev. A.02.50 or lower cannot recall files saved with 
E5052B firmware Rev. A.03.00. 

Saving Display Screen 

You can save the E5052B’s screen image on a file in the bitmap or PNG format. 
The saved file can be recalled for later use with PC application software. 

Operational Procedure 

Follow the steps below to save the screen image on a file. 

1. Display the screen that you want to save on a file. 

2. Press System to display the system menu. Use the following softkey from the 
System menu. 

Softkey Function 

Dump Screen Image Saves the screen information on a file 

 The image displayed on the screen just before pressing System 
is saved in the file. 
For more information, refer to Images You Can Print/Save. 

3. Press Dump Screen Image to open the “Save As” dialog box. For information 
on the Save As dialog box, refer to the description for Save As dialog box. In this 
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case, either Bitmap Files (with the extension of *.bmp) or Portable Network 
Graphics (with the extension of *.png) is selected as the file type. 

4. Select the file type. 

5. Specify the folder in which you want to save the file and enter the file name. 
Press Save to save the screen image of the E5052B in a file. 

Other topics about Data Output 

Printing Screen Image 

 Overview 

 Images You Can Print/Save 

 Printing Procedure 

Other topics about Data Output 

Overview 

By connecting a printer to the USB port of the E5050B, you can print the 
displayed screen of the E5052B. 
  

Images You Can Print/Save 

You can print/save the images that are stored in the clipboard. However, unless 
images are stored on the clipboard, the current screen image will be 
printed/saved. 

Storing Images in Clipboard 

The System > Dump Screen Image key provides a screen capture function as well. 
In other words, the image displayed on the screen just before pressing System > 
Dump Screen Image is saved on the clipboard. 

 The images stored on the clipboard are cleared after executing 
print/save operations. 

Printing Procedure 
Preparing Printing 

Follow the steps below to prepare for printing. 

1. Power off the E5052B. 

2. Power on the printer and then connect it to the E5052B. 

 Do not connect unsupported printers to the E5052B. 

3. Power on the E5052B. 



Data Analysis and Data Output 

353 

4. Press System. 

5. Press Printer Setup to open the “Printers” window. Select the printer you want 
to use and set it up by referring to the instruction manual for the printer. 

6. The Printers window will close. 
  

Printing 

Follow the steps below to print the screen image. 

1. Display the screen that you want to print out. 

2. Press System to save the current screen image on the clipboard. 

3. As required, press Invert Image to toggle the selection of printing either in the 
displays’s actual colors or in the image’s inverted colors. (This can save much 
ink by, for example, printing with a white rather than black background.) 

4. Press Print to start printing. 
 
Pressing Abort Printing during the printing operation stops the printing. 

 If you start printing before the printer is ready (e.g. not 
powered on yet), the Printers Folder dialog box may be displayed as 
shown below. In this case, press Cancel to close the Printers Folder 
dialog box and retry the operation after the printer is ready. 

  

 


